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Graphics in Calc

Calc is often used to present data, and to make forecasts and predictions. Graphics can turn an 
average spreadsheet into a more professional and memorable spreadsheet. Calc can import 
various vector (line drawing) and raster (bitmap) file formats. The most commonly used graphic 
formats are GIF, JPG, PNG, and BMP. See LibreOffice Help for a full list of the formats that Calc 
can import.

Graphics in Calc are of three basic types:

• Image files, such as photographs, drawings, and scanned images

• Diagrams created using LibreOffice drawing tools

• Charts and graphs created using LibreOffice Chart facility, see Chapter 3 Creating Charts 
and Graphs for more information

Although using graphics in Calc is very similar to using graphics in any other component of 
LibreOffice, this chapter explains some of the differences in their use. It also covers some of the 
more advanced graphics functions and how they can further enhance your spreadsheet.

Note
The term graphics refers to both pictures and drawing objects. Often the word 
images is used when referring to pictures and other graphics that are not drawing 
objects.

Adding graphics (images)

Graphics or images (sometimes called pictures in LibreOffice), such as corporate logos and 
photographs, are probably the most common types of graphics added to a Calc spreadsheet. They
may be, for example, downloaded from the Internet, scanned, created with a graphics program; or 
photographs taken with a digital camera.

Images can be inserted in three ways:

• Using the Insert Picture dialog

• From the gallery

• From the clipboard by copying and pasting

Inserting image files
The most common source of graphics is existing files and to insert an image from a file as follows:

1) Click in the cell in the spreadsheet where you want the image to appear. Do not worry too 
much about the position of the file as positioning can be changed, see “Positioning, resizing
and arranging images” on page 16 for more information.

2) Go to Insert > Picture > From File on the main menu bar, or click the From File icon  
on the Insert toolbar to open the Insert Picture dialog (Figure 1). If the Insert toolbar is not 
open, go to View > Toolbars > Insert on the main menu bar.

3) On the Insert Picture dialog, navigate to the file to be inserted and select it.

4) If required, select Preview to view a thumbnail of the selected image on the right of the 
dialog so you can verify that you have the correct file.

5) Click Insert as Link or Link (depending on computer setup) if you want to link the file to 
the original file (see “Linking files” below for more information). If you do not select Insert 
as Link or Link, the file is embedded into the spreadsheet (see “Embedding image files” 
below for more information).
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Figure 1: Insert Picture dialog

6) Click Open and the file is inserted into the spreadsheet as a floating image and is anchored
to the cell in which the cursor was placed.

Note
The Insert Picture dialog may look different from the one shown in Figure 1, 
depending on your operating system and whether you have selected to use the 
LibreOffice Open/Save dialogs in Tools > Options > LibreOffice > General.

Linking files
To create a link to a file containing an image instead of embedding the image into a spreadsheet, 
use the Insert picture dialog and select the Insert as Link or Link option. When you click Open, a 
warning dialog (Figure 2) opens informing you of the hazards of linking a file and asks you to 
confirm whether you want to Keep Link or change to Embed Graphic.

Figure 2: Linking warning dialog
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Click Keep Link and the image is displayed in the document, but when the document is saved, it 
contains only a reference to the image file and not the image itself. The document and the image 
remain as two separate files, which are temporarily merged only when you open the spreadsheet 
again.

Click Embed Graphic and the image is displayed in the spreadsheet. The image file is embedded 
into the spreadsheet and the two files become one file. See “Embedding image files” below for 
more information.

• Advantage – you can modify the image file separately without changing the spreadsheet 
because the link to the file remains valid and the modified image will appear when you next
open the spreadsheet. This can be a big advantage if you (or someone else, perhaps a 
graphic artist) is updating images.

• Advantage – linking can reduce the file size of the spreadsheet when it is saved, because 
the image file itself is not included. However, file size is usually not a problem on modern 
computers with a reasonable amount of memory, unless the spreadsheet includes many 
large graphics files. Calc can easily handle large files.

• Disadvantage – if you send the document to someone else, or move it to a different 
computer, you must also send the image files and keep the same file structure. This 
prevents the link from being broken and blank areas appearing in the spreadsheet because
Calc cannot find the linked file. For example, you might keep image files in a subfolder 
named Images inside the same folder containing the Calc document. Any recipient of the 
Calc spreadsheet needs to put the image files in a subfolder with the same name in the 
same named folder as the Calc spreadsheet.

Note

When inserting the same image several times in the document, it might appear 
beneficial to create links. However, this is not necessary, as LibreOffice embeds 
only one copy of the image file in the document. Deleting one or more of the 
copies does not affect the other copies of the same file.

Embedding image files
Embedding a image into your spreadsheet makes the image a permanent part of your 
spreadsheet. Any changes you make to an embedded image will only appear in your spreadsheet 
and the original image file will not affected.

Embedding happens when you insert an image into your spreadsheet using copying and pasting, 
or clicking Embed Graphic when inserting files with the Insert Picture dialog.

• Advantage – embedding graphics into your spreadsheet is that the graphic is always 
available no matter what computer is used to open the spreadsheet.

• Disadvantage – embedding graphics is that it creates large file sizes, which may not be 
desirable if you have limited capacity for storing computer files. Also, if the original graphic 
is altered, then your drawing will not have an up to date version each time you open your 
drawing.

Note
When a raster graphic is embedded into a LibreOffice spreadsheet, the format of that 
graphic is automatically changed to PNG format.
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Embedding linked image files
If you originally linked the image files, you can easily embed and save in a Calc spreadsheet at a 
later time if you so wish.

1) Open the spreadsheet in Calc.

2) Go to Edit > Links on the main menu bar to open the Edit Links dialog (Figure 3) shows all
the linked files.

Figure 3: Edit Links dialog

3) Select the files you want to change from linked to embedded.

4) Click Break Link and confirm you want to remove the selected link. The file then becomes 
embedded into the spreadsheet.

Note
Going from embedded to linked files is not so easy. You must delete each 
embedded file and, one at a time, selecting the Insert as Link or Link option when
you reinsert each file.

Copying and pasting
Using the clipboard, you can copy and paste images from one Calc spreadsheet into another Calc 
spreadsheet, or from another component of LibreOffice (Writer, Draw, and so on) into a 
spreadsheet, or from other programs into a Calc spreadsheet. Copying and pasting embeds the 
image file 

1) Open both the source document and the Calc spreadsheet into which you want to copy the 
image.

2) In the source document, select the image to be copied.

3) Go to Edit > Copy on the main menu bar, or click the Copy icon  on the Standard 
toolbar, or use the keyboard shortcut Ctrl+C to copy the image to the clipboard.

4) Switch to the Calc spreadsheet and click in the cell where the image is to be inserted.

5) Go to Edit > Paste on the main menu bar, or click the Paste icon  on the Standard 
toolbar, or use the keyboard shortcut Ctrl+V to paste the image into the spreadsheet.
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Note

You can also right-click and select Copy from the context menu to copy the image 
to the clipboard. You then right-click in the cell you want to use for an anchor and 
select Paste from the context menu to embed the image into your spreadsheet. 
However, this method only works for image files when you are copying and pasting
between modules of LibreOffice.

Using the Gallery
The Gallery (Figure 4) provides a convenient way to make available reusable objects such as 
images and sounds that you can insert into your documents. The Gallery is available in all 
components of LibreOffice and has several images grouped together in collections or themes, for 
example Finance, Computer, People and so on. However, you can add your own images by using 
My Theme or creating a theme. The Gallery is explained in more detail in the Getting Started 
Guide Chapter 11 Graphics, the Gallery, and Fontwork.

Figure 4: Gallery dialog

1) Click on the Gallery icon  on the Standard toolbar or go to Tools > Gallery on the main
menu bar to open the Gallery.

2) Navigate through the Gallery to find the required image.

3) Right-click on the required image and select Insert > Copy from the context menu or click 
and drag the image from the Gallery into the Calc spreadsheet.

By default, the Gallery is docked above the Calc spreadsheet. To expand the Gallery, position the 
cursor over the line that divides it from the top of the spreadsheet. When the cursor changes to 
parallel lines with arrows, click and drag downward. The spreadsheet automatically re-sizes in 
response.

To expand the Gallery without affecting the workspace, undock it so it floats over the workspace. 
Hold down the Ctrl key and double-click on the Gallery title bar, or use the keyboard shortcut 
Ctrl+Shift+F10. The Gallery then becomes a floating dialog on top of the spreadsheet.

To dock the Gallery in its default position above the spreadsheet, hold down the Ctrl key and 
double-click on the Gallery title bar.

When the Gallery is docked, you can hide it and view the full Calc spreadsheet. Click the 
Hide/Show button (highlighted in Figure 4) in the bar separating the Gallery from the spreadsheet. 
To show the Gallery again, click the Hide/Show button again. To close the Gallery, go to Tools > 
Gallery on the main menu bar and uncheck Gallery, or click on the Gallery icon again.
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Modifying images

When you insert a new image, you may need to modify it to suit the document. This section 
describes how to resize, crop, rotate and adjust an image in Calc. Any changes made in Calc do 
not affect the original image, whether it is an embedded or linked image file.

Calc provides several tools for working with images and these tools are sufficient for most 
requirements. However, for professional results it is generally better to use a software designed to 
modify image files, for example GIMP, and then insert the result into Calc. GIMP is an open-source
graphics program that can be downloaded from http://www.gimp.org/downloads/.

Figure 5: Picture toolbar and available tools

Using the Picture toolbar
When you insert an image or select one already present in your spreadsheet, the Picture toolbar 
opens (Figure 5). If it does not open, go to View > Toolbars > Picture on the main menu bar. The 
tools available from left to right on the Picture toolbar are as follows:

• Filter – opens the Graphic Filter toolbar, which is described in “Using graphic filters” on 
page 12.

• Graphics mode – changes the display of the graphic from color to grayscale, black and 
white, or a watermark. This setting affects only the display and printing of the picture; the 
original picture file remains unchanged.

– Default – the graphic is displayed unaltered in color.

– Grayscale – the graphic is displayed in 256 shades of gray.

– Black/White – the graphic is displayed in black and white.

– Watermark – the brightness and contrast of the graphic are reduced to the extent that 
the graphic can be used as a watermark (background).
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• Color – opens the Color toolbar (Figure 6) to adjust the values of the RGB colors, 
brightness, contrast and Gamma. These adjustments do not affect the original picture, but 
the values are stored in LibreOffice as a separate formatting set.

– Red, Green, Blue – select values between -100% (no color) to +100% (full intensity); 
0% represents the original color value of the graphic.

– Brightness – select a value between –100% (totally black) and +100% (totally white).

– Contrast – select a value between –100% (minimum) and +100% (maximum).

– Gamma – this affects the brightness of the middle color tones. Select a value between 
0.10 (minimum) to 10 (maximum) Try adjusting this value if changing brightness or 
contrast does not give you the required result.

Figure 6: Color toolbar

• Transparency – adjust the degree of transparency of the picture between 0% (opaque) 
and 100% (fully transparent).

• Line – opens the Line dialog so you can adjust the border style of the selected image. See 
the Draw Guide for more information on how to modify lines.

• Area – opens the Area dialog allowing you to edit color, gradient, hatching and fills of the 
background area that contains the image — not the image itself. To see the background, 
you must set the transparency of the image to a suitably high value. See the Draw Guide 
for more information on how to modify areas.

• Shadow – sets the default shadow effect around the image. To adjust the shadow effect, 
open the Area dialog and click on the Shadow tab. See the Draw Guide for more 
information on how to modify shadows.

• Crop Picture – opens the Crop dialog and allows you to crops or trims the selected image.
For more information, see “Cropping images” on page 13.

• Anchor – allows you to toggle between anchoring the image to a cell or to a page. For 
more information, see “Anchoring images” on page 19.

• Bring to Front – brings the selected image to the front of the stack when there is more 
than one image in the spreadsheet. For more information, see “Arranging images” on page
19.

• Send to Back – sends the selected image to the rear of the stack when there is more than 
one image in the spreadsheet. For more information, see “Arranging images” on page 19.

• To Foreground – allows the image to float in front of the spreadsheet cells. For more 
information, see “Arranging images” on page 19.

• To Background – moves the selected image into the background so that appears behind 
the spreadsheet cells. For more information, see “Arranging images” on page 19.

• Display Grid – displays or hides grid lines that you can use to align images on a page.

• Snap to Grid – automatically aligns images to vertical and horizontal grid lines. To override
this feature, hold down the Alt key when you drag an object.

• Helplines While Moving – displays guides or helplines when dragging an image to a new 
position.

• Alignment – if two or more images are selected, adjusts the horizontal and vertical 
alignment of the images in relation to each other. For more information, see “Aligning 
images” on page 20.
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Using graphic filters

Note

Applying graphic filters to any image consecutively will progressively degrade the 
quality of the image. The graphic filters used in Calc utilize what is known as a 
destructive editing algorithm, whereby each filter is applied to the image 
immediately, changing the original data of the image. Successive transformations 
result in less and less original data remaining, thus compromising the quality of the
inserted picture. While this might be acceptable for use in simple documents, it is 
still recommended that dedicated photo or image editing software be used to 
perform anything but the simplest of manipulations.

Figure 7: Graphic Filter toolbar and tools

After selecting an image and the Picture toolbar (Figure 5) has opened, click on the Filter icon  
to open the Graphic Filter toolbar (Figure 7). Filters work on the current view of a graphic and they 
can be combined. Filters always apply to the entire graphic and it is not possible to use filters to 
edit only a part of the object.

• Invert – inverts or reverses the color values of a color image (similar to a color negative), 
or the brightness values of a grayscale image. Apply the filter again to revert to the original 
image.

• Smooth – softens or blurs the image by applying a low pass filter reducing the contrast 
between neighboring pixels and produces a slight lack of sharpness. Also opens the 
Smooth dialog where you can set the Smooth Radius parameter used for the Smooth filter 
when you click OK.

• Sharpen – sharpens the image by applying a high pass filter increasing the contrast 
between neighboring pixels emphasizing the difference in brightness. This will accentuate 
the outlines and the effect will be strengthened if you apply the filter several times.

• Remove Noise – removes noise by applying a median filter by comparing every pixel with 
its neighbors. It then replaces extreme values of those pixels that deviate in color by a large
amount from a mean value by a pixel with a mean color value. The amount of picture 
information does not increase, but because there are fewer contrast changes resulting in a 
graphic that looks smoother.
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• Solarization – solarization is a phenomenon in photography in which the image recorded 
on a negative or on a photographic print is wholly or partially reversed in tone. Dark areas 
appear light or light areas appear dark. Solarization was originally a photochemical effect 
used during photographic film development and is now used in the digital world of 
computing to create a change or reversal of color.

Clicking Solarization opens the Solarization dialog allowing you to define the threshold 
value for solarization. Entering a Threshold value above 70% reverses the color values. 
Selecting the Invert option, all the colors are inverted.

• Aging – aging creates a look that resembles photographs developed in the early days of 
photography. All pixels are set to their gray values and then the green and blue color 
channels are reduced by the amount specified in the Aging dialog while the red color 
channel is not changed. Clicking Aging opens the Aging dialog allowing you to define the 
Aging degree and create an old look for your graphic.

• Posterize – posterizing reduces the number of colors in a graphic making it look flatter. 
When used on a photograph, posterizing can make the photograph look like a painting. 
Clicking Posterize opens the Posterize dialog allowing you to define the number of Poster 
colors to produce the effect you want.

• Pop Art – changes the colors of an image to a pop-art format.

• Charcoal Sketch – displays the image as a charcoal sketch. The contours of the graphic 
are drawn in black and the original colors are suppressed.

• Relief – this filter calculates the edges of an image in relief as if the image is illuminated by 
a light source. Clicking Relief opens the Relief dialog where you can select the position of 
the Light source producing shadows that differ in direction and magnitude.

• Mosaic – this filter joins groups of pixels and converts them into a rectangular tile in a 
single color creating an image that appears to be a mosaic. The larger the individual 
rectangles created, the fewer details the mosaic graphic has.

Clicking Mosaic opens the Mosaic dialog allowing you to set the number of pixels used to 
create the Width and Height of each tile created. Selecting Enhanced edges will enhance 
the edges of each tile to create a sharper definition.

Cropping images
When you only want to display a section of an image in your spreadsheet, you may can crop or 
hide parts of an image. If you want to remove or delete areas of an image then it is recommended 
to use LibreOffice Draw or another graphics package before inserting the image into your 
spreadsheet.

1) Select the image in your spreadsheet.

2) Click the Crop Picture icon  on the Picture toolbar to open the Crop dialog (Figure 8).

3) Using the options available in the Crop dialog and described below, specify how the image 
is cropped. It is not possible to use the mouse for cropping an image in Calc. The thumbnail
shown in the dialog preview displays the image area that will remain after cropping with an 
inner rectangle.

4) Click OK to close the dialog and your cropped image is displayed in your spreadsheet.

Note
If you crop an image in Calc, the original image file is not affected. However, if you 
export the spreadsheet to HTML format, the full original image is exported, not the 
cropped image.
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Figure 8: Crop dialog

Note
The cropped shape is always a rectangle. More complex cropped shapes are not 
possible in Calc. To create more complex shapes when cropping, use a dedicated 
photograph or image editing software, then import the resulting image into Calc.

The options available in the Crop dialog are as follows:

• Crop – allows you to trim or scale the selected image, or to add white space around the 
image.

– Keep scale – maintains the original scale of the image when cropping so that only the 
size of the image changes.

– Keep image size – maintains the original size of the image when you crop so that only 
the scale of the image changes. To reduce the scale of the image, select this option and
enter negative values in the cropping boxes. To increase the scale of the image, enter 
positive values in the cropping boxes.

– Left and Right – if Keep Scale is selected, enter a positive amount to trim the left or 
right edge of the image, or a negative amount to add white space to the left or right of 
the image. If Keep image size is selected, enter a positive amount to increase the 
horizontal scale of the image, or a negative amount to decrease the horizontal scale of 
the image.

– Top and Bottom – if Keep Scale is selected, enter a positive amount to trim the top or 
bottom of the image, or a negative amount to add white space above or below the 
image. If Keep image size is selected, enter a positive amount to increase the vertical 
scale of the image, or a negative amount to decrease the vertical scale of the image.

• Scale – allows you to change the scale of the selected image. In the Width and Height 
fields enter a value for the width or height of the selected image as a percentage.

• Image size – allows you to change the size of the selected image. In the Width and Height 
fields enter a value for the width or height of the selected image.

• Preview field – displays a preview of the selected image.

• Original Size – returns the selected image to its original image size which is indicated 
above the Original Size button. The bitmap image density is shown alongside the original 
size of the image.

Modifying images 14



Adding text
To add text to an image you have inserted into your spreadsheet. Any text added to an image 
becomes an integral part of that image and will move with the image when the image is 
repositioned. For more information on adding text to images, see the Draw Guide.

1) Select the image you want to add text to.

2) Double-click on the image and the text cursor flashes in the center of the image. The Text 
Formatting toolbar automatically opens at the top of the spreadsheet.

3) Enter your text and make any formatting adjustments to the text using the tools on the Text 
Formatting toolbar.

4) When finished, click outside the image to cancel the text editing mode and your text will 
appear in the default position at the center of the image.

Figure 9: Text dialog

5) To adjust the position of the text or how it appears in the image, right-click on the image 
and select Text from the context to open the Text dialog (Figure 9).

6) Make any necessary changes and click OK to close the dialog. The various options 
available are described below. If an option is grayed out in the Text dialog, then it is not 
available for use in Calc.

The options in the Text dialog are as follows:

• Text – sets the layout and anchoring properties for text in the selected image. The text is 
positioned relative to the edges of the image.

– Fit width to text – expands the width of the image to the width of the text, if the image is 
smaller than the text.

– Fit height to text – expands the height of the object to the height of the text, if the object 
is smaller than the text.

– Fit to frame – resizes the text to fit the entire area of the image.

– Adjust to contour – adapts the text flow so that it matches the contours of the selected 
image.

– Word wrap text in shape – wraps the text that you add after double-clicking a custom 
shape to fit inside the shape.
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– Resize shape to fit text – resizes a custom shape to fit the text that you enter after 
double-clicking the shape.

• Spacing to borders – specify the amount of space to leave between the edges of the 
image and the borders of the text.

– Left – enter the amount of space to leave between the left edge of the image and the 
left border of the text.

– Right – enter the amount of space to leave between the right edge of the image and the
right border of the text.

– Top – enter the amount of space to leave between the top edge of the image and the 
upper border of the text.

– Bottom – enter the amount of space to leave between the bottom edge of the image 
and the lower border of the text.

• Text anchor – set the anchor position. Click where you want to place the anchor for the 
text.

• Full width – anchors the text to the full width of the image.

Positioning, resizing and arranging images

Using the mouse

Positioning
To move an image to a new position in your spreadsheet, click on the image and drag it to a new 
position. Release the mouse button when you are satisfied. The image will still be anchored to the 
cell or page the image was originally anchored to.

Resizing
1) Click on the image to display the colored selection handles.

2) Position the cursor over one of the colored selection handles. The cursor changes shape 
giving a graphical representation of the direction of the resizing. The corner handles resize 
both the width and the height of the image simultaneously. The top, bottom, left and right 
handles only resize one dimension at a time.

3) Click and drag to resize the image.

4) Release the mouse button when satisfied with the new size.

Tip To retain the original proportions of the image, Shift+click one of the corner handles,
then drag.

Position and Size dialog
If you want to accurately position and size an image in your spreadsheet, go to Format > Graphic 
> Position and Size on the main menu bar, or right-click on an image and select Position and 
Size from the context menu (Figure 10).

Position and Size
Open the Position and Size dialog and click on the Position and Size tab (Figure 10) to set the 
appropriate values.
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• Position – specify the location of the selected image on the spreadsheet.

– Position X – enter the horizontal distance that you want to move the object relative to 
the base point selected in the grid.

– Position Y – enter the vertical distance that you want to move the object relative to the 
base point selected in the grid.

– Base point – select a base point in the grid and then enter the amount that you want to 
shift the image relative to the base point that you selected in the Position Y and 
Position X boxes. The base points correspond to the selection handles on an image.

Figure 10: Position and Size dialog

• Size – specify the amount by which you want to resize the selected image with respect to 
the selected base point.

– Width – enter a width for the selected image.

– Height – enter a height for the selected image.

– Keep ratio – maintains proportions when you resize the selected image.

– Base point – select a base point in the grid, and then enter the new size dimensions for 
the selected image in the Width and Height boxes.

• Protect

– Position – prevents changes to the position or the size of the selected image.

– Size – prevents you from resizing the image.

• Adapt – specifies, if the size of a drawing image should be adjusted to fit the size of 
entered text.

– Fit width to text – expands the width of the image to the width of the text, if the image is 
smaller than the text.

– Fit height to text – expands the height of the image to the height of the text, if the image
is smaller than the text.

The units of measurement used for X//Y coordinates and the width and height of the image are set 
by going to Tools > Options > LibreOffice Draw > General.

Positioning, resizing and arranging images 17



The default location of the base points for position and size is the upper left corner of the 
spreadsheet. You can temporarily change this base point to make positioning or dimensioning 
simpler by clicking on a position corresponding to the location of the base point you want to use. 
This change in base point is only valid for single use and the base point is reset to the standard 
position of top left corner when you close the Position and Size dialog.

Rotating images
To accurately rotate an image, click on the Rotation tab of the Position and Size dialog (Figure 11). 
Use this dialog to define the rotation angle and the location of the pivot point.

Figure 11: Position and Size dialog – Rotation page

• Pivot point – the selected image is rotated around a pivot point that you specify. The 
default pivot point is at the center of the image. If you set a pivot point too far outside of the 
image boundaries, the image could be rotated off the page.

– Position X – enter the horizontal distance from the left edge of the page to the pivot 
point.

– Position Y – enter the vertical distance from the top edge of the page to the pivot point.

– Default settings – select where you want to place the pivot point. Default position is the 
center of the image. Changing the rotation pivot point is only valid for single use. The 
pivot point is reset to default settings when you close the Position and Size dialog.

• Rotation angle – specify the number of degrees that you want to rotate the selected 
image, or click in the rotation grid.

– Angle – enter the number of degrees that you want to rotate the selected image.

– Default settings – click on the indicator to rotate the image. The number of degrees is 
shown in the Angle box as you rotate the indicator.

Slant and corner radius
To accurately set the corner radius or slant angle of an image, click on the Slant & Corner Radius 
tab of the Position and Size dialog (Figure 12).
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Figure 12: Position and Size dialog – Slant & Corner Radius page

• Corner Radius – you can only round the corners of a rectangular image. If this section is 
grayed out, then you cannot set a corner radius.

– Radius – enter the radius of the circle that you want to use to round the corners. The 
larger the value for corner radius set, the rounder the corners of an image become.

• Slant – slants the selected image along the bottom edge of the image.

– Angle – enter the angle of the slant axis. The slant angle relates to how much an image
inclines or slants from its normal vertical position on a drawing.

Arranging images
Each image that you place in your spreadsheet is successively stacked on the preceding image. 
Use the arrange commands to change the stacking order of images in your spreadsheet. You 
cannot change the stacking order of text.

1) Select the image you want to rearrange.

2) Go to Format > Arrange on the main menu bar, or right-click on the image and select one 
of the arrange options described below.

3) Alternatively, click on the Bring to Front icon  or the Send to Back icon  on the 
Picture toolbar to quickly move your image to the front or rear of the stack.

The options available for arranging images are as follows:

• Bring to Front – moves the selected image to the top of the stacking order, so that it is in 
front of other images.

• Bring Forward – moves the selected image up one level, so that it is closer to top of the 
stacking order. Not available on the Picture toolbar.

• Send Backward – moves the selected image down one level, so that it is closer to the 
bottom of the stacking order. Not available on the Picture toolbar.

• Send to Back – moves the selected image to the bottom of the stacking order, so that it is 
behind the other images.

• To Foreground – moves the selected image in front of text.

• To Background – moves the selected image behind text. To select a background image so
that you can modify or replace it, you have to use the Navigator. Other methods of 
selection, such as clicking or double-clicking, do not work.

Anchoring images
To anchor an image or change the type of anchor used:

1) Go to Format > Anchor > To Page or To Cell on the main menu bar, or right-click on the 
image and select To Page or To Cell from the context menu.
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2) Alternatively, click on the Change Anchor icon  on the Picture toolbar and the anchor 
type will toggle between To Page or To Cell.

Anchors are used for images so that they stay in their position in relation to other items.

• To Page – anchoring an image to the page allows it to be positioned in a specific place on 
the page. The image does not move when cells are added or deleted and is equivalent to 
an absolute reference. The image will always stay in the same position on the page where 
it is placed.

• To Cell – anchoring an image to a cell ensures that the graphic always stays with the 
content it is originally anchored to. If an image is anchored to cell B10, and a new row is 
inserted, the graphic will then be anchored to cell B11 and is equivalent to a relative 
reference.

Aligning images
When you have more than one image in your spreadsheet, you can align these images to give 
your spreadsheet a more professional look.

1) Select all of the graphics to be aligned.

2) Go to Format > Alignment on the main menu bar, or right-click on the image and select 
Alignment from the context menu, or click on the Alignment icon on the Picture toolbar.

3) Select one of the six options available for alignment and your images will be aligned.

The six options include three for aligning the images horizontally (left, centered, right) and three for
aligning the images vertically (top, center, bottom).

• Left – horizontally aligns the left edges of the selected images.

• Centered – horizontally centers the selected images.

• Right – horizontally aligns the right edges of the selected images.

• Top – vertically aligns the top edges of the selected images.

• Center – vertically centers the selected images.

• Bottom – vertically aligns the bottom edges of the selected images.

Grouping and ungrouping images

Grouping
You can group several images so that they become object in your spreadsheet.

1) Select the images you want to group.

2) Go to Format > Group > Group on the main menu bar, or right-click on the selected 
images and select Group > Group from the context menu.

Ungrouping
1) Select the image group you want to ungroup.

2) Go to Format > Group > Ungroup on the main menu bar, or right-click on the selected 
images and select Group > Ungroup from the context menu.

Editing grouped images
1) Select the image group where you want to edit an image within the group.

2) Go to Format > Group > Enter Group on the main menu bar, or right-click on the selected 
images and select Group > Edit Group from the context menu.
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3) Select the image you want to make changes to and carry out those changes.

4) Go to Format > Group > Exit Group on the main menu bar, or right-click on the selected 
images and select Group > Exit Group from the context menu.

Calc drawing tools

Calc, like all other components of LibreOffice, has a range of tools to create drawings and this 
chapter covers the default options in Calc. For a more detailed explanation of the drawing tools 
and their uses, see the Draw Guide. However, if you need to create complex drawings for your 
spreadsheet, it is recommended to use LibreOffice Draw or another drawing program and then 
insert the drawing into your spreadsheet.

Drawing toolbar
To begin using the drawing tools, go to View > Toolbars > Drawing to open the Drawing toolbar, 
which appears in its default position at the bottom of the spreadsheet. You can make this toolbar a 
floating toolbar and move it to a convenient position. When the Drawing toolbar opens, it opens 
with a default set of tools as shown in Figure 13.

Figure 13: Drawing toolbar

The drawing tools available for use when the Drawing toolbar is opened are shown in and these 
are indicated by a border around the tool icon. Any not on the Drawing toolbar does not have a 
border around the tool icon. To add tools to the Drawing toolbar, right-click in an empty area on the 
toolbar and select Visible Buttons from the context menu.

Drawing tools
Referring to Figure 14, the drawing tools are explained as follows:

• Selection – when selected, lets you select objects in the current document. To select more 
than one object, drag a selection frame around the objects. To add an object to a selection, 
press Shift and then click the object.

Figure 14: Available drawing tools
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• Line – draws a straight line where you drag in the current spreadsheet. To constrain the 
line to 45 degrees, hold down Shift while you drag.

To enter text on a line, double-click the line and type or paste your text. The text direction 
corresponds to the direction you dragged to draw the line. To hide the line, select None 
from the drop-down list for Line Style on the Drawing Object Properties toolbar (Figure 15 
on page 24).

• Rectangle – draws a rectangle in the current spreadsheet. Click where you want to place a
corner of the rectangle, and drag to the size you want. To draw a square, hold down Shift 
while you drag.

• Ellipse – draws an oval in the current spreadsheet. Click where you want to draw the oval, 
and drag to the size you want. To draw a circle, hold down Shift while you drag.

• Polygon – draws a line composed of a series of straight line segments. Drag to draw a line
segment, click to define the endpoint of the line segment, and then drag to draw a new line 
segment. Double-click to finish drawing the line. To create a closed shape, double-click the 
starting point of the line. Hold the Shift key while drawing a polygon to position new points 
at 45 degree angles.

The Edit Points mode enables you to interactively modify the individual points of the 
polygon.

• Curve – draws a smooth Bezier curve. Click where you want the curve to start, drag, 
release, and then move the pointer to where you want the curve to end and click. Move the 
pointer and click again to add a straight line segment to the curve. Double-click to finish 
drawing the curve. To create a closed shape, double-click the starting point of the curve. 
The arc of the curve is determined by the distance you drag.

• Freeform Line – draws a freeform line where you drag in the current spreadsheet. To end 
the line, release the mouse button. To draw a closed shape, release the mouse button near
the starting point of the line.

• Arc – draws an arc in the current spreadsheet. To draw an arc, drag an oval to the size you
want, and then click to define the starting point of the arc. Move the cursor to where you 
want to place the endpoint and click. You do not need to click on the oval. To draw an arc 
that is based on a circle, hold down Shift while you drag.

• Ellipse Pie – draws a filled shape that is defined by the arc of an oval and two radius lines 
in the current spreadsheet. To draw an ellipse pie, drag an oval to the size you want, and 
then click to define the first radius line. Move the cursor to where you want to place the 
second radius line and click. You do not need to click on the oval. To draw a circle pie, hold 
down Shift while you drag.

• Circle Segment – draws a filled shape that is defined by the arc of a circle and a diameter 
line in the current spreadsheet. To draw a circle segment, drag a circle to the size you want,
and then click to define the starting point of the diameter line. Move the cursor to where you
want to place the endpoint of the diameter line and click. You do not need to click on the 
circle. To draw an ellipse segment, hold down Shift while you drag.

• Text – draws a text box with horizontal text direction where you drag in the current 
spreadsheet. Drag a text box to the size you want anywhere in the spreadsheet and then 
type or paste your text. Rotate the text box to get rotated text.

• Vertical Text – draws a text box with vertical text direction where you click or drag in the 
current spreadsheet. Drag a text box to the size you want anywhere in the spreadsheet and
then type or paste your text. Only available when Asian language support is enabled in 
Tools > Options > Language Settings > Languages.

• Text Animation – inserts animated text with horizontal text direction into the current 
spreadsheet.
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• Callouts – draws a line that ends in a rectangular callout with horizontal text direction from 
where you drag in the current spreadsheet. Drag a handle of the callout to resize the 
callout. To add text, click the edge of the callout and then type or paste your text. To change
a rectangular callout to a rounded callout, drag the largest corner handle when the cursor 
changes shape.

• Vertical Callouts – draws a line that ends in a rectangular callout with vertical text direction
from where you drag in the current spreadsheet. Drag a handle of the callout to resize the 
callout. To add text, click the edge of the callout, and then type or paste your text. To 
change a rectangular callout to a rounded callout, drag the largest corner handle when the 
pointer changes shape. Only available when Asian language support is enabled in Tools > 
Options > Language Settings > Languages.

• Basic Shapes – opens the Basic Shapes toolbar which you can use to insert shapes into 
your spreadsheet.

• Symbol Shapes – opens the Symbol Shapes toolbar from which you can insert symbols 
into your spreadsheet.

• Block Arrows – opens the Block Arrows toolbar from which you can insert block arrows 
into your spreadsheet.

• Flowchart – opens the Flowchart toolbar from which you can insert flowchart symbols into 
your spreadsheet.

• Callouts – opens the Callouts toolbar from which you can insert callout shapes into your 
spreadsheet.

• Stars and Banners – opens the Stars and Banners toolbar from which you can insert star 
and banner shapes into your spreadsheet.

• Points – enables you to edit points on the drawing you are creating in your spreadsheet.

• Fontwork Gallery – opens the Fontwork Gallery from which you can insert graphical text 
art into your spreadsheet.

• From File – inserts a picture or image into the current spreadsheet.

• Extrusion On/Off – switches the 3D effects on and off for selected objects.

Using drawing tools
1) Click in the spreadsheet where you want the drawing to be anchored. You can change the 

anchor type later, if necessary.

2) Select the tool from the Drawing toolbar (Figure 13 on page 21).

3) Move the cursor to where you want the graphic to appear, then click-and-drag to create the 
drawing object. Some tools have other requirements; see the Help or the Draw Guide for 
details. The selected drawing function remains active, so you can draw another object of 
the same type.

4) To cancel the selected drawing function, press the Esc key or click on the Select icon on 
the Drawing toolbar.

Drawing object properties
For more information on the properties of drawing objects, see the Draw Guide.
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Setting properties
You can set the default properties for a drawing object before you draw an object. These default 
properties are applied only to the current spreadsheet and are are not retained when you close the 
spreadsheet. The properties only apply to drawing objects.

1) Click Select on the Drawing toolbar (Figure 13 on page 21).

2) On the Drawing Object Properties toolbar (Figure 15), set the values or options you want to
use for each property. When you select area or line properties, dialogs open where you can
set the values used for area or line

Figure 15: Drawing Object Properties toolbar

Changing properties
You can change the properties of an existing drawing object (fill color, line type and weight, 
anchoring, and so on) using either the Drawing Object Properties toolbar (Figure 15), or the 
options available on the main menu bar or the context menu when you right-click on the drawing 
object.

Resizing drawing objects
Select the object and click on one of the selection handles then drag the object to its new size. For 
a scaled resizing, select one of the corner handles and keep the Shift key pressed while dragging 
the handle. For more information, see “Positioning, resizing and arranging images” on page 16.

Grouping and ungrouping drawing objects
Grouping, ungrouping and editing grouped drawing objects, see “Grouping and ungrouping 
images” on page 20 for more information.

Additional tools

Some additional tools are only available for images or graphics when the you right-click on an 
image or graphic and open the context menu.

Description
You can add metadata in the form of a title and description to an image. This information is used by
accessibility tools (such as screen reader software) and as ALT (alternative) attributes if you export
the document to HTML.

Name
You can add a custom name to be assigned to an image and this will make an image easier to find 
in the Navigator. Also, assigning names to an image allows it to be easily identified when teams of 
personnel are working on the same multi page spreadsheet.

Flip
Flips the image either horizontally or vertically. Any text added to the image also changes 
orientation with the image, but only when the image is flipped vertically.
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Assign Macro
Opens the Assign Macro dialog (Figure 16) so you can add programmable functionality to the 
graphic. Calc has a very good macro functionality and more information on macros can be found in
Chapter 12 Calc Macros.

Figure 16: Assign Macro dialog

Hyperlink
For images and graphics, you can define a hyperlink at another location in your spreadsheet, 
another document or web page. To do this, select the graphic, right-click and select Hyperlink from
the context menu to open the Hyperlink dialog (Figure 17). See Chapter 10 Linking Calc Data for 
more information on hyperlinks.

Figure 17: Hyperlink dialog
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Compress graphic
You can compress a graphic to reduce the file size of your spreadsheet. To do this, select the 
graphic, right-click and select Compress Graphic from the context menu to open a dialog (Figure 
18) where you can set the compression options. The dialog shows the type, original size, view 
size, rand image capacity of the graphic.

Use the dialog to select the type of compression and the resolution of the reduced image. When 
you have made your changes, click Calculate and the size of the compressed graphic is displayed
in New Capacity. If you are satisfied with the new capacity, click OK and the graphic is 
compressed.

Figure 18: Compress Graphic dialog

Edit with external tool
You can edit a graphic with an external tool to use more advanced tools. To do this, select the 
graphic, right-click and select Edit with External Tool from the context menu. The dialog that 
opens will depend on your computer setup.

Image maps

An image map is a reference-sensitive graphic or text frame. In Calc, you Ctrl+click on defined 
areas (also known as hotspots) in the graphic or text frame to go to a target or linked reference 
such as a URL. The reference areas, along with any linked URLs and corresponding text are 
displayed when resting the cursor on these areas that have been defined in the ImageMap Editor.
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Image map types
There are two types of ImageMaps.

• Server Side ImageMap – is evaluated on the server computer and appear for the reader 
as a picture or frame on the page. Click on the ImageMap with the mouse, and the 
coordinates of the relative position are sent to the server. The server then determines the 
next step to take. There are several incompatible methods to define this process, the two 
most common being W3C (CERN) HTTP Server (Format type: MAP – CERN) and NCSA 
HTTP Server (Format type: MAP – NCSA)

LibreOffice creates ImageMaps for both methods. Select the format from the File type list in
the Save As dialog in the ImageMap Editor. Separate map files are created which you must
upload to the server. You will need to ask your provider or network administrator which type
of ImageMaps are supported by the server and how to access the evaluation program.

• Client Side ImageMap – is evaluated on the client computer. The area of the picture or 
frame where the reader can click is indicated by the appearance of a linked URL when the 
cursor passes over the area. The ImageMap is stored in a layer below the picture and 
contains information about the referenced regions. The only disadvantage of Client Side 
ImageMaps is that older Web browsers cannot read them; a disadvantage that will, 
however, resolve itself in time.

When saving the ImageMap, select the file type SIP – StarView ImageMap. This saves the 
ImageMap directly in a format which can be applied to every active picture or frame in your 
document. However, if you just want to use the ImageMap on the current picture or text 
frame, you do not have to save it in any special format. After defining the regions, simply 
click Apply. Client Side ImageMaps saved in HTML format are inserted directly into the 
page in HTML code.

Creating image maps
1) Position the cursor where you want the ImageMap in your spreadsheet.

2) Insert an image or graphic you want to use into your spreadsheet.

3) Make sure the image or graphic is selected and go to Edit-> ImageMap on the main menu 
bar to open the ImageMap Editor (Figure 19). The ImageMap Editor displays the image or 
graphic as a background.

4) Use the tools in the ImageMap Editor to draw a hotspot shape, for example a rectangle, 
over the image at the background. A hotspot is highlighted in Figure 19.

5) Enter the URL in the Address text box that will open a web browser when the user clicks 
the hotspot.

6) Optionally, enter text in the Text box that will show as a tip when the user hovers the cursor 
over the hotspot.

7) Click the Apply icon to apply your changes to the hotspot.

8) If necessary, click the Save icon to save the image or graphic for future use in ImageMap 
file format in the file location that you want to use.

9) To check if the hotspot works correctly, deselect the graphic or image in Calc and then 
Ctrl+click on the hotspot to open your browser at the correct webpage or file location.

10) Save the spreadsheet before closing the spreadsheet and LibreOffice.

Notes
It is recommended not to use the whole image or graphic as a hotspot when defining 
a single link. If you have to use the whole image or graphic, then right-click on the 
image or graphic and select Hyperlink from the context menu.
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Figure 19: ImageMap Editor dialog

ImageMap tools
The toolbar at the top of the ImageMap Editor dialog contains the following tools and boxes. 
Depending on the type of hotspot being added to the image map, some tools will not become 
active until you change the type of hotspot being added.

• Apply – applies the changes that you made to the image map.

• Open – loads and existing image map in the MAP-CERN, MAP-NCSA or SIP StarView file 
format.

• Save – saves the image map in the MAP-CERN, MAP-NCSA or SIP StarView file format.

• Select – selects a hotspot in the image map so you can edit it.

• Rectangle – draws a rectangular hotspot on the selected image or graphic. Hold the Shift 
key down to draw a square hotspot.

• Ellipse – draws an elliptical hotspot on the selected image or graphic. Hold the Shift key 
down to draw a circular hotspot.

• Polygon – draws a polygonal hotspot on the selected image or graphic. Click and drag in 
the image or graphic and then click to define one side of the polygon. Move the cursor to 
where you want to place the end of the next side of the polygon and then click. Repeat until
you have drawn all the sides of the polygon. When you are finished, double-click to close 
the polygon.

• Freeform Polygon – draws a hotspot that is based on a freeform polygon. Select and 
move the cursor to where you want to draw the hotspot. Drag a freeform line and release to
close the shape.

• Edit Points – lets you change the shape of the selected hotspot by editing the anchor 
points.

• Move Points – lets you move individual anchor points of the selected hotspot.

• Insert Points – inserts an anchor point where you click on the outline of the selected 
hotspot.

• Delete Points – deletes the selected anchor point from the outline of the selected hotspot
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• Undo – reverses the last command or last entry you typed.

• Redo – reverses the last Undo command.

• Active – disable or enables the hyperlink for the selected hotspot. A disabled hotspot is 
transparent.

• Macro... – assigns a macro that runs when click the selected hotspot.

• Properties... allows you to define the properties of the selected hotspot.

• Address – enter the URL for the file that you want to open when you click the selected 
hotspot.

• Text – enter the text that you want to display when the cursor rests on the hotspot.

• Frame – enter the name of the target frame that you want to open the URL in. You can also
select a standard frame name from the list. The value _self for the target frame will work in 
the vast majority of occasions. It is not recommended to use the other types of frames 
unless absolutely necessary.

– _self – file opens in the current frame.

– _blank – file opens in a new page.

– _parent – file opens in the parent frame of the current frame. If there is no parent frame,
the current frame is used.

– _top – file opens in the topmost frame in the hierarchy.

Editing image maps
1) Select the image or graphic and go to Edit-> ImageMap on the main menu bar to open the 

ImageMap Editor (Figure 19). The ImageMap Editor displays the image or graphic as a 
background.

2) Select the hotspot you want to edit. A hotspot is highlighted in Figure 19.

3) Click on the Properties icon to open the Properties dialog (Figure 20).

Figure 20: Properties dialog for ImageMap Editor

4) Make the necessary changes in the text boxes for URL, Frame, Name, Alternative text and 
Description.

5) Click OK to save the changes and close the dialog.

6) Click the Apply icon to apply your changes to the hotspot in the selected graphic or image.
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7) If necessary, click the Save icon to save the image or graphic for future use in ImageMap 
file format in the file location that you want to use.

8) To check if the hotspot works correctly, deselect the graphic or image in Calc and then 
Ctrl+click on the hotspot to open your browser at the correct webpage or file location.

9) Save the spreadsheet before closing the spreadsheet and LibreOffice.
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