
Calc Guide

Chapter 6 
Printing, Exporting and 
E-mailing



Copyright

This document is Copyright © 2005–2013 by its contributors as listed below. You may distribute it 
and/or modify it under the terms of either the GNU General Public License 
(http://www.gnu.org/licenses/gpl.html), version 3 or later, or the Creative Commons Attribution 
License (http://creativecommons.org/licenses/by/3.0/), version 3.0 or later.

All trademarks within this guide belong to their legitimate owners.

Contributors
Barbara Duprey Jean Hollis Weber John A Smith
Christian Chenal Martin Saffron Peter Schofield

Feedback
Please direct any comments or suggestions about this document to: 
documentation@global.libreoffice.org.

Acknowledgments
This chapter is adapted and updated from Chapter 6 of the OpenOffice.org 3.3 Calc Guide. The 
contributors to that chapter are:

Jean Hollis Weber Emma Kirsopp Peter Kupfer
Shelagh Manton Kashmira Patel Linda Worthington

Publication date and software version
Published 29 December 2013. Based on LibreOffice 4.1.

Note for Mac users

Some keystrokes and menu items are different on a Mac from those used in Windows and Linux. 
The table below gives some common substitutions for the instructions in this chapter. For a more 
detailed list, see the application Help.

Windows or Linux Mac equivalent Effect

Tools > Options 
menu selection

LibreOffice > Preferences Access setup options

Right-click Control+click or right-click 
depending on computer setup

Opens a context menu

Ctrl (Control) ⌘ (Command) Used with other keys

F5 Shift+⌘+F5 Opens the Navigator

F11 ⌘+T Opens the Styles and Formatting window

Documentation for LibreOffice is available at http://www.libreoffice.org/get-help/documentation

http://www.libreoffice.org/get-help/documentation
mailto:documentation@global.libreoffice.org
http://creativecommons.org/licenses/by/3.0/
http://www.gnu.org/licenses/gpl.html


Contents

Copyright..............................................................................................................................2
Contributors.................................................................................................................................2

Feedback.....................................................................................................................................2

Acknowledgments........................................................................................................................2

Publication date and software version.........................................................................................2

Note for Mac users...............................................................................................................2

Printing..................................................................................................................................5
Quick printing...............................................................................................................................5

Controlling printing.......................................................................................................................5
General page..........................................................................................................................6
LibreOffice Calc page..............................................................................................................6
Page Layout page...................................................................................................................6
Options page...........................................................................................................................6

Printing multiple pages on a single sheet.....................................................................................7

Selecting pages to print...............................................................................................................7
Individual page........................................................................................................................7
Range of pages.......................................................................................................................7
Selection printing.....................................................................................................................7

Using print ranges...............................................................................................................8
Defining and printing print ranges................................................................................................8

Adding print ranges......................................................................................................................8

Editing print ranges......................................................................................................................9

Viewing print ranges....................................................................................................................9

Named print ranges...................................................................................................................10
Defining and naming.............................................................................................................10
Printing named ranges..........................................................................................................10
Deleting named print ranges..................................................................................................11

Removing print ranges...............................................................................................................11

Repeat printing of rows or columns............................................................................................12
Using print ranges.................................................................................................................12
Using named print ranges.....................................................................................................12

Page breaks........................................................................................................................13
Inserting page breaks................................................................................................................13

Deleting page breaks.................................................................................................................13

Deleting multiple page breaks....................................................................................................13

Printing options for page styles.......................................................................................13

Headers and footers..........................................................................................................15
Setting headers and footers.......................................................................................................15

Header or footer contents..........................................................................................................17

Exporting to PDF................................................................................................................18
Directly as PDF..........................................................................................................................18

Controlling PDF content and quality...........................................................................................19
General page........................................................................................................................19

Printing, Exporting and E-mailing 3



Initial View page....................................................................................................................21
User Interface page...............................................................................................................22
Links page.............................................................................................................................22
Security page........................................................................................................................23

Exporting to other formats................................................................................................24
Other formats.............................................................................................................................25

Web pages.................................................................................................................................25

E-mailing spreadsheets.....................................................................................................25

Digital signing of documents............................................................................................25
Digital signatures.......................................................................................................................25

Applying digital signatures.........................................................................................................26
Digitally signing.....................................................................................................................26
Removing digital signatures..................................................................................................27
Digitally signing macros.........................................................................................................28

Removing personal data...................................................................................................28

Printing, Exporting and E-mailing 4



Printing

Quick printing

To quickly print a spreadsheet, click on the Print File Directly icon  on the Standard toolbar to 
send the entire spreadsheet to the default printer that is defined for your computer.

Note

You can change the action of the Print File Directly icon to send a document to 
the printer defined for the document instead of the default printer for the computer. 
Go to Tools > Options > Load/Save > General and select the Load printer 
settings with the document option.

Controlling printing
For more control over printing, use the Print dialog by going to File > Print on the main menu bar 
or by using the keyboard shortcut Ctrl+P. The Print dialog (Figure 1) has four tabs where you can 
choose a range of options as described in the following sections.

Figure 1. Print dialog – General page

Note

If the option Use LibreOffice dialogs is selected in Tools > Options > General > 
Print, then the Print dialog will be similar to the one shown in this chapter. If Use 
LibreOffice dialogs is not selected, the Print dialog displayed will depend on your 
computer setup.

Note

The options selected on the Print dialog apply to this printing of this document only. 
To specify default printing settings for LibreOffice, go to Tools > Options > 
LibreOffice > Print and Tools > Options > LibreOffice Calc > Print. For details, 
see Chapter 14 Setting Up and Customizing Calc.
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General page
On the General page of the Print dialog (Figure 1), you can:

• Select which printer to use from the printers available in the Printer section.

• Select which sheets and pages to print, the number of copies to print, whether to collate 
multiple copies, and the page order for printing in the Range and Copies section. (See 
“Selecting pages to print“ on page 7.)

• Click Properties to display a printer-specific dialog where you can select paper size, 
portrait or landscape orientation, duplex printing if available, and which paper tray to use.

LibreOffice Calc page
On LibreOffice Calc page of the Print dialog (Figure 2), you can select whether or not to include 
the output of empty pages when you print your spreadsheet.

Figure 2. Print dialog – LibreOffice Calc page

Page Layout page
On the Page Layout page of the Print dialog (Figure 3), you can select how many pages are printed per 
sheet of paper, the order in which the pages are printed on a sheet, and whether a border is drawn 
around each page.

Figure 3. Print dialog – Page Layout page

Options page
On the Options page of the Print dialog (Figure 4) you can select whether to print to a file (instead 
of to a printer), create single print jobs when you want to use collated output (instead of a separate 
print job for each copy), or use only the paper size specified in the printer preferences.

Figure 4. Print dialog – Options page

Printing 6



Printing multiple pages on a single sheet
To print multiple pages of a spreadsheet on one piece of paper:

1) Go to File > Print on the menu bar or use the keyboard shortcut Ctrl+P to open the Print 
dialog and then select the Page Layout page (Figure 3).

2) In the Layout section, select from the Pages per sheet drop-down list the number of pages 
to print per sheet. The preview panel on the right shows how the pages will look in the 
printed document.

3) When printing more than two pages per sheet, select the order in which the pages are 
printed on a sheet from the Order drop-down list.

4) To distinguish each page on a sheet, select the Draw a border around each page option.

5) Click OK.

Selecting pages to print
In addition to printing a full spreadsheet document, you can choose whether to print individual 
pages, a range of pages, or selected sheets and cells within the spreadsheet.

Individual page
To print an individual page:

1) Go to File > Print on the menu bar or use the keyboard shortcut Ctrl+P to open the Print 
dialog and then select the General page (Figure 1).

2) In the Ranges and copies section, select the Pages option.

6) Enter the number of the page to print, then click OK.

Range of pages
To print a range of pages:

1) Go to File > Print on the menu bar or use the keyboard shortcut Ctrl+P to open the Print 
dialog and then select the General page (Figure 1).

2) In the Ranges and copies section, select the Pages option.

7) Enter the number of the pages to print (for example 1-4 or 1,3,7,11), or any combination of 
the two (for example: 1-4,5-9,10), then click OK.

Selection printing
To print a selection from a spreadsheet:

1) In the document, select the sheets or the cells you want to print.

2) Go to File > Print on the menu bar or use the keyboard shortcut Ctrl+P to open the Print 
dialog and then select the General page (Figure 1).

3) In the Ranges and copies section, select Selected sheets or Selected cells option, then 
click OK.

Note
After printing, make sure you have deselected any sheets or cells. If you keep these 
sheets or cells selected, the next time you enter data on one sheet, you will enter 
data on all the selected sheets. This might not be what you want.
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Using print ranges

You can define which range of cells on a spreadsheet are to be printed. The cells on the sheet that 
are not part of the defined print range are not printed or exported. Also, any sheets without a 
defined print range are not printed or exported to a PDF file, unless the document uses the Excel 
file format.

Note
For files opened in Excel format, all sheets that do not contain a defined print range 
are printed. The same behavior occurs when you export the Excel formatted 
spreadsheet to a PDF file.

Defining and printing print ranges
To set a user-defined print range, which will replace any existing defined print range:

1) Select the range of cells that are to be used in the print range.

2) Go to Format > Print Ranges > Define on the main menu bar. Automatic page break lines 
are then displayed on the screen, defining the cells that are included in the print range.

3) Click on the Print File Directly icon  on the Standard toolbar to print the defined print 
range. Alternatively, go to File > Print on the main menu bar or use the keyboard shortcut 
Ctrl+P to open the Print dialog and click OK to print the defined print range.

Tip

You can check the print range by going to File > Page Preview in the main menu 

bar, or by clicking the Page Preview icon  in the Standard toolbar, or by using 
the keyboard shortcut Ctrl+Shift+O. Calc will display only the cells in the print 
range. You can also go to View > Page break preview on the main menu bar to 
see the print range without going to the page preview. See “Viewing print ranges” 
on page 9.

Adding print ranges
After defining a print range, you can add more cells to it. This allows multiple and separate areas of
the same sheet to be printed, while not printing the whole sheet. After you have defined a print 
range:

1) Select the range of cells to be added to an existing print range.

2) Go to Format > Print Ranges > Add on the main menu bar to add the selected cells to the
existing print range. Page break lines are displayed on the screen around the added cells 
and will print as a separate page, even if both print ranges are on the same sheet.

Figure 5: Edit Print Ranges dialog
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Editing print ranges
At any time, you can directly edit the print range, for example to add to, remove, or resize part of 
the print range.

1) Go to Format > Print Ranges > Edit on the main menu bar to open the Edit Print Ranges 
dialog (Figure 5).

Figure 5 shows an example of two print ranges defined which are separated by a comma. 
The first print range is bounded by cell A1 ($A$1) in the top left and cell B8 ($B$8) in the 
bottom right corner. The second print range is E1 to F8 ($E$1:$F$8).

2) If only a single range is defined, then clicking anywhere in the Print range box displays the 
defined print range bounded in blue, as shown in Figure 6.

Figure 6: Single print range marked by a bounding box

3) To directly add new cells to the defined print ranges, type a comma at the end of the 
displayed data in the Print range text box as the separator for the print range to be added.

4) Select the cell range using the cursor, or directly type in the cell references using the same 
format of the print ranges already defined in the Print range text box. Remember to 
separate the cell references with a colon.

5) To remove a print range, select the print range in the Print range text box and delete it. 
Make sure the remaining print ranges only have a single comma as a separator and that 
there is not a comma at the end of the sequence.

6) To resize a print range, edit the data in the Print range text box for each print range you 
want to resize.

7) Click OK to save your changes and close the dialog.

Viewing print ranges
After print ranges have been defined, they are formatted with automatic page breaks. To view the 
page breaks, go to View > Page Break Preview on the main menu bar to open Page Break 
Preview (Figure 7). 

Figure 7: Page break preview
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The print ranges are outlined by default with a blue border and contain a pale gray page number in 
the center of each page. The nonprinting area of the spreadsheet normally has a gray background.

To exit Page Break Preview, go to View > Normal on the main menu bar.

Named print ranges
In addition to defining a print range for each print job, you can also define a range of cells to be 
used repeatedly. This is useful if different areas of a large spreadsheet have to be printed for 
different reports; several named print ranges can be defined to meet this need.

Figure 8: Define Names dialog

Defining and naming
1) Select the cells you want to define and name as a print range, then go to Insert > Names > 

Define on the main menu bar to open the Define Names dialog (Figure 8). The selected 
cells are displayed in the Range box.

Alternatively open the Define Names dialog, then select the cells you want to define and 
name. The selected cells are then displayed in the Range box.

2) Type a name for the range in the Name box. Make sure you do not use spaces in the name
as shown by the example in Figure 8.

3) If necessary, you can edit or set the range of selected cells for the print range in the Range 
box. See “Editing print ranges” on page 9 for more information on editing ranges of cells.

4) Make sure Document (Global) is selected from the Scope drop-down list.

5) Select Print range from Range Options to define the settings as a print range.

6) Click Add to accept the data and close the dialog.

Printing named ranges
Defining and naming print ranges allows you to quickly select a print range for printing without 
having to select a range of cells every time. To select a named range for printing:

1) Go to Format > Print Ranges > Edit on the main menu bar to open the Edit Print Ranges 
dialog (Figure 5 on page 8).

2) Select the defined and named print range from the Print range drop-down list.

3) Click OK to close the dialog.
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4) Click on the Print File Directly icon  on the Standard toolbar to print the defined print 
range. Alternatively, go to File > Print on the main menu bar or use the keyboard shortcut 
Ctrl+P to open the Print dialog and click OK to print the defined print range.

Deleting named print ranges
To delete a named print range if it is no longer required:

1) Go to Insert > Names > Manage on the main menu bar or use the keyboard shortcut 
Ctrl+F3 to open the Manage Names dialog (Figure 9).

2) Select the named print range you want to delete and confirm it is a print range by checking 
the options in Range Options.

3) Click Delete and then click OK to close the dialog.

Figure 9: Manage Names dialog

Removing print ranges
It may become necessary to remove a defined print range, for example if the whole sheet needs to 
be printed later, or you no longer want to print some of the added ranges.

Go to Format > Print Ranges > Remove on the main menu bar to remove all of the defined print 
ranges in the spreadsheet, except for named print ranges. After the print range is removed, the 
default page break lines for the selected paper size will appear on the screen.

To remove specific print ranges, see “Editing print ranges” on page 9.

To remove named print ranges, see “Deleting named print ranges” on page 11.
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Repeat printing of rows or columns
If a spreadsheet is printed on multiple pages, you can define specific rows or columns to repeat 
print on each printed page.

Using print ranges
1) Go to Format > Print Ranges > Edit on the main menu bar to open the Edit Print Ranges 

dialog (Figure 10).

2) In the Rows to repeat text box, type the references for the rows to be repeat printed. For 
example, to repeat rows 1, 2 and 3, type $1:$3. This automatically changes Rows to 
repeat from - none - to - user defined -.

Alternatively, place the cursor in the Rows to repeat text box and then, using the mouse, 
select a cell in each row you want to be repeat printed. It is not necessary to select the 
whole row.

3) In the Columns to repeat, type the references for the columns to be repeat printed. For 
example, to repeat column A, type $A. This automatically changes Columns to repeat from 
- none - to - user defined -.

Alternatively, place the cursor in the Columns to repeat text box and then, using the mouse,
select a cell in each column you want to be repeat printed. It is not necessary to select the 
whole column.

4) Click OK to save your changes and close the dialog.

Figure 10: Repeat printing of rows and columns

Using named print ranges
You can also define named print ranges to use for repeat printing of rows or columns as follows:

1) Define and name the rows and/or columns you want to repeat print. See “Named print 
ranges” on page 10 for more information.

2) Select Repeat column and/or Repeat row from Range Options to define the columns 
and/or rows for repeat printing in the Define Names dialog (Figure 8 on page 10).

3) Click Add to accept the data and close the dialog.

4) Go to Format > Print Ranges > Edit on the main menu bar to open the Edit Print Ranges 
dialog (Figure 10).

5) Select the defined and named print ranges from the Rows to repeat and/or Columns to 
repeat drop-down lists.

6) Click OK to save your changes and close the dialog.

Using print ranges 12



Page breaks

While defining a print range can be a powerful tool, it may sometimes be necessary to manually 
adjust the printing of a Calc spreadsheet to make sure that it prints the way you want it to look. 
This is done by using manual breaks. You can insert two types of page breaks into a spreadsheet:

• Row break – is a horizontal page break inserted above a selected cell in a row. For 
example, if the selected cell is H15, then a row break is created between rows 14 and 15.

• Column break – is a vertical page break nserted to the left of the selected cell in a column.
For example, if the selected cell is H15, then a column break is created between columns 
G and H.

When a manual break is inserted, it appears as a blue line or as a bold line between the rows or 
columns on the display. The actual appearance depends on your computer setup. To see manual 
break lines more easily on your display, you can change their appearance. Go to Tools > Options 
> LibreOffice > Appearance and scroll down to the Spreadsheet section where you change how 
page breaks appear.

Inserting page breaks
1) Select the cell where you want to insert a manual break in the spreadsheet.

2) Go to Insert > Page Break on the main menu bar.

3) Select Row Break to insert a row break above the cell or Column Break to insert a column
break to the left of the cell.

4) Alternatively, go to View > Page Break Preview on the main menu bar, right-click in the 
spreadsheet and select Insert Row Break or Insert Column Break from the context 
menu. Remember to go to View > Normal on the main menu bar and return to the 
standard spreadsheet view.

Deleting page breaks
1) Select the cell where you want to delete a manual break from the spreadsheet.

2) Go to Edit > Delete Page Break on the main menu bar.

3) Select Row Break to delete a row break from above the cell or Column Break to delete a 
column break from the left of the cell.

Deleting multiple page breaks
Multiple manual row and column breaks can exist in the same spreadsheet. If you want to remove 
all breaks from the spreadsheet:

1) Go to View > Page Break Preview on the main menu bar.

2) Right-click in the spreadsheet and select Delete All Manual Breaks from the context menu
to remove all manual breaks from your spreadsheet.

3) Go to View > Normal on the main menu bar to return to the standard spreadsheet view.

Printing options for page styles

When using page styles for your spreadsheets, you can include printing options within the page 
style; for example, page order, details, scale to be printed and so on. Using page styles allows you 
to quickly set up and change the printing options of different sheets within your spreadsheet. See 
Chapter 4 Using Styles and Templates in Calc for more information about page styles.
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Figure 11. Page Style dialog – Sheet page

Make sure you have selected the correct sheet within your spreadsheet before setting the print 
options. Go to Format > Page on the main menu bar to open the Page Style dialog, then click on 
the Sheet tab (Figure 11) to set the printing options for a page style within the spreadsheet. The 
dialog indicates which page style you are about to change.

• Page Order – defines the order in which data in a sheet is numbered and printed when it 
does not fit on one printed page. A preview of the page order is shown in the graphic on the
top right of the dialog in Figure 11.

– Top to bottom, then right – prints vertically from the left column to the bottom of the 
sheet.

– Left to right, then down – prints horizontally from the top row of the sheet to the right 
column.

– First page number – select this option if you want the first page to start with a number 
other than 1. Enter the number of the first page in the box.

• Print – defines which elements of the spreadsheet are to be printed.

– Column and row headers – prints the column and row headers.

– Grid – prints the borders of the individual cells as a grid. For the view on screen, make 
your selection under LibreOffice > Preferences > LibreOffice Calc > View > Grid 
lines.

– Comments – prints the comments defined in the spreadsheet. Comments will be printed
on a separate page, along with the corresponding cell reference.

– Objects/graphics – includes all inserted objects (if printable) and graphics with the 
printed spreadsheet.

– Charts – prints the charts that have been inserted into your spreadsheet.

– Drawing Objects – includes all drawing objects in the printed spreadsheet.
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– Formulas – prints the formulas contained in the cells, instead of the results of any 
formulas used in the spreadsheet.

– Zero Values – specifies that cells with a zero value are printed with a zero (0) in the cell.

• Scale – defines a page scale for the printed spreadsheet.

– Scaling mode – select a scaling mode from the drop-down list. Appropriate controls for 
the scaling mode selected will be shown below the drop-down list box.

– Reduce/enlarge printout – specifies a scaling factor to scale all printed pages. Enter the
scaling factor as a percentage in the box.

– Fit print range(s) to width/height – specifies the maximum number of pages horizontally 
(width) and vertically (height) on which every sheet with the current Page Style is to be 
printed. 

The print ranges are always scaled proportionally, so the resulting number of pages 
may be less than specified.

You may clear one of the boxes; then the unspecified dimension will use as many 
pages as necessary.

If you clear both boxes, the scaling factor will be 100%.

– Width in pages – enter the maximum number of pages to be printed horizontally across.

– Height in pages – enter the maximum number of pages to be printed vertically stacked.

– Fit print range(s) on number of pages – specifies the maximum number of pages to be 
printed for each sheet that uses the same Page Style. The scale will be reduced as 
necessary to fit the defined number of pages.

– Number of pages – enter the maximum number of pages to be printed.

Headers and footers

Headers and footers are predefined pieces of text that are printed at the top or bottom of a sheet 
outside of the sheet area. Headers and footers are set the same way and you can have different 
content on left and right pages that use the same page style.

Setting headers and footers
To turn the headers or footers on in your spreadsheet:

1) Select the sheet where you want to turn on the header or footer.

2) Got to Format > Page on the main menu bar to open the Page Style dialog and select the 
Header (or Footer) tab (Figure 12). The Header and Footer pages in the Page Style dialog 
are identical.

3) Select the Header on or Footer on option.

4) Enter the values for the other options according to your requirements. These options are 
described below.

5) Click OK to save your changes and close the dialog.
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Figure 12: Page Style dialog – Header page

The options available for headers or footers are as follows:

• Header on or Footer on – adds a header or footer to the current page style.

• Same content left/right – even and odd pages share the same content. To assign a 
different header or footer to even and odd pages, deselect this option and then click Edit. 
See “Header or footer contents” on page 17 for more information.

• Left margin – enter the amount of space to leave between the left edge of the page and 
the left edge of the header or footer.

• Right margin – enter the amount of space to leave between the right edge of the page and
the right edge of the header or footer.

• Spacing – enter the amount of space to maintain between the bottom edge of the header 
or footer and the top edge of the spreadsheet text.

• Height – enter the height that you want for the header or footer.

• AutoFit height – automatically adjusts the height of the header or footer to fit the content 
that you enter.

• Preview Field – displays a preview of the current selection.

• More – opens the Border/Background dialog (Figure 13) where you can define the 
appearance of borders, background colors, or background patterns for headers or footers. 
See Chapter 4 Using Styles and Templates in Calc for more information.

• Edit – opens the Header or Footer dialog (Figure 14) where you can add text, edit text, or 
change the appearance of the text that is placed in the header or footer. See “Header or 
footer contents” below for more information.
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Figure 13: Border/Background dialog for headers or footers

Figure 14: Header dialog

Header or footer contents
The headers or footers in a Calc spreadsheet has three columns for text. Each column can either 
be empty or have different contents from the other columns.

1) Select the sheet where you want to turn on the header or footer.

2) Open the Page Style dialog (Figure 12), then select Header on or Footer on and the 
options for the header or footer. See “Setting headers and footers” above for more 
information.

3) Click Edit to open the Header or Footer dialog (Figure 14). If Same content left/right is 
deselected in the Page Style dialog, the Header or Footer dialog will have tabbed pages 
where you can set the header or footer contents for right and left pages.
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4) To enter standard contents into the header or footer, select an option from the Header or 
Footer drop-down list.

5) To enter customized contents into the header or footer, click in one the area boxes and type
your text, or click in one of the area boxes and click one of the Custom header or Custom 
footer icons. These icons are explained below.

6) To change the appearance of the text in the header or footer, click the Text Attributes icon

 to open the Text Attributes dialog.where you can set the font, font effects and font 
position.

7) Click OK to save the changes to text attributes and close the Text Attributes dialog.

8) Click OK to save the changes to the contents of the header or footer and close the Header 
or Footer dialog.

9) Click OK to save the changes to your header or footer and close the Page Style dialog.

The icons available for a Custom header or Custom footer are as follows:

• Text Attributes  – opens a Text Attributes dialog where you can assign formats to new 
or selected text. The Text Attributes dialog contains tabbed pages for Font, Font Effects and
Font Position.

• Title  – inserts a file name placeholder in the selected area. Click to insert the title. 
Click and hold to select either Title, File Name or Path/File Name from the context menu 
that opens. If a title has not be assigned to the spreadsheet, the file name for the 
spreadsheet will be inserted instead.

• Sheet Name  – inserts a placeholder in the selected area for the sheet name of the 
selected sheet in the spreadsheet.

• Page  – inserts a placeholder in the selected area for the page number. This allows 
continuous page numbering in a spreadsheet.

• Pages  – inserts a placeholder in the selected area for the total number of pages in the 
spreadsheet.

• Date  – inserts a placeholder in the selected area for the current date which will be 
repeated in the header/footer on each page of the spreadsheet.

• Time  – inserts a placeholder in the selected area for the current time which will be 
repeated in the header/footer on each page of the spreadsheet.

Exporting to PDF

LibreOffice can export documents to PDF (Portable Document Format). This industry-standard file 
format is ideal for sending a file for someone else to view using Adobe Reader or other PDF 
viewers. The process and dialogs are the same for Writer, Calc, Impress, and Draw, with a few 
minor differences mentioned in this section.

Directly as PDF

Click on the Export Directly as PDF icon  on the Standard toolbar to export the entire 
spreadsheet using your default PDF settings. You are asked to enter the file name and location for 
the PDF file, but you cannot choose page range, image compression, or other options.
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Figure 15: PDF Options dialog – General page

Controlling PDF content and quality
For more control over the content and quality of the resulting PDF:

1) Go to File > Export as PDF on the main menu bar to open the PDF Options dialog (Figure 
15). The options on the pages of this dialog are described below.

2) When you have selected the appropriate settings for exporting to PDF, click Export.

3) In the dialog that opens, enter the location and file name of the PDF to be created.

4) Click Save to export the file. See the Getting Started guide for more information.

General page
Sets the general options when exporting a file in PDF format (Figure 15).

• Range – sets the export options for the pages included in the PDF file.

– All – exports all defined print ranges. If no print range is defined, exports the entire 
document.

– Pages – exports the numbered pages you have typed in the box. To export a range of 
pages, use the format 3-6. To export single pages, use the format 7;9;11. You can also 
export a combination of page ranges and single pages, by using a format like 
3-6;8;10;12.

– Selection – exports the current selection.

• Images – sets the export options for images inserted into your spreadsheet. EPS images 
with embedded previews are exported only as previews. EPS images without embedded 
previews are exported as empty placeholders.

– Lossless compression – selects a lossless compression of images. All pixels are 
preserved.

– JPEG compression – selects a JPEG compression of images. With a high quality level, 
almost all pixels are preserved. With a low quality level, some pixels are lost and 
artifacts are introduced, but file sizes are reduced.
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– Quality – enter the quality level for JPEG compression.

– Reduce image resolution – select to resample or downsize the images to a lower 
number of pixels per inch. Select the target resolution for the images in the box.

• Watermark – adds a watermark to the pages of the PDF file.

– Sign with Watermark – when selected, a transparent overlay of the text you enter into 
the Watermark Text box will appear on each page of the PDF file.

• General – sets general PDF export options.

– Embed OpenDocument file – this setting enables you to export the document as a PDF 
file containing two file formats: PDF and ODF. In PDF viewers it behaves like a normal 
PDF file, but it remains fully editable in LibreOffice.

– PDF/A-1a – converts to the PDF/A-1a format. This is defined as an electronic document
file format for long term preservation. All fonts that were used in the source document 
will be embedded into the generated PDF file. PDF tags will be written.

– Tagged PDF – select to write PDF tags. This can increase file size by huge amounts. 
Tagged PDF contains information about the structure of the document contents. This 
can help to display the document on devices with different screens and when using 
screen reader software.

– Create PDF form – select to create a PDF form. This can be filled out and printed by the
user of the PDF document.

– Submit format – select the format of submitting forms from within the PDF file. Select 
the format of the data that you will receive from the submitter: FDF (Forms Data 
Format), PDF, HTML, or XML. This setting overrides the control of the URL property 
that you set in the document.

– Allow duplicate field names – allows you to use the same field name for multiple fields 
in the generated PDF file. If disabled, field names will be exported using generated 
unique names.

– Export bookmarks – select to export bookmarks of Writer documents as PDF 
bookmarks. Bookmarks are created for all outline paragraphs (Tools > Outline 
Numbering) and for all table of contents entries for which you assigned hyperlinks in 
the source document.

– Export comments – select to export comments of Writer and Calc documents as PDF 
notes.

– Export automatically inserted blank pages – if selected, automatically inserts blank 
pages into the PDF file. This is option is recommended if you are creating a PDF file to 
be printed double-sided. For example, in a book a chapter paragraph style may be set 
to always start with an odd numbered page. If the previous chapter ends on an odd 
page, LibreOffice inserts an even numbered blank page. This option controls whether to
export that blank page or not.

– Embed standard fonts – normally the 14 standard Postscript fonts are not embedded in 
a PDF file because every PDF reader software already contains these fonts. Enable 
this option to embed the standard fonts that are installed on your system and that are 
used in the document. Use this option if you expect to have a better looking or more 
useful standard font than the font that is available on a computer the user uses to read 
the PDF file.

– View PDF after Export – opens the PDF file in your default PDF reader after the file has
been exported.
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Initial View page
On the Initial View page (Figure 16), you can select how the PDF file opens by default in a PDF 
viewer. The options are as follows.

Figure 16: PDF Options dialog – Initial View page

• Panes

– Page only – the PDF file shows only the page contents.

– Bookmarks and page – the PDF file shows a bookmarks list and the page contents.

– Thumbnails and page – the PDF file shows a thumbnails list and the page contents.

– Open on page – the PDF file opens at the specified page.

• Magnification

– Default – the PDF file shows the page contents without zooming. If the reader software 
is configured to use a zoom factor by default, the page shows with that zoom factor.

– Fit in window – the PDF file shows the page zoomed to fit entirely into the reader 
window.

– Fit width – the PDF file shows the page zoomed to fit the width of the reader window.

– Fit visible – the PDF file shows the text and graphics on the page zoomed to fit the 
width of the reader window.

– Zoom factor – specifies the zoom factor to apply when the reader opens the PDF file.

• Page layout

– Default – the PDF file shows the pages according to the layout setting of the reader 
software.

– Single page – the PDF file shows one page at a time.

– Continuous – the PDF file shows pages in a continuous vertical column.

– Continuous facing – the PDF file shows pages side by side in a continuous column. For
more than two pages, the first page is displayed on the right.

– First page is left – the PDF file shows pages side by side in a continuous column. For 
more than two pages, the first page is displayed on the left. You must enable support 
for complex text layout on Language settings – Languages in the Options dialog.
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User Interface page
On the User Interface page (Figure 17), you can select options to control how a PDF viewer 
displays the file. Some of these options are useful when you are creating a PDF to be used as a 
presentation or a kiosk-type display.

Figure 17: PDF Options dialog –  User Interface page

• Window options

– Resize window to initial page – the PDF file is shown in a window displaying the whole 
initial page.

– Center window on screen – the PDF file is shown in a reader window centered on 
screen.

– Open in full screen mode – the PDF file is shown in a full screen reader window in front 
of all other windows.

– Display document title – the PDF file is shown with the document title in the reader title 
bar.

• Transitions – not used in Calc

• User interface options

– Hide menu bar – hides the reader menu bar when the document is active.

– Hide toolbar – hides the reader toolbar when the document is active.

– Hide window controls – hides the reader controls when the document is active.

• Bookmarks

– All bookmark levels – shows all bookmark levels when the reader opens the PDF file.

– Visible bookmark levels – shows bookmark levels down to the selected level when the 
reader opens the PDF file.

Links page
On the Links page (Figure 18) you can select how bookmarks and hyperlinks are exported when 
you export your spreadsheet as a PDF file.

• Export bookmarks as named destinations – the bookmarks (targets of references) in 
PDF files can be defined as rectangular areas. Additionally, bookmarks to named objects 
can be defined by their names. Select this option to export the names of objects in your 
spreadsheet as valid bookmark targets. This allows links to those objects by name from 
other documents.

• Convert document references to PDF targets – select this option to convert the URLs 
referencing other ODF files to PDF files with the same name. In the referencing URLs the 
extensions .odt, .odp, .ods, .odg, and .odm are converted to the extension .pdf.
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Figure 18: PDF Options dialog –  Links page

• Export URLs relative to file system – select this option to export URLs to other 
documents as relative URLs in the file system. See Relative hyperlinks in the Calc Help for 
more information.

• Cross-document links – specify how to handle hyperlinks from your PDF file to other files.

– Default mode – links from your PDF document to other documents will be handled as is
specified in your operating system.

– Open with PDF reader application – cross-document links are opened with a PDF 
reader application that currently shows the document. The PDF reader application must
be able to handle the specified file type inside the hyperlink.

– Open with Internet browser – cross-document links are opened with an Internet 
browser. The Internet browser must be able to handle the specified file type inside the 
hyperlink.

Security page
Use the Security page (Figure 19) to encrypt and set passwords when you export your 
spreadsheet and create the PDF file. Setting encryption and passwords also allows you to apply 
restrictions on printing and if changes or copying can be carried out on the PDF file.

The options on the Security page become available only when passwords have been set.

Note
The security settings are effective only if the user is using a PDF viewer that 
respects security settings.

Figure 19: PDF Options dialog –  Security page
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• Set passwords – click to open the Set Passwords dialog (Figure 20) where you enter the 
passwords. You can enter a password (Set open password) to open the file and an 
optional password (Set permission password) that allows you to restrict what readers can
do with the PDF file.

Figure 20: Set passwords dialog

• Printing

– Not permitted – printing the document is not permitted.

– Low resolution (150 dpi) – the PDF file can be printed only in low resolution (150 dpi). 
Not all PDF readers honor this setting.

– High resolution – the PDF file can be printed in high resolution.

• Changes

– Not permitted – no changes of the content are permitted.

– Inserting, deleting, and rotating pages – only inserting, deleting, and rotating of pages is
permitted.

– Filling in form fields – only filling in of form fields is permitted.

– Commenting, filling in form fields – only commenting and filling in of form fields is 
permitted.

– Any except extracting pages – all changes are permitted, except for extracting pages.

• Enable copying of content – select to enable copying of content to the clipboard.

• Enable text access for accessibility tools – select to enable text access for accessibility 
tools.

Note
Permissions settings are effective only if the user’s PDF viewer respects the 
settings.

Exporting to other formats

LibreOffice uses the term “export” for some file operations involving a change of file type. If you 
want to use another spreadsheet file format, use File > Save As. If you want to create web pages 
from your spreadsheet, use File > Export.
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Other formats
To export a spreadsheet file or a selected section of a spreadsheet in another format:

1) Go to File > Save As on the main menu bar, or use the keyboard shortcut Ctrl+Shift+S to 
open the Save As dialog.

2) Select the location where to save the file.

3) Specify a file name for the exported document in the File name text box.

4) Select the required spreadsheet format from the File format drop-down list.

5) Click Save to save the spreadsheet in the selected format and close the dialog.

Web pages
To export a Calc spreadsheet or a section of a spreadsheet to a series of web pages:

1) Go to File > Export on the main menu bar to open the Export dialog.

2) Select the location where to export the file.

3) Specify a file name for the exported document in the File name text box.

4) Select XHTML (.html; .xhtml) as the file type from the File format drop-down list.

5) Click Export to export the spreadsheet in the selected format and close the dialog.

E-mailing spreadsheets

LibreOffice provides several ways to send documents quickly and easily as an e-mail attachment in
OpenDocument format (LibreOffice default format), other spreadsheet formats, or as a PDF file. 
You can also email a document to several recipients. For more information, see the Getting Started 
guide.

To send the spreadsheet as an email:

1) Go to File > Send on the main menu bar and select from the following options. LibreOffice 
opens your default e-mail program with the spreadsheet attached in the selected format.

– Document as E-mail – the spreadsheet is sent in the default ODF format.

– E-mail as OpenDocument Spreadsheet – the spreadsheet is sent in the ODF format.

– E-mail as Microsoft Excel – the spreadsheet is sent in the Excel format.

– E-mail as PDF – LibreOffice opens the PDF Options dialog where you can select the 
parameters to be used for the PDF file. See “Controlling PDF content and quality” on 
page 19 for more information. Click Send when you have set the PDF parameters.

2) In your e-mail program, enter the recipient, subject, and any text you want to add, then 
send the e-mail.

Digital signing of documents

Digital signatures
To sign a document digitally, you need a personal key, also known as a certificate. A personal key 
is stored on your computer as a combination of a private key, which must be kept secret, and a 
public key, which you add to your documents when you sign them. You can get a certificate from a 
certification authority, which may be a private company or a governmental institution.
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When you apply a digital signature to a document, a checksum is computed from the document 
content plus your personal key. The checksum and your public key are stored together with the 
document.

When someone later opens a signed document on any computer with a recent version of 
LibreOffice, the program will compute the checksum again and compare it with the stored 
checksum. If both are the same, the program will signal that you see the original, unchanged 
document. In addition, the program can show you the public key information from the certificate. 
You can compare this key with the public key that is published on the web site of the certificate 
authority.

Whenever someone changes something in the document, the change breaks the digital signature.

On Windows operating systems, the Windows features for validating a signature are used. On 
Linux systems, files that are supplied by Mozilla Thunderbird or Firefox are used to validate the 
signature. For a more detailed description of how to get and manage a certificate, and signature 
validation, see Digital Signatures in the LibreOffice Help.

Applying digital signatures

Note
If you are using a Linux operating system, you must install a recent version of 
Thunderbird, Mozilla Suite, or Firefox software to install some system files that are 
needed for encryption.

Digitally signing
The following procedure is only an example of how to digitally sign a document. The actual 
procedure depends on how your computer is set up and the computer operating system.

1) Open the file that you want to digitally sign.

2) Go to File > Digital Signatures on the main menu bar or right-click on the Digital 
Signature icon in the Status Bar and select Digital Signatures.

Note
If the document has not been signed, the Digital Signature icon does not appear in
the Status Bar and the icon area is blank.

3) If the document contains comments, a warning dialog opens asking if you wish to continue.
Click Yes to continue, or click No to exit and take appropriate action to remove the 
comments and restart this procedure.

4) If you have not saved the document since the last change, a message box appears. Click 
Yes to save the file. If you click No, the procedure exits. When you have saved the file, the 
Digital Signatures dialog opens (Figure 21).

5) Click Sign Document to open the Select Certificate dialog (Figure 22).

6) Select the certificate you want to use and click OK to close the Select Certificate dialog.

7) Click Close to close the Digital Signatures dialog and digitally sign your file. The Digital 

Signature icon  appears in the Status Bar at the bottom of the workspace.

Note
If you make any changes to the document after digitally signing, the digital signature
is removed automatically and you have to repeat the above procedure to digitally 
sign it again.
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Figure 21: Digital Signatures dialog

Figure 22: Select Certificate dialog

Removing digital signatures
The following procedure is only an example of how to remove a digital signature. The actual 
procedure depends on how your computer is setup and the computer operating system.

1) Open the file from which you want to remove the digital signature.

2) Go to File > Digital Signatures on the main menu bar or right-click on the Digital 
Signature icon in the Status Bar and select Digital Signatures to open the Digital 
Signatures dialog (Figure 21).

3) Select the certificate you want to remove, then click Remove.

4) Click Close to the Digital Signatures dialog. The file is no longer digitally signed and the 
Digital Signature icon is removed from the Status Bar at the bottom of the workspace.
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Digitally signing macros
Normally, macros are part of a document. If you sign a document, the macros inside the document 
are signed automatically. If you want to only sign the macros, but not the document, proceed as 
follows:

1) Go to Tools > Macros > Digital Signature on the main menu bar.

2) Apply the signature as described in “Digitally signing” above.

Removing personal data

You may wish to ensure that personal data, versions, notes, hidden information, or recorded 
changes are removed from files before you send them to other people or create PDFs from them.

• In Tools > Options > LibreOffice > Security > Options, you can set Calc to remind you 
when files contain certain information and remove personal information automatically on 
saving.

• To remove personal and some other data from a file, go to File > Properties. On the 
General page, deselect Apply user data and then click Reset. This removes any names in
the created and modified fields, deletes the modification and printing dates, and resets the 
editing time to zero, the creation date to the current date and time, and the version number 
to 1.

• To remove version information, either go to File > Versions on the main menu bar, select 
the versions from the list and click Delete, or use Save As and save the file with a different 
name.
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