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Introduction

This chapter covers methods for editing shared documents: sharing (collaboration), recording
changes, adding comments, reviewing changes, merging and comparing documents, and saving
and using document versions. Basic editing techniques are discussed in Chapter 2, Entering,
Editing, and Formatting Data.

Sharing documents (collaboration)

In LibreOffice Writer, Impress, and Draw, only one user at a time can open any document for
editing. In Calc, many users can open the same spreadsheet for writing at the same time.

Each user who wants to collaborate should be sure to enter a name on the Tools > Options >
LibreOffice > User Data page.

Some menu commands are not available (grayed out) when change tracking or document sharing
is activated.

Setting up a spreadsheet for sharing

At any time, you can set up a spreadsheet for sharing with others. With the spreadsheet document
open, choose Tools > Share Document to activate the collaboration features for this document. A
dialog opens where you can enable or disable sharing.

L= Ty

Share Document

Share thiz spreadsheet with other users!

Mote: Changes to Formatting attributes like fonks, colors, and number
Formats will not be sawved and some Functionalities like editing charts and
drawing objects are not available in shared mode, Turn off shared mode
ko get exclusive access needed For those changes and functionalities,

Users currenthy accessing this spreadshest

Mame |.ﬁ.ccessed
Jean Weber (exclusive access) 03072008 11:21

Help Ik ] [ Cancel

Figure 1: Choosing to share a spreadsheet

To enable sharing, check the box at the top of the dialog, and then click OK. If the spreadsheet has
been saved previously, a message appears stating that you must save it to activate shared mode;
click Yes to continue. If the spreadsheet has not been saved previously, the Save dialog appears.
After saving, the word (shared) is shown on the title bar after the document's title.

The Tools > Share Document command can be used to switch the mode for a document from
unshared to shared. However, if you want to use a shared document in unshared mode, you need
to save the shared document using another name or path. This creates a copy of the spreadsheet
that is not shared.
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Opening a shared spreadsheet

When you open a spreadsheet document that is in shared mode, a message appears stating that
the document is in shared mode and that some features are not available in this mode. After
clicking OK, the document is opened in shared mode. You can select the option to not show the
warning again.

The following features are disabled in a shared spreadsheet document:

Edit > Changes, except for Merge Document
Edit > Compare Document
Edit > Sheet > Move/Copy & Delete

Insert > Cells > Shift Cells Down & Shift Cells Right
Insert > Sheet from file

Insert > Names

Insert > Comment

Insert > Picture > From File

Insert > Movie and Sound

Insert > Object

Insert > Chart

Insert > Floating Frame

Format > Sheet > Rename, Tab Color
Format > Merge Cells > Merge and Center, Merge Cells, Split Cells
Format > Print Ranges

Tools > Protect Document

Data > Define Range

Data > Sort

Data > Subtotals

Data > Validity

Data > Multiple Operations
Data > Consolidate

Data > Group and Outline (all)
Data > Pivot Table

Saving a shared spreadsheet

When you save a shared spreadsheet, one of several situations may occur:

* |If the document was not modified and saved by another user since you opened it, the
document is saved.

* If the document was modified and saved by another user since you opened it, one of the
following events will occur:

—  If the changes do not conflict, the document is saved, the message below appears,
and any cells modified by the other user are shown with a red border.

6 Your spreadsheet has been updated with changes saved by other |

LUSers.

Figure 2: Update message after saving

- If the changes conflict, the Resolve Conflicts dialog is shown. You must decide for
each conflict which version to keep, yours or the other person’s. When all conflicts are
resolved, the document is saved. While you are resolving the conflicts, no other user
can save the shared document.
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Resolve Conflicts

There are conflicting changes in this shared spreadsheet. Conflicts must be resolved before saving the spreadsheet. Keep
either own or other changes.

Sheetl

Cell A4 changed from 'sort of testing' to 'some test’ Martin Fox 05/05/2010 08:11
Cell A4 changed from 'sort of testing’ to 'some sort of test’ Martin Fox 05/05/2010 08:12

Keep Mine Keep Other |

| Keep All Mine | | Keep All Others | | Cancel | | Help

Figure 3: Resolve Conflicts dialog

« If another user is trying to save the shared document and resolve conflicts, you see a
message that the shared spreadsheet file is locked due to a merge-in in progress. You can
choose to cancel the Save command for now, or retry saving later.

When you successfully save a shared spreadsheet, the document shows the latest version of all
changes saved by all users.

Recording changes

You can use several methods to record changes that you or others make to a document:

* You can use change marks to show added material, deleted material, and changes to
formatting. Later, you or another person can review the document and accept or reject
each change. Not available in shared files.

* If you are not using file sharing, you can make changes to a copy of the document (stored
in a different folder, under a different name, or both), then use Calc to compare the files and
show the changes. See page 13.

* You can save versions that are stored as part of the original file. See page 14.

Reviewers can leave comments in the document, either attached to specific changes or
standalone.

Preparing a document for review (optional)

This feature is not available in shared documents. When you send a document to someone else to
review or edit, you may want to set it up so that the editor or reviewer does not have to remember
to turn on the revision marks.

After you have turned on revision marks, you can optionally password protect the document so that
any user must enter the correct password in order to turn off protection and accept or reject
changes. It is not necessary to password protect the document while preparing it for review.

1) Open the document and make sure that the Edit > Changes > Record menu item has a
check mark next to it, indicating that change recording is active. You can also use File >
Properties > Security and select Record changes.
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2) (Optional) Click Edit > Changes > Protect Records. On the Enter Password dialog, type a
password (twice) and click OK. You can also use File > Properties > Security and click
the Protect button to open the Enter Password dialog.

Identifying copies of spreadsheets

When not using the document sharing feature, it is important to keep track of the different copies of
the document. This can be done either in the file name or in the file title. If you have not provided a
file title in the spreadsheet’s properties, the spreadsheet’s file name is displayed in the title bar. To
set the title of the spreadsheet, select File > Properties > Description.

Recording changes (tutorial)

For this chapter we will work with a budget proposal for a baseball team.

You are the sponsor of a youth baseball team. The coach has submitted a budget to
you for the season and you need to edit the costs and return it to her.

You are concerned that if you just make the changes, then the coach will not see the
changes you made. You decide to use Calc with the record changes feature turned on,
so that the coach can easily see the change you have made.

Figure 4 shows the budget spreadsheet your coach submitted.

@) | Default x| |ariat Ello Zl BrUis=== b % 3% %o o | es
[is o o3 = |
A | &8 | c | o | E |

1 Baseball Budget Proposal

2 [ltern Description Cluantity Cost Total Comrnents

5 |Unifarms 25 $50.00  $1,250.00 Meed to update the team look

4 |Baseballs 250 $4.00 %1,000.00%e need to 10 per game

5 |Umpire fees 25 $50.00  $1,250.001 Umpire per game

& |Bats 5 $35.00 $175.00We need bats of various sizes

7 |Snacks 25 $15.00 $375.00This is the max cost per game for after game snacks

& |Batting helmets 5 $40.00 $200.00We need a minimum of 5

9 |Catching Gear 1 $300.00 $300.00 Meed ta protect the catcher, ald gear ugly

10 |Spare Gloves 4 545.00 $180.00 Just in case someone forgets their glove

11 54.730.00 Total

12

Figure 4: Baseball budget spreadsheet

Looking over the figures, you see a few places where money could be saved:
* Post-game snhacks can be bought by parents.
* New uniforms can wait; only buy 10 to replace damaged ones.
* Buy cheaper baseballs.
* Only buy 2 spare gloves.
To make these changes, use the record changes feature in Calc. To start recording changes:
1) Open the Budget Spreadsheet.
2) Select Edit > Changes > Record from the menu bar.
3) Begin editing the document.
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A colored border, with a dot in the upper left-hand corner, appears around a cell where changes
were made (Figure 5). Other reviewers then quickly know which cells were edited. A deleted
column or row is marked by a heavy colored bar.

5 |Defautt = Jaria e =l B7 U
[B11 x| X = |

. i c [ o ] :
Baseball Budget Proposal

A% 3% T X | &

Spare Gloves 2 $45.00 $90.00 Just in case someone forgets their glave
$3.015.00 Total

1
2 |ltem Description Cluantit Cost Total Comments
3 |Uniforms 10 $50.00 F500.00 Meed to update the team look
4 |Baseballs 250 $2.00]  $500.00%e need to 10 per game
5 |Umpire fees 25 $50.00  %1,250.001 Umpire per game
6 |Bats 5 $35.00 $175.00 We need bats of various sizes
7 _|Shacks E $15.00 $0.00 This is the max cost per game for after game snacks
8 |Batting helmets a $40.00 $200.00Wve need a minimurn of 5
9 |Catching Gear 1 $300.00 $300.00 Meed to protect the catcher, old gear ugly
10
[ 12 |

=
Figure 5: Edited document with red border on changed cells

Note Some changes, for example cell formatting, are not recorded and marked.

To change the color that indicates changes, select Tools > Options > LibreOffice

Tip Calc > Changes.

When you finish editing the document, you can send it to your coach.

You may want to explain your rationale for the changes. You can share your insight in two ways: by
adding comments to the changes you made, or by adding general comments to the spreadsheet.

Adding comments to changes

Calc automatically adds to any recorded change a comment that describes what was changed (for
example, Cell B4 changed from ‘9’ to ‘4’). Reviewers and authors can add their own comments to
explain their reasons for the changes.
To add a comment to a change:

1) Make the change to the spreadsheet.

2) Select the cell with the change.

3) Choose Edit > Changes > Comments. The dialog shown in Figure 6 appears.

e 00 Insert Comment
Contents —_—
OK
Author Jean Weber, 23/09/2013 10:05 __
Text | Cancel |

We can only afford 10 uniforms
| Help |

Figure 6: Insert Comment dialog
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4) Type your comment and click OK. The automatically-added comment provided by Calc
cannot be edited.

After you have added a comment to a changed cell, you can see it by hovering the mouse pointer
over the cell, as shown in Figure 7.

B3 = fo X = |0
A —— ¢ [ o ]

1 | Jean Weber, 23/09/2013 10:05:15: 0.
We can only afford 10 uniforms

& Item Description Cluantit 09 ( Cell B3 changed from '25' to '10') ts
nUmﬁ:urms -, 10 Al8
4 |Baseballs "& 280 $2.00|  $500.00 We need to
5 |Umpire fees 25 F50.000 $1.250.001 Umpire pe
= Bt~ L= T2E mn CATE MO A mmad e

Figure 7: Comment added to cell B3

The comment also appears in the dialog when you are accepting and rejecting changes, as shown
in the first line of Figure 12 on page 12.

Editing change comments

1) Select the cell with the change comment that you want to edit.
2) Select Edit > Changes > Comments.
3) Edit the comment and click OK.

Adding other comments

Calc provides another type of comments (formerly called “notes”), which authors and reviewers
often use to exchange ideas, ask for suggestions, or brainstorm in the document.

To add a comment:
1) Select the cell that the comment applies to.

2) Select Insert > Comment or right-click and select Insert Comment. (The latter method
does not work if the automatic spelling checker is active and the cell contains a misspelled
word.) The box shown in Figure 8 appears.

Comments

Meed to update the team look

YWe need to 10 per game

1 Umnpire per game

We need bats of various sizes

This is the max cost per game for after garme snacks
e need a minimurm of &

Meed to protect the catcher, old gear ugly

Figure 8: Inserting a comment

3) Type the text of your comment in the box, then click outside the box to close it.

Now the cell to which you added the comment has a colored dot in the upper right-hand corner, as
shown in Figure 9. It does not have a colored border, unless the cell was also changed.
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e need bats of various sizes
This I1s the max cost per game for after game Snackslzl
YWe need a minimum of 5

[ | 1 1 1 1 1

Figure 9: Colored dot in cell containing a comment

Ti You can change the colors Calc uses for notes by selecting Tools > Options >
P LibreOffice > Appearance.

To view the comment you just added, hover the mouse pointer over the cell that has a comment;
the comment appears, as shown below.

WWe need to 10 per game
1 Urnpire per game Why do we need 5
Wye need bats of various sizes helmets?

This is the max cost per game for after game snacks

[v/e need a minimum of 5

Meed to protect the catcher, old gear ugly

P SN N ) [ )

Figure 10: Viewing a comment

Editing comments
You can edit and format the text of a comment, just as you do for any other text.

1) Right-click on the cell containing the comment marker and choose Show comment from
the context menu.

2) Select the comment, then double-click on it. The cursor changes to the usual blinking text-
entry cursor, and the Formatting toolbar changes to show text attributes.

3) When done, click outside the comment to deselect it. To hide the comment again, right-click
on the cell and deselect Show Comment on the context menu.

Formatting comments

You can change the background color, border style, transparency, and other attributes of a
comment.

1) Right-click on the cell containing the comment marker, and choose Show comment from
the context menu.

2) Click on the comment itself. The Formatting toolbar changes to show many of the comment
formatting options. These are the same as the options for formatting graphics; see Chapter
5, Using Graphics in Calc, for more information.
You can also right-click on the comment to see a menu of choices, some of which lead to
dialogs in which you can fine-tune the formatting; these dialogs are also discussed in
Chapter 5.

3) When done, click outside the comment to deselect it. To hide the comment again, right-click
on the cell and deselect Show Comment on the context menu.

Finding comments using the Navigator

The small comment markers in the corners of cells can be difficult to see, so Calc provides another
way to find them, by using the Navigator. If any comments are in the spreadsheet, the Navigator
shows a mark (usually a + or an arrow) next to the word Comments. Click on this mark to display a
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list of comments. Double-click on the comment you want to jump directly to the cell it is associated
with.

Reviewing changes

At this point, we are going to change our perspective from the point of view of the team sponsor to
that of the coach, so we can see how to review and accept or reject the changes to the document
the coach originally wrote.

You are the coach of a youth baseball team and you submitted a potential budget
created in Calc to your team sponsor.

Your sponsor has reviewed the document using the record changes feature of Calc.
Now, you want to review those changes and accept or reject the counter proposal.

Because the sponsor recorded changes in Calc, you can easily see what changes were
made and decide how to act.

Viewing changes

You have some control over what changes you see when reviewing a document. Select Edit >
Changes > Show from the Menu bar. The Show Changes dialog Figure 11) opens.

- Show Changes ®
|&] Show changes in spreadsheet oK
Filter settings Cancel
| Hep

[] show accepted changes

[] Show rejected changes

Figure 11: Show changes dialog

Accepting or rejecting changes

When you receive a document back with changes, the beauty of the recording changes system
becomes evident. Now, as the original author, you can step through each change and decide how
to proceed. To begin this process:

1) Open the edited document.
2) Select Edit > Changes > Accept or Reject. The dialog shown in Figure 12 appears.

3) You can step through the changes one at a time, choosing to accept or reject each change
as you go through. You can also accept or reject all changes at one time.
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Accept or Reject Changes

‘Li5t| Filter
Action Position Author Date Comment
- Changed contents Sheetl.B7 Jean Weber 23/09/2013 10:1 Another comment
<emply> Sheetl.B7 Jean Weber 23/09/2013 10:1 (Original: <empty>)
'z Sheetl.B7 Jean Weber 23/09/2013 10:1 (Changed to '12')
0’ Sheetl.B7 Jean Weber 23/09/2013 10:1 Another comment (Changed t
+ Changed contents Sheetl1.B10 Jean Weber 23/09/2013 10:1
-I Accepted
Changed conte Sheetl.B3 Jean Weber 23/09/2013 10:0 We can only afford 10 uniform|
Changed conte Sheetl.G7 24/09/2013 12:4 (Cell G7 changed from 'We ng
-I Rejected
Changed conte Sheetl.G7 Jean Weber 23/09/2013 10:1 (Cell G7 changed from 'G7" tg
i J >
h Accept I [ Reject I l Accept All I l Reject All I I Close

Figure 12: Accept or Reject changes dialog

The Comment column by default contains an explanation of the change that was made. If the

reviewer added a comment to the change, it is displayed, followed by the description of the
change, as in the first line of Figure 12.

If a change has been superceded by later change (by either the same person or another person),
the changes are hierarchically arranged with a plus sign for opening up the hierarchy.

Below the list of changes to be accepted or rejected are shown any changes that have previously

been dealt with.

On the Filter tab of this dialog (Figure 13), you can choose how to filter the list of changes: by date,
author, cell range, or comments containing specific terms. After selecting the filter criteria, switch
back to the List tab to see the results.

-

- Accept or Reject Changes »
List |Filter|
[E Date |since . [22;09;2913 | [11:10 | o)
and | H | H L
[5] Author Jean Weber =
[] Range I |
[] Comment
Accept Reject | Accept All I Reject All | Close

Figure 13: Filters set here affect the list of changes shown on the List tab

Reviewing changes
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Merging documents

You submitted your budget proposal to your sponsor, but you sent it to one of
your assistant coaches as well. Both of them returned their revised budget to
you at the same time.

You could review each document and the changes separately, but to save time,
you want to see both of their revisions simultaneously.

To do this, you can use Calc’s merge document feature.

The processes discussed to this point are effective when you have one reviewer at a time.
Sometimes, however, multiple reviewers all return edited versions of a document at the same time.
In this case, it may be quicker to review all of these changes at once, rather than one review at a
time. For this purpose, you can merge documents in Calc.

To merge documents, all of the edited documents need to have recorded changes in them.
1) Open the original document.
2) Select Edit > Changes > Merge Document.
3) Afile selection dialog opens. Select a file you want to merge and click OK.

4) After the documents merge, the Accept or Reject Changes dialog opens, showing changes
by more than one reviewer. If you want to merge more documents, close the dialog and
then repeat steps 2 and 3.

Now all of the changes are combined into one document and you can accept or reject the changes.
Changes from different authors appear in cells outlined in different colors, as shown in Figure 14.
In this example, all of the changes from Robert are outlined in blue and the changes from Mia are
outlined in red.

Baseball Budget Proposal
ltern Description Cluantity Cost Total Comments
Uniforms 10 $50.00  $500.00 Meed to update the team look
Basehalls 275 §2.00]  $550.00 We need to 10 per garne
mpire fees 25 $50.00  §1,250.001 Umpire per game
Bats 5 $35.00  $175.00We need bats of various sizes
=nacks El $15.00 $0.00 Thig is the max cost per game for after game snacks
Batting helmets 5 F40.00 $200.00 Ve need a minimum of 5 |
Catching Gear 1 §175.00]  $175.00 Meed to protect the catcher, old gear ugly
Spare Gloves 2 $45.00 $90.00Just in caze sameone forgets their glove

$2.940.00 Total

Figure 14: Merged documents with different author colors

Comparing documents

Sometimes when sharing documents, reviewers may forget to record the changes they make. This
is not a problem with Calc, because Calc can find the changes by comparing documents.

In order to compare documents you need to have the original document and the one that is edited.
To compare them:

1) Open the edited document that you want to compare with the original document.

2) Select Edit > Compare Document.

Comparing documents 13



3) An open document dialog appears. Select the original document and click Insert.
Calc finds and marks the changes as follows:
» All data that occurs in the edited document but not in the original is identified as inserted.

* All data that is in your original document but is not in the edited document is identified as
deleted.

* All data that is changed, is marked as changed.

From this point you can go through and accept or reject changes as you could normally.

Saving versions

Most documents go through many drafts. It is often useful to save new versions of a document.
You can do this by saving a copy of the document (under a different name) after each revision, or
by using Calc’s version feature.

Caution . . o
f If you do a Save As... of a document with different versions stored in it, the old

versions are not saved in the new file.

To use version management in Calc:

1) Choose File > Versions. The Versions dialog opens.

¥ersions of Budget x|
MWew versions
Close
Sawe Mew Wersion [ Always save a version on closing

L. . Qpen
Existifig versions

Date and time Saved by Comments Show,..

Delete

Compare
Help

Figure 15: Version management dialog

2) Click the Save New Version button to save a new version.
3) Adialog opens where you can enter comments about this version.
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Insert ¥ersion Comment 5'

Date and tirme : 0570372009, 16:51:19

Saved by Robert Brown

Fevision accepted from Sponsor and Assistant Cu:uau:}“l

o] 4 Cancel Help

Figure 16: Version comment dialog
4) After you enter your comment and click OK, the new version is included in the version list.

¥ersions of Budget

Mew versions

Existing wversions

|

Clase

I |_ Always save awversion on closing

Open

|

Date and tirme Saved by Comments Show...

0570372009, 16:43:50 RobertBrown Criginal

0570372009, 16:52:26 RobertBrown Revision accepted from Sponsor and Assistant Co

Delete

carmpare

il

Help

Figure 17: Updated version list

Now when you save the file, both versions are saved in the same file. From this point you can:

* Open an old version — Select the version and click the Open button and a read-only copy
of a previous version opens.

* Compare all versions — Clicking the Compare button performs an action similar to merging
documents together. An Accept or Reject Changes dialog opens showing all of the changes
through the different versions.

* Review the comments — Select a version and click the Show button to display the full
comments made by yourself or other reviewers.

Note The new file is larger, as if two spreadsheets were saved together.

Saving versions 15
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