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What is Calc?

Calc is the spreadsheet component of LibreOffice. You can enter data (usually numerical) in a
spreadsheet and then manipulate this data to produce certain results.

Alternatively, you can enter data and then use Calc in a “What if...” manner by changing some of
the data and observing the results without having to retype the entire spreadsheet or sheet.

Other features provided by Calc include:
* Functions, which can be used to create formulas to perform complex calculations on data.
» Database functions, to arrange, store, and filter data.
* Dynamic charts; a wide range of 2D and 3D charts.

* Macros, for recording and executing repetitive tasks; scripting languages supported include
LibreOffice Basic, Python, BeanShell, and JavaScript.

* Ability to open, edit, and save Microsoft Excel spreadsheets.

* Import and export of spreadsheets in multiple formats, including HTML, CSV, PDF, and
PostScript.

6 Note

If you want to use macros written in Microsoft Excel using the VBA macro code in
LibreOffice, you must first edit the code in the LibreOffice Basic IDE editor. See
Chapter 13 Getting Started with Macros and Calc Guide Chapter 12 Calc Macros.

Spreadsheets, sheets and cells

Calc works with elements called spreadsheets. Spreadsheets consist of a number of individual
sheets, each sheet containing cells arranged in rows and columns. A particular cell is identified by
its row number and column letter.

Cells hold the individual elements — text, numbers, formulas, and so on — that make up the data to
display and manipulate.

Each spreadsheet can have several sheets, and each sheet can have several individual cells. In
Calc, each sheet can have a maximum of 1,048,576 rows (65,536 rows in Calc 3.2 and earlier) and
a maximum of 1024 columns.

Calc main window

When Calc is started, the main window opens (Figure 1). The parts of this window are described
below.

Title bar

The Title bar, located at the top, shows the name of the current spreadsheet. When the
spreadsheet is newly created, its name is Untitled X, where X is a number. When you save a
spreadsheet for the first time, you are prompted to enter a name of your choice.

6 | Chapter 5 Getting started with Calc



Menu bar

The Menu bar is where you select one of the menus and various sub-menus appear giving you
more options. You can also customize the Menu bar; see Chapter 14 Customizing LibreOffice for
more information.

Title bar Menu bar  Standard toclbar Formatting toolbar

rd

@ - o Untitled 1- LibreOFfice Calc

File Edit View Insert Format Tools Data Jafindow Help
E-BH= BER v& X% & @i by 2HE O

{8/ | Liberation Sans * (10 v BJ U === -’t :EII-_I'-;'jJﬁ BX M = 0 »
Al | RE =

e
L | [

a Active cell Active cell reference Column headers — Formula bar
----- i (Mame box)

1" Sheet Age I — To— ;
zh i \ Default \ m £ Sum=0 - u + 100%

Sheet tabs Status bar
Row headers

Figure 1: Calc main dialog, without Sidebar

* File — contains commands that apply to the entire document; for example Open, Save,
Wizards, Export as PDF, Print, Digital Signatures and so on.

* Edit — contains commands for editing the document; for example Undo, Copy, Changes,
Fill, Plug-in and so on.

* View — contains commands for modifying how the Calc user interface looks; for example
Toolbars, Column & Row Headers, Full Screen, Zoom and so on.

* Insert — contains commands for inserting elements into a spreadsheet; for example Cells,
Rows, Columns, Sheets, Picture and so on.

* Format — contains commands for modifying the layout of a spreadsheet; for example Cells,
Page, Styles and Formatting, Alignment and so on.

* Tools — contains various functions to help you check and customize your spreadsheet, for
example Spelling, Share Document, Gallery, Macros and so on.

« Data — contains commands for manipulating data in your spreadsheet; for example Define
Range, Sort, Consolidate and so on.

* Window - contains commands for the display window; for example New Window, Split and
so on.

* Help — contains links to the help system included with the software and other
miscellaneous functions; for example Help, License Information, Check for Updates and so
on.

Calc main window | 7



Toolbars

The default setting when Calc opens is for the Standard and Formatting toolbars to be docked at
the top of the workspace (Figure 1).

Calc toolbars can be either docked and fixed in place, or floating, allowing you to move a toolbar
into a more convenient position on your workspace. Docked toolbars can be undocked and either
moved to different docked position on the workspace, or left as a floating toolbar. Toolbars that are
floating when opened can be docked into a fixed position on your workspace.

The default set of icons (sometimes called buttons) on toolbars provide a wide range of common
commands and functions. You can also remove or add icons to toolbars, see Chapter 14
Customizing LibreOffice for more information.

Formula bar

The Formula Bar is located at the top of the sheet in the Calc workspace. The Formula Bar is
permanently docked in this position and cannot be used as a floating toolbar. If the Formula Bar is
not visible, go to View on the Menu bar and select Formula Bar.

(A1 lv| K E = | I
Figure 2: Formula bar ' ' ' ' ' ' ' '

Going from left to right and referring to Figure 2, the Formula Bar consists of the following:

* Name Box — gives the current active cell reference using a combination of a letter and
number, for example Al. The letter indicates the column and the number indicates the row
of the selected cell.

* Function Wizard ﬁ — opens a dialog from which you can search through a list of
available functions. This can be very useful because it also shows how the functions are
formatted.

* Sum E — clicking on the Sum icon totals the humbers in the cells above the selected cell
and then places the total in the selected cell. If there are no numbers above the selected
cell, then the cells to the left are totaled.

* Function = - clicking on the Function icon inserts an equals (=) sign into the selected cell
and the Input line, allowing a formula to be entered.

* Input line — displays the contents of the selected cell (data, formula, or function) and allows
you to edit the cell contents.

* You can also edit the contents of a cell directly in the cell itself by double-clicking on the
cell. When you enter new data into a cell, the Sum and Function icons change to Cancel

and Accept icons 3 "35'}.

“ Note

In a spreadsheet the term “function” covers much more than just mathematical
functions. See the Calc Guide Chapter 7 Using Formulas and Functions for more
information.
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Spreadsheet layout

Individual cells

The main section of the workspace in Calc displays the cells in the form of a grid. Each cell is
formed by the intersection of one column and one row in the spreadsheet.

At the top of the columns and the left end of the rows are a series of header boxes containing
letters and numbers. The column headers use an alpha character starting at A and go on to the
right. The row headers use a numerical character starting at 1 and go down.

These column and row headers form the cell references that appear in the Name Box on the
Formula Bar (Figure 2). If the headers are not visible on your spreadsheet, go to View on the Menu
bar and select Column & Row Headers.

Sheet tabs

In Calc you can have more than one sheet in a spreadsheet. At the bottom of the grid of cells in a

spreadsheet are sheet tabs indicating how many sheets there are in your spreadsheet. Clicking on
a tab enables access to each individual sheet and displays that sheet. An active sheet is indicated
with a white tab (default Calc setup). You can also select multiple sheets by holding down the Ctr/

key while you click on the sheet tabs.

To change the default name for a sheet (Sheetl, Sheet2, and so on), right-click on a sheet tab and
select Rename Sheet from the context menu. A dialog opens, in which you can type a new name
for the sheet. Click OK when finished to close the dialog.

To change the color of a sheet tab, right-click on the tab and select Tab Color from the context
menu to open the Tab Color dialog (Figure 3). Select your color and click OK when finished to
close the dialog. To add new colors to this color palette, see Chapter 14 Customizing LibreOffice
for more information.

& Tab Color

iDefault |

AEEEEEEN ma]
AR EREEEC
AC0NEEEEEEEEN
AEEEEEENEEEE
AREREN | HeNN
AEEREEENEEN S
JOOSNNENEN
AR SN/ mENEn
H AN N N EE
Default

| Help | I OK | Cancel |

Figure 3: Tab color dialog

Status bar

The Calc status bar (Figure 4) provides information about the spreadsheet as well as quick and
convenient ways to change some of its features. Most of the fields are similar to those in other
components of LibreOffice; see Chapter 1 Introducing LibreOffice in this guide and the Calc Guide
Chapter 1 Introducing Calc for more information.
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Selection Digital Cell or object Zoom

mode signature information percentage
Sheet 1/1 Default m [ Sum=0 - O + | 100%
Sheet Page Insert Unsaved Zoom
number style mode changes slider

Figure 4: Calc status bar

Sidebar

The Calc Sidebar (View > Sidebar) is located on the right side of the window. It is a mixture of
toolbar and dialog and consists of five decks: Properties, Styles and Formatting, Gallery,
Navigator, and Functions. Each deck has a corresponding icon on the Tab panel to the right of the
sidebar, allowing you to switch between them.

Properties N = Configuration Menu button
= character Bl = :
S TR Title bar
Liberation Sans - 10 |+ -ﬁ
B /7 U - i & Tabs
ﬁ - M
= (=)
= Alignment @
=E = = = il .
Ed & Panel title
Left indent: Merge Cells
_ Deck
Opt Wrap text
Text grientation:
Content panel
Y | Vertically Stacked
= —=
- | . o* v
E cell Appearance o More Options button

Figure 5: Calc Sidebar with Properties open

The decks are described below.
* Properties: This deck includes four content panels.

— Character: Provides controls for formatting the text, such as font family, size, and color.

Some controls, such as superscript, only become active when the text cursor is active in
the Input line of the Formula bar or the cell.

- Alignment: Provides controls to align the text in various ways, including horizontal and
vertical alignment, wrapping, indenting, merging, text orientation, and vertical stacking.

— Cell Appearance: Provides controls to set the appearance options, including cell
background color, cell border formats including line color and style, and grid lines.
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- Number Format: Provides a way to quickly change the format of numbers including
decimals, currency, dates, or numeric text. Numerical and label field controls for Forms
are also available.

Each of these panels has a More Options button, which opens a dialog that gives a
greater number of options. These dialogs lock the document for editing until they are
closed.

» Styles and Formatting: This deck contains a single panel, which is the same as that
opened by selecting the Styles and Formatting button (F11) from the Text Formatting
toolbar.

* Gallery: This deck contain a single panel, which is the same as that opened by selecting
Gallery from the Standard toolbar or Tools > Gallery from the Menu bar.

* Navigator: This deck contains a single panel, which is essentially the same as the
Navigator window opened by clicking the Navigator button on the Standard toolbar or
selecting View > Navigator (F5) from the Menu bar. Only the Contents button is absent in
the Sidebar’s Navigator panel.

* Functions: This deck contains a single panel, which is the same as the window opened by
selecting Insert > Function List from the Menu bar.

To the right side of the title bar of each open deck is a Close button (X), which closes the deck to
leave only the Tab bar open. Clicking on any Tab button reopens the deck.

The Sidebar can be hidden, or revealed if already hidden, by clicking on the edge Hide/Show
button. You can adjust the deck width by dragging on the left edge of the sidebar.

Opening a CSV file

Comma-separated-values (CSV) files are spreadsheet files in a text format where cell contents are
separated by a character, for example a comma or semi-colon. Each line in a CSV text file
represents a row in a spreadsheet. Text is entered between quotation marks; numbers are entered
without quotation marks.

To open a CSV file in Calc:

1) Choose File > Open on the Menu bar and locate the CSV file that you want to open.

2) Select the file and click Open. By default, a CSV file has the extension . csv. However,
some CSV files may have a . txt extension.

3) The Text Import dialog (Figure 6) opens allowing you to select the various options
available when importing a CSV file into a Calc spreadsheet.

4) Click OK to open and import the file.

The various options for importing CSV files into a Calc spreadsheet are as follows:
* Import
— Character Set — specifies the character set to be used in the imported file.

— Language — determines how the number strings are imported.

If Language is set to Default for CSV import, Calc will use the globally set language. If
Language is set to a specific language, that language will be used when importing
numbers.

— From Row — specifies the row where you want to start the import. The rows are visible
in the preview window at the bottom of the dialog.

Opening a CSV file | 11



® O Text Import - [SampleSpreadsheet.csv]

ot

Import

Character set icode (UTF E

Language Default - English (UK) 2

From row 1 =

Separator options

Fixed width @® Sseparated by
& Tab & Comma & semicolon Space Other
Merge delimiters Text delimiter | " v

Other options

Quoted field as text | Detect special numbers
Fields
Column type
__|standard [standard _|Standard _|Standard |Standard |standard
1 Surname First Name Address City Country
2| Weber Jean PO Box 640 Airlie Beach Australia
E Schofield Peter Jankowskiego Opole Poland
13
oK | Cancel Help

Figure 6: Text Import dialog

* Separator Options — specifies whether your data uses separators or fixed widths as
delimiters.

— Fixed width — separates fixed-width data (equal number of characters) into columns.
Click on the ruler in the preview window to set the width.

— Separated by — select the separator used in your data to delimit the data into columns.
When you select Other, you specify the character used to separate data into columns.
This custom separator must also be contained in your data.

— Merge delimiters — combines consecutive delimiters and removes blank data fields.
— Text delimiter — select a character to delimit text data.

* Other options

— Quoted fields as text — when this option is enabled, fields or cells whose values are
quoted in their entirety (the first and last characters of the value equal the text delimiter)
are imported as text.

— Detect special numbers — when this option is enabled, Calc will automatically detect all
number formats, including special number formats such as dates, time, and scientific
notation. The selected language also influences how such special numbers are
detected, since different languages and regions many have different conventions for
such special numbers.

When this option is disabled, Calc will detect and convert only decimal numbers. The
rest, including numbers formatted in scientific notation, will be imported as text. A
decimal number string can have digits 0-9, thousands separators, and a decimal
separator. Thousands separators and decimal separators may vary with the selected
language and region.
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* Fields — shows how your data will look when it is separated into columns.

— Column type — select a column in the preview window and select the data type to be
applied the imported data.

— Standard — Calc determines the type of data.
— Text — imported data are treated as text.

— US English — numbers formatted in US English are searched for and included
regardless of the system language. A number format is not applied. If there are no US
English entries, the Standard format is applied.

— Hide — the data in the column are not imported.

Saving spreadsheets

To save a spreadsheet, see Chapter 1 Introducing LibreOffice for more details on how to save files
manually or automatically. Calc can also save spreadsheets in a range of formats and also export
spreadsheets to PDF, HTML and XHTML file formats; see the Calc Guide Chapter 6 Printing,
Exporting, and E-mailing for more information.

Saving in other spreadsheet formats

If you need to exchange files with users who are unable to receive spreadsheet files in Open
Document Format (ODF) (* . ods), which Calc uses as default format, you can save a spreadsheet
in another format.

1) Save your spreadsheet in Calc spreadsheet file format (* . ods).
2) Select File > Save As on the Menu bar to open the Save As dialog (Figure 7).

@ sSaveas
[fhumefpeterfDrnpbnfoOBﬁ Calc Guide l - | 5T F_'|
Places Title | Type Size |pate modified
[J Default Directo 5 calc 3.4 Folder 29/11/2012, 13:04:47 [~
3 chapoo Folder 29/11/2012, 13:03:48
3 chapo1 Folder 06/12/2012,11:56:32 |-
3 chapo2 Folder 29/11/2012, 13:03:49
3 Chap03 Folder 29/11/2012, 13:04:17
3 chapo4 Folder 29/11/2012, 13:03:48
3 chapos Folder 29/11/2012, 13:04:47
3 chapos Folder 29/11/2012, 13:04:17
3 chapo7 Folder 29/11/2012,13:03:49 |
= ™ Chapo8 Folder 29/11/2012.13:03:49 |~
File name: [ sampleSpreadsheet [ w] “
File type: IMicrosoft Excel 2007/2010/2013 XML (.xlsx) k2 cancel '
' Help '
[ save with password & Automatic File name extension
_| EditFilter settings

Figure 7: Save As dialog
3) In File name, if you wish, enter a new file name for the spreadsheet.
4) In File type drop-down menu, select the type of spreadsheet format you want to use.

5) If Automatic file name extension is selected, the correct file extension for the
spreadsheet format you have selected will be added to the file name.
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6) Click Save.

7) Each time you click Save, the Confirm File Format dialog opens (Figure 8). Click Use
[xxx] Format to continue saving in your selected spreadsheet format or click Use ODF
Format to save the spreadsheet in Calc ODS format.

8) If you select Text CSV format (* . csv) for your spreadsheet, the Export Text File dialog
(Figure 9) opens allowing you to select the character set, field delimiter, text delimiter and
so on to be used for your CSV file.

[ @ Confirm File Format 1
This document may contain formatting or content that cannot be

saved in the currently selected File format "Microsoft Excel
2007/2010/2013 XML".

Use the default ODF file format to be sure that the document is saved correctly.

& Ask when not saving in ODF format

| Use ODF Format | I ‘Use Microsoft Excel 2007/2010/2013 XML Format:

Figure 8: Confirm File Format dialog

#® Export Text File

Field options
Character set [Unicode (UTF-8) 2 | ﬁ
Field delimiter [ ; [ ~]
Text delimiter (" [w] [T

[& save cell content as shown

["] save cell formulae instead of calculated values
["] Quote all text cells

[] Fixed column width

Figure 9: Export Text File dialog for CSV files

P Tip

To have Calc save documents by default in a file format other than the default ODF
format, go to Tools > Options > Load/Save > General. In Default file format and
ODF settings > Document type, select Spreadsheet, then in Always save as, select
your preferred file format.

Navigating within spreadsheets

Calc provides many ways to navigate within a spreadsheet from cell to cell and sheet to sheet. You
can generally use the method you prefer.

Cell navigation

When a cell is selected or in focus, the cell borders are emphasized. When a group of cells is
selected, the cell area is colored. The color of the cell border emphasis and the color of a group of
selected cells depends on the operating system being used and how you have set up LibreOffice.
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Using the mouse — place the mouse pointer over the cell and click the left mouse button.
To move the focus to another cell using the mouse, simply move the mouse pointer to the
cell where you want the focus to be and click the left mouse button.

Using a cell reference — highlight or delete the existing cell reference in the Name Box on
the Formula Bar (Figure 2 on page 8). Type the new cell reference of the cell you want to

move to and press Enter key. Cell references are case-insensitive: for example, typing
either a3 or A3 will move the focus to cell A3.

Using the Navigator — click on the Navigator icon @ on the Standard toolbar or press
the F5 key to open the Navigator dialog (Figure 10) or click the Navigator Tab button in

the open Sidebar. Type the cell reference into the Column and Row fields and press the
Enter key.

Using the Enter key — pressing Enter moves the cell focus down in a column to the next
row. Pressing Shift+Enter moves the focus up in a column to the next row.

Using the Tab key — pressing Tab moves the cell focus right in a row to the next column.
Pressing Shift+Tab moves the focus to the left in a row to the next column.

Using the arrow keys — pressing the arrow keys on the keyboard moves the cell focus in
the direction of the arrow pressed.

@ Navigator

Column |[a - EHEHE
Row 1 - EEm e -

Sheet1
Sheet2
Sheet3
Sheet4
Sheets
EH Range names
& Databaseranges
P Linked areas
& Image
lih OLE objects
2] Comments
& Drawing objects

* |

Unkitlada(ackive)

Figure 10: Navigator dialog in Calc

Using Home, End, Page Up and Page Down
— Home moves the cell focus to the start of a row.

— End moves the cell focus to the last cell on the right in the row that contains data.

— Page Down moves the cell focus down one complete screen display.

Page Up moves the cell focus up one complete screen display.

Sheet navigation

Each sheet in a spreadsheet is independent of the other sheets in a spreadsheet, though
references can be linked from one sheet to another sheet. There are three ways to navigate
between different sheets in a spreadsheet.

Using the Navigator — when the Navigator is open (Figure 10), double-clicking on any of
the listed sheets selects the sheet.
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* Using the keyboard — using key combinations Ctrl+Page Down moves one sheet to the
right and Ctrl+Page Up moves one sheet to the left.

* Using the mouse — clicking on one of the sheet tabs at the bottom of the spreadsheet
selects that sheet.

If your spreadsheet contains a lot of sheets, then some of the sheet tabs may be hidden behind the
horizontal scroll bar at the bottom of the screen. If this is the case:

* Using the four buttons to the left of the sheet tabs can move the tabs into view (Figure 11).
» Dragging the scroll bar edge to the right may reveal all the tabs.

* Right-clicking on any of the arrows opens a context menu where you can select a sheet
(see Figure 12).

“ Note

When you insert a new sheet into your spreadsheet, Calc automatically uses the next
number in the numeric sequence as a name. Depending on which sheet is open when
you insert a new sheet, and the method you use to insert a new sheet, the new sheet
may not be in numerical order. It is recommended to rename sheets in your
spreadsheet to make them more recognizable.

Move to the first sheet
Move ta the next sheet on the left
Move to the next sheet on the right

/ Move to the last sheet

Sheet 2 /6 Default

Sheet tabs
Figure 11: Navigating sheet tabs

26
27

22 |

v Sheet1
Sheet2

g Sheet3
7 Sheet4
Sheets

[ itz /Sheets ;Sheetd /Sheet)

e e e

Sheet1/5
Figure 12: Right-click any arrow button

Keyboard navigation

Pressing a key or a combination of keys allows you to navigate a spreadsheet using the keyboard.
A key combination is where you press more than one key together, for example Ctrl+Home key
combination to move to cell Al. Table 1 lists the keys and key combinations you can use for
spreadsheet navigation in Calc.
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Table 1. Keyboard cell navigation

Keyboard
shortcut

—

—

'
l
Ctri+ -

Ctrl+ —

Ctrl+1

Ctrl+1

Ctrl+Home

Ctrl+End

Alt+Page Down
Alt+Page Up
Ctrl+Page Down

Ctrl+Page Up

Tab
Shift+Tab
Enter
Shift+Enter

Cell navigation

Moves cell focus right one cell
Moves cell focus left one cell
Moves cell focus up one cell
Moves cell focus down one cell

Moves cell focus to the first column on the right containing data in that row if cell
focus is on a blank cell.

Moves cell focus to the last column on the right in the same range of occupied
cells in that row if cell focus is on a cell containing data.

Moves cell focus to the last column on the right in the spreadsheet if there are no
more cells containing data.

Moves cell focus to the last column on the left containing data in that row if cell
focus is on a blank cell.

Moves cell focus to the first column on the left in the same range of occupied
cells in that row if cell focus is on a cell containing data.

Moves cell focus to the first column in that row if there are no more cells
containing data.

Moves cell focus from a blank cell to the first cell above containing data in the
same column.

Moves cell focus to the first row in the same range of occupied cells if cell focus is
on a cell containing data.

Moves cell focus from the last cell containing data to the cell in the same column
in the last row of the spreadsheet.

Moves cell focus from a blank cell to the first cell below containing data in the
same column.

Moves cell focus to the last row in the same range of occupied cells in that
column if cell focus is on a cell containing data.

Moves cell focus from the last cell containing data to the cell in the same column
in the last row of the spreadsheet.

Moves cell focus from anywhere on the spreadsheet to Cell A1 on the same
sheet.

Moves cell focus from anywhere on the spreadsheet to the last cell in the lower
right-hand corner of the rectangular area of cells containing data on the same
sheet.

Moves cell focus one screen to the right (if possible).
Moves cell focus one screen to the left (if possible).

Moves cell focus to the same cell on the next sheet to the right in sheet tabs if the
spreadsheet has more than on sheet.

Moves cell focus to the same cell on the next sheet to the left in sheet tabs if the
spreadsheet has more than on sheet.

Moves cell focus to the next cell on the right
Moves cell focus to the next cell on the left
Down one cell (unless changed by user)

Up one cell (unless changed by user)
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Customizing the Enter key

You can customize the direction in which the Enter key moves the cell focus by going to Tools >
Options > LibreOffice Calc > General. Select the direction cell focus moves from the drop-down
list. Depending on the file being used or the type of data being entered, setting a different direction
can be useful. The Enter key can also be used to switch into and out of editing mode. Use the first
two options under Input settings in Figure 13 to change the Enter key settings.

Input settings

B Press Enter to move selection 5

Down
[] Press Enter to switch to edit mode Right
[} Expand Formatting Up

"] Expand references when new columns/rows are inserted
& Highlight selection in column/row headers
[ Use printer metrics For text formatting

& show overwrite warning when pasting data
Figure 13: Customizing the Enter key

Selecting items in a spreadsheet

Selecting cells

Single cell

Left-click in the cell. You can verify your selection by looking in the Name Box on the Formula Bar
(Figure 2 on page 8).

Range of contiguous cells
A range of cells can be selected using the keyboard or the mouse.

To select a range of cells by dragging the mouse cursor:

1) Clickin acell.

2) Press and hold down the left mouse button.

3) Move the mouse around the screen.

4) Once the desired block of cells is highlighted, release the left mouse button.
To select a range of cells without dragging the mouse:

1) Click in the cell which is to be one corner of the range of cells.
2) Move the mouse to the opposite corner of the range of cells.
3) Hold down the Shift key and click.

P Tip

You can also select a contiguous range of cells by first clicking in the Selection mode
field on the Status Bar (Figure 4 on page 10) and selecting Extending selection
before clicking in the opposite corner of the range of cells. Make sure to change back
to Standard selection or you may find yourself extending a cell selection
unintentionally.
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To select a range of cells without using the mouse:

1) Select the cell that will be one of the corners in the range of cells.
2) While holding down the Shift key, use the cursor arrows to select the rest of the range.

P Tip

You can also directly select a range of cells using the Name Box. Click into the Name
Box on the Formula Bar (Figure 2 on page 8). To select a range of cells, enter the cell
reference for the upper left-hand cell, followed by a colon (:), and then the lower right-
hand cell reference. For example, to select the range that would go from A3 to C6, you
would enter A3:C6.

Range of non-contiguous cells
1) Select the cell or range of cells using one of the methods above.
2) Move the mouse pointer to the start of the next range or single cell.

3) Hold down the Ctrl key and click or click-and-drag to select another range of cells to add to
the first range.

4) Repeat as necessary.
Selecting columns and rows

Single column or row
To select a single column, click on the column header (Figure 1 on page 7).

To select a single row, click on the row header.

Multiple columns or rows
To select multiple columns or rows that are contiguous:
1) Click on the first column or row in the group.
2) Hold down the Shift key.
3) Click the last column or row in the group.
To select multiple columns or rows that are not contiguous:
1) Click on the first column or row in the group.
2) Hold down the Ctrl key.
3) Click on all of the subsequent columns or rows while holding down the Ctrl key.

Entire sheet

To select the entire sheet, click on the small box between the column headers and the row headers
(Figure 14), or use the key combination Ctrl+A to select the entire sheet, or go to Edit on the Menu
bar and select Select All.

2 \
Select all box

Figure 14: Select All box
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Selecting sheets

You can select either one or multiple sheets in Calc. It can be advantageous to select multiple
sheets, especially when you want to make changes to many sheets at once.

Single sheet

Click on the sheet tab for the sheet you want to select. The tab for the selected sheet becomes
white (default Calc setup).

Multiple contiguous sheets
To select multiple contiguous sheets:

1)
2)
3)
4)

Click on the sheet tab for the first desired sheet.
Move the mouse pointer over the sheet tab for the last desired sheet.
Hold down the Shift key and click on the sheet tab.

All tabs between these two selections will turn white (default Calc setup). Any actions that
you perform will now affect all highlighted sheets.

Multiple non-contiguous sheets
To select multiple non-contiguous sheets:

1)
2)
3)
4)
5)

Click on the sheet tab for the first desired sheet.

Move the mouse pointer over the sheet tab for the second desired sheet.
Hold down the Ctrl key and click on the sheet tab.

Repeat as necessary.

The selected tabs will turn white (default Calc setup). Any actions that you perform will now
affect all highlighted sheets.

All sheets
Right-click a sheet tab and choose Select All Sheets from the context menu.

Working with columns and rows

Inserting columns and rows

@

Note
When you insert a column, it is inserted to the left of the highlighted column. When you
insert a row, it is inserted above the highlighted row.

When you insert columns or rows, the cells take the formatting of the corresponding
cells in the next column to left or the row above.

Single column or row
Using the Insert menu:

1) Select a cell, column, or row where you want the new column or row inserted.
2) Go to Insert on the Menu bar and select either Insert > Columns or Insert > Rows.
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Using the mouse:
1) Select a column or row where you want the new column or row inserted.
2) Right-click the column or row header.
3) Select Insert Columns or Insert Rows from the context menu.

Multiple columns or rows
Multiple columns or rows can be inserted at once rather than inserting them one at a time.

1) Highlight the required number of columns or rows by holding down the left mouse button on
the first one and then dragging across the required number of identifiers.

2) Proceed as for inserting a single column or row above.

Deleting columns and rows

Single column or row
To delete a single column or row:
1) Select a cell in the column or row you want to delete.

2) Go to Edit on the Menu bar and select Delete Cells or right-click and select Delete from
the context menu.

3) Select the option you require from the Delete Cells dialog (Figure 15).

& Delete Cells

Selection [ o ]
) shift cells up

@ | cancel |

) Delete entire row(s) { Help ]

() Delete entire column(s)

Figure 15: Delete Cells dialog

Alternatively:
1) Click in the column or header to select the column or row.

2) Go to Edit on the Menu bar and select Delete Cells or right-click and select Delete
Columns or Delete Rows from the context menu.

Multiple columns or rows
To delete multiple columns or rows:
1) Select the columns or rows, see “Multiple columns or rows” on page 19 for more
information.

2) Go to Edit on the Menu bar and select Delete Cells or right-click and select Delete
Columns or Delete Rows from the context menu.
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Working with sheets

Inserting new sheets

Click on the Add Sheet icon 5. This inserts a new sheet after the last sheet in the spreadsheet
without opening the Insert Sheet dialog. The following methods open the Insert Sheet dialog
(Figure 16) where you can position the new sheet, create more than one sheet, name the new
sheet, or select a sheet from a file.

1) Select the sheet where you want to insert a new sheet, then go to Insert > Sheet on the
Menu bar.

2) Right-click on the sheet tab where you want to insert a new sheet and select Insert Sheet
from the context menu.

3) Click in the empty space at the end of the sheet tabs.

4) Right-click in the empty space at the end of the sheet tabs and select Insert Sheet from the
context menu.

@ Insert Sheet

Position

@® Before current sheet:

() After current sheet Cancel
Sheet ﬂelp |

@® Newsheet

No. of sheets 1 e

Name [Sheetﬁ ]
() Erom file

Browse...

| Link

Figure 16: Insert Sheet dialog

Moving and copying sheets

You can move or copy sheets within the same spreadsheet by dragging and dropping or using the
MovelCopy Sheet dialog. To move or copy a sheet into a different spreadsheet, you have to use
the MovelCopy Sheet dialog.

Dragging and dropping
To move a sheet to a different position within the same spreadsheet, click and hold on the sheet
tab and drag it to its new position before releasing the mouse button.

To copy a sheet within the same spreadsheet, hold down the Ctrl key (Option key on Mac) then
click on the sheet tab and drag it to its new position before releasing the mouse button. The mouse
pointer may change to include a plus sign depending on the setup of your operating system.
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Using a dialog

Use the Movel/Copy Sheet dialog (Figure 17) to specify exactly whether you want the sheet in the
same or a different spreadsheet, its position within the spreadsheet, the sheet name when you
move or copy the sheet.

1) Inthe current document, right-click on the sheet tab you wish to move or copy and select
Move/Copy Sheet from the context menu or go to Edit > Sheet > Move/Copy on the
Menu bar.

2) Select Move to move the sheet or Copy to copy the sheet.

3) Select the spreadsheet where you want the sheet to be placed from the drop-down list in
To document. This can be the same spreadsheet, another spreadsheet already open, or
you can create a new spreadsheet.

4) Select the position in Insert before where you want to place the sheet.

5) Type a name in the New nhame text box if you want to rename the sheet when it is moved
or copied. If you do not enter a name, Calc creates a default name (Sheet 1, Sheet 2, and
SO on).

6) Click OK to confirm the move or copy and close the dialog.

>

qf Caution
When you move or copy to another spreadsheet or a new spreadsheet, a conflict may
occur with formulas linked to other sheets in the previous location.

% 0 MovefCopy Sheet

EoN

Action

Copy
Location
To document
Untitled1 (current document) =

Insert before

Sheet2
Sheet3
-move to end position -

New name

Sheet1

Help | | (o] 4 | Cancel

Figure 17: Move/Copy Sheet dialog

Deleting sheets

To delete a single sheet, right-click on the sheet tab you want to delete and select Delete Sheet
from the context menu, or go to Edit > Sheet > Delete from on the Menu bar. Click Yes to confirm
the deletion.
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To delete multiple sheets, select the sheets (see “Selecting sheets” on page 20), then right-click
one of the sheet tabs and select Delete Sheet from the context menu, or go to Edit > Sheet >
Delete from on the Menu bar. Click Yes to confirm the deletion.

Renaming sheets

By default, the name for each new sheet added is SheetX, where X is the number of the next sheet
to be added. While this works for a small spreadsheet with only a few sheets, it can become
difficult to identify sheets when a spreadsheet contains many sheets.

You can rename a sheet using one of the following methods:
* Enter the name in the Name text box when you create the sheet using the Insert Sheet
dialog (Figure 16 on page 22).
* Right-click on a sheet tab and select Rename Sheet from the context menu to replace the
existing name with a different one.
» Double-click on a sheet tab to open the Rename Sheet dialog.

“ Note

Sheet names must start with either a letter or a number; other characters including
spaces are not allowed. Apart from the first character of the sheet name, permitted
characters are letters, numbers, spaces, and the underscore character. Attempting to
rename a sheet with an invalid name will produce an error message.

Viewing Calc

Changing document view

Use the zoom function to show more or fewer cells in the window when you are working on a
spreadsheet. For more about zoom, see Chapter 1 Introducing LibreOffice in this guide.

Freezing rows and columns

Freezing locks a number of rows at the top of a spreadsheet or a number of columns on the left of
a spreadsheet or both rows and columns. Then, when moving around within a sheet, the cells in
frozen rows and columns always remain in view.

Figure 18 shows some frozen rows and columns. The heavier horizontal line between rows 3 and
23 and the heavier vertical line between columns F and Q indicate that rows 1 to 3 and columns A
to F are frozen. The rows between 3 and 23 and the columns between F and Q have been scrolled
off the page.

A | B | ¢ | b | E | F Q | R |
1 Sumame |First Name |Address City Country
2 Weber Jean PO Box 640  |Airlie Beach |Australia
3 Schofield Peter Jankowskiego (Opole Poland
23
24

Figure 18: Frozen rows and columns

Freezing rows or columns

1) Click on the row header below the rows where you want the freeze, or click on the column
header to the right of the columns where you want the freeze.
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2) Go to Window on the Menu bar and select Freeze. A heavier line appears between the
rows or columns indicating where the freeze has been placed.

Freezing rows and columns

1) Click into the cell that is immediately below the rows you want frozen and immediately to
the right of the columns you want frozen.

2) Go to Window on the Menu bar and select Freeze. A heavier line appears between the
rows or columns indicating where the freeze has been placed.

Unfreezing

To unfreeze rows or columns, go to Window on the Menu bar and uncheck Freeze. The heavier
lines indicating freezing will disappear.

Splitting the screen

Another way to change the view is by splitting the screen your spreadsheet is displayed in (also
known as splitting the window). The screen can be split horizontally, vertically, or both giving you
up to four portions of the spreadsheet in view at any one time. An example of splitting the screen is
shown in Figure 19 where a split is indicated by additional window borders within the sheet.

Why would you want to do this? For example, consider a large spreadsheet in which one cell
contains a number that is used by three formulas in other cells. Using the split-screen technique,
you can position the cell containing the number in one section and each of the cells with formulas
in the other sections. You can then change the number in one cell and watch how it affects each of
the formulas.

1 Beta= 3.2000
2 A= 0.1000
7 Al= Beta*AO0*(1"AD) 0.2880
8 A2= Beta*Al*(1"Al) 0.6562
9 Ad= Beta*AZY1*AZ2) 0.7219
10 Ad= Beta*A3*(1"A3) 0.6424
11 AS=| Beta*AO*(1"Ad) 0.7351

Figure 19: Split screen example

Splitting horizontally or vertically

1) Click on the row header below the rows where you want to split the screen horizontally or
click on the column header to the right of the columns where you want to split the screen
vertically.

2) Go to Window on the Menu bar and select Split. Window borders appear between the
rows or columns indicating where the split has been placed, as shown in Figure 20.

3) Alternatively

* For a horizontal split, drag the new horizontal window border beneath the row where you
want the horizontal split positioned.

* For a vertical split, drag the new vertical window border across to the right of the column
where you want the vertical split positioned.
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Splitting horizontally and vertically

1) Click in the cell that is immediately below the rows where you want to split the screen
horizontally and immediately to the right of the columns where you want to split the screen
vertically.

2) Go to Window on the Menu bar and select Split. Heavy black lines appear between the
rows or columns indicating where the split has been placed.

Beta*A0*(1*A0)
Beta*Al*(1*Al)
Beta*AZ*(1*A2)
Beta*A3*(1*A3)
Beta*A0*(1*Ad)

Figure 20: Split screen window borders

Removing split views
To remove a split view, do one of the following:

» Drag the split window borders back to their places at the ends of the scroll bars.
* Go to Window on the Menu bar and uncheck Split.

Using the keyboard

Most data entry in Calc can be accomplished using the keyboard.

Numbers

Click in the cell and type in a number using the number keys on either the main keyboard or
numeric keypad. By default, numbers are right aligned in a cell.

Minus numbers

To enter a negative number, either type a minus (=) sign in front of the number or enclose the
number in parentheses (), for example (1234). The result for both methods of entry will be the
same, for example -1234.

Leading zeroes

To retain a minimum number of integer characters in a cell when entering numbers in order to
retain the number format, for example 1234 and 0012, leading zeros have to be added using one
of the following methods:
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Method 1

1) With the cell selected, right-click on the cell, select Format Cells from the context menu or

go to Format > Cells on the Menu bar or use the keyboard shortcut Ctr/+1 to open the
Format Cells dialog (Figure 21).

@ Format cells

]Number5|ant Font Effects Alignment Borders Background| Cell Protection

Category Format Language
- | |Default-English (UK) |2 |

Percent -1234
Currency -1234.12
Date -1,234
Time -1,234.12
Scientific -1,234.12
Epceen Ejl§§)1 2) 1234.56789
Euc!lean Value e :
Options

Decimal places 0 = [] Megative numbers red

Leading zeros 1 = [] Thousands separator
Format code
(General [l || B || % |

Figure 21: Format Cells dialog — Numbers page

2) Make sure the Numbers tab is selected then select Number in the Category list.

3) In Options > Leading Zeros, enter the minimum number of characters required. For
example, for four characters, enter 4. Any number less than four characters will have
leading zeros added, for example 12 becomes 0012.

4) Click OK. The number entered retains its number format and any formula used in the
spreadsheet will treat the entry as a number in formula functions.

Method 2

1) Select the cell.

2) Open the Sidebar (View > Sidebar) and click the Open Panel (+) icon on the Number
Format panel to open it.

3) Select Number in the Category list box.

4) Set the Leading zeroes value box to 4. Formatting is applied immediately.

El Number Format &

Category:

k

(Number

13 % B [T asc
Decimal places: 'Leading ;eroes:'
2 z 4 =

Negative numbers red

Thousands separator

Figure 22: Set Leading zeroes
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If a number is entered with leading zeroes, for example 01481, without first setting the Leading
zeros parameter, then by default Calc will automatically drop the leading 0. To preserve leading
Zeros in a number:

1) Type an apostrophe (') before the number, for example '01481.

2) Move the cell focus to another cell. The apostrophe is automatically removed, the leading
zeros are retained and the number is converted to text left aligned.

Numbers as text
Numbers can also be entered as text using one of the following methods.
Method 1
1) With the cell selected, right-click on the cell and select Format Cells from the context menu

or go to Format > Cells on the Menu bar or use the keyboard shortcut Ctr/+1 to open the
Format Cells dialog (Figure 21).

2) Make sure the Numbers page is selected, then select Text from the Category list.
3) Click OK and the number, when entered, is converted to text and, by default, left aligned.

Method 2
1) Select the cell.

2) Open the Sidebar (View > Sidebar) and click the Open Panel (+) icon on the Number
Format panel.

3) Select Text in the Category list box. Formatting is applied to the cell immediately.

4) Click back on the cell. Enter the number and move focus from the cell to have the data
formatted.

e Note

Any numbers that have been formatted as text in a spreadsheet will be treated as a
zero by any formulas used in the spreadsheet. Formula functions will ignore text
entries.

Text
Click in the cell and type the text. By default, text is left-aligned in a cell.

Date and time
Select the cell and type the date or time.

You can separate the date elements with a slash (/) or a hyphen (=) or use text, for example 10 Oct
2012. The date format automatically changes to the selected format used by Calc.

When entering a time, separate time elements with colons, for example 10:43:45. The time format
automatically changes to the selected format used by Calc.

To change the date or time format used by Calc, use one of the following methods.

Method 1
1) With the cell selected, right-click on the cell and select Format Cells from the context
menu, or go to Format > Cells on the Menu bar, or use the keyboard shortcut Cirl+1, to
open the Format Cells dialog (Figure 21).

2) Make sure the Numbers page is selected, then select Date or Time from the Category list.
3) Select the date or time format you want to use from the Format list.
4) Click OK.
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Method 2
1) Select the cell.

2) Open the Sidebar (View > Sidebar) and click the Open Panel (+) icon on the Number
Format panel.

3) Select Date in the Category list box, or click the Date icon below the list box.

4) Click the More Options button in the panel title bar to open the Format Cells dialog.
5) Select the date or time format you want to use from the Format list.

6) Click OK.

= Number Format =

! More Options

Category:

123 % _By| 1] |eec

Decimal places: Leading zeroes:

0 0
MNegative numbers red
Thousands separator

Figure 23: Select Date and More Options

Autocorrection options

Calc automatically applies many changes during data input using autocorrection, unless you have
deactivated any autocorrect changes. You can also undo any autocorrection changes by using the
keyboard shortcut Ctrl+Z or manually by going back to the change and replacing the autocorrection
with what you want to actually see.

To change the autocorrect options, go to Tools > AutoCorrect Options on the Menu bar to open
the AutoCorrect dialog (Figure 24).

Replace

Edits the replacement table for automatically correcting or replacing words or abbreviations in your
document.

Exceptions

Specify the abbreviations or letter combinations that you do not want LibreOffice to correct
automatically.

Options
Select the options for automatically correcting errors as you type and then click OK.

Localized options

Specify the AutoCorrect options for quotation marks and for options that are specific to the
language of the text.

Reset
Resets modified values back to the LibreOffice default values.
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#® AutoCorrect
Replacements and exceptions for language: [English (UK) = ]
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Figure 24: AutoCorrect dialog

Deactivating automatic changes

Some AutoCorrect settings are applied when you press the spacebar after you enter data. To turn
off or on Calc AutoCorrect, go to Tools > Cell Contents on the Menu bar and deselect or select
Autolnput.

Speeding up data entry

Entering data into a spreadsheet can be very labor-intensive, but Calc provides several tools for
removing some of the drudgery from input.

The most basic ability is to drop and drag the contents of one cell to another with a mouse. Many
people also find Autolnput helpful. Calc also includes several other tools for automating input,
especially of repetitive material. They include the fill tool, selection lists, and the ability to input
information into multiple sheets of the same document.

Using the Fill tool

The Calc Fill tool is used to duplicate existing content or create a series in a range of cells in your
spreadsheet (Figure 25).

1) Select the cell containing the contents you want to copy or start the series from.

2) Drag the mouse in any direction or hold down the Shift key and click in the last cell you
want to fill.

3) Go to Edit > Fill on the Menu bar and select the direction in which you want to copy or
create data (Up, Down, Left or Right) or Series from the context menu.
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Alternatively, you can use a shortcut to fill cells.

1)
2)

3)

Select the cell containing the contents you want to copy or start the series from.

Move the cursor over the small square in the bottom right corner of the selected cell. The
cursor will change shape.

Click and drag in the direction you want the cells to be filled. If the original cell contained
text, then the text will automatically be copied. If the original cell contained a number, a
series will be created.

' A1:A8

Using a fill series

When you select a series fill from Edit > Fill > Series, the Fill Series dialog (Figure 26) opens.
Here you can select the type of series you want.

@ Fill Series
Direction Series type Time unit
@® Down @ Linear (® Day ﬁ
) Right () Growth ) Weekday Cancel
O Up ) Date () Month Help
@ Left () AutoFill @ Year
Startvalue [32 l
End value [ l
Increment " |

Figure 26: Fill Series dialog

Direction — determines the direction of series creation.

— Down — creates a downward series in the selected cell range for the column using the
defined increment to the end value.

— Right — creates a series running from left to right within the selected cell range using the
defined increment to the end value.

— Up — creates an upward series in the cell range of the column using the defined
increment to the end value.

— Left — creates a series running from right to left in the selected cell range using the
defined increment to the end value.
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* Series Type — defines the series type.
— Linear — creates a linear number series using the defined increment and end value.
— Growth — creates a growth series using the defined increment and end value.
— Date — creates a date series using the defined increment and end date.

— AutoFill - forms a series directly in the sheet. The AutoFill function takes account of
customized lists. For example, by entering January in the first cell, the series is
completed using the list defined in LibreOffice > Tools > Options > LibreOffice Calc
> Sort Lists. AutoFill tries to complete a value series by using a defined pattern. For
example, a numerical series using 1,3,5 is automatically completed with 7,9,11,13; a
date and time series using 01.01.99 and 15.01.99, an interval of fourteen days is used.

* Unit of Time — in this area you specify the desired unit of time. This area is only active if
the Date option has been chosen in the Series type area.

— Day - use the Date series type and this option to create a series using seven days.
— Weekday — use the Date series type and this option to create a series of five day sets.

— Month — use the Date series type and this option to form a series from the names or
abbreviations of the months.

— Year — use the Date series type and this option to create a series of years.
« Start Value — determines the start value for the series. Use numbers, dates or times.
« End Value — determines the end value for the series. Use numbers, dates or times.

* Increment — determines the value by which the series of the selected type increases by

each step. Entries can only be made if the linear, growth or date series types have been
selected.

% Options - LibreOffice Calc - Sort Lists

» LibreOffice ; ;
» LoadfSave e - Entries | New s
» Language Settings sun,Mon,Tue,Wed,Thu,Fri,Sat January I
¥ LibreOffice Calc Sunday,MondayTuesday,Wednesday,Thur |February add
General Jan,Feb,Mar,Apr,May,Jun,Jul,Aug,Sep,0¢ Mar'ch =i
Defaults January,February,March,April,May,June, [lilE00
View sunday,Monday,Tuesday,wWednesday,Thur |May Delete
Calculate Nissan,lyar,Sivan,Tammuz,Av,ElulTishri,- |June T
Formula July
sort Lis| August
changes September
Compatibility October
Grid November
Print December
> LibreOffice Base
* Charts
* Internet
Copy list from: |SSheet1.5A%1:5A%8 Copy
[ oK | | Cancel _ Help | Revert

Figure 27: Sort Lists dialog
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Defining a fill series
To define your own fill series:

1) Go to Tools > Options > LibreOffice Calc > Sort Lists to open the Sort Lists dialog
(Figure 27). This dialog shows the previously-defined series in the Lists box on the left and
the contents of the highlighted list in the Entries box.

2) Click New and the Entries box is cleared.

3) Type the series for the new list in the Entries box (one entry per line).
4) Click Add and the new list will now appear in the Lists box.

5) Click OK to save the new list.

Using selection lists

Selection lists are available only for text and are limited to using only text that has already been
entered in the same column.

1) Select a blank cell in a column that contains cells with text entries.

2) Right-click and select Selection Lists from the context menu. A drop-down list appears
listing any cell in the same column that either has at least one text character or whose
format is defined as text.

3) Click on the text entry you require and it is entered into the selected cell.

Sharing content between sheets

You might want to enter the same information in the same cell on multiple sheets, for example to
set up standard listings for a group of individuals or organizations. Instead of entering the list on
each sheet individually, you can enter the information in several sheets at the same time.

1) Go to Edit > Sheet > Select on the Menu bar to open the Select Sheets dialog.

@@ Select Sheets

o

Sheet1 e
Sheet2 Cancel
Sheet3

Sheet4 Help |

Figure 28: Select Sheets dialog

2) Select the individual sheets where you want the information to be repeated. Use the Shift
and Ctrl (Options on Mac) keys to select multiple sheets.

3) Click OK to select the sheets and the sheet tabs will change color.

4) Enter the information in the cells on the first sheet where you want it to appear and it will be
repeated in all the selected sheets.

“ Note

This technique automatically overwrites, without any warning, any information that is
already in the cells on the selected sheets. Make sure you deselect the additional
sheets when you are finished entering information that is going to be repeated before
continuing to enter data into your spreadsheet.
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Validating cell contents

When creating spreadsheets for other people to use, validating cell contents ensures that they
enter data that is valid and appropriate for the cell. You can also use validation in your own work as
a guide to entering data that is either complex or rarely used.

Fill series and selection lists can handle some types of data, but are limited to predefined
information. To validate new data entered by a user, select a cell and go to Data > Validity on the
Menu bar to define the type of contents that can be entered in that cell. For example, a cell may
require a date or a whole number with no alphabetic characters or decimal points, or a cell may not
be left empty.

Depending on how validation is set up, validation can also define the range of contents that can be
entered, provide help messages explaining the content rules set up for the cell and what users
should do when they enter invalid content. You can also set the cell to refuse invalid content,
accept it with a warning, or start a macro when an error is entered. See the Calc Guide Chapter 2
Entering, Editing and Formatting Data for more information on validating cell contents.

Editing data

Deleting data

Deleting data only

Data can be deleted from a cell without deleting any of the cell formatting. Click in the cell to select
it and then press the Delete key.

Deleting data and formatting
Data and cell formatting can be deleted from a cell at the same time.
1) Click in the cell to select it.

2) Press the Backspace key, or right-click in the cell and select Delete Contents from the
context menu, or go to Edit > Delete Contents) on the Menu bar to open the Delete
Contents dialog (Figure 29). Here you can delete the different aspects of the data in the
cell or to delete everything in the cell.

%@ 0 Delete Contents

Selection

B Text B Numbers

& Date & time & Formulas

& Comments Formats
Objects
{ QK | | Cancel || Help

Figure 29: Delete Contents dialog
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Replacing data

To completely replace data in a cell and insert new data, select the cell and type in the new data.
The new data will replace the data already contained in the cell but will retain the original
formatting used in the cell.

Alternatively, click in the Input Line on the Formula Bar (Figure 2 on page 8), then double-click on
the data to highlight it completely and type the new data.

Editing data

Sometimes it is necessary to edit the contents of cell without removing all of the data from the cell.
For example, changing the phrase “Sales in Qtr. 2" to “Sales rose in Qtr” can be done as follows.

Using the keyboard
1) Click in the cell to select it.
2) Pressthe F2 key and the cursor is placed at the end of the cell.

3) Use the keyboard arrow keys to reposition the cursor where you want to start entering the
new data in the cell.

4) When you have finished, press the Enter key and your editing changes are saved.

Using the mouse
1) Double-click on the cell to select it and place the cursor in the cell for editing.
2) Either:
* Reposition the cursor to where you want to start entering the new data in the cell.
* Single-click to select the cell.

3) Move the cursor to the Input Line on the Formula Bar (Figure 2 on page 8) and click at the
position where you want to start entering the new data in the cell.

4) When you have finished, click away from the cell to deselect it and your editing changes
are saved.

Formatting data

6 Note

All the settings discussed in this section can also be set as a part of the cell style. See
the Calc Guide Chapter 4 Using Styles and Templates in Calc for more information.

Multiple lines of text

Multiple lines of text can be entered into a single cell using automatic wrapping or manual line
breaks. Each method is useful for different situations.

Automatic wrapping
To automatically wrap multiple lines of text in a cell, use one of the following methods.

Method 1
1) Right-click on the cell and select Format Cells from the context menu, or go to Format >
Cells on the Menu bar, or press Ctri+1, to open the Format Cells dialog.

2) Click on the Alignment tab (Figure 30).
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3) Under Properties, select Wrap text automatically and click OK.

@ o Format Cells

Mumbers | Font | Fonkt Effects | Alignment | Borders  Background | Cell Protection

Text alignment

Horizontal Indent WVertical

i s | lopt |Default =N
Text orientation
; I b, Degrees ["] Vertically stacked
0 =
- ABCD o
¥ Reference edge
- "
£ &= o
Properties
~| Wrap text automatically
Hyphenation active
—| shrink to fik cell size
I oK | Cancel [ | Help || Reset |

Figure 30: Format Cells dialog — Alignment page

Method 2
1) Select the cell.

2) Open the Sidebar (View > Sidebar) and click the Open Panel (+) icon on the Alignment
panel.

3) Select the Wrap text option to apply the formatting immediately.

= Alignment |
= =3 E
Leftindent: Merge Cells
opt = | |

Texk orientation:

-, - | Vertically Stacked
- —=
i ~ 0° =

Figure 31: Wrap text formatting

Manual line breaks

To insert a manual line break while typing in a cell, press Ctrl+Enter. This method does not work
with the cursor in the input line. When editing text, double-click the cell, then reposition the cursor
to where you want the line break.

When a manual line break is entered, the cell width does not change and your text may still overlap
the end of the cell. You have to change the cell width manually or reposition your line break so that
your text does not overlap the end of the cell.
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Shrinking text to fit the cell

The font size of the data in a cell can automatically adjust to fit inside cell borders. To do this,
select the Shrink to fit cell size option under Properties in the Format Cells dialog (Figure 30) on
the Alignment page. This dialog is also available by clicking the More Options button in the
Character title bar of the Properties deck on the opened Sidebar.

Formatting numbers

Several different number formats can be applied to cells by using icons on the Formatting toolbar
(highlighted in Figure 32). Select the cell, then click the relevant icon to change the number format.

Formatting i
@ |Liberation sans »| |10 =|| B F U | =

Figure 32: Number icons on Formatting toolbar

For more control or to select other number formats, use the Numbers page of the Format Cells
dialog (Figure 21 on page 27):

* Apply any of the data types in the Category list to the data.
* Control the number of decimal places and leading zeros in Options.
* Enter a custom format code.

* The Language setting controls the local settings for the different formats such as the date
format and currency symbol.

Some number formats are available from the Sidebar's Number Format panel in the Properties
deck. Click the More Options button to open the Format Cells dialog described above.
= Number Format =]
Category:

|General =

123 | % B M | asc
Figure 33: Number format icons in the
Number Format panel on the Sidebar

Formatting a font
To quickly select a font and format it for use in a cell:

1) Select the cell.

2) Click the small triangle on the right of the Font Name box on the Formatting toolbar
(highlighted in Figure 34) and select a font from the drop-down list.

3) Click on the small triangle on the right of the Font Size on the Formatting toolbar and select
a font size from the drop down list.

Formattin =X
@Sans -Dsfug.% B A% Wil e O0-2-4A- ]

Figure 34: Font Name and Size on Formatting toolbar

4) To change the character format, click on the Bold, /talic, or Underline icons.
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5) To change the paragraph allgnment of the fo
(Left, Center, Right, Justified) £ =

click on one of the four alignment icons

nt,

6) To change the font color, click the arrow next to the Font Color icon & to display the color
palette, then select the desired color.

The Properties deck of the Sidebar has two panels, Character and Alignment, which between
them contain all the formatting controls from the Formatting toolbar.

To specify the language used in the cell, open the Font page on the Format Cells dialog. You can
also select the More Options button on either of the Sidebar panels to open the Format Cells
dialog. Changing language in a cell allows different languages to be used within the same
document.

Use the Font Effects tab on the Format Cells dialog to set other font characteristics. See the Calc
Guide Chapter 4 Using Styles and Templates in Calc for more information.

Formatting cell borders

To format the borders of a cell or a group of selected cells, click on the Borders icon [] on the
Formatting toolbar, and select one of the border options displayed in the palette.

To format the line style and line color for the borders of a cell, click the small arrows next to the

Line Style ...... and Line Color (Border Color) I-_Il icons on the Formatting toolbar. A line style
palette and a border color palette respectively are displayed.

The Cell Appearance panel of the Properties deck in the Sidebar contains Cell border, Line
style and Line color controls.

For more control, including the spacing between cell borders and any data in the cell, use the
Borders page of the Format Cells dialog (Figure 21 on page 27), where you can also define a
shadow style. Clicking the More Options button on the Cell Appearance title bar, or clicking More
in the panel’s line style drop-down list, opens the Format Cells dialog at the Borders page.

See the Calc Guide Chapter 4 Using Styles and Templates in Calc for more information.

e Note

Cell border properties apply only to the selected cells and can only be changed if you
are editing those cells. For example, if cell C3 has a top border, that border can only be
removed by selecting C3. It cannot be removed in C2 despite also appearing to be the
bottom border for cell C2.

Formatting cell background
To format the background color for a cell or a group of cells, click the small arrow next to the

Background Color icon & on the Formatting toolbar. A color palette, similar to the Font Color
palette, is displayed. You can also use the Background tab of the Format Cells dialog (Figure 21 on
page 27). The Cell Appearance panel of the Properties deck in the Sidebar contains a Cell
background control with a color palette. See the Calc Guide Chapter 4 Using Styles and
Templates in Calc for more information.
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AutoFormat of cells

Using AutoFormat

You can use Calc’s AutoFormat feature to format a group of cells quickly and easily.

1)

2)
3)
4)
5)
6)

Select the cells in at least three columns and rows, including column and row headers, that

you want to format.

Go to Format > AutoFormat on the Menu bar to open the AutoFormat dialog (Figure 35).
Select the type of format and format color from the list.

If necessary, click More to open Formatting if Formatting is not visible.
Select the formatting properties to be included in the AutoFormat function.

Click OK.

& AutoFormat

Format

3-D

Black 1

Black 2

Blue

Brown

Currency

Currency 3-D
Currency Grey
Currency Lavender
Currency Turquoise
Default

Green

[

Formatting
& Number Format
& Borders

& Font
& Pattern

& Alignment

& AutoFit width and heighl

Delete |

Rename

Figure 35: AutoFormat dialog

Defining a new AutoFormat

You can define a new AutoFormat so that it becomes available for use in all spreadsheets.

1)

2)
3)

4)
5)

6)

Format the data type, font, font size, cell borders, cell background and so on for a group of

cells.

Go to Edit > Select All on the Menu bar to select the whole spreadsheet.

Go to Format > AutoFormat to open the AutoFormat dialog and the Add button is now

active.
Click Add.

In the Name box of the Add AutoFormat dialog that opens, type a meaningful name for the

new format.

Click OK to save. The new AutoFormat is now available in the Format list in the AutoFormat

dialog.

Using themes

Calc comes with a predefined set of formatting themes that you can apply to spreadsheets. It is hot
possible to add themes to Calc and they cannot be modified. However, you can modify their styles
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after you apply them to a spreadsheet and the modified styles are only available for use for that
spreadsheet when you save the spreadsheet.

To apply a theme to a spreadsheet:

1) Click the Choose Themes icon % in the Tools toolbar. If this toolbar is not visible, go to
View > Toolbars on the Menu bar and select Tools, and the Theme Selection dialog
(Figure 36) opens. This dialog lists the available themes for the whole spreadsheet.

2) Select the theme that you want to apply. As soon as you select a theme, the theme styles
are applied to the spreadsheet and are immediately visible.

3) Click OK.

4) If you wish, you can now open the Styles and Formatting window to modify specific styles.
These modifications do not modify the theme; they only change the appearance of the style
in the specific spreadsheet you are creating.

#® Theme Selection

(standard) -]
Autumn Leaves
Be

Black and White
Blackberry Bush
Blue Jeans
Fifties Diner
Glacier

Green Grapes
Marine
Millennium
MNature

Neon ~
Night
PC Nostalgia
Pactal

Figure 36: Theme Selection dialog

Using conditional formatting

You can set up cell formats to change depending on conditions that you specify. For example, in a
table of numbers, you can show all the values above the average in green and all those below the
average in red.

Conditional formatting depends upon the use of styles and the AutoCalculate feature must be
enabled. Go to Tools > Cell Contents > AutoCalculate on the Menu bar to enable this feature.
See the Calc Guide Chapter 2 Entering, Editing, and Formatting Data for more information.

Hiding and showing data

In Calc you can hide elements so that they are neither visible on a computer display nor printed
when a spreadsheet is printed. However, hidden elements can still be selected for copying if you
select the elements around them. For example, if column B is hidden, it is copied when you select
columns A and C.

For more information on how to hide and show data, including how to use outline groups and
filtering, see the Calc Guide Chapter 2 Entering, Editing, and Formatting Data.
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Hiding data

To hide sheets, rows, and columns:
1)
2)
3)
4)

Select the sheet, row or column you want to hide.
Go to Format on the Menu bar and select Sheet, Row or Colum
Select Hide from the menu and the sheet, row or column can no

from the context menu.
To hide and protect data in selected cells:

n.
longer viewed or printed.

Alternatively, right-click on the sheet tab, row header or column header and select Hide

1) Go to Tools > Protect Document and select Sheet from the menu options. The Protect
Sheet dialog dialog will open (Figure 37).

2) Select Protect this sheet and the contents of protected cells.

3) Create a password and then confirm the password.

4) Select or deselect the user selection options for cells.

5) Click OK.

6) Select the cells you want to hide.

7) Go to Format > Cells on the Menu batr, or right-click and select Format Cells from the
context menu, or use the keyboard shortcut Ctr/+1 to open the Format Cells dialog.

8) Click the Cell Protection tab (Figure 38) and select an option to hide the cells.

9) Click OK.

@ Protect Sheet

[# Protect this sheet and the contents of protected cells

[
[

Password

Confirm

Options
Allow all users of this sheet to:

. " fiSelect protected cells|

& Select unprotected cells
Figure 37: Protect Sheet dialog

Cancel

' Help

@ Format Cells
|Numbers| Font | Font Effects| Alignment BnrderslBackgrnund|Cell Protection

Protection

sheet has been protected.
& Protected

(] Hide formula and specify 'Sheet'.

Prink
[] Hidewhen printing

Figure 38: Cell Protection page in Format Cells dialog

Cell protection is only effective after the current

Select 'Protect Document' From the 'Tools' menu

The cells selected will be omitted when printing.
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’ Note

When data in cells are hidden, the blank cells remain visible in the spreadsheet.

Showing data

To show hidden sheets, rows, and columns:
1) Select the sheets, rows or columns each side of the hidden sheet, row or column.
2) Go to Format on the Menu bar and select Sheet, Row or Column.

3) Select Show from the menu and the sheet, row or column will be displayed and can be
printed.

4) Alternatively, right-click on the sheet tabs, row headers or column headers and select Show
from the context menu.

To show hidden data in cells:
1) Go to Tools > Protect Document and select Sheet from the menu options.
2) Enter the password to unprotect the sheet and click OK.

3) Go to Format > Cells on the Menu bar, or right-click and select Format Cells from the
context menu, or use the keyboard shortcut Ctr/+1 to open the Format Cells dialog.

4) Click the Cell Protection tab (Figure 38) and deselect the hide options for the cells.
5) Click OK.

Sorting records

Sorting within Calc arranges the cells in a sheet using the sort criteria that you specify. Several
criteria can be used and a sort applies each criteria consecutively. Sorts are useful when you are
searching for a particular item and become even more useful after you have filtered data.

Also, sorting is useful when you add new information to your spreadsheet. When a spreadsheet is
long, it is usually easier to add new information at the bottom of the sheet, rather than adding rows
in their correct place. After you have added information, you then carry out a sort to update the
spreadsheet.

For more information on how to sort records and the sorting options available, see the Calc Guide
Chapter 2 Entering, Editing, and Formatting Data.

® sort
‘-Surt CriterialOptinns
sort key 1 =
: @® Ascending
[First Name 2
() Descending
Sort key 2
@® Ascending
[-undefined - = ]
() Descending
Sort key 3
- (®) Ascending
-undefined - .
) Descending

Figure 39: Sort Criteria dialog
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To sort cells in your spreadsheet:

1) Select the cells to be sorted.
2) Go to Data > Sort on the Menu bar to open the Sort dialog (Figure 39).

3) Select the sort criteria from the drop down lists. The selected lists are populated from the
selected cells.

4) Select either ascending order (A-Z, 1-9) or descending order (Z-A, 9-1).
5) Click OK and the sort is carried out on your spreadsheet.

Using formulas and functions

You may need more than numbers and text on your spreadsheet. Often the contents of one cell
depend on the contents of other cells. Formulas are equations that use numbers and variables to
produce a result. Variables are placed in cells to hold data required equations.

A function is a predefined calculation entered in a cell to help you analyze or manipulate data. All
you have to do is enter the arguments and the calculation is automatically made for you. Functions
help you create the formulas required to get the results that you are looking for.

See the Calc Guide Chapter 7 Using Formulas and Functions for more information.

Analyzing data

Calc includes several tools to help you analyze the information in your spreadsheets, ranging from
features for copying and reusing data, to creating subtotals automatically, to varying information to
help you find the answers you need. These tools are divided between the Tools and Data menus.

One of the most useful of these tools is the PivotTable, which is used for combining, comparing,
and analyzing large amounts of data easily. Using the PivotTable, you can view different
summaries of the source data, display the details of areas of interest, and create reports, whether
you are a beginner, an intermediate or advanced user.

See the Calc Guide Chapter 8 Using Pivot Tables and Chapter 9 Data Analysis for more
information on pivot tables and other tools available in Calc to analyze your data.

Printing

Printing from Calc is much the same as printing from other LibreOffice components (see Chapter
10 Printing, Exporting, and Emailing in this guide). However, some details for printing in Calc are
different, especially regarding preparation for printing.

Print ranges

Print ranges have several uses, including printing only a specific part of the data or printing
selected rows or columns on every page. For more information about using print ranges, see the
Calc Guide Chapter 6 Printing, Exporting, and E-mailing.

Defining a print range
To define a new print range or modify an existing print range:
1) Select the range of cells to be included in the print range.

2) Go to Format > Print Ranges > Define on the Menu bar. Page break lines are displayed
on screen.

Printing | 43



3) To check the print range, go to File > Page Preview on the Menu bar or click on the Page

Preview icon . LibreOffice will display the cells in the print range.

Adding to a print range

After defining a print range, you can add more cells to it by creating another print range. This
allows multiple, separate areas of the same sheet to be printed while not printing the whole sheet.

1) After defining a print range, select an extra range of cells for adding to the print range.

2) Go to Format > Print Ranges > Add on the Menu bar to add the extra cells to the print
range. The page break lines are no longer displayed on the screen.

3) To check the print ranges, go to File > Page Preview on the Menu bar or click on the Page

Preview icon . LibreOffice will display the print ranges as separate pages.

“ Note

The additional print range will print as a separate page, even if both ranges are on the
same sheet.

Removing a print range

It may become necessary to remove a defined print range, for example, if the whole sheet needs to
be printed later.

To remove all the defined print ranges, go to Format > Print Ranges > Remove on the Menu bar.
After the print ranges have been removed, the default page break lines will appear on the screen.

Editing a print range
At any time, you can directly edit the print range, for example to remove or resize part of the print

range. Go to Format > Print Ranges > Edit on the Menu bar to open the Edit Print Ranges
dialog where you can define the print range.

Printing options

To select the printing options for page order, details, and scale to be used when printing a
spreadsheet:

1) Go to Format > Page on the Menu bar to open the Page Style dialog (Figure 40).
2) Select the Sheet tab and make your selections from the available options.
3) Click OK.

For more information on printing options, see the Calc Guide Chapter 6 Printing, Exporting, and
E-mailing.

Repeat printing of rows or columns

If a sheet is printed on multiple pages, you can set up certain rows or columns to repeat on each
printed page. For example, if the top two rows of the sheet as well as column A need to be printed
on all pages, do the following:

1) Go to Format > Print Ranges > Edit on the Menu bar to open the Edit Print Ranges
dialog (Figure 41).

2) Type the row identifiers in the Rows to repeat box. For example, to repeat rows 1 and 2,
type $1:$2. This automatically changes Rows to repeat from, - none - to - user defined -.
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Figure 40: Page Style dialog

3) Type the column identifiers in the Columns to repeat box. For example, to repeat column A,
type $A. In the Columns to repeat list, - none - changes to - user defined -.

4) Click OK.
For more information on editing print ranges, see the Calc Guide, Chapter 6 Printing, Exporting,
and E-mailing.
@& o Edit Print Ranges

Print range

|-entire sheet- |2 | |

Rows to repeat

l-userdefined- |3 | b1:52 | .
Columns to repeat
|-none- =4 | |
0K || Cancel | | Help

Figure 41: Edit Print Ranges dialog

Page breaks

While defining a print range can be a powerful tool, it may sometimes be necessary to manually
adjust the Calc printout manually using a manual or page break. A page break helps to ensure that
your data prints properly according to your page size and page orientation. You can insert a
horizontal page break above or a vertical page break to the left of the active cell.
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For more information on manual breaks, see the Calc Guide Chapter 6 Printing, Exporting, and
E-mailing.

Inserting a break
To insert a page break:
1) Navigate to the cell where the page break will begin.
2) Go to Insert > Page Break on the Menu bar.
3) Select Row Break to create a page break above the selected cell.
4) Select Column Break to create a page break to the left of the selected cell.

Deleting a page break
To remove a page break:
1) Navigate to a cell that is next to the break you want to remove.
2) Go to Edit > Delete Page Break on the Menu bar.
3) Select Row Break or Column Break depending on your need and break is removed.

e Note

Multiple manual row and column breaks can exist on the same page. When you want
to remove them, you have to remove each break individually.

Headers and footers

Headers and footers are predefined pieces of text that are printed at the top or bottom of a page
when a spreadsheet is printed. Headers and footers are set and defined using the same method.
For more information on setting and defining headers and footers, see the Calc Guide Chapter 6
Printing, Exporting, and E-mailing.

Headers and footers are also assigned to a page style. You can define more than one page style
for a spreadsheet and assign different page styles to different sheets within a spreadsheet. For
more information on page styles, see the Calc Guide Chapter 4 Using Styles and Templates.

Setting a header or footer
To set a header or footer:
1) Navigate to the sheet that you want to set the header or footer for.
2) Go to Format > Page on the Menu bar to open the Page Style dialog (Figure 42).
3) On the Page Style dialog, select Header or Footer tab.
4) Select the Header on or Footer on option.

5) Select Same content left/right option if you want the same header or footer to appear on
all the printed pages.

6) Set the margins, spacing, and height for the header or footer. You can also select AutoFit
height box to automatically adjust the height of the header or footer.

7) To change the appearance of the header or footer, click on More to open the borders and
background dialog.

8) To set the contents, for example page number, date and so on, that appears in the header
or footer, click on Edit to open the style dialog.
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Figure 42: Header page of Page Style dialog
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