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Note for Mac users

Some keystrokes and menu items are different on a Mac from those used in Windows and Linux.
The table below gives some common substitutions for the instructions in this chapter. For a more
detailed list, see the application Help.

Windows or Linux  Mac equivalent Effect
Tools > 0pt_|ons LibreOffice > Preferences Access setup options
menu selection
Right-click Control+click and/or right-click o

. pen a context menu

depending on computer setup

Ctrl (Control) 3 (Command) Used with other keys
F5 Shift+38+F5 Open the Navigator
F11 #+T Open the Styles and Formatting window
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Introduction

This chapter describes some common customizations that you may wish to carry out.

You can customize menus, toolbars, and keyboard shortcuts in LibreOffice, add new menus and
toolbars, and assign macros to events. However, you cannot customize context (right-click) menus.

Other customizations are made easy by extensions that you can install from the LibreOffice
website or from other providers.

‘ Note

Since LibreOffice 5.1, the menu bars in Writer, Calc, and Impress have been
reorganized to improve the usability of the application. The most used application
commands were put together in the Styles, Sheets, and Slide menus, respectively.

‘ Note

Customizations to menus and toolbars can be saved in a template. To do so, first save
them in a document and then save the document as a template as described in
Chapter 3, Using Styles and Templates.

Customizing menu content

In addition to changing the menu font (described in Chapter 2, Setting up LibreOffice), you can add
and rearrange categories on the menu bar, add commands to menus, and make other changes.

To customize menus:

1) Choose Tools > Customize to display the Customize dialog. Choose the Menus page
(Figure 1).

Menus | Context Menus  Keyboard  Toolbars | Events

LibreOFfice Writer Menus

Menu  File = New...
Menu -
Menu Content
Entries Add Command
Open...
[ Open RemoteFile... Add Separator
Recent Documents
(& Close Add Submenu
&, Wizards L2
Templates 4 ¥ Modify A
& Reload Remove

Versions...

Saveln LibreOffice Writer 2

Description

Help OK Cancel Reset

Figure 1: The Menus page of the Customize dialog
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2)

3)

4)

5)

In the Save In drop-down list, choose whether to save this changed menu for the
application (for example, LibreOffice Writer) or for a selected document (for example,
SampleDocument.odt).

In the section LibreOffice [name of the program (example: Writer)] Menus, select from
the Menu drop-down list the menu that you want to customize. The list includes all the main
menus as well as submenus (menus that are contained under another menu). For example,
in addition to File, Edit, View, and so on, there is File | Send and Edit | Changes. The
commands available for the selected menu are shown in the central part of the dialog.

To customize the selected menu, click on the Modify button. You can also add commands
to a menu by clicking on the Add button. These actions are described in the following
sections. Use the up and down arrows next to the Entries list to move the selected menu
item to a different position.

When you have finished making all your changes, click OK (not shown in illustration) to
save them.

Creating a new menu
In the Menus page of the Customize dialog, click New to display the New Menu dialog (Figure 2).

1)
2)

3)

Type a name for your new menu in the Menu name box.

Use the up and down arrow buttons to move the new menu into the required position on the
menu bar.

Click OK (not shown in illustration) to save.

The new menu now appears on the list of menus in the Customize dialog. (It will appear on the
menu bar itself after you save your customizations.)

After creating a new menu, you need to add some commands to it, as described in “Adding a
command to a menu” on page 6.

& ® Mew Menu
Menu name:

| New Menu 1

! Menu position:

| File
Edit
View

t Insert
Format

. Table 1
Tools
Window ¥
Help

I Mew Menu 1

Figure 2: Adding a new menu

Modifying existing menus

To modify an existing menu, either user-made or inbuilt, select it in the Menu list and click the
Menu button to drop down a list of modifications: Move, Rename, Delete. Not all of these
modifications can be applied to all the entries in the Menu list. For example, Rename and Delete
are not available for the supplied menus, and Move is not available for submenus.
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To move a menu (such as File), choose Menu > Move. A dialog similar to the one shown in
Figure 2 (but without the Menu name box) opens. Use the up and down arrow buttons to move the
menu into the required position.

To move submenus (such as File | Send), select the main menu (File) in the Menu list and then, in
the Menu Content section of the dialog, select the submenu (Send) in the Entries list and use the
arrow keys to move it up or down in the sequence. Submenus are easily identified in the Entries list
by a small black triangle on the right hand side of the name.

In addition to renaming, you can allocate a letter in a custom menu’s hame, which will become
underlined, to be used as a keyboard shortcut, allowing you to select that menu by pressing Alt+
that letter. Existing submenus can be edited to change the letter which is used to select their
default shortcut.

1) Select a custom menu or a submenu in the Menu drop-down list.
2) Click the Menu button and select Rename.

3) Add atilde (~) in front of the letter that you want to use as an accelerator. For example, to
select the Send submenu command by pressing S (after opening the File menu using
Alt+F), enter ~Send. This changes it from the default d.

e Note

It is possible to use a letter already in use in the menu list (for example, in the Insert
menu, the letter v is used in Envelope and in Movie and sound as an accelerator).
However, you should use an unused letter if possible, to make it simpler to navigate.

Adding a command to a menu

You can add commands to both the supplied menus and menus you have created. On the
Customize dialog, select the menu in the Menu list and click the Add button in the Menu Content
section of the dialog.

On the Add Commands dialog (Figure 3), select a category and then the command, and click Add.
The dialog remains open, so you can select several commands. When you have finished adding
commands, click Close. Back on the Customize dialog, you can use the up and down arrow
buttons to arrange the commands in your preferred sequence.

% O Add Commands

To add a command to a menu, select the category and then the command. You can also
drag the command to the Commands list of the Menus tab page in the Customize | Add
dialog.

Close
Category

All categories

Help

EAUI‘.OPIIOI:: Address Data Source

Templates Bibliography Database
View Create HTML Documenk
cE)dSEions Create Master Document
BASIC ' o E::E Macros
i‘;r?seecrltalFunctlons Extended Tips
Documents Get help online

Format Help

Navigate HelponHelp
Controls LibreOffice Credits
Table © Libreoffice Help
Drawing License Information
Image &; Load URL

Data 5. Media

Frame iii Media Player

Text [ New

Numherinn = Rlaiss Dracankakan =

Description

Figure 3: Adding a command to a menu
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Modifying menu entries

In addition to changing the sequence of entries on a menu or submenu, you can add submenus,
rename or delete the entries, and add group separators.

To begin, select the menu or submenu to be modified from the Menu list near the top of the
Customize page, then select the entry in the Entries list under Menu Content. Click the Modify
button and choose the required action from the drop-down list of actions.

Most of the actions should be self-explanatory. Begin a group adds a separator line after the
highlighted entry.

Customizing toolbars

You can customize toolbars in several ways, including choosing which icons are visible and locking
the position of a docked toolbar (as described in Chapter 1, Introducing LibreOffice), and adding or
deleting icons (commands) in the list of those available on a toolbar. You can also create new
toolbars. This section describes how to create new toolbars and add or delete icons on existing
ones.

To get to the toolbar customization dialog (Figure 4), do any of the following:
* On the toolbar, right-click in the toolbar and choose Customize Toolbar.
e Choose View > Toolbars > Customize from the menu bar.
* Choose Tools > Customize from the menu bar and go to the Toolbars page.

% O Customize

Menus | Context Menus | Keyboard | Toolbars | Events

LibreOffice Writer Toolbars
Toolbar Standard

3

New...

4

Style @ Icons lcons & Texk Text Toolbar -

Toolbar Content

Commands m o Add Command
o D New Add Separator
~] [ Manage Templates
[%:[ Open... + Modify

2 Open RemoteFile...
& H save ¥ Remove
| B saveAs...
— E-mail Document... Reset

Saveln LibreOffice Writer 2

Description
Help OK Cancel Reset

Figure 4: The Toolbars page of the Customize dialog
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Modifying existing toolbars
To modify an existing toolbar:

1) Inthe Save In drop-down list, choose whether to save this changed toolbar for the
application (for example, Writer) or for a selected document.

2) Inthe section LibreOffice [name of the program (example: Writer)] > Toolbars, select
from the Toolbar drop-down list the toolbar that you want to customize.

3) Click on the Toolbar or Modify buttons, and add commands to a toolbar by clicking on the
Add button. You can also create a new toolbar by clicking on the New button. These
actions are described in the following sections.

4) When you have finished making all your changes, click OK to save them.

Creating a new toolbar
To create a new toolbar:

1) Choose Tools > Customize > Toolbars from the menu bar.

2) Click New. On the Name dialog (Figure 5), type the new toolbar’s name and choose from
the Save In drop-down list where to save this changed menu: for the application (for
example, Writer) or for a selected document.

3) Click OK.

The new toolbar now appears on the list of toolbars in the Customize dialog. After creating
a new toolbar, you need to add some commands to it, as described below.

] ] Name
Toolbar name:

New Toolbar 1]

Save in:

LibreOffice Writer [~ |

Help Ok Cancel

Figure 5: Naming a new toolbar

Adding a command to a toolbar

If the list of available buttons for a toolbar does not include all the commands you want on that
toolbar, you can add commands. When you create a new toolbar, you need to add commands to it.

1) On the Toolbars page of the Customize dialog, select the toolbar in the Toolbar list and click
the Add button in the Toolbar Content section of the dialog.

2) The Add Commands dialog is the same as for adding commands to menus (Figure 3).
Select a category and then the command, and click Add. The dialog remains open, so you
can select several commands. When you have finished adding commands, click Close. If
you insert an item which does not have an associated icon, the toolbar will display the full
name of the item: the next section describes how to choose an icon for a toolbar command.

3) Back on the Customize dialog, you can use the up and down arrow buttons to arrange the
commands in your preferred sequence.

4) When you have finished making changes, click OK to save.
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Choosing icons for toolbar commands

Toolbar buttons usually have icons, not words, on them, but not all of the commands have
associated icons.

To choose an icon for a command, select the command and click Modify > Change icon. On the
Change Icon dialog, you can scroll through the available icons, select one, and click OK to assign
it to the command (Figure 6).

% Change Icon

Icons Impork...

HExXxAaLHEUSe AP E IS
PO sivBEYBEGCE HE T
m g M ESREYE YR DSEE
w"R¥OLIEFPFeDvOoO@eEs" .
PRI EH D ST @ e 758 -

Note:
The size of an icon should be 16x16 pixel to achieve best quality.
Different sized icons will be scaled automatically.

Delete

Help OK Cancel

Figure 6: Change Icon dialog

To use a custom icon, create it in a graphics program and import it into LibreOffice by clicking the
Import button on the Change Icon dialog. Custom icons should be 16 x 16 pixels in size to achieve
the best quality and should not contain more than 256 colors.

Example: Adding a Fax icon to a toolbar

You can customize LibreOffice so that a single click on an icon automatically sends the current
document as a fax.

1)

2)
3)
4)

5)

6)

Be sure the fax driver is installed. Consult the documentation for your fax modem for more
information.

Choose Tools > Options > LibreOffice Writer > Print. The dialog in Figure 7 opens.
Select the fax driver from the Fax list and click OK.

Right-click in the Standard toolbar. In the drop-down menu, choose Customize Toolbar.
The Toolbars page of the Customize dialog appears (Figure 4). Click Add.

On the Add Commands dialog (Figure 8), select Documents in the Category list, then
select Send Default Fax in the Commands list. Click Add. Now you can see the new icon
in the Commands list.

In the Commands list, click the up or down arrow button to position the new icon where you
want it. Click OK and then click Close.

Your toolbar now has a new icon to send the current document as a fax.
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Options - LibreOffice Writer - Print

> LibreOffice Contents Pages Comments
F Load/Save . .
» Language Settings Pictures and objects Left pages © None
M L|b|gg:f:;:]Wmer Form controls Right pages ") Comments only
View Page background Brochure 1 End of document
{ Formatting Aids i
| Grid Print text in black Right to Left End of page
{ Basic Fonts (Western) : - .
Basic Fonts (Asian) Hidden text In margins
Basic Fonts (CTL) Text placeholder
Print
Table Other
gzgln;?aer?son Print automatically inserted blank pages
Compatibility Paper tray from printer settings
AutoCaption
Mail Merge E-mail Fax E
» LibreOffice Writer/\Web -[N one]
> LibreOffice Base
» Charts Lexmark E232
> Internet LEPS0S0
Figure 7: Setting up LibreOffice for sending faxes
@ 0 Add Commands
To add a command to a toolbar, select the category and then the command. Then drag Add
the command to the Commands list of the Toolbars tab page in the Customize dialog.
Close
Category Commands
Edit = 4 Previous Mail Merge Entry = Help
Options &} Print
BASIC &4 Prink Directly

Description

Special Functions

Print Merged Documents

Insert Printer Settings
E Properties

E%:.rrinqaatte Recheck Document
Conltrols % gs\llr(;ad
Table
g S
mage
Dat;’ = Save Document
Frame Save Merged Documents
Text [El save Remote
Numbering “=3Send Default Fa
Modify Send E-Mail Messages
Internal Send Via Bluetooth

» LibreOffice Macros versions

Figure 8: Adding a Send Fax command to a toolbar

Assigning shortcut keys

In addition to using the built-in keyboard shortcuts (listed in Appendix A), you can define your own.
You can assign shortcuts to standard LibreOffice functions or your own macros and save them for
use with the entire LibreOffice suite.
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“ " Caution

Be careful when reassigning your operating system’s or LibreOffice’s predefined
shortcut keys. Many key assignments are universally understood shortcuts, such as
F1 for Help, and are always expected to provide certain results. Although you can
easily reset the shortcut key assignments to the LibreOffice defaults, changing some
common shortcut keys can cause confusion, especially if other users share your
computer.

To adapt shortcut keys to your needs, use the Customize dialog, as described below.
1) Select Tools > Customize > Keyboard. The Customize dialog (Figure 9) opens.

2) To have the shortcut key assignment available in all components of LibreOffice, select
LibreOffice in the upper right.

3) Next select the required function from the Category and Function lists.
4) Now select the desired shortcut keys in the Shortcut keys list and click the Modify button.

5) Click OK to accept the change. Now the chosen shortcut keys will execute the function
chosen in step 3 above whenever they are pressed.

e Note

All existing shortcut keys for the currently selected Function are listed in the Keys
selection box. If the Keys list is empty, it indicates that the chosen key combination is
free for use. If it were not, and you wanted to reassign a shortcut key combination that
is already in use, you must first delete the existing key.

Shortcut keys that are grayed-out in the listing on the Customize dialog, such as F1
and F10, are not available for reassignment.

Example: Assigning styles to shortcut keys

You can configure shortcut keys to quickly assign styles in your document. Some shortcuts are
predefined, such as Ctr/+0 for the Text body paragraph style, Ctrl+1 for the Heading 1 style, and
Ctrl+2 for Heading 2. You can modify these shortcuts and create your own.

1) Click Tools > Customize > Keyboard. The Keyboard page of the Customize dialog opens.

2) To have the shortcut key assignment available only with one component (for example,
Writer), select that component’s name in the upper right corner of the page; otherwise
select LibreOffice to make it available to every component.

3) Choose the shortcut keys you want to assign a style to. In this example, we have chosen
Ctrl+9. This enables the Modify button.

4) In the Functions section at the bottom of the dialog, scroll down in the Category list to
Styles. Click the expansion symbol (usually a + sign or triangle) to expand the list of styles.

5) Choose the category of style. (This example uses a paragraph style, but you can also
choose character styles and others.) The Function list will display the names of the
available styles for the selected category. The example shows some of LibreOffice’s
predefined styles.

6) To assign Ctrl+9 to be the shortcut key combination for the List 1 style, select List 1 in the
Function list, and then click Modify. Ctr/+9 now appears in the Keys list on the right, and
List 1 appears next to Ctr[+9 in the Shortcut keys box at the top.

7) Make any other required changes, and then click OK to save these settings and close the
dialog.
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Menus Context Menus | Keyboard | Toolbars | Events

Shortcut Keys ) LibreOFfice
cerl+2 Heading 2 - = .
Ctrl+3 Heading 3 @® writer
Cerl+4 Heading 4 »
Cerl+5 Heading 5 Modify
cerl+e
Ctrl+7 Delete
Ckrl+8
Cerl+A
ctrl+B Bold
cerl+C Save...
cerl+D Double Underline -

Crrl+FE Cantar i Reset

Functions
Cateqory Function Keys

Modify - |Index Heading NI CErl+9)
Internal Index Separator
P LibreOffice Macros List
¥ Skyles Lisk 1
Character List 1 Cont.
List 1End
Pages Lisk 1 Skart
Frame Lisk 2
Numbering Liskt 2 Cont.
Table List 2 End =
Cell Lichk T Chock 3

Figure 9: Defining keyboard shortcuts for applying styles

Saving changes to a file

Changes to the shortcut key assignments can be saved in a keyboard configuration file for use at a
later time, thus permitting you to create and apply different configurations as the need arises. To
save keyboard shortcuts to a file:

1) After making your keyboard shortcut assignments, click the Save button at the right of the
Customize dialog (Figure 9).

2) Inthe Save Keyboard Configuration dialog, select All files from the Save as Type list.

3) Next enter a name for the keyboard configuration file in the File name box, or select an
existing file from the list. If you need to, browse to find a file from another location.

4) Click Save. A confirmation dialog appears if you are about to overwrite an existing file,
otherwise there will be no feedback and the file will be saved.

Loading a saved keyboard configuration

To load a saved keyboard configuration file and replace your existing configuration, click the Load
button at the right of the Customize dialog, and then select the configuration file from the Load
Keyboard Configuration dialog.

Resetting the shortcut keys

To reset all of the keyboard shortcuts to their default values, click the Reset button near the bottom
right of the Customize dialog. Use this feature with care as no confirmation dialog will be displayed,;
the defaults will be set without any further notice or user input.
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Assighing macros to events

In LibreOffice, when something happens, we say that an event occurred. For example, a document
was opened, a key was pressed, or the mouse moved. You can associate a macro with an event,
so the macro is run when the event occurs. A common use is to assign the “open document” event
to run a macro that performs certain setup tasks for the document.

To associate a macro with an event, use the Events page of the Customize dialog. For more
information, see Chapter 13, Getting Started with Macros.

Adding functionality with extensions

An extension is a package that can be installed into LibreOffice to add new functionality and
improve your productivity with LibreOffice. Template sets, spelling dictionaries, clipart galleries,
macros, and dialog libraries can be packaged as LibreOffice extensions.

Several extensions are shipped bundled with LibreOffice and are installed with the program. These
can only be removed by changing the installation options. Others can be downloaded from various
websites. The official extension repository is located at http://extensions.libreoffice.org/. These
extensions are free of charge.

Some extensions from other sources are free of charge; others are available for a fee. Check the
descriptions to see what licenses and fees apply to the ones that interest you.

Installing extensions
Extensions can be installed in any of these ways:

» Directly from the *.oxt file in your system'’s file browser: double-click the file.

* From your web browser, if it can be configured to open this file type from a web page
hyperlink: select the hyperlink, and then select to Open the file.

In both cases, after the Extension Manager opens, a warning dialog opens for you to verify
the installation and then continue. The file is installed as a “user only” file in a multi-user
system.

» Directly from Tools > Extension Manager, as follows:

1) In LibreOffice, select Tools > Extension Manager from the menu bar. The option to view
the extensions bundled with LibreOffice can be deselected to view more easily those
installations that have been added by a user.

2) Inthe Extension Manager dialog (Figure 10), click Add.

3) Afile browser window opens. Find and select the extension you want to install and click
Open.

4) Users with administrator or root privileges will see a dialog where they can choose to install
extensions “for all users” (shared) or “only for me” (user). Normal users without those
privileges can install, remove, or modify extensions only for their own use (user).

5) The extension begins installing.

In all cases, during the process you may be asked to accept a license agreement. When the
installation is complete, the extension is listed in the Extension Manager dialog.

P ip

To get extensions that are listed in the repository, you can open the Extension
Manager and click the Get more extensions online link. You do not need to
download them separately.
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Figure 10: Using the Extension Manager
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