j LibreOffice

The Document Foundation

Writer Guide

Chapter 11
Using Mail Merge

Form Letters, Mailing Labels, and Envelopes



Copyright

This document is Copyright © 2011-2014 by the LibreOffice Documentation Team. Contributors
are listed below. You may distribute it and/or modify it under the terms of either the GNU General
Public License (http://www.gnu.org/licenses/gpl.html), version 3 or later, or the Creative Commons
Attribution License (http://creativecommons.org/licenses/by/4.0/), version 4.0 or later.

All trademarks within this guide belong to their legitimate owners.

Contributors

Ron Faile Jr.
Jean Hollis Weber
John A Smith

Feedback

Please direct any comments or suggestions about this document to the Documentation Team’s
mailing list: documentation@global.libreoffice.org

Note: Everything you send to a mailing list, including your email address and any other personal
information that is written in the message, is publicly archived and cannot be deleted.

Acknowledgments

This chapter is adapted and updated from Chapter 11 of the OpenOffice.org 3.3 Writer Guide. The
contributors to that chapter are:

Agnes Belzunce Dick Detwiler Peter Hillier-Brook
Peter Kupfer Alan Madden lain Roberts
Barbara M. Tobias Jean Hollis Weber Michele Zarri

Publication date and software version
Published 19 July 2014. Based on LibreOffice 4.2.

Note for Mac users

Some keystrokes and menu items are different on a Mac from those used in Windows and Linux.
The table below gives some common substitutions for the instructions in this chapter. For a more
detailed list, see the application Help.

Windows or Linux  Mac equivalent Effect
Tools > Options LibreOffice > Preferences Access setup options
menu selection
Right-click Control+click and/or right-click  Opens a context menu
depending on computer setup
Ctrl (Control) ¥ (Command) Used with other keys
F5 Shift+3+F5 Opens the Navigator
F11 B+T Opens the Styles and Formatting window

Documentation for LibreOffice is available at http://www.libreoffice.org/get-help/documentation


http://www.libreoffice.org/get-help/documentation
mailto:documentation@global.libreoffice.org
http://creativecommons.org/licenses/by/4.0/
http://www.gnu.org/licenses/gpl.html

Contents

O 0T 43T T | 0 N 2
(0] 01 171 01U (0] =3O PP P PP SSPPPPPPIN 2
== T | o = xS 2
ACKNOWIEAGMENTS. ... e e e e e e e e e e e e e e et e e e e e e e e e aaaaeeeeeanneans 2
Publication date and SOftWAIE VEISION.........ooiiiiiiiiiiiie et eeeeenes 2

NOtE fOr MAC USEIS... i e e nnnnnn 2

What iS Mail MEIrge?2...uuuiiiiiiiiiiiirrsnnsrsssssssssrssrsrrrr s ssssssssssrnnnnnnssss 4

Creating and registering the data SOUICE........cccccovniirissemmmmrs s 4

Deregistering @ data SOUFCE........cuuiiiiiiissemrnnnrrnnssssssssssss s sssssssss s s sssssssssssssssssssssnsnss 7

Re-registering an existing data SOUICEe.........ccecmmmmmrrrimninssssssrnssr s s esssnnes 7

Creating a form letter ... ————— 7
Editing Merged dOCUMENTS.........oiiiiiiite ettt e e e e e e e e e e e e e s enees 11

Printing mailing labels..........ccoi 11
Preparing fOr PrINTING.........eei e e e e e e et e e e e e e bbb a e s e e e e e e e e e e aaaaaaaana 11
Removing blank iN€s from 18DEIS. ..........ovviii e 14
101 (T o P PPPPP 15
Editing a saved file of Mailing 1aDIS...........uuiiiiiie e 15

T LT =T LYY Lo o = 16
Setting up enVElOPES FOI PIINTING. ....ceviiiiiieeeie e e e e e e e e e as 16
Merging and printing the ENVEIOPES. .........oooiiiiiee e 19
Creating an envelope tEMPIALE. ...........uuuiiiiiiiiiiii e e 19

Using the Mail Merge Wizard to create a form letter..........ccooevmmmmrriinniniissnnnennnnnnnnnnnnn. 20
Step 1: Select starting OCUMENT...........oiiiiiiiice e e e e e e e e e e eaeaes 20
Step 2: SeleCt OCUMEBNT TY P, ...ttt e e e e e e e e e e e e s 20
Step 3: INSert addreSS DIOCK. ... oo 21

Selecting the data source (AddreSs liSt)..........uu e 22
Selecting the address DIOCK...........oii e 22
1Y/ F= 1o a1 o TRt 4T ] (o 23
Step 4: Create SAlULALION...........ooi i e e e e e e e e a e aaa 24
STEP 5: AGJUST AYOUL. ...ttt e e e e e e e e e e e e s e s e e e e e e e enananns 26
Step 6: Edit document and insert extra fields. ..o 27
Step 7: PersonaliZe AOCUMENTS. ... .....uuuiiiiieie e e e e et e e e e e e e e e e e e e e et e e e et e e e et e eeenes 28
Step 8: SAVE, PIINE OF SENG. . ...ttt e e e e e e e et e e et e e e e e e ennnaes 29

Using Mail Merge 3



What is mail merge?

LibreOffice Writer provides very useful features to create and print:

* Multiple copies of a document to send to a list of different recipients (form letters)

* Mailing labels

* Envelopes
All these facilities, though different in application, are based around the concept of a registered
data source, from which is derived the variable address information necessary to their function.
This chapter describes the entire process. The steps include:

1) How to create and register a data source.

2) How to create and print form letters, mailing labels, and envelopes.

3) Optionally, how to save the output in an editable file instead of printing it directly.

Creating and registering the data source

A data source is a database containing the name and address records (and optionally other
information) from which a mailing list may be derived. Although you can create and print mailing
labels and envelopes without using a data source, in most cases using one is the best approach.
This chapter assumes that you are using a data source.

LibreOffice can access a wide variety of sources of data to create the database, including
spreadsheets, text files and databases such as MySQL, Adabas, and ODBC. If the information to
be used in the mail merge is currently in a format that LibreOffice cannot access directly, you need
to convert it, for example by exporting it to a comma-separated values (CSV) file.

For the following example we start with a spreadsheet with the following column (field) headers:
Title, First Name, Last Name, Address, State/County, Country, Post Code, Sex, and Points. A
sample of data is shown in Figure 1.

File Edit View Insert Format Tools Data Window Help
BrE-laFEEE T BB a9 @il e B
- [H | pefault | |Uberatonsans  [w] (10 [v] B 4 A 0p U= Ay
ES V £ 2 = | Exshire
A B | C | D E F | G | H | 1

1 |Title |First Mame Last Name Address State/County Country Post Code Sex Points
3 1, First Avenue

Mrs.  |Alice Azure Average Town Ampshire AAL 1AA F 67
! 2, Bottom Lane

Mr.  Brian Brown Bilborough Burkshire BB2 2BBE M 01

Figure 1: Spreadsheet data example

After being created as described below, for a data source to be directly accessible from within a
Writer document, it must be registered. You only need to do this once; after that, the data source is
available to all components of LibreOffice.

1) From within any Writer document, or from the LibreOffice Start Center, choose File >
Wizards > Address Data Source.
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2) The choices on the first page of the wizard vary with your operating system. Select the
appropriate type of external address book. In this example, it is Other external data
source. Click Next.

L T
Address Book Data Source Wizard
Steps LibreOffice lets you access address data already present in your system. To do this, a
LibreCffice data source will be created in which your address data is available in
1. Address book type tabular form.
2, Connection Settings This wizard helps you create the data source.

3. Table selection

Flease select the type of yvour external address book:

Eld Assignimer () Mozilla f Metscape
5. Data Source Title {3 Thunderbird fTcedove
() LDAP address data
() outlook address book

) Windows system address book
(%) Other external data source!

Figure 2: Select type of external address book

1
i
L
T

Cancel

3) On the next page of the Wizard, click the Settings button.

[§ Address Book Data Source Wizard
Steps To set up the new data source, additional information is required.
1. Address book type Click the following button to open another dialog in which you then enter the

. . necessary information.
2.Connection Settings

3.Table s
4. Field Assignment
5.Data Source Title

ection

Figure 3: Starting the Settings part of the Wizard

4) Inthe Data Source Properties page, select the Database type. In our example, it is
Spreadsheet. Click Next.

[§ DataSource Properties: Spreadsheet

Select the type of database to which you want to establish a connection.

Database type Spreadsheet v

On the following pages, you can make detailed settings for the connection.

The new settings you make will overwrite your existing settings.

Figure 4: Selecting the database type
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5) In the next dialog, click Browse and navigate to the spreadsheet that contains the address
information. Select the spreadsheet and click Open to return to this dialog. At this time you
may wish to test that the connection has been correctly established by clicking on the Test
Connection button (not shown in illustration).

[§ Database properties - Connection settings =

General

Path to the spreadsheet document

|fh ome/jeanweber/Documents/Addresses.ods

Figure 5: Selecting the spreadsheet document

6) Click Finish.

7) On the following page, click Next. Because this is a spreadsheet, do not click Field

Assignment.

[§ Address Book Data Source Wizard

B

Steps

1. Address book type
2. Connection Settings
3. Table selection

4. Field Assignment
5.Data Source Title

To incorporate the address data in your templates, LibreOffice has to know
which fields contain which data.

For instance, you could have stored the e-mail addresses in a field named
"email”, or "E-mail" or "EM" - or something completely different.

Click the button below to open another dialog where you can enter the settings
for your data source.

There are no fields assigned at this time.
You can either assign fields now or do so later by first choosing:
"File - Template - Address Book Source..."

Figure 6: Because this is a spreadsheet, do not click Field Assignment

8) A database file will be created. Name the file in the path in the Location field. The default is
Addresses.odb; but you may replace Addresses with another name if you wish. You may
also change the name in the “Address book name” field. The name in this field is the
registered name, which LibreOffice will display in data source listings. In our example, the
name “Points” was used for both.

[§ Address Book Data Source Wizard

ES

Steps

1. Address book type
2.Connection Settings
3. Table selection

4. Field Assignment
5.Data Source Title

That was all the information necessary to integrate your address data into
LibreOffice.

Now, just enter the name under which you want to register the data source in
LibreOffice.

Location

| \homeljeanweber\Documents\Points.odb

Make this address book available to all modules in LibreOffice.
Address book name

| Points

Figure 7: Name the .odb file and the address book

9) Click Finish. The data source is now registered.
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Deregistering a data source

To remove a registered data source from LibreOffice so it is no longer available for use, as for
example an obsolete address list, do the following:

1) Open the Data sources window (by selecting View > Data Sources from the Menu bar, or
by pressing F4, or by selecting the Data Sources icon on the Standard toolbar).

2) Inthe left pane, the Data source explorer, right-click a data source.

3) Select Registered databases from the context menu.

4) In the Registered databases dialog which opens, select the data source to be removed.
5) Click Delete, then click Yes in the confirmation box which opens.

6) Repeat steps 4) and 5) as required.

7) Click OK to close the Registered databases dialog.

This does not delete the database from your system. It can be registered again using the methods
outlined below.

Re-registering an existing data source

To re-register an existing database file of addresses do the following:

1) Open the Data sources window (by selecting View > Data Sources from the Menu bar, or
by pressing F4, or by selecting the Data Sources icon on the Standard toolbar).

2) In the left pane, the Data source explorer, right-click a data source.
3) Select Registered databases from the context menu.
4) In the Registered databases dialog which opens, click the New button

5) In the Create Database Link dialog which opens, click the Browse button and navigate to
the database file location and select it. Click the Open button to return to the Create
Database Link dialog.

6) Change the Registered name if required.
7) Click the OK button to exit this dialog.
8) Click the OK button to exit the Registered databases dialog.

Creating a form letter

Example: Sending a letter to your customer base

A mail order company organized a campaign to assign credit points to their
customers according to the quantity of goods they buy during one year.

At the end of the year, they want to send a letter to each customer to show the total
of credit points collected.

You can create a form letter manually, which is the simplest and most comprehensive method and
is described here, or you can use the Mail Merge wizard as described in “Using the Mail Merge
Wizard to create a form letter” starting on page 20. If you elect to use the wizard, pay close
attention to its current limitations, as identified within its description.

1) Create a new text document: File > New > Text Document, or open a pre-existing form
letter with File > Open.

2) Display the registered data sources: View > Data sources (or press F4).

Creating a form letter



3) Find the data source that you wish to use for the form letter, in this case Points. Expand
the Points and Tables folders, and select Sheetl. The address data file is displayed.

File Edit View Insert Format Table Tools Window Help
BE-re-dallEEa TS B-a 2E-P @@
|_a Default Style V Liberation Sans V 12 V B A & @ E @ - A~

& QE-IHiWi %V B oo
7 13 Addresses | Title | FirstName | LastName | Address | State/County | Country |
T @Bibliugraphy ] B Mrs. Alice Azure 1, First Aver Ampshire i
+ @ Emailaddresses M. Brian Brown 2, Bottom Lz|Burkshire 3
L @ Point _|mr. Charles Coffee 3,Carter Cre Cropshire {
ints ] __|Mrs. Daoriz Damson 4, Deepdale Deepshire [
# 45 Queries Ll [ [Mr. Edward Eatmore 5, Elizabeth | Exshire f
Mr, Frederick Fairhead &, Foresight | Fineshire f
¥l Record| 1 [ofs [»][m]

Figure 8: Selecting the data source

4) Now create or modify the form letter by typing in the text, punctuation, line breaks, and so
on that will be present in all of the letters.

To add the mail-merge fields where needed (such as names and addresses), click in the
field heading and drag it to the appropriate point in the letter.

Note that address lines should be in individual paragraphs, not separated by line breaks as
might seem preferable. The reason for this will be made clear in the next step.

¢ o
Title | Firstkame | Last Name |
B [Mrs. Alice Azure 1, First Aveni
Mr. Erian Brown 2, Bottom Lar
Mr. Charles Coffee 3, Carter Cre
Mrs, Doris Damson 4, Deepdale |
Mr. Edward Eatmore 5, Elizabeth =
Click on dafa source Mr. Frederic Fairhead &, Foresight !
headings here... Mr. George Green 7, Great Auk
Rewdi  [or  ®  WWLI
..and drag to here to .
inzert fields in form letter E = 1 = g = i = 1

To

——® - Tiilew -<Firs-Name= -<Last-Name=T
T . Address=-T

e SiateCounty=-T

3 —Post-Code=T

= | Countryz-T

Figure 9: Dragging fields to the body of the form letter

5) Continue until you have composed the entire document. At this time you may wish to
consider suppressing any blank lines that may appear in the resulting letters. If not, skip
ahead to Step 7.
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ITD:'J ]

= Title=-=Firsg-Name> -<Last-Name="T

<Address=1

=otateCounty=T

=Post-Code=T

= Country=T

I - .

5-November-20071

| ; 3

Dear = Titlem ~Last-Name= 1

Thank-you-very-much-for-your-particpation-in-our-“ Points”-promotion. - We-are-pleased
|1':D-I'.ufﬂrm-yﬂu-thﬂt—ynu-hﬂ.ve-ﬂarnﬂd- =FPoints=-thisvearT

in:rur loyalty-to-our -company -1s-greaty-apprecated-and-we-hope-to-be-of cononung
servicein-thefuturs. T

|

Yours-sincerdyT

(General -Supply-ple-
Wetherbridge -+ XEXT-17Y7

Figure 10: The completed form letter

6) To suppress blank lines:
a) Click at the end of the first paragraph to be suppressed if empty, and then choose
Insert > Fields > Other to display the Fields dialog.

b) Select the Functions tab and then click on Hidden Paragraph in the Type column.

Fields ﬁ1

Document | Cross-references |Functhrls|DocInforrnation Variables | Database

Type Format Condition

Conditional text I[Points.Sheetl.Last Name]
Input list
Input field Jal
Execute macro
Placeholder
Combine characters
Hidden text

Hidden Paragraph

oot ) (_cose ] [_sob ]

Figure 11: Hidden paragraph insertion
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c) Now click in the Condition box and enter the details of the condition that defines a
blank address field. It has the general form of:

| [Database.Table.Database field]

where the ‘' (NOT) character indicates the negative case and the square brackets
indicate the condition.

For example, in our Points database the condition to test if the Last Name field is
empty would be:

I [Points.Sheetl.Last Name] as illustrated in Figure 11.
To test for multiple conditions use the operators AND and/or OR between the

conditional statements, for example:
I[Points.Sheetl.Title]AND![Points.Sheetl.Last Name]

d) Click Insert, but do not close the dialog until you have amended all the lines that
should be suppressed.

7) The document is now ready to be printed.
a) Choose File > Print and respond with Yes in the message box.

W Your document contains address database fields. Do you want to print a form letter?

dee J[ wo [ e

Figure 12: Mail merge confirmation message

b) In the Mail Merge dialog (Figure 13), you can choose to print all records or selected
records. To select records to be printed, use Ctrl+click to select individual records. To
select a block of records, select the first record in the block, scroll to the last record in
the block, and Shift+click on the last record.

c) Click OK to send the letters directly to the printer. Or, you can save the letters to a file
for further editing or formatting; see “Editing merged documents” below.

d) If you have not saved the original, prototype form letter document (template) previously,
then you should do so now. Having a form letter template could greatly simplify the
creation of other form letters in the future and is highly recommended.

-~

..
Mail Merge [
e = -] -]
: Q G- ®elzel | w7 EJ
- £9 points ”~ | Title | First Name | Last Mame | Address | State/County | Country | Post
¥ 43 Queries | b {Mrs, | Alice Azure 1, First Aver Ampshire AA A
L % Tables Mr. Erian Brown 2, Bottom Lz Burkshire BE[ =]
= o N Mr. Charles Coffes 3,Carter Cre Cropshire CC
P - st Mrs, Doris Diamson 4, Deepdale | Despshire DD| |
LS 2 Record| 1 [of6(2) (k](m] (% >
Records Cutput
) all (¥} Printer ) File
(*) selected records
{}Ercum: 1 To: 1 R - S
Save as sinale documer

Figure 13: The Mail Merge dialog
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Editing merged documents

You may prefer to save the letters to a file, to allow for proofreading or some later formatting. To do

this:
1)

2)

3)

In the Mail Merge dialog (Figure 13), select File in the output section, instead of using the
default Printer selection.

This changes the dialog to display the Save merged document section, where Save as
single document is preselected. You can choose to save each letter as an individual
document instead.

Sawve merged document
{(*) 5ave as single document

(") save as individual documents

Click OK. In the Save as dialog, enter a file name for the saved letters and choose a folder
in which to save them. The letters will be saved consecutively as separate pages in the
single document, or numbered consecutively in individual files if saved as individual
documents.

You can now open the letters and edit them individually as you would edit any other document.

Printing mailing labels

Before beginning this process, note the brand and type of labels you intend to use.

Preparing for printing

To prepare mailing labels for printing:

1)
2)
3)

4)

Choose File > New > Labels.
On the Options tab, ensure that the Synchronize contents option is selected.

On the Labels tab (Figure 15), select the Database and Table. Select the Brand of labels
to be used, and then select the Type of label.

If you are unable to identify your label product in the list, then you can define the labels you
have. Select the User setting in the Type selection box. Click on the Format tab of the
Labels dialog. The default settings are shown in Figure 16. Take a ruler and measure on
your labels those dimensions illustrated in Figure 14, and enter them into the respective
boxes on the left side.

Left maragin H. Pitch
. ) L
Top margin
Aitidth
"|'I. P|t|:h Rclll,l.lls
Height
P L J
Columns

Figure 14: Required information for label set-up
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¥ 1

Labels
Labels |Furmat Cptions
Inscription
Label text [ Address Database
BN IPaints ]|
Table
L ISheett ]|
Database field
v| [« | ]
[i] 1 [i]
Farmat
() Continuous Brand |.-5.'-.-'ery A4 [i“
@ sheet Type 138160 Address ]
15160 Address: 2.50"x 150" (3x 7)
Cancel ] [ Help ] [ Reset ]

Figure 15: Select Database, Table, label Brand, and label Type

o 1
Te—
Labels
|Labe|s|FDrlTlat bpﬁons|
Horizontal pitch | 004 [%] Avery A4 [User]
Vertical pitch 150" |4
Width 3.90" |4 Lef'tmargip H.F;ib:h
Height 150" [%] 1
Top margin
Left margin 0.13" {i}
Fidth
Top marain 0.60" {i} el
) Rows
Columns 2 =) V. Pitch
Rows 7 {i} Heipht
Page Width 8.27" (%] B ¥
Page Height 11.69" [&] Columns

Figure 16: User label default settings

5) You can now save your label template if you are likely to use it again. Click Save.

6) Inthe Save Label Format dialog that opens (Figure 17), enter names for your label Brand
and Type. Click OK.
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Save Label Format

Qptions
Brand Genericy|
Type Tu2sheet

Cancel

Figure 17: Name and save the label.

7) Click the Labels tab. Click the drop-down arrow under Database field. Select the first field
to be used in the label (in this example, Title). Click the left arrow button to move this field

to the Label text area, as shown in Figure 18.

Figure 18: Move fields from Database field list

to Label text area

..-ElFurmat Options
Inscription
Label text [] Address Database
<Paints,Sheet 1.0, Title > [~ IPaints ]|
Table
L ISheett B
Database field
v (€] [rite (]
<] i [*]

8) Continue adding fields and inserting desired punctuation, spaces, and line breaks until the
label is composed. Figure 19 shows the completed label.

| Format || Options

«<Points.Sheetl.0.Country =

Inscription
Label text [] address Database
<Points.Sheet1.0.Title > <Points.Shet[a | Paints ]
<Points.Sheetl1.0. Address >
«<Points,5heet1.0.5tate/County = Table
<Points,Sheetl,0.Post Code =
Isheett ]

Database field

E 4u |Cu:uunh'1,-' B"
(<] m 2]
Farmat
) Continuous Brand |.-5.very A4 B"
© gheet Type 38160 Address v

13160 Address: 2.50" x 1.50" (3x 7)

[ Mew Document l [ Cancel

J[_ oo |

Reset

Figure 19: The completed label
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9)

Click New Document. You now have a new, single-page document containing a series of
frames, one for each label of the selected type and filled with the data source address
fields that you selected. Quite often some of the fields in your address data source will be
unused, leading to blank lines in your labels. If this is not important, go to “Printing” on page
15; otherwise, continue with “Removing blank lines from labels”.

Removing blank lines from labels

1)

2)

3)

First ensure that the label frames are showing the field contents (data source headings),
rather than their underlying field names. If this is not the case, then either press Ctrl+F9 or
choose View > Field Names to toggle the view.

Next, ensure that you can see non-printing characters, such as paragraph marks, line
breaks and so on. If these are not already visible, choose View > Nonprinting Characters
from the Menu bar, or press Ctrl+F10, or click on the Nonprinting Characters icon ( T )
on the Standard toolbar.

You will now see that address field separation is created by line breaks ( =), rather than
paragraphs ('ﬂ). As the suppression of blank address fields depends on hiding paragraphs,
not lines, you need to replace line breaks with paragraphs as follows.

Click in the first label, at the end of the last data source address field in the first line of the
label. Press Delete to remove the new line character and then press Return (or the Enter
key) to insert a paragraph marker. Repeat this action for each line in the address.

If the line spacing in the first label is not satisfactory, you may wish to correct this before
proceeding, by modifying the paragraph style associated with the address. Unless you
have changed it, the address uses the Default style.

The objective of step 3) is to replace all line breaks at the end of data source

Caution address fields with paragraphs. Sometimes the address data field may be longer
ﬁ than the width of the label and will wrap to the next physical line: make sure that

4)

5)

you are not misled by this into deleting and replacing anything other than line
break characters.

Click again at the end of the first paragraph to be conditionally suppressed and then
choose Insert > Fields > Other. Select the Functions tab and then click on Hidden
Paragraph in the Type column. Now click in the Condition box and enter the details of the
condition that defines a blank address field. It has the general form of:

| [Database.Table.Database field]

where the ‘' (NOT) character indicates the negative case and the square brackets indicate
the condition.

For example, in our Points database the condition to test if the Last Name field is empty
would be

I[Points.Sheetl.Last Name] as illustrated in Figure 11.

To test for multiple conditions, use the operators AND and/or OR between the conditional
statements, for example:

I[Points.Sheetl1.Title]AND![Points.Sheetl.Last Name]
Click Insert, but do not close the dialog until all lines have been amended.
Repeat for each paragraph to be conditionally suppressed, remembering to advance the

cursor to the end of the line in question before changing the last element of the condition
and Inserting the result.

14
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The last paragraph of the label address block ends with a special field,
Next record:Database.Table (Next record:Points.Sheetlinour

Caution example), and the Hidden paragraph field must be inserted before this field. This
can generally be accomplished by clicking at the end of the paragraph and then
using the Left Arrow key once to skip back over it.

A clue that you omitted this action is the observation that some records have been
skipped and are missing from the final output.

6) Remembering that we selected Synchronize contents
earlier, you should now be able to see a small window
containing a Synchronize Labels button. Click on this | Synchronize Labels
button and the hidden paragraph fields are propagated
to all the labels in your document.

You now have a template suitable for future use with the same data source and type of
label. If you wish to save it, use File > Templates > Save as Template to save it as an
Open Document Text Template (.ott) into the My Templates folder in the Templates
Manager dialog.

Printing
1) Choose File > Print. The message shown in Figure 12 appears. Click Yes to print.

2) In the Mail Merge dialog (Figure 13), you can choose to print all records or selected
records. To select records to be printed, use Ctrl+click to select individual records. To select
a block of records, select the first record in the block, scroll to the last record in the block,
and Shift+click on the last record.

3) Click OK to send the labels directly to the printer.

If you prefer to save the labels to a file, perhaps to allow some later editing such as
changing the typeface or paragraph format, then you should select File in the output
section of the Mail Merge dialog, rather than using the default Printer selection. This
changes the dialog to highlight the Save merged document section, where Save as single
document is preselected.

In this case, clicking OK brings up the Save as dialog, where a file name can be entered for
the saved labels.

If you did not save the prototype label fields document (template) in Step 6 of the
Removing blank lines from documents paragraph, then you are prompted to do so now by
another Save as dialog.

In either case, whether printing or saving to file, despite there apparently being only one
page of labels, the printed or saved output will be expanded to include all of the selected
records from the data source.

Editing a saved file of mailing labels

To edit a saved file of mailing labels, open the saved label file in the normal way. You will be
prompted to update all links. Choose No for the following reason: The first label on the page is
termed the “Master Label” and all other labels are linked to it. If you update the links, then all labels
will end up containing the same data, which is probably not what you want.

You can edit individual records in the normal way, by highlighting and changing the font name, for
example.

However, you cannot edit all labels globally (for example, to change the font name for all records)
by the technique of selecting the entire document. To achieve this result you have to edit the
paragraph style associated with the label records as follows.
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1) Right-click any correctly spelled word in a label record. Select Edit Paragraph Style from
the context menu. (Note: If you click on a misspelled word, a different menu appears.)

2) Then from the Paragraph Style dialog, you can make changes to the font name, the font
size, the indents, and other attributes.

Printing envelopes

Instead of printing mailing labels, you may wish to print directly onto envelopes. By selecting Insert
> Envelope from the Menu bar, you may select one of two methods for their production. The first is
where the envelope is embedded within a letter, generally as the first page (Insert in the Envelope
dialog), and the second is where the envelope is an independent document (New Document in the
dialog). In each case the addressing data may be manually entered, for example by copying and
pasting from the letter with which it is associated, or it may originate within an address data source.

This section assumes the use of an address data source and, for convenience, a free-standing
envelope. The production of envelopes involves two steps, setup and printing.

Setting up envelopes for printing

1) Choose Insert > Envelope from the Menu bar.

2) Inthe Envelope dialog, select the Format tab (Figure 20), where you can select the
envelope format to use. You can then arrange the layout of the envelope to suit your
requirements, together with the character and paragraph attributes to be used in the
Sender and Addressee areas. These attributes are accessed using the Edit buttons to the
right of the dialog, next to the word Format.

-~

.,

Envelope
Envelope |Format Printer
Addressee
Position
Sl 1357 ¢ Format
fromtop |2.47° [ Character...
Paragraph. ..
Sender
Position
fromleft lo.39" [&1 Format
fromtop |g,39" [2]
Size
Format DL Envelope V
wdtr  [s.66" (3] B O
Height 433" 2] -
Mew Document ] I Insert ] ’ Cancel ] I Help ] [ Reset

Figure 20: Envelope formatting dialog
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If the list of envelope formats in the Size section of this dialog does not include the
Note size you need, choose User Defined (at the bottom of the list) and specify the
envelope size using the Width and Height boxes.

At this stage it is only possible to vary the position of the origin points (upper left
corners) of the frames that will hold the Sender and Addressee information, but
once the envelope has been created, full adjustment of size and position will
become possible and you may wish to make some cosmetic adjustments.

Tip

3) The next step is to select the Printer tab (Figure 21), from where you may choose the
printer you intend to use, its setup—for example, specification of the tray holding envelopes
—and other printer-related options such as envelope orientation and shifting. You may
need to experiment with these settings to achieve the best results with your printer.

Envelope H

Envelope |Format |Printer

Envelope orientation

| =| L= =1 L
T il il H}‘

(%) Print from top

) Print from bottom

Shift right 0.00"

ol <]

A

Shift down 0.00"

‘}

Current Printer
EPS0M Stylus DXE400 Series

Figure 21: Choosing printer options for an envelope

4) Select the Envelope tab (Figure 22).

5) Choose whether or not to add Sender information to the envelope by selecting or
deselecting the Sender option. If wanted, edit the information in the Sender box (Sender is
the “from” on the envelope).

6) You now have the choice of creating the Addressee fields by dragging and dropping from
the data source headings (as described in “Creating a form letter” on page 7, and in
particular in Figure 9) or using the facilities of the Envelope tab.

7) If you prefer dragging and dropping, then click New Document, drag your data source
headings into the Addressee area on your new envelope and skip to step 10), otherwise
continue with the next step.

8) Verify, add, or edit the information in the Addressee box. You can use the right-hand drop-
down lists to select the database and table from which you can access the Addressee
information, in a similar fashion to that described for “Printing mailing labels”, paragraphs 3,
4 and 5. The similarity of the method with Figure 18 and Figure 19 will be clear.
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Envelope

Envelope Format ||Printer

Addresses Database

<Points.Sheet1.0.Tite > <Poini|a Points "
<Points.Sheet1.0. Address >
<Points.5heet1,0.5tate/County

<Points.Sheet1.0.Post Code > Table
‘ Sheetl w

Database field

< > Post Code iV]
Title
Sender First Mame
- Last Mame
John Smith
enn s & Address
State fCounty
Country
Fost Code %
SEX
Points
I

Figure 22: Choosing addressee and sender information for envelopes

9) When you have finished formatting, click either the New Document or Insert button to
finish. As might be expected, New Document creates only the envelope template in a new
document, whereas Insert inserts the envelope into your current document as page 1.

If you don’t want to proceed with this envelope, click Cancel or press the Esc key. You can
also click Reset to remove your changes and return to the original settings extant when the
dialog opened.

You can now modify the placement of the frames containing the sender and addressee
information, or make further changes to the character and paragraph attributes (for
example, the font) or add a logo or other graphic to the envelope.

If you frequently print envelopes from the same database onto the same size
Tip envelopes, at this point you may wish to create a template from this setup. See
“Creating an envelope template” on page 19.

10) Quite often some of the fields in your address data source will be unused, leading to blank
lines in your envelope Addressee area. If this is not important, you can skip the next few

paragraphs and go straight to “Merging and printing the envelopes” on page 19, otherwise
continue as described here.

The following procedure is very similar to that used for a similar purpose in the

Note section on printing mailing labels. It is reproduced here for ease of reference.

a) First ensure that the envelope is showing the field contents (data source headings),
rather than their underlying field names. If this is not the case, then either press
Ctrl+F9 or choose View > Field Names to toggle the view.
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b)

d)

e)

Next, ensure that you can see non-printing characters, such as paragraph marks, line
breaks and so on. If these are not already visible, choose View > Nonprinting
Characters from the menu bar, or press Ctrl+F10, or click on the Nonprinting

Characters icon ( T ) on the Standard toolbar.

You will now see that address field separation is created by line breaks (=), rather

than paragraphs ('ﬂ). As the suppression of blank address fields depends on hiding
paragraphs, not lines, you need to replace line breaks with paragraphs as follows.

Click at the end of the last data source address field in the first line of the envelope.
Press Delete to remove the new line character and then press Return (or the Enter
key) to insert a paragraph. Repeat this action for each line of the envelope.

If the line spacing in the Addressee area is not satisfactory, you may wish to correct
this before proceeding, by modifying the paragraph style associated with the address.
Unless you have changed it, the address uses the Default style.

Click again at the end of the first paragraph to be conditionally suppressed and then
choose Insert > Fields > Other. Select the Functions tab and then click on Hidden
Paragraph in the Type column. Now click in the Condition box and enter the details
of the condition that defines a blank address field. It has the general form of:

I [Database.Table.Database field]

where the ‘' (NOT) character indicates the negative case and the square brackets
indicate the condition.

For example, in our Points database the condition to test if the Last Name field is
empty would be:

I [Points.Sheetl.Last Name] as illustrated in Figure 11.

To test for multiple conditions, use the operators AND and/or OR between the
conditional statements, for example:

I[Points.Sheetl.Title]AND! [Points.Sheetl.Last Name]

Click Insert, but do not close the dialog until all lines have been amended.

Repeat for each paragraph to be conditionally suppressed, remembering to advance
the cursor to the end of the line in question before changing the last element of the
condition and Inserting the result.

Merging and printing the envelopes

To merge addresses and print the envelopes:
1) Choose File > Print. A message box (Figure 12) appears. Click Yes to print.

2) The Mail Merge dialog (Figure 13) appears. As with form letters and mailing labels, you can
choose to print envelopes for one, several or all address records in the database.

3) Make your selections and then click OK to print direct to the printer. To check the envelopes
before printing them, see “Editing merged documents” on page 11 for instructions.

Creating an envelope template

When your envelope layout and fields are complete to your satisfaction, you can save the result as

a template.

1) Choose File > Templates > Save As Template.
2) Inthe Template Manager dialog, select My Templates and click on Save.
3) Enter a name in the text input box and click OK to save the template.
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Using the Mail Merge Wizard to create a form letter

The manual method of creating a form letter described in “Creating a form letter” on page 7
provides the most control over the result and is therefore recommended. If you prefer to use the
Mail Merge wizard, the technique is described below.

Open a new document with File > New > Text Document and start the Mail Merge wizard using
Tools > Mail Merge Wizard. The wizard opens, as shown in Figure 23.

Step 1: Select starting document
The wizard gives various options to select your starting document:
* Use the current document.
* Create a new document.
e Start with an existing document.
e Start from a template.

For the purposes of this description, we assume that you opened a new text document. This will
ensure that all the steps in the wizard are fully explored, although with experience you may find it
more practical to use a draft you prepared earlier, which will allow for the skipping of some steps.

Select Use the current document and click Next.

oo =1
Mail Merge Wizard
Steps Select starting document for the mail merge
1. iSelect starting document: Select the document upon which to base the mail merge document

2. Select document type
tp {#) Uze the current document

3. Insert address block

(") Create a new document
4, Create salutation

5. Adjust layout (") Start with existing document Browse...

6. Edit document (") Start from a template Browse...
7. Personalise document

8. Save, print or send

Figure 23: Select starting document

Step 2: Select document type

The wizard can produce letters or, if a Java Mail connection exists, email messages. In this
example, we are producing a letter. Select Letter and click Next.
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Mail Merge Wizard

What type of document do you want to create?

5, Adjust layout

Figure 24: Choose document type

Step 3: Insert address block

Steps
{E} Letter
1. Select starting document
2.:5elect document type! () E-mail message
3. Insert address block Send letters to a group of recipients. The letters can contain an address blodk and a salutation.
4, Create salutation The letters can be personalized for each recipient.

This is the most complex step in the wizard. In this step (Figure 25) you will do three things:
1) Tell the wizard which data source to use. The data source must be an existing file; in this

example it is the “Points” spreadsheet created earlier.

2) Select the address block to use in the document. This means choosing which fields appear
(for example, whether the country is included) and how they look.

3) Make sure that the fields all match correctly. This is very important. For example, the UK
English version of the wizard has a field called <Surname>. If your spreadsheet has a

column called “Last Name”, you need to tell the wizard that <Surname> and “Last Name”

are equivalent. This is described in “Matching the fields” on page 23.

3. Insert address block

; 2 This document must contain an address blodk
4. Creats sautation

<Title> <Forename> <surmamd <Titke >

<Couniry = <Country =
[] suppress lines with empty fields

7. Personalise document

8. Save, print or send

5. Adjust layout < Address Ling 1= <Forename> <Sumame >
: <Regon:> <Address Line 1>
6. Edit document <Postrade <Pastcode> <City>

Mail Merge Wizard ﬁ
Steps Insert address block
1. Select starting document 1. 1. Select the address list containing the address dats Sl P e i
you want to use, This data is needed to ceats the = entAddress List... |
st aiess Hock. Current address list: Points

your data source,

4, Check that the address data matches.

3. Match the field name used in the mail merge to the column headers in

Mrs. Alce Azdre
1, First Avenue
Average Town
Ampshire
AAL 144
Dooument: 1 [4][x]
= ot I moo> ] o

Figure 25: Insert address block

Using the Mail Merge Wizard to create a form letter
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Selecting the data source (address list)

1)

2)

3)

If the current address list, identified beneath the Select Different Address List button in
section 1, is not the one you wish to use, click the button to open the Select Address List
dialog (Figure 26) for choosing a data source.

If you have not already created the address list, you may click Create to do so now. This
step will allow you to create a CSV (Comma Separated Values) file with a new list of
address records.

If you have an address list that is not registered in LibreOffice, but which you wish to use,
click Add and select the file from the location in which it is saved.
In each of the above cases a new data source (ODB file) will be created and registered.

Select the address list and click OK to return to step 3 of the wizard. We retain “Points” as
our address book for this example. The wizard can also exclude certain records; click Filter
to choose them.

T 1
Select Address List
Select an address list. Click 'Add..." to select recipients fram a different list. If you do not have an
address list you can create one by dicking 'Create...".
Your recpients are selected from:
MName Table | [ Add.. ]
AddressBook
Foints Shesti [ Create. .. |
| Eier... |
l K l [ Cancel ] [ Help

Figure 26: Select address list dialog

Selecting the address block

1)

2)

In section 2 (shown in Figure 25), select the address block to appear on the letter, define its
appearance, and choose the fields it contains. The main page gives two choices. Click
More to open the Select Address Block dialog for more choices.

The Select Address Block dialog (Figure 27) displays the original two blocks plus other
choices for the format of the address block (you may need to scroll down to see all of the
choices). You can also optionally include or exclude the country (for example, only include
the country if it is not England) in the Address block settings. The formats provided are
relatively common, but they might not exactly match your preference. If this is the case,
select the address block that is closest to what you want and click Edit, which opens the
Edit Address Block dialog.
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Select Address Block

Select your preferred address block

<Title = <Forename> <Surnamex
<Address Line 1=

<Region=

<Postrode =

<Country >

<Company Mame =
<Farename > <Surname =
<Address Line 1=
“Postcode > < City >

«Title »

<Forename> <Surname =
«<Address Line 1=
«Postcode = < City =
<Country =

<Company Mame >
<Forename> <Surname =
«<Address Line 1=
<Postcode > < City >

< Country =

Address block settings
() Mever indude the country/region

() Always indude the country/region
{(*) Only indude the country/region if it is not:

England

Figure 27: Select address block

3) In the Edit Address Block dialog, you can add or delete address elements using the arrow
buttons on the left. To move elements around, use the arrow buttons on the right. For
example, to add an extra space between forename and surname in Figure 28, click
<Surname> and then click the right arrow button.

Company Mame
Address Line 1
Address Line 2
City

Region

Postoode

Country

Telephone private
Telephone business
E-mail Address

Surname

Preview

Mrs, Alice Azure
1, First Avenue
Average Town

Edit Address Block
Address elements 1, Drag address elements here
Title <Title > <Forename > <Surname m
Forename <Address Line 1= .

Gender

Figure 28: Edit address block

Matching the fields

Finally, it is time to match the wizard's fields with the spreadsheet fields, so that items like
<Surname> and “Last Name” match correctly.

1) Look at section 3 of the wizard (shown in Figure 25 on page 21). The box at the bottom
displays one record at a time, using the address block format you specified. Use the right
and left arrow buttons below that address box to step through the addresses, checking that
they display correctly. Do not assume that all the records display correctly, just because
one or two do. Check them all if you can, or at least a good proportion.
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2) If the addresses do not display correctly (and they probably will not right away), click Match
Fields.

3) The Match Fields dialog (Figure 29) has three columns:

* Address Elements are the terms the wizard uses for each field, such as
<Forename> and <Surname>.

e Use the Matches to Field column to select, for each address element, the field from
your data source that matches it.

* The Preview column shows what will be shown for this field from the selected
address block, so you can double-check that the match is correct.

4) When you have matched all the fields, click OK to return to step 3 of the wizard. Now, when
you use the arrow buttons to look at all the addresses, they should all look correct. If not,
go back and change anything you're not happy with, before clicking Next to move to step 4.

Note that you will not be able to continue until you have correctly matched all the fields in
your chosen address block. If you see <not yet matched> in a field position it indicates that
the field in question is not correctly matched.

Match Fields

Assign the fields from your data source to match the address elements.

Address elements Matches to field: Preview |
S
<Title = Tite » | Mrs,
<Forename = First Mame Lv Alice
<Surname = {ast Mame v | Azure
Last Mame Y
<Company Mame > Address
State fCounty
<Address Line 1= Country 1, First Avenue Average ...
Post Code hl
<Address Line 2= nane e w
Address block preview

Mrs, Alice Azure
1, First Avenue
Average Town

[ Ok ] [ Cancel ] [ Help ]

Figure 29: Match fields dialog

5) Notice the option for Suppress lines with empty fields in section 2 of Figure 25. Using
the Wizard, you do not have to create your own conditional suppression fields.

Step 4: Create salutation
It is possible to create just about any salutation you want in this step.

By selecting the This document should contain a salutation option, the General salutation list
box is enabled. Some general texts are available in the list box, or you can enter your own text,
such as Hello club member. A preview pane displays your choice.
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By also selecting the Insert personalized salutation option, further salutation constructs become
available.

You can, for example, use a different greeting for men and women. To do this, Writer must have
some way of knowing whether a person is male or female. In our spreadsheet (see Figure 1) we
had a column called Sex. In the section Address list field indicating a female recipient, set the
Field name to Sex and the Field value to F. The Male salutation is then printed for all men and the
Female salutation for all women.

You do not need to tell LibreOffice who is a male, because it assumes that all non-

Note female records are males.

If you do not have such a column in your spreadsheet, then you can leave the Field name and
Field value boxes empty and use the customized content of the Male list box for the salutation.

Mail Merge Wizard E‘“’E#
Steps Create a salutation

1. Select starting document [+] This document should contain  salutation

2, Select document type [¥] Insert personalised salutation

3. Insert address block Female Diear Mrs, <Surnames, W - B, ..

4. Create salutafion Male Dear Mr. <Surmame’, 1'k--"l

5. Adjust layout Address list fisld ndicating a female recipient
&, Edit document Field name Sex v

7. Personalise document Field wvalue F &

8. Sawve, printor send General salutation

To whom it may concemm, w
Preview
Dear Mrs, Azure, Match fields...

Dear Mr, Azure,

Document: 1 [ [*]

Figure 30: Create a salutation

As an example:

1) Click the New button alongside the Male list box. The Custom Salutation (Male Recipients)
dialog opens (see Figure 31).

2) Select Salutation in the Salutation elements listings.
3) Click the Add to salutation arrow button to add it to box 1.

4) Open the list box choices for box 2, select an appropriate greeting or type your own text
into the list box. Edit it as needed.

5) Select and move across Title from the Salutation elements listings into box 1.

6) Add a space and then move Last Name across.

7) Finally, move Punctuation Mark across and select the comma from the choices in box 2.
8) The construct is shown in the Preview box.

9) Carry out any final editing. Click OK.
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Custom Salutation (Male Recipients)

Salutation elements

Salutation
Punctuation Mark
Text

Title

First Mame

Last Mame
Company Mame
Address Line 1
Address Line 2
City

State

ZIP

Country
Telephone private
Telephone business

[

[

1. Drag salutation elements into the box below

<Salutation = =Title > <Last Name >=Punctuation Mark>

E

2. Customize salutation

r

Preview

Dear Mrs Azure,

Figure 31: Customizing the salutation

You can see that the <Title> field takes care of the gender aspect of the salutation. Using this
method allows you to use gender neutral titles such as Doctor (Dr) and Reverend (Rev), or titles
such as Ms or Master.

Step 5: Adjust layout

In step 5, you can adjust the position of the address block and salutation on the page. You can
place the address block anywhere on the page. The salutation is always on the left, but you can
move it up and down the page. Use the buttons shown in Figure 32 to move the elements.

-

Mail Merge Wizard

[X]

Steps

L
2
3.

4

Adjust layout of address block and salutation

Select starting document
Select document type
Insert address block
Creats salutaion

5. Adjustlayout

6.

T

g

Edit document

Personalise document

Save, print or send

Figure 32: Adjust layout

Zoom |Entre page 1]
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Step 6: Edit document and insert extra fields

In step 6 you have another opportunity to exclude particular recipients from the mail merge, as
shown in Figure 33.

Steps

Figure 33: Edit document

You can also edit the body of the document. If you started with a blank document, you can write
the whole letter in this step. Click Edit Document to shrink the wizard to a small window (Figure

Select starting document
Select document type
Insert address block

Create salutalion

Edit document

Personalise document

Save, print or send

Preview and edit the document

The preview of a merged document is visible now. To ses the preview of another dooument dick
ane of the arrows.

Redpent 2

[[] Exdude this redpient

Edit Document

Write or edit your document naw if you have not already done so. The changes wil effect all
merged documents,

Clicking 'Edit Document, ..' will tempararily reduce the wizard to & small window s0 you can edit the
mail merge document, After editing the document, refturn to the wizard by ciicking ‘Return to Mail
Merge Wizard in the small window.

| Edit Document. .. |

34) so you can easily edit the letter.

You need to perform another important task in this step. The wizard only inserts information from

HMail M erge Wizard

= =]

@ Return to Mail Merge Wizard

Figure 34: Minimized mail merge wizard

the name and address fields, but you may wish to add additional data. In our example, we want to
tell each person how many points they had accumulated during the year; that information is in the
database. To do this:

Click Edit Document in step 6 of the wizard.

Choose Insert > Fields > Other. The Fields dialog opens.
Click the Database tab.

On the left hand side, select Mail merge fields.

Under Database selection find your data source (in this example, it is Points). Expand it to

1)
2)
3)
4)
5)

6)

7

Note

see the fields.

Click the field you want to insert (Points), then click Insert to insert the field.

You can insert any number of fields any number of times into your mail merge document.

Click Close when you are done.

The Database selection lists the data source you selected in step 3. All the
information you need for the letter must be contained in that data source.

Using the Mail Merge Wizard to create a form letter
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Fields

Document |(CrossTeferences |Functions | DocInformation |Variables | Database

Type Database selection
Any record = [TT] Sheetl &]
Database Mame Title
Mail merge First Mame
Mext record
Last Mame
Record number
Address
StatefCounty
Country
Postrode
Sex
Points
[l A Tl o P O A [ |
Condition Add database file
Format
Record number (%) From database
() User-defined |GEnEraI M
Insert ] ’ Close l ’ Help ]

Figure 35: Insert mail merge fields dialog

Step 7: Personalize documents
This step creates all your letters, one per recipient.

Clicking the Edit individual Document button here is similar to step 6. The difference is that you
now edit a long file containing all of the letters, so you can make changes to a particular letter to

one person. In this step of the Mail Merge wizard, click Find to open a dialog that allows searches
within the document, perhaps for an individual addressee.

Steps

. Select starting document
2. Select document type

3. Insert address block

4, Create salutation

8. Edit document

7. iPersonalise document:

&, Save, print or send

Personalise the mail merge documents

‘You can personalise particular documents. Cliding ‘Edit individual document...' wil tempararily
reduce the wizard to a small window so you can edit your document. After editing the document,
return to the wizard by dicking "Return to Mai Merge Wizard in the small winidow.

| Edit individual decument...

Eind
st | [
] whole words anly
[ ] Backwards
[] Match case

Figure 36: Personalize document

As with step 6, when editing the document, the wizard shrinks to a small window (Figure 34). Click
on this window to expand the wizard to its full size.
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Step 8: Save, print or send

You have now completed the mail merge process. The last step is to do something with it. In step
8, you can save the original sample letter, save the merged document, print the letters right away

or, if you created email messages, send them.

You probably want to save the starting (prototype) document and the merged document. To do this,

select Save starting document to reveal the Save starting document section containing the
Save starting document button. This button will be active only if the document has not already

been saved. Clicking on this button brings up the standard Save as dialog. Once you have named

and saved the document you return to the Step 8 dialog as shown in Figure 38.

Steps Save, print or send the document
1. Select starting document Select one of the options below:
2. Select document type (¥) save starting document

3. Insert address block (O save merged document

) Print merged document
4, Create salutation

Save starting document
6. Edit document

() Send merged document as E-Mail

[ Save starting document

7. Personalise document

8. Save, print or send:

Figure 37: Step 8: Save, print or send

The merged document can now be saved by selecting Save merged document. This will reveal
the Save merged document settings section, from which you can select to save either as one
large file containing all the individual, generated letters or as a separate file for each letter.

Steps Save, print or send the document
1. Select starting document Select one of the options belaw:
2. Select document type (O save starting document

3. Insert address block © save merged document

() Print merged document
4, Create salutation

() Send merged document as E-Mail

Save merged document settings

6. Edit document

(*1 53ve as single document:
7. Personalise document

() Save as individual documents
&. Sawve, print or send .=

[ Save Documents

Figure 38: Saving a merged document

When you have saved the merged document, you can print the final letters now or later, and you
can still manually check and edit the letters if necessary. If you elect to print at this stage, the

dialog shown in Figure 39 appears; it should be self-explanatory.

Using the Mail Merge Wizard to create a form letter
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Mail Merge Wizard

Steps

1. Select starting document
2. Select document type

3, Insert address block

4, Creats salutaton

J AORISTIEYOUTL

&, Edit doument

7. Personalise document

r——

8. Save, print or send

Save, print or send the document

Select one of the options below;

() Save starting document
{3 Save menged document

(") Send merged document as E-Mail

Print s=ttings

Erintar Caran MP780 Series Printer

@Printé]dnmmmts
Ofom  [1 | Tofa

I Print Documents

Figure 39: Printing the merged document
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