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Note for Mac users

Some keystrokes and menu items are different on a Mac from those used in Windows and Linux.
The table below gives some common substitutions for the instructions in this chapter. For a more
detailed list, see the application Help.

Windows or Linux Mac equivalent Effect
T°°|8.> Options menu LibreOffice > Preferences Access setup options
selection
Right-click Control+click or right-click
. Opens a context menu

depending on computer setup
Ctrl (Control) 3 (Command) Used with other keys
F5 Shift+3+F5 Open the Navigator
F11 #8+T Open the Styles and Formatting window

Documentation for LibreOffice is available at http://www.libreoffice.org/get-help/documentation
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Choosing options for all of LibreOffice

This section covers some of the settings that apply to all the components of LibreOffice. For
information on settings not discussed here, see the Help.

Click Tools > Options. The list in the left-hand box of the Options — LibreOffice dialog varies
depending on which component of LibreOffice is open. The illustrations in this chapter show the list
as it appears when a Writer document is open.

Click the marker (+ or triangle) by LibreOffice on the left-hand side. A list of pages drops down.
Selecting an item in the list causes the right-hand side of the dialog to display the relevant page.

¥ LibreOffice

General
Memory
View
Print
Paths
Colars
Fonts
Security
Personalization
Appearance
Accessibility
Advanced
Basic IDE Options
Online Update
OpenCL

» Load/Save

Figure 1: LibreOffice options

6 Note

The Reset button, located in the lower right of the full Options dialog, has the same
effect on all pages of the dialog. It resets the options to the values that were in place
when you opened the dialog.

If you are using a version of LibreOffice other than US English, some field labels may be different
from those shown in the illustrations.

User Data options

Because LibreOffice can use the name or initials stored in the LibreOffice — User Data page for
several things, including document properties (created by and last edited by information) and the
name of the author of comments and changes, you will want to ensure that the correct information
appears here.

Fill in the form (not shown here), or amend or delete any existing information. If you do not want
user data to be part of the document’s properties, clear the box at the bottom.

General options
The options on the LibreOffice — General page are described below Figure 2.
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Help

& Tips Extended tips

Openl/Save Dialogs
4 Use LibreOffice dialogs

Document Status
Printing sets "document modified"” status
Allow to save document even when the document is not modified
Year (Two Digits)
Interpret as years between 1930 I;_I and 2029

Help Improve LibreOffice
Collect usage data and send it to The Document Foundation

Figure 2: Setting general options for LibreOffice

Help - Tips
When Tips is active, one or two words will appear when you hold the mouse pointer over an
icon or field, without clicking.

Help — Extended tips
When Extended tips is active, a brief description of the function of a particular icon or menu
command or a field on a dialog appears when you hold the mouse pointer over that item.

Open/Save Dialogs — Use LibreOffice dialogs
To use the standard Open and Save dialogs for your operating system, deselect the Use
LibreOffice dialogs option. When this option is selected, the Open and Save dialogs
supplied with LibreOffice will be used. See Chapter 1, Introducing LibreOffice, for more about
the LibreOffice Open and Save dialogs. This book uses the LibreOffice Open and Save
dialogs in illustrations.

Document status - Printing sets “document modified” status
If this option is selected, then the next time you close the document after printing, the print
date is recorded in the document properties as a change and you will be prompted to save
the document again, even if you did not make any other changes.

Document status — Allow to save document even when the document is not modified
Normally when a document has not been modified, the File > Save menu option and the
Save button on the Standard toolbar are disabled and the keyboard shortcut Ctr/+S has no
effect. Select this option to allow documents to be saved even when they have not been
modified.

Year (two digits)
Specifies how two-digit years are interpreted. For example, if the two-digit year is set to
1930, and you enter a date of 1/1/30 or later into your document, the date is interpreted as
1/1/1930 or later. An “earlier” date is interpreted as being in the following century; that is,
1/1/20 is interpreted as 1/1/2020.

Memory options

The options on the LibreOffice — Memory page control how LibreOffice uses your computer’s
memory and how much memory it requires. Before changing them, you may wish to consider the
following points:

* More memory can make LibreOffice faster and more convenient (for example, more undo
steps require more memory); but the trade-off is less memory available for other
applications and you could run out of memory altogether.

Choosing options for all of LibreOffice | 5



* If your documents contain a lot of objects such as images, or the objects are large,
LibreOffice’s performance may improve if you increase the memory for LibreOffice or the
memory per object. If you find that objects seem to disappear from a document that
contains a lot of them, increase the number of objects in the cache. (The objects are still in
the file even if you cannot see them on screen.)

* To load the Quickstarter when you start your computer, select the option near the bottom of
the dialog. This makes LibreOffice start faster; the trade-off is LibreOffice uses some
memory even when not being used. This option is called Enable systray quickstarter on
Linux. It is not available on Mac OS X or on systems where the Quickstarter module has
not been installed.

Undao

4|k

Murmnber of steps 100

Graphics cache

Use for LibreOffice 20 | MB
Mermory per object 5.2 ~{ MB
Bernove from memory after 00:10 = hh:mm

Cache for inserted objects

4k

Murnber of objects 20
LibreQffice Quickstarter

| Load LibreOffice during systern start-up

Figure 3: Choosing Memory options for the LibreOffice applications

View options

The options on the LibreOffice — View page affect the way the document window looks and
behaves. Some of these options are described below. Set them to suit your personal preferences.

User Interface — Scaling
If the text in the help files or on the menus of the LibreOffice user interface is too small or too
large, you can change it by specifying a scaling factor. Sometimes a change here can have
unexpected results, depending on the screen fonts available on your system. However, it
does not affect the actual font size of the text in your documents.

User Interface - Icon size and style
The first box specifies the display size of toolbar icons (Automatic, Small, or Large). The
Automatic icon size option uses the setting for your operating system. The second box
specifies the icon style (theme); here the Automatic option uses an icon set compatible with
your operating system and choice of desktop: for example, KDE or Ghome on Linux.

User interface — Screen font anti-aliasing
(Not available in Windows.) Select this option to smooth the screen appearance of text. Enter
the smallest font size to apply anti-aliasing.
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User Interface Graphics Output

Scaling: 100% | |Z]

Icon size and style: RIS BILUREE

Small kJ Tango <

&4 Screen font antialiasing

L4 Use OpenGL for all rendering

Force OpenGL even if blacklisted

from: 8 pixels 1<) Menu
lcons in menus: | Automatic ﬁ
Mouse
Mouse positioning: Font Lists
No automatic positioning &) Show preview of fonts

Middle mouse button: 3 Show foe hestory

Automatic scrolling < Selection

Transparency:  60% [

Figure 4: Choosing View options for LibreOffice applications
Mouse positioning
Specifies if and how the mouse pointer will be positioned in newly opened dialogs.

Middle mouse button
Defines the function of the middle mouse button.

* Automatic scrolling — dragging while pressing the middle mouse button shifts the view.

* Paste clipboard — pressing the middle mouse button inserts the contents of the
“Selection clipboard” at the cursor position.

The “Selection clipboard” is independent of the normal clipboard that you use by Edit >
Copyl/Cut/Paste or their respective keyboard shortcuts. Clipboard and “Selection clipboard”
can contain different contents at the same time.

Function Clipboard Selection clipboard

Copy content Edit > Copy Ctrl+C Select text, table, or object.

Paste content Edit > Paste Ctr/+V pastes at Clicking the middle mouse button pastes
the cursor position. at the mouse pointer position.

Pasting into another No effect on the clipboard The last marked selection is the content

document contents. of the selection clipboard.

Graphics output — Use hardware acceleration
Directly accesses hardware features of the graphical display adapter to improve the screen
display. Not supported on all operating systems and LibreOffice distributions.

Graphics output — Use anti-aliasing
Enables and disables anti-aliasing, which makes the display of most graphical objects look
smoother and with fewer artifacts. Not supported on all operating systems and LibreOffice
distributions.

P io

Press Shift+Ctrl+R to restore or refresh the view of the current document after
changing the anti-aliasing settings, to see the effect.
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Graphics output — Use OpenGL for all rendering
Enables and disables the use of the 3D graphics language OpenGL. Not supported on all
operating systems and LibreOffice distributions.

Menu - icons in menus
Causes icons as well as words to be visible in menus.

Font Lists — Show preview of fonts
Causes the font list to look like Figure 5, Left, with the font names shown as an example of
the font; with the option deselected, the font list shows only the font names, not their
formatting (Figure 5, Right). The fonts you will see listed are those that are installed on your
system.

Fonts which are tuned for use with a specific script, such as Arabic, Hebrew, Malayalam, and
so on, now show an additional preview of some sample text in the target script.

Liberation Sang| 11 + B / U Liberation Sang| 11 w

Liberation Mono & Liberation Mono »
_ . Liberation Sans
Liberation Sans Liberation Sans Marrow
i ; Liberation Serif
LI.bEI'EL'[IIIJn SElFISI Marrow Liffey Script 5F
Liberation Serif LilyupPC
o . Linux Biolinum G
ey o oFgF
il Linux Libertine G
LivUPC Jhiushng Lucida Bright
. - Lucida Calligraph
Linux Biolinum G Lucida c-:.ngnlep Y
Linux Libertine G Lucida Fax
i i Lucida Handwriting
Lucida Bright Lucida Sans
Eucid’a Cﬁlﬂ_i i ﬁ Lucida Sans Typewriter
. grapny Lucida Sans Unicode
Lucida Console v Mackintosh SF v

Figure 5: Font list (Left) with preview; (Right) without preview

Font Lists — Show font history
Causes the last five fonts you have assigned to the current document to be displayed at the
top of the font list. Otherwise fonts are shown in alphabetical order.

Selection - Transparency
Determines the appearance of selected text or graphics, which appear on a shaded
background. To make the shaded background more or less dark, increase or decrease the
Transparency setting.

If you prefer selected material to appear in reversed color (typically white text on a black
background), deselect this option.

Print options

On the LibreOffice — Print page, set the print options to suit your default printer and your most
common printing method. Most of these options should be self-explanatory.

The option PDF as Standard Print Job Format is not available on Windows. Select this option to
change the internal print job format from a Postscript document description to a PDF description.
This format has a humber of advantages over Postscript. For more information, see
http://www.linuxfoundation.org/collaborate/workgroups/openprinting/pdf_as_standard_print_job_format

Deselecting this option reverts to the Postscript document workflow system.

8 | Chapter 2 Setting Up LibreOffice


http://www.linuxfoundation.org/collaborate/workgroups/openprinting/pdf_as_standard_print_job_format
http://www.linuxfoundation.org/collaborate/workgroups/openprinting/pdf_as_standard_print_job_format

Reduce print data

Settings for: (s) Printer () Print to file
¥ Reduce transparency ¥ Reduce gradient
(») Automatically (s) Gradient stripes |64 |

() No transparenc i
v p Y () Intermediate color

¥ Reduce bitmaps | | Convert colors to grayscale
() High print quality
() Normal print quality
(e) Resolution |200 DPI (default)
™ Include transparent objects
[+ PDF as Standard Print Job Format

Printer warnings
|| Paper size v Transparency
| Paper orientation
Figure 6: Choosing general printing options to apply to all LibreOffice components

In the Printer warnings section near the bottom of the page, you can choose whether to be warned
if the paper size or orientation specified in your document does not match the paper size or
orientation available for your printer. Having these warnings turned on can be quite helpful,
particularly if you work with documents produced by people in other countries where the standard
paper size is different from yours.

P Tip

If your printouts are incorrectly placed on the page or chopped off at the top, bottom, or
sides, or the printer is refusing to print, the most likely cause is page size
incompatibility.

Paths options

On the LibreOffice — Paths page, you can change the location of files associated with, or used by,
LibreOffice to suit your working situation. In a Windows system, for example, you might want to
store documents by default somewhere other than My Documents.

To make changes, select an item in the list shown in Figure 7 and click Edit. On the Select Path
dialog (not shown; may also be titled Edit Paths), add or delete folders as required, and then click
OK to return to the Options dialog. Note that some items can have at least two paths listed: one to
a shared folder (which might be on a network) and one to a user-specific folder (normally on the
user’s personal computer).

» i

You can use the entries on the LibreOffice — Paths page to compile a list of files, such
as those containing AutoText, that you need to back up or copy to another computer.
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Paths used by LibreOffice
Type Path
AutoCorrect [Users/jean/Library/Application Support/LibreOffice/4 fuser/autocorr
AutoText [Users/jean/Library/Application Support/LibreOffice/4 fuser/autotext
Backups [Users/jean/Library/Application Support/LibreOffice/4 fuser/backup
Dictionaries {Users/jean/Library/Application Support/LibreOffice/4 fuser/wordbook
Gallery [Users/jean/Library/Application Support/LibreOffice/4 fuser/gallery
Images {Users/jean/Library/Application Support/LibreOffice/4 fuser/gallery
My Documents [Users/jean/Documents
Templates /Applications/LibreOffice.app/Contents /MacQ5/../share/template /commao
Temporary files /Users/jean/Library/Application Support/LibreOffice/4 fuser/temp

Figure 7: Viewing the paths of files used by LibreOffice

Color options

On the LibreOffice — Colors page, you can specify colors to use in LibreOffice documents. You can
select a color from a color table, edit an existing color, and define new colors. These colors are
stored in your color palette and are then available in all components of LibreOffice.

To modify a color:

1) Select the color to modify from the list or the color table.

2) Enter the new values that define the color. You can choose the RGB (Red, Green, Blue) or
the CMYK (Cyan, Magenta, Yellow, Black) system to specify your color. The changed color
appears in the lower of the two color preview boxes at the top.

3) Modify the Name as required.
4) Click the Modify button. The newly defined color is now listed in the Color table.

Properties

Name: Tango: Sky Blue 1 Add

Color: [ Tango: Sky Blue 1 a Modify

Table: standard

H EENEEEN EH
NN NN rRGB [
ANEEEEEEEEEN _
ANEEEEEEEEN R 114 )
/NN EEEEEE i
ENEEE | | [[/ENE G 159 )
ANEEEENT SN :
HINENE EECES B 207 o
EiEEO=

Delete

Pick...

Figure 8: Defining colors to use in color palettes in LibreOffice

Alternatively, click the Pick button to open the Pick a Color dialog, shown in Figure 9. Here you can
select a color from the window on the left, or you can enter values on the right using your choice of
RGB, CMYK, or HSB (Hue, Saturation and Brightness) values.
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o Pick a Color
RGB
| Red: s |3
" Green: 159 ]
| Blue: 207 |[Z]
Hex #: 729fcf
HSB
© Hue: 211° 2]
) Saturation:  45% | [
I 1 Brightness:  81% Iél
CMYK
Cyan: 45% )
Magenta: 23% [
Yellow: 0% B
I T ¢
Help Cancel

Figure 9: Editing colors

The color window on the left is linked directly with the color input fields on the right; as you choose
a color in the window, the numbers change accordingly. The color field at the lower left shows the

value of the selected color on the left and the currently set value from the color value fields on the
right.

Modify the color components as required and click OK to exit the dialog. The newly defined color
now appears in the lower of the color preview boxes shown in Figure 8. Type a name for this color
in the Name box, then click the Add button. A small box showing the new color is added to the
Color table.

Another way to define or alter colors is through the Colors page of the Area dialog, where you can
also save and load palettes, a feature that is not possible here. In Calc, draw a temporary draw
object and use the context menu of this object to open the Area dialog. If you load a palette in one
component of LibreOffice, it is only active in that component; the other components keep their own
palettes.

Fonts options

You can define replacements for any fonts that might appear in your documents. If you receive
from someone else a document containing fonts that you do not have on your system, LibreOffice
will substitute fonts for those it does not find. You might prefer to specify a different font from the
one that the program chooses.

' Note

These choices do not affect the default font for your documents. To do that, you need
to change the default template for documents, as described in Chapter 3.
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On the LibreOffice — Fonts page:
1) Select the Apply replacement table option.

2) Select or type the name of the font to be replaced in the Font box. (If you do not have this
font on your system, it will not appear in the drop-down list in this box, so you need to type

it in.)

3) Inthe Replace with box, select a suitable font from the drop-down list of fonts installed on

your computer.

Replacement table
Font Replace with
Likeration Sans v | |Open Sans W 58
Always Screen only | Font Feplace with
Liberation Sans Open Sans

Apply replacement table

Font settings for HTML, Basic and SQL sources

Fonts |Autumatic W

Maon-proportional fonts only
Size |10 v

Figure 10: Defining a font to be substituted for another font

4) The check mark to the right of the Replace with box turns green. Click on this check mark.
A row of information now appears in the larger box below the input boxes. Select Always to
replace the font, even if the original font is installed on your system. Select Screen only to

replace the screen font only and never replace the font for printing. The results of
combining these selections are given in Table 1.

5) In the bottom section of the page, you can change the typeface and size of the font used to

display source code such as HTML and Basic (in macros).
Table 1. Font substitution replacement actions

Always Screenonly  Replacement action

checkbox  checkbox

checked blank Font replacement on screen and when printing, whether the font is
installed or not.

checked checked Font replacement only on screen, whether the font is installed or not.

blank checked Font replacement only on screen, but only if font is not available.

blank blank Font replacement on screen and when printing, but only if font is not

available.
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Security options

Use the LibreOffice — Security page to choose security options for saving documents and for
opening documents that contain macros.

Security Options and Warnings

Adjust security related options and define warnings for hidden information in

documents. Options...

Passwords for Web Connections

Persistently save passwords for web connections

Macro Security

Adjust the security level for executing macros and specify trusted macro

developers. Macro Security...

Certificate Path
Select the Network Security Services certificate directory to use for digital

signatures. Certificate...
TSAs
Maintain a list of Time Stamping Authority (TSA) URLs to be used for digital TSAs

signatures in PDF export.

Figure 11: Choosing security options for opening and saving documents

Security options and warnings

If you record changes, save multiple versions, or include hidden information or notes in your
documents, and you do not want some of the recipients to see that information, you can set
warnings to remind you to remove it, or you can have LibreOffice remove some of it
automatically. Note that (unless removed) much of this information is retained in a file
whether the file is in LibreOffice’s default OpenDocument format, or has been saved to other
formats, including PDF.

Click the Options button to open a separate dialog with specific choices (Figure 13). See
“Security options and warnings” on page 14.

Macro security

Click the Macro Security button to open the Macro Security dialog (not shown here), where
you can adjust the security level for executing macros and specify trusted sources.

Certificate Path

Users can digitally sign documents using LibreOffice. A digital signature requires a personal
signing certificate. Most operating systems can generate a self-signed certificate. However, a
personal certificate issued by an outside agency (after verifying an individual’s identity) has a
higher degree of trust associated with it than does a self-signed certificate. LibreOffice does
not provide a secure method of storing these certificates, but it can access certificates that
have been saved using other programs. Click the Certificate button and select which
certificate store to use.

Note

The Certificate Path option appears only on Linux and Mac systems. On Windows,
LibreOffice uses the default Windows location for storing and retrieving certificates.
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Passwords for web connections
You can enter a master password to enable easy access to websites that require a user
name and password. If you select the Persistently save passwords for web connections
option, the Set Master Password dialog opens (Figure 12). LibreOffice will securely store all
passwords that you use to access files from web servers. You can retrieve the passwords
from the list after you enter the master password.

| 800 Set Master Password

Passwords for web connections are protected by a master
password. You will be asked to enter it once per session, if
LibreOffice retrieves a password from the protected password
list.

Enter password:

Reenter password:

Caution: If you forget the master password, you will be
unable to access any of the information protected by it.
Passwords are case sensitive.

| Help | OK | Cancel |

Figure 12: Set Master Password dialog for web connections

Security options and warnings
The following options are on the Security options and warnings dialog (Figure 13).

[ ] - - Security Optic-mez and 'u;'u'arnings -
Security Warnings
Warn if document contains recorded changes, versions, hidden information or notes:
When saving or sending [ When signing
When printing When creating PDF files
| Security Options
Remove personal information on saving
Recommend password protection on saving
[ Ctr-click required to follow hyperlinks

Block any links from documents not among the trusted locations (see Macro Security)

Help . OK Cancel

Figure 13: Security options and warnings dialog

Remove personal information on saving
Select this option to always remove user data from the file properties when saving the file. To
manually remove personal information from specific documents, deselect this option.
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Ctrl-click required to follow hyperlinks
The default behavior in LibreOffice is to Ctrl+click on a hyperlink to open the linked
document. Many people find creation and editing of documents easier when accidental clicks
on links do not activate the links. To set LibreOffice to activate hyperlinks using an ordinary
click, deselect this option.

The other options on this dialog should be self-explanatory.

Personalization
You can customize the overall appearance of LibreOffice with themes designed for Mozilla Firefox.

On the LibreOffice — Personalization page, select Own Theme and then click Select Theme.
Another dialog opens. Type a search term, click Search, and wait while theme thumbnails load.
Select one and click OK to apply the theme. After a brief pause the appearance of LibreOffice will
refresh and reflect the selected theme. An example is shown in Figure 15. For full details about
themes, visit the Mozilla website: https://www.https://addons.mozilla.org/en-US/firefox/themes/

Firefox Themes
Default look, do not use Themes

Pre-installed Theme (if available)

« Own Theme Select Theme

&) & Select Firefox Theme

Custom Search

Suggested Themes by Category
Categories:
LibreOffice Abstract Caolor Music MNature

Help OK Cancel

Figure 14: Personalization dialogs

File Edit View Insert Format Table Tools Window Help.
BrE-aes B asr SN oYY e e
0OeTedBody v| Liberationsans |v| 11 v| B T U E‘Ir‘-i =
Figure 15: Sample personalized theme
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Appearance options

Writing, editing, and (especially) page layout are often easier when you can see the page margins
(text boundaries), the boundaries of tables and sections (in Writer documents), page breaks in
Calc, grid lines in Draw or Writer, and other features. In addition, you might prefer to use colors that
are different from LibreOffice’s defaults for such items as comment indicators or field shadings.

On the LibreOffice — Appearance page (Figure 16), you can specify which items are visible and the
colors used to display various items.

» To show or hide items such as text boundaries, select or deselect the options next to the
names of the items.

« To change the default colors for items, click the down-arrow in the Color Setting column by
the name of the item and select a color from the list box. Note that you can change the list
of available colors as described in “Color options” on page 10.

» To save your color changes as a color scheme, click Save, type a name in the Scheme
box, and then click OK.

Color scheme

Scheme LibreQffice hdl

Custom colors

On |User interface elements | Color setting |Preview |
General i
Document background [ Automatic |» I:I

Text boundaries [ automatic [+ I:I
Application background [ automatic | I:I

Chiject boundaries [ automatic |« |:|

Table boundaries [ automatic |« |:|
Faont calor Bl Automatic |+ -

[ Unvisited links m Automatic [~ [T

T wticidmd limlen — Y

Figure 16: Showing or hiding text, object, and table boundaries

Accessibility options

Accessibility options include whether to allow animated graphics or text, how long help tips remain
visible, some options for high contrast display, and a way to change the font for the user interface
of the LibreOffice program.

Accessibility support relies on the Java Runtime Environment for communication with assistive
technology tools. The Support assistive technology tools option is not shown on all LibreOffice
installations. See Assistive Tools in LibreOffice in the Help for other requirements and information.

Select or deselect the options as required.
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Miscellanecus cptions

Support assistive technology tools (program restart required)
Use text selection cursor in read-conly text documents
J| Allow animated graphics

| Allow animated text
J| Help tips disappear after 4 +| seconds

Options for high contrast appearance
J| Automnatically detect high contrast mode of operating system

Use automatic font coler for screen display

| Use systern colors for page previews

Figure 17: Choosing accessibility options

Advanced options

Java options
If you install or update a Java Runtime Environment (JRE) after you install LibreOffice, or if
you have more than one JRE installed on your computer, you can use the LibreOffice —
Advanced options page to choose the JRE for LibreOffice to use.

Java options
EI Use a Java runtime environment

Java runtime environments (JRE) already installed:

Vendor Version Features Add...
(+) Apple Inc. 1.6.0_65
Parameters...
Class Path...

Location: [System/Library/]ava/JavaVirtualMachines/1.6.0.jdk/Contents/Home

Optional (unstable) options
¥ Enable experimental features

[V Enable macro recording (limited)

Expert Configuration

Figure 18: Choosing a Java runtime environment

If you are a system administrator, programmer, or other person who customizes JRE
installations, you can use the Parameters and Class Path pages (reached from the Java
page) to specify this information.

If you do not see anything listed in the middle of the page, wait a few minutes while
LibreOffice searches for JREs on the hard disk.

If LibreOffice finds one or more JRES, it will display them there. You can then select the Use
a Java runtime environment option and (if necessary) choose one of the JREs listed.
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Optional (unstable) options

Enable experimental features
Selecting this option enables features that are not yet complete or contain known bugs. The
list of these features is different version by version.

Enable macro recording (limited)
This option enables macro recording with some limitations. Opening a window, switching
between windows, and recording in a different window to that in which the recording began,
is not supported. Only actions relating to document contents are recordable, so changes in
Options or customizing menus are not supported. For more about macro recording, see
Chapter 13, Getting Started with Macros.

Expert Configuration
Most users will have no need to use this. Click the Expert Configuration button to open a
new window in which you can fine-tune the LibreOffice installation. The page offers detailed
configuration options for many aspects of LibreOffice’s appearance and performance.
Double-click on a listed preference to enter a value to configure the preference.

Basic IDE options

The Basic IDE Options are available after Enable experimental features has been selected on
the Advanced page of the Options dialog and the options have been saved. These options are for
macro programmers and are not discussed here.

Code Completion

Enable Code Completion

Code Suggestion
Autocorrection

Autoclose Quotes
Autoclose Parenthesis

[ ] Autoclose Procedures

Language Features

| Use extended types

Figure 19: Basic IDE Options dialog

Online update options

On the LibreOffice — Online Update page (Figure 20), you can choose whether and how often to
have the program check the LibreOffice website for program updates. If the Check for updates
automatically option is selected, an icon appears at the right-hand end of the menu bar when an
update is available. Click this icon to open a dialog where you can choose to download the update.

If the Download updates automatically option is selected, the download starts when you click the
icon. To change the download destination, click the Change button and select the required folder in
the file browser window.
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Online Update Options
Check for updates automatically

() Every Day
() Every Week
@ Every Month

Last checked: 08/25,/10, 05:27:00 PP

[] Download updates automatically

Download destination:
ChUserstJared\Desktop

Figure 20: Online update options

Choosing Load/Save options

You can set the Load/Save options for loading and saving documents to suit the way you work.

If the Options dialog is not already open, click Tools > Options. Click the expansion symbol (+ or

triangle) to the left of Load/Save.

General

Most of the choices on the Load/Save — General page are familiar to users of other office suites.

Some items of interest are described below.

Load
¥ Load user-specific settings with the document
™ Load printer settings with the document

Save

[ Save AutoRecovery information every |15

|| Automatically save the document too
[ Edit document properties before saving
[ Always create backup copy
[ Save URLs relative to file system
E] Save URLs relative to internet
Default file format and ODF settings

ODF format version:

Minutes

| 1.2 Extended (recommended) =

Document type: | Text document

[ Warn when not saving in ODF or default format

Always save as: | ODF Text Document

Figure 21: Choosing Load and Save options
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Load user-specific settings with the document
A LibreOffice document contains certain settings that are read from the user’s system. When
you save a document, these settings are saved with it.

Select this option so that when a document loads, it ignores the stored settings in favor of the
settings on your computer.

Even if you do not select this option, some settings are taken from your LibreOffice installation:
» Settings available in File > Print > Options
* Name of Fax
* Spacing options for paragraphs before text tables
* Information about automatic updating for links, field functions and charts
* Information about working with Asian character formats.
The following setting is always loaded with a document, whether or not this option is marked:

« Data source linked to the document and its view.

If you deselect this option, the user’s personal settings do not overrule the settings in the
document. For example, your choice (in the options for LibreOffice Writer) of how to update
links is affected by the Load user-specific settings option.

Load printer settings with the document
If enabled, the printer settings will be loaded with the document. This can cause a document
to be printed on a distant printer (perhaps in an office setting), if you do not change the
printer manually in the Print dialog. If disabled, your standard printer will be used to print this
document. The current printer settings will be stored with the document whether or not this
option is selected.

Save AutoRecovery information every __ Minutes
Choose whether to enable AutoRecovery and how often to save the information used by the
AutoRecovery process.

AutoRecovery in LibreOffice saves the information needed to restore all open documents in
case of a crash. If you have this option set, recovering your document after a system crash
will be easier.

Automatically save the document too
Specifies that LibreOffice saves all open documents when saving auto recovery information.
Uses the same time interval as AutoRecovery does.

Edit document properties before saving
If you select this option, the Document Properties dialog pops up to prompt you to enter
relevant information the first time you save a new document (or whenever you use Save As).

Always create backup copy
Saves the previous version of a document as a backup copy whenever you save a
document. Every time LibreOffice creates a backup copy, the previous backup copy is
replaced. The backup copy gets the extension BAK. Authors whose work may be very
lengthy should always consider using this option.

Save URLs relative to file system / internet
Use this option to select the default for relative addressing of URLSs in the file system and on
the Internet. Relative addressing is only possible if the source document and the referenced
document are both on the same drive.

A relative address always starts from the directory in which the current document is located.
In contrast, absolute addressing always starts from a root directory. The following table
demonstrates the difference in syntax between relative and absolute referencing:
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Examples File system Internet

relative ..[images/img.jpg ..[images/img.jpg

absolute file:///c|/work/images/img.jpg http://myserver.com/work/images/img.jpg

If you choose to save relatively, the references to embedded graphics or other objects in your
document will be saved relative to the location in the file system. In this case, it does not
matter where the referenced directory structure is recorded. The files will be found regardless
of location, as long as the reference remains on the same drive or volume. This is important if
you want to make the document available to other computers that may have a completely
different directory structure, drive or volume names. It is also recommended to save relatively
if you want to create a directory structure on an Internet server.

If you prefer absolute saving, all references to other files will also be defined as absolute,
based on the respective drive, volume or root directory. The advantage is that the document
containing the references can be moved to other directories or folders, and the references
remain valid.

Default file format and ODF settings
ODF format version. LibreOffice by default saves documents in OpenDocument Format
(ODF) version 1.2 Extended. While this allows for improved functionality, there may be
backwards compatibility issues. When a file saved in ODF 1.2 Extended is opened in an
editor that uses earlier versions of ODF (1.0/1.1), some of the advanced features may be
lost. Two notable examples are cross-references to headings and the formatting of numbered
lists. If you plan to share documents with people who use editors that use older versions of
ODF, you may wish to save the document using ODF version 1.0/1.1.

Document type. If you routinely share documents with users of Microsoft Office, you might
want to change the Always save as attribute for documents to one of the Microsoft Office
formats. Current versions of Microsoft Word can open ODT files, so this may no longer be
needed.

VBA Properties

On the VBA Properties page, you can choose whether to keep any macros in Microsoft Office
documents that are opened in LibreOffice.

Microsoft Word 97/2000/XP
Load Basic code

Executable code

Save original Basic code

Microsoft Excel 97/2000/XP
Load Basic code

Executable code

Save original Basic code

Microsoft PowerPoint 97/2000/XP
Load Basic code

Save original Basic code

Figure 22: Choosing Load/Save VBA Properties
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If you choose Load Basic code, you can edit the macros in LibreOffice. The changed code is
saved in an ODF document but is not retained if you save into a Microsoft Office format.

If you choose Save original Basic code, the macros will not work in LibreOffice but are retained
unchanged if you save the file into Microsoft Office format.

If you are importing a Microsoft Word or Excel file containing VBA code, you can select the option
Executable code. Whereas normally the code is preserved but rendered inactive (if you inspect it
with the StarBasic IDE you will notice that it is all commented), with this option the code is ready to
be executed.

Save original Basic code takes precedence over Load Basic code. If both options are selected
and you edit the disabled code in LibreOffice, the original Microsoft Basic code will be saved when
saving in a Microsoft Office format.

To remove any possible macro viruses from the Microsoft Office document, deselect Save original
Basic code. The document will be saved without the Microsoft Basic code.

Microsoft Office

On the Load/Save — Microsoft Office page, you can choose what to do when importing and
exporting Microsoft Office OLE objects (linked or embedded objects or documents such as
spreadsheets or equations).

Select the [L] options to convert Microsoft OLE objects into the corresponding LibreOffice OLE
objects when a Microsoft document is loaded into LibreOffice (mnemonic: “L” for “load”).

Select the [S] options to convert LibreOffice OLE objects into the corresponding Microsoft OLE
objects when a document is saved in a Microsoft format (mnemonic: “S” for “save”).

Embedded Objects

| (sl |

/] [ MathType to LibreOffice Math or reverse

o o WinWord to LibreOffice Writer or reverse

U o4 Excel to LibreOffice Calc or reverse

Y 7 PowerPoint to LibreOffice Impress or reverse

SmartArt to LibreOffice shapes or reverse

[L]: Load and convert the object

[S]: Convert and save the object
Character Highlighting

Export as: () Highlighting — Shading

Figure 23: Choosing Load/Save Microsoft Office options
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HTML compatibility

Choices made on the Load/Save — HTML Compatibility page affect HTML pages imported into
LibreOffice and those exported from LibreOffice. See HTML documents; importing/exporting in the

Help for more information.

Font sizes

Size 1 7

Size 2 10
Size 3 12
Size 4 14
Size 5 18
Size & 24
Size 7 36

W

A

Import
[ ] Use 'English {USA)' locale for numbers

[ ] Import unknown HTML tags as fields
[] Ignore font settings
Export

Mozilla Firefox W

[ ] LibreOffice Basic
Display warning
] Brint layout
Copy local graphics to Internet

Character set Western Europe (Windows-121 %

Figure 24. Choosing HTML compatibility options

Font sizes

Use these fields to define the respective font sizes for the HTML <font size=1> to <font
size=7> tags, if they are used in the HTML pages. (Many pages no longer use these tags.)

Import - Use 'English (USA)' locale for numbers
When importing numbers from an HTML page, the decimal and thousands separator
characters differ according to the locale of the HTML page. The clipboard, however, contains
no information about the locale. If this option is not selected, numbers will be interpreted
according to the Locale setting in Tools > Options > Language Settings > Languages
(see page 24). If this option is selected, numbers will be interpreted as for the English (USA)

locale.

Import — Import unknown HTML tags as fields
Select this option if you want tags that are not recognized by LibreOffice to be imported as
fields. For an opening tag, an HTML_ON field will be created with the value of the tag name.
For a closing tag, an HTML_OFF will be created. These fields will be converted to tags in the

HTML export.

Import - Ignore font settings

Select this option to have LibreOffice ignore all font settings when importing. The fonts that
were defined in the HTML Page Style will be used.

Export

To optimize the HTML export, select a browser or HTML standard from the Export box. If
LibreOffice Writer is selected, specific LibreOffice Writer instructions are exported.

Export - LibreOffice Basic

Select this option to include LibreOffice Basic macros (scripts) when exporting to HTML
format. You must activate this option before you create the LibreOffice Basic macro;
otherwise the script will not be inserted. LibreOffice Basic macros must be located in the
header of the HTML document. Once you have created the macro in the LibreOffice Basic
IDE, it appears in the source text of the HTML document in the header.
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If you want the macro to run automatically when the HTML document is opened, choose
Tools > Customize > Events. See Chapter 13, Getting Started with Macros, for more
information.

Export — Display warning
When the LibreOffice Basic option (see above) is not selected, the Display warning option
becomes available. If the Display warning option is selected, then when exporting to HTML
a warning is shown that LibreOffice Basic macros will be lost.

Export - Print layout
Select this option to export the print layout of the current document as well. The HTML filter
supports CSS2 (Cascading Style Sheets Level 2) for printing documents. These capabilities
are only effective if print layout export is activated.

Export — Copy local graphics to Internet
Select this option to automatically upload the embedded pictures to the Internet server when
uploading using FTP.

Export — Character set
Select the appropriate character set for the export.

Choosing language settings

To customize the language settings in LibreOffice, you can do any of the following:
* Install the required dictionaries
* Change some locale and language settings
* Choose spelling options

Install the required dictionaries

LibreOffice automatically installs several dictionaries with the program. To add other dictionaries,
be sure you are connected to the Internet, and then choose Tools > Language > More
Dictionaries Online. LibreOffice will open your default web browser to a page containing links to
additional dictionaries that you can install. Follow the prompts to select and install the ones you
want.

Change some locale and language settings

You can change some details of the locale and language settings that LibreOffice uses for all
documents, or for specific documents.

In the Options dialog, click Language Settings > Languages. The exact list shown depends on
the Enhanced language support settings (see Figure 26).

4 LibreQffice + LibreOffice
Load/Save + Load/Save
Language Settings = Language Setfings
Languanges: Languages:
Writing Aids Writing Aids
English sentence checking Searching in Japanese
+ LibreQffice Writer Asian Layout
4 LibreQffice Writer Mieb Complex Text Layout
+ LibreQffice Base English sentence checking
4 Charts 41 LibreOffice Writer
+  Internet + - LibreOffice Writer/\Web
+ LibreQffice Base

Figure 25: LibreOffice language options, without and with
Asian and CTL options enabled
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On the right-hand side of the Language Settings — Languages page, change the User interface,
Locale setting, Default currency, and Default languages for documents as required. In the
example, English (USA) has been chosen for all the appropriate settings.

Language of

User interface

Locale setting English (USA)
Decimal separator key

Default currency Default - USD

Date acceptance patterns M/D/Y;M/D

Default languages for documents

Western % English (USA)
Asian [None]
Complex text layout (CTL) [None]

Enhanced language support
Ignore system input language

Default - English (USA)

™ Same as locale setting (. )

ik

Ak

Ak

For the current document only

Figure 26: Choosing language options

User interface
The language of the user interface is usually set at the time LibreOffice is installed to match
the language of the operating system. If more than one language has been installed for
LibreOffice, you can select which language will be used for menus, dialogs, and help files.

Locale setting
The local setting is the basis for many other settings within LibreOffice, for example defaults
for numbering, currency, and units of measure. Unless you select something else here, the

locale of the operating system will be set as default.

Decimal separator key
If the Decimal separator key option is selected, LibreOffice will use the character defined by
the default locale. If this option is not selected, the keyboard driver defines the character

used.

Default currency
The Default currency is that used in the country entered as Locale. The default currency
determines the proper formatting of fields formatted as currency. If the locale setting is
changed, the default currency changes automatically. If the default currency is changed, all
dialogs involving currency and all currency icons will be changed in all open documents.
Documents that were saved with one currency as the default will open using the new
currency defaults.

Date acceptance patterns
Date acceptance patterns define how LibreOffice recognizes input as dates. Locale also
defines the default expression of dates. You can define additional date patterns, separated
by semicolons, using Y, M, & D for Year, Month, and Day. LibreOffice will always correctly
interpret dates entered in ISO 8601 format as Y-M-D and YYYY-MM-DD.

>
e

" Caution
Data entered into a Calc spreadsheet or a Writer table must be entered in a format

defined by Local in order to be recognized as dates.
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Default languages for documents

Select the languages used for the spelling checker, thesaurus, and hyphenation features of
LibreOffice. If these options are only for the current document, select For the current
document only.

If necessary, select the options to enable support for Asian languages (Chinese, Japanese,
Korean) and support for CTL (complex text layout) languages such as Urdu, Thai, Hebrew,
and Arabic. If you choose either of these options, the next time you open this dialog, you will
see some extra choices under Language Settings, as shown in Figure 25. These choices
(Searching in Japanese, Asian Layout, and Complex Text Layout) are not discussed here.

Enhanced language support — Ignore system input language

Default language settings depend on the Locale setting. The default locale is based on that
of the computer’s operating system. A keyboard layout is normally based on the language
used by the operating system but can be changed by the user. If this option is not selected,
and there is a change in keyboard layout, input from the keyboard will be different from what
is expected.

Choose spelling options

To choose the options for checking spelling, click Language Settings > Writing Aids. In the
Options section of the page (Figure 27), choose the settings that are useful for you.

Writing aids
Available language modules
™ Hunspell SpellChecker Edit...
@ Mac OS5 X Spell Checker
il 1 imbbmennt menmamane -~ bhonrsleme (Cmmlinkd

User-defined dictionaries

|| standard [All] New...
™ en-GB '[' English (UK) 1]’
™ en-Us ' English (USA} 'T
™ technical [All] Delete
[ IgnoreAllList [All]

Edit...

Options
IE Check spelling as you type Edit...

Check uppercase words
Check words with numbers

Get more dictionaries online...

Figure 27: Choosing languages, dictionaries, and options for checking spelling

Some considerations:

If you do not want spelling checked while you type, deselect Check spelling as you type.
This option can also be deselected using the AutoSpellcheck button on the Standard
toolbar.

If you want grammar to be checked as you type, you must have Check spelling as you
type enabled too.
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* If you use a custom dictionary that includes words in all upper case and words with
numbers (for example, AS/400), select Check uppercase words and Check words with
numbers.

* Check special regions includes headers, footers, frames, and tables when checking
spelling.

Here you can also check which user-defined (custom) dictionaries are active by default, and add or
remove user-installed dictionaries, by clicking the New or Delete buttons. Dictionaries installed by
the system cannot be deleted.

English sentence checking

On the Language Settings > English sentence checking page, you can choose which items are
checked for, reported to you, or converted automatically. This menu is also found in the English
dictionaries extension installed by default by LibreOffice. Select Tools > Extension Manager,
select the English spelling dictionaries and click the Options button to reveal the menu. Select
which of the optional features you wish to check.

After selecting the additional grammar checks, you must restart LibreOffice, or reload the
document, for them to take effect.

Grammar checking

Possible mistakes Capitalization
Word duplication Parentheses
Punctuation
] Word spacing Em dash
Quotation marks -4 Multiplication sign
Sentence spacing En dash
Apostrophe Ellipsis
More spaces Minus sign
Others

Convert to metric (*C, km/h, m, kg, [}
Thousand separation of large numbers
Convert to non-metric (*F, mph, ft, b, gal)

Figure 28: Choosing options for checking sentences in English

Grammar checking

Possible mistakes
Checks for things such as; with it’s, he don’t, this things and so on.

Capitalization
Checks for the capitalization of sentences. The sentence boundary detection depends on
abbreviations.

Word duplication
Checks for all word duplication, rather than just the default words ‘and’, ‘or’, ‘for’, and ‘the’.

Parentheses
Checks for pairs of parentheses and quotation marks.

Punctuation

Word spacing
This option is selected by default. It checks for single spaces between words, indicating
instances of double or triple spaces, but not of more spaces than that.
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Sentence spacing
Checks for a single space between sentences, indicating when one or two extra spaces are
found.

More spaces
Checks word and sentence spacing for more than two extra spaces.

Em dash; En dash
These options force a non-spaced em dash to replace a spaced en dash, or force a spaced
en dash to replace a non-spaced em dash.

Quotation marks
Checks for correct typographical double quotation marks.

Multiplication sign
This option is selected by default. It replaces an ‘X’ used as a multiplication symbol with the
correct typographical symbol.

Apostrophe
Replaces an apostrophe with the correct typographical character.

Ellipsis
Replaces three consecutive periods (full stops) with the correct typographical symbol.

Minus sign
Replaces a hyphen with the correct minus typographical character.

Others

Convert to metric; Convert to non-metric
Converts quantities in a given type of unit to quantities in the other type of unit: metric to
imperial or imperial to metric.

Thousands separation of large numbers
Converts a number with five or more significant digits to a common format, that is one which
uses the comma as a thousands separator, or to the 1ISO format which uses a narrow space
as a separator.

Choosing Internet options

The Internet options available depend on your operating system.
Use the Proxy page (if available) to save proxy settings for use with LibreOffice.

[§ Options - Internet - E-mail (X}
LibreOffice E %
Load/Save Sending documents as e-mail attachments
Language Settings : - - - p
LibreOffice Writer E-mail program |/usr/lib/thunderbird/thunderbird

LibreOffice Writer/Web
LibreOffice Base
Charts
Internet
Proxy .
I
Browser Plug-in
MediaWiki

 vvewwewvwvww

Figure 29: Internet options, showing E-mail page available to Linux users

If you are using a Mozilla browser (such as Firefox) on Windows or Linux, you can enable the
Browser Plug-in so you can open LibreOffice files in your browser, print them, save them, and work
with them in other ways.
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If you are using a Unix- or Linux-based operating system (including Mac OS X), an additional page
of E-mail options is available, where you can specify the e-mail program to use when you send the
current document as e-mail. Under Windows the operating system’s default e-mail program is
always used.

A MediaWiki publisher is included on Windows and Linux. To enable it, select MediaWiki in the
Internet options, then click the Add button to open the dialog shown in Figure 30. Here you can
specify the address (URL) and log-in information for a wiki. You can add several wikis to the list.

[§ Mediawiki
MediaWiki Server

URL [

Account

Username |

Password |

[ Save password

[ Help l 0K ] l Cancel

Figure 30: Specifying a MediaWiki server account

Controlling LibreOffice’s AutoCorrect functions

Some people find some or all of the items in LibreOffice’s AutoCorrect function annoying because
they change what you type when you do not want it changed. Many people find some of the
AutoCorrect functions quite helpful; if you do, then select the relevant options. But if you find
unexplained changes appearing in your document, this is a good place to look to find the cause.

To open the AutoCorrect dialog, click Tools > AutoCorrect Options. (You need to have a
document open for this menu item to appear.) In Writer, this dialog has five tabs, as shown in
Figure 31. In other components of LibreOffice, the dialog has only four tabs. More details are given
in the component guides.
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@ @ AutoCorrect
]. Replacements and exceptions for language: English (USA) <
Replace Exceptions _ Localized Options Word Completion

™M | M|

Use replacement table

o | Correct TWo INitial CApitals

Capitalize first letter of every sentence

Automatic *bold* and _underline_

URL Recognition

Replace dashes

Delete spaces and tabs at beginning and end of paragraph
Delete spaces and tabs at end and start of line

Ignore double spaces

Correct accidental use of cAPS LOCK key

Apply numbering - symbol; =

Apply border

Create table

| Apply Styles

Remove blank paragraphs

Replace Custom Styles

Replace bullets with: =

Combine single line paragraphs if length greater than 50%

[M]: Replace while modifying existing text
[T]: AutoCarrect while typing

Help GG  cancel Reset

Figure 31: The AutoCorrect dialog in Writer, showing some of the choices on the Options tab

Edit...
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