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Inserting comments in a drawing
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What is Draw?

LibreOffice Draw is a vector graphics drawing program, although it can also perform some
operations on raster graphics (pixels). Using Draw, you can quickly create a wide variety of
graphical images.

Vector graphics store and display an image as an assembly of simple geometric elements such as
lines, circles, and polygons, rather than a collection of pixels (points on the screen). Vector
graphics allow for easier storage and scaling of the image.

Draw is fully integrated into the LibreOffice suite, and this simplifies exchanging graphics with all
components of the suite. For example, if you create an image in Draw, reusing it in a Writer
document is as simple as copying and pasting the image. You can also work with drawings directly
from within Writer or Impress, using a subset of the functions and tools from Draw.

The functionality of LibreOffice Draw is extensive and, even though it was not designed to rival
high-end graphics applications, it possesses more functionality than the drawing tools that are
generally integrated with most office productivity suites.

A few examples of the drawing functions are: layer management, magnetic grid-point system,
dimensions and measurement display, connectors for making organization charts, 3D functions
that enable small three-dimensional drawings to be created (with texture and lighting effects),
drawing and page-style integration, and Bézier curves.

This chapter introduces some features of Draw and does not attempt to cover all of the Draw
features. See the Draw Guide and the application help for more information.

Draw main window

The main components of the Draw main window are shown in Figure 1:
* Menu bar
* Standard toolbar
* Pages pane
*  Workspace
« Status bar
» Drawing toolbar
* Sidebar

Workspace

The large area in the center of the window (Workspace) is where you create your drawings and
this drawing area can be surrounded with toolbars and information areas. The number and position
of the visible tools vary with the task in hand and user preferences, therefore your setup may look
different from Figure 1.

In LibreOffice Draw, the maximum size of a drawing is 300 cm by 300 cm.
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Drawing toolbar Menu bar

@l Untitled 1 - LibreOffice Draw *
Edit View Inset Format JTools Modify Window Help
-BE-HEH BABE &=

Pages ¥ |1

i -

-- i ==

E-

Standard toolbar

AeTA O -B-%-

~

Workspace

2 - Status bar

H Layout

W
¥
Controls Dimension Lines |

Shape selected 153 4.00 /

Figure 1: LibreOffice Draw workspace

Pages pane
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Sidebar
- ] b4
x
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Froperties x =
Character e
» Paragraph =
4 Area [ i
Eill: @|
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Transparency: -
Mone W 0%
4 Line
Width:
Color: = -
Transparency: 0% 5
Sty le:
- Continuous
Brrow:
= none - w
- none - w
L
Ed Slide 1 of 1 (Layout) | Default | <+

You can split drawings in Draw over several pages. Multi-page drawings are used mainly for
presentations. The Pages pane gives an overview of the pages that you create in your drawing. If
the Pages pane is not visible, go to View on the Menu bar and select Page Pane. To make
changes to the page order, drag and drop one or more pages.

Sidebar

The Sidebar has four main sections. To expand a section you want to use, click on its icon or click
on the small triangle at the top of the icons and select a section from the drop down list. Only one
section at a time can be open. If the Sidebar is not visible, go to View on the Menu bar and select

Sidebar from the context menu.

Properties

Opens sub-sections for object properties that you can change to suit your requirements. The
sub-sections are Insert Shapes, Character, Paragraph, Area, Line and Position and Size.

Styles and Formatting @

Here you can edit and apply image styles to objects within your drawing. When you edit a
style, the changes are automatically applied to all of the elements formatted with this image

style in your drawing.
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Gallery

Opens the Drawing gallery where you can insert an object into your drawing either as a copy
or as a link. A copy of an object is independent of the original object. Changes to the original
object have no effect on the copy. A link remains dependent on the original object. Changes
to the original object are also reflected in the link.

Navigator =
Opens the Drawing navigator, in which you can quickly move between pages in your drawing
or select an object on the drawing. It is recommended to give pages and objects in your
drawing meaningful names so that you can easily identify them when using the Navigator.

Rulers

You should see rulers (bars with numbers) on the upper and left-hand sides of the workspace. If
they are not visible, you can enable them by selecting View > Ruler in the Menu bar. The rulers
show the size of a selected object on the page using double lines (highlighted in Figure 2). When
no object is selected, they show the location of the mouse pointer, which helps to position drawing
objects more accurately.

You can also use the rulers to manage object handles and guide lines, making it easier to position
objects.

The page margins in the drawing area are also represented on the rulers. You can change the
margins directly on the rulers by dragging them with the mouse. The margin area is indicated by
the grayed out area on the rulers as shown in Figure 2.

rmzsanﬂ-s@

Figure 2: Rulers showing size of a selected object

To change the measurement units of the rulers, which can be defined independently, right-click on
a ruler and select the measurement unit from the drop down list, as illustrated for the horizontal
ruler in Figure 3.
| T e e T

Millimeter
' Centimeter
Meter
Kilometer
Inch
Foot
Miles
Poinkt
Pica
Char
Line

Figure 3: Ruler units
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Status bar

The Status bar is located at the bottom of the workspace in all LibreOffice components. It includes
several Draw-specific fields. For details on the contents and use of these fields, see Chapter 1
Introducing LibreOffice in this guide and in the Draw Guide Chapter 1 Introducing Draw.

Information area Object size  Digital signature Zoom slider
| Shape selected 1 076/064  :£572x4.19 K, Slide 1/1 (Layout) Default - ——C0— + 100%
Position Unsaved changes Slide number Zoom percentage

Figure 4: Draw status bar

6 Note

The sizes are given in the current measurement unit. They might not be the same as
the ruler units. The measurement unit on the Status bar is defined in Tools > Options
> LibreOffice Draw > General, where you can also change the scale of the page.

Toolbars

To display or hide the various Draw toolbars, go to View > Toolbars on the Menu bar. On the
menu that appears, select which toolbars you want to display. For more about working with
toolbars, see Chapter 1 Introducing LibreOffice in this guide.

The tools available in the Draw toolbars are explained in the following sections. The appearance of
the toolbar icons may vary depending on your operating system and the selection of icon size and
style in Tools > Options > LibreOffice > View.

Standard toolbar

The Standard toolbar is the same for all LibreOffice components and is not described in detail in
this chapter. By default, it is located just under the Menu bar.

Drawing toolbar

The Drawing toolbar is the most important toolbar in Draw. It contains all the necessary functions
for drawing various geometric and freehand shapes and for organizing them on the page. By
default, it is docked vertically on the left side of the Draw window.

Line and Filling toolbar

The Line and Filling toolbar lets you modify the main properties of a drawing object. The icons
and pull-down lists vary according to the type of object selected. For example, to change the style
of a line, click on the up and down arrows for Line Style and select the required style.

The functions on this toolbar are also provided in the Properties pane of the sidebar when a
drawing object is selected. By default, the Line and Filling toolbar is not shown, but you can display
it from the View > Toolbars menu.

Text Formatting toolbar

If the selected object is text, the Sidebar shows relevant formatting choices in the Properties pane.
By default, the Text Formatting toolbar is not shown, but you can display it from the View >
Toolbars menu. If you have enabled both the Line and Filling toolbar and the Text Formatting
toolbar, Draw switches between them depending on what object is selected.

Draw main window | 9



Options toolbar

Use the Options toolbar to activate or deactivate various drawing aids. By default, the Options
toolbar is not shown, but you can display it from the View > Toolbars menu.

Choosing and defining colors

To display the Colors dialog (Figure 5), select View > Toolbars > Color Bar to display the current
color palette. By default, the Color Bar is displayed below the workspace. You can hide or show it
by clicking on its Hide/Show button. Here you can rapidly choose the color of objects in your
drawing (lines, areas, and 3D effects). The first box corresponds to none (no color).

2k 26 24

~

H 4+ M [ Layout | Controls Dimension Lines |
(I 0 ][] O .-
|

LK
BN ) (U (N O - ]
L JC )N . )
(__JC__ ) (S (N ) (N S N
pm— ) L B
| /NN N N NN N NN NN G e
ey )
(NN NN NN NN NN NN NN NN NN N
EE N N . e

Figure 5: Color bar

You can access several specialized color palettes in Draw, as well as change individual colors to

your own taste. To

do this, use the Area dialog by selecting Format > Area on the Menu bar or

clicking the Area icon a on the Sidebar, then selecting the Colors tab (Figure 6).

@ Area
Area  Shadow  Transparency ﬁ Gradients  Hatching  Bitmaps
Properties
Name: ITango: Sky Blue 1 | Add
Color: | [ Tango: Sky Blue 1 E Modify
Table: standard ~ Delete
(W T TTTTTN
/N (.
et -
AN N R 114 [
BEEE T T T -
EREEES [ INEen G 159 2]
EEEEEEES EN -
| HNEEN AN e B 207 2]
C ]|
Pick...
| Embed
Help Cancel | | Reset

Figure 6: Area dialog — Colors page
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To load another palette, click on the Load Color List icon . The file selector dialog asks you to
choose one of the standard LibreOffice palettes (files with the file extension *.soc). For example,
web . soc is a color palette that is adapted to creating drawings for placing in web pages. These
colors will display correctly on workstations with screens capable of at least 256 colors.

The color selection box also lets you individually change any color by modifying the numerical
values in the fields provided to the right of the color palette. You can use the color schemes known
as CMYK (Cyan, Magenta, Yellow, Black) or RGB (Red, Green, Blue).

Click on the Pick button to open the Pick a Color dialog, where you can set individual colors. See
“Color options” in Chapter 2 Setting Up LibreOffice in this guide.

For a more detailed description of color palettes and their options, see the Draw Guide Chapter 10
Advanced Draw Techniques.

Drawing basic shapes

Draw provides a wide range of shapes, located in palettes accessed from the Drawing toolbar.

This section describes only a few of the basic shapes, including text, which are treated as objects
in Draw. See the Draw Guide for a complete description of the shapes available.

Some of the icons on the Drawing toolbar will change according to the shape that has been
selected from the choices available. Icons with tool palettes available are indicated by a small
triangle to the right of the icon.

e Note

When you draw a basic shape or select one for editing, the Info field at the left side in
the status bar changes to reflect the present action: for example Line created, Text
frame xxyy selected, and so on.

Drawing a straight line

Click on the Line icon // and place the cursor at the point where you want to start the line (Figure
7). Drag the mouse while keeping the mouse button pressed. Release the mouse button at the
point where you want to end the line. A selection handle appears at each end of the line, showing
that this object is the currently selected object. The selection handle at the starting point of the line
is slightly larger than the other selection handle.

Keep the Ctrl key pressed while drawing a line to enable the end of the line to snap to the nearest
grid point.

“ Note

This is the default behavior of the Ctrl key. However, if the Snap to Grid option on the
View > Grid menu has been selected, the Ctrl key deactivates the snap to grid activity.

Keep the Shift key pressed while you draw a line to restrict the drawing angle of the line to a
multiple of 45 degrees (0, 45, 90, 135, and so on).

“ Note

This is the default behavior of the Shift key. However, if the option When creating or
moving objects in the Snap position section of Tools > Options > LibreOffice Draw >
Grid has been selected, the action of the Shift key is the opposite. Lines will
automatically be drawn at a multiple of 45 degrees unless the Shift key is pressed.
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Starting point

Figure 7: Drawing a straight line

Hold down the Alt key while drawing a line to cause the line to extend outwards symmetrically in
both directions from the start point. This lets you draw lines by starting from the middle of the line.

When a line is drawn, it uses default attributes. To change any of these attributes, select a line by
clicking on it, then right-click and select Line from the context menu or go to Format > Line on the
Menu bar to open the Line dialog (Figure 8). Alternatively, click on the Properties icon on the
Sidebar and open the Line sub-section. Line style, line width, and line color can also be changed
using the controls in the Line and Filling toolbar at the top of the workspace.

e Line
| Line | Line Styles  Arrow Styles
Line Properties Arrow Styles
Style: Start style: End style:
Continuous el -— Arrow [4] =% Square | &4

Color: Width: Width:

I Tango: Sky Blue 2 = 0.08" [ 0.08" [
Width: Center Center

0.00"| 2] Synchronize ends
Transparency: Corner and Cap Styles

0% | |° Carner style: Cap style:

Rounded | < | Flat | < |
™ A
™ VAN
= ] . N
S N
Help Lok | cancel Reset

Figure 8: Line dialog

Drawing an arrow
Arrows are drawn like lines. In fact Draw classifies arrows as a subgroup of lines: lines with
arrowheads. The information field on the status bar shows them only as lines. Click on the Line

Ends with Arrow icon =% on the Drawing toolbar or the Insert Shapes sub-section in Sidebar
Properties to draw an arrow. The arrow head is drawn at the end point of the arrow when you
release the mouse button.

Choosing line endings
Several types of line endings (arrows, circles, squares, and others) are available in Draw. Click on

the small triangle to the right of the Lines and Arrows =¥ icon on the Drawing toolbar or the
Insert Shapes sub-section in Sidebar Properties to open a tool palette containing tools for drawing
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lines and arrows. Alternatively, go to View > Toolbars > Arrows to open the Arrows toolbar as a
floating toolbar (Figure 9). The icon for the tool used most recently will be shown on the Drawing
toolbar to make it easier to use the same tool again.

.‘_
After drawing the line, you can change the arrow style by clicking on the Arrowheads icon = in
the Line and Filling toolbar and select the arrow start and end options.

Arrows ¥ X
P I R R P e N R
|/ Line

|=# Line Ends with Arrow
|+ Line with Arrow/Circle
|#a| Line with Arrow/Square

|l Line (45°)

| Line Starts with Arrow
|+ Line with Circle/Arrow
|=+/ Line with Sguare/Arrow

[+ Dimension Line
\## Line with Arrows

Figure 9: Arrows toolbar and available tools

Drawing rectangles or squares

Drawing a rectangle is similar to drawing a straight line. Click on the Rectangle icon [& in the
Drawing toolbar or the Insert Shapes sub-section in Sidebar Properties. As you draw the rectangle
with the mouse cursor, the rectangle appears with its bottom right corner attached to the cursor.

Squares are rectangles with all sides of equal length. To draw a square, click on the Rectangle
icon [ and hold down the Shift key whilst you draw a square.

e Note

If the option When creating or moving objects has been selected in Tools > Options >
LibreOffice Draw > General, the action of the Shift key is reversed. When the
Rectangle tool is selected, a square is drawn. To draw a rectangle, you have to press
the Shift key when drawing. This Shift key reversal also applies when drawing ellipses
and circles.

To draw a rectangle or square from its center rather than the bottom right corner, position your
cursor on the drawing, press the mouse button and then hold down the Alt key while dragging with
the cursor. The rectangle or square uses the start point (where you first clicked the mouse button)
as the center.

Drawing circles or ellipses

To draw an ellipse (also called an oval), click on the Ellipse icon @ on the Drawing toolbar or the
Insert Shapes sub-section in Sidebar Properties. A circle is an ellipse with both axes the same
length. To draw a circle, click on the Ellipse icon and hold down the Shift key whilst you draw a
circle.
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To draw an ellipse or circle from its center, position your cursor on the drawing, press the mouse
button and then hold down the Alt key while dragging with the cursor. The ellipse or circle uses the
start point (where you first clicked the mouse button) as the center.

6 Note

If you first press and hold down the Ctrl key and then click on one of the icons for Line,
Rectangle, Ellipse, or Text, a standard sized object is drawn automatically in the work
area; the size, shape, and color are all standard values. These attributes can be
changed later, if desired. See the Draw Guide for more information.

Drawing curves or polygons

To draw a curve or polygon click the Curve icon "g on the Drawing toolbar or the Insert Shapes
sub-section in Sidebar Properties. Click on the triangle to the right of the icon to open the tool
palette containing tools that are available for drawing curves and polygons (Figure 10). The icon for
the tool used most recently will be shown on the Drawing toolbar to make it easier to use the same
tool again.

If you move the mouse cursor over one of the icons, a tooltip pops up with a description of the
function.

Xy

Curve, Filled
Polygon, filled
Polygon (45°), Filled
Free-form Line, Filled

Curve
Polygon

Polygon (45°)
Free-form Line

NP PR

Figure 10: Curves (Lines) toolbar and available tools

“ Note

Hovering the mouse pointer over this icon gives a tooltip of Curve. If you open the
floating toolbar, the title is Lines, as shown in Figure 10.

Holding down the Shift key when drawing lines with the Curve or Polygon tools will
restrict the angles between the lines to 45 or 90 degrees.

Curves

Click and hold the left mouse button to create the starting point of your curve, then, while holding
down the left mouse button, drag from the starting point to draw a line. Release the left mouse
button and continue to drag the cursor to bend the line into a curve. Click to set the end point of the
curve and fix the line on the page. To continue with your line, drag the mouse cursor to draw a
straight line. Each mouse click sets a corner point and allows you to continue drawing another
straight line from the corner point. A double click ends the drawing of your line.
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Afilled curve automatically joins the last point to the first point to close off the figure and fills it with
the current standard fill color. A curve without filling will not be closed at the end of the drawing.

Polygons

Click and draw the first line from the start point with the left mouse button held down. As soon as
you release the mouse button, a line between the first and second points is drawn. Move the
cursor to draw the next line. Each mouse click sets a corner point and allows you to draw another
line. A double-click ends the drawing.

A filled polygon automatically joins the last point to the first point to close off the figure and fills it
with the current standard fill color. A polygon without filling will not be closed at the end of the
drawing.

Polygons 45°

Like ordinary polygons, these are formed from lines, but the angles between lines are restricted to
45 or 90 degrees.

Freeform lines

Using the freeform line tools is similar to drawing with a pencil on paper. Press and hold the left
mouse button and drag the cursor to the line shape you require. It is not necessary to end the
drawing with a double-click, just release the mouse button and the drawing is completed.

If Freeform Line Filled is selected, the end point is joined automatically to the start point and the
object is filled with the appropriate color.

Adding text

To activate the text tool, click on the Text icon T for horizontal text or the Vertical Text icon ™ for
vertical script. If the Vertical Text icon is not visible, check that Asian has been selected in Tools >
Options > Language Settings > Languages. You can display the Text Formatting toolbar (View >
Toolbars) or use the Character section in the Properties pane of the Sidebar to select font type,
font size, and other text properties before you start typing.

After activating the Text command, click at the location where you want to position the text. A small
text frame appears, containing only the cursor. This frame can be moved like any other object. A
text frame is also dynamic and grows as you enter text.

The information field in the status bar shows that you are editing text and also provides details
about the current cursor location using paragraph, row, and column numbers (Figure 11).

Typing text in a frame
(text box).

| Layout | Controls | Dimension Lines |
_ TextEdit: Paragraph 1, Row 2, Column 11 13 0.15/8.90

Figure 11: Text information on the Status Bar

You can insert a line break with the Shift+Enter key combination or start a new paragraph with the
Enter key. The insertion of line breaks or new paragraphs does not terminate text editing or
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deselect the text frame. When you have finished typing text, click outside the text frame to cancel
adding or editing text.

Text properties can also be changed during text input, with any changes taking effect from the
cursor position onwards. To change the properties for all of the text in the text frame, you have to
highlight all text in the text frame.

You can create Graphic styles that you can reuse for other text frames. Select Format > Styles
and Formatting or press F11 to open the Styles and Formatting dialog, or click on the Styles and

Formatting icon II on the Sidebar. Graphic styles affect all of the text within a text frame. To only
format parts of the text, use direct formatting with the Text Formatting toolbar or the Character and
Paragraph sub-sections in Sidebar Properties.

Text frames can also have fill colors, shadows, and other attributes, just like any other Draw object.
You can rotate the frame and write the text at any angle. These options are available by right-
clicking on the text frame itself.

If you double-click on a graphic object, or press F2 or click on the Text icon when an object is
selected, you can add text to the graphic object. This text then becomes part of the graphic object.

A graphic object is not dynamic and does not behave like a text frame. To keep text within the
borders of the object, you have to use paragraphs, line breaks, or smaller text size, increase the
object size, or combine all four methods.

For more information about text, see the Draw Guide Chapter 2 Drawing Basic Shapes and
Chapter 9 Adding and Formatting Text.

Glue points and connectors

Glue points

All Draw objects have glue points, which are not normally displayed. Glue points become visible

when the Connectors icon “ls is selected on the Drawing toolbar or the Insert Shapes
sub-section in Sidebar Properties. Most objects have four glue points (Figure 12). You can add
more glue points and customize glue points, using the Glue Points toolbar (Figure 13). Go to View
> Toolbars > Glue Points on to open the toolbar.

Glue points are not the same as the selection handles of an object. The handles are for moving or
changing the shape of an object. Glue points are used to fix or glue a connector to an object so
that when the object moves, the connector stays fixed to the object. For a more detailed
description on the use of glue points, see the Draw Guide Chapter 3 Working with Objects and
Object Points and Chapter 8 Connections, Flowcharts and Organization Charts.

Figure 12: Glue points
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Connectors

Connectors are lines or arrows whose ends automatically snap to a glue point of an object.

Connectors are especially useful in drawing organization charts, flow diagrams, and mind-maps.
When objects are moved or reordered, the connectors remain attached to a glue point. Figure 14
shows an example of two objects and a connector.

Gluepoints ~ vXx
hEaEd |®EHEE ML
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Insert Glue Point

Exit Direction Left
Exit Direction Top
Exit Direction Right
Exit Direction Bottom

Glue Point Relative

Glue Point Horizontal Left
Glue Point Horizontal Center
Glue Point Horizontal Right

Glue Point Vertical Top
Glue Point Vertical Center
Glue Point Vertical Bottom

Figure 13: Glue Points toolbar and available tools

Draw offers a range of different connectors and connector functions. On the Drawing toolbar or the
Insert Shapes sub-section in Sidebar Properties, click on the triangle next to the Connector icon

o to open the Connectors toolbar (Figure 15). For a more detailed description of the use of
connectors, see the Draw Guide Chapter 8 Connections, Flowcharts and Organization Charts.

Figure 14: A connector between two objects
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Figure 15: Connectors toolbar
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Drawing geometric shapes

The icons for drawing geometric shapes are located on the Drawing toolbar. The geometric shapes
are explained in the following sections. Clicking on the triangle to the right of the icon on the
Drawing toolbar opens a floating toolbar giving access to the tools for that shape.

P Tip

The use of these tools for geometric shapes is similar to the tool used for drawing
rectangles or squares. For more information, see page 13 and the Draw Guide Chapter
2 Drawing Basic Shapes.

‘ Note

The icons for geometric shapes displayed on the Drawing toolbar will change shape
according to the last tool selected and used to draw an object.

Basic shapes

Click on the triangle to the right of the Basic Shapes icon @ to open the Basic Shapes toolbar.
This toolbar also includes a rectangle tool identical to the one on the Drawing toolbar.

Basic Shapes v X
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Figure 16: Basic Shapes toolbar

Symbol shapes

Click on the triangle to the right of the Symbol Shapes icon @ to open the Symbol Shapes
toolbar.

Symbol Shapes v X
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Figure 17: Symbol Shapes toolbar

Block arrows

Click on the triangle to the right of the Block Arrows icon %+ to open the Block Arrows toolbar.

Block Arrows -
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Figure 18: Block Arrows toolbar
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Flowcharts
Click on the triangle to the right of the Flowcharts icon ﬁ to open the Flowchart toolbar for
symbols used in drawing flowcharts. The creation of flowcharts, organization charts, and similar

planning tools is further described in the Draw Guide Chapter 8 Connections, Flowcharts and
Organization Chatrts.

Flowchart v
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Figure 19: Flowcharts toolbar

Callouts
Click on the triangle to the right of the Callouts icon [;] to open the Callouts toolbar.

Callouts v X
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Figure 20: Callouts toolbar

Stars and banners

Click on the triangle to the right of the Stars icon 'ﬁ' to open the Stars and Banners toolbar.

Stars and Banners * ¥

WY RERBRSREER@

Figure 21: Stars and Banners toolbar

Note

You can add text to all of these geometric shapes. For more information, see the Draw
Guide Chapter 2 Drawing Basic Shapes and Chapter 10 Advanced Draw Techniques.

Selecting objects

Direct selection

The easiest way to select an object is to click directly on it. For objects that are not filled, click on
the object outline to select it. One click selects; a second click deselects. To select or deselect
more than one object, hold the shift button down while clicking.

Selection by framing

You can also select several objects at once by dragging the mouse cursor around the objects. This
cursor dragging draws a rectangle around the objects and only objects that lie entirely within the
rectangle will be selected.
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To select multiple objects by framing, the Select icon on the Drawing toolbar must be active.

“ Note

When dragging the mouse cursor to select multiple objects, the selection rectangle
being drawn is also known as a marquee.

Selecting hidden objects

Even if objects are located behind others and not visible, they can still be selected. Hold down the
Alt key and click on the object at the front of where the hidden object is located, then click again to
select the hidden object. If there are several hidden objects, keep holding down the Alt key and
clicking until you reach the object you want. To cycle through the objects in reverse order, hold
down the Alt+Shift keys and click.

When you click on the selected object, its outline will appear briefly through the objects covering it.

e Note

Using the Alt key method works on computers using a Windows or Mac operating
systems. On a computer using a Linux operating system the Tab key method,
described below, has to be used.

To select an object that is covered by another object using the keyboard, use the Tab key to cycle
through the objects, stopping at the object you want to select. To cycle through the objects in
reverse order, press Shift+Tab. This is a very quick way to reach an object, but it may not be
practical if there a large number of objects in a drawing.

Arranging objects

In a complex drawing, several objects may be stacked on top of one another. To rearrange the
stacking order by moving an object forward or backward, select an object, click Modify > Arrange
on the Menu bar and select Bring Forward or Send Backward. Alternatively, right-click the object,
select Arrange from the context menu, then Bring Forward or Send Backward.

The arrange options are also available by clicking on the small triangle to the right of the Arrange

icon on the Line and Filling toolbar. This opens the Position toolbar giving access to the
various arrangement options (Figure 22).

Position v x
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Bring to Front
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Send Backward
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In Front of Object
Behind Object
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Reverse

Figure 22: Position toolbar and available tools
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Moving and adjusting object size

When moving an object or changing its size, check the left-hand area of the status bar at the
bottom of the Draw window (Figure 23). The area on the left of the Status bar, from left to right,
shows what object is selected, its position on the drawing in X/Y coordinates and dimensions of the
object. The units of measurement are those selected in Tools > Options > LibreOffice Draw >
General.

For more information on moving and adjusting object size, see the Draw Guide Chapter 3 Working
with Objects and Object Points.
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Figure 23: Left end of status bar when moving or adjusting an object

Moving objects

To move an object (or a group of objects), select it and then click within the object borders and hold
down the left mouse button while dragging the mouse. During movement, the ghost image of the
object appears to help with repositioning (Figure 24). To locate the object at its new location,
release the mouse button.

Figure 24: Moving an object

Adjusting object size

To change the size of a selected object (or a group of selected objects), move the mouse cursor to
one of the selection handles. The mouse cursor will change shape to indicate the direction of
movement for that selection handle. As you change the size of the object, a ghosted outline of the
object appears (Figure 25). When you have reached the desired size of the object, release the
mouse button.

The results depend on which selection handle you use. To resize an object along one axis, use a
side handle. To resize along both axes, use a corner handle.

Figure 25: Adjusting object size
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' Note

If you press the Shift key while resizing an object, the change in size will be carried out
symmetrically with respect to the two axes so that the aspect ratio of the object remains
the same. This Shift key behavior works on all selection handles.

This is the default behavior of the Shift key. However, if When creating or moving
objects has been selected in Tools > Options > LibreOffice Draw > Grid, the action
of the Shift key is reversed and the aspect ratio will be preserved unless the Shift key is
pressed.

Rotating and slanting an object

For more information on rotating and slanting an object, see the Draw Guide Chapter 3 Working
with Objects and Object Points.

Rotating an object

To rotate an object (or a group of objects), select the object, then go to rotation mode using one of
the following methods:

* Click on the Rotate icon @“ on the Line and Filling toolbar.

¢ Goto View > Toolbars > Mode and select the Rotate icon @h

The selection handles will change shape and color (Figure 26). Also a rotation point will appear in
the center of the object. As you move the mouse cursor over the handles, the cursor changes
shape. The corner handles are for rotating an object and the top, bottom and side handles are to
slant an object.

Figure 26: Rotating an object

Move the mouse cursor to one of the corner handles and it normally changes to an arc with an
arrow at each end. Click and hold the mouse button, then start to move the cursor to rotate the
object. A ghost image of the object being rotated appears and the current angle of rotation is
shown in the status bar.

' Note

Rotation works differently for 3D objects because rotation occurs in global axes and not
in a single axis. See the Draw Guide Chapter 7 Working with 3D Objects for more
information.
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The rotation point is normally located at the center of an object. To change the position of the
rotation point, click on the object with the mouse cursor and drag the object until the rotation point
is at the desired position. This rotation point can even be outside of the object.

“ Note

If you press the Shift key while rotating an object, rotation will be restricted to 15° of
movement.

This is the default behavior of the Shift key. However, if When creating or moving
objects has been selected in Tools > Options > LibreOffice Draw > Grid, the action
of the Shift key is reversed and rotation will be restricted to 15° of movement unless the
Shift key is pressed.

Slanting an object

To slant an object, use the handles located at the midpoints on the top, bottom and sides of a
selected object. The mouse cursor changes when it hovers over one of these midpoint handles.
The axis used for slanting an object is the object edge directly opposite the midpoint handle being
used to slant the object. This axis stays fixed in location while the other sides of the object move in
relation to it as you drag the mouse cursor.

Click and hold the mouse button, then start to move the cursor to shear the object. A ghost image
of the object being slanted appears (Figure 27) and the current angle of slant is shown in the status
bar.

6 Note

If you press the Shift key while slanting an object, slanting will be restricted to 15° of
movement. This is the default behavior of the Shift key. However, if When creating or
moving objects has been selected in Tools > Options > LibreOffice Draw > Grid, the
action of the Shift key is reversed and slanting will be restricted to 15° of movement
unless the Shift key is pressed.

Figure 27: Slanting an object

Rotating and slanting an object | 23



Editing objects

To edit an object or change attributes such as color or border width, the Line and Filling toolbar, the
Text Formatting toolbar, the Sidebar Properties section, or a context menu can be used. More
information on editing objects and changing attributes can be found in the Draw Guide Chapter 4
Changing Object Attributes.

Line and Filling toolbar

By default, the Line and Filling toolbar in Draw is not shown. To display it, go to View > Toolbars
> Line and Filling on the Menu bar to open the toolbar (Figure 28) at the top of the workspace.
The most common object attributes can be edited using this toolbar. You can also open the Line

dialog by clicking on the Line icon ﬁ and the Area dialog by clicking on the Area icon & for
access to more formatting options.

utneandFiling
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Styles and Formatting |[@) AreaStyle/Filling
@ Line |=| shadow
(=) Arrow Style &y ImageMap
| Linestyle |&| Effects
[ Linewidth % Flip
B Position and Size
|@) Line Color [=¢] Alignment
@ Area |dis| Arrange

Figure 28: Line and Filling toolbar and its available tools

Text Formatting toolbar

You can open the Text Formatting toolbar by selecting View > Toolbars > Text Formatting on the
Menu bar. The tools on this toolbar will not become active until text has been selected.
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Figure 29: Text Formatting toolbar and its available tools
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Sidebar Properties

When you select an object in your drawing, the sub-sections in Sidebar Properties become active
(Figure 30). You can change the properties or options of an object without having to open a dialog
or use any of the available tools on the various toolbars provided by Draw. To expand a sub-

section, click on the plus (+) sign or arrow next to the sub-section title.
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Paragraph &
E Area =
Line =
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Position and Size

Figure 30: Sub-sections in Sidebar Properties

Context menu

When an object is selected and you right-click on the object, a context menu (Figure 31) opens that
applies to the selected object. You can change object attributes without having to open a dialog.

Menu entries with a small arrow on the right-hand side contain a submenu.

Line...
Area...
Texk...
Position and Size...

Character...
Paragraph...

LS F 9=

T
Alignment
Flip
Convert

Description...

Bring to Front
Bring Forward
Send Backward
send to Back

Behind Object

In Front of Object

L |dd BT T

Figure 31: Example of a context menu

Formatting lines and borders

In LibreOffice the term line indicates both a freestanding segment (line), outer edge of a shape
(border), or an arrow. In most cases the properties of the line you can modify are its style (solid,

dashed, invisible, and so on), its width, and its color.
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Select the line you need to format and then use the controls on the Line and Filling toolbar to
change the most common options (highlighted in Figure 32).

B A<- 2 /020" ; |NEEM Tango:: |[@& |None % | s (@) |kd - 2 -
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Figure 32: Common line properties (style, color, width)

If you need to fine tune the appearance of a line, choose Format > Line from the Menu bar, or

right-click on the line and select Line from the context menu, or select the Line icon & from the
Line and Filling toolbar. All of these methods open the Line dialog (Figure 9 on page 13), where
you can set line properties. This dialog consists of three pages: Line, Line Styles, and Arrow
Styles. Alternatively, use the Line sub-section in Sidebar Properties to change the appearance of a
line.

Arrows, arrowheads, and line endings

Arrows, arrowheads, and other line endings are usually referred to as arrows and can be treated
the same as lines when editing and changing attributes. Select a line and click on the Arrow Style

.'__
icon —# from the Line and Filling toolbar to open the Arrowheads menu (Figure 33).
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Figure 33: Arrowheaas menu

Several types of arrowheads are available. Each end of a line can have a different arrowhead or no
arrowhead). Arrowheads are only applicable to lines and they have no effect on the border of an
object.

Formatting area fill

The term area fill refers to the inside of an object, which can be a uniform color, gradient, hatching
pattern, or bitmap (Figure 34). An area fill can be made partly or wholly transparent. In most cases,
you will choose one of the standard fill options, which are all available from the Line and Filling
toolbar, or the Area sub-section in Sidebar Properties. You can also define your own area fills. For
more information on formatting area fill, see the Draw Guide Chapter 4 Changing Object Attributes.
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Figure 34: Different types of area fill

Using styles

Suppose that you want to apply the same area fill, line thickness, and border to a set of objects.
This repetitive process can be greatly simplified by the use of styles. Styles allow you to define a
format (a style) and then apply that format to multiple objects. For more information on styles, see
Chapter 3 Using Styles and Templates in this guide, the Writer Guide Chapter 6 Introduction to
Styles, and the Draw Guide Chapter 4 Changing Object Attributes.

Positioning objects

Snap function

In Draw, objects can be accurately and consistently positioned using the snap function. Grid points,
shap points and lines, object frames, individual points on objects, or page edges can all be used
with the snap function.

Snap function is easier to work with at the highest zoom values that are practical for your display.
Two different snap functions can be used at the same time; for example snapping to a guide line
and to the page edge. It is recommended, however, to activate only the functions that you really

need.

For more detailed information about the snap function, see the Draw Guide Chapter 3 Working
with Objects and Object Points and Chapter 10 Advanced Draw Techniques.

Snap to grid

Use Snap to grid to position an object to a grid point. Go to View > Grid > Snap to Grid on the
Menu bar or click on the Snap to Grid icon on the Options toolbar to turn on or off the snap to grid
function. If the Options toolbar is not visible, go to View > Toolbars > Options on the Menu bar.

Figure 35: Positioning with snap to grid
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Displaying the grid
To display the grid in Draw or to switch off the grid, go to View > Grid > Display Grid on the Menu
bar or click on the Display Grid icon on the Options toolbar.

Configuring the grid
The resolution, snap and snap position of the grid points can be configured. Go to Tools >
Options > LibreOffice Draw > Grid on the Menu bar to open the options dialog for the grid.

Grid
[ Snap to grid
[7] visible grid
Resolution Subdivision
Horizontal: |E = Horizontal: |E - | space(s)
Vertical: |@C Vertical: |£ - space(s)

["] synchronize axes

Snap Snap position

(] Tosnap lines ] when creating or moving objects

[ To the page margins & Extend edges

[] To object frame ] When rotating 15.00° |-

[C] To object points ]
e bl Point reduction |15.00° <

Snap range |-5pixels =

Figure 36: Configuring the grid

» Vertical and horizontal spacing of the dots in the grid. You can also change the unit of
measurement used in the general Draw options by going to Tools > Options > LibreOffice
Draw > General.

* The resolution is the size of the squares or rectangles in the grid. If the resolution is 1 cm
horizontal and 2 cm vertical, the grid consists of rectangles 2 cm high and 1 cm wide.

* Subdivisions are additional points that appear along the sides of each rectangle or square
in the grid. Objects can snap to subdivisions as well as to the corners of the grid.

* The pixel size of the snap area defines how close you need to bring an object to a snap
point or line before it will snap to it.

» The default color of the grid is light gray. To change the color of the grid points, go to Tools
> Options > LibreOffice > Appearance on the Menu bar.

Help lines

Draw has help lines to easily allow you to position an object using the rulers at the top and left side
of the workspace. To turn on or off the help lines, go to Tools > Options > LibreOffice Draw >
View on the Menu bar and select Snap Lines when moving option or go to the Options toolbar

and click on the Helplines While Moving icon .
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Applying special effects

With Draw, you can apply many special effects to objects and groups of objects. This section is an
introduction to some of these effects. For more information on special effects, see the Draw Guide
Chapter 4 Changing Object Attributes.

To access the tools used for special effects, go to View > Toolbars > Mode (Figure 37). Rotate
and Flip can also be accessed by going to Modify on the Menu bar or by right-clicking on the
object and using the context menu.
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Gradient
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Figure 37: Mode toolbar and its available tools

Flipping objects
The quickest and easiest method to flip an object horizontally or vertically is as follows:

1) Click on a graphic object and the selection handles will show.

2) Right-click and select Flip > Vertically or Horizontally, or go to Modify > Flip > Vertically
or Horizontally on the Menu bar and the selected object will be flipped to face the other
direction.

However, the Flip tool on the Mode or Drawing toolbar can be used to give you greater control
over the flipping process. Using the Flip tool allows you to change the position and angle that the
object flips over and this is described in the Draw Guide Chapter 4 Changing Object Attributes.

Mirror copies

At the moment no mirror command exists in Draw. However, mirroring an object can be emulated
by using the Flip tool, as described in the Draw Guide Chapter 4 Changing Object Attributes.

Distorting an object

Three tools on the Mode toolbar let you drag the corners and edges of an object to distort the
image.

;j? Distort tool distorts an object in perspective.
Eﬂl Set to Circle (slant) creates a pseudo three-dimensional effect.

Eﬁ? Set in Circle (perspective) creates a pseudo three-dimensional effect.
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In all three cases you are initially asked if you want to transform the object to a curve. This is a
necessary first step, so click Yes. Then you can move the object handles to produce the desired
effect. See the Draw Guide Chapter 4 Changing Object Attributes for maore information on how to
distort an object.

Dynamic transparency gradients

You can control transparency gradients in the same manner as color gradients. Both types of
gradient can be used together. With a transparency gradient, the direction and degree of object fill
color changes from opaque to transparent. In a regular gradient, the fill changes from one color to
another, but the degree of transparency remains the same.

The Transparency and Gradient tools on the Mode toolbar dynamically control transparency and
color gradients. See the Draw Guide Chapter 4 Changing Object Attributes for more information on
how to create transparencies and gradients in an object.

Duplication

Duplication makes copies of an object while applying a set of changes such as color or rotation to
the duplicates that are created.

1) Click on an object or group of objects and go to Edit > Duplicate on the Menu bar or use
the keyboard shortcut Shift+F3 to open the Duplicate dialog (Figure 38).
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Figure 38: Duplicate dialog

2) Select the required options chosen from the options
available. For example, when the options in the dialog
are applied to a rectangle, they produce the result shown
in Figure 39.

Figure 39: Duplication result
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Cross-fading

Cross-fading transforms one object shape to another object shape and only works when two
objects are selected.

1) Select two differently shaped obijects.
2) Go to Edit > Cross-fading on the Menu bar to open the Cross-fading dialog (Figure 40).
3) Select Increments to determine the number of shapes between the two objects.

4) Select Cross-fading attributes to apply a gradual change of line and fill properties
between the two objects.

5) Select Same orientation to apply a smooth transition between the two objects.

6) Click on OK and the result is a new group of objects with the first object selected as the
start object and the second object selected as the end object. For example, when the
options in the dialog are applied to a rectangle and a triangle, the cross fade produces the
result shown in Figure 41.
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Figure 40: Cross-fading dialog

Figure 41: Cross-fading result

Combining multiple objects

Using Draw, you can group or combine objects together allowing you to treat multiple objects as
one unit, or to merge objects to form a new shape. For more information, see the Draw Guide
Chapter 5 Combining Multiple Objects.

Grouping of objects is similar to putting objects into a container. You can move the objects as a
group and apply global changes to the objects within the group. A group can always be undone
and the objects that make up the group can always be manipulated separately. The objects within
a group also retain their own individual properties.

Combining objects is a permanent merging of objects that creates a new object. The original
objects are no longer available as individual entities and cannot be edited as individual objects.
Any editing of a combined object affects all the objects that were used when combination was
carried out.
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Grouping

Temporary grouping

A temporary grouping is when several objects are selected using the Select icon on the Drawing
toolbar or using the mouse to drag a rectangle around the objects (also known as a marquee). Any
changes to object parameters you carry out are applied to all of the objects within the temporary
group. For example, you can rotate a temporary group of objects in its entirety.

To cancel a temporary grouping of objects simply click outside of the selection handles displayed
around the objects.

Permanent grouping

A permanent grouping of objects is created after you have selected your objects and then going to
Modify > Group on the Menu bar, or right clicking on the selection and select Group from the
context menu, or using the keyboard shortcut Ctr/+Shift+G. When you deselect your selection the
objects remain grouped together.

When objects are permanently grouped, any editing operations carried out on that group are
applied to all members of the group. If you click on one member of the group, the whole group is
selected.

You can edit an individual member of a group without ungrouping or breaking the group. Select the
group and go to Modify > Enter Group, or right click and select Enter Group from the context
menu, or use the keyboard shortcut F3, or double click on the group.

When you have finished editing an individual member of a group, go to Modify > Exit Group, or
right click and select Exit Group from the context menu, or use the keyboard shortcut Shift+F3.

Ungrouping
To ungroup or break apart a group of objects, select the group then go to Modify > Ungroup on

the Menu bar, or right click and select Ungroup from the context menu or use the keyboard
shortcut Ctri+Alt+Shift+G.

Combining objects

Combining objects is a permanent merging of objects that creates a new object. The original
objects are no longer available as individual entities and cannot be edited as individual objects.
Any editing of a combined object affects all the objects that were used when combination was
carried out.

Select several objects, then go to Modify > Combine on the Menu bar, or right click on the objects
and select Combine from the context menu, or use the keyboard shortcut Ctr/+Shift+K.

After you have selected your objects, the Merge, Subtract, and Intersect functions also become
available so that you can create a new object from your selected objects. See the Draw Guide
Chapter 5 Combining Multiple Objects for more information on these functions.

Arranging, aligning, and distributing objects

In Draw you can arrange, align, and distribute selected objects in relation to each other:

* Arrange the position of an object by moving it either forward or backward in relation to the
order of objects.

» Align objects with respect to each other using Left, Centered, or Right for horizontal
alignment and Top, Center, or Bottom for vertical alignment.

» Distribute objects so that the space between each of the objects is the same.
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See the Draw Guide Chapter 5 Combining Multiple Objects for more information on arranging and
aligning objects in relation to each other.

Inserting and editing pictures

Draw contains a number of functions for editing pictures or raster graphics (bitmaps); for example,
photos and scanned images. This includes the import and export of graphics, and conversion from
one graphic format to another.

Draw includes a large range of graphic filters so that it can read and display several graphic file
formats. It also includes several tools for working with raster graphics, but does not have the same
functionality as specialized graphic programs like Gimp or Adobe Photoshop. See the Draw Guide
Chapter 6 Editing Pictures for more information.

You can add pictures from several sources:
» Directly from a scanner (Insert > Picture > Scan)

* Images created by another program, including photographs from a digital camera (Insert >
Picture > From File)

* The Draw Gallery; see Chapter 11 Graphics, the Gallery, and Fontwork in this guide for
more information.

Working with 3D objects

Although Draw does not match the functionality of the leading drawing or picture editing programs,
it is capable of producing and editing very good 3D drawings.

Draw offers two types of 3D objects: 3D bodies and 3D shapes. Depending on which type you
choose, there are different methods of editing of a 3D object (rotation, illumination, perspective,
and so on) with 3D shapes being simpler to set up and edit than 3D bodies. However, 3D bodies
currently allow for more customization.

See the Draw Guide Chapter 7 Working with 3D Objects for more information.

Exporting graphics

Draw saves graphics and images in the open source format *.odg. To save a graphic or the entire
file in another format, use File > Export and select a format from the list displayed. The graphic
formats that Draw can export and save to are listed in Appendix B Open Source, Open Standards,
OpenDocument in this guide.

You can also export Draw files to HTML, XHTML, PDF, or Flash. PDF export for modules of
LibreOffice is described in Chapter 10 Printing, Exporting, and E-mailing of this guide.

HTML export uses a conversion wizard that creates as many web pages as there are pages in your
Draw document. You can optionally choose to display pages in frames with a navigator and set an
index page. For more information, see Chapter 12 Creating Web Pages in this guide.

Inserting comments in a drawing

You can insert comments into your drawing in a similar process to the one used in Writer and Calc.

1) GotoInsert > Comment on the menu bar. A small box containing your initials appears in
the upper left-hand corner of your drawing with a larger text box beside it (Figure 42). Draw
automatically adds your name and the date at the bottom of this text box.
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2) Type or paste your comment into the text box. You can apply basic formatting to parts of
the text by selecting it, right-clicking, and choosing from the context menu. From this menu,
you can also delete the current comment, all the comments from the same author, or all the
comments in the document.

3) You can move the small comment markers to anywhere you wish on the drawing. Typically
you might place it on or near an object you refer to in the comment.

4) To show or hide the comment markers, go to View > Comments on the Menu bar.
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Figure 42: Inserting comments

You can go to Tools > Options > User Data to enter the name you want to appear in the Author
field of the comment.

If more than one person edits the document, each author is automatically allocated a different
background color.
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