Getting Started Guide
 

Chapter 1  
Introducing LibreOffice

Copyright

This document is Copyright © 2010–2016 by the LibreOffice Documentation Team. Contributors are listed below. You may distribute it and/or modify it under the terms of either the GNU General Public License (http://www.gnu.org/licenses/gpl.html), version 3 or later, or the Creative Commons Attribution License (http://creativecommons.org/licenses/by/4.0/), version 4.0 or later.

All trademarks within this guide belong to their legitimate owners.

Contributors

Jean Hollis WeberPeter SchofieldOlivier Hallot
Hazel Russman Martin Saffron Ron Faile Jr.
Jeremy CartwrightJohn A SmithDave Barton

Feedback

Please direct any comments or suggestions about this document to the Documentation Team’s mailing list: documentation@global.libreoffice.org

Note: Everything you send to a mailing list, including your email address and any other personal information that is written in the message, is publicly archived and cannot be deleted.

Acknowledgments

This chapter is adapted and updated from previous editions of this chapter. The contributors to those editions are:

Thomas AstleitnerRichard BarnesAgnes Belzunce
Daniel CarreraLaurent Duperval Richard Holt
Ian LaurensonAlan MaddenCarol Roberts
Iain RobertsGary SchnablJanet M. Swisher
Jean Hollis WeberLinda WorthingtonMichele Zarri

Publication date and software version

Published 24 May 2016. Based on LibreOffice 5.1.

Note for Mac users

Some keystrokes and menu items are different on a Mac from those used in Windows and Linux. The table below gives some common substitutions for the instructions in this chapter. For a more detailed list, see the application Help.

Windows or Linux

Mac equivalent

Effect

Tools > Options menu selection

LibreOffice > Preferences

Access setup options

Right-click

Control+click and/or right-click depending on computer setup

Open a context menu

Ctrl (Control)

⌘ (Command)

Used with other keys

F5

Shift+⌘+F5

Open the Navigator

F11

⌘+T

Open the Styles and Formatting window

 

Contents

Copyright

Contributors

Feedback

Acknowledgments

Publication date and software version

Note for Mac users

What is LibreOffice?

Writer (word processor)

Calc (spreadsheet)

Impress (presentations)

Draw (vector graphics)

Base (database)

Math (formula editor)

Advantages of LibreOffice

Minimum requirements

How to get the software

How to install the software

Extensions and add-ons

Starting LibreOffice

Opening an existing document before starting LibreOffice

Quickstarter

Activating Quickstarter

Using Quickstarter on Windows or Linux

Disabling Quickstarter

Reactivating Quickstarter

Parts of the main window

Menu bar

Toolbars

Displaying or hiding toolbars

Sub-menus and tool palettes

Moving toolbars

Floating toolbars

Customizing toolbars

Context menus

Status bar

Sidebar

Starting new documents

Opening existing documents

Saving documents

Save command

Save As command

Password protection

Changing the password

Saving documents automatically

Opening and saving files on remote servers

Renaming and deleting files

Choosing Open and Save As dialogs

Using the Navigator

Undoing and redoing changes

Reloading a document

Closing a document

Closing LibreOffice

 

What is LibreOffice?

LibreOffice is a freely available, fully-featured office productivity suite. Its native file format is Open Document Format (ODF), an open standard format that is being adopted by governments worldwide as a required file format for publishing and accepting documents. LibreOffice can also open and save documents in many other formats, including those used by several versions of Microsoft Office.

LibreOffice includes the following components.

Writer (word processor)

Writer is a feature-rich tool for creating letters, books, reports, newsletters, brochures, and other documents. You can insert graphics and objects from other components into Writer documents. Writer can export files to HTML, XHTML, XML, Adobe Portable Document Format (PDF), and several versions of Microsoft Word files. It also connects to your email client.

Calc (spreadsheet)

Calc has all of the advanced analysis, charting, and decision making features expected from a high-end spreadsheet. It includes over 300 functions for financial, statistical, and mathematical operations, among others. The Scenario Manager provides “what if” analysis. Calc generates 2D and 3D charts, which can be integrated into other LibreOffice documents. You can also open and work with Microsoft Excel workbooks and save them in Excel format. Calc can also export spreadsheets in several formats, including for example Comma Separated Value (CSV), Adobe PDF and HTML formats.

Impress (presentations)

Impress provides all the common multimedia presentation tools, such as special effects, animation, and drawing tools. It is integrated with the advanced graphics capabilities of LibreOffice Draw and Math components. Slideshows can be further enhanced using Fontwork special effects text, as well as sound and video clips. Impress is compatible with Microsoft PowerPoint file format and can also save your work in numerous graphics formats, including Macromedia Flash (SWF).

Draw (vector graphics)

Draw is a vector drawing tool that can produce everything from simple diagrams or flowcharts to 3D artwork. Its Smart Connectors feature allows you to define your own connection points. You can use Draw to create drawings for use in any of the LibreOffice components, and you can create your own clip art and then add it to the Gallery. Draw can import graphics from many common formats and save them in over 20 formats, including PNG, HTML, PDF, and Flash.

Base (database)

Base provides tools for day-to-day database work within a simple interface. It can create and edit forms, reports, queries, tables, views, and relations, so that managing a relational database is much the same as in other popular database applications. Base provides many new features, such as the ability to analyze and edit relationships from a diagram view. Base incorporates two relational database engines, HSQLDB and PostgreSQL. It can also use dBASE, Microsoft Access, MySQL, or Oracle, or any ODBC compliant or JDBC compliant database. Base also provides support for a subset of ANSI-92 SQL.

Math (formula editor)

Math is the LibreOffice formula or equation editor. You can use it to create complex equations that include symbols or characters not available in standard font sets. While it is most commonly used to create formulas in other documents, such as Writer and Impress files, Math can also work as a standalone tool. You can save formulas in the standard Mathematical Markup Language (MathML) format for inclusion in web pages and other documents not created by LibreOffice.

Advantages of LibreOffice

Here are some of the advantages of LibreOffice over other office suites:

You can read more about LibreOffice and The Document Foundation on their websites at http://www.libreoffice.org/ and http://www.documentfoundation.org/.

Minimum requirements

LibreOffice 5.1 requires one of the following operating systems:

Administrator rights are needed for the installation process.

Some LibreOffice features (wizards and the HSQLDB database engine) require that the Java Runtime Environment (JRE) is installed on your computer. Although LibreOffice will work without Java support, some features will not be available.

For a more detailed listing of requirements, see the LibreOffice website, http://www.libreoffice.org/get-help/system-requirements/.

How to get the software

Versions of LibreOffice for Windows, Linux, and Mac OS X can be downloaded free from http://www.libreoffice.org/download. You can also download the software by using a Peer-to-Peer client, such as BitTorrent, at the same address.

Linux users will also find LibreOffice included in many of the latest Linux distributions; Ubuntu is just one example.

Mac OS X users can also get two versions of LibreOffice from the App Store: LibreOffice Vanilla (free) and LibreOffice-from-Collabora (an enterprise-ready version; small fee).

How to install the software

Information on installing and setting up LibreOffice on the various supported operating systems is given here: http://www.libreoffice.org/get-help/install-howto/.

Extensions and add-ons

Extensions and add-ons are available to enhance LibreOffice. Several extensions are installed with the program and you can get others from the official extensions repository, http://extensions.libreoffice.org/. See Chapter 14, Customizing LibreOffice for more information on installing extensions and add-ons.

Starting LibreOffice

In general, you start LibreOffice the same way you start any other program on your computer.

On computers with Windows or Linux operating systems, a menu entry for LibreOffice and each LibreOffice component appears in the system menu of your computer. On computers operating Mac OS X, only a menu entry for LibreOffice is added to the Applications menu.

Clicking on the LibreOffice menu entry, desktop icon, or tile opens the LibreOffice Start Center (Figure 1) from where you can select the individual components of LibreOffice. You can also select to open an existing file or use a template.

Opening an existing document before starting LibreOffice

You can start LibreOffice by double-clicking the filename of an ODF document on the desktop, or in a file manager such as Windows Explorer or the Mac’s Finder. The appropriate component of LibreOffice will start and the document will be loaded.

You can also open files stored in remote servers running Content Management Interoperability Services (CMIS). CMIS, like OpenDocument Format, is an OASIS standard. When using CMIS servers, the service will ask you for the necessary credentials for file access.

 

Figure 1: LibreOffice Start Center

 

If you do not have Microsoft Office installed on your computer, or if Microsoft Office is installed but you have associated Microsoft Office file types with LibreOffice, then when you double-click on the following files, they open in LibreOffice:

If you did not associate the file types and Microsoft Office is installed on your computer, then when you double-click on a Microsoft Office file, it opens using the appropriate Microsoft Office component.

For more information on opening files, see “Opening existing documents” on page 16.

Quickstarter

When LibreOffice is installed on computers running Windows or Linux, a Quickstarter feature may also be installed. When Quickstarter is activated, the necessary library files are loaded when the computer system is started, resulting in a shorter startup time for LibreOffice components.

Computers with a Mac operating system do not have a Quickstarter.

Activating Quickstarter

On computers operating a Linux or Windows operating system, the default installation of LibreOffice does not set the Quickstarter to load automatically. To activate it:

  1. 1)Open LibreOffice. 

  2. 2)Go to Tools > Options > LibreOffice > Memory on the Menu bar and select Load LibreOffice during system start-up (if using Windows) or select Enable systray Quickstarter (if using Linux). 

  3. 3)Close and restart LibreOffice to have Quickstarter appear. 

Using Quickstarter on Windows or Linux

After Quickstarter has been activated, an icon
is installed into the system tray at the bottom of the display. Quickstarter is then available at all times, whether LibreOffice is open or not.
 

To start a LibreOffice component directly by using Quickstarter:

  1. 1)Right-click the Quickstarter icon in the system tray to open a pop-up menu (Figure 2). 

  2. 2)Select the LibreOffice component you want to open to create a new document, or select From Template to open the Template Manager, or select Open Document to open an existing document. 

 

Figure 2: Quickstarter menu in Windows

 

Disabling Quickstarter

To temporarily close Quickstarter on a computer using a Windows operating system, right-click on the Quickstarter icon in the system tray and select Exit Quickstarter in the pop-up menu. However, when the computer is restarted, Quickstarter will be loaded again.

To prevent the Quickstarter from loading during system startup, do one of the following:

Reactivating Quickstarter

If Quickstarter has been disabled, you can reactivate it by using the instructions given in “Activating Quickstarter” above.

Parts of the main window

The main window is similar for each component of LibreOffice, although some details vary. See the relevant chapters in this guide about Writer, Calc, Draw, and Impress for descriptions of those details.

Common features include the Menu bar, standard toolbar, and formatting toolbar at the top of the window and the status bar at the bottom.

Menu bar

The Menu bar is located across the top of the LibreOffice window, just below the title bar. When you select one of the menus listed below, a sub-menu drops down to show commands.

Toolbars

LibreOffice has two types of toolbars: docked (fixed in place) and floating. Docked toolbars can be moved to different locations or made to float, and floating toolbars can be docked.

In a default LibreOffice installation, the top docked toolbar, just under the Menu bar, is called the Standard toolbar. It is consistent across the LibreOffice applications.

The second toolbar at the top, in a default LibreOffice installation, is the Formatting bar. It is context-sensitive; that is, it shows the tools relevant to the current position of the cursor or the object selected. For example, when the cursor is on a graphic, the Formatting bar provides tools for formatting graphics; when the cursor is in text, the tools are for formatting text.

Displaying or hiding toolbars

To display or hide toolbars, go to View > Toolbars on the Menu bar, then click on the name of a toolbar from the drop-down list. An active toolbar shows a check-mark beside its name. Toolbars created from tool palettes are not listed in the View menu.

To close a toolbar go to View > Toolbars on the Menu bar and deselect the toolbar, or right-click in an empty space between the icons on a toolbar and select Close toolbar from the context menu.

Sub-menus and tool palettes

Toolbar icons with a small triangle to the right will display sub-menus, tool palettes, and alternative methods of selecting items, depending on the icon.

Tool palettes can be made into a floating toolbar. Figure 3 shows an example of a tool palette from the Drawing toolbar made into a floating toolbar. See “Moving toolbars” and “Floating toolbars” below for more information on moving and floating these toolbars created from tool palettes.

 

Figure 3: Example of tearing off a tool palette

 

Moving toolbars

Docked toolbars can be undocked and moved to a new docked position or left as a floating toolbar.

  1. 1)Move the mouse cursor over the toolbar handle, which is the small vertical bar to the left of a docked toolbar and highlighted in Figure 4. 

  2. 2)Hold down the left mouse button and drag the toolbar to the new location. The toolbar can be docked in a new position at the top, sides or bottom of the main window, or left as a floating toolbar. 

  3. 3)Release the mouse button. 

To move a floating toolbar, click on its title bar and drag it to a new floating location or dock the toolbar at the top or bottom of the main window.

 

Figure 4: Toolbar handles

 

You can also dock a floating toolbar by holding down the Ctrl key and double-clicking in the title bar of the toolbar.

Floating toolbars

LibreOffice includes several additional toolbars, whose default setting appear as floating toolbars in response to the current position of the cursor or selection. You can dock these toolbars to the top or bottom of the main window, or reposition them on your computer display (see “Moving toolbars” above).

Some of these additional toolbars are context sensitive and will automatically appear depending on the position of the cursor. For example, when the cursor is in a table, a Table toolbar appears, and when the cursor is in a numbered or bullet list, the Bullets and Numbering toolbar appears.

Customizing toolbars

You can customize toolbars in several ways, including choosing which icons are visible and locking the position of a docked toolbar. You can also add icons and create new toolbars, as described in Chapter 14 Customizing LibreOffice. To access the customization options for a toolbar, right-click in an empty space between the icons on a toolbar to open a context menu as follows:

 

Figure 5: Selection of visible toolbar icons

 

Context menus

Context menus provide quick access to many menu functions. They are opened by right-clicking on a paragraph, graphic, or other object. When a context menu opens, the functions or options available will depend on the object that has been selected. A context menu can be the easiest way to reach a function, especially if you are not sure where the function is located in the menus or toolbars.

Status bar

The status bar is located at the bottom of the workspace. It provides information about the document and convenient ways to change some features quickly. It is similar in Writer, Calc, Impress, and Draw, but each LibreOffice component includes some component-specific items. An example of the Writer status bar is shown in Figure 6.

 
 

Figure 6: Example status bar from Writer

 

Page, sheet, or slide number and page count

Shows the current page, sheet, or slide number and the total number of pages, sheets, or slides in the document. Double-click on this field to open the Navigator. Other uses of this field depend on the LibreOffice component.

Words and characters

Shows the total number of words and characters in the document or in the selection.

Page style or slide design

Shows the current page style or slide design. To edit the current page style or slide design, double-click on this field. To choose a different page style or slide design, right-click on this field and select from the list that pops up.

Language

Shows the current language of the text at the current cursor position.

Insert mode

Shows the type of insert mode the program is in. This field is blank if the program is in Insert mode. Each time the Ins key is pressed, or this field is clicked, the mode toggles between Insert and Overwrite.

Selection mode

Click to choose different selection modes. The icon does not change, but when you hover the mouse pointer over this field, a tooltip indicates which mode is active.

Unsaved changes

The icon shown here is different when changes to the document have not been saved.

Digital signature

If the document has been digitally signed, an icon shows here. You can click the icon to sign the document, or to view the existing certificate.

Object information

Displays information relevant to the position of the cursor or the selected element of the document.

View layout

Select between Single-page view, Multiple-page view, and Book view to change how your document is displayed.

Zoom slider

Drag the Zoom slider, or click on the + and signs to change the view magnification of your document.

Zoom percentage

Indicates the magnification level of the document. Right-click on the percentage figure to open a list of magnification values from which to choose. Double-clicking on this percentage figure opens the Zoom & View Layout dialog.

Sidebar

To activate the Sidebar, select View > Sidebar from the Menu bar. The Sidebar (Figure 7) is located on the right side of the edit views of Writer, Calc, Impress, and Draw. It contains one or more panels, based on the current document context. Panels are organized into decks. A tab bar on the right side of the sidebar allows you to switch between different decks.

 

All components contain the Properties, Styles and Formatting, Gallery, and Navigator decks. Some components have additional decks, such as Master Pages, Custom Animation, and Slide Transition for Impress; Manage Changes for Writer; and Functions for Calc.

A panel is like a combination of a toolbar and a dialog. For example, you can freely mix working in the main edit window to enter text and use the Properties panel in the sidebar to change text attributes.

Tool bars and Sidebar panels share many functions. For example, the buttons for making text bold or italic exist in both the Formatting toolbar and the Properties panel.

For more detail, see the Sidebar explanation in the relevant LibreOffice component’s user guide.

To hide the Sidebar, click on the gray Hide button on the left. Click on the same button to show the Sidebar again.

To undock the Sidebar and make it floating, and to dock a floating Sidebar, use the drop-down list at the top of the tab bar (see Figure 8). From the same list you can choose which items to include in the Sidebar.

 

Starting new documents

You can start a new, blank document in LibreOffice in several ways.

When LibreOffice is running but no document is open, the Start Center (Figure 1 on page 8) is shown. Click one of the icons to open a new document of that type, or click the Templates icon to start a new document using a template.

You can also start a new document in one of the following ways:

If all documents are closed without closing LibreOffice, then the Start Center will be displayed.

Opening existing documents

You can also open an existing document in one of the following ways:

When using the Open dialog, navigate to the folder you want and select the file you want, and then click Open. If a document is already open in LibreOffice, the second document opens in a new window.

In the Open dialog, you can reduce the list of files by selecting the type of file you are looking for. For example, if you choose Text documents as the file type, you will only see documents Writer can open (including .odt, .doc, .txt); if you choose Spreadsheets, you will see .ods, .xls, and other files that Calc opens.

You can also open an existing document that is in a format that LibreOffice recognizes by double-clicking on the file icon on the desktop or in a file manager such as Windows Explorer. LibreOffice has to be associated with file types that are not ODF files for the appropriate LibreOffice component to open.

You can choose whether to use the LibreOffice Open/Save dialogs or the ones provided by your computer’s operating system. See “Choosing Open and Save As dialogs” on page 20 for more information. This book uses the LibreOffice dialogs in illustrations.

When opening files stored in a remote server, you may be asked to enter your user name and password to log in the server.

Saving documents

You can save documents as follows:

Save command

To save a document if you are keeping the document’s current filename and location, do one of the following:

Using the Save command will overwrite the last saved version of the file.

Save As command

To save a document if you want to create a new document, or change the filename and/or file format, or save the file in a different location on your computer:

When the Save As dialog (Figure 9) or Save dialog opens, enter the file name, change the file type (if applicable), navigate to a new location (if applicable), and click Save.

The dialog that opens when using the Save As command depends on the options that have been set in LibreOffice. See “Choosing Open and Save As dialogs” on page 20 for more information.

Password protection

To restrict who can open and read a document, or open and edit the document, use password protection.

  1. 1)Using the Save As command above, select the Save with password option in the Save As dialog or Save dialog. 

  2. 2)Click Save and the Set Password dialog opens (Figure 10). 

  3. 3)In File Encryption Password, enter a password to open the document and then enter the same password as confirmation. 

  4. 4)To restrict who can edit the document, click Options. 

  5. 5)In File Sharing Password, select Open file read-only, enter a password to allow editing, and then enter the same password as confirmation. 

  6. 6)Click OK and the dialog closes. If the passwords match, the document is saved password-protected. If the passwords do not match, you receive an error message. 

 

LibreOffice uses a very strong encryption mechanism that makes it almost impossible to recover the contents of a document if you lose or forget the password.

Changing the password

When a document is password-protected, you can change the password while the document is open. Go to File > Properties > General on the Menu bar and click the Change Password button. This opens the Set Password dialog where you can enter a new password.

Saving documents automatically

LibreOffice can save files automatically as part of the AutoRecovery feature. Automatic saving, like manual saving, overwrites the last saved state of the file.

To set up automatic file saving:

  1. 1)Go to Tools > Options > Load/Save > General on the Menu bar. 

  2. 2)Select Save AutoRecovery information every and set the time interval. 

  3. 3)Click OK. 

Opening and saving files on remote servers

LibreOffice 5.1 can open and save files stored on remote servers. Keeping files on remote servers allows you to work with the documents using different computers. For example, you can work on a document in the office during the day and edit it at home for last-minute changes. Storing files on a remote server also backs up documents from computer loss or hard disk failure. Some servers are also able to check-in and check-out files, thus controlling their usage and access.

LibreOffice 5.1 supports many document servers that use well known network protocols such as FTP, WebDav, Windows share, and SSH. It also supports popular services like Google Drive and Microsoft OneNote, as well as commercial and open source servers that implement the OASIS CMIS standard.

To access remote servers, you must use LibreOffice Open and Save dialogs. If you use your operating system dialogs for saving and opening files, go to Tools > Options > LibreOffice > General and check the option Use LibreOffice dialogs.

To enable a remote server connection, use one of these methods:

Then click on the Add Service button (Figure 12) in the dialog to open the File Service dialog.

Depending on the type of file service you choose in the Type listbox, different parameters are necessary to fully qualify the connection to the remote server (Figure 11).