Getting Started Guide
 

Chapter 2  
Setting up LibreOffice

Choosing Options to Suit the Way You Work

Copyright

This document is Copyright © 2010–2016 by the LibreOffice Documentation Team. Contributors are listed below. You may distribute it and/or modify it under the terms of either the GNU General Public License (http://www.gnu.org/licenses/gpl.html), version 3 or later, or the Creative Commons Attribution License (http://creativecommons.org/licenses/by/4.0/), version 4.0 or later.

All trademarks within this guide belong to their legitimate owners.

Contributors

Jean Hollis Weber

Olivier Hallot

Hazel Russman

John A Smith

Martin Saffron

Steve Schwettman

Ron Faile Jr.

 

 

Feedback

Please direct any comments or suggestions about this document to the Documentation Team’s mailing list: documentation@global.libreoffice.org

Note: Everything you send to a mailing list, including your email address and any other personal information that is written in the message, is publicly archived and cannot be deleted.

Acknowledgments

This chapter is revised and updated from Chapter 2 of Getting Started with OpenOffice.org 3.x. The contributors to that chapter are:

Jean Hollis Weber

Agnes Belzunce

Daniel Carrera

Peter Hillier-Brook

Stefan A. Keel

Michele Zarri

Publication date and software version

Published 17 May 2016. Based on LibreOffice 5.1.

Note for Mac users

Some keystrokes and menu items are different on a Mac from those used in Windows and Linux. The table below gives some common substitutions for the instructions in this chapter. For a more detailed list, see the application Help.

Windows or Linux

Mac equivalent

Effect

Tools > Options menu selection

LibreOffice > Preferences

Access setup options   

Right-click

Control+click and/or right-click depending on computer setup

Open a context menu

Ctrl (Control)

⌘ (Command)

Used with other keys

F5

Shift+⌘+F5

Open the Navigator

F11

⌘+T

Open the Styles and Formatting window

Contents

Copyright

Contributors

Feedback

Acknowledgments

Publication date and software version

Note for Mac users

Choosing options for all of LibreOffice

User Data options

General options

Memory options

View options

Print options

Paths options

Color options

Fonts options

Security options

Security options and warnings

Personalization

Application colors

Accessibility options

Advanced options

Basic IDE options

Online update options

OpenCL options

Choosing Load/Save options

General

VBA Properties

Microsoft Office

HTML compatibility

Choosing language settings

Install the required dictionaries

Change some locale and language settings

Choose spelling options

English sentence checking

Grammar checking

Punctuation

Others

Other languages sentence checking

Choosing Internet options

Controlling LibreOffice’s AutoCorrect functions

 

Choosing options for all of LibreOffice

This section covers some of the settings that apply to all the components of LibreOffice. For information on settings not discussed here, see the Help.

Click Tools > Options. The list in the left-hand box of the Options – LibreOffice dialog varies depending on which component of LibreOffice is open. The illustrations in this chapter show the list as it appears when a Writer document is open.

Click the marker (+ or triangle) by LibreOffice on the left-hand side. A list of pages drops down. Selecting an item in the list causes the right-hand side of the dialog to display the relevant page.

 

Figure 1: LibreOffice options

 

The Reset button, located in the lower right of the full Options dialog, has the same effect on all pages of the dialog. It resets the options to the values that were in place when you opened the dialog.

If you are using a version of LibreOffice other than US English, some field labels may be different from those shown in the illustrations.

User Data options

Because LibreOffice can use the name or initials stored in the LibreOffice – User Data page for several things – including document properties (‘created by’ and ‘last edited by’ information), the name of the author of comments and changes, and the sender address in mailing lists – you will want to ensure that the correct information appears here.

Fill in the form (not shown here), or amend or delete any existing information. If you do not want user data to be part of the document’s properties, clear the box at the bottom.

General options

The options on the LibreOffice – General page are described below Figure 2.

 

Figure 2: Setting general options for LibreOffice

 

Help – Extended tips

When Extended tips is active, a brief description of the function of a particular icon or menu command or a field on a dialog appears when you hold the mouse pointer over that item.

Open/Save Dialogs – Use LibreOffice dialogs

To use the standard Open and Save dialogs for your operating system, deselect the Use LibreOffice dialogs option. When this option is selected, the Open and Save dialogs supplied with LibreOffice will be used. See Chapter 1, Introducing LibreOffice, for more about the LibreOffice Open and Save dialogs. This book uses the LibreOffice Open and Save dialogs in illustrations.

Document status – Printing sets “document modified” status

If this option is selected, then the next time you close the document after printing, the print date is recorded in the document properties as a change and you will be prompted to save the document again, even if you did not make any other changes.

Year (two digits)

Specifies how two-digit years are interpreted. For example, if the two-digit year is set to 1930, and you enter a date of 1/1/30 or later into your document, the date is interpreted as 1/1/1930 or later. An “earlier” date is interpreted as being in the following century; that is, 1/1/20 is interpreted as 1/1/2020.

Help Improve LibreOffice – Collect usage data and send it to The Document Foundation

Send usage data to help The Document Foundation improve usability of the software. Data about usage patterns helps with identifying the most frequently used sequences of commands while performing common tasks; the developers can then design a user interface that is easier to use and more productive. The usage data is sent anonymously and carries no document contents, only the commands used.

Memory options

The options on the LibreOffice – Memory page control how LibreOffice uses your computer’s memory and how much memory it requires. Before changing them, you may wish to consider the following points:

 

Figure 3: Choosing Memory options for the LibreOffice applications

 

View options

The options on the LibreOffice – View page affect the way the document window looks and behaves. Some of these options are described below Figure 4. Set them to suit your personal preferences.

 

Figure 4: Choosing View options for LibreOffice applications

 

User Interface – Scaling

If the text in the help files or on the menus of the LibreOffice user interface is too small or too large, you can change it by specifying a scaling factor. Sometimes a change here can have unexpected results, depending on the screen fonts available on your system. However, it does not affect the actual font size of the text in your documents.

User Interface – Icon size and style

The first box specifies the display size of toolbar icons (Automatic, Small, or Large). The Automatic icon size option uses the setting for your operating system. The second box specifies the icon style (theme); here the Automatic option uses an icon set compatible with your operating system and choice of desktop: for example, KDE or Gnome on Linux.

User interface – Screen font anti-aliasing

(Not available in Windows.) Select this option to smooth the screen appearance of text. Enter the smallest font size to apply anti-aliasing.

Mouse positioning

Specifies if and how the mouse pointer will be positioned in newly opened dialogs.

Middle mouse button

Defines the function of the middle mouse button.

The “Selection clipboard” is independent of the normal clipboard that you use by Edit > Copy/Cut/Paste or their respective keyboard shortcuts. Clipboard and “Selection clipboard” can contain different contents at the same time.

Function

Clipboard

Selection clipboard

Copy content

Edit > Copy Ctrl+C

Select text, table, or object.

Paste content

Edit > Paste Ctrl+V pastes at the cursor position.

Clicking the middle mouse button pastes at the mouse pointer position.

Pasting into another document

No effect on the clipboard contents.

The last marked selection is the content of the selection clipboard.

Graphics output – Use hardware acceleration

Directly accesses hardware features of the graphical display adapter to improve the screen display. Not supported on all operating systems and LibreOffice distributions.

Graphics output – Use anti-aliasing

Enables and disables anti-aliasing, which makes the display of most graphical objects look smoother and with fewer artifacts. Not supported on all operating systems and LibreOffice distributions.

Press Shift+Ctrl+R to restore or refresh the view of the current document after changing the anti-aliasing settings, to see the effect.

Graphics output – Use OpenGL for all rendering (on restart)

Enables and disables the use of the 3D graphics language OpenGL. Not supported on all operating systems and LibreOffice distributions.

Graphics output – Force OpenGL even if blacklisted (on restart)

Forces the use of OpenGL even if the graphics device is blacklisted. A device is blacklisted when it is buggy or may render graphics with poor quality. Not supported on all operating systems and LibreOffice distributions.

Menu – icons in menus

Causes icons as well as words to be visible in menus.

Font Lists – Show preview of fonts

Causes the font list to look like Figure 5, Left, with the font names shown as an example of the font; with the option deselected, the font list shows only the font names, not their formatting (Figure 5, Right). The fonts you will see listed are those that are installed on your system.

Fonts which are tuned for use with a specific script, such as Arabic, Hebrew, Malayalam, and so on, now show an additional preview of some sample text in the target script.

 
 

Figure 5: Font list (Left) with preview; (Right) without preview

Print options

On the LibreOffice – Print page, set the print options to suit your default printer and your most common printing method. Most of these options should be self-explanatory.

The option PDF as Standard Print Job Format is not available on Windows. Select this option to change the internal print job format from a Postscript document description to a PDF description. This format has a number of advantages over Postscript. For more information, see http://www.linuxfoundation.org/collaborate/workgroups/openprinting/pdf_as_standard_print_job_format

Deselecting this option reverts to the Postscript document workflow system.

In the Printer warnings section near the bottom of the page, you can choose whether to be warned if the paper size or orientation specified in your document does not match the paper size or orientation available for your printer. Having these warnings turned on can be quite helpful, particularly if you work with documents produced by people in other countries where the standard paper size is different from yours.

If your printouts are incorrectly placed on the page or chopped off at the top, bottom, or sides, or the printer is refusing to print, the most likely cause is page size incompatibility.

 

Figure 6: Choosing general printing options to apply to all LibreOffice components

 

Paths options

On the LibreOffice – Paths page, you can change the location of files associated with, or used by, LibreOffice to suit your working situation. In a Windows system, for example, you might want to store documents by default somewhere other than My Documents.

To make changes, select an item in the list shown in Figure 7 and click Edit. On the Select Path dialog (not shown; may also be titled Edit Paths), add or delete folders as required, and then click OK to return to the Options dialog. Note that some items can have at least two paths listed: one to a shared folder (which might be on a network) and one to a user-specific folder (normally on the user’s personal computer).

You can use the entries on the LibreOffice – Paths page to compile a list of files, such as those containing AutoText, that you need to back up or copy to another computer.

 

Figure 7: Viewing the paths of files used by LibreOffice

 

Color options

On the LibreOffice – Colors page, you can specify colors to use in LibreOffice documents. You can select a color from a color table, edit an existing color, and define new colors. These colors are stored in your color palette and are then available in all components of LibreOffice.

To modify a color:

  1. 1)Select the color to modify from the list or the color table. 

  2. 2)Enter the new values that define the color. You can choose the RGB (Red, Green, Blue) or the CMYK (Cyan, Magenta, Yellow, Black) system to specify your color. The changed color appears in the lower of the two color preview boxes at the top. 

  3. 3)Modify the Name as required. 

  4. 4)Click the Modify button. The newly defined color is now listed in the Color table. 

 

Figure 8: Defining colors to use in color palettes in LibreOffice

 

Alternatively, click the Pick button to open the Pick a Color dialog, shown in Figure 9. Here you can select a color from the window on the left, or you can enter values on the right using your choice of RGB, CMYK, or HSB (Hue, Saturation and Brightness) values.

The color window on the left is linked directly with the color input fields on the right; as you choose a color in the window, the numbers change accordingly. The color field at the lower left shows the value of the selected color on the left and the currently set value from the color value fields on the right.

Modify the color components as required and click OK to exit the dialog. The newly defined color now appears in the lower of the color preview boxes shown in Figure 8. Type a name for this color in the Name box, then click the Add button. A small box showing the new color is added to the Color table.

Another way to define or alter colors is through the Colors page of the Area dialog, where you can also save and load palettes, a feature that is not possible here. In Calc, draw a temporary draw object and use the context menu of this object to open the Area dialog. If you load a palette in one component of LibreOffice, it is only active in that component; the other components keep their own palettes.

 

Figure 9: Editing colors

 

Fonts options

You can define replacements for any fonts that might appear in your documents. If you receive from someone else a document containing fonts that you do not have on your system, LibreOffice will substitute fonts for those it does not find. You might prefer to specify a different font from the one that the program chooses.

These choices do not affect the default font for your documents. To do that, you need to change the default template for documents, as described in Chapter 3.

On the LibreOffice – Fonts page:

  1. 1)Select the Apply replacement table option. 

  2. 2)Select or type the name of the font to be replaced in the Font box. (If you do not have this font on your system, it will not appear in the drop-down list in this box, so you need to type it in.) 

  3. 3)In the Replace with box, select a suitable font from the drop-down list of fonts installed on your computer. 

  4. 4)The check mark to the right of the Replace with box turns green. Click on this check mark. A row of information now appears in the larger box below the input boxes. Select Always to replace the font, even if the original font is installed on your system. Select Screen only to replace the screen font only and never replace the font for printing. The results of combining these selections are given in Table 1. 

  5. 5)In the bottom section of the page, you can change the typeface and size of the font used to display source code such as HTML and Basic (in macros). 

 

Figure 10: Defining a font to be substituted for another font

 

Table 1. Font substitution replacement actions

Always checkbox

Screen only checkbox

Replacement action

checked

blank

Font replacement on screen and when printing, whether the font is installed or not.

checked

checked

Font replacement only on screen, whether the font is installed or not.

blank

checked

Font replacement only on screen, but only if font is not available.

blank

blank

Font replacement on screen and when printing, but only if font is not available.

Security options

Use the LibreOffice – Security page to choose security options for saving documents and for opening documents that contain macros.

Security options and warnings

If you record changes, save multiple versions, or include hidden information or notes in your documents, and you do not want some of the recipients to see that information, you can set warnings to remind you to remove it, or you can have LibreOffice remove some of it automatically. Note that (unless removed) much of this information is retained in a file whether the file is in LibreOffice’s default OpenDocument format, or has been saved to other formats, including PDF.

Click the Options button to open a separate dialog with specific choices (Figure 13). See “Security options and warnings” on page 14.

 

Figure 11: Choosing security options for opening and saving documents

 

Macro security

Click the Macro Security button to open the Macro Security dialog (not shown here), where you can adjust the security level for executing macros and specify trusted sources.

Certificate Path

Users can digitally sign documents using LibreOffice. A digital signature requires a personal signing certificate. Most operating systems can generate a self-signed certificate. However, a personal certificate issued by an outside agency (after verifying an individual’s identity) has a higher degree of trust associated with it than does a self-signed certificate. LibreOffice does not provide a secure method of storing these certificates, but it can access certificates that have been saved using other programs. Click the Certificate button and select which certificate store to use.

The Certificate Path option appears only on Linux and Mac systems. On Windows, LibreOffice uses the default Windows location for storing and retrieving certificates.

Passwords for web connections

You can enter a master password to enable easy access to websites that require a user name and password. If you select the Persistently save passwords for web connections option, the Set Master Password dialog opens (Figure 12). LibreOffice will securely store all passwords that you use to access files from web servers. You can retrieve the passwords from the list after you enter the master password.

 

Figure 12: Set Master Password dialog for web connections

 

Security options and warnings

The following options are on the Security options and warnings dialog (Figure 13).