Getting Started Guide
 

Chapter 6  
Getting Started with Impress

Presentations in LibreOffice

Copyright

This document is Copyright © 2010–2016 by the LibreOffice Documentation Team. Contributors are listed below. You may distribute it and/or modify it under the terms of either the GNU General Public License (http://www.gnu.org/licenses/gpl.html), version 3 or later, or the Creative Commons Attribution License (http://creativecommons.org/licenses/by/4.0/), version 4.0 or later.

All trademarks within this guide belong to their legitimate owners.

Contributors

Peter Schofield

Jean Hollis Weber

Hazel Russman

Kevin O’Brien

Ron Faile Jr.

Olivier Hallot

Feedback

Please direct any comments or suggestions about this document to the Documentation Team’s mailing list: documentation@global.libreoffice.org

Note: Everything you send to a mailing list, including your email address and any other personal information that is written in the message, is publicly archived and cannot be deleted.

Acknowledgments

This chapter is adapted and updated from Chapter 6 of Getting Started with OpenOffice.org 3.3. The contributors to that chapter are:

Agnes BelzunceBarbara M. TobiasDan Lewis
Jean Hollis Weber Peter Hillier-Brook Claire Wood
Stefan A. Keel Linda WorthingtonGary Schnabl
Michele Zarri

Publication date and software version

Published 23 July 2016. Based on LibreOffice 5.1.

Note for Mac users

Some keystrokes and menu items are different on a Mac from those used in Windows and Linux. The table below gives some common substitutions for the instructions in this chapter. For a more detailed list, see the application Help.

Windows or Linux

Mac equivalent

Effect

Tools > Options menu selection

LibreOffice > Preferences

Access setup options

Right-click

Control+click and/or right-click depending on computer setup

Open a context menu

Ctrl (Control)

⌘ (Command)

Used with other keys

F5

Shift+⌘+F5

Open the Navigator

F11

⌘+T

Open the Styles and Formatting window

 

Contents

Copyright

Contributors

Feedback

Acknowledgments

Publication date and software version

Note for Mac users

What is Impress?

Starting Impress

Main Impress window

Workspace

Slides pane

Sidebar

Toolbars

Status bar

Workspace views

Normal view

Outline view

Notes view

Handout view

Slide Sorter view

Customizing Slide Sorter view

Moving a slide using Slide Sorter

Selecting and moving groups of slides

Working in Slide Sorter view

Creating a new presentation using the Presentation Wizard

Formatting a presentation

Inserting slides

New slide

Duplicate slide

Selecting slide layout

Modifying slide elements

Adding text

Adding objects

Modifying the appearance of all slides

Modifying the slide show

Adding and formatting text

Using AutoLayout text boxes

Using text boxes

Vertical text

Quick font resizing

Pasting text

Pasting unformatted text

Formatting pasted text

Creating bulleted and numbered lists

AutoLayout text boxes

Text boxes

Creating a new outline level

Changing list appearance

Adding pictures, tables, charts, and media

Adding pictures

Adding tables

Adding charts

Adding media files

Adding graphics, spreadsheets, and other objects

Working with slide masters and styles

Styles

Slide masters

Creating a slide master

Applying a slide master

Loading additional slide masters

Modifying a slide master

Adding text, footers, and fields to all slides

Text

Footers

Fields

Adding comments to a presentation

Setting up a slide show

One slide set – multiple presentations

Hiding slides

Custom slide shows

Slide transitions

Slide advance

Running a slide show

Presenter Console

Using Impress Remote control

Getting Impress Remote

Connecting the mobile device to the computer

Enabling remote control in Impress

Running a slide show with Impress Remote

 

What is Impress?

Impress is the presentation (slide show) program included in LibreOffice. You can create slides that contain many different elements, including text, bulleted and numbered lists, tables, charts, and a wide range of graphic objects such as clipart, drawings, and photographs. Impress also includes a spelling checker, a thesaurus, text styles, and background styles.

This chapter includes instructions, screenshots, and hints to guide you through the Impress environment while designing your presentations. Although more difficult designs are mentioned in this chapter, explanations for creating them are in the Impress Guide. If you have a working knowledge of how to create slide shows, we recommend you use the Impress Guide for your source of information.

To use Impress for more than very simple slide shows requires some knowledge of the elements which the slides contain. Slides that contain text use styles to determine the appearance of that text. Creating drawings in Impress is similar to the Draw program included in LibreOffice. For this reason, we recommend that you also see Chapter 3 Using Styles and Templates and Chapter 7 Getting Started with Draw in this guide. You may also wish to consult the Draw Guide for more details on how to use the drawing tools.

Starting Impress

You can start Impress in several ways, as described in Chapter 1 Introducing LibreOffice.

When you start Impress for the first time, the Presentation Wizard may be shown. See “Creating a new presentation using the Presentation Wizard” on page 13. Otherwise, the main Impress window is displayed.

You can turn the Presentation Wizard on and off in Tools > Options > LibreOffice Impress > General > New document by selecting or deselecting the Start with wizard option.

Main Impress window

The main Impress window (Figure 1) has three parts: the Slides pane, Workspace, and Sidebar. Additionally, several toolbars can be displayed or hidden during the creation of a presentation.

You can close the Slides pane or the Sidebar by clicking the X in the upper right corner of each pane or go to View > Slide Pane or View > Sidebar on the Menu bar to deselect the pane. To reopen a pane, go to View on the Menu bar and select Slide Pane or Sidebar again.

You can also maximize the Workspace area by clicking on the Hide/Show marker in the middle of the vertical separator line (highlighted in Figure 1). Using the Hide/Show marker hides, but does not close, the Slide pane or Sidebar. To restore a pane, click again on its Hide/Show marker.

Workspace

The Workspace (normally in the center of the main window) opens in the Normal view. It has five tabs: Normal, Outline, Notes, Handout, and Slide Sorter. These five tabs are called View buttons. Since LibreOffice 5.1, the View buttons are not shown by default; but they can be activated by choosing View > Modes Tab Bar from the menu bar.

The Workspace below the View buttons changes with the chosen view. The workspace views are described in “Workspace views” on page 9.

 

Figure 1: Main window of Impress; ovals indicate the Hide/Show markers. The View Tab Bar is visible in this image.

 

Slides pane

The Slides pane contains thumbnail pictures of the slides in your presentation in the order in which they will be shown, unless you change the slide show order. Clicking a slide in this pane selects it and places it in the Workspace. When a slide is in the Workspace, you can make changes to it.

Several additional operations can be performed on one or more slides simultaneously in the Slides pane:

It is also possible to perform the following operations, although there are more efficient methods than using the Slides pane:

Sidebar

The Sidebar has seven sections. To expand a section you want to use, click on its icon or click on the small triangle at the top of the icons and select a section from the drop down list. Only one section at a time can be open.

Properties
 

Shows the layouts included within Impress. You can choose the one you want and use it as it is, or modify it to meet your own requirements. However, it is not possible to save customized layouts.

Master Pages
 

Here you define the page (slide) style for your presentation. Impress includes several designs for Master Pages (slide masters). One of them – Default – is blank, and the rest have background and styled text.

Go to Format > Styles > Styles and Formatting on the Menu bar or press the F11 key to open the Styles and Formatting dialog, where you can modify the styles used in any master page to suit your purpose. This can be done at any time.

Custom Animation
 

A variety of animations can be used to emphasize or enhance different elements of each slide. The Custom Animation section provides an easy way to add, change, or remove animations.

Slide Transition
 

Provides a number of slide transition options. The default is set to No Transition, in which the following slide simply replaces the existing one. However, many additional transitions are available. You can also specify the transition speed (slow, medium, fast), choose between an automatic or manual transition, and choose how long the selected slide should be shown (automatic transition only).

Styles and Formatting
 

Here you can edit and apply graphics styles and create new ones, but you can only edit existing presentation styles. When you edit a style, the changes are automatically applied to all of the elements formatted with this style in your presentation. If you want to ensure that the styles on a specific slide are not updated, create a new master page for the slide.

Gallery
 

Opens the Impress gallery from which you can insert an object into your presentation either as a copy or as a link. A copy of an object is independent of the original object, so changes to the object have no effect on the copy. A link remains dependent on the original object and changes to the object are reflected in the link.

Navigator
 

Opens the Impress navigator, in which you can quickly move to another slide or select an object on a slide. It is recommended to give slides and objects in your presentation meaningful names so that you can easily identify them when using the navigator.

Toolbars

Many toolbars can be used during slide creation. They can be displayed or hidden by going to View > Toolbars on the Menu bar and selecting from the context menu.

You can also select the icons that you wish to appear on each toolbar. For more information, refer to Chapter 1 Introducing LibreOffice.

Many of the toolbars in Impress are similar to the toolbars in Draw. Refer to the Draw Guide for details on the functions available and how to use them.

Status bar

The Status bar (Figure 2), located at the bottom of the Impress window, contains information that you may find useful when working on a presentation. For details on the contents and use of these fields, see Chapter 1 Introducing LibreOffice in this guide and the Impress Guide Chapter 1 Introducing Impress.

 

Figure 2: Status bar

 

The sizes are given in the current measurement unit (not to be confused with the ruler units). This measurement unit is defined in Tools > Options > LibreOffice Impress > General.

From left to right, you will find:

Example selection

Examples of information shown

Text area

Text Edit: Paragraph x, Row y, Column z

Charts, spreadsheets

Embedded object (OLE) “ObjectName” selected

Graphics

Bitmap with transparency selected

You can hide the Status Bar and its information by going to View on the Menu bar and deselecting Status Bar.

Workspace views

Each of the Workspace views is designed to ease the completion of certain tasks. It is therefore useful to familiarize yourself with them in order to accomplish those tasks quickly.

Beginning with LibreOffice 5.1, the Workspace View tab bar is hidden by default. Turn it visible by choosing View > Modes Tab Bar.

Each Workspace view displays a different set of toolbars when selected. These toolbar sets can be customized by going to View > Toolbars on the Menu bar, then check or uncheck the toolbar you want to add or remove.

Normal view

Normal view is the main view for working with individual slides. Use this view to format and design and to add text, graphics, and animation effects.

To place a slide in the slide design area (Normal view) (Figure 1 on page 6), click the slide thumbnail in the Slides pane or double-click it in the Navigator (see Chapter 1 Introducing LibreOffice and the Impress Guide for more information on the Navigator).

Outline view

Outline view (Figure 3) contains all the slides of the presentation in their numbered sequence. It shows topic titles, bulleted lists, and numbered lists for each slide in outline format. Only the text contained in the default text boxes in each slide is shown, so if your slide includes other text boxes or drawing objects, the text in these objects is not displayed. Slide names are not included either.

 

Figure 3: Outline view

 
 

Figure 4: Outline level and movement arrows in Text Formatting toolbar

 

Use Outline view for the following purposes:

Notes view

Use the Notes view (Figure 5) to add notes to a slide. These notes are for your information and are not seen by the audience when the presentation is shown.

 

Figure 5: Notes view

 
  1. 1)Click the Notes tab in the Workspace. 

  2. 2)Select the slide to which you want to add notes: click the slide in the Slides pane, or double-click the slide name in the Navigator. 

  3. 3)In the text box below the slide, click on the words Click to add notes and begin typing. 

You can resize the Notes text box using the colored resizing handles which appear when you click on the edge of the box. You can also move the box by placing the pointer on the border, then clicking and dragging. To make changes in the text style, click on the Styles and Formatting icon
on the Sidebar.
 

Handout view

Handout view is for setting up the layout of your slide for a printed handout. Click the Handout tab in the workspace and the Layouts section opens on the Sidebar (Figure 6). Here you can choose to print 1, 2, 3, 4, 6, or 9 slides per page. If the Layouts section does not open, then click on the Properties icon
at the side of the Sidebar.
 

Use this view also to customize the information printed on the handout. Refer to the Impress Guide Chapter 10 Printing, E-mailing, Exporting, and Saving Slide Shows for instructions on printing slides, handouts, and notes.

Go to Insert > Page Number, Insert > Fields, or Insert > Header and Footer on the Menu bar and the Header and Footer dialog opens. Click on the Notes and Handouts tab (Figure 7) and select the elements you want to appear on each handout page and their contents. More details on how to use this dialog are provided in the Impress Guide.

 
 
 
 

Slide Sorter view

Slide Sorter view (Figure 8) contains all of the slide thumbnails. Use this view to work with a group of slides or with only one slide.

 

Figure 8: Slide Sorter view

 

Customizing Slide Sorter view

To change the number of slides per row:

  1. 1)Go to View > Toolbars and select Slide Sorter and Slide View to show or hide the Slide Sorter and Slide View toolbars (Figure 9). 

  2. 2)Adjust the number of slides (up to a maximum of 15). 

 

Figure 9: Slide Sorter and Slide View toolbars

 

Moving a slide using Slide Sorter

To move a slide in a presentation in the Slide Sorter:

  1. 1)Click the slide and the slide is highlighted (Figure 8). 

  2. 2)Drag and drop the slide to the location you want. 

Selecting and moving groups of slides

To select a group of slides, use one of these methods:

To move a group of slides, select them and then drag and drop the group to their new location.

Working in Slide Sorter view

You can work with slides in the Slide Sorter view just as you can in the Slide pane. To make changes, right-click a slide and choose any of the following from the context menu:

Creating a new presentation using the Presentation Wizard

This section describes how to start a new presentation using the Presentation Wizard.

The first thing to do is decide on the purpose of the presentation and set out a plan. Although you can make changes as you go, you will save a lot of time by having an initial idea of who the audience will be, the structure, the content, and how the presentation will be delivered.

When you start Impress, the Presentation Wizard may appear (Figure 10).

  1. 1)In step 1, under Type, choose one of the options. These options are covered in the Impress Guide. 

 

Figure 10: Choosing the type of presentation

 
  1. 2)Click Next. Figure 11 shows the Presentation Wizard step 2 as it appears if you selected Empty Presentation at step 1. If you selected From template, an example slide is shown in the Preview box. 

  2. 3)Choose a design under Select a slide design. The slide design section gives you two main choices: Presentation Backgrounds and Presentations. Each one has a list of choices for slide designs. If you want to use one of these other than <Original>, click it to select it. 

 

Figure 11: Selecting a slide design

 
  1. 4)Select how the presentation will be used under Select an output medium. The majority of presentations are created for computer screen display so it is recommended to select Screen. You can change the page format at any time. 

The Screen page is set by default for a 4:3 display (28cm x 21cm) so it is not suitable for modern widescreen displays. Use the Widescreen option instead. You can also change the slide size and proportions at any time by switching to Normal view and selecting Slide > Page/Slide Properties... .

  1. 5)Click Next and step 3 of the Presentation Wizard appears (Figure 12). 

  1. a)Choose the desired slide transition from the Effect drop-down menu. 

  2. b)Select the desired speed for the transition between the different slides in the presentation from the Speed drop-down menu. Medium is a good choice for now. 

  3. c)Select the presentation type. For most purposes, choose Default; you can change this later. For details on the choices under Automatic, see the Impress Guide. 

 

Figure 12: Selecting a slide transition effect

 

If you did not select a template in step 1 of the Presentation Wizard, then steps 4 and 5 will not appear after step 3. Click Create and your new presentation is created.

  1. 6)Click Next. In step 4 of the Presentation Wizard appears, you can enter information about your company and the presentation you are creating. 

 

Figure 13: Entering information about your presentation

 
  1. 7)Click Next. In step 5, the Presentation Wizard shows a preview of what your presentation will look like (Figure 14). If the preview does not appear, select Preview. 

  2. 8)If you want to create a summary of your presentation, select Create summary. 

  3. 9)Click Create and your new presentation is created. 

You can accept the default values for both Effect and Speed unless you are skilled at creating presentations. Both of these values can be changed later while working with slide transitions and animations. These two features are explained in more detail in the Impress Guide Chapter 9 Slide Shows.