Getting Started Guide
 

Chapter 7  
Getting Started with Draw

Vector Drawing in LibreOffice

Copyright

This document is Copyright © 2010–2016 by the LibreOffice Documentation Team. Contributors are listed below. You may distribute it and/or modify it under the terms of either the GNU General Public License (http://www.gnu.org/licenses/gpl.html), version 3 or later, or the Creative Commons Attribution License (http://creativecommons.org/licenses/by/4.0/), version 4.0 or later.

All trademarks within this guide belong to their legitimate owners.

Contributors

Peter Schofield

Jean Hollis Weber

Hazel Russman

Ron Faile Jr.

Olivier Hallot

 

Feedback

Please direct any comments or suggestions about this document to the Documentation Team’s mailing list: documentation@global.libreoffice.org

Note: Everything you send to a mailing list, including your email address and any other personal information that is written in the message, is publicly archived and cannot be deleted.

Acknowledgments

This chapter is adapted and updated from Chapter 7 of Getting Started with OpenOffice.org 3.3. The contributors to that chapter are:

Agnes Belzunce

Chris Bonde

Daniel Carrera

Regina Henschel

Michel Pinquier

Iain Roberts

Gary Schnabl

Joe Sellman

Jim Taylor

Alex Thurgood

Jean Hollis Weber

Linda Worthington

Michele Zarri

 

 

Publication date and software version

Published 21 July 2016. Based on LibreOffice 5.1.

Note for Mac users

Some keystrokes and menu items are different on a Mac from those used in Windows and Linux. The table below gives some common substitutions for the instructions in this chapter. For a more detailed list, see the application Help.

Windows or Linux

Mac equivalent

Effect

Tools > Options menu selection

LibreOffice > Preferences

Access setup options   

Right-click

Control+click and/or right-click depending on computer setup

Open a context menu

Ctrl (Control)

⌘ (Command)

Used with other keys

F5

Shift+⌘+F5

Open the Navigator

F11

⌘+T

Open the Styles and Formatting window

 

Contents

Copyright

Contributors

Feedback

Acknowledgments

Publication date and software version

Note for Mac users

What is Draw?

Draw main window

Workspace

Pages pane

Layers bar

Sidebar

Rulers

Status bar

Toolbars

Standard toolbar

Drawing toolbar

Line and Filling toolbar

Text Formatting toolbar

Options toolbar

Working with layers

Adding a layer

Choosing and defining colors

Drawing basic shapes

Drawing a straight line

Drawing an arrow

Choosing line endings

Drawing rectangles or squares

Drawing circles or ellipses

Drawing curves or polygons

Curves

Polygons

Polygons 45°

Freeform lines

Adding text

Glue points and connectors

Glue points

Connectors

Drawing geometric shapes

Basic shapes

Symbol shapes

Block arrows

Flowcharts

Callouts

Stars and banners

Selecting objects

Direct selection

Selection by framing

Selecting hidden objects

Arranging objects

Moving and adjusting object size

Moving objects

Adjusting object size

Rotating and slanting an object

Rotating an object

Slanting an object

Editing objects

Line and Filling toolbar

Text Formatting toolbar

Sidebar Properties

Context menu

Formatting lines and borders

Arrows, arrowheads, and line endings

Formatting area fill

Using styles

Positioning objects

Snap function

Snap to grid

Displaying the grid

Configuring the grid

Help lines

Applying special effects

Flipping objects

Mirror copies

Distorting an object

Dynamic transparency gradients

Duplication

Cross-fading

Combining multiple objects

Grouping

Temporary grouping

Permanent grouping

Ungrouping

Combining objects

Arranging, aligning, and distributing objects

Inserting and editing pictures

Working with 3D objects

Exporting graphics

Inserting comments in a drawing

 

What is Draw?

LibreOffice Draw is a vector graphics drawing program, although it can also perform some operations on raster graphics (pixels). Using Draw, you can quickly create a wide variety of graphical images.

Vector graphics store and display an image as an assembly of simple geometric elements such as lines, circles, and polygons, rather than a collection of pixels (points on the screen). Vector graphics allow for easier storage and scaling of the image.

Draw is fully integrated into the LibreOffice suite, and this simplifies exchanging graphics with all components of the suite. For example, if you create an image in Draw, reusing it in a Writer document is as simple as copying and pasting the image. You can also work with drawings directly from within Writer or Impress, using a subset of the functions and tools from Draw.

The functionality of LibreOffice Draw is extensive and, even though it was not designed to rival high-end graphics applications, it possesses more functionality than the drawing tools that are generally integrated with most office productivity suites.

A few examples of the drawing functions are: layer management, magnetic grid-point system, dimensions and measurement display, connectors for making organization charts, 3D functions that enable small three-dimensional drawings to be created (with texture and lighting effects), drawing and page-style integration, and Bézier curves.

This chapter introduces some features of Draw and does not attempt to cover all of the Draw features. See the Draw Guide and the application help for more information.

Draw main window

The main components of the Draw main window are shown in Figure 1:

Workspace

The large area in the center of the window (Workspace) is where you create your drawings and this drawing area can be surrounded with toolbars and information areas. The number and position of the visible tools vary with the task in hand and user preferences, therefore your setup may look different from Figure 1.

In LibreOffice Draw, the maximum size of a drawing is 300 cm by 300 cm.

Pages pane

You can split drawings in Draw over several pages. Multi-page drawings are used mainly for presentations. The Pages pane gives an overview of the pages that you create in your drawing. If the Pages pane is not visible, go to View on the Menu bar and select Page Pane. To make changes to the page order, drag and drop one or more pages.

 

Figure 1: LibreOffice Draw workspace

 

Layers bar

A layer is a workspace where you insert your drawings elements and objects. The layers bar is located on the bottom of the workplace and contains the guides for layer selection and layer command. For more information on layers see “Working with layers“ on page 10.

Sidebar

The Sidebar has four main sections. To expand a section, click on its icon or click on the small triangle at the top of the icons and select a section from the drop down list. Only one section at a time can be open. If the Sidebar is not visible, go to View on the Menu bar and select Sidebar from the context menu.

Properties
 

Opens sub-sections for object properties that you can change to suit your requirements. The sub-sections are Insert Shapes, Character, Paragraph, Area, Line and Position and Size.

Styles and Formatting
 

Here you can edit and apply image styles to objects within your drawing. When you edit a style, the changes are automatically applied to all of the elements formatted with this image style in your drawing.

Gallery
 

Opens the Drawing gallery where you can insert an object into your drawing either as a copy or as a link. A copy of an object is independent of the original object. Changes to the original object have no effect on the copy. A link remains dependent on the original object. Changes to the original object are also reflected in the link.

Navigator
 

Opens the Drawing navigator, in which you can quickly move between pages in your drawing or select an object on the drawing. It is recommended to give pages and objects in your drawing meaningful names so that you can easily identify them when using the Navigator.

Rulers

You should see rulers (bars with numbers) on the upper and left-hand sides of the workspace. If they are not visible, you can enable them by selecting View > Ruler in the Menu bar. The rulers show the size of a selected object on the page using double lines (highlighted in Figure 2). When no object is selected, they show the location of the mouse pointer, which helps to position drawing objects more accurately.

You can also use the rulers to manage object handles and guide lines, making it easier to position objects.

The page margins in the drawing area are also represented on the rulers. You can change the margins directly on the rulers by dragging them with the mouse. The margin area is indicated by the grayed out area on the rulers as shown in Figure 2.

 

Figure 2: Rulers showing size of a selected object

 

To change the measurement units of the rulers, which can be defined independently, right-click on a ruler and select the measurement unit from the drop down list, as illustrated for the horizontal ruler in Figure 3.

 

Figure 3: Ruler units

 

Status bar

The Status bar is located at the bottom of the workspace in all LibreOffice components. It includes several Draw-specific fields. For details on the contents and use of these fields, see Chapter 1 Introducing LibreOffice in this guide and in the Draw Guide Chapter 1 Introducing Draw.

 

Figure 4: Draw status bar

 

The sizes are given in the current measurement unit. They might not be the same as the ruler units. The measurement unit on the Status bar is defined in Tools > Options > LibreOffice Draw > General, where you can also change the scale of the page.

Toolbars

To display or hide the various Draw toolbars, go to View > Toolbars on the Menu bar. On the menu that appears, select which toolbars you want to display. For more about working with toolbars, see Chapter 1 Introducing LibreOffice in this guide.

The tools available in the Draw toolbars are explained in the following sections. The appearance of the toolbar icons may vary depending on your operating system and the selection of icon size and style in Tools > Options > LibreOffice > View.

Standard toolbar

The Standard toolbar is the same for all LibreOffice components and is not described in detail in this chapter. By default, it is located just under the Menu bar.

Drawing toolbar

The Drawing toolbar is the most important toolbar in Draw. It contains all the necessary functions for drawing various geometric and freehand shapes and for organizing them on the page. By default, it is docked vertically on the left side of the Draw window.

Line and Filling toolbar

Use the Line and Filling toolbar to modify the main properties of a drawing object. The icons and pull-down lists vary according to the type of object selected. For example, to change the style of a line, click on the up and down arrows for Line Style and select the required style.

The functions on this toolbar are also provided in the Properties pane of the sidebar when a drawing object is selected. By default, the Line and Filling toolbar is not shown, but you can display it from the View > Toolbars menu.

Text Formatting toolbar

If the selected object is text, the Sidebar shows relevant formatting choices in the Properties pane. By default, the Text Formatting toolbar is not shown, but you can display it from the View > Toolbars menu. If you have enabled both the Line and Filling toolbar and the Text Formatting toolbar, Draw switches between them depending on what object is selected.

Options toolbar

Use the Options toolbar to activate or deactivate various drawing aids. By default, the Options toolbar is not shown, but you can display it from the View > Toolbars menu.

Working with layers

Use layers to create a complex drawing by stacking simpler drawings in each layer. The area of a layer that does not contain an object is transparent. You can add any number of layers in a drawing document. A layer can be set to visible or hidden, it can be printable or not. Layers are common to all pages of the drawing.

A Draw document contains three default layers that you cannot delete or rename. Here are the common ways of using them:

For more information on layers, see the Draw Guide Chapter 11 Advanced Draw Techniques.

Adding a layer

To add a layer to your drawing, select Insert > Layer... from the menu bar or right-click any layer tab in the Layers bar on the bottom of the workspace (Figure 1) and choose Insert Layer... The Insert Layer dialog opens (Figure 5).

Add a name, title, and description of the layer. Select if you want it printable or not, visible or hidden, or locked to prevent further changes or accidental edits.

A hidden layer still shows in the Layers bar, but its name is in blue. You cannot reorder layers in the Layers bar.

Layers do not determine the stacking order of objects on the page, except for the Controls layer which is always in front of other layers. The stacking order of objects is determined by the sequence in which you add the objects. You can rearrange the stacking order by Modify > Arrange.

 
 

Choosing and defining colors

To display the Colors dialog (Figure 6), select View > Toolbars > Color Bar to display the current color palette. By default, the Color Bar is displayed below the workspace. You can hide or show it by clicking on its Hide/Show button. Here you can rapidly choose the color of objects in your drawing (lines, areas, and 3D effects). The first box corresponds to none (no color).

 

Figure 6: Color bar

 

You can access several specialized color palettes in Draw, as well as change individual colors to your own taste. To do this, use the Area dialog by selecting Format > Area on the Menu bar or clicking the Area icon on the Sidebar, then selecting the Colors tab (Figure 7).

To load another palette, click on the Load Color List icon. The file selector dialog asks you to choose one of the standard LibreOffice palettes (files with the file extension *.soc). For example, web.soc is a color palette that is adapted to creating drawings for placing in web pages. These colors will display correctly on workstations with screens capable of at least 256 colors.

 

Figure 7: Area dialog – Colors page

 

The color selection box also lets you individually change any color by modifying the numerical values in the fields provided to the right of the color palette. You can use the color schemes known as CMYK (Cyan, Magenta, Yellow, Black) or RGB (Red, Green, Blue).

Click on the Pick button to open the Pick a Color dialog, where you can set individual colors. See “Color options” in Chapter 2 Setting Up LibreOffice in this guide.

For a more detailed description of color palettes and their options, see the Draw Guide Chapter 11 Advanced Draw Techniques.

Drawing basic shapes

Draw provides a wide range of shapes, located in palettes accessed from the Drawing toolbar.

This section describes only a few of the basic shapes, including text, which are treated as objects in Draw. See the Draw Guide for a complete description of the shapes available.

Some of the icons on the Drawing toolbar will change according to the shape that has been selected from the choices available. Icons with tool palettes available are indicated by a small triangle to the right of the icon.

When you draw a basic shape or select one for editing, the Info field at the left side in the status bar changes to reflect the present action: for example Line created, Text frame xxyy selected, and so on.

Drawing a straight line

Click on the Line icon and place the cursor at the point where you want to start the line (Figure 8). Drag the mouse while keeping the mouse button pressed. Release the mouse button at the point where you want to end the line. A selection handle appears at each end of the line, showing that this object is the currently selected object. The selection handle at the starting point of the line is slightly larger than the other selection handle.

 

Figure 8: Drawing a straight line

 

Keep the Ctrl key pressed while drawing a line to enable the end of the line to snap to the nearest grid point.

This is the default behavior of the Ctrl key. However, if the Snap to Grid option on the View > Grid menu has been selected, the Ctrl key deactivates the snap to grid activity.

Keep the Shift key pressed while you draw a line to restrict the drawing angle of the line to a multiple of 45 degrees (0, 45, 90, 135, and so on).

This is the default behavior of the Shift key. However, if the option When creating or moving objects in the Snap position section of Tools > Options > LibreOffice Draw > Grid has been selected, the action of the Shift key is the opposite. Lines will automatically be drawn at a multiple of 45 degrees unless the Shift key is pressed.

Hold down the Alt key while drawing a line to cause the line to extend outwards symmetrically in both directions from the start point. This lets you draw lines by starting from the middle of the line.

When a line is drawn, it uses default attributes. To change any of these attributes, select a line by clicking on it, then right-click and select Line from the context menu or go to Format > Line on the Menu bar to open the Line dialog (Figure 9). Alternatively, click on the Properties icon on the Sidebar and open the Line sub-section. Line style, line width, and line color can also be changed using the controls in the Line and Filling toolbar at the top of the workspace.

 

Figure 9: Line dialog

 

Drawing an arrow

Arrows are drawn like lines. In fact Draw classifies arrows as a subgroup of lines: lines with arrowheads. The information field on the status bar shows them only as lines. Click on the Line Ends with Arrow icon on the Drawing toolbar or the Insert Shapes sub-section in Sidebar Properties to draw an arrow. The arrow head is drawn at the end point of the arrow when you release the mouse button.

Choosing line endings

Several types of line endings (arrows, circles, squares, and others) are available in Draw. Click on the small triangle to the right of the Lines and Arrows icon on the Drawing toolbar or the Insert Shapes sub-section in Sidebar Properties to open a tool palette containing tools for drawing lines and arrows. Alternatively, go to View > Toolbars > Arrows to open the Arrows toolbar as a floating toolbar (Figure 10). The icon for the tool used most recently will be shown on the Drawing toolbar to make it easier to use the same tool again.

After drawing the line, you can change the arrow style by clicking on the Arrowheads icon in the Line and Filling toolbar and select the arrow start and end options.

 

Figure 10: Arrows toolbar and available tools

 

Drawing rectangles or squares

Drawing a rectangle is similar to drawing a straight line. Click on the Rectangle icon in the Drawing toolbar or the Insert Shapes sub-section in Sidebar Properties. As you draw the rectangle with the mouse cursor, the rectangle appears with its bottom right corner attached to the cursor.

Squares are rectangles with all sides of equal length. To draw a square, click on the Rectangle  icon and hold down the Shift key whilst you draw a square.

If the option When creating or moving objects has been selected in Tools > Options > LibreOffice Draw > General, the action of the Shift key is reversed. When the Rectangle tool is selected, a square is drawn. To draw a rectangle, you have to press the Shift key when drawing. This Shift key reversal also applies when drawing ellipses and circles.

To draw a rectangle or square from its center rather than the bottom right corner, position your cursor on the drawing, press the mouse button and then hold down the Alt key while dragging with the cursor. The rectangle or square uses the start point (where you first clicked the mouse button) as the center.

Drawing circles or ellipses

To draw an ellipse (also called an oval), click on the Ellipse icon on the Drawing toolbar or the Insert Shapes sub-section in Sidebar Properties. A circle is an ellipse with both axes the same length. To draw a circle, click on the Ellipse icon and hold down the Shift key whilst you draw a circle.

To draw an ellipse or circle from its center, position your cursor on the drawing, press the mouse button and then hold down the Alt key while dragging with the cursor. The ellipse or circle uses the start point (where you first clicked the mouse button) as the center.

If you first press and hold down the Ctrl key and then click on one of the icons for Line, Rectangle, Ellipse, or Text, a standard sized object is drawn automatically in the work area; the size, shape, and color are all standard values. These attributes can be changed later, if desired. See the Draw Guide for more information.

Drawing curves or polygons

To draw a curve or polygon click the Curve icon on the Drawing toolbar or the Insert Shapes sub-section in Sidebar Properties. Click on the triangle to the right of the icon to open the tool palette containing tools that are available for drawing curves and polygons (Figure 11). The icon for the tool used most recently will be shown on the Drawing toolbar to make it easier to use the same tool again.

Move the mouse cursor over one of the icons to show a tooltip with a description of the function.