Getting Started Guide
 

Chapter 8  
Getting Started with Base

Relational Databases in LibreOffice

Copyright

This document is Copyright © 2010–2016 by the LibreOffice Documentation Team. Contributors are listed below. You may distribute it and/or modify it under the terms of either the GNU General Public License (http://www.gnu.org/licenses/gpl.html), version 3 or later, or the Creative Commons Attribution License (http://creativecommons.org/licenses/by/4.0/), version 4.0 or later.

All trademarks within this guide belong to their legitimate owners.

Contributors

Dan Lewis

Jean Hollis Weber

Hazel Russman

Ron Faile Jr.

Olivier Hallot

 

Feedback

Please direct any comments or suggestions about this document to the Documentation Team’s mailing list: documentation@global.libreoffice.org

Note: Everything you send to a mailing list, including your email address and any other personal information that is written in the message, is publicly archived and cannot be deleted.

Acknowledgments

This chapter is based on Chapter 8 of Getting Started with OpenOffice.org 3.3. The contributors to that chapter are:

Dan Lewis

Magnus Adielsson

JiHui Choi

Iain Roberts

Jean Hollis Weber

 

Publication date and software version

Published 30 June 2016. Based on LibreOffice 5.1.

Note for Mac users

Some keystrokes and menu items are different on a Mac from those used in Windows and Linux. The table below gives some common substitutions for the instructions in this chapter. For a more detailed list, see the application Help.

Windows or Linux

Mac equivalent

Effect

Tools > Options menu selection

LibreOffice > Preferences

Access setup options   

Right-click

Control+click and/or right-click depending on computer setup

Open a context menu

Ctrl (Control)

⌘ (Command)

Used with other keys

F5

Shift+⌘+F5

Open the Navigator

F11

⌘+T

Open the Styles and Formatting window

 

Contents

Copyright

Contributors

Feedback

Acknowledgments

Publication date and software version

Note for Mac users

Introduction

Planning a database

Creating a new database

Creating database tables

Using the Wizard to create a table

Creating a table by copying an existing table

Creating tables in Design View

Defining relationships

Creating a database form

Using the Wizard to create a form

Modifying a form

Creating forms and sub forms in Design View

Entering data in a form

Quickly populate a table with data from a spreadsheet

Creating queries

Using the Wizard to create a query

Using the Design View to create a query

Creating reports

Creating a report: Example

Report wizard vs Report Design View

Vacations table report

Report Builder: another way to create reports

Accessing other data sources

Accessing a spreadsheet as a data source

Registering *.odb databases

Using data sources in LibreOffice

Viewing data sources

Editing data sources

Launching Base to work on data sources

Using data sources in Writer and Calc

Writer documents

Calc spreadsheets

 

Introduction

A data source, or database, is a collection of pieces of information that can be accessed or managed by LibreOffice. For example, a list of names and addresses is a data source that could be used for producing a mail merge letter. A shop stock list could be a data source managed through LibreOffice.

This chapter covers creating a database, showing what is contained in a database and how the different parts are used by LibreOffice.

LibreOffice uses the terms “Data Source” and “Database” to refer to the same thing, which could be a database such as MySQL or dBase or a spreadsheet or text document holding data.

A database consists of a number of fields that contain the individual pieces of data. Each table of the database is a group of fields. When creating a table, you also determine the characteristics of each field within it. Forms are for data entry into the fields of one or more tables which have been associated with the form. They can also be used for viewing fields from one or more tables associated with the form. A query creates a new table from the existing tables based upon how you create the query. A report organizes the information from the fields of a query into a document according to your requirements.

LibreOffice Base uses the HSQL database engine. All of the files created by this engine, including the database forms, are kept in one zipped file.

To use Base, you need to use a Java Runtime Environment (JRE). Please go to Tools > Options > LibreOffice > Advanced to select a JRE from those installed on your computer.

If a JRE is not already installed, you will need to download and install one. For Windows, you need to get Java from www.java.com. For Linux, you can download it from the same website or you can use openjdk-7-jre, available from the repository of your Linux version. Mac OS X users can install a JRE from Apple Inc.

Base creates relational databases. This makes it fairly easy to create a database in which the fields of the database have relationships with each other.

For example: Consider a database for a library. It will contain a field for the names of the authors and another field for the names of the books. There is an obvious relationship between the authors and the books they have written. The library may contain more than one book by the same author. This is what is known as a one-to-many relationship: one author and more than one book. Most if not all the relationships in such a database are one-to-many relationships.

Consider an employment database for the same library. One of the fields contains the names of the employees while others contain the social security numbers, and other personal data. The relationship between the names and social security numbers is one-to-one: only one social security number for each name.

If you are acquainted with mathematical sets, a relational database can easily be explained in terms of sets: elements, subsets, unions, and intersections. The fields of a database are the elements. The tables are subsets. Relationships are defined in terms of unions and intersections of the subsets (tables).

To explain how a database works and how to to use it, we will create one for automobile expenses.

Planning a database

The first step in creating a database is to ask yourself many questions. Write them down, and leave some space between the questions to write the answers later. At least some of the answers should seem obvious after you take some time to think.

You may have to go through this process a few times before everything becomes clear in your mind and on paper. Using a text document for these questions and answers makes it easier to move the questions around, add additional questions, or change the answers.

Here are some of the questions and answers I developed before I created a database for automobile expenses. I had an idea of what I wanted before I started, but as I began asking questions and listing the answers, I discovered that I needed additional tables and fields.

What are the fields going to be? My expenses divided into three broad areas: fuel purchases, maintenance, and vacations. The annual cost for the car’s license plate and driver’s license every four years did not fit into any of these. It will be a table of its own: license fees.

What fields fit the fuel purchases area? Date purchased, odometer reading, fuel cost, fuel quantity, and payment method for it. (Fuel economy need not be included, as it can be calculated using a query.)

What fields fit the maintenance area? Date of service, odometer reading, type of service, cost of service, and next scheduled service of this type (for example, for oil changes, list when the next oil change should be). But it would be nice if there was a way to write notes. So a field for notes was added to the list.

What fields fit the vacations area? Date, odometer reading, fuel (including all the fields of the fuel table), food (including meals and snacks), motel, total tolls, and miscellaneous. Since these purchases are made by one of two bank cards or with cash, I want a field to state which payment type was used for each item.

What fields fit into the food category? Breakfast, lunch, supper, and snacks seem to fit. Do I list all the snacks individually or list the total cost for snacks for the day? I chose to divide snacks into two fields: number of snacks and total cost of snacks. I also need a payment type for each of these: breakfast, lunch, supper, and total cost of snacks.

What are the fields that are common to more than one area? Date appears in all of the areas as does odometer reading and payment type.

How will I use this information about these three fields? While on vacation, I want the expenses for each day to be listed together. The date fields suggest a relationship between the vacation table and the dates in each of these tables: fuel and food, This means that the date fields in these tables will be linked as we create the database.

The type of payment includes two bank cards and cash. So we will create a table with a field for the type of payment and use it in list boxes in the forms.

While we have listed fields we will create in the tables of the database, there is one more field that may be needed in a table: the field for the primary key, an identifier unique to each record. In some tables, a suitable field for the primary key has already been listed. In other tables such as the payment type, an additional field for the primary key must be created.

Creating a new database

To create a new database, select File > New > Database from the menu bar, or click the arrow next to the New icon on the Standard toolbar and select Database from the drop-down menu. Both methods open the Database Wizard.

On the first page of the Database Wizard, select Create a new database and then click Next.

The second page has two questions. Make sure the choice for the first question is Yes, register the database for me and the choice for the second question is Open the database for editing. Click Finish.

In Writer, the F4 key opens and closes the Data Source window containing the list of registered databases. In Calc, press Ctrl+Shift+F4 to open the Data Source window. If a database is not registered, this window will not contain it, so you cannot access the database in Writer or Calc.

Save the new database with the name Automobile. This opens the Automobile – LibreOffice Base window. Figure 1 shows part of this window.

 

Figure 1: Creating database tables

 

Every time the Automobile database is opened, the Automobile – LibreOffice Base window opens. Changes can then be made to the database. The title for this window is always <database name> – LibreOffice Base.

As you create a database, you should save your work regularly. This means more than saving what you have just created. You must save the whole database as well.

For example, when you create your first table, you must save it before you can close it. This makes it part of the database in memory. But it is only when you save the database file that the table is written to disk.

Database files in Open Document Format are stored with the *.odb extension. This file format is actually a container of all elements of the database, including forms, reports, tables, and the data itself. The same format can also store a connection to an external database server instead of the local data, for example, to access a MySQL or PostgresSQL database server in your network.

Creating database tables

In a database, a table stores information in a group of things we call fields. For example, a table might hold an address book, a stock list, a phone book or a price list. A database must have at least one table and may have several.

Each field of a table contains information of a single type. For example, the Phone field of an address book would only contain phone numbers. Similarly, a price list table could contain two fields: Name and Price. The Name field would contain the names of the items;  the Price field would contain the amount of each item.

To work with tables, click the Tables icon in the Database list, or press Alt+a. The three tasks that you can perform on a table are in the Tasks list (see Figure 1).

Using the Wizard to create a table

Wizards are designed to do the basic work. Sometimes this is not sufficient for what we want; in those cases we can use a wizard as a starting point and then build upon what it produces.

The Table Wizard in Base contains two categories of suggested tables: business and personal. Each category contains sample tables from which to choose. Each table has a list of available fields. We can delete some of these fields and add other fields.

A field in a table is one bit of information. For example, a price list table might have one field for item name, one for the description, and a third for the price.

Since none of the fields we need for our Automobile database are contained in any of the sample wizard tables, we will create a simple table using the wizard that has nothing to do with our database. This section is merely an exercise in explaining how the Wizard works.

The Wizard permits the fields of the table to come from more than one suggested table. We will create a table with fields from three different suggested tables in the Wizard.

Every table requires a Primary key field. (What this field does will be explained later.) We will use this field to number our entries and want that number to automatically increase as we add each entry.

Click Use Wizard to Create Table. This opens the Table Wizard (Figure 2).

Step 1: Select fields

We will use the CD-Collection Sample table in the Personal category and Employees in the Business category to select the fields we need.

  1. 1)Category: Select Personal. The Sample Tables drop down list changes to a list of personal sample tables. 

  2. 2)Sample tables: Select CD-Collection. The Available fields box changes to a list of available fields for this table. 

  3. 3)Selected fields: Using the > button, move the following fields from the Available fields window to the Selected fields window in this order: CollectionID, AlbumTitle, Artist, DatePurchased, Format, Notes, and NumberofTracks. 

  4. 4)Selected Fields from another sample table. Click Business as the Category. Select Employees from the drop down list of sample tables. Use the > button to move the Photo field from the Available fields window to the Selected fields window. It will be at the bottom of the list directly below the NumberofTracks field. 

  5. 5)If you make a mistake in selecting fields, click on the field name in the Selected fields list and use the < button to move it from the Selected fields list back to the Available fields list. 

  6. 6)If you make a mistake in the order of the selected fields, click on the field name that is in the wrong order and use the Up or Down arrow on the right side of the Selected fields list to move the field name to the correct position. 

  7. 7)Click Next. 

 

Figure 2: Selecting fields for the table

 

Step 2: Set field types and formats

 

Figure 3: Changing field types

 

In this step you give the fields their properties. When you click a field, the information on the right changes. (See Figure 3.) You can then make changes to meet your needs. Click each field, one at a time, and make the changes listed below.

If any of these fields requires a mandatory entry, set Entry required to Yes. A blank field will then not be allowed. In general, only set Entry required to Yes if something must always be put in that field. By default, Entry required is set to No.

In Base the maximum length of each field must be specified on creation. It is not easy to change this later, so if in doubt specify a greater length. Base uses VARCHAR as the field format for text fields. This format uses only the actual number of characters in a field up to the limit set, so a field containing 20 characters will occupy only 20 characters even if the limit is set at 100. Two album titles containing 25 and 32 characters respectively will use space for 25 and 32 characters and not 100 characters.

When you have finished, click Next.

Each field has a Field Type, which must be specified. Types include text, integer, date, and decimal. If the field is going to have general information in it (for example, a name or a description), use text. If the field will always contain a number (for example, a price), the type should be decimal or another numerical field. The wizard picks the right field type, so to get an idea of how this works, see what the wizard has chosen for different fields.

Step 3: Set primary key

  1. 1)Create a primary key should be checked. 

  2. 2)Select option Use an existing field as a primary key. 

  3. 3)In the Fieldname drop down list, select CollectionID. 

  4. 4)Check Auto value if it is not already checked. Click Next. 

A primary key uniquely identifies an item (or record) in the table. For example, you might know two people called “Randy Herring” or three people living at the same address and the database needs to distinguish between them.

The simplest method is to assign a unique number to each one: number the first person 1, the second 2, and so on. Each entry has one number and every number is different, so it is easy to say “record ID 172”. This is the option chosen here: CollectionID is just a number assigned automatically by Base to each record of this table.

Step 4: Create the table

  1. 1)If desired, rename the table at this point. If you rename it, make the name meaningful to you. For this example, make no changes. 

  2. 2)Leave the option Insert data immediately checked. 

  3. 3)Click Finish to complete the table wizard. Close the window created by the table wizard. You are now back to the main window of the database with the listing of the tables, queries, forms, and reports. Notice that a table named “CD-Collection” is now listed in the Tables portion of the window. 

  4. 4)Click the Save button at the top of the main window. 

Creating a table by copying an existing table

If you have a large collection of music, you might want to create a table for each type of music you have. Rather than creating each table from the wizard, you can make copies of the original table, naming each according to the type of music contained in it.

  1. 1)Click on the Tables icon in the Database pane to see the existing tables. 

  2. 2)Right-click on the CD-Collection table icon. Choose Copy from the pop-up menu. 

  3. 3)Move the mouse pointer below this table, right-click, and select Paste. The Copy table dialog opens. 

  4. 4)Change the table name to CD-Jazz and click Next. 

  5. 5)Click the >> button to move all the fields from the left box to the right box and click Next. 

  6. 6)Since all the fields already have the proper Field type, no changes should be needed. However, this is the time and place to make any changes if they are needed. (See Caution below for the reason why.) Click Create. The new table is created. 

  7. 7)Click the Save button at the top of the main database window. 

Once tables have been created using the wizard, and data has been entered, editing a table should be very limited. You can add or delete fields, but adding a field requires you to enter the data for that one field for every existing record with an entry for that field.

Deleting a field deletes all the data once contained in that field. Changing the field type of a field can lead to data being lost either partially or completely. When creating a new table, it pays to create the fields with the correct names, length, and format before you add any data.

Deleting a table removes all of the data contained in every field of the table. Unless you are sure, do not delete a table.

Creating tables in Design View

Design View is a more advanced method for creating a new table, in which you directly enter information about each field in the table. We will use this method for the tables of our database.

While the Field type and formatting are different in Design View, the concepts are the same as in the Wizard.

The first table to be created is Fuel. Its fields are FuelID, Date, FuelCost, FuelQuantity, Odometer, and PaymentType.

  1. 1)Click Create Table in Design View (which opens the Table Design dialog). 

  2. 2)FuelID field: Type FuelID as the first Field Name. Press the Tab key to move to the Field Type column. Select Integer [INTEGER] as the Field Type from the drop down list. (The default setting is Text [VARCHAR].) 

A shortcut for selecting from the Field Type drop down list: press the key for the first letter of the choice. You can cycle through the choices for a given letter by repeatedly pressing that key.

  1. a)Change the Field Properties in the bottom section.
    Change AutoValue from No to Yes. 

  2. b)Set FuelID as the Primary key.
    Click in the Field Name cell directly below FuelID. The dialog automatically sets FuelID as the primary key and places a key icon in front of FuelID. (Figure
    4) 

 

Figure 4: Defining the primary key field

 

Certain of the Integer filed types (Integer and BigInt for example) have an AutoValue Field Property. When using one of these field types, your selection of Yes for the AutoValue value automatically makes the field the primary key.

Primary keys for any other field type must be selected by right-clicking the rectangle before the field and selecting Primary key in the context menu.

The primary key serves only one purpose: to identify each record uniquely. Any name can be used for this field. We have used FuelID for convenience, so we know to which table it belongs.

  1. 3)All other fields (Date, FuelCost, FuelQuantity, Odometer, and PaymentType): 

  1. a)Type the next field name in the Field Name column. 

  2. b)Select the Field Type for each field. 

  1. c)FuelCost, FuelQuantity, and Odometer need changes in the Field Properties section (Figure 5). 

  1. d)Repeat steps a) through c) until you have entered all of the fields. 

 

Figure 5: Changing field properties

 
  1. e)To access additional formatting options, click the ellipse button (…) to the right of the Format example field. 

Description can be any of the categories listed in the figure below, or can be left blank.

 

Figure 6: Format example options

 
  1. 4)To save and close the table, select File > Save. Name the table Fuel. Close the Fuel table. 

  2. 5)In the main database window, click the Save button. 

 

Figure 7: Fields in Vacations table

 

Follow the same steps to create the Vacations table. The fields, field types, and Descriptions are listed in Figure 7.

Making Date the primary key has to be done in a different way because this field’s field type is Date, not Integer.

    1. a)Right-click to the left of the field name Date. 

    2. b)Select Primary Key in the context menu. 

Defining relationships

Now that the tables have been created, what are the relationships between our tables? This is the time to define them based upon the questions we asked and answered in the beginning.

When on vacation, we want to enter all of our expenses at once each day. Most of these expenses are in the Vacations table, but the fuel we buy is not. So we will link these two tables using the Date fields. Since the Fuel table may have more than one entry per date, this relationship between the Vacations and Fuel tables is one to many (it is designated 1:n.)

The Fuel and Maintenance tables do not really have a relationship even though they share similar fields: Date and Odometer readings.

As you create your own databases, you will also need to determine if tables are related and how.

  1. 1)To begin defining relationships, select Tools > Relationships. The Automobile – LibreOffice Base: Relation Design window opens and the Add Tables dialog pops up. (You can also open it by clicking the Add Tables icon on the Relation Design window.) 

  2. 2)In the Add Tables dialog, use either of these ways to add a table to the Relation Design window: 

  1. 3)Click Close to close the Add Tables dialog when you have added the tables you want. 

  2. 4)Define the relationship between the Vacations and Fuel tables:  click the New Relation icon. This opens the Relations window (Figure 9). Our two tables are listed in the Tables involved section. 

  1. a)In the Fields involved section, click the drop-down list under the Fuel label. 

  2. b)Select Date from the Fuel table list. 

  3. c)Click in the cell to the right of this drop-down list. This opens a drop down list for the Vacations table. 

  4. d)Select Date from the Vacations table list. It should now look like Figure 9. 

  5. e)Modify the Update options and Delete options section of the Relation window (Figure 10). 

    1. i)Select Update cascade. 

    2. ii)Select Delete cascade. 

 

Figure 8: Designation for a 1:n relationship

 
 

Figure 9: Selected fields in a relationship

 
The primary key can contain more than one field. (Its foreign key1 will contain the same number of fields.) If this were the case in Figure 9, the other fields of the primary field for the Fuel table would be listed under Date. The corresponding fields of the foreign key would be listed under Vacations. Detailed information about this is in the Base Guide.
 

Figure 10: Update options and Delete options section

 
  1. f)Click OK. 

  2. g)Save the Relation Design dialog if the Save button is active. 

  3. h)Close the Relation Design dialog. 

  4. i)Click the Save button at the top of the main database window. 

While these options are not strictly necessary, they do help. Having them selected permits you to update a table that has a relationship defined with another table which has been modified. It also permits you to delete a field from the table without causing inconsistencies.

Creating a database form

Databases are used to store data. But, how is the data put into the database? Forms are used to do this. In the language of databases, a form is a front end for data entry and editing.

A simple form consists of the fields from a table (Figure 11). More complex forms can contain much more, including additional text, graphics, selection boxes, and many other elements. Figure 12 is made from the same table with a text label (Fuel Purchases), a list box placed in PaymentType, and a graphic background.

A list box is useful when a field contains a fixed choice of options. It saves you from having to type data by hand, and ensures that invalid options are not entered.

 
 

In our database, payments for food or fuel might be made from one of two credit cards (Dan or Kevin) or in cash, so these would be the available options for all boxes that contain payments.

To create a list box, we first need to create a small, separate table containing the options. This is then linked to the corresponding field in the form. The topic is dealt with in detail in the Base User Guide and will not be pursued further here.

Using the Wizard to create a form

We will use the Form Wizard to create a Vacations form, which will contain a form and a subform.

In the main database window (Figure 1), click the Forms icon in the left column. In the Tasks list, double-click Use Wizard to Create Form to open the Form Wizard (Figure 13). Simple forms require only some of these steps, while more complex forms may use all of them.

Step 1: Select fields

  1. 1)Under Tables or queries, select Table: Vacations. Available fields lists the fields for the Vacations table. 

  2. 2)Click the right double arrow to move all of these fields to the Fields in the form list. Click Next. 

 

Figure 13: Form Wizard steps

 

Step 2: Set up a subform

Since we have already created a relationship between the Fuel and Vacations tables, we will use that relationship. If no relationship had been defined, this would need to be done in step 4.

  1. 1)Click the box labeled Add Subform 

  2. 2)Click Subform based upon existing relation. 

  3. 3)Fuel is listed as a relation we want to add. So click Fuel to highlight it, as in Figure 14. Click Next. 

 

Figure 14: Adding a subform

 

Step 3: Add subform fields

This step is similar to step 1. The only difference is that not all of the fields will be used in the subform.

  1. 1)Fuel is preselected under Tables or queries. 

  2. 2)Use the >> button to move all the fields to the right. 

  3. 3)Click the FuelID field to highlight it. 

  4. 4)Use the < button to move the FuelID to the left (Figure 15).  

  5. 5)Click Next. 

 

Figure 15: Selecting fields of a sub form

 

Step 4: Get joined fields

This step is for tables or queries for which no relationship has been defined. Because we have already defined the relationship, the wizard skips this step.

It is possible to create a relationship between two tables that is based upon more than one pair of fields. How to do that and why is discussed in the Base Guide.

When selecting a pair of fields from two tables to use as a relationship, they have to have the same field type. That is why we used the Date field from both tables: both their field types are Date[DATE].

Whether a single pair of fields from two tables are chosen as the relationship, or two or more pairs are chosen, certain requirements must be met for the form to work.

Step 5: Arrange controls

A control in a form consists of two parts: label and field. This step in creating the form determines where a control’s label and field are placed relative to each other. The four choices from left to right are Columnar left, Columnar—Labels on top, As Data Sheet, and In Blocks - Labels Above.

  1. 1)Arrangement of the main form: Click the second icon (Columnar—Labels on top). The labels will be placed above their field. 

  2. 2)Arrangement of the sub form: Click the third icon (As Data Sheet). (The labels are column headings and the field entries are in spreadsheet format.) Click Next. 

 

Figure 16: Arrange controls

 

Step 6: Set data entry

Unless you have a need for any of these entries to be checked, accept the default settings. Click Next.

Step 7: Apply styles

  1. 1)Select the color you want in the Apply Styles list. (I chose the beige which is Orange 4 in the Color table.) 

  2. 2)Select the Field border you want. (I prefer the 3D look. You might want to experiment with the different possible settings.) 

  3. 3)Click Next. 

Step 8: Set name

  1. 1)Enter the name for the form. In this case, it is Fuel. 

  2. 2)Click Modify the form. 

  3. 3)Click Finish. The form opens in Edit mode. 

Modifying a form

We will be moving the controls to different places in the form and changing the background to a picture. We will also modify the label for the PaymentType field as well as change the field to a list box.

First, we must decide what we want to change. The discussion will follow this ten step outline of our planned changes.

Here are some methods that we will be using in these steps. The controls in the main form consist of a label and its field. Sometimes we want to work with the entire control, sometimes with only the label or the field, and there are times when we want to work with a group of controls.

 

Figure 17: A selected control

 
 

Figure 18: Selecting a field of a control

 
  1. a)Click the field of the top left control to be moved, to select it. 

  2. b)Move the cursor to just above and to the left of the selected control. 

  3. c)Drag the cursor to the bottom right of the group of controls and release the mouse button. 

As you drag the cursor, a dashed box appears, showing what is contained in your selection. Make sure it is big enough to include the entire length of all the controls.

When you release the mouse button, a border with its green handles appears around the controls you selected.

 

Figure 19: Selecting multiple controls

 

Move the cursor over one of the fields. It changes to a drag icon. Drag the group of controls to where you want them.

When either changing size or moving a control, two properties of the Form Design toolbar should be selected: Snap to Grid, and Guides when Moving. Your controls will line up better, and an outline of what you are moving moves as the cursor moves. You should also have both rulers active (View > Ruler).

Step 1: Change the Date field

  1. 1)Ctrl+click the Date field to select it. 

  2. 2)Move the cursor over the middle green handle on the right side. It should change to a double-headed arrow. 

  3. 3)Hold the left mouse button down as you drag the cursor to the right until the length is 6 cm. The vertical dashed line is lined up with the 6. Release the mouse button. 

  4. 4)Click the Control icon in the Form Controls toolbar. If it is not visible, select View > Toolbars > Form Controls. The Properties: Date Field window opens. Each line contains a property of the field. 

 

Figure 20: Form Controls toolbar

 

To see what the Date field will look like, click the Form Mode On/Off icon (the second icon from the left in Figure  20). You can do this any time you want to see the form with the changes you have made.

Step 2: Shorten the width of some fields

All of the fields with a label containing the word payment are too wide. They need to be shortened before the controls are moved.

 

Figure 21: Selecting a field

 
  1. 1)Ctrl+click the BPayment field. 

  2. 2)Move the cursor over the middle green handle on the right. The cursor becomes a double-headed arrow. 

  3. 3)Drag the cursor to the left until the field is 2.5 cm (1 inch) wide. 

  4. 4)Repeat these steps to shorten these fields: Lpayment, SPayment, SnPayment, Mpayment, and MiscPayment. 

If you have the Snap to Grid and Guides when moving icons selected in the Design Format toolbar, you will see how wide the field is as you shorten it.

Step 3: Move the controls to group them by category

We want to move the controls so that they look like Figure 22.

  1. 1)Click the first control you want to move. A border appears around the control with eight green handles. 

  2. 2)Move the cursor over the label or field of the control. It changes shape to a drag icon. 

  3. 3)Drag and drop the control to where you want it. 

  4. 4)Use the same steps to move the rest of the controls to where they belong. 

 

Figure 22a: Positioning of controls (left side of form)

 
 

Figure 22b: Positioning of controls (right side of form)

 

Do not use Ctrl+click when moving a field. It moves either the field or the label but not both. To move both, use a plain mouse click and drag to the desired spot.

Step 4: Change the label wording

Field names are required to be single words. However, the labels for the fields in a form can be more than one word. So we will change them by editing the text in the label.

  1. 1)Ctrl+click the SnackNo label. Do one of the following: 

  1. 2)The dialog that opens is labeled Properties: Label Field. It contains all the properties of the selected label. 

  1. 3)Use the same procedure to change these labels as well: BPayment to Payment, LPayment to Payment, SPayment to Payment, Miscellaneous to Misc., SnackCost to Snack Cost, MPayment to Payment, MiscPayment to Misc. Payment, and MiscNotes to Misc. Notes. 

You can modify all of the listings in the Properties window. For example, if you change the Alignment from Left to Center, the word or words in the label are centered within the label. When you have some time, you might want to experiment with different settings just to see the results you get.

Step 5: Change the widths of the labels and fields

We want the fields of the following controls to be 2 cm wide (0.8 inches): Breakfast, Lunch, Supper, Odometer, Snack No., Tolls, Snack Cost, Motel, and Misc. All of the payment fields were changed in step 2, but Misc. Payment needs to be changed to 3 cm (1.2 inches).

  1. 1)Right-click Breakfast and select Position and Size. On the Position and Size dialog, change Width to 2 cm. 

  2. 2)Repeat for the other listed controls, using 3 cm for MiscPayment. 

When changing the position or size of an entire control, use the Position and Size dialog or the drag and drop method.

When working with either the label or the field (but not both at the same time), you can use the Properties dialog to make these changes when you want to be exact. However, you need to be careful not to accidentally select the entire control for use with the Properties dialog or you will apply exactly the same values to both the label and field. For example, if you enter the values for a new position, both the field and the label moves to the same position and the field is positioned on top of the label. Then you will have to move each of them to where you really want them.

To open the Properties dialog, right-click a control and select Control from the pop-up menu. Or, you can click the Control icon in the Form Controls toolbar. Just be careful, and use Ctrl+Z to undo any mistakes you may make. Detailed instructions on how to use the Properties window are given in the Base Guide.

Step 6: Change the Misc. Notes field

We want the Misc. Notes control, which has a field type of Memo, to have a vertical scroll bar for additional text space if desired.

 

Figure 23: Scroll bar selections in the Properties window

 
  1. 1)Ctrl+click the Misc. Notes field. The green handles should surround the field but not its label. 

  2. 2)Click the Control icon to open the Properties window (Figure 23). 

  3. 3)Scroll down to the Text type property with single-line as the default value. 

  1. 4)Scroll down to the Scrollbars setting. Change the selection from None to Vertical in this list. 

  2. 5)Close the Properties window. (Esc key) 

  3. 6)Lengthen the Misc. Notes field by moving the cursor over the middle green handle at the bottom of the field and dragging down until the length is 6 cm (2.4 inches). 

Step 7: Change labels and fields in the subform

The subform is located at the bottom of the form. We want to widen the Date column,  and change the label for the PaymentType column to two words.

 

Step 8: Add headings to groups

This step is easier to do if you have end-of-paragraph markers visible. Choose View > Non printing Characters to turn them on.

 

Figure 24: Apply Styles list

 
  1. 1)Make sure the cursor is in the upper left corner. If it is not, click in that corner to move it there. 

  2. 2)Press the Enter key to move the cursor down to the space between the Date field and the Breakfast field. 

  3. 3)Change the Apply Styles drop down list from Default to Heading 2. 

  4. 4)Use the spacebar to move the cursor to where you want the heading to start. 

  5. 5)Type the heading Meals. 

  6. 6)Use the spacebar to move the cursor to the center of snack area. 

  7. 7)Type the heading Snacks. 

  8. 8)Use the Enter key to move the cursor between the Supper control and the subform. 

  9. 9)Use the spacebar to move the cursor to the center of the subform. 

  10. 10)Change the Apply Styles drop down list from Default to Heading 2. 

  11. 11) Type the heading Fuel Data. 

If you know how to use styles, you can open the Styles and Formatting window using F11. Right-clicking the Heading 2 paragraph style allows you to modify the appearance of all three headings. See Chapter 6 of the Writer Guide for details.

Step 9: Change the background of a form

The background for a form can be a color, or a graphic (picture). You can use any of the colors in the Color Table at Tools > Options > LibreOffice > Colors. If you know how to create custom colors, you can use them. You can also use a picture (graphic file) as the background.

To add a color to the form background:

  1. 1)Right-click the form to open a context menu. 

  2. 2)Select Page. 

  3. 3)Make sure the Area tab has been selected. (It should have a white background while the other tabs have a gray one..)