Getting Started Guide
 

Chapter 10  
Printing, Exporting, E‑mailing

 

Copyright

This document is Copyright © 2010–2016 by the LibreOffice Documentation Team. Contributors are listed below. You may distribute it and/or modify it under the terms of either the GNU General Public License (http://www.gnu.org/licenses/gpl.html), version 3 or later, or the Creative Commons Attribution License (http://creativecommons.org/licenses/by/4.0/), version 4.0 or later.

All trademarks within this guide belong to their legitimate owners.

Contributors

John A Smith

Jean Hollis Weber

Hazel Russman

Ron Faile Jr.

Olivier Hallot

 

Feedback

Please direct any comments or suggestions about this document to the Documentation Team’s mailing list: documentation@global.libreoffice.org

Note: Everything you send to a mailing list, including your email address and any other personal information that is written in the message, is publicly archived and cannot be deleted.

Acknowledgments

This chapter is based on Chapter 10 of Getting Started with OpenOffice.org 3.3. The contributors to that chapter are:

Jean Hollis Weber

Agnes Belzunce

Michael Kotsarinis

Peter Kupfer

Robert Scott

Janet M. Swisher

Joe Sellman

 

 

Publication date and software version

Published 21 June 2016. Based on LibreOffice 5.0.

Note for Mac users

Some keystrokes and menu items are different on a Mac from those used in Windows and Linux. The table below gives some common substitutions for the instructions in this chapter. For a more detailed list, see the application Help.

Windows or Linux

Mac equivalent

Effect

Tools > Options menu selection

LibreOffice > Preferences

Access setup options   

Right-click

Control+click and/or right-click depending on computer setup

Open a context menu

Ctrl (Control)

⌘ (Command)

Used with other keys

F5

Shift+⌘+F5

Open the Navigator

F11

⌘+T

Open the Styles and Formatting window

 

Contents

Copyright

Contributors

Feedback

Acknowledgments

Publication date and software version

Note for Mac users

Quick printing

Controlling printing

Selecting general printing options

Printing multiple pages on a single sheet of paper

Selecting pages/sheets/slides to print

Writer

Calc

Impress and Draw

Printing handouts, notes, or outlines in Impress

Printing a brochure

Printing envelopes, labels, business cards

Printing in black and white (on a color printer)

Previewing pages/sheets before printing

Writer

Calc

Exporting to PDF

Quick export to PDF

Controlling PDF content and quality

General page of PDF Options dialog

Initial View page of PDF Options dialog

User Interface page of PDF Options dialog

Links page of PDF Options dialog

Security page of PDF Options dialog

Digital Signatures page of PDF Options dialog

Exporting to other formats

E-mailing documents

E-mailing a document to several recipients

Digital signing of documents

Removing personal data

 

Quick printing

Click the Print File Directly icon (
) to send the entire document to the default printer defined for your computer.
 

You can change the action of the Print File Directly icon to send the document to the printer defined for the document instead of the default printer for the computer. Go to Tools > Options > Load/Save > General and select the Load printer settings with the document option.

Controlling printing

For more control over printing, use the Print dialog (File > Print or Ctrl+P).

 

Figure 1: The Print dialog

 

The options selected on the Print dialog apply to this printing of this document only.

To specify default printing settings for LibreOffice, go to Tools > Options > LibreOffice > Print and Tools > Options > LibreOffice [Component] > Print. See Chapter 2, Setting Up LibreOffice, for more details.

The Print dialog has four pages, from which you can choose a range of options, as described in the following sections.

The different components of LibreOffice have different available print settings, as summarized in Table 1.

Table 1: Print options in LibreOffice components

Feature

Writer

Calc

Impress

Draw

Select pages/sheets/slides to print

Yes

Yes

Yes

Yes

Print multiple pages/sheets/slides on one page

Yes

Yes

Yes

Yes

Print a brochure

Yes

No

Yes

Yes

Print envelopes

Yes

No

No

No

Print labels or business cards

Yes

No

No

No

Preview pages/sheets before printing

Yes

Yes

No

No

Selecting general printing options

On the General tab of the Print dialog, you can choose:

Some selections may not be available all the time. For example, if the document contains no comments, the Print – Comments drop-down list does not work.

 

Figure 2: Choosing whether and where to print comments

 

Select the Properties button to display the selected printer’s properties dialog where you can choose portrait or landscape orientation, which paper tray to use, and the paper size to print on.

On the Options tab of the Print dialog (Figure 3), the last item, Use only paper tray from printer preference, is not available in Calc.

 

Figure 3: General print options

 

Printing multiple pages on a single sheet of paper

You can print multiple pages of a document on one sheet of paper. To do this:

  1. 1)In the Print dialog, select the Page Layout tab (Figure 4). 

 

Figure 4: Printing multiple page per sheet of paper

 
  1. 2)In the Layout section, select from the drop-down list the number of pages to print per sheet. The preview panel on the left of the Print dialog shows how the printed document will look. 

When printing more than 2 pages per sheet, you can choose the order in which they are printed across and down the paper.

 
  1. 3)In the Page sides section, select whether to print all pages or only some pages. Click the OK button. 

In Writer, to print two pages per sheet in “facing pages” (book layout) style, print from Print Preview instead. See page 12.

Selecting pages/sheets/slides to print

In addition to printing a full document, you can choose to print individual pages/sheets/slides, ranges of pages/sheets/slides, or a selection of a document. The details vary slightly between Writer, Calc, Draw, and Impress, as described in this section.

Writer

Printing an individual page:

  1. 1)Choose File > Print from the Menu bar, or press Ctrl+P. 

  2. 2)On the Print dialog, select the page to print. 

  1. a)In the Range and copies section of the General page, select the Pages option. The text input box displays the current page number. 

  2. b)Enter the page number of the page you want to print. The preview box changes to show the selected page. 

  1. 3)Click OK. 

Printing a range of pages:

  1. 1)Choose File > Print from the Menu bar, or press Ctrl+P. 

  2. 2)On the Print dialog, select the range of pages to print. 

  1. a)In the Range and copies section of the General page, select the Pages option. 

  2. b)Enter the sequence numbers of the pages to print (for example, 1–4 or 1,3,7,11). 

  1. 3)Click OK. 

Printing a selection of text:

  1. 1)In the document, select the material (text and graphics) to print. 

  2. 2)Choose File > Print from the Menu bar, or press Ctrl+P. 

  3. 3)The Range and copies section of the Print dialog now includes a Selection option and the preview box shows the selected material. See Figure 5. 

  4. 4)Click OK. 

 

Figure 5: Printing a selection of text

 

Calc

You can choose single sheets, multiple sheets, and selections of cells for printing.

 

Figure 6: Choosing what to print in Calc

 

Printing an individual sheet:

  1. 1)In the spreadsheet, click on the sheet tab to select the sheet you want to print. 

  2. 2)Choose File > Print from the Menu bar, or press Ctrl+P. 

  3. 3)In the Range and copies section of the Print dialog, choose the Selected sheets option. 

  4. 4)Click OK. 

Printing a range of sheets:

  1. 1)In the spreadsheet, select the sheets to print. 

  1. a)Select the first sheet. 

  2. b)Hold down the Control key. 

  3. c)Click on the additional sheet tabs. 

  4. d)Release the Control key when all required sheets are selected. 

  1. 2)Choose File > Print from the Menu bar, or press Ctrl+P. 

  2. 3)In the Range and copies section of the Print dialog, choose the Selected sheets option. 

  3. 4)Click OK. 

Printing a selection of cells:

  1. 1)In the document, select the section of cells to print. 

  2. 2)Choose File > Print from the Menu bar, or press Ctrl+P. 

  3. 3)In the Ranges and copies section of the Print dialog, select the Selected cells option. 

  4. 4)Click OK. 

After printing, be sure to deselect the extra sheets. If you keep them selected, the next time you enter data on one sheet, you enter data on all the selected sheets. This might not be what you want.

Impress and Draw

You can choose individual slides, ranges of slides, or selections of slides for printing.

 

Figure 7: Choosing what to print in Impress and Draw

 

Printing an individual slide:

  1. 1)Choose File > Print from the Menu bar, or press Ctrl+P. 

  2. 2)Select the slide to print. 

  1. a)In the Range and copies section of the Print dialog, select the Slides option. 

  2. b)Enter the number of the slide to print. 

  1. 3)Click OK. 

Printing a range of slides:

  1. 1)Choose File > Print from the Menu bar, or press Ctrl+P. 

  2. 2)Select the slides to print. 

  1. a)In the Range and copies section of the Print dialog, select the Slides option. 

  2. b)Enter the number of the slides to print (for example 1-4 or 1,3,7,11). 

  1. 3)Click OK. 

Printing a selection from a slide, or a selection from multiple slides:

  1. 1)In the document, select the section of the slide to print. 

  2. 2)Choose File > Print from the Menu bar, or press Ctrl+P. 

  3. 3)Select the Selection option in the Range and copies section of the Print dialog. 

  4. 4)Click OK. 

Printing handouts, notes, or outlines in Impress

Handouts prints the slides in reduced size on the page, from one to nine slides per page. The slides can be printed horizontally (landscape orientation) or vertically (portrait orientation) on the page.

Notes prints a single slide per page with any notes entered for that slide in Notes View.

Outline prints the title and headings of each slide in outline format.

To print handouts, notes, or outlines:

  1. 1)Choose File > Print from the Menu bar, or press Ctrl+P. 

  2. 2)In the Print section of the Print dialog, select the required option. 

  3. 3)For Handouts, you can then choose how many slides to print per page, and the order in which they are printed. 

  4. 4)Click OK. 

 

Printing a brochure

In Writer, Impress, and Draw, you can print a document with two pages on each side of a sheet of paper, arranged so that when the printed pages are folded in half, the pages are in the correct order to form a booklet or brochure.

Plan your document so it will look good when printed half size; choose appropriate margins, font sizes, and so on. You may need to experiment.

To print a brochure on a single-sided printer:

  1. 1)Choose File > Print, or press Ctrl+P. 

  2. 2)In the Print dialog, click Properties. 

  3. 3)Check that the printer is set to the same orientation (portrait or landscape) as specified in the page setup for your document. Usually the orientation does not matter, but it does for brochures. Click OK to return to the Print dialog. 

  4. 4)Select the Page layout tab in the Print dialog. 

  5. 5)Select the Brochure option. 

  6. 6)In the Page sides section, select the Back sides / left pages option from the Include drop-down list. Click OK. 

 

Figure 8: Selecting which pages to print

 
  1. 7)Take the printed pages out of the printer, turn the pages over, and put them back into the printer in the correct orientation to print on the blank side. You may need to experiment a bit to find out what the correct arrangement is for your printer. 

  2. 8)On the Print dialog, in the Page sides section, select the Front sides / right pages option from the Include drop-down box. Click OK. 

If your printer can print double-sided automatically, choose All pages.

Printing envelopes, labels, business cards

Printing envelopes, labels, or business cards using Writer involves two steps: setup and printing.

For details of how to set these up, see Chapter 11, Using Mail Merge, in the Writer Guide. To print:

  1. 1)Choose File > Print from the Menu bar, or press Ctrl+P. 

  2. 2)On the Print dialog, under Range and copies, choose Pages and type 1 in the box. Click OK. 

Printing in black and white (on a color printer)

You may wish to print documents in black and white on a color printer. Several choices are available. Please note that some color printers may print in color regardless of the settings you choose.

Change the printer settings to print in black and white or grayscale:

  1. 1)Choose File > Print, or press Ctrl+P, to open the Print dialog. 

  2. 2)Click Properties to open the Properties dialog for the printer. The available choices vary from one printer to another, but you should find options for the Color settings. See your printer’s help or user manual for more information. 

  3. 3)The choices for color might include black and white or grayscale. Choose the required setting. 

  4. 4)Click OK to confirm your choice and return to the Print dialog, 

  5. 5)Click OK to print the document. 

Grayscale is better if you have any graphics in the document.

Change the LibreOffice settings to print all color text and graphics as grayscale:

  1. 1)Choose Tools > Options > LibreOffice > Print. 

  2. 2)Select the Convert colors to grayscale option. Click OK to save the change. 

  3. 3)Open the Print dialog (File > Print), or press Ctrl+P. 

  4. 4)Click OK to print the document. 

Change the LibreOffice Writer (or Calc, Impress, Draw) settings to print all color text as black, and all graphics as grayscale:

  1. 1)Choose Tools > Options > LibreOffice Writer > Print. 

  2. 2)Under Contents, select the Print text in black option. Click OK to save the change. 

  3. 3)Open the Print dialog (File > Print), or press Ctrl+P. 

  4. 4)Click OK to print the document. 

Previewing pages/sheets before printing

You can use the previewing options in Writer and Calc to view the document as it will be printed. Different viewing options are available.

Writer

The normal page view in Writer shows you what each page will look like when printed and you can edit the pages in that view. If you are designing a document to be printed double-sided, you may want to see what facing pages look like. Writer provides two ways to do this:

 

To use Print Preview:

Writer now displays the Print Preview toolbar instead of the Formatting toolbar.

 

Figure 9: Print Preview toolbar (Writer)

 

Calc

To preview the sheets in Calc before printing:

  1. 1)Choose File > Print Preview. 

The Calc window now displays the Print Preview toolbar instead of the Formatting toolbar.

 

Figure 10: Print Preview toolbar (Calc)

 
  1. 3)Choose the print options and click the Print button. 

Exporting to PDF

LibreOffice can export documents to PDF (Portable Document Format). This industry-standard file format is ideal for sending the file to someone else to view using Adobe Reader or other PDF viewers.

The process and dialogs are the same for Writer, Calc, Impress, and Draw, with a few minor differences mentioned in this section.

Unlike Save As, the Export command writes a copy of the current document in a new file with the chosen format, but keeps the current document and format open in your session.

Quick export to PDF

Click the Export Directly as PDF icon (
) to export the entire document using the PDF settings you most recently selected on the PDF Options dialog (see below). You are asked to enter the file name and location for the PDF file, but you do not get a chance to choose a page range, the image compression, or other options.
 

Controlling PDF content and quality

For more control over the content and quality of the resulting PDF, use File > Export as PDF. The PDF Options dialog opens. This dialog has six pages (General, Initial View, User Interface, Links, Security, and Digital Signatures). Select the appropriate settings, and then click Export. Then you are asked to enter the location and file name of the PDF to be created, and click Save to export the file.

Another choice is to use File >  Export. This opens the Export dialog. Select the PDF file format, file name and location and click Export. This then opens the PDF Options dialog. Click Export when all the selections have been made.

General page of PDF Options dialog

On the General page (Figure 11), you can choose which pages to include in the PDF, the type of compression to use for images (which affects the quality of images in the PDF), and other options.

Range section

Images section

Watermark section

 

Figure 11: General page of PDF Options dialog

 

EPS (Encapsulated PostScript) images with embedded previews are exported only as previews. EPS images without embedded previews are exported as empty placeholders.

General section

Initial View page of PDF Options dialog

On the Initial View page (Figure 12), you can choose how the PDF opens by default in a PDF viewer. The selections should be self-explanatory.

If you have Complex Text Layout enabled (in Tools > Options > Language settings > Languages), an additional selection is available under Continuous facing: First page is left (normally, the first page is on the right when using the Continuous facing option).

 

Figure 12: Initial View page of PDF Options dialog

 

User Interface page of PDF Options dialog

On the User Interface page, you can choose more settings to control how a PDF viewer displays the file. Some of these choices are particularly useful when you are creating a PDF to be used as a presentation or a kiosk-type display.

Window options section

 

Figure 13: User Interface page of the PDF Options dialog

 

User interface options section

Transitions

In Impress, displays slide transition effects as their respective PDF effects.

Bookmarks

Select how many heading levels are displayed as bookmarks, if Export bookmarks is selected on the General page.

Links page of PDF Options dialog

On the Links page, you can choose how links are exported to PDF.

 

Figure 14: Links page of PDF Options dialog

 

Export bookmarks as named destinations

If you have defined Writer bookmarks, Impress or Draw slide names, or Calc sheet names, this option exports them as “named destinations” to which Web pages and PDF documents can link.

Convert document references to PDF targets

If you have defined links to other documents with OpenDocument extensions (such as .odt, .ods, and .odp), this option converts the files’ extensions to .pdf in the exported PDF document.

Export URLs relative to file system

If you have defined relative links in a document, this option exports those links to the PDF.

Cross-document links

Defines the behavior of links clicked in PDF files. Select one among the following alternatives:

Security page of PDF Options dialog

PDF export includes options to encrypt the PDF (so that it cannot be opened without a password) and apply some digital rights management (DRM) features.

Permissions settings are effective only if the user’s PDF viewer respects the settings.