Getting Started Guide
 

Chapter 11  
Graphics, Gallery, Fontwork

 

Copyright

This document is Copyright © 2010–2016 by the LibreOffice Documentation Team. Contributors are listed below. You may distribute it and/or modify it under the terms of either the GNU General Public License (http://www.gnu.org/licenses/gpl.html), version 3 or later, or the Creative Commons Attribution License (http://creativecommons.org/licenses/by/4.0/), version 4.0 or later.

All trademarks within this guide belong to their legitimate owners.

Contributors

Jean Hollis Weber

Hazel Russman

John A Smith

Ron Faile Jr.

Martin Saffron

Olivier Hallot

Feedback

Please direct any comments or suggestions about this document to the Documentation Team’s mailing list: documentation@global.libreoffice.org

Note: Everything you send to a mailing list, including your email address and any other personal information that is written in the message, is publicly archived and cannot be deleted.

Acknowledgments

This chapter is adapted and updated from Chapter 11 of Getting Started with OpenOffice.org. The contributors to that chapter are:

Agnes BelzunceDaniel CarreraPeter Hillier-Brook
Peter KupferIain RobertsJean Hollis Weber
Linda WorthingtonMichele Zarri

Publication date and software version

Published 30 June 2016. Based on LibreOffice 5.1.

Note for Mac users

Some keystrokes and menu items are different on a Mac from those used in Windows and Linux. The table below gives some common substitutions for the instructions in this chapter. For a more detailed list, see the application Help.

Windows or Linux

Mac equivalent

Effect

Tools > Options menu selection

LibreOffice > Preferences

Access setup options   

Right-click

Control+click and/or right-click depending on computer setup

Open a context menu

Ctrl (Control)

⌘ (Command)

Used with other keys

F5

Shift+⌘+F5

Open the Navigator

F11

⌘+T

Open the Styles and Formatting window

 

Contents

Copyright

Contributors

Feedback

Acknowledgments

Publication date and software version

Note for Mac users

Introduction

Adding images to a document

Inserting an image file

Drag and drop

Insert Image dialog

Linking an image file

Embedding linked images

Inserting an image from the clipboard

Inserting an image using a scanner

Inserting an image from the Gallery

Inserting an image as a background

Modifying and positioning graphics

Managing the LibreOffice Gallery

Adding objects to the Gallery

Deleting images from the Gallery

Adding a new theme to the Gallery

Deleting a theme from the Gallery

Location of the Gallery and the objects in it

Creating an image map

Using LibreOffice’s drawing tools

Creating drawing objects

Setting or changing properties for drawing objects

Resizing a drawing object

Grouping drawing objects

Using Fontwork

Creating a Fontwork object

Editing a Fontwork object

Using the Fontwork toolbar

Using the Formatting toolbar

Using menu options

Using the 3D-Settings toolbar

Moving and resizing Fontwork objects

 

Introduction

You can add graphic and image files, including photos, drawings, and scanned images, to LibreOffice documents. LibreOffice can import various vector (line drawing) and raster (bitmap) file formats. The most commonly used graphic formats are GIF, JPG, PNG, and BMP. See Appendix B for a full list of the graphic formats LibreOffice can import.

Graphics in LibreOffice are of three basic types:

This chapter covers images and diagrams.

More detailed descriptions on working with drawing tools can be found in the Draw Guide and Impress Guide. Instructions on how to create charts are given in the Calc Guide.

Adding images to a document

Images can be added to a document in several ways: by inserting an image file, directly from a graphics program or a scanner, by dragging them from the clip art internal gallery, or by copying and pasting from a source being viewed on your computer.

Inserting an image file

When the image is in a file stored on the computer, you can insert it into an LibreOffice document using either of the following methods.

Drag and drop

  1. 1)Open a file browser window and locate the image you want to insert. 

  2. 2)Drag the image into the LibreOffice document and drop it where you want it to appear. A faint vertical line marks where the image will be dropped. 

This method embeds (saves a copy of) the image file in the document. To link the file instead of embedding it, hold down the Ctrl+Shift keys while dragging the image.

Insert Image dialog

  1. 1)Click in the LibreOffice document where you want the image to appear. 

  2. 2)Choose Insert > Image from the menu bar. 

  3. 3)On the Insert Image dialog, navigate to the file to be inserted, and select it. 

  4. 4)At the bottom of the dialog (Figure 1) are two options, Preview and Link. Select Preview to view a thumbnail of the selected image in the preview pane on the right, so that you can verify that you have the correct file. See page 5 for the use of Link. 

  5. 5)Click Open. 

If you choose the Link option, a message box appears when you click Open. It asks if you want to embed the graphic instead. Choose Keep Link if you want the link, or Embed Graphic if you do not. To prevent this message from appearing again, deselect the option Ask when linking a graphic at the bottom of the message.

 

Figure 1: Insert Image dialog

 

Linking an image file

If the Link option in the Insert picture dialog is selected, LibreOffice creates a link to the file containing the image instead of saving a copy of the image in the document. The result is that the image is displayed in the document, but when the document is saved, it contains only a reference to the image file, not the image itself. The document and the image remain as two separate files, and they are merged together only when you open the document again.

Linking an image has two advantages and one disadvantage:

When inserting the same image several times in the document, it would appear beneficial to link rather than embed; however, this is not necessary as LibreOffice embeds only one copy of the image file in the document.

Embedding linked images

If you originally linked the images, you can easily embed one or more of them later if you wish. To do so:

  1. 1)Open the document in LibreOffice and choose Edit > Links. 

  2. 2)The Edit Links dialog (Figure 2) shows all the linked files. In the Source file list, select the files you want to change from linked to embedded. 

  3. 3)Click the Break Link button. 

  4. 4)Save the document. 

Going the other way, from embedded to linked, is not so easy—you must replace the images, one at a time, selecting the Link option when you do so.

 

Figure 2: The Edit Links dialog

 

Inserting an image from the clipboard

Using the clipboard, you can copy images into a LibreOffice document from another LibreOffice document and from other programs. To do this:

  1. 1)Open both the source document and the target document. 

  2. 2)In the source document, select the image to be copied. 

  3. 3)Click once on the selected image and press Ctrl+C to copy the image to the clipboard. 

  4. 4)Switch to the target document. 

  5. 5)Click to place the cursor where the graphic is to be inserted. 

  6. 6)Press Ctrl+V to insert the image. 

If the application from which the graphic was copied is closed before the graphic is pasted into the target, the image stored on the clipboard could be lost.

Inserting an image using a scanner

If a scanner is connected to your computer, LibreOffice can call the scanning application and insert the scanned item into the LibreOffice document as an image. To start this procedure, place the cursor where you want the graphic to be inserted and choose Insert > Media > Scan > Select Source.

Although this practice is quick and easy, it is unlikely to result in a high-quality image of the correct size. You may get better results by passing scanned material into a graphics program and cleaning it up there before inserting the resulting image into LibreOffice.

Inserting an image from the Gallery

The Gallery (Figure 3) provides a convenient way to group reusable objects such as graphics and sounds that you can insert into your documents. The Gallery is available in all components of LibreOffice. See “Managing the LibreOffice Gallery” on page 8. You can copy or link an object from the Gallery into a document.

To insert an object:

  1. 1)Click the Gallery icon in the Sidebar. 

  2. 2)Select a theme. 

  3. 3)Select an object with a single click. 

  4. 4)Drag and drop the image into the document. 

You can also right-click on the object and choose Insert.

 

Figure 3: The Gallery in the Sidebar

 

To insert an object as a link:

  1. 1)Choose Insert > Media > Clip Art Gallery and select a theme. 

  2. 2)Select an object with a single click, then while pressing the Shift and Ctrl keys, drag and drop the object into the document. 

Inserting an image as a background

To insert an image as the background to a page or paragraph:

  1. 1)Choose Insert > Media > Clip Art Gallery and select a theme. 

  2. 2)Select an object with a single click, right-click on the object, and choose Insert as  Background > Page or > Paragraph. 

Modifying and positioning graphics

LibreOffice provides many tools for cropping, resizing, modifying, filtering, and positioning graphics; wrapping text around graphics; and using graphics as backgrounds and watermarks. These tools are described in relevant chapters of the other guides. Some sophisticated adjustments of the graphics are best done in an image manipulation program and the results brought into LibreOffice, rather than using LibreOffice’s built-in tools.

Managing the LibreOffice Gallery

Graphics in the Gallery are grouped by themes, such as Arrows, Diagrams, and People. You can create other groups or themes and add your own pictures or find extensions containing more graphics. Click on a theme to see its contents displayed in the Gallery window.

You can display the Gallery in Icon View (Figure 3) or Detailed View (Figure 4), and you can hide or show the Gallery by clicking on the Sidebar’s Hide button.

 

Figure 4: Gallery in Detailed View

 

In some installations, only the My themes theme is customizable, although new themes can be added as explained in “Adding a new theme to the Gallery” on page 10. The locked themes are easily recognizable by right-clicking on them; the only available option in the context menu is Properties.

By default, the Gallery is opened in the Sidebar. You can float the Gallery as you can other Sidebar panes; see Chapter 1, Introducing LibreOffice, for more information.

Adding objects to the Gallery

You may wish to add to the My Theme folder in the Gallery any images that you use frequently, for example, a company logo. You can then easily insert these graphics into a document later.

  1. 1)Right-click on the My Theme folder and select Properties from the context menu. 

  2. 2)In the theme’s Properties dialog, click the Files tab (Figure 5). 

 

Figure 5: Gallery Properties dialog

 

To add several files at once:

  1. 1) Click the Find Files button. 

  2. 2)The Select path dialog (not shown) opens. You can enter the path for the file’s directory in the Path text box, or you can navigate to locate the file’s directory. 

  3. 3)Click the Select button to start the search. A list of graphic files is then displayed in the Properties dialog. You can use the File type drop-down list to limit the files displayed. 

  4. 4)To add all of the files shown in the list, click Add All. Otherwise, select the files to add and then click Add (hold down either the Shift key or the Ctrl key while clicking on the files). 

To add a single file:

  1. 1)Click Add to open the Gallery dialog. 

  2. 2)Use the navigation controls to locate the image to add to the theme. Select it and then click Open to add it to the theme. 

  3. 3)Click OK on the Properties dialog to close it. 

Deleting images from the Gallery

To delete an image from a theme:

  1. 1)Right-click on the name of the image file or its thumbnail in the Gallery. 

  2. 2)Click Delete in the context menu. A message appears, asking if you want to delete this object. Click Yes. 

Deleting the name of a file from the list in the Gallery does not delete the file from the hard disk or other location.

Adding a new theme to the Gallery

To add a new theme to the Gallery:

  1. 1)Click the New Theme button above the list of themes (Figure 4). 

  2. 2)In the Properties of New Theme dialog, click the General tab and type a name for the new theme. 

  3. 3)Click the Files tab and add images to the theme, as described earlier. 

Deleting a theme from the Gallery

To delete a theme from the Gallery:

  1. 1)Go to Insert > Media > Clip Art Gallery. 

  2. 2)Select from the list of themes the theme you wish to delete. 

  3. 3)Right-click on the theme, then click Delete on the context menu. 

Location of the Gallery and the objects in it

Graphics and other objects shown in the Gallery can be located anywhere on your computer’s hard disk, on a network drive, or other removable media. When you add graphics to the Gallery, the files are not moved or copied; the location of each new object is simply added as a reference.

In a workgroup, you may have access to a shared Gallery (where you cannot change the contents unless authorized to do so) and a user Gallery, where you can add, change, or delete objects.

The location of the user Gallery is specified in Tools > Options > LibreOffice > Paths. You can change this location, and you can copy your gallery files (SDV) to other computers.

Gallery contents provided with LibreOffice are stored in a different location. You cannot change this location.

Gallery themes can be packed for distribution through the LibreOffice extensions framework. In that case, the location of the graphic files is determined by the extension settings. To get more gallery themes, visit the LibreOffice extensions website at http://extensions.libreoffice.org.

Creating an image map

An image map defines areas of an image (called hotspots) with hyperlinks to web addresses, other files on the computer, or parts of the same document. Hotspots are the graphic equivalent of text hyperlinks (described in Chapter 12). Clicking on a hotspot causes LibreOffice to open the linked page in the appropriate program (for example, the default browser for an HTML page; LibreOffice Calc for an ODS file; a PDF viewer for a PDF file). You can create hotspots of various shapes and include several hotspots in the same image.

To use the image map editor:

  1. 1)In your LibreOffice document, click on the picture in which you want to create the hotspots. 

  2. 2)Choose Edit > ImageMap from the menu bar. The ImageMap Editor (Figure 6) opens. 

  3. 3)Use the tools and fields in the dialog (described below) to define the hotspots and links necessary. 

  4. 4)Click the Apply icon
    to apply the settings.
    to apply the settings. 
  5. 5)When done, click the Save icon
    to save the image map to a file, then click the X in the upper right corner to close the dialog.
    to save the image map to a file, then click the X in the upper right corner to close the dialog. 

The main part of the dialog shows the image on which the hotspots are defined. A hotspot is identified by a line indicating its shape.

The toolbar at the top of the dialog contains the following tools:

 

Figure 6: The dialog to create or edit an image map

 

Below the toolbar, specify for the selected hotspot:

The value _self for the target frame will usually work just fine. It is therefore not recommended to use the other choices unless absolutely necessary.

Using LibreOffice’s drawing tools

You can use LibreOffice’s drawing tools to create graphics such as simple diagrams using rectangles, circles, lines, text, and other predefined shapes. You can also group several drawing objects to make sure they maintain their relative position and proportion.

You can place the drawing objects directly on a page in your document, or you can insert them into a frame.

You can also use the drawing tools to annotate photographs, screen captures, or other illustrations produced by other programs, but this is not recommended because:

In general, if you need to create complex drawings, it is recommended to use LibreOffice Draw, which includes many more features such as layers, styles, and so on.

Creating drawing objects

To begin using the drawing tools, display the Drawing toolbar (Figure 7) by clicking View > Toolbars > Drawing.

If you are planning to use the drawing tools repeatedly, you can tear off this toolbar and move it to a convenient place on the window.

 

1

Select

5

Freeform Line

9

Symbol Shapes

13

Stars

2

Line

6

Text

10

Block arrows

14

Points

3

Rectangle

7

Callouts

11

Flowcharts

15

Fontwork Gallery

4

Ellipse

8

Basic Shapes

12

Callouts

16

From File

 

 

 

 

 

17

Extrusion On/Off

Figure 7: The Drawing toolbar

To use a drawing tool:

  1. 1)Click in the document where you want the drawing to be anchored. You can change the anchor later, if necessary. 

  2. 2)Choose the tool from the Drawing toolbar (Figure 7). The mouse pointer changes to a drawing-functions pointer similar to this one for a rectangle shape
    .
    . 
  3. 3)Move the cross-hair pointer to the place in the document where you want the graphic to appear and then click and drag to create the drawing object. Release the mouse button. The selected drawing function remains active, so that you can draw another object of the same type. 

  4. 4)To cancel the selected drawing function, press the Esc key or click on the Select icon (the arrow) on the Drawing toolbar. 

  5. 5)You can now change the properties (fill color, line type and weight, anchoring, and others) of the drawing object using either the Drawing Object Properties toolbar (Figure 8) or the choices and dialogs reached by right-clicking on the drawing object. 

Setting or changing properties for drawing objects

To set the properties for a drawing object before you draw it:

  1. 1)On the Drawing toolbar (Figure 7), click the Select tool. 

  2. 2)On the Drawing Object Properties toolbar (Figure 8), click on the icon for each property and select the value you want for that property. 

  3. 3)For more control, or to define new attributes, you can click on the Area or Line icons on the toolbar to display detailed dialogs. 

 

1

Styles and Formatting

4

Line Style

7

Area

10

Effects

2

Line

5

Line Width

8

Area Style / Filling

11

Alignment

3

Arrow Style

6

Line Color

9

Shadow

12

Arrange

Figure 8: Drawing Object Properties toolbar

The default you set applies to the current document and session. It is not retained when you close the document or close Writer, and it does not apply to any other document you open. The defaults apply to all the drawing objects except text objects.

To change the properties for an existing drawing object:

  1. 1)Select the object. 

  2. 2)Continue as described above. 

You can also specify the position and size, rotation, and slant and corner radius properties of the drawing object:

  1. 1)Right-click on the drawing object and then choose Position and Size from the context menu. The Position and Size dialog is displayed. 

  2. 2)Choose any properties, as required. 

Resizing a drawing object

An object is resized in a similar way to an image. Select the object, click on one of the eight handles around it and drag it to its new size. The object will be scaled up or down. For an unscaled resizing, select one of the handles and keep the Shift key pressed while dragging the handle to its new size.

For more sophisticated control of the size of the object, choose Format > Frame and Object > Properties from the Menu bar. Use the Type tab to set the position and size independently. If the Keep ratio option is selected, then the two dimensions change so that the proportion is maintained, resulting in a scaled resizing.

Grouping drawing objects

Grouping drawing objects makes it easier to handle several objects as a single entity, while preserving their relative sizes and positions.

To group drawing objects:

  1. 1)Select one object, then hold down the Shift key and select the others you want to include in the group. The bounding box expands to include all the selected objects. 

  2. 2)With the objects selected, hover the mouse pointer over one of the objects and choose Format > Group > Group from the Menu bar or right-click and choose Group > Group from the pop-up menu. 

You cannot include an embedded or linked graphic in a group with drawing objects.

Using Fontwork

With Fontwork you can create graphical text art objects to make your work more attractive. There are many different settings for text art objects (line, area, position, size, and more), so you have a large choice.

Fontwork is available with each component of LibreOffice, but you will notice small differences in the way that each component displays it.

Creating a Fontwork object

  1. 2)In the Fontwork Gallery (Figure 9), select a Fontwork style, then click OK. The Fontwork object will appear in your document. Notice the colored squares around the edge (indicating that the object is selected) and the yellow dot; these are discussed in “Moving and resizing Fontwork objects” on page 18. 

 

Figure 9: The Fontwork Gallery

 
  1. 3)Double-click the object to edit the Fontwork text (see Figure 10). Select the text and type your own text in place of the black Fontwork text that appears over the object. 

 

Figure 10: Editing Fontwork text

 
  1. 4)Click anywhere in a free space or press Esc to apply your changes. 

Editing a Fontwork object

Now that the Fontwork object is created, you can edit some of its attributes. To do this, you can use the Fontwork toolbar, the Formatting toolbar, or menu options as described in this section. If the selected Fontwork object is a 3-D object, you can also use the 3D-Settings toolbar.

Using the Fontwork toolbar

Make sure that the Fontwork toolbar, shown in Figure 11, is visible. If you do not see it, go to View > Toolbars > Fontwork. Click on the different icons to edit Fontwork objects.

 

Figure 11: The floating Fontwork toolbar

 
 

Fontwork Shape: Edits the shape of the selected object. You can choose from a palette of shapes.

 
 

Fontwork Same Letter Heights: Changes the height of characters in the object. Toggles between normal height (some characters taller than others, for example capital letters, d, h, l and others) and all letters the same height.

 

Figure 13: Left: normal letters; right: same letter heights

 
 

Fontwork Alignment: Changes the alignment of characters. Choices are left align, center, right align, word justify, and stretch justify. The effects of the text alignment can only be seen if the text spans over two or more lines. In the stretch justify mode, all the lines are filled completely.

 
 

Fontwork Character Spacing: Changes the character spacing and kerning in the object. Select from the choices in the drop-down list.

 

Using the Formatting toolbar

Now let us go further and customize the Fontwork object with several more attributes.

Click on the Fontwork object. The Formatting toolbar changes to show the options for editing the object. (The toolbar shown in Figure 14 appears when you use Fontwork in Writer.)