Getting Started Guide
 

Chapter 3  
Using Styles and Templates

Using Consistent Formatting in Your Documents

Copyright

This document is Copyright © 2017 by the LibreOffice Documentation Team. Contributors are listed below. You may distribute it and/or modify it under the terms of either the GNU General Public License (http://www.gnu.org/licenses/gpl.html), version 3 or later, or the Creative Commons Attribution License (http://creativecommons.org/licenses/by/4.0/), version 4.0 or later.

All trademarks within this guide belong to their legitimate owners.

Contributors

John A Smith

Jean Hollis Weber

Hazel Russman

Olivier Hallot

Martin Saffron

Ron Faile Jr.

Bruce Byfield

 

 

Feedback

Please direct any comments or suggestions about this document to the Documentation Team’s mailing list: documentation@global.libreoffice.org

Note: Everything you send to a mailing list, including your email address and any other personal information that is written in the message, is publicly archived and cannot be deleted.

Acknowledgments

This document is adapted and updated from previous editions of this chapter. The contributors to those editions are:

Jean Hollis Weber

Michele Zarri

Agnes Belzunce

Daniel Carrera

Peter Hillier-Brook

Peter Kupfer

Gary Schnabl

Janet Swisher

 

Publication date and software version

Published 15 February 2017. Based on LibreOffice 5.2.

Note for Mac users

Some keystrokes and menu items are different on a Mac from those used in Windows and Linux. The table below gives some common substitutions for the instructions in this chapter. For a more detailed list, see the application Help.

Windows or Linux

Mac equivalent

Effect

Tools > Options menu selection

LibreOffice > Preferences

Access setup options

Right-click

Control+click or right-click depending on computer setup

Opens a context menu

Ctrl (Control)

⌘ (Command)

Used with other keys

F5

Shift+⌘+F5

Open the Navigator

F11

⌘+T

Open the Styles and Formatting window

 

Contents

Copyright

Contributors

Feedback

Acknowledgments

Publication date and software version

Note for Mac users

What is a template?

What are styles?

Applying styles

Using the Styles menu in Writer

Using the Styles and Formatting window

Using Fill Format Mode

Using the Apply Style list

Using keyboard shortcuts

Modifying styles

Changing a style using the Style dialog

Updating a style from a selection

Using AutoUpdate

Updating styles from a document or template

Creating new (custom) styles

Creating a new style using the Style dialog

Creating a new style from a selection

Dragging and dropping to create a style

Copying styles from a template or document

Deleting styles

Using a template to create a document

Creating a document from the Templates dialog

Creating a document from a template in the Start Center

Creating a template

Creating a template from a document

Creating a template using a wizard

Editing a template

Updating a document from a changed template

Adding templates obtained from other sources

Installing individual templates

Installing collections of templates

Setting a default template

Setting a template as the default

Resetting the default template

Associating a document with a different template

Organizing templates

Creating a template category

Deleting a template category

Moving a template

Deleting a template

Importing a template

Exporting a template

Examples of style use

Defining a different first page for a document

Dividing a document into chapters

Changing page orientation within a document

Displaying different headers on right and left pages

Controlling page breaks automatically

Compiling an automatic table of contents

Defining a sequence of paragraph styles

 

What is a template?

A template is a model document that you use to create other documents. For example, you can create a template for business reports that has your company’s logo on the first page. New documents created from this template will all have your company’s logo on the first page.

Templates can contain anything that regular documents can contain, such as text, graphics, a set of styles, and user-specific setup information such as measurement units, language, the default printer, and toolbar and menu customization.

All documents in LibreOffice are based on templates. You can create a specific template for any document type (text, spreadsheet, drawing, presentation). If you do not specify a template when you start a new document, then the document is based on the default template for that type of document. If you have not specified a default template, LibreOffice uses the blank template for that type of document that is installed with LibreOffice. See “Setting a default template” on page 17 for more information.

Since LibreOffice version 4.4, you can create templates for Master Documents as well as for ordinary documents.

What are styles?

A style is a set of formats that you can apply to selected pages, text, frames, and other elements in your document to quickly change their appearance. Often applying a style means applying a whole group of formats at the same time.

Many people manually format paragraphs, words, tables, page layouts, and other parts of their documents without paying any attention to styles. They are used to writing documents according to physical attributes. For example, you might specify the font family, font size, and any formatting such as bold or italic.

Styles are logical attributes. Using styles means that you stop saying “font size 14pt, Times New Roman, bold, centered” and you start saying “Title” because you have defined the “Title” style to have those characteristics. In other words, using styles means that you shift the emphasis from what the text (or page, or other element) looks like, to what the text is.

Styles help improve consistency in a document. They also make major formatting changes easy. For example, you may decide to change the indentation of all paragraphs, or change the font of all titles. For a long document, this simple task can require making individual changes in dozens of places. By contrast, when you use styles, you only need to make a single change.

In addition, styles are used by LibreOffice for many processes, even if you are not aware of them. For example, Writer relies on heading styles (or other styles you specify) when it compiles a table of contents. Some common examples of style use are given in “Examples of style use” on page 21.

LibreOffice supports the following types of styles:

Different styles are available in the various components of LibreOffice, as listed in Table 1.

LibreOffice comes with many predefined styles. You can use the styles as provided, modify them, or create new styles, as described in this chapter.

Table 1. Styles available in LibreOffice components

Style Type

Writer

Calc

Draw

Impress

Page

X

X

 

 

Paragraph

X

 

 

 

Character

X

 

 

 

Frame

X

 

 

 

Numbering

X

 

 

 

Cell

 

X

 

 

Presentation

 

 

X

X

Graphics

(included in Frame styles)

 

X

X

Applying styles

LibreOffice provides several ways for you to select styles to apply:

Using the Styles menu in Writer

LibreOffice 5.1 added a new menu to ease the use of styles. The menu has the most important paragraph and character styles for almost every text document. It also has entries for style management in the bottom. The Styles menu does not have styles for frames, pages, and lists.

To apply a paragraph style, position the insertion point in the paragraph, and then select one of the  paragraph styles in the Style menu. To apply a character style to several characters or more than one word, select the characters first and apply the character style from the menu.

You cannot add custom styles to the Styles menu.

Using the Styles and Formatting window

The Styles and Formatting window includes the most complete set of tools for styles. To use it for applying styles:

  1. 1)  Select View > Styles and Formatting or Styles > Styles and Formatting from the Menu bar, or press F11 (⌘+T on a Mac), or click the Styles and Formatting tab in the Sidebar (View > Sidebar to open it). 

The Styles and Formatting window shows previews of the styles available. Figure 1 shows the window for Writer, with Paragraph Styles visible.

  1. 2)  Select one of the buttons at the top left of the Styles and Formatting window to display a list of styles in that category. 

  2. 3)  To apply an existing style, position the insertion point in the paragraph, frame, page, or word, and then double-click the name of the style in one of these lists. To apply a character style to more than one word, select the characters first. 

At the bottom of the Styles and Formatting window is a drop-down list. In Figure 1 the window shows Applied Styles, meaning the list includes only the styles used in the document. You can choose to show all styles or other groups of styles, for example only custom styles.

 

Figure 1: The Styles and Formatting window for Writer, showing paragraph styles

 

Using Fill Format Mode

Use Fill Format to apply a style to many different areas quickly without having to go back to the Styles and Formatting window and double-click every time. This method is quite useful when you need to format many scattered paragraphs, cells, or other items with the same style:

  1. 1)  Open the Styles and Formatting window and select the style you want to apply. 

  2. 2)  Select the Fill Format Mode button. 

  3. 3)  To apply a paragraph, page, or frame style, hover the mouse over the paragraph, page, or frame and click. To apply a character style, hold down the mouse button while selecting the characters. Clicking a word applies the character style for that word. 

  4. 4)  Repeat step 3 until you have made all the changes for that style. 

  5. 5)  To quit Fill Format mode, click the Fill Format Mode button again or press the Esc key. 

When this mode is active, a right-click anywhere in the document undoes the last Fill Format action. Be careful not to accidentally right-click and undo actions you want to keep.

Using the Apply Style list

After you have used a paragraph style at least once in a document, the style name appears on the Apply Style list near the left-hand end of the Formatting toolbar.

You can open this list and click the style you want, or you can use the up and down arrow keys to move through the list and then press Enter to apply the highlighted style.

Select More at the bottom of the Apply Style list to open the Styles and Formatting window.

 

Figure 2: The Apply Style list on the Formatting toolbar

 

Using keyboard shortcuts

Some keyboard shortcuts for applying styles are predefined. For example, in Writer Ctrl+0 applies the Text body style, Ctrl+1 applies the Heading 1 style, and Ctrl+2 applies the Heading 2 style. You can modify these shortcuts and create your own; see Chapter 14, Customizing LibreOffice, for instructions.

Manual formatting (also called direct formatting) overrides styles, and you cannot get rid of the manual formatting by applying a style to it.

To remove manual formatting, select the text, right-click, and choose Clear Direct Formatting from the context menu, or select the text and press Ctrl+M.

Modifying styles

LibreOffice includes predefined styles, but you can also create custom styles. You can modify both types of styles in several ways:

Any changes you make to a style are effective only in the current document. To change styles in more than one document, you need to change the template or copy the styles into the other documents as described on page 10.

Changing a style using the Style dialog

To change an existing style using the Style dialog, right-click on the required style in the Styles and Formatting window and select Modify from the pop-up menu.

The Style dialog displayed depends on the type of style selected. Each Style dialog has several tabs. See the chapters on styles in the user guides for details.

Updating a style from a selection

To update a style from a selection:

  1. 1)  Open the Styles and Formatting window. 

  2. 2)  In the document, select an item that has the format you want to adopt as a style. 

When updating a paragraph style, make sure that the selected paragraph contains unique properties. If it mixes font sizes or font styles, those mixed properties will remain the same as before.

  1. 3)  In the Styles and Formatting window, select the style to update, then click on the arrow next to the New Style from Selection icon and click Update Style

 

Figure 3: Updating a style from a selection

 

You can also modify styles using the submenu on each style in the Apply Style list on the Formatting toolbar (see Figure 4).

 

Figure 4: Modifying a style from the Apply Style list

 

Using AutoUpdate

AutoUpdate applies to paragraph and frame styles only. If the AutoUpdate option is selected on the Organizer page of the Paragraph Style or Frame Style dialog, applying direct formatting to a paragraph or frame using this style in your document automatically updates the style itself.

If you are in the habit of manually overriding styles in your document, be sure that AutoUpdate is not enabled.

Updating styles from a document or template

You can update styles by copying (loading) them from a template or another document. See “Copying styles from a template or document” on page 12.

Creating new (custom) styles

You may want to add some new styles. You can do this by using either the Style dialog or the New Style from Selection tool.

Creating a new style using the Style dialog

To create a new style using the Style dialog, right-click in the Styles and Formatting window and select New from the pop-up menu.

If you want your new style to be linked with an existing style, first select that style and then right-click and select New.

If you link styles, then when you change the base style (for example, by changing the font from Times to Helvetica), all the linked styles will change as well. Sometimes this is exactly what you want; other times you do not want the changes to apply to all the linked styles. It pays to plan ahead.

The dialogs and choices are the same for defining new styles and for modifying existing styles. See the chapters on styles in the user guides for details.

If a document needs custom styles derived from base styles, consider prefixing the name of the custom styles with a few characters to highlight them among other styles in the list. For example, you might name a modified Heading 1 style for an annual report AR Heading 1.

Creating a new style from a selection

You can create a new style by copying an existing manual format. This new style applies only to this document; it will not be saved in the template.

  1. 1)  Open the Styles and Formatting window and choose the type of style you want to create. 

  2. 2)  In the document, select the item you want to save as a style. 

  3. 3)  In the Styles and Formatting window, select on the New Style from Selection icon. 

  4. 4)  In the Create Style dialog, type a name for the new style. The list shows the names of existing custom styles of the selected type. Click OK to save the new style. 

 

Figure 5: Naming a new style created from a selection

 

Dragging and dropping to create a style

You can drag and drop a selection into the Styles and Formatting window to create a new style. The element to drag depends upon the LibreOffice application.

Writer

Select some text and drag it to the Styles and Formatting window. If Paragraph Styles are active, the paragraph style will be added to the list. If Character Styles are active, the character style will be added to the list.

Calc

Drag a cell selection to the Styles and Formatting window to create a cell style.

Draw/Impress

Select and drag a drawing object to the Styles and Formatting window to create a graphic style.

Copying styles from a template or document

You can copy styles into a document by loading them from a template or from another document:

  1. 1)  Open the document you want to copy styles into. 

  2. 2)  In the Styles and Formatting window, click the arrow next to the New Style from Selection icon, and then select Load Styles (see Figure 3). 

  3. 3)  On the Load Styles dialog (Figure 6), find either a template or an ordinary document from which to copy styles. Click the From File button to open a window from which to select the required document. 

  4. 4)  Select the types of styles to copy from the checkboxes at the bottom of the dialog. 

  5. 5)  Select Overwrite if you want to replace styles in the original document that have the same name as styles in the document from which you are importing styles. If this box is not selected, you will only copy styles whose names are not used in the original document. 

  6. 6)  Click OK to copy the styles. 

 

Figure 6: Copying styles from a template into the open document

 

If your document has a table of contents, and if you have used custom styles for headings, the heading levels associated with outline levels in Tools > Outline Numbering will revert to the defaults of Heading 1, Heading 2, and so on when you load Text Styles from a file that does not use the same custom styles. You will need to change these back to your custom heading styles.

Deleting styles

You cannot remove (delete) any of LibreOffice’s predefined styles from a document or template, even if they are not in use.

You can remove any user-defined (custom) styles; but before you do, you should make sure the styles are not in use in the current document.

To delete any unwanted styles, in the Styles and Formatting window select each one to be deleted (hold Ctrl while selecting multiple styles), and then right-click on a selected style and select Delete on the context menu.

If the style is not in use, it is deleted immediately without confirmation. If the style is in use, you receive a warning message asking you to confirm deletion.

If you delete a style that is in use, all objects with that style will return to the default style.

Using a template to create a document

Creating a document from the Templates dialog

To use a template to create a document:

  1. 1)  From the Menu bar, choose File > New > Templates. You can also click on the small arrow next to the New icon and select Templates. The Templates dialog opens. 

  2. 2)  From the listbox at the top of the dialog, select the category of template you want to use.All the templates contained in that folder are listed on the page (as shown in Figure 7). 

  3. 3)  Select the required template and click OK, or double-click on the selected template. A new document based on the template opens in LibreOffice. 

The template the document is based upon is listed in File > Properties > General. The connection between the template and the document remains until the template is modified and, the next time that the document is opened, you choose not to update it to match the template.

 

Figure 7: Templates dialog, showing a selected template

 

Creating a document from a template in the Start Center

You can create a document from the template view of the Start Center. The Start Center is visible when no other document is open.

To open the Templates dialog from the Start Center, click on the Templates button in the left pane. The button is also a drop-down list to select the templates of a given type of document. The Manage Templates option on the list opens the Template dialog (Figure 7).

Creating a template

You can create templates in two ways: by saving a document as a template or by using a wizard.

Creating a template from a document

In addition to formatting, any settings that can be added to or modified in a document can be saved within a template. For example, you can also save printer settings, and general behaviors set from Tools > Options, such as Paths and Colors.

Templates can also contain predefined text, saving you from having to type it every time you create a new document. For example, a letter template may contain your name, address, and salutation.

You can also save menu and toolbar customizations in templates; see Chapter 14, Customizing LibreOffice, for more information.

To create a template from a document and save it to My Templates:

  1. 1)  Open a new or existing document of the type you want to make into a template (text document, spreadsheet, drawing, or presentation). 

  2. 2)  Add any content that you want to appear in any document you create from the new template, for example company logo, copyright statement, and so on. 

  3. 3)  Create or modify any styles that you want to use in the new template. 

  4. 4)  From the Menu bar, choose File > Templates > Save as Template. The Save as Template dialog (Figure 8) opens, displaying the existing categories and a textbox to enter a name for the new template. 

  5. 5)  Select the My Templates folder. 

  6. 6)  Click Save. The template is saved and the dialog closes. 

 

Figure 8: Save as Template dialog

 

Although the Save as Template dialog shows no document type when saving a new template of any type, the template will appear on the correct tab (Documents, Spreadsheets, Presentations, Drawings) when you return to the Templates dialog.

Creating a template using a wizard

You can use wizards to create templates for letters, faxes, and agendas, and to create presentations and Web pages.

For example, the Fax Wizard guides you through the following choices:

To create a template using a wizard:

  1. 1)  From the Menu bar, choose File > Wizards > [type of template required] (see Figure 9). 

  2. 2)  Follow the instructions on the pages of the wizard. This process is slightly different for each type of template, but the format is very similar. 

  3. 3)  In the last section of the wizard, you can specify the template name which will show in the Templates dialog, and also the name and location for saving the template. The two names can be different but this may later cause confusion. The default location is your user templates directory, but you can choose a different location. 

  4. 4)  To set the file name or change the directory, select the Path button (the three dots to the right of the location). The Save As dialog opens. Make your selections and click Save to close the dialog. 

 

Figure 9: Creating a template using a wizard

  1. 5)  Finally, you can choose whether to create a new document from the template immediately, or manually change the template, and then click Finish to save the template. For future documents, you can re-use the template created by the wizard, just like any other template. 

You may need to open the Templates dialog and click Refresh on the Action menu to have any new templates appear in the listings.

Editing a template

You can edit a template’s styles and content, and then, if you wish, you can reapply the template’s styles to documents that were created from that template. You cannot reapply content.

To edit a template:

  1. 1)  From the Menu bar, choose File > Templates > Manage Templates or press Ctrl+Shift+N. The Templates dialog opens. You can also open the Templates dialog from the Start Center. 

  2. 2)  Navigate to the template that you want to edit. Click once on it to activate the file handling controls (see Figure 7). Right-click to open the context menu click Edit. The template opens in LibreOffice. 

  3. 3)  Edit the template as you would edit any other document. To save your changes, choose File > Save from the Menu bar. 

Updating a document from a changed template

If you make any changes to a template and its styles, the next time you open a document that was created from the template before the changes, a confirmation message is displayed.

To update the document:

  1. 1)  Click Update Styles to apply the changed styles in the template to the document. 

  2. 2)  Select Keep Old Styles if you do not want to apply the changed styles in the template to the document (but see the Caution notice below). 

If you choose Keep Old Styles, the document is no longer connected to the template, even though the template is still listed under File > Properties > General. You can still import styles manually from the template, but to reconnect it to the template, you will have to copy it into an empty document based on the template.

Adding templates obtained from other sources

LibreOffice refers to sources for templates as repositories. A repository can be local (a directory on your computer to which you have downloaded templates) or remote (a URL from which you can download templates).

You can get to the official template repository by using the Get more templates for LibreOffice button at the right-hand end of the Templates dialog, as shown in Figure 10, or by typing http://templates.libreoffice.org/template-center in your browser’s address bar.

If you have enabled experimental features in Tools > Options > LibreOffice > Advanced, the Templates dialog shows a Repository button that you can use to add other template repositories. As this is an experimental feature, it may not work reliably.

On other websites you may find collections of templates that have been packaged into extension (OXT) files. These are installed a little differently, as described below.

 

Figure 10: Getting more templates for LibreOffice

 

Installing individual templates

To install individual templates:

  1. 1)  Download the template and save it anywhere on your computer. 

  2. 2)  Import the template into a template folder by following the instructions in “Importing a template” on page 20

You can manually copy new templates into the template folders. The location varies with your computer’s operating system. To learn where the template folders are stored on your computer, go to Tools > Options > LibreOffice > Paths.

Installing collections of templates

The Extension Manager provides an easy way to install collections of templates that have been packaged as extensions. Follow these steps:

  1. 1)  Download the extension package (OXT file) and save it anywhere on your computer. 

  2. 2)  In LibreOffice, select Tools > Extension Manager from the Menu bar. In the Extension Manager dialog, click Add to open a file browser window. 

  3. 3)  Find and select the package of templates you want to install and click Open. The package begins installing. You may be asked to accept a license agreement. 

  4. 4)  When the package installation is complete, restart LibreOffice. The templates are available for use through File > Templates > Manage Templates and File > New > Templates and the extension is listed in the Extension Manager. 

See Chapter 14, Customizing LibreOffice, for more about the Extension Manager.

Setting a default template

If you create a document by choosing File > New > Text Document (or Spreadsheet, Presentation, or Drawing) from the Menu bar, LibreOffice creates the document from the default template for that type of document. You can, however, change the default whenever you choose.

You may know that Microsoft Word employs a normal.dot or normal.dotx file for its default template and how to regenerate it.

LibreOffice does not have a similar default template file; the “factory defaults” are embedded within the software.

Setting a template as the default

Most default settings, such as page size and page margins, can be changed in Tools > Options, but those changes apply only to the document you are working on. To make those changes the default settings for that document type, you need to replace the default template with a new one.

You can set any template displayed in the Templates dialog to be the default for that document type:

  1. 1)  From the Menu bar, choose File > Templates > Manage Templates

  2. 2)  In the Templates dialog, open the category containing the template that you want to set as the default, then select the template. 

  3. 3)  Right-click on the selected template and click the Set as default button (see Figure 7). 

The next time that you create a document of that type by choosing File > New, the document will be created from this template.

Resetting the default template

To re-enable LibreOffice’s original default template for a document type as the default for that type:

  1. 1)  In the Templates dialog, click the Action Menu icon on the bottom left (Figure 11). 

  2. 2)  Point to Reset Default Template on the drop-down menu, and click Text Document (or other template type). 

These choices do not appear unless a custom template has been set as the default, as described in the previous section.

The next time that you create a document by choosing File > New, the document will be created from the original default template for the document type.