Chapter 3
Using Styles and Templates
Using Consistent Formatting in Your Documents
Copyright

This document is Copyright © 2017 by the LibreOffice Documentation Team. Contributors are listed below. You may distribute it and/or modify it under the terms of either the GNU General Public License (http://www.gnu.org/licenses/gpl.html), version 3 or later, or the Creative Commons Attribution License (http://creativecommons.org/licenses/by/4.0/), version 4.0 or later.

All trademarks within this guide belong to their legitimate owners.

Contributors

John A Smith  Jean Hollis Weber  Hazel Russman
Olivier Hallot  Martin Safron  Ron Faile Jr.
Bruce Byfield

Feedback

Please direct any comments or suggestions about this document to the Documentation Team’s mailing list: documentation@global.libreoffice.org

Note: Everything you send to a mailing list, including your email address and any other personal information that is written in the message, is publicly archived and cannot be deleted.

Acknowledgments

This document is adapted and updated from previous editions of this chapter. The contributors to those editions are:

Jean Hollis Weber  Michele Zarri  Agnes Belzunce
Daniel Carrera  Peter Hillier-Brook  Peter Kupfer
Gary Schnabl  Janet Swisher

Publication date and software version

Published 15 February 2017. Based on LibreOffice 5.2.

Note for Mac users

Some keystrokes and menu items are different on a Mac from those used in Windows and Linux. The table below gives some common substitutions for the instructions in this chapter. For a more detailed list, see the application Help.

<table>
<thead>
<tr>
<th>Windows or Linux</th>
<th>Mac equivalent</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Tools &gt; Options menu selection</strong></td>
<td><strong>LibreOffice &gt; Preferences</strong></td>
<td>Access setup options</td>
</tr>
<tr>
<td><strong>Right-click</strong></td>
<td><strong>Control+click or right-click depending on computer setup</strong></td>
<td>Opens a context menu</td>
</tr>
<tr>
<td><strong>Ctrl (Control)</strong></td>
<td>⌘ (Command)</td>
<td>Used with other keys</td>
</tr>
<tr>
<td><strong>F5</strong></td>
<td>Shift+⌘+F5</td>
<td>Open the Navigator</td>
</tr>
<tr>
<td><strong>F11</strong></td>
<td>⌘+T</td>
<td>Open the Styles and Formatting window</td>
</tr>
</tbody>
</table>

Documentation for LibreOffice is available at http://documentation.libreoffice.org/
## Contents

Copyright .......................................................................................................................... 2
  Contributors .................................................................................................................. 2
  Feedback ....................................................................................................................... 2
  Acknowledgments ......................................................................................................... 2
  Publication date and software version ......................................................................... 2
  Note for Mac users ....................................................................................................... 2

What is a template? ........................................................................................................ 5

What are styles? ............................................................................................................... 5

Applying styles ............................................................................................................. 6
  Using the Styles menu in Writer .................................................................................. 6
  Using the Styles and Formatting window .................................................................... 7
  Using Fill Format Mode .............................................................................................. 7
  Using the Apply Style list ......................................................................................... 8
  Using keyboard shortcuts .......................................................................................... 8

Modifying styles .......................................................................................................... 9
  Changing a style using the Style dialog ....................................................................... 9
  Updating a style from a selection ................................................................................ 9
  Using AutoUpdate ...................................................................................................... 10
  Updating styles from a document or template ............................................................ 10

Creating new (custom) styles ...................................................................................... 10
  Creating a new style using the Style dialog ............................................................... 10
  Creating a new style from a selection ........................................................................ 11
  Dragging and dropping to create a style .................................................................... 11

Copying styles from a template or document ............................................................. 12

Deleting styles ............................................................................................................ 12

Using a template to create a document ...................................................................... 13
  Creating a document from the Templates dialog ..................................................... 13
  Creating a document from a template in the Start Center ......................................... 13

Creating a template .................................................................................................... 14
  Creating a template from a document ....................................................................... 14
  Creating a template using a wizard .......................................................................... 15

Editing a template ....................................................................................................... 16
  Updating a document from a changed template ....................................................... 16

Adding templates obtained from other sources ....................................................... 16
  Installing individual templates ................................................................................ 17
  Installing collections of templates ........................................................................... 17

Setting a default template .......................................................................................... 17
  Setting a template as the default .............................................................................. 17
  Resetting the default template ................................................................................ 18

Associating a document with a different template .................................................. 18
Organizing templates
Creating a template category
Deleting a template category
Moving a template
Deleting a template
Importing a template
Exporting a template

Examples of style use
Defining a different first page for a document
Dividing a document into chapters
Changing page orientation within a document
Displaying different headers on right and left pages
Controlling page breaks automatically
Compiling an automatic table of contents
Defining a sequence of paragraph styles
What is a template?

A template is a model document that you use to create other documents. For example, you can create a template for business reports that has your company’s logo on the first page. New documents created from this template will all have your company’s logo on the first page.

Templates can contain anything that regular documents can contain, such as text, graphics, a set of styles, and user-specific setup information such as measurement units, language, the default printer, and toolbar and menu customization.

All documents in LibreOffice are based on templates. You can create a specific template for any document type (text, spreadsheet, drawing, presentation). If you do not specify a template when you start a new document, then the document is based on the default template for that type of document. If you have not specified a default template, LibreOffice uses the blank template for that type of document that is installed with LibreOffice. See “Setting a default template” on page 17 for more information.

Since LibreOffice version 4.4, you can create templates for Master Documents as well as for ordinary documents.

What are styles?

A style is a set of formats that you can apply to selected pages, text, frames, and other elements in your document to quickly change their appearance. Often applying a style means applying a whole group of formats at the same time.

Many people manually format paragraphs, words, tables, page layouts, and other parts of their documents without paying any attention to styles. They are used to writing documents according to physical attributes. For example, you might specify the font family, font size, and any formatting such as bold or italic.

Styles are logical attributes. Using styles means that you stop saying “font size 14pt, Times New Roman, bold, centered” and you start saying “Title” because you have defined the “Title” style to have those characteristics. In other words, using styles means that you shift the emphasis from what the text (or page, or other element) looks like, to what the text is.

Styles help improve consistency in a document. They also make major formatting changes easy. For example, you may decide to change the indentation of all paragraphs, or change the font of all titles. For a long document, this simple task can require making individual changes in dozens of places. By contrast, when you use styles, you only need to make a single change.

In addition, styles are used by LibreOffice for many processes, even if you are not aware of them. For example, Writer relies on heading styles (or other styles you specify) when it compiles a table of contents. Some common examples of style use are given in “Examples of style use” on page 21.

LibreOffice supports the following types of styles:

- **Page styles** include margins, headers and footers, borders and backgrounds. In Calc, page styles also include the sequence for printing sheets.
- **Paragraph styles** control all aspects of a paragraph’s appearance, such as text alignment, tab stops, line spacing, and borders, and can include character formatting.
- **Character styles** affect selected text within a paragraph, such as the font and size of text, or bold and italic formats.
- **Frame styles** are used to format graphic and text frames, including text wrap, borders, backgrounds, and columns.
- **List styles** allow you to select, format, and position numbers or bullets in lists.
• **Cell styles** include fonts, alignment, borders, background, number formats (for example, currency, date, number), and cell protection.

• **Graphics styles** in drawings and presentations include line, area, shadowing, transparency, font, connectors, dimensioning, and other attributes.

• **Presentation styles** include attributes for font, indents, spacing, alignment, and tabs.

Different styles are available in the various components of LibreOffice, as listed in Table 1.

LibreOffice comes with many predefined styles. You can use the styles as provided, modify them, or create new styles, as described in this chapter.

### Table 1. Styles available in LibreOffice components

<table>
<thead>
<tr>
<th>Style Type</th>
<th>Writer</th>
<th>Calc</th>
<th>Draw</th>
<th>Impress</th>
</tr>
</thead>
<tbody>
<tr>
<td>Page</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Paragraph</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Character</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Frame</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Numbering</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cell</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Presentation</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Graphics</td>
<td>(included in Frame styles) X</td>
<td>X</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

### Applying styles

LibreOffice provides several ways for you to select styles to apply:

- The Styles menu in Writer
- Styles and Formatting window (floating, or in Sidebar)
- Fill Format Mode
- Apply Style List
- Keyboard shortcuts

### Using the Styles menu in Writer

LibreOffice 5.1 added a new menu to ease the use of styles. The menu has the most important paragraph and character styles for almost every text document. It also has entries for style management in the bottom. The Styles menu does not have styles for frames, pages, and lists.

To apply a paragraph style, position the insertion point in the paragraph, and then select one of the paragraph styles in the **Style** menu. To apply a character style to several characters or more than one word, select the characters first and apply the character style from the menu.

Note

You cannot add custom styles to the Styles menu.
Using the Styles and Formatting window

The Styles and Formatting window includes the most complete set of tools for styles. To use it for applying styles:

1) Select View > Styles and Formatting or Styles > Styles and Formatting from the Menu bar, or press F11 (Cmd+T on a Mac), or click the Styles and Formatting tab in the Sidebar (View > Sidebar to open it).

   The Styles and Formatting window shows previews of the styles available. Figure 1 shows the window for Writer, with Paragraph Styles visible.

2) Select one of the buttons at the top left of the Styles and Formatting window to display a list of styles in that category.

3) To apply an existing style, position the insertion point in the paragraph, frame, page, or word, and then double-click the name of the style in one of these lists. To apply a character style to more than one word, select the characters first.

   Tip

   At the bottom of the Styles and Formatting window is a drop-down list. In Figure 1 the window shows Applied Styles, meaning the list includes only the styles used in the document. You can choose to show all styles or other groups of styles, for example only custom styles.

   Figure 1: The Styles and Formatting window for Writer, showing paragraph styles

Using Fill Format Mode

Use Fill Format to apply a style to many different areas quickly without having to go back to the Styles and Formatting window and double-click every time. This method is quite useful when you need to format many scattered paragraphs, cells, or other items with the same style:

1) Open the Styles and Formatting window and select the style you want to apply.

2) Select the Fill Format Mode button.

3) To apply a paragraph, page, or frame style, hover the mouse over the paragraph, page, or frame and click. To apply a character style, hold down the mouse button while selecting the characters. Clicking a word applies the character style for that word.

4) Repeat step 3 until you have made all the changes for that style.

5) To quit Fill Format mode, click the Fill Format Mode button again or press the Esc key.
Caution
When this mode is active, a right-click anywhere in the document undoes the last Fill Format action. Be careful not to accidentally right-click and undo actions you want to keep.

Using the Apply Style list
After you have used a paragraph style at least once in a document, the style name appears on the Apply Style list near the left-hand end of the Formatting toolbar.

You can open this list and click the style you want, or you can use the up and down arrow keys to move through the list and then press Enter to apply the highlighted style.

Tip
Select More at the bottom of the Apply Style list to open the Styles and Formatting window.

Figure 2: The Apply Style list on the Formatting toolbar

Using keyboard shortcuts
Some keyboard shortcuts for applying styles are predefined. For example, in Writer Ctrl+0 applies the Text body style, Ctrl+1 applies the Heading 1 style, and Ctrl+2 applies the Heading 2 style. You can modify these shortcuts and create your own; see Chapter 14, Customizing LibreOffice, for instructions.

Caution
Manual formatting (also called direct formatting) overrides styles, and you cannot get rid of the manual formatting by applying a style to it.

To remove manual formatting, select the text, right-click, and choose Clear Direct Formatting from the context menu, or select the text and press Ctrl+M.
Modifying styles

 LibreOffice includes predefined styles, but you can also create custom styles. You can modify both types of styles in several ways:

• Change a style using the Style dialog
• Update a style from a selection
• Use AutoUpdate (paragraph and frame styles only)
• Load or copy styles from another document or template

**Note**

Any changes you make to a style are effective only in the current document. To change styles in more than one document, you need to change the template or copy the styles into the other documents as described on page 10.

Changing a style using the Style dialog

To change an existing style using the Style dialog, right-click on the required style in the Styles and Formatting window and select **Modify** from the pop-up menu.

The Style dialog displayed depends on the type of style selected. Each Style dialog has several tabs. See the chapters on styles in the user guides for details.

Updating a style from a selection

To update a style from a selection:

1) Open the Styles and Formatting window.
2) In the document, select an item that has the format you want to adopt as a style.

**Caution**

When updating a paragraph style, make sure that the selected paragraph contains unique properties. If it mixes font sizes or font styles, those mixed properties will remain the same as before.

3) In the Styles and Formatting window, select the style to update, then click on the arrow next to the **New Style from Selection** icon and click **Update Style**.

![Figure 3: Updating a style from a selection](image-url)
Tip
You can also modify styles using the submenu on each style in the Apply Style list on the Formatting toolbar (see Figure 4).

Figure 4: Modifying a style from the Apply Style list

Using AutoUpdate
AutoUpdate applies to paragraph and frame styles only. If the AutoUpdate option is selected on the Organizer page of the Paragraph Style or Frame Style dialog, applying direct formatting to a paragraph or frame using this style in your document automatically updates the style itself.

Tip
If you are in the habit of manually overriding styles in your document, be sure that AutoUpdate is not enabled.

Updating styles from a document or template
You can update styles by copying (loading) them from a template or another document. See “Copying styles from a template or document” on page 12.

Creating new (custom) styles
You may want to add some new styles. You can do this by using either the Style dialog or the New Style from Selection tool.

Creating a new style using the Style dialog
To create a new style using the Style dialog, right-click in the Styles and Formatting window and select New from the pop-up menu.

If you want your new style to be linked with an existing style, first select that style and then right-click and select New.

If you link styles, then when you change the base style (for example, by changing the font from Times to Helvetica), all the linked styles will change as well. Sometimes this is exactly what you want; other times you do not want the changes to apply to all the linked styles. It pays to plan ahead.

The dialogs and choices are the same for defining new styles and for modifying existing styles. See the chapters on styles in the user guides for details.
Tip

If a document needs custom styles derived from base styles, consider prefixing the name of the custom styles with a few characters to highlight them among other styles in the list. For example, you might name a modified Heading 1 style for an annual report AR Heading 1.

Creating a new style from a selection

You can create a new style by copying an existing manual format. This new style applies only to this document; it will not be saved in the template.

1) Open the Styles and Formatting window and choose the type of style you want to create.
2) In the document, select the item you want to save as a style.
3) In the Styles and Formatting window, select on the New Style from Selection icon.
4) In the Create Style dialog, type a name for the new style. The list shows the names of existing custom styles of the selected type. Click OK to save the new style.

Figure 5: Naming a new style created from a selection

Dragging and dropping to create a style

You can drag and drop a selection into the Styles and Formatting window to create a new style. The element to drag depends upon the LibreOffice application.

Writer
Select some text and drag it to the Styles and Formatting window. If Paragraph Styles are active, the paragraph style will be added to the list. If Character Styles are active, the character style will be added to the list.

Calc
Drag a cell selection to the Styles and Formatting window to create a cell style.

Draw/Impress
Select and drag a drawing object to the Styles and Formatting window to create a graphic style.
Copying styles from a template or document

You can copy styles into a document by loading them from a template or from another document:

1) Open the document you want to copy styles into.
2) In the Styles and Formatting window, click the arrow next to the New Style from Selection icon, and then select Load Styles (see Figure 3).
3) On the Load Styles dialog (Figure 6), find either a template or an ordinary document from which to copy styles. Click the From File button to open a window from which to select the required document.
4) Select the types of styles to copy from the checkboxes at the bottom of the dialog.
5) Select Overwrite if you want to replace styles in the original document that have the same name as styles in the document from which you are importing styles. If this box is not selected, you will only copy styles whose names are not used in the original document.
6) Click OK to copy the styles.

![Figure 6: Copying styles from a template into the open document](image)

Caution

If your document has a table of contents, and if you have used custom styles for headings, the heading levels associated with outline levels in Tools > Outline Numbering will revert to the defaults of Heading 1, Heading 2, and so on when you load Text Styles from a file that does not use the same custom styles. You will need to change these back to your custom heading styles.

Deleting styles

You cannot remove (delete) any of LibreOffice's predefined styles from a document or template, even if they are not in use.

You can remove any user-defined (custom) styles; but before you do, you should make sure the styles are not in use in the current document.

To delete any unwanted styles, in the Styles and Formatting window select each one to be deleted (hold Ctrl while selecting multiple styles), and then right-click on a selected style and select Delete on the context menu.
If the style is not in use, it is deleted immediately without confirmation. If the style is in use, you receive a warning message asking you to confirm deletion.

Caution

If you delete a style that is in use, all objects with that style will return to the default style.

Using a template to create a document

Creating a document from the Templates dialog

To use a template to create a document:

1) From the Menu bar, choose File > New > Templates. You can also click on the small arrow next to the New icon and select Templates. The Templates dialog opens.

2) From the listbox at the top of the dialog, select the category of template you want to use. All the templates contained in that folder are listed on the page (as shown in Figure 7).

3) Select the required template and click OK, or double-click on the selected template. A new document based on the template opens in LibreOffice.

The template the document is based upon is listed in File > Properties > General. The connection between the template and the document remains until the template is modified and, the next time that the document is opened, you choose not to update it to match the template.

Creating a document from a template in the Start Center

You can create a document from the template view of the Start Center. The Start Center is visible when no other document is open.

Figure 7: Templates dialog, showing a selected template
To open the Templates dialog from the Start Center, click on the Templates button in the left pane. The button is also a drop-down list to select the templates of a given type of document. The Manage Templates option on the list opens the Template dialog (Figure 7).

Creating a template

You can create templates in two ways: by saving a document as a template or by using a wizard.

Creating a template from a document

In addition to formatting, any settings that can be added to or modified in a document can be saved within a template. For example, you can also save printer settings, and general behaviors set from Tools > Options, such as Paths and Colors.

Templates can also contain predefined text, saving you from having to type it every time you create a new document. For example, a letter template may contain your name, address, and salutation.

You can also save menu and toolbar customizations in templates; see Chapter 14, Customizing LibreOffice, for more information.

To create a template from a document and save it to My Templates:

1) Open a new or existing document of the type you want to make into a template (text document, spreadsheet, drawing, or presentation).
2) Add any content that you want to appear in any document you create from the new template, for example company logo, copyright statement, and so on.
3) Create or modify any styles that you want to use in the new template.
4) From the Menu bar, choose File > Templates > Save as Template. The Save as Template dialog (Figure 8) opens, displaying the existing categories and a textbox to enter a name for the new template.
5) Select the My Templates folder.
6) Click Save. The template is saved and the dialog closes.

Figure 8: Save as Template dialog
Note

Although the Save as Template dialog shows no document type when saving a new template of any type, the template will appear on the correct tab (Documents, Spreadsheets, Presentations, Drawings) when you return to the Templates dialog.

Creating a template using a wizard

You can use wizards to create templates for letters, faxes, and agendas, and to create presentations and Web pages.

For example, the Fax Wizard guides you through the following choices:

- Type of fax (business or personal)
- Document elements like the date, subject line (business fax), salutation, and complimentary close
- Options for sender and recipient information (business fax)
- Text to include in the footer (business fax)

To create a template using a wizard:

1) From the Menu bar, choose File > Wizards > [type of template required] (see Figure 9).

2) Follow the instructions on the pages of the wizard. This process is slightly different for each type of template, but the format is very similar.

3) In the last section of the wizard, you can specify the template name which will show in the Templates dialog, and also the name and location for saving the template. The two names can be different but this may later cause confusion. The default location is your user templates directory, but you can choose a different location.

4) To set the file name or change the directory, select the Path button (the three dots to the right of the location). The Save As dialog opens. Make your selections and click Save to close the dialog.

5) Finally, you can choose whether to create a new document from the template immediately, or manually change the template, and then click Finish to save the template. For future documents, you can re-use the template created by the wizard, just like any other template.

You may need to open the Templates dialog and click Refresh on the Action menu to have any new templates appear in the listings.
**Editing a template**

You can edit a template’s styles and content, and then, if you wish, you can reapply the template’s styles to documents that were created from that template. You cannot reapply content.

To edit a template:

1) From the Menu bar, choose **File > Templates > Manage Templates** or press **Ctrl+Shift+N**. The Templates dialog opens. You can also open the Templates dialog from the Start Center.

2) Navigate to the template that you want to edit. Click once on it to activate the file handling controls (see Figure 7). Right-click to open the context menu click **Edit**. The template opens in LibreOffice.

3) Edit the template as you would edit any other document. To save your changes, choose **File > Save** from the Menu bar.

**Updating a document from a changed template**

If you make any changes to a template and its styles, the next time you open a document that was created from the template before the changes, a confirmation message is displayed.

To update the document:

1) Click **Update Styles** to apply the changed styles in the template to the document.

2) Select **Keep Old Styles** if you do not want to apply the changed styles in the template to the document (but see the Caution notice below).

![Caution](https://example.com/caution.png)

**Caution**

If you choose **Keep Old Styles**, the document is no longer connected to the template, even though the template is still listed under **File > Properties > General**. You can still import styles manually from the template, but to reconnect it to the template, you will have to copy it into an empty document based on the template.

**Adding templates obtained from other sources**

LibreOffice refers to sources for templates as repositories. A repository can be local (a directory on your computer to which you have downloaded templates) or remote (a URL from which you can download templates).

You can get to the official template repository by using the **Get more templates for LibreOffice** button at the right-hand end of the Templates dialog, as shown in Figure 10, or by typing http://templates.libreoffice.org/template-center in your browser’s address bar.

If you have enabled experimental features in **Tools > Options > LibreOffice > Advanced**, the Templates dialog shows a **Repository** button that you can use to add other template repositories. As this is an experimental feature, it may not work reliably.

On other websites you may find collections of templates that have been packaged into extension (OXT) files. These are installed a little differently, as described below.

![Figure 10: Getting more templates for LibreOffice](https://example.com/figure10.png)
Installing individual templates

To install individual templates:

1) Download the template and save it anywhere on your computer.
2) Import the template into a template folder by following the instructions in “Importing a template” on page 20.

Tip

You can manually copy new templates into the template folders. The location varies with your computer’s operating system. To learn where the template folders are stored on your computer, go to Tools > Options > LibreOffice > Paths.

Installing collections of templates

The Extension Manager provides an easy way to install collections of templates that have been packaged as extensions. Follow these steps:

1) Download the extension package (OXT file) and save it anywhere on your computer.
2) In LibreOffice, select Tools > Extension Manager from the Menu bar. In the Extension Manager dialog, click Add to open a file browser window.
3) Find and select the package of templates you want to install and click Open. The package begins installing. You may be asked to accept a license agreement.
4) When the package installation is complete, restart LibreOffice. The templates are available for use through File > Templates > Manage Templates and File > New > Templates and the extension is listed in the Extension Manager.

See Chapter 14, Customizing LibreOffice, for more about the Extension Manager.

Setting a default template

If you create a document by choosing File > New > Text Document (or Spreadsheet, Presentation, or Drawing) from the Menu bar, LibreOffice creates the document from the default template for that type of document. You can, however, change the default whenever you choose.

Note for Microsoft Word users

You may know that Microsoft Word employs a normal.dot or normal.dotx file for its default template and how to regenerate it.

LibreOffice does not have a similar default template file; the “factory defaults” are embedded within the software.

Setting a template as the default

Most default settings, such as page size and page margins, can be changed in Tools > Options, but those changes apply only to the document you are working on. To make those changes the default settings for that document type, you need to replace the default template with a new one.

You can set any template displayed in the Templates dialog to be the default for that document type:

1) From the Menu bar, choose File > Templates > Manage Templates.
2) In the Templates dialog, open the category containing the template that you want to set as the default, then select the template.
3) Right-click on the selected template and click the Set as default button (see Figure 7).
The next time that you create a document of that type by choosing File > New, the document will be created from this template.

**Resetting the default template**

To re-enable LibreOffice's original default template for a document type as the default for that type:

1) In the Templates dialog, click the **Action Menu** icon on the bottom left (Figure 11).
2) Point to **Reset Default Template** on the drop-down menu, and click **Text Document** (or other template type).

These choices do not appear unless a custom template has been set as the default, as described in the previous section.

The next time that you create a document by choosing File > New, the document will be created from the original default template for the document type.

![Figure 11: Resetting the default template for text documents](image)

**Associating a document with a different template**

At the time of writing this chapter, LibreOffice has no direct method of changing the template that a document uses; the Template Changer extension has not been updated for this version of LibreOffice. However, you can copy the contents of a document into an empty document that uses a different template.

For best results, the names of styles should be the same in the existing document and the new template. If they are not, use **Edit > Find & Replace** to replace old styles with new ones. See Chapter 4, Getting Started with Writer, for more about replacing styles using Find & Replace.

To associate a document with another template:

1) Use **File > Templates > Manage Templates** to open the Templates dialog, and select the template you want to use. A new document opens, containing any text or graphics that were in the template.
2) Delete any unwanted text or graphics from this new document.
3) Open the document you want to change. Select **Edit > Select All** or press **Ctrl+A**.
4) Select **Edit > Copy**, or press **Ctrl+C**, to copy the contents of the document to the clipboard.
5) Click inside the blank document created in step 1. Go to **Edit > Paste**, or press **Ctrl+V**, to paste the contents from the old document into the new one.
6) Update the table of contents, if there is one. Close the old file without saving. Go to **File > Save As** to save the new file with the name of the file from which content was taken. When asked, confirm that you want to overwrite the old file. You may prefer to save the new file under a new name and preserve the old file under its original name.
Caution

Any changes recorded (tracked) in the document will be lost during this process. The resulting document will contain only the changed text.

Organizing templates

LibreOffice can use only those templates that are in its template folders or categories. You can create new template categories and use them to organize your templates. For example, you might have one template category for report templates and another for letter templates. You can also import and export templates.

To begin, choose File > Templates > Manage Templates to open the Templates dialog.

Creating a template category

To create a template category:

1) Click the Action button of the Templates dialog.
2) Click New category on the context menu (see Figure 12).
3) In the pop-up dialog, type a name for the new category and click OK.

![Figure 12: Creating a new category](image)

Note

You cannot create a sub-category inside a template category in LibreOffice.

Deleting a template category

You cannot delete template categories supplied with LibreOffice. Nor can you delete any categories added by the Extension Manager unless you first delete the extension that installed them.

However, you can delete a category that you created. Select it and click the Delete button. When a message box appears asking you to confirm the deletion, click Yes.

Moving a template

To move a template from one template category to another, select it in the Templates dialog, and click the Move button in the bottom center of the dialog (see Figure 13). In the popup dialog, select the required category and click OK.
Deleting a template

You cannot delete templates supplied with LibreOffice. Nor can you delete any templates installed by the Extension Manager except by deleting the extension that installed them.

However, you can delete templates that you have created or imported:

1) In the Templates dialog, select the category that contains the template you want to delete.
2) Select the template to delete.
3) Right-click to open the context menu of the template and click Delete (Figure 7). A message box appears and asks you to confirm the deletion. Click Yes.

Importing a template

Before you can use a template in LibreOffice, it must be in one of the folders listed for the Template path in Tools > Options > LibreOffice > Paths:

1) In the Templates dialog, click the Import button on the bottom right. The Select Category dialog appears.
2) Find and select the category where you want to import the template and click OK. A standard file browser window opens.
3) Find and select the template that you want to import and click Open. The file browser window closes and the template appears in the selected category.

Exporting a template

To export a template from a template category to another location in your computer or network:

1) In the Templates dialog, locate the category that contains the template to export.
2) Select the template that you want to export.
3) Click the Export button in the bottom right of the dialog. The Save As window opens.
4) Find the folder into which you want to export the template and select Save.
Examples of style use

The following examples of common use of page and paragraph styles are taken from Writer. There are many other ways to use styles; see the guides for the various components for details.

Defining a different first page for a document

Many documents, such as letters and reports, have a first page that is different from the other pages in the document. For example, the first page of a letterhead typically has a different header, or the first page of a report might have no header or footer, while the other pages do. With LibreOffice, you can define the page style for the first page and specify the style for the following pages to be applied automatically.

As an example, we can use the First Page and Default page styles that come with LibreOffice. Figure 14 shows what we want to happen: the first page is to be followed by the default page, and all the following pages are to be in the Default page style. Details are in Chapter 4, Formatting Pages, in the Writer Guide.

![Figure 14: Flow of page styles](image)

Dividing a document into chapters

In a similar way, you can divide a document into chapters. Each chapter might start with the First Page style, with the following pages using the Default page style, as above. At the end of the chapter, insert a manual page break and specify the next page to have the First Page style to start the next chapter, as shown in Figure 15.

![Figure 15: Dividing a document into chapters using page styles](image)

Changing page orientation within a document

A Writer document can contain pages in more than one orientation. A common scenario is to have a landscape page in the middle of a document, whereas the other pages are in a portrait orientation. This setup can also be created with page breaks and page styles.

To insert a landscape page in the middle of your document, insert a page break and select a page style with the landscape orientation on. LibreOffice default landscape page style is Landscape. You may have to adjust the other page properties such as headers, footers, and page numbering of the landscape style. To go back to the portrait page style, insert another page break and select the default portrait page style of your document.
Displaying different headers on right and left pages

Page styles can be set up to have the facing left and right pages mirrored or only right (first pages of chapters are often defined to be right-page only) or only left. When you insert a header on a page style set up for mirrored pages or right-and-left pages, you can have the contents of the header be the same on all pages or be different on the right and left pages. For example, you can put the page number on the left-hand edge of the left pages and on the right-hand edge of the right pages, put the document title on the right-hand page only, or make other changes.

Controlling page breaks automatically

Writer automatically flows text from one page to the next. If you do not like the default settings, you can change them. For example, you can require a paragraph to start on a new page or column and specify the style of the new page. A typical use is for chapter titles to always start on a new right-hand (odd-numbered) page.

Compiling an automatic table of contents

To compile an automatic table of contents, first apply styles to the headings you want to appear in the contents list, then use Tools > Outline Numbering to tell Writer which styles go with which level in the table of contents. By default, tables of contents use Heading styles, but you can use whatever combination of styles you prefer. See Chapter 4 for more information.

Defining a sequence of paragraph styles

You can set up one paragraph style so that when you press Enter at the end of that paragraph, the following paragraph automatically has the style you wish applied to it. For example, you could define a Heading 1 paragraph to be followed by a Text Body paragraph. A more complex example would be: Title followed by Author followed by Abstract followed by Heading 1 followed by Text Body. By setting up these sequences, you can usually avoid having to apply styles manually.

22 | Chapter 3 Using Styles and Templates