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What is Writer?

Writer is the word processor component of LibreOffice. In addition to the usual features of a word 
processor (spelling check, thesaurus, hyphenation, autocorrect, find and replace, automatic 
generation of tables of contents and indexes, mail merge and others), Writer provides these 
important features:

• Templates and styles (see Chapter 3)

• Page layout methods, including frames, columns, and tables

• Automated tables of contents and indexes

• Embedding or linking of graphics, spreadsheets, and other objects

• Built-in drawing tools

• Master documents—to group a collection of documents into a single document

• Change tracking during revisions

• Database integration, including a bibliography database

• Mail merge

• Export to PDF, including bookmarks (see Chapter 10)

• Document digital signature

• Form design and filling

• And many more

These features are covered in detail in the Writer Guide.

The Writer interface

The main Writer workspace is shown in Figure 1. The menus and toolbars are described in 
Chapter 1, Introducing LibreOffice. Some other features of the Writer interface are covered in this 
chapter.

Figure 1: The main Writer workspace
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Status Bar
The Writer Status Bar provides information about the document and convenient ways to change 
some document features quickly.

Figure 2: Left end of Status Bar

Figure 3: Right end of Status Bar

Page number
Shows the current page number, the sequence number of the current page (if different), and 
the total number of pages in the document. For example, if you restarted page numbering at 
1 on the third page, its page number is 1 and its sequence number is 3.

If any bookmarks have been defined in the document, a right-click on this field pops up a list 
of bookmarks; click on the required one.

To jump to a specific page in the document, double-click on this field. The Navigator opens. 
Click in the Page Number field and type the sequence number of the required page and 
press Enter.

Word and character count 
The word and character count of the document is shown in the Status Bar, and is kept up to 
date as you edit. Any text selected in the document will be counted and this count will replace 
the displayed count.

To display extended statistics such as character counts excluding spaces, double-click the 
word count in the Status Bar, or choose Tools > Word Count.

You can also see the number of words and characters (and other information including the 
number of pages, tables, and graphics) in the entire document in File > Properties > 
Statistics.

Page style
Shows the style of the current page. To change the page style, right-click on this field. A list of 
page styles pops up; choose a different style by clicking on it.

To edit the current page style, double-click on this field. The Page Style dialog opens.

Language
Shows the language at the cursor position, or for the selected text, that is used for checking 
spelling and for hyphenation and thesaurus.
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Click to open a menu where you can choose another language for the selected text or for the 
paragraph where the cursor is located. You can also choose None (Do not check spelling) 
to exclude the text from a spelling check or choose More to open the Character dialog. Any 
directly formatted language settings can be reset to the default language from this menu.

Insert mode
This area is blank when in Insert mode. Click to change to Overwrite mode; click again to 
return to Insert mode. In Insert mode, any text after the cursor position moves forward to 
make room for the text you type; in Overwrite mode, text after the cursor position is replaced 
by the text you type. This feature is disabled when in Record Changes mode.

Selection mode
Click to choose different selection modes. The icon does not change, but when you hover the 
mouse pointer over this field, a tooltip indicates which mode is active.

When you click in the field, a context menu displays the available options.

Mode Effect

Standard selection Click in the text where you want to position the cursor; click in a cell 
to make it the active cell. Any other selection is deselected.

Extending selection (F8) Clicking in the text extends or crops the current selection.

Adding selection (Shift+F8) A new selection is added to an existing selection. The result is a 
multiple selection.

Block selection 
(Ctrl+Shift+F8)

A block of text can be selected.

On Windows systems, you can hold down the Alt key while dragging to select a block of text. 
You do not need to enter the block selection mode.

Document changes status
The icon that is displayed here changes from this one ( ) if the document has no unsaved 
changes, to this one ( ) if it has been edited and the changes have not been saved. Click 
on the unsaved changes icon to save the document.

Digital signature
If the document has been digitally signed, this icon ( ) is displayed here; otherwise, it is 
blank. To sign the document, or to view the certificate, click the icon.

Section or object information
When the cursor is on a section, heading, or list item, or when an object (such as a picture or 
table) is selected, information about that item appears in this field. Double-clicking in this 
area opens a relevant dialog. For details, consult the Help or the Writer Guide.

View layout
Click an icon to change between single page, side-by-side, and book layout views. The effect 
varies with the combination of window width and zoom factor in use. You can edit the 
document in any view. See Figure 4.

Zoom
To change the view magnification, drag the Zoom slider, or click on the + and – signs, or 
right-click on the zoom level percent to pop up a list of magnification values from which to 
choose. Zoom interacts with the selected view layout to determine how many pages are 
visible in the document window.
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Figure 4: View layouts: single, side-by-side, book.

Sidebar
The Sidebar (Figure 5) is normally open by default on the right side of the Writer window. If 
necessary, select View > Sidebar from the Menu bar to display it. The Sidebar also has a 
Hide/Show button.

Figure 5: Properties panel of Sidebar in Writer

The Writer Sidebar contains four decks by default: Properties, Styles and Formatting, Gallery, and 
Navigator. If you have selected Enable experimental features in Tools > Options > LibreOffice 
> Advanced, a fifth deck (Manage Changes) will appear, and a sixth (Design) can be selected in 
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Sidebar Settings > Customization. Each deck has a corresponding icon on the Tab bar to the 
right of the sidebar, allowing you to switch between them.

Each deck consists of a title bar and one or more content panels. Toolbars and sidebar panels 
share many functions. For example, the buttons for making text bold or italic exist in both the 
Formatting toolbar and the Character panel of the Properties deck.

Some panels contain a More Options button ( ), which opens a dialog to give greater choice of 

editing controls. The dialog that opens locks the document for editing until the dialog is closed.

The decks are described below.

• Properties: Contains tools for direct formatting within the document. The tools are 
separated into four panels for text editing:

– Styles: Apply a paragraph style at the cursor position. Create or update a style.

– Character: Modify text by the font type, size, color, weight, style and spacing.

– Paragraph: Style the paragraph by alignment, lists or bullets, background color, indent, 
and spacing.

– Page: Format the page by orientation, margin, size, and number of columns.

If a graphic is selected, then the following panels open:

– Area: Modify the graphic background area fill mode and transparency.

– Graphic: Modify the graphic’s brightness, contrast, color mode and transparency.

– Position: Modifications to width and height.

– Wrap: Permits wrap modifications where these are available.

If a drawing object is selected, then the following panels are available:

– Area: Fill and transparency edits are available.

– Line: Permits edits to the line style, width, color, arrows, corners, and cap styles.

– Position and Size: Enables edits to width, height, rotation, and flip attributes.

If a frame is selected, then the wrap panel opens but may be grayed-out if frame wrap is 
not available.

Caution
Be aware that by changing the options on the Page panel, you will change the page style 
in use, modifying not only the current page but all pages using the same page style.

• Styles and Formatting: Manage the styles used in the document, apply existing styles, 
create new ones or modify them.

• Gallery: Add images and diagrams included in the Gallery themes. The Gallery displays as 
two sections; the first lists the themes by name (Arrows, Background, Diagrams, etc.) and 
the second displays the images in the selected category. Select the New Theme button to 
create new categories. To insert an image into a file, or add a new image to the new 
category, drag and drop the selected image.

• Navigator: Browse the document and reorganize its content by selecting different content 
categories, such as headings, tables, frames, graphics, etc. This deck is similar to the 
floating toolbar that can be opened from View > Navigator on the Menu bar or the 
Navigator button on the Standard Toolbar. However, the Sidebar Navigator does not 
contain a List Box On/Off button.
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• Manage Changes: Lists all changes done in the document since the Track Changes mode 
was activated. This deck is an alternate view of the Manage Changes dialog that can be 
opened from Edit > Track Changes > Manage Changes on the Menu bar. This tab is 
available only when Enable experimental features has been selected in Tools > Options 
> LibreOffice > Advanced.

• Design: Provides quick access to themes (fonts and colors) and style presets. This deck is 
available only when Experimental Features is enabled in Tools > Options > LibreOffice > 
Advanced and when the deck is selected in Sidebar Settings > Customization.

Changing document views

Writer has three ways to view a document: Normal, Web, and Full Screen. To change the view, go 
to the View menu and click on the required view. (When in Full Screen view, press the Esc key to 
return to either Normal or Web view.)

You can also choose View > Zoom > Zoom from the menu bar to display the Zoom & View Layout 
dialog, where you can set the same options as on the Status Bar.

Normal (previously called Print Layout) is the default view in Writer. In this view, you can use the 
Zoom slider and the View Layout icons on the Status bar to change the magnification.

In Web Layout view, you can use only the Zoom slider; the View Layout buttons on the Status bar 
are disabled, and most of the choices on the Zoom & View Layout dialog are not available. In Web 
layout there is no visual indication of page boundaries.

In Full Screen view, the document is displayed using the zoom and layout settings previously 
selected. To exit Full Screen view and return to either Normal or Web view, press the Esc key or 
toggle the Full Screen button on the floating toolbar in the top left-hand corner. You can also use 
Ctrl+Shift+J to enter or exit Full Screen view.

In Normal view, you can hide or show the headers and footers and the gap between pages. To do 
this, choose View > Hide Whitespace from the Menu bar. A checkmark will appear next to the 
option. Once this option is activated, white space is also hidden in Full Screen view.

Moving quickly through a document

In addition to the navigation features of the Status Bar (described above), you can use the 
Navigator window and the Navigation toolbar, either from the Standard toolbar or from the Sidebar, 
as described in Chapter 1, Introducing LibreOffice.

The Navigation toolbar (Figure 6) shows buttons for all the object types shown in the Navigator, 
plus some extras (for example, the Find command).

Figure 6: Navigation toolbar

Click a button to select that object type. Now the Previous and Next buttons (in the Navigator 
itself, in the Navigation Toolbar, and on the Find toolbar) will jump to the previous or next object of 
the selected type. This is particularly helpful for finding items like index entries, which can be 
difficult to see in the text. The names of the buttons (shown in the tooltips) change to match the 
selected category; for example, Next Graphic, Next Bookmark, or Continue search forward.

For more uses of the Navigator in Writer, see the Writer Guide.
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Working with documents

Chapter 1, Introducing LibreOffice, includes instructions on starting new documents, opening 
existing documents, saving documents, accessing remote servers, and password-protecting 
documents. Chapter 3, Using Styles and Templates, covers how to create a document from a 
template.

By default, LibreOffice loads and saves files in the OpenDocument file format (ODF), a 
standardized file format (ISO-IEC 26300) used by many software applications. Writer documents 
have the extension .ODT.

Tip 
Wherever choice of the document file format is possible, choose the default ODF 
format when working with LibreOffice.

Saving as a Microsoft Word file
If you need to exchange documents with users of Microsoft Word who are unwilling or unable to 
receive .ODT files, you can open, edit, and save documents in Microsoft Word formats.

You can also create and edit .ODT files and then save them as .DOC or .DOCX files. To do this:

 1) Important—First save your document in the file format used by LibreOffice Writer (.ODT). If 
you do not, any changes you made since the last time you saved will appear only in the 
Microsoft Word version of the document.

 2) Then choose File > Save As. 

 3) On the Save As dialog, in the File type (or Save as type) drop-down menu, select the type 
of Word format you need. You may also choose to change the file name.

 4) Click Save.

From this point on, all changes you make to the document will occur only in the new document. 
You have changed the name and file type of your document. If you want to go back to working with 
the ODT version of your document, you must open it again.

Tip
Saving in ODF format gives you the option to redo the document if the recipient of your 
document experiences trouble with the Microsoft format.

Tip
To have Writer save documents by default in the Microsoft Word file format, go to 
Tools > Options > Load/Save > General. In the section named Default file format 
and ODF settings, under Document type, select Text document, then under Always 
save as, select your preferred file format.

Using built-in language tools

Writer provides some tools that make your work easier if you mix multiple languages within the 
same document or if you write documents in various languages.

The main advantage of changing the language for a text selection is that you can then use the 
correct dictionaries to check spelling and apply the localized versions of Autocorrect replacement 
tables, thesaurus, grammar, and hyphenation rules.
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You can also set the language for a paragraph or a group of characters as None (Do not check 
spelling). This option is especially useful when you insert text such as web addresses or 
programming language snippets that you do not want to check for spelling.

Specifying the language in character and paragraph styles can be problematic unless you use a 
particular style for a different language. Changing the Language on the Font tab of the Paragraph 
Styles dialog, will change the language for all paragraphs that use that paragraph style. You can 
set certain paragraphs to be checked in a language that is different from the language of the rest of 
the document by putting the cursor in the paragraph and changing the language on the Status Bar. 
See Chapter 9, Working with Styles, in the Writer Guide for information on how to manage the 
language settings of a style.

You can also set the language for the whole document, for individual paragraphs, or even for 
individual words and characters, from Tools > Language on the Menu bar.

Another way to change the language of a whole document is to use Tools > Options > Language 
Settings > Languages. In the Default languages for documents section, you can choose a 
different language for all the text that is not explicitly marked as a different language.

The spelling checker works only for those languages in the list that have the symbol ( ) next to 
them. If you do not see the symbol next to your preferred language, you can install the additional 
dictionary using Tools > Language > More Dictionaries Online.

The language used for checking spelling is also shown in the Status Bar, next to the page style in 
use.

Working with text

Working with text (selecting, copying, pasting, moving) in Writer is similar to working with text in 
any other program. LibreOffice also has some convenient ways to select items that are not next to 
each other, select a vertical block of text, and paste unformatted text.

Selecting items that are not consecutive
To select nonconsecutive items (as shown in Figure 7) using the mouse:

 1) Select the first piece of text.

 2) Hold down the Ctrl key and use the mouse to select the next piece of text.

 3) Repeat as often as needed.

To select nonconsecutive items using the keyboard:

 1) Select the first piece of text. (For more information about keyboard selection of text, see the 
topic “Navigating and selecting with the keyboard” in the LibreOffice Help (F1).)

 2) Press Shift+F8. This puts Writer in “Adding selection” mode.

 3) Use the arrow keys to move to the start of the next piece of text to be selected. Hold down 
the Shift key and select the next piece of text.

 4) Repeat as often as required.

Now you can work with the selected text (copy it, delete it, change the style, and so on).

Press Esc to exit from this mode.
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Figure 7: Selecting items that are not next to each other

Selecting a vertical block of text
You can select a vertical block or “column” of text that is separated by spaces or tabs (as you might 
see in text pasted from e-mails, program listings, or other sources), using LibreOffice’s block 
selection mode. To change to block selection mode, use Edit > Selection Mode > Block Area, or 
press Ctrl+F8, or click on the Selection icon in the Status Bar and select Block selection from the 
list.

Figure 8: Selection icon

Now highlight the selection, using mouse or keyboard, as shown below.

Figure 9: Selecting a vertical block of text

Cutting, copying, and pasting text
Cutting and copying text in Writer is similar to cutting and copying text in other applications. You 
can use the mouse or the keyboard for these operations. You can copy or move text within a 
document, or between documents, by dragging or by using menu selections, toolbar buttons, or 
keyboard shortcuts. You can also copy text from other sources such as Web pages and paste it 
into a Writer document.

To move (drag and drop) selected text using the mouse, drag it to the new location and release it. 
To copy selected text, hold down the Ctrl key while dragging. The text retains the formatting it had 
before dragging.

To move (cut and paste) selected text, use Ctrl+X to cut the text, insert the cursor at the paste-in 
point and use Ctrl+V to paste. Alternatively, use the buttons on the Standard toolbar.
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When you paste text, the result depends on the source of the text and how you paste it. If you click 
on the Paste button, any formatting the text has (such as bold or italics) is retained. Text pasted 
from Web sites and other sources may also be placed into frames or tables. If you do not like the 
results, click the Undo button or press Ctrl+Z.

To make the pasted text inherit the paragraph style at the insertion point:

• Choose Edit > Paste Special, or

• Click the arrow button of the combination Paste button, or

• Click the Paste button without releasing the left mouse button.

Then select Unformatted text from the resulting menu.

The range of choices on the Paste Special menu varies depending on the origin and formatting of 
the text (or other object) to be pasted. See Figure 10 for an example with text on the clipboard.

Figure 10: Paste Special menu

Finding and replacing text and formatting
Writer has two ways to find text within a document: the Find toolbar for fast searching and the Find 
& Replace dialog. In the dialog, you can:

• Find and replace words and phrases

• Use wildcards and regular expressions to fine-tune a search

• Find and replace specific attributes or formatting

• Find and replace paragraph styles

Using the Find toolbar
By default, the Find toolbar is shown docked at the bottom of the LibreOffice window (just above 
the Status Bar) in Figure 11, but you can float it or dock it in another location. If the Find toolbar is 
not visible, you can display it by choosing View > Toolbars > Find from the Menu bar or by 
pressing Ctrl+F. For more information on floating and docking toolbars, see Chapter 1, Introducing 
LibreOffice.

Figure 11: Docked position of Find toolbar

To use the Find toolbar, click in the box and type your search text, then press Enter to find the next 
occurrence of that term from the current cursor position. Click the Find Next or Find Previous 
buttons as needed.
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Click the Find All button to select all instances of the search term within the document. Select 
Match Case to find only the instances that exactly match the search term. Select the button to the 

right of Match Case ( ) to open the Find & Replace dialog.

Click the Navigate by button to open the Navigator and the Navigation toolbar, which are 
described in “Moving quickly through a document” on page 10.

To close the Find toolbar, click the X button on the left, or press Esc on the keyboard when the text 
cursor is in the search box. Ctrl+F toggles the Find toolbar off and on.

Using the Find & Replace dialog
To display the Find & Replace dialog, use the keyboard shortcut Ctrl+H or choose Edit > Find & 

Replace from the Menu bar. If the Find toolbar is open, click the Find & Replace button ( ) on 

the toolbar. When the dialog is open, optionally click Other Options to expand it. Click the button 
again to reduce the dialog options.

Figure 12: Expanded Find & Replace dialog

To use the Find & Replace dialog:

 1) Type the text you want to find in the Find box.

 2) To replace the text with different text, type the new text in the Replace box.

 3) You can select various options such as matching the case, matching whole words only, or 
doing a search for similar words.

The other options include searching only in selected text, searching from the current cursor 
position backwards toward the beginning of the file, searching for similar words, and 
searching in comments.

 4) When you have set up your search, click Find Next. To replace the found text, click 
Replace.

For more information on using Find & Replace, see the Writer Guide.
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Tip
If you click Find All, LibreOffice selects all instances of the search text in the 
document. Similarly, if you click Replace All, LibreOffice replaces all matches, without 
stopping for you to accept each instance.

Caution
Use Replace All with caution; otherwise, you may end up with some highly 
embarrassing (and often hilarious) mistakes. A mistake with Replace All might require 
a manual, word-by-word, search to fix.

Inserting special characters
A special character is one not found on a standard user’s keyboard. For example, © ¾ æ ç ñ ö ø ¢ 
are all special characters not available on an English keyboard. To insert a special character:

 1) Place the cursor where you want the character to appear.

 2) Choose Insert > Special Character or click on the Special Character icon in the main 
toolbar to open the Special Characters dialog.

 3) Select the characters (from any font or mixture of fonts) you wish to insert, in order, then 
click OK. The characters selected for insertion are shown in the lower left of the dialog. As 
you select a character, it is shown on the right, along with its numerical code.

Tip
Different fonts include different special characters. If you do not find a particular 
special character, try changing the Font selection.

Figure 13: The Special Characters dialog, where you can insert special characters
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Inserting dashes and non-breaking spaces and hyphens
To prevent two words from being separated at the end of a line, press Ctrl+Shift when you type the 
space between the two words. This inserts a non-breaking space.

In cases where you do not want the hyphen to appear at the end of a line, for example in a number 
such as 123-4567, you can press Shift+Ctrl+minus sign to insert a non-breaking hyphen.

To enter en and em dashes, you can use the Replace dashes option on the Options tab under 
Tools > AutoCorrect Options. This option replaces two hyphens, under certain conditions, with 
the corresponding dash.

– is an en-dash; that is, a dash the width of the letter “n” in the font you are using. Type at least 
one character, a space, one or two hyphens, another space, and at least one more letter. The 
one or two hyphens will be replaced by an en-dash.

— is an em-dash; that is, a dash the width of the letter “m” in the font you are using. Type at least 
one character, two hyphens, and at least one more character. The two hyphens will be 
replaced by an em-dash. Exception: if the characters are numbers, as in a date or time range, 
the two hyphens are replaced by an en-dash.

See the Help for more details. For other methods of inserting dashes, see Chapter 3, Working with 
Text: Basics in the Writer Guide.

Checking spelling and grammar
Writer provides a spelling checker, which checks to see if each word in the document is in the 
installed dictionary. Also provided is a grammar checker, which can be used separately or in 
combination with the spelling checker.

Automatic Spell Checking (found on the Tools menu) checks each word as it is typed and 
displays a wavy red line under any unrecognized words. Right-click on an unrecognized word to 
open a context menu. You can click on one of the suggested words to replace the underlined word 
with the one selected. If the list does not contain the word you want, click Spelling and Grammar 
to open a dialog. When the word is corrected, the line disappears.

To perform a combined spelling and grammar check on the document (or a text selection), click the 
Spelling and Grammar button on the Standard toolbar, or choose Tools > Spelling and 
Grammar. This checks the document or selection and opens the Spelling and Grammar dialog if 
any unrecognized words are found. In order to use this, the appropriate dictionaries must be 
installed. By default, four dictionaries are installed: a spelling checker, a grammar checker, a 
hyphenation dictionary, and a thesaurus.

Here are some more features of the spelling checker:

• You can change the dictionary language (for example, Spanish, French or German) on the 
Spelling and Grammar dialog.

• You can add a word to the dictionary. Click Add to Dictionary in the Spelling and Grammar 
dialog or in the context menu.

• Click the Options button on the Spelling and Grammar dialog to open a dialog similar to 
the one in Tools > Options > Language Settings > Writing Aids described in Chapter 2. 
There you can choose whether to check uppercase words and words with numbers, and 
you can manage custom dictionaries, that is, add or delete dictionaries and add or delete 
words in a dictionary.

• You can set paragraphs to be checked in a specific language (different from the rest of the 
document) using several methods, for example by clicking on the Text Language field on 
the Status Bar. See Chapter 9, Working with Styles, in the Writer Guide for more 
information.
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• You can select additional grammar checking rules through Tools > Options > Language 
Settings > English sentence checking, or through Tools > Extension Manager > 
English spelling dictionaries > Options.

See Chapter 3, Working with Text: Basics, in the Writer Guide for a detailed explanation of the 
spelling and grammar checking facility.

Using synonyms and the thesaurus
To access a short list of synonyms, right-click on a word and point to Synonyms on the context 
menu.  A submenu of alternative words and phrases is displayed. Click on a word or phrase in the 
submenu to have it replace the highlighted word or phrase in the document.

The thesaurus gives a more extensive list of alternative words and phrases. To use the thesaurus, 
click on Thesaurus from the Synonyms submenu. If the current language does not have a 
thesaurus installed, this feature is disabled.

Note
Thesaurus and synonyms are writing aids provided by language communities. If these 
aids are not available for your language, consider joining the LibreOffice project to help 
your language community get one.

Using AutoCorrect
Writer’s AutoCorrect function has a long list of common misspellings and typing errors, which it 
corrects automatically. For example, “hte” will be changed to “the”. It also includes codes for 
inserting special characters, emoji, and other symbols.

AutoCorrect is turned on when Writer is installed. You may wish to disable some of its features, 
modify others, or turn it off completely.

You can add your own corrections or special characters or change those supplied with LibreOffice. 
Choose Tools > AutoCorrect > AutoCorrect Options to open the AutoCorrect dialog. On the 
Replace tab, you can define which strings of text are corrected and how. In most cases, the 
defaults are fine.

To stop Writer replacing a specific spelling, go to the Replace tab, highlight the word pair, and click 
Delete. To add a new spelling to the list, type it into the Replace and With boxes on the Replace 
tab, and click New.

See the different tabs of the dialog for the wide variety of other options available to fine-tune 
AutoCorrect.

To turn AutoCorrect off, uncheck Tools > AutoCorrect > While Typing.

Tip
AutoCorrect can be used as a quick way to insert special characters. For example, (c) 
will be changed to ©. You can add your own special characters.

LibreOffice has an extensive list of special characters accessible with AutoCorrect. For 
example, type :smiling: and AutoCorrect will replace it by ☺.

Using Word Completion
If Word Completion is enabled, Writer tries to guess which word you are typing and offers to 
complete the word for you. To accept the suggestion, press Enter. Otherwise, continue typing.

To turn off Word Completion, select Tools > AutoCorrect > AutoCorrect Options > Word 
Completion and deselect Enable word completion.
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You can customize word completion from the Word Completion page of the AutoCorrect dialog:

• Add (append) a space automatically after an accepted word.

• Show the suggested word as a tip (hovering over the word) rather than completing the text 
as you type.

• Collect words when working on a document, and then either save them for later use in 
other documents or select the option to remove them from the list when closing the 
document.

• Change the maximum number of words remembered for word completion and the length of 
the smallest words to be remembered.

• Delete specific entries from the word completion list.

• Change the key that accepts a suggested entry—the options are right arrow, End key, 
Return (Enter), Space bar, and Tab.

Note
Automatic word completion only occurs after you type a word for the second time in a 
document.

Using AutoText
Use AutoText to store text, tables, fields, and other items for reuse and assign them to a key 
combination for easy retrieval. For example, rather than typing “Senior Management” every time 
you use that phrase, you can set up an AutoText entry to insert those words when you type “sm” 
and press F3.

AutoText is especially powerful when assigned to fields. See Chapter 16, Working with Fields, in 
the Writer Guide for more information.

To store some text as AutoText:

 1) Type the text into your document.

 2) Select the text.

 3) Choose Tools > AutoText (or press Ctrl+F3).

 4) In the AutoText dialog, type a name for the AutoText in the Name box. Writer will suggest a 
one-letter shortcut, which you can change.

 5) Choose the category for the AutoText entry, for example My AutoText.

 6) Click the AutoText button at the bottom of the dialog and select from the menu either New 
(to have the AutoText retain specific formatting, no matter where it is inserted) or New (text 
only) (to have the AutoText take on the existing formatting around the insertion point).

 7) Click Close to return to your document.

 8) To insert AutoText, type the shortcut and press F3.

Tip
If the only option under the AutoText button is Import, either you have not entered a 
name for your AutoText or there is no text selected in the document.

For more about using AutoText, see Chapter 3, Working with Text: Basics in the Writer Guide.
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Formatting text

Using styles is recommended
Styles are central to using Writer. Styles enable you to easily format your document consistently, 
and to change the format with minimal effort. A style is a named set of formatting options. When 
you apply a style, you apply a whole group of formats at the same time. In addition, styles are used 
by LibreOffice for many processes, even if you are not aware of them. For example, Writer relies 
on heading styles (or other styles you specify) when it compiles a table of contents.

Caution
Manual formatting (also called direct formatting) overrides styles, and you cannot get 
rid of the manual formatting by applying a style to it.

Tip
To remove manual formatting, select the text and choose Format > Clear Direct 
Formatting from the Menu bar, or right-click and choose Clear Direct Formatting 
from the context menu, or click the Clear Direct Formatting button on the Formatting 
toolbar, or use Ctrl+M from the keyboard.

Note
When clearing direct formatting, the text formatting will return to the applied paragraph 
style and not the default paragraph style.

Writer defines several types of styles, for different types of elements: characters, paragraphs, 
pages, frames, and lists. See Chapter 3, Using Styles and Templates, in this book and Chapters 8 
and 9 in the Writer Guide.

Formatting paragraphs
You can apply many formats to paragraphs using the buttons on the Formatting toolbar and by 
using the Paragraph panel of the Sidebar’s Properties deck. Not all buttons are visible in a 
standard installation, but you can customize the toolbar to include those you use regularly. These 
buttons and formats include:

• Apply Style

• Bullets On/Off (with a palette of bullet styles)

• Numbering On/Off (with a palette of numbering styles)

• Align Left, Center Horizontally, Align Right, or Justified

• Align Top, Center Vertically, Align Bottom

• Line Spacing (choose from 1, 1.15, 1.5, 2, or custom spacing

• Increase Paragraph Spacing, Decrease Paragraph Spacing

• Increase Indent, Decrease Indent

• Paragraph (to open the Paragraph dialog)

Formatting characters
You can apply many formats to characters using the buttons on the Formatting toolbar and by 
using the Character panel of the Sidebar’s Properties deck. Not all buttons are visible in a standard 
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installation, but you can customize the toolbar to include those you use regularly. These buttons 
and formats include:

• Font Name, Font Size

• Bold, Italic, Underline, Double Underline, Overline, Strikethrough, Outline

• Superscript, Subscript

• Uppercase, Lowercase

• Increase Font Size, Decrease Font Size

• Font Color (with a palette of colors)

• Background Color (with a palette of colors)

• Highlighting (with a palette of colors)

• Character (to open the Character dialog)

Autoformatting
You can set Writer to format parts of a document automatically according to the choices made on 
the Options page of the AutoCorrect dialog (Tools > AutoCorrect > AutoCorrect Options).

Tip
If you notice unexpected formatting changes occurring in your document, this is the 
first place to look for the cause. In most cases Undo (Ctrl+Z) fixes the issue.

The Help describes each of these choices and how to activate the autoformats. Some common 
unwanted or unexpected formatting changes include:

• Horizontal lines. If you type three or more hyphens (---), underscores (___) or equal signs 
(===) on a line and then press Enter, the paragraph is replaced by a horizontal line as wide 
as the column in the page. The line is actually the lower border of the preceding paragraph.

• Bulleted and numbered lists. A bulleted list is created when you type a hyphen (-), star (*), 
or plus sign (+), followed by a space or tab at the beginning of a paragraph. A numbered list 
is created when you type a number followed by a period (.), followed by a space or tab at 
the beginning of a paragraph. Automatic numbering is only applied to paragraphs formatted 
with the Default, Text body or Text body indent paragraph styles.

To turn autoformatting on or off, choose Format > AutoCorrect and select or deselect the items on 
the list.

Creating numbered or bulleted lists
There are several ways to create numbered or bulleted lists:

• Use autoformatting, as described above.

• Use list (numbering) styles, as described in Chapter 8, Introduction to Styles, and Chapter 
9, Working with Styles, in the Writer Guide.

• Use the Numbering and Bullets buttons on the Formatting toolbar or on the Paragraph 
panel of the Sidebar’s Properties deck: select the paragraphs for the list, and then click the 
appropriate button on the toolbar or in the Sidebar.

Note
It is a matter of personal preference whether you type your information first, then apply 
numbering/bullets, or apply them as you type.
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Using the Bullets and Numbering toolbar
You can create nested lists (where one or more list items has a sub-list under it, as in an outline) 
by using the buttons on the Bullets and Numbering toolbar (Figure 14). You can move items up or 
down the list, create sub-points, change the style of bullets, and access the Bullets and Numbering 
dialog, which contains more detailed controls. Use View > Toolbars > Bullets and Numbering to 
see the toolbar.

Note

If numbering or bullets are being applied automatically in a way that you find 
inappropriate, you can switch them off temporarily by unchecking Format > 
AutoCorrect > While Typing.

1 Promote One Level 5 Insert Unnumbered 
Entry

8 Move Up with Subpoints

2 Demote One Level 9 Move Down with Subpoints

3 Promote One Level with 
Subpoints

6 Move Up 10 Restart Numbering

4 Demote One Level with 
Subpoints

7 Move Down 11 Bullets and Numbering

Figure 14: Bullets and Numbering toolbar

Using the Sidebar for Bullets and Numbering
The Bullets and Numbering features (drop-down palettes of tools) on the Paragraph panel on the 
Properties deck of the Sidebar can also be used to create nested lists and access the Bullets and 
Numbering dialog. However, the Sidebar does not include tools for promoting and demoting items 
in the list, as found on the Bullets and Numbering toolbar.

Setting tab stops and indents
The horizontal ruler shows the tab stops. Any tab stops that you have defined will overwrite the 
default tab stops. Tab settings affect indentation of full paragraphs (using the Increase Indent and 
Decrease Indent buttons on the Formatting toolbar) as well as indentation of parts of a paragraph 
(by pressing the Tab key on the keyboard).

Using the default tab spacing can cause formatting problems if you share documents with other 
people. If you use the default tab spacing and then send the document to someone else who has 
chosen a different default tab spacing, tabbed material will change to use the other person’s 
settings. Instead of using the defaults, define your own tab settings, as described in this section.

To define indents and tab settings for one or more selected paragraphs, double-click on a part of 
the ruler that is not between the left and right indent icons to open the Indents & Spacing page of 
the Paragraph dialog. Double-click anywhere between the left and right indent icons on the ruler to 
open the Tabs page of the Paragraph dialog.

A better strategy is to define tabs for the paragraph style. See Chapters 8 and 9 in the Writer 
Guide for more information.
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Tip
Using tabs to space out material on a page is not recommended. Depending on what 
you are trying to accomplish, a table is usually a better choice.

Changing the default tab stop interval

Caution
Any changes to the default tab setting will affect the existing default tab stops in any 
document you open afterward, as well as tab stops you insert after making the 
change.

To set the measurement unit and the spacing of default tab stop intervals, go to Tools > Options > 
LibreOffice Writer > General.

Figure 15: Selecting a default tab stop interval

You can also set or change the measurement unit for rulers in the current document by right-
clicking on the ruler to open a list of units. Click on one of them to change the ruler to that unit. The 
selected setting applies only to that ruler.

Figure 16: Changing the measurement unit for a ruler

Hyphenating words
You have several choices regarding hyphenation: let Writer do it automatically (using its 
hyphenation dictionaries), insert conditional hyphens manually where necessary, or don’t 
hyphenate at all.

Automatic hyphenation
To turn automatic hyphenation of words on or off:

 1) Click on the Styles and Formatting tab in the Sidebar to open the Styles and Formatting 
deck.

 2) On the Paragraph Styles page (Figure 17), right-click on Default Style and select Modify.

 3) On the Paragraph Style dialog (Figure 18), go to the Text Flow page.

 4) Under Hyphenation, select or deselect the Automatically option. Click OK to save.
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Figure 17: Modifying a style

Note
Turning on hyphenation for the paragraph Default Style affects all other paragraph 
styles that are based on Default Style. You can individually change other styles so that 
hyphenation is not active; for example, you might not want headings to be hyphenated. 
Any styles that are not based on Default Style are not affected. See Chapter 3, Using 
Styles and Templates, for more about styles based on other styles.

Figure 18: Turning on automatic hyphenation

You can also set hyphenation choices through Tools > Options > Language Settings > Writing 
Aids. In Options, near the bottom of the dialog, scroll down to find the hyphenation settings.

Figure 19: Setting hyphenation options

To change the minimum number of characters for hyphenation, or the minimum number of 
characters before or after a line break, select the item, and then click the Edit button in the Options 
section.

Hyphenation options set on the Writing Aids dialog are effective only if hyphenation is turned on 
through paragraph styles.
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Manual hyphenation
To manually hyphenate words, do not use a normal hyphen, which will remain visible even if the 
word is no longer at the end of a line when you add or delete text or change margins or font size. 
Instead, use a conditional hyphen, which is visible only when required.

To insert a conditional hyphen inside a word, click where you want the hyphen to appear and press 
Ctrl+hyphen or use Insert > Formatting Mark > Optional hyphen. The word will be hyphenated 
at this position when it is at the end of the line, even if automatic hyphenation for this paragraph is 
switched off.

Formatting pages

Writer provides several ways for you to control page layouts: page styles, columns, frames, tables, 
and sections. For more information, see Chapter 6, Formatting Pages, in the Writer Guide.

Tip
Page layout is usually easier if you show text, object, table, and section boundaries in 
Tools > Options > LibreOffice > Appearance, and paragraph ends, tabs, breaks, 
and other items in Tools > Options > LibreOffice Writer > Formatting Aids.

Creating headers and footers
A header is an area that appears at the top of a page above the margin. A footer appears at the 
bottom of the page below the margin. Information such as page numbers inserted into a header or 
footer displays on every page of the document with that page style.

Note
A header and a footer are properties of the page style. Set or unset headers and 
footers of all page styles in use in your document.

Inserting a header or footer
To insert a header, you can either:

• Choose Insert > Header and Footer > Header > Default Style (or some other page style, 
if not Default Style), or

• Click above the top margin to make the Header marker appear (Figure 20), and then click 
on the +. 

Figure 20: Header marker at top of text area

After a header has been created, a down-arrow appears on the header marker. Click on this arrow 
to drop down a menu of choices for working with the header (Figure 21).
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Figure 21: Header menu

To format a header, you can use either the menu item shown in Figure 21 or Format > Page > 
Header. Both methods take you to the same tab on the Page Style dialog.

Inserting header and footer contents
Other information such as document titles and chapter titles is often put into the header or footer. 
These items are best added as fields. That way, if something changes, the headers and footers are 
updated automatically. Here is one common example.

To insert the document title into the header:

 1) Choose File > Properties > Description and type a title for your document.

 2) Add a header (Insert > Header and Footer > Header > Default).

 3) Place the cursor in the header part of the page.

 4) Choose Insert > Fields > Title. The title should appear on a gray background (which does 
not show when printed and can be turned off).

 5) To change the title for the whole document, go back to File > Properties > Description.

Fields are covered in detail in Chapter 16, Working with Fields, in the Writer Guide.

For more about headers and footers, see Chapter 6, Formatting Pages, and Chapter 8, 
Introduction to Styles, in the Writer Guide.

Numbering pages

Displaying the page number
To display page numbers automatically:

 1) Insert a header or footer, as described in “Creating headers and footers” above.

 2) Place the cursor in the header or footer where you want the page number to appear and 
choose Insert > Page Number.

Including the total number of pages
To include the total number of pages (as in “page 1 of 12”):

 1) Type the word “page” and a space, then insert the page number as above.

 2) Press the space bar once, type the word “of” and a space, then choose Insert > Field > 
Page Count.

Note
The Page Count field inserts the total number of pages in the document, as shown on 
the Statistics tab of the document’s Properties window (File > Properties). If you 
restart page numbering anywhere in the document, then the total page count may not 
be what you want. See Chapter 6, Formatting Pages, in the Writer Guide for more 
information.
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Restarting page numbering
Often you will want to restart the page numbering at 1, for example on the page following a title 
page or a table of contents. In addition, many documents have the “front matter” (such as the table 
of contents) numbered with Roman numerals and the main body of the document numbered in 
Arabic numerals, starting with 1.

You can restart page numbering in two ways.

Method 1:

 1) Place the cursor in the first paragraph of the new page.

 2) Choose Format > Paragraph.

 3) On the Text Flow tab of the Paragraph dialog (Figure 18 on page 24), select Breaks.

 4) Select Insert and then With Page Style and specify the page style to use.

 5) Specify the page number to start from, and then click OK.

Tip
Method 1 is also useful for numbering the first page of a document with a page 
number greater than 1. For example, you may be writing a book, with each chapter in 
a separate file. Chapter 1 may start with page 1, but Chapter 2 could begin with page 
25 and Chapter 3 with page 51.

Method 2:

 1) Insert > Manual break.

 2) By default, Page break is selected on the Insert Break dialog (Figure 22).

 3) Choose the required page Style.

 4) Select Change page number.

 5) Specify the page number to start from, and then click OK.

Figure 22: Restarting page numbering after a manual page break
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Changing page margins
You can change page margins in three ways:

• Using the page rulers—quick and easy, but does not have fine control

• Using the Page Style dialog—can specify margins to two decimal places

• Using the Page panel on the Properties deck of the Sidebar

Caution
If you change the margins, the new margins affect the page style and will be shown in 
the Page Style dialog the next time you open it.

Because the page style is affected, the changed margins apply to all pages using that 
style.

To change margins using the rulers:

 1) The gray sections of the rulers are the margins. Put the mouse cursor over the line between 
the gray and white sections. The pointer turns into a double-headed arrow and displays the 
current setting in a tool-tip.

 2) Hold down the left mouse button and drag the mouse to move the margin.

Figure 23: Moving the margins

Caution
The small arrowheads (gray triangles) on the ruler are used for indenting paragraphs. 
They are often in the same place as the page margins, so you need to be careful to 
move the margin marker, not the arrows. The double-headed arrows shown in Figure 
23 are mouse cursors shown in the correct position for moving the margin markers.

To change margins using the Page Style dialog:

 1) Right-click anywhere in the text area on the page and select Page from the context menu.

 2) On the Page tab of the dialog, type the required distances in the Margins boxes.

To change margins using the Page panel of the Properties deck of the Sidebar:

 1) On the open Sidebar (View > Sidebar) select the Properties tab.

 2) Open the Page panel if is not open by clicking the plus (+) symbol in the panel title

 3) Click the Margin button to open the sub-panel and enter the required dimensions in the 
Custom size boxes (clicking the More Options button will open the Page Style dialog). 
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Adding comments to a document

Authors and reviewers often use comments to exchange ideas, ask for suggestions, or mark items 
needing attention.

You can select a contiguous block of text, which may be multiple paragraphs, for a comment; or 
you can select a single point at which the comment will be inserted.

To insert a comment, select the text, or place the cursor in the place the comment refers to, and 
choose Insert > Comment or press Ctrl+Alt+C. The anchor point of the comment is connected by 
a dotted line to a box on the right-hand side of the page where you can type the text of the 
comment. A Comments button is also added to the right of the horizontal ruler; you can click this 
button to toggle the display of the comments.

Writer automatically adds at the bottom of the comment the author’s name and a time stamp 
indicating when the comment was created. Figure 24 shows an example of text with comments 
from two different authors.

Figure 24: Example of comments

Choose Tools > Options > LibreOffice > User Data to configure the name you want to appear in 
the Author field of the comment, or to change it.

If more than one person edits the document, each author is automatically allocated a different 
background color. 

Right-click on a comment to open a context menu where you can delete the current comment, all 
the comments from the same author, or all the comments in the document. From this menu, you 
can also open a dialog to apply some basic formatting to the text of comments. You can paste 
saved text using the Paste button in the menu. You can also change the font type, size, and 
alignment in the usual editing manner.

To navigate from one comment to another, open the Navigator (F5), expand the Comments 
section, and click on the comment text to move the cursor to the anchor point of the comment in 
the document. Right-click on the comment to quickly edit or delete it.

You can also navigate through the comments using the keyboard. Use Ctrl+Alt+Page Down to 
move to the next comment and Ctrl+Alt+Page Up to move to the previous comment.

Comments can be printed next to the text in the right margin as they appear on screen. Each page 
is scaled down in order to make space for the comments to fit on the underlying paper size.

Adding comments to a document | 29



Creating a table of contents

Writer lets you build an automated table of contents from the headings in your document. Before 
you start, make sure that the headings are styled consistently. For example, you can use the 
Heading 1 style for chapter titles and the Heading 2 and Heading 3 styles for chapter subheadings.

Although tables of contents can be customized extensively in Writer, often the default settings are 
all you need. Creating a quick table of contents is simple:

 1) When you create your document, use the following paragraph styles for different heading 
levels (such as chapter and section headings): Heading 1, Heading 2, Heading 3, and so 
on. These are what will appear in your table of contents.

 2) Place the cursor where you want the table of contents to appear.

 3) Choose Insert > Table of Contents and Index > Table of Contents, Index or 
Bibliography.

 4) Change nothing in the Insert Index/Table dialog. Click OK.

If you add or delete text (so that headings move to different pages) or you add, delete, or change 
headings, you need to update the table of contents.

To do this:

 1) Place the cursor within the table of contents.

 2) Right-click and choose Update index from the context menu.

Note
If you cannot place the cursor in the table of contents, choose Tools > Options > 
LibreOffice Writer > Formatting Aids, and then select Enable Cursor in the 
Protected areas section.

You can customize an existing table of contents at any time. Right-click anywhere in it and choose 
Edit Index from the context menu. Chapter 14, Tables of Contents, Indexes, and Bibliographies, in 
the Writer Guide describes in detail all the customizations you can choose.

Creating indexes and bibliographies

Indexes and bibliographies work in a similar way to tables of contents. Chapter 14, Tables of 
Contents, Indexes, and Bibliographies, in the Writer Guide describes the process in detail.

In addition to alphabetical indexes, other types of indexes supplied with Writer include those for 
illustrations, tables, and objects, and you can even create a user-defined index. For example, you 
might want an index containing only the scientific names of species mentioned in the text, and a 
separate index containing only the common names of species. Before creating some types of 
indexes, you first need to create index entries embedded in your Writer document.

Working with graphics

Graphics in Writer are of three basic types:

• Image files, including photos, drawings, scanned images, and others

• Diagrams created using LibreOffice’s drawing tools

• Charts created using LibreOffice’s Chart component

See Chapter 11, Graphics, the Gallery, and Fontwork, in this book and Chapter 11, Working with 
Images, in the Writer Guide.
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Printing

See Chapter 10, Printing, Exporting, and E-mailing, in this book and Chapter 7, Printing, Exporting, 
and E-mailing, in the Writer Guide for details on previewing pages before printing, selecting print 
options, printing in black and white on a color printer, printing brochures, and other printing 
features.

Using mail merge

Writer provides very useful features to create and print:

• Multiple copies of a document to send to a list of different recipients (form letters)

• Mailing labels

• Envelopes

All these facilities use a registered data source (a spreadsheet or database containing the name 
and address records and other information). Chapter 13, Using Mail Merge, in the Writer Guide 
describes the process.

Tracking changes to a document

You can use several methods to keep track of changes made to a document.

 1) Make your changes to a copy of the document (stored in a different folder, or under a 
different name, or both), then use Writer to combine the two files and show the differences. 
Choose Edit > Track Changes > Compare Document.

 2) Save versions that are stored as part of the original file. However, this method can cause 
problems with documents of non-trivial size or complexity, especially if you save a lot of 
versions. Avoid this method if you can.

 3) Use Writer’s change marks (often called “redlines” or “revision marks”) to show where you 
have added or deleted material, or changed formatting. Choose Edit > Track Changes > 
Record Changes before starting to edit. Later, you or another person can review and 
accept or reject each change. Choose Edit > Track Changes > Show Changes. Right-
click on an individual change and choose Accept Change or Reject Change from the 
context menu, or choose Edit > Track Changes > Manage Changes to view the list of 
changes and accept or reject them. Details are in the Writer Guide.

Tip
Not all changes are recorded. For example, changing a tab stop from align left to align 
right, and changes in formulas (equations) or linked graphics are not recorded.

Caution
A document with track changes activated but with the changes not shown carries an 
invisible history of document editing of which the current user may not be aware. 
Contents deleted or modified can be recovered. While this is a feature, it is also a 
potential security risk.
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Using fields

Fields are extremely useful features of Writer. They are used for data that changes in a document 
(such as the current date or the total number of pages) and for inserting document properties such 
as name, author, and date of last update. Fields are the basis of cross-referencing (see below); 
automatic numbering of figures, tables, headings, and other elements; and a wide range of other 
functions—far too many to describe here. See Chapter 16, Working with Fields, in the Writer Guide 
for details.

Linking and cross-referencing within a document

If you type in cross-references to other parts of a document, those references can easily get out of 
date if you reorganize the order of topics, add or remove material, or reword a heading. Writer 
provides two ways to ensure that your references are up to date, by inserting links to other parts of 
the same document or to a different document: hyperlinks and cross-references.

The two methods have the same result if you click the link when the document is open in Writer: 
you are taken directly to the cross-referenced item. However, they also have major differences:

• The text in a hyperlink does not automatically update if you change the text of the linked 
item (although you can change it manually), but changed text does automatically update in 
a cross-reference.

• When using a hyperlink, you do not have a choice of the content of the link (for example 
text or page number), but when using a cross-reference, you have several choices, 
including bookmarks.

• To hyperlink to an object such as a graphic, and have the hyperlink show useful text such 
as Figure 6, you need to give such an object a useful name (instead of a default name like 
Graphics6), or use the Hyperlink dialog to modify the visible text. In contrast, cross-
references to figures with captions automatically show useful text, and you have a choice of 
several variations of the name.

• If you save a Writer document to HTML, hyperlinks remain active but cross-references do 
not. (Both remain active when the document is exported to PDF.)

Using hyperlinks
See Chapter 12, Creating Web Pages, for details on creating hyperlinks within a document and to 
other documents and websites.

Using cross-references
Replace any typed cross-references with automatic ones and, when you update fields, all the 
references will update automatically to show the current wording or page numbers. The Cross-
references tab of the Fields dialog lists some items, such as headings, bookmarks, figures, tables, 
and numbered items such as steps in a procedure. You can also create your own reference items; 
see “Setting References” in Chapter 16, Fields, in the Writer Guide for instructions.

To insert a cross-reference to a heading, figure, bookmark, or other item:

 1) In your document, place the cursor where you want the cross-reference to appear.

 2) If the Fields dialog is not open, click Insert > Cross-reference. On the Cross-references 
tab (Figure 25), in the Type list, select the type of item to be referenced (for example, 
Heading or Figure). You can leave this page open while you insert many cross-references.

 3) Click on the required item in the Selection list, which shows all the items of the selected 
type. You can type some characters in the top box under Selection to filter the list in the 
selection box.
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 4) In the Insert reference to list, choose the format required. The list varies according to the 
Type. The most commonly used options are Reference (to insert the full text of a heading 
or caption), Category and Number (to insert a figure number preceded by the word Figure 
or Table, but without the caption text), Numbering (to insert only the figure or table number, 
without the word “Figure” or “Table”), or Page (to insert the number of the page the 
referenced text is on). Click Insert.

Figure 25: The Cross-references tab of the Fields dialog 

Using bookmarks
Bookmarks are listed in the Navigator and can be accessed directly from there with a single mouse 
click. You can cross-reference to bookmarks and create hyperlinks to bookmarks, as described 
above.

 1) Select the text you want to bookmark. Click Insert > Bookmark.

 2) On the Insert Bookmark dialog, the larger box lists any previously defined bookmarks. Type 
a name for this new bookmark in the top box, and then click Insert.
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Using master documents

Master documents are typically used for producing long documents such as a book, a thesis, or a 
long report; or when different people are writing different chapters or other parts of the full 
document, so you don’t need to share files. A master document joins separate text documents into 
one larger document, and unifies the formatting, table of contents, bibliography, index, and other 
tables or lists. For details on using master documents, see Chapter 15, Master Documents, in the 
Writer Guide.

You can add master document templates to LibreOffice in the same way as ordinary document 
templates. Creating a new document based on a master document template creates a master 
document with the same initial content as the template it is based upon. See Chapter 3, Styles and 
Templates, for more about creating and using templates.

Classifying document contents

Document classification and security are important for businesses and governments. Where 
sensitive information is exchanged between users and organizations, the parties agree how such 
information will be identified and handled. LibreOffice provides standardized means for sensitive 
information to be identified: a set of standard fields that can be used to hold sensitivity information.

LibreOffice implemented the open standards produced by TSCP (Transglobal Secure Collaboration 
Participation, Inc.) independent of a specific vendor. It contains three BAF (Business Authentication 
Framework) categories: Intellectual Property, National Security and Export Control. Each category 
has four BAILS (Business Authorization Identification and Labeling Scheme) levels: Non-Business, 
General Business, Confidential, and Internal Only.

To enable document classification, open the Classification bar (View > Toolbars > Classification). 
This toolbar contains listboxes to help in selecting the security of the document. LibreOffice then 
adds custom fields in the document properties (File > Properties, Custom fields tab) to store the 
classification policy as document metadata.

To prevent a breach in security policy, contents with a higher classification level cannot be pasted 
into documents with a lower classification level. 

For more information, refer to the Help or to Chapter 17, Fields, in the Writer Guide.

Creating fill-in forms

A standard text document displays information: a letter, report, or brochure, for example. Typically 
the reader may either edit everything or nothing. A form has sections that are not to be edited, and 
other sections that are designed for the reader to make changes. For example, a questionnaire has 
an introduction and questions (which do not change) and spaces for the reader to enter answers.

Forms are used in three ways:

• To create a simple document for the recipient to complete, such as a questionnaire sent out 
to a group of people who fill it in and return it.

• To link into a database or data source and allow the user to enter information. Someone 
taking orders might enter the information for each order into a database using a form.

• To view information held in a database or data source. A librarian might call up information 
about books.

Writer offers several ways to fill information into a form, including check boxes, option buttons, text 
boxes, pull-down lists, and spinners. See Chapter 17, Forms, in the Writer Guide.
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