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What is Impress?

Impress is the presentation (slide show) program included in LibreOffice. You can create slides that 
contain many different elements, including text, bulleted and numbered lists, tables, charts, and a 
wide range of graphic objects such as clipart, drawings, and photographs. Impress also includes a 
spelling checker, a thesaurus, text styles, and background styles.

This chapter includes instructions, screenshots, and hints to guide you through the Impress 
environment while designing your presentations. Although more difficult designs are mentioned in 
this chapter, explanations for creating them are in the Impress Guide. If you have a working 
knowledge of how to create slide shows, we recommend you use the Impress Guide for your 
source of information.

To use Impress for more than very simple slide shows requires some knowledge of the elements 
which the slides contain. Slides that contain text use styles to determine the appearance of that 
text. Creating drawings in Impress is similar to the Draw program included in LibreOffice. For this 
reason, we recommend that you also see Chapter 3 Using Styles and Templates and Chapter 7 
Getting Started with Draw in this guide. You may also wish to consult the Draw Guide for more 
details on how to use the drawing tools.

Starting Impress

You can start Impress in several ways, as described in Chapter 1 Introducing LibreOffice.

When you start Impress for the first time, the Presentation Wizard may be shown. See “Creating a 
new presentation using the Presentation Wizard” on page 13. Otherwise, the main Impress window 
is displayed.

You can turn the Presentation Wizard on and off in Tools > Options > LibreOffice Impress > 
General > New document by selecting or deselecting the Start with wizard option.

Main Impress window

The main Impress window (Figure 1) has three parts: the Slides pane, Workspace, and Sidebar. 
Additionally, several toolbars can be displayed or hidden during the creation of a presentation.

Tip
You can close the Slides pane or the Sidebar by clicking the X in the upper right corner 
of each pane or go to View > Slide Pane or View > Sidebar on the Menu bar to 
deselect the pane. To reopen a pane, go to View on the Menu bar and select Slide 
Pane or Sidebar again.

You can also maximize the Workspace area by clicking on the Hide/Show marker in 
the middle of the vertical separator line (highlighted in Figure 1). Using the Hide/Show 
marker hides, but does not close, the Slide pane or Sidebar. To restore a pane, click 
again on its Hide/Show marker.

Workspace
The Workspace (normally in the center of the main window) opens in the Normal view. It has five 
tabs: Normal, Outline, Notes, Handout, and Slide Sorter. These five tabs are called View 
buttons. Since LibreOffice 5.1, the View buttons are not shown by default; but they can be 
activated by choosing View > Modes Tab Bar from the menu bar. 

The Workspace below the View buttons changes with the chosen view. The workspace views are 
described in “Workspace views” on page 9.
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Figure 1: Main window of Impress; ovals indicate the Hide/Show markers. The View Tab Bar is 
visible in this image.

Slides pane
The Slides pane contains thumbnail pictures of the slides in your presentation in the order in which 
they will be shown, unless you change the slide show order. Clicking a slide in this pane selects it 
and places it in the Workspace. When a slide is in the Workspace, you can make changes to it.

Several additional operations can be performed on one or more slides simultaneously in the Slides 
pane:

• Add new slides to the presentation.

• Mark a slide as hidden so that it will not be shown as part of the presentation.

• Delete a slide from the presentation if it is no longer needed.

• Rename a slide.

• Duplicate a slide (copy and paste).

• Move a slide to another place in the slide stack by dragging and dropping it to the desired 
position. If the position is not visible in the slide pane, the slide stack will scroll up or down 
accordingly.

It is also possible to perform the following operations, although there are more efficient methods 
than using the Slides pane:

• Change the slide transition following the selected slide or after each slide in a group.

• Change the slide design.

• Change slide layout for a group of slides simultaneously.
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Sidebar
The Sidebar has seven sections. To expand a section you want to use, click on its icon or click on 
the small triangle at the top of the icons and select a section from the drop down list. Only one 
section at a time can be open.

Properties 
Shows the layouts included within Impress. You can choose the one you want and use it as it 
is, or modify it to meet your own requirements. However, it is not possible to save customized 
layouts.

Master Pages 
Here you define the page (slide) style for your presentation. Impress includes several 
designs for Master Pages (slide masters). One of them – Default – is blank, and the rest 
have background and styled text.

Tip
Go to Format > Styles > Styles and Formatting on the Menu bar or press the F11 
key to open the Styles and Formatting dialog, where you can modify the styles used in 
any master page to suit your purpose. This can be done at any time.

Custom Animation 
A variety of animations can be used to emphasize or enhance different elements of each 
slide. The Custom Animation section provides an easy way to add, change, or remove 
animations.

Slide Transition 
Provides a number of slide transition options. The default is set to No Transition, in which the 
following slide simply replaces the existing one. However, many additional transitions are 
available. You can also specify the transition speed (slow, medium, fast), choose between an 
automatic or manual transition, and choose how long the selected slide should be shown 
(automatic transition only).

Styles and Formatting 
Here you can edit and apply graphics styles and create new ones, but you can only edit 
existing presentation styles. When you edit a style, the changes are automatically applied to 
all of the elements formatted with this style in your presentation. If you want to ensure that 
the styles on a specific slide are not updated, create a new master page for the slide.

Gallery 
Opens the Impress gallery from which you can insert an object into your presentation either 
as a copy or as a link. A copy of an object is independent of the original object, so changes to 
the object have no effect on the copy. A link remains dependent on the original object and 
changes to the object are reflected in the link.

Navigator 
Opens the Impress navigator, in which you can quickly move to another slide or select an 
object on a slide. It is recommended to give slides and objects in your presentation 
meaningful names so that you can easily identify them when using the navigator.
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Toolbars
Many toolbars can be used during slide creation. They can be displayed or hidden by going to 
View > Toolbars on the Menu bar and selecting from the context menu.

You can also select the icons that you wish to appear on each toolbar. For more information, refer 
to Chapter 1, Introducing LibreOffice.

Many of the toolbars in Impress are similar to the toolbars in Draw. Refer to the Draw Guide for 
details on the functions available and how to use them.

Status bar
The Status bar (Figure 2), located at the bottom of the Impress window, contains information that 
you may find useful when working on a presentation. For details on the contents and use of these 
fields, see Chapter 1 Introducing LibreOffice in this guide and the Impress Guide Chapter 1 
Introducing Impress.

Figure 2: Status bar

Note
The sizes are given in the current measurement unit (not to be confused with the ruler 
units). This measurement unit is defined in Tools > Options > LibreOffice Impress > 
General.

From left to right, you will find:

• Information area – changes depending on the selection. For example:

Example selection Examples of information shown

Text area Text Edit: Paragraph x, Row y, Column z

Charts, spreadsheets Embedded object (OLE) “ObjectName” selected

Graphics Bitmap with transparency selected

• Cursor position – the position of the cursor or of the top left corner of the selection 
measured from the top left corner of the slide, followed by the width and height of the 
selection or text box where the cursor is located.

• Unsaved changes – a flag indicating that the file needs saving. Double-clicking on this flag 
opens the file save dialog.

• Digital signature – a flag indicating whether the document is digitally signed. After the file 
has been saved, double-clicking on this flag opens the digital signatures dialog.

• Slide number – the slide number currently displayed in the Workspace and the total 
number of slides in the presentation.

• Page (slide) style – the style associated with the slide, handout, or notes page currently in 
the Workspace. Double-clicking on the style name opens the slide design dialog.

• Zoom slider – adjusts the zoom percentage of the Workspace displayed.

• Zoom percentage – indicates the zoom percentage of the Workspace displayed. Double-
clicking on zoom percentage opens the zoom and layout dialog.
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You can hide the Status Bar and its information by going to View on the Menu bar and deselecting 
Status Bar.

Workspace views

Each of the Workspace views is designed to ease the completion of certain tasks. It is therefore 
useful to familiarize yourself with them in order to accomplish those tasks quickly.

Note
Beginning with LibreOffice 5.1, the Workspace View tab bar is hidden by default. Turn 
it visible by choosing View > Modes Tab Bar.

Note
Each Workspace view displays a different set of toolbars when selected. These toolbar 
sets can be customized by going to View > Toolbars on the Menu bar, then check or 
uncheck the toolbar you want to add or remove.

Normal view
Normal view is the main view for working with individual slides. Use this view to format and design 
and to add text, graphics, and animation effects.

To place a slide in the slide design area (Normal view) (Figure 1 on page 6), click the slide 
thumbnail in the Slides pane or double-click it in the Navigator (see Chapter 1 Introducing 
LibreOffice and the Impress Guide for more information on the Navigator).

Outline view
Outline view (Figure 3) contains all the slides of the presentation in their numbered sequence. It 
shows topic titles, bulleted lists, and numbered lists for each slide in outline format. Only the text 
contained in the default text boxes in each slide is shown, so if your slide includes other text boxes 
or drawing objects, the text in these objects is not displayed. Slide names are not included either.

Figure 3: Outline view

Figure 4: Outline level and movement arrows in Text Formatting toolbar

Use Outline view for the following purposes:

• Quickly inserting text for fast content creation or editing, when formatting and adding  
graphic objects is postponed until the final stages of creating the presentation.

• Making changes in the text of a slide:

– Adding and deleting the text in a slide as in the Normal view.
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– Moving the paragraphs of text in the selected slide up or down by using the up and 
down arrow buttons (Move Up or Move Down) on the Text Formatting toolbar 
(highlighted in Figure 4).

– Changing the outline level for any of the paragraphs in a slide using the left and right 
arrow buttons (Promote or Demote) on the Text Formatting toolbar.

– Moving a paragraph and changing its outline level at the same time using a combination 
of these four arrow buttons.

• Comparing slides with your outline (if you have prepared one in advance). If you notice 
from your outline that another slide is needed, you can create it directly in the Outline view 
or you can return to the Normal view to create it.

Notes view
Use the Notes view (Figure 5) to add notes to a slide. These notes are for your information and are 
not seen by the audience when the presentation is shown.

Figure 5: Notes view

 1) Click the Notes tab in the Workspace.

 2) Select the slide to which you want to add notes: click the slide in the Slides pane, or 
double-click the slide name in the Navigator.

 3) In the text box below the slide, click on the words Click to add notes and begin typing.

You can resize the Notes text box using the colored resizing handles which appear when you click 
on the edge of the box. You can also move the box by placing the pointer on the border, then 
clicking and dragging. To make changes in the text style, click on the Styles and Formatting icon 

 on the Sidebar.

Handout view
Handout view is for setting up the layout of your slide for a printed handout. Click the Handout tab 
in the workspace and the Layouts section opens on the Sidebar (Figure 6). Here you can choose 
to print 1, 2, 3, 4, 6, or 9 slides per page. If the Layouts section does not open, then click on the 

Properties icon  at the side of the Sidebar.

Use this view also to customize the information printed on the handout. Refer to Chapter 10, 
Printing, E-mailing, Exporting, and Saving Slide Shows, in the Impress Guide for instructions on 
printing slides, handouts, and notes. 
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Go to Insert > Page Number, Insert > Fields, or Insert > Header and Footer on the Menu bar 
and the Header and Footer dialog opens. Click on the Notes and Handouts tab (Figure 7) and 
select the elements you want to appear on each handout page and their contents. More details on 
how to use this dialog are provided in the Impress Guide.

Figure 6: Handout layouts

Figure 7: Header and Footer dialog – Notes and Handouts page

Slide Sorter view
Slide Sorter view (Figure 8) contains all of the slide thumbnails. Use this view to work with a group 
of slides or with only one slide.

Figure 8: Slide Sorter view
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Customizing Slide Sorter view
To change the number of slides per row:

 1) Go to View > Toolbars and select Slide Sorter and Slide View to show or hide the Slide 
Sorter and Slide View toolbars (Figure 9).

 2) Adjust the number of slides (up to a maximum of 15).

Figure 9: Slide Sorter and Slide View toolbars

Moving a slide using Slide Sorter
To move a slide in a presentation in the Slide Sorter:

 1) Click the slide and the slide is highlighted (Figure 8).

 2) Drag and drop the slide to the location you want.

Selecting and moving groups of slides
To select a group of slides, use one of these methods:

• Using the Ctrl key – click on the first slide and, while pressing the Ctrl key, select the other 
desired slides.

• Using the Shift key – click on the first slide, and while pressing the Shift key, select the final 
slide in the group. This selects all of the other slides between the first and the last slide 
selected.

• Using the mouse – click slightly to one side (left or right) of the first slide to be selected. 
Hold down the left mouse button and drag the cursor until all of the slides you want 
selected are highlighted.

To move a group of slides, select them and then drag and drop the group to their new location.

Working in Slide Sorter view
You can work with slides in the Slide Sorter view just as you can in the Slide pane. To make 
changes, right-click a slide and choose any of the following from the context menu:

• New Slide – adds a new slide after the selected slide (see “New slide” on page 16).

• Duplicate Slide – creates a duplicate of the selected slide and places the new slide 
immediately after the selected slide (see “Duplicate slide” on page 16).

• Delete Slide – deletes the selected slide.

• Rename Slide – allows you to rename the selected slide.

• Slide Layout – allows you to change the layout of the selected slide.

• Slide Transition – allows you to change the transition of one or a group of selected slides.

• Hide Slide – any slides that are hidden are not shown in the slide show.

• Cut – removes the selected slide and saves it to the clipboard.

• Copy – copies the selected slide to the clipboard without removing it.

• Paste – inserts a slide from the clipboard after the selected slide.
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Creating a new presentation using the Presentation Wizard

This section describes how to start a new presentation using the Presentation Wizard.

Tip
The first thing to do is decide on the purpose of the presentation and set out a plan. 
Although you can make changes as you go, you will save a lot of time by having an 
initial idea of who the audience will be, the structure, the content, and how the 
presentation will be delivered.

When you start Impress, the Presentation Wizard may appear (Figure 10). 

 1) In step 1, under Type, choose one of the options. These options are covered in the Impress 
Guide.

– Empty presentation creates a blank presentation.

– From template uses a template design already created as the basis for a new 
presentation. The wizard changes to show a list of available templates. Choose the 
template you want.

– Open existing presentation continues work on a previously created presentation. The 
wizard changes to show a list of existing presentations. Choose the presentation you 
want.

Figure 10: Choosing the type of presentation

 2) Click Next. Figure 11 shows the Presentation Wizard step 2 as it appears if you selected 
Empty Presentation at step 1. If you selected From template, an example slide is shown in 
the Preview box.

 3) Choose a design under Select a slide design. The slide design section gives you two main 
choices: Presentation Backgrounds and Presentations. Each one has a list of choices for 
slide designs. If you want to use one of these other than <Original>, click it to select it.

– The types of Presentation Backgrounds are shown in Figure 11. When you select a 
presentation background, you will see a preview of the slide design in the Preview 
window.

– <Original> is for a blank presentation slide design.
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Figure 11: Selecting a slide design

 4) Select how the presentation will be used under Select an output medium. The majority of 
presentations are created for computer screen display so it is recommended to select 
Screen. You can change the page format at any time.

Note

The Screen page is set by default for a 4:3 display (28cm x 21cm) so it is not suitable 
for modern widescreen displays. Use the Widescreen option instead. You can also 
change the slide size and proportions at any time by switching to Normal view and 
selecting Slide > Page/Slide Properties.

 5) Click Next and step 3 of the Presentation Wizard appears (Figure 12).

a) Choose the desired slide transition from the Effect drop-down menu.

b) Select the desired speed for the transition between the different slides in the 
presentation from the Speed drop-down menu. Medium is a good choice for now.

c) Select the presentation type. For most purposes, choose Default; you can change this 
later. For details on the choices under Automatic, see the Impress Guide.

Figure 12: Selecting a slide transition effect
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Note
If you did not select a template in step 1 of the Presentation Wizard, then steps 4 and 
5 will not appear after step 3. Click Create and your new presentation is created.

 6) Click Next. In step 4 of the Presentation Wizard, you can enter information about your 
company and the presentation you are creating.

Figure 13: Entering information about your presentation

 7) Click Next. In step 5, the Presentation Wizard shows a preview of what your presentation 
will look like (Figure Erro: Origem da referência não encontrada). If the preview does not 
appear, select Preview.

Figure 14: Presentation preview

 8) To create a summary of your presentation, select Create summary.

 9) Click Create and your new presentation is created.
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Tip
You can accept the default values for both Effect and Speed unless you are skilled at 
creating presentations. Both of these values can be changed later while working with 
slide transitions and animations. These two features are explained in more detail in  
Chapter 9, Slide Shows, in the Impress Guide

Formatting a presentation

A new presentation contains only one empty slide. In this section we will start adding new slides 
and preparing them for the intended contents.

Inserting slides

New slide
A new slide can be inserted into a presentation as follows:

 1) Go to Slide on the Menu bar and select New Page/Slide. 

– Or, right-click on a slide in the Slides Pane or Slide Sorter view and select New Slide 
from the context menu.

– Or, right-click in an empty space in the Workspace and select Slide > New Slide from 
the context menu.

– Or click the NewPage/Slide icon  in the Presentation toolbar. You can also select 
the desired layout of the new slide if you click on the small downward arrow of the icon. 
If the Presentation toolbar is not visible, go to View > Toolbars on the Menu bar and 
select Presentation from the list.

 2) A new slide is inserted after the selected slide in the presentation.

Duplicate slide
Sometimes, rather than starting from a new slide you may want to duplicate a slide already 
included in your presentation. To duplicate a slide:

 1) Select the slide you want to duplicate from the Slides Pane.

 2) Go to Slide on the Menu bar and select Duplicate Page/Slide.

– Or, right-click on the slide in the Slides Pane or Slide Sorter view and select Duplicate 
Slide from the context menu.

– Or, right-click on a slide in the Workspace and select Slide > Duplicate Slide from the 
context menu.

– Or, click on the triangle to the right of the Slide icon in the Presentation toolbar and 
select Duplicate Page/Slide from the context menu. If the Presentation toolbar is not 
visible, go to View > Toolbars on the Menu bar and select Presentation from the list.

 3) A duplicate slide is inserted after the selected slide in the presentation.

Selecting slide layout
When creating a presentation, the first slide is normally a title slide. You can use either a blank 
layout or one of the title layouts as your title slide.
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Click on the Properties icon  at the side of the Sidebar to open Layouts section and display 
the available layouts (Figure 15). The layouts included in LibreOffice range from a blank slide to a 
slide with six contents boxes and a title.

Figure 15: Available slide layouts

To create a title, if one of the title layouts has been selected, click on Click to add title and then type 
the title text. To add text content, depending on the slide layout selected, click on Click to add text. 
To adjust the formatting of the title, subtitle or content modify the presentation style; see the 
Impress Guide Chapter 2 Using Slide Masters, Styles, and Templates.

Note
Text and graphical elements can be readjusted at any time during the preparation of 
the presentation, but changing the layout of a slide that already contains some content 
can have an effect on the content format. Therefore, it is recommended that you pay 
particular attention to the layout you select to prevent any loss of content.

Tip
To view the names for the included layouts, use the Tooltip feature: position the cursor 
on an icon in the Layout section (or on any toolbar icon) and its name will be displayed 
in a small rectangle.

In Tools > Options > LibreOffice > General > Help, select the Extended tips option 
to get more detailed tooltip information.

To select or change the layout of a slide, select the slide in the Slides Pane so that it appears in the 
Workspace and select the desired layout from the Layouts section in the Sidebar. Several layouts 
contain one or more content boxes. Each of these content boxes can be configured to contain text, 
movies, images, charts or tables.

You can choose the type of content by clicking on the corresponding icon that is displayed in the 
middle of the content box as shown in Figure 16. If you intend to use the content box for text, click 
on Click to add text.
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Figure 16: Selecting content type

Modifying slide elements
A slide contains elements that were included in the slide master, as well as those elements 
included in the selected slide layout. However, it is unlikely that the predefined layouts will suit all 
your needs for your presentation. You may want to remove elements that are not required or insert 
objects such as text and graphics.

Although Impress does not allow you to create new layouts, you can resize and move the layout 
elements. It is also possible to add elements without being limited to the size and position of the 
layout boxes.

To resize a contents box, click on the outer frame so that the resizing handles are displayed. To 
move it, place the mouse cursor on the frame so that the cursor changes shape. You can now click 
and drag the contents box to a new position on the slide.

To remove any unwanted element:

 1) Click the element to highlight it. The resizing handles show that it is selected.

 2) Press the Delete key to remove it.

Note
Changes to any of the layouts included in Impress can only be made using View > 
Normal, which is the default. Attempting any changes by modifying a slide master, 
although possible, may result in unpredictable results and requires extra care as well 
as a certain amount of trial and error.

Adding text
To add text to a slide that contains a text frame, click on Click to add text in the text frame and then 
type your text. The Outline styles are automatically applied to the text as you insert it. You can 
change the outline level of each paragraph as well as its position within the text by using the arrow 
buttons on the Text Formatting toolbar (see Figure 4 and “Outline view” on page 9) or using the Tab 
key while positioning the cursor at the beginning of the paragraph. For more information on text, 
see “Adding and formatting text” on page 20.
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Adding objects
To add any objects to a slide, for example a picture, clipart, drawing, photograph, or spreadsheet, 
click on Insert then select from the drop down menu what type of object you want to insert. For 
more information, see “Adding pictures, tables, charts, and media” on page 25.

Modifying the appearance of all slides
To change the background and other characteristics of all slides in the presentation, you need to 
modify the master page or choose a different master page as explained in “Working with slide 
masters and styles” on page 27.

A Slide Master is a slide with a specified set of characteristics that acts as a template and is used 
as the starting point for creating other slides. These characteristics include slide background, 
objects in the background, formatting of any text used, and any background graphics.

Note
LibreOffice uses three terms for a slide that is used to create other slides: master slide, 
slide master, and master page. This book uses the term slide master, except when 
describing the user interface.

Impress has a range of slide masters and these are found in the Master Pages section of the 
Sidebar. You can also create and save additional slide masters or add more from other sources. 
See the Impress Guide Chapter 2 Using Slide Masters, Styles, and Templates for more information 
on creating and modifying slide masters.

If all you need to do is to change the background, you can use a shortcut:

 1) Select Slide > Page/Slide Properties... and go to the Background tab on the Page Setup 
dialog that opens. 

 2) Select the desired background between solid color, gradient, hatching, and bitmap. 

 3) Click OK to apply it.

 4) A dialog opens asking if the background should be applied to all the slides. Click Yes if you 
want all the slides modified and Impress will automatically modify the master page for you.

Note
Inserting and correctly formatting a background is beyond the scope of this chapter, 
but you can find all the information you need in the Draw Guide Chapter 4 Changing 
Object Attributes or in the Impress Guide Chapter 6 Formatting Graphic Objects.

Modifying the slide show
By default the slide show will display all the slides in the same order as they appear in the slide 
sorter, without any transition between slides. You need to use keyboard input or mouse interaction 
to move from one slide to the next.

You can use Slide Show on the Menu bar to change the order of the slides, choose which ones 
are shown, automate moving from one slide to the next, and other settings. To change the slide 
transition, animate slides, add a soundtrack to the presentation, and make other enhancements, 
you need to use functions in the Sidebar. See the Impress Guide for details on how to use all of 
these features.
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Adding and formatting text

Many of your slides are likely to contain some text. This section gives some guidelines on how to 
add text and change its appearance. Text used in slides is contained in text boxes. For more 
information on adding and formatting text, see the Impress Guide Chapter 3 Adding and 
Formatting Text.

You can add two types of text boxes to a slide:

• Choose a predefined layout from the Layouts section of the Sidebar and do not select any 
special content type. These text boxes are called AutoLayout text boxes.

• Create a text box using the Text icon  on the Standard toolbar (Figure 17) or the Text 
toolbar (Figure 18), or use the keyboard shortcut F2.

Figure 17: Standard toolbar

Figure 18: Text toolbar

Using AutoLayout text boxes
 1) Make sure Normal view is selected.

 2) Click in the text box that reads Click to add text.

 3) Type or paste your text in the text box.

Using text boxes
 1) Make sure Normal view is selected.

 2) Click on the Text icon on the Standard or Text toolbar or use the keyboard shortcut F2. If 
the Standard or Text toolbars are not visible, go to View > Toolbars on the Menu bar and 
select Standard or Text.

 3) Click and drag to draw a box for the text on the slide. Do not worry about the vertical size 
and position as the text box will expand if needed as you type.

 4) Release the mouse button when finished. The cursor appears in the text box, which is now 
in edit mode (a colored border shown in Figure 19).

 5) Type or paste your text in the text box.

 6) Click outside the text box to deselect it.

You can move, resize, and delete text boxes. For more information, see the Impress Guide 
Chapter 3 Adding and Formatting Text.

Vertical text
In addition to the normal text boxes where text is horizontally aligned, it is possible to insert text 
boxes where the text is aligned vertically. Vertical text is available only when Asian languages are 

enabled in Tools > Options > Language Settings > Languages. Click the Vertical Text icon  
in the Standard toolbar or Text toolbar to create a vertical text box.

20 | Chapter 6  Getting Started with Impress



Figure 19: Creating and editing text boxes

Quick font resizing
Impress has an Increase Font icon and a Decrease Font icon on the Text Formatting toolbar 
(highlighted in Figure 20) to increase or decrease the font size of selected text. The amount by 
which the font size changes depends on the standard sizes available for the font in use.

Figure 20: Quick font resizing on Text Formatting toolbar

Note
AutoLayout text boxes can automatically resize fonts to let the box contain all the text 
you insert. If you insert a long piece of text, the font size may shrink to fit into the box. 
Otherwise, the font keeps its default size.

Pasting text
Text may be inserted into the text box by copying it from another document and pasting it into 
Impress. However, pasted text will probably not match the formatting of the surrounding text on the 
slide or that of the other slides in the presentation. This may be what you want on some occasions; 
however, in most cases you want to make sure that the presentation style is consistent and does 
not become a patchwork of different paragraph styles, font types, bullet points and so on. There 
are several ways to ensure consistency in your presentation.

Pasting unformatted text
It is normally good practice to paste text without formatting and apply the formatting later. To paste 
text without formatting:

• Use the keyboard shortcut Ctrl+Shift+V and select Unformatted text from the Paste 
Special dialog that opens.

• Or click on the small triangle next to the Paste icon in the Standard toolbar and select 
Unformatted text from the context menu.

The unformatted text will be formatted with the outline or paragraph style at the cursor position in 
an AutoLayout text box or with the default graphic style in a normal text box.
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Formatting pasted text
When formatting pasted text, you can use the tools available on the Text Formatting toolbar (Figure 
21), or the tools available in the Character and Paragraph sections of the Properties deck in the 
Sidebar (Figure 22). If the Character and Paragraph sections do not automatically open after 

selecting some text, click on the Properties icon  at the side of the Sidebar.

Figure 21: Text Formatting toolbar

Figure 22: Sidebar Character section

If you are pasting the text into an AutoLayout text box, you need to apply the appropriate outline 
style to the text to give it the same look and feel as the rest of the presentation.

 1) Paste the text in the desired position.

 2) Select the text you have just pasted.

 3) Select Format > Default formatting on the Menu bar.

 4) Use the four arrow buttons on the Text Formatting toolbar (highlighted in Figure 4 on page 
9) to move the text to the appropriate position and give it the appropriate outline level.

– Left arrow promotes a list entry by one level (for example from Outline 3 to Outline 2). 
You can get the same result by placing the cursor at the beginning of the paragraph and 
pressing the Shift + Tab keys.

– Right arrow button demotes a list entry by one level. Press the Tab key to get the same 
result after placing the cursor at the beginning of the paragraph.

– Up arrow moves a list entry up in the list order.

– Down arrow moves a list entry down in the list order.

 5) Apply any necessary manual formatting to the text to change font attributes, tabs, and so 
on.

If you are pasting text in a text box, you can still use styles to format the text quickly. Only one 
graphic style can be applied to the pasted text, as follows:

 1) Paste the text in the desired position.
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 2) Select the text you have just pasted.

 3) Select the desired graphical style to format the text.

 4) Apply any necessary manual formatting to the text to change font attributes, tabs, and so on.

Creating bulleted and numbered lists
The procedure to create a bulleted or numbered list is quite different depending on the type of text 
box used, although the tools to manage the list and customize the appearance are the same. In 
AutoLayout text boxes, the outline styles available are, by default, bulleted lists. For normal text 
boxes an additional step is required to create a bulleted list.

AutoLayout text boxes
AutoLayout text boxes included in the available layouts are already formatted as a bulleted list. 
Create a slide with a bulleted list as follows:

 1) From the Layout pane, choose a slide design that contains a text box.

 2) In the text box, click on Click to add text.

 3) Type your text and press the Enter key to start a new bulleted point.

The default list type is a bulleted list. Methods for changing the appearance of a list are explained 
in “Changing list appearance” on page 24.

Tip
Press Shift+Enter to start a new line without creating a new bullet point. The new line 
will have the same indentation as the previous line. To switch off bullets altogether, 
click the Bullets On/Off icon  on the Text Formatting toolbar. If the Text Formatting 
toolbar is not displayed, go to View > Toolbar > Text Formatting on the Menu bar.

Text boxes
Create a bulleted list in a text box as follows:

 1) Click the Text icon  on the Standard toolbar and draw a text box on your slide.

 2) Click the Bullets On/Off icon  on the Text Formatting toolbar.

 3) Type the text and press Enter to start a new bulleted line.

The default list type is a bulleted list. Methods for changing the appearance of a list are explained 
in “Changing list appearance” on page 24.

Creating a new outline level
In AutoLayout text boxes, create a new outline level as follows:

 1) If necessary, press Enter to begin a new list entry.

 2) To demote a list entry (move it to the right), press the Tab key or click the Demote (right 
arrow) icon on the Text Formatting toolbar or use the keyboard shortcut Alt+Shift+Right. 
The list entry moves to the right and is indented to the next outline level.

 3) To promote a list entry (move it to the left), press Shift+Tab or click the Promote (left arrow) 
icon on the Text Formatting toolbar or use the keyboard shortcut Alt+Shift+Left. The list 
entry moves to the left and is indented at the next higher level.

 4) To create a new list entry at the same level as the previous one, press Enter again.

In the AutoLayout text boxes, promoting or demoting an item in the list corresponds to applying a 
different outline style. The second outline level corresponds to Outline 2 style, the third outline level 
to Outline 3 style, and so on. A change in level and style produces other changes, for example, to 
font size, bullet type, and so on.
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In text boxes, a new outline level can only be created by using the Tab key to demote the list entry 
and the Shift+Tab key combination to promote the list entry.

Note
Do not try to change the outline level by selecting the text and then clicking the desired 
outline style as you would in Writer. Due to the way that presentation styles work in 
Impress, it is not possible to change the level in this way.

Changing list appearance
You can fully customize list appearance by changing the bullet type or numbering for the entire list 
or for only a single entry. All of the changes can be made using the Bullets and Numbering dialog 
(Figure 23), which is accessed by going to Format > Bullets and Numbering on the Menu bar or 

by clicking on the Bullets Icon or the Numbering icon  on the Text Formatting toolbar.

For the entire list:

 1) Select the entire list or click on the border of the text box so that the resizing handles are 
displayed.

 2) Select Format > Bullets and Numbering on the Menu bar or click on the Bullets or 

Numbering icon  on the Text Formatting toolbar.

Figure 23: Bullets and Numbering dialog

 3) The Bullets and Numbering dialog (Figure 23) contains five pages: Bullets, Numbering type, 
Image, Position, and Customize.

– If a bullet list is needed, select the desired bullet style from the default styles available 
on the Bullets page.

– If a graphics style is needed, select one from those available on the Image page.

– If a numbered list is needed, select one of the default numbering styles on the 
Numbering type page.

– Use the Position page to set the indent and numbering spacing and alignment of your 
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list.

– Use the Customize page to customize the numbering, color, relative size, and character 
used for your list.

 4) For a single list entry, click anywhere in the text and then follow steps 2 and 3 above.

If the list was created in an AutoLayout text box, then an alternative way to change the entire list is 
to modify the Outline styles. Changes made to the outline style will apply to all the slides using 
them.

Adding pictures, tables, charts, and media

A contents box can contain pictures, tables, charts, or media as well as text. This section provides 
a quick overview of how to work with these objects. For more information on adding pictures, 
tables, charts, or media, please refer to the Impress Guide.

Adding pictures
To add a picture to a contents box:

 1) Go to Insert > Image on the Menu bar and then select either From file or Scan.

 2) Alternatively, after inserting a new slide, click the Insert Image icon (Figure 16 on page 18) 
on the new slide and select the file from the Insert Image dialog that opens. To see a 
preview of the picture, select Preview at the bottom of the Insert Image dialog.

 3) Move the picture to the desired location.

 4) The picture will automatically resize to fill the area of the content box. Follow the directions 
in the note below when manually resizing a graphic.

Note
When resizing a graphic, right-click the picture. Select Position and Size from the 
context menu and make sure that Keep ratio is selected. Then adjust the height or 
width to the size you need. As you adjust one dimension, both dimensions will change 
to keep the width and height ratio the same, ensuring that the picture will not become 
distorted. Remember also that resizing a bitmap image will reduce its quality; it is 
better to create an image of the desired size outside of Impress.

Adding tables
To add basic tables to a slide:

 1) Go to Insert > Table on the Menu bar, or click the Table icon  on the Standard toolbar.

 2) If there is a table already on the slide and it is selected, click the Table icon  on the 
Table toolbar. The Table toolbar is only visible after selecting View > Toolbars > Table on 
the Menu bar and when a table is selected.

 3) Alternatively, and after inserting a new slide into your presentation, click the Insert Table 
icon (Figure 16 on page 18).

 4) Select the number of rows and columns required from the Insert Table dialog that opens.

 5) Alternatively, click the small triangle to the right of the Table icon  and select the number 
of rows and columns by dragging the cursor.

 6) Select a design style from the available options for your table in the Table Design deck in 
the Properties section of the Sidebar (Figure 24). If the Table Design section does not 
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automatically open after inserting or selecting a table, click on the Properties icon at the 
side of the Sidebar.

Note
Selecting from any of the styles in the Table Design section in the Sidebar creates a 
table based on that style. If you create a table by another method, you can still apply a 
style of your choice later.

The Table toolbar in Impress offers the same functions as the Table toolbar in Writer, with the 
exception of the calculation functions Sort and Sum. To use Sum and Sort in your presentation, 
you have to insert a Calc spreadsheet.

After the table is created, you can modify it by adding and deleting rows and columns, adjusting 
width and spacing, adding borders, background colors and so on. For more information on working 
with tables see the Impress Guide Chapter 3 Adding and Formatting Text and the Writer Guide 
Chapter 9 Working with Tables.

Figure 24: Sidebar Table Design section

Entering data into table cells is similar to working with text box objects. Click in the cell you wish to 
add data to and begin typing. To move around cells quickly, use the following keyboard options:

• Press the arrow keys to move the cursor to another cell if the cell is empty, or to the next 
character if the cell already contains text.

• Press the Tab key to move to the next cell on the right and press Shift+Tab to move to the 
next cell on the left.
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Adding charts
To insert a chart in a slide:

 1) Go to Insert > Chart on the Menu bar or click on the Chart icon  in the Standard 
toolbar.

 2) Alternatively and after inserting a new slide, click on the Insert Chart icon (Figure 16 on 
page 18).

 3) Impress will insert a default chart and open the Chart dialog. To modify the chart type, insert 
your own data and change the formatting, refer to the Impress Guide.

Adding media files
To insert media files, such as music and movie clips, in a slide:

 1) Go to Insert > Audio or Video on the Menu bar.

 2) Alternatively and after inserting a new slide, click on the Insert Audio or Video icon (Figure 
16 on page 18).

 3) A media player will open at the bottom of the screen and you can preview the media.

 4) When an audio file is inserted, the contents box will show a loudspeaker image.

Adding graphics, spreadsheets, and other objects
Graphics, such as shapes, callouts, and arrows, are often useful to complement the text on a slide. 
These objects are handled much the same way as graphics in Draw. For more information, see the 
Draw Guide Chapter 7 Getting Started with Draw, or the Impress Guide Chapters 4, 5, and 6.

Spreadsheets embedded in Impress include most of the functionality of Calc spreadsheets and are 
capable of performing extremely complex calculations and data analysis. If you need to analyze 
your data or apply formulas, these operations are best performed in a Calc spreadsheet and the 
results displayed in an embedded Calc spreadsheet or even better in an Impress table.

Alternatively, go to Insert > Object > OLE Object on the Menu bar. You can select from options 
that include a LibreOffice 5.0 Spreadsheet. This opens a spreadsheet in the middle of the slide and 
the menus and toolbars change to those used in Calc. You can start adding data, though you may 
have to resize the visible area on the slide. You can also insert an existing spreadsheet and use 
the viewport to select the data that you want to display on your slide.

Impress offers the capability of inserting into a slide various other types of objects such as Writer 
documents, Math formulas, Draw drawings, or another presentation. For details on using these 
objects, refer to the Impress Guide Chapter 7 Including Spreadsheets, Charts, and Other Objects.

Working with slide masters and styles

A slide master is a slide that is used as the starting point for other slides. It is similar to a page style 
in Writer and it controls the basic formatting of all slides based on it. A slide show can have more 
than one slide master.

Note
LibreOffice uses three terms for a slide that is used to create other slides: master slide, 
slide master, and master page. This book uses the term slide master, except when 
describing the user interface.

A slide master has a defined set of characteristics, including background colors, graphics, 
gradients; and other objects (such as logos, decorative lines and so on), headers and footers, 
placement and size of text frames, and text format.
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Styles
All of the characteristics of slide masters are controlled by styles. New slides that you create using 
a slide master have styles that are inherited from the slide master which was used. Changing a 
style in a slide master results in changes to all slides based on that slide master, but you can 
modify individual slides without affecting the slide master.

Note
Although it is highly recommended to use the slide masters whenever possible, there 
are occasions where manual changes are needed for a particular slide, for example to 
enlarge the chart area when the text and chart layout is used. 

Slide masters have two types of styles associated with them: presentation styles and image styles. 
The prepackaged presentation styles can be modified, but new presentation styles cannot be 
created. For image styles, you can modify the prepackaged styles and also create new image 
styles.

Presentation styles affect three elements of a slide master: background, background objects (such 
as icons, decorative lines, and text frames), and text placed on the slide. Text styles are further 
divided into Notes, Outline 1 through Outline 9, Subtitle, and Title. The outline styles are used for 
the different levels of the outline to which they belong. For example, Outline 2 is used for the sub-
points of Outline 1, and Outline 3 is used for the sub-points of Outline 2, and so on.

Image styles are not restricted and can affect many of the elements of a slide. Note that text styles 
exist in both the presentation and image style selections.

Slide masters
Impress comes with a collection of slide masters. These slide masters are shown in the Master 
Pages section of the Sidebar (Figure 25), which has three subsections: Used in This Presentation, 
Recently Used, and Available for Use. Click the + sign next to the name of a subsection to expand 
it to show thumbnails of the slides, or click the – sign to collapse the subsection to hide the 
thumbnails.

Each of the slide masters shown in the Available for Use list is from a template of the same name. 
If you have created your own templates, or added templates from other sources, slide masters 
from those templates will also appear in this list.

Creating a slide master
Creating a new slide master is similar to modifying the default slide master.

 1) Enable editing of slide masters by selecting View > Slide Master on the Menu bar and the 
Master View toolbar opens (Figure 26). If the Master View toolbar does not appear, go to 
View > Toolbars and select Master View.

 2) On the Master View toolbar, click the New Master icon .

 3) A new slide master appears in the Slides pane. Modify this slide master to suit your 
requirements.

 4) It is also recommended that you rename this new slide master. Right-click on the slide in 
the Slides pane and select Rename master from the context menu.

 5) When finished creating a slide master, click Close Master View on the Master View toolbar 
and return to normal slide editing mode.
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Figure 25: Sidebar Master Pages section

Figure 26: Master View toolbar

Applying a slide master
To apply a slide master to all the slides in your presentation:

 1) Click on the Master Pages icon  in the Sidebar to open the Master Pages section 
(Figure 25).

 2) To apply one of the slide masters from the available selection to all slides in your 
presentation, right-click on it and select Apply to All Slides on the context menu.

To apply a different slide master to one or more selected slides:

 1) In the Slide Pane, select the slide or slides where you want to use a new slide master.

 2) In the Master Pages section on the Sidebar, right-click on the slide master you want to 
apply to the selected slides, and select Apply to Selected Slides on the context menu.
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Loading additional slide masters
Sometimes, in the same set of slides, you may need to mix multiple slide masters that may belong 
to different templates. For example, you may need a completely different layout for the first slide of 
the presentation, or you may want to add to your presentation a slide from a different presentation 
(based on a template available on the hard disk).

 1) Go to Slide > Slide Design on the Menu bar or right-click on a slide in the Slides Pane and 
select Slide Design from the context menu to open the Slide Design dialog (Figure 27). 
This dialog shows the slide masters already available for use.

 2) To add more slide masters, click the Load button to open the Load Slide Design dialog 
(Figure 28).

 3) Select in the Load Slide Design dialog the template from which to load the slide master and 
click OK.

 4) Click OK again to close the Slide Design dialog.

 5) The slide masters in the template you selected to use are now shown in the Available for 
use subsection of Master Pages.

Figure 27: Slide Design dialog

Figure 28: Load Slide Design dialog
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Note
The slide masters you have loaded will also be available the next time you load the 
presentation. If you want to delete the unused slide masters, click the corresponding 
checkbox in the Slide Design dialog. If the slide master was not used in the 
presentation, it is removed from the list of available slide masters.

Tip
To limit the size of the presentation file, you may want to minimize the number of slide 
masters used.

Modifying a slide master
The following items can be changed on a slide master:

• Background (color, gradient, hatching, or bitmap)

• Background objects (for example, a logo or decorative graphics)

• Size, placement, and contents of header and footer elements to appear on every slide

• Size and placement of default frames for slide titles and content

For more information on modifying slide masters, see the Impress Guide Chapter 2 Using Slide 
Masters, Styles, and Templates.

 1) Select View > Slide Master from the Menu bar. This unlocks the properties of a slide 
master so you can edit it.

 2) Select a slide master in Master Pages in the Slides pane.

 3) Select an object on the slide master in the Workspace and the Sidebar will display the 
property options that can be changed for the selected object. Figure 29 shows a graphic 
object selected with the Graphic properties section open on the Sidebar.

 4) Make all necessary changes to the slide master, then click the Close Master View icon on 
the Master View toolbar or go to View > Normal on the Menu bar to exit from editing slide 
masters.

 5) Save your presentation file before continuing.

Caution
Any changes made to one slide when in Master View mode will appear on all slides 
using this slide master. Always make sure you Close Master View and return to Normal 
view before working on any of the presentation slides.

Note
The changes made to one of the slides in Normal view (for example, changes to the 
bullet point style, the color of the title area, and so on) will not be overridden by 
subsequent changes to the slide master. There are cases, however, where it is 
desirable to revert a manually modified element of the slide to the style defined in the 
slide master. To revert back to default formatting, select the element and select 
Format > Default Formatting from the Menu bar.
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Figure 29: Editing a slide master

Adding text, footers, and fields to all slides
A slide master can have text, footers, or fields added so that they appear on every slide in your 
presentation. Headers are not normally added to slides.

Text
 1) Go to View > Slide Master on the Menu bar to open Master View (Figure 30).

 2) On the Drawing toolbar, select the Text icon or press the F2 key.

 3) Click and drag in the master page to draw a text object and then type or paste your text into 
the text object.

 4) Go to View > Normal on the Menu bar or click on Close Master View on the Master View 
toolbar when you have finished entering text objects that you want to appear on every slide 
in your presentation.

Footers
To add a footer to your slides:

 1) Go to View > Slide Master on the Menu bar to open Master View (Figure 30).

 2) Go to Insert > Field or Insert > Page Number on the Menu bar and time to open the 
Header and Footer dialog (Figure 31).

 3) Select the type of date and time and type in the footer text and slide number from the 
available options in the dialog.

 4) Click Apply to All to apply your changes to all the slide masters in your presentation, or 
click Apply to apply your changes to the selected slide master in your presentation.

 5) Alternatively, you can add the date/time, footer text and slide number directly into their 
respective areas as shown in Figure 30.

Note
Normally only footers are used on a slide. To create a header, you can use a text box 
as explained in “Text” on page 32.
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Figure 30: Example master view

Figure 31: Footer dialog in Impress

Fields
To add a field into an object or as a separate object on a slide, select Insert > Fields on the Menu 
bar and select the required field from the submenu. If you want to edit this field in your slide, see 
the Impress Guide Chapter 3 Adding and Formatting Text for more information.

The fields you can use in Impress are as follows:

• Date (fixed)

• Date (variable): updates automatically when you reload a file
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• Time (fixed)

• Time (variable): updates automatically when you reload a file

• Author: first and last names listed in the LibreOffice user data

• Page Number: the slide number in Impress

• Page Count: the number of slides in your presentation

• File Name

Tip
To change the author information, go to Tools > Options > LibreOffice > User Data 
on the Menu bar.

To change the number format (1,2,3 or a,b,c or i,ii,iii, and so on) for the number field, 
go to Slide > Page/Slide Properties... on the Menu bar and then select a format from 
the Format list in the Layout Settings area.

To change a paragraph style throughout your presentation, open the Styles and 
Formatting dialog and modify the appropriate presentation style.

Adding comments to a presentation

Impress supports comments similar to those in Writer and Calc.

In Normal View, go to Insert > Comment on the Menu bar to open a blank comment (Figure 32). A 
small box containing your initials appears in the upper left-hand corner of the slide, with a larger 
text box beside it. Impress automatically adds your name and the current date at the bottom of the 
text box.

Type or paste your comment into the text box. You can optionally apply some basic formatting to 
the comment by selecting it, right-clicking, and choosing from the context menu that opens. This 
menu allows you to apply formatting to selected text, delete the current comment, delete all 
comments from the same author, or delete all comments in the presentation.

Figure 32: Inserting comments

You can move the small comment markers to anywhere you wish on the slide. Typically you might 
place it on or near an object you refer to in the comment.

To show or hide the comment markers, choose View > Comments.

Select Tools > Options > User Data to configure the name you want to appear in the comment.

If more than one person edits the document, each author is automatically allocated a different 
background color for their comments.
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Creating a photo album

Impress can creat a photo album from a set of images, usually with one photo per slide. This photo 
album can source multimedia shows with graphics and images or even collect your latest vacation 
pictures into a presentation file.

To insert a photo album into your presentation

 1) Open an existing or blank presentation.

 2) Go to the slide that precedes the photo album.

 3) Choose Insert > Media > Photo Album.

 4) In the Create Photo Album dialog (Figure 33), click Add. A standard file browser opens.

 5) Locate the files you want to insert.

Note
If several images are in the same folder, you can select a group of photos using the 
Shift or Ctrl keys while clicking on their filenames.

 6) Click Open to add the files to the Photo Album.

Figure 33: The photo album dialog box with photo preview

Tip
Click on a file name to display it in the Preview area.

 7) Select the number of images per slide in the Slide layout list box.

 8) Select the Add caption to each slide option, if necessary, to insert a text box for the 
caption.

 9) Create the required sequence by removing images or moving them up or down in the list of 
images. When the sequence of images is ready, click Insert Slides. (You can change the 
sequence and remove or insert images later, as you can with any slides.)

Impress will create a presentation with as many pages as determined by the Slide layout number 
of slides per page. If you selected Add caption to each slide, there will be a placeholder for the 
image caption (title) on each slide.
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Tip
Use the slide sorter (see page 11) to reorder your photo album. Use slide transitions 
(page 36) to go smoothly to  the following photo. Use audio resources (page 27) to 
insert a musical background.

Setting up a slide show

As mentioned in “Modifying the slide show” on page 19, Impress allocates reasonable default 
settings for slide shows, while at the same time allowing for customizing many aspects of the slide 
show experience. This section covers only some aspects; more advanced techniques are 
explained in the Impress Guide Chapter 9 Slide Shows.

Most of the tasks are best done in Slide Sorter view where you can see most of the slides 
simultaneously. Go to View > Slide Sorter on the Menu bar or click the Slide Sorter tab at the top 
of the Workspace.

One slide set – multiple presentations
In many situations, you may find that you have more slides than the time available to present them 
or you may want to provide a rapid overview without dwelling on the details. Rather than having to 
create a new presentation, you can use two tools that Impress offers: hiding slides and custom 
slide shows.

Hiding slides
 1) Select the slide you want to hide in the Slide Pane or Slide Sorter view on the Workspace 

area.

 2) Go to Slide > Hide Slide on the Menu bar or right-click on the slide thumbnail and select 
Hide Slide from the context menu. Hidden slides are marked by a diagonal bars across the 
slide.

Custom slide shows
If you want to create a custom slide show from the same presentation:

 1) Select the slides you want to use in your custom slide show.

 2) Go to Slide Show > Custom Slide Show on the Menu bar.

 3) Click on the New button to create a new sequence of slides and save it with a different 
name. You can have as many slide shows as you want from a single presentation.

Slide transitions
Slide transition is the animation that is played when a slide is changed for the next slide in your 
presentation. You can configure the slide transition from the Slide Transition section in the Tasks 
Pane.

 1) Go to Slide > Slide Transition on the Menu bar or click on the Slide Transition icon  
on the Sidebar to open the options available for slide transitions.

 2) Select the desired transition, the speed of the animation, and whether the transition should 
happen when you click the mouse (preferred) or automatically after a certain number of 
seconds.

 3) Click Apply to All Slides to apply the transition for all of your presentation or continue 
selecting transitions to place between each slide in your presentation.
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Tip
The Slide Transition section has a very useful choice: Automatic preview. Select its 
checkbox and when you make any changes in a slide transition, the new slide is 
previewed in the Slide Design area, including its transition effect.

Slide advance
You can set the presentation to advance automatically to the next slide after a set amount of time 
from the Slide Transition section in the Sidebar.

 1) Go to Advance slide and select the Automatically after option.

 2) Enter the required amount of time in seconds that each slide will be displayed.

 3) Click on the Apply to All Slides button to apply the same display time to all slides.

To apply a different display time to each slide in your presentation:

 1) Go to Slide Show > Rehearse Timings on the Menu bar and the slide show starts.

 2) When you are ready to advance to the next slide, mouse click on the display background or 
press the right arrow or space bar on your keyboard.

 3) Impress will memorize the timings for each slide and will advance to the next slide 
automatically using these timings when you run the slide show.

To restart a slide show automatically after the last slide has been displayed:

 1) Go to Slide Show > Slide Show Settings on the Menu bar.

 2) Select Auto and the timing of the pause between slide shows.

 3) Click OK when you have finished.

Running a slide show 
To run a slide show, do one of the following:

• Click Slide Show > Start from first Slide on the Menu bar.

• Click the Start from first Slide icon  on the Presentation toolbar.

• Press F5 on the keyboard.

If the slide advance is set to Automatically after X sec, let the slide show run by itself.

If the slide advance is set to On mouse click, do one of the following to move from one slide to the 
next:

• Use the arrow keys on the keyboard to go to the next slide or to go back to the previous 
one.

• Click the mouse to move to the next slide.

• Press the spacebar on the keyboard to advance to the next slide.

Right-click anywhere on the screen to open a context menu where you can navigate through the 
slides and set other options.

To exit the slide show at any time including when the slide show has ended, press the Esc key.

Presenter Console
LibreOffice Impress has a Presenter Console function that can be used when an extra display for 
presentation has been connected to your computer. The Presenter Console (Figure 34) provides 
extra control over slide shows by using different views on your computer display and on the display 
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that the audience sees. The view you see on your computer display includes the current slide, the 
upcoming slide, any slide notes, and a presentation timer.

For more information and details about using the Presenter Console, see the Impress Guide 
Chapter 9 Slide Shows.

Figure 34: Impress Presenter Console

Using Impress Remote control

Impress Remote is a mobile application developed by the community for Android and iOS systems 
that allows you to control a live presentation with a mobile device such as a phone or tablet.

The connection between your mobile device and the computer running your presentation is made 
through a Bluetooth pairing or a local network connection between the two.

Getting Impress Remote
To get the software, access your mobile device application store, either Google Play Store for 
Android devices or Apple Store for IOs devices. Search for “Impress Remote” and select the one 
that is from The Document Foundation and install it in your device.

Connecting the mobile device to the computer
Activate Bluetooth on both devices, then pair the devices. (Refer to the manuals for your mobile 
device and computer operating system for instructions on enabling, setting up a Bluetooth 
identifier, and pairing.)

Once the pairing is established, your mobile device is ready to control your presentation.

Enabling remote control in Impress
An Impress slide show with remote control is not enabled by default. To enable it, go to Tools > 
Options > LibreOffice Impress > General and select Enable Remote Control checkbox in the 
Presentation area of the dialog (Figure 35).
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Figure 35: LibreOffice  settings for Impress remote control

Running a slide show with Impress Remote
To run a slide show using Impress Remote, follow these steps:

 1) On both devices, make sure Bluetooth is already enabled and configured.

 2) On your computer, open the presentation you would like to present.

 3) On your phone:

a) Open Impress Remote from the main menu (Figure 36).

b) To select your computer, tap its name. The presentation opened on the computer 
begins automatically (Figures 37 and 38).

Figure 36: Bluetooth 
visible device

Figure 37: Impress 
presentation as seen in 
mobile device

Figure 38: All slides
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To advance the presentation
Tap the slide thumbnail or use the phone’s physical volume up button.

To go backwards
Double-tap the slide thumbnail or use the phone’s physical volume down button.

To skip slide animations and transitions
Swipe left to go to the next slide, or swipe right to go backwards.

To end the presentation, use the Back button of the phone, or open the menu and select Stop 
slide show.
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