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Managing Graphic Objects

Introduction
This chapter describes how to manage graphic objects and in particular how to rotate, distort,
arrange, and position them on the slide. Though this chapter focuses on the shapes that can be
created with the available tools in Impress, some of the techniques described in this chapter are
also applicable to images imported into slides.

Drawing toolbar
Default drawing tools
The Drawing toolbar (Figure 1) contains the majority of the tools normally used to create graphic
objects. If this toolbar is not visible, select View > Toolbars > Drawing from the main menu bar.
Table 1 describes the default set of tools that are available on the Drawing toolbar.
To draw a shape, select the desired tool from the toolbar (or from the submenu opened by clicking
the triangle to the right of the tool), then place your cursor on the slide and drag the mouse to
define an enclosing rectangle. Keep the Shift key pressed to obtain a shape where the height and
width are equal. Press the Alt key to draw a shape from its center.

Figure 1: Drawing toolbar
Your Drawing toolbar may differ from the one shown in Figure 1 as this depends on
how many drawing tools have been placed on the toolbar. Right-click on an empty
area of the Drawing toolbar, then select Visible Buttons from the context menu to
display the available tools. From this dialog you can install and remove tools to and
from the toolbar. Installed tools are indicated by a border around the icon.

Note

Table 1: Default set of drawing tools on the Drawing toolbar
Tool

Name

Purpose

Select

Selects objects. To select a group of objects, click above the top left object
and drag the mouse below the bottom right object of the intended selection
while keeping the mouse button pressed. A “marching ants” rectangle
identifying the selection area is displayed. You can also select several
objects by pressing and holding the Shift key while selecting the individual
objects.

Line

Draws a straight line from the point where you click the mouse to the point
where you drag the mouse pointer and release the mouse button. Press
the Shift key to restrict the angle of the line to multiples of 45°. Press the
Alt key to draw a line from its center. Press the Ctrl key to detach the end
point of the line from the grid (see “Snapping objects to grid or snap
guides” on page 21).

Line Ends
with Arrow

Draws a straight line ending with an arrowhead. The arrowhead is placed
at the end of the line where you release the mouse button. The Shift, Alt
and Ctrl keys have the same effect as for the Line tool.

Drawing toolbar
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Tool
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Name

Purpose

Rectangle

Draws a rectangle when you drag the mouse from the top left to the bottom
right corner. Press the Shift key to draw a square. Press the Alt key to draw
a rectangle or square from its center.

Ellipse

Draws an ellipse. Press the Shift key to draw a circle. Press the Alt key to
draw an ellipse or circle from its center.

Text

Creates a text box with text aligned horizontally.

Vertical Text

Creates a text box with text aligned vertically. This tool is available only
when Asian language support has been enabled in Tools > Options >
Language Settings > Languages.

Curve

Draws a shape depending on the option that has been selected. Click the
triangle to the right of the tool icon to show the available options. Actual
icon shown will depend on the option that has been selected. Note that the
title of this submenu when undocked from the Drawing toolbar is Lines.

Connector

Draws a connector line between two figures. Click the triangle to the right
of the tool icon to show the available options. Actual icon shown will
depend on the option that has been selected. Each option is described in
“Working with connectors” on page 24.

Lines and
Arrows

Draws a line ending in an arrow. Click the triangle to the right of the tool
icon to show the available options. Actual icon shown will depend on the
option that has been selected. Note that the title of this submenu when
undocked from the Drawing toolbar is Arrows.

Basic
Shapes

Click the triangle to the right of the tool icon to open a toolbar showing the
available options. Actual icon shown will depend on the option that has
been selected.
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Tool

Name

Purpose

Symbol
Shapes

Click the triangle to the right of the tool icon to open a toolbar showing the
available options. Actual icon shown will depend on the option that has
been selected.

Block
Arrows

Click the triangle to the right of the tool icon to open a toolbar showing the
available options. Actual icon shown will depend on the option that has
been selected.

Flowcharts

Click the triangle to the right of the tool icon to open a toolbar showing the
available options. Actual icon shown will depend on the option that has
been selected.

Callouts

Click the triangle to the right of the tool icon to open a toolbar showing the
available options. Actual icon shown will depend on the option that has
been selected.

Stars

Click the triangle to the right of the tool icon to open a toolbar showing the
available options. Actual icon shown will depend on the option that has
been selected.

Points

Edits the individual points that form the shape or line. Select this tool and
then select a shape or a line. You can also press the F8 key to select this
tool.

Glue Points

Edits the glue points of a graphic object. Glue points are the positions
where connector lines terminate or start. See “Managing glue points” on
page 25 for instructions.

Fontwork
Gallery

Opens the Fontwork gallery. See “Using Fontwork” on page 29 for further
information.

From File

Equivalent to Insert > Picture > From file on the main menu bar. See
Chapter 4 Adding and Formatting Pictures for details.

Drawing toolbar
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Tool

Name

Purpose

Gallery

Opens the gallery. Equivalent to Tools > Gallery on the main menu bar.
See Chapter 4 Adding and Formatting Pictures for details.

Extrusion
On/Off

Switches 3D effects on or off for the selected object. Clicking this button
also opens the 3D settings toolbar. See “Working with 3D objects” on page
26 for details.

Additional drawing tools
In addition to the default set of drawing tools available on the Drawing toolbar (Figure 1), you can
install additional tools. These additional tools are described in Table 2.
To install additional tools onto the Drawing toolbar:
1) Right-click on an empty area on the Drawing toolbar.
2) Select Visible Buttons from the context menu to display a list of the available tools.
3) To install a tool, click on it and the tool will appear in the Drawing toolbar. The list of
available tools will close automatically. Installed tools are indicated by a border around the
icon.
To remove any additional tools from the Drawing toolbar:
1) Right-click on an empty area on the Drawing toolbar.
2) Select Visible Buttons from the context menu to display a list of the available tools.
3) To remove a tool, click on it and the tool is removed from the Drawing toolbar. Uninstalling
a tool removes the border around the tool icon. The list of available tools will close
automatically.

Table 2: Additional drawing tools
Tool
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Name

Purpose

3D Objects

Click the triangle to the right of the tool icon to open a toolbar showing the
available options. Actual icon shown will depend on the option that has
been selected. Select the desired 3D shape, then draw it by placing your
cursor on the slide and dragging your mouse to define an enclosing
rectangle. Keep the Shift key pressed to obtain a 3D shape where the
height and width are equal. Press the Alt key to draw a 3D shape from its
center.

To Curve

Converts the selected object to a Bézier curve.

To Polygon

Converts the selected object to a polygon (a closed object bounded by
straight lines). The appearance of the object does not change. If you want,
you can right-click and choose Edit Points to view the changes.

To 3D

Converts the selected 2D object to a 3D object.

To 3D
Rotation
Object

Converts the selected 2D object to a 3D rotation object.
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Tool

Name

Purpose

Insert

Inserts a slide, table, from file, movie and sound, formula, or chart into your
presentation. Click the triangle to the right of the tool icon to open the
Insert toolbar showing the available options. Actual icon shown depends
on the option that has been selected.

Controls

Inserts various form controls into your presentation. Click the triangle to the
right of the tool icon to open the Form Controls toolbar showing the
available options.

Animated
Image

Adds animation to a selected object on a slide. Opens the Animation
dialog.

Creating lines and shapes
Creating shapes and lines is basically the same procedure for all lines and shapes:
1) Click on the triangle to the right of the tool you want to use on the Drawing toolbar and
select the desired tool from the available selection. Note that the tools on the Drawing
toolbar show the last tool shape selected.
2) Position your cursor on the slide, then click and drag to create the line or shape.
3) Release the mouse button when you have drawn your line or shape. You can then modify
and reposition your line or shape using the procedures described later in this chapter.

Regular shapes
When creating shapes that are included in Impress, one or more dots may be displayed in a
different color to the selection handles. These dots perform a different function according to the
shape they are applied to, as listed below.
Basic Shapes

• Rounded rectangle and rounded square – use the dot to change the radius of the curve
that replaces the angled corners of a rectangle or square.

• Circle pie – use the dots to change the size of the filled sector.
• Isosceles triangle – use the dot to modify the shape and type of the triangle.
• Trapezoid, parallelogram, hexagon, or octagon – use the dot to change the internal angles
between the sides.

•
•
•
•
•
•

Cross – use the dot to change the thickness of the four arms of the cross.
Ring – use the dot to change the internal diameter of the ring.
Block arc – use the dot to change both internal diameter and size of the filled area.
Cylinder and cube – use the dot to change the perspective.
Folded corner – use the dot to change the size of the folded corner.
Frame – use the dot to change the thickness of the frame.

Creating lines and shapes
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Symbol Shapes

•
•
•
•

Smiley face – use the dot to change the smile on the face.
Sun, moon and heart – use the dot to change the shape of the symbol.
Prohibited symbol – use the dot to change the thickness of the ring and the diagonal bar.
Double bracket, left bracket, right bracket and double brace – use the dot to change the
curvature of the bracket.

• Left brace and right brace – use the dots to change the curvature of the brace and the
position of the point.

• Square bevel, octagon bevel and diamond bevel – use the dot to change the thickness of
the bevel.
Block Arrows

• Left arrow, right arrow, up arrow, down arrow, left and right arrow, up and down arrow,
striped right arrow and notched right arrow – use the dot to change the shape and
thickness of the arrows.

• Up and right arrow, up, right and down arrow and 4-way arrow – use the dots to change the
shape and thickness of the arrows.

• Pentagon and chevron – use the dot to change the angle between the sides and the shape.
• Right arrow callout, left arrow callout, up arrow callout, down arrow callout, left and right
arrow callout, up and down arrow callout, up and right arrow callout and 4-way arrow
callout – use the dots to change the shape and thickness of the callouts.

• Circular arrow – use the dots to change the thickness and area of the arrow.
Callouts

• For all callouts use the dots to change the length, position and angle of the pointer.
Stars

• 4-point star, 8-point star and 24-point star – use the dot to change the thickness and shape
of the star points.

• Vertical scroll and horizontal scroll – use the dot to change the width and shape of the
scroll.

• Doorplate – use the dot to change the inward curvature of the corners.

Curves, polygons and freeform lines

Figure 2: Lines (curves) toolbar
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To draw a curve, polygon, or freeform line, click the Curve icon
on the Drawing toolbar. The
default action of this tool is to show the last selected tool and, by default, the last selected tool will
be used. To use a different tool, click on the triangle to the right of the icon to open the tools that
are available (Figure 2). Note that the title of this tool submenu when undocked from the Drawing
toolbar is Lines.
If a filled curve, polygon, or freeform line was selected, Impress draws the line connecting the last
point to the start point and fills the inside area with the default color.

Curves
1)
2)
3)
4)
5)
6)

Select either Curve filled or Curve.
Click and hold the left mouse button to create the starting point of your curve.
While holding down the left mouse button, drag from the starting point to draw a line.
Release the left mouse button and continue to drag the cursor to bend the line into a curve.
Click to set the end point of the curve and fix the line on the page.
To continue with the line, drag the mouse cursor to draw a straight line. Each mouse click
sets a corner point and allows you to continue drawing another straight line from the corner
point.
7) Double-click to end the drawing of your line.

Note

Holding down the Shift key when drawing lines with the Curve or Polygon tools will
also restrict the angles between the lines to 45 or 90 degrees.

Polygons
1) Select either Polygon filled or Polygon.
2) Click and draw the first line from the start point with the left mouse button held down. As
soon as you release the mouse button, a line between the first and second points is drawn.
3) Move the cursor to draw the next line. Each mouse click sets a corner point and allows you
to draw another line.
4) Double-click to end the drawing of your polygon.

Polygons 45°
Select either Polygon (45°) filled or Polygon (45°) and these polygons are drawn in the same
way as polygons above. However, the angles between line segments are restricted to 45 or 90
degrees as you draw your polygon.

Freeform lines
Using the Freeform Line tools is similar to drawing with a pencil on paper.
1) Select either Freeform line filled or Freeform line.
2) Press and hold the left mouse button and drag the cursor to the line shape you require.
3) When you finished drawing your freeform line, release the mouse button and the drawing is
completed.

Creating lines and shapes
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Grouping objects together
It is often convenient to group objects together so that they are treated as a single object by
Impress. A group of objects can be formatted as if it was a single object, moved, rotated, deleted,
and so on.
This section gives only a brief introduction to grouping of objects. For more information on working
with grouped objects, see the Draw Guide Chapter 5 Combining Multiple Objects.

Grouping
To group objects together:
1) Select the objects to be grouped using the selection tool on the Drawing toolbar and draw a
rectangle around the objects to be grouped, or hold down the Shift key and click on each
object. To select all the objects, go to Edit > Select All on the main menu bar or use the
keyboard combination Ctrl+A.
2) When the selection handles are displayed, go to Format > Group > Group on the main
menu bar or use the keyboard combination Ctrl+Shift+G or right-click on an object within
the selected group and select Group from the context menu.

Editing or formatting groups
To edit or format a group of objects:
1) Click on any one of the objects in the group to select the group. Any editing or formatting is
then carried out on all the objects within the group.
2) To edit an individual object within a group:
a) After selecting the group, press the F3 key or go to Format > Group > Enter Group on
the main menu bar or right-click and select Enter Group from the context menu.
b) Select individual objects within the group for editing or formatting.
c) When you have finished editing or formatting, use the keyboard combination Ctrl+F3 or
go to Format > Group > Exit group on the main menu bar or right-click and select Exit
Group from the context menu. The whole group then becomes selected.

Ungrouping
To ungroup objects:
1) Click on any one of the objects in the group to select the group.
2) When the selection handles are displayed, go to Format > Group > Ungroup on the menu
bar or use the keyboard combination Ctrl+Alt+Shift+G or right-click on the group and select
Ungroup from the context menu.

Tip
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If you use the group and ungroup commands often, why not add them to one of the
toolbars shown by default so that the commands are readily available? To do so, you
will need to customize the selected toolbar. See Chapter 11 Setting Up and
Customizing Impress.
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Positioning graphic objects
Using a mouse
To position a graphic object using a mouse:
1) Click on a graphic object or a group of objects to display the selection handles.
2) Move the cursor over a selected graphic object until the cursor changes shape. For
example, on most operating systems, the cursor associated with moving objects is a
clenched hand or a four-headed arrow.
3) Click and drag the graphic object to the desired position. You can also use the arrow keys
to move the selected object or group to a new position.
4) Release the mouse button.

Tip

By default Impress makes the objects snap to the grid. If you need to position the
object between two points of the grid, hold down the Ctrl key, then click on the object
and move it to the desired position. Alternatively, you can turn off this snap function or
modify the grid resolution by going to Tools > Options > LibreOffice Impress >
Grid.

Using the Position and Size dialog
For a more accurate placement of the graphic object, use the Position and Size dialog (Figure 3):
1) With the object selected and the selection handles displayed, press F4 or go to Format >
Position and Size on the main menu bar, or right-click on the selected object and select
Position and Size from the context menu.
2) Click on the Position and Size tab.

Figure 3: Position and Size dialog
Positioning graphic objects
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3) Use the Position section of the dialog to specify the X (horizontal) and Y (vertical) position
of the graphic object. The values represent the distance of the base point selected on the
right hand side of the dialog. The default selection for base point is relative to the top left
corner of the slide.
4) To prevent accidental modification of the position of the graphic object, select the Position
option in the Protect section of the dialog.
5) Click OK when satisfied and to close the dialog.

Note

The units of measurement for this dialog and other dialogs in Impress are set in
Tools > Options > LibreOffice Impress > General.

Using the Sidebar
You can use the Position and Size subsection on the Sidebar to position a graphic object. After
selecting the graphic object, click on the Properties icon
on the Sidebar and then click on the
plus (+) sign next to the title to open the Position and Size subsection (Figure 4).
Use the Horizontal and Vertical text boxes and enter the values you want to use for the X
(horizontal) and Y (vertical) position of the graphic object. The values represent the distance of the
selected base point and the default position is the top left corner of the slide.

Note

Clicking on the More Options icon on the Sidebar Position and Size subsection will
open the Position and Size dialog.

Figure 4: Sidebar – Position and Size subsection
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Resizing graphic objects
Using a mouse
To resize a graphic object using a mouse:
1) Click on a graphic object or a group of objects to display the selection handles.
2) Position the pointer over one of the selection handles. The pointer changes shape giving a
graphical representation of the direction of the resizing. The corner handles resize both the
width and the height of the graphic object simultaneously, while the other four handles
resize only one dimension at a time.
3) Click and drag to resize the graphic object.
4) Release the mouse button to complete resizing.

Tip

To retain the original proportions of the graphic, Shift+click one of the corner handles,
then drag. Release the mouse button before releasing the Shift key.

Using the Position and Size dialog
For more accurate resizing of the graphic object, use the Position and Size dialog (Figure 3):
1) With the object selected and the selection handles displayed, press F4 or go to Format >
Position and Size on the main menu bar, or right-click on the selected object and select
Position and Size from the context menu.
2) Click on the Position and Size tab.
3) Select as the base point the part of the graphic object that you would like to anchor to the
page. The default selection of top left corner means, that when resizing, the position of the
top left corner of the object will not change.
4) Now modify either the Width value or the Height value of the object in the Size section.
5) To maintain the proportions between width and height, select the Keep ratio option before
modifying any value. When Keep ratio is selected, changes to one dimension results in an
automatic change to the other with the ratio between width and height maintained.
6) To prevent accidental modifications of the size, select the Size option in the Protect section
of the dialog.
7) Click OK when satisfied and to close the dialog.

Using the Sidebar
You can use the Position and Size subsection on the Sidebar to resize a graphic object. After
selecting your graphic object, click on the Properties icon
on the Sidebar and then click on
then click on the plus (+) sign next to the title to open the Position and Size subsection (Figure 4).
Use the Width and Height text boxes and enter the values for the width and height of the graphic
object. To maintain the ratio between width and height of a graphic object, select the Keep ratio
option.

Note

Clicking on the More Options icon on the Sidebar Position and Size subsection will
open the Position and Size dialog.

Resizing graphic objects
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Applying special effects
As well as the basic actions of moving and resizing an object, a number of special effects can also
be applied to objects in Impress. Several of these effects are readily available in the Mode toolbar
(Figure 5). If the Mode toolbar is not showing, select it from View > Toolbars > Mode.
This section describes how to rotate, flip, distort and two ways of setting an object in a circle. The
transparency and gradient tools are more specific to formatting and are discussed in Chapter 6
Formatting Graphic Objects.

Figure 5: Mode toolbar

Rotating graphic objects
Rotation of an object can be carried out either using your mouse, using a dedicated dialog, or
using the Sidebar. This is similar to changing position and size of an object.

Using a mouse
To rotate a graphic using a mouse:
1) Click on a graphic object and the selection handles will show.
2) Click the Rotate icon
on the Line and Filling or Mode toolbars or click again on the
graphic object. The square selection handles change shape and also change color (Figure
6). Also, a pivot point indicating the rotation center appears in the center of the object.
3) Move the mouse over one of the corner handles and the mouse cursor shape will change.
4) Click the mouse and move in the direction in which you want to rotate the graphic object.
Only the corner selection handles are active for rotation.
5) When satisfied with the rotation, release the mouse button.
6) To change the rotation center of the object, click and drag the pivot point to the desired
position before rotating. The pivot point can be moved to any position on the slide, even
outside of the object boundaries.
7) To restrict the rotation angles to multiples of 15 degrees, press and hold the Shift key while
rotating the graphic. This is very handy for rotating pictures through a right angle, for
example from portrait to landscape. Remember to release the Shift key before releasing
the mouse button.

Note
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The icons representing the functions in the toolbars may be different depending on
the operating system used and on whether LibreOffice has been customized. When
in doubt, hover the mouse over an icon and wait for the tooltip to appear showing the
name of the icon.
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Figure 6: Object selected for rotation

Using the Position and Size dialog
Instead of rotating a graphic object manually, you can use the Rotation page of the Position and
Size dialog (Figure 7) to accurately rotate an object in degrees:
1) With the object selected and the selection handles displayed, press F4 or go to Format >
Position and Size on the main menu bar, or right-click on the selected object and select
Position and Size from the context menu.
2) Click on the Rotation tab.

Figure 7: Rotation page of the Position and Size dialog
3) In the Pivot point section, select the position of the pivot point. The default position of the
pivot point is the center of the object.
4) In the Rotation angle section, enter the degrees in the Angle text box by which to rotate
the graphic object.
5) Alternatively, in Default settings, click on the Rotation Angle indicator and drag it to a new
angle. The angle of rotation is displayed in the Angle text box.
6) Click OK when satisfied and to close the dialog.
Applying special effects
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Using the Sidebar
You can use the Position and Size subsection on the Sidebar to rotate a graphic object. After
selecting your graphic object, click on the Properties icon
on the Sidebar and then click on
then click on the plus (+) sign next to the title to open the Position and Size subsection (Figure 4).
In Rotation, either, click on the Rotation Angle indicator and drag it to a new angle, or enter the
rotation angle in Rotation text box, or select an angle setting from the drop-down list.

Note

Clicking on the More Options icon on the Sidebar Position and Size subsection will
open the Position and Size dialog.

Flipping objects
Using the context menu
The quickest and easiest method to flip an object horizontally or vertically is as follows:
1) Click on a graphic object to display the selection handles.
2) Right-click on the selected object and select Flip > Horizontally or Flip > Vertically from
the context menu to flip the selected object so it faces the other direction.

Using the Flip tool
The Flip tool on the Drawing or Mode toolbar can also be used. Using this tool also allows you to
change the position and angle that the object flips over (Figure 8).
1) Click on a graphic object and the selection handles will show.
2) Click on the Flip icon
on the Drawing or Mode toolbar and the axis of symmetry
appears as a dashed line through the center of the object. The object will be flipped about
this axis of symmetry.
3) Click and drag the axis of symmetry to a new position, or position the cursor in one of the
circles at each end of the axis of symmetry and drag with your mouse cursor to change the
angle.
4) Place the mouse cursor over one of the object selection handles until it changes shape.
5) Click and drag your cursor across the axis of symmetry to flip the object. The new position
of the object is shown faintly until the mouse is released.
6) Release the mouse button and the object will appear flipped over. Angle and position of the
flip will depend on the angle and position of the axis of symmetry.

Figure 8: Using the Flip tool
18
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Note

If you press the Shift key while moving the axis of symmetry, it will rotate in 45-degree
increments.

Using the Sidebar
You can use the Position and Size subsection on the Sidebar to rotate a graphic object. After
selecting your graphic object, click on the Properties icon
on the Sidebar and then click on
then click on the plus (+) sign next to the title to open the Position and Size subsection (Figure 4).
In Rotation, click on the Flip Vertical icon
axis or click on the Flip Horizontal icon
axis.

Note

to flip the selected object vertically about its central
to flip the selected object horizontally about its central

Clicking on the More Options icon on the Sidebar Position and Size subsection will
open the Position and Size dialog.

Mirror copies
Impress does not include a mirror command. However, mirroring an object can be emulated by
flipping the object:
1) Select the object you want to make a mirror copy of and copy the object to the clipboard.
2) Flip the object using one of the methods in “Flipping objects” above, then move the flipped
object to one side.
3) Click on an empty area of the page to deselect the object.
4) Paste from the clipboard to put a copy of the object into your slide.
5) Select both images, then right-click and select Alignment from the context menu.
6) Select the type of alignment you want to use. Top, Center, or Bottom if you are creating a
horizontal mirror copy. Left, Centered, or Right if you are creating a vertical mirror copy.

Distorting images
Three tools on the Mode toolbar (Figure 5 on page 16) let you drag the corners and edges of an
object to distort the image. The Distort icon

distorts an object in perspective, the Set to Circle

(slant) icon
and Set in Circle (perspective) icon
both create a pseudo three-dimensional
effect. Note that when using these tools, you have to transform an object to a curve before
distorting.

Distort tool
1) Select an object and click on the Distort icon
on the Mode toolbar.
2) Click Yes to convert the object to a curve. If the object is already a curve, this dialog does
not appear.
3) Click and drag a corner selection handle to distort the object using the opposite corner
selection handle as an anchor point for the distortion (Figure 9).
4) Click and drag the vertical selection handles to distort the object using the opposite vertical
side as an anchor point for the distortion.
5) Click and drag the horizontal selection handles to distort the object using the opposite
horizontal side as an anchor point for the distortion.
Applying special effects
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Figure 9: Distorting an object

Set in circle (perspective) tool

Figure 10: Setting an image to a circle with perspective
1) Select an object and click on the Set in Circle (perspective) icon
in the Mode toolbar.
2) Click Yes to convert the object to a curve. If the object is already a curve, this dialog does
not appear.
3) Click and drag one of the selection handles to give a pseudo three-dimensional perspective
using the opposite side as an anchor point (Figure 10). A ghosted image appears as you
drag to give you and indication of the resulting object will look.

Set to circle (slant) tool

Figure 11: Setting an image to a circle with slant
1) Select an object and click on the Set to Circle (slant) icon
in the Mode toolbar.
2) Click Yes to convert the object to a curve. If the object is already a curve, this dialog does
not appear.
3) Click and drag one of the selection handles to give a pseudo three-dimensional perspective
using the opposite side as an anchor point (Figure 11). A ghosted image appears as you
drag to give you and indication of the resulting object will look.
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Note

Transforming an object into a curve is a safe operation, but it cannot be reversed
other than by using the Undo function.

Aligning objects
Use the alignment tools to adjust the relative position of an object compared to another object.
These alignment tools are only available if two or more objects are selected.

Figure 12: Align Objects toolbar
1) Select the objects you want to align.
2) Click on the triangle to the right of the Alignment icon
in the Line and Filling toolbar or
go to View > Toolbars > Align Objects on the main menu bar to open the Align Objects
toolbar (Figure 12). The Alignment icon shown on the Line and Filling toolbar will depend
on the alignment option that had been previously selected.
3) Alternatively, right-click on the group of selected objects and select Alignment, then one of
the alignment options from the context menu.
The alignment options are as follows:

• Left, Centered, Right – determines the horizontal alignment of the selected objects.
• Top, Center, Bottom – determines the vertical alignment of the selected objects.

Snapping objects to grid or snap guides
Sometimes it is important to align objects to specific points of the page or to make sure that objects
that appear on multiple slides are placed in exactly the same position. For this purpose Impress
provides two mechanisms: Grid and Snap Lines.

Using the grid
Options for the grid are available by right-clicking on an empty part of the page in Normal view and
choosing Grid or by selecting View > Grid from the menu bar. The options available from the
context menu that opens are:

• Display Grid – displays the grid.
• Snap to Grid – the anchor points of an object will be placed on a grid when the object is
moved or resized.

• Grid to Front – displays the grid in the foreground.

Snapping objects to grid or snap guides
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To set up the grid spacing and snapping options, go to Tools > Options > LibreOffice Impress >
Grid on the menu bar.

Using snap lines
Options for the guides are available by right-clicking on an empty part of the page in Normal view
and choosing Snap Lines or by selecting View > Snap Lines from the menu bar. The options
available from the context menu that opens are:

• Display Guides – the guides are shown on the slide.
• Snap to Snap Lines – the anchor points of the objects snap to the guides when the object
is moved or resized.

• Snap Lines to Front – displays the guides in the foreground.

Figure 13: New Snap Object dialog

Creating a new snap point/line
1) Right-click on an empty part of the work area and select Insert Snap Point/Line from the
context menu to open the New Snap Object dialog (Figure 13).
2) Specify the type of snap object. Depending on the choice made determines which field
becomes active:

•
•
•

Point both X and Y fields become active.
Vertical only X field becomes active.

Horizontal only Y field become active.
3) Enter the position of the snap point/line.
4) Click OK to close the dialog.

Tip

When positioning the Snap Lines, it is useful to display the rulers. To do so, select
View > Rulers. Drag a Snap Line directly onto the slide by clicking on the ruler and
then dragging onto the slide.

Editing snap points/lines
1) Right-click next to or on the guide to be edited.
2) Select Edit Snap line from the context menu.
3) Enter a new value in the X or Y field for the line position and click OK.
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Deleting guides
1) Right-click next or on the guide to be deleted.
2) Select Delete Snap line from the context menu.

Arranging objects
Impress organizes objects in a stack so that the objects on the top level of the stack cover the
objects on lower levels if any overlapping occurs. The stack level of each object can be changed
by arranging shapes on a slide or page.
To change the stack level of an object, select an object or objects and then click the small triangle
on the side of the Arrange icon
on the Line and Filling toolbar to open the Position toolbar
(Figure 14). The Arrange icon shown on the Line and Filling toolbar will depend on the arrange
option that had been previously selected.
Alternatively, right-click on your selected objects and select Arrange, then select an arrange option
from the context menu.
The first four tools determine the stack level of a selected object:

•
•
•
•

Bring to front: – the selected object is moved in front of all other objects.
Bring forward – the selected object is moved one level up in the stack.
Send backwards – the selected object is moved one level down in the stack.
Send to back – the selected object is moved behind all other objects.The other three tools
determine the relative positions of the selected objects:

• In front of object – moves the first selected object in front of the second selected object.
• Behind object – moves the first selected object behind the second selected object.
• Reverse – swaps the stacking order of two selected objects.

Figure 14: Position toolbar
To use the In front of object and Behind object tools:
1) Select the first object by clicking on it.
2) Select In front of object or Behind object from the context menu and the mouse cursor
changes to a pointing hand.
3) Click on the second object and the objects swap positions.

Arranging objects
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Working with connectors
Connectors are lines that can be anchored to glue points and by default are positioned on the
border of an object. When an object with a connector attached is moved or resized, the connector
automatically adjusts to the change. When creating a flowchart, organization chart, schematics, or
diagrams, it is highly recommended to use connectors instead of simple lines.
When a connector is drawn or selected Impress displays selection handles which are not shown
for normal lines. The termination points of a connector are square at the start of a connector and
round at the end of a connector. The selection handles on a connector are used to modify the
routing of a connector where applicable.
Impress offers a wide variety of predefined connectors, which differ in the termination shape (none,
arrow, custom) and in the way the connector is drawn (straight, line, curved).

Figure 15: Connector toolbar

Drawing connectors
A simple method of drawing is as follows. For more information on how to format a connector, refer
to Chapter 6 Formatting Graphic Objects.
1) Click on the triangle next to the Connector icon
on the Drawing toolbar and select the
type of connector you want to use. The Connector icon shown on the Drawing toolbar will
depend on the connector that had been previously selected and used (Figure 15).
2) Move the mouse cursor over one of the objects to be connected and small crosses appear
around the object edges which are the glue points to which a connector can be attached
(Figure 16).
3) Click on the required glue point to attach one end of the connector, then hold the mouse
button down and drag the connector to another object.
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Figure 16: Example of using a connector
4) When the cursor is over the glue point of the target object release the mouse button and
the connector is drawn.
5) The selection handles that appear on the connector are used to adjust the path of the
connector so that the connector does not cover another object in its path.

Managing glue points
A glue point is the attachment point for a connector on an object. Each object shape has a number
of predefined glue points, but it is possible to define new ones, as well as edit them, using the
Gluepoints toolbar.
1) Click on the Gluepoints icon
on the Drawing toolbar or go to View > Toolbars >
Gluepoints on the main menu bar to open the toolbar (Figure 17).
2) Select an object on your slide.
3) To insert a new glue point onto the selected object, click on the Insert Glue Point icon.
4) If you want to fix the direction a connector uses when connecting to a glue point, click on
one of the exit direction icons. This is useful if you have multiple connectors terminating on
one side of an object or the position of the default glue point is not satisfactory.
5) Move the cursor to the position you require on the selected object, then click the mouse
button to insert the glue point.
6) Make sure that the Glue point relative icon is selected to maintain the relative position of a
glue point when resizing the object.

Figure 17: Gluepoints toolbar

Working with connectors
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7) Deselecting the Glue point relative icon activates the remaining six icons on the toolbar.
Use these tools to fix the position of the glue point during the resizing of the object.
8) To delete a glue point you have inserted, select it with the cursor and press the Delete key.
The default glue points on an object cannot be deleted.
9) To move a glue point you have inserted, select it with the cursor and drag the glue point to
a new position. The default glue points on an object cannot be moved.

Tip

Glue points are placed by default on the grid (see “Snapping objects to grid or snap
guides” on page 21 for information). However it is sometimes necessary to fine tune
the position of a glue point depending on the shape of the object. To do this, press
the Ctrl key to display guide lines and keep the Ctrl key pressed while dragging the
glue point to the new position.

Working with 3D objects
Although Impress offers advanced functions to manipulate 3D objects, this guide describes only
the 3D settings applicable to an object. For additional information on how to use advanced 3D
effects such as geometry and shading, refer to the Draw Guide.
3D objects can be created in Impress in any of the following ways:

• Click on the triangle to the right of the 3D Objects icon

on the Drawing toolbar and
select a 3D object from the options. After selection, draw your 3D object on your slide as
you would with any object. The 3D Objects icon shown on the Drawing toolbar will depend
on the 3D object that had been previously selected and used.

• Go to View > Toolbars > 3D-Objects on the main menu bar to open the 3D-Objects
toolbar (Figure 18). The selection and drawing of 3D objects is the same as clicking on the
3D Objects icon on the Drawing toolbar.

• Right-click on an object already on your slide and select Convert > To 3D or To 3D
Rotation Object from the context menu. To 3D adds thickness to the object to create a 3D
object. To 3D Rotation Object creates a 3D object by rotating the object around an axis.

Figure 18: 3D-Objects toolbar

• Select an object and click on the Extrusion on/off icon

on the Drawing toolbar to
apply a basic 3D effect and open the 3D-Settings toolbar. Select one of the options on the
3D-Settings toolbar to apply a different 3D effect (Figure 19 and Table 3).

26

Managing Graphic Objects

Figure 19: 3D-Settings toolbar

Table 3: 3D-Settings tools and their purpose
Tool

Note

Name

Purpose

Extrusion On/Off

Adds thickness to an object and activates the 3D properties.

Tilt Down

Tilts the object downwards around a horizontal axis.

Tilt Up

Tilts the object up around a horizontal axis.

Tilt Left

Tilts the object left around a vertical axis.

Tilt Right

Tilts the object right around a vertical axis.

Depth

Determines the thickness of the shape. An extended toolbar opens
where some default values are given. If none of the values are
satisfactory, select Custom and then enter the desired thickness.

Direction

Opens an extended toolbar that lets you pick the direction of the
perspective as well as the type (parallel or perspective).

Lighting

Opens an extended toolbar that lets you specify the direction and
intensity of light.

Surface

Choose between Wire frame (useful when manipulating the object),
Matt, Plastic, or Metal.

3D Color

Selects the color of the object thickness.

Most of the Fontwork shapes (see “Using Fontwork” on page 29) have 3D properties
and can be manipulated with the 3D-Settings toolbar.

Converting objects to different types
You can convert an object into a different type. Right-click on the object and select Convert from
the context menu to display the following options:

• To Curve – converts the selected object to a Bézier curve. Click on the Points icon

on

the Drawing toolbar to edit the points after conversion to a Bézier curve.

• To Polygon – converts the selected object to a polygon. Click on the Points icon

to

edit the object after conversion to a polygon. A polygon always consists of straight
segments.

• To Contour – for basic shapes, this is equivalent to converting to polygon. For more
complex shapes (or for text objects) this conversion creates a group of polygons that you
can then manipulate by pressing F3 to enter the group.

• To 3D – converts the selected object to a 3D object.

Converting objects to different types
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• To 3D Rotation Object – creates a three-dimensional shape by rotating the selected object
around its vertical axis.

• To Bitmap – converts the selected object to a bitmap.
• To Metafile – converts the selected object to Windows Metafile Format (WMF), containing
both bitmap and vector graphic data.

Note

In most cases the conversion to a different type does not produce immediately visible
results.
To Curve, To Polygon, To 3D, and To 3D Rotation Object can be added to the
Drawing toolbar as additional tools by right-clicking in an empty area on the toolbar
and selecting Visible Buttons.

Tip

Setting up interaction with an object
You can associate an object to an action that is performed when it is clicked and this is called an
interaction:
1) Select the object for which an interaction will be created.
2) Click on the Interaction icon
on the Line and Filling toolbar or right-click on the object
and select Interaction from the context menu to open the Interaction dialog (Figure 20).
3) Select the interaction type and the parameters (if applicable). The interactions are
explained in Table 4 and the Interaction dialog changes depending on the type of
interaction selected.
4) Click OK to close the dialog.
5) To remove an interaction from a graphic object follow Steps 1 to 2 and then select No
action as the interaction type at Step 3.

Figure 20: Interaction dialog
Table 4: Interaction types and their parameters
Interaction

Parameters

Go to previous slide

No parameters.

Go to next slide

No parameters.

Go to first slide

No parameters.

Go to last slide

No parameters.

Go to page or object

Specify the target from the list in the Target box. You can search for a
specific target in the Slide/Object box at the bottom of the screen.
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Interaction

Parameters

Go to document

Select the document in the Document box. Use the Browse button to open
a File Open dialog. If the document to be opened is in Open Document
Presentation format, the target list will be populated allowing selection of
the specific target.

Play sound

Select the file containing the sound to be played. Use the Browse button to
open a File Open dialog.

Run program

Select the program to execute. Use the Browse button to open a File Open
dialog.

Run macro

Select a macro that will run during the presentation. Use the Browse button
to open the Macro Selector dialog.

Exit presentation

When the mouse is clicked over the object, the presentation will terminate.

Using Fontwork
Use Fontwork to obtain special text effects. For more about this topic, see the Getting Started
Guide Chapter 11 Graphics, the Gallery, and Fontwork.
To start using Fontwork:
1) Click on the Fontwork Gallery icon
on the Drawing toolbar or on the Fontwork toolbar
to open the Fontwork Gallery dialog (Figure 21).

Figure 21: Fontwork Gallery

Using Fontwork
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2) Select the preferred style from the Fontwork Gallery dialog and click OK. The text Fontwork
in the selected style appears on the slide. You can modify its shape and properties after it
has been placed on the slide.
3) Double-click the object to edit the Fontwork text. Type your own text to replace the word
Fontwork that appears over the object.
4) Press the Esc key or click outside the area with the selection handles to exit.

Using the Fontwork toolbar
Make sure that the Fontwork toolbar (Figure 22) is visible on the workspace. If not, select View >
Toolbars > Fontwork from the main menu bar.

Figure 22: Fontwork toolbar
In addition to the Fontwork Gallery icon, this toolbar contains the following tools:

• Fontwork Shape

– changes the shape of the selected object. Shapes are selected
from the options that become available when you click on the icon.

• Fontwork Same Letter Heights

– changes the height of characters in the selected
object. Toggles between normal height where characters have different heights to where all
characters are the same height.

• Fontwork Alignment:

– specifies the text alignment within the frame from the options

available.

• Fontwork Character Spacing

– selects the desired spacing between characters and
whether kerning pairs should be used. For custom spacing, input a percentage value:
100% is normal spacing; less than 100% is tight spacing; more than 100% is expanded
spacing.

Modifying Fontwork as an object
It is possible to treat Fontwork text as an object and therefore to apply to it all the formatting that
has been described in this chapter. Assign line properties only to Fontwork which does not have a
3D effect, otherwise the changes will not be visible.
You can modify some of the Fontwork shapes just as you modify the angles of trapezoid and
parallelogram basic shapes by moving the dot that is displayed along with the selection handles.

Animations
Animated slide transitions can be added between slides to give your presentation a more
professional look when you change to the next slide (see Chapter 9 Slide Shows for more
information on transitions). However, Impress also allows you to add animations onto the slides to
create more interest in your presentation.
An animation consists of a sequence of images or objects called frames that are displayed in
succession when the animation runs. Each frame may contain one or more objects. For example,
make bullet points appear one by one; make pictures, shapes or other objects appear singly or as
a group onto a slide. Animations can be controlled using the keyboard or mouse click or
automatically in a timed sequence.
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Tip

Animations can look great in a presentation, but overuse of animations can make a
good presentation into a poor presentation. Always use discretion when adding
animations to your presentation.

Custom Animation
The Custom Animation section (Figure 23) is located in the Sidebar to the right of the Workspace in
Impress. It is used to add an animation effect to an object on a slide, or change the animation
effect of an object. To open the Custom Animation section, click on the Custom Animation
icon on the Sidebar, or right-click on a selected object and select Custom Animation on the
context menu, go to Slide Show > Custom Animation on the main menu bar.

Note

Anything that can be placed onto a slide is an object. For example, an object can
include an image, clip art drawing, text, and so on.

Custom animation options
The available options on the Custom Animation section on the Sidebar allows you to control how
the animation is animated on your slide.

Figure 23: Sidebar Custom Animation

• Add Effect

– click on this icon to open the Custom Animation dialog (Figure 24) and
add an animation effect to an object on a slide.

• Remove Effect

– click on this icon to remove any selected animation effects from an

object.

Animations
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• Modify Effect

– click on this icon to open the Custom Animation dialog (Figure 24) and
modify an animation effect applied to an object on a slide.

• Move Up

– click on this icon to move the selected animation effect up the order of
animation effects that have been applied to an object.

• Move Down

– click on this icon to move the selected animation effect down the order of
animation effects that have been applied to an object.

• Preview Effect

– click on this icon to preview the selected animation effect applied to

an object.

• Start – select from the drop-down list how an animation effect starts when running an
animation:

–
–
–

On click – the animation stops at this effect until the next mouse click.
With previous – the animation runs immediately.
After previous – the animation runs as soon as the previous animation ends.

• Direction – select from the drop-down list how an animation effect appears on the slide.
• Speed – select the speed or duration of the selected animation effect.
• Automatic preview – select this option to automatically preview an animation effect as it is
selected in the Custom Animation dialog (Figure 24).

• Effect Options

– click this icon to open the Effect Options dialog (Figure 25) where
you can select, adjust and apply options to the animation effect and timing.

Figure 24: Custom Animation dialog
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Custom Animation dialog
The Custom Animation dialog (Figure 24) contains the following tabbed pages for creating
animation effects on a selected object:

•
•
•
•
•
•

Entrance – how an animated object appears on the slide.
Emphasis – how an animated object is emphasized when it appears on the slide.
Exit – how an animated object leaves the slide.
Motion Paths – how an object moves on the slide during animation.
Misc Effects – selects media effects from the miscellaneous effects.
Automatic preview – previews any new or edited animation effects on the slide.

Effect Options dialog
The Effect Options dialog (Figure 25) specifies the settings and enhancements on how an
animation effect appears on your slide.

Figure 25: Effect Options dialog
The Effect page contains the following options:

• Direction – specifies the direction for the effect and is the same option that is displayed in
the Custom Animation section on the Sidebar.

• Sound – select a sound from the drop-down list when the animation effect is run.
• After animation – select from the drop-down list what happens after an animation effect
ends.

–
–
–
–

Dim with color – after the animation a dim color fills the shape.
Don't dim – no after-effect runs.
Hide after animation – hides the shape after the animation ends.
Hide on next animation – hides the shape on the next animation.

• Dim color – select a dim color.
• Text animation – select the animation mode for the text of the current shape:
–
All at once – animates the text all at once.
Animations
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–
–

Word by word – animates the text word by word.
Letter by letter – animates the text letter by letter.

• Delay between characters – specifies the percentage of delay between animations of
words or letters.
The Timing page contains the following options:

• Start – displays the start property of the selected animation effect. The following start
properties are available:

–
–
–

On click – the animation stops at this effect until the next mouse click.
With previous – the animation runs immediately.
After previous – the animation runs as soon as the previous animation ends.

• Delay – specifies an additional delay in seconds until the effect starts.
• Speed – specifies the duration of the effect.
• Repeat – specifies whether and how to repeat the current effect. Enter the number of
repeats, or select from the list:

–
–
–

none – the effect is not repeated.
Until next click – the animation is repeated until the next mouse click.
Until end of slide – the animation repeats as long as the slide is displayed.

• Rewind when done playing – specifies whether to let the animated shape return to its
starting state after the animation ends.

• Animate as part of click sequence – specifies whether to let the animation start in the
normal click sequence.

• Start effect on click of – specifies whether to let the animation start when a specified
shape is clicked. Select the shape by its name from the drop-down list.

Creating an animation
To create an animated object or objects using Custom Animation:
1) Select an object on a slide.
2) Open the Custom Animation section (Figure 23) in the Sidebar, or go to Slide Show >
Custom Animation on the main menu bar.
3) Click on Add in Custom Animation to open the Custom Animation dialog (Figure 24).
4) Select an effect category and the type of effect you want to apply to the selected object.
5) Select how the effect starts, the direction, and the speed (if available) of the effect from the
various options included on the drop-down lists.
6) Click Effect Options icon
to open the Effect Options dialog (Figure 25) to set the
effect options for the animation, then click OK to close the dialog.
7) If necessary, change the appearance order of the objects in the animation using the Move
Up

and Move Down

icons.

8) Click Preview Effect
icon to check the animation effect.
9) When you are satisfied, run the slide show to check your presentation.
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Inserting animated images
You can create an animated image and then insert it into your presentation by going to Insert >
Animated Image on the main menu bar to open the Animation dialog (Figure 26). The animation
controls are explained in Table 5.

Figure 26: Animation dialog
Table 5: Animation dialog controls
Control

Animations

Control Name

Purpose

First image

Jumps to the first image in the animation sequence.

Backwards

Plays the animation backwards.

Stop

Stops playing the animation.

Play

Plays the animation.

Last image

Jumps to the last image in the animation sequence.

Image number

Indicates the position of the current image in the animation
sequence. If you want to view another image, enter its number
or click the up and down arrows.

Duration

Enter the number of seconds to display the current image. This
option is only available if you select Bitmap object in Animation
group.

Loop count

Sets the number of times that animation will play. If you want
the animation to play continuously, select Max. This option is
only available if you select Bitmap object in Animation group.

Apply Object

Adds selected object or objects as a single image.

35

Control

Control Name

Purpose

Apply Objects
Individually

Adds an image for each selected object. If you select a grouped
object, an image is created for each object in the group.
You can also select an animation, such as an animated GIF,
and click this icon to open it for editing. When you are finished
editing the animation, click Create to insert a new animation
into your slide.

Delete Current
Image

Deletes the current image from the animation sequence.

Delete All Images

Deletes all images in the animation.

Number

Total number of images in the animation.

Group object

Assembles images into a single object so that they can be
moved as a group. You can still edit individual objects by
double-clicking the group in the slide.

Bitmap object

Combines images into a single image.

Create

Inserts the animation into the current slide.

Creating an animation
To create an animation using Insert > Animated Image on the menu bar:
1) Create the object you intend to animate, using the drawing tools.
2) Go to Insert > Animated Image on the menu bar to open the Animation dialog (Figure 26
and Table 5).
3) Select the object and click on Apply Object icon to add it as the first frame of the
animation.
4) Apply a transformation or change to the object; for example, rotation, change color, add or
remove characters, and so on.
5) When you are ready, create the second frame of the animation and click Apply Object
again to add another frame to the animation.
6) Repeat steps 3, 4, and 5 until you have created all the desired frames of the animation.
7) Select Bitmap object in Animation group to customize the timing of each of the frames
and the number of repetitions for the animation.
8) Set the duration of each frame in the animation in Duration and the number of repetitions in
Max to create a loop for your animation. Selecting Max creates a continuous loop.
9) Click Create and the animated image is placed in the center on your slide.
10) Adjust the position of your animated object on your slide.

Note
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If the image to be copied consists of several objects, you can choose to treat each
object as a separate frame. In this case, click on Apply objects individually icon.
Remember that each object will be centered in the animation.
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