Impress Guide 7.3
Copyright

This document is Copyright © 2022 by the LibreOffice Documentation Team. Contributors are listed below. You may distribute it and/or modify it under the terms of either the GNU General Public License (https://www.gnu.org/licenses/gpl.html), version 3 or later, or the Creative Commons Attribution License (https://creativecommons.org/licenses/by/4.0/), version 4.0 or later.

All trademarks within this guide belong to their legitimate owners.

Book = 1

Contributors

To this edition
Peter Schofield Kees Kriek

To previous editions
Peter Schofield Claire Wood Jean Hollis Weber
Vasudev Narayanan Rachel Kartch T. Elliot Turner
Dimona Delvere Michele Zarri Hazel Russman
Peter Hillier-Brook Gary Schnabl Linda Worthington
Felipe Viggiano Regina Henschel Low Song Chuan
Samantha Hamilton Dave Barton

Feedback

Please direct any comments or suggestions about this document to the Documentation Team's mailing list: documentation@global.libreoffice.org

Note

Everything sent to a mailing list, including email addresses and any other personal information that is written in the message, is publicly archived and cannot be deleted.

Publication date and software version

Published May 2022. Based on LibreOffice 7.3 Community.
Other versions of LibreOffice may differ in appearance and functionality.

Documentation for LibreOffice is available at https://documentation.libreoffice.org/en/
Contents

Copyright........................................................................................................................................... 4

Preface.................................................................................................................................................. 9
  Who is this user guide for?.................................................................................................................. 10
  What is in this user guide?.................................................................................................................. 10
  Minimum requirements for using LibreOffice.................................................................................. 10
  How to get LibreOffice...................................................................................................................... 10
  Installing LibreOffice....................................................................................................................... 10
  Setting up and customizing LibreOffice........................................................................................... 10
  Extensions and add-ons...................................................................................................................... 11
  Where to get more help..................................................................................................................... 11
  What you see may be different........................................................................................................... 13
  Using LibreOffice on macOS........................................................................................................... 14
  Who wrote this user guide?............................................................................................................... 15
  Frequently asked questions.............................................................................................................. 15
  What is new in LibreOffice 7.3?........................................................................................................ 17

Chapter 1, Introducing Impress.......................................................................................................... 19
  What is Impress?................................................................................................................................ 20
  Starting Impress.................................................................................................................................. 20
  Main Impress window........................................................................................................................ 22
  Workspace views............................................................................................................................... 29
  Creating presentations....................................................................................................................... 32
  Running a presentation...................................................................................................................... 39

Chapter 2, Master Slides, Styles, and Templates.................................................................................. 41
  Designing a presentation..................................................................................................................... 42
  What are master slides?...................................................................................................................... 42
  Working with master slides.............................................................................................................. 43
  Working with styles........................................................................................................................... 61
  Working with templates.................................................................................................................... 65

Chapter 3, Adding and Formatting Text............................................................................................. 73
  Introduction....................................................................................................................................... 74
  Working with text boxes.................................................................................................................... 74
  Inserting text...................................................................................................................................... 88
  Formatting text................................................................................................................................... 90
  Creating lists...................................................................................................................................... 96
  Text callouts..................................................................................................................................... 102
  Using tables....................................................................................................................................... 104
  Using fields....................................................................................................................................... 113
  Using hyperlinks.............................................................................................................................. 114

Chapter 4, Adding and Formatting Images......................................................................................... 119
  Introduction...................................................................................................................................... 120
  Inserting images............................................................................................................................... 120
  Gallery themes................................................................................................................................. 122
## Chapter 5, Managing Graphic Objects

- Introduction ................................................................. 140  
- Drawing toolbar ......................................................... 140  
- Creating lines and shapes .............................................. 145  
- Grouping objects .......................................................... 150  
- Positioning and resizing graphic objects ......................... 152  
- Applying special effects ............................................... 156  
- Aligning objects ............................................................ 161  
- Using grid or snap functions ........................................... 161  
- Using Helplines .............................................................. 166  
- Arranging objects .......................................................... 167  
- Connectors and glue points .............................................. 168  
- Working with 3D objects ............................................... 174  
- Converting objects ........................................................ 175  
- Interaction with objects ................................................ 175  
- Fontwork ................................................................. 177  
- Animations ................................................................. 179

### Chapter 6, Formatting Graphic Objects

- Introduction ................................................................. 188  
- Line formatting ............................................................. 188  
- Area fill formatting ...................................................... 196  
- Working with area fills ................................................ 199  
- Working with shadows .................................................. 214  
- Working with transparencies ......................................... 216  
- Text in objects ............................................................. 218  
- Formatting connectors ................................................... 221  
- Working with styles ...................................................... 222

### Chapter 7, OLE, Spreadsheets, Charts, and Other Objects

- OLE objects ............................................................... 228  
- Spreadsheets ............................................................... 230  
- Charts ................................................................. 241  
- Audio and video ............................................................ 248  
- Formulas ................................................................. 249  
- Drawings, text files, HTML files and other objects .......... 250

### Chapter 8, Adding and Formatting Slides, Notes, Comments, and Handouts

- Working with slides ...................................................... 252  
- Creating slides from an outline ..................................... 256  
- Formatting slides ........................................................ 258  
- Presentation notes ....................................................... 264  
- Inserting comments ..................................................... 271  
- Printing handouts ....................................................... 272

---

| LibreOffice 7.3 Impress Guide |

---
Chapter 9, Slide Shows and Photo Albums......................................................... 275
  Introduction........................................................................................................ 276
  Creating slide shows.......................................................................................... 276
  Slide transitions................................................................................................ 281
  Animations.......................................................................................................... 284
  Using interactions.............................................................................................. 289
  Slide shows........................................................................................................ 290
  Photo albums.................................................................................................... 294

Chapter 10, Saving Slide Shows, Printing, Emailing, and Exporting............. 299
  Saving slide shows............................................................................................ 300
  Quick printing.................................................................................................... 301
  Default printer................................................................................................... 302
  Controlled printing............................................................................................ 303
  Printing examples............................................................................................ 308
  Emailing............................................................................................................. 311
  Exporting............................................................................................................ 312

Chapter 11, Setting Up and Customizing Impress........................................... 317
  Introduction........................................................................................................ 318
  LibreOffice options........................................................................................... 318
  Impress options................................................................................................ 323
  Customizing user interface................................................................................ 327
  Adding extensions............................................................................................. 328

Chapter 12, User Interface Variants................................................................. 329
  Introduction........................................................................................................ 330
  Selecting a user interface................................................................................... 330
  Standard Toolbar UI........................................................................................ 331
  Tabbed UI........................................................................................................... 331
  Single Toolbar & Sidebar UI.............................................................................. 332
  Tabbed Compact UI.......................................................................................... 342
  Groupedbar Compact UI................................................................................... 342
  Contextual Single UI........................................................................................ 343

Appendix A, Keyboard Shortcuts................................................................. 345
  Introduction........................................................................................................ 346
  macOS keyboard shortcuts............................................................................... 346
  Impress keyboard shortcuts............................................................................. 347
  Menu keyboard shortcuts.................................................................................. 351
  Toolbar keyboard shortcuts.............................................................................. 356

Appendix B, Toolbars......................................................................................... 361
  Introduction........................................................................................................ 362
  Using toolbars................................................................................................... 362
  Toolbars............................................................................................................. 365
Preface
Who is this user guide for?

Anyone who wants to quickly acquire knowledge on LibreOffice Impress and is new to presentation software, or may be familiar with another office suite, will find this user guide very useful.

LibreOffice is an open-source office productivity software suite containing capabilities for word processing, spreadsheets, presentations, graphics, databases, and formula editing. LibreOffice Impress is used as a visual aid and is the presentations application for LibreOffice. It is compatible with a wide range of formats like Microsoft PowerPoint (.ppt, .pptx). Presentations can be exported in several file formats, for example, PDF, HTML, and numerous graphic formats.

What is in this user guide?

This user guide introduces the main features of Impress, the presentations (slide show) component of LibreOffice. Impress slides can contain text, bulleted and numbered lists, tables, charts, clip art, and other objects. Also, Impress comes with prepackaged styles, slide backgrounds, and templates to help in creating presentations.

Minimum requirements for using LibreOffice

For a detailed list of requirements and operating systems supported, see the LibreOffice website, https://www.libreoffice.org/get-help/system-requirements/

How to get LibreOffice

Versions of LibreOffice for Windows, Linux, and macOS are freely available and can be downloaded from https://www.libreoffice.org/download. Linux users will also find LibreOffice included free in many of the latest distributions.

Portable and other versions of LibreOffice are listed on the download page. Linux, Vanilla, and other versions may differ in a few features from the descriptions in this user guide.

Installing LibreOffice

Information on installing and setting up LibreOffice on the various supported operating systems is given here: https://www.libreoffice.org/get-help/install-howto/

Setting up and customizing LibreOffice

To change the default settings (options) in LibreOffice to match the required preferences, go to Tools > Options on the Menu bar (LibreOffice > Preferences in macOS).

Tip

Many settings are intended for power users and programmers. If it is difficult to understand what an option does, LibreOffice recommended leaving the option on its default setting unless instructions in this user guide recommend changing the setting.

Settings are described in LibreOffice Help and the Getting Started Guide. These two sources provide information on how to customize menus, toolbars, and keyboard shortcuts in LibreOffice Impress, add new menus and toolbars, and assign macros to events. Some settings of particular interest to Impress users are also covered in Chapter 11, Setting Up and Customizing Impress.
Extensions and add-ons

Functionality can be added to LibreOffice with extensions and add-ons. Several extensions are installed with the program and other extensions from the official extensions repository, https://extensions.libreoffice.org/ or from other sources. See the Getting Started Guide for more information on installing extensions and add-ons.

Where to get more help

This user guide and other LibreOffice user guides, the built-in Help system, and user support systems assume that users are familiar with computer and basic functions such as starting a program, opening and saving files.

Help system

LibreOffice comes with an extensive Help system and this can be used as the first line of support. Windows and Linux users can choose to download and install the offline Help for use when not connected to the Internet. Offline Help is installed with the MacOS version of LibreOffice.

To display the LibreOffice Help, press F1 or go to Help > LibreOffice Help on the Menu bar. If the offline help is not installed on a computer, but connected to the Internet, a dialog opens giving the option to Read Help Online. Select this option and the default web browser opens at the LibreOffice online help pages in the LibreOffice website.

The Help menu also includes links to other LibreOffice information and support facilities.

- **What's This?** – for quick tips when a toolbar is visible, place the cursor over any of the tool icons to see a small tooltip box with a brief explanation of the tool function. Also Extended Tips can be activated by going to Tools > Options > LibreOffice > General on the Menu bar. Extended Tips provide a brief description about tools and commands. To display an extended tip, use the keyboard Shift+F1, then point to a tool or command.

- **User Guides** – opens the default browser at the Documentation page of the LibreOffice website https://documentation.libreoffice.org/en/english-documentation/. This page gives access to the LibreOffice User Guides and other useful information that can be opened in the default browser. Also, the User Guides are available in PDF format as a free download or to buy as printed copies.

- **Show Tip of the Day** – opens a small window with a random tip on how to use LibreOffice.

- **Search Commands** – opens a window where typing a few letters, or the name of a Menu bar command, for example, quickly finds where the command is located. Clicking on a command in the resulting list may open a relevant dialog or have other effects.

- **Get Help Online** – opens the default browser at the Ask LibreOffice forum of questions and answers from the LibreOffice community, https://ask.libreoffice.org/en/questions/. From this page, bugs can be reported, new features suggested and communicated with other users in the LibreOffice community.

- **Restart in Safe Mode** – opens a dialog window giving options to restart LibreOffice and reset the software to its default settings. Restarting in safe mode also provides an opportunity to restore LibreOffice from a backup.

- **Get Involved** – opens the default browser at the Get Involved page of the LibreOffice website, https://www.libreoffice.org/community/get-involved/. Choose a topic of interest to help improve the program.
• **Donate to LibreOffice** – opens the default browser at the Donation page of the LibreOffice website, [https://donate.libreoffice.org/](https://donate.libreoffice.org/) providing an opportunity to make a donation to support LibreOffice.

• **License Information** – outlines the licenses under which LibreOffice is made available.

• **Check for Updates** – opens a dialog and checks the LibreOffice website for updates to version of the software. The dialog provides an opportunity to download and install any updates to LibreOffice.

• **About LibreOffice** – opens a dialog and displays information about the version of LibreOffice and the operating system being used. This information is often requested if the community is asked for help or assistance with the software (on macOS, this option is found under **LibreOffice** on the Menu bar).

### Other free online support

The LibreOffice community not only develops software, but provides free, volunteer-based support. See Table 1 and the web page [https://www.libreoffice.org/get-help/](https://www.libreoffice.org/get-help/). For comprehensive online support from the community, look at mailing lists and the Ask LibreOffice website, [https://ask.libreoffice.org/en/questions/](https://ask.libreoffice.org/en/questions/). Other user websites also offer free tips and tutorials.

**Table 1: Free support for LibreOffice users**

<table>
<thead>
<tr>
<th>Free LibreOffice support</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>FAQs</strong></td>
</tr>
<tr>
<td>Answers to frequently asked questions</td>
</tr>
<tr>
<td><a href="https://wiki.documentfoundation.org/Faq">https://wiki.documentfoundation.org/Faq</a></td>
</tr>
<tr>
<td><strong>Mailing lists</strong></td>
</tr>
<tr>
<td>Free community support is provided by a network of experienced users</td>
</tr>
<tr>
<td><a href="https://www.libreoffice.org/get-help/mailing-lists/">https://www.libreoffice.org/get-help/mailing-lists/</a></td>
</tr>
<tr>
<td><strong>Questions &amp; Answers and Knowledge Base</strong></td>
</tr>
<tr>
<td>Free community assistance is provided in a Question &amp; Answer formatted web service. Search similar topics or open a new one in</td>
</tr>
<tr>
<td><a href="https://ask.libreoffice.org/en/questions">https://ask.libreoffice.org/en/questions</a></td>
</tr>
<tr>
<td>The service is available in several other languages; just replace /en/ with de, es, fr, ja, ko, nl, pt, tr, and many others in the web address above.</td>
</tr>
<tr>
<td><strong>Native language support</strong></td>
</tr>
<tr>
<td>The LibreOffice website in various languages</td>
</tr>
<tr>
<td><a href="https://www.libreoffice.org/community/nlc/">https://www.libreoffice.org/community/nlc/</a></td>
</tr>
<tr>
<td>Mailing lists for native languages</td>
</tr>
<tr>
<td><a href="https://wiki.documentfoundation.org/Local_Mailing_Lists">https://wiki.documentfoundation.org/Local_Mailing_Lists</a></td>
</tr>
<tr>
<td>Information about social networking</td>
</tr>
<tr>
<td><a href="https://wiki.documentfoundation.org/Website/Web_Sites_services">https://wiki.documentfoundation.org/Website/Web_Sites_services</a></td>
</tr>
<tr>
<td><strong>Accessibility options</strong></td>
</tr>
<tr>
<td>Information about available accessibility options.</td>
</tr>
<tr>
<td><a href="https://www.libreoffice.org/get-help/accessibility/">https://www.libreoffice.org/get-help/accessibility/</a></td>
</tr>
<tr>
<td><strong>OpenOffice Forum</strong></td>
</tr>
<tr>
<td>Another forum that provides support for LibreOffice, among other open source office suites. <a href="https://forum.openoffice.org/en/forum/">https://forum.openoffice.org/en/forum/</a></td>
</tr>
</tbody>
</table>

### Paid support and training

Support and training is available through service contracts from a vendor or consulting firm specializing in LibreOffice. For information about certified professional support, see The Document Foundation website: [https://www.documentfoundation.org/gethelp/support/](https://www.documentfoundation.org/gethelp/support/).
What you see may be different

Illustrations

LibreOffice runs on Windows, Linux, and macOS operating systems, each of which has several versions and can be customized by users (fonts, colors, themes, window managers). The illustrations in this guide were taken from a variety of computers and operating systems. Therefore, some illustrations will not look exactly like what is seen on a computer display.

Also, some of the dialogs may differ because of the settings selected in LibreOffice. Either use dialogs from the computer system (default) or dialogs provided by LibreOffice. To change to using LibreOffice dialogs:

1) On Linux and Windows operating systems, go to **Tools > Options > LibreOffice > General** on the Menu bar to open the dialog for general options.

2) On a Mac operating system, go to **LibreOffice > Preferences > General** on the Menu bar to open the dialog for general options.

3) Select Use LibreOffice dialogs in **Open/Save dialogs** to display the LibreOffice dialogs on a computer display, as shown in Figure 1.

4) Click **OK** to save the settings and close the dialog.

Icons

The LibreOffice community has created icons for several icon sets, including Breeze, Colibre, Elementary, Sifr, and Tango. Each user can select a preferred set. The icons used to illustrate some of the many tools available in LibreOffice may differ from the ones used in this guide. The icons in this user guide have been taken from a LibreOffice installation that has been set to display the Colibre set of icons.

![Options LibreOffice General dialog](image)

**Figure 1: Options LibreOffice General dialog**
Change the icon set used in a LibreOffice installation as follows:

1) On Linux and Windows operating systems, go to **Tools > Options > LibreOffice > View** on the Menu bar to open the dialog for view options.

2) On a Mac operating system, go to **LibreOffice > Preferences > LibreOffice > View** on the Menu bar to open the dialog for view options.

3) In **Icon Style** select Colibre from the options available in the drop down list as shown in Figure 2.

4) In **Icon Size**, select **Small** from the drop down lists for **Toolbar**, **Notebookbar** and **Sidebar**, as shown in Figure 2.

5) Click **OK** to save the settings and close the dialog.

**Note**

Some Linux operating systems, for example Ubuntu, include LibreOffice as part of the installation and may not include the Colibre icon set. This icon set can be downloaded from the software repository for the Linux operating system being used.

### Using LibreOffice on macOS

Some keystrokes and menu items are different on macOS from those used in Windows and Linux. Table 2 below gives some common substitutions for the instructions in this user guide. For more information on keyboard shortcuts, see LibreOffice help and Appendix A, Keyboard Shortcuts in this user guide.

<table>
<thead>
<tr>
<th><strong>Windows or Linux</strong></th>
<th><strong>macOS equivalent</strong></th>
<th><strong>Effect</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Tools &gt; Options</strong> on Menu bar</td>
<td><strong>LibreOffice &gt; Preferences</strong> on Menu bar</td>
<td>Access to setup options</td>
</tr>
</tbody>
</table>

**Figure 2: Options LibreOffice View dialog**
<table>
<thead>
<tr>
<th>Windows or Linux</th>
<th>macOS equivalent</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Right-click</td>
<td>Ctrl+click and/or right-click depending on computer setup</td>
<td>Opens a context menu</td>
</tr>
<tr>
<td>Ctrl or Control</td>
<td>⌘ and/or Cmd or Command, depending on keyboard</td>
<td>Used with other keys</td>
</tr>
<tr>
<td>Alt</td>
<td>⌥ and/or Alt or Option depending on keyboard</td>
<td>Used with other keys</td>
</tr>
<tr>
<td>F11</td>
<td>⌘+T</td>
<td>Open the Styles deck in the Sidebar</td>
</tr>
</tbody>
</table>

Who wrote this user guide?

This user guide was written by volunteers from the LibreOffice community. Profits from sales of the printed edition will be used to benefit the community.

Frequently asked questions

How is LibreOffice licensed?
LibreOffice is distributed under the Open Source Initiative (OSI) approved Mozilla Public License (MPL). See https://www.libreoffice.org/about-us/licenses/

It is based on code from Apache OpenOffice made available under the Apache License 2.0, but also includes software that differs from version to version under a variety of other Open Source licenses. New code is available under LGPL 3.0 and MPL 2.0.

May I distribute LibreOffice to anyone?
Yes

May I sell it?
Yes

May I use it in my business?
Yes.

How many computers may I install it on?
As many as you like.

Is LibreOffice available in my language?
LibreOffice has been translated (localized) into over 40 languages, so your language probably is supported. Additionally, there are over 70 spelling, hyphenation, and thesaurus dictionaries available for languages, and dialects that do not have a localized program interface. The dictionaries are available from the LibreOffice website at: www.libreoffice.org.

How can you make it for free?
LibreOffice is developed and maintained by volunteers and has the backing of several organizations.

I am writing a software application. May I use programming code from LibreOffice in my program?
You may, within the parameters set in the MPL and/or LGPL. Read the licenses: https://www.mozilla.org/MPL/2.0/.
Why do I need Java to run LibreOffice? Is it written in Java?

LibreOffice is not written in Java; it is written in the C++ language. Java is one of several languages that can be used to extend the software. The Java JDK/JRE is only required for some features. The most notable one is the HSQLDB relational database engine.

Java is available at no cost. More information and download links to the appropriate edition for your operating system can be found at: https://java.com/en/download/manual.jsp

Note

If the LibreOffice features that require Java are to be used, it is important that the correct 32-bit or 64-bit edition matches the installed version of LibreOffice. For more information, see the Getting Started Guide. If Java is not to be used, nearly all of the LibreOffice features can still be used.

How can I contribute to LibreOffice?

You can help with the development and user support of LibreOffice in many ways, and you do not need to be a programmer. To start, check out this webpage:
https://www.libreoffice.org/community/get-involved/

May I distribute the PDF of this user guide, or print and sell copies?

Yes, as long as requirements are met for one of the licenses in the copyright statement at the beginning of this user guide. There is no need to request special permission. LibreOffice request that you share with the project some of the profits you make from sales of user guides, in consideration of all the work we have put into producing them.

Donate to LibreOffice: https://www.libreoffice.org/donate/

What is new in LibreOffice 7.3?

The LibreOffice 7.3 Release Notes are available at this link
https://wiki.documentfoundation.org/ReleaseNotes/7.3

Also at this link, the release notes for earlier versions of LibreOffice are located giving more information on the features that are included in LibreOffice.
Chapter 1,
Introducing Impress

Presentations in LibreOffice
What is Impress?

Impress is the presentation (slide show) program included in LibreOffice. Impress creates presentations in the Open Document Presentation (ODP) format, which can be opened by other presentation software or can be exported in different presentation formats.

Slides can be created that contain many different elements, including text, bulleted and numbered lists, tables, charts, and a wide range of graphic objects such as clipart, drawings and photographs. Impress also includes a spelling checker, a thesaurus, text styles, and background styles.

This chapter introduces the Impress user interface. The remaining chapters in this user guide explain all the features available in Impress that can be used to create more sophisticated slide shows.

To use Impress for more than very simple presentations requires some knowledge of the elements which the slides contain. Slides containing text use styles to determine the appearance of that text. Creating drawings in Impress is similar to the Draw module included in LibreOffice. It is recommended to consult the Draw Guide for more details on how to use the drawing tools.

Starting Impress

Impress can be started in several ways:

- From the LibreOffice Start Center that opens when LibreOffice is opened and no other LibreOffice module is open.
  - Click on Impress Presentation to create a new presentation;
  - Click on Open File and navigate to the folder where there is an existing presentation.
- From the system menu using the standard menu from which most applications are started. Details vary with the operating system. See the Getting Started Guide for more information, some examples are listed below:
  - Start menu in Windows.
  - Applications menu in Linux with a Gnome desktop.
  - Applications menu in macOS.
- From any open module of LibreOffice, go to File > New > Presentation on the Menu bar, or click on the triangle ▼ next to New on the Standard toolbar and select Presentation from the drop-down menu.

Note

When LibreOffice is installed on a computer, a menu entry for each component is normally added to the system menu. The exact name and location of these menu entries depend on the operating system and graphical user interface.

Note

The New icon displayed on the Standard toolbar depends on which LibreOffice module is open when creating a new presentation.
When starting Impress, the main Impress window (Figure 3) opens and, as default, with the Select a Template dialog displayed (Figure 4). Templates included with Impress are designed to fit the two standard sizes of presentation slides: 4:3 and 16:9 ratios. However, templates will adapt to other sizes that are available and can be selected by going to Slide > Slide Properties > Paper Format on the Menu bar, or Format in the Slide panel in the Properties deck on the Sidebar.
To start Impress without the Select a Template dialog opening, deselect Show this dialog at startup in the lower left of the dialog.

In Windows or Linux, go to Tools > Options > LibreOffice Impress > General on the Menu bar and deselect Start with Template Selection under New Document.

In macOS, go to LibreOffice > Preferences > LibreOffice Impress > General on the Menu bar and deselect Start with Template Selection under New Document.

**Main Impress window**

The main Impress window (Figure 3) has three main sections: Slides pane, Workspace, and Sidebar. At the top of the main window is the Menu bar and toolbars. Toolbars can be displayed or hidden during the creation of a presentation.

**Tip**

The Slides pane and/or Sidebar can be closed by clicking the X in the upper right corner of each pane, or go to View > Slides pane or View > Sidebar on the Menu bar to deselect. To reopen a pane, select View > Slides pane or View > Sidebar on the Menu bar.

**Tip**

To maximize the Workspace area click on the Hide/Show marker in the middle of the vertical separator line (highlighted in Figure 3). Using the Hide/Show marker hides, but does not close, the Slides pane or Sidebar. To restore, click again on its Hide/Show marker.

**Menu bar**

The Impress Menu bar, at the top of the main window, provides several menus common to all LibreOffice modules. The commands may differ between each LibreOffice module for File, Edit, View, Insert, Format, Tools, Window, and Help. Impress has two extra menus for Slide and Slide Show. When a menu is selected, a submenu drops down to show commands. The Menu bar can be customized and for more information, see the Getting Started Guide.

**Workspace**

The Workspace (normally the center of the main window) opens in the Normal view. It has four standard views of Normal, Outline, Notes, and Slide Sorter (Figure 5). For more information on workspace views, see “Workspace views” page 31.

*Figure 5: Workspace view tabs*

If master slides are being used, then master views become available: Master Slide, Master Notes and Master Handout. There are no tabs for master views and are selected by going to
View on the Menu bar. For more information on master slides, see Chapter 2, Using Slide Masters, Styles, and Templates.

**Slides pane**

The Slides pane contains thumbnail images of slides in a presentation in the order in which the slides are shown. The slide show order can be changed and is described in Chapter 9, Slide Shows & Photo Albums. Clicking on a slide image in the Slides pane selects it and places the slide in the Workspace where changes are made to the displayed slide.

- To display or close the Slides pane, go to View > Slides pane on the Menu bar.
- To close the Slides pane, click on the X in the right top corner of the Slides pane.
- To display or hide the Slides pane, use the Hide/Show marker on the left of the Workspace.

Several additional operations can be carried out on one or more slides in the Slides pane. Also, these additional operations are available from a context menu when right-clicking on a slide in the Slides pane.

- Add new slides to a presentation.
- Hide a slide so that it will not show in a presentation.
- Delete a slide from a presentation.
- Rename a slide.
- Duplicate a slide.
- Move a slide to another position in the slide order by dragging and dropping it to the desired position.
- The following operations can also be carried out, although there are more efficient methods than using the Slides pane:
  - Change the slide transition following the selected slide or after each slide in a group.
  - Change the sequence of slides in the presentation.
  - Change the slide design.
  - Change slide layout for a group of slides simultaneously.

**Sidebar**

The Impress Sidebar, normally located on the right side of the Workspace, is similar to the Sidebar in the other LibreOffice modules. It consists of eight decks, as described below. To open a deck, use one of the following methods:

- Click on its icon on the right side of the Sidebar.
- Click on Sidebar Settings at the top of the Sidebar and select a deck from the drop-down list.
- Go to View on the Menu bar and select the deck required from the submenu.

To display or hide the Sidebar, use one of the following methods:

- Go to View > Sidebar on the Menu bar.
- Use the keyboard shortcut Ctrl+F5 (macOS ⌘+F5).
- Use the Hide/Show marker on the right of the Workspace (Figure 3 on page 23).
- To close the Sidebar, click on the X in the right top corner of the Sidebar.
- To display the Sidebar, click on one of the Sidebar icons to open a deck.
**Properties**
The Properties deck has ten panels, allowing the slide layout to be changed and the formatting of any objects on a slide.

- When a slide is selected and appears in the Workspace, the Properties deck opens with the Slide and Layouts panels available.
- When an object on a slide is selected, the Properties deck has the following panels available: Character, Lists, Paragraph, Area, Shadow, Line, Position and Size, Columns, Effect, and Image. Actual panels displayed depends on the type of object selected.

**Styles**
On the Styles deck, drawing and presentation styles can be applied to a selected object, new styles created for drawing and presentation, and both types of styles can be modified. When saving changes to a style, the changes are applied to all of the elements formatted with that style in the presentation. For more information on styles, see Chapter 2, Using Slide Masters, Styles, and Templates.

**Gallery**
On the Gallery deck, an object can be inserted into a presentation either as a copy or as a link. A copy of an object is independent of the original object. Changes to the original object have no effect on the copy. A link remains dependent on the original object. Changes to the original object are also reflected in the link.

**Navigator**
The Navigator deck displays all objects contained in a presentation. It provides a convenient way to move between slides in a presentation or select an object on a slide. It is recommended to give slides and objects in a presentation meaningful names for easy identification when using the Navigator. For more information, see “Navigator” on page 29.

**Shapes**
The Shapes deck provides panels for quick selection of most items that are available on the Drawing toolbar: Lines and Arrows, Curves and Polygons, Connectors, Basic Shapes, Symbol Shapes, Block Arrows, Flowchart, Callout Shapes, Stars and Banners, and 3D Objects.

**Slide transition**
The Slide Transition deck provides a selection of slide transitions available in Impress. Also there are controls to adjust transition speed, automatic or manual transition, and how long a selected slide is shown (automatic transition only). For more information on transitions, see Chapter 9, Slide Shows & Photo Albums.

**Animation**
The Animation deck provides an easy way to add, change, or remove animations for different elements or objects on a slide and adjust how they appear during a slide show. For more information on animation, see Chapter 9, Slide Shows & Photo Albums.

**Master slides**
Using the Master Slides deck, the slide design can be selected for a presentation. Impress includes several designs of master slides. The default master slide is blank, but the remaining master slides have backgrounds and styled text. For more information on master slides, see Chapter 2, Using Slide Masters, Styles, and Templates.
Rulers

Rulers are positioned on the upper and left-hand sides of the Workspace. If the rulers are not visible, go to View > Rulers in the Menu bar. Rulers show the size of a selected object on the slide using double lines (highlighted in Figure 6). Also, rulers are used to manage object handles and guide lines when positioning objects.

To change the measurement units of the rulers, right-click on a ruler and select the measurement unit from the drop-down list, as shown in Figure 7 for the horizontal ruler. The horizontal and vertical rulers can be set to different measurement units.

The page margins in the drawing area are also represented on the rulers. The margins can be changed directly on the rulers by dragging them with the cursor. The margin area is indicated by either a grayed out area on the rulers or borders around the unused area of the ruler. This margin indication depends on computer setup and operating system.

![Figure 6: Rulers showing object size](image)

![Figure 7: Changing ruler units](image)

**Note**

The sizes are given in the current measurement unit and might not be the same as the ruler units. The measurement unit on the Status bar is defined in Tools > Options > LibreOffice Impress > General.
**Status Bar**

The Status Bar (Figure 8), located at the bottom of the Impress main window, contains information that may be useful when working on a presentation. To hide the Status Bar, go to View on the Menu bar and deselect Status Bar.

![Status Bar Diagram](image)

**Figure 8: Status Bar**

**Slide number**  
The slide number currently displayed in the Workspace and the total number of slides in the presentation.

**Information area**  
This changes depending on the object selected on the slide. Examples of the information displayed are shown in Table 3.

**Table 3: Examples of information on Status Bar**

<table>
<thead>
<tr>
<th>Example selection</th>
<th>Examples of information shown</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text area</td>
<td>Text Edit: Paragraph x, Row y, Column z</td>
</tr>
<tr>
<td>Charts, spreadsheets</td>
<td>Embedded object (OLE) “ObjectName” selected</td>
</tr>
<tr>
<td>Graphics</td>
<td>Bitmap with transparency selected</td>
</tr>
</tbody>
</table>

**Master slide**  
The master slide associated with the slide or notes page currently displayed in the Workspace. Right-click to open a list of available master slides and select one to apply it to the selected slide. Double-click to open the Available Master Slides dialog. For more information on master slides, see Chapter 2, Using Slide Masters, Styles and Templates.

**Cursor position/Object size**  
Shows different information depending on whether objects are selected or not.
- When no object is selected, the position numbers show the current position (X and Y coordinates) of the cursor.
- When an object is selected and being resized with the cursor, the object size numbers show the size of the object (width and height).
- If an object is selected, the position numbers show X and Y coordinates of the upper-left corner and the object size number pair displays the size of the object. These numbers do not relate to the object itself, but to the selection outline, which is the smallest possible rectangle that can contain the visible part or parts of the object.
- When an object is selected, clicking in either of these areas opens the Position and Size dialog.

**Unsaved changes**  
Indicates if there are any unsaved changes in the presentation. Clicking this icon saves the document. If the presentation has not been saved before, the Save As dialog opens giving the opportunity to save the presentation.
Digital signatures
Indicates if the presentation has a digital signature.

Text language
Indicates the language used for any text on a presentation.

Fit slide
When this icon is clicked on, the slide in the Workspace zooms to fit in the Workspace.

Zoom slider
When moved, the slide changes its viewing zoom in the Workspace.

Zoom percentage
Indicates the zoom level of the slide displayed in the Workspace. Clicking on zoom percentage opens the Zoom & View Layout dialog where the settings for zoom factor and view layout are adjusted.

Navigator
The Navigator displays all objects contained in a presentation. It provides another convenient way to move around a presentation and find items in it.

To open the Navigator dialog (Figure 9) go to View > Navigator on the Menu bar, or use the keyboard shortcut Ctrl+Shift+F5 (macOS ⌘+Shift+F5). Alternatively, click on Navigator in the Sidebar to open the Navigator deck that is similar in appearance and function as the Navigator dialog.

The Navigator is more useful if slides and objects (pictures, spreadsheets, and so on) are given meaningful names, instead of leaving them with default names, such as “Slide 1” and “Shape 1” and so on (as shown in Figure 9). Using meaningful names allows for slides or objects to be easily identified and located in a presentation.

![Navigator](image)

Figure 9: Navigator dialog

Toolbars
Many toolbars can be used during slide creation. To display or hide the various toolbars in Impress, go to View > Toolbars on the Menu bar and select the required toolbar from the submenu that appears. For example, Standard and Drawing toolbars are displayed by default, but the Line and Filling, and Text Formatting toolbars are not displayed and have to be selected.
To change the tools available on any toolbar, right-click in an empty area on the toolbar and select **Visible Buttons** from the context menu. Installed tools are indicated by a check mark next to the tool name, or the tool icon is highlighted, depending on the computer operating system. Click on a tool name to hide or show it in the toolbar. For more information, see Chapter 11, Setting Up and Customizing Impress, Appendix B, Toolbars, and the Getting Started Guide.

**Note**

The appearance of the toolbar icons varies depending on the computer operating system, and the selection of icon size and style in **Tools > Options > LibreOffice > View**. For more information about working with toolbars, see Appendix B, Toolbars and the Getting Started Guide.

The following toolbars are widely used when creating a presentation:

**Standard toolbar**

The Standard toolbar (Figure 10) is the same for all LibreOffice modules and is not described in detail in this user guide. By default, it is docked and located just under the Menu bar at the top of the Workspace.

![Figure 10: Standard toolbar](image)

**Drawing toolbar**

The Drawing toolbar (Figure 11) contains all the necessary functions for drawing various geometric and freehand shapes, and for organizing them in a slide. By default, it is docked and located on the left of the Workspace. More information on the Drawing toolbar can be found in Chapter 5, Managing Graphic Objects.

![Figure 11: Drawing toolbar](image)

**Line and Filling toolbar**

The Line and Filling toolbar (Figure 12) provides the tools for modifying the properties of an object, for example line color, line style, line width, fill color and style, and other properties of a selected object. If the selected object is a text frame, the Line and Filling toolbar is automatically replaced by the Text Formatting toolbar (Figure 13).

![Figure 12: Line and Filling toolbar](image)
**Text Formatting toolbar**

The Text Formatting toolbar (Figure 13) is similar to the Formatting toolbar in LibreOffice Writer and only appears when a text object has been selected in a presentation, automatically replacing the Line and Filling toolbar (Figure 12).

![Text Formatting toolbar](image)

*Figure 13: Text Formatting toolbar*

**Workspace views**

The Impress workspace has four standard views selected using tabs: Normal, Outline, Notes, and Slide Sorter. These tabs are normally displayed top of the Workspace. If the tabs are not displayed, then go to View > Views Tab Bar on the Menu bar. Also, different workspace views can be selected by going to View on the Menu bar and selecting a view from the submenu. Each of the workspace views is designed to ease the completion of certain tasks.

Master views only become available in the Workspace when Master Slide, Master Notes or Master Handout are selected. There are no tabs for master views and can only be selected by going to View on the Menu bar. For more information on master slides, see Chapter 2, Using Slide Masters, Styles, and Templates.

![Workspace views](image)

*Note*

Each workspace view displays a different set of toolbars when selected. To customize these toolbar sets, go to View > Toolbars on the Menu bar, then check or uncheck the toolbars to add or remove.

**Normal view**

Normal view is the main standard view for creating individual slides in a presentation. In Normal view slides are designed, text or graphics added and formatted, and any animation effects added to text or graphics.

To place a slide in Normal view of the Workspace, either click on the slide thumbnail in the Slides pane or click on the slide name in the Navigator.

![Normal view](image)

*Figure 14: Example of Outline view in Workspace*
Outline view

Outline view in the Workspace (Figure 14) contains all of the slides of a presentation in a numbered sequence. It shows topic titles, bulleted lists, and numbered lists for each slide in outline format. Only the text contained in the default text boxes in each slide is shown. If text boxes or graphic objects have been added to the slides, then these objects are not displayed. Slide names are not included.

Outline view can be used for the following:

- Making changes in the text of a slide.
- Adding or deleting text in a slide as in Normal view.
- Moving a paragraph in a slide up or down by using the movement arrows on the Outline toolbar (Figure 15).
- Changing the outline level of a paragraph in a slide using the left and right arrow buttons on the Outline toolbar.
- Comparing slides with an outline, if an outline has been prepared in advance. If another slide is required, it can be created directly in Outline view, or Normal view.

Notes view

Use Notes view in the Workspace (Figure 16) to add notes to a slide. These notes are not seen when the presentation is shown to an audience using an external display connected to a computer.

6) Click on Notes in the Workspace to open Notes view.
7) Click a slide in the Slides pane so that the slide appears in the Workspace.
8) In the text box below the slide, click on the words Click to add notes and begin typing the required notes for the selected slide.

The Click to add notes text box can be resized using the resizing handles which appear when the edge of the notes box is selected. Move or change the size of the box by clicking and dragging on the box border.
When text is inserted in the Click to add notes text box, it is automatically formatted using the predefined Notes style in Presentation Styles in the Styles deck on the Sidebar. The Notes style can be formatted to the presentation requirements. For more information, see Chapter 8, Adding and Formatting Slides, and Notes.

**Slide Sorter view**

The Slide Sorter view in the Workspace (Figure 17) contains all the thumbnails of slides used in a presentation. Use this view to work with one slide or a group of slides.

**Customizing Slide Sorter view**

To change the number of slides per row in Slide Sorter view:

1) Go to View > Toolbars > Slide View on the Menu bar to show the Slide View toolbar (Figure 18).

2) Adjust the number of slides in the Slides per Row box, up to a maximum of 15.
Changing slide order
To change the slide order in a presentation of a single slide or a group of slides using Slide Sorter view is as follows:

1) Select a slide or a group of slides.
2) Drag and drop the slide or group of slides at the new position in the presentation.

Selecting a group of slides
To select a group of slides in Slide Sorter view, use one of the following methods:

- **Ctrl key** – click on the first slide and, while holding the Ctrl key (macOS ⌘), select the required slides. The selected slides do not have to be next to each other.
- **Shift key** – click on the first slide, and while pressing the Shift key, select the final slide for the group. This selects all of the slides between the first and the last slide selected.
- **Cursor** – position the cursor slightly to one side and outside the first slide, then click and hold dragging the cursor until all of the slides required for the group are selected.

Working in Slide Sorter view
Working with slides in Slide Sorter view is similar to working with slides in the Slides pane. To make changes, right-click on a slide in Slide Sorter view and choose one of the following from the context menu:

- **Cut** – removes the selected slide and saves it to the clipboard.
- **Copy** – copies the selected slide to the clipboard without removing it.
- **Paste** – inserts a slide from the clipboard after the selected slide.
- **New Slide** – adds a new slide after the selected slide.
- **Duplicate Slide** – creates a duplicate of the selected slide and places the new slide immediately after the selected slide.
- **Rename Slide** – renames the selected slide.
- **Hide Slide** – any slides that are hidden are not shown in the presentation.
- **Delete Slide** – deletes the selected slide.
- **Layout** – allows changes to the layout of the selected slide.
- **Move** – allows moving or repositioning of the slide in the presentation order.

Creating presentations
By default, Impress opens with the Select a Template dialog displayed to select a template for a new presentation. To create a new presentation without a template, click on Cancel in the Select a Template dialog and a blank slide opens in the Workspace and Slides pane.

To prevent the Select a Template dialog from opening, go to Tools > Options > LibreOffice Impress > General on the Menu bar to open Options LibreOffice Impress General dialog (Figure 19) and deselect the option Start with Template Selection.
For more information on creating presentations, slide show options, and presentation settings, see Chapter 9, Slide Shows & Photo Albums and Chapter 11, Setting Up and Customizing Impress.

![Options LibreOffice Impress General dialog](image)

**Figure 19: Options LibreOffice Impress General dialog**

**Tip**
The first thing to do is decide on the purpose of a presentation and plan accordingly. Having an idea of the audience type, the structure, the content, and how the presentation will be delivered, will save a lot of time from the start.

**New presentation**
When creating a new presentation, Impress shows only one slide in the Slides pane and Workspace.

**Inserting new slide**
A new slide is inserted into a presentation using one of the following methods.

- Go to Slide > **New Slide** on the Menu bar.
- Right-click in the Slides pane and select **New Slide** from the context menu.
- Use the keyboard shortcut **Ctrl+M** (macOS **⌘+M**)
- Go to **Slide Sorter** view in the Workspace, right-click on a slide and select **New Slide** from the context menu.
- Click on **New Slide** in the Presentation toolbar (Figure 20). If the Presentation toolbar is not visible, go to View > **Toolbars** on the Menu bar and select **Presentation** from the drop-down list.

![Presentation toolbar](image)

**Figure 20:**
Presentation toolbar
**Note**

A new slide is inserted after the selected slide in the presentation. If a slide is not selected, then the new slide is inserted as the last slide in the presentation.

**Duplicating slides**

To duplicate a slide, select a slide for duplication in the Slides pane and use one of the following methods. A duplicate slide is inserted after the selected slide in the presentation.

- Right-click on a slide in the Slides pane and select **Duplicate Slide** from the context menu.
- Go to **Slide Sorter** view in the Workspace, right-click on a slide and select **Duplicate Slide** from the context menu.
- Go to **Slide > Duplicate Slide** on the Menu bar.
- Click on **Duplicate Slide** on the Presentation toolbar.

**Slide format**

Click on **Properties** on the Sidebar and open the **Slide** panel (Figure 21) to display the format options available for a presentation. The **Slide** panel allows for quick formatting of all slides included in a presentation and selecting master slides for a presentation. For more information on formatting slides and using master slides, see Chapter 2, Using Slide Masters, Styles, and Templates and Chapter 8, Adding and Formatting Slides and Notes.

![Figure 21: Slide and Layouts panels in Properties deck on Sidebar](image)

**Slide layout**

By default in Impress, the **Title Slide** layout is used for the first slide when a new presentation is created. The layouts included in Impress range from a blank slide to a slide with six contents.
boxes and a title. For more information on slide layouts, see Chapter 8, Adding and Formatting Slides, and Notes.

The first slide in a presentation is normally a title slide. The layouts Title Slide, which also contains a section for a subtitle, or Title Only are the most suitable layouts for the first slide in a presentation. For the remaining slides, select the most suitable layout to use for the slide contents.

Impress does not have the functionality to create custom layouts. However, the different elements in a slide layout can be resized and moved. For more information, see "Modifying slide elements" on page 38.

**Selecting slide layout**

The available layouts are shown in the *Layouts* panel on the Properties deck on the Sidebar. After selecting a slide, select the slide layout using one of the following methods:

- Go to the Properties deck on the Sidebar to open the *Layouts* panel (Figure 21).
- Click on *Slide Layout* on the Presentation toolbar to open the *Layouts* panel on the Properties deck on the Sidebar.
- Click on *Slide > Layout* on the Menu bar to open a drop-down list showing the layouts by name.
- Right-click on the selected slide and select *Layouts* in the context menu.

**Changing slide layout**

After selecting a slide in a presentation, change the slide layout using one of the following methods:

1. Select a slide in the presentation.
2. Select a new layout for the slide using one of the methods described in “Selecting slide layout” above.

**Slide contents**

Several layouts can contain one or more content boxes. Each of these content boxes can be configured to contain the following elements:

- **Slide title** – click on *Click to add Title* and type a title in the text box. Impress enters text editing mode and the Text Formatting toolbar automatically opens. For more information on formatting text, see Chapter 3, Adding and Formatting Text.
- **Text** – click on *Click to add Text* and type the contents into the text box. Impress enters text editing mode and the Text Formatting toolbar automatically opens. For more information on formatting text, see Chapter 3, Adding and Formatting Text.
- **Table** – go to *Insert > Table* on the Menu bar and the Insert Table dialog opens. Enter the number of columns and rows, then click *OK*. The dialog closes and a table is inserted into the slide. Impress enters text editing mode and the Text Formatting toolbar automatically opens. For more information on using tables, see Chapter 3, Adding and Formatting Text.
- **Chart** – go to *Insert > Chart* on the Menu bar and the Impress default chart is placed in the slide. The *Chart Type* panel opens in the Properties deck on the Sidebar allowing editing of the chart to the presentation requirements. For more information on using charts, see Chapter 7, OLE, Spreadsheets, Charts, and Other Objects.
- **Image** – go to *Insert > Image* on the Menu bar and a file browser opens. Navigate to where the required image is located. Select the file and click on *Open*. The image is placed into the slide and the file browser closes. The *Image* panel opens in the Properties deck on the Sidebar allowing editing of the image file. For more information on
using images, see Chapter 4, Adding and Formatting Images, and Chapter 7, OLE, Spreadsheets, Charts, and Other Objects.

- **Audio or video** – go to **Insert > Audio or Video** on the Menu bar and a file browser opens. Navigate to where the required audio or video file is located. Select the file and click on **Open**. The audio or video file is placed into the slide and the file browser closes. The Media Playback toolbar opens allowing operation of the audio or video file. For more information, see Chapter 7, OLE, Spreadsheets, Charts, and Other Objects.

**Note**

Text and graphic elements can be readjusted at any time during the preparation of a presentation. However, changing slide layout that already has contents can have a dramatic effect. If the layout is changed after contents have been added, the contents are not lost, but they may need to be reformatted.

**Modifying slide elements**

When a slide is inserted into a presentation, it contains elements that were included in the selected slide layout. However, it is unlikely that the predefined layouts will suit all requirements for a presentation. Elements required maybe removed or objects inserted such as text and/or graphics.

Although Impress does not have the functionality to create new layouts, it allows for the resizing and moving of the slide elements. It is also possible to add slide elements without being limited to the size and position of content boxes.

**Note**

It is recommended that changes to slide elements in the layouts included in Impress are only made using **Normal** view, which is the default. Attempting any changes to a slide element when in **Master** view is possible, but may result in unpredictable results and requires extra care as well as a certain amount of trial and error.

**Moving contents box**

1) Click on the outer frame of the contents box so that the selection handles are displayed.
2) Place the cursor on the frame so that the cursor changes shape. This is normally a clenched hand, but depends on the computer setup and operating system.
3) Click and drag the contents box to its new position on the slide, then release.

**Resizing contents box**

1) Click on the outer frame so that the selection handles are displayed.
2) Place the cursor on a selection handle the frame so that the cursor changes shape.
3) Click and drag the selection handle on the frame to resize the contents box, then release.
   - Top and bottom selection handles change the height of a contents box.
   - Left and right selection handles change the width of a contents box.
   - Corner selection handles change width and height of a contents box.

**Removing elements**

1) Click a contents box or an element to highlight it and the selection handles are displayed.
2) Press the **Delete** (macOS Ctrl+D) or **Backspace** key to remove the contents box or element.
Adding text
There are two ways of adding text to a slide – contents box or text box. For more information on text, see Chapter 3, Adding and Formatting Text.

- **Contents box** – click *Click to add Text* in the contents box and type the text. Outline styles are automatically applied to the text as it is inserted. If required, change the outline level of each paragraph as well as its position within the contents box by using the arrow buttons on the Outline toolbar and Workspace **Outline** view.

- **Text box** – click on **Insert Text Box** on the Standard toolbar or Drawing toolbar to select text mode, then click on the slide. A text box is created and the Text Formatting toolbar automatically opens. Type the text and click outside the text box to end text mode.

Adding images or objects
To add images or objects to a slide, for example a picture, clipart, drawing, photograph, or spreadsheet, click on **Insert** on the Menu bar and select in the drop-down menu the image or object type required. For more information on adding objects, see the following chapters:

- Chapter 4, Adding and Formatting Images
- Chapter 5, Managing Graphic Objects
- Chapter 6, Formatting Graphic Objects
- Chapter 7, OLE, Spreadsheets, Charts, and Other Objects

Modifying slide appearance
To change the background and other characteristics of all slides in the presentation, the master slide has to be modified or a different master slide selected.

A master slide has a specified set of characteristics that acts as a template and is used as the starting point for creating other slides. These characteristics include slide background, objects in the background, formatting of any text used, and any background graphics.

Impress has a range of master slides, found in the Master Slides deck on the Sidebar. Additional master slides can be created or and saved, or added from other sources. See Chapter 2, Using Slide Masters, Styles, and Templates for information on creating and modifying master slides.

For example, to change the background of an individual slide or a master slide:

1) Right click on a slide or master slide and select **Slide Properties** from the context menu to open the Slide Properties dialog (Figure 22).

2) Select **Background** and then select the type of background to use from None, Color, Gradient, Bitmap, Pattern and Hatch.

3) Make a selection from the various properties available for each type of background.

4) Click **OK** to apply save the changes and close the dialog.

**Note**
Inserting and correctly formatting background is beyond the scope of this chapter. For more information, see Chapter 6, Formatting Graphic Objects.
Modifying presentations

By default, a presentation displays all the slides in the same order as they appear in Slide Sorter view on the Workspace. It is recommended to review the entire presentation and answer some questions. Run the presentation at least once (see “Running a presentation” on page 41), then answer the following questions. Also there maybe more questions after running a presentation for the first time.

- Are the slides in the correct order? If not, some of the slides have to be moved.
- Is the information well spaced and visible to members of an audience at the back of a large room? The audience may not be able to see information at the bottom of a slide, so redesign the presentation to fit the top three-quarters of a screen.
- Would an additional slide make a particular point clearer? If so, create another slide.
- Are some of the slides unnecessary? Hide or delete the slides not required.
- Would animations help some of the slides? This is considered an advanced technique.
- Should some of the slides have a different slide transition than others? The transition of those slides should be changed.

Once the questions have been answered, make the necessary changes. Making changes can be carried out in Slide Sorter view on the Workspace.

Tip

If one or more slides seem to be unnecessary, hide the slide or slides, and view the slide show a few more times to make sure they are not required. To hide a slide, right-click the slide in the Slides pane and select Hide Slide from the context menu. Do not delete a slide until this is done or the slide may have to be created again.
**Slide order**
Change the slide order in a presentation using one of the following methods:

- In **Slide Sorter** view, click on the slide that has to be moved and drag it to its new position in the presentation.
- In the Slides pane, click on the slide that has to be moved and drag it to its new position in the presentation.

**Animations**
If animations are going to be added to slides in a presentation, click on **Animation** on the Sidebar to open the Animation deck giving access to the various animation options as follows:

- Animation category.
- Animation effect.
- How the animation starts.
- Animation direction, duration and delay.
- Automatic preview.

Animation is an advanced technique and is beyond the scope of this chapter. For more information on animation, see Chapter 9, Slide Shows & Photo Albums.

**Slide transitions**
To give a presentation a professional look, it is recommended to add transitions between each slide in a presentation. Click on **Slide Transition** on the Sidebar to open the Slide Transition deck giving access to the various transition options as follows:

- Transition type.
- Modify the transition.
- How the slide advances in the presentation.
- Automatic preview

Adding slide transitions is an advanced technique and is beyond the scope of this chapter. For more information on slide transitions, see Chapter 9, Slide Shows & Photo Albums.

**Running a presentation**

When a presentation is completed, it is recommended to test run the presentation and make sure that everything is correct before showing the presentation in front of an audience. To display a presentation in front of an audience, a Presenter Console is available in LibreOffice Impress. However, the Presenter Console does require multiple displays to be connected to the computer for it to function.

For more information and details about running a presentation and showing it to an audience, see Chapter 9, Slide Shows & Photo Albums.

**Single displays**

Running a slide show using a single display is as follows:

1) Start the slide using one of the following methods:
   - Go to **Slide Show** on the Menu bar and select **Start from First Slide** from the submenu or use the keyboard shortcut F5.
   - Go to **Slide Show** on the Menu bar and select **Start from Current Slide** from the submenu or use the keyboard shortcut Shift+F5.
2) To display each slide in the presentation during the slide show, use one of the following methods:
   – Press the spacebar to advance to the next slide in the presentation.
   – Press the arrow keys to show the next or previous slide in the presentation.
   – If the option *Change slide by clicking on background* has been selected in Slide Show Settings, position the cursor on the slide and click to move to the next slide.

3) When the slide show has ended or to exit the slide show before it has finished, press the *Esc* key to close the slide show and return to Impress.

**Multiple displays**

When multiple displays are connected to a computer, the Presenter Console (Figure 23) in LibreOffice Impress becomes available providing extra control over a presentation as follows:

- On the multiple displays, the audience sees the current slide in the presentation.
- The current slide, next slide in the presentation, any slide notes, and a presentation timer are displayed on the computer display providing control of how the slide show is presented to the audience.
- Starting a slide show using Presenter Console and multiple displays is similar to running a slide show on a single display. For more information and details about using the Presenter Console, see Chapter 9 Slide Shows & Photo Albums.

*Figure 23: Presenter Console*
Chapter 2,  
*Master Slides, Styles, and Templates*
Designing a presentation

In addition to careful planning of the content, as discussed in Chapter 1, Introducing Impress, designing and planning of a presentation is important. Before this can be done, it is recommended to create an outline to determine some of the requirements for the appearance of the slides. For example:

- What color combinations (background and text) will look good and also be easy for an audience to read?
- Would an image help an audience understand the contents better?
- Is there any particular text and image that has to appear on all the slides? For example a company name and logo.
- Would an audience benefit from having the slides numbered so that they can quickly refer to one of them?
- Is a background graphic or gradient required? If so, select something that does not interfere or clash with content such as the colors used in charts.
- How many master slides are required?
- Will one slide design suit all presentation content?

The appearance of slides can be changed as the presentation is developed, but planning ahead saves time in the long run.

What are master slides?

A master slide is a slide that is used as the starting point for other slides. It is similar to a page style in LibreOffice Writer as it controls the basic formatting of all slides based on it. A presentation can have more than one master slide.

Note

LibreOffice uses three terms for one concept: master slide, slide master, and master page. All refer to a slide which is used to create other slides. This user guide uses the term master slide, except when describing the user interface.

A master slide has a defined set of characteristics that are automatically placed onto a slide being created for a presentation. This may include, for example, a background color, graphics, or gradients. Also objects (for example, logos, decorative lines), headers and footers, placement and size of text frames, and text formatting can all be included on a master slide.

All of the characteristics of master slides are controlled by styles. The styles of any new slide created are inherited from the master slide from which it was created. In other words, the styles of the master slide are available and applied to all slides created from that master slide.

Changing a style in a master slide results in changes to all the slides based on that master slide. It is, however, possible to modify each individual slide without affecting the master slide.

Master slides have two types of styles associated with them: presentation styles and drawing styles. The presentation styles can be modified, but new presentation styles cannot be created. For drawing styles, the styles can be modified and new drawing styles can be created. For more information, see “Working with styles” on page 67.
Note

It is recommended to use the master slides whenever possible. However, there are occasions where manual changes are needed for a particular slide. For example, editing a slide to enlarge the chart area when the text and chart layout is used.

Working with master slides

Impress comes with a collection of master slides. These master slides are shown in the Master Slides deck of the Sidebar (Figure 24). This deck has three panels: **Used in This Presentation**, **Recently Used**, and **Available for Use**. Click the expand marker next to the name of a panel to expand it and show master slide thumbnails, or click the collapse marker to collapse the panel to hide the thumbnails.

- **Used in This Presentation** — displays the master slides from a presentation template that are being used in the presentation that is being created.
- **Recently Used** — displays the master slides from presentation templates that have been recently used in a presentation.
- **Available for Use** — displays the master slides that from the default presentation templates that were installed with LibreOffice, or installed from other sources. For example, the presentation templates available on the LibreOffice website at https://www.libreoffice.org/discover/templates-and-extensions/. For more information on presentation templates, see “Working with templates” on page 71.
If a new presentation is being created without using one of the templates available then a default master slide is available (see Chapter 1, Introducing Impress for more information). This default master slide is a good starting point for creating master slides. An example of the default master slide is shown in Figure 25.

Creating master slides

Creating a new master slide is carried out when Impress is in Master View.

4) Go to View > Master Slide on the Menu bar to open Master View in the Workspace. The Master View toolbar also opens (Figure 26). If the Master View toolbar does not open, go to View > Toolbars on the Menu bar and select Master View.

5) Create a new master slide using one of the following methods and a new master slide appears in the Slides pane:
   – Click on New Master in the Master View toolbar.
   – Right-click on a master slide in the Slides pane and select New Master from the context menu.
   – Go to Slide > New Master on the Menu bar.

6) Rename the new master slide using one of the following methods and open the Rename Slide dialog (Figure 27):
   – Click on Rename Master in the Master View toolbar.
   – Right-click on the new master slide in the Slides pane and select Rename Master from the context menu.
7) Enter a memorable name for the new master slide in the Name text box, then click on OK to save the changes and close the dialog.

8) Make sure the new master slide is selected in the Slides pane and add all the text, graphics and master elements that are required for the new master slide. The chapters in this user guide give more information on adding, editing, formatting and managing the different types of objects on a master slide.

9) When finished creating a new master slide, use one of the following methods to return to Normal View:
   – Click on Close Master View on the Master View toolbar.
   – Go to View > Normal on the Menu bar.

10) Save the presentation file before continuing.

**Applying master slides**

To apply a master slide to all slides or selected slides in a presentation:

1) Click on Master Slides to open the Master Slides deck on the Sidebar.

2) Right-click on the master slide required in the Used in This Presentation section in the Master Slides deck on the Sidebar.

3) Select Apply to All Slides or Apply to Selected Slides from the context menu.

**Loading additional master slides**

In a presentation, it maybe necessary to mix multiple master slides that belong to different templates (for more information, see “Working with templates” on page 71). For example, use a completely different layout for the first slide of the presentation, or add a slide from a different presentation.

1) Select the slide or slides in the Slides pane where the master slide is to be changed.

2) Go to Slide > Change Slide Master on the Menu bar to open the Available Master Slides dialog (Figure 28).

3) To add master slides, click on Load to open the Load Master Slide dialog (Figure 29).

4) In Categories, select the template category to use.

5) In Templates, select the template to use for master slides.

6) Click OK to close the Load Master Slide dialog and the master slides from the selected template appear in the Available Master Slides dialog.

7) Select the master slide required in Select a Slide Design box.

8) To apply the selected master slide to all slides in a presentation, select Exchange background page.

9) To apply the slide design to selected slides only, deselect Exchange background page.
10) Click **OK** to apply the template selection and close the Available Master Slides dialog.

![Available Master Slides dialog](image)

**Figure 28: Available Master Slides dialog**

![Load Master Slide dialog](image)

**Figure 29: Load Master Slide dialog**
Editing master slides

The following items can be changed on a master slide:

- Background (color, gradient, hatching, or bitmap). For more information, see “Selecting and applying backgrounds” on page 55.
- Background objects (for example, a logo or decorative graphics). For more information, see “Adding images” on page 57; Chapter 4, Adding and Formatting Pictures; Chapter 5, Managing Graphic Objects; and Chapter 6, Formatting Graphic Objects.
- Text attributes for the main text area and notes. For more information, see “Adding text and fields” on page 63 and Chapter 3, Adding and Formatting Text.
- Size and placement of default frames for slide titles and content. For more information, see “Default text areas” on page 57.
- Size, placement, and contents of header and footer elements to appear on every slide. For more information, see “Adding text and fields” on page 63 and Chapter 3, Adding and Formatting Text.

**Editing**

1) Select View > Master Slide on the Menu bar. This also opens the Master View toolbar.
2) Select a master slide for editing in the Slides pane so that it appears in the Workspace (Figure 30).
3) Go to Slide > Slide Properties on the Menu bar or right-click in the Workspace and select Slide Properties from the context menu to open the Slide Setup dialog (Figure 31).
4) Use the various options in the Slide, Background and Transparency pages in the Slide Setup dialog to make changes to the master slide format.
5) Click OK to save the changes and close the Slide Setup dialog.
6) Select an object on the master slide, then right-click on the object to open a context menu.
7) Select one of the options from the context menu to edit the object. Selecting an option may open another context menu, a dialog, an application or file browser window to make the necessary changes to a selected object.

8) Click on Close Master View on the Master View toolbar or go to View > Normal on the Menu bar to exit from editing master slides.

9) Save the presentation file before continuing.
Note

Any changes made to a master slide in Master Slide view appear on all slides using the same master slide. Always make sure to close Master Slide view and return to Normal view before working on any of the presentation slides.

Direct formatting

Any changes made to any object on a slide in Normal view (for example, changes to bullet point style, color of the title area, and so on) will not be overridden by subsequent changes made to the master slide used for that slide. However, where it is desirable to revert the formatting of a manually formatted object on a slide to the style defined in the master slide, select the object on the slide and use one of the following methods to change the formatting:

- Go to Format > Clear Direct Formatting on the Menu bar.
- Right-click on an object and select Clear Direct Formatting from the context menu.

Note

The title and text boxes inherit the properties of a master slide, but if the position of these text boxes in the master slide has changed, the layout may appear corrupted. Some of the layout elements may have to have the horizontal and/or vertical manually repositioned on a slide.

Figure 32: Slide Properties dialog - Background Color page

Selecting and applying backgrounds

Backgrounds can be applied to a number of elements in Impress (for example: slide, default text area, image and so on). The procedure is similar when applying a background to a master slide, a slide, or an object on a slide.

Using slide setup

1) Select View > Master Slide on the Menu bar. This also opens the Master View toolbar.
2) Select a master slide in the Slides pane so that it appears in the Workspace.

3) Go to **Slide > Slide Properties** on the Menu bar or right-click in the Workspace and select **Slide Properties** from the context menu to open the Slide Properties dialog.

4) Select the Background tab to open the Background page on the Slide Properties dialog (Figure 32).

5) Select the type of background required from **Color, Gradient, Bitmap, Pattern and Hatch**. See Chapter 6, Formatting Graphic Objects for more information on how to use the options available for each type of background selected.

6) When satisfied with the slide background, click **OK** to save the changes and close the Slide Properties dialog.

**Using background style**

1) Select **View > Master Slide** on the Menu bar. This also opens the Master View toolbar.

2) Select a master slide in the Slides pane so that it appears in the Workspace.

3) Click on **Styles** on the Sidebar to open the Styles deck.

4) Click on **Presentation Styles** on the Styles deck to open the **Presentation Styles** list (Figure 33).

5) Right-click on **Background** style and select **Modify** from the context menu to open the Background dialog. This dialog only has an **Area** tab and offers the same options as the Background page in the Slide Properties dialog.

6) Select the type of background required from **Color, Gradient, Bitmap, Pattern and Hatch**. See Chapter 6, Formatting Graphic Objects for more information on how to use the options available for each type of background selected.

7) When satisfied with the background, click **OK** to save the changes and close the Background dialog.
Tip

Custom fills can be created for each type of background. See Chapter 6, Formatting Graphic Objects for more information on creating custom fills for each type of background.

Adding images

When the same image appears on every slide of a presentation, the easiest and quickest solution is to use a master slide. This saves time creating a presentation and allows modification or repositioning of the image on all slides. If the same image is added to each slide manually, modification and repositioning has to be performed on each individual slide in a presentation, which can produce errors. In addition to images, a number of other objects can be added to the background, for example decorative lines, text, shapes, and company logos.

LibreOffice supports a large number of image and graphic formats. For more information on working with images, see Chapter 4, Adding and Formatting Pictures; Chapter 5, Managing Graphic Objects; and Chapter 6, Formatting Graphic Objects.

For example, one of the most common actions in preparing a presentation is to add an image to the master slide. To insert an image already available on the computer, follow these steps:

1) Select View > Master Slide on the Menu bar. This also opens the Master View toolbar.
2) Select the master slide where the image is to be added.
3) Select Insert > Image on the Menu bar to open the file browser.
4) Navigate to the directory where the image is located and select it.
5) Click Open to close the file browser and the image is placed centrally into the master slide.
6) If necessary, modify and/or reposition the image on the master slide.
7) Right-click on the image and select Arrange > Send to Back from the context menu. This moves the image to the background so that any information added to the slide when creating a presentation appears over the background image.

Note

LibreOffice offers the option to insert an image as a link to a file rather than embedding it in a presentation. This is only useful when a presentation is not intended for distribution onto other computers and remains in the same directory structure and computer. For example, a presentation could be created on a notebook computer, which is used to give the presentation to a group of clients.

However, if the presentation file is to be distributed to other computers, the image must be embedded to avoid the “missing image” syndrome when the presentation is given using a different computer.

Default text areas

When a master slide is opened for editing, it contains five default text areas, as shown in Figure 25 on page 50.

- Title area for AutoLayouts.
- Object area for AutoLayouts.
- Date area.
- Footer area.
Quick positioning and resizing
Click in any of these areas to display the selection handles around the default text area. Use these selection handles to modify the size and position of a default text area.

1) Select the default text area for repositioning so that the selection handles are visible.
2) Move the cursor toward the border of the default text area, not on a selection handle, and the cursor changes shape. Normally this is a clenched hand, but the shape is dependent on the computer setup and operating system.
3) Click and hold, then drag the default text area to the desired position. Release when the text area is at the desired position.
4) Position the cursor over a left or right selection handle and the cursor changes shape.
5) Click and hold, then drag the left or right selection handle to change the width of the default text area. Release when the text area is at the desired width.
6) Position the cursor over a top or bottom selection handle and the cursor changes shape.
7) Click and hold, then drag the top or bottom selection handle to change the height of the default text area. Release when the text area is at the desired height.
8) Position the cursor over a corner selection handle and the cursor changes shape.
9) Click and hold, then drag the corner selection handle to change both the height and width of the default text area at the same time. Release when the desired width and height are reached.

Note
The shape of the cursor usually changes when positioned over a selection handle giving a clear visual indication of how it will affect the shape of the default text area when the selection handle is moved.

Tip
Keep the Shift key pressed while dragging a selection handle to maintain the ratio between the width and height dimensions of the default text area.

Controlled positioning and resizing
To accurately control the shape, size and position of a default text area, it is recommended to use the Position and Size dialog or the Position and Size panel in the Properties deck on the Sidebar.

1) Select the default text area by clicking on its border.
2) Use one of the following methods to access the position and size options for a default text area:
   - Go to Format > Object and Shape > Position and Size on the Menu bar to open the Position and Size dialog (Figure 34).
   - Use the keyboard shortcut F4 to open the Position and Size dialog.
   - Right-click on the border of the default text area and select Position and Size from the context menu to open the Position and Size dialog.
   - Click on Properties on the Sidebar to open the Properties deck, then open the Position and Size panel (Figure 35).
Figure 34: Position and Size dialog
The Position and Size options are explained fully in the *Draw Guide*. Only short descriptions of the most important functions are provided as follows:

- **Position** – specifies the X (horizontal) and Y (vertical) position of the default text area. The values represent the distance of the selected base point and the default position is the top left corner of the slide.
- **Size** – specifies the width and height of the default text area.
- **Base point** – available in the Position and Size dialog only. Allows selection of a point on the rectangular area that does not move while resizing. The default setting of top left corner means that the position of the top left corner of the area will not change after resizing.
- **Rotation** – rotates the default text area. For example, place the footer area on the side of the slide by rotating each text area by 90 degrees obtain a more modern layout. In general, it is preferable to use only horizontal or vertical orientation for ease of editing, although the program does not impose restrictions on the values that can be used.
- **Slant & Corner Radius** – adds a corner radius to a text box border only, but if a visible line style has been selected. Slant options are only available for images or shapes, not text boxes.
Background
Change the type of area fill used for backgrounds in a default text area using one of the following methods. The options available depend on the type of area fill selected. See Chapter 6, Formatting Graphic Objects for more information on changing backgrounds.

- Go to Format > Object and Shape > Area on the Menu bar to open the Area dialog (Figure 36).
- Right-click on the default text area and select Area from the context menu to open the Area dialog.
• Click on **Properties** on the Sidebar to open the Properties deck, then open the **Area** panel (Figure 37).

**Figure 38: Line dialog - Line page**

**Figure 39: Line panel in Properties deck on Sidebar**

**Border**

Change the type of line used for borders in a default text area using one of the following methods. The options available depend on the type of line selected. See Chapter 6, Formatting Graphic Objects for more information on changing borders.
• Go to Format > Object and Shape > Line on the Menu bar to open the Line dialog (Figure 38).
• Right-click on the object and select Line from the context menu to open the Line dialog.
• Click on Properties on the Sidebar to open the Properties deck, then open the Line panel (Figure 39).

Alignment
Change the alignment of default text area in relation to its position on a master slide or the alignment between a default text area and other objects on a master slide using one of the following methods. See Chapter 5, Managing Graphic Objects for more information on changing alignment of default text areas.

• Go to Format > Align Objects on the Menu bar and select the type of alignment from the options available in the context menu.
• Right-click on the object and select Align Objects from the context menu, then select the type of alignment from the options available in the context menu.
• Click on the triangle ▼ to the right of Align Objects on the Line and Filling toolbar and select the type of alignment from the options available.
• Select the required alignment tool in the Position and Size panel in the Properties deck on the Sidebar.

Arrangement
Arrange the position of an object on a slide in relation to other objects on a slide using one of the following methods. See Chapter 5, Managing Graphic Objects for more information on changing position of default text areas in relation to other objects.

• Go to Format > Arrange on the Menu bar and select the type of arrangement from the options available in the context menu.
• Right-click on the object and select Arrange from the context menu, then select the type of arrangement from the options available in the context menu.
• Click on the required arrangement tool on the left end of the Line and Filling toolbar.
• Select the required arrangement tool in the Position and Size panel on the Properties deck on the Sidebar.

Adding text and fields
Adding text and fields to a master slide allows placing of information that will appear on all the slides in a presentation. For example, presentation title, company name and logo, date, and slide number. For more information on adding and formatting text and fields, see Chapter 3, Adding and Formatting Text.

Text
Text objects can be placed anywhere on the master page to appear on every slide in a presentation. Text objects can also be placed in the footer if the default fields in the footer of a presentation are not going to be used.

1) Select View > Master Slide on the Menu bar to open the master slide view. This also opens the Master View toolbar.
2) Select the master slide so that it appears in the Workspace.
3) Switch text editing mode on using one of the following methods. The Text Formatting toolbar (Figure 40) automatically opens replacing the Line and Filling toolbar.
   – Select Insert Text Box on the Standard or Drawing toolbar.
– Go to **Insert > Text Box** on the Menu bar.
– Use the keyboard shortcut **F2**.

![Text Formatting toolbar](image)

**Figure 40: Text Formatting toolbar**

4) Click once on the master slide so that a text box is created and there is a flashing cursor inside the text box.

5) Type or paste the text into the text object, then format the text. See Chapter 3, Adding and Formatting Text for more information.

6) Click outside the text object to close the Text Formatting toolbar and reopen the Line and Filling toolbar.

7) Click **Close Master View** on the Master View toolbar or go to **View > Normal** on the Menu bar when adding and formatting text to a master slide is completed.

**Default footer sections**

By default, the footer used in a slide consists of three sections with each section containing a default field as follows:

- **Left section** – date and time, labelled *Date Area*. Field name is `<date/time>`.
- **Center section** – footer text, labelled *Footer Area*. Field name is `<footer>`. This section can be used for the presentation title, file name and so on.
- **Right section** – slide number, labelled *Slide Number Area*. Field name is `<number>`.

**Header and Footer dialog**

The default footer fields are set up as follows using the Header and Footer dialog (Figure 41):

1) Select **View > Master Slide** on the Menu bar to open the master slide view. This also opens the Master View toolbar.

2) Select the master slide so that it appears in the Workspace.

3) Go to **Insert > Header and Footer** on the Menu bar to open the Header and Footer dialog.

4) Select **Date and Time** for the date and time to appear in the left section of the footer.
   – For a fixed date and time in the left footer section, select **Fixed** and enter the date to use in the text box.
   – For a variable date and time in the left footer section, select **Variable**, then select the format and language to use from the **Format** and **Language** drop down lists. Using a variable date and time means that each time the presentation is opened, the date and time are updated.

5) To place text in the footer center section, select **Footer** and then type or paste the required text into the **Footer text** box.

6) To place the slide number in the right section of the footer, select **Slide number**.

7) If the footer is not going to appear on the first slide of a presentation, select **Do not show on the first slide**. The first slide is normally the title slide of a presentation.

8) Click **Apply** to save the changes and close the Header and Footer dialog.
9) To format the text used for the default footer fields, see Chapter 3, Adding and Formatting Text for more information.

![Header and Footer dialog - Slides page](image)

**Figure 41: Header and Footer dialog - Slides page**

10) Click **Close Master View** on the Master View toolbar or go to **View > Normal** on the Menu bar when setting up the default footer fields is completed.

---

### Note

It is possible to format, resize, and reposition the default sections of a footer. See “Default text areas” on page 57 and Chapter 3, Adding and Formatting Text for more information.

---

**Custom footer sections**

The default fields in a footer section can be replaced with text or manual fields as follows:

1) Select **View > Master Slide** on the Menu bar to open the master slide view. This also opens the Master View toolbar.

2) Select the master slide so that it appears in the Workspace.

3) Highlight the default field in the footer section and press the *Delete* or *Backspace* key. A flashing text cursor appears in the footer section and the Text Formatting toolbar automatically opens replacing the Line and Filling toolbar.

4) Type in the text or insert a manual field into the footer section. For more information on manual fields, see “Manual fields” below.

5) Format the text or manual field placed in the footer section. See Chapter 3, Adding and Formatting Text for more information.

6) Click outside the footer section to close the Text Formatting toolbar and reopen the Line and Filling toolbar.

7) Click **Close Master View** on the Master View toolbar or go to **View > Normal** on the Menu bar when setting up a custom footer section is completed.
**Manual fields**

Manual fields, for example date or slide number, can be added as text objects on a master slide or replace one of the default footer fields. The fields used in Impress are as follows:

- Date (fixed)
- Date (variable) – updates automatically each time the presentation is opened.
- Time (fixed)
- Time (variable) – updates automatically each time the presentation is opened and each time a slide is opened more than once during a presentation.
- Author – first and last names listed in the LibreOffice user data.
- Slide number
- Slide Title
- Slide Count
- File Name

**Inserting fields**

Insert a field on a master slide as follows:

1) Select **View > Master Slide** on the Menu bar to open the master slide view. This also opens the Master View toolbar.
2) Select the master slide so that it appears in the Workspace.
3) Click anywhere on the master slide without selecting an object.
4) Go to **Insert > Field** on the Menu bar and select the required field from the context menu. By default, the field is placed in the center of the master slide.
5) Reposition the field text box to the desired position on the master slide. See “Default text areas” on page 57 for more information.
6) Format the text placed in a field, see Chapter 3 Adding and Formatting Text for more information.
7) Click **Close Master View** on the Master View toolbar or go to **View > Normal** on the Menu bar when inserting a field is completed.

**Replacing default fields**

Replace a default footer field on a master slide as follows:

1) Select **View > Master Slide** on the Menu bar to open the master slide view.
2) Select the master slide so that it appears in the Workspace.
3) Highlight all of the characters used in the default field being replaced in the footer.
4) Go to **Insert > Field** on the Menu bar and select the required field from the context menu.
5) Format the text placed in the field, see Chapter 3 Adding and Formatting Text for more information.
6) Click **Close Master View** on the Master View toolbar or go to **View > Normal** on the Menu bar when replacing the default footer fields is completed.

**Tip**

To change the number format (1, 2, 3 or a, b, c or i, ii, iii, and so on) for the slide number, go to **Slide > Slide Properties** on the Menu bar to open the Slide Properties dialog. In **Layout Settings**, select the type of number format to use from the **Slide numbers** drop down list.
Working with styles

A style is a set of formats that can be applied to selected elements such as slides, text, lists, frames, borders, lines and area fills in a presentation to quickly set or change their appearance. Applying a style means applying a group of formats at the same time providing a consistent look to a presentation. For example, to manually change an attribute on the same object type on every slide in a presentation is time consuming and prone to errors. Using styles reduces time and provides greater accuracy.

Impress has two types of styles available for formatting text and graphic objects – presentation styles and drawing styles.

- For information on formatting text, see Chapter 3, Adding and Formatting Text.
- For information on formatting graphic objects, see Chapter 6, Formatting Graphic Objects and the Draw Guide.
- More information on styles used in LibreOffice can be found in the Getting Started Guide.

Note

The presence of text and title styles both in the presentation and drawing styles may seem confusing. This apparent duplication is because Impress uses special text boxes (auto layout boxes) when adding structured text to slides where presentation styles apply. The title and other text styles in drawing styles are used on any other text boxes, or text associated with shapes or lines.

Presentation styles

Presentation styles in Impress are used when creating a presentation using one of the Impress slide layouts. These presentation styles are divided into four categories.

- **Background** and **Background objects** – are used to format objects on the default master slide such as icons, decorative lines, and shapes.
- **Notes** – formats the text used in presentation notes.
- **Outline 1 thru Outline 9** – are used for the different levels of the outline to which they belong. For example, Outline 2 is used for the sub-points of Outline 1, Outline 3 is used for the sub-points of Outline 2 and so on.
- **Subtitle** and **Title** – formats the text used for any titles or subtitles used on slides.

Note

As with the Heading styles in Writer, the Outline styles in Impress are hierarchically linked. For example, changing an attribute in the Outline 1 style cascades through all the other styles for Outline levels.

The default master slide and slide layouts in Impress use auto layout boxes. Presentation styles can only be used within these auto layout boxes. An example of text using these presentation styles is shown in Figure 25 on page 50.

Presentation styles cannot be created or deleted, but can be formatted, modified or updated to the presentation requirements. Also, the presentation style used for an object cannot be changed to another presentation style. For example, text with Outline 2 style cannot be changed to Outline 3 style.
Note

Changing outline levels is done in normal view using the Tab key or Shift+Tab key combination or the Promote and Demote tools on the Outline toolbar. See Chapter 3, Adding and Formatting Text for more information.

Note

Any text added to a slide using the text tools available is automatically placed in a standard text box and allocated the Default Drawing Style from Drawing Styles. For more information on formatting text, see Chapter 3, Adding and Formatting Text.

Drawing styles

Drawing styles in Impress define the characteristics of graphic and text objects placed on a slide. These styles include attributes for line, area, shadowing, transparency, text, connectors and dimensioning.

For example, when creating organization charts in a presentation, it will probably be required to have all of the objects with a consistent appearance, such as line style, font type, shadow, and so on. The easiest way to achieve this result with the minimum effort is to use a drawing style for the objects and apply it to each object. The major benefit is that if there is a change, say, the background color of objects, all that is required is to modify the style rather than each individual object.

Drawing styles included with Impress cannot be deleted, but can be formatted, modified, and updated. New or custom drawing styles can be created, see “Custom styles” on page 70. Any custom style created is only available in the presentation where it was created.

Accessing styles

Use one of the following methods to access styles available in Impress.

- Use the keyboard shortcut F11 (Windows and Linux) or ⌘+T (macOS) and open the Styles deck on the Sidebar.
- Go to Format > Styles on the Menu bar and select an option from the submenu that opens. This will open the Graphic Styles dialog for the selected style.
- Click on Show the Styles Sidebar (F11) located on the Line and Filling toolbar and open the Styles deck on the Sidebar.
- Click on Styles on the Sidebar to open the Styles deck.

Editing styles

Formatting presentation and drawing styles can be carried out in either Normal or Master Slide view. Formatting options are available in dialogs for each style or using Format on the Menu bar. For more information on formatting text and objects, see Chapter 3, Adding and Formatting Text and Chapter 6, Formatting Graphic Objects.

Dialog formatting

1) Select an object on a slide or master slide and its style is highlighted in the Styles deck on the Sidebar.

2) Go to Format > Styles > Edit Style on the Menu bar or right-click on the highlighted style in the Styles deck on the Sidebar to open the formatting dialog for the selected style. An example dialog for the Title style is shown in Figure 42.
3) Use the various options available in the tabbed pages of the dialog to format the style.
4) Click **OK** to save the formatting changes and close the dialog.

**Note**

Clicking on **Reset** before clicking **OK** removes all formatting changes made in the style formatting dialog.

**Format menu**

1) Open the Styles deck on the Sidebar. See “Accessing styles” on page 68 for more information.

2) Click on **Presentation Styles** or **Drawing Styles** at the top left of the Styles deck and select a style from the displayed list.

3) Go to **Format** on the Menu bar to open a submenu with various formatting options available. Depending on the object selected, some formatting options will not be available and are greyed out.

4) Select a formatting option from the submenu. Depending on the option selected, another submenu may open giving further formatting options or a formatting dialog opens.

**Modifying**

1) Open the Styles deck on the Sidebar. See “Accessing styles” on page 68 for more information.
2) Click on Presentation Styles or Drawing Styles at the top left of the Styles deck and select a style from the displayed list.

3) Right-click on the style selected and select Modify from the context menu to open the formatting dialog for the style selected. An example dialog for the Title style is shown in Figure 42.

4) Make the necessary changes to the selected style using the various options available in the dialog that has opened.

5) Click OK to save the changes and close the dialog.

**Updating**

Updating a presentation or drawing style is similar to modifying, but changes to the text or object are made first. Updating styles can only be carried out in Normal view.

1) Select the text or object on a slide in Normal view.

2) Use the various tools on the Text Formatting toolbar, Line and Filling toolbar, or the options in Format on the Menu bar to format the selected object.

3) Open the Styles deck on the Sidebar. See “Accessing styles” on page 68 for more information.

4) Click on Presentation Styles or Drawing Styles at the top left of the Styles deck and select a style from the displayed list. The style used for the selected object will be highlighted.

5) Click on Update Style at the top right of the Styles deck and the style is updated to include the formatting changes made to the selected object.

**Custom styles**

Custom presentation styles cannot be created in Impress, only custom drawing styles can be created. These custom drawing styles are only available for the presentation being created.

1) Create or select an object on a slide to create a custom drawing style.

![Figure 43: New Style from Selection dialog](image)
2) Format the object to the presentation requirements using the various formatting options available in the Text Formatting toolbar, Line and Filling toolbar, or the options in Format on the Menu bar.

3) Open the Styles deck on the Sidebar. See “Accessing styles” on page 68 for more information.

4) Click on Drawing Styles at the top left of the Styles deck to open the drawing styles list.

5) Click on New Style from Selection at the top right of the Styles deck and the New Style from Selection dialog opens (Figure 43).

6) Enter a name for the custom drawing style in the Enter new style name text box.

7) Click OK to close the Create Style dialog. The custom drawing style is created and appears in the drawing styles list in the Styles deck on the Sidebar.

Direct formatting

Direct formatting overrides any formatting applied to an object when a style is used. Direct formatting cannot be removed from an object by applying a style to it. To remove any direct formatting, select the object so that the selection handles are visible, then use one of the following methods to clear any direct formatting:

- Use the keyboard shortcut Ctrl+Shift+M (macOS Shift+M).
- Go to Format > Clear Direct Formatting in the Menu bar.
- If the object is a text object, highlight all of the text and then click on Clear Direct Formatting on the Text Formatting toolbar.
- If the object is a text object, highlight all of the text, right-click on the selected text and select Clear Direct Formatting from the context menu.

Linked styles

Impress styles support linking or inheritance. This allows a style to be linked to another (parent) style so that it inherits all the formatting settings of the parent, creating families of styles.

For example, if there are multiple boxes that differ in color, but are otherwise identically formatted, the best way to proceed is to define a style for the box including borders, area fill, font, and so on. Then create a number of styles that are hierarchically dependent, but differ only in the fill color attribute. For example, if the font size or the thickness of the border needs to be changed, only change the parent style and all the other linked (child) styles change accordingly.

Assigning styles keyboard shortcuts

LibreOffice provides a set of predefined keyboard shortcuts which allow quick application of styles while working with a presentation. These shortcuts can be redefined or custom shortcuts created. For more information, see Appendix A, Keyboard Shortcuts and the Getting Started Guide.

Working with templates

A template is a special type of presentation that is used as a basis to create presentations. For example, create a template for business presentations so that any new presentations have the company logo, name and information on the first slide and the remaining slides in the presentation only show the company logo and name.

Templates can contain anything that presentations can contain, such as text, graphics, a set of styles, and user-specific setup information such as measurement units, language, the default printer, and toolbar and menu customization.
All document types created using LibreOffice are based on templates. Specific templates can be created for any document type (text, spreadsheet, drawing, presentation). If a template is not specified when creating a new document, then the default template for that type of document is used. If a default template is not specified, LibreOffice uses the blank template for that type of document that is installed with LibreOffice. This default template can be changed, see “Setting default template” on page 74 for more information.

However, Impress is a little different from other LibreOffice components, in that it starts with the Select a Template dialog (Figure 44), unless this option has been turned off for this dialog in LibreOffice options. When creating a presentation and the template dialog is active, it opens offering several choices for templates as a starting point for a presentation. If this Select a Template dialog is turned off for creating a new presentation, LibreOffice uses the LibreOffice default template for presentations. If a default template has been defined, LibreOffice uses this default template to create a presentation, see “Setting default template” on page 74 for more information.

For more information on templates and how to use them, see the Getting Started Guide.

**Templates supplied with LibreOffice**

Impress comes with a set of predefined templates. These templates only contain backgrounds and background objects, providing a starting point to create presentations or presentation templates.

Any templates created are located in the My Templates folder after the template has been saved as a presentation template. These templates appear in the LibreOffice startup window and the Select a Template dialog the next time LibreOffice is started.

---

*Figure 44: Select a Template dialog*

All document types created using LibreOffice are based on templates. Specific templates can be created for any document type (text, spreadsheet, drawing, presentation). If a template is not specified when creating a new document, then the default template for that type of document is used. If a default template is not specified, LibreOffice uses the blank template for that type of document that is installed with LibreOffice. This default template can be changed, see “Setting default template” on page 74 for more information.

However, Impress is a little different from other LibreOffice components, in that it starts with the Select a Template dialog (Figure 44), unless this option has been turned off for this dialog in LibreOffice options. When creating a presentation and the template dialog is active, it opens offering several choices for templates as a starting point for a presentation. If this Select a Template dialog is turned off for creating a new presentation, LibreOffice uses the LibreOffice default template for presentations. If a default template has been defined, LibreOffice uses this default template to create a presentation, see “Setting default template” on page 74 for more information.

For more information on templates and how to use them, see the Getting Started Guide.

**Templates supplied with LibreOffice**

Impress comes with a set of predefined templates. These templates only contain backgrounds and background objects, providing a starting point to create presentations or presentation templates.

Any templates created are located in the My Templates folder after the template has been saved as a presentation template. These templates appear in the LibreOffice startup window and the Select a Template dialog the next time LibreOffice is started.
Use one of the following methods to create a new presentation using a template:

- Click on the triangle ▼ on the right of **Templates** in LibreOffice start up window and then select **Impress Templates** from the context menu to display the available presentation templates. Select a template and a new presentation opens.

- Go to **File > New > Templates** on the Menu bar to open the Templates dialog (this dialog is similar to the Select a Template dialog). Select **Presentations** from the **Filter** drop-down list to display presentation templates. Select a presentation template and click **OK**. The dialog closes and a new presentation opens.

- Use the keyboard shortcut **Ctrl+Shift+N** (macOS ⌘+Shift+N) to open the Templates dialog (this dialog is similar to the Select a Template dialog). Select **Presentations** from the **Filter** drop-down list to display presentation templates. Select a presentation template and click **OK**. The dialog closes and a new presentation opens.

**Creating templates**

Create a template and save it to a template folder as follows:

1) Open a presentation or presentation template as a starting point for a new template.
2) Add and format the content and styles as required for the new presentation template.
3) Go to **File > Templates > Save As Template** on the Menu bar to open the Save as Template dialog (Figure 45).
4) Enter a name for the new template in the **Enter Template Name** text box.
5) Select a template category for the new template.
6) If required, select the option **Set as default template** to use as the default template the next time LibreOffice is opened and no template is selected. See “Setting default template” below for more information on setting default templates.

![Save As Template dialog](Figure 45: Save As Template dialog)
7) Click on **Save** to save the new template and close the Save as Template dialog. The template appears in the LibreOffice startup window and the Select a Template dialog the next time LibreOffice is started.

---

**Note**

When saving a new template, it is important to save the template in one of the categories given in the Save as Template dialog. This allows LibreOffice to find the new template and use it for creating a new presentation.

---

### Setting default template

If a new presentation is being created and no template is selected, LibreOffice creates the presentation from the default Impress template. This is normally a blank template. However, any presentation template can be set as the default template, even a new template that has been recently created. The template has to be located in a category displayed in the Save as Template dialog so that LibreOffice can find it. The default template can always be reset to the original LibreOffice default template.

**Changing default template**

1) Use one of the following methods to open the Select a Template dialog.
   - Go to **File > New > Templates** on the Menu bar.
   - Go to **File > Templates > Manage Templates** on the Menu bar.
2) Select the template to use as the default LibreOffice presentation template.
3) Right-click on the selected template and select **Set as Default** from the context menu.
4) Click on **Open** and a new presentation opens using the new default template and sets the default presentation template in LibreOffice. The next time a new presentation is created and a template is not selected, the presentation is created using the new default presentation template.

**Resetting default template**

To reset the default presentation template back to the original LibreOffice default template for presentations:

1) Use one of the following methods to open the Select a Template dialog.
   - Go to **File > New > Templates** on the Menu bar.
   - Go to **File > Templates > Manage Templates** on the Menu bar.
2) Select the presentation template that is being used as the default presentation template in the Select a Template dialog.
3) Right-click on the template and select **Reset Default** from the context menu.
4) Click on **Close** to close the Select a Template dialog. The next time that a new presentation is created and a template is not selected, the presentation is created using the default LibreOffice presentation template.

### Editing templates

Template styles and content can be edited and reapplied to presentations that were created from that template.

1) Use one of the following methods to open the Select a Template dialog.
   - Go to **File > New > Templates** on the Menu bar.
   - Go to **File > Templates > Manage Templates** on the Menu bar.
– Click on the triangle ▼ on the right of Templates in LibreOffice start up window and select Impress Templates from the context menu.

2) Right-click on the template to be edited and select Edit from the context menu and the template opens in Impress.

3) Edit and update the styles, text and/or objects on the selected template.

4) Go to File > Save on the Menu bar or use the keyboard shortcut Ctrl+S (macOS ⌘+S) to save the changes.

5) Close the template or create a presentation using the edited template.

**Note**

Any presentation created from the template before editing can be updated to show the changed template settings the next time the presentation is opened after template editing. A confirmation dialog opens asking if the updated styles are to be used or keep the old styles. If keep the old styles is selected, then the presentation continues to use the old styles without any confirmation.

**Organizing templates**

LibreOffice can only use templates that are in LibreOffice template categories (template folders). New LibreOffice template categories can be created and used to organize LibreOffice templates. For example, separate template categories for different projects or clients. Templates can also be imported and exported.

**Tip**

The location of folders used LibreOffice template categories varies with computer operating systems. To learn where the template folders are stored on a computer, go to Tools > Options > LibreOffice > Paths.

**Creating custom categories**

1) Use one of the following methods to open the Select a Template dialog.
   – Go to File > New > Templates on the Menu bar.
   – Go to File > Templates > Manage Templates on the Menu bar.

2) Right-click on Tools in the bottom left of the Select a Template dialog and select New Category from the context menu.

3) Enter a category name in Enter new category name box that has opened.

4) Click OK to save the new category and the category appears in the Filter drop-down list for categories at the top of the Select a Template dialog.

**Deleting custom categories**

Template categories supplied with LibreOffice or installed using the Extension Manager cannot be deleted. Only custom categories that have been created in Impress can be deleted.

1) Use one of the following methods to open the Select a Template dialog.
   – Go to File > New > Templates on the Menu bar.
   – Go to File > Templates > Manage Templates on the Menu bar.

2) Right-click on Tools in the bottom left of the Select a Template dialog.

3) Select Delete Category from the context menu to open the Delete Category dialog (Figure 46).
4) Select the custom category for deletion.
5) Click OK to delete the custom category and confirm the deletion.

**Moving templates**

1) Use one of the following methods to open the Select a Template dialog.
   - Go to **File > New > Templates** on the Menu bar.
   - Go to **File > Templates > Manage Templates** on the Menu bar.

2) Select the template that is going to be moved.
3) Click on Move at the bottom of the Select a Template dialog to open the Select Category dialog (Figure 47).

4) Select a category from the displayed list in Select from Existing Category, or select Create a New Category and create a new category for the template.

5) Click OK to move the template to its new category and close the Select Category dialog.

**Deleting templates**

Templates supplied with LibreOffice or installed using the Extension Manager cannot be deleted. Only templates that have been created in Impress or imported from other sources can be deleted.

1) Use one of the following methods to open the Select a Template dialog.
   - Go to File > New > Templates on the Menu bar.
   - Go to File > Templates > Manage Templates on the Menu bar.

2) Right-click on the template being deleted and select Delete from the context menu.

3) Click on Yes to confirm the deletion.

**Renaming templates**

Templates supplied with LibreOffice or installed using the Extension Manager cannot be renamed. Only templates that have been created in Impress or imported from other sources can be renamed.

1) Use one of the following methods to open the Select a Template dialog.
   - Go to File > New > Templates on the Menu bar.
   - Go to File > Templates > Manage Templates on the Menu bar.

2) Right-click on the template being renamed and select Rename from the context menu.

3) Enter a new template name in the text box that has opened.

4) Click on OK to save the new template name.

**Importing templates**

If a template is in a different location on the computer, then the template must be imported into a LibreOffice category for LibreOffice to recognize the template.

1) Use one of the following methods to open the Select a Template dialog.
   - Go to File > New > Templates on the Menu bar.
   - Go to File > Templates > Manage Templates on the Menu bar.

2) Click on Import at the bottom of the Select a Template dialog to open the Select Category dialog.

3) Select a category from the displayed list or select Create a New Category in the Select Category dialog.

4) In the file browser window that opens, navigate to the folder where the template is located on the computer.

5) Select the template and click Open. The file browser window closes and the template appears in the selected category.

**Exporting templates**

1) Use one of the following methods to open the Select a Template dialog.
   - Go to File > New > Templates on the Menu bar.
   - Go to File > Templates > Manage Templates on the Menu bar.
2) Select the template for export, then click on **Export** at the bottom of the Select a Template dialog to open a file browser window.

3) Navigate to the folder where the template is to be exported to and click on **OK**. The template is exported to the selected location and the file browser window closes.
Chapter 3,
Adding and Formatting Text
Introduction

Any text used in slides is contained in text boxes and this chapter describes the following:

- How to create, modify, use, and delete text boxes.
- How to create, modify and format the various types of text that can be inserted.
- How to insert special forms of text such as ordered (numbered) or unordered (bulleted) lists, tables, fields, hyperlinks, and text columns.

Working with text boxes

Adding text boxes to slides is carried out using one of the following methods:

- Use a predefined Impress layout which includes AutoLayout text boxes.
- Create a text box using the Insert Text Box for a horizontally aligned text box on the Standard toolbar (Figure 48) or the Drawing toolbar (Figure 49).
- Create a text box using the Insert Vertical Text for a vertically aligned text box on the Standard toolbar or the Drawing toolbar.
- Use the keyboard shortcut F2 to create text boxes on a slide for horizontal text.

![Standard toolbar](image)

Figure 48: Standard toolbar

![Drawing toolbar](image)

Figure 49: Drawing toolbar

Note

The Insert Vertical Text tool for creating a vertical text box and inserting vertical text is only available when Asian and Complex text layout (CTL) options are enabled. Go to Tools > Options > Language Settings > Languages on the Menu bar (macOS LibreOffice > Preferences > Language Settings > Languages) to select these options for vertical text to be available in Impress.
AutoLayout text boxes

AutoLayout text boxes are automatically created when one of the slide layouts available in Impress is selected.

4) Make sure **Normal** view is selected in the Workspace.

5) Select a slide layout using one of the following methods:
   - Open the **Layouts** panel in the Properties deck on the Sidebar (Figure 50)
   - Go to **Slide > Layout** on the Menu bar to open a submenu listing the available slide layouts.

6) Click on **Click to add Title** or **Click to add Text**. This text automatically disappears and is replaced by a flashing text cursor. The Text Formatting toolbar (Figure 51) automatically opens replacing the Line and Filling toolbar.

7) Type or paste text into the AutoLayout text box and, if necessary, format the text to the presentation requirements using the information in this chapter.

8) If necessary, copy, resize, and/or reposition the AutoLayout text box using the information in this chapter.

9) Click outside the AutoLayout text box to deselect it.
Creating text boxes

1) For horizontal text, click on Insert Text Box, or for vertical text, click on Insert Vertical Text on the Standard toolbar or the Drawing toolbar. The Text Formatting toolbar automatically opens, replacing the Line and Filling toolbar.

2) Create a horizontal text box using one of the following methods:
   - Click on the slide and a text box is automatically created with the text cursor flashing in a single line text box. The text box increases in width as text is entered in a single line and the text box height does not change. To create multiple lines and increase the height, use the Enter key to create new single line paragraphs within the text box.
   - For multiple line text boxes, click and drag the cursor on the slide to set the width of the text box. As text is entered, the height of a text box automatically increases as text wraps creating multiple lines in the text box.

3) Create a vertical text box using one of the following methods:
   - Click on the slide and a text box is automatically created with the text cursor flashing in a single line text box. The text box increases in height as text is entered in a single line and the text box width does not change. To create multiple lines and increase the width, use the Enter key to create new single line paragraphs within the text box.
   - For multiple line text boxes, click and drag the cursor on the slide to set the height of the text box. As text is entered, the width of a text box automatically increases as text wraps creating multiple lines in the text box.

4) Type or paste the text into the text box.

5) Click outside the text box to deselect it.

Text box borders

By default, when an AutoLayout text box or a text box is created, the borders of the text box are only displayed when the text box is selected. Use one of the following methods to create a visible border around the text box.

When creating a text box border, if the properties of the line style selected are changed, for example, in the Line dialog, then the properties are also changed in the Line and Filling toolbar, and the Line panel in the Properties deck on the Sidebar.

Figure 52: Line and Filling toolbar
**Line and Filling toolbar**

1) Click on a text box to select it so that the border is displayed indicating that the text box is in edit mode.

2) In **Line Style** on the Line and Filling toolbar (Figure 52), select a line style from the drop-down list to use as a text box border. If the Line and Filling toolbar is not visible, go to **View > Toolbars > Line and Filling** on the Menu bar.

3) In **Line Width** on the Line and Filling toolbar, enter a width for the line style selected for the text box border.

4) In **Line Color** on the Line and Filling toolbar, select a color from one of the available color palettes, or create a custom color.

5) Click outside the text box to exit edit mode.

**Line dialog**

1) Click on a text box to select it so that the border is displayed indicating that the text box is in edit mode.

2) Open the Line dialog (Figure 53) using one of the following methods:
   - Right-click on the text box border and select **Line** from the context menu.
   - Go to **Format > Object and Shape > Line** on the Menu bar.

3) Click on **Line** to open the **Line** page.

4) In **Style**, select a line style from the drop-down list to use as a text box border.

5) In **Color**, select a color for the line style from one of the available color palettes, or create a custom color.

6) In **Width**, enter a width for the line style selected.

7) If necessary, in **Transparency**, enter a percentage value for the line style.

8) If necessary, in **Corner Style**, select the type of corner style from the options in the drop-down list.

9) Click **OK** to save the changes and close the Line dialog.

10) Click outside the text box to exit edit mode.

**Note**

For a corner style to be clearly visible in a text box border, it is recommended to set the line width at a thickness above 0.35cm, as shown by the example in Figure 54.

---

**Figure 53: Line dialog - Line page for creating text box border**
1) Click on a text box to select it so that the border is displayed indicating that the text box is in edit mode.

2) Click on Properties to open the Properties deck in the Sidebar, then click on Line to open the Line panel (Figure 55).

3) In Line, select a line style from the drop-down list to use as a text box border.

4) In Width, enter a width for the line style selected.

5) In Color, select a color for the line style from one of the available color palettes, or create a custom color.

6) If necessary, in Transparency, enter a percentage value for the line style.

7) Click outside the text box to exit edit mode.

Line panel in Sidebar

- Click on a text box to select it so that the border is displayed indicating that the text box is in edit mode.
- Click on Properties to open the Properties deck in the Sidebar, then click on Line to open the Line panel (Figure 55).
- In Line, select a line style from the drop-down list to use as a text box border.
- In Width, enter a width for the line style selected.
- In Color, select a color for the line style from one of the available color palettes, or create a custom color.
- If necessary, in Transparency, enter a percentage value for the line style.
- Click outside the text box to exit edit mode.
Positioning and resizing text boxes

Moving text boxes with cursor
1) Click in the text box to select it so that the border is displayed indicating that the text box is in edit mode.
2) Move the cursor over the border and the cursor changes shape to the move cursor for the computer operating system (for example, a hand).
3) Click, hold and drag on the border to move the text box. A dashed outline of the text box shows where the text box will be placed as shown in Figure 56.
4) Release the button when the text box is in the required position.
5) Click outside the text box to exit edit mode.

Resizing text boxes with cursor
1) Click in the text box to select it so that the selection handles are displayed indicating that the text box is in edit mode.
2) Move the cursor over a selection handle and the cursor changes shape indicating the direction the text box will be resized.
3) Click, hold and drag on a selection handle to resize the text box. A dashed outline appears indicating the new size of the text box as it is being resized, as shown in Figure 57. The selection handles are used to resize the text box as follows:
   - Corner handles change the width and height of the text box simultaneously.
   - Top and bottom selection handles change the height of the text box.
   - Right and left selection handles change the width of the text box.
4) Release the button when the text box is at the required size.
5) Click outside the text box to exit edit mode.
Figure 57: Resizing text boxes

Note

To maintain the proportions of a text box while resizing, press and hold the Shift key, then click and drag a selection handle. Make sure to release the button before releasing the Shift key.

Figure 58: Position and Size dialog
**Position and Size dialog**

For more accurate control over the size and position of an AutoLayout text box or text box, it is recommended to use the Position and Size dialog (Figure 58).

1) Click in the text box to select it so that the selection handles are displayed indicating that the text box is in edit mode.

2) Open the Position and Size dialog using one of the following methods:
   - Go to **Format > Object and Shape > Position and Size** on the Menu bar.
   - Right-click on the text box border and select **Position and Size** from the context menu.
   - Use the keyboard shortcut F4.

3) Click on **Position and Size** to open the **Position and Size** page.

4) Use the various options available on the **Position and Size** page to position the text box.

5) Click **OK** to save the changes and close the Position and Size dialog.

6) Click outside the text box to exit edit mode.

The options available on the **Position and Size** page are as follows:

- **Position**
  - **Position X** (horizontal) and **Position Y** (vertical) – specify position of the text box. The position values of the text box represent the distance of the **Base point** to the top left corner of the slide.
  - **Base point** – position the text box by selecting one of the nine available positions. By default, the **Base point** is the top left corner of the text box.

- **Size**
  - **Width** and **Height** – specify size of the text box. To maintain the width/height ratio of the text box, select **Keep ratio**. The size values represent the distance of the **Base point** relative to the top left corner of the slide.
  - **Base point** – position the text box by selecting one of the nine available positions. By default, the **Base point** is the top left corner of the text box.

- **Protect** – prevent accidental modification of the position or size of the text box by selecting **Position and/or Size** options.

- **Adapt** – allow the text box to adjust its height and/or width as text is entered by selecting **Fit width to text** and/or **Fit height to text**.

**Position and Size on Sidebar**

For more accurate control over the size and position of a text box, the **Position and Size** panel in the Properties deck on the Sidebar (Figure 59) can also be used. However, there are fewer options available in the **Position and Size** panel on the Sidebar than in the Position and Size dialog.

1) Click in the text box to select it so that the selection handles are displayed indicating that the text box is in edit mode.

2) Click on **Properties** on the Sidebar to open the Properties deck, then click on **Position and Size** to open the **Position and Size** panel.

3) Specify measurement values in the **Position X** (horizontal) and **Position Y** (vertical) boxes to position of the text box on the slide. The position values of the text box represent the distance between the top left of text box to the top left corner of the slide.
4) Specify measurement values in the Width and Height boxes to adjust the size of the text box. To maintain the width/height ratio of the text box, select Keep ratio.

5) When satisfied with the changes, click outside the text box to save the changes and exit edit mode.

### Rotating text boxes

**Using the cursor**

1) Click in the text box border to select it so that the selection handles are displayed indicating that the text box is in edit mode.

2) Click again on the text box border and the selection handles change shape and color, as shown by the example in Figure 60. A rotation center appears in the center of the text box.

3) Move the cursor over a corner selection handle and the cursor changes shape to indicate rotation.

4) Click, hold and drag the text to rotate it. A ghosted image of the text box appears as the text box is being rotated.
5) Release the button when the text box has reached the desired rotation angle.
6) If necessary, click and drag the rotation center to a different position to change the rotation angle. The rotation center can be positioned outside of the text box.
7) Click outside the text box to exit edit mode.

**Position and Size dialog**

For more accurate control over the size and position of an AutoLayout text box or text box, it is recommended to use the options available on the **Rotation** page of the Position and Size dialog (Figure 61).

1) Click in the text box to select it so that the selection handles are displayed indicating that the text box is in edit mode.
2) Open the Position and Size dialog using one of the following methods:
   - Go to **Format > Object and Shape > Position and Size** on the Menu bar.
   - Right-click on the text box border and select **Position and Size** from the context menu.
3) Click on Rotation to open the Rotation page.

4) If necessary, in Pivot Point, enter a measurement for Position X and Position Y to move the position of the pivot point.

5) Alternatively, select a pivot point from one of the 9 positions in Default settings:

6) In Rotation Angle, enter the number of degrees for rotation in the Angle text box.

7) Alternatively, in Default settings:, click on the rotation angle indicator and drag it to a new angle. The angle of rotation is displayed in the Angle text box.

8) Click OK to save the changes and to close the Position and Size dialog.

9) Click outside the text box to exit edit mode.

**Position and Size panel on Sidebar**

1) Click in the text box to select it so that the selection handles are displayed indicating that the text box is in edit mode.

2) Make sure that the text box has a visible border.

3) Open the Position and Size dialog using one of the following methods:

   - Go to Format > Object and Shape > Position and Size on the Menu bar.
   - Right-click on the text box border and select Position and Size from the context menu.
   - Use the keyboard shortcut F4.

---

**Corner radius**

The Corner Radius option in the Slant & Corner Radius page of the Position and Size dialog (Figure 62) is only available when a text box has a border. See “Text box borders” on page 86 for more information on creating text box borders.

---

**Note**

The options Slant, Corner Point 1, and Corner Point 2 on the Slant & Corner Radius page of the Position and Size dialog are not available for text box borders.

1) Click in the text box to select it so that the selection handles are displayed indicating that the text box is in edit mode.

2) Make sure that the text box has a visible border.
4) Click on **Slant & Corner Radius** to open the **Slant & Corner Radius** page.

5) In **Corner Radius**, enter a measurement in the **Radius** text box to change the radius of the corners on the text box.

6) Click **OK** to save the changes and to close the Position and Size dialog.

7) Click outside the text box to exit edit mode.

**Text positioning**

Text can be repositioned within an AutoLayout text box or a text box as follows:

1) Click in the text box to select it so that the selection handles are displayed indicating that the text box is in edit mode.

2) Right-click in the text box and select **Text Attributes** from the context menu to open the Text dialog (Figure 63).

3) Use the various options on the **Text** page to position the text within the text box.

4) Click **OK** to save the changes and close the dialog.

5) Click outside the text box to deselect it.

![Figure 63: Text dialog - Text page](image)

The options available in the Text dialog are as follows:

- **Drawing Object Text**
  - *Fit width to text* – width of the text box is automatically adjusted to the width of the text.
  - *Fit height to text* – height of the text box is automatically adjusted to the height of the text.
– *Fit to frame* – the text width and height is adjusted to the width and height of the text box.

- **Spacing to Borders** – creates margins around the text within the text box.
- **Text Anchor** – sets the anchor point for the text within the text box. When the *Full width* option is selected, the text is automatically positioned in the center of the text box.

**Text animation**

Text within an AutoLayout text box or a text box can be animated using the options available in the *Text Animation* page in the Text dialog. For more information on the text animation effects, see Chapter 9, Slide Shows.

**Text columns**

Text within an AutoLayout text box or a text box can be placed into columns using the options available in the *Text Columns* page in the Text dialog (Figure 64), or the *Columns* panel in Properties deck on the Sidebar (Figure 65).

1) Click in the text box to select it so that the selection handles are displayed indicating that the text box is in edit mode.

2) Right-click in the text box and select **Text Attributes** from the context menu to open the Text dialog.

3) Click on the *Text Columns* tab to open the *Text Columns* page in the Text dialog, or click on *Columns* in Properties on the Sidebar to open the *Columns* panel.

4) Set the number of columns required in the *Number of columns* box and the required spacing between the columns in the *Spacing* box. An example of columns in a text box is shown in Figure 66.

5) Save the changes and deselect the text box using one of the following methods:
   - On the Text dialog, click **OK** to save the changes and close the dialog, then click outside the text box to deselect it.
   - On the *Columns* panel in the Properties deck on the Sidebar, click outside the text box to deselect it and save the changes.

![Figure 64: Text dialog - Text Columns page](image)
Deleting text boxes

1) Click in the text box to select it so that the border and selection handles are displayed indicating that the text box is in edit mode.

2) Press the Delete or Backspace key to delete the text box.

Tip

If there is more than one text box to delete, it is quicker to drag a selection marquee around the text boxes and then press Delete or Backspace. Take care to avoid selecting and accidentally deleting any text boxes or shapes still required.
**Inserting text**

**Pasting text**

Text can be inserted into an AutoLayout or normal text box by copying from another document and pasting into Impress. However, the text will probably not match the formatting of the surrounding text or that of the other slides in the presentation. This may be what is required on some occasions. However, it is recommended, for a professional look, to make sure that the presentation style is consistent and does not become a patchwork of different styles, font types, bullet points, and so on.

**Unformatted text**

It is good practice to paste text without formatting and apply the formatting later, reducing the risk of errors in a presentation.

1) Highlight and copy the text in another document or slide.

2) Create a text box on a slide and make sure the text cursor is flashing in the text box. See “Starting Impress” on page 22 for more information.

3) Paste unformatted text at the cursor position in a text box using one of the following methods.
   - Go to Edit > Paste Special > Paste Unformatted Text on the Menu bar.
   - Click on the triangle ▼ to the right of Paste on the Standard toolbar and select Unformatted text from the context menu.
   - Use the keyboard shortcut Ctrl+Shift+V (macOS ⌘+Shift+V) and select Unformatted text from the Paste Special dialog that opens.
   - Use the keyboard shortcut Ctrl+Alt+Shift+V (macOS +⌥⌘+Shift+V) and unformatted text is pasted into a text box.

4) Format the text to the presentation requirements using the tools on the Text Formatting toolbar or the options in Format on the Menu bar. Alternatively, and for text boxes only, apply a Drawing Style to the text.

---

**Note**

A Presentation Style used in AutoLayout text boxes cannot be changed by selecting another Presentation Style. Make sure the AutoLayout text box uses the Presentation Style required. See Chapter 2, Master Slides, Styles and Templates for more information. Outline levels and outline styles are changed using the Tab key or Shift+Tab key combination.

---

**Formatted text**

Pasting formatted text into a text box or AutoLayout text box will overwrite any formatting and replace the text box style.

1) Highlight and copy the text in another document or slide.

2) Create a text box on a slide and make sure the text cursor is flashing in the text box. See “Starting Impress” on page 22 for more information.

3) Paste formatted text into the text box. Text is pasted at the cursor position in the text box and the text formatting of the pasted text overwrites any style formatting of the text box.
   - Go to Edit > Paste on the Menu bar.
   - Click on Paste on the Standard toolbar.
   - Use the keyboard shortcut Ctrl+V (macOS ⌘+V).
4) If necessary, format the text to to the presentation requirements using the various tools on the Text Formatting toolbar or the options available in Format on the Menu bar.

5) To clear any formatting of the pasted text and use the text box style, go to Format > Clear Direct Formatting on the Menu bar. See Chapter 2, Master Slides, Styles and Templates for more information.

**Note**

Drawing Styles can be created in Impress. These Drawing Styles are only available for the Impress presentation being created and saved. Also, templates can be created to include any Drawing Styles allowing the template to be used for presentations.

**Inserting special characters**

Special characters can be inserted into text, for example copyright, mathematical, geometric, or monetary symbols.

1) Click at the position in the text where the special character is to be inserted.

2) Go to Insert > Special Character on the Menu bar to open the Special Characters dialog (Figure 67).

3) Select the font and character subset from the Font and Subset drop-down lists.

![Special Characters dialog](image)

**Figure 67: Special Characters dialog**

4) Locate and select the special character from the special characters available. The selected special character appears in the preview box and its name is displayed below the preview box.

5) Alternatively, select the special character from the display of Recent Characters or Favorite Characters. The selected special character appears in the preview box and its name is displayed below the preview box.
6) Click on **Insert** to close the dialog and insert the special character at the cursor position in the text.

7) Alternatively, double-click on the selected special character to insert the special character at the cursor position in the text. This also closes the dialog.

8) If the special character is frequently used, click on **Add to Favorites** and the special character is added to the display of **Favorite Characters**.

### Inserting formatting marks

Formatting marks are special characters that can be inserted into text to correct the formatting. For example, it may not be desirable for words that are separated by a space or a hyphen to span over two lines. The solution is to insert a non-breaking space or non-breaking hyphen.

1) Click at the position where the formatting mark is to be inserted into the text.

2) Go to **Insert > Formatting Mark** on the Menu bar to open a submenu.

3) Select the formatting mark required and it is inserted into the text at the cursor position.

The formatting marks that are available in Impress are as follows:

- **Non-breaking space** – inserts a space that keeps two adjacent words or characters together on line breaks. Keyboard shortcut Ctrl+Shift+Space (macOS ⌘+Shift+Space).
- **Non-breaking hyphen** – inserts a hyphen that keeps two adjacent characters together on line breaks.
- **Soft hyphen** – inserts an invisible hyphen within a word that will appear and create a line break once it becomes the last character in a line.
- **Narrow no break space** – inserts a narrow space that keeps two adjacent words or characters together on line breaks. A narrow space has a width that is about 70% of a normal space. It is used to represent the narrow space occurring around punctuation characters and can also be used as a numeric group separator. Keyboard shortcut Alt+Shift+Space (macOS ⌥+Shift+Space).
- **No-width optional break** – inserts an invisible space within a word that will insert a line break once it becomes the last character in a line. Keyboard shortcut Ctrl+/ (macOS ⌘+/).
- **Word Joiner** – inserts a special character preventing hyphenation of a word keeping the word together at the end of a line.
- **Left-to-right mark** – inserts a text direction mark that affects the text direction of any text following the mark. Only available when **Complex text layout** (CTL) is enabled.
- **Right-to-left mark** – inserts a text direction mark that affects the text direction of any text following the mark. Only available when **Complex text layout** (CTL) is enabled.

### Formatting text

Text formatting can give a presentation a consistent and professional look without any distracting elements. Understanding of an audience is enhanced by preventing any distracting elements in a presentation. Text formatting can be applied (for example color, alignment, bullet types) to characters, words, sentences, paragraphs, and lists.

Text formatting tools are available on the Text Formatting toolbar and drop-down menus in **Format** on the Menu bar. For more information on text formatting, see the **Writer Guide**.

### Quick font resizing

After selecting text, the font size can be quickly increased or decreased using the tools **Increase Font Size** (Ctrl+) (macOS ⌘+) and **Decrease Font Size** (Ctrl+) (macOS ⌘+) on the Text
Formatting toolbar. The amount by which the font size changes depends on the standard sizes available for the font in use.

**Note**

AutoLayout text boxes automatically adjust font size of text inserted into it. For example, when a long piece of text is inserted into an AutoLayout text box, the font size may decrease in size to fit into the box.

**Selecting text**

Text must be selected before it can be formatted using one of the following methods. Any formatting changes applies only to the selected text.

- To format all the text in a text box, click once on the border of the text box to display the selection handles. Any formatting changes applies to all text in the text box.
- To format only part of the text, select text using one of the following methods:
  - Click in the text and drag the cursor over the text to highlight the text.
  - Double-click on text to select a complete word or triple click to select a whole paragraph.
  - Click in the text, then press and hold the *Shift* key and use the keyboard arrow keys to select text.

**Using styles**

When text is entered, either in an AutoLayout text box or in a text box, it is formatted with a set of predefined attributes known as a style. The style used depends on the type of text box being used. For more information on using, modifying and updating styles, see Chapter 2, Master Slides, Styles and Templates.

Sometimes it is quicker and more efficient to apply manual or direct formatting. However, in situations where the same formatting is required in many different parts of a presentation, the use of styles is recommended. This creates a consistent look to a presentation and reduces the possibility of any errors. Impress has two categories of styles – Presentation Styles and Drawing Styles.

**Presentation Styles**

Presentation styles are used in AutoLayout text boxes, master slide backgrounds, and master slide background objects.

The style applied to the text depends on the type of AutoLayout text box. These styles cannot be deleted, renamed or changed for another presentation style to change the formatting of the text. For example, to change an outline style for another outline style, the outline level has to be changed using the keyboard shortcuts *Tab* or *Shift+Tab*.

Presentation styles can be modified to change the text formatting or updated to change the style after formatting the text.

**Note**

Unlike LibreOffice Writer, where it is recommended to use styles whenever possible, manual or direct formatting has to be used more often in LibreOffice Impress. The reason is that Presentation Styles in Impress are restricted. For example, it is not possible to have two different Outline 1 levels using different types of bullet points for the same outline level. Also, the lack of support for character styles forces the use of manual or direct formatting to format sections of text when necessary.
**Drawing Styles**

Drawing styles are used for text in text boxes and any graphic object placed on a slide. For information on formatting graphic objects, see Chapter 6, Formatting Graphic Objects.

When text is entered into a text box, the Default Drawing Style is applied to the text. This style can be changed by selecting another style from the text group of Drawing Styles. These styles cannot be deleted or renamed, but can be modified to change the text formatting or updated to change the style after formatting the text. Also, custom drawing styles can be created, but are only available for the presentation being created.

**Text formatting**

Direct or manual text formatting can be applied directly to characters, words, sentences, and paragraphs. Direct formatting overrides any formatting that has been applied to text when using styles.

1) Format text using one of the following methods. Any formatting applied to text is immediate.
   - Use the formatting tools on the Text Formatting toolbar.
   - Go to **Format** on the Menu bar and select a formatting option from the drop-down menu. Selecting a formatting option opens either a context menu or a dialog providing further formatting options to apply to the selected text.
   - Use the options available in the Paragraph and Character dialogs.
   - Use the options available in the **Paragraph** and **Character** panels in the Properties deck on the Sidebar.

2) Click outside the text box to deselect the text.

**Paragraph dialog**

The Paragraph dialog (Figure 68) is used to format paragraphs of text.

1) Select text in a paragraph or the whole paragraph. See “Selecting text” on page 101 for more information.
Use one of the following methods and open the Paragraph dialog. Any formatting applied to a paragraph is immediate.

- Right click on the selected text and select Paragraph from the context menu.
- Go to Format > Paragraph on the Menu bar.

3) Use the various options available on the tabbed pages of the Paragraph dialog to format the text.

4) Click OK to save the changes and close the dialog.

5) Click outside the text box to deselect the text.

**Note**

For information on the various formatting options available for text in the pages of the Paragraph dialog, refer to the *Writer Guide*.

**Sidebar Paragraph panel**

An alternative method of formatting paragraphs is to use the Paragraph panel (Figure 69) in the Properties deck on the Sidebar. The formatting options are limited, but are similar in use to the formatting options in the various pages of the Paragraph dialog. Any formatting applied to a paragraph using the Sidebar is immediate.

1) Select the text box so that the selection handles and border are displayed.

2) On the Sidebar, click on Properties to open the Properties deck.

3) Click on Paragraph to open the Paragraph panel.
4) Format the text using the various tools available in the Paragraph panel. See “Paragraph dialog” on page 102 for more information on formatting options.

5) If necessary, click on More Options on the right of the title bar to open the Paragraph dialog to format text.

**Note**

For information on the various formatting options available for text in the Paragraph panel on the Sidebar, refer to the *Writer Guide*.

**Character formatting**

Direct or manual character formatting can be applied directly to individual characters and words. Direct character formatting overrides any formatting that has been applied using direct text formatting and presentation or drawing styles.

1) Select the characters for formatting. See “Selecting text” on page 101 for more information.

2) Format characters using one of the following methods.
   - Various formatting tools on the Text Formatting toolbar. Formatting applied to character(s) is immediate.
   - Go to Format on the Menu bar. Selecting a formatting option opens either a context menu or dialog where further formatting options are selected.
   - Use the options available in the Character dialog. Clicking **OK** on the dialog applies the formatting changes.
– Use the options available in the Character panel in the Properties deck on the Sidebar. Formatting applied to character(s) is immediate.

3) Click outside the text box to deselect the text.

**Character dialog**

1) Open the Character dialog (Figure 70) using one of the following methods:
   – Right-click on the selected text box and select **Character** from the context menu.
   – Go to **Format > Character** on the Menu bar.
2) Select the characters or words in the text box for formatting.
3) Use the various options available on the tabbed pages of the Character dialog to format the selected characters.
4) Click **OK** to save the changes and close the dialog.
5) Click outside the text box to deselect it.

**Note**

For information on the various formatting options available for characters in the pages of the Character dialog, refer to the **Writer Guide**.

![Character dialog](Figure 70: Character dialog - Fonts page)
Sidebar Character panel

An alternative method of formatting text is to use the Character panel (Figure 71) in the Properties deck on the Sidebar. The formatting options available in the Character panel are limited, but are similar in use to the formatting options available in the various pages of the Character dialog.

1) Select a text box so that the selection handles and border are displayed.
2) On the Sidebar, click on Properties to open the Properties deck.
3) Click on Character to open the Character panel.
4) Format the text using the various tools available in the Character panel. See “Character dialog” on page 105 for more information on formatting options.
5) If necessary, click on More Options on the right of the title bar to open the Character dialog to format text.

Note

For information on the various formatting options available for characters in the Character panel on the Sidebar, refer to the Writer Guide.

Creating lists

The procedure to create an unordered (bulleted) or ordered (numbered) list varies depending on the type of text box used. The tools to manage and format a list are the same.

Note

Creating unordered or ordered lists in Impress is similar to LibreOffice Writer. For more information on unordered or ordered lists, see the Writer Guide.
Note

In AutoLayout text boxes, promoting or demoting an item in a list changes the presentation style to match the outline level. For example, second outline level corresponds to Outline 2 style, third outline level to Outline 3 style, and so on. This change of outline level may change the formatting of the list point (for example font size, bullet type, and so on).

AutoLayout text boxes

In AutoLayout text boxes and, by default, the outline styles available are unordered lists. An example of these outline styles is shown in Figure 72. These outline styles are presentation styles and cannot be deleted, but can be modified or updated to the presentation requirements. See Chapter 2, Master Slides, Styles and Templates for more information on styles.

By default, the list created in an AutoLayout text box is an unordered list. To customize the list appearance or to change from unordered to ordered or ordered to unordered, see “Formatting lists” on page 109 for more information.

1) Create a new presentation and go to View > Normal on the Menu bar.

![Working Presentation](image)

Figure 72: Example of outline unordered list

![Outline toolbar](image)

Figure 73: Outline toolbar

2) Select a layout for the slide using one of the following methods:
   - Right-click in a blank area on the slide and select a layout type from the context menu that opens.
   - Go to Slide > Layout on the Menu bar and select a layout from the drop-down list.
   - Select a layout from the layouts displayed in the Layouts panel in the Properties deck on the Sidebar.

3) Click on the text *Click to add Text* and start typing the first list item.
4) When the first list point is finished, click on Enter to create a new list point.

5) Use the keyboard combination Shift+Enter to start a new line without creating a new list point. This new line has the same indentation as the text in the list point.

6) To demote the outline level of a list point, use one of the following methods:
   – Click on the Tab key.
   – Use the keyboard shortcut Alt+Shift+Right Arrow (macOS ⌥+Shift+Right Arrow).
   – Click on Demote on the Outline toolbar (Figure 73).
   – Click on Demote on the Lists panel in the Properties deck on the Sidebar.
   – Go to Format > Lists on the Menu bar and select Demote from the submenu.

7) To promote the outline level of a list point, use one of the following methods:
   – Use the keyboard shortcut Shift+Tab.
   – Use the keyboard shortcut Alt+Shift+Left Arrow (macOS ⌥+Shift+Left Arrow).
   – Click on Promote on the Outline toolbar.
   – Click on Promote on the Lists panel in the Properties deck on the Sidebar.
   – Go to Format > Lists on the Menu bar and select Promote from the submenu.

8) To move a list point lower in the list order without changing the outline level, use one of the following methods:
   – Click on Move Down on the Outline toolbar.
   – Click on Move Down on the Lists panel in the Properties deck on the Sidebar.
   – Go to Format > Lists on the Menu bar and select Move Down from the submenu.
   – Use the keyboard shortcut Alt+Shift+Down Arrow (macOS ⌥+Shift+Down Arrow).

9) To move a list point higher in the list order without changing the outline level, use one of the following methods:
   – Click on Move Up on the Outline toolbar.
   – Click on Move Up on the Lists panel in the Properties deck on the Sidebar.
   – Go to Format > Lists on the Menu bar and select Move Up from the submenu.
   – Use the keyboard shortcut Alt+Shift+Up Arrow (macOS ⌥+Shift+Up Arrow).

10) To change the type and appearance of a list, see “Formatting lists” on page 109 for more information.

**Note**

Do not change the outline style of a list point by selecting the list point and then selecting another outline style. In Impress it is not possible to change presentation styles used for outline levels in this way.

**Text boxes**

1) Create a text box on a slide and make sure the cursor is flashing in the text box. See “Starting Impress” on page 22 on how to create a text box.

2) Create a list using one of the following methods:
   – Click on Toggle Unordered List or Toggle Ordered List on the Text Formatting toolbar.
   – Click on Toggle Unordered List or Toggle Ordered List in the Lists panel in the Properties deck on the Sidebar.
3) When the first list point is finished, click on Enter to create a new list point.

4) Use the keyboard combination Shift+Enter to start a new line without creating a new list point. This new line has the same indentation as the text in the list point.

5) To increase the indent level of a list point, use one of the following methods:
   – Click on the Tab key.
   – Use the keyboard shortcut Alt+Shift+Right Arrow (macOS ⇧+Shift+Right Arrow).
   – Click on Demote on the Outline toolbar.
   – Click on Demote on the Lists panel in the Properties deck on the Sidebar.
   – Go to Format > Lists on the Menu bar and select Demote from the submenu.

6) To decrease the indent level of a list point, use one of the following methods:
   – Use the keyboard shortcut Shift+Tab.
   – Use the keyboard shortcut Alt+Shift+Left Arrow (macOS ⇧+Shift+Left Arrow).
   – Click on Promote on the Outline toolbar.
   – Click on Promote on the Lists panel in the Properties deck on the Sidebar.
   – Go to Format > Lists on the Menu bar and select Promote from the submenu.

7) To move a list point lower in the list order without changing the indent level, use one of the following methods:
   – Click on Move Down on the Outline toolbar.
   – Click on Move Down on the Lists panel in the Properties deck on the Sidebar.
   – Go to Format > Lists on the Menu bar and select Move Down from the submenu.
   – Use the keyboard shortcut Alt+Shift+Down Arrow (macOS ⇧+Shift+Down Arrow).

8) To move a list point higher in the list order without changing the indent level, use one of the following methods:
   – Click on Move Up on the Outline toolbar.
   – Click on Move Up on the Lists panel in the Properties deck on the Sidebar.
   – Go to Format > Lists on the Menu bar and select Move Up from the submenu.
   – Use the keyboard shortcut Alt+Shift+Up Arrow (macOS ⇧+Shift+Up Arrow).

9) To change the type and appearance of a list, see “Formatting lists” below for more information.

**Formatting lists**

• Change the list type, properties, size, position, and scope for the entire list or for a single list point using the Bullets and Numbering dialog (Figure 74).
• Change the list type, promote or demote a list point, or move a list point up or down in the list order using the **Lists** panel in the Properties deck on the Sidebar (Figure 75).
• Promote or demote a list point, or move a list point up or down in the list order using the Outline toolbar.
• Change the list type using the tools on the Text Formatting toolbar.
• Format the text used in the list. See “Formatting text” on page 100 for more information.
Click on More Bullets or More Numbering after clicking on the triangle ▼ on the right of Toggle Unordered List or Toggle Ordered List on the Text Formatting toolbar or in the Lists panel in the Properties deck on the Sidebar. This opens the More Bullets dialog (Figure 76) and the More Numbering dialog Figure 77).

For more information on the options available in the Bullets and Numbering dialog for unordered or ordered lists, see the Writer Guide.
Text callouts

A text callout is a short line of text connected by a line to highlight or point out a feature of an illustration or drawing, and give information about that feature as shown by the example in Figure 78. Two types of text callouts are available — Callouts for horizontal text and Vertical Callouts for vertical text.

The text callouts are a legacy from the first versions of LibreOffice and are available on the Text toolbar. They can also be installed on other toolbars, for example Standard or Line toolbar. For more information on customizing toolbars, see Appendix B, Toolbars or the Getting Started Guide.

![Figure 78: Example of using text callouts](image)

**Note**

Newer custom shape callouts can be found by selecting Callout Shapes on the Drawing toolbar, or the Callouts panel in the Shapes deck on the Sidebar. These custom shape callouts have the same purpose as text callouts, but have different options available.

Creating text callouts

1) Click on Callouts for horizontal text, or Vertical Callouts for vertical text on the Text toolbar.
2) Click in the drawing and drag the cursor to create the callout.
3) Double click in the callout box to enter text mode.
4) Type the required text, then click in a blank space in the drawing. The callout box adjusts its size horizontally and/or vertically to fit the text within the callout box.
5) Select the callout and click on the selection handle at the end of the connector line, then drag the end of the connector line to the required position.
6) With the callout still selected, click on the callout box and drag it to the required position.
7) Click in a blank space in the drawing to deselect the text callout and save the changes.

Editing text callouts

1) Double click in the callout box to enter text mode and, if required, edit and format the text.
2) Click in a blank space in the drawing to save the changes to the text.
3) Select the text callout so that the selection handles are displayed.

4) Right click on the selected text callout and select an option from the context menu to change the attributes for position, size, line, and area of the text callout. For more information, see Chapter 3, Working with Objects, and Chapter 4, Changing Object Attributes.

5) Click on the selection handle at the end of the connector line and drag it to change the position of the line end or the length of the connector line.

6) Select the text callout and open the Position and Size dialog (Figure 79) using one of the following methods:
   – Right-click on the selected callout and select **Position and Size** from the context menu.
   – Go to **Format > Position and Size** on the Menu bar.
   – Use the keyboard shortcut **F4**.

**Note**

The **Callout** page in the Position and Size dialog shown in Figure 79 is only available when a text callout has been selected. It is not available for **Callout Shapes** that are available on the Drawing toolbar, or in the **Callouts** panel in the Shapes deck on the Sidebar.

7) Click on the **Callout** tab to open the formatting options available for text callouts.

8) In **Callout Styles**, select the style of text callout from **Straight Line**, **Angled Line**, or **Angled Connector Line**.

9) In **Spacing**, enter the amount of space required between the end of the callout line and the callout box.

10) In **Extension**, select from the drop-down list how the callout line from extends the callout box.

11) In the **By** text box, enter a distance value to create a space between the start point of the connector line and the callout box.

12) In **Length**, enter the length of the callout line segment that extends from the callout box to the angle point of the connector line.
The **Length** option is only available if **Angled Connector Line** is selected as callout style and the **Optimal** check box is not selected.

13) **In Optimal**, select this option to display the angle point in a connector line at an optimal distance from the callout box.

14) Click in a blank space in the drawing to deselect the text callout and save the changes.

### Using tables

Tables are a powerful mechanism to convey structured information quickly when used in a presentation. Tables can be created directly in a presentation, eliminating the need to embed a Calc spreadsheet or a Writer text table. However, in some circumstances, it makes sense to embed a table into a presentation, especially when greater functionality is required in the table. The tables provided by Impress do have limited functionality.

Several predefined table designs are available in the **Table Design** panel in the Properties deck on the Sidebar (Figure 80). The **Table Design** panel is only available when a table is selected in a slide.

When working with tables in Impress, the Table toolbar (Figure 81) automatically opens, providing tools for creating and formatting a table.

![Figure 80: Table Design panel in Properties deck on Sidebar](image-url)
Inserting tables

When inserting a table into a slide, it is useful to know the number of rows and columns required as well as an approximate idea of how the table will look. The table can then be formatted after creation should it be necessary.

**Note**

When a table is inserted into a slide, the table is created inside a text box at the center of the slide with the default style and settings already applied. The text box is the same size as the rows and columns of the table. Currently the default settings are hard coded into LibreOffice. A table can be formatted to the presentation requirements using the tools and options available.

**Insert Table dialog**

1) Select the slide which will contain the table and, if necessary, modify the slide layout to create space for the table.

2) Go to **Insert > Table** on the Menu bar to open the Insert Table dialog (Figure 82).

3) Specify the **Number of columns** and **Number of rows** in the text boxes.

4) Click **OK** to insert the table in the slide and close the dialog.

**Table graphic**

1) Select the slide which will contain the table and, if necessary, modify the slide layout to create space for the table.

2) Click on **Table** on the Standard or Table toolbar to open the Table graphic (Figure 83).
3) Click, hold and drag the cursor across and down in the table graphic to create the required number of rows and columns.

4) Release the cursor to insert the table in the slide and close the Table graphic.

5) Alternatively, click on More Options in the Table graphic to open the Insert Table dialog and create the rows and columns required.

Formatting tables

Sidebar Table Design panel

1) Insert a table into a slide or select a table in a slide.

2) Click on Table Design in the Properties deck on the Sidebar to open the Table Design panel and display the available designs.

3) Select a design for the table and the types of rows and columns from the available options.

The following options for rows and columns are available in the Table Design panel:

- **Header row** – selected by default. In a table, the first row is normally a header row and is displayed with a different background from the rest of the table.

- **Total row** – if selected, it changes the background of the last row to make it stand out from the other rows.

- **Banded rows** – selected by default. Alternate rows have different backgrounds making it easier to read data entered into the rows. An example of banded rows is shown in Figure 84.

- **First column** – when selected, highlights the first column of the table using a darker background.

- **Last column** – when selected, highlights the last column of the table using a darker background.
• **Banded columns** – when selected, alternate columns are highlighted with dark and light colors. An example of banded columns is shown in Figure 84.

**Table toolbar**

When a table is selected, the Table toolbar is displayed. If the Table toolbar is not displayed when a table is selected, go to **View > Toolbars > Table** on the Menu bar. The Table toolbar contains the majority of the tools required to format a table.

• **Table** – inserts a new table in the selected slide.

• **Border Style** – opens a drop-down selection of available border styles. Select cells in a table, then apply a border style. If the required border style is not available, use the **Borders** page in the Table Properties dialog.

• **Border Color** – select a color from the available color palettes for the borders that are used for selected cells. If the required border color is not available, use the **Borders** page in the Table Properties dialog.

• **Borders** – opens a drop-down menu where a predefined border configuration can be selected for cells. If the required border pattern is not available, use the Borders page in the Table Properties dialog.

• **Area Style/Filling** – opens a drop-down menu to apply an area style fill to selected cells: **None**, **Color**, **Gradient**, **Hatching**, **Bitmap** or **Pattern**. Depending on area style selected, the second drop-down list shows the available fillings for the each area style selected. Refer to Chapter 6, Formatting Graphic Objects for more information.

• **Merge Cells** – merges the selected cells into one cell. The contents of merged cells are also merged. Alternatively, right-click on selected cells and select **Merge Cells** from the context menu, or go to **Format > Table > Merge Cells** on the Menu bar.

• **Split Cells** – splits a selected cell into multiple cells either horizontally, in equal proportions, or vertically. Make sure that the cursor is positioned in the cell for splitting, then click on **Split Cells** to open the Split Cells dialog (Figure 85). Alternatively, right-click on the selected cell and select **Split Cells** from the context menu, or go to **Format > Table > Split Cells** on the Menu bar.

In the Split Cells dialog, select the number of cells required when splitting a cell and whether to split the cell **Horizontally** or **Vertically**. When splitting horizontally, the selected cells can be split using **Into equal proportions** to create cells of equal size. The contents of the split cell are kept in the original cell (left or top cell).
• **Optimize** – evenly distributes the selected rows and columns in a table either horizontally or vertically. Selecting **Optimize** opens the Optimize toolbar (Figure 86) and contains the following tools. Alternatively, right-click in selected cells and select the appropriate **Optimize** tool from the context menu.
  
  – **Minimal Column Width** – defines the minimal column width for selected columns and depends on the shortest entry within a column.
  
  – **Minimal Row Height** – determines the minimal row height for selected rows and depends on the font size of the smallest character in the row.
  
  – **Optimal Column Width** – defines the optimal column width for selected columns and depends on the longest entry within a column.
  
  – **Optimal Row Height** – determines the optimal row height for selected rows and depends on the font size of the largest character in the row.
  
  – **Distribute Columns Evenly** – adjusts the width of the selected columns to match the width of the widest column in the selection. The total width of the table cannot exceed the width of the page.
  
  – **Distribute Rows Equally** – adjusts the height of the selected rows to match the height of the tallest row in the selection.

• **Align Top, Center Vertically, Align Bottom** – selects vertical alignment of text in selected cells.

  Alternatively, right-click in selected cells and select **Align** from the context menu or go to **Format > Align Text** on the Menu bar, then select the required alignment.

• **Insert Row Above, Insert Row Below, Insert Column Before, Insert Column After** – select a row or column then click on one of these tool to insert a row or column.

  Alternatively, right-click in a selected cell and select **Insert** from the context menu, then select one of the insert options from the second context menu.
Alternatively, go to **Format > Table > Insert Rows** or **Insert Columns** on the Menu bar to open the Insert Row dialog (Figure 87) or Insert Column dialog (Figure 88). Select number of rows or columns and the insertion position then click **OK** to insert.

- **Delete Row, Delete Column, Delete Table** – after selecting a cell, clicking on these tools deletes a single row, a single column, or the complete table. To delete more than one row or column, highlight cells across the number of rows or columns as required, then click on **Delete Row** or **Delete Column**.

  Alternatively, right-click in the selected cells and select **Delete > Delete Row, Delete Column**, or **Delete Table** from the context menu.

  Alternatively, after selecting a cell, go to **Format > Table** on the Menu bar and select **Delete Row, Delete Column**, or **Delete Table** from the submenu.

- **Select Table, Select Column, Select Rows** – these tools select a complete table, or columns/rows where cells are selected.

  By default these tools are not displayed on the Table toolbar. To display these tools, right-click in a blank area on the toolbar and select **Visible Buttons** from the context menu. Click on the tool required from the **Visible Buttons** list to add it to the toolbar.

- **Table Design** – click on this tool to open the **Table Design** panel in the Properties deck on the Sidebar. See “Sidebar Table Design panel” on page 116 for more information.

- **Table Properties** – click on this tool to open the Table Properties dialog.

**Table Properties dialog**

The Table Properties dialog (Figure 89) has five tabbed pages that provide formatting options for **Font**, **Font Effects**, **Borders**, **Background**, and **Shadow**. The Table Properties dialog is opened using one of the following methods:
• Right-click in a table and select **Table Properties** from the context menu.
• Go to **Format > Table > Properties** on the Menu bar.
• Click on **Table Properties** in the Table toolbar.

The formatting options available on each dialog page are as follows:

• **Font** (Figure 89) – select *Family*, *Typeface* or *Style* (Italic, Bold, etc.), *Size* and *Language* for text in the table. A sample of the font selected is displayed in the preview box.

• **Font Effects** (Figure 90) – select the required Font Color, Text Decoration and Effects for the text in the table. A sample of the font effects applied to the text is displayed in the preview box.

• **Borders** (Figure 91) – select a border configuration from the options available in *Line Arrangement*, *Line*, and *Padding*. Refer to Chapter 6, Formatting Graphic Objects for more information.

![Table Properties dialog](image)

*Figure 89: Table Properties dialog - Font page*
Figure 90: Table Properties dialog - Font Effects page

Figure 91: Table Properties dialog - Borders page
• **Background** (Figure 92) – select a background (area fill) from *None*, *Color*, *Gradient*, *Hatching*, *Bitmap* or *Pattern*. The options available change to match the background selected. This page provides the same functions as *Area Style/Filling* on the Table toolbar. Refer to Chapter 6, Formatting Graphic Objects for more information.

• **Shadow** (Figure 93) – shadows can be added to a table. The option *Use shadow* must be selected before the other options can set. Refer to Chapter 6, Formatting Graphic Objects for more information.

**Position and size**

Tables are placed into text boxes when created and are treated just like any other graphic object in an Impress presentation. However, only the Position and Size dialog (Figure 58 on page 90) can be used for tables. See “Position and Size dialog” on page 91 for more information.
Open the Position and Size dialog using one of the following methods after selecting the table:

- Right-click on the table and select **Position and Size** from the context menu.
- Go to **Format > Object and Shape > Position and Size** on the Menu bar.
- Use the keyboard shortcut **F4**.

The position of the table text box can also be changed by clicking on the border and dragging to move the table text box to a new position. Also, the table text box size can be changed by clicking and dragging on the selection handles. See “Starting Impress” on page 22 for more information.

**Note**

When the size of a text box containing a table is changed, the table also increases or decreases in size to keep the text box filled with the table.

---

**Using fields**

Fields allow the automatic insertion of text into a slide. Fields are commonly used when creating templates and slide masters. For more information, see Chapter 2, Slide Masters, Styles, and Templates.

**Inserting fields**

Insert a field into a slide as follows:

1. Select the slide so that it appears in the Workspace.
2. Go to **Insert > Field** on the Menu bar and select the type of field from the options in the submenu. The field is placed centrally on the selected slide in a text box.
3. If necessary, position and resize the field text box. See “Starting Impress” on page 22 for more information.
4. If necessary, format the text used for the field information. See “Formatting text” on page 100 for more information.

**Field types**

The types of field available are as follows:

- **Date (fixed)** – inserts the current date into a slide as a fixed field. The date is not automatically updated. Available date formats depends on the language setting in **Tools > Options > Language Settings > Language**. Right-click on the date field and select the required date format from the context menu.
- **Date (variable)** – inserts the current date into a slide as a variable field. The date is automatically updated each time the file is opened. Available date formats depends on the language setting in **Tools > Options > Language Settings > Language**. Right-click on the date field and select the required date format from the context menu.
- **Time (fixed)** – inserts the current time into a slide as a fixed field. The time is not automatically updated. Available time formats depends on the language setting in **Tools > Options > Language Settings > Language**. Right-click on the time field and select the required time format from the context menu.
- **Time (variable)** – inserts the current time into a slide as a variable field. The time is automatically updated each time the file is opened. Available time formats depends on the language setting in **Tools > Options > Language Settings > Language**. Right-click on the time field and select the required time format from the context menu.
• **Author** – inserts the first and last names of the author of the presentation. This information is taken from values entered in the LibreOffice user data. To modify this information go to **Tools > Options > LibreOffice > User Data**.

• **Slide Number** – inserts the slide number into the current slide. Alternatively, go to **Format > Slide Number** on the Menu bar. To add a slide number to every slide, go to **View > Master Slide** on the Menu bar and insert the slide number field on the master slide.

• **Slide Title** – inserts the slide title. The default slide name is Slide # if the slide has not been renamed.

• **Slide Count** – inserts the total number of slides in the presentation.

• **File Name** – inserts the name of the file used for the presentation. The file name only appears after the file has been saved.

### Using hyperlinks

When inserting text that can be used as a hyperlink, such as a website address or URL, Impress formats it automatically, creating a hyperlink, and applying color and underlining. If default settings are not being used in Impress, then the hyperlink has to be inserted manually.

**Tip**

To prevent automatically turning website addresses or URLs into hyperlinks, go to **Tools > AutoCorrect Options > Options** and deselect **URL Recognition**.

**Tip**

To change the color of hyperlinks, go to **Tools > Options > LibreOffice > Application Colors**, scroll to **Unvisited links** and/or **Visited links**. Select the checkboxes, then select new colors from the color palettes for the links and click **OK**. Note that this color change changes the color for all hyperlinks across all components of LibreOffice.

### Inserting hyperlinks

1) Select the slide where the hyperlink is going to be inserted.

2) Go to **Insert > Hyperlinks** on the Menu bar or use the keyboard shortcut **Ctrl+K** to open the Hyperlink dialog (Figure 94).

3) On the left hand side, select the type of hyperlink for insertion. The top right part of the dialog changes depending on the hyperlink type. A full description of all options, and their interactions, is beyond the scope of this chapter. A summary of the most common choices used in a presentation is given below.

4) Create the hyperlink using the Hyperlink dialog, then click **Apply** to insert the hyperlink into the slide. The hyperlink is inserted into a text box.

5) Click **Close** or **OK** to close the dialog.

### Hyperlink types

- **Internet** (Figure 94) – select either Web or FTP protocol. Enter the required web address in the **URL** text box and a name for the hyperlink in the **Text** text box.

- **Mail** (Figure 95) – enter email details in **Recipient** and the subject of the link in **Subject**.
• **Document** (Figure 96) – creates a hyperlink to another document or to another place in a document, commonly referred to as a bookmark. Enter the details in the *Path* text box, or click on **Open File** to open a file browser. Leave this blank if the link is to a target in the same presentation.

Optionally, specify a target, for example a specific slide. Click on **Target in Document** to open a dialog where a target can be selected. If the name of the target is known, type it into the *Target* text box.

• **New Document** (Figure 97) – creates a hyperlink to a new document. Select **Edit now** to edit the newly created document immediately or **Edit later** to only create the hyperlink. Choose the type of document to create from the *File type* drop-down list. Click on **Select path** to open a file browser so that a directory is selected for the new document.

• **Further Settings** – this section in the Hyperlink dialog is common to all the hyperlink types, although some choices are more relevant to some types of links.
  - **Frame** – set the value to determine how the hyperlink opens. This applies to documents that open in a web browser.
  - **Form** – specifies if the link is to be presented as text or as a button.
  - **Text** – specifies the text that will be visible to the user.
  - **Name** – applicable to HTML documents. It specifies text that will be added as a NAME attribute in the HTML code behind the hyperlink.

![Hyperlink dialog - Internet page](image)

*Figure 94: Hyperlink dialog - Internet page*
Figure 95: Hyperlink dialog - Mail page

Figure 96: Hyperlink dialog - Document page
Figure 97: Hyperlink dialog – New Document page

Formatting hyperlinks

A hyperlink is inserted in the center of the current slide. To edit the text, the size of a hyperlink text box, or to reposition the hyperlink on the slide:

1) Select the hyperlink by dragging a selection across the text to display the text box border and selection handles. DO NOT click on the hyperlink because this will open the hyperlink.

2) Right-click on the selected hyperlink and select the type of formatting required from the options available in the context menu.

3) To reposition hyperlink, click and drag on the border to move the hyperlink on the slide.

4) Select Position and Size from the context menu or press the F4 key to open the Position and Size dialog where options can be selected to move the hyperlink or resize the text box. See “Starting Impress” on page 22 for more information.
Chapter 4,
Adding and Formatting Images
Introduction

Images are often used in presentations as they can convey a large amount of information more quickly than the written word. Images, such as a company logo for example, can give a presentation a more professional look. Also, an Impress presentation can consist of only images, such as a slideshow of holiday snapshots to share with friends.

Inserting images

This section describes several ways to insert an image from an external source into the presentation. Once the image has been inserted, it can be formatted extensively.

Image files

Inserting image files

Inserting an image from a file is easy and the image can be formatted after it has been placed on the slide.

5) Insert a new slide into the presentation or select a slide in the presentation. See Chapter 1, Introducing Impress for more information.
6) If necessary, select a layout for the slide. See Chapter 1, Introducing Impress for more information.
7) Go to Insert > Image on the Menu bar and the Insert Image file browser opens (Figure 98).
8) Navigate to the directory containing the required image and select the file. LibreOffice is compatible with a large number of image formats.
9) If necessary, select Preview and a thumbnail of the selected file is displayed in the preview pane on the right of the file browser.

Figure 98: Example of Insert Image file browser

10) Click on Open to place the image in the center of the selected slide and close the file browser window. The image is displayed with selection handles around the image border.
11) Format the image to the presentation requirements. See “Formatting images” on page 138 for more information.

**Linking image files**
To insert a linked image, select **Insert as Link** in the Insert Image file browser. The selected image file is then inserted as a link to a file rather than embedding the image file into a presentation. However, it is preferable to embed images so that a presentation can be copied and used on other computers. Sometimes, it makes sense to link an image file rather than embed it and the reasons for linking could be as follows:

- When an image file is large, linking rather than embedding dramatically reduces the file size of the presentation.
- When the same image file is used in many presentations. For example, when using the same background image for all the presentations created.
- When the linked file is only available when the presentation is opened. For example, if the presentation is a slide show of holiday photographs.

**Inserting scanned images**
Inserting an image from a scanner is normally a simple process if the following points are valid for the computer being used:

- Scanner software driver has been installed on the computer.
- Scanner is supported by the SANE system and the computer operating system is Linux or other UNIX operating system.
- Scanner is TWAIN compatible and the computer is operating Windows or macOS.
- Scanner is configured on a computer with LibreOffice software installed.

The following scanning procedure is only an example to demonstrate how to insert an image from a scanner. The actual procedure used depends on computer operating system, the type of scanner being used, and the scanner driver software installed.

1) Prepare the image for the scanner and make sure that the scanner is switched on.
2) If the scanner and scanning software has not been used before, go to **Insert > Media > Scan > Select Source** on the Menu bar to open a scanner dialog.
3) If the scanner and scanning software is already installed on the computer, then go to **Insert > Media > Scan > Request** on the Menu bar to open a scanner dialog.
4) If there is more than one scanner connected to a computer, select the scanner from the **Select Source** or **Device Used** drop-down list.
5) If available, click **Create Preview** or **Preview** to create a preview scan of the image and place it in the preview area.
6) If necessary crop the scanned image to what is required and make any necessary scanning adjustments.
7) Click **Scan** and the image is scanned. Impress then places the scanned image in the center of the selected slide.
8) Format the image to the presentation requirements. See “Formatting images” on page 138 for more information.
Inserting Gallery images

The Gallery deck on the Sidebar contains a collection of images that can be used in a presentation. Images can also be added to the Gallery, making it an essential tool for creating presentations quickly and with a consistent look. The Gallery is available in all LibreOffice components. For more information on the Gallery, see the *Getting Started Guide*.

1) Open the Gallery deck in the Sidebar (Figure 99) using one of the following methods:
   - Go to *Insert > Media > Gallery* on the Menu bar.
   - Click on *Gallery* in the Sidebar.
2) Select a theme from the available themes and the images for that theme are displayed.
3) Scroll through the available images and select the required image.
4) Click and hold on the image and drag it onto the slide. Release the hold and the image is inserted centrally into the slide.
5) Format the image to the presentation requirements. See “Formatting images” on page 138 for more information.

Gallery themes

Default themes

Images in the Gallery are grouped by themes, such as *Arrows*, *Bullets*, *Diagrams* and so on, and these default themes are listed alphabetically in the box at the top of the Gallery deck on the Sidebar (Figure 99). Click on a theme to see its images displayed in the Gallery deck.

The default themes in the Gallery are read-only. No images or graphics can be added to or deleted from these themes. The default themes are easily identified by right-clicking on a theme name and the only available option in the context menu is *Properties*.  

Figure 99: Gallery deck on Sidebar

---

120 | LibreOffice 7.3 Impress Guide
Custom themes

When custom themes have been created, they are the only themes where images can be added. Custom themes are listed alphabetically, along with the default themes, in the box at the top of the Gallery deck on the Sidebar. Custom themes are easily identified by right-clicking on a theme name and the options available in the context menu are **Delete**, **Rename** and **Properties**.

Creating themes

1) Open the Gallery deck in the Sidebar using one of the following methods:
   – Go to **Insert > Media > Gallery** on the Menu bar.
   – Click on **Gallery** in the Sidebar.

2) Click **New** at the bottom of the Gallery deck and the Properties of New Theme dialog opens (Figure 100).

3) Click on **General** and type a name for the new theme in the text box.

4) Click **OK** to save the new theme and close the dialog. The new theme is displayed in the list of themes in the Gallery.

Note

The name of the Properties of New Theme dialog changes to show the name of the newly created custom theme in the Gallery deck.

Adding theme images

1) Right-click on a custom theme name in the theme list on the Gallery deck and select **Properties** from the context menu to open the Properties of New Theme dialog.

2) Click on **Files** (Figure 101) to open the **Files** page, then click on **Find Files** to open a Select Path dialog.

3) Navigate to the folder that contains the images required and select the folder.

4) Click **OK** to close the Select Path dialog. The files contained in the folder appear in the Properties of New Theme dialog.

5) If necessary, select **Preview** and any image selected appears in the preview box.

6) Select the files required for the custom theme and click on **Add**. The added files disappear from the file list and the images appear in the custom theme on the Gallery deck.
7) To add all the files in the list, then click **Add All**. All the files disappear from the list and the images appear in the custom theme on the Gallery deck.

8) Click **OK** and close the Properties of New Theme dialog.

### Deleting theme images

Custom themes are the only themes where images can be deleted.

1) Open the Gallery deck and select a new theme that has been created.
2) Right-click on the image being deleted and select **Delete** from the context menu.
3) Click **Yes** in the confirmation message to delete the image.

---

**Note**

Images in custom themes are linked files and are deleted from the Gallery only. The original image files are not deleted.

### Updating themes

All images in the Gallery are linked files. It is recommended that any custom themes are updated on a regular basis to make sure that all the files are still available.

1) Open the Gallery deck and select a new theme that has been created.
2) Right-click on the name of a custom theme that contains at least one image.
3) Select **Update** from the context menu and the links to all the image files are updated.
Formatting images

Moving images
For more information on moving images, see Chapter 6, Formatting Graphic Objects.

1) Click on an image to select it and display the selection handles.
2) Move the cursor over the image until it changes shape. The cursor shape depends on the computer operating system, for example a clenched hand.
3) Click, hold and drag the picture to the desired position, then release the hold when the image is in the desired position.

Resizing images
For more information on resizing images, see Chapter 6, Formatting Graphic Objects.

1) Click on an image to select it and display the selection handles.
2) Position the cursor over one of the selection handles. The cursor changes shape giving a graphical representation of the direction of the resizing.
3) Click, hold and drag the selection handle to resize the image, then release the hold when the image is at the required size.

Note
The corner selection handles resize both the width and the height of the graphic object simultaneously. The top and bottom selection handles resize the image height. The left and right selection handles resize the image width.

Note
To retain the original proportions of the graphic as a selection handle is dragged, Shift+Click and hold on a selection handle, then drag the selection handle. Make sure to release the hold before releasing the Shift key.

Tip
Re-sizing a bitmapped (raster) image affects the image resolution causing some degree of blurring. It is recommended to use a specialized graphics program to correctly scale the picture to the desired size before inserting it into a presentation. LibreOffice recommends Gimp (https://www.gimp.org).

Rotating, slanting or skewing images
For more information on rotating, slanting or skewing images and objects, see Chapter 6, Formatting Graphic Objects.

1) Click on an image to select it and display the selection handles.
2) Select rotation mode (Figure 102) using one of the following methods. The color and shape of the selection handles changes depending on the computer operating system and setup.
   - Click on **Rotate** on the Drawing toolbar (Figure 103).
   - Click again on a selection handle.

3) The central selection handle is the normal rotation point for the selected image. If required, click, hold and drag this rotation point to another position (even outside of the image) to change how the selected image is rotated.

4) Click, hold and drag a selection handle to rotate, slant or skew the image as follows. A ghost image appears while dragging the cursor.
   - Corner selection handles rotate the image.
   - Left and right selection handles slant the image.
   - Top and bottom selection handles skew the image.

5) Release the hold when the required rotation, slanting or skewing is reached.
To restrict the rotation angles to multiples of 15 degrees, Shift+Click on a selection handle and then drag to rotate, slant or skew. Make sure to release the mouse button before releasing the Shift key.

Using Image Filters

Image Filter toolbar
When an image is selected, the Image toolbar (Figure 104) and the Image Filter toolbar (Figure 105) become available to format an image.

1) Select an image on a slide.
2) Go to View > Toolbars > Image on the Menu bar to open the Image toolbar. The Image toolbar only opens when an image is selected.
3) Click on Filter to open the Image Filter toolbar. The Image Filter toolbar only opens when an image is selected.
4) Select the required filter and it is applied immediately to the image. See “Image filters” below for more information on filters.
5) Alternatively, go to Format > Image > Filter on the Menu bar and select a filter from the submenu. This applies the image filter at the filter default settings.
6) Click outside the image to deselect it and save the presentation.

Image filters
The effect each image filter has on an image is described below. The best way to judge if a filter works is to try it. See the Draw Guide for more information on image filters and examples of the filter effects.

- **Invert** – inverts or reverses the color values of a color image (similar to a color negative), or the brightness values of a grayscale image. Apply the filter again to revert to the original graphic.

- **Smooth** – softens or blurs the image by applying a low pass filter reducing the contrast between neighboring pixels and produces a slight lack of sharpness. Selecting this filter opens the Smooth dialog to set and use the smooth radius parameter.

- **Sharpen** – sharpens the image by applying a high pass filter, increasing the contrast between neighboring pixels emphasizing the difference in brightness. This accentuates the outlines and the effect is strengthened if the filter is applied several times.
• **Remove Noise** – removes noise by applying a median filter comparing every pixel with its neighbor creating an image that looks smoother. It replaces any pixel with extreme values that deviate in color by a large amount from the mean value with a pixel that has a mean color value. The amount of image information does not increase because there are fewer contrast changes.

• **Solarization** – solarization is a phenomenon in photography where an image recorded on a negative or on a photographic print is wholly or partially reversed in tone. Dark areas appear light or light areas appear dark. Solarization was originally a photochemical effect used during photographic film development and is now used in the digital world of computing to create a change or reversal of color. Selecting this image filter opens the Solarization dialog, where the Threshold value for solarization can be defined. Entering a threshold value above 70% reverses the color values. Selecting the Invert option causes all the colors to be inverted.

• **Aging** – aging creates a look that resembles photographs developed in the early days of photography. All pixels are set to their gray values. The green and blue color channels are reduced by the amount specified in Aging degree in the Aging dialog. Red color channel is not changed. Selecting this image filter opens the Aging dialog, where the Aging degree can be defined creating an old look to an image.

• **Posterize** – posterizing reduces the number of colors in an image making it look flatter. When used on a photograph, posterizing can make the photograph look like a painting. Selecting this image filter opens the Posterize dialog, where the number of poster colors can be defined to produce the required effect.

• **Pop Art** – select this image filter to change the colors of an image to a pop-art format.

• **Charcoal Sketch** – selecting this image filter displays an image as a charcoal sketch. The contours of the image are drawn in black and the original colors are suppressed.

• **Relief** – this image filter calculates the edges of an image in relief as if the image is illuminated by a light source. Selecting this image filter opens the Emboss dialog where the position of the Light source can be selected producing shadows that differ in direction and magnitude.

• **Mosaic** – this image filter joins groups of pixels and converts them into a rectangular tile in a single color creating an image that appears to be a mosaic. The larger the individual rectangles created, the fewer details the mosaic graphic has. Selecting this image filter opens the Mosaic dialog, where the number of pixels used can be set to create the Width and Height of each tile created. Selecting Enhanced edges enhances the edges of each tile to create a sharper definition.

### Changing image mode

The **Image Mode** drop-down list on the Image toolbar provides options to change the color or image mode of a selected image. The options for image mode are as follows and an example of using Image Mode is shown in Figure 106.

• **Default** – image color is not changed.

• **Grayscale** – the image is shown in grayscale. A color image becomes monochrome in grayscale. Color sliders can be used to apply a uniform color to the monochrome graphic object.

• **Black and White** – the image is shown in black and white. All brightness values below 50% appear black, all brightness values over 50% appear white.

• **Watermark** – in an image, the brightness is raised and the contrast reduced to allow the image to be used in the background as a watermark.
Figure 106: Example of image modes

Figure 107: Example of adjusting color level
Color adjustment

The Color toolbar is used to adjust individual colors within the whole of the image (red, green, blue), as well as the brightness, contrast, and gamma of the image. Increasing the gamma value of an image makes it more suitable to be used as a background or watermark as the image has less interference with a dark text. An example of changing the percentage and levels for color, brightness, contrast, and gamma of an image is shown in Figure 107.

After selecting an image, open the Color toolbar (Figure 108) using one of the following methods to change the values for color adjustment:

- Click on Color in the Image toolbar.
- Go to Format > Image > Color on the Menu bar.

Replacing colors and transparent areas

The Color Replacer dialog (Figure 109) only allows a color to be replaced or changed in embedded images for another color or a color set as transparent. The embedded image must be a bitmap (for example BMP, GIF, JPG, or PNG) or a metafile (for example WMF).

Up to four colors can be replaced at once. Color Replacer only works on the same color in the entire image. Individual areas in an image cannot be selected for color replacement.

The colors available in the Replace with... drop-down lists are all contained in color palettes that are part of the installation of LibreOffice. If any custom colors have been created, then these colors are available in the custom palette. For more information on creating custom colors, see the Draw Guide.

Note

The Color Replacer can only be used on embedded images. If the Color Replacer is used on a linked image, the following error message appears “This image is linked to a document. Do you want to unlink the image in order to edit it?”.

Replacing colors

1) Select an embedded image to start using the Color Replacer.
2) Go to Tools > Color Replacer on the Menu bar to open the Color Replacer dialog.
3) Click on **Pipette** at the top of the Color Replacer dialog to activate the color selection mode.

4) Move the cursor over the color being replaced in the selected image and click on the color. A check box is now marked and the selected color appears in **Source color**.

5) If necessary, select another three colors in the selected image. A maximum of four colors can be selected.

6) Enter the amount of tolerance required for replacing the color in the **Tolerance** box. The default selection is 10% tolerance.

7) Select a color from the color palettes available in the **Replace with…** drop-down list for each color selected. **Transparent** is the default selection.

8) After selecting up to four colors for replacement, click **Replace** to replace the colors in the selected image. An example of replacing colors is shown in Figure 110.

9) There is no preview of the effect. If the result is not what is required, select **Edit > Undo** in the Menu bar and repeat the color replacement.
Note
If the Replace button does not become active when replacing colors, then the file format of the image is not compatible with LibreOffice Impress.

Note
Using Color Replacer replaces all occurrences of the Source color in the selected image.

Note
The default selection of Transparent in Replace with... removes the selected color from the image and creates transparent areas in the image.

Replacing transparent areas
1) Select an embedded image to start using the Color Replacer.
2) Go to Tools > Color Replacer on the Menu bar to open the Color Replacer dialog.
3) Select Transparency in the Color Replacer dialog.
4) Select a color from the available color palettes in the drop-down list next to Transparency.
5) Click Replace to replace the transparent areas with the selected color.
6) There is no preview of the effect. If the result is not what is required, select Edit > Undo in the Menu bar and repeat the transparency replacement.

Tolerance parameter
The Tolerance parameter is used to set how much of the source color in an embedded image is replaced by another color.

• Replacing colors that are similar to the color being replaced, enter a low value for the tolerance parameter.
• Replacing a wider range of colors, enter a higher value for the tolerance parameter.

Image transparency
Specifies the transparency in an image. A percentage value of 0% is a fully opaque image and a percentage value of 100% is a fully transparent image. As with the gamma value of an image, increasing the transparency makes the image blend more smoothly into the background making any overlay text easier to read.

Click on Transparency on the Image toolbar and change the percentage value in the text box to adjust the image transparency. An example of adjusting the transparency percentage is shown in Figure 111.
Adjusting shadow settings

Select an image, then click on Shadow on the Image toolbar to apply a shadow to the image. The shadow applied uses the settings from the Shadow page of the Area dialog (Figure 112). If a shadow is already applied to the image, clicking on Shadow removes the shadow from the image.

The preview box in the dialog shows how the shadow looks when the settings are adjusted and applied as follows:

1) Go to Format > Object and Shape > Area on the Menu bar to open the Area dialog.
2) Click on Shadow to open the Shadow page.
3) Select the option Use shadow in Properties.
4) Select the shadow position from one of nine positions for casting the shadow from the image.
5) Select a shadow color from the available color palettes in the Color drop-down list.
6) Enter a distance for the shadow to be offset from the image in the Distance box.
7) Enter a value in the *Blur* box to create a softer look for the shadow. The higher the setting, the softer the shadow appears. Value of 0 (minimum), the shadow is sharp. The value of 150 (maximum), the shadow is at its softest.

8) Enter a percentage in the *Transparency* box. The value of 0% (minimum), the shadow is opaque. The value of 100% (maximum), the shadow is transparent.

**Cropping images**

In Impress, images can be cropped using a mouse or a dialog. Mouse cropping is easier, but dialog cropping provides more precise control.

**Mouse cropping**

1) Select an image and use one of the following methods to put the image into cropping mode and crop marks appear around the image (Figure 113):
   - Click **Crop Image** on the Image toolbar.
   - Go to **Format > Image > Crop** on the Menu bar.
   - Right click on the image and select **Crop** from the context menu.

2) Place the cursor over any of the crop marks and the cursor changes shape. Click, hold and drag the crop mark to crop the image.
   - Corner crop marks change width and height of an image.
   - Left and right crop marks change the width of an image.
   - Top and bottom crop marks change the height of an image.

3) Click outside the image to deactivate cropping mode.

**Note**

Press and hold the *Shift* key, then click, hold and drag a crop mark to proportionally reduce width and height of the image at the same time. Release the hold before releasing the *Shift* key.

![Image cropping marks](image.png)

*Figure 113: Image cropping marks*
Dialog cropping

1) Select an image and go to Format > Image > Crop Dialog on the Menu bar to open the Crop dialog (Figure 114).

2) Crop the image using the options given in the Crop dialog. A preview of the selected image and cropping results appear in the dialog.

3) Click OK to save the changes and close the dialog.

The Crop dialog has the following options:

- **Crop** – adjusts the crop size and type of cropping for an image.
  - **Keep scale** – maintains the original scale of the image when cropped. The size of the image changes to the cropped size (Figure 115).
– *Keep image size* – maintains the original size of the image when cropped. The scale of the image changes (Figure 116). To reduce the scale of the graphic, select this option and enter negative values in the cropping boxes. To increase the scale of the graphic, enter positive values in the cropping boxes.

– *Left* – if *keep scale* is selected, enter a positive amount to trim the left edge of the image, or a negative amount to add white space to the left of the image. If *keep image size* is selected, enter a positive amount to increase the horizontal scale of the image, or a negative amount to decrease the horizontal scale of the image.

– *Right* – if *keep scale* is selected, enter a positive amount to trim the right edge of the image, or a negative amount to add white space to the right of the image. If *keep image size* is selected, enter a positive amount to increase the horizontal scale of the image, or a negative amount to decrease the horizontal scale of the image.

– *Top* – if *keep scale* is selected, enter a positive amount to trim the top of the image, or a negative amount to add white space above the image. If *keep image size* is selected, enter a positive amount to increase the vertical scale of the image, or a negative amount to decrease the vertical scale of the image.

– *Bottom* – if *keep scale* is selected, enter a positive amount to trim the bottom of the image, or a negative amount to add white space below the image. If *keep image size* is selected, enter a positive amount to increase the vertical scale of the image, or a negative amount to decrease the vertical scale of the image.

• **Scale** – changes the scale of the selected image.
  – *Width* – enter the width for the selected image as a percentage.
  – *Height* – enter the height of the selected image as a percentage.

• **Image Size** – changes the size of the selected image.
  – *Width* – enter a width for the selected image.
  – *Height* – enter a height for the selected image.

• **Original Size** – returns the selected image to its original size.

**Deleting images**

Click on an image to display the selection handles and press the *Delete* or *Backspace* key.

**Creating image maps**

An image map defines areas of the image (called hotspots) associated with a URL (a web address or a file on the computer). Hotspots are the graphic equivalent of text hyperlinks. In Impress, clicking on a hotspot opens the linked page in the appropriate program (for example, default browser for HTML pages; LibreOffice Writer for ODT files; PDF viewer for PDF files).

Hotspots can be created in various shapes, such as rectangles, ellipses, and polygons, and several hotspots can be included in the same image. When clicking on a hotspot, the URL opens in a browser window or frame that has been specified. Also, text can be specified to appear when the cursor hovers over a hotspot.

Use the ImageMap dialog (Figure 117) to create or edit a hotspot:

1) Select an image on a slide and go to **Tools > ImageMap** on the Menu bar and the ImageMap dialog opens. The main part of the dialog shows the selected image where hotspots will be defined.
Figure 117: ImageMap dialog

2) Use the tools at the top of the dialog and the fields to define hotspots and their links.
3) Click on **Apply** to apply the settings.
4) When finished, click on **Save** to save the image map to a file and open a file browser.
5) Navigate to the folder where the image map is going to be saved and enter a name for the image map.
6) Click on **Save** and the file browser closes.
7) Click on **Close** to close the ImageMap dialog.

The tools available in the ImageMap dialog are as follows:

- **Apply** – applies any changes made.
- **Open** – opens a file browser window for navigating to a folder where an image map has been saved.
- **Save** – opens a file browser window for navigating to a folder where the image map is to be saved.
- **Close** – closes the Image Map dialog. A confirmation window opens asking for confirmation of what happens to any changes that have been made.
- **Select** – used to select a hotspot that has been created on an image.
- **Rectangle, Ellipse, Polygon and FreeForm Polygon** – drawing tools for hotspot shapes. These tools work in exactly the same way as the corresponding tools in the Drawing toolbar. For more information see Chapter 5, Managing Graphic Objects.
- **Edit Points, Move Points, Insert Points, Delete Points** – advanced editing tools to manipulate the shape of a polygon hotspot. Select **Edit Points** first to activate the other points tools.
• **Undo** – reverses any previous action taken.
• **Redo** – carries out any action that has been previously undone.
• **Active** – toggles the status of the hotspot activating a selected hotspot or deactivating it if active.
• **Macro** – associates a macro with the hotspot instead of a hyperlink.
• **Properties** – sets the hyperlink properties and adds the **Name** attribute to the hyperlink.
• **Address** – enter the URL address that points to a hyperlink, or to an anchor in a document (for example a specific slide number). Using an anchor in a document, write the address in this format: `file:///<path>/document_name#anchor_name`.
• **Text** – enter the text that is displayed when the cursor is moved over the hotspot.
• **Frame** – where the target of the hyperlink opens.
  – `_blank` – opens in a new browser window.
  – `_self` – default selection and opens in the current window.
  – `_top` – file opens in the topmost frame in the hierarchy.
  – `_parent` – file opens in the parent frame of the current frame. If there is no parent frame, the current frame is used.

**Tip**

The value `_self` for the target frame works on the vast majority of occasions. It is not recommended to use the other values, if available, unless absolutely necessary.
Chapter 5,
Managing Graphic Objects
Introduction

This chapter describes how to rotate, distort, arrange, and position graphic objects on a slide focusing on the shapes that can be created with the available tools in Impress. However, some of the techniques described in this chapter are also applicable to images imported into slides.

Drawing toolbar

The Drawing toolbar (Figure 118) contains the majority of the tools normally used to create graphic objects. If this toolbar is not visible, select View > Toolbars > Drawing from the Menu bar. By default, the Drawing toolbar is docked vertically at the left side of the Impress window.

![Drawing toolbar](image)

**Figure 118: Drawing toolbar**

*Note*

The Drawing toolbar shown in Figure 118 may differ between different operating systems and computer setup. Also, the Drawing toolbar displayed depends on how many drawing tools have been placed on the toolbar. Right-click in an empty area of the Drawing toolbar, then select Visible Buttons from the context menu to display the available tools. Using Visible Buttons, tools can be installed and removed to and from the toolbar. See Appendix B, Toolbars for more information.

Drawing tools

From left to right, the drawing tools shown in Figure 118 are as follows:

- **Select** – selects objects. To select a group of objects, position the cursor above the top left object, then click, hold and drag the cursor below the bottom right object of the intended selection. A rectangle identifying the selection area is displayed. Also, several objects can be selected by holding down the Shift key while selecting the individual objects.

- **Zoom & Pan** – used to zoom out and pan the selected slide in the Workspace. Hold down the Ctrl key (macOS ⌘) and select the tool to zoom out and reduce the screen display of a slide in LibreOffice. The current zoom factor is displayed as a percentage value on the Status bar. Hold down the Shift key and select the tool to move the displayed slide without changing the zoom percentage.

- **Insert Text Box** – creates a text box with text aligned horizontally. See Chapter 3, Adding and Formatting Text for more information on working with text.

- **Insert Vertical Text** – creates a text box with text aligned vertically. This tool is available only when Asian language support has been enabled in Tools > Options > Language Settings > Languages (macOS LibreOffice > Preferences > Language Settings > Languages). See Chapter 3, Adding and Formatting Text for more information on working with text.
• **Line Color** – click on the triangle ▼ next to **Line Color** to open a color palette and select a color for the line. More colors are available by selecting a different color palette from the drop-down list at the top of the color palette.

• **Fill Color** – click on the triangle ▼ next to **Fill Color** to open a color palette and select a color for the area fill. More colors are available by selecting a different color palette from the drop-down list at the top of the color palette.

• **Insert Line** – draws a straight line from the point where the cursor is dragged to the point where the cursor is released. Press the **Shift** key to restrict the angle of the line to multiples of 45°. Press the **Alt** key (macOS ⊕) to draw a line from its center. Release the cursor before releasing the **Shift** or **Alt** (macOS ⊕) keys.

• **Rectangle** – draws a rectangle when the cursor is dragged from the top left to the bottom right corner. Press the **Shift** key to draw a square. Press the **Alt** key (macOS ⊕) to draw a shape from its center. Press the **Shift** + **Alt** keys (macOS ⊕+Shift) to draw a square from the center. Release the cursor before releasing the **Shift** or **Alt** (macOS ⊕) keys.

• **Ellipse** – draws an ellipse. Press the **Shift** key to draw a circle. Press the **Alt** key (macOS ⊕) to draw a shape from its center. Press the **Shift** + **Alt** keys (macOS ⊕+Shift) to draw a circle from the center. Release the cursor before releasing the **Shift** or **Alt** (macOS ⊕) keys.

• **Line and Arrows** – draws a straight line ending with an arrowhead. The arrowhead is placed at the end of the line where the cursor is released. Click the triangle ▼ next to **Line and Arrows** to show the available tools (Figure 119). The **Shift** and **Alt** (macOS ⊕) keys have the same effect as the **Line** tool. Actual icon shown on the toolbar depends on the tool that had previously been selected.

![Lines and Arrows sub-toolbar](image1)

*Figure 119: Lines and Arrows sub-toolbar*

• **Curves and Polygons** – draws a shape depending on the option that has been selected. Click the triangle ▼ next to **Curves and Polygons** to show the available tools (Figure 120). Actual icon shown on the toolbar depends on the tool that had previously been selected.

![Curves and Polygons sub-toolbar](image2)

*Figure 120: Curves and Polygons sub-toolbar*

• **Connectors** – draws a connector line between two figures. Click the triangle ▼ next to **Connectors** to show the available tools (Figure 121). Actual icon shown on the toolbar depends on the tool that had previously been selected. For more information see “Connectors and glue points” on page 186.

![Connectors sub-toolbar](image3)

*Figure 121: Connectors sub-toolbar*

• **Basic Shapes** – click the triangle ▼ next to **Basic Shapes** to open a toolbar showing the available tools (Figure 122). The **Shift** and **Alt** (macOS ⊕) keys have the same effect as
the **Rectangle** tool. Actual icon shown on the toolbar depends on the tool that had previously been selected.

![Basic Shapes sub-toolbar](image1)

*Figure 122: Basic Shapes sub-toolbar*

- **Symbol Shapes** – click the triangle ▼ next to **Symbol Shapes** to open a toolbar showing the available tools (Figure 123). The Shift and Alt (macOS ⌥) keys have the same effect as the **Rectangle** tool. Actual icon shown on the toolbar depends on the tool that had previously been selected.

![Symbol Shapes sub-toolbar](image2)

*Figure 123: Symbol Shapes sub-toolbar*

- **Block Arrows** – click the triangle ▼ next to **Block Arrows** to open a toolbar showing the available tools (Figure 124). The Shift and Alt (macOS ⌥) keys have the same effect as the **Rectangle** tool. Actual icon shown on the toolbar depends on the tool that had previously been selected.

![Block Arrows sub-toolbar](image3)

*Figure 124: Block Arrows sub-toolbar*

- **Flowchart** – click the triangle ▼ next to **Flowchart** to open a toolbar showing the available tools (Figure 125). The Shift and Alt (macOS ⌥) keys have the same effect as the **Rectangle** tool. Actual icon shown on the toolbar will depend on the tool that had previously been selected.

![Flowchart sub-toolbar](image4)

*Figure 125: Flowchart sub-toolbar*

- **Callouts** – click the triangle ▼ next to **Callout Shapes** to open a toolbar showing the available tools (Figure 126). The Shift and Alt (macOS ⌥) keys have the same effect as the **Rectangle** tool. Actual icon shown on the toolbar depends on the tool that had previously been selected.

![Callouts sub-toolbar](image5)

*Figure 126: Callouts sub-toolbar*

- **Stars and Banners** – click the triangle ▼ next to **Stars and Banners** to open a toolbar showing the available tools (Figure 127). The Shift and Alt (macOS ⌥) keys have the
same effect as the **Rectangle** tool. Actual icon shown on the toolbar depends on the tool that had previously been selected.

![Stars and Banners toolbar](image)

*Figure 127: Stars and Banners sub-toolbar*

- **3D-Objects** – click the triangle ▼ next to **3D-Objects** to open a toolbar showing the available tools (Figure 128). The *Shift* and *Alt* (macOS ~) keys have the same effect as the **Rectangle** tool. Actual icon shown on the toolbar depends on the tool that had previously been selected. For more information on 3D objects, see “Working with 3D objects” on page 192.

![3D-Objects toolbar](image)

*Figure 128: 3D-Objects sub-toolbar*

- **Rotate** – select an object then click on this tool to switch the object in rotation mode. The selection handles change color and pivot point appears in the center of the object.

- **Align Objects** – click the triangle ▼ next to **Align Objects** to open the available alignment tools (Figure 129) for two or more objects: See “Aligning objects” on page 179 for more information.
  - **Left, Centered, Right** – determines the horizontal alignment of selected objects.
  - **Top, Center, Bottom** – determines the vertical alignment of selected objects.

![Align Objects toolbar](image)

*Figure 129: Align Objects sub-toolbar*

- **Arrange** – changes the stack level of an object. Click the triangle ▼ next to **Arrange** to open the available arrange tools (Figure 130) for a selected object. See “Arranging objects” on page 185 for more information.
  - **Bring to front** – the selected object is moved in front of all other objects.
  - **Bring forward** – the selected object is moved one level up in the stack.
  - **Send backwards** – the selected object is moved one level down in the stack.
  - **Send to back** – the selected object is moved behind all other objects.
  - **In front of object** – moves the first selected object in front of the second selected object.
  - **Behind object** – moves the first selected object behind the second selected object.
  - **Reverse** – swaps the stacking order of two selected objects.
• **Distribute Selection** – changes the distribution between objects by using the horizontal and vertical spacing between objects (Figure 131). A minimum of three objects have to be selected for this tool to be active.

• **Shadow** – applies a shadow to a selected object using the shadow settings from the Area or Line dialog.

• **Crop Image** – this tool only becomes active when an image is selected that can be cropped.

• **Filter** – this tool only becomes active when an image is selected and opens the available filter options (Figure 132) for application to an image. For more information on image filters, see the *Draw Guide*.
  
  – **Invert** – inverts the color values of a color image, or the brightness values of a grayscale image. Apply the filter again to reverse the effect.
  
  – **Smooth** – softens or blurs the image by applying a low pass filter.
  
  – **Sharpen** – sharpens the image by applying a high pass filter.
  
  – **Remove Noise** – removes noise by applying a median filter.
  
  – **Solarization** – opens a dialog for defining solarization. Solarization refers to an effect that looks like what can happen when there is too much light during photo development.
  
  – **Aging** – all pixels are set to their gray values. The green and blue color channels are then reduced by the amount you specify. The red color channel is not changed.
  
  – **Posterize** – opens a dialog to determine the number of poster colors. This effect is based on the reduction of the number of colors. It makes photos look like paintings.
  
  – **Pop Art** – converts an image to a pop-art format.
  
  – **Charcoal Sketch** – displays the image as a charcoal sketch. The contours of the image are drawn in black, and the original colors are suppressed.
  
  – **Relief** – displays a dialog for creating reliefs. You can choose the position of the imaginary light source that determines the type of shadow created, and how the graphic image looks in relief.
  
  – **Mosaic** – joins small groups of pixels into rectangular areas of the same color. The larger the individual rectangles are, the fewer details the graphic image has.
• **Points** – select this tool and then select an object to edit the individual points in the object. The object must be converted to a curve or polygon first before editing the object points. Clicking on the keyboard shortcut `F8` also selects this tool.

• **Show Glue Points Functions** – opens the Glue Points toolbar (Figure 133) for editing the glue points of a graphic object. Glue points are the positions where connector lines terminate or start. See “Glue points” on page 189 for more information.

![Figure 133: Glue Points toolbar](image)

• **Toggle Extrusion** – switches 3D effects on or off for the selected object. Clicking on this tool also opens the 3D-Settings toolbar (Figure 134). See “Working with 3D objects” on page 192 for more information.

![Figure 134: 3D-Settings toolbar](image)

## Creating lines and shapes

This section is an introduction to creating lines and shapes. For more information on working with lines and shapes, see the *Draw Guide*.

### Drawing regular shapes

Regular shapes that are available on the Drawing toolbar are as follows:

<table>
<thead>
<tr>
<th>Shape</th>
<th>Symbol Shapes</th>
<th>Callouts Shapes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rectangle</td>
<td>Symbol Shapes</td>
<td>Callouts Shapes</td>
</tr>
<tr>
<td>Ellipse</td>
<td>Block Arrows</td>
<td>Blocks</td>
</tr>
<tr>
<td>Basic Shapes</td>
<td>Flowchart</td>
<td>3D Objects</td>
</tr>
<tr>
<td>Symbol Shapes</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Block Arrows</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Flowchart</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Callouts Shapes</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Blocks</td>
<td></td>
<td></td>
</tr>
<tr>
<td>3D Objects</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Some icons for regular shapes have a triangle ▼ next to the icon that gives access to several different types of regular shapes. Also, the icons for some of the regular shapes displayed on the Drawing toolbar show the last tool used for each of these regular shapes.

Drawing a regular shape is as follows:

1. Select the required tool from the Drawing toolbar or from a sub-toolbar after selecting the triangle ▼ next to the icon.
2. Place the cursor on the slide, then click and drag to define an enclosing rectangle.
3. Release the cursor and the selected shape is drawn on the slide.
4. Press and hold the **Shift** key when creating a shape to maintain equal height and width. For example, using **Rectangle** or **Ellipse** to draw a square or a circle. Release the cursor before releasing the **Shift** key.
5. Press and hold the **Alt** key (macOS ⌘) to draw a shape from its center. Release the cursor before releasing the **Alt** key (macOS ⌘).
6. Press and hold the **Shift** and **Alt** (macOS ⌘) keys when creating a shape to maintain equal height and width and draw the shape from the center. For example, when using **Rectangle** or **Ellipse** tool to draw a square or a circle. Release the cursor before releasing the **Shift** and **Alt** (macOS ⌘) keys.
14) Press and hold the Ctrl key (macOS ⌘) when creating a shape to snap the top left corner of the shape selection box to the nearest grid point.

**Note**

If the Snap to Grid option in Tools > Options > LibreOffice Impress > Grid (macOS LibreOffice > Preferences > LibreOffice Impress > Grid) has been selected, pressing and holding the Ctrl key (macOS ⌘) prevents the top left corner of the shape selection box snapping to the nearest grid point.

**Regular shape adjustment**

When creating shapes that are included in Impress, one or more dots maybe displayed in a different color to the selection handles. These dots perform a different function according to the shape they are applied to and are listed below.

**Basic Shapes**

The Basic Shapes with shape adjustment dots are as follows:

- **Rectangle, Rounded** – changes the radius of the curve used for corners on a rounded rectangle or square.
- **Square, Rounded** – changes the radius of the curve used for corners on a rounded rectangle or square.
- **Parallelogram** – changes the internal angles between the sides.
- **Trapezoid** – changes the internal angles between the sides.
- **Circle Pie** – changes the size of the filled sector.
- **Block Arc** – changes both internal diameter and size of the filled area.
- **Isosceles Triangle** – changes the shape and type of the triangle.
- **Hexagon** – changes the internal angles between the sides.
- **Octagon** – changes the internal angles between the sides.
- **Cylinder** – changes the perspective.
- **Cube** – changes the perspective.
- **Folded Corner** – changes the size of the folded corner.
- **Cross** – changes the thickness of the four arms of the cross.
- **Frame** – changes the thickness of the frame.
- **Ring** – changes the internal diameter of the ring.

**Symbol Shapes**

The Symbol Shapes with shape adjustment dots are as follows:

- **Smiley Face** – changes the smile on the face.
- **Sun** – changes the shape of the symbol.
- **Moon** – changes the shape of the symbol.
- **Prohibited** – changes the thickness of the ring and the diagonal bar.
- **Square Bevel** – changes the thickness of the bevel.
- **Octagon Bevel** – changes the thickness of the bevel.
- **Diamond Bevel** – changes the thickness of the bevel.
- **Double Bracket** – changes the curvature of the bracket.
• **Left Bracket** – changes the curvature of the bracket.
• **Right Bracket** – changes the curvature of the bracket.
• **Double Brace** – changes the curvature of the bracket.
• **Left Brace** – changes the curvature of the brace and the position of the point.
• **Right Brace** – changes the curvature of the brace and the position of the point.

**Block Arrows**
The Block Arrows with shape adjustment dots are as follows:

• **Right Arrow** – changes the shape and thickness of the arrow.
• **Left Arrow** – changes the shape and thickness of the arrow.
• **Down Arrow** – changes the shape and thickness of the arrow.
• **Up Arrow** – changes the shape and thickness of the arrow.
• **Left and Right Arrow** – changes the shape and thickness of the arrow.
• **Up and Down Arrow** – changes the shape and thickness of the arrow.
• **Circular Arrow** – changes the shape and thickness of the arrow.
• **Chevron** – changes the angle between the sides and the shape.
• **Pentagon** – changes the angle between the sides and the shape.
• **Striped Right Arrow** – changes the shape and thickness of the arrow.
• **Up, Right and Down Arrow** – changes the shape and thickness of the arrow.
• **Notched Right Arrow** – changes the shape and thickness of the arrow.
• **Up and Right Arrow** – changes the shape and thickness of the arrow.
• **Right Arrow Callout** – changes the shape and thickness of the callout.
• **Down Arrow Callout** – changes the shape and thickness of the callout.
• **Up Arrow Callout** – changes the shape and thickness of the callout.
• **Left and Right Arrow Callout** – changes the shape and thickness of the callout.
• **Up and Down Arrow Callout** – changes the shape and thickness of the callout.
• **4-way Arrow Callout** – changes the shape and thickness of the callout.
• **Up and Right Arrow Callout** – changes the shape and thickness of the callout.

**Callout Shapes**
All Callouts use shape adjustment dots to change the length, position and angle of the pointer.

**Stars and Banners**
The Stars and Banners with shape adjustment dots are as follows:

• **4-Point Star** – changes the thickness and shape of the star points.
• **8-Point Star** – changes the thickness and shape of the star points.
• **24-Point Star** – changes the thickness and shape of the star points.
• **Vertical Scroll** – changes the width and shape of the scroll.
• **Horizontal Scroll** – changes the width and shape of the scroll.
• **Doorplate** – changes the inward curvature of the corners.
## Drawing curves, polygons and freeform lines

Curves, polygons and lines on the Drawing toolbar have a triangle ▼ next to the icon. Clicking on this triangle ▼ opens a sub-toolbar giving access to several different types of curves, polygons and lines. The icons on the Drawing toolbar show the last tool used for each of these curves, polygons and lines. If a filled curve, filled polygon, or filled freeform line was selected, Impress draws the line connecting the last point to the start point and fills the inside area with the default fill color.

### Curves

1. Click the triangle ▼ next to Curves and Polygons on the Drawing toolbar to open the Curves and Polygons sub-toolbar.
2. Select either Curve or Curve Filled.
3. Place the cursor on the slide, then click and drag to create the starting point of a curve.
4. Release the cursor and drag the cursor to draw a curve on the slide, bending the line into a curve.
5. Click to set the end point of the curve and fix the curve on the slide.
6. Drag the cursor to continue drawing a straight line. Each click sets a corner point and allows drawing of another straight line from the corner point.
7. Double-click to end the drawing of the curve. If Curve Filled was selected, Impress automatically fills the curve with the default fill color.

**Note**

Holding down the Shift key when drawing lines with the curve or polygon tools restricts the angles between lines to 45 or 90 degrees.

### Polygons and Polygons 45°

1. Click the triangle ▼ next to Curves and Polygons on the Drawing toolbar to open the Curves and Polygons sub-toolbar.
2. Select either Polygon, Polygon Filled, Polygon (45°) or Polygon Filled (45°).
3. Place the cursor on the slide, then click and drag to draw the first line from the start point. Release the cursor and a line between the first and second points is drawn.
4. Move the cursor to draw the next line. Each click sets a corner point and allows drawing of another line.
5. Double-click to end the drawing of a polygon. If Polygon Filled or Polygon Filled (45°) was selected, Impress automatically fills the polygon with the default fill color.

**Note**

If Polygon (45°) or Polygon Filled (45°) were selected, the movement of the cursor and the angles between lines is restricted to increments of 45°.

### Freeform lines

Using Freeform Line or Freeform Line Filled tools is similar to drawing with a pencil on paper.

1. Click the triangle ▼ next to Curves and Polygons on the Drawing toolbar to open the Curves and Polygons sub-toolbar.
2. Select either Freeform Line or Freeform Line Filled.
3. Click and drag the cursor to the line shape required.
4) When finished drawing a freeform line, release the cursor and the drawing is completed. If Freeform Line Filled was selected, Impress automatically fills the drawing between the start and end points with the default fill color.

**Drawing lines and arrows**

*Straight lines*

A straight line is the simplest element or object in Impress to create.

1) Use one of the following methods to draw a line:
   - Click **Insert Line** in the Drawing toolbar.
   - Click the triangle ▼ on the right of **Lines and Arrows** on the Drawing toolbar and select **Insert Line** from the Lines and Arrows sub-toolbar.

2) Click at the start position for the line and drag the cursor.

3) Release the cursor at the end position of the line. A selection handle appears at each end of the line. The selection handle at the starting point of the line is slightly larger than the end selection handle, as shown in Figure 135.

4) Keep the *Ctrl* key (macOS *⌘*) pressed while drawing a line to enable the end of the line to snap to the nearest grid point.

5) Keep the *Shift* key pressed while drawing a line to restrict the drawing angle of a line to multiple of 45 degrees.

6) Keep the *Alt* key (macOS *⌥*) pressed while drawing a line to cause the line to extend outwards symmetrically in both directions from the start point. This draws lines by starting from the middle of the line.

![Figure 135: Line starting point](image)

**Note**

If the *Snap to Grid* option in **Tools > Options > LibreOffice Impress > Grid** (macOS **LibreOffice > Preferences > LibreOffice Impress > Grid**) has been selected, pressing and holding the *Ctrl* key (macOS *⌘*) prevents the line or arrow snapping to the nearest grid point.

*Arrows*

Arrows are drawn like lines and are classified as a subgroup of lines, that is lines with arrowheads. Hovering the cursor over each type of arrow that is available shows the type of endings each tool will draw.
1) Click the triangle ▼ on the right of **Lines and Arrows** on the Drawing toolbar and select the type of arrow from the Lines and Arrows sub-toolbar.

2) Click at the starting position for drawing the arrow, then drag the cursor. The arrowhead(s) is drawn at the end of the line when the cursor is released.

3) Keep the Ctrl key (macOS ⌘) pressed while drawing an arrow to enable the end of the arrow to snap to the nearest grid point.

4) Keep the Shift key pressed while drawing an arrow to restrict the drawing angle of an arrow to multiple of 45 degrees.

5) Keep the Alt key (macOS ⌥) pressed while drawing an arrow to cause the arrow to extend outwards symmetrically in both directions from the start point. This draws arrows by starting from the middle of the arrow.

**Grouping objects**

Grouping of objects is similar to putting objects into a container. Objects within a group are moved together as one object and any changes made are applied globally to the objects within the group. A group can always be undone and the objects that make up the group can always be manipulated separately.

This section gives only a brief introduction to grouping of objects. An example of grouping two objects together is shown in Figure 136. For more information on working with grouped objects, see the *Draw Guide*.

**Temporary grouping**

Temporary grouping is when several objects are selected. Any changes to the objects are applied to all of the objects within the temporary group. For example, a temporary group of objects can be rotated in its entirety.

A temporary group is created using one of the following methods:

- Hold down the Shift key whilst clicking multiple objects on a slide.
- Click and drag the cursor to create a marquee around multiple objects. Release the cursor and all the objects within the marquee are selected.

To cancel a temporary grouping of objects, simply click outside of the selection handles displayed around the objects.

*Figure 136: Example of grouping objects*
**Grouping**

To group objects together permanently:

1) Objects are grouped together using one of the following methods:
   - Hold down the *Shift* key whilst clicking multiple objects on a slide.
   - Click and drag the cursor to create a marquee around multiple objects. Release the cursor and all the objects within the marquee are selected.
   - To select all the objects on the slide, go to *Edit > Select All* on the Menu bar or use the keyboard shortcut *Ctrl+A* (macOS *⌘A*).

2) With selection handles displayed, use one of the following methods to create a group of selected objects:
   - Go to *Format > Group > Group* on the Menu bar.
   - Use the keyboard shortcut *Ctrl+Shift+G* (macOS *⌘ Shift+G*).
   - Right-click on an object within the selected group and select *Group* from the context menu.

**Editing or formatting groups**

1) Click on an object in the group to select the group. Any editing or formatting can then be carried out on all the objects within the group or on individual objects within the group.

2) To edit an individual object within a group, enter the group using one of the following methods:
   - Use the keyboard shortcut *F3*.
   - Go to *Format > Group > Enter Group* on the Menu bar.
   - Right-click and select *Enter Group* from the context menu.

3) Select individual objects within the group for editing or formatting. An example of editing individual objects in a group is shown in Figure 137.

4) When editing or formatting is completed, use one of the following methods to exit the group and the whole group then becomes selected:
   - Use the keyboard shortcut *Ctrl+F3* (macOS *⌘F3*).
   - Go to *Format > Group > Exit Group* on the Menu bar.
   - Right-click and select *Exit Group* from the context menu.

![Figure 137: Example of editing inside a group](image)
Ungrouping

1) Click on any one of the objects in the group to select the group.
2) With selection handles displayed, use one of the following methods to ungroup a group of objects:
   - Go to Format > Group > Ungroup on the Menu bar.
   - Use the keyboard shortcut Ctrl+Alt+Shift+G (macOS ⌘+⌥+Shift+G).
   - Right-click on the group and select Ungroup from the context menu.

Tip

If group and ungroup commands are regularly used, or any other command, commands can be added to a toolbar so that they are readily available. See Chapter 11, Setting Up and Customizing Impress and the Getting Started Guide for more information on customizing the user interface.

Positioning and resizing graphic objects

Using the cursor

Positioning

For quick positioning of an object on a slide, use the cursor as follows:

1) Click on an object or a group of objects to display the selection handles.
2) Move the cursor over a selected graphic object until the cursor changes shape. The cursor shape depends on the computer setup and the computer operating system.
3) Click and drag the object to the desired position. During movement, a ghost image of the object appears to help with repositioning (Figure 138).
4) Release the cursor when the object is in the desired position.

![Figure 138: Example of moving objects](image)

Note

The arrow keys can also be used to quickly move a selected object or group to a new position.
**Resizing**
For quick positioning of an object on a slide, use the cursor as follow:

1) Click on an object or a group of objects to display the selection handles.
2) Move the cursor over a selection handle.
3) Click and drag the selection handle to resize the graphic object. During resizing, a ghost image of the object appears to help with resizing (Figure 139).
4) To maintain the width to height ratio, hold down the *Shift* key before clicking and dragging on a selection handle. Remember to release the cursor before releasing the *Shift* key.
5) Release the cursor when the object is at the desired size.

**Position and Size dialog**

**Positioning**
For a more accurate placement of a graphic object on a slide, use the Position and Size dialog (Figure 140) as follows:

1) Select an object to display the selection handles, then open the Position and Size dialog using one of the following methods:
   – Use the keyboard shortcut *F4*.
   – Go to **Format > Object and Shape > Position and Size** on the Menu bar.
   – Right-click on the selected object and select **Position and Size** from the context menu.
   – Click on **More Options** on the right of the title bar for the **Position and Size** panel in the Properties deck on the Sidebar.
2) Click on the **Position and Size** tab to open the **Position and Size** page.
3) In the **Position** section, specify *Position X* (horizontal) and *Position Y* (vertical) position of the object. The values represent the distance from the *Base point* selected on the right hand side of the dialog. The default selection for *Base point* is relative to the top left corner of the slide.
4) If necessary, in the **Protect** section of the dialog, select the *Position* option to prevent the object from being repositioned.
5) Click **OK** to save the changes and to close the dialog.
Note

The units of measurement used in this dialog and other Impress dialogs are set in Tools > Options > LibreOffice Impress > General (macOS LibreOffice > Preferences > LibreOffice Impress > General).

Resizing

1) Select an object to display the selection handles, then open the Position and Size dialog using one of the following methods:
   - Use the keyboard shortcut F4.
   - Go to Format > Object and Shape > Position and Size on the Menu bar.
   - Right-click on the selected object and select Position and Size from the context menu.
   - Click on More Options on the right of the title bar for the Position and Size panel in the Properties deck on the Sidebar.

2) Click on the Position and Size tab to open the Position and Size page.

3) In Size, select a Base point that to use as an anchor when resizing the object. The default selection of top left corner means that the top left corner of the object will not change position when resizing.

4) To maintain the proportions between width and height, in the Size section select the Keep ratio option before changing the Width or Height. When Keep ratio is selected, changes to one dimension results in an automatic change to the other dimension maintaining the ratio between object width and height.

5) In the Size section, specify the Width and Height of the object.
6) If necessary, in the **Protect** section of the dialog, select the **Size** option to prevent the object from being resized.

7) Click **OK** to save the changes and to close the dialog.

**Sidebar Position and Size panel**

*Positioning*

Use the **Position and Size** panel in the Properties deck on the Sidebar (Figure 141) to position a graphic object as follows:

1) Select an object to display the selection handles.

2) Click on **Properties** in the Sidebar to open the Properties deck.

3) Click on **Position and Size** to open the panel.

4) Specify **Position X** (horizontal) and **Position Y** (vertical) position of the object. The values represent the distance from the **Base point** that has been selected in the Position and Size dialog.

5) Press the **Enter** key to make the changes.

![Figure 141: Position and Size panel in Properties deck on Sidebar](image-url)
**Resizing**

Use the **Position and Size** panel in the Properties deck on the Sidebar to resize an object as follows:

1) Select an object to display the selection handles.
2) Click on **Properties** in the Sidebar to open the Properties deck.
3) Click on **Position and Size** to open the panel.
4) To maintain the proportions between width and height, select the *Keep ratio* option before changing the *Width* or *Height*. When *Keep ratio* is selected, changes to one dimension results in an automatic change to the other maintaining the ratio between object width and height.
5) Press the *Enter* key to make the changes.

**Applying special effects**

As well as the basic actions of moving and resizing an object, a number of special effects can also be applied to objects in Impress. This section describes how to rotate, flip, and distort an object.

**Rotating graphic objects**

**Cursor rotation**

1) Select an object to display the selection handles.
2) On the Line and Filling toolbar, click on the triangle ▼ next to **Transformations** then click on **Rotate** on the Transformations sub-toolbar. The selection handles change shape and color as shown in Figure 142. A pivot point indicating the rotation center also appears in the center of the object.
3) Move the cursor over one of the corner handles and the cursor changes shape indicating the movement direction.
4) Click on a corner selection handle and move in the direction required to rotate the object. Only the corner selection handles are active for rotation.
5) When satisfied with the rotation, release the cursor.
6) To change the rotation center of the object, click and drag the pivot point to the desired position before rotating. The pivot point can be moved to any position on the slide, even outside of the object boundaries.

![Figure 142: Example of rotating objects](image)

7) To restrict the rotation angles to multiples of 15 degrees, press and hold the *Shift* key while rotating the object. This is useful for rotating pictures through a right angle, for
example from portrait to landscape. Remember to release the Shift key before releasing the cursor.

**Position and Size dialog rotation**

Instead of rotating an object manually, use the Rotation page of the Position and Size dialog (Figure 143) to accurately rotate an object.

1) Select an object to display the selection handles, then open the Position and Size dialog using one of the following methods:
   - Use the keyboard shortcut F4.
   - Go to Format > Object and Shape > Position and Size on the Menu bar.
   - Right-click on the selected object and select Position and Size from the context menu.
   - Click on More Options on the right of the title bar for the Position and Size panel in the Properties deck on the Sidebar.

2) Click on the Rotation tab to open the Rotation page.

3) If necessary, in Pivot Point enter a measurement for Position X and Position Y to move the position of the pivot point. The default position of the pivot point is the center of the object. Alternatively, select a pivot point from one of the 9 positions in Default settings.

4) In Rotation Angle, enter the degree amount for rotation in the Angle text box. Alternatively, in Default settings, click on the rotation angle indicator and drag it to a new angle. The angle of rotation is displayed in the Angle text box.

5) Click OK to save the changes and to close the dialog.

**Sidebar rotation**

Use the Position and Size panel in the Properties deck on the Sidebar to rotate an object as follows:

1) Select an object to display the selection handles.

   ![Position and Size dialog - Rotation page](image)

   *Figure 143: Position and Size dialog - Rotation page*

2) Click on Properties in the Sidebar to open the Properties deck.
3) Click on **Position and Size** to open the panel.

4) In **Rotation**, enter the degree amount for rotation in the text box or click on the rotation angle indicator and drag it to a new angle. The angle of rotation is displayed in the **Rotation** text box.

5) Press the **Enter** key to make the changes.

**Flipping objects**

**Quick flipping**

1) Click on an object to display the selection handles.

2) Quickly flip a selected object so it faces the other direction using one of the following methods:
   - Right-click on the selected object and select **Flip > Vertically** or **Horizontally** from the context menu.
   - Click on **Vertically** or **Horizontally** flip tool on the Standard toolbar.
   - Go to **Format > Flip > Vertically** or **Horizontally** on the Menu bar.
   - Click on **Flip Vertically** or **Flip Horizontally** in the **Position and Size** panel on the Properties deck of the Sidebar.

**Flip tool**

To change the position and angle that an object flips over, the **Flip** tool on the Transformations toolbar (Figure 144) is used as shown by the example in Figure 145.

1) Click on an object to display the selection handles.

2) Go to **View > Toolbars > Transformations** to open the Transformations toolbar.

3) Click on **Flip** on the Transformations toolbar and a symmetry axis appears as a dashed line through the center of the object. The object is flipped about this axis of symmetry.

4) Click and drag the symmetry axis to a new position, or position the cursor in one of the circles at each end of the symmetry axis and drag with the cursor to change the angle.

---

Figure 144: Transformations toolbar

**Figure 145: Example of using the Flip tool**
5) Place the cursor over one of the selection handles for the object.
6) Click and drag the cursor across the symmetry axis to flip the object. The new position of the object is shown faintly until the cursor is released.
7) Release the cursor and the object appears flipped over. Angle and position of the flip depends on the angle and position of the symmetry axis.

**Note**
Press and hold the `Shift` key while moving the symmetry axis to rotate it in 45-degree increments.

**Mirror copies**
Impress does not include a mirror command. However, mirroring an object can be emulated by flipping the object:

1) Select the object to make a mirror copy and copy the object to the clipboard.
2) Flip the object using one of the methods in “Quick flipping” on page 176, then move the flipped object to one side.
3) Click in an empty area of the slide to deselect the object.
4) Paste the copied object from the clipboard into the slide.
5) Select both objects, then right-click and select **Alignment** from the context menu.
6) Select the type of alignment required. **Top**, **Center**, or **Bottom** if a horizontal mirror copy is being created. **Left**, **Centered**, or **Right** if a vertical mirror copy is being created.

**Distorting images**
Three tools on the Transformations toolbar allow an object to be distorted.

- **Distort** – distorts an object in perspective.
- **Set to circle (slant)** and **Set in Circle (perspective)** – both create a pseudo 3D effect.

**Note**
When using these tools, an object has to be converted to a curve before distorting. Converting an object into a curve cannot be reversed and can only be undone by using the **Undo** function.

**Distort tool**
Examples of distorting an object with the **Distort** tool are shown in Figure 146.

1) Select an object and click on **Distort** on the Transformations toolbar.
2) Click **Yes** to convert the object to a curve. If the object is already a curve, this dialog does not appear.
3) Click and drag a corner selection handle to distort the object using the opposite corner selection handle as an anchor point for the distortion.
4) Click and drag the vertical selection handles to distort the object using the opposite vertical side as an anchor point for the distortion.
5) Click and drag the horizontal selection handles to distort the object using the opposite horizontal side as an anchor point for the distortion.
Set in Circle (perspective) tool
Examples of distorting an object with the Set in Circle (perspective) tool are shown in Figure 147.

1) Select an object and click on the Set in Circle (perspective) in the Transformations toolbar.
2) Click Yes to convert the object to a curve. If the object is already a curve, this dialog does not appear.
3) Click and drag one of the selection handles to give a pseudo 3D perspective using the opposite side as an anchor point. A ghosted image appears as the object is distorted to give an indication of how the resulting object will look.

Set to circle (slant) tool
Examples of distorting an object with the Set to circle (slant) tool are shown in Figure 148.

1) Select an object and click on the Set to circle (slant) in the Transformations toolbar.
2) Click Yes to convert the object to a curve. If the object is already a curve, this dialog does not appear.
3) Click and drag one of the selection handles to give a pseudo 3D perspective using the opposite side as an anchor point. A ghosted image appears as the object is distorted to give an indication of how the resulting object will look.
Aligning objects

Use the alignment tools in LibreOffice to adjust the relative position of an object compared to another object. These alignment tools are only active if two or more objects are selected. The alignment options are as follows:

- **Left, Centered, Right** – determines the horizontal alignment of selected objects.
- **Top, Center, Bottom** – determines the vertical alignment of selected objects.

Select the objects for alignment and use one of the following methods to access the align options:

- Click on the triangle ▼ next to **Align Objects** on the Line and Filling toolbar. Select an alignment option from the tools available. The **Align Objects** icon shown on the Line and Filling toolbar depends on the last tool used.
- Go to **View > Toolbars > Align Objects** on the Menu bar to open the Align Objects toolbar. Select an alignment option from the tools available.
- Right-click on the group of selected objects and select **Align Objects** and then one of the alignment options from the context menu.

Using grid or snap functions

In Impress, objects can be positioned accurately and consistently using grid points, snap points and lines, object frames, individual points on objects, or page edges. This function is known as Snap. It allows positioning of an object in exactly the same place on multiple slides.

It is easier to use snap functions at the highest practical zoom value for a presentation. Two different snap functions can be used at the same time. For example, snapping to a guide line and the slide edge. It is recommended to activate only those snap functions that are really required.

Configuring grid and snap

To configure the grid and snap in a presentation, go to **Tools > Options > LibreOffice Impress > Grid** (macOS **LibreOffice > Preferences > LibreOffice Impress > Grid**) on the Menu bar to display the Grid dialog (Figure 149).

- **Grid** – specifies the settings for the grid used in Impress. This grid helps to determine the exact position of objects. Also, the grid can be set in line with the snap grid. If the snap grid is activated, to move or create individual objects without snapping to the grid, keep the **Shift** key pressed to deactivate this function for as long as necessary.
  - **Snap to grid** – specifies whether to move frames, drawing elements, and controls only between grid points. To change the status of **Snap to grid** only for the current action, drag an object while holding down the **Ctrl** key (macOS ⌘).
  - **Visible grid** – specifies whether to display the grid.
- **Resolution**
  - **Horizontal** – defines the unit of measure for the spacing between grid points on the X-axis.
  - **Vertical** – defines the grid points spacing in the desired unit of measurement on the Y-axis.
- **Subdivision**
  - **Horizontal** – specify the number of intermediate spaces between grid points on the X-axis.
Figure 149: Options LibreOffice Impress Grid dialog

Figure 150: Options toolbar

- **Vertical** – specify the number of intermediate spaces between grid points on the Y-axis.
- **Synchronize axes** – specifies whether to change the current grid settings symmetrically. The resolution and subdivision for the X and Y axes remain the same.

- **Snap**
  - **To snap lines** – snaps the edge of a dragged object to the nearest snap line when the cursor is released. Also, this setting can be defined by using **Snap to Snap Guides** on the Options toolbar (Figure 150).
  - **To the page margins** – specifies whether to align the contour of the graphic object to the nearest page margin. The cursor or a contour line of the object must be in the snap range. In a presentation, this function can also be accessed with **Snap to page Margins** in the Options toolbar.
  - **To object frame** – specifies whether to align the contour of the object to the border of the nearest object. The cursor or a contour line of the object must be in the snap range. In a presentation, this function can also be accessed with **Snap to Object Border** in the Options toolbar.
  - **To object points** – specifies whether to align the contour of the object to the points of the nearest object. This only applies if the cursor or a contour line of the object is in the snap range. In a presentation, this function can also be accessed with **Snap to Object Points** in the Options toolbar.
  - **Snap range** – defines the snap distance between the cursor and the object contour. Snaps to a snap point if the cursor is closer than the distance selected.

- **Constrain Objects**
  - **When creating or moving objects** – specifies that objects are restricted vertically, horizontally or diagonally (45°) when creating or moving them. This setting can be temporarily deactivated by pressing and holding the **Shift** key.
– **Extend edges** – specifies that a square is created based on the longer side of a rectangle when the Shift key is pressed before releasing the cursor. This also applies to an ellipse (a circle will be created based on the longest diameter of the ellipse). When Extend edges is not selected, a square or a circle is created based on the shorter side or diameter.

– **When rotating** – specifies that objects can only be rotated within the rotation angle that is selected. To rotate an object outside the defined angle, press the Shift key when rotating. Release the Shift key when the desired rotation angle is reached.

– **Point reduction** – defines the angle for point reduction. When working with polygons, this is useful in reducing the editing points.

The grid and snap functions can also be displayed and switched on or off using one of the following methods:

- Go to **Tools > Options > LibreOffice Impress > Grid** (macOS LibreOffice > Preferences > LibreOffice Impress > Grid) on the Menu bar to display the Grid dialog.
- Right-clicking on a slide and using the options in the context menu.
- Using the tools in the Options toolbar.

**Snap to grid**

**Using Snap to Grid**

Use the Snap to Grid function to move an object exactly onto a grid point in a slide. This function can be switched on and off using one of the following methods:

- Go to **View > Snap Guides > Snap to Grid** on the Menu bar.
- Right-click on a slide and selecting **Snap Guides > Snap to Grid** from the context menu.
- Click on **Snap to Grid** on the Options toolbar.

**Displaying grid**

To display or turn off the grid in a presentation using one of the following methods:

- Go to **View > Grid and Helplines > Display Grid** on the Menu bar.
- Click on **Display Grid** on the Options toolbar.
- Right-click on a slide and select **Grid and Helplines > Display Grid** from the context menu.
- Select **Visible grid** option in **Tools > Options > LibreOffice Impress > Grid** (macOS LibreOffice > Preferences > LibreOffice Impress > Grid).

**Changing color of grid points**

By default and depending on the display and computer setup, the grid points are gray and are not always easy to see. To change the color of the grid points, go to **Tools > Options > LibreOffice > Application Colors** (macOS LibreOffice > Preferences > LibreOffice > Application Colors) to open the Options LibreOffice Application Colors dialog (Figure 151). In the Drawing/Presentation section, select a more suitable color for the grid from the drop-down list to make the grid points more prominent against the color scheme being used.

**Snap points and lines**

Unlike the grid, snap lines and snap points are inserted when positioning an object to a specific position on a slide. Snap lines can either be horizontal or vertical and appear as dashed lines. Snap points appear as small crosses with dashed lines. Snap points and snap lines do not appear in printed output.
Inserting snap points and lines

To insert a snap point or line use one of the following methods to open the New Snap Object dialog (Figure 152):

- Go to **Insert > Snap Guide** on the Menu bar.
- Right-click in an empty space on a slide and select Insert Snap Guide from the context menu.

The options available in the New Snap Object dialog are as follows:

- **Position** – sets the position of a selected snap point or line relative to the top left corner of the page.
  - **X:** enter the amount of space required between the snap point or line and the left edge of the page.
– Y: enter the amount of space required between the snap point or line and the top edge of the page.

• **Type** – specifies the type of snap object required.
  – **Point** – inserts a snap point. Both X and Y text boxes are active.
  – **Vertical** – inserts a vertical snap line. Only X text box is active.
  – **Horizontal** – inserts a horizontal snap line. Only Y text box is active.

**Tip**

When positioning snap lines, it is useful to display the rulers by selecting **View > Rulers** on the Menu bar. Click on the horizontal or vertical ruler and drag a snap line onto the slide.

**Displaying snap points and lines**

Display or turn off snap points and lines in a presentation using one of the following methods:

- Go to **View > Snap Guides > Display Snap Guides** on the Menu bar.
- Click on **Display Snap Guides** on the Options toolbar.
- Right-click on a slide and select **Snap Guides > Display Snap Guides** from the context menu.

**Editing snap points**

1) Right-click on a snap point and select **Edit Snap Point** from the context menu to open the Edit Snap Point dialog (Figure 153).
2) Enter new X: and Y: coordinate settings for the snap point and click **OK**. Alternatively, drag the snap point to a new position on the slide.

*Figure 153: Edit Snap Point dialog*

*Figure 154: Edit Snap Line dialog*
Editing snap lines

1) Right-click on a snap line and select **Edit Snap Line** from the context menu to open the Edit Snap Line dialog (Figure 154).

2) Enter a new $X$: coordinate setting for vertical snap lines or a new $Y$: coordinate setting for horizontal snap lines and click **OK**. Alternatively, drag a snap line to a new position on the slide.

Deleting snap points and lines

1) Right-click on a snap point or line.

2) Select **Delete Snap Point** or **Delete Snap Line** from the context menu.

**Note**

Clicking on **Delete** in the Edit Snap Point or Edit Snap Line dialog also deletes a snap point or snap line.

Configuring snap range

To configure the snap range of when an object snaps to a position.

1) Go to **Tools > Options > LibreOffice Impress > Grid** (macOS **LibreOffice > Preferences > LibreOffice Impress > Grid**) on the Menu bar to open the Options LibreOffice Impress Grid dialog.

2) Enter the number of pixels to set the proximity of when the object snaps into position in the **Snap range** text box. The default setting is 5 pixels.

3) Click **OK** to set the new snap range and close the dialog.

Using Helplines

Helplines are a function in Impress to help position objects and can be displayed while an object is being moved. They extend from the edges of the object to the rulers at the top and left side of a workspace and do not have a snap function (Figure 155).

![Figure 155: Example of using helplines](image-url)
Use one of the following methods to display helplines while moving an object:

- Go to Tools > Options > LibreOffice Impress > View (macOS LibreOffice > Preferences > LibreOffice Impress > View) to open the Options LibreOffice Impress View dialog (Figure 156) on the Menu bar and select Helplines while moving.
- Click on Helplines While Moving on the Options toolbar.
- Right-click in an empty area on a slide and select Grid and Helplines > Helplines While Moving from the context menu.

**Arranging objects**

Impress organizes objects in a stack so that the objects on the top level of the stack cover the objects on lower levels, if any overlapping occurs. The stack level of each object can be changed by arranging shapes on a slide. Select an object or objects and use one of the following methods to change the stack level:

- Click on the required arrange tool on the Line and Filling toolbar.
- Right-click on selected objects and select Arrange, then select the required arrange option from the context menu.
- Go to Format > Arrange on the Menu bar and select an option from the submenu.

The options available for arranging the object stack level on a slide are as follow:

- **Bring to Front** (Ctrl+Shift++) (macOS ⌘+Shift++) – the selected object is moved in front of all other objects.
- **Bring Forward** (Ctrl++) (macOS ⌘++) – the selected object is moved one level up in the stack.
- **Send Backward** (Ctrl+-) (macOS ⌘+-) – the selected object is moved one level down in the stack.
- **Send to Back** (Ctrl+Shift+-) (macOS ⌘+Shift+-) – the selected object is moved behind all other objects.
- **In Front of Object** – moves the first selected object in front of the second selected object. Select the first object, then click on the second object and the objects swap position.
• **Behind Object** – moves the first selected object behind the second selected object. Select the first object, then click on the second object and the objects swap position.

• **Reverse** – swaps the stacking order of two selected objects.

## Connectors and glue points

Connectors are lines that can be anchored to glue points and by default are positioned on the border of an object. When an object with a connector attached is moved or resized, the connector automatically adjusts to the change. When creating a flowchart, organization chart, schematics, or diagrams, it is highly recommended to use connectors instead of simple lines.

### Connectors

When a connector is drawn or selected, Impress displays selection handles that are different to the selection handles for normal lines. The termination points of a connector are round at each end of a connector. The square selection handles on a connector line are used to change the routing of a connector where applicable.

Impress offers a wide variety of predefined connectors, which differ in the termination shape (none, arrow, circle) and in the way the connector is drawn (straight, line, curved). A full list of available connector types is shown below. The connector types that are installed on the Connectors sub-toolbar (Figure 157) are normally indicated by a check mark or highlighting, depending on the computer operating system and setup.

#### Figure 157: Connectors sub-toolbar

**Available connector types numbered left to right**

<table>
<thead>
<tr>
<th>Connector Ends with Arrow</th>
<th>Curved Connector with Arrows</th>
</tr>
</thead>
<tbody>
<tr>
<td>Straight Connector Ends with Arrow</td>
<td>Line Connector with Arrows</td>
</tr>
<tr>
<td>Curved Connector Ends with Arrow</td>
<td>Connector Starts with Arrow</td>
</tr>
<tr>
<td>Line Connector Ends with Arrow</td>
<td>Straight Connector Starts with Arrow</td>
</tr>
<tr>
<td>Connector</td>
<td>Curved Connector Starts with Arrow</td>
</tr>
<tr>
<td>Straight Connector</td>
<td>Line Connector Starts with Arrow</td>
</tr>
<tr>
<td>Curved Connector</td>
<td>Connector Ends with Circle</td>
</tr>
<tr>
<td>Line Connector</td>
<td>Straight Connector Ends with Circle</td>
</tr>
<tr>
<td>Connector with Arrows</td>
<td>Line Connector Ends with Circle</td>
</tr>
<tr>
<td>Straight Connector with Arrows</td>
<td>Curved Connector with Circles</td>
</tr>
</tbody>
</table>

### Drawing connectors

1) Click on the triangle ▼ next to Connectors on the Drawing toolbar to open the Connectors sub-toolbar (Figure 157). The Connectors icon shown on the Drawing toolbar depends on the last connector that had been previously used.

2) Select the type of connector required from the Connectors sub-toolbar.

3) Move the cursor over one of the objects to be connected and small crosses appear around the object edges, normally in the same position as selection handles. These crosses are glue points to which a connector attaches, as shown in Figure 158.
Figure 158: Example of connector glue points

Figure 159: Example of connectors between objects

4) Click on the required glue point to attach one end of the connector, then click, hold and drag the connector to another object.

5) When the cursor is over the glue point of the target object release the cursor and the connector is drawn.

6) The selection handles that appear on the connector are used to adjust the path of the connector so that the connector can be adjusted not to cover another object in its path, as shown by the example in Figure 159.

Connector types
The full range of predefined connectors can be accessed by clicking on the triangle ▼ on the title bar of the Connectors sub-toolbar and selecting Visible Buttons.

Connectors fall into four type groups as follows:

- **Standard** – connector name starts with Connector. Line segments run vertically and horizontally creating a connector with one or more 90-degree angle bends.

- **Line** – connector name starts with Line. Consists of a line segment with two smaller segments at the ends and creates a connector that bends near a glue point. To adjust the length of the line segment between a bend point and a glue point, click the connector and drag the bend point.
• **Straight** – connector name starts with *Straight*. Consists of a single line and draws a straight line connector.

• **Curved** – connector name starts with *Curved*. Based on Bézier curves and curves around objects, creating a curved line connector.

**Formatting connectors**

To detach or reposition a connector, click on a round selection handle at either end of the connector and drag to a different location, as shown in Figure 159.

To change the connector route between objects avoiding any objects on the route, click on a square control handle on the connector line and drag it to a new position, as shown in Figure 159.

To change a connector type, right-click on the connector and select `Connector` from the context menu to open the Connector dialog (Figure 160). Use this dialog to select a connector type and change the connector properties.

- **Type** – select the connector type from the drop-down list.
- **Line skew** – defines the skew of the line and the dialog preview displays the result.
- **Line spacing** – sets the spacing for the connectors.
  - *Begin horizontal* – amount of horizontal space required at the beginning of the connector.
  - *Begin vertical* – amount of vertical space required at the beginning of the connector.
  - *End horizontal* – amount of horizontal space required at the end of the connector.
  - *End vertical* – amount of vertical space required at the end of the connector.
- **Preview window** – a left click zooms in on the preview and a right-click zooms out.

*Figure 160: Connector dialog*
Note

The ends of the connector cannot be swapped, that is start point cannot become the end point and the end point cannot become the start point. To swap the ends of a connector, a new connector has to be created in the opposite direction.

Glue points

Glue points are not the same as the selection handles of an object. The selection handles are for moving or changing the shape of an object. Glue points are used to fix or glue a connector to an object so that when the object moves, the connector stays fixed to that object.

All objects have glue points, which are not normally displayed and only become visible when Connectors on the Drawing toolbar is selected. Note that the Connectors icon changes shape depending on the last connector tool used.

To insert, customize or delete glue points on an object, open the Glue Points toolbar (Figure 161) using one of the following methods:

- Go to View > Toolbars > Glue Points on the Menu bar.
- Go to Edit > Glue Points on the Menu bar.
- Click on Show Glue Point Functions on the Drawing toolbar.

![Glue Points toolbar](Figure 161: Glue Points toolbar)

Glue point types

When the Glue Points toolbar opens, only the six tools on the left of the toolbar are active. The remaining six tools on the right of the toolbar only become active when Glue Point Relative is deselected.

The six tools on the left of the Glue Points toolbar are as follows:

- **Insert Glue Point** – inserts a glue point when clicking twice on an object. See “Inserting glue points” on page 190 for more information.
- **Exit Direction Left** – connector attaches to the left edge of the selected glue point.
- **Exit Direction Top** – connector attaches to the top edge of the selected glue point.
- **Exit Direction Right** – connector attaches to the right edge of the selected glue point.
- **Exit Direction Bottom** – connector attaches to the bottom edge of the selected glue point.
- **Glue Point Relative** – maintains the relative position of a selected glue point to an object when that object is resized. This tool is selected by default when the Glue Point toolbar opens.

The six tools on the right of the Glue Points toolbar only become active when Glue Point Relative is deselected.

- **Glue Point Horizontal Left** – when applied to a glue point in an object and the object is resized, the horizontal position of the glue point remains fixed at the same distance from the left edge of the object. The vertical position of the glue point changes with the resizing of the object.
- **Glue Point Horizontal Center** – when applied to a glue point in an object and the object is resized, the horizontal position of the glue point remains fixed at the same distance.
from the horizontal center of the object. The vertical position of the glue point changes with the resizing of the object.

- **Glue Point Horizontal Right** – when applied to a glue point in an object and the object is resized, the horizontal position of the glue point remains fixed at the same distance from the right edge of the object. The vertical position of the glue point changes with the resizing of the object.

- **Glue Point Vertical Top** – when applied to a glue point in an object and the object is resized, the vertical position of the glue point remains fixed at the same distance from the top edge of the object. The horizontal position of the glue point changes with the resizing of the object.

- **Glue Point Vertical Center** – when applied to a glue point in an object and the object is resized, the vertical position of the glue point remains fixed at the same distance from the vertical center of the object. The horizontal position of the glue point changes with the resizing of the object.

- **Glue Point Vertical Bottom** – when applied to a glue point in an object and the object is resized, the vertical position of the glue point remains fixed at the same distance from the bottom edge of the object. The horizontal position of the glue point changes with the resizing of the object.

**Note**

Glue points inserted into an object can only have one horizontal position and one vertical position. Only one horizontal position and/or one vertical position can be selected on the Glue Points toolbar and used to customize a glue point.

**Inserting glue points**

By default, most objects normally have four glue points. Insert additional glue points into an object as follows:

1) Make sure no objects are selected and use one of the following methods to open the Glue Points toolbar:
   - Go to **View > Toolbars > Glue Points** on the Menu bar.
   - Go to **Edit > Glue Points** on the Menu bar.
   - Click on **Show Glue Point Functions** on the Drawing toolbar.

2) Select the object, then click on **Insert Glue Point** on the Glue Points toolbar. Alternatively, right-click on a glue point previously inserted and select **Insert Glue Point** from the context menu.

3) Move the cursor to a position where the glue point is to be inserted into an object and click to insert the glue point.

4) To insert more glue points, move the cursor to a new position and click to insert another glue point.

5) With the glue point selected, select the type of glue point required from the options on the Glue Points toolbar.

6) To move a glue point to another position, click on the glue point and drag it to its new position.

7) When inserting glue points is complete, make sure **Insert Glue Point** on the Glue Points toolbar is deselected.
Tip

When inserting, moving or customizing glue points, it is recommended to use the zoom function to make it easier to work with glue points. Also, glue points snap to the grid making it easier to position a glue point.

Note

Only glue points that have been inserted onto an object can be customized or deleted. The default glue points included with an object cannot be customized or deleted.

Customizing glue point exit direction

1) Make sure no objects are selected and use one of the following methods to open the Glue Points toolbar:
   – Go to View > Toolbars > Glue Points on the Menu bar.
   – Go to Edit > Glue Points on the Menu bar.
   – Click on Show Glue Point Functions on the Drawing toolbar.
2) Double-click on a glue point that has been inserted to select the glue point for customization.
3) Select an exit direction for the connector from the options available on the Glue Points toolbar, or right-click on the glue point and select the exit direction from the context menu.
4) When customizing exit direction is complete, make sure Insert Glue Point on the Glue Points toolbar is deselected.

Customizing glue point position

1) Make sure no objects are selected and use one of the following methods to open the Glue Points toolbar:
   – Go to View > Toolbars > Glue Points on the Menu bar.
   – Go to Edit > Glue Points on the Menu bar.
   – Click on Show Glue Point Functions on the Drawing toolbar.
2) Double-click on a glue point that has been inserted to select the glue point for customization.
3) Click on Glue Point Relative on the Glue Points toolbar to deselect this tool, or right-click on the glue point and deselect Glue Point Relative from the context menu.
4) Select the horizontal and vertical positioning tools required for the glue point. Only one horizontal positioning tool and one vertical positioning tool can be used on a glue point at any one time.
5) When customizing glue point position is complete, make sure Insert Glue Point on the Glue Points toolbar is deselected.

Deleting glue points

1) Make sure no objects are selected and use one of the following methods to open the Glue Points toolbar:
   – Go to View > Toolbars > Glue Points on the Menu bar.
   – Go to Edit > Glue Points on the Menu bar.
   – Click on Show Glue Point Functions on the Drawing toolbar.
2) Select the glue point that has been previously inserted.
3) Press the *Delete* key, or *Backspace* key, or go to **Edit > Cut** on the Menu bar.

## Working with 3D objects

Although Impress offers advanced functions to manipulate 3D objects, this guide describes only the 3D settings applicable to an object. For additional information on how to use advanced 3D effects such as geometry and shading, refer to the *Draw Guide*.

3D objects can be created in Impress in any of the following ways:

- Click on the triangle ▼ next to **3D Objects** on the Drawing toolbar and select a 3D object from the drop-down list. After selection, draw a 3D object in exactly the same way as any other object. The icon shown on the Drawing toolbar depends on the 3D object that had been previously selected and used.

- Go to **View > Toolbars > 3D-Objects** on the Menu bar to open the 3D-Objects toolbar (Figure 162). This toolbar is the same as the 3D-Objects sub-toolbar that is available on the Drawing toolbar.

![3D-Objects toolbar](image)

*Figure 162: 3D Objects toolbar*

- Right-click on an object already drawn on a slide and select **Convert > To 3D** or **To 3D Rotation Object** from the context menu. **To 3D** adds thickness to the object to create a 3D object. **To 3D Rotation Object** creates a 3D object by rotating the object around an axis.

- Select an object and click on **Toggle Extrusion** on the Drawing toolbar to apply a basic 3D effect and open the 3D-Settings toolbar (Figure 163). Select one of the options on the 3D-Settings toolbar to apply a different 3D effect. The options available on the 3D-Settings toolbar are as follows:

![3D-Settings toolbar](image)

*Figure 163: 3D-Settings toolbar*

- **Toggle Extrusion** – adds thickness to an object and activates the 3D properties.
- **Tilt Down** – tilts the object downwards around a horizontal axis.
- **Tilt Up** – tilts the object up around a horizontal axis.
- **Tilt Left** – tilts the object left around a vertical axis.
- **Tilt Right** – tilts the object right around a vertical axis.
- **Depth** – determines the thickness of the shape. An extended toolbar opens where some default values are given. If none of the values are satisfactory, select **Custom** and then enter the desired thickness.
- **Direction** – clicking on the triangle ▼ next to **Direction** opens a sub-toolbar to select the direction of the perspective as well as the type (parallel or perspective).
- **Lighting** – clicking on the triangle ▼ next to **Lighting** opens a sub-toolbar to specify the direction and intensity of light.
- **Surface** – clicking on the triangle ▼ next to **Surface** opens a sub-toolbar to specify the type of surface from *Wire Frame* (useful when manipulating the object), *Matt*, *Plastic*, or *Metal*.
– **3D–Color** – clicking on the triangle ▼ next to **3D–Color** opens a color palette to select a color for object thickness when an object is extruded to 3D.

**Note**

Most of the Fontwork shapes (see “Fontwork” on page 195) have 3D properties and can be manipulated with the 3D-Settings toolbar.

**Converting objects**

Objects are converted into different types using one of the following methods:

- Right-click on the object and select **Convert** from the context menu, then select a conversion option from the context menu.
- Select an object and go to **Format > Convert** on the Menu bar and select a conversion option from the context menu.

The conversion options are as follows:

- **To Curve** – converts the selected object to a Bézier curve. Click on **Points** on the Drawing toolbar to edit the points after conversion to a Bézier curve.
- **To Polygon** – converts the selected object to a polygon. Click on **Points** on the Drawing toolbar to edit the object after conversion to a polygon. A polygon always consists of straight segments.
- **To Contour** – for basic shapes and is equivalent to converting to polygon. For more complex shapes (or for text objects) this conversion creates a group of polygons that can be manipulated by entering the group.
- **To 3–D** – converts the selected object to a 3D object.
- **To 3–D Rotation Object** – creates a three-dimensional shape by rotating the selected object around its vertical axis.
- **To Bitmap** – converts the selected object to a bitmap.
- **To Metafile** – converts the selected object to Windows Metafile Format (WMF), containing both bitmap and vector graphic data.

**Note**

In most cases the conversion to a different type does not immediately produce visible results.

**Tip**

**To Curve, To Polygon, To 3–D, and To 3–D Rotation Object** can be added to the Drawing toolbar as additional tools by right-clicking in an empty area on the toolbar and selecting **Visible Buttons**. See Appendix B, Toolbars for more information.

**Interaction with objects**

Associating an object to an action that is performed when the object is clicked is called an interaction.
1) Select an object for interaction and open the Interaction dialog (Figure 164) using one of the following methods:
   - Click on Interaction on the Line and Filling toolbar.
   - Right-click on the object and select Interaction from the context menu.
   - Go to Format > Interaction on the Menu bar.

2) Select the interaction from the available options in Action at mouse click and any parameters (if applicable) that maybe available. The Interaction dialog changes depending on the type of interaction selected. The interactions and parameters are explained in Table 4.

3) Click OK to save the changes and close the dialog.

4) To remove an interaction from an object follow Steps 1 and 2 and then select No action as the interaction type at Step 3.

Table 4: Interaction types and parameters

<table>
<thead>
<tr>
<th>Interaction</th>
<th>Parameters</th>
</tr>
</thead>
<tbody>
<tr>
<td>No action</td>
<td>No parameters.</td>
</tr>
<tr>
<td>Go to previous slide</td>
<td>No parameters.</td>
</tr>
<tr>
<td>Go to next slide</td>
<td>No parameters.</td>
</tr>
<tr>
<td>Go to first slide</td>
<td>No parameters.</td>
</tr>
<tr>
<td>Go to last slide</td>
<td>No parameters.</td>
</tr>
<tr>
<td>Go to page or object</td>
<td>Specify the target from the list in the Target box. Search for a specific target in the Slide/Object box at the bottom of the screen.</td>
</tr>
<tr>
<td>Go to document</td>
<td>Select the document in the Document box. Use Browse to open a file browser. If the document to be opened is in ODP format, the target list is populated allowing selection of the specific target.</td>
</tr>
<tr>
<td>Play sound</td>
<td>Select the file containing the sound to be played. Use Browse to open a file browser.</td>
</tr>
<tr>
<td>Interaction</td>
<td>Parameters</td>
</tr>
<tr>
<td>--------------</td>
<td>---------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Run program</td>
<td>Select the program to execute. Use <strong>Browse</strong> to open a file browser.</td>
</tr>
<tr>
<td>Run macro</td>
<td>Select a macro that runs during the presentation. Use <strong>Browse</strong> to open the Macro Selector dialog.</td>
</tr>
<tr>
<td>Exit presentation</td>
<td>When the cursor is clicked over the object, the presentation terminates.</td>
</tr>
</tbody>
</table>

**Fontwork**

With Fontwork, graphical text art objects can be created to make a presentation more attractive. There are many different settings for text art objects (line, area, position, size, and more) giving a large selection of effects. For more information about Fontwork, see the *Getting Started Guide*.

Fontwork is also available with the Writer, Calc, and Draw modules of LibreOffice, but there are small differences in the way that each module displays it.

**Creating Fontwork**

1) Click on **Fontwork** on the Standard toolbar or go to **Insert > Fontwork** on the Menu bar to open the Fontwork Gallery dialog (Figure 165).

2) Select a Fontwork style from the dialog and click **OK**. The selected Fontwork appears centrally on the slide and the dialog closes.

3) Double-click on the Fontwork text graphic to switch on editing mode.

4) Type in the required text to replace the default text in the Fontwork graphic and the text appears over the default text as shown by the example in Figure 166.

5) Press the **Esc** key or click outside the Fontwork graphic and the text replaces default text.
Figure 165: Fontwork Gallery dialog

Figure 166: Example of creating Fontwork

Figure 167: Fontwork toolbar
Fontwork toolbar

The Fontwork toolbar (Figure 167) becomes visible and active when a Fontwork object is selected. If the toolbar is not visible, go to View > Toolbars > Fontwork on the Menu bar. The Fontwork toolbar contains the following tools:

- **Insert Fontwork Text** – opens the Fontwork Gallery dialog.
- **Fontwork Shape** – changes the shape of the selected object. Clicking on the triangle ▼ next to Fontwork Shape opens the Fontwork Shape sub-toolbar (Figure 168) allowing selection of different Fontwork shapes.
- **Fontwork Same Letter Heights** – changes the height of characters in the selected Fontwork object. Toggles between normal height where the characters have different heights to where all characters have the same height.
- **Fontwork Alignment** – specifies the text alignment within the frame. Options available are **Left Align**, **Center**, **Right Align**, **Word Justify**, and **Stretch Justify**. The effects of the text alignment can only be seen if the text spans over two or more lines. In the Stretch Justify mode, all lines are filled completely.
- **Fontwork Character Spacing** – selects the spacing between characters and whether kerning pairs are used. Options available are **Very Tight**, **Tight**, **Normal**, **Loose**, **Very Loose** and **Custom Spacing**. For **Custom Spacing**, input a percentage value: 100% is normal character spacing, less than 100% character spacing is tighter, and more than 100% character spacing is looser.
- **Toggle Extrusion** – converts the Fontwork object into a 3D shape using extrusion. See the Draw Guide for more information.

Modifying Fontwork

It is possible to treat Fontwork text as an object and apply all the formatting that has been described in this chapter. Assign line properties only to Fontwork which does not have a 3D effect, otherwise the changes will not be visible. Also, modify some of the Fontwork shapes by moving the dot that is displayed along with the selection handles. This is similar to modification of the angles of trapezoid and parallelogram basic shapes.

Animations

Animated slide transitions can be added between slides to give presentations a more professional look when changing to the next slide (see Chapter 9, Slide Shows for more information on transitions). However, Impress also allows animations to be added onto the slides to create more interest in a presentation.

An animation consists of a sequence of images or objects called frames that are displayed in succession when the animation runs. Each frame may contain one or more objects. For example, make bullet points appear one by one; make pictures, shapes or other objects appear singly or as a group onto a slide. Animations can be controlled using the keyboard, a click, or automatically in a timed sequence.
**Note**

Anything that can be placed onto a slide is an object. For example, an object can be an image, clip art drawing, text, and so on.

**Tip**

Animations can look great in a presentation, but overuse of animations can make a good presentation into a poor presentation. Always use discretion when adding animations to a presentation.

**Creating an animation**

1) Select an object on a slide and open the Animation deck on the Sidebar (Figure 169) using one of the following methods:
   - Click on **Animation** on the Sidebar.
   - Right-click on a selected object and select **Animation** from the context menu.
   - Go to View > Animation on the Menu bar.
2) Click on **Add Effect** tool to add the selected object into the Animation preview box.
3) Select a category type from the options available in the **Category** drop-down list.
4) Select an animation effect from the options available in the **Effects** list.
5) Select how the animation starts from the options available in the **Start** drop-down list.
6) Select how the animation appears from the options in the **Direction** drop-list. Available options are specific to the effect selected in the **Effects** list.

7) Enter a time in seconds for how long the animation lasts in the **Duration** box.

8) Enter a timing delay in seconds for when the animated object appears in the presentation in the **Delay** box.

9) If necessary, click on **Options** to open the Effect Options dialog (Figure 170) to set any effect options required for the animation, then click **OK** to close the Effect Options dialog.

10) If necessary, change the order of when the selected object appears in the animation using **Move Up** or **Move Down** tools below the **Animation** preview box.

11) Click on **Play** to preview the animation effect.

12) If necessary, select **Automatic Preview** so that each time the animation is changed, there is a preview of the effect.

13) When satisfied, run the slide show to check the presentation.
Animation tools and options

The available tools and options on the Animation deck on the Sidebar allows control over animation applied to an object on a slide.

- **Add Effect** – adds a selected object to the Animation preview box and add animation effects to the object.
- **Remove Effect** – removes a selected object and its animated effects from the Animation preview box.
- **Move Up** – moves the selected object and its animation effect up the order of animation effects that have been applied to an object.
- **Move Down** – moves the selected animation effect down the order of animation effects that have been applied to an object.
- **Category** – select a category from the options available in the drop-down list.
- **Effect** – select an animation effect from the options available in the list.
- **Start** – select from the drop-down list how an animation effect starts when running an animation:
  - *On click* – the animation stops at this effect until the next click.
  - *With previous* – the animation runs immediately.
  - *After previous* – the animation runs as soon as the previous animation ends.
- **Direction** – select from the drop-down list how an animation effect appears on the slide. The options available depend on the animation effect selected.
- **Options** – opens the Effect Options dialog for adjusting and applying options to the animation effect and timing.
- **Duration** – select the duration, in seconds, of the selected animation effect.
- **Delay** – select the delay, in seconds, of when the animation effect starts.
- **Automatic Preview** – select this option to automatically preview an animation effect when it is applied to an object.
- **Play** – test run the animation.

Effect Options dialog

**Effect page**

The **Effect** page (Figure 170) contains options that match the animation effect selected:

- **Settings**
  - *Direction* – specify the direction of the animation effect from the options available in the drop-down list.
- **Enhancement**
  - *Sound* – select a sound from the drop-down list that plays when the animation effect is run.
  - *After animation* – select from the drop-down list what happens after an animation effect ends.
    - Don’t dim – no after-effect runs.
    - Dim with color – after the animation a dim color fills the shape.
    - Hide after animation – hides the shape after the animation ends.
    - Hide on next animation – hides the shape on the next animation.
Figure 170: Effect Options dialog - Effect page

- **Dim color** – select a dim color from the available color palettes.
- **Text animation** – select the animation mode for the text in an object:
  - All at once – animates the text all at once.
  - Word by word – animates the text word by word.
  - Letter by letter – animates the text letter by letter.
- **Delay between characters** – specifies the percentage of delay between animations of words or letters.

**Timing page**

The **Timing** page on the Effect Options dialog (Figure 171) contains the following options:

- **Timing**
  - **Start** – displays the start property of the selected animation effect.
    - On click – the animation stops at this effect until the next click.
    - With previous – the animation runs immediately.
    - After previous – the animation runs as soon as the previous animation ends.
  - **Delay** – specifies a delay in seconds before the effect starts.
  - **Duration** – specifies the duration in seconds of the effect.
  - **Repeat** – specifies whether and how to repeat the current effect. Enter the number of repeats, or select from the list:
    - **none** – the effect is not repeated.
    - **Until next click** – the animation is repeated until the next click.
    - **Until end of slide** – the animation repeats as long as the slide is displayed.
  - **Rewind when done playing** – specifies whether to let the animated object returns to its starting state after the animation ends.
Trigger

- **Animate as part of click sequence** – specifies whether to let the animation start in the normal click sequence.
- **Start effect on click of** – specifies whether to let the animation start when a specified shape is clicked. Select the shape by its name from the drop-down list.

**Text Animation page**

The **Text Animation** page on the Effect Options dialog (Figure 172) contains the following options:

- **Group text** – specifies how the text is animated as follows:
  - As one object – the whole text object is animated.
  - All paragraphs at once – all text paragraphs are animated.
– *By XX level paragraphs* – text for the outline level selected is animated. The options available depends on how many outline levels there are in the animated text.

- **Automatically after** – specifies a delay in seconds before the text animation effect starts.
- **Animate attached shape** – animates an object that contains text.
- **In reverse order** – text paragraphs are animated in reverse order.

**Animated images**

Animation of drawing objects, text objects, and graphic objects (images) on slides can make a presentation more interesting. LibreOffice Impress provides a simple animation editor where animation images (frames) can be created by assembling objects from a slide. The animation effect is achieved by rotating through static frames that are created.

**Creating animated image**

The following is an example of how to create an animated image.

1) Select an object or group of objects for inclusion in an animation and go to **Insert > Media > Animated Image** to open the Animation dialog (Figure 173).

2) Add an object or objects using one of the following methods:
   - Click on **Apply Object** to add a single object or a group of objects to the current animation frame.
   - Click on **Apply Objects Individually** to create a separate animation frame for each of the selected objects.

![Animation dialog](image)

*Figure 173: Animation dialog*
3) In **Animation Group**, select **Bitmap object**.
4) Enter the frame (image) number in the **Image Number** box to setup the image.
5) In **Duration** specify the duration time in seconds for displaying a frame.
6) Specify the number of times a frame is displayed in the animation sequence in **Loop Count**. This is called looping.
7) Repeat Steps 4 thru 6 for each image or object used for the animated image.
8) Click on **Create** and the animated image appears centrally on the slide.

**Note**
If the image to be copied consists of several objects, each object can be treated as a separate frame. In this case, click on **Apply Objects Individually**. Remember that each object is centered in the animation.

**Animation dialog controls**
- **First Image** – jumps to the first image in the animation sequence.
- **Backwards** – plays the animation backwards.
- **Stop** – stops playing the animation.
- **Play** – plays the animation.
- **Last Image** – jumps to the last image in the animation sequence.
- **Image Number** – indicates the position of the current image in the animation sequence. To view another image, enter its number or click the up and down arrows.
- **Duration** – enter the number of seconds to display the current image. This option is only available if **Bitmap object** is selected in **Animation group**.
- **Loop Count** – sets the number of times that animation will play. If the animation is to play continuously, select **Max**. This option is only available if **Bitmap object** is selected in **Animation group**.
- **Apply Object** – adds selected object or objects as a single image.
- **Apply Objects Individually** – adds an image for each selected object. If a grouped object is selected, an image is created for each object in the group.
- **Delete Current Image** – deletes the current image from the animation sequence.
- **Delete All Images** – deletes all images in the animation.
- **Number** – total number of images in the animation.
- **Group object** – assembles images into a single object so that they can be moved as a group. Individual objects can still be edited by double-clicking the group in the slide.
- **Bitmap object** – combines images into a single image.
- **Create** – inserts the animation into the current slide.

**Note**
An animation, such as an animated GIF, can be selected. Click **Apply Objects Individually** to open it for editing. When finished editing the animation, click **Create** to insert a new animation into a slide.
Chapter 6,
Formatting Graphic Objects
Introduction

The format of each graphic object, in addition to its size, rotation, and position on the slide, is determined by a number of attributes that define the line, text, and area fill of each object. These attributes (among others) also contribute to a graphics style. Although this chapter discusses mainly the manual formatting of objects, it concludes by showing how to create, apply, modify, and delete graphics styles.

Note

When hovering the cursor over an icon or tool on a toolbar or in the Sidebar, pop-up text indicates the purpose of the icon or tool.

Line formatting

In LibreOffice the term line indicates both a freestanding segment (line), the outer edge of a shape (border), or an arrow. In most cases, the properties of the line that can be modified are style (solid, dashed, invisible, and so on), width, color, and type of arrowhead.

Note

When adding color to a line or arrow, refer to “Color fills” on page 222 on how to change color, create custom colors, modify colors, or delete colors.

Line and Filling toolbar

Format a line using the Line and Filling toolbar (Figure 174) as follows:

9) Make sure a line is selected on a slide.
10) Select a line style from the Line Style drop-down list.
11) Either type the line width in the Line Width text box, or use the up and down arrows to change the line width.
12) Click on the triangle ▼ to the right of Line Color and select a color from one of the color palettes that are available.
13) If necessary, select from the Arrow Style drop-down list the type of arrowhead for each end of the line and change the line into an arrow. The left drop-down list adds an arrow head to the beginning of the line. The right drop-down list adds an arrow head to the end of the line.
14) If necessary, click on Shadow to add a shadow to the line. The shadow applied uses the settings set in the Line dialog (Figure 179 on page 215).
15) Deselect the line to save the changes to the line.

Figure 174: Line and Filling toolbar
Sidebar

To format a line using the **Line** panel in the Properties deck on the Sidebar (Figure 175):

1) Make sure a line is selected on a slide.
2) Click on **Properties** on the Sidebar to open the Properties deck.
3) Click on **Line** to open the **Line** panel.
4) In **Line** when an arrow is being created, select from the **Arrow Style** drop-down list the type of arrowhead for each end of the line and change the line into an arrow. The left drop-down list adds an arrow head to the beginning of the line. The right drop-down list adds an arrow head to the end of the line.
5) In **Line**, select from the **Line Style** drop-down list the type of line from the options available.
6) In **Width**, select a line width from the options in **Select the width of the line** drop-down list or enter a width in the **Custom Line Width** text box.
7) In **Color**, select a line color from one of the color palettes that are available in the **Line Color** drop-down list.
8) In **Transparency**, move the slider or enter a percentage in the text box to set the shadow transparency.
9) In **Corner style**, select a corner style from the options available in the drop-down list.
10) In **Cap style**, select the style of the line end caps from the drop-down list. The cap style is added to dashes also if dashes have been used in the line style.
11) Deselect the line to save the changes to the line.
12) If necessary, click on **More Options** on the right of the title bar and open the Line dialog for more control over formatting lines.
Line dialog

To fully change the appearance of a line, then the Line dialog is used. The line dialog consists of four pages: Line, Shadow, Line Styles and Arrow Styles, which are explained in the following sections.

1) Make sure a line is selected on a slide.

2) Open the Line dialog (Figure 176) using one of the following methods:
   - Go to Format > Object and Shape > Line on the Menu bar.
   - Right-click on the line and select Line from the context menu.
   - Click on More Options on the right of the Line panel title bar in the Properties deck on the Sidebar.

3) When all changes have been made to the selected line, click OK to close the dialog and save the changes. The preview box at the bottom of the dialog shows the effect of any changes made to a line.

Line page

The Line page in the Line dialog (Figure 176) is where the basic parameters of a line are selected and are as follows:

- Line Properties – this section is used to set the following parameters:
  - Style – select a line style from the Style drop-down list.
  - Color – select a predefined color from the available color palettes. To create a custom color, see to “Color fills” on page 222 for more information.
  - Width – specifies the thickness of the line.
Figure 177: Example of line transparency (0%, 25%, 50%, 75% left to right)

- **Transparency** – sets the transparency percentage of a line. Figure 177 is an example of the effect different transparency percentages have when lines placed over an object.

- **Arrow Styles** – this section is only applicable to individual lines and is not used for lines that form the borders of an object.
  - **Start Style** – select the arrow style for the start of a line from the drop-down list.
  - **Width** – specifies the thickness of the start arrow ending.
  - **End Style** – select the arrow style for the end of a line from the drop-down list.
  - **Width** – specifies the thickness of the end arrow ending.
  - **Center** – moves the center of the arrow endings to the end point of the line. Figure 178 is an example of the effects of selecting this option.
  - **Synchronize ends** – makes the two line ends identical.

Figure 178: Example of default (top) and center (bottom) arrow heads

- **Corner and Cap Styles** – determines how the connection between two segments of a line looks. To appreciate the difference between corner and cap styles, choose a thick line style and observe how the preview changes as each option is selected.
  - **Corner style** – select the shape used at the corners of the line from the drop-down list. For a small angle between lines, a mitered shape is replaced with a beveled shape.
  - **Cap style** – select the style of the line end caps from the drop-down list. The caps are added to inner dashes as well.

### Line shadows

The Shadow page (Figure 179) of the Line dialog provides options to add and format a line shadow. The shadow settings in this dialog are the same as the shadow settings in the Area dialog (Figure 200 on page 237). However, shadow settings in the Line dialog can have different values than the shadow settings in the Area dialog. For more information on shadow settings, see “Working with shadows” on page 237.
To quickly apply a shadow to a line, click on Shadow on the Line and Filling toolbar. Using the Shadow tool creates a shadow using the settings from the Shadow page in the Line dialog.

**Line styles**

Line styles are useful in a drawing when adding several lines of similar types. This reduces the need to format individual lines. LibreOffice provides standard line styles that can be used in a drawing. Also, line styles can be created, saved, and deleted.

The Line Styles page in the Line dialog (Figure 180) provides the options to use predefined line styles and to create or change line styles. An example of the line style selected or created is displayed at the bottom of the Line Styles page.

**Creating line styles**

1) Create a line in a drawing.
2) Open the Line dialog using one of the following methods:
   – Go to Format > Object and Shape > Line on the Menu bar.
   – Right-click on the line and select Line from the context menu.
3) Click on Line Styles to open the Line Styles page.
4) Select from the Line style drop-down menu a predefined line style that is similar to the line style being created.
5) Click Add and type a name for the new line style in the Name dialog that opens, then click OK to close the dialog. The name of the new style appears in the Line style box.
6) In the Type drop-down lists, select Dots or Dash. For lines with only dots or dashes, select the same type in both Type boxes.
7) In Number, specify the number of dots or dashes required. For different sized groups of dots or dashes, set a different quantity number in each Number box.
8) In Length, specify the length percentage for dashes. Length is not available if Dots has been selected for Type.
9) In Spacing, set a spacing percentage between the dots and/or dashes.
10) If necessary, select Fit to line width so that the new style fits the width of the selected line.
11) The new line style created is available only in the current document. To use the new line style in other documents, click on **Save Line Styles** and type a unique filename in the Save as dialog that opens. Saved line styles have the file extension of .sod.

12) To use a previously created line style, click on **Load Line Styles**, then select a style from the list of saved styles and click on **Open** to load the style into the document.

13) If necessary, click on **Modify** to change the name of the style and follow Steps 4 thru 11 to create and use a new line style.

14) Click **OK** to save any changes and close the Line dialog.

**Note**

When creating a line style, it is recommended to use a unique name for the line style. This prevents one of the predefined line styles in LibreOffice from being overwritten and causing formatting problems in other documents that use the predefined line styles.

**Deleting line styles**

1) Open the Line dialog and click on **Line Styles** to open the **Line Styles** page.

2) Select the line style for deletion from the **Line style** drop-down list.

3) Click on **Delete**, then confirm the deletion by clicking on **Yes** in the confirmation dialog that opens.

4) Click **OK** to save any changes and close the Line dialog.
**Note**

When deleting line styles, make sure that the line style is not used in another document. It is recommended to only delete line styles that have been created and not to delete one of the LibreOffice predefined line styles. This prevents any formatting problems in other documents where the line style has been used.

**Arrow styles**

**Creating arrow styles**

Any shape can be used as an arrowhead, but the shape must be convertible to a curve. A curve is something drawn without lifting a pencil. For example, a star can be converted to a curve, but a smiley face cannot.

1) Select a shape, or create a shape that can be converted to a curve for use as a new arrowhead. The part of the shape that is going to be point of the arrowhead must face upward. An example of a new arrowhead is shown in Figure 181.

2) If necessary, select the shape, right-click and select **Convert > To Curve** from the context menu. If the shape is already a curve, **To Curve** will not be available.

3) Make sure the arrowhead shape is selected.

4) Open the Line dialog and click on **Arrow Styles** to open the **Arrow Styles** page (Figure 182).

5) Click on **Add**, type a name for the new arrow style in the dialog that opens, then click **OK**. The new arrowhead style appears on the **Arrow Styles** page and at the bottom of the **Arrow style** drop-down list.

6) The new arrow style created is available only in the current document. To use the created arrow style in other documents, click on **Save arrow styles** and type a unique filename in the dialog that opens. Saved arrow styles have the file extension of `.soe`.

7) To use a previously saved arrow styles, click on **Load arrow styles** to open a file browser and select the style from the saved list of styles. Click **Open** to load the style into a document.

![Figure 181: Example of a shape being used for a arrowhead](image)
If necessary, make changes to the arrow style and click on \textit{Modify}, then enter a name in the dialog to change the name of the arrow style.

Click \textbf{OK} to save any changes and close the Line dialog.

\textbf{Deleting arrow styles}

1) Open the Line dialog using one of the following methods:
   – Go to \textit{Format > Object and Shape > Line} on the Menu bar.
   – Right-click on the line and select \textit{Line} from the context menu.

2) Click on \textbf{Arrow Styles} to open the \textbf{Arrow Styles} page.

3) Select the arrow style for deletion from the \textit{Arrow style} drop-down list.

4) Click on \textbf{Delete}, then confirm the deletion by clicking on \textbf{Yes} in the confirmation dialog that opens.

5) Click \textbf{OK} to save any changes and close the Line dialog.

\textbf{Note}

When deleting arrow styles, make sure that the arrow style is not used in another document. It is recommended to only delete arrow styles that have been created and not to delete one of the LibreOffice predefined arrow styles. This prevents any formatting problems in other documents where the arrow style has been used.
Figure 183: Examples of area fill types

Area fill formatting

Area fill refers to the inside of an object that has an unbroken border, for example a rectangle, circle, star, pentagon and so on. An area fill can be a uniform color, gradient, hatching pattern, or bitmap, as shown by the examples in Figure 183. An area fill can also be made partly or wholly transparent and throw a shadow. For more information on area fills, see “Working with area fills” on page 222.

Line and Filling toolbar

Tools on the Line and Filling toolbar provide a wide number of default fillings available to quickly format graphic objects. If this toolbar is not showing, go to View > Toolbars > Line and Filling on the Menu bar.

1) Select an object so that the selection handles are displayed.
2) From the Area Style/Filling drop-down list on the Line and Filling toolbar, select the type of fill required.
   - None – select this option if an area fill for an object is not required.
   - Color (Figure 184) – select a color palette from the available options in the drop-down list, then select a color by clicking on the color.
   - Gradient (Figure 185) – select the required gradient from the drop-down list.
   - Hatching (Figure 186) – select the required hatching from the drop-down list.
   - Bitmap (Figure 187) – select the required bitmap from the drop-down list.
   - Pattern (Figure 188) – select the required pattern from the drop-down list.
3) Deselect the object to save any changes.
Chapter 6, Formatting Graphic Objects | 195

Figure 184: Color area fills

Figure 185: Gradient area fills

Figure 186: Hatching area fills

Figure 187: Bitmap area fills

Figure 188: Pattern area fills
Figure 189: Area panel in Properties deck on Sidebar

Sidebar

1) Select an object for editing.
2) Click on Properties on the Sidebar to open the Properties deck, then click on Area to open the Area panel (Figure 189).
3) Use the various options in the Fill and Transparency drop-down lists to format the fill and transparency of an object. For more information on area fills, see “Working with area fills” on page 222.
4) Deselect the object to save any changes.
5) If necessary, click on More Options on the right of the Area title bar to open the Area dialog giving more control over the appearance of the object fill.

Note

The area fills available in the Fill drop-down list are the same as the drop-down lists available on the Line and Filling toolbar and shown in Figures 184 thru 188.

Note

If an area fill for an object is not required, select None from the Fill drop-down list in the Area panel in the Properties deck on the Sidebar.

Area dialog

Use the Area dialog (Figure 190) to change existing area fills with greater control or create an area fill.

1) Select an object for editing.
2) Open the Area dialog using one of the following methods:
   - Go to Format > Object and Shape > Area on the Menu bar.
   - Right-click on the object and select Area from the context menu.
   - Click on More Options on the right of the Area panel title on the Sidebar.
3) Click on Area to open the Area page.

4) Select the type of area fill from the options available: None, Color, Bitmap, Gradient, Pattern, or Hatch. For more information on area fills, see “Working with area fills” below.

5) Select the style of area fill from the options that become available. The number of available options depends on the type of area fill selected.

6) Click OK to close the Area dialog and save the changes.

---

**Note**

If an area fill for an object is not required, select None from the options available after opening the Area page in the Area dialog.

---

### Working with area fills

Although the characteristics of an existing area fill can be changed and then modified by clicking the **Modify** button, it is recommended that only custom area fills are modified rather than modifying the predefined area fills supplied with LibreOffice. Predefined area fills may be reset when LibreOffice is updated.

### Color fills

**Using color**

1) Select an object for editing.

2) Open the Area dialog and click on Area to open the Area page, then click on Color to open the options available for a color fill (Figure 190).

3) In Palette, select the required color palette from the drop-down list and the required color from the available colors shown. All color fills available are solid colors.

   - **Active** – shows the present color fill of a selected object. After selecting a new color, a preview of the selected color appears in **New**.
Alternative, enter the RGB or Hex values of a color in the appropriate text box.

Alternatively, click on Pick to open the Pick a Color dialog (Figure 191). Select a color from the color box or enter the RGB, Hex, HSB or CMYK values for the color required.

If a color has been used before, then select the required color from those available in Recent Colors.

4) Click OK to close the dialog and save the changes. The area fill appears in the selected object.

Creating custom colors with Area dialog

Custom colors can be created either as a combination of the three primary colors using RGB notation of Red (R), Green (G), and Blue (B) or using CMYK percentages of Cyan (C), Magenta (M), Yellow (Y), and Black (K).

1) Select an object for editing.
2) Open the Area dialog and click on Area to open the Area page, then click on Color to open the options available for a color fill.
3) Specify the Red (R), Green (G), and Blue (B) values on a 0 to 255 scale to create a new color.
4) Click on Add in Custom Palette and enter a name in the Name dialog that opens.
5) Click OK to close the Name dialog and the color is added to the Custom palette.
6) Click OK to save the changes and close the Area dialog. The new color appears as a fill in the selected object.
Creating colors with Pick a Color dialog

1) Select an object for editing.
2) Open the Area dialog and click on Area to open the Area page, then click on Color to open the options available for a color fill.
3) Click on Pick to open the Pick a Color dialog (Figure 191).
4) Create a new color using one of the following methods. A preview of the color created is shown in the colored box below the original color on the left side of the dialog.
   - Select a color range from the colored bar, then, using the cursor, move the target in the colored box until the cursor is on the color required.
   - Enter values for Red (R), Green (G), and Blue (B) in the RGB text boxes.
   - Enter values for Cyan (C), Magenta (M), Yellow (Y), and Key (K) (black) in the CMYK text boxes.
   - Enter values for Hue (H), Saturation (S), and Brightness (B) in the HSB text boxes. HSB values do not change the color, but how a color looks.
   - If known, enter the Hex# number in the text box. For example, Hex numbers are normally used when a specific color has been created, for example a company logo.

   Note
   
   Changing one set of color values automatically changes the values in the other sets of color values.

5) Click OK to close the Pick a Color dialog.
6) Click on Add in Custom Palette and enter a name for the color in the Name dialog that opens.
7) Click OK to close the Name dialog and the color is added to the Custom palette.
8) Click OK to save the changes and close the Area dialog. The new color appears as a fill in the selected object.

Deleting custom colors

1) Select an object for editing and open the Area dialog.
2) Click on Area to open the Area page, then click on Color to open the options available for a color fill.
3) Select Custom from the Palette drop-down list in Colors.
4) Select the color for deletion from those displayed and click on Delete. There is no confirmation given when deleting a color.
5) Click OK to save the changes and close the Area dialog.

   Note
   
   Only colors that have been created and placed in the custom palette can be deleted. Colors from any of the other color palettes available in LibreOffice cannot be deleted.

Adding color palettes

Color palettes that are compatible with LibreOffice can be added using Extensions: Color Palettes as follows:

1) Select an object for editing and open the Area dialog.
2) Click on Area to open the Area page, then click on Color to open the options available for a color fill.
3) In **Colors**, click on **Add color palettes via extension** to open the Extensions: Color Palette dialog (Figure 192).

4) Select a color palette from the list of available color palette extensions and click on **Install** to install the extension into LibreOffice.

5) Click on **Close** to close the Extensions: Color Palette dialog and the color palette appears in the **Palette** drop-down list ready for use.

**Gradient fills**

**Using gradients**

1) Select an object for editing.

2) Open the Area dialog and click on **Area** to open the **Area** page, then click on **Gradient** (Figure 193) to open the options available for a gradient fill.

3) In **Gradient**, select the required gradient from the list of available gradients and it appears in **Preview**.

4) To override the default gradient transition of a selection, deselect **Automatic** in **Options** and then enter the values for **Type**, **Increment**, **Angle**, **Border**, **From Color**, and **To Color** in the available boxes.

5) Click **OK** to close the dialog and save the changes. The area fill appears in the selected object.
Creating custom gradients

Gradients can be modified or custom gradient can be created. Several types of gradients are predefined in LibreOffice and changing the From Color and To Color settings could be sufficient to obtain a satisfactory result.

1) Select the object where a custom gradient is going to be used.
2) Open the Area dialog and click on Area to open the Area page, then click on Gradient to open the options available for a gradient fill.
3) Select one of the predefined gradients shown in the Gradient box and the gradient appears in Preview.
4) In Options, select a gradient type from the Type drop-down list: Linear, Axial, Radial, Ellipsoid, or Square. Each gradient type changes the gradient displayed in Preview.
5) Adjust the settings in Options as necessary. The options used to create a gradient are summarized in Table 5. Depending on the gradient type selected, some options will not be available.
6) Click on Add and enter a name for the gradient in the Name dialog that opens.
7) Click OK to close the Name dialog and the gradient is added to the end of the gradients displayed in the Gradient box.
8) Click OK to close the Area dialog and save the changes.
It is recommended to only modify, rename or delete gradients that have been created. These custom gradients are always positioned at the bottom of the gradients displayed in the Gradient box. Modifying, renaming or deleting gradients that are installed with LibreOffice may cause problems in documents that use one of these gradients.

<table>
<thead>
<tr>
<th>Gradient property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Linear gradient</td>
<td>The color transitions from the starting color to the end color in a straight line.</td>
</tr>
<tr>
<td>Axial gradient</td>
<td>The color transitions from the starting color to the end color from the object center to the object edges in two opposite directions.</td>
</tr>
<tr>
<td>Radial gradient</td>
<td>The color transitions from the starting color to the end color in a circular pattern.</td>
</tr>
<tr>
<td>Ellipsoid gradient</td>
<td>The color transitions from the starting color to the end color in an elliptical pattern.</td>
</tr>
<tr>
<td>Quadratic gradient</td>
<td>The color transitions from the starting color to the end color from the object edges to the object center in four directions.</td>
</tr>
<tr>
<td>Square gradient</td>
<td>The color transitions from the starting color to the end color from the object edges to the object center in a square pattern.</td>
</tr>
<tr>
<td>Increment</td>
<td>Enter the number of steps for blending the two colors of the gradient. By default this is set to Automatic.</td>
</tr>
<tr>
<td>Center X</td>
<td>For Radial, Ellipsoid, Square and Rectangular gradients, modify these values to set the horizontal offset of the gradient center.</td>
</tr>
<tr>
<td>Center Y</td>
<td>For Radial, Ellipsoid, Square and Rectangular gradients, modify these values to set the vertical offset of the gradient center.</td>
</tr>
<tr>
<td>Angle</td>
<td>For all gradient types, modifies the angle of the gradient axis.</td>
</tr>
<tr>
<td>Border</td>
<td>Increase this value to make the gradient start further away from the border of the shape.</td>
</tr>
<tr>
<td>From Color</td>
<td>The start color for the gradient. In the edit box enter the intensity of the color: 0% corresponds to black, 100% to the full color.</td>
</tr>
<tr>
<td>To Color</td>
<td>The end color for the gradient. In the edit box enter the intensity of the color: 0% corresponds to black, 100% to the full color.</td>
</tr>
</tbody>
</table>

Modifying gradients

1) Select the object where the gradient is going to be modified.
2) Open the Area dialog and click on Area to open the Area page, then click on Gradient to open the options available for a gradient fill.
3) Select one of the predefined gradients shown in the Gradient box and the gradient appears in Preview.
4) Select a gradient previously created and added to the gradients displayed in the Gradient dialog.
5) Enter the new values for the gradient options that need to be changed. See Table 5 for more information on gradient options. Depending on the type of gradient selected, some options may not be available.
6) Click **Modify** to save the changes. There is no confirmation given when modifying a
gradient.

7) Click **OK** to close the Area dialog and save the changes.

**Renaming gradients**
1) Select the object where the gradient is going to be renamed.

2) Open the Area dialog and click on **Area** to open the **Area** page, then click on **Gradient** to
open the options available for a gradient fill.

3) Right-click on the gradient and select **Rename** from the context menu.

4) Enter a name for the gradient in the Name dialog that opens.

5) Click **OK** save the gradient in the Name dialog.

6) Click **OK** to save the changes and close the Area dialog.

**Deleting gradients**
1) Select the object where the gradient is going to be deleted.

2) Open the Area dialog and click on **Area** to open the **Area** page, then click on **Gradient** to
open the options available for a gradient fill.

3) Select a gradient that has been created and added to the gradients displayed in the
**Gradient** box.

4) Right-click on the gradient and select **Delete** from the pop-up menu. Click on **Yes** to
confirm the deletion.

5) Click **OK** to save the changes and close the Area dialog.

**Advanced gradient controls**
1) Select an object that contains a gradient as a fill.

2) Open the Area dialog and click on **Area**, then click on **Gradient** to open the **Gradient**
page.

3) Go to **View > Toolbars > Transformations** on the Menu bar or click on
**Transformations** on the Line and Filling toolbar to open the Transformations toolbar
(Figure 194).

4) Click **Interactive gradient tool** in the Transformations toolbar. This displays a dashed
line connecting two colored squares. The colors show the **From Color** and **To Color** that
are used for the selected gradient (Figure 195).

5) Select the type of gradient required for the object from the **Type** drop-down list in **Options**
on the **Gradient** page in the Area dialog. The gradient properties are adjusted depending
on the gradient type selected and these properties are explained below.

– **Linear gradients** – move the **From Color** square to change where the gradient starts
(border value). Move the **To Color** square to change the orientation (angle value).

– **Axial gradients** – move the **To Color** square to change both the angle and border
properties of the gradient. Only the **To Color** square can be moved.

– **Radial gradients** – move the **From Color** square to modify the border property to set
the width of the gradient circle. Move the **To Color** square to change the point where
the gradient ends (Center X and Center Y values).
6) Click OK to save the changes and close the Area dialog.

**Note**

Moving the squares creates different effects depending on the type of gradient. For example, for a linear gradient, the start and end squares of the gradient are always situated either side of the center point of the object.

---

**Image fills**

**Note**

Image fills in the Area dialog are called bitmap fills in the drop-down lists on the Line and Filling toolbar, and the Area panel in the Properties deck on the Sidebar.

---

**Using images**

1) Select an object for editing.
2) Open the Area dialog and click on Area to open the Area page, then click on Image (Figure 196) to open the options available for an image fill.
3) In Image, select the required image from the list of available images and it appears in Preview. Alternatively, click on Add/Import to open a file browser window, then select a file to use as an image fill.

---
4) To override the settings for the selected image, in **Options**, enter values for **Style**, **Size**, **Position**, **Tiling Position**, and **Tiling Offset**. See Table 6 for information on **Options**.

5) Click **OK** to close the dialog and save the changes. The area fill appears in the selected object.

**Table 6: Image options**

<table>
<thead>
<tr>
<th><strong>Option</strong></th>
<th><strong>Purpose</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Style – Custom position/size</td>
<td>When selected, the position of the image in the object and the size of the image can be determined.</td>
</tr>
<tr>
<td>Style – Tiled</td>
<td>When selected, the image is tiled to fill the area. The size of the image used for the tiling is determined by the <strong>Size</strong> settings</td>
</tr>
<tr>
<td>Style – Stretched</td>
<td>When selected, an image is stretched to fill object area.</td>
</tr>
<tr>
<td>Size – Width</td>
<td>Sets the width of the image. For example, 100% means that the image original width is resized to occupy the whole fill area width, 50% means that the image width is half that of the fill area.</td>
</tr>
<tr>
<td>Size – Height</td>
<td>Sets the height of the image. For example, 100% means that the image original height is resized to occupy the whole fill area height, 50% means that the image height is half that of the fill area.</td>
</tr>
<tr>
<td>Option</td>
<td>Purpose</td>
</tr>
<tr>
<td>----------------------</td>
<td>------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Size – Scale</td>
<td>When selected, image size is given as a percentage for Width and Height. When deselected, the actual size of the image is given for Width and Height.</td>
</tr>
<tr>
<td>Position</td>
<td>When selected, the anchoring point of the image is determined. Default position is Center.</td>
</tr>
<tr>
<td>Tiling Position – X offset</td>
<td>When Tile is selected, sets the offset for the image width in percentage values. 50% offset means that Impress places the middle part of the image at the anchor point and starts tiling from there.</td>
</tr>
<tr>
<td>Tiling Position – Y offset</td>
<td>When Tile is selected, sets the offset for the image height in percentage values. 50% offset means that Impress places the middle part of the image at the anchor point and starts tiling from there.</td>
</tr>
<tr>
<td>Tiling Offset – Row</td>
<td>When Tile is selected, offsets the rows of tiled images by the entered percentage value so that each row is offset from the previous row.</td>
</tr>
<tr>
<td>Tiling Offset – Column</td>
<td>When Tile is selected, offsets the columns of tiled images by the entered percentage value so that each column is offset from the previous column.</td>
</tr>
</tbody>
</table>

![Image](libreoffice.png)

Figure 197: Example of using image fills

**Editing images**

1) Select an object for editing that contains an image as a fill, or insert an image into a selected object
2) Open the Area dialog and click on Area to open the Area page, then click on Image to open the options available for an image fill.
3) Select an image from the options available in Image to use and edit as a fill. Note that any imported images are also available.
4) In Options, select the properties for Style, Size, Position, Tiling Position and Tiling Offset. See Table 6 for more information on bitmap properties. The best way to understand image properties is to use them. Figure 197 shows examples of using image fills.
5) Click OK to save the changes and close the Area dialog.
Importing images
1) Select an object to import an image into the object.
2) Open the Area dialog and click on Area to open the Area page, then click on Image to open the options available for an image fill.
3) Click on Add/Import and a file browser window opens.
4) Navigate to the directory containing the image file, then select it and click Open.
5) Enter a name for the new image in the Name dialog that opens, then click OK to close the Name dialog. The imported image appears at the bottom of the Image preview box.
6) Select the imported image in the Image preview box.
7) Click OK to import the image into the selected object and close the Area dialog.

Renaming images
1) Select an object that uses an image.
2) Open the Area dialog and click on Area to open the Area page, then click on Image to open the options available for an image fill.
3) Right-click on the image selected for renaming and select Rename from the context menu.
4) Enter a new name for the image in the Name dialog that opens.
5) Click OK save the change and close the Name dialog.
6) Click OK to save the changes and close the Area dialog.

Note
It is recommended to only rename or delete images that have been created or imported. Renaming or deleting images that are installed with LibreOffice may cause problems in documents that use one of these images.

Deleting images
1) Select an object that contains the image being deleted.
2) Open the Area dialog and click on Area to open the Area page, then click on Image to open the options available for an image fill.
3) Right-click on the image that is going to be deleted in the Image preview box.
4) Select Delete from the context menu and click on Yes to confirm the deletion.
5) Click OK to save the changes and close the Area dialog.

Pattern fills
Using patterns
1) Select an object for editing.
2) Open the Area dialog and click on Area to open the Area page, then click on Pattern (Figure 198) to open the options available for a pattern fill.
3) In Pattern, select a pattern from the available patterns and it appears in Preview.
4) Click OK to save the changes and close the Area dialog. The pattern area fill appears in the selected object.

Creating patterns
1) Select an object that contains a pattern as a fill or insert a pattern into the selected object.
2) Open the Area dialog and click on **Area** to open the **Area** page, then click on **Pattern** to open the options available for a pattern fill.

![Area dialog - Area Pattern page](image)

3) If necessary, select a pattern from the options available in the **Pattern** preview box. Note that any imported patterns are also available. The selected pattern appears in **Pattern Editor**.

4) In **Options**, select a color from the available color palettes for the **Foreground Color** and **Background Color**.

5) In **Pattern Editor**, start creating the pattern by clicking in the squares (pixels) to change color. Each click in a square swaps the color from **Background Color** to **Foreground Color** or **Foreground Color** to **Background Color**. Check the pattern being created to see if the desired effect is being achieved.

6) Click on **Add** to open a Name dialog.

7) Enter a name for the new pattern, then click **OK** to close the Name dialog. The new pattern appears at the bottom of the **Pattern** preview box.

8) Click **OK** to save the changes and close the Area dialog.

---

**Note**

It is recommended to only modify, rename or delete patterns that have been created. Modifying, renaming or deleting patterns that were installed with LibreOffice may cause problems in documents that use one of these patterns.
Modifying patterns

1) Select an object that contains a pattern or insert a pattern into the selected object.
2) Open the Area dialog and click on Area to open the Area page, then click on Pattern to open the options available for a pattern fill.
3) If necessary, select a pattern from the options available in the Pattern preview box. Note that any imported patterns are also available. The selected pattern appears in Pattern Editor.
4) Enter new colors for the Foreground Color and Background Color from the available color palettes.
5) In Pattern Editor, start modifying the pattern by clicking in the squares (pixels) to change color. Each click in a square swaps the color from Background Color to Foreground Color or Foreground Color to Background Color. Check the pattern being created to see if the desired effect is being achieved.
6) Click on Modify to save the pattern changes. There is no confirmation given when modifying a pattern fill.
7) Click OK to close the Area dialog and save the changes.

Renaming patterns

1) Select an object that contains a pattern, or insert a pattern into the selected object.
2) Open the Area dialog and click on Area to open the Area page, then click on Pattern to open the options available for a pattern fill. The selected pattern appears in Pattern Editor.
3) Right-click on the pattern for renaming in the Preview box and select Rename from the context menu.
4) Enter a name for the pattern in the Name dialog that opens.
5) Click OK save the renaming and close the Name box.
6) Click OK to save the changes and close the Area dialog.

Deleting patterns

1) Select an object that contains a pattern, or insert a pattern into the selected object.
2) Open the Area dialog and click on Area to open the Area page, then click on Pattern to open the options available for a pattern fill. The selected pattern appears in Pattern Editor.
3) Right-click on the pattern for deletion in the Preview box and select Delete from the context menu.
4) Click on Yes to confirm the deletion.
5) Click OK to save the changes and close the Area dialog.

Hatch fills

Using hatch fills

1) Select an object for editing.
2) Open the Area dialog and click on Area to open the Area page, then click on Hatch to open the options available for a hatch fill (Figure 199).
3) Select a hatch from the options shown in the Hatch box and the selected hatch appears in the Preview box.
4) If necessary, to override the Options settings for the selected hatch fill, enter a new values for Spacing, Angle, Line type, Line color, and Background Color.
When creating new hatch fills or modifying an existing hatch fill, use the options available on the Area Hatch page in the Area dialog. See Table 7 for an explanation of the options available for a hatch fill.

**Note**

It is recommended to create a new hatch fill rather than modify an existing hatch fill.

1) Select an object that contains a hatch fill, or insert a hatch fill into the selected object.
2) Open the Area dialog and click on **Area** to open the **Area** page, then click on **Hatch** to open the options available for a hatch fill.
3) As a starting point, select a hatch fill similar to the one being created. The selected hatch fill appears in the **Preview** box.
4) Change the values of the option settings for the hatch fill. The hatch fill displayed in the **Preview** box changes to reflect the changes in option values.
5) Click on **Add** to open the Name dialog and enter a name for the new hatch fill.
6) Click **OK** to close the Name dialog. The new hatch fill appears at the bottom of the hatch fills displayed in the **Hatch** box.
7) Click **OK** to close the Area dialog and save the changes. The new hatch fill appears in the selected object.

### Table 7: Hatch fill options

<table>
<thead>
<tr>
<th>Hatch option</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Spacing</td>
<td>Determines the spacing between two lines of the hatching fill. As the value is changed the <strong>Preview</strong> is updated.</td>
</tr>
<tr>
<td>Angle</td>
<td>Determines the angle used for the hatch lines. Either use the slider or enter a value in the box to change the angle.</td>
</tr>
<tr>
<td>Line type</td>
<td>Set single, double or triple line for the style of the hatching fill.</td>
</tr>
<tr>
<td>Line color</td>
<td>Select a color of the lines that form the hatching fill from the drop-down list of available color palettes</td>
</tr>
<tr>
<td>Background color</td>
<td>Select a color for the background color behind the hatching lines from the drop-down list of available color palettes</td>
</tr>
</tbody>
</table>

**Note**

It is recommended to only modify, rename or delete hatch fills that have been created. Modifying, renaming or deleting hatch fills that were installed with LibreOffice may cause problems in documents that use one of these hatch fills.

### Modifying hatch fills

1) Select the object that contains the hatch fill that is to be modified.

2) Open the Area dialog and click on **Area** to open the **Area** page, then click on **Hatch** to open the options available for a hatch fill.

3) Enter new values for the option settings of the hatch fill. The hatch fill displayed in the **Preview** box changes to reflect the changes in option values. See Table 7 for information on hatch options.

4) Click **Modify** to save the changes. There is no confirmation given when modifying a hatch fill.

5) Click **OK** to save the changes and close the Area dialog.

### Renaming hatch fills

1) Select the object that contains the hatch fill that is to be renamed.

2) Open the Area dialog and click on **Area** to open the **Area** page, then click on **Hatch** to open the options available for a hatch fill.

3) Right-click on the hatch fill displayed in the **Hatch** box and select **Rename** from the context menu.

4) Enter a name for the hatch fill in the Name dialog that opens.

5) Click **OK** to save the renaming and close the Name dialog.

6) Click **OK** to save the changes and close the Area dialog.

### Deleting hatch fills

1) Select the object that contains the hatch fill that is to be deleted.

2) Open the Area dialog and click on **Area** to open the **Area** page, then click on **Hatch** to open the options available for a hatch fill.

3) Right-click on the hatch fill displayed in the **Hatch** box and select **Delete** from the context menu.

4) Click on **Yes** to confirm the deletion.
5) Click **OK** to save the changes and close the Area dialog.

---

**Working with shadows**

Shadows can be applied to objects such as lines, shapes and text. The options available for shadows are as follows:

- **Position grid** – select one of nine points determining the direction in which the shadow is cast from the object. Only available in the **Shadow** page of the Area dialog (Figure 200).
- **Angle** – determines the angle in which the shadow is cast from the object. Only available in the **Shadow** panel in the Properties deck on the Sidebar.
- **Distance** – determines the offset distance between the object and the shadow.
- **Color** – sets the color used for the shadow.
- **Blur** – sets how much the edges of a shadow are blurred or softened.
- **Transparency** – determines the amount of transparency for the shadow: 0% opaque shadow, 100% transparent shadow.

---

**Area dialog**

1) Select an object where a shadow is going to be applied.

2) Open the Area dialog and click on **Shadow** to open the **Shadow** page (Figure 200).

3) Select **Use shadow** in **Properties** and the shadow options become active.

4) Select from one of nine points the direction in which the shadow is going to be cast in relation to the object.

5) In **Color**, select the color palette from the drop-down list of available palettes and then select the color required for the shadow.

6) In **Distance**, enter a distance to set spacing between the object and the shadow.

7) In **Blur**, enter a value to soften the edges of the shadow.

8) In **Transparency**, enter the percentage in the text box for the shadow transparency.

9) Click **OK** to close the Area dialog and save the changes.

---

*Figure 200: Area dialog – Shadow page*
1) Select an object where a shadow is going to be applied.
2) Click on **Properties** to open the Properties deck on the Sidebar.
3) Click on **Shadow** to open the **Shadow** panel (Figure 201) in the Properties deck.
4) Select **Enable** and the shadow options become active.
5) In **Angle**, select from one of the options available from the drop-down list to set the direction of where the shadow is going to be cast in relation to the object.
6) In **Distance**, enter a distance to set spacing between the object and the shadow.
7) In **Color**, select the color palette from the drop-down list of available palettes and then select the color required for the shadow.
8) In **Blur**, enter a value to soften the edges of the shadow.
9) In **Transparency**, move the slider or enter a percentage in the text box to set the shadow transparency.
10) Deselect the object to save the changes made.

**Sidebar**

1) Select an object where a shadow is going to be applied.
2) Click on **Properties** to open the Properties deck on the Sidebar.
3) Click on **Shadow** to open the **Shadow** panel (Figure 201) in the Properties deck.
4) Select **Enable** and the shadow options become active.
5) In **Angle**, select from one of the options available from the drop-down list to set the direction of where the shadow is going to be cast in relation to the object.
6) In **Distance**, enter a distance to set spacing between the object and the shadow.
7) In **Color**, select the color palette from the drop-down list of available palettes and then select the color required for the shadow.
8) In **Blur**, enter a value to soften the edges of the shadow.
9) In **Transparency**, move the slider or enter a percentage in the text box to set the shadow transparency.
10) Deselect the object to save the changes made.

**Line and Filling toolbar**

1) Select an object where a shadow is going to be applied.
2) Click on **Shadow** on the Line and Filling toolbar. A shadow is created using the settings from the **Shadow** page in the Area dialog.
3) Deselect the object to save the changes made.
Working with transparencies

Transparencies can be applied to objects and to any shadow that has been applied to an object. In Impress two types of transparencies can be applied to an object – uniform transparency and gradient transparency. For more information on gradient transparencies, including an example of combining a color gradient with a gradient transparency, see “Gradient fills” on page 225.

Using Area dialog

1) Select an object where a transparency is going to be applied.
2) Open the Area dialog and click on Transparency to open the Transparency page (Figure 202).
3) To create a uniform transparency, select Transparency and enter a percentage in the text box.
4) To create a gradient transparency so that the area becomes gradually transparent, select Gradient and select the type of gradient transparency from the Type drop-down list: Linear, Axial, Radial, Ellipsoid, Quadratic or Square.
5) If a gradient transparency has been selected, set the parameters for the type of the gradient transparency that has been selected. Refer to Table 8 for a description of the properties. The available parameters depends on the type of gradient transparency.
6) Click OK to close the Area dialog and save the changes.

Table 8: Gradient transparency options

<table>
<thead>
<tr>
<th>Gradient transparency options</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Center X</td>
<td>Used for Radial, Ellipsoid, Quadratic and Square gradients. The values to set the horizontal offset of the gradient center.</td>
</tr>
</tbody>
</table>
Gradient transparency options

<table>
<thead>
<tr>
<th>Gradient transparency options</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Center Y</td>
<td>Used for Radial, Ellipsoid, Quadratic and Square gradients. The values to set the vertical offset of the gradient center.</td>
</tr>
<tr>
<td>Angle</td>
<td>Used for Linear, Axial, Ellipsoid, Quadratic and Square gradients. Specifies the angle of the gradient axis.</td>
</tr>
<tr>
<td>Border</td>
<td>Increase this value to make the gradient start further away from the border of the object.</td>
</tr>
<tr>
<td>Start value</td>
<td>Value for the starting transparency gradient. 0% is fully opaque, 100% means fully transparent.</td>
</tr>
<tr>
<td>End value</td>
<td>Value for the ending transparency gradient. 0% is fully opaque, 100% means fully transparent.</td>
</tr>
</tbody>
</table>

Using Area panel on Sidebar

1) Select an object where a transparency is going to be applied.
2) Open the Area panel in the Properties deck on the Sidebar (Figure 203).
3) Click on the Transparency option box to open a drop-down list of available options.
4) To create a uniform transparency, select Solid and use the slider or text box to change the transparency percentage.
5) To create a gradient transparency so that the area becomes gradually transparent, select from the Transparency drop-down list either Linear, Axial, Radial, Ellipsoid, Quadratic or Square.
6) If a gradient transparency has been selected, set the parameters for the type of the gradient transparency that has been selected. Refer to Table 8 for a description of the properties. The available parameters depends on the type of gradient transparency.
7) Click away from the object to deselect it and save the changes.

Figure 203: Area panel in Properties deck on Sidebar
### Text in objects

By default, an object is not dynamic when it is created and does not behave like a text box. If the text exceeds the object borders, then the text has to be reduced in font size, or the object size increased to accommodate the text.

#### Adding text

1) Select the object where text is to be added.

2) Put the selected object into text mode using one of the following methods. The cursor becomes a flashing text cursor centrally inside the object indicating text mode is active. The Text Formatting toolbar automatically opens replacing the Line and Filling toolbar.
   - Double-click on the object.
   - Use the keyboard shortcut F2.
   - Go to Insert > Text Box on the Menu bar.
   - Click on Insert Text Box on the Standard or Drawing toolbar to insert horizontal text.
   - Click on Insert Vertical Text n the Standard or Drawing toolbar to insert vertical text.

**Note**

If double-clicking does not work, go to View > Toolbars on the Menu bar to open the Options toolbar, then select Double-click to edit Text.

3) Type the required text. Horizontal text is centrally aligned horizontal and vertically within the boundaries of the object. Vertical text is centrally on the left side of the object.

4) Alternatively, copy and paste text into the selected object. It is recommended to paste text into an object as unformatted text and then format the text to to the presentation requirements.

5) When finished, click outside of the object or press Esc to cancel text mode. The Line and Filling toolbar automatically opens replacing the Text Formatting toolbar.

**Note**

Vertical text is only available if Asian and/or Complex text layout have been selected in Tools > Options > Language Settings > Languages (macOS LibreOffice > Preferences > Language Settings > Languages).

#### Formatting text in objects

This section only covers formatting of how text appears inside an object. For more information on formatting text attributes, see Chapter 3, Adding and Formatting Text.

1) Select the object which contains text and use one of the following methods to open the Text dialog (Figure 204):
   - Go to Format > Object and Shape > Text Attributes on the Menu bar.
   - Right-click on the text inside the object and select Text Attributes from the context menu.

2) Click on Text to open the Text page.

3) Format and edit the text within an object using the available options. The options are described in Table 9.

4) Click OK to close the Text dialog and save the changes to the text.
5) To format the text attributes (for example paragraph alignment or font type) use the tools available on the Text Formatting toolbar, or go to Format > Text on the Menu bar and use the options available in the drop-down menu. See Chapter 3, Adding and Formatting Text for more information on formatting text attributes.

Table 9: Object text formatting options

<table>
<thead>
<tr>
<th>Text options</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Word wrap text in shape</td>
<td>Starts a new line automatically when the border of the object is reached.</td>
</tr>
<tr>
<td>Resize shape to fit text</td>
<td>Expands an object when the text inserted in the object is too large.</td>
</tr>
<tr>
<td>Spacing to borders</td>
<td>Specify the amount of space between the borders of the object and the text.</td>
</tr>
<tr>
<td>Text anchor</td>
<td>Used to anchor the text to a particular point within the object.</td>
</tr>
<tr>
<td>Full width</td>
<td>Anchors the text in the center of the object and uses the full width of the object before wrapping text.</td>
</tr>
</tbody>
</table>

**Text animation**

Text can be animated when it has been placed into an object and is a separate animation from object animation. For information on object animation, see Chapter 5, Managing Graphic Objects.

1) Select the object which contains text.

2) Open the Text dialog and click on Text Animation to open the Text Animation page (Figure 205).

3) Select the type of animation required from the Effect drop-down list as follows:
   - No animation – default setting.
   - Blink – the text blinks on the screen.
– *Scroll through* – the text moves into the object and then out following the selected direction.
– *Scroll back and forth* – the text moves first in the selected direction, but bounces back at the object border.
– *Scroll in* – the text scrolls in towards the given direction starting from the edge of the object and stops in the center.

4) Set the *Direction* of the animation using one of the four arrows to set the scroll direction for the text.

5) Set the *Properties* for the animation using the following options:
– *Start inside* – animation starts from inside the object.
– *Text visible when exiting* – select to see the text while editing.
– *Animation cycles* – select *Continuous* and the text animates continuously or set a specific number of cycles for the animation.
– *Increment* – sets the amount the animation moves in *Pixels* when selected or a specific distance when *Pixels* is deselected. The units of measurement depends on the settings in *Tools > Options > LibreOffice Impress > General* (macOS *LibreOffice > Preferences > LibreOffice Impress > General*).
– *Delay* – starts the animation when *Automatically* is selected or after a specific length of time when *Automatically* is deselected.

6) Click **OK** to close the Text dialog and save the animation effect.

**Text columns**

When text columns are added to an object, the whole of the object is used for the text columns.

1) Select the object which contains text.
2) Open the Text dialog and click on **Text Columns** to open the **Text Columns** page (Figure 206).
3) Enter the number of columns required in the Number of columns box.
4) Enter the spacing required between each column in the Spacing box. The units of measurement depends on the settings in Tools > Options > LibreOffice Impress > General (macOS LibreOffice > Preferences > LibreOffice Impress > General).
5) Click OK to close the Text dialog and save the changes.

**Formatting connectors**

Connectors are lines that join two objects and always start from or finish at a glue point on an object. See Chapter 5, Managing Graphic Objects for a description and use of the connectors.

1) Right-click on a connector and select Connector from the context menu to open the Connector dialog (Figure 207). The Connector dialog displays a preview of a connector as changes are made.
2) Select the type of connector from the Type drop-down list.
3) Set the Line skew for the connector. **Line skew** is used to set the distance between connectors where multiple connectors overlap.
4) Set the **Line spacing** for the connector. **Line spacing** is used to set the horizontal and vertical space between the connector and the object at each end of the connector.

5) Click **OK** to close the Connector dialog and save the changes.

### Working with styles

To achieve consistency in slides, a presentation, or applying the same formatting to a large number of objects, it is recommended to use styles. In Impress, styles used for objects are called drawing styles.

Drawing styles are similar to paragraph styles that are used for text. A drawing style groups all formatting properties applicable to an object and associates this properties group with a name. This allows the properties group to be used for other objects. If a drawing style is modified (for example, changing area color), the changes are automatically applied to all objects that use the same drawing style.

If Impress is used frequently, a library of well defined drawing styles is an invaluable tool for speeding up the process of formatting objects to any requirements that have to be followed (for example, company colors or fonts).

For more information on drawing styles in Impress, see Chapter 2, Slide Masters, Styles, and Templates.

### Linked drawing styles

Drawing styles support inheritance which allows a style to be linked to another (parent) style so that it inherits all the formatting settings of the parent. This inheritance creates families of styles.

For example, if multiple boxes are required that only differ in color, but are otherwise identically formatted, it is recommended to define a style for the box including borders, area fill, font, and so on as the parent drawing style. A number of drawing styles are then created that are hierarchically dependent to the parent style, but differing only in the fill color attribute. These drawing styles are known as child styles. If it is necessary to change the font size or border thickness, the parent style is changed and all the child styles change accordingly.

![Figure 208: Drawing styles in Styles deck on Sidebar](image)
Default drawing style

In Impress, the drawing styles are located in the Styles deck on the Sidebar (Figure 208). Click on Drawing Style to open the drawing styles that are available in the presentation. The Default Drawing Style cannot be deleted and is automatically applied to any graphic object created on a slide. This style is the starting point for creating new drawing styles.

**Note**

The Default Drawing Style can be modified. However, a modified Default Drawing Style only applies to the presentation where the style was modified.

Creating drawing styles

*New style from Sidebar*

1) Select an object or create a new object.
2) Open the Styles deck on the Sidebar using one of the following methods:
   - Click on Styles at the side of the Sidebar.
   - Click on Show the Styles Sidebar on the Line and Filling toolbar.
   - Use the keyboard shortcut $F11$.
3) Click on Drawing Styles on the left of the Styles title bar to open the Drawing Styles panel.
4) Right-click on a drawing style that is selected in the list and select New from the context menu to open the Graphic Styles dialog (Figure 209).
5) Click on Organizer to open the Organizer page.
6) Enter a name for the new drawing style in the Name text box.
7) In Inherit from text box, select None from the drop-down list if the new drawing style is NOT going to be linked. When the object was created, it was allocated the Default Drawing Style and this new drawing style linked by default to the Default Drawing Style.
8) Use the various pages in the Graphic Styles dialog to format the new style.
   - Font, Font Effects, Indents & Spacing, Alignment, Tabs, Highlighting and Asian Typography – provides options for formatting any text inserted into a graphic object.
   - Dimensioning – provides options for formatting of dimension lines.
   - Text, Text Animation, Connector, Line, Area, Shadowing, and Transparency – provides options for formatting of graphic objects.
   - Click OK to close the Graphics Styles dialog and save the new drawing style.
Note

Any new drawing style created is automatically placed in the **Custom Styles** category.

**New style from selected object**

1) Select an object to use for creating a new drawing style.
2) Carry out any formatting changes to the object using the various dialogs and menu options available in Impress.
3) Open the Styles deck on the Sidebar and click on **Drawing Styles** on the left of the Styles title bar to open the **Drawing Styles** panel.
4) Click on **New Style from Selection** on the right of the Styles deck title bar to open the New Style from Selection dialog (Figure 210).
5) Enter a name for the new drawing style in the **Enter new style name** text box. A list is displayed of existing custom styles of that are available.
6) Click **OK** to save the new drawing style and close the New Style from Selection dialog.

**Modifying drawing styles**

1) Open the Styles deck on the Sidebar and click on **Drawing Styles** on the left of the Styles title bar to open the **Drawing Styles** panel.
2) Right-click on the style that is to be modified and select **Modify** from the context menu to open the Graphic Styles dialog.
3) Carry out any formatting changes to the drawing style using the options in the various pages of the Graphic Styles dialog.
4) Click **OK** to save the changes and close the Graphic Styles dialog.
Updating drawing styles

1) Select an object or create a new object.
2) Carry out any formatting changes to the object using the various dialogs and menu options available in Impress.
3) Open the Styles deck on the Sidebar and click on Drawing Styles on the left of the Styles title bar to open the Drawing Styles panel.
4) Click on Update Style on the right of the Styles deck title bar to update the style. There is no confirmation that the style has been updated.

Applying drawing styles

1) Open the Styles deck on the Sidebar and click on Drawing Styles on the left of the Styles title bar to open the Drawing Styles panel.
2) Select an object in the presentation to apply a drawing style.
3) Double-click on the drawing style name and apply the drawing style to the selected object.

Deleting drawing styles

The predefined drawing styles in Impress cannot be deleted, even if the predefined drawing style is not in use. Only custom (user defined) styles can be deleted.

1) Open the Styles deck on the Sidebar and click on Drawing Styles on the left of the Styles title bar to open the Drawing Styles panel.
2) Right-click on a custom drawing style and click Delete on the context menu.
3) Click Yes to confirm the deletion of the custom drawing style.

Note

Before deleting a custom drawing style, make sure the style is not in use in the presentation.
Chapter 7, 
OLE, Spreadsheets, Charts, 
and Other Objects
OLE objects

Object Linking and Embedding (OLE) is a software technology that allows linking and embedding of the following types of files into an Impress presentation.

- LibreOffice spreadsheets
- LibreOffice charts
- LibreOffice drawings
- LibreOffice formulas
- LibreOffice text

The major benefit of using OLE objects is that it provides a quick and easy method of editing an object using tools from the software that created the object. These file types can all be created using LibreOffice and OLE objects can be created from new or from an existing file.

Inserting new OLE objects

When inserting a new OLE object, it is only available in the presentation it is being inserted into and the OLE object can only be edited using Impress.

4) Select the slide in a presentation to insert an OLE object.
5) Go to Insert > Object > OLE Object on the Menu bar to open the Insert OLE Object dialog (Figure 211).
6) Select Create new and then select the type of OLE object in Object Type.
7) Click OK and a new OLE object is inserted in the center of the slide in edit mode. The toolbars displayed change providing the necessary tools to create a new OLE object.

Note

For computers using the Windows operating system, an additional option of Further objects is available in the Object Type list. Clicking on Further objects opens an Insert Object dialog (Figure 212) allowing an OLE object using other software that is compatible with OLE and LibreOffice to be inserted. This option is available for new OLE objects and OLE objects from a file.

Figure 211: Insert OLE Object dialog
Inserting OLE objects from files

1) Select the slide in a presentation to insert an OLE object.
2) Go to Insert > Object > OLE Object on the Menu bar to open the Insert OLE Object dialog.
3) Select Create from file and the dialog changes to a file search dialog (Figure 213).
4) Click on Search and a file browser window opens.
5) Navigate to where the file is located.
6) Select the file required and click Open. The filename appears in the File text box.
7) Insert the OLE object into the center of the slide in edit mode using one of the following methods:
   - Click **OK** to insert the file as an OLE object.
   - Select **Link to file**, then click **OK** to insert the OLE object with a link to the original file.
   - Select **Display as icon**, then click **OK** to insert the OLE object as an icon. When the icon is clicked on, the OLE object opens in a new window.
Note

By default, when inserting a file into a slide as an OLE object, any changes made to the original file after insertion do not affect the copy of the file inserted into a presentation. Also, changes to the file copy in a presentation do not change the original file. If any changes made to the file, either in the original or in the presentation, are to appear in both versions the original file has to be linked with the presentation when the file is inserted.

Editing OLE objects

1) Double-click on the OLE object to open it in edit mode. The toolbars in Impress change to provide the necessary tools for editing an OLE object.
2) When editing the OLE object is complete, click anywhere outside the OLE object to exit editing.
3) Save the presentation. Any changes made to the OLE object are also saved.

Resizing and moving OLE objects

Resizing and moving OLE objects is exactly the same as resizing and moving graphic objects in Impress. For more information, see Chapter 5, Managing Graphic Objects.

Note

When resizing or moving a spreadsheet in slides, ignore any horizontal and vertical scroll bars, and the first row and first column. The first row and first column are easily recognizable because of their light background color. They are only used for spreadsheet editing purposes and are not included in the spreadsheet that appears as an OLE object on the slide.

Note

Do not double click on an OLE spreadsheet object when moving or resizing. Double clicking opens the OLE object editing mode for spreadsheets.

Spreadsheets

To include a spreadsheet in an Impress presentation, either insert an existing spreadsheet file or insert a new spreadsheet as an OLE object. For more information on spreadsheets, see the Calc Guide and the Getting Started Guide.

Embedding a spreadsheet into Impress includes most of the functionality of a Calc spreadsheet. Impress is capable of using Calc functions to carry out calculations and data analysis. However, if complex data or formulas are going to be used, it is recommended to perform those operations in a separate Calc spreadsheet first, then embed the spreadsheet into Impress with the results.

It is tempting to use spreadsheets in Impress for creating tables or presenting data in a tabular format. However, inserting a table into Impress is often more suitable and faster, depending on the complexity of the data. See Chapter 3, Adding and Formatting Text for more information on inserting and formatting tables.
Note

The entire spreadsheet is inserted into a slide as an OLE object. If the spreadsheet contains more than one sheet and the one required is not visible, double-click the spreadsheet and then select a different sheet from the sheet tab row at the bottom. See “Editing OLE objects” on page 256 for more information on editing a spreadsheet as an OLE object.

Editing spreadsheets

When a spreadsheet is inserted into a slide, it is in edit mode ready for inserting or modifying data or modifying the format (Figure 214). The following also happens to provide tools and functions for spreadsheets:

- A Calc formatting toolbar opens at the top of the Workspace as shown by the example in Figure 214. The following tools become available providing basic formatting for spreadsheets:
  - Name Box – this gives the active cell reference or the name of a selected range of cells.
  - Function Wizard
  - Select Function
  - Formula.
  - Input Line – this is an edit box for entering data or reviewing the displayed contents of the active cell. If necessary, click on the triangle ▼ on the right to expand the edit box and provide space for long functions requiring multiple lines.

- The Formatting toolbar for spreadsheets (Figure 215) opens replacing the Line and Filling toolbar.

- The Menu bar changes providing spreadsheet formatting options.

Figure 214: Example spreadsheet in Impress

Figure 215: Formatting toolbar for spreadsheets
**Cell navigation**

By default, when an embedded spreadsheet is opened, the active cell is A1. To move around the spreadsheet to select a cell to make it active, use one of the following methods:

- Keyboard arrow keys.
- Position the cursor in a cell and click.
- Press the *Enter* key to move one cell down and *Shift+Enter* combination to move one cell up.
- Press the *Tab* key to move one cell to the right and *Shift+Tab* combination to move one cell to the left.

**Note**

Other keyboard shortcuts are available to navigate around a spreadsheet. Refer to *Getting Started Guide* or the *Calc Guide* for more information.

**Entering data**

Data input into a cell can only be done when a cell is active. An active cell is easily identified by a thickened and bolder border. The cell reference for the active cell is displayed in the *Name Box* at the left hand end of the Calc editing toolbar.

1) Double-click on the embedded spreadsheet to open in edit mode.
2) Select a cell to make it active and start typing in the cell or in the *Input Line*. The data input displayed in the *Input Line* makes the data entry easier to read.
3) Use the various tools and options on the Menu bar to enter data, formula, function, text, or date into a cell.
4) To confirm data input into a cell use one of the following methods:
   - Select a different cell with the cursor.
   - Press the *Enter* key, or the *Shift+Enter* key combination.
   - Press the *Tab* key, or *Shift+Tab* key combination.
5) When finished editing the embedded spreadsheet, click anywhere outside the border to exit edit mode and save the changes.

**Tip**

Sometimes it is useful to treat numbers as text (for example, telephone numbers). To prevent Impress from removing the leading zeros or right aligning numbers in a cell, type a single quotation mark (‘) before entering a number as text.

**Merging cells**

1) Double-click on the embedded spreadsheet to open in edit mode.
2) Highlight the required number of cells to be merged.
3) If there is no data in the cells being merged, use one of the following methods to merge cells:
   - Go to *Format > Merge and Unmerge Cells > Merge and Center Cells* on the Menu bar.
   - Go to *Format > Merge and Unmerge Cells > Merge Cells* on the Menu bar.
   - Right-click on the selected cells and select *Merge Cells* from the context menu.
4) If the selected cells for merging contain data, the Merge Cells dialog (Figure 216) automatically opens. Merge the selected cells as follows:
   a) Use one of the methods in Step 3 to merge cells and open the Merge Cells dialog.
   b) Select an option in the Merge Cells dialog.
   c) Click OK to merge the cells and close the Merge Cells dialog.

5) When finished editing the embedded spreadsheet, click anywhere outside the border to exit edit mode and save the changes.

**Splitting cells**
Only multiple cells that have been merged can be split into separate cells.

1) Double-click on the embedded spreadsheet to open in edit mode.
2) Select a cell that was merged from multiple cells.
3) Split the merged cell into separate cells using one of the following methods:
   - Go to Format > Merge Cells > Split Cells on the Menu bar.
   - Right-click on the cell and select Split Cells from the context menu.
4) When finished editing the embedded spreadsheet, click anywhere outside the border to exit edit mode and save the changes.

**Inserting cells**

1) Double-click on the embedded spreadsheet to open in edit mode.
2) Select the same number of cells on the embedded spreadsheet as are going to be inserted.
3) Insert cells using one of the following methods. Inserting cells opens the Insert Cells dialog (Figure 217).
   - Go to Sheet > Insert Cells on the Menu bar.
   - Right-click on the selected cells and select Insert from the context menu.
   - Use the keyboard shortcut Ctrl++ (macOS ⌘++)
4) Select an insert option for cells, then click OK to insert the cells and close the Insert Cells dialog.
5) When finished editing the embedded spreadsheet, click anywhere outside the border to exit edit mode and save the changes.
Inserting rows

1) Double-click on the embedded spreadsheet to open in edit mode.
2) Select the same number of rows on the embedded spreadsheet as are going to be inserted.
3) Insert rows using one of the following methods:
   - Go to Sheet > Insert Rows > Rows Above or Sheet > Insert Rows > Rows Below on the Menu bar.
   - Right-click on the selected rows and select Insert Rows Above or Insert Rows Below from the context menu.
   - Open the Insert Cells dialog, as in “Inserting cells” above, and select Entire row to insert rows above the selected rows.
4) When finished editing the embedded spreadsheet, click anywhere outside the border to exit edit mode and save the changes.

Inserting columns

1) Double-click on the embedded spreadsheet to open in edit mode.
2) Select the same number of columns on the embedded spreadsheet as are going to be inserted.
3) Insert columns using one of the following methods:
   - Go to Sheet > Insert Columns > Columns Before or Sheet > Insert Columns > Columns After on the Menu bar.
   - Right-click on the selected columns and select Insert Columns Before or Insert Columns After from the context menu.
   - Open the Insert Cells dialog, as in “Inserting cells” above, and select Entire column to insert columns to the left of the selected columns.
4) When finished editing the embedded spreadsheet, click anywhere outside the border to exit edit mode and save the changes.

Deleting cells

1) Double-click on the embedded spreadsheet to open in edit mode.
2) Select the cells for deletion on the embedded spreadsheet.
3) Delete the selected cells using one of the following methods. Deleting cells opens the Delete Cells dialog (Figure 218).
   - Go to Sheet > Delete Cells on the Menu bar.
   - Right-click on the selected cells and select Delete from the context menu.
4) Select a delete option, then click OK to delete the cells and close the dialog.
5) When finished editing the embedded spreadsheet, click anywhere outside the border to exit edit mode and save the changes.

**Deleting rows**
1) Double-click on the embedded spreadsheet to open in edit mode.
2) Select the rows for deletion on the embedded spreadsheet.
3) Delete the selected rows using one of the following methods:
   – Go to Sheet > Delete Rows on the Menu bar.
   – Right-click on the selected rows and select Delete Rows from the context menu.
   – Open the Delete Cells dialog, as in “Deleting cells” above, and select Delete entire row(s).
4) When finished editing the embedded spreadsheet, click anywhere outside the border to exit edit mode and save the changes.

**Deleting columns**
1) Double-click on the embedded spreadsheet to open in edit mode.
2) Select the columns for deletion on the embedded spreadsheet.
3) Delete the selected columns using one of the following methods:
   – Go to Sheet > Delete Columns on the Menu bar.
   – Right-click on the selected columns and select Delete Columns from the context menu.
   – Open the Delete Cells dialog, as in “Deleting cells” above, and select Delete entire column(s).
4) When finished editing the embedded spreadsheet, click anywhere outside the border to exit edit mode and save the changes.

**Quickly inserting sheets**
1) Double-click on the embedded spreadsheet to open in edit mode.
2) Quickly insert a sheet using one of the following methods:
   – Click on the plus sign to the left of the sheet names and a new sheet is added to the spreadsheet after the last sheet in the spreadsheet.
   – Go to Sheet > Insert Sheet at End on the Menu bar and enter a name for the sheet in the Append Sheet dialog that opens, then click OK. A new sheet is added to the spreadsheet after the last sheet in the spreadsheet.
3) When finished editing the embedded spreadsheet, click anywhere outside the border to exit edit mode and save the changes.

**Note**

If there are multiple sheets in an embedded spreadsheet, only the active sheet is shown on the slide after exiting edit mode.

**Inserting sheets**

For more control over inserting sheets into an embedded spreadsheet, the Insert Sheet dialog (Figure 219) is used as follows:

1) Double-click on the embedded spreadsheet to open in edit mode.

2) Open the Insert Sheet dialog using one of the following methods:
   – Right-click on the sheet names and select **Insert Sheet** from the context menu.
   – Go to **Sheet > Insert Sheet** on the Menu bar.

3) In **Position** select one of the following options:
   – **Before current sheet** – inserts sheets before the active sheet in the spreadsheet.
   – **After current sheet** – inserts sheets after the active sheet in the spreadsheet.

4) In **Sheet** select **New sheet** and the **No. of sheets required**.

5) In the **Name** text box, enter a name for the new sheet. This option is not available if inserting multiple sheets.

6) Click **OK** to insert the sheet and close the Insert Sheet dialog.

![Figure 219: Insert Sheet dialog](image)
7) When finished editing an embedded spreadsheet, click anywhere outside the border to exit edit mode and save the changes.

**Insert sheet from file**

When inserting a sheet from a file, the Insert Sheet dialog has to be used.

1) Double-click on the embedded spreadsheet to open it in edit mode.
2) Open the Insert Sheet dialog using one of the following methods:
   - Right-click on the sheet names and select **Insert Sheet** from the context menu.
   - Go to **Sheet > Insert Sheet** on the Menu bar.
3) In **Position** select one of the following options:
   - **Before current sheet** – inserts sheets before the active sheet in the spreadsheet.
   - **After current sheet** – inserts sheets after the active sheet in the spreadsheet.
4) In **Sheet**, select **From file** and click on **Browse** to open an Insert browser window.
5) Navigate to the file location and select the file.
6) Click on **Open** and the sheet names contained in the file appear in the preview box.
7) If necessary, click on **Link** to create a link to the original file.
8) Select the sheet required for insertion in the preview box.
9) Click **OK** to insert the selected sheet into the embedded spreadsheet and close the Insert Sheet dialog.
10) When finished editing an embedded spreadsheet, click anywhere outside the border to exit edit mode and save the changes.

**Renaming sheets**

1) Double-click on the embedded spreadsheet to open it in edit mode.
2) Select the sheet for renaming to make it active.
3) Right-click on the sheet tab and select **Rename Sheet** from the context menu, or go to **Sheet > Rename Sheet** on the Menu bar.
4) Enter a new name for the sheet in the Rename Sheet dialog that opens.
5) Click **OK** to save the name change and close the Rename Sheet dialog.
6) When finished editing the embedded spreadsheet, click anywhere outside the border to exit edit mode and save the changes.

**Moving or copying sheets**

1) Double-click on the embedded spreadsheet to open it in edit mode.
2) Select the sheet for moving or copying to make it active.
3) Right-click on the sheet tab and select **Move or Copy Sheet** from the context menu, or go to **Sheet > Move or Copy Sheet** on the Menu bar to open the Move/Copy Sheet dialog (Figure 220).
4) Move or copy a sheet to another position within the embedded spreadsheet in the same presentation as follows:
   a) In **Action**, select the **Move** option or **Copy** option.
   b) In **Location**, select a destination from the options in the **To document** drop-down list.
      In Impress, the presentation is named as **Untitled 1 (current document)**.
   c) In **Insert before**, select the position within the spreadsheet from the available list.
d) If necessary, enter a new name for the sheet in the **New name** text box.

e) Click **OK** to move or copy the sheet and close the Move/Copy sheet dialog.

---

**Note**

To move or copy a sheet from an embedded spreadsheet in an Impress presentation into another document, then the target document must be a Calc spreadsheet or a document that contains an embedded Calc spreadsheet.

5) Move or copy a sheet to another document containing a spreadsheet is as follows:

a) Make sure the spreadsheet in the target document is selected.

b) In **Action**, select the **Move** option or **Copy** option.

c) In **Location**, select a destination from the options in the **To document** drop-down list. In Impress, the presentation is named as Untitled 1 (current document). If the document is a Calc spreadsheet, the filename of the Calc spreadsheet is displayed.

d) In **Insert before**, select the position within the spreadsheet from the available list.

e) If necessary, enter a new name for the sheet in the **New name** text box.

f) Click **OK** to move or copy the sheet and close the Move/Copy sheet dialog.

6) To move the sheet within the embedded spreadsheet using the cursor, click on the sheet tab and drag the selected sheet to a new position.

7) When finished editing the embedded spreadsheet, click anywhere outside the border to exit edit mode and save the changes.
**Deleting sheets**

1) Double-click on the embedded spreadsheet to open it in edit mode.
2) Select the sheet for deletion to make it active.
3) Right-click on the sheet tab and select **Delete Sheet** from the context menu, or go to **Sheet > Delete Sheet** on the Menu bar.
4) Click **Yes** to confirm the deletion of the sheet.
5) When finished editing the embedded spreadsheet, click anywhere outside the border to exit edit mode and save the changes.

**Formatting spreadsheets**

For presentation purposes, it may be necessary to change the formatting of a spreadsheet to match the style used in the presentation.

When working on an embedded spreadsheet, any styles created in Calc are also available for use. However, if styles are going to be used, it is recommended to create specific styles for embedded spreadsheets. Calc styles maybe unsuitable when working in Impress.

![Figure 221: Format Cells dialog - Numbers page](image)

---

*Chapter 7, OLE, Spreadsheets, Charts, and Other Objects* | 237
**Cell data formatting**

1) Select a cell or a range of cells in an embedded spreadsheet using one of the following methods:
   - Click in a cell to select it.
   - To select the whole sheet, click on the blank cell at the top left corner between the row and column headers.
   - To select the whole sheet, use the keyboard shortcut `Ctrl+A` (macOS `⌘+A`).
   - To select a column, click on the column header at the top of the spreadsheet.
   - To select a row, click on the row header on the left hand side of the spreadsheet.

2) Open the Format Cells dialog (Figure 221) using one of the following methods:
   - Right-click on a cell and select **Format Cells** from the context menu.
   - Go to **Format > Cells** on the Menu bar.
   - Use the keyboard shortcut `Ctrl+1` (macOS `⌘+1`).

3) Use the various pages in the Format Cells dialog to format the cell data so that it matches the style of the presentation.

4) Click **OK** to close the Format Cells dialog and save the formatting changes.

5) When finished formatting the embedded spreadsheet, click anywhere outside the border to exit edit mode and save the changes.

**Row formatting**

1) Select a row by clicking in the row header.

2) Adjust the row height using one of the following methods:
   - Right-click in the row header and select **Row Height** from the context menu to open the Row Height dialog and set the row height in the **Height** text box.
   - Right-click in the row header and select **Row Height** from the context menu to open the Row Height dialog and select **Default value** for row height.
   - Right-click in the row header and select **Optimal Height** from the context menu to open the Optimal Height dialog. Enter an optimal height in the **Add** text box or select **Default value**. The optimal row height depends on the font size of the largest character in a row.
   - Hover the cursor over the bottom border in the row header until it changes shape, then click and drag the border to increase or decrease the row height.

3) When finished formatting the embedded spreadsheet, click anywhere outside the border to exit edit mode and save the changes.

**Column formatting**

1) Select a column by clicking in the column header.

2) Adjust the column width using one of the following methods:
   - Right-click in the column header and select **Column Width** from the context menu to open the Column Width dialog and set the column width in the **Width** text box.
   - Right-click in the column header and select **Column Width** from the context menu to open the Column Width dialog and select **Default value** for column width.
   - Right-click in the column header and select **Optimal Width** from the context menu to open the Optimal Column Width dialog. Enter an optimal width in the **Add** text box or select the **Default value**. The optimal column width depends on the longest entry within a column.
Using formatting styles
When using styles in an embedded spreadsheet and the spreadsheet is in edit mode, Impress displays the available styles for a spreadsheet in the Styles deck on the Sidebar (Figure 222). Styles used in an embedded spreadsheet are similar to paragraph styles used in LibreOffice Writer.

1) Select the data in a cell or cells in the embedded spreadsheet.
2) Click on Styles to open the Styles deck in the Sidebar.
3) Double-click on a style to apply that style to the cell data.
4) When finished formatting the embedded spreadsheet, click anywhere outside the border to exit edit mode and save the changes.

Charts
A chart is a graphical interpretation of information that is contained in a spreadsheet. The following information only provides basic information on charts. For more information about creating charts and the use of charts, see the Calc Guide.

Inserting charts
1) Select a slide to insert a chart.
2) Use one of the following methods to insert a chart:
   - Go to Insert > Chart on the Menu bar and an example chart (Figure 223) is inserted at the center of the selected slide in editing mode.
   - Click on Insert Chart on the Standard toolbar and an example chart is inserted in the center of the slide in editing mode.
   - Go to Insert > Object > OLE Object on the Menu bar to insert a chart as an OLE object. See “Introduction” on page 84 for more information on inserting OLE objects.
3) If necessary, click outside the chart area to cancel editing mode.

**Note**

When an embedded chart is in editing mode, the Formatting toolbar (Figure 224) for charts automatically opens replacing the Line and Filling and Standard toolbars.

### Selecting chart types

Data can be presented using a variety of different chart types. Impress contains several examples of chart types that will help to convey information to an audience. Select a chart type using the Chart Type dialog or the **Chart Type** panel in the Properties deck on the Sidebar.

### Chart types

The following summary of available chart types to help selection of a chart type suitable for the data being used to create the chart. Column, bar, pie and area charts are available as 2D or 3D types. For more information on charts, see the *Calc Guide*.

- **Column** – often used to display data that shows trends over time. This chart is the default chart type used when a chart is inserted into a slide. It is recommended to use column charts where there is a relatively small number of data points. If the data is a large time series, it is recommended to use a line chart.
- **Bar** – give an immediate visual impact for data comparison where time is not important, for example comparing the popularity of products in a marketplace.
- **Pie** – give a comparison of proportions. For example, when comparing what different departments spent on different items or what different departments actually spent overall.
They work best with a small range of values, for example six or less. Using larger range of values, the visual impact of a pie chart begins to fade.

- **Area** – are versions of line or column charts. They are useful when emphasis of volume change is required. Area charts have a greater visual impact than a line chart, but the type of data used does make a difference to the visual impact.

- **Line** – are time series with progression. Ideal for raw data and useful for charts with data showing trends or changes over time where an emphasis in continuity is required. On line charts, the X-axis is ideal for representing time series data. 3D lines confuse the viewer, so just using a thicker line gives a better visual impact.

- **XY (Scatter)** – are typically used for showing and comparing numeric values, like scientific, statistical, and engineering data. It combines x and y values into single data points and shows them in irregular intervals, or clusters. The X-axis usually plots the independent variable or control parameter (often a time series).

- **Bubble** – are used to represent three variables. Two variables identify the position of the center of a bubble on a Cartesian graph, while the third variable indicates the radius of the bubble.

- **Net** – are similar to polar or radar graphs and are useful for comparing data not in time series, but show different circumstances, such as variables in a scientific experiment. The poles of the net chart are the Y-axes of other charts. Generally, between three and eight axes are best; any more and this type of chart becomes confusing.

- **Stock** – are specialized column graphs specifically used for stocks and shares. choose traditional lines, candlestick, and two-column charts. The data required for these charts is specialized with a series for opening price, closing price, and high and low prices. The X-axis represents a time series.

- **Column and line** – are a combination of two other chart types. It is useful for combining two distinct, but related data series, for example sales over time (column) and the profit margin trends (line).

*Figure 225: Chart Type dialog*
**Chart Type dialog**

1) Make sure the chart is selected and is in editing mode. The chart has a border and selection handles when in editing mode.

2) Open the Chart Type dialog (Figure 225) using one of the following methods:
   - Click on **Chart Type** on the Formatting toolbar.
   - Go to **Format > Chart Type** on the Menu bar.
   - Right-click on the chart and select **Chart Type** from the context menu.

3) Select a chart type from the left-hand preview box and the chart examples on the right change. The available options for chart types also change to match the selected chart type.

4) Select a chart example from the right-hand preview box.

5) Select the options required for the chart type selected.

6) Click **OK** to close the Chart Type dialog and return to the edit window.

7) Continue to format the chart, add data to the chart, or click outside the chart to return to normal view.

**Sidebar Chart Type**

1) Make sure the chart is selected and is in editing mode. The chart has a border and selection handles when in editing mode.

2) Click on **Properties** on the Sidebar to open the Properties deck.

3) Click on the Chart Type title bar to open the **Chart Type** panel (Figure 226).

4) Select the chart type from the **Chart Type** drop-down list.

5) Select a chart example from the preview box.

![Figure 226: Chart Type panel in Properties deck on Sidebar](image-url)
6) Select the chart elements required for the chart type from the Elements panel on the Sidebar (Figure 227).

7) Continue to format the chart, add data to the chart, or click outside the chart to return to normal view.

**Formatting charts**

**Entering chart data**

1) Make sure the chart is selected and is in editing mode. The chart has a border and selection handles when in editing mode.

2) Open the Data Table dialog (Figure 228) using one of the following methods:
   - Click on Data Table on the Formatting toolbar for charts.
   - Go to View > Data Table on the Menu bar.
   - Right-click on the chart and select Data Table from the context menu.

3) Type or paste information into the cells to enter data into the Data Table dialog.

4) Use the tools in the top of the Data Table dialog to insert, delete or reposition rows or columns.

5) Click on Close to save the changes and close the Data Table dialog.

6) Click outside the chart to return to normal view.
Note

To insert, delete or reposition a column, use the tools **Insert Series**, **Delete Series**, **Move Series Left**, and **Move Series Right** in the Data Table dialog.
Adding or removing chart elements

1) Make sure the chart is selected and is in editing mode. The chart has a border and selection handles when in editing mode.

2) Add an element to the chart using one of the following methods:
   – Go to **Insert** on the Menu bar and select an element from the submenu.
   – Right-click directly on the chart and select an element from the context menu.
   – Right-click directly on the chart wall and select an element from the context menu.
   – Open the **Elements** panel in the Properties deck on the Sidebar (Figure 229) and select an element from the options available.

**Note**

The method selected to add an element changes the type of element that can be added to the chart. Also, when adding some elements to the chart, a dialog may open with more options to select for the element being added.

3) Remove an element from a chart using one of the following methods:
   – Right-click on the chart element and select the delete option from the context menu. The type of element selected for removal changes the delete options in the context menu.
   – Select a chart element and press the *Delete* or *Backspace* key to remove the element from the chart.
   – Open the **Elements** panel in the Properties deck on the Sidebar and deselect the element.

4) Click outside the chart to return to normal view.

Chart and chart elements formatting

For more information on formatting a chart, chart elements, and the formatting options available, see the *Calc Guide*.

1) Make sure the chart is selected and is in editing mode. The chart has a border and selection handles when in editing mode.

2) Format an element on the chart using one of the following methods:
   – Go to **Format** on the Menu bar and select an element for formatting.
   – Right-click on an element and select **Format XXXX** from the context menu. The format options available depend on which chart element has been selected. For example, select the chart wall and the format option is called **Format Chart Wall**.
   – Use the various tools on the Formatting toolbar for charts to format a chart element.

3) Select an element and open a formatting dialog specific for the element selected.

4) Use the various options in the formatting dialog to format the element.

Resizing and moving charts

A chart and its chart elements can be resized and moved just like other objects on a slide. For more information on resizing and moving a chart, see Chapter 5, Managing Graphic Objects and the *Calc Guide*. 
Audio and video

Inserting audio or video

Using a file browser

1) Go to Insert > Audio or Video on the Menu bar and a file browser for Insert Audio or Video opens (Figure 230).
2) Navigate to the folder where the audio or video file is located. Only the audio and video files that are compatible with Impress will be available in the file browser.
3) Select a compatible audio or video file and click Open to embed the file in the center of the slide. The Media Playback toolbar (Figure 231) automatically opens.
4) Reposition and/or resize the audio or video file. See Chapter 5, Managing Graphic Objects for more information.
Using the Gallery

1) If the Gallery deck is not already open, use one of the following methods to open the Gallery deck:
   – Go to View > Sidebar on the Menu bar to open the Sidebar and select Gallery from the options available.
   – Use the keyboard shortcut Ctrl+F5 to open the Sidebar and select Gallery from the options available.
   – Go to View > Gallery on the Menu bar.

2) Browse to a theme containing media files, for example Sounds.

3) Click on the audio or video option required and drag it onto the slide. The Media Playback toolbar automatically opens.

4) Reposition and/or resize the audio or video file. See Chapter 5, Managing Graphic Objects for more information.

Media playback

The Media Playback toolbar automatically opens when an audio or video file is selected. The Media Playback toolbar contains the following tools from left to right:

- Insert Audio or Video – opens the Insert Audio or Video file browser where a media file is selected for insertion into a slide.
- Play – plays the media playback.
- Pause – pauses the playing of the media.
- Stop – stops the playing of media.
- Repeat – if selected, repeats the playing of the media until the tool is deselected.
- Position – selects the position of where to start playing from within the media file.
- Mute – suppresses the volume of a media file.
- Volume – adjusts the volume of the media file.
- Media Path – indicates where the media file is stored on a computer.

Formulas

Go to Insert > Object > Formula Object on the Menu bar to create a formula in a slide. A formula can also be inserted as an OLE object; see “Introduction” on page 84 for more information.

When editing a formula, the Math menu becomes available allowing the creation or editing of a formula. For more information on how to create formulas, see the Math Guide or the Getting Started Guide.

When creating formulas, care should be taken with font sizes to make sure formulas are similar in size to the font used in the presentation. To change font attributes of a formula, go to Format > Font Size on the Menu bar. To change font type, go to Format > Fonts on the Menu bar.

Note

Unlike formulas in Writer, a formula in Impress is treated as an object and is not automatically aligned with the rest of the objects on the slide. The formula can be moved around like other objects in Impress, but cannot be resized.
Drawings, text files, HTML files and other objects

Drawings, text files, HTML files and other objects can be inserted into an Impress presentation, but only objects that are compatible with Impress can be inserted. Go to Insert > File on the Menu bar to open a file selection dialog. Only files compatible with Impress are available for selection. Drawings, text files, HTML files and other objects can also be inserted as OLE objects; see “Introduction” on page 84 for more information.
Chapter 8,
Adding and Formatting Slides, Notes, Comments, and Handouts
Working with slides

Inserting new slides
A new slide is inserted into a presentation after the selected slide that is displayed in the Workspace. If slide masters have been used in the presentation, the inserted slide uses the master slide of the selected slide displayed in the Workspace.

1) Open the presentation where new slides are going to be added, or create a new presentation.
2) Make sure Normal view is selected in the Workspace.
3) To insert a new slide between slides, select the slide in the presentation where a new slide is going to be inserted after the selected slide, then use one of the following methods to insert a new slide:
   - Go to Slide > New Slide on the Menu bar.
   - Right-click on the selected slide in the Slides pane and select New Slide from the context menu.
   - Right-click on the selected slide in the Slide Sorter view and select New Slide from the context menu.
   - Use the keyboard shortcut Ctrl+M (macOS ^+M).
4) To insert a new slide at the end of a presentation make sure there are no slides selected in the Slides pane, then use one of the following methods:
   - Go to Slide > New Slide on the Menu bar.
   - Right-click in an empty area in the Slides pane and select New Slide from the context menu.

Inserting slides from a file

1) Open the presentation where new slides are going to be added, or create a new presentation.
2) Make sure Normal view is selected in the Workspace.
3) Select the slide in the presentation where a new slide is to be inserted after the selected slide. Alternatively, to insert a slide at the end of the presentation, make sure that there are no slides selected in the Slides pane.
4) Go to Slide > Insert Slide from File on the Menu bar to open the Insert File dialog (Figure 232).
5) Navigate to the presentation file where the slide is located and click on Open to open the Insert Slides/Objects dialog (Figure 233).

Figure 232: Insert File dialog
6) Click on the triangle next to the filename in the Insert Slides/Objects dialog to expand the list of slides.

7) Select the slides required for insertion into the presentation.

8) If required, select the Link option to embed the slide as an OLE object.

9) If required, select Delete unused backgrounds to remove any unreferenced background slides and presentation layouts from the presentation.

10) Click OK to insert the slide into the presentation and close the dialog.

**Note**

When inserting a slide from a file, a slide can be optionally linked instead of copying. This embeds the slide into a presentation using OLE. See Chapter 7, OLE, Spreadsheets, Charts, and Other Objects for more information about OLE.

**Tip**

Figure 233 shows the importance of giving descriptive names to slides in a presentation to help with identification. Refer to “Renaming slides” on page 283 for more information.

**Copying and pasting between presentations**

1) Open the presentation that contains the required slide(s) for copying.

2) Make sure that the Slide Sorter view is open in the Workspace to easily locate the slide(s) for copying.

3) Select the required slide(s) and copy using one of the following methods:
   - Go to Edit > Copy on the Menu bar.
   - Right-click and select Copy from the context menu.
   - Click on Copy in the Standard toolbar.
   - Use the keyboard shortcut Ctrl+C (macOS ⌘+C).
4) Open the presentation where the copied slide(s) is going to be pasted into.
5) Make sure that Slide Sorter view is open in the Workspace.
6) Select the slide at the point where the copied slide(s) are going to be pasted. Alternatively, to paste a slide at the end of the presentation, make sure that there are no slides selected in the Slides pane.
7) Paste the copied slide(s) into the presentation using one of the following methods:
   – Go to Edit > Paste on the Menu bar.
   – Right-click and select Paste from the context menu.
   – Click on Paste in the Standard toolbar.
   – Use the keyboard shortcut Ctrl+V (macOS ⌘V).

**Dragging and dropping between presentations**

1) Open both presentations where slides are going to be moved or copied between.
2) Make sure that both presentations are open in Slide Sorter view in the Workspace.
3) In the target presentation, select the slide at the point where the copied slides are going to be inserted. Alternatively, to insert slides at the end of the target presentation, make sure that there are no slides selected in the Slides pane.
4) In the source presentation, select the required slides that are being moved or copied.
5) To move the slides, click on the selected slides then drag and drop the selected slides into the target presentation.
6) To copy the slides, click on the selected slides and hold down the Ctrl key (macOS ⌘) while dragging and dropping the slides into the target presentation.

**Duplicating slides**

Duplicating a slide is an easy method of adding slides to a presentation if the new slides are to inherit formatting, layout, and animations from a selected slide.

1) Open Normal or Slide Sorter views in the Workspace.
2) Select the slides for duplication in the Slide Sorter view or the Slides pane.
3) Go to Slide > Duplicate Slide on the Menu bar, or right click on the selected slides and select Duplicate Slide from the context menu. The duplicated slides are inserted into the presentation after the selected slides.

**Tip**

Duplicating a slide is a good way of preventing slides from being shown with too much information, which can make it difficult for an audience to understand. If a slide becomes crowded with information, try duplicating the slide and splitting the information points over two or more slides. All the formatting, backgrounds, and so on are preserved in each duplicated slide.

**Renaming slides**

1) Open Normal or Slide Sorter views in the Workspace.
2) Select a slide and open the Rename Slide dialog using one of the following methods:
   – Go to Slide > Rename Slide on the Menu bar.
   – Right-click on the selected slide in the Slides pane and select Rename Slide from the context menu.
3) Right-click on the selected slide in the **Slide Sorter** view and select **Rename Slide** from the context menu.

4) In the Rename Slide dialog, type a new name for the slide in the **Name** text box.

**Expanding slides**

Occasionally there may be a slide with too many points to fit in the space available. Instead of reducing the font size or using other methods to squeeze more text onto the slide, it is better to subdivide the contents of the slide into two or more slides.

1) Select the slide for expansion in the Slides pane.

2) Go to **Slide > Expand Slide** on the Menu bar. This creates new slides from the first outline level on the original slide. The first outline level becomes the title of each new slide. Outline levels below each first level on the original slide are moved up one outline level in the new slides. An example of expanded slides is shown in Figure 234.

3) If necessary, rearrange the new slides in the presentation order.

**Creating summary slides**

Summary slides are useful for creating an agenda for a presentation.

1) Select the slide that will be the first slide to appear in the summary.

2) Go to **Slide > Summary Slide** on the Menu bar to create a summary slide at the end of the presentation. Bullet points are created using the titles of the slides in the presentation. An example summary slide is shown in Figure 235.
3) If necessary, move the summary slide to the position where it is to appear in the presentation.

**Note**
When expanding a slide or creating a summary slide, the selected slide must contain an outline.

### Deleting slides
Select a slide or slides in the Slides pane, *Normal* view, or *Slide Sorter* view in the Workspace, then use one of the following methods to delete slides:

- Go to *Slide > Delete Slide* on the Menu bar.
- Right-click on a selected slide and select *Delete Slide* from the context menu.
- Press the *Delete* or *Backspace* key.

### Creating slides from an outline
When planning a presentation it may be useful to develop an outline from a LibreOffice Writer file. Once the outline is created, one or more separate slides can be created for each of the top level outline elements.

**Using a Writer document**

1) Open the file in Writer that is going to be used as a base to create a presentation outline.

2) Go to *File > Send > Outline to Presentation* on the Writer Menu bar. A new presentation is created and opens in Impress Outline view and the heading paragraph styles are converted into the outline styles used in Impress. An example outline from a Writer document is shown in Figure 236.

3) If necessary, duplicate or expand slides and manually change slide contents to create a simpler presentation for better understanding by an audience. For more information, see “Duplicating slides” on page 283 and “Expanding slides” on page 284.

**Note**
To create a presentation from a Writer document, the Writer document must contain headings formatted using heading paragraph styles.
Using AutoAbstract

1) Open the file in Writer that is going to be used as a base to create a presentation outline.

2) Go to File > Send > AutoAbstract to Presentation on the Writer Menu bar to open the Create AutoAbstract dialog (Figure 237).

3) Select the number of outline levels to be created in the presentation in the Included outline levels box. For example, if three levels are selected, all headings formatted with Heading 1 to 3 styles are included as Outline levels 1 to 3.

4) Select the number of paragraphs for each outline level to be created in the presentation in the Paragraphs per level box. For example, if three paragraphs are selected, each outline level will contain three paragraphs.

5) Click OK to close the Create AutoAbstract dialog and create an outline in a new Impress presentation.

6) Some outline levels may have too many points to fit on one slide. If necessary, duplicate or expand slides and manually change slide contents to create a simpler presentation that an audience will understand better. For more information, see “Duplicating slides” on page 283 and “Expanding slides” on page 284.
7) When the presentation is created, some hierarchical structure of the outline may be lost. If necessary, use **Promote** or **Demote** tools on the Outline toolbar (Figure 238) to move the outline points to the correct level.

![Outline toolbar](image)

*Figure 238: Outline toolbar*

To create a presentation using AutoAbstract and send content from Writer to Impress, the text must contain headings formatted with the heading paragraph styles.

### Copying and pasting an outline

1) Open the file in Writer containing the outline that is going to be used as a presentation outline.

2) Highlight the outline and select **Edit > Copy** on the Menu bar, or right click on the selected outline and select **Copy** from the context menu.

3) Create a new presentation in Impress or create a new slide in an existing presentation.

4) Select the required layout for the slides. For more information, see Chapter 1, Introducing Impress.

5) Paste the copied outline into the text area of the slide. Do not worry if the text does not fit the space on the slide.

6) If the slide contains too much text, duplicate or expand slides and manually change slide contents to create a simpler presentation that an audience can better understand. For more information, see “Duplicating slides” on page 283 and “Expanding slides” on page 284.

7) When the presentation is created, some hierarchical structure of the outline may be lost. If necessary, use **Promote** or **Demote** tools on the Outline toolbar to move the outline points to the correct level.

### Formatting slides

Use master slides in a presentation to create a professional look and avoid manually modifying the formatting of each individual slide. Multiple master slides can be used in a single presentation to provide the same look to groups of slides or individual slides. See Chapter 2, Master Slides, Styles, and Templates for more information about using master slides.

### Slide setup

**Slide Setup dialog**

1) Make sure that **Normal** view is selected in the Workspace.

2) Open the Slide Properties dialog (Figure 239) using one of the following methods:
   - Go to **Slide > Slide Properties** on the Menu bar.
   - Right-click in an empty area on the slide and select **Slide Properties** from the context menu.
3) Use the various options available in the **Slide**, **Background**, and **Transparency** pages in the Slide Setup dialog to setup the slide. See Chapter 2, Master Slides, Styles and Templates for more information on the various options available in the Slide Properties dialog.

4) Click **OK** to save the changes and close the Slide Setup dialog.

**Sidebar Slide section**

Options selected in the **Slide** panel (Figure 240) in the Properties deck on the Sidebar are applied immediately to the slide.

1) Make sure that **Normal** view is selected in the Workspace.

2) Click on **Properties** in the Sidebar to open the Properties deck.

3) Click on **Slide** to open the Slide panel in the Properties deck.

4) Select the slide size to use from the predefined sizes in the **Format** drop-down list.

5) Select the slide orientation to use from the **Orientation** drop-down list.

6) Select the slide background to use from the **Background** drop-down list. The background type selected changes the options available. For more information on slide backgrounds, see Chapter 2, Master Slides, Styles and Templates.

7) If necessary, select the master slide to use from the **Master Slide** drop-down list.

8) If necessary, select to use or deselect not to use **Master Background or Master Objects** on the slide. Only available if a master slide has been used for the slide.

9) If necessary, click on **Master View** to check on how the master slide selected looks and if it matches the presentation requirements.
Selecting master slides

A master slide can be applied to all the slides in a presentation or only to selected slides in a presentation. This allows the use of more than one master slide in a presentation. For more information on master slides, see Chapter 2, Master Slides, Styles and Templates.

1) Make sure that Normal view is selected in the Workspace.

2) In the Sidebar, click on Master Slides to open the Master Slides deck (Figure 241) and display the master slides available for use.
3) Select a master slide from the options available in the sections for Used in This Presentation, Recently Used, or Available for Use.

4) Apply the selected master slide to slides using one of the following methods:
   – For all slides in the presentation, right-click on the selected master slide and select Apply to All Slides from the context menu.
   – For selected slides only, right-click on the selected master slide and select Apply to Selected Slides from the context menu.

Changing master slides

1) Make sure that Normal view is selected in the Workspace.
2) Select the slide in the Slides pane so that it appears in the Workspace.
3) Right-click in a blank area on the slide in the Workspace and select Change Slide Master from the context menu to open the Available Master Slides dialog (Figure 242).
4) Navigate the master slides displayed in the Select a Slide Design preview box to locate the required master slide. If the required master slide is not displayed, then click on Load to open the Load Master Slide dialog (Figure 243).
   a) Select the category of master slide required from the Categories list.
   b) Select the template required from the Templates list and a preview of the template appears in the Preview box.
   c) Click OK to close the Load Master Slide dialog and the master slide templates appear in the Select a Slide Design preview box in the Available Master Slides dialog.
5) Select the required master slide from the master slides displayed and click OK. The slide changes to show the new master slide and the Available Master Slides dialog closes.

![Available Master Slides dialog](image)

**Figure 242: Available Master Slides dialog**
Figure 243: Load Master Slide dialog

Figure 244: Slide Properties dialog - Background page
Changing slide background

1) Make sure that Normal view is selected in the Workspace.

2) Select a slide in the presentation.

3) Open the Slide Properties dialog using one of the following methods:
   – Go to Slide > Slide Properties on the Menu bar.
   – Right-click in an empty area on the slide and select Slide Properties from the context menu.

4) Click on Background to open the Background page (Figure 244) and select the type of background required. For more information on background types, see Chapter 2, Master Slides, Styles, and Templates, and Chapter 6, Formatting Graphic Objects.

5) Select from the various options offered by the different background types the background effect for the selected slide.

6) Click OK to save the changes to the background and close the Slide Properties dialog.

Note

Only the background for one slide in a presentation can be changed at a time. To change the background on more than one slide at a time, master slides have to be used. For more information on slide backgrounds, see Chapter 2, Master Slides, Styles and Templates.

Choosing slide layout

After creating a new slide, a layout is then selected to suit the slide contents and the presentation requirements. Impress comes with predefined layouts that can be applied as a starting point for a slide and Figure 245 shows the predefined layouts that are available. If the layouts available in Impress do not fit the presentation requirements, layout elements can be rearranged, duplicated, resized, or deleted as necessary.

![Figure 245: Layouts panel in Properties deck on sidebar](image)
1) Make sure that Normal or Slide Sorter view is selected in the Workspace.

2) Select a slide in the presentation.

3) Change the slide layout using one of the following methods:
   – Select a layout in the Layouts panel in the Properties deck on the Sidebar.
   – Go to Slide > Layout on the Menu bar and select a layout from the options in the submenu.
   – Right-click on the slide in the Slides pane and select Layout from the context menu, then select a layout from the options in the context menu.
   – Right-click on the slide in Slide Sorter view in the Workspace and select Layout from the context menu, then select a layout from the options in the context menu.
   – Right-click in an empty area on the slide in Normal view in the Workspace and select Layout from the context menu, then select a layout from the options in the context menu.

4) When the slide layout has changed, make the necessary formatting, resizing, and repositioning adjustments to the elements on the slide. For more information on adjustments of slide elements, refer to the other chapters in this guide.

**Note**

If the layout is changed on a slide that already contains text and objects, Impress does not delete these elements, but repositions the elements according to the selected layout. This may result in some elements overlapping or being out of position.

**Note**

Custom defined layouts cannot be created and saved in Impress for use on several slides. It is recommended to create a master slide or template that uses a custom layout and can be used on several slides. For more information on master slides and templates, see Chapter 2, Master Slides, Styles, and Templates.

**Note**

Hovering the cursor over a layout in the Layouts panel in the Properties deck on the Sidebar displays the layout type. These layout types match the layout list that is displayed in a context menu or submenu.

**Presentation notes**

Notes provide a convenient way to create reminders or add extra information to slides in a presentation. Notes are not displayed during a presentation. However, using dual displays, notes can be displayed on a second display as a presentation cue.

**Note**

When using a second display, it is recommended to use the Presenter Console. The Presenter Console allows the display on a second screen of presentation notes, the next slide, and other useful information while a slide is shown on the display that the audience sees. For more information on the Presenter Console, see Chapter 1, Introducing Impress and Chapter 9, Slide Shows & Photo Albums.
Click to add Notes

Figure 246: Notes view in Workspace

Click to move the slide

Click to edit the notes format

Figure 247: Master Notes view in Workspace
Adding notes

1) Select a slide to add notes to and open the Notes view (Figure 246) using one of the following methods:
   - Click on Notes at the top of the Workspace.
   - Go to View > Notes on the Menu bar.
   - Click on Display Views and select Notes in Edit Modes on the Standard toolbar.

2) Click on Click to add notes below the slide then type or paste text or graphics as required into the notes box.

3) To add notes to another slide, repeat Steps 1 and 2.

4) When adding notes, is complete, return to Normal view in the Workspace.

Note

The notes text box and slide image can be moved and resized on the Notes page. Also, more text boxes can be added to the Notes page. Refer to the other chapters in this guide for more information.

Formatting notes

It is recommended to use Master Notes to format the appearance of notes, rather than formatting notes individually for each slide.

1) Select a slide that has notes added.

2) Open Master Notes view (Figure 247) using one of the following methods:
   - Go to View > Master Notes on the Menu bar.
   - Click on Master on the Standard toolbar, then click on Notes at the top of the Workspace.
   - Click on Display Views and select Master Notes in Master Modes on the Standard toolbar.

3) Open the Slide Properties dialog for master notes (Figure 248) using one of the following methods:
   - Go to Slide > Slide Properties on the Menu bar.
   - Right-click in an empty area on the master note and select Slide Properties from the context menu.

4) Use the various options available in the Slide Properties dialog to setup the master note. See Chapter 2, Master Slides, Styles and Templates for more information on the various options available in the Slide Properties dialog.

5) Click OK save the formatting changes and close the Slide Properties dialog.

Adding text

When text is inserted in the Notes text box, it is automatically formatted using the predefined Notes style that is in Presentation Styles in the Styles deck on the Sidebar. The Notes style cannot be deleted, but can be modified to match the presentation requirements.

Text boxes can also be added to the notes page and then modified to suit the presentation requirements. Also, text styles for any text in a text box can be created to suit the text requirements. Any text styles created are placed in the Custom category. These custom styles can be deleted when there is no further requirement for the custom style.
Figure 248: Slide Properties dialog in Notes view

Figure 249: Notes dialog
For more information on creating styles, adding text, and formatting text, see Chapter 2, Slide Masters, Styles and Templates, or Chapter 3, Adding and Formatting Text.

1) Click on **Styles** on the Sidebar to open the Styles deck.
2) Click on **Presentation Styles** at the top of the Styles deck to open **Presentation Styles**.
3) Right click on **Notes** presentation style and select **Modify** from the context menu. This opens the Notes dialog (Figure 249).
4) Use the various pages and options in the Notes dialog to modify the **Notes** presentation style to the presentation requirements.
5) Click OK to save the changes and close the Notes dialog.

**Headers and Footers**

In Notes, information can be entered into the header and footer areas on the notes page. The header and footer areas are similar to the header and footer areas used in the master slides. The header and footer areas are Header text; Date and time – fixed or variable; Footer text; Page number.

1) Select a slide that has notes added and open the **Notes** view. See “Adding notes” on page 295.
2) Open Master Notes view. See “Formatting notes” on page 295.
3) Go to **Insert > Header and Footer** on the Menu bar to open the Header and Footer dialog (Figure 250).
4) Click on **Notes and Handouts** to open the **Notes and Handouts** page.
5) To add header text to the notes page, select **Header** and enter the text for the header in the **Header text** text box.

![Header and Footer dialog - Notes and Handouts page](image)

**Figure 250: Header and Footer dialog - Notes and Handouts page**
6) To add the date and time to the notes page, select Date and time and enter a fixed or variable date and time as follows:
   - If the date and time is fixed, select Fixed and enter the date and time required in the Fixed text box.
   - If the date and time is variable, select Variable, then select the date and time format from the Format drop-down list and select the language used from the Language drop-down list. The language selected affects the available date and time formats.

7) To add footer text to the notes page, select Footer and enter the text for the footer in the Footer text box.

8) To add page numbers to the notes page, select Page Number so that the page number appears on each notes page in a presentation.

9) Click on Apply to All to save the changes and close the Header and Footer dialog.

### Printing notes

For more information on printing slides and notes, see Chapter 10, Printing, E-mailing, Exporting, and Saving Slide Shows.

#### Linux or Windows

1) Select a slide that has notes added and open the Notes view. See “Adding notes” on page 295.

2) Go to File > Print on the Menu bar, or use the keyboard shortcut Ctrl+P to open the Print dialog (Figure 251).

3) Select the LibreOffice Impress tab to open the LibreOffice Impress page and access the options for printing notes.

4) In Document, select Notes from the Type drop-down list.

5) In Contents, Color, and Size, select any additional options that are required, for example Slide name, Original colors, Original size.

6) Click OK to print and close the Print dialog.

#### macOS

1) Select a slide that has notes added and open the Notes view. See “Adding notes” on page 295.

2) Go to File > Print on the Menu bar, or use the keyboard shortcut macOS +⌘+P to open the Print dialog (Figure 252).

3) Make sure that LibreOffice is selected from the drop-down list.

4) In LibreOffice Impress, select Notes from the Document drop-down list.

5) In Contents, Color, and Size, select any additional options that are required, for example Slide name, Original colors, Original size.

6) Click OK to print and close the Print dialog.

### Exporting notes as PDF

The PDF contains separate pages for the slides and the notes. For example, if the presentation has 10 slides, the PDF contains 20 pages consisting of 10 pages of individual slides followed by 10 pages of notes formatted for the paper size selected.

1) Select a slide that has notes added and open the Notes view. See “Adding notes” on page 295.
Figure 251: Print dialog - LibreOffice Impress page for Linux or Windows

Figure 252: Print dialog - LibreOffice Impress page for macOS
2) Go to File > Export As > Export as PDF on the Menu bar to open the PDF Options dialog (Figure 253).

3) On the General page, select the option Export notes pages.

4) If necessary, select Export only notes pages to create a PDF file that only contains the presentation notes.

5) If required, open the other pages in the PDF Options dialog and select the necessary options to create a PDF file.

6) Click on Export to open a file browser window and navigate to the folder where the PDF file is to be saved.

7) Enter a filename, click on Save to save the file in the designated folder and close the file browser window and PDF Options dialog.

**Inserting comments**

1) Select Tools > Options > LibreOffice > User Data to configure the name and initials that appear in a comment. This is necessary so that user initials appear in comments and identify the comment author.

2) In Normal view, go to Insert > Comment on the Menu bar or use the keyboard shortcut Ctrl+Alt+C (macOS ⌘+⌘+C) to insert a comment (Figure 254).
   - A small comment marker containing the user initials creating the comment appears in the upper left-hand corner of the slide along with a larger comment box. Impress automatically adds the user name and current date at the bottom of the comment box.
   - If more than one user edits the document, each user is automatically allocated a different background color.
3) Type or paste the text into the comment box.

4) If necessary, move the small comment marker anywhere to a different position on the slide. This is normally on or near an object being referred to in the comment.

5) To show or hide the comment markers, go to View > Comments on the Menu bar.

### Printing handouts

Handouts are used to distribute a copy of the presentation slides to each member of an audience and are printed using the printing options available in Impress. Figure 255 shows an example of handouts ready for printing.

**Note**

The printing of handouts depends on the printer, computer operating system, and computer setup. The following printing procedure for handouts is only an example of how to print handouts.

1) If required, create headers and footers for the handouts as follows:
   a) Go to Insert > Header and Footer on the Menu bar to open the Header and Footer dialog.
   b) Click on Notes and Handouts to open the Notes and Handouts page.
   c) Select the required header and footer options from the default options. See “Headers and Footers” on page 297 for more information.
   d) Click on Apply to All to save the options for the handouts and close the Header and Footer dialog.

2) Go to File > Print on the Menu bar, or use the keyboard shortcut Ctrl+P (macOS ⌘+P) to open the Print dialog.
3) For Linux or Windows – click on **LibreOffice Impress** to open the page for handout printing and select the printing options from the **Document** drop–down lists as follows:
   – **Type**: – select **Handouts** from the drop down list.
   – **Slides per page**: – select how many slides are printed on a sheet of paper.
   – **Order**: – select the order in which the slides are printed on a sheet of paper.

4) For macOS – make sure **LibreOffice** is selected and select the printing options from the **LibreOffice Impress** drop–down lists as follows:
   – **Document**: – select **Handouts** from the drop down list.
   – **Slides per page**: – select how many slides are printed on a sheet of paper.
   – **Order**: – select the order in which the slides are printed on a sheet of paper.

5) In **Contents**, select **Slide name**, **Date and time**, or **Hidden pages** if one or all of these options are to be printed on the handouts.

6) In **Color**, select one option on how the handouts are printed.

7) In **Size**, select one option on how the handouts are printed.

8) Click on **Print** to print the handouts and close the Print dialog.
Chapter 9, Slide Shows and Photo Albums
Introduction

LibreOffice Impress provides the tools to organize and display a slide show, including:

• Which slides to show and in what sequence.
• Whether to run the show automatically or manually.
• Transitions between slides.
• Animations on individual slides.
• Interactions: what happens when clicking on a button or link.
• A presenter console.

Creating slide shows

Basic settings

Most tasks associated with putting together a slide show are best done in Slide Sorter view where all of the slides in the presentation appear in the Workspace.

9) Open the Slide Sorter view (Figure 256) using one of the following methods:
   – Go to View > Slide Sorter on the Menu bar.
   – Click on the Slide Sorter tab at the top of the Workspace.

10) Go to Slide Show > Slide Show Settings on the Menu bar to open the Slide Show Settings dialog (Figure 257).

11) Select the options required for the slide show.

12) Click OK to save the changes and close the Slide Show Settings dialog.

Figure 256: Slide Sorter view
Slide Show options

- **Range** – select which slides to include in the slide show.
  - *All slides* – includes all slides except for those slides marked Hidden (see “Hiding slides” on page 309). Slides are shown in the sequence they occur in the file. To change the sequence, either rearrange the slides in Slide Sorter view or select the custom slide show option.
  - *From* – starts the show at the slide selected from the drop-down list. For example, there maybe several slides at the beginning that describe the company, but when presenting this slide show to work colleagues, this introduction could be skipped.
  - *Custom slide show* – shows the slides in a different sequence from the sequence previously setup. This setting is not available until a custom slide show has been setup (see “Custom slide show” on page 310). Many different custom shows can be setup as required from one set of slides and they appear in the drop-down list for this option.

- **Presentation Mode** – select how the slides are displayed.
  - *Full screen* – shows the slides full screen without the LibreOffice program controls visible and exits the show after the last slide.
  - *In a window* – runs the slide show in the Impress window and exits the show after the last slide.
  - *Loop and repeat after* – restarts the slide show after the last slide has displayed and after the specified time delay. Setting of this option allows the slide show to automatically run continuously. A pause slide is displayed between the last slide and the start slide. Press the Esc key at any time to stop the show. If zero is entered as time delay, the show restarts immediately without showing a pause slide.
– **Show logo** – shows the LibreOffice logo on the pause slide when *Loop and repeat after* option is selected.

**Note**

Before selecting the option *Loop and repeat after*, make sure that the option *After* is selected and that an interval time setting has been entered. The option *After* is in **Advance slide** options located in the Slide Transitions deck on the Sidebar (Figure 262 on page 313). If there is no interval time setting for *After*, then the option *Loop and repeat after* will not function.

**Options** – determine how the slide show runs as a presentation.

– **Change slides manually** – prevents slides from changing automatically even if an automatic transition has been set up.

– **Mouse pointer visible** – shows the mouse pointer during a slide show. If a laser pointer or other device is being used to highlight items of interest during the show, this can be useful.

– **Mouse pointer as pen** – enables writing or drawing on slides during the presentation. Anything written with the pen is not saved when exiting the slide show. The color of the pen cannot be changed.

– **Animations allowed** – displays all frames of animated GIF files during the slide show. If this option is not selected, only the first frame of an animated GIF file is displayed. This has nothing to do with the slide animations described in “Animations” on page 315.

– **Change slides by clicking on background** – advances to the next slide when the slide background is clicked. Also, pressing the spacebar advances to the next slide.

– **Presentation always on top** – prevents any other program window from appearing on top of the presentation.

**Multiple Displays** – determines how the slide show is displayed.

– **Presentation display** – select from the drop-down list which display to use for full screen slide show mode. Only available if the computer being used for the slide show is connected to more than one display monitor.

**Note**

The multiple displays setting is not an option saved with the presentation file, but is instead saved as a local setting in the user configuration for the computer. This means that if the presentation is opened on a different computer, the local settings for that computer are applied.

**Hiding slides**

Some slides may not be required in a particular slide show. Either hide some of the slides or set up a custom slide show to suit the requirements. For example, there maybe draft slides that are not shown until they are finished, or there maybe some slides that contain information that is not to be shown to an audience.

**Hiding slides**

1) In the **Slides** pane, or **Slide Sorter** view in the Workspace, select the slides that are to be hidden.
2) Hidden slides are displayed greyed out indicating that it is hidden as shown in Figure 258. The slide is not deleted and remains in the presentation file. Hide selected slides using one of the following methods:
   – Click on Hide Slide in the Slide View toolbar (Figure 259).
   – Right-click on the selected slide and select Hide Slide from the context menu.
   – Go to Slide > Hide Slide on the Menu bar.

Showing hidden slides

1) In the Slides pane, or Slide Sorter view, select the hidden slides.
2) Show the selected slides using one of the following methods. Show Slide is only active when there hidden slides are selected in a presentation.
   – Click on Show Slide in the Slide View toolbar.
   – Right-click on the selected slide and select Show Slide from the context menu.
   – Go to Slide > Show Slide on the Menu bar.

Custom slide show

To show the slides in a different order, rearrange the slides in the Slides pane or Slide Sorter view in the Workspace, or create a custom slide show. In a custom slide show, select which slides to include as well as the order in which they are shown.

Creating custom slide show

1) Go to Slide Show > Custom Slide Show on the Menu bar to open the Custom Slide Shows dialog (Figure 260).
2) Click on New to open the Define Custom Slide Show dialog (Figure 261).
3) Type a name for the new custom slide show in the Name text box.
4) In the **Existing slides** box, select the slides using one of the following methods:
   - Click on an individual slide to select it.
   - Hold down the Shift key and click the first and last slide to create a consecutive group of slides.
   - Hold down the Ctrl key (macOS ⌘) and click on individual slides to create a group of slides.

5) Click on >> to include the slides in the **Selected slides** box.

6) If required, rearrange the slide order in the **Selected slides** box by clicking on a slide name and dragging it to a new position in the list.

7) Click **OK** to close the Define Custom Slide Shows dialog.

8) Click on **Start** to test the custom slide show as a presentation.

9) Click **OK** to save the custom slide show and close the Custom Slide Shows dialog.
Using custom slide show
1) Go to Slide Show > Custom Slide Show on the Menu bar to open the Custom Slide Shows dialog.
2) Select the required custom slide show and click on Start to run the selected custom slide show.
3) When the presentation is over, click OK to close the Custom Slide Shows dialog.

Editing custom slide show
1) Go to Slide Show > Custom Slide Show on the Menu bar to open the Custom Slide Shows dialog.
2) Select the name of the custom slide show for editing.
3) Click on Edit and the Define Custom Slide Show dialog opens.
4) Add slides, remove slides, change the slide order, or change the name of the custom slide show in the Define Custom Slide Show dialog.
5) Click OK to save the custom slide show and close the Custom Slide Shows dialog.
6) Click OK to close the Custom Slide Shows dialog.

Copying custom slide show
1) Go to Slide Show > Custom Slide Show on the Menu bar to open the Custom Slide Shows dialog.
2) Select the name of the custom slide show for copying and click on Copy. The name of the selected custom slide show is repeated with (Copy 1) added to the name.
3) Select the name of the copied custom slide show and click on Edit and the Define Custom Slide Show dialog opens.
4) Change the name of the copied custom slide show in the Define Custom Slide Show dialog.
5) Click OK to save the copied custom slide show and close the Define Custom Show dialog.
6) Click OK to close the Custom Slide Shows dialog.

Deleting custom slide show
1) Go to Slide Show > Custom Slide Show on the Menu bar to open the Custom Slide Shows dialog.
2) Select the name of the custom slide show for deletion and click on Delete. Deletion is immediate and no confirmation message appears.
3) Click OK to close the Custom Slide Shows dialog.

Slide transitions
Slide transitions are effects and/or sounds that take place between slides when slides are changed in a slide show. Transitions add a professional look to a slide show, smoothing the change over between slides.

Adding transitions
1) Click on Slide Transition in the Sidebar to open the Slide Transition deck (Figure 262).
2) Open the presentation file to add slide transitions.
3) In the Slides pane or Slide Sorter view, select the slide to apply a slide transition.
4) Click on the required transition from the displayed list to apply it to the selected slide.

5) In **Modify Transition**, select from the available options as follows:
   - **Variant** – select an option from the drop-down list. The available options change according to the transition that has been selected.
   - **Duration** – enter a time for how long the transition lasts.
   - **Sound** – select a sound from the drop-down list that is played when the transition activates. If a sound is selected, the *Loop until next sound* option becomes active. Select this option to play the sound repeatedly until another sound starts. If there are no subsequent sounds in a slide show, the selected sound plays continuously for the remainder of the show. Sounds can be played when *None* is selected for the transition effect.

6) In **Advance Slide**, select one of the two following options on how the slides change in a presentation. Only one option can be selected as follows:
   - **On mouse click** – each time the mouse is clicked, the presentation advances to the next slide.
   - **After** – enter a time in the box to elapse before the next slide in the presentation advances automatically into view.

**Note**

A time must be entered in *After* to automatically open the next slide and allow the option *Loop and repeat after* in **Presentation Mode** to function when it is required for a slide show to automatically run continuously.
7) If required and to apply the same transition to all slides in the presentation, click on Apply Transition to All Slides option in Advance Slide.

8) To check how the transition looks, click on Play option in Advance Slide.

9) Alternatively, to automatically preview how the transition looks when it is applied to a slide, select Automatic Preview option in Advance Slide.

**Tip**

A single type of transition can be applied to all the slides in the slide show or a different transition to individual slides in the slide show. While using many different transitions may look good, it may make the slide show look unprofessional.

**Removing transitions**

1) Click on Slide Transition in the Sidebar to open the Slide Transition deck.

2) In the Slides pane or Slide Sorter view, select the slide or slides to remove the slide transition.

3) Select None at the top of the available transitions in the Slide Transition deck.

**Note**

Slides with transitions are indicated by a star in the bottom left corner of the slide when viewed in the Slides pane or the Slide Sorter view.

**Playing music**

Music can be played during a slide show instead of a sound as a transition effect. When using music in a slide show, make sure any musical copyright or licensing for the music is not being infringed.

1) Click on Slide Transition in the Sidebar to open the Slide Transition deck.

2) Open the presentation file to add slide transitions.

3) In the Slides pane or Slide Sorter view, select the slide where music is going to be added as part of the slide transition.

4) In Modify Transition, select Other sound from the Sound drop-down list.

5) In the file browser window that opens, navigate to where the music file is located and select the music file required.

6) Click on Play to check if the music file is suitable.

7) If the music is suitable, click Open to add the music to the selected slide and close the file browser window.

8) To play a music file continuously in the slide show, select Loop until next sound in Modify Transition. The music file restarts once it is finished until the next music file that is inserted in the slide show.

**Note**

Do not select the Apply Transition to All Slides option to prevent the selected music file restarting as each slide opens in the presentation.
Note

The music file is linked to a slide show rather than embedded. If the slide show is going to be displayed on a different computer, the music file must be available on the computer where the slide show is going to be displayed and the link to the music file must be established before starting the slide show.

Animations

Slide animations are similar to transitions, but are applied to individual elements in a single slide, such as title, chart, shape, or individual bullet point. Animations can make a presentation more lively and memorable. However, as with transitions, heavy use of animations can be fun, but distracting and even annoying for an audience expecting a professional presentation.

Animations are best applied using Normal view to make it easier to select individual objects on a single slide.

Note

At present it is not possible to apply animations to elements in master slides. This means that to display the items in a text box one by one and use the same animation on more than one slide, the effects have to be applied to each slide. Alternatively, copy the animated element from one slide to another.

Figure 263: Animation deck on Sidebar
Applying animation

On a slide, an element such as a graphic or an entire text box has selection handles around it when selected. If a portion of the text in a text box is selected, selection handles may not be displayed.

The following procedure is an example of applying an animation to an object. The options available for an animation depend on the Category, Effect and slide element that have been selected to create an animation.

1) Go to View > Normal on the Menu bar to open Normal view in the Workspace.
2) Select a slide in the Slides pane so that it appears in Normal view.
3) On the Sidebar, select Animation to open the Animation deck (Figure 263).
4) Select a slide element that is going to be animated on the slide that is displayed in Normal view.
5) Click on Add Effect (+ plus sign) to open the animation options and add the slide element into the Animation box.
6) In Category, select a category from the options in the drop-down list.
7) In Effect, select an animation effect from the available options in the Effect list.
8) In Start, select how the animation starts from the options in the drop-down list.
9) In Direction, select the direction of the animation from the drop-down list.
10) In Duration, enter a time for the duration of the animation in the box.
11) In Delay, enter a time for the delay before the animation starts in the box.
12) If more animation options are required, see “Additional animation options” on page 317 for more information.
13) If required, select Automatic Preview so to automatically check how the animation looks when it is applied to a slide element.
14) Click on Play to check how the animation looks when applied to a slide element.

Changing animation

1) Go to View > Normal on the Menu bar to open Normal view in the Workspace.
2) On the Sidebar, select Animation to open the Animation deck.
3) Select a slide in the Slides pane so that it appears in Normal view.
4) Select the slide element in the Animation box that has the animation effect that is going to be changed.
5) Use the procedure in “Applying animation” on page 316 to select a new animation effect for the selected element.
6) Click on Play to check how the animation looks when applied to a slide element.

Removing animation

1) Go to View > Normal on the Menu bar to open Normal view in the Workspace.
2) On the Sidebar, select Animation to open the Animation deck.
3) Select the slide and the animated element being removed.
4) Click on Remove Effect to remove the animation from the selected element.
Additional animation options

Some animations have additional options that can be set or changed. Available options are dependent on the animation selected.

1) Go to View > Normal on the Menu bar to open Normal view in the Workspace.
2) On the Sidebar, select Animation to open the Animation deck.
3) Select the slide and element to apply additional animation options.
4) Click on Options to the right of the Direction drop-down list and open the Effect Options dialog (Figure 264).
5) Select the options required for the animation effect. For more information on effect options, see “Effect options”, “Timing options” and “Text animation options” below.
6) Click OK to save the changes and close the Effect Options dialog.

Effect options

Specifies the settings and enhancements for the selected animation using the following options on the Effect page in the Effect options dialog (Figure 264).

- **Direction** – specifies the direction for the effect.
- **Sound** – select a sound from the drop-down list or select one of the special entries as follows:
  - *(No sound)* – no sound is played during animation of the effect.
  - *(Stop previous sound)* – the sound of the previous effect is stopped as soon as the current effect runs.
  - *Other sound* – displays a file open dialog to select a sound or music file.
- **After animation** – select what happens after animation.
  - *Don't dim* – no after-effect runs.
– **Dim with color** – after the animation a dim color fills the shape.
– **Hide after animation** – hides the shape after the animation ends.
– **Hide on next animation** – hides the shape on the next animation.

- **Dim color** – select the dim color. Only available if Dim with color has been selected.
- **Text animation** – select the animation mode for the text of the current shape:
  – **All at once** – animates the text all at once.
  – **Word by word** – animates the text word by word.
  – **Letter by letter** – animates the text letter by letter.

- **Delay between characters** – specifies the percentage of delay between animations if Word by word or Letter by letter has been selected for Text animation.

**Timing options**
Specifies the timing for the selected animation using the following options on the Timing page of the Effects Options dialog (Figure 265).

- **Start** – displays the start property of the selected animation effect.
  – **On click** – the animation stops at this effect until the next mouse click.
  – **With previous** – the animation runs immediately.
  – **After previous** – the animation runs as soon as the previous animation ends.

- **Delay** – specifies an additional delay in seconds until the effect starts.
- **Speed** – specifies the duration of the effect in seconds.

![Effect Options dialog - Timing page](image)

*Figure 265: Effect Options dialog - Timing page*
• **Repeat** – specifies when and how to repeat the current effect. Enter the number of repeats, or select from the list:
  – *none* – the effect is not repeated.
  – *Until next click* – the animation is repeated until the next mouse click.
  – *Until end of slide* – the animation repeats as long as the slide is displayed.
• ** Rewind when done playing** – the animated shape returns to its starting state after the animation ends.
• **Animate as part of click sequence** – allows the animation start in a normal click sequence.
• **Start effect on click of** – allows the animation start when a specified shape is clicked. Select the shape by its name from the drop-down list.

**Text animation options**
Specifies the text animation settings for the selected animation using the following options on the Text Animation page of the Effects Options dialog (Figure 266).

• **Group text** – specifies how multiple paragraphs are animated:
  – *As one object* – all paragraphs are animated as one object.
  – *All paragraphs at once* – all paragraphs are animated at once, but paragraphs can have different effects.
  – *By 1st level paragraphs* – the first level paragraphs, including sub-level paragraphs, are animated one after another.
• **Automatically after** – if By 1st level paragraphs is selected for Group text, the paragraphs are animated one after the other. Enter an additional delay in seconds to animate subsequent paragraphs.
• **Animate attached shape** – deselect this box to animate only the text, not the shape.
• **In reverse order** – animates the paragraphs in reverse order.

![Effect Options dialog - Text Animation page](image)

**Animation example**
Creating animations on a slide takes practice to achieve the animation effect required. The following steps explains how to setup the simple example animation shown in Figure 267 using multiple animations. The example slide is taken from a LibreOffice presentation. It would be very easy to create a similar slide and recreate this example.

1) Go to **View > Normal** on the Menu bar to open **Normal** view in the Workspace.
2) Select a slide for animation.
3) On the Sidebar, select Animation to open the Animation deck.
4) Select the elements on the slide, then click on Add Effect (+ plus sign) to open the animation options on the Animation deck. The selected elements appear in the box on the Animation deck.
5) Select the first element (Shape 11) and select Entrance from the Category drop-down list and select the following options for the animation:
   – Effect – Venetian Blinds
   – Start – On click
   – Direction – Vertical
   – Duration – 0.50 sec
6) Select the second element (Shape 3) and select Motion Paths from the Category drop-down list and select the following options for the animation:
   – Effect – 5 Point Star
   – Start – After previous
   – Duration – 10.00 sec
7) Go to Slide Show > Rehearse Timings on the Menu bar and check the animation of these two objects.

**Using interactions**

Interactions are where objects on a slide are used to create an event when clicked on with the mouse cursor. These objects with interactions can be buttons, images, or text objects.

1) Go to View > Normal on the Menu bar to open Normal view in the Workspace.
2) Select a slide to add an interaction to an object on the slide.
3) Select the object, then right-click on the object and select Interaction from the context menu, or go to Format > Interaction on the Menu bar, to open the Interaction dialog (Figure 268).

4) Select an interaction from the Action at mouse click drop-down list. The options available for further selection and to setup the interaction depend on the type of interaction that has been selected.

5) Click OK to save the changes and close the Interaction dialog.

Slide shows

Running a slide show

1) Open a presentation and start the slide show using one of the following methods:
   – Use the keyboard shortcut F5 to start from the first slide or Shift+F5 to start from the current slide.
   – Go to Slide Show > Start from First Slide or Start from Current Slide on the Menu bar.
   – Click on Start from First Slide on the Slide Sorter toolbar.

2) If slide transition is set to Automatically after x sec, the slide show starts and runs after the set time has elapsed.

3) If slide transition is set to On mouse click, use one of the following methods to advance the slides:
   – Click the left mouse button.
   – Press the down arrow key.
   – Press the right arrow key.
– Press the page down key.
– Press the spacebar.

4) To navigate backwards through a slide show one slide at a time, use one of the following methods:
– Press the up arrow key.
– Press the left arrow key.
– Press the page up key.

5) Right-click on a slide during a slide show to open a context menu with more navigation options. For more information on these navigation options, see “Context menu navigation and options” below.

6) When the last slide has displayed, the message *Click to exit presentation* is displayed on screen. Press the *Esc* key or click the mouse button to exit the slide show.

7) To exit the slide show and return to the Impress workspace at any time, press the *Esc* key during the slide show.

**Note**

During the slide show, any animations on a slide are run in the configured order as the slide is displayed.

**Context menu navigation and options**

If the slide show consists of more than one slide, right-clicking on the screen opens a context menu displaying navigation options as follows:

- **Next** – moves to the next slide in the slide show.
- **Previous** – moves to the previous slide in the slide show.
- **Go to Slide** – displays a sub-context menu allowing selection and navigation to any slide in the slide show. The list of slides shows the need to name slides in a slide show rather than using the default slide names of Slide 1, Slide 2, and so on. Naming slides makes it easier to identify the required slide.
- **Mouse Pointer as Pen** – allows the cursor to be used as a pen and draw on a slide to emphasize or explain a point.
- **Pen Width** – opens a sub-context menu providing options to set the width of any lines drawn on a slide when using the cursor as a pen.
- **Change Pen Color** – opens a dialog allowing changes to the line color when using the cursor as a pen.
- **Erase all ink on Slide** – deletes all lines drawn after using the cursor as a pen.
- **Screen** – opens a sub-context menu with a black or white color choice. This is useful if the slide show is going to be paused for a break or to demonstrate something else.
- **End Show** – ends the presentation and returns to the Impress workspace. This is the same effect as pressing the *Esc* key.

**Automatic slide show repeat**

1) Select a slide in **Normal** and open the Slide Transition deck in the Sidebar.

2) In the **Advance Slide** panel, make sure the option **After** is selected and a time setting is entered in the box before the next slide is advanced. For more information on transitions, see “Slide transitions” on page 312.
3) Go to **Slide Show > Slide Show Settings** on the Menu bar to open the Slide Show Settings dialog.

4) In **Presentation Mode**, select the option *Loop and repeat after* and insert a time delay in the box before the slide show is displayed again.

5) If necessary, select **Show logo** if a company logo is to be displayed during the pause between slide shows.

6) Click **OK** to save the settings and close the Slide Show Settings dialog.

### Slide show timing

#### Default timing

1) Click on **Slide Transition** in the Sidebar to open the Slide Transition deck.

2) Select *None* in **Slide Transition** as the transition effect.

3) Select the option *After* in **Advance Slide** and set a time in the box.

4) Click on **Apply Transition to All Slides** in **Advance Slide** to set the default timing for the slide show.

5) Go to **Slide Show > Start from First Slide** on the Menu bar to check how the presentation runs.

6) If necessary, adjust the default timing until the slide show runs as required.

#### Variable timing

1) Select **Slide Show > Rehearse Timings** on the Menu bar. The slide show starts in full screen mode and a timer appears in the lower left corner of the display.

2) When advancing to the next slide, click on the timer to set the time duration for the displayed slide and advance to the next slide. To keep the default time duration for a slide, click the slide and not the timer.

3) Continue until the time duration is set for all slides in the slide show. Impress records the time duration set for each slide.

4) To exit from rehearsal timing of the slide show, press the *Esc* key, or click on the slide.

### Presenter Console

LibreOffice Impress normally includes the Presenter Console as part of the LibreOffice installation. If the Presenter Console is not included, the extension can be downloaded from the LibreOffice website and installed on a computer. For more information, see Chapter 11, Setting up and Customizing Impress.

The Presenter Console (Figures 269, 270, and 271) provides extra control over slide shows when using dual displays, such as a laptop for control and a large display or projector for an audience. The view on the laptop display includes the current slide that can be seen by the audience, the next slide in the presentation, any slide notes, and a presentation timer.

**Note**

The Presenter Console only works with operating systems that support two displays. When two displays are being used, one display can be a laptop.

The Presenter Console provides the following views when making a presentation:

- **Default view** – displays the current slide, including any effects and the next slide in the presentation (Figure 269). Click on the **Previous** and **Next** arrows to navigate a presentation.
• **Notes view** – click on Notes to switch to display any notes that accompany each slide in the presentation (Figure 270). Click on Notes again to return to the default view.

• **Slides view** – click on Slides to switch to display the slide thumbnails that are being used for the presentation (Figure 271). Click on Slides again to return to the default view.

• **Exchange** – click on this icon to switch the Presentation Console between displays.

---

Figure 269: Presenter Console - default view

Figure 270: Presenter Console - Notes view
Photo albums

Impress can create a photo album from a set of images, usually with one photo per slide. This photo album can be a slide show or multimedia show with graphics, images, or photographs.

Creating photo album

1) Create a new presentation or open an existing presentation.
2) Select the slide that is going to precede the photo album. In a new presentation, this is the first slide.
3) Go to Insert > Media > Photo Album on the Menu bar to open the Create Photo Album dialog (Figure 272).
4) Click on Add to open a file browser.
5) Navigate to the folder where the photographs are located.
6) Select the photographs and click on Open. This closes the file browser and the selected files appear in the Create Photo Album dialog.
7) Select the number of images per slide in the Slide layout: drop-down list.
8) If required, select Add caption to each slide inserting a text box on each slide allowing a caption to be added to the photographs.
9) If required and there is only one image per slide, select Fill Screen for each photograph to fill the entire slide.
10) Create the required sequence of photographs by moving the files up or down in the list of selected files.
11) When the sequence is ready, click Insert Slides to create the number of slides required for the photo album. Impress creates a presentation with as many slides that are required to contain the photographs. The sequence of slides can be changed if necessary.
12) If required, move photographs between slides and create frames for photographs. For more information see “Editing photo albums” below.

13) If required, run the photo album as a slide show. See “Creating slide shows” on page 307 and “Slide shows” on page 321.

**Editing photo albums**

When a photo album is created, the full images of photographs are placed within the boundaries of the slides created for the photo album. Each of the photographs in the photo album can be edited just like any other object that can be placed on a slide. For more information on formatting photographs, see the following chapters of the Impress Guide:

Chapter 4, Adding and Formatting Images

Chapter 5, Managing Graphic Objects

Chapter 6, Formatting Graphic Objects

However, to make the photo album look more attractive, frames can be added to each photograph in the photo album and the photographs enhanced using options available on the Sidebar.

Experiment with different levels for each of the following options to create the right effect for each photograph in the photo album.

1) Select a photograph in the photo album to open the **Image**, **Line** and **Effect** panels in the Properties deck on the Sidebar (Figure 273).

2) In the **Image** panel, adjust the following options to enhance the photograph:
   - **Color** — select the color mode from the drop-down list.
   - **Brightness** — select the brightness level as a percentage.
   - **Contrast** — select the contrast level as a percentage.
   - **Transparency** — select the transparency level as a percentage.
Figure 273: Image, Line and Effect panels in Properties deck on Sidebar
3) In the **Line** panel, select the following options to create a frame around the photograph. Figure 274 shows an example of a photo where a line frame has been added.

- **Line** — select the line style from the drop-down list.
- **Width** — select the line width from the drop-down list or enter a line width in the **Custom Line Width** box.
- **Color** — select a color from the available color palettes, or create a custom color for the line frame.
- **Transparency** — select the transparency level as a percentage for the line frame.

4) In the **Effect** panel, select the following options to create a soft frame around the photograph. Figure 275 shows an example of a photo where a soft frame has been added.

- **Glow Radius** — adjust the radius value to apply a soft frame around the outside of the photograph.
- **Glow Color** — select a color for the soft frame from the available color palettes.
- **Glow Transparency** — enter a transparency value to adjust the transparency of the soft frame.
- **Soft Edge Radius** — adjust the radius value to reduce the internal width of the soft frame and make the photograph look smaller.
Chapter 10,
Saving Slide Shows,
Printing, Emailing, and
Exporting
Saving slide shows

Slide shows created in Impress are, by default, saved in the Open Document Presentation (ODP) format. However, Impress can open and save a slide show in other widely used and recognized presentation formats.

New slide show

5) Create a new slide show. For more information, see Chapter 1, Introducing Impress and Chapter 9, Slide Shows and Photo Albums.

6) Save the new slide show using one of the following methods to open a file browser window (Figure 276).
   – Click on Save on the Standard toolbar.
   – Go to File > Save on the Menu bar.
   – Use the keyboard shortcut Ctrl+S (macOS ⌘+S).

7) Navigate to the folder where the slide show is to be saved.

8) Enter a filename in the File name, Name, or Save as text box, depending on computer operating system.

9) Select a file format from the drop-down list at the bottom of the file browser window. By default, the file format is ODF Presentation (.odp).

10) Click on Save to save the slide show and close the file browser window.

Figure 276: File browser for saving new slide show
Note

If the slide show is not being saved in the ODP presentation format, a Confirm File Format dialog (Figure 277) opens asking confirmation of the file format selected.

ODP format

1) Open a slide show in Impress and make all the required changes. Impress opens slide shows that have been saved in a presentation format that Impress recognizes.

2) Save the slide show in ODP format using one of the following methods:
   - Click on Save on the Standard toolbar.
   - Go to File > Save on the Menu bar.
   - Use the keyboard shortcut Ctrl+S (macOS ⌘+S).

Other presentation formats

1) Open a slide show in Impress and make all the required changes. Impress opens slide shows that have been saved in a presentation format that Impress recognizes.

2) Save the slide show in a presentation format that Impress recognizes, use one of the following methods:
   - Click the triangle ▼ to the right of Save on the Standard toolbar and select Save As from the drop-down menu.
   - Go to File > Save As on the Menu bar.
   - Use the keyboard shortcut Ctrl+S (macOS ⌘+Shift+S).

3) In the file browser window that opens, navigate to the folder where the slide show is to be saved.

4) Enter a filename in the Name text box.

5) Select a presentation file format from the drop-down list at the bottom of the file browser window. By default, the file format is ODF Presentation (.odp).

6) Click on Save to save the slide show and close the file browser window.

Quick printing

To quickly print a document or presentation, click on Print Directly on the Standard toolbar (Figure 278) to send the entire document to the default printer that is defined for the computer.
Figure 278: Standard toolbar with Print Directly installed

If Print Directly is not visible on the Standard toolbar, it can be added as follows:

1) Right-click in an empty area on the Standard toolbar and select Visible Buttons from the context menu.
2) Select Print Directly from the list of available tools and the Print Directly tool is added to the Standard toolbar.

**Note**

The action of Print Directly can be changed by sending a document to the printer defined for the document instead of the default printer defined for the computer. Go to Tools > Options > Load/Save > General (macOS LibreOffice > Preferences > Load/Save > General) on the Menu bar and select the option Load printer settings with the document.

**Default printer**

To specify the default printer, go to File > Printer Setup on the Menu bar to open the Printer Setup dialog. An example of a Printer Setup dialog is shown in Figure 279.

1) Select the required printer from the printers listed in the Name drop-down list.
2) Click on Properties to open the Properties dialog for the selected printer and select the required options from those available in the dialog. The options available in this dialog depends on the type of printer connected to the computer and the computer operating system being used.
3) Click OK to save the selected options and close the Properties dialog.
4) Click OK to save the printer selection and close the Printer Setup dialog.

Figure 279: Example of a Printer Setup dialog
Controlled printing

For more control over printing, open and use the Print dialog using one of the following methods. Due to different computer setups and operating systems, the print dialog that opens may differ from the dialogs shown in this user guide. However, the printing options available for LibreOffice remain the same.

- Go to File > Print on the Menu bar.
- Use the keyboard shortcut Ctrl+P (macOS ⌘+P).
- Click on Print on the Standard toolbar.

**Note**

The options selected in the Print dialog only apply to the printing of the current document that is open in Impress. To specify default print settings for LibreOffice, go to Tools > Options > LibreOffice > Print (macOS LibreOffice > Preferences > LibreOffice > Print) on the Menu bar to open the Options LibreOffice Print dialog.

**Note**

Any print options selected with the Print dialog when printing from Impress overrides the default printer settings that have been set using Tools > Options > LibreOffice > Print (macOS LibreOffice > Preferences > LibreOffice > Print) and Tools > Options > LibreOffice Impress > Print (macOS LibreOffice > Preferences > LibreOffice Impress > Print).

**Note**

Due to different computer setups and different operating systems, the print dialog that opens may differ from the dialogs displayed in this chapter. However, the printing options available for LibreOffice remain the same.

Linux or Windows printing

**General options**

The following general options are an example of what may be available on the General page of the Print dialog (Figure 280).

- **Printer** — select the printer to use from the printers available in the drop-down list.
- **Properties** — click on this button to open the properties dialog for the printer being used. The options available in this dialog depends on the type of printer connected to the computer and the computer operating system being used.
- **Range and Copies** — select from the following options:
  - **All Slides** — prints all the slides in the presentation.
  - **Selection** — prints the slides selected in LibreOffice Impress.
  - **Slides** — select the page number(s) to print. For multiple pages, use the format 1, 3, 7 or 1 – 5, 7, 9 for page number selection.
  - **Include** — select from the drop-down list Odd and Even Pages, Odd Pages, or Even Pages.
  - **More > Paper sides** — select from the drop-down list Print on one side (simplex), Print on both sides (duplex long edge), or Print on both sides (duplex short edge).
More > Number of copies — enter number of printed copies required for the document.

More > Collate — collates multiple printed copies into separate documents.

More > Order — select from Create separate print jobs for collated output (only available when more than one copy is being printed) or Print in reverse order.

Page Layout — select from the following options:

Paper size — select the paper size to use from drop-down list

Orientation — select from the drop-down list Automatic, Portrait or Landscape.

More > Pages per sheet — select from the drop-down list how many pages are printed on one sheet of paper.

More > Order — select from the drop-down list the printing order of multiple pages on one sheet of paper.

More > Draw a border around each page — when multiple slides are printed on one sheet of paper, a border is drawn around each slide.

More > Brochure — prints the document so the pages can be folded into a brochure or booklet.
The following options are available on the LibreOffice Impress page of the Print dialog (Figure 281) where settings are defined specific to the current document type:

- **Contents** – when selected prints Slide name, Date and time on the slides and any Hidden pages in the presentation.
- **Color** – prints the presentation in Original colors, Grayscale, or Black & white.
- **Size** – print the presentation using one of the following options:
  - Original size — prints the slide using its original size.
  - Fit to printable page — the presentation size is changed so that it fits on the paper size used for printing.
  - Distribute on multiple sheets of paper — used if the slides are too large for the paper size being used.
  - Tile sheet of paper with repeated slides — used to print several slides of a presentation on a sheet of paper.

**macOS printing**

*LibreOffice Impress options*

By default, when the Print dialog opens, the page for LibreOffice Impress printing options is already selected, as shown in Figure 282.
Figure 282: Print dialog – macOS - LibreOffice Impress options

- **Printer** — select the printer to be used from the drop-down list. If the default printer is being used, then this printer will already be selected.
- **Presets** — select from the drop-down list a printing preset. The presets available depend on the type of printer connected to the computer. This also includes any custom presets that have been created.
- **Copies** — enter the number of copies to be printed.
- **Black & White** — select this option to print the presentation in monochrome if the printer selected is capable of color printing.
- **Two-Sided** — select this option to print the presentation double sided if the printer selected is capable of double sided printing.
- **Pages** — only prints all the pages in the document.
- **Pages From** to **To** — select the page number(s) to print. For multiple pages, use the format 1, 3, 7 or 1 – 5, 7, 9 for page number selection.
- **Print selection only** — only prints the selected area(s) or object(s) in the current drawing.
- **Document** — select the type of document to print from the drop-down list: *Slides; Handouts; Notes; Outline*.
- **Slides per page** — only available when *Handouts* is selected as the document type. Select from the drop-down list either *According to layout*, or the number of slides per page.
- **Order** — only available when *Handouts* is selected as the document type. Select from the drop-down list either *Left to right, then down* or *Top to bottom, then right*. 
• **Contents** — when selected prints *Slide name, Date and time* on the slides and any *Hidden pages* in the presentation.

• **Color** — prints the presentation in *Original colors, Grayscale*, or *Black & white*.

To access more printing options in *LibreOffice Impress*, click on **More** to open the second page of LibreOffice Impress options, as shown by the example in Figure 283.

• **Size** — print the presentation using one of the following options:
  – *Original size* — prints the slides using the original size.
  – *Fit to printable page* — the slide size is changed so that it fits on the paper size used for printing.
  – *Distribute on multiple sheets of paper* — used if the slides are too large for the paper size being used.
  – *Tile sheet of paper with repeated slides* — used to print multiple copies of a slide on a page.

• **Brochure** — when selected, prints the document so the pages can be folded into a brochure or booklet.

• **Include** — select which pages to print from the drop-down list: *All pages; Front sides/right pages; Back sides/left pages*. Only available when **Brochure** is selected.
  – *Use only paper tray from printer preferences* — when selected, the printer tray selected on the printer overrides the selected tray in the printer properties on the computer.
  – *All Slides* — all the slides in the slide show are printed.
– **Slides**: — enter the slide number(s) in the text box that are to be printed. For multiple slides, use the format 1, 3, 7 or 1 – 5, 7, 9 for slide number selection.
– **Selection** — prints the slides selected in LibreOffice Impress in the Slides pane.

**General printing**

Click on the LibreOffice drop-down list to select the general printing. The following options are an example only.

- **Media & Quality**
  - **Feed from** — select from the drop-down list the paper tray to use if the printer has more than one paper tray.
  - **Media Type** — select from the drop-down list the paper type that has been loaded into the paper tray being used, for example *Envelope, Photo, Plain Paper*.
  - **Quality** — select the level of printing quality required.

- **Layout**
  - **Pages per sheet** — select from the drop-down list how many slides are printed on one sheet of paper.
  - **Layout Direction** — select the printing order of multiple slides on one sheet of paper.
  - **Border** — when multiple slides are printed on one sheet of paper, a border is drawn around each slide.
  - **Two-Sided** — select from the drop-down list how a multi-page document is going to be bound: *Off; Long-Edge binding; Short-Edge binding, Booklet*.
  - **Reverse page orientation** — if LibreOffice prints the slides in the wrong order, select this option and print the document again.
  - **Flip horizontally** — if LibreOffice prints the pages in the wrong orientation, select this option and print the document again.

- **Paper Handling**
  - **Collate pages** — when selected collates multiple printed copies into separate documents.
  - **Pages to Print** — select which slides in the document to print from the drop-down list: *All pages; Odd only; Even only*.
  - **Page Order** — select the page printing order from the drop-down list: *Automatic; Normal; Reverse*.
  - **Scale to fit paper size** — adjusts the printed slide to fit the paper size.
  - **Destination Paper Size** — select a paper size from the options available in the drop-down list. Only available if Scale to fit paper size has been selected.

- **Cover Page** — provides options of when to print a cover page and the type of of cover page.

- **Watermark** — provides options to print watermark text on the slides, for example *Confidential* if the presentation is of a sensitive nature.

**Printing examples**

The following printing instructions are examples only. Actual method of printing may differ from these examples as this depends on computer operating system, computer setup, and the printer being used. For more information on printing, see the *Writer Guide*.
Printing slides

The following printing procedure is an example only. Actual printing procedure does depend on computer operating system and how the computer has been setup.

1) Open the Print dialog using one of the following methods:
   – Go to File > Print on the Menu bar.
   – Use the keyboard shortcut Ctrl+P (macOS ⌘+P).
   – Click on Print on the Standard toolbar.

2) Click on General to open the page for general print options and, if necessary, select a printer from the Printer drop-down list of printers available.

3) If necessary, in Printer click on Properties to display a properties dialog for the selected printer and select the options required. Click OK to save the Properties selection and close the dialog. Actual printer properties available depend on the printer selected and computer operating system being used. An example of a printer properties dialog is shown in Figure 284.

4) In Range and Copies, select which slides to print, odd or even pages, the paper sides to print on (simplex or duplex), number of copies, collate multiple copies, and the print order.

5) In Page Layout, select the paper size, orientation, pages per sheet, and, if necessary, brochure printing.

6) Click on LibreOffice Impress to open the page for LibreOffice Impress print options.

Figure 284: Example dialog for printer properties
7) In **Document**, select the document type, slides per page and the printing order from the drop-down lists.

8) In **Contents**, select whether to print slide name, date and time, and/or hidden pages.

9) In **Color**, select the type of color to print.

10) In **Size**, select the printed size, to fit on a printable page, to distribute on multiple sheets of paper, or tile sheet of paper with repeated slides.

11) Click **OK** to print the slides and close the Print dialog.

### Brochure printing

Slides can be printed so that, when printed, the slides are in the correct order to form a booklet or brochure.

The printer procedures below are only examples. Actual printing procedure depends on the computer operating system and type of printer being used. It is best to experiment to find the correct method for brochure printing.

### Single sided printing

The following procedure is an example of how to create a brochure or booklet using a printer that is only capable of printing single sided.

1) Open the Print dialog using one of the following methods:
   - Go to **File > Print** on the Menu bar.
   - Use the keyboard shortcut **Ctrl+P** (macOS ⌘+P).
   - Click on **Print** on the Standard toolbar.

2) Click on **General** to open the page for general print options and, if necessary, select a printer from the **Printer** drop-down list of printers available.

3) Click on **Properties** to open the printer properties dialog for the printer being used and check the printer is set to the same page orientation as specified for the page setup for the slides. Usually page orientation does not matter, but it is important for brochures.

4) Click **OK** to close the properties dialog and return to the Print dialog.

5) In **Range and Copies**, select **All Slides**. A minimum of four slides is required to create a brochure.

6) In **Range and Copies**, select the **Number of copies** required to match the required number of brochures.

7) In **Layout**, select **Brochure**.

8) In **Range and Copies**, select **Even slides** option in **Include**.

9) Click **OK** to print the even slides in the presentation.

10) Take the printed slides out of the printer and put them back into the printer in the correct orientation to print on the other side of the paper. It maybe necessary to experiment and find out what the correct arrangement is for the printer being used.

11) In **Range and Copies**, select **Odd slides** option in **Include**.

12) In **Range and Copies**, select the same **Number of copies** used for printing the even slides.

13) Click **OK** to print the odd slides in the presentation and close the Print dialog.

14) Assemble the brochures and bind them, if necessary.
**Double sided or duplex printing**

Printing a brochure on a printer that is capable of double sided or duplex printing makes the task of creating brochures a lot simpler.

1) Open the Print dialog using one of the following methods:
   - Go to **File > Print** on the Menu bar.
   - Use the keyboard shortcut **Ctrl+P** (macOS **⌘+P**).
   - Click on **Print** on the Standard toolbar.

2) Click on **General** to open the page for general print options and, if necessary, select a printer from the **Printer** drop-down list of printers available.

3) Click on **Properties** to open the printer properties dialog for the printer being used and check the printer is set to the same page orientation as specified for the page setup for the slides. Usually page orientation does not matter, but it is important for brochures.

4) Click **OK** to close the properties dialog and return to the Print dialog.

5) In **Range and Copies**, select **All Slides**. A minimum of four slides is required to create a brochure.

6) In **Range and Copies**, select **Print on both sides (duplex long edge)** or **Print on both sides (duplex short edge)** option. Normally, long edge binding is used for portrait printing and short edge binding is used for landscape printing.

7) In **Range and Copies**, select the **Number of copies** required to match the required number of brochures.

8) In **Range and Copies**, select the **Collate** option. This option is only active when printing multiple copies of the same document.

9) In **Layout**, select **Brochure**.

10) Click **OK** to close the Print dialog and print the required number of pages for the brochures.

11) If necessary, bind the brochures to match either long edge or short edge binding.

**Emailing**

LibreOffice provides two methods of emailing an Impress slide show as an attachment in ODP format or PDF format directly from the Impress module. For more information on emailing LibreOffice documents, see the **Getting Started Guide**.

**Note**

There must be a default email program available for the LibreOffice emailing facility to work correctly.

**ODP format**

1) Make sure the presentation file is open in Impress.

2) Go to **File > Send > Email Document** on the Menu bar and the default email program opens with the presentation file already attached to the email.

3) Enter the name of the recipient, subject line, and message then send the email.

**PDF format**

1) Make sure the presentation file is open in Impress.
2) Go to Format > Send > Email as PDF on the Menu bar and the PDF Options dialog (Figure 285) opens.

3) If necessary, select the required PDF options to create a PDF version of the slide show. Normally, the default options already selected are sufficient to create a PDF file that the email recipient will be able to open.

4) Click on Send to close the PDF Options dialog and the default email program opens with the PDF file already attached to the email.

5) Enter the name of the recipient, subject line, and message then send the email.

**Exporting**

Impress can export presentations in the PDF format as well as other file formats. The PDF format is a standard file format for file viewing and is ideal for sending the file to someone who can only view a slide show file using a PDF viewer.

For more information on exporting LibreOffice documents, see the *Getting Started Guide*.

**Quick PDF export**

1) Make sure the presentation file is open in Impress.

2) Use one of the following methods to export the file as a PDF file and open a file browser window.
   - Click on Export Directly as PDF on the Standard toolbar.
   - Go to File > Export As > Export Directly as PDF on the Menu bar.

3) In the file browser window, navigate to the folder where the PDF file is to be saved.
4) In the Name text box, enter a filename for the PDF file or use the filename that is displayed in this text box. The file format is fixed as PDF and cannot be changed.

5) Click on Save to save the slide show file as a PDF file and close the file browser window.

**PDF export**

For more control over the content and quality of a PDF file, it is recommended to use the PDF Options dialog. For more information on the options available when exporting a slide show as a PDF file, see the *Getting Started Guide*.

1) Make sure the slide show file is open in Impress.
2) Go to File > Export as PDF on the Menu bar to open the PDF Options dialog.
3) Using the various pages in the PDF Options dialog, select the options required for the PDF file. For more information, see the *Getting Started Guide*.
4) Click on Export to open a file browser window.
5) In the file browser window, navigate to the folder where the PDF file is to be saved.
6) In the Name text box, enter a filename for the PDF file or use the filename that is displayed in this text box. The file format is fixed as PDF and cannot be changed.
7) Click on Export to save and export the file to the selected location.

**Web pages (HTML) export**

Presentations can be exported as a series of web pages (HTML format) that can be viewed in any browser.

---

*Note*

Exporting presentations as web pages (HTML) does not retain any animation effects or slide transitions.

1) Make sure the presentation file is open in Impress.
2) Create a folder to contain the HTML pages that are generated and select the folder as the destination for the HTML pages.

3) Go to File > Export on the menu bar to open a file browser window and navigate to where the HTML version of the presentation is going to be saved.

4) Enter a name for the HTML file in the Name text box at the top of the file browser window.

5) At the bottom of the file browser window, select HTML Document (Impress) (.html; .htm) format from the drop-down list.

6) Click on Save and the HTML Export dialog opens at the Assign Design page (Figure 286).

7) Select a design for all of the HTML pages, either from an existing design or by creating a new design. If there is no previously saved design available, the Existing Design option is not available.

8) Click on Next to select the publication type to use for creating the web pages, as shown in Figure 287. The available options change depending on publication type selected.
   - **Standard HTML format** – one page for each slide with navigation links to move from slide to slide.
   - **Standard HTML with frames** – one page with a navigation bar on the left-hand side and uses slide title as navigation links. Click on links to display pages in right-hand side.
   - **Single-document HTML** – creates one HTML document from the slide show.
   - **Automatic** – one page for each slide with each page set with the refresh meta tag so a browser automatically cycles from one page to the next.
   - **WebCast** – generates an ASP or Perl application to display the slides. Currently, LibreOffice has no direct support for PHP.

9) Click on Next> to select the format for saving images (PNG, GIF or JPG) and the monitor resolution used from the options available in Monitor Resolution, as shown in Figure 288. When selecting a monitor resolution, consider what type of display users may have. For example, if high resolution is selected, then users with a medium-resolution display has to scroll sideways to see the entire slide.
10) Click on Next> and enter the details for a title page (Figure 289), such as name of the author, e-mail address and home page, along with any additional information that maybe required. This page does not display if the Create title page option was not selected when selecting Publication Type.

11) Click on Next> to select the style of navigation buttons to use when moving from one page to another from the options available in Select Button Style (Figure 290). If buttons are not being used, make sure Text only is selected.

12) Click on Next> to select the color scheme for the web pages from the options available in Select Color Scheme (Figure 291). Available schemes include the existing scheme for the presentation, one based upon browser colors, and a user-defined scheme. A new scheme can be saved so that it appears on the first page of the HTML export wizard.

13) Click on Create to generate the HTML files. If this is a new design, a dialog opens to save the design for future use.
Export in other formats

1) Make sure the presentation file is open in Impress.
2) Go to **File > Export** on the menu bar to open a file browser window and navigate to where the HTML version of the slide show is going to be saved.
3) Enter a name for the exported file in the *Name* text box at the top of the file browser window.
4) At the bottom of the file browser window, select the required format from the drop-down list.
5) Click on **Save** to export the file to the selected location. Depending on the format selected, an options dialog may open allowing further options to be selected for the file format selected.
6) Click on **OK** to save the exported file and close the options dialog. For more information on exporting files, see the *Getting Started Guide*. 

*Figure 290: HTML Export dialog - Select Button Style page*

*Figure 291: HTML Export dialog - Select Color Scheme page*
Chapter 11,
Setting Up and Customizing Impress
Introduction

This chapter covers some of the settings in LibreOffice that apply when using Impress, but may also apply to all the other modules in LibreOffice. The illustrations in this chapter have been taken from LibreOffice Impress. For more information on setting up and customizing all the modules in LibreOffice, see the Getting Started Guide.

LibreOffice options

**Note**

Revert has the same effect on all pages in the Options LibreOffice dialog. It resets the options to the values that were in place when LibreOffice was opened.

**User Data options**

Impress uses the first and last name stored in User Data for document properties, optional author field used in slides, and the name associated with any comments that have been made.

1) Go to Tools > Options (macOS LibreOffice > Preferences) on the Menu bar to open the Options LibreOffice dialog (Figure 292). The list on the left-hand side varies depending on which component of LibreOffice is open.

2) Click the expansion marker next to LibreOffice on the left-hand side and select User Data to open the user data options page for LibreOffice.

3) Enter or edit details that are to be used for document properties.

4) Click OK to save the changes and close the Options LibreOffice dialog.

*Figure 292: Options LibreOffice dialog - User Data page*
View options

1) Go to **Tools > Options** (macOS **LibreOffice > Preferences**) on the Menu bar to open the Options LibreOffice dialog. The list on the left-hand side varies depending on which component of LibreOffice is open.

2) Click the expansion marker next to LibreOffice on the left-hand side to open a list of pages and select **View** to open the view options page for LibreOffice (Figure 293).

3) Enter or edit details that are to be used for viewing a file in LibreOffice.

4) Click **OK** to save the changes and close the Options LibreOffice dialog.

View options control how the user interface for LibreOffice appears when creating slides. For more information on customizing the user interface, see the **Getting Started Guide**.

- **Icon style** — specifies the icon style for icons in toolbars and dialogs.
- **Icon size** — sets the icon size to **Automatic**, **Small**, **Large** or **Extra Large**.
  - **Toolbar** — specifies the display size of toolbar icons.
  - **Notebookbar** — specifies the display size of notebook bar icons.
  - **Sidebar** — specifies the display size of sidebar icons.
- **Visibility** — displays icons according to system settings and themes.
  - **Menu icons** — select from **Automatic**, **Hide**, or **Show**. **Automatic**.
  - **Shortcuts** — displays keyboard shortcuts next to the corresponding menu items.
- **Mouse** — defines how the cursor is positioned and the action of the middle button, if used.
  - **Positioning** — specifies if and how the cursor is positioned in newly opened dialogs.
  - **Middle button** — defines the function of the middle mouse button. First function is for automatic scrolling dragging while pressing the middle mouse button shifts the view. The second function is to insert clipboard contents at the cursor position by pressing the middle mouse button.
- **Graphics Output** — defines how graphics are displayed.
– **Use hardware acceleration** — directly accesses hardware features of the graphical display adapter to improve the screen display. The support for hardware acceleration is not available for all operating systems and platform distributions of LibreOffice.

– **Use anti-aliasing** — when supported, enables and disables anti-aliasing of graphics. With anti-aliasing enabled, the display of most graphical objects looks smoother and with less artifacts.

– **Use Skia for all rendering** — currently this option is disabled in LibreOffice.

- **Font Lists** — defines how the fonts are displayed.
  - **Show preview of fonts** — displays how a selected font will appear on the user interface.
  - **Screen font antialiasing** — when selected, the display of fonts looks smoother and with less artifacts.
  - **from:** — sets the minimum size of a font being used before **Screen font antialiasing** is applied to smooth the font.

### Print options

Print options can be selected and changed using the **Print** page of the Options LibreOffice dialog or during the printing process. Available print options shown in the print dialog do depend on operating system, computer setup, and the type of printer being used. An example of print options available are shown in Figure 294. See Chapter 10, Saving Slide Shows, Printing, Emailing, and Exporting for more information about the printing of slide shows.

1. Go to **Tools > Options** (macOS **LibreOffice > Preferences**) on the Menu bar to open the Options LibreOffice dialog.
2. Click the expansion marker next to LibreOffice on the left-hand side to open a list of subsections and select **Print** to open the printing options page for LibreOffice (Figure 294).
3. Select the print settings that suit the selected printer and the most common printing method.
4. Click **OK** to save the changes and close the Options LibreOffice dialog.

![Figure 294: Options LibreOffice dialog - Print page](image)
Using the print options it is possible to reduce amount of data sent to the printer. This increases the print speed because print files are smaller. It also makes it easier for printers with a smaller memory to print. However, reducing print data can result in slightly lower print quality.

- **Settings** — specifies whether the print settings apply to the printer or to a file.
  - **Printer** — define options for reducing data while printing directly to a printer.
  - **Print to file** — define options for reducing data while printing to a file.

- **Defaults**
  - **PDF as standard print job format** — specifies the use of PDF format when sending a file to the printer.
  - **Convert colors to grayscale** — specifies that all colors are printed only as grayscale.
  - **Include transparent objects** — when selected, any reduction in print quality also applies to the transparent areas of objects.

- **Reduce bitmaps** — specifies that bitmaps are printed with reduced quality. The resolution can only be reduced and not increased.
  - **Resolution** — specifies the maximum print quality in dpi.
  - **Normal print quality** — corresponds to a resolution of 200dpi.
  - **High print quality** — corresponds to a resolution of 300dpi.

- **Reduce transparency** — if selected, any transparent objects are printed as normal, depending on the selection of the two following options.
  - **Automatically** — specifies that any transparencies are only printed if the transparent areas covers less than a quarter of the entire page.
  - **No transparency** — when selected, transparencies are not printed.

**Note**

Transparencies cannot be sent directly to a printer. The document areas where transparencies are visible must always be calculated as bitmaps and sent to the printer. Depending on the size of the bitmaps and the print resolution, a large amount of data may result.

- **Warnings** — defines which warnings appear before any printing starts.
  - **Paper size** — select this option if a certain paper size is required for printing a document. If the paper size required is not available in the current printer, a warning is displayed.
  - **Paper orientation** — select this option if a specific page orientation is required for a document. If the format is not available, a warning is displayed.
  - **Transparency** — select this option if a warning is required when transparencies are contained in the document. A dialog appears allowing selection if the transparency is to be printed.

- **Reduce gradient** — if selected, gradients are printed with reduced quality.
  - **Gradient stripes** — specifies the maximum number of gradient stripes for printing.
  - **Intermediate color** — specifies that gradients are only printed in a single intermediate color.
Application Color options

Application colors specify which color is used to display various elements of the user interface in LibreOffice. The only option specific to Impress is the color of the grid points.

1) Go to Tools > Options (macOS LibreOffice > Preferences) on the Menu bar to open the Options LibreOffice dialog.

2) Click the expansion marker next to LibreOffice on the left-hand side to open a list of sections and select Application Colors to open the color options page for the colors used in LibreOffice (Figure 295).

3) In Custom Colors, scroll down to Drawing/Presentation.

4) Select from the list of color palettes a color to use for the Grid.

5) Click OK to save the changes and close the Options LibreOffice dialog.

Note

To save the color changes as a color scheme, click on Save and type a name in the dialog that opens, then click OK.
Impress options

In the Options LibreOffice dialog, click the expansion marker on the left-hand side of LibreOffice Impress to open a list of sections available for Impress.

1) Go to Tools > Options (macOS LibreOffice > Preferences) on the Menu bar to open the Options LibreOffice dialog.

2) Click the expansion marker next to LibreOffice Impress on the left-hand side to open a list of sections.

3) Select an option section from the list of sections that are available (Figure 296), then select from the required options from the options available.

4) Click OK to save the changes and close the Options LibreOffice dialog.

General options

Select LibreOffice Impress > General to specify the general options for slide shows (Figure 296).

- **New document**
  - *Start with Template Selection* — if selected, the Select a Template dialog opens when creating a new presentation.

- **Settings**
  - *Copy when moving* — if selected, a copy is created when an object is moved while holding down the *Ctrl* key. The same applies for rotating and resizing an object. The original object remains in its current position and size.
  - *Use background cache* — specifies whether to use the cache for displaying objects on the master slide. This speeds up the display. Deselect this option to display contents being changed on the master slide.
Objects always moveable — when selected, it allows moving an object with Rotate enabled. If this option is not selected, Rotate can only be used to rotate an object.

Unit of measurement — determines the unit of measurement used in Impress.

Tab stops — defines the spacing between tab stops.

Compatibility — these settings are valid for the current presentation only.

Use printer metrics for document formatting — specifies that printer metrics are applied for printing and also for formatting the display on the screen. If this option is not selected, a printer independent layout is used for screen display and printing. If this option is set for the current document and the document is saved, for example, in an older binary format, this option is not saved. If the file is then opened from the older format, this option is set by default.

Add spacing between paragraphs and tables — specifies that Impress calculates the paragraph spacing. Similar to Microsoft PowerPoint which adds the bottom spacing of a paragraph to the top spacing of the next paragraph to calculate the total spacing between both paragraphs. Impress utilizes only the larger of the two spacings.

Presentation

Enable remote control — when selected, allows a remote control to be used for presentations.

Enable Presenter Console — when selected, the Presenter Console opens for presentations when using multiple displays.

Text objects

Allow quick editing — if selected, text can be edited immediately after clicking a text object. If deselected, double-click to edit text. This mode can be activated by clicking on Allow Quick Editing in the Options toolbar (Figure 297).

Only text area selectable — specifies whether to select a text frame by clicking the text. In the area of the text frame that is not filled with text, an object behind the text frame can be selected. This mode can be activated by clicking on Select Text Area Only in the Options toolbar.

View options

Select LibreOffice Impress > View (Figure 298) to specify the Display options for the available display modes.

Rulers visible — when selected, displays the rulers at the top and to the left of the work area.

Figure 298: Options LibreOffice Impress dialog - View page
• **Helplines while moving** — when selected, displays guides when moving an object. Impress creates dotted guides that extend beyond the box containing the selected object and covering the entire Workspace to help in positioning of an object. This mode can also be activated by clicking on **Helplines While Moving** on the Options toolbar.

• **All control points in Bézier editor** — displays the control points of all Bézier points if a Bézier curve is selected. If this option is not selected, only the control points of the selected Bézier points are visible.

• **Contour of each individual object** — Impress displays the contour line of each individual object when moving an object. When an objects is being moved, this option shows if there is any conflict with other objects in the target position. If this option is not selected, Impress displays only a square contour that includes all selected objects.

### Grid options

Select **LibreOffice Impress > Grid** (Figure 299) to specify the grid settings for Impress. Using a grid helps in determining the exact position of objects. The grid can also be set to line up with the snap grid.

• **Grid**
  - **Snap to grid** — activates the snap function. If this option is selected and want to move or create individual objects without snapping to the grid. This setting can be temporarily deactivated by pressing the **Shift** key to deactivate **Snap to grid** whilst moving the individual object. This mode can also be activated by clicking on **Snap to Grid** on the Options toolbar.
  - **Visible grid** — displays grid points on the screen. These points will not display or print as part of a presentation.

• **Resolution**
  - **Horizontal** — defines the measurement unit for the spacing between grid points on the X-axis.
  - **Vertical** — defines the measurement unit for the spacing between grid points on the Y-axis.

![Figure 299: Options LibreOffice Impress dialog - Grid page](image)

**Figure 299: Options LibreOffice Impress dialog - Grid page**

  - **Synchronize axes** — when selected, the measurement and spacing settings for X- and Y-axes are synchronized for **Resolution** and **Subdivision**.
• **Subdivision**
  - **Horizontal** — specify the number of intermediate spaces between grid points on the X-axis.
  - **Vertical** — specify the number of intermediate spaces between grid points on the Y-axis.

• **Snap**
  - **To snap lines** — snaps the edge of an object being dragged to the nearest snap line when the mouse button is released. This mode can also be activated by clicking on **Snap to Snap Lines** on the Options toolbar.
  - **To the page margins** — specifies whether to align the contour of the graphic object to the nearest page margin. The cursor or a contour line of the graphics object must be in the snap range. This mode can also be activated by clicking on **Snap to Page Margins** on the Options toolbar.
  - **To object frame** — specifies whether to align the contour of the graphic object to the border of the nearest graphic object. The cursor or a contour line of the graphics object must be in the snap range. This mode can also be activated by clicking on **Snap to Object Border** on the Options toolbar.
  - **To object points** — specifies whether to align the contour of the graphic object to the points of the nearest graphic object. This only applies if the cursor or a contour line of the graphics object is in the snap range. This mode can also be activated by clicking on **Snap to Object Points** on the Options toolbar.
  - **Snap range** — defines the snap distance between the cursor and the object contour. If the cursor is nearer than the distance specified, the cursor snaps to a snap point.

• **Constrain Objects**
  - **When creating or moving objects** — specifies that graphic objects are restricted vertically, horizontally or diagonally (45°) when creating or moving them. This setting can be temporarily deactivated by pressing and holding the **Shift** key.
  - **Extend edges** — specifies that a square is created based on the longer side of a rectangle when the **Shift** key is pressed before releasing the mouse button. This also applies to an ellipse where a circle is created based on the longest diameter of the ellipse. When this option is NOT selected, a square or a circle is created based on the shorter side or diameter.
  - **When rotating** — specifies that graphic objects can only be rotated within the rotation angle that is selected. If an object is to be rotated outside the defined angle, press and hold the **Shift** key when rotating. Release the **Shift** key when the desired rotation angle is reached.
  - **Point reduction** — defines the angle for point reduction. When working with polygons, this is useful to reduce editing points.
Print options

Select **LibreOffice Impress > Print** (Figure 300) to specify print settings for a presentation. See Chapter 10 Saving Slide Shows, Printing, E-mailing, and Exporting for more information about printing and the options available.

- **Page Options**
  - *Default* – pages are printed at the default setting for printing.
  - *Fit to page* – a slide is resized to fit the printed page, while maintaining the relative positions of the objects on the slide.
  - *Tile pages* – specifies that pages are printed in tiled format. If the pages or slides are smaller than the paper, several pages or slides are printed on one page of paper.
  - *Brochure* – select this option to print the document in brochure format. Select *Front* to print from the front to the back of a brochure. Select *Back* to print from the back to the front of a brochure.
  - *Paper tray from printer settings* – when selected, the paper tray used is defined in the printer setup.

- **Print**
  - *Page name* – when selected, the page name is printed.
  - *Date* – when selected, the current date is printed.
  - *Time* – when selected, the current time is printed.
  - *Hidden pages* – when selected, any hidden pages in the slide show are printed.

- **Quality**
  - *Default* – when selected, the slides are printed in color.
  - *Grayscale* – when selected, the slides are printed as grayscale.
  - *Black & white* – when selected, the slides are printed in black and white.

Customizing user interface

Impress menus, toolbars, and keyboard shortcuts can be customized by adding, deleting, or modifying items in the menus, toolbars, and keyboard shortcuts that are used when creating slides and slide shows. For more information on customizing the user interface, see Chapter 12, User Interface Variants; Appendix B, Toolbars; and the *Getting Started Guide*. 

Figure 300: Options LibreOffice Impress dialog - Print page
Adding extensions

An extension is a package that can be installed into LibreOffice Impress to add a new function. Although individual extensions can be found in different places, the official LibreOffice extension repository is at https://extensions.libreoffice.org/. Some extensions are free of charge, while some are available for a fee. Check the descriptions to see what licenses and fees apply to each extension. For more information on extensions, see the Getting Started Guide.
Chapter 12,
User Interface Variants
Introduction

By default, commands and tools used in LibreOffice Impress are grouped in a user interface consisting of cascading menus and toolbars. The functions and use of these cascading menus and toolbars are described in previous chapters of this user guide.

This chapter describes the user interface variants that are available for LibreOffice Impress. A user then has the option to select the user interface that suits their requirements and methods of creating presentations in LibreOffice Impress.

Note

When changing the user interface, the variant can be applied only to LibreOffice Impress, or applied to all the modules in LibreOffice.

Selecting a user interface

To select a user interface variant or switch between the user interface variants:

5) Go to **View > User Interface** on the Menu bar to open the Select Your Preferred User Interface dialog (Figure 301).
6) In **UI variants**, select one of the variants. An example of the selected variant is shown in the **Preview** box, along with a short description.
7) Click on **Apply to Impress** to apply the variant selection to LibreOffice Impress only, or click on **Apply to All** to apply the user interface variant to all the LibreOffice modules. The LibreOffice window changes to match the selected variant.
8) Click **Close** to close the dialog.

Figure 301: Select Your Preferred User Interface Variant dialog

Note

If the option **Enable experimental features** has been selected in the **Tools > Options > Advanced** dialog, several more variants appear in **UI variants**. Being experimental, these variants are not described in this user guide.
In all the user interface variants, the Sidebar can be hidden or shown by clicking on the Hide/Show button on the left of the Sidebar.

**Standard Toolbar UI**

The Standard Toolbar user interface is the default view when LibreOffice is installed and the Workspace opened for the first time. Figure 302 shows an example of the default Workspace view in LibreOffice Impress consisting of the following:

- Menu bar at the top of the Workspace.
- Standard toolbar positioned below the Menu bar.
- Drawing toolbar positioned vertically on the left of the Workspace.
- Sidebar on the right of the Workspace.

For more information on the Impress Workspace, see Chapter 1, Introducing Impress.

**Tabbed UI**

The Tabbed user interface provides a familiar interface for users coming from proprietary office suites, for example, Microsoft Office. Every tab within this user interface consists of a set of tools grouped by context. The context changes automatically depending on the LibreOffice module and the object selected.

It includes a Menu bar, a Tab bar, and tool icons grouped in context that would be normally used in LibreOffice Impress. If the tool icons on a tab page do not fit into the width of the Impress window, a double chevron >> appears at the right end of the row. Click the double chevron >> to display more commands.
Figure 303: Quick menu options

Figure 304: Icon bar

Figure 305: Customize dialog - Notebookbar page
On Windows and Linux operating systems, the Menu bar can be hidden or displayed by clicking on Menubar at the left end of the Tab bar.

On the right of the Tab bar, a Quick menu (≡) (Figure 303) is available giving access to some commonly used commands and links. Some of the Quick menu items have submenus, indicated by a small triangle ► on the right. The Quick menu is the same for all tabs.

On the left of the Tab bar, an Icon bar (Figure 304) is available giving access to some commonly used tools – Menubar; Open (Ctrl+O); Save (Ctrl+S); Undo (Ctrl+Z); Redo (Ctrl+Y); Start from First Slide (F5).

The Tabbed user interface can be customized using the Notebookbar page of the Customize dialog (Figure 305) to show or hide the individual tools on the various tabs. For more information on customization of LibreOffice, see the Getting Started Guide and the Writer Guide.

When using the Tabbed user interface, the Impress toolbars are no longer visible. If necessary, it is possible to open toolbars by going to View > Toolbars on the Menu bar or Quick menu > Toolbars.

Fixed tabs

The fixed tabs in the Tabbed user interface for Impress are described on the following pages. The following figures show the left and right ends of the tabs separately so they are large enough to more easily see the commands.

File tab

The File tab (Figure 306) is a fixed tab providing commands to create new documents; open, save, print, and close documents; manage templates; export to PDF and EPUB; display document properties; add a digital signature; and sign an existing PDF.

The File tab has two menus (Figures 307 and 308): File and Help. The File tab menu contains the same commands as the tools available on the tab. The Help tab menu provides links to a variety of resources.

Figure 306: Tabbed user interface - File tab
Home tab

The Home tab (Figure 309) is a fixed tab providing commands to cut, copy, paste, and format text; insert common items (for example images, tables, charts); apply, update, and edit drawing styles; and so on. The Home menu (Figure 310) at the right end of the Home tab bar provides additional tools that are not on the tab.
**Insert tab**

The **Insert** tab (Figure 311) is a fixed tab providing tools to insert many commonly used items. The **Insert** menu (Figure 312) at the right end of the **Insert** tab bar provides some of the same tools.

![Figure 311: Tabbed user interface - Insert tab](image)

**Layout tab**

The **Layout** tab (Figure 313) is a fixed tab providing tools to create a slide layout. The **Layout** menu (Figure 314) at the right end of the **Layout** tab bar provides some of the same tools.

![Figure 313: Tabbed user interface - Layout tab](image)
Figure 314: Layout tab – Layout menu

Figure 315: Tabbed user interface - Slide Show tab

Figure 316: Slide Show tab - Slide Show menu
**Slide Show tab**

The Slide Show tab (Figure 315) is a fixed tab providing tools for creating a slide show. The Slide Show menu (Figure 316) at the right end of the Slide Show tab bar provides some of the same tools.

**Review tab**

The Review tab (Figure 317) is a fixed tab providing tools for reviewing a slide show. The Review menu (Figure 318) provides additional text editing tools. Some of these tools appear only if Asian or Complex Text Layout are selected in Tools > Options > Language Settings > Languages.

**View tab**

The View tab (Figure 319) is a fixed tab providing tools to control the display of slides on a screen. The View menu (Figure 320) provides additional tools relating to the display of slides on a screen.
Extension tab

The Extension tab (Figure 321) is a fixed tab containing only the tool to access the Extension Manager allowing the installation of extensions that are compatible for use in LibreOffice.

Tools tab

The Tools tab (Figure 322) is a fixed tab providing several tools for macros; color replacer; media player; and so on. The Tools menu (Figure 323) provides some of the same tools, plus extra tools for organizing, for example, macros and dialogs; image map; data sources; and so on.
Additional tabs

Additional tabs appear between the View and Extension tabs when an object in Impress is selected. The illustrations show the left and right ends of the tabs separately so they are large enough to more easily see the commands.

**Draw tab**

The Draw tab (Figure 324) becomes available when a drawing object is selected in a slide. It provides tools for editing, transforming, grouping, aligning, and distributing draw objects. The Draw tab menu (Figure 325) provides some of the tools required for editing, transforming and converting drawing objects.
The Image tab (Figure 326) becomes available when an image is selected in a slide, for example a photograph. It provides tools for working with images, such as cropping, borders, area styles, colors, and so on. The Image tab menu (Figure 327) provides links to dialogs for working with images.

**Image tab**

![Image tab menu](image)

**Figure 325: Draw tab - Draw menu**

**Figure 326: Tabbed user interface - Image tab**

**Figure 327: Image tab - Image menu**
**Object tab**

The **Object** tab (Figure 328) becomes available when an object, such as a chart, is selected. It provides tools to position, resize, choose colors, and so on for the selected object. The **Object** tab menu (Figure 329) provides extra tools matching the type of object selected.

![Object tab](image)

*Figure 328: Tabbed user interface - Object tab*

![Object menu](image)

*Figure 329: Object tab - Object menu*

**Table tab**

The **Table** tab (Figure 330) becomes available when a table is selected in a slide. It provides tools to format a table to the presentation requirements. The **Table** tab menu (Figure 331) includes extra tools for editing a table.

![Table tab](image)

*Figure 330: Tabbed user interface - Table tab*

![Table menu](image)

*Figure 331: Table tab - Table menu*
**Media tab**

The **Media** tab (Figure 332) only becomes available when a media object is selected in a slide. It provides tools for positioning and running an audio or video file. The **Media** tab menu (Figure 333) includes extra tools for editing a media object.

![Figure 332: Tabbed user interface - Media tab](image)

**Single Toolbar & Sidebar UI**

When selected, the **Single Toolbar** and **Sidebar** user interfaces only show the Menu bar with no toolbars. However, toolbars can be added to either of these user interfaces by going to **View > Toolbars** on the Menu bar and selecting the required toolbar from the options available. For more information on toolbars, see Appendix B, Toolbars in this guide and the *Getting Started Guide*.

**Tabbed Compact UI**

The **Tabbed Compact** user interface has the same tabs as the **Tabbed** user interface, but the tools on each tab are arranged as a single row of tools. Some of these tools have drop-down menus with extra options. Figure 334 shows an example of the **File** tab in the **Tabbed Compact** user interface.

The tab menu on the right of the **Tabbed Compact** user interface provides the same options as the tab menus in the **Tabbed** user interface, see “Tabbed UI” on page 370 for more information.

![Figure 334: Example of Tabbed Compact user interface showing File tab](image)

**Groupedbar Compact UI**

The **Groupedbar Compact** user interface is divided into groups that contain commands organized as sets of tools and menus. The tools and menus that are available change to suit the type of object selected. Clicking on the double chevron >> displays more tools for editing an object. Figure 335 shows an example of **Groupedbar Compact** user interface when a basic shape object is selected.
The **Groupedbar Compact** menu (Figure 336) on the right-hand end of this interface provides extra tools for working with LibreOffice Impress, including convenient ways to change the user interface and access toolbars.

![Figure 335: Example of Groupedbar Compact user interface with an object selected](image)

**Figure 335: Example of Groupedbar Compact user interface with an object selected**

**Figure 336: Menu for Groupedbar Compact UI**

### Contextual Single UI

The **Contextual Single** user interface displays a single toolbar to suit the type of object that has been selected. Clicking on the double chevron `>>` displays more tools for editing an object. Figure 337 shows an example of a **Contextual Single** user interface when a basic shape object is selected.

![Figure 337: Example of Contextual Single user interface with a basic shape selected](image)
Appendix A, 
Keyboard Shortcuts
# Introduction

LibreOffice can be used without requiring a pointing device, such as a mouse or trackball, by using the keyboard shortcuts that are available in Impress. Tasks as varied and complex as docking and undocking toolbars and windows, or changing the size or position of objects can all be accomplished with using keyboard shortcuts. Although LibreOffice has an extensive set of keyboard shortcuts, each LibreOffice module has keyboard shortcuts that are specific to that module. For help with LibreOffice keyboard shortcuts, or using LibreOffice with a keyboard only, search the LibreOffice Help using the “shortcut” or “accessibility” keywords.

In addition to using keyboard shortcuts that are listed in this appendix, keyboard shortcuts can also be user defined. Assign keyboard shortcuts to standard Impress functions or macros and save them for use with Impress only, or with the other modules in LibreOffice. To customize keyboard shortcuts, see the *Getting Started Guide* for more information.

## macOS keyboard shortcuts

Some keystrokes and menu items are different on a macOS computer from those used in Windows or Linux computers. This due to the way the different operating systems work and the different types of keyboards used. Also, the labelling on the keyboards may vary depending on the age of the computer and style of keyboard being used. The following information shows the most common variations in keyboard shortcuts and keyboard labelling.

### Shift, Control and Alt keys

<table>
<thead>
<tr>
<th>Windows or Linux</th>
<th>macOS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Control or Ctrl</td>
<td>⌘ or Cmd or Command</td>
</tr>
<tr>
<td>Alt</td>
<td>⌥ or Option or Alt</td>
</tr>
<tr>
<td>Shift or ▲</td>
<td>Shift or ▲</td>
</tr>
<tr>
<td>Caps Lock</td>
<td>⌃ or Caps Lock</td>
</tr>
<tr>
<td>Control or Ctrl</td>
<td>^ or Control or Ctrl</td>
</tr>
</tbody>
</table>

### Home and End keys

<table>
<thead>
<tr>
<th>Windows or Linux</th>
<th>macOS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Home</td>
<td>Fn + Left Arrow</td>
</tr>
<tr>
<td>End</td>
<td>Fn + Right Arrow</td>
</tr>
</tbody>
</table>

### Page Up and Page Down

<table>
<thead>
<tr>
<th>Windows or Linux</th>
<th>macOS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Screen Up</td>
<td>Fn + Up Arrow</td>
</tr>
<tr>
<td>Page Up</td>
<td>⌥ or Option or Alt + Fn + Up Arrow</td>
</tr>
<tr>
<td>Screen Down</td>
<td>Fn + Down Arrow</td>
</tr>
<tr>
<td>Page Down</td>
<td>⌥ or Option or Alt + Fn + Down Arrow</td>
</tr>
</tbody>
</table>

---

**Note**

Some keyboard shortcuts are not available for computers using macOS and are indicated in the following tables by a blank cell.
## Impress keyboard shortcuts

### Impress functions

<table>
<thead>
<tr>
<th>Windows Linux</th>
<th>macOS</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>F2</strong></td>
<td>F2</td>
<td>Switches to text edit mode and opens the Text Formatting toolbar.</td>
</tr>
<tr>
<td><strong>F3</strong></td>
<td>F3</td>
<td>Enter and edit a group of objects.</td>
</tr>
<tr>
<td><strong>Ctrl + F3</strong></td>
<td>⌘ + F3</td>
<td>Exit a group of objects.</td>
</tr>
<tr>
<td><strong>Shift + F3</strong></td>
<td>Shift + F3</td>
<td>Opens the Duplicate dialog of a selected object.</td>
</tr>
<tr>
<td><strong>F4</strong></td>
<td>F4</td>
<td>Opens the Position and Size dialog of a selected object.</td>
</tr>
<tr>
<td><strong>Alt + Shift + F5</strong></td>
<td>⌃ + Shift + F5</td>
<td>Opens Notes view and displays the first slide in the slide show.</td>
</tr>
<tr>
<td><strong>Ctrl + Shift + F5</strong></td>
<td>⌘ + Shift + F5</td>
<td>Opens the Navigator.</td>
</tr>
<tr>
<td><strong>F7</strong></td>
<td>F7</td>
<td>Start spelling checker.</td>
</tr>
<tr>
<td><strong>Shift + F7</strong></td>
<td>Shift + F7</td>
<td>Switches on or off the automatic spell checking.</td>
</tr>
<tr>
<td><strong>Ctrl + F7</strong></td>
<td>⌘ + F7</td>
<td>Opens the Thesaurus dialog for the language being used. Impress has to be in text editing mode to access the thesaurus.</td>
</tr>
<tr>
<td><strong>F8</strong></td>
<td>F8</td>
<td>When selected, opens the Edit Points toolbar.</td>
</tr>
<tr>
<td><strong>Ctrl + Shift + F8</strong></td>
<td>⌘ + Shift + F8</td>
<td>Fit text to frame of a selected object.</td>
</tr>
<tr>
<td><strong>F11</strong></td>
<td>⌘ + T</td>
<td>Open the Styles deck on the Sidebar.</td>
</tr>
</tbody>
</table>

### Slide shows

<table>
<thead>
<tr>
<th>Windows Linux</th>
<th>macOS</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>F5</strong></td>
<td>F5</td>
<td>Starts a slide show.</td>
</tr>
<tr>
<td><strong>Shift + F5</strong></td>
<td>Shift + F5</td>
<td>Starts a slide show at the slide where the slide show was previously stopped at.</td>
</tr>
<tr>
<td><strong>Left click</strong></td>
<td>Left click</td>
<td>Shows the next slide, or plays the next animation effect on a slide.</td>
</tr>
<tr>
<td><strong>Right Arrow</strong></td>
<td>Right Arrow</td>
<td>Shows the next slide, or plays the next animation effect on a slide.</td>
</tr>
<tr>
<td><strong>Page Down</strong></td>
<td>⌃ + Fn + Down Arrow</td>
<td>Shows the next slide, or plays the next animation effect on a slide.</td>
</tr>
<tr>
<td><strong>Spacebar</strong></td>
<td>Spacebar</td>
<td>Shows the next slide, or plays the next animation effect on a slide.</td>
</tr>
<tr>
<td><strong>Enter</strong></td>
<td>Enter</td>
<td>Shows the next slide, or plays the next animation effect on a slide.</td>
</tr>
<tr>
<td><strong>Right click</strong></td>
<td>Right click</td>
<td>Shows the previous slide, or plays the previous animation effect on a slide.</td>
</tr>
<tr>
<td>Windows Linux</td>
<td>macOS</td>
<td>Effect</td>
</tr>
<tr>
<td>---------------</td>
<td>---------------</td>
<td>-------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Left Arrow</strong></td>
<td><strong>Left Arrow</strong></td>
<td>Shows the previous slide, or plays the previous animation effect on a slide.</td>
</tr>
<tr>
<td><strong>Up Arrow</strong></td>
<td><strong>Up Arrow</strong></td>
<td>Shows the previous slide, or plays the previous animation effect on a slide.</td>
</tr>
<tr>
<td><strong>Page Up</strong></td>
<td>⌘ + Fn + Up Arrow</td>
<td>Shows the previous slide, or plays the previous animation effect on a slide.</td>
</tr>
<tr>
<td><strong>Backspace</strong></td>
<td><strong>Backspace</strong></td>
<td>Shows the previous slide, or plays the previous animation effect on a slide.</td>
</tr>
<tr>
<td><strong>Home</strong></td>
<td>Fn + Left Arrow</td>
<td>Go to first slide in the slide show.</td>
</tr>
<tr>
<td><strong>End</strong></td>
<td>Fn + Right Arrow</td>
<td>Go to the last slide in the slide show.</td>
</tr>
<tr>
<td>Alt + Page Up</td>
<td>⌘ + Fn + Up Arrow</td>
<td>Go to the previous slide without playing any animation effects.</td>
</tr>
<tr>
<td>Alt + Page Down</td>
<td>⌘ + Fn + Down Arrow</td>
<td>Go to next slide without playing any animation effects.</td>
</tr>
<tr>
<td><strong>B or . (period)</strong></td>
<td>B or . (period)</td>
<td>Show black screen until next key or mouse wheel event.</td>
</tr>
<tr>
<td>Esc or – (minus)</td>
<td>Esc or – (minus)</td>
<td>Stop and close the slide show.</td>
</tr>
<tr>
<td>[Number] Enter</td>
<td>[Number] Enter</td>
<td>Type the number of a slide and press Enter to show the slide.</td>
</tr>
</tbody>
</table>

### Impress shortcuts

<table>
<thead>
<tr>
<th>Windows Linux</th>
<th>macOS</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Plus (+)</strong></td>
<td>Plus (+)</td>
<td>Zoom in.</td>
</tr>
<tr>
<td><strong>Minus (-)</strong></td>
<td>Minus (-)</td>
<td>Zoom out.</td>
</tr>
<tr>
<td><strong>Times (×)</strong> on number pad</td>
<td><strong>Times (*) on number pad</strong></td>
<td>Fits the slide to fill the Workspace view.</td>
</tr>
<tr>
<td><strong>Divide (÷)</strong> on number pad</td>
<td><strong>Divide (/) on number pad</strong></td>
<td>Zooms in on the selected object.</td>
</tr>
<tr>
<td>Ctrl + Shift + G</td>
<td>⌘ + Shift + G</td>
<td>Group selected objects.</td>
</tr>
<tr>
<td>Shift + Ctrl + Alt + G</td>
<td>⌘ + Shift + ⌘ + G</td>
<td>Ungroup selected group.</td>
</tr>
<tr>
<td>Ctrl + click</td>
<td>⌘ + click</td>
<td>Enter a group to edit individual objects in the group. Click outside the group to return to normal view.</td>
</tr>
<tr>
<td>Ctrl + Shift + G</td>
<td>⌘ + Shift + G</td>
<td>Combine selected objects.</td>
</tr>
<tr>
<td>Ctrl + Shift + Alt + K</td>
<td>⌘ + Shift + ⌘ + K</td>
<td>Split a selected object that has been combined from a group of two or more objects.</td>
</tr>
<tr>
<td>Ctrl + +</td>
<td>⌘ + +</td>
<td>Bring to front.</td>
</tr>
<tr>
<td>Ctrl + Shift + +</td>
<td>⌘ + Shift + +</td>
<td>Bring forward.</td>
</tr>
<tr>
<td>Ctrl + -</td>
<td>⌘ + -</td>
<td>Send backward.</td>
</tr>
<tr>
<td>Ctrl + Shift + -</td>
<td>⌘ + Shift + -</td>
<td>Send to back.</td>
</tr>
<tr>
<td>Windows Linux</td>
<td>macOS</td>
<td>Effect</td>
</tr>
<tr>
<td>---------------</td>
<td>-------</td>
<td>--------</td>
</tr>
<tr>
<td>Arrow</td>
<td>Arrow</td>
<td>Moves a selected object in the direction of the Arrow. Also moves a slide within the Workspace when no objects are selected.</td>
</tr>
<tr>
<td>Shift + Click and drag</td>
<td>Shift + Click and drag</td>
<td>Hold down Shift then click and drag when resizing an object to maintain the proportions of the object.</td>
</tr>
<tr>
<td>Shift + Click and drag</td>
<td>Shift + Click and drag</td>
<td>Constrains movement of a selected object horizontally or vertically when dragged.</td>
</tr>
<tr>
<td>Ctrl + Click and drag</td>
<td>⌘ + Click and drag</td>
<td>Hold down the Ctrl (⌘) key, then click and drag a selected object to create a copy of the object.</td>
</tr>
<tr>
<td>Alt + Click and drag</td>
<td>⌥ + Click and drag</td>
<td>Hold down the Alt (⌥) key and draw or resize an object from the centre of the object.</td>
</tr>
<tr>
<td>Alt + Click</td>
<td>⌥ + Click</td>
<td>Select an object that is behind the currently selected object.</td>
</tr>
<tr>
<td>Alt + Shift + Click</td>
<td>⌥ + Shift + Click</td>
<td>Select an object that is in front of the currently selected object.</td>
</tr>
<tr>
<td>Shift + Click</td>
<td>Shift + Click</td>
<td>Selects several adjacent objects or characters. Click at the start of a selection, move to the end of the selection, and then hold down Shift while you click.</td>
</tr>
<tr>
<td>Tab</td>
<td>Tab</td>
<td>Select objects in the order in which they were created.</td>
</tr>
<tr>
<td>Shift + Tab</td>
<td>Shift + Tab</td>
<td>Select objects in the reverse order in which they were created.</td>
</tr>
<tr>
<td>Esc</td>
<td>Esc</td>
<td>Exit current mode.</td>
</tr>
<tr>
<td>Page Up</td>
<td>⌥ + Fn + Up Arrow</td>
<td>Switch to the previous slide. No function on the first slide.</td>
</tr>
<tr>
<td>Page Down</td>
<td>⌥ + Fn + Down Arrow</td>
<td>Switch to the next slide. No function on the last slide.</td>
</tr>
<tr>
<td>Enter</td>
<td>Enter</td>
<td>Activate a place-holder object in a new presentation (only if the frame is selected).</td>
</tr>
<tr>
<td>Ctrl + Enter</td>
<td>⌘ + Enter</td>
<td>AutoLayouts in Impress use placeholders for slide titles, text, and objects. To select a placeholder, press Ctrl + Enter (⌘ + Enter). To move to the next placeholder, press Ctrl + Enter (⌘ + Enter) again. Pressing Ctrl + Enter (⌘ + Enter) after reaching the last placeholder in a slide, a new slide is inserted after the current slide using the same layout.</td>
</tr>
</tbody>
</table>

**Editing text**

<table>
<thead>
<tr>
<th>Windows Linux</th>
<th>macOS</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl + -</td>
<td>⌘ + -</td>
<td>Inserts a custom hyphen in text at the cursor position. Also known as a soft hyphen.</td>
</tr>
<tr>
<td>Windows</td>
<td>macOS</td>
<td>Effect</td>
</tr>
<tr>
<td>---------</td>
<td>-------</td>
<td>--------</td>
</tr>
<tr>
<td>Ctrl + Shift + - 🅰 + Shift + -</td>
<td>Inserts a non-breaking hyphen in text at the cursor position. Also known as a hard hyphen.</td>
<td></td>
</tr>
<tr>
<td>Ctrl + Shift + Space 🅰 + Shift + Space</td>
<td>Non-breaking spaces. Non-breaking spaces are not used for hyphenation and are not expanded if the text is justified.</td>
<td></td>
</tr>
<tr>
<td>Shift + Enter Shift + Enter</td>
<td>Line break without paragraph change.</td>
<td></td>
</tr>
<tr>
<td>Left Arrow Left Arrow</td>
<td>Moves the cursor one character to the left.</td>
<td></td>
</tr>
<tr>
<td>Shift + Left Arrow Shift + Left Arrow</td>
<td>Moves the cursor one character to the left and selects the character.</td>
<td></td>
</tr>
<tr>
<td>Ctrl + Left Arrow ⌥ + Left Arrow</td>
<td>Moves the cursor to the beginning of the previous word.</td>
<td></td>
</tr>
<tr>
<td>Ctrl + Shift + Left Arrow ⌥ + Shift + Left Arrow</td>
<td>Moves the cursor to the left and selects the word on the left.</td>
<td></td>
</tr>
<tr>
<td>Right Arrow Right Arrow</td>
<td>Moves the cursor one character to the right.</td>
<td></td>
</tr>
<tr>
<td>Shift + Right Arrow Shift + Right Arrow</td>
<td>Moves the cursor one character to the right and selects the character.</td>
<td></td>
</tr>
<tr>
<td>Ctrl + Right Arrow ⌥ + Right Arrow</td>
<td>Moves the cursor to the beginning of the next word.</td>
<td></td>
</tr>
<tr>
<td>Ctrl + Shift + Right Arrow ⌥ + Shift + Right Arrow</td>
<td>Moves the cursor to the right and selects the word on the right.</td>
<td></td>
</tr>
<tr>
<td>Up Arrow Up Arrow</td>
<td>Moves the cursor up one line.</td>
<td></td>
</tr>
<tr>
<td>Shift + Up Arrow Shift + Up Arrow</td>
<td>Moves the cursor up one line in the text and selects the lines of text.</td>
<td></td>
</tr>
<tr>
<td>Ctrl + Up Arrow ⌥ + Up Arrow</td>
<td>Moves the cursor to the beginning of the paragraph.</td>
<td></td>
</tr>
<tr>
<td>Ctrl + Shift + Up Arrow ⌥ + Shift + Up Arrow</td>
<td>Moves the cursor to the beginning of the paragraph. Selects the text in the paragraph from the cursor position to the beginning of the paragraph.</td>
<td></td>
</tr>
<tr>
<td>Down Arrow Down Arrow</td>
<td>Moves the cursor down one line.</td>
<td></td>
</tr>
<tr>
<td>Shift + Down Arrow Shift + Down Arrow</td>
<td>Moves the cursor down one line in the text and selects the lines of text.</td>
<td></td>
</tr>
<tr>
<td>Ctrl + Down Arrow ⌥ + Down Arrow</td>
<td>Moves the cursor to the end of the paragraph.</td>
<td></td>
</tr>
<tr>
<td>Ctrl + Shift + Down Arrow ⌥ + Shift + Down Arrow</td>
<td>Moves the cursor to the end of the paragraph. Selects the text in the paragraph from the cursor position to the end of the paragraph.</td>
<td></td>
</tr>
<tr>
<td>Home</td>
<td>Moves the cursor to the beginning of the line.</td>
<td></td>
</tr>
<tr>
<td>Shift + Home</td>
<td>Moves the cursor to the beginning of the line and selects the text from the cursor position.</td>
<td></td>
</tr>
<tr>
<td>Ctrl + Home</td>
<td>Moves the cursor to the beginning of the text block on the slide.</td>
<td></td>
</tr>
<tr>
<td>End</td>
<td>Moves the cursor to the end of the line.</td>
<td></td>
</tr>
<tr>
<td>Shift + End</td>
<td>Moves the cursor to the end of the line and selects the text from the cursor position.</td>
<td></td>
</tr>
<tr>
<td><strong>Windows</strong></td>
<td><strong>macOS</strong></td>
<td><strong>Effect</strong></td>
</tr>
<tr>
<td>------------</td>
<td>-----------</td>
<td>------------</td>
</tr>
<tr>
<td>Ctrl + End</td>
<td></td>
<td>Moves the cursor to the end of the text block on the slide.</td>
</tr>
<tr>
<td>Ctrl + Del</td>
<td></td>
<td>Delete the text from the cursor position to the end of the word.</td>
</tr>
<tr>
<td>Ctrl + Shift + Del</td>
<td></td>
<td>Delete the text from the cursor position to the end of the sentence.</td>
</tr>
<tr>
<td>Ctrl + Backspace</td>
<td>⌘ + Backspace</td>
<td>Delete the text from the cursor position to the beginning of the word.</td>
</tr>
<tr>
<td>Ctrl + Shift + Backspace</td>
<td>⌘ + Shift + Backspace</td>
<td>Delete the text from the cursor position to the beginning of the sentence.</td>
</tr>
</tbody>
</table>

**Slide Sorter and Slide Pane**

<table>
<thead>
<tr>
<th><strong>Windows</strong></th>
<th><strong>macOS</strong></th>
<th><strong>Effect</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Home</td>
<td>Home</td>
<td>Set the focus to the first slide.</td>
</tr>
<tr>
<td>End</td>
<td>End</td>
<td>Set the focus to the last slide.</td>
</tr>
<tr>
<td>Left Arrow</td>
<td>Left Arrow</td>
<td>Set the focus to the previous slide.</td>
</tr>
<tr>
<td>Right Arrow</td>
<td>Right Arrow</td>
<td>Set the focus to the next slide.</td>
</tr>
<tr>
<td>Ctrl + Shift + Down Arrow</td>
<td>⌘ + Shift + Down Arrow</td>
<td>Move selected slides down one position in Slide Sorter view. With multiple slides selected, the slides are moved together with the last selected slide in the list.</td>
</tr>
<tr>
<td>Ctrl + Shift + Up Arrow</td>
<td>⌘ + Shift + Up Arrow</td>
<td>Move selected slides up one position in Slide Sorter view. With multiple slides selected, the slides are moved together with the first selected slide in the list.</td>
</tr>
<tr>
<td>Ctrl + Shift + End</td>
<td></td>
<td>Move selected slides to end of Slide Sorter list.</td>
</tr>
<tr>
<td>Ctrl + Shift + Home</td>
<td></td>
<td>Move selected slides to start of Slide Sorter list.</td>
</tr>
<tr>
<td>Enter</td>
<td>Enter</td>
<td>Change to Normal view with the active slide when in Slide Sorter view. Add a new slide when in Slide Pane.</td>
</tr>
</tbody>
</table>

**Menu keyboard shortcuts**

The keyboard shortcuts listed in the following tables are available in each menu category on the Menu bar. The tables give the menu item or sub-item, operating system validity, and the effect or purpose of the shortcut.

**Note**

The menus listed below are in the same order as displayed on the Menu bar from left to right.
# File Menu

<table>
<thead>
<tr>
<th>Menu item or sub-item</th>
<th>Windows</th>
<th>macOS</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>New &gt; Presentation</td>
<td>Ctrl + N</td>
<td>⌘ + N</td>
<td>Opens a new presentation</td>
</tr>
<tr>
<td>New &gt; Templates</td>
<td>Shift + Ctrl + N</td>
<td>⌘ + Shift + N</td>
<td>Opens the Templates dialog</td>
</tr>
<tr>
<td>Open</td>
<td>Ctrl + O</td>
<td>⌘ + O</td>
<td>Opens the Open file browser for navigation to a folder and selecting a document.</td>
</tr>
<tr>
<td>Save</td>
<td>Ctrl + S</td>
<td>⌘ + S</td>
<td>Saves the open document.</td>
</tr>
<tr>
<td>Save As</td>
<td>Ctrl + Shift + S</td>
<td>⌘ + Shift + S</td>
<td>Opens the Save as file browser to save the open document as a new document.</td>
</tr>
<tr>
<td>Print</td>
<td>Ctrl + P</td>
<td>⌘ + P</td>
<td>Opens the Print dialog to select how the document is printed</td>
</tr>
<tr>
<td>Exit LibreOffice</td>
<td>Ctrl + Q</td>
<td>⌘ + P</td>
<td>Closes the open file and quits LibreOffice</td>
</tr>
</tbody>
</table>

# Edit Menu

<table>
<thead>
<tr>
<th>Menu item or sub-item</th>
<th>Windows</th>
<th>macOS</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo</td>
<td>Ctrl + Z</td>
<td>⌘ + Z</td>
<td>Undoes the previous editing action.</td>
</tr>
<tr>
<td>Redo</td>
<td>Ctrl + Y</td>
<td>⌘ + Y</td>
<td>Reverses the action of the last Undo command.</td>
</tr>
<tr>
<td>Cut</td>
<td>Ctrl + X</td>
<td>⌘ + X</td>
<td>Deletes the selected object and places it on the clipboard.</td>
</tr>
<tr>
<td>Copy</td>
<td>Ctrl + C</td>
<td>⌘ + C</td>
<td>Copies the selected object to the clipboard.</td>
</tr>
<tr>
<td>Paste</td>
<td>Ctrl + V</td>
<td>⌘ + V</td>
<td>Places the object on the clipboard into the document.</td>
</tr>
<tr>
<td>Paste Special</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>&gt; Paste Unformatted Text</td>
<td><code>Ctrl + Shift + Alt + V</code></td>
<td>⌘ + Shift + ⌃ + V</td>
<td>Paste copied text at the cursor position without any formatting.</td>
</tr>
<tr>
<td>Select All</td>
<td>Ctrl + A</td>
<td>⌘ + A</td>
<td>Selects all objects on a slide.</td>
</tr>
<tr>
<td>Find</td>
<td>Ctrl + F</td>
<td>⌘ + F</td>
<td>Opens the Find toolbar</td>
</tr>
<tr>
<td>Find and Replace</td>
<td>Ctrl + H</td>
<td>⌃ + ⌘ + F</td>
<td>Opens the Find and Replace dialog</td>
</tr>
<tr>
<td>Points</td>
<td>F8</td>
<td>F8</td>
<td>Opens the Edit Points toolbar if there is an object on the slide that uses editable points, for example a freeform line.</td>
</tr>
</tbody>
</table>
### Menu item or sub-item

<table>
<thead>
<tr>
<th>Menu item or sub-item</th>
<th>Windows/Linux</th>
<th>macOS</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Edit Mode</strong></td>
<td>Ctrl + Shift + M</td>
<td>⌘ + Shift + M</td>
<td>Switches on or off the Impress edit mode. When switched off, a slide show is displayed in read only mode.</td>
</tr>
</tbody>
</table>

### View menu

<table>
<thead>
<tr>
<th>Menu item or sub-item</th>
<th>Windows/Linux</th>
<th>macOS</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Rulers</strong></td>
<td>Ctrl + Shift + R</td>
<td>⌘ + Shift + R</td>
<td>Switches the rulers off and on in the Workspace.</td>
</tr>
<tr>
<td><strong>Sidebar</strong></td>
<td>Ctrl + F5</td>
<td>⌘ + F5</td>
<td>Opens or closes the Sidebar.</td>
</tr>
<tr>
<td><strong>Styles</strong></td>
<td>F11</td>
<td>⌘ + T</td>
<td>Opens or closes the Styles deck on the Sidebar.</td>
</tr>
<tr>
<td><strong>Navigator</strong></td>
<td>Ctrl + Shift+F5</td>
<td>⌘ + Shift + F5</td>
<td>Opens the <strong>Navigator</strong>.</td>
</tr>
</tbody>
</table>

### Insert menu

<table>
<thead>
<tr>
<th>Menu item or sub-item</th>
<th>Windows/Linux</th>
<th>macOS</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Object &gt; Formula Object</strong></td>
<td>Ctrl + Alt + =</td>
<td>⌘ + ⌥ + =</td>
<td>Inserts a formula into the slide</td>
</tr>
<tr>
<td><strong>Text Box</strong></td>
<td>F2</td>
<td>F2</td>
<td>Switches to text edit mode and opens the Text Formatting toolbar.</td>
</tr>
<tr>
<td><strong>Comment</strong></td>
<td>Ctrl + Alt + C</td>
<td>⌘ + ⌥ + C</td>
<td>Inserts a new comment box onto the selected slide.</td>
</tr>
<tr>
<td><strong>Hyperlink</strong></td>
<td>Ctrl + K</td>
<td>⌘ + K</td>
<td>Opens the Hyperlink dialog.</td>
</tr>
<tr>
<td><strong>Formatting</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Mark &gt; Insert non-breaking space</strong></td>
<td>Ctrl + Shift + Space</td>
<td>⌘ + Shift + Space</td>
<td>Inserts a non-breaking space at the cursor position.</td>
</tr>
<tr>
<td><strong>Mark &gt; Insert Narrow No-break Space</strong></td>
<td>Ctrl + Shift + F5</td>
<td>⌘ + Shift + F5</td>
<td>Inserts a no-breaking space at the cursor position.</td>
</tr>
<tr>
<td><strong>Mark &gt; No-width Optional Break</strong></td>
<td>Ctrl + /</td>
<td>⌘ + /</td>
<td>Inserts a no-width no optional break at the cursor position.</td>
</tr>
</tbody>
</table>

### Format menu

<table>
<thead>
<tr>
<th>Menu item or sub-item</th>
<th>Windows/Linux</th>
<th>macOS</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Text &gt; Bold</strong></td>
<td>Ctrl + B</td>
<td>⌘ + B</td>
<td>Applies <strong>Bold</strong> format to selected text.</td>
</tr>
<tr>
<td><strong>Text &gt; Italic</strong></td>
<td>Ctrl + I</td>
<td>⌘ + I</td>
<td>Applies <strong>Italic</strong> format to selected text.</td>
</tr>
<tr>
<td>Menu item or sub-item</td>
<td>Windows/Linux</td>
<td>macOS</td>
<td>Effect</td>
</tr>
<tr>
<td>--------------------------------------</td>
<td>---------------</td>
<td>-------------</td>
<td>------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Text &gt; Superscript</td>
<td>Ctrl + Shift + P + C</td>
<td></td>
<td>Applies superscript format to selected text.</td>
</tr>
<tr>
<td>Text &gt; Subscript</td>
<td>Ctrl + Shift + B + B</td>
<td></td>
<td>Applies subscript format to selected text.</td>
</tr>
<tr>
<td>Text &gt; Increase Size</td>
<td>Ctrl + ]</td>
<td>+ ]</td>
<td>Increases the point size of selected text.</td>
</tr>
<tr>
<td>Text &gt; Decrease Size</td>
<td>Ctrl + [</td>
<td>+ [</td>
<td>Decreases the point size of selected text.</td>
</tr>
<tr>
<td>Spacing &gt; Line Spacing 1</td>
<td>Ctrl + 1</td>
<td>+ 1</td>
<td>Sets the line spacing in a paragraph to a single line.</td>
</tr>
<tr>
<td>Spacing Line Spacing 5</td>
<td>Ctrl + 5</td>
<td>+ 5</td>
<td>Sets the line spacing in a paragraph to one and half lines.</td>
</tr>
<tr>
<td>Spacing &gt; Line Spacing 2</td>
<td>Ctrl + 2</td>
<td>+ 2</td>
<td>Sets the line spacing in a paragraph to two lines.</td>
</tr>
<tr>
<td>Align &gt; Left</td>
<td>Ctrl + L</td>
<td>+ L</td>
<td>Sets the paragraph alignment to left aligned.</td>
</tr>
<tr>
<td>Align &gt; Center</td>
<td>Ctrl + E</td>
<td>+ E</td>
<td>Sets the paragraph alignment to center aligned.</td>
</tr>
<tr>
<td>Align &gt; Right</td>
<td>Ctrl + R</td>
<td>+ R</td>
<td>Sets the paragraph alignment to right aligned.</td>
</tr>
<tr>
<td>Align &gt; Justified</td>
<td>Ctrl + J</td>
<td>+ J</td>
<td>Sets the paragraph alignment to justified.</td>
</tr>
<tr>
<td>Lists &gt; Demote</td>
<td>Shift + Alt + Right Arrow</td>
<td></td>
<td>Demotes a point to the next level when Outline view.</td>
</tr>
<tr>
<td>Lists &gt; Promote</td>
<td>Shift + Alt + Left Arrow</td>
<td></td>
<td>Promotes a point to the next level when in Outline view.</td>
</tr>
<tr>
<td>Lists &gt; Move Down</td>
<td>Shift + Alt + Down Arrow</td>
<td>Shift + ^ + Down Arrow</td>
<td>Moves a point down the order when in Outline view.</td>
</tr>
<tr>
<td>Lists &gt; Move Up</td>
<td>Shift + Alt + Up Arrow</td>
<td>Shift + ^ + Up Arrow</td>
<td>Moves a point up the order when in Outline view.</td>
</tr>
<tr>
<td>Clear Direct Formatting</td>
<td>Shift + Ctrl + M + ^ + Shift + M</td>
<td></td>
<td>Removes direct formatting from the selection. Direct formatting is formatting that is applied without using styles.</td>
</tr>
<tr>
<td>Styles &gt; Manage Styles</td>
<td>F11</td>
<td>+ T</td>
<td>Opens or closes the Styles deck on the Sidebar.</td>
</tr>
<tr>
<td>Object and Shape &gt; Position and Size</td>
<td>F4</td>
<td>F4</td>
<td>Opens the Position and Size dialog of a selected object.</td>
</tr>
<tr>
<td>Arrange &gt; Bring to Front</td>
<td>Ctrl + Shift + + +</td>
<td>+ +</td>
<td>Moves a selected object to the front of other objects.</td>
</tr>
<tr>
<td>Arrange &gt; Bring Forward</td>
<td>Ctrl + +</td>
<td>+ +</td>
<td>Moves a selected object in front of the forward object.</td>
</tr>
</tbody>
</table>
Menu item or sub-item | Windows | macOS | Effect
--- | --- | --- | ---
Arrange > Send Backward | Ctrl + - | ⌘ + - | Moves a selected object behind the backward object.
Arrange > Send to Back | Ctrl + Shift + - | ⌘ + Shift + - | Moves a selected object to the back of other objects.
Group > Group | Ctrl + Shift + G | ⌘ + Shift + G | Group selected objects.
Group > Ungroup | Ctrl + Alt + Shift + G | ⌘ + Alt + Shift + G | Ungroup selected group.
Group > Enter Group | F3 | F3 | Enter and edit a group of objects.
Group > Exit Group | Ctrl + F3 | ⌘ + F3 | Exit a group of objects.

Slide menu

Menu item or sub-item | Windows | macOS | Effect
--- | --- | --- | ---
New Slide | Ctrl + M | ^ + M | Inserts a new slide into the slide show.
Jump to Last Edited Slide | Alt + Shift + F5 | ⌘ + Shift + F5 | Opens the last slide edited in the document.
Move > Slide to Start | Ctrl + Shift + Home | | Moves the selected slide to the beginning of the slide show.
Move > Slide Up | Ctrl + Shift + Up | ⌘ + Shift + Up Arrow | Moves the selected slide above the previous slide. No function on the first slide.
Move > Slide Down | Ctrl + Shift + Down | ⌘ + Shift + Down Arrow | Moves the selected slide below the next slide. No function on the last slide.
Move > Slide to End | Ctrl + Shift + End | | Moves the selected slide to the end of the slide show.
Navigate > To Previous Slide | Page Up | Up Arrow | Switch to the previous slide. No function on the first slide.
Navigate > To Next Slide | Page Down | Down Arrow | Switch to the next slide. No function on the last slide.

Slide Show menu

Menu item or sub-item | Windows | macOS | Effect
--- | --- | --- | ---
Start from First Slide | F5 | F5 | Starts a slide show from the first slide.
Start from Current Slide | Shift + F5 | Shift + F5 | Starts a slide show at the slide where the slide show was previously stopped at.
### Tools menu

<table>
<thead>
<tr>
<th>Menu item or sub-item</th>
<th>Windows Linux</th>
<th>macOS</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Spelling</td>
<td>F7</td>
<td>⌘ + Shift + ;</td>
<td>Start spelling checker.</td>
</tr>
<tr>
<td>Automatic Spell Checking</td>
<td>Shift + F7</td>
<td>Shift + F7</td>
<td>Switches on or off the automatic spell checking.</td>
</tr>
<tr>
<td>Thesaurus</td>
<td>Ctrl + F7</td>
<td>⌘ + F7</td>
<td>Opens the Thesaurus dialog for the language being used. Impress has to be in text editing mode to access the thesaurus.</td>
</tr>
<tr>
<td>Extension Manager</td>
<td>Ctrl + Alt + E</td>
<td>⌘ + ⌥ + E</td>
<td>Opens the Extension Manager dialog.</td>
</tr>
<tr>
<td>Options</td>
<td>Alt + F12</td>
<td>⌘ + ,</td>
<td>Opens the Options LibreOffice dialog.</td>
</tr>
</tbody>
</table>

### Windows menu

<table>
<thead>
<tr>
<th>Menu item or sub-item</th>
<th>Windows Linux</th>
<th>macOS</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Closes Window</td>
<td>Ctrl + W</td>
<td>⌘ + W</td>
<td>Closes the active window. If there is only one window, LibreOffice Impress closes.</td>
</tr>
</tbody>
</table>

### Help menu

<table>
<thead>
<tr>
<th>Menu item or sub-item</th>
<th>Windows Linux</th>
<th>macOS</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>LibreOffice Help</td>
<td>F1</td>
<td>F1</td>
<td>Opens the browser application at the LibreOffice Help pages.</td>
</tr>
</tbody>
</table>

### Toolbar keyboard shortcuts

Impress provides several toolbars to help in creating slides and slide shows. Some of the tools on these Impress toolbars can be activated using a keyboard shortcut.

**Note**

The toolbars are listed in the same order that is displayed in the context menu that opens when clicking on **View > Toolbars** on the Menu bar.
### Drawing

<table>
<thead>
<tr>
<th>Tool name</th>
<th>Windows Linux</th>
<th>macOS</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert Text Box</td>
<td>F2</td>
<td></td>
<td>Switches to text edit mode and opens the Text Formatting toolbar.</td>
</tr>
<tr>
<td>Position and Size</td>
<td>F4</td>
<td></td>
<td>Opens the Position and Size dialog of a selected object.</td>
</tr>
<tr>
<td>Points</td>
<td>F8</td>
<td></td>
<td>Opens the Edit Points toolbar if there is an object on the slide that uses editable points, for example a freeform line.</td>
</tr>
</tbody>
</table>

### Find

<table>
<thead>
<tr>
<th>Tool name</th>
<th>Windows Linux</th>
<th>macOS</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Find and Replace</td>
<td>Ctrl + H</td>
<td>⌘ + F</td>
<td>Opens the Find and Replace dialog</td>
</tr>
</tbody>
</table>

### Form Design

<table>
<thead>
<tr>
<th>Tool name</th>
<th>Windows Linux</th>
<th>macOS</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Position and Size</td>
<td>F4</td>
<td>F4</td>
<td>Opens the Position and Size dialog of a selected object.</td>
</tr>
<tr>
<td>Bring to Front</td>
<td>Ctrl + Shift + +</td>
<td>⌨ + Shift + +</td>
<td>Moves a selected object to the front of other objects.</td>
</tr>
<tr>
<td>Send to Back</td>
<td>Ctrl + Shift + -</td>
<td>⌨ + Shift + -</td>
<td>Moves a selected object to the back of other objects.</td>
</tr>
<tr>
<td>Group</td>
<td>Ctrl + Shift + G</td>
<td>⌨ + Shift + G</td>
<td>Group selected objects.</td>
</tr>
<tr>
<td>Ungroup</td>
<td>Ctrl + Alt + Shift + G</td>
<td>⌨ + ⌘ + Shift + G</td>
<td>Ungroup selected group.</td>
</tr>
<tr>
<td>Enter Group</td>
<td>F3</td>
<td>F3</td>
<td>Enter and edit a group of objects.</td>
</tr>
<tr>
<td>Exit Group</td>
<td>Ctrl + F3</td>
<td>⌨ + F3</td>
<td>Exit a group of objects.</td>
</tr>
</tbody>
</table>

### Image

<table>
<thead>
<tr>
<th>Tool name</th>
<th>Windows Linux</th>
<th>macOS</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bring to Front</td>
<td>Ctrl + Shift + +</td>
<td>⌨ + Shift + +</td>
<td>Moves a selected object to the front of other objects.</td>
</tr>
<tr>
<td>Bring Forward</td>
<td>Ctrl + +</td>
<td>⌨ + +</td>
<td>Moves a selected object in front of the forward object.</td>
</tr>
<tr>
<td>Send Backward</td>
<td>Ctrl + -</td>
<td>⌨ + -</td>
<td>Moves a selected object behind the backward object.</td>
</tr>
<tr>
<td>Send to Back</td>
<td>Ctrl + Shift + -</td>
<td>⌨ + Shift + -</td>
<td>Moves a selected object to the back of other objects.</td>
</tr>
</tbody>
</table>
### Line and Filling

<table>
<thead>
<tr>
<th>Tool name</th>
<th>Windows Linux</th>
<th>macOS</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Position and Size</td>
<td>F4</td>
<td>F4</td>
<td>Opens the Position and Size dialog of a selected object.</td>
</tr>
<tr>
<td>Bring to Front</td>
<td>Ctrl + Shift +</td>
<td>⌘ + Shift +</td>
<td>Moves a selected object to the front of other objects.</td>
</tr>
<tr>
<td>Bring Forward</td>
<td>Ctrl +</td>
<td>⌘ +</td>
<td>Moves a selected object in front of the forward object.</td>
</tr>
<tr>
<td>Send Backward</td>
<td>Ctrl + -</td>
<td>⌘ + -</td>
<td>Moves a selected object behind the backward object.</td>
</tr>
<tr>
<td>Send to Back</td>
<td>Ctrl + Shift +</td>
<td>⌘ + Shift +</td>
<td>Moves a selected object to the back of other objects.</td>
</tr>
<tr>
<td>Show the Styles Sidebar</td>
<td>F11</td>
<td>⌘ + T</td>
<td>Opens the Styles deck on the Sidebar.</td>
</tr>
</tbody>
</table>

### Outline

<table>
<thead>
<tr>
<th>Tool name</th>
<th>Windows Linux</th>
<th>macOS</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Demote</td>
<td>Shift + Alt +</td>
<td>⌘ +</td>
<td>Demotes a point to the next level when Outline view.</td>
</tr>
<tr>
<td>Promote</td>
<td>Shift + Alt +</td>
<td>⌘ + Left Arrow</td>
<td>Promotes a point to the next level when in Outline view.</td>
</tr>
<tr>
<td>Move Down</td>
<td>Shift + Alt +</td>
<td>⌘ + Down Arrow</td>
<td>Moves a point down the order when in Outline view.</td>
</tr>
<tr>
<td>Move Up</td>
<td>Shift + Alt +</td>
<td>⌘ + Up Arrow</td>
<td>Moves a point up the order when in Outline view.</td>
</tr>
</tbody>
</table>

### Slide Sorter

<table>
<thead>
<tr>
<th>Tool name</th>
<th>Windows Linux</th>
<th>macOS</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start from First Slide</td>
<td>F5</td>
<td>F5</td>
<td>Starts a slide show from the first slide</td>
</tr>
</tbody>
</table>

### Standard

<table>
<thead>
<tr>
<th>Tool name</th>
<th>Windows Linux</th>
<th>macOS</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>New</td>
<td>Ctrl + N</td>
<td>⌘ + N</td>
<td>Opens a new presentation document.</td>
</tr>
<tr>
<td>Templates</td>
<td>Ctrl + Shift +N</td>
<td>⌘ + Shift +N</td>
<td>Opens the Templates dialog to create a new document using a template.</td>
</tr>
<tr>
<td>Open</td>
<td>Ctrl + O</td>
<td>⌘ + O</td>
<td>Opens the Open file browser so you can navigate to a folder and select a document.</td>
</tr>
<tr>
<td>Save</td>
<td>Ctrl + S</td>
<td>⌘ + S</td>
<td>Saves the open document.</td>
</tr>
<tr>
<td>Tool name</td>
<td>Windows/Linux</td>
<td>macOS</td>
<td>Effect</td>
</tr>
<tr>
<td>-------------------</td>
<td>----------------</td>
<td>--------------</td>
<td>----------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Save As</td>
<td>Ctrl + Shift + S</td>
<td>⌘ + Shift + S</td>
<td>Opens the Save as file browser so you can save the open document as a new document.</td>
</tr>
<tr>
<td>Edit Mode</td>
<td>Ctrl + Shift + M</td>
<td>⌘ + Shift + M</td>
<td>Switches on edit mode when a document is in read only mode.</td>
</tr>
<tr>
<td>Print</td>
<td>Ctrl + P</td>
<td>⌘ + P</td>
<td>Opens the Print dialog to select how the document is printed.</td>
</tr>
<tr>
<td>Cut</td>
<td>Ctrl + X</td>
<td>⌘ + X</td>
<td>Deletes the selected object and places it on the clipboard.</td>
</tr>
<tr>
<td>Copy</td>
<td>Ctrl + C</td>
<td>⌘ + C</td>
<td>Copies the selected object to the clipboard.</td>
</tr>
<tr>
<td>Paste</td>
<td>Ctrl + V</td>
<td>⌘ + V</td>
<td>Places the object on the clipboard into the document.</td>
</tr>
<tr>
<td>Clear Direct Formatting</td>
<td>Ctrl + Shift + M</td>
<td>⌘ + Shift + M</td>
<td>Removes direct formatting that has been applied without using styles.</td>
</tr>
<tr>
<td>Undo</td>
<td>Ctrl + Z</td>
<td>⌘ + Z</td>
<td>Undoes the previous editing action.</td>
</tr>
<tr>
<td>Redo</td>
<td>Ctrl + Y</td>
<td>⌘ + Y</td>
<td>Reverses the action of the last <strong>Undo</strong> command.</td>
</tr>
<tr>
<td>Find and Replace</td>
<td>Ctrl + H</td>
<td>⌘ + ~ + F</td>
<td>Opens the Find and Replace dialog.</td>
</tr>
<tr>
<td>Spelling</td>
<td>F7</td>
<td>F7</td>
<td>Starts the spelling checker.</td>
</tr>
<tr>
<td>Toggle Automatic Spell</td>
<td>Shift + F7</td>
<td>Shift + F7</td>
<td>Switches on or off the automatic spell checking.</td>
</tr>
<tr>
<td>Start from First Slide</td>
<td>F5</td>
<td>F5</td>
<td>Starts a slide show.</td>
</tr>
<tr>
<td>Start from Current Slide</td>
<td>Shift + F5</td>
<td>Shift + F5</td>
<td>Starts a slide show at the slide where the slide show was previously stopped at.</td>
</tr>
<tr>
<td>Insert Text Box</td>
<td>F2</td>
<td>F2</td>
<td>Switches to text edit mode and opens the Text Formatting toolbar.</td>
</tr>
<tr>
<td>Insert Hyperlink</td>
<td>Ctrl + K</td>
<td>⌘ + K</td>
<td>Opens the Hyperlink dialog.</td>
</tr>
</tbody>
</table>

**Standard (Single Mode)**

<table>
<thead>
<tr>
<th>Tool name</th>
<th>Windows/Linux</th>
<th>macOS</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>New</td>
<td>Ctrl + N</td>
<td>⌘ + N</td>
<td>Opens a new presentation document.</td>
</tr>
<tr>
<td>Open</td>
<td>Ctrl + O</td>
<td>⌘ + O</td>
<td>Opens the <strong>Open</strong> file browser for navigation to a folder and select a document.</td>
</tr>
<tr>
<td>Save</td>
<td>Ctrl + S</td>
<td>⌘ + S</td>
<td>Saves the open document.</td>
</tr>
<tr>
<td>Print</td>
<td>Ctrl + P</td>
<td>⌘ + P</td>
<td>Opens the Print dialog to select how the document is printed.</td>
</tr>
<tr>
<td><strong>Tool name</strong></td>
<td><strong>Windows</strong></td>
<td><strong>Linux</strong></td>
<td><strong>macOS</strong></td>
</tr>
<tr>
<td>--------------</td>
<td>-------------</td>
<td>-----------</td>
<td>-----------</td>
</tr>
<tr>
<td>Undo</td>
<td>Ctrl + Z</td>
<td>⌘ + Z</td>
<td></td>
</tr>
<tr>
<td>Redo</td>
<td>Ctrl + Y</td>
<td>⌘ + Y</td>
<td></td>
</tr>
<tr>
<td>Insert Text Box</td>
<td>F2</td>
<td>F2</td>
<td></td>
</tr>
<tr>
<td>Position and Size</td>
<td>F4</td>
<td>F4</td>
<td></td>
</tr>
<tr>
<td>Group</td>
<td>Ctrl + Shift + G</td>
<td>⌘ + Shift + G</td>
<td></td>
</tr>
<tr>
<td>Ungroup</td>
<td>Ctrl + Alt + Shift + G</td>
<td>⌘ + ⌥ + Shift + G</td>
<td></td>
</tr>
<tr>
<td>Enter Group</td>
<td>F3</td>
<td>F3</td>
<td></td>
</tr>
<tr>
<td>Exit Group</td>
<td>Ctrl + F3</td>
<td>⌘ + F3</td>
<td></td>
</tr>
<tr>
<td>Start from First Slide</td>
<td>F5</td>
<td>F5</td>
<td></td>
</tr>
<tr>
<td>Start from Current Slide</td>
<td>Shift + F5</td>
<td>Shift + F5</td>
<td></td>
</tr>
</tbody>
</table>

**Standard (Viewing Mode)**

<table>
<thead>
<tr>
<th><strong>Tool name</strong></th>
<th><strong>Windows</strong></th>
<th><strong>Linux</strong></th>
<th><strong>macOS</strong></th>
<th><strong>Effect</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Save As</td>
<td>Ctrl + Shift + S</td>
<td>⌘ + Shift + S</td>
<td></td>
<td>Opens the Save as file browser to save the open document as a new document.</td>
</tr>
<tr>
<td>Edit Mode</td>
<td>Ctrl + Shift + M</td>
<td>⌘ + Shift + M</td>
<td></td>
<td>Switches on edit mode when a document is in read only mode.</td>
</tr>
<tr>
<td>Print</td>
<td>Ctrl + P</td>
<td>⌘ + P</td>
<td></td>
<td>Opens the Print dialog to select how the document is printed.</td>
</tr>
<tr>
<td>Copy</td>
<td>Ctrl + C</td>
<td>⌘ + C</td>
<td></td>
<td>Copies the selected object to the clipboard.</td>
</tr>
<tr>
<td>Find and Replace</td>
<td>Ctrl + H</td>
<td>⌘ + ⌥ + F</td>
<td></td>
<td>Opens the Find and Replace dialog.</td>
</tr>
<tr>
<td>Start from First Slide</td>
<td>F5</td>
<td>F5</td>
<td></td>
<td>Starts a slide show from the first slide.</td>
</tr>
</tbody>
</table>

**Text**

<table>
<thead>
<tr>
<th><strong>Tool name</strong></th>
<th><strong>Windows</strong></th>
<th><strong>Linux</strong></th>
<th><strong>macOS</strong></th>
<th><strong>Effect</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert Text Box</td>
<td>F2</td>
<td>F2</td>
<td></td>
<td>Switches to text edit mode and opens the Text Formatting toolbar.</td>
</tr>
</tbody>
</table>
Impress Guide 7.3

Appendix B, Toolbars
Introduction

In Impress there are several toolbars available to help in creating a presentation. Each toolbar has a default set of tools and the option to add additional tools to a toolbar.

Note

The icons displayed in the Impress toolbars illustrated in this appendix may differ from what is displayed on a computer screen. Toolbar icons depend on the computer operating system being used and how LibreOffice has been set up. For more information on customizing LibreOffice and the toolbars, see the Getting Started Guide.

Using toolbars

Displaying toolbars

To display and make a toolbar active, go to View > Toolbars on the Menu bar. A submenu opens with an alphabetical list of toolbars available for creating presentations in LibreOffice Impress. Click on a toolbar name to display it and make it active. Active toolbars are indicated by highlighting or a check mark next to the name.

Impress toolbars available

| 3D-Objects | Glue Points | Slide View |
| 3D-Settings | Image | Standard |
| Align Objects | Insert | Standard (Single Mode) |
| Comments | Legacy Circles and Ovals | Standard (Viewing Mode) |
| Distribute Selection | Legacy Rectangles | Table |
| Drawing | Line and Filling | Text |
| Edit Points | Master View | Text Formatting |
| Find | Media Playback | Transformations |
| Fontwork | Options | TSCP Classification |
| Form Controls | Outline | Zoom |
| Form Design | Presentation | |
| Form Navigation | Slide Sorter | |

Note

Some toolbars, although selected in View > Toolbars on the Menu bar, will not display until an object of the correct type is selected in a presentation. For example, the Image toolbar only displays when an image is selected.

Closing toolbars

To close a toolbar, use one of the following methods:

- Go to View > Toolbars on the Menu bar and deselect the toolbar.
- Right-click on an icon on a toolbar and select Close Toolbar from the context menu.
- Click on the X in the right corner of the title bar of a floating toolbar.
Moving toolbars

Docked toolbars
By default, some toolbars are docked into position in the Impress main window. For example, the Standard toolbar is docked at the top of the main window. Docked toolbars can be undocked and moved to a new docked position on the main window or left as a floating toolbar.

9) Move the cursor over the small vertical handle at the left end of the toolbar, as shown in Figure 338. The cursor changes to the moving cursor used for the computer system and setup.

10) Click and drag the toolbar to a new location. This can be a new docked position or a floating toolbar. A hashed border appears around the toolbar indicating the toolbar position as it is dragged.

11) Release the cursor when the required position is reached.

![Toolbar handles](image)

Figure 338: Toolbar handles

Note
If the small vertical bar is not visible at the left end of a docked toolbar, then the toolbar is locked into position. A docked toolbar must be unlocked before it can be moved to a new position in the Impress main window. See “Locking toolbars” on page 406 for more information.

Floating toolbars
To move a floating toolbar, click on its title bar and drag it to a new floating location. Release the mouse button when the toolbar is in the required position. A floating toolbar does not have to be positioned on the Impress main window for it to function.

Floating sub-toolbars
Some tools on a toolbar have a triangle ▼ to the right of the tool indicating that more tools are available on a sub-toolbar, for example Basic Shapes on the Drawing toolbar. Sub-toolbars can be turned into floating toolbars and moved into a new position as follows:

![Click here and drag to create a floating toolbar](image)

Figure 339: Creating floating sub-toolbar
1) Move the cursor over the horizontal handle at the top of the toolbar, as shown in Figure 339. The cursor changes to the moving cursor used for the computer system and setup.

2) Click and drag the toolbar to a new location to create a floating sub-toolbar.

3) Release the cursor when the required position is reached.

4) To close the floating sub-toolbar, right-click on the triangle ▼ in the sub-toolbar title bar and select Close Toolbar from the context menu.

**Docking toolbar**

To dock a floating toolbar, use one of the following methods:

- Click on the title bar and drag it to the top, bottom, left side, or right side of the main window. When the toolbar reaches a docking position, a hashed border appears at the docked position. Release the cursor and the toolbar is docked.

- Right-click on the toolbar and select Dock Toolbar from the context menu. The toolbar moves into a docked position. If the position is not suitable, move the toolbar to a new docked position.

- To dock all floating toolbars that are active, right-click on the toolbar and select Dock All Toolbars from the context menu.

**Locking toolbars**

**Docked toolbars**

When a toolbar has been docked into position on the Impress main window, the toolbar can also be locked into position preventing the toolbar from becoming a floating toolbar.

- To lock a toolbar into a docked position, right-click in a blank area on the toolbar and select Lock Toolbar Position from the context menu. A check mark appears against this option indicating the toolbar is now locked.

- To unlock a toolbar, right-click in a blank area on the toolbar and click on Lock Toolbar Position in the context menu. The check mark next to this option disappears indicating the toolbar is now unlocked. A small vertical or horizontal bar appears at the left end or top of the toolbar indicating that the toolbar is unlocked. This bar is also is used to move the toolbar.

**Note**

Some toolbars cannot be docked or locked into position. This is indicated by the options Dock Toolbar and/or Lock Toolbar Position being grayed out, making the options unavailable.

**Docking toolbar**

To prevent sub-toolbars from becoming floating sub-toolbars, sub-toolbars have to be locked as follows:

1) Save the presentation that is open in Impress.

2) Go to View > Toolbars on the Menu bar and select Lock Toolbars from the context menu.

3) Select Restart Now in the Restart LibreOffice dialog that opens to activate the Lock Toolbars option.

4) To unlock sub-toolbars so they can become floating sub-toolbars, repeat Steps 1 thru 3. The Lock Toolbars option is an on/off switch.
Using **Lock Toolbars** option affects all sub-toolbars available in LibreOffice modules.

### Editing toolbars

When LibreOffice is installed on a computer, it includes a set of toolbars suitable for each LibreOffice component. Each toolbar has a default set of visible tools. Tools can be added or deleted, and toolbars can be customized.

#### Adding tools

1. Right-click in a blank area on a toolbar, or click on the triangle ▼ on the right of the toolbar title bar.
2. Select **Visible Buttons** from the context menu to display a list of available tools.
3. Click on the tool required and the tool appears in the toolbar. The list of available tools closes automatically. If there is a highlight or check mark next to the tool, then that tool is already installed on the toolbar.

**Note**

When adding tools using **Visible Buttons**, the tool is added to the toolbar at the same position as the tool appears in the **Visible Buttons** list. That is, the top tool in **Visible Buttons** appears at the left end of the toolbar and the bottom tool appears at the right end of the toolbar. Tool positions cannot be changed using **Visible Buttons**.

#### Deleting tools

1. Right-click in a blank area on a toolbar, or click on the triangle ▼ on the right of the toolbar title bar.
2. Select **Visible Buttons** from the context menu to display a list of available tools.
3. Click on the tool no longer required and the tool is removed from the toolbar. The highlight or check mark next to the tool is also removed. The list of available tools closes automatically.

#### Customizing toolbars

Extra tools and commands that are not available in **Visible Buttons** can be added to a toolbar using customization. Customization also allows the creation of new toolbars if a specific set of tools are required for a specific task. For information on customizing toolbars, see the *Getting Started Guide*.

### Toolbars

**Note**

The available tools listed for each toolbar below are all available for installation on a toolbar when **Visible Buttons** is opened in the context menu for each toolbar. The tools already installed on a toolbar are indicated in **Visible Buttons** either by the tool icon being highlighted or by a check mark. This install indication depends on computer setup and computer operating system being used.

**Note**

On some toolbars, the icons have a triangle ▼ to the right of an icon. Click on this triangle to open further options that are available for use.
Note

Some of the tools in the toolbars also have the option of using a keyboard shortcut instead of clicking on the tool. For a full list of keyboard shortcuts that are available in Impress, see Appendix A, Keyboard Shortcuts.

3D-Objects

The 3D-Objects toolbar (Figure 340) provides tools to create 3D objects in a slide. It is activated by going to View > Toolbars > 3D-Objects on the Menu bar. Alternatively, click on the small triangle ▼ next to the 3D-Objects icon displayed on the Drawing toolbar to open a submenu giving access to the available 3D objects.

![3D-Objects toolbar](image)

**Available tools from left to right**
- Cube
- Sphere
- Cylinder
- Cone
- Pyramid
- Torus
- Shell
- Half Sphere

3D-Settings

The 3D-Settings toolbar (Figure 341) and its tools only become active when an object has been converted to 3D using the tool Toggle Extrusion and the converted object is selected.

![3D-Settings toolbar](image)

**Available tools from left to right**
- Toggle Extrusion
- Tilt Down
- Tilt Up
- Tilt Left
- Tilt Right
- Depth
- Direction
- Lighting
- Surface
- 3D Color

The following tools on the 3D-Settings toolbar have a triangle ▼ on the right of the icon. Click on this triangle to open a drop-down menu giving access to various options as follows:

- **Depth** — 3D extrusion depth – 0cm; 1cm; 2.5cm; 5cm; 10cm; Infinity; Custom. The measurement unit depends on the ruler settings in Tools > Options > LibreOffice Impress > General (macOS LibreOffice > Preferences > LibreOffice Impress > General).
- **Direction** — 3D extrusion direction and type – Parallel; Perspective.
- **Lighting** — lighting direction and lighting level of 3D extrusion – Bright; Normal; Dim.
- **Surface** — surface type of 3D extrusion – Wire Frame; Matt; Plastic; Metal.
- **3D Color** — color of 3D extrusion. Select a color from one of the available color palettes.
**Align Objects**

The Align Objects toolbar (Figure 342) provides tools for aligning several objects in a slide to improve the visual impact of objects on a slide.

![Align Objects toolbar](image)

*Figure 342: Align Objects toolbar*

**Available tools from left to right**

| Left | Centered | Right | Top | Center | Bottom |

**Comments**

The Comments toolbar (Figure 343) provides tools for adding, deletion, and navigation of comments in a presentation. To use comments, it is recommended to add the name and initials of all users in **Tools > Options > LibreOffice > User Data** (macOS **LibreOffice > Preferences > LibreOffice > User Data**) so that comments can be easily identified.

![Comments toolbar](image)

*Figure 343: Comments toolbar*

**Available tools from left to right**

| Comment | Previous Comment | Next Comment | Delete Comment | Delete All Comments |

**Distribute Selection**

The Distribute Selection toolbar (Figure 344) provides tools to distribute three or more selected objects evenly along the horizontal axis or vertical axis. Also, the spacing between objects can be evenly distributed.

![Distribute Selection toolbar](image)

*Figure 344: Distribute Selection toolbar*

**Available tools from left to right**

| Horizontally Left | Horizontally Right | Vertically Spacing |
| Horizontally Center | Vertically Top | Vertically Bottom |
| Horizontally Spacing | Vertically Center | |

**Drawing**

The Drawing toolbar (Figure 345) provides the majority of the tools normally used to create graphic objects on slides in a presentation. By default, this toolbar is normally docked on the left side of the Workspace.
Some tool shapes on the Drawing toolbar change depending on the last tool that was previously selected and used.

- Click on the triangle ▼ to the right of a tool to open a sub-toolbar. Select the required shape to add to a drawing.
- To create a sub-toolbar, click and drag at the top of the pop-up toolbar to an empty area on the main window. The sub-toolbars for each object type and the various shapes available are shown Figures 346 to 355.
Edit Points

The Edit Points toolbar (Figure 356) provides tools for editing the points of a curve or an object that has been converted to a curve. The toolbar only becomes active when an object is selected and one of the following methods is used to open the toolbar:

- Click on Edit Points on the Drawing or Standard toolbar.
- Use the keyboard shortcut F8.
Available tools from left to right

<table>
<thead>
<tr>
<th>Edit Points</th>
<th>Convert to Curve</th>
<th>Smooth Transition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move Points</td>
<td>Close Bezier</td>
<td>Symmetric Transition</td>
</tr>
<tr>
<td>Insert Points</td>
<td>Split Curve</td>
<td>Eliminate Points</td>
</tr>
<tr>
<td>Delete Points</td>
<td>Corner Point</td>
<td></td>
</tr>
</tbody>
</table>

Find

The Find toolbar (Figure 357) opens by default in the bottom left corner of the Impress main window. This toolbar is normally docked at the bottom left of the Impress main window above the Status bar. However, it can be undocked and made into a floating toolbar.

![Figure 357: Find toolbar](image)

Find toolbar

Available tools from left to right

<table>
<thead>
<tr>
<th>Close Find Bar</th>
<th>Find Next</th>
<th>Find and Replace</th>
</tr>
</thead>
<tbody>
<tr>
<td>Find Text</td>
<td>Find All</td>
<td></td>
</tr>
<tr>
<td>Find Previous</td>
<td>Match Case</td>
<td></td>
</tr>
</tbody>
</table>

Fontwork

The Fontwork toolbar (Figure 358) is used to create graphical text objects in a slide and provide the tools for editing the graphical text object. This toolbar only becomes active when a Fontwork graphical text object in a slide has been selected.

![Figure 358: Fontwork toolbar](image)

Fontwork toolbar

Available tools from left to right

<table>
<thead>
<tr>
<th>Insert Fontwork Text</th>
<th>Fontwork Same Letter Heights</th>
<th>Fontwork Character Spacing</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fontwork Shape</td>
<td>Fontwork Alignment</td>
<td>Toggle Extrusion</td>
</tr>
</tbody>
</table>

Some tools on the Fontwork toolbar have a triangle ▼ to the right of the tool. Click on the triangle to open a pop-up toolbar or drop-down option list.

- **Fontwork Shape** — select the required shape for the Fontwork graphical text object from the options available.
- **Fontwork Alignment** — select the paragraph alignment from the options available.
- **Fontwork Character Spacing** — select the required character spacing from the options available.

Form Controls

The Form Controls toolbar (Figure 359) provides the tools required to create an interactive form. This allows controls to be added to a form in a text, drawing, spreadsheet, presentation, or HTML document (for example a button that opens another presentation or slide).
Figure 359: Form Controls toolbar

Available tools from left to right

<table>
<thead>
<tr>
<th>Select</th>
<th>Option Button</th>
<th>Time Field</th>
</tr>
</thead>
<tbody>
<tr>
<td>Design Mode</td>
<td>List Box</td>
<td>Currency Field</td>
</tr>
<tr>
<td>Toggle Form Control Wizards</td>
<td>Combo Box</td>
<td>Pattern Field</td>
</tr>
<tr>
<td>Form Design</td>
<td>Push Button</td>
<td>Table Control</td>
</tr>
<tr>
<td>Control Properties</td>
<td>Image Button</td>
<td>Navigation Bar</td>
</tr>
<tr>
<td>Form Properties</td>
<td>Formatted Field</td>
<td>Image Control</td>
</tr>
<tr>
<td>Label</td>
<td>Date Field</td>
<td>File Selection</td>
</tr>
<tr>
<td>Text Box</td>
<td>Numerical Field</td>
<td>Spin Button</td>
</tr>
<tr>
<td>Check Box</td>
<td>Group Box</td>
<td>Scrollbar</td>
</tr>
</tbody>
</table>

Form Design

The Form Design toolbar (Figure 360) opens a form in Design Mode so that it can be edited. Controls of the form cannot be activated or its contents edited when in Design Mode. However, the position and size of the controls can be changed, other properties edited, and added or deleted controls in Design Mode.

Figure 360: Form Design toolbar

Available tools from left to right

<table>
<thead>
<tr>
<th>Select</th>
<th>Automatic Control Focus</th>
<th>Align Objects</th>
</tr>
</thead>
<tbody>
<tr>
<td>Control Properties</td>
<td>Bring to Front</td>
<td>Open in Design Mode</td>
</tr>
<tr>
<td>Form Properties</td>
<td>Send to Back</td>
<td>Display Grid</td>
</tr>
<tr>
<td>Position and Size</td>
<td>Group</td>
<td>Snap to Grid</td>
</tr>
<tr>
<td>Form Navigator</td>
<td>Ungroup</td>
<td>Helplines While Moving</td>
</tr>
<tr>
<td>Activation Order</td>
<td>Enter Group</td>
<td></td>
</tr>
<tr>
<td>Add Field</td>
<td>Exit Group</td>
<td></td>
</tr>
</tbody>
</table>

Form Navigation

The Form Navigation toolbar (Figure 361) provides tools to edit a database table or control the data view. The toolbar is normally displayed at the bottom of a document that contains fields that are linked to a database. This toolbar is only active when forms are connected to a database; an inactivate toolbar is shown in Figure 361.

The Form Navigation toolbar also allows movement within records as well as inserting and deleting records. If data is saved in a form, the changes are transferred to the database. This toolbar also provides tools providing sort, filter, and search functions for data records.

Figure 361: Form Navigation toolbar

Available tools from left to right
Glue Points

The Glue Points toolbar (Figure 362) provides tools to insert a glue point or modify the properties of a glue point. A glue point is a point where a connector is attached to an object. By default, LibreOffice automatically places a glue point at the center of each side of the bounding rectangle for every object created.

![Glue Points toolbar](image)

**Available tools from left to right**
- Insert Glue Point
- Exit Direction Left
- Exit Direction Top
- Exit Direction Right
- Exit Direction Bottom
- Glue Point Relative
- Glue Point Horizontal Left
- Glue Point Horizontal Center
- Glue Point Horizontal Right
- Glue Point Vertical Top
- Glue Point Vertical Center
- Glue Point Vertical Bottom

Image

The Image toolbar (Figure 363) provides tools to edit, modify, align, reposition and resize images. The toolbar only becomes active and available when an image is selected in a presentation. The Image toolbar automatically replaces the Line and Filling toolbar when it becomes active.

![Image toolbar](image)

**Available tools from left to right**
- Position and Size
- Align Objects
- Left
- Centered
- Right
- Top
- Center
- Bottom
- Arrange
- Bring to Front
- Bring Forward
- Send Backward
- Send to Back
- In Front of Object
- Behind Object
- Reverse
- Line Style
- Line Width
- Line Color
- Area Style/Filling
- Fill Color
- Shadow
- Filter
- Image Mode
- Crop
- Vertically
- Horizontally
- Transformations
- Transparency
- Color
- Line
- Area
- Animation
Interaction

**Insert**

The Insert toolbar (Figure 364) provides tools to insert different types of objects into a slide.

![Insert toolbar](image)

*Figure 364: Insert toolbar*

**Available tools from left to right**

- New Page
- Floating Frame
- Insert Page from File
- Table
- Image
- Insert Audio or Video (Media in Visible Buttons)
- Formula Object
- Chart
- OLE Object

**Legacy Circles and Ovals**

The Legacy Circles and Ovals toolbar (Figure 365) provides tools to insert different types of circles and ovals into a drawing.

![Legacy Circles and Ovals toolbar](image)

*Figure 365: Legacy Circles and Ovals toolbar*

**Available tools from left to right**

- Insert Ellipse
- Circle
- Ellipse Pie
- Circle Pie
- Ellipse Segment
- Circle Segment
- Circle
- Ellipse, Unfilled
- Circle Pie
- Ellipse Pie, Unfilled
- Circle Pie, Unfilled
- Ellipse Segment, Unfilled
- Circle Segment, Unfilled
- Arc
- Circle Arc

**Legacy Rectangles**

The Legacy Rectangles toolbar (Figure 366) provides tools to insert different types of rectangles and squares into a slide.

![Legacy Rectangles toolbar](image)

*Figure 366: Legacy Rectangles toolbar*

**Available tools from left to right**

- Insert Rectangle
- Square
- Rectangle, Rounded
- Rounded Square
- Rectangle, Unfilled
- Square, Unfilled
- Rounded Rectangle, Unfilled
- Rounded Square, Unfilled
Line and Filling
The Line and Filling toolbar (Figure 367) provides tools and drop-down lists for editing lines, arrows, and object borders. The tools available vary depending on the type of object selected for editing.

Figure 367: Line and Filling toolbar
Available tools from left to right
Position and Size | Send to Back | Horizontally
Align Objects | In Front of Object | Transformations
Left | Behind Object | Line
Centered | Reverse | Area
Right | Line Style | 3D Effects
Top | Line Width | Image Map
Center | Line Color | Animation
Bottom | Area Style/Filling | Interaction
Arrange | Fill Color | Show the Styles Sidebar
Bring to Front | Shadow | Display Grid
Bring Forward | Arrow Style | Helplines While Moving
Send Backward | Vertically | 

Master View
The Master View toolbar (Figure 368) provides tools to create a new master slide, rename a master slide, delete a master slide, and close master view. This toolbar is only active when Impress is in master view.

Figure 368: Master View toolbar
Available tools from left to right
New Master | Delete Master
Rename Master | Close Master View
Media Playback

The Media Playback toolbar (Figure 369) provides the tools required to insert, view, play, and listen to audio and video files. The toolbar only becomes active when an audio or video file is selected. Impress supports many different media formats depending on the computer operating system being used.

![Media Playback toolbar]

Figure 369: Media Playback toolbar

Available tools from left to right
- Insert Audio or Video
- Play
- Pause
- Stop
- Repeat
- Position
- Mute
- Volume
- View

Options

The Options toolbar (Figure 370) provides tools for editing various settings for newly created presentations, for example how objects snap to the grid when being moved or resized.

![Options toolbar]

Figure 370: Options toolbar

Available tools from left to right
- Rotation Mode after Clicking Object
- Display Grid
- Display Snap Guides
- Helplines While Moving
- Snap to Grid
- Snap to Snap Guides
- Snap to Page Margins
- Snap to Object Borders
- Snap to Object Points
- Allow Quick Editing
- Select Text Area Only
- Double-click to edit Text
- Modify Object with Attributes
- Exit All Groups

Outline

The Outline toolbar (Figure 371) provides tools for working with outlines.

![Outline toolbar]

Figure 371: Outline toolbar

Available tools from left to right
- Demote
- Promote
- Move Down
- Move Up
- Show Formatting
- Black & White View
- Show Only First Level
- Show All Levels
- Hide Subpoints
- Show Subpoints
Presentation

The Presentation toolbar (Figure 372) provides tools for working with presentations.

Available tools from left to right
New Slide | Change Slide Master | Go to Last Slide
Duplicate Slide | Expand Slide | Move Slide to Start
Rename Slide | Go to First Slide | Move Slide Up
Delete Slide | Go to Previous Slide | Move Slide Down
Slide Layout | Go to Next Slide | Move Slide to End

Slide Sorter

The Slide Sorter toolbar (Figure 373) allows selection of slides in the current presentation and start a presentation from the first slide.

Available tools from left to right
Select | Start from First Slide

Slide View

The Slide View toolbar (Figure 374) opens with the Slide Sorter view and provides tools to rehearse timings of a slide show; hide and show slides, and change the number of slides displayed in Slide Sorter view.

Available tools from left to right
Rehearse Timings | Hide Slide
Show Slide | Slides per Row
**Standard**

The Standard toolbar (Figure 375) is common to all LibreOffice modules and provides tools for creating and editing documents using LibreOffice. The Standard toolbar differs between different LO modules to allow for different toolsets used in creating the different types of documents.

![Standard toolbar](image)

**Figure 375: Standard toolbar**

**Available tools from left to right**
- Load URL
- New
- Templates
- Open
- Open Remote
- Save
- Save As
- Email
- Edit Mode
- Export Directly as PDF
- Print Directly
- Print
- Cut
- Copy
- Paste
- Clone Formatting (Clone in Visible Buttons)
- Clear

- Undo
- Redo
- Find and Replace
- Spelling
- Auto Spellcheck
- Zoom & Pan
- Zoom
- Display Grid (Grid in Visible Buttons)
- Helplines While Moving
- Display Views
- Views Tab Bar
- Format Slide
- Master Slide
- Start from First Slide
- Start from Current Slide
- Table

- Insert Image (Image in Visible Buttons)
- Insert Audio or Video (Media in Visible Buttons)
- Insert Chart (Chart in Visible Buttons)
- Text Box
- Insert Special Characters (Symbol in Visible Buttons)
- Vertical Text
- Insert Fontwork Text
- Insert Hyperlink (Hyperlink in Visible Buttons)
- Show Draw Functions (Draw Functions in Visible Buttons)
- Interaction
- LibreOffice Help
- What’s That

**Standard (Single Mode)**

The Standard (Single Mode) toolbar (Figure 376) can be used instead of the Standard toolbar if necessary. The Standard (Single Mode) toolbar is normally used when the user interface is switched to single mode. For more information on selecting and using user interface variants, see Chapter 12, User Interface Variants.

![Standard (Single Mode) toolbar](image)

**Figure 376: Standard (Single Mode) toolbar**

**Available tools from left to right**
New
Open
Save
Export Directly as PDF
Print
Print Preview
Undo
Redo
Find and Replace
Clone Formatting (Clone in Visible Buttons)
Spelling
Entire Page
New Slide
Duplicate Slide
Rename Slide
Delete Slide
Slide Layout
Display Views
Text Box
Vertical Text
Insert Image (Image in Visible Buttons)
Insert Audio or Video (Media in visible Buttons)
Insert Chart (Chart in Visible Buttons)
Table
Insert Fontwork
Insert Line (Line in visible Buttons)
Rectangle
Ellipse
Lines and Arrows
Curves and Polygons
Connectors
Basic Shapes
Symbol Shapes
Block Arrows (Arrow Shapes in Visible Buttons)
Flowchart (Flowchart Shapes in Visible Buttons)
Callouts (Callout Shapes in Visible Buttons)
Stars and Banners (Star Shapes in Visible Buttons)
3D Objects
Position and Size
Rotate
Flip
Align Objects
Arrange
Select at least three objects to distribute (Distribution in Visible Buttons)
Group
Ungroup
Enter Group
Exit Group
Select
Entire Page
Zoom & Pan
Zoom
Start from First Slide
Start from Current Slide

Standard (Viewing Mode)

The Standard (Viewing Mode) toolbar (Figure 377) provides tools to save, edit and distribute a document.

![Standard (Viewing Mode) toolbar](image)

**Figure 377: Standard (Viewing Mode) toolbar**

**Available tools from left to right**

- Save As
- Export Directly as PDF
- Copy
- Edit Mode
- EPUB
- Find and Replace
- Read Only Mode
- Print Directly
- Zoom
- Attach to Email (Email in Visible Buttons)
- Print
- Start from First Slide

376 | *LibreOffice 7.3 Impress Guide*
Table

The Table toolbar (Figure 378) provides tools and options to edit and format a table placed on a slide. This toolbar only becomes active when a table is selected.

![Table toolbar](image)

**Available tools from left to right**
- Table
- Border Style
- Border Color
- Borders (Shift to overwrite)
- Area Style/Filling
- Fill Color
- Merge Cells
- Split Cells
- Optimize
- Align Top (Top in Visible Buttons)
- Center Vertically (Center in Visible Buttons)
- Align Bottom (Bottom in Visible Buttons)
- Insert Row Above
- Insert Row Below
- Insert Column Before
- Insert Column After
- Delete Row
- Delete Column
- Delete Table
- Select Table
- Select Column
- Select Row
- Table Design
- Table Properties

Text

The Text toolbar (Figure 379) provides tools to insert text boxes and callouts into a slide.

![Text toolbar](image)

**Available tools from left to right**
- Insert Text Box (Text Box in Visible Buttons)
- Fit Text in Textbox Size
- Callouts
- Insert Vertical Text (Vertical Text in Visible Buttons)
- Fit Vertical Text to Frame
- Vertical Callouts

Text Formatting

The Text Formatting toolbar (Figure 380) provides tools for formatting text and alignment commands. This toolbar becomes active when text in a text box or graphic object has been selected and it automatically replaces the Line and Filling toolbar.
**Text Formatting**

Available tools from left to right:
- Font Name
- Font Size
- Increase Font Size (Increase in Visible Buttons)
- Decrease Font Size (Decrease in Visible Buttons)
- Bold
- Italic
- Underline
- Double Underline
- Strikethrough
- Overline
- Superscript
- Subscript
- Toggle Shadow (Shadow in Visible Buttons)
- Apply outline attribute to font (Outline Font Effect in Visible Buttons)
- Clear Direct Formatting (Clear in Visible Buttons)
- lowercase
- UPPERCASE
- SMALL CAPITALS
- Font Color
- Character Highlighting Color
- Toggle Unordered List (Unordered List in Visible Buttons)
- Toggle Ordered List (Ordered List in Visible Buttons)
- Outline Format
- Align Left (Left in Visible Buttons)
- Align Center (Center in Visible Buttons)
- Align Right (Right in Visible Buttons)
- Justified
- Align Top (Top in Visible Buttons)
- Center Vertically (Center in Visible Buttons)
- Align Bottom (Bottom in Visible Buttons)
- Set Line Spacing (Line Spacing in Visible Buttons)
- Character Spacing
- Increase Paragraph Spacing (Increase in Visible Buttons)
- Decrease Paragraph Spacing (Decrease in Visible Buttons)
- Text direction from left to right
- Text direction from top to bottom
- Left-To-Right
- Right-To-Left
- Select All
- Character
- Paragraph

**Transformations**

The Transformations toolbar (Figure 381) provides tools to modify the shape, orientation, or fill of selected objects.

Available tools from left to right:
- Rotate
- Flip
- In 3D Rotation Object
- Set in Circle (perspective)
- Set to circle (slant)
- Distort
- Interactive transparency tool (Transparency tool in Visible Buttons)
- Interactive gradient tool (Gradient tool in Visible Buttons)

**TSCP Classification**

The TSCP Classification toolbar (Figure 382) provides tools to help in selecting the security of a document. LibreOffice adds custom fields in the document properties (File > Properties > ...
Custom Properties) to store the classification policy as document metadata. TSCP stands for Transglobal Secure Collaboration Participation.

![TSCP Classification toolbar](image)

**Figure 382: TSCP Classification toolbar**

**Available tools from left to right**

| Apply document classification (Level) | Manage Document Classification |

**Zoom**

The Zoom toolbar (Figure 383) provides tools to reduce or enlarge the screen display of the current presentation.

![Zoom toolbar](image)

**Figure 383: Zoom toolbar**

**Available tools from left to right**

<table>
<thead>
<tr>
<th>Zoom In</th>
<th>Zoom Out</th>
<th>100%</th>
<th>Zoom Previous</th>
<th>Zoom Next</th>
<th>Entire Page</th>
<th>Page Width</th>
<th>Optimal View (Optimal in Visible Buttons)</th>
<th>Object Zoom</th>
<th>Zoom &amp; Pan</th>
<th>Shift</th>
</tr>
</thead>
</table>

Appendix B, Toolbars | 379
Impress Guide

Working With Presentations

About this book:
This book is for beginners to advanced users and covers the main features of Impress, the presentations component of LibreOffice. Using Impress, slides containing text, unordered and ordered lists, tables, charts, clip art, and other objects can be created. Impress comes with predefined text styles and slide backgrounds, but text styles and slide backgrounds can be created to match the presentation requirements.

Impress is fully integrated into LibreOffice simplifying the exchanging of text, graphics and data with Writer, Calc, and Draw.

About the authors:
This book was written by volunteers from the LibreOffice community. Profits from the sales of the printed edition are used to benefit the community.

A PDF version of this book can be downloaded free from: https://documentation.libreoffice.org/en/

About LibreOffice:
LibreOffice is the free, libre, and open source personal productivity suite from The Documentation Foundation. It runs on Windows, macOS, and GNU/Linux. Support and documentation is free from a large, dedicated community of users, contributors, and developers.

Get involved as a volunteer and work in many areas: development, quality assurance, documentation, translation, user support, and more.

Download LibreOffice for free from https://libreoffice.org/downloads/

For commercial use:
Work with certified LibreOffice professionals for any business needs, from deployment or conversion from other office suits, staff training, or custom development needs.

For information on professional support services, go to https://www.libreoffice.org/get-help/professional-support/