Impress Guide

7.0

LibreOffice is a registered trademark of The Document Foundation
Further Information is available at libreoffice.org
Copyright

This document is Copyright © 2021 by the LibreOffice Documentation Team. Contributors are listed below. You may distribute it and/or modify it under the terms of either the GNU General Public License (http://www.gnu.org/licenses/gpl.html), version 3 or later, or the Creative Commons Attribution License (http://creativecommons.org/licenses/by/4.0/), version 4.0 or later.

All trademarks within this guide belong to their legitimate owners.

Contributors

To this edition.

Peter Schofield          Claire Wood          Jean Hollis Weber
Felipe Viggiano          Regina Henschel      Samantha Hamilton
Olivier Hallot           Dave Barton

To previous editions.

Peter Schofield          Dimona Delvere       Michele Zarri
T. Elliot Turner         Jean Hollis Weber     Hazel Russman
Chad D. Lines            Low Song Chuan       Jaimon Jacob
Muhammad Sufyan Zainalabidin Dan Lewis       Agnes Belzunce
Peter Hillier-Brook      Gary Schnabl        Claire Wood
Rachel Kartch            Linda Worthington

Feedback

Please direct any comments or suggestions about this document to the Documentation Team’s mailing list: documentation@global.libreoffice.org

Note

Everything sent to a mailing list, including your email address and any other personal information that is written in the message, is publicly archived and cannot be deleted.

Publication date and software version

Published February 2021. Based on LibreOffice 7.0.
## Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copyright</td>
<td>2</td>
</tr>
<tr>
<td>Preface</td>
<td>6</td>
</tr>
<tr>
<td>Who is this user guide for?</td>
<td>7</td>
</tr>
<tr>
<td>What's in this user guide?</td>
<td>7</td>
</tr>
<tr>
<td>Minimum requirements for using LibreOffice</td>
<td>7</td>
</tr>
<tr>
<td>How to get LibreOffice</td>
<td>7</td>
</tr>
<tr>
<td>Installing LibreOffice</td>
<td>7</td>
</tr>
<tr>
<td>Loading additional master slides</td>
<td>7</td>
</tr>
<tr>
<td>Extensions and add-ons</td>
<td>8</td>
</tr>
<tr>
<td>What you see may be different</td>
<td>9</td>
</tr>
<tr>
<td>Using LibreOffice on macOS</td>
<td>10</td>
</tr>
<tr>
<td>Who wrote this user guide?</td>
<td>11</td>
</tr>
<tr>
<td>Frequently asked questions</td>
<td>11</td>
</tr>
<tr>
<td>What is new in LibreOffice 7.0?</td>
<td>12</td>
</tr>
<tr>
<td>Chapter 1 Introducing Impress</td>
<td>13</td>
</tr>
<tr>
<td>What is Impress?</td>
<td>14</td>
</tr>
<tr>
<td>Starting Impress</td>
<td>14</td>
</tr>
<tr>
<td>Main Impress window</td>
<td>15</td>
</tr>
<tr>
<td>Workspace views</td>
<td>22</td>
</tr>
<tr>
<td>Creating Presentations</td>
<td>25</td>
</tr>
<tr>
<td>Running a slide show</td>
<td>33</td>
</tr>
<tr>
<td>Presenter Console</td>
<td>33</td>
</tr>
<tr>
<td>Chapter 2 Master Slides, Styles, and Templates</td>
<td>35</td>
</tr>
<tr>
<td>Designing a presentation</td>
<td>36</td>
</tr>
<tr>
<td>What are master slides?</td>
<td>36</td>
</tr>
<tr>
<td>Working with master slides</td>
<td>37</td>
</tr>
<tr>
<td>Working with styles</td>
<td>53</td>
</tr>
<tr>
<td>Working with templates</td>
<td>58</td>
</tr>
<tr>
<td>Chapter 3 Adding and Formatting Text</td>
<td>65</td>
</tr>
<tr>
<td>Introduction</td>
<td>66</td>
</tr>
<tr>
<td>Working with text boxes</td>
<td>66</td>
</tr>
<tr>
<td>Inserting text</td>
<td>73</td>
</tr>
<tr>
<td>Formatting text</td>
<td>76</td>
</tr>
<tr>
<td>Creating lists</td>
<td>89</td>
</tr>
<tr>
<td>Using tables</td>
<td>95</td>
</tr>
<tr>
<td>Using fields</td>
<td>103</td>
</tr>
<tr>
<td>Using hyperlinks</td>
<td>104</td>
</tr>
<tr>
<td>Chapter 4 Adding and Formatting Images</td>
<td>108</td>
</tr>
<tr>
<td>Introduction</td>
<td>109</td>
</tr>
<tr>
<td>Inserting images</td>
<td>109</td>
</tr>
<tr>
<td>Managing Gallery themes</td>
<td>111</td>
</tr>
</tbody>
</table>
Chapter 5 Managing Graphic Objects.................................................................................. 125
  Introduction.................................................................................................................. 126
  Drawing toolbar........................................................................................................... 126
  Creating lines and shapes............................................................................................. 130
  Grouping objects together........................................................................................... 136
  Positioning and resizing graphic objects..................................................................... 138
  Applying special effects............................................................................................... 141
  Aligning objects........................................................................................................... 146
  Using grid or snap functions....................................................................................... 146
  Using Helplines........................................................................................................... 151
  Arranging objects......................................................................................................... 152
  Connectors and glue points......................................................................................... 153
  Working with 3D objects.............................................................................................. 158
  Converting objects........................................................................................................ 159
  Interaction with objects............................................................................................... 160
  Fontwork....................................................................................................................... 161
  Animations..................................................................................................................... 163

Chapter 6 Formatting Graphic Objects............................................................................. 171
  Introduction.................................................................................................................. 172
  Line formatting............................................................................................................ 172
  Area fill formatting..................................................................................................... 178
  Working with area fills............................................................................................... 184
  Text in objects............................................................................................................. 197
  Formatting connectors............................................................................................... 200
  Working with image styles......................................................................................... 201

Chapter 7 OLE, Spreadsheets, Charts, and Other Objects............................................. 205
  OLE objects.................................................................................................................. 206
  Spreadsheets................................................................................................................ 208
  Charts............................................................................................................................ 217
  Audio and video.......................................................................................................... 222
  Formulas....................................................................................................................... 224
  Drawings, text files, HTML files and other objects..................................................... 224

Chapter 8 Adding and Formatting Slides, Notes, Comments, and Handouts.............. 225
  Introduction.................................................................................................................. 226
  Inserting, renaming, and removing slides.................................................................... 226
  Creating slides from an outline.................................................................................... 231
  Formatting slides......................................................................................................... 233
  Presentation notes........................................................................................................ 238
  Adding comments........................................................................................................ 244
  Printing handouts........................................................................................................ 245

4 | Impress Guide
<table>
<thead>
<tr>
<th>Chapter 9 Slide Shows and Photo Albums</th>
<th>247</th>
</tr>
</thead>
<tbody>
<tr>
<td>Introduction</td>
<td>248</td>
</tr>
<tr>
<td>Creating slide shows</td>
<td>248</td>
</tr>
<tr>
<td>Using slide transitions</td>
<td>253</td>
</tr>
<tr>
<td>Animations</td>
<td>255</td>
</tr>
<tr>
<td>Using interactions</td>
<td>261</td>
</tr>
<tr>
<td>Slide shows</td>
<td>262</td>
</tr>
<tr>
<td>Photo albums</td>
<td>266</td>
</tr>
<tr>
<td>Chapter 10 Saving Slide Shows, Printing, Emailing, and Exporting</td>
<td>268</td>
</tr>
<tr>
<td>Saving slide shows</td>
<td>269</td>
</tr>
<tr>
<td>Printing</td>
<td>271</td>
</tr>
<tr>
<td>Emailing</td>
<td>274</td>
</tr>
<tr>
<td>Exporting</td>
<td>275</td>
</tr>
<tr>
<td>Chapter 11 Setting Up and Customizing Impress</td>
<td>280</td>
</tr>
<tr>
<td>Introduction</td>
<td>281</td>
</tr>
<tr>
<td>LibreOffice options</td>
<td>281</td>
</tr>
<tr>
<td>Impress options</td>
<td>285</td>
</tr>
<tr>
<td>Customizing user interface</td>
<td>289</td>
</tr>
<tr>
<td>Adding extensions</td>
<td>290</td>
</tr>
<tr>
<td>Appendix A Keyboard Shortcuts</td>
<td>291</td>
</tr>
<tr>
<td>Introduction</td>
<td>292</td>
</tr>
<tr>
<td>Impress keyboard shortcuts</td>
<td>292</td>
</tr>
<tr>
<td>Menu keyboard shortcuts</td>
<td>296</td>
</tr>
<tr>
<td>Toolbar keyboard shortcuts</td>
<td>301</td>
</tr>
<tr>
<td>Appendix B Toolbars</td>
<td>306</td>
</tr>
<tr>
<td>Introduction</td>
<td>307</td>
</tr>
<tr>
<td>Using toolbars</td>
<td>307</td>
</tr>
<tr>
<td>Toolbars</td>
<td>309</td>
</tr>
</tbody>
</table>
Preface

Presentations in LibreOffice
Who is this user guide for?

LibreOffice is a feature-rich, free, and open source office suite. It includes several powerful applications for word processing, spreadsheets, presentations, graphics, databases, and formula editing. Impress is the presentations application. It is compatible with a wide range of formats including Microsoft PowerPoint (.ppt, .pptx), and you can export your work in several formats, for example PDF, HTML, Adobe Flash, and numerous graphic formats.

You may be new to presentation software, or you may be familiar with another office suite. This user guide will get anyone up to speed quickly with LibreOffice Impress.

What’s in this user guide?

This user guide introduces the main features of Impress, the presentations (slide show) component of LibreOffice. Using Impress, you can create slides that contain text, bulleted and numbered lists, tables, charts, clip art, and other objects. Also, Impress comes with prepackaged styles, slide backgrounds, and templates to help you create presentations.

Minimum requirements for using LibreOffice

For a detailed list of requirements and operating systems supported, see the LibreOffice website, https://www.libreoffice.org/get-help/system-requirements/

How to get LibreOffice

Versions of LibreOffice for Windows, Linux, and macOS is freely available and can be downloaded from https://www.libreoffice.org/download. Linux users will also find LibreOffice included free in many of the latest distributions.

Portable and other versions of LibreOffice are listed on the download page. Linux, Vanilla, and other versions may differ in a few features from the descriptions in this user guide.

Installing LibreOffice

Information on installing and setting up LibreOffice on the various supported operating systems is given here: https://www.libreoffice.org/get-help/install-howto/

Loading additional master slides

You can change the default settings (options) in LibreOffice to suit your preferences. To change settings, go to Tools > Options on the main menu bar (LibreOffice > Preferences on macOS). Settings are described in the Help and in Chapter 2 Setting up LibreOffice in the Getting Started Guide.

Some settings of particular interest to Impress users are covered in Chapter 11 Setting Up and Customizing Impress. In this chapter you will find information on how to customize menus, toolbars, and keyboard shortcuts in LibreOffice Impress, add new menus and toolbars, and assign macros to events.
Tip

Many settings are intended for power users and programmers. If you do not understand what an option does, we recommend leaving it on the default setting unless instructions in this user guide recommend changing the setting.

Extensions and add-ons

This user guide and other LibreOffice user guides, the built-in Help system, and user support systems assume that you are familiar with your computer and basic functions such as starting a program, opening and saving files.

Help systems

LibreOffice comes with an extensive Help system. This is your first line of support. Windows and Linux users can choose to download and install the offline Help for use when not connected to the Internet; the offline Help is installed with the program on MacOS.

To display the Help system, press F1 or select Help > LibreOffice Help from the Menu bar. If you do not have the offline help installed on your computer and you are connected to the Internet, your default browser will open the online Help pages on the LibreOffice website.

The Help menu includes links to other LibreOffice information and support facilities.

- **What's This?** – for quick tips when a toolbar is visible, place the mouse pointer over any of the icons to see a small box (tooltip) with a brief explanation of the icon function. In addition, you can choose whether to activate **Extended Tips** using Tools > Options > LibreOffice > General.

- **User Guides** – opens your default browser at the Documentation page of the LibreOffice website https://documentation.libreoffice.org/en/english-documentation/. There you will find User Guides (to download as free PDFs or buy as printed copies) and other useful information.

- **Show Tip-of-the-Day** – opens a small window with a random tip on how to use LibreOffice.

- **Get Help Online** – opens your default browser at the Ask LibreOffice forum of questions and answers from the LibreOffice community, https://ask.libreoffice.org/en/questions/.

- **Send Feedback** – opens your default browser at the Feedback page of the LibreOffice website https://www.libreoffice.org/get-help/feedback/. From there you can report bugs, suggest new features and communicate with others in the LibreOffice community.

- **Restart in Safe Mode** – opens a dialog window where you will have the option to restart LibreOffice and reset the software to its default settings.

- **Get Involved** – opens your default browser at the Get Involved page of the LibreOffice website, https://www.libreoffice.org/community/get-involved/. There you can choose a topic of interest to help improve the program.

- **Donate to LibreOffice** – opens your default browser at the Donation page of the LibreOffice website, https://donate.libreoffice.org/. There you can choose to make a donation to support LibreOffice.

- **License Information** – outlines the licenses under which LibreOffice is made available.
• **Check for Updates** – pens a dialog and checks the LibreOffice website for updates to your version of the software.

• **About LibreOffice** – opens a dialog and displays information about the version of LibreOffice and the operating system you are using. This information will often be requested if you ask the community for help or assistance with the software (on macOS, this option is found under *LibreOffice* on the main menu bar).

### Other free online support

The LibreOffice community not only develops software, but provides free, volunteer-based support. See Table 1 and this web page: [https://www.libreoffice.org/get-help/](https://www.libreoffice.org/get-help/)

For comprehensive online support from the community, look at mailing lists and the Ask LibreOffice website, [https://ask.libreoffice.org/en/questions/](https://ask.libreoffice.org/en/questions/). Other websites run by users also offer free tips and tutorials.

**Table 1: Free support for LibreOffice users**

<table>
<thead>
<tr>
<th>Free LibreOffice support</th>
</tr>
</thead>
<tbody>
<tr>
<td>FAQs</td>
</tr>
<tr>
<td>Mailing lists</td>
</tr>
<tr>
<td>Questions &amp; Answers and Knowledge Base</td>
</tr>
<tr>
<td>Native language support</td>
</tr>
<tr>
<td>Accessibility options</td>
</tr>
</tbody>
</table>

### Paid support and training

You can also pay for support through service contracts from a vendor or consulting firm specializing in LibreOffice. For information about certified professional support, see [The Document Foundation website:](https://www.documentfoundation.org/gethelp/support/).
What you see may be different

Illustrations

LibreOffice runs on Windows, Linux, and macOS operating systems, each of which has several versions and can be customized by users (fonts, colors, themes, window managers). The illustrations in this guide were taken from a variety of computers and operating systems. Therefore, some illustrations will not look exactly like what you see on your computer display.

Also, some of the dialogs may differ because of the settings selected in LibreOffice. You can either use dialogs from your computer system (default) or dialogs provided by LibreOffice. To change to using LibreOffice dialogs:

1) On Linux and Windows operating systems, go to **Tools > Options > LibreOffice > General** on the main menu bar to open the dialog for general options.

2) On a Mac operating system, go to **LibreOffice > Preferences > General** on the main menu bar to open the dialog for general options.

3) Select **Use LibreOffice dialogs in Open/Save dialogs** to display the LibreOffice dialogs on your computer display.

4) Click **OK** to save your settings and close the dialog.

Icons

The LibreOffice community has created icons for several icon sets, including Breeze, Colibre, Elementary, Sifr, and Tango. Each user can select a preferred set. The icons used to illustrate some of the many tools available in LibreOffice may differ from the ones used in this guide. The icons in this user guide have been taken from a LibreOffice installation that has been set to display the Colibre (SVG) set of icons.

To change the icon set used in your LibreOffice installation is as follows:

1) On Linux and Windows operating systems, go to **Tools > Options > LibreOffice > View** on the main menu bar to open the dialog for view options.

2) On a Mac operating system, go to **LibreOffice > Preferences > LibreOffice > View** on the main menu bar to open the dialog for view options.

3) In **User interface > Icon size** and style select **Colibre (SVG)** from the options available in the drop down list.

4) Click **OK** to save your settings and close the dialog.

Note

Some Linux operating systems, for example Ubuntu, include LibreOffice as part of the installation and may not include the Colibre icon set. You should be able to download the Colibre icons from the software repository for your Linux operating system.

Using LibreOffice on macOS

Some keystrokes and menu items are different on macOS from those used in Windows and Linux. The table below gives some common substitutions for the instructions in this user guide. For a more detailed list, see the application Help.
Table 2: Using LibreOffice on macOS

<table>
<thead>
<tr>
<th>Windows or Linux</th>
<th>macOS equivalent</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tools &gt; Options</td>
<td>LibreOffice &gt; Preferences</td>
<td>Access setup options</td>
</tr>
<tr>
<td>menu selection</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Right-click</td>
<td>Control+click and/or right-click depending on computer setup</td>
<td>Opens a context menu</td>
</tr>
<tr>
<td>(Ctrl) (Control)</td>
<td>(⌘) (Command)</td>
<td>Used with other keys</td>
</tr>
<tr>
<td>\texttt{F11}</td>
<td>(⌘+T)</td>
<td>Open the sidebar Styles deck</td>
</tr>
</tbody>
</table>

Who wrote this user guide?

This user guide was written by volunteers from the LibreOffice community. Profits from sales of the printed edition will be used to benefit the community.

Frequently asked questions

How is LibreOffice licensed?
LibreOffice is distributed under the Open Source Initiative (OSI) approved Mozilla Public License (MPL). See https://www.libreoffice.org/about-us/licenses/

It is based on code from Apache OpenOffice made available under the Apache License 2.0 but also includes software that differs from version to version under a variety of other Open Source licenses. New code is available under LGPL 3.0 and MPL 2.0.

May I distribute LibreOffice to anyone?
Yes

May I sell it?
Yes

May I use it in my business?
Yes.

How many computers may I install it on?
As many as you like.

Is LibreOffice available in my language?
LibreOffice has been translated (localized) into over 40 languages, so your language probably is supported. Additionally, there are over 70 spelling, hyphenation, and thesaurus dictionaries available for languages, and dialects that do not have a localized program interface. The dictionaries are available from the LibreOffice website at: www.libreoffice.org.

How can you make it for free?
LibreOffice is developed and maintained by volunteers and has the backing of several organizations.

I am writing a software application. May I use programming code from LibreOffice in my program?
You may, within the parameters set in the MPL and/or LGPL. Read the licenses: https://www.mozilla.org/MPL/2.0/.
Why do I need Java to run LibreOffice? Is it written in Java?
LibreOffice is not written in Java; it is written in the C++ language. Java is one of several languages that can be used to extend the software. The Java JDK/JRE is only required for some features. The most notable one is the HSQLDB relational database engine.
Java is available at no cost. More information and download links to the appropriate edition for your operating system can be found at: https://java.com/en/download/manual.jsp.

Note
If you want to use LibreOffice features that require Java, it is important that the correct 32-bit or 64-bit edition matches the installed version of LibreOffice. See Chapter 2 Advanced Options of the Getting Started Guide. If you do not want to use Java, you can still use nearly all of the LibreOffice features.

How can I contribute to LibreOffice?
You can help with the development and user support of LibreOffice in many ways, and you do not need to be a programmer. To start, check out this webpage: https://www.libreoffice.org/community/get-involved/

May I distribute the PDF of this user guide, or print and sell copies?
Yes, as long as you meet the requirements of one of the licenses in the copyright statement at the beginning of this user guide. You do not have to request special permission. We request that you share with the project some of the profits you make from sales of user guides, in consideration of all the work we have put into producing them.
Donate to LibreOffice: https://www.libreoffice.org/donate/

What is new in LibreOffice 7.0?
The LibreOffice 7.0 Release Notes are available at this link https://wiki.documentfoundation.org/ReleaseNotes/7.0.
At this link you will also find the release notes for earlier versions of LibreOffice which will give you more information on the features that are included in LibreOffice.
Chapter 1
Introducing Impress
What is Impress?

Impress is the presentation (slide show) program included in LibreOffice. Impress creates presentations in the ODP format, which can be opened by other presentation software or can be exported in different presentation formats.

You can create slides that contain many different elements, including text, bulleted and numbered lists, tables, charts, and a wide range of graphic objects such as clip-art, drawings and photographs. Impress also includes a spelling checker, a thesaurus, text styles, and background styles.

This chapter introduces the Impress user interface. The remaining chapters in this guide explain all the features available in Impress that can be used to create more sophisticated slide shows.

To use Impress for more than very simple slide shows, requires some knowledge of the slide elements. Slides containing text use styles to determine the appearance of that text. Creating drawings in Impress is similar to using the Draw program included in LibreOffice. See the Draw Guide for more details on how to use the drawing tools.

Starting Impress

You can start Impress in several ways:

- From the LibreOffice Start Center that opens when LibreOffice is opened and no other LibreOffice module is open.
  - Click on Impress Presentation to create a new presentation;
  - Click on Open File and navigate to the folder where there is an existing presentation.
- From the system menu using the standard menu from which most applications are started. Details vary with your operating system. See the Getting Started Guide for more information and some examples are listed below:
  - Start menu in Windows.
  - Applications menu in Linux with a Gnome desktop.
  - Applications menu in macOS.
- From any open module of LibreOffice, go to File > New > Presentation on the Menu bar, or click on New on the Standard toolbar and select Presentation from the drop-down menu.

When you start Impress for the first time, the main Impress window opens, as default, with the Select a Template dialog displayed (Figure 1). Templates included with Impress are designed to fit the two standard sizes of presentation slides: 4:3 and 16:9 ratios. However, templates will adapt to other sizes that are available and can be selected by going to Slide > Properties > Paper Format on the Menu bar or Format in the Slide section in the Properties deck on the Sidebar.

Note

When LibreOffice was installed on your computer, a menu entry for each component is normally added to your system menu. The exact name and location of these menu entries depend on the operating system and graphical user interface.

The New icon displayed on the Standard toolbar will depend on which LibreOffice module you have open when you want to create a new presentation.
Tip

To start Impress without the Select a Template dialog (Figure 1), deselect *Show this dialog at startup* in the lower left of the dialog.

In Windows or Linux, go to **Tools > Options > LibreOffice Impress > General** on the Menu bar and deselect *Start with Template Selection* under *New Document*.

In macOS, **LibreOffice > Preferences > LibreOffice Impress > General** on the Menu bar and deselect *Start with Template Selection* under *New Document*.

**Main Impress window**

The main Impress window (Figure 2) has three main sections: Slides pane, Workspace, and Sidebar. At the top is a menu bar and toolbars. Toolbars can be displayed or hidden during the creation of a presentation.

Tip

You can close the Slides pane or Sidebar by clicking the X in the upper right corner of each pane or go to **View > Slides pane** or **View > Sidebar** on the Menu bar to deselect the pane. To reopen a pane, select **View > Slides pane** or **View > Sidebar** on the Menu bar.
Tip

You can maximize the Workspace area by clicking on the Hide/Show marker in the middle of the vertical separator line (highlighted in Figure 2). Using the Hide/Show marker hides, but does not close, the Slides pane or Sidebar. To restore a pane, click again on its Hide/Show marker.

Menu bar

The Impress Menu bar, at the top of the main window, provides several menus common to all LibreOffice modules. The commands may differ between the modules for File, Edit, View, Insert, Format, Tools, Window, and Help. Impress has two extra menus for Slide and Slide Show. When you select one of the menus, a sub-menu drops down to show commands. The Menu bar can be customized and for more information, see the Getting Started Guide.

Workspace

The Workspace (normally the center of the main window) opens in the Normal view. It has four standard views selected using tabs: Normal, Outline, Notes, and Slide Sorter (Figure 3). For more information on workspace views, see “Workspace views” page 22.

If you are using master slides, then master views become available: Master Slide, Master Notes and Master Handout. There are no tabs for master views and can only be selected by going to View on the Menu bar. For more information on master slides, see Chapter 2, Using Slide Masters, Styles, and Templates.
**Slides pane**

The Slides pane contains thumbnail images of slides in a presentation in the order in which they will be shown. This slide show order can be changed and is described in Chapter 9, Slide Shows. Clicking on a slide image in the Slides pane selects it and places the slide in the Workspace where you can make changes to the displayed slide.

- To display or close the Slides pane, go to **View > Slides pane** on the Menu bar.
- To close the Slides pane, click on the X in the right top corner of the Slides pane.
- To display or hide the Slides pane, use the **Hide/Show** marker on the left of the Workspace (Figure 2 on page 16).

Several additional operations can be carried out on one or more slides in the Slides pane. These additional operations are available from a context menu when you right click in the Slides pane.

- Add new slides to a presentation.
- Hide a slide so that it will not show in a presentation.
- Delete a slide from a presentation.
- Rename a slide.
- Duplicate a slide (copy and paste).
- Move a slide to another position in the slide order by dragging and dropping it to the desired position.

**Sidebar**

The Impress Sidebar, normally located on the right side of the Workspace, is similar to the Sidebar in the other LibreOffice modules and consists of seven decks. To open a deck, use one of the following methods:

- Click on its icon on the right side of the Sidebar.
- Click on **Sidebar Settings** at the top right of the Sidebar and select a deck from the drop-down list.
- Go to **View** on the Menu bar and select the deck required from the drop down menu.

To display or hide the Sidebar, use one of the following methods:

- Go to **View > Sidebar** on the Menu bar.
- Use the keyboard shortcut **Ctrl+F5**.
- Use the **Hide/Show** marker on the right of the Workspace (Figure 2 on page 16).
- To close the Sidebar, click on the X in the right top corner of the Sidebar.
- To display the Sidebar, click on one of the Sidebar icons to open a deck.

**Properties**

The Properties deck has nine sections allowing you to change slide layout and the format of any objects on a slide. The use of these sections is explained in this user guide.

- When a slide is selected and appears in the Workspace, the sections available to change slide layout are **Slide and Layouts**.
When an object on a slide is selected, the sections available to change object format are **Character, Paragraph, Area, Lists, Shadow, Line, and Position and Size**.

**Slide transition**
The Slide Transition deck provides a selection of slide transitions available in Impress, transition speed, automatic or manual transition, and how long a selected slide is shown (automatic transition only). For more information on transitions, see Chapter 9, Slide Shows.

**Animation**
The Animation deck provides an easy way to add, change, or remove animations to different elements or objects on a slide and how they appear during a slide show. For more information on animations, see Chapter 9, Slide Shows.

**Master Slides**
On the Master Slides deck you define the slide style for your presentation and Impress includes several designs of master slides. The default master slide is blank, but the remaining master slides have backgrounds and styled text. For more information on master slides, see Chapter 2, Using Slide Masters, Styles, and Templates.

**Styles**
On the Styles deck you can quickly apply drawing and presentation styles to a selected object, create new styles for drawing and presentation, and modify both types of styles. When you save changes to a style, the changes are applied to all of the elements formatted with that style in the presentation. For more information on styles, see Chapter 2, Using Slide Masters, Styles, and Templates.

**Gallery**
Opens the Gallery deck where you can insert an object into your presentation either as a copy or as a link. A copy of an object is independent of the original object. Changes to the original object have no effect on the copy. A link remains dependent on the original object. Changes to the original object are also reflected in the link.

**Navigator**
Opens the Navigator deck where you can quickly move between slides in your presentation or select an object on a slide. It is recommended to give slides and objects in your presentation meaningful names so that you can easily identify them when using the navigator. For more information, see “Navigator” on page 21.

**Rulers**
You should see rulers (bars with numbers) on the upper and left-hand sides of the workspace. If they are not visible, enable the rulers by selecting **View > Rulers** in the Menu bar. The rulers show the size of a selected object on the page using double lines (highlighted in Figure 4). You can also use the rulers to manage object handles and guide lines when positioning objects.
The page margins in the drawing area are also represented on the rulers. You can change the margins directly on the rulers by dragging them with the mouse. The margin area is indicated by the grayed out area on the rulers as shown in Figure 4.

To change the measurement units of the rulers, which can be defined independently, right-click on a ruler and select the measurement unit from the drop down list, as illustrated for the horizontal ruler in Figure 5.

**Status bar**

The Status bar (Figure 6), located at the bottom of the main window, contains information that you may find useful when working on a presentation. You can hide the Status bar by going to View on the Menu bar and deselecting Status Bar.

**Note**

The sizes are given in the current measurement unit and might not be the same as the ruler units. The measurement unit on the Status bar is defined in Tools > Options > LibreOffice Impress > General.
Slide number
The slide number currently displayed in the Workspace and the total number of slides in the presentation.

Information area
This changes depending on the object selected on the slide. Examples are shown in the following table.

<table>
<thead>
<tr>
<th>Example selection</th>
<th>Examples of information shown</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text area</td>
<td>Text Edit: Paragraph x, Row y, Column z</td>
</tr>
<tr>
<td>Charts, spreadsheets</td>
<td>Embedded object (OLE) “ObjectName” selected</td>
</tr>
<tr>
<td>Graphics</td>
<td>Bitmap with transparency selected</td>
</tr>
</tbody>
</table>

Master slide
The master slide associated with the slide or notes page currently displayed in the Workspace. Right-click to pop up a list of available master slides and select one to apply it to the selected slide. Double-click to open the Available Master Slides dialog (for more information, see Chapter 2, Using Slide Masters, Styles and Templates).

Cursor position/Object size
Shows different information depending on whether objects are selected or not.
- When no object is selected, the position numbers show the current position (X and Y coordinates) of the mouse cursor.
- When an object is selected and being sized with the mouse, the object size numbers show the size of the object (width and height).
- If an object is selected, the position numbers shows X and Y coordinates of the upper-left corner and the object size number pair displays the size of the object.
  These numbers do not relate to the object itself, but to the selection outline, which is the smallest possible rectangle that can contain the visible part or parts of the object.
- When an object is selected, clicking in either of these areas opens the Position and Size dialog.

Unsaved changes
Indicates if there are any unsaved changes in your presentation. Clicking this icon saves the document. If the presentation has not been saved before, the Save As dialog opens giving you the opportunity to save the presentation.

Digital signatures
Indicates if your presentation has a digital signature.

Text language
Indicates the language used for any text on your presentation.

Fit slide
When this icon is clicked on, the slide in the workspace zooms to fit in the Workspace.

Zoom slider
When moved, the slide changes its viewing zoom in the Workspace.

Zoom percentage
Indicates the zoom level of the slide displayed in the Workspace. Clicking on zoom percentage opens the Zoom & View Layout dialog where you adjust the settings for zoom factor and view layout.
Navigator

The Navigator displays all objects contained in a presentation. It provides another convenient way to move around a presentation and find items in it.

To open the Navigator dialog (Figure 7) go to View > Navigator on the Menu bar, or use the keyboard shortcut Ctrl+Shift+F5. Alternatively, click on Navigator in the Sidebar to open the Navigator deck that is similar in appearance and function as the Navigator dialog.

The Navigator is more useful if you give your slides and objects (pictures, spreadsheets, and so on) meaningful names, instead of leaving them with default names, such as “Slide 1” and “Shape 1” and so on (as shown in Figure 7). This will allow you to easily locate a slide or object in your presentation.

Toolbars

Many toolbars can be used during slide creation. To display or hide the various toolbars in Impress, go to View > Toolbars on the Menu bar and select from the drop down menu that appears which toolbars you want to display. For example, the Standard and Drawing toolbars are shown by default, but the Line and Filling and Text Formatting toolbars are not shown.

You can select the icons or buttons that you want to appear on toolbars. To change the visible icons or buttons on any toolbar, right-click in an empty area on the toolbar and select Visible Buttons from the context menu. Visible icons or buttons are indicated by a check mark next to the icon name. Click on an icon name to hide or show it in the toolbar. For more information, see Chapter 11, Setting Up and Customizing Impress and the Getting Started Guide.

The toolbars that are widely used when creating a presentation are as follows:

**Standard toolbar**

The Standard toolbar (Figure 8) is the same for all LibreOffice modules and is not described in detail in this user guide. By default, it is located just under the Menu bar at the top of the Workspace.
Drawing toolbar
The Drawing toolbar (Figure 9) contains all the necessary functions for drawing various geometric and freehand shapes, and for organizing them in a slide. More information on the Drawing toolbar can be found in Chapter 5, Managing Graphic Objects.

Figure 9: Drawing toolbar

Line and Filling toolbar
The Line and Filling toolbar (Figure 10) lets you modify the main properties of an object. The icons and pull-down lists vary according to the type of object selected. The Line and Filling toolbar lets you change color, style, and width of a line drawn, fill color and style, and other properties of an object. The object must be selected with a mouse click. If the selected object is a text frame, the Line and Filling toolbar changes to the Text Formatting toolbar (Figure 11).

Figure 10: Line and Filling toolbar

Text Formatting toolbar
The Text Formatting toolbar (Figure 11) is similar to the Formatting toolbar in LibreOffice Writer and only appears when a text object has been selected in your presentation, automatically replacing the Line and Filling toolbar.

Figure 11: Text Formatting toolbar

Note
The appearance of the toolbar icons varies depending on your operating system and the selection of icon size and style in Tools > Options > LibreOffice > View. For more information about working with toolbars, see the Getting Started Guide.

Workspace views
The Impress workspace has four standard views selected using tabs: Normal, Outline, Notes, and Slide Sorter. These tabs are normally displayed the top of the Workspace (Figure 3 on page 16). If the tabs are not displayed, then go to View > Views Tab Bar on the Menu bar. You can also select the different Workspace views by going to View on the Menu bar and selecting a view from the drop down menu.

If you are using master slides, then master views become available in the Workspace: Master Slide, Master Notes and Master Handout. There are no tabs for master views and can only be selected by going to View on the Menu bar and selecting Master Slide, Master Notes or Master Handout. For more information on master slides, see Chapter 2, Using Slide Masters, Styles, and Templates.

Normal view
Normal view is the main standard view for creating individual slides in a presentation. In Normal view you can design slides, add and format any text or graphics, and add any animation effects to text or graphics.
To place a slide in Normal view of the Workspace (Figure 3 on page 16), either click on the slide thumbnail in the Slides pane or click on the slide name in the Navigator.

Outline view

Outline view in the Workspace (Figure 12) contains all of the slides of the presentation in their numbered sequence. It shows topic titles, bulleted lists, and numbered lists for each slide in outline format. Only the text contained in the default text boxes in each slide is shown. If you have added text boxes or graphic objects to the slides, then these objects are not displayed. Slide names are not included.

- Use Outline view for the following:
  - Making changes in the text of a slide:
  - Add or delete text in a slide as in Normal view.
  - Move a paragraph in a slide up or down by using the movement arrows on the Outline toolbar (Figure 13).
  - Change the outline level of a paragraph in a slide using the left and right arrow buttons on the Outline toolbar.

Figure 12: Outline view in Workspace

Figure 13: Outline toolbar

- Comparing slides with your outline (if you have prepared one in advance). If you notice from your outline that another slide is needed, you can create it directly in Outline view, or you can return to Normal view to create it.

Note

If the Outline toolbar does not appear when in Outline view, then go to View > Toolbars on the Menu bar and select Outline from the drop down list.
Notes view

Use **Notes** view in the Workspace (Figure 14) to add notes to a slide. These notes are not seen when the presentation is shown to an audience using an external display connected to your computer.

1) Click the **Notes** tab in the Workspace.
2) Click the slide in the Slides pane so that the slide appears in the Workspace.
3) In the text box below the slide, click on the words *Click to add notes* and begin typing your notes.

You can resize the *Click to add notes* text box using the resizing handles which appear when you click on the edge of the box. You can also move or change the size of the box by clicking and dragging on the box border.

When text is inserted in the *Click to add notes* text box, it is automatically formatted using the predefined **Notes** style that you can find in **Presentation Styles** in the Styles deck on the Sidebar. You can format the **Notes** style to suit your needs. For more information, see Chapter 8, Adding and Formatting Slides, and Notes.

![Figure 14: Notes view in Workspace](image)

![Figure 15: Slide Sorter view in Workspace](image)

![Figure 16: Slide View toolbar](image)
Slide Sorter view
The Slide Sorter view in the Workspace (Figure 15) contains all the thumbnails of slides used in your presentation. Use this view to work with one slide or a group of slides.

Customizing Slide Sorter view
To change the number of slides per row in Slide Sorter view:

1) Go to View > Toolbars > Slide View on the Menu bar to show the Slide View toolbar (Figure 16)
2) Adjust the number of slides, up to a maximum of 15, in the Slides per Row box.

Changing slide order
Changing the slide order in a presentation of a single slide or a group of slides using Slide Sorter view is as follows:

1) Select a slide or a group of slides.
2) Drag and drop the slide or group of slides at the location you want.

Selecting a group of slides
To select a group of slides, use one of these methods:

- Click on the first slide and, while holding the Ctrl key, select the required slides. The selected slides do not have to be next to each other.
- Click on the first slide, and while pressing the Shift key, select the final slide for the group. This selects all of the slides between the first and the last slide selected.
- Position the cursor slightly to one side and outside the first slide, then click and hold the left mouse button and drag the cursor until all of the slides you want in the group are selected.

Working in Slide Sorter view
You can work with slides in Slide Sorter view just as you can in the Slides pane. To make changes, right-click on a slide and choose one of the following from the context menu:

- Cut – removes the selected slide and saves it to the clipboard.
- Copy – copies the selected slide to the clipboard without removing it.
- Paste – inserts a slide from the clipboard after the selected slide.
- New Slide – adds a new slide after the selected slide.
- Duplicate Slide – creates a duplicate of the selected slide and places the new slide immediately after the selected slide.
- Rename Slide – allows you to rename the selected slide.
- Hide Slide – any slides that are hidden are not shown in the slide show.
- Delete Slide – deletes the selected slide.
- Layout – allows you to change the layout of the selected slide.
- Move – allows you to move or reposition the slide in the slide show order.
Creating Presentations

By default, Impress opens with the Select a Template dialog displayed (Figure 1 on page 15) where you can select a template to use in your presentation. To create a new presentation without using a template, click on **Cancel** in the Select a Template dialog and a blank slide appears in the Workspace and Slides pane.

**Tip**

The first thing to do is decide on the purpose of the presentation and plan the presentation. Having an idea of who the audience will be, the structure, the content, and how the presentation will be delivered, will save you a lot of time from the start.

To prevent the Select a Template dialog from opening when you create a new presentation, go to **Tools > Options > LibreOffice Impress > General** on the Menu bar to open Options – LibreOffice Impress – General dialog (Figure 17) and deselect the option **Start with New Template Selection**.

For more information on creating presentations, slide show options, and presentation settings, see Chapter 9, Slide Shows and Chapter 11, Setting Up and Customizing Impress.

New presentation

When you create a new presentation, Impress shows only one slide in the Slides pane and Workspace (Figure 2 page 16). You can add new slides or duplicate slides to your presentation as follows.

**Inserting new slide**

A new slide is inserted into a presentation using one of the following methods.

- Go to **Slide > New Slide** on the Menu bar.
- Right-click in the Slides pane and select **New Slide** from the context menu.
- Use the keyboard shortcut Ctrl+M.
• Go to Slide Sorter view in the Workspace, right-click on a slide and select New Slide from the context menu.

• Click on New Slide icon in the Presentation toolbar (Figure 18). If the Presentation toolbar is not visible, go to View > Toolbars on the Menu bar and select Presentation from the drop down list.

**Note**

A new slide is inserted after the selected slide in the presentation. If a slide is not selected, then the new slide is inserted as the last slide in the presentation.

**Duplicate slide**

To duplicate a slide, select the slide you want to duplicate in the Slides pane and use one of the following methods. A duplicate slide is inserted after the selected slide in the presentation.

• Right-click on a slide in the Slides pane and select Duplicate Slide from the context menu.

• Go to Slide Sorter view in the Workspace, right-click on a slide and select Duplicate Slide from the context menu.

![Properties](image)

![Layouts](image)

Figure 19: Slide and Layouts sections in Properties on Sidebar

• Go to Slide > Duplicate Slide on the Menu bar.
• Click on the **Duplicate Slide** icon in the Presentation toolbar (Figure 18).

### Slide format

Click on **Properties** on the Sidebar and open the **Slide** section (Figure 19) to display the format options available for your presentation. The **Slide** section allows you to quickly format all the slides included in your presentation and select master slides for your presentation. For more information on formatting slides and using master slides, see Chapter 2, Using Slide Masters, Styles, and Templates and Chapter 8, Adding and Formatting Slides and Notes.

### Slide layout

By default in Impress, the **Title Slide** layout is used for the first slide when you create a new presentation. The layouts included in Impress range from a blank slide to a slide with six contents boxes and a title. For more information on slide layouts, see Chapter 8, Adding and Formatting Slides and Notes.

The first slide in a presentation is normally a title slide. The layouts **Title Slide**, which also contains a section for a subtitle, or **Title Only** are the most suitable layouts for the first slide in a presentation. For the remaining slides you will probably use the **Title, Contents** layout.

Impress does not have the functionality to create custom layouts. However, you can resize and move the different elements in a slide layout. For more information, see “Modifying slide elements” on page 30.

---

**Tip**

To view the names for slide layouts, use the tooltip feature. Position the cursor on an icon in the **Layout** section (or on any other tool icon) in the Properties deck on the Sidebar and its name will be displayed in a small rectangle.

---

**Selecting slide layout**

After selecting a slide in your presentation, select a slide layout using one of the following methods:

- Click on the required layout in **Layouts** section of the Properties deck in the Sidebar (Figure 19).
- Go to **Slide > Layout** on the Menu bar and select the required layout from the drop down list.
- Right click on a slide in the Slides pane, select **Layout** from the context menu and select a layout from the drop down list.
- Click on **Slide Layout** on the Presentation toolbar (Figure 18 on page 26) and select a layout from the options available.

---

**Note**

Text and graphic elements can be readjusted at any time during the preparation of a presentation, but changing the layout of a slide that already contains some contents can have a dramatic effect. It is therefore recommended that you pay particular attention to the layout you select. If you do need to change the layout after contents have been added, the contents are not lost though they may need to be reformatted.
**Changing slide layout**

After selecting a slide in your presentation, change the slide layout using one of the following methods:

- Click on the required layout in *Layouts* section of the Properties deck in the Sidebar (Figure 19).
- Go to *Slide > Layout* on the Menu bar and select the required layout from the drop down list.
- Right click on a slide in the Slides pane, select *Layout* from the context menu and select the required layout from the drop down list.
- Click on the *Slide Layout* icon on the Presentation toolbar (Figure 18 on page 26) and select a layout from the options available.

**Slide contents**

Several layouts contain one or more content boxes. Each of these boxes can be configured to contain one of the following elements: slide title, text, table, chart, image or audio/video, as shown in Figure 20.

![Click to add Title](image)

**Figure 20: Selecting slide contents type**

- **Slide title** – click on *Click to add Title* and type a title in the text box. Impress enters text editing mode and the Text Formatting toolbar (Figure 11 on page 22) automatically opens. For more information on formatting text, see Chapter 3, Adding and Formatting Text.
- **Text** – click on *Click to add Text* and type your contents in the text box. Impress enters text editing mode and the Text Formatting toolbar automatically opens. For more information on formatting text, see Chapter 3, Adding and Formatting Text.
- **Table** – click on *Insert Table* and the Insert Table dialog opens. Enter the number of columns and rows, then click *OK*. The dialog closes and a table is inserted into the slide. Impress enters text editing mode and the Text Formatting toolbar automatically opens. For more information on using tables, see Chapter 3, Adding and Formatting Text.
- **Chart** – click on *Insert Chart* and the Impress default chart is placed in the slide. The *Chart Type* section in the Properties deck on the Sidebar opens allowing you to edit the chart to your requirements. For more information on using charts, see Chapter 7, OLE, Spreadsheets, Charts, and Other Objects.
• **Image** – click on *Insert Image* and a file browser opens. Navigate to where the image you want to use is located. Select the file and click on **Open**. The image is placed into the slide and the file browser closes. The *Image* section in Properties on the Sidebar opens allowing you to edit the image file. For more information on using images, see Chapter 4, Adding and Formatting Pictures and Chapter 7, OLE, Spreadsheets, Charts, and Other Objects.

• **Audio or video** – click on *Insert Audio or Video* and a file browser opens. Navigate to where the audio or video file you want to use is located. Select the file and click on **Open**. The image is placed into the slide and the file browser closes. The *Media Playback* section in Properties on the Sidebar opens allowing you to operate the audio or video file. For more information on using audio and video, see Chapter 7, OLE, Spreadsheets, Charts, and Other Objects.

---

**Modifying slide elements**

When a slide is inserted into your presentation, it contains elements that were included in the selected slide layout. However, it is unlikely that the predefined layouts will suit all your needs for your presentation. You may want to remove elements that are not required or insert objects such as text and/or graphics.

Although Impress does not have the functionality to create new layouts, it allows you to resize and move the slide elements. It is also possible to add slide elements without being limited to the size and position of content boxes.

**Note**

It is recommended that changes to slide elements in the layouts included in Impress are only be made using normal view, which is the default. Attempting any changes to a slide element when in master view is possible, but may result in unpredictable results and requires extra care as well as a certain amount of trial and error.

**Moving contents box**

1) Click on the outer frame so that the selection handles are displayed.

2) Place the mouse cursor on the frame so that the cursor changes shape. This is normally a clenched hand, but depends on your computer setup.

3) Click the mouse button and drag the contents box to its new position on the slide, then release the mouse button.

**Resizing contents box**

1) Click on the outer frame so that the selection handles are displayed.

2) Place the mouse cursor on a selection handle the frame so that the cursor changes shape.

3) Click the mouse button and drag the selection handle on the frame to resize the contents box, then release the mouse button.
   - Top and bottom selection handles change the height of a contents box.
   - Left and right selection handles change the width of a contents box.
   - Corner selection handles change width and height of a contents box.

**Removing elements**

1) Click a contents box or an element to highlight it and the selection handles are displayed.
2) Press the *Delete* or *Backspace* key to remove the contents box or element.

**Adding text**

There are two ways of adding text to a slide – contents box or text box. For more information on text, see Chapter 3, Adding and Formatting Text.

- **Contents box** – click *Click to add text* (Figure 20 on page 29) in the contents box and type your text. Outline styles are automatically applied to the text as you insert it. You can change the outline level of each paragraph as well as its position within the contents box by using the arrow buttons on the Outline toolbar (Figure 13 on page 23) and Workspace **Outline** view (Figure 12 on page 23).

- **Text box** – click on **Text** on the Standard toolbar (Figure 8 on page 21) or Drawing toolbar (Figure 9 on page 22) to select text mode, then click on your slide. A text box is created and the Text Formatting toolbar (Figure 11 on page 22) automatically opens. Type your text and click outside the text box to end text mode.

**Adding images or objects**

To add images or objects to a slide, for example a picture, clipart, drawing, photograph, or spreadsheet, click on **Insert** on the Menu bar and select from the drop down menu the image or object type you require. For more information on adding objects, see the following chapters:

- Chapter 4, Adding and Formatting Images
- Chapter 5, Managing Graphic Objects
- Chapter 6, Formatting Graphic Objects
- Chapter 7, OLE, Spreadsheets, Charts, and Other Objects

**Modifying slide appearance**

To change the background and other characteristics of all slides in the presentation, you need to modify the master slide or select a different master slide.

A master slide is a slide with a specified set of characteristics that acts as a template and is used as the starting point for creating other slides. These characteristics include the background, objects in the background, formatting of any text used, and any background graphics.

Impress has included a range of master slides, found in the **Master Slide** section on the Properties deck in the Sidebar. You can also create and save additional master slides or add more from other sources. See Chapter 2, Using Slide Masters, Styles, and Templates for information on creating and modifying master slides.

For example, to change the background of an individual slide or a master slide:

1) Right click on a slide or master slide and select **Properties** from the context menu to open the Slide Setup dialog (Figure 21).

2) Select **Background** and then select the type of background to use from *None*, *Color*, *Gradient*, *Bitmap*, *Pattern* and *Hatch*.

3) Make your selection from the various properties that are available for each type of background.

4) Click **OK** to apply your changes and close the dialog.
Modifying slide shows

By default, a slide show will display all the slides in the same order as they appear in Slide Sorter view on the Workspace (Figure 15 on page 24).

Now is a good time to review the entire presentation and answer some questions. Run the slide show at least once (see “Running a slide show” on page 33) before answering them. You may have some questions of your own.

- Are the slides in the correct order? If not, some of them will need to be moved.
- Is the information well spaced and visible to members of an audience at the back of a large room? They may not be able to see information at the bottom of a slide, so you may need to design your presentation to fit the top three-quarters of the screen.
- Would an additional slide make a particular point clearer? If so, another slide needs to be created.
- Do some of the slides seem unnecessary? Hide or delete them.
- Would animations help some of the slides? This is considered an advanced technique.
- Should some of the slides have a different slide transition than others? The transition of those slides should be changed.

Once you have answered these and your own questions, make the necessary changes. Making changes is done easily in Slide Sorter view on the Workspace.
Tip
If one or more slides seem to be unnecessary, hide the slide or slides, and view the slide show a few more times to make sure they are not needed. To hide a slide, right-click the slide in the Slides pane and select Hide Slide from the context menu. Do not delete a slide until you have done this or you may have to create that slide again.

Slide order
Change the slide order in your presentation using one of the following methods:

- In the Slide Sorter view, click on the slide you want to move and drag it to its new position in the presentation.
- In Slides pane, click on the slide you want to move and drag it to its new position in the presentation.

Animations
If you want to add animations to slides in your presentation, click on Animation on the Sidebar to open the Animation deck giving access to the various animation options as follows:

- Animation category.
- Animation effect.
- How the animation starts.
- Animation direction, duration and delay.
- Automatic preview.

Animation is an advanced technique and is beyond the scope of this chapter. For more information on animation, see Chapter 9, Slide Shows.

Slide transitions
To give your presentation a professional look, it is recommended to add transitions between each slide in your presentation. Click on Slide Transition on the Sidebar to open the Slide Transition deck giving access to the various transition options as follows:

- Transition type.
- Modify the transition.
- How the slide advances in the presentation.
- Automatic preview

Adding slide transitions is an advanced technique and is beyond the scope of this chapter. For more information on slide transitions, see Chapter 9, Slide Shows.

Running a slide show
When you have completed your presentation, it is recommended to run a slide show as a test to make sure that everything is to your satisfaction. For more information and details about running a slide show, see Chapter 9, Slide Shows.

1) To run a slide show after completing your presentation, use one of the following methods:
– Go to **Slide Show** on the Menu bar and select **Start from First Slide** from the context menu or use the keyboard shortcut *F5*. The Presenter Console (Figure 22) automatically opens.

– Go to **Slide Show** on the Menu bar and select **Start from Current Slide** from the context menu or use the keyboard shortcut *Shift + F5*. The Presenter Console automatically opens.

2) If the option *Automatically after X seconds* has been selected, the slide show will automatically run after the selected time has elapsed.

3) If the option *On mouse click* has been selected, use one of the following methods to move to the next slide.

   – Click the mouse button to advance to the next slide.
   – Use the arrow keys on the keyboard to go to the next slide or back to the previous one.
   – Press the *Spacebar* on the keyboard to advance to the next slide.
   – Click on the arrows displayed at the bottom of the Presenter Console to move to the next slide or back to the previous one.

4) When the slide show has ended or to exit the slide show before it has finished, press the *Esc* key to close the Presenter Console and return to your presentation in Impress.

**Presenter Console**

The Presenter Console (Figure 22) in LibreOffice Impress can also be used when an extra display for presentation has been connected your computer. The Presenter Console provides extra control over slide shows by using different display views:

   • On an external display the audience sees the current slide in the presentation.
   • On your computer display you see the current slide, the upcoming slide, any slide notes, and a presentation timer.

For more information and details about using the Presenter Console, see *Chapter 9 Slide Shows*. 
Figure 22: Impress Presenter Console
Chapter 2
Master Slides, Styles, and Templates
Designing a presentation

In addition to careful planning of the content, as discussed in Chapter 1 Introducing Impress, you need to plan the appearance of the presentation. It is best to do this after you have developed an outline, because the outline will determine some of the requirements for the appearance of the slides. For example:

- What color combinations (background and text) will look good and also be easy for your audience to read?
- Would an image help your audience understand the contents better?
- Do you want particular text and image to appear on all the slides? For example a company name and logo.
- Would the audience benefit from having the slides numbered so that they can quickly refer to one of them?
- Do you want a background graphic or gradient? If so, you need to pick something that does not interfere or clash with content such as the colors used in charts.
- Will you need one or more master slide?
- Will one slide design suit all of the presentation content?

You can change the appearance of slides as you develop the presentation, but planning ahead will save you time in the long run.

What are master slides?

A master slide is a slide that is used as the starting point for other slides. It is similar to a page style in LibreOffice Writer as it controls the basic formatting of all slides based on it. A presentation can have more than one master slide.

Note

LibreOffice uses three terms for one concept: master slide, slide master, and master page. All refer to a slide which is used to create other slides. This user guide uses the term master slide, except when describing the user interface.

A master slide has a defined set of characteristics, including the background color, graphic, or gradient. It also can include objects (for example, logos, decorative lines) in the background; headers and footers; placement and size of text frames; and text formatting.

All of the characteristics of master slides are controlled by styles. The styles of any new slide you create are inherited from the master slide from which it was created. In other words, the styles of the master slide are available and applied to all slides created from that master slide. Changing a style in a master slide results in changes to all the slides based on that master slide. It is, however, possible to modify each individual slide without affecting the master slide.

Note

It is highly recommended to use the master slides whenever possible. However, there are occasions where manual changes are needed for a particular slide. For example, you could edit an individual slide to enlarge the chart area when the text and chart layout is used.
Master slides have two types of styles associated with them: presentation styles and drawing styles. The presentation styles can be modified, but new presentation styles cannot be created. For drawing styles, you can modify the styles and also create new drawing styles. For more information, see “Workspace views” on page 22.

**Working with master slides**

Impress comes with a collection of master slides. These master slides are shown in the Master Slides deck of the Sidebar (Figure 23). This deck has three sections: **Used in This Presentation**, **Recently Used**, and **Available for Use**. Click the expand marker next to the name of a section to expand it and show thumbnails of the master slides, or click the collapse marker to collapse the section to hide the thumbnails.

Each of the master slides shown in the **Available for Use** section is from a template of the same name. These presentation templates are included when install LibreOffice on your computer. If you have created your own templates, or added templates from other sources, master slides from those templates will also appear in this list. See “Creating Presentations” on page 26 for more information about templates.

If you have decided to create a new presentation without using one of the templates available (see Chapter 1, Introducing Impress for more information), then a default master slide is available. This default master slide is a good starting point for creating master slides. An example of the default master slide is shown in Figure 24.

![Figure 23: Master Slides deck on Sidebar](image-url)
Creating master slides

Creating a new master slide is carried out when Impress is in Master View.

1) Go to View > Master Slide on the main menu bar to open Master View in the Workspace. The Master View toolbar also opens (Figure 25). If the Master View toolbar does not open, go to View > Toolbars on the main menu bar and select Master View.

2) Create a new master slide using one of the following methods and a new master slide appears in the Slides Pane:
   - Click on New Master in the Master View toolbar.
   - Right-click on a master slide in the Slides Pane and select New Master from the context menu.
   - Go to Slide > New Master on the Menu bar.

3) Rename the new master slide using one of the following methods and open the Rename Slide dialog (Figure 26):
   - Click on Rename Master in the Master View toolbar.
   - Right-click on the new master slide in the Slides Pane and select Rename Master from the context menu.
4) Enter a memorable name for the new master slide in the Name text box, then click on OK to save the changes and close the dialog.

5) Make sure the new master slide is selected in the Slides Pane and add all the text, graphics and master elements that you want to use for the new master slide. The chapters in this user guide give more information on adding, editing, formatting and managing the different types of objects on a master slide.

6) When finished creating a new master slide, use one of the following methods to return to Normal View:
   – Click on Close Master View on the Master View toolbar.
   – Go to View > Normal on the Menu bar.

7) Save the presentation file before continuing.

**Applying master slides**

To apply a master slide to all slides or selected slides in a presentation:

1) Click on the Master Slides icon to open the Master Slides deck on the Sidebar (Figure 23 on page 38).
2) Right-click on the master slide you want to use in the Used in This Presentation section in the Master Slides deck on the Sidebar.
3) Select Apply to All Slides or Apply to Selected Slides from the context menu.

**Loading additional master slides**

In a presentation, you may need to mix multiple master slides that may belong to different templates (for more information, see “Creating Presentations” on page 26). For example, you may want a completely different layout for the first slide of the presentation, or want to add a slide from a different presentation to your current presentation.

1) Select the slide or slides in the Slides Pane where you want to change the master slide.
2) Go to Slide > Change Slide Master on the Menu bar to open the Available Master Slides dialog (Figure 27).
3) To add master slides, click on Load to open the Load Master Slide dialog (Figure 28).
4) In the Load Master Slide dialog, select the template category and the template from which to load the master slide.
5) Click OK to close the Load Master Slide dialog and the master slides from the selected template appear in the Available Master Slides dialog.
6) Select the master slide you want to use in Select a Slide Design box.
7) To apply the selected master slide to all slides in your presentation, select the Exchange background page check box.
8) To apply the slide design to the selected slides only, deselect the Exchange background page check box.
9) Click OK to apply your selection to the slides and close the Available Master Slides dialog.
Figure 27: Available Master Slides dialog

Figure 28: Load Master Slide dialog
Editing master slides

The following items can be changed on a master slide:

- Background (color, gradient, hatching, or bitmap). See “Using LibreOffice on macOS” on page 10 for more information.
- Background objects (for example, adding a logo or decorative graphics), See “Adding images” on page 45, Chapter 4, Adding and Formatting Pictures, Chapter 5, Managing Graphic Objects, and Chapter 6, Formatting Graphic Objects for more information.
- Text attributes for the main text area and notes. See “Adding text and fields” on page 51 and Chapter 3, Adding and Formatting Text for more information.
- Size, placement, and contents of header and footer elements to appear on every slide. See “Adding text and fields” on page 51 and Chapter 3, Adding and Formatting Text for more information.
- Size and placement of default frames for slide titles and content. See “Default text areas” on page 46 for more information.

Editing a master slide is as follows:

1) Select View > Master Slide from the Menu bar. This also opens the Master View toolbar (Figure 25 on page 39).
2) Select a master slide you want to edit in the Slides Pane so that it appears in the Workspace (Figure 29).
3) Go to Slide > Properties on the Menu bar or right-click in the Workspace and select Properties from the context menu to open the Slide Setup dialog (Figure 30).
4) Use the various options in the Slide, Background and Transparency pages in the Slide Setup dialog to make changes to the format of your master slide.
5) Click OK to save your changes and close the Slide Setup dialog.
6) Select an object on the master slide, then right-click on the object to open a context menu.
7) Select one of the options from the context menu to edit the object. Selecting an option may open another context menu, a dialog, an application or file browser window so you can make the necessary changes to your selected object.

8) Click on **Close Master View** on the Master View toolbar or go to **View > Normal** on the Menu bar to exit from editing master slides.

9) Save your presentation file before continuing.

---

**Note**

Any changes made to a master slide when in **Master Slide** view will appear on all slides using the same master slide. Always make sure you close **Master Slide** view and return to **Normal** view before working on any of the presentation slides.

Any changes made to any object on a slide in **Normal** view (for example, changes to bullet point style, color of the title area, and so on) will not be overridden by subsequent changes made to the master slide used for that slide. However, where it is desirable to revert the formatting of a manually formatted object on a slide to the style defined in the master slide, select the object on the slide and use one of the following methods to change the formatting:

- Go to **Format > Clear Direct Formatting** on the Menu bar.
- Right-click on an object and select **Clear Direct Formatting** from the context menu.

---

**Note**

Depending on the contents of a slide, you may want to apply a different layout. The title and text boxes inherit the properties of a master slide, but if you have changed the position of these text boxes in the master slide, the layout may appear corrupted. You may need to re-position some of the layout elements manually on a slide.

---

**Selecting and applying backgrounds**

Backgrounds can be applied to a number of elements in Impress (for example: slide, default text area, image and so on). The procedure is similar when applying a background to a slide or an object.
Using slide setup

1) Select View > Master Slide from the Menu bar. This also opens the Master View toolbar (Figure 25 on page 39).

2) Select a master slide you want to edit in the Slides Pane so that it appears in the Workspace (Figure 29 on page 42).

3) Go to Slide > Properties on the Menu bar or right-click in the Workspace and select Properties from the context menu to open the Slide Setup dialog (Figure 30).

4) Select the Background tab to open the Background page (Figure 31).

5) Select the type of background required from Color, Gradient, Bitmap, Pattern and Hatch. See Chapter 6, Formatting Graphic Objects for more information on how to use the options available for each type of background selected.

6) When satisfied with your background, click OK to save your changes and close the Slide Setup dialog.

Using background style

1) Select View > Master Slide from the Menu bar. This also opens the Master View toolbar.

2) Select a master slide you want to edit in the Slides Pane so that it appears in the Workspace.

3) Click on Styles on the Sidebar to open the Styles deck.

4) Click on Presentation Styles on the Styles deck to open the Presentation Styles list (Figure 32).

5) Right-click on Background style and select Modify from the context menu to open the Background dialog. This dialog has one tab (Area) and offers the same options as the Background page in the Slide Setup dialog (Figure 31).

6) Select the type of background required from Color, Gradient, Bitmap, Pattern and Hatch. See Chapter 6, Formatting Graphic Objects for more information on how to use the options available for each type of background selected.

7) When satisfied with your background, click OK to save your changes and close the Background dialog.
Adding images

When you want the same image to appear on every slide of your presentation, the easiest and quickest solution is to use the master slide. It saves time while creating the presentation allowing you to modify or reposition the image on all slides. If the same image is added to each slide manually, modification and repositioning have to be performed on each individual slide in the presentation. In addition to images, you can add a number of other objects in the background, for example decorative lines, text, and shapes.

LibreOffice supports a large number of image and graphic formats. For more information on working with images, see Chapter 4, Adding and Formatting Pictures, Chapter 5, Managing Graphic Objects and Chapter 6, Formatting Graphic Objects.

For example, one of the most common actions in preparing a presentation is to add an image to the master slide. To insert an image already available on the computer, follow these steps:

1) Select View > Master Slide from the Menu bar. This also opens the Master View toolbar (Figure 25 on page 39).
2) Select the master slide where you want to add an image.
3) Select Insert > Image… on the Menu bar to open the file browser.
4) Navigate to the directory where your image is located and select it.
5) Click Open and the image is placed into your master slide and the file browser closes.
6) If necessary, modify and/or reposition the image on your master slide.
7) Right-click on the image and select Arrange > Send to Back from the context menu. This moves the image to the background so that any information you add to the slide when creating a presentation appears over the background image.
Note

LibreOffice offers the option to insert an image as a link to the file rather than embedding it in your presentation. This is only useful when a presentation is not intended for distribution onto other computers and it will remain in the same computer and directory structure. For example, it could be created on a notebook computer, which is then used to give the presentation to a group of clients.

However, if the presentation file is to be distributed onto other computers, the image must be embedded to avoid the “missing image” syndrome when the presentation is given using a different computer.

Default text areas

When a master slide is opened for editing, it contains five default text areas, as shown in Figure 24 on page 39.

- Title area for AutoLayouts
- Object area for AutoLayouts
- Date area
- Footer area
- Slide number area

Position and size

Click with the mouse button on any of these areas to display the selection handles around the default text area. Use these selection handles to modify the size and position of a default text area.

1) To quickly change the position of a default text area:
   a) Select the default text area you want to reposition so that the selection handles are visible.
   b) Move the cursor toward the border of the default text area, not on a selection handle, and the cursor changes shape. The cursor shape is dependent on your computer setup (normally a clenched hand).
   c) Click the left mouse button and drag the default text area to the desired position, then release the left mouse button.

2) To quickly change the shape and/or size of a default text area:
   a) Position the cursor over a left or right selection handle.
   b) Click the left mouse button and drag the left or right selection handle to change the width of the default text area.
   c) Position the cursor over a top or bottom selection handle.
   d) Click the mouse button and drag the top or bottom selection handle to change the height of the default text area.
   e) Position the cursor over a corner selection handle.
   f) Click the mouse button and drag the corner selection handle to change both the height and width of the default text area at the same time.
   g) Release the mouse button when the default text area is the required width or height.
**Note**

The shape of the mouse cursor usually changes shape when positioned over a selection handle giving a clear visual indication of how it will affect the shape of the default text area.

**Tip**

Keep the *Shift* key pressed while dragging a selection handle to maintain the ratio between the width and height dimensions of the default text area.

![Position and Size dialog](image)

*Figure 33: Position and Size dialog*

To accurately control the shape, size and position of a default text area, it is recommended to use the Position and Size dialog or the *Position and Size* section in the Properties deck on the Sidebar.

1) Select the default text area by clicking on its border.

2) Use one of the following methods to access the options available for the position and size of a default text area:
   - Go to **Format > Object and Shape > Position and Size** on the Menu bar to open the Position and Size dialog (Figure 33).
   - Use the keyboard shortcut *F4* to open the Position and Size dialog.
   - Right-click on the border of the default text area and select *Position and Size* from the context menu to open the Position and Size dialog.
   - Click on *Properties* on the Sidebar and open the Properties deck, then open the *Position and Size* section (Figure 34).

The functions of the Position and Size options are explained fully in the *Draw Guide*. Only short descriptions of the most important functions are provided as follows:

- Use **Position** to specify the X (horizontal) and Y (vertical) position of the default text area. The values represent the distance of the selected base point and the default position is the top left corner of the slide.
Figure 34: Position and Size section in Properties on Sidebar

- Use Size to specify the width and height of the default text area.
- In the Position and Size dialog only, the Base point section allows you to select a point on the rectangular area that you do not want to move while resizing. The default setting of top left corner means that the position of the top left corner of the area will not change after resizing.
- Use Rotation to rotate the default text area. For example, you can place the footer area on the side by rotating each text area by 90 degrees and obtain a more modern-looking layout. In general it is preferable to use only right angles for ease of editing, although the program does not impose restrictions on the values that can be used.
- Use Slant & Corner Radius page to add a corner radius to a text box border only if a visible line style has been selected. The slant options works are only available for images or shapes.

Background

Change the type of area fill used for backgrounds in a default text area using one of the following methods. The options available depend on the type of area fill selected. See Chapter 6, Formatting Graphic Objects for more information on changing backgrounds.

- Go to Format > Object and Shape > Area on the Menu bar to open the Area dialog (Figure 35).
- Right-click on the default text area and select Area from the context menu to open the Area dialog.
- Click on Properties on the Sidebar and open the Properties deck, then open the Area section (Figure 36).
Figure 35: Area dialog

Figure 36: Area section in Properties on Sidebar

Figure 37: Line dialog
Border

Change the type of line used for borders in a default text area using one of the following methods. The options available in this dialog will depend on the type of line selected. See Chapter 6, Formatting Graphic Objects for more information on changing borders.

- Go to Format > Object and Shape > Line on the Menu bar to open the Line dialog (Figure 37).
- Right-click on the object and select Line from the context menu to open the Line dialog.
- Click on Properties on the Sidebar and open the Properties deck, then open the Line section (Figure 38).

Alignment

Change the alignment of default text area in relation to its position on a master slide or the alignment between a default text area and other objects on a master slide using one of the following methods. See Chapter 5, Managing Graphic Objects for more information on changing alignment of default text areas.

- Go to Format > Align on the Menu bar and select the type of alignment from the options available in the context menu.
- Right-click on the object and select Align from the context menu, then select the type of alignment from the options available in the context menu.
- Click on the downward triangle ▼ to the right of Align on the Line and Filling toolbar and select the type of alignment from the options available.
- Select the required alignment tool in the Position and Size section on the Properties deck on the Sidebar (Figure 34 on page 48).

Arrangement

Arrange the position of an object on a slide in relation to other objects on a slide using one of the following methods. See Chapter 5, Managing Graphic Objects for more information on changing position of default text areas in relation to other objects.
• Go to Format > Arrange on the Menu bar and select the type of arrangement from the options available in the context menu.
• Right-click on the object and select Arrange from the context menu, then select the type of arrangement from the options available in the context menu.
• Click on the required arrangement tool on the left end of the Line and Filling toolbar.
• Select the required arrangement tool in the Position and Size section on the Properties deck on the Sidebar.

Adding text and fields

Adding text and fields to a master slide allows you to place information that you want to appear on all the slides in your presentation: for example a presentation title, company name and logo, date and slide number. For more information on adding and formatting text and fields, see Chapter 3, Adding and Formatting Text.

Text

Text objects can be placed anywhere on the master page so that it appears on every slide in your presentation. Text objects can also be placed in the footer if you do not want to use the default fields in the footer of your presentation.

1) Select View > Master Slide from the Menu bar to open the master slide view. This also opens the Master View toolbar (Figure 25 on page 39).
2) Select the master slide where you want to add a text object so that it appears in the Workspace.
3) Switch on text editing mode using one of the following methods. The Text Formatting toolbar (Figure 39) automatically opens replacing the Line and Filling toolbar.
   – Select Insert Text Box on the Standard or Drawing toolbar.
   – Go to Insert > Text Box on the Menu bar.
   – Use the keyboard shortcut F2.
4) Click once on the master slide so that a text box is created and there is a flashing cursor inside the text box.
5) Type or paste your text into the text object.
6) Format the text after placing it on your master slide. See Chapter 3, Adding and Formatting Text for more information.
7) Click outside the text object to close the Text Formatting toolbar and reopen the Line and Filling toolbar.
8) Click Close Master View on the Master View toolbar or go to View > Normal on the Menu bar when you have completed adding and formatting text to your master slide.

Default footer sections

By default, the footer used in a slide consists of three sections (Figure 24 on page 39) with each section containing a default field as follows:

• Left section – date and time and is labelled Date Area. Field name is <date/time>.

Figure 39: Text Formatting toolbar
Header and Footer dialog

The default footer fields are set up as follows using the Header and Footer dialog (Figure 40):

1) Select View > Master Slide from the Menu bar to open the master slide view. This also opens the Master View toolbar (Figure 25 on page 39).

2) Select the master slide where you want to add a text object so that it appears in the Workspace.

3) Select Date and Time for the date and time to appear in the left section of the footer.
   - For a fixed date and time in the left footer section, select Fixed and enter the date you want to use in the Fixed text box.
   - For a variable date and time in the left footer section, select Variable, then select the format and language you want to use from the Format and Language drop down lists. Using a variable date and time means that each time the presentation is opened, the date and time are updated.

4) To place text in the footer center section, select Footer and then type or paste your text into the Footer text input field.

5) To place the slide number in the right section of the footer, select Slide number.

6) If you do not want the footer to appear on the first slide of your presentation, select Do not show on the first slide. The first slide is normally the title slide of your presentation.

7) Click Apply to save your changes and close the Header and Footer dialog.

8) To format the text used for the default footer fields, see Chapter 3 Adding and Formatting Text for more information.
9) Click Close Master View on the Master View toolbar or go to View > Normal on the Menu bar when you have completed setting up the default footer fields.

**Note**

The default sections in a footer can be formatted, resized and repositioned. See “Default text areas” on page 46 for more information.

**Custom footer sections**

The default fields in a footer section can be replaced with text or manual fields as follows:

1) Select View > Master Slide from the Menu bar to open the master slide view. This also opens the Master View toolbar (Figure 25 on page 39).

2) Highlight the default field in the footer section and press the Delete or Backspace key. A flashing text cursor will appear in the footer section and the Text Formatting toolbar automatically opens replacing the Line and Filling toolbar.

3) Type in your text or insert a manual field into the footer section. For more information on manual fields, see “Manual fields” below.

4) Format the text or manual field placed in the footer section. See Chapter 3, Adding and Formatting Text for more information.

5) Click outside the footer section to close the Text Formatting toolbar and reopen the Line and Filling toolbar.

6) Click Close Master View on the Master View toolbar or go to View > Normal on the Menu bar when you have completed setting up a custom footer section.

**Manual fields**

Manual fields, for example date or page number (slide number), can be added as text objects on a master slide or replace one of the default footer fields. The fields you can use in Impress are:

- Date (fixed)
- Date (variable) – updates automatically when you open the presentation again.
- Time (fixed)
- Time (variable) – updates automatically when you open the presentation again and each time you open a slide more than once during a presentation.
- Author – first and last names listed in the LibreOffice user data.
- Slide number
- Slide Title
- Slide Count
- File Name

To place a field on your master slide:

1) Select View > Master Slide from the Menu bar to open the master slide view. This also opens the Master View toolbar (Figure 25 on page 39).

2) Click anywhere on the master slide.

3) Go to Insert > Field on the Menu bar and select the required field from the context menu.
4) By default the field is placed in the center of the master slide. Reposition the field text box to the desired position on your master slide. See “Default text areas” on page 46 for more information.

5) To format the text used in a field, see Chapter 3 Adding and Formatting Text for more information.

6) Click Close Master View on the Master View toolbar or go to View > Normal on the Menu bar when you have completed replacing the default footer fields.

To replace a default footer field on your master slide:

1) Select View > Master Slide from the Menu bar to open the master slide view. This also opens the Master View toolbar (Figure25 on page 39).

2) Highlight all of the characters used in the default field you want to replace in the footer.

3) Go to Insert > Field on the Menu bar and select the required field from the context menu.

4) To format the text used in a field, see Chapter 3 Adding and Formatting Text for more information.

5) Click Close Master View on the Master View toolbar or go to View > Normal on the Menu bar when you have completed replacing the default footer fields.

Tip

To change the number format (1, 2, 3 or a, b, c or i, ii, iii, and so on) for the slide number, go to Slide > Properties on the Menu bar and select in Layout Settings the type of number to use from the Slide numbers: drop down list.

To change the author information, go to Tools > Options > LibreOffice > User Data on the Menu bar.

Working with styles

A style is a set of formats that you can apply to selected elements such as slides, text, lists, frames, borders, lines and area fills in a presentation to quickly set or change their appearance. Applying a style means applying a group of formats at the same time providing a consistent look to your presentation. For example, to manually change an attribute on the same object type on every slide in your presentation is time consuming and prone to errors. Using styles reduces time and provides greater accuracy.

Impress has two types of styles available for formatting text and graphic objects – presentation styles and drawing styles.

- For information on formatting text, see Chapter 3, Adding and Formatting.
- For information on formatting graphic objects, see Chapter 6, Formatting Graphic Objects and the Draw Guide.
- More information on styles used in LibreOffice can be found in the Getting Started Guide.
The presence of text and title styles both in the presentation and drawing styles may seem confusing. This apparent duplication is because Impress uses special text boxes (auto layout boxes) when adding structured text to slides where presentation styles apply. The title and other text styles in drawing styles are used on any other text boxes you may want to add, or text associated with shapes or lines.

Presentation styles

Presentation styles in Impress are used when creating a presentation using one of the Impress slide layouts. These presentation styles are divided into four categories.

- **Background** and **Background objects** – are used to format objects on the default master slide such as icons, decorative lines, and shapes.
- **Notes** – formats the text used in presentation notes.
- **Outline 1 thru Outline 9** – are used for the different levels of the outline to which they belong. For example, Outline 2 is used for the sub-points of Outline 1, Outline 3 is used for the sub-points of Outline 2 and so on.
- **Subtitle** and **Title** – formats the text used for any titles or subtitles used on slides.

As with the Heading styles in Writer, the Outline styles in Impress are hierarchically linked. For example, a change to an attribute in the Outline 1 style will cascade through all the other styles for Outline levels.

The default master slide and slide layouts in Impress use auto layout boxes. Presentation styles can only be used within these auto layout boxes. An example of text using these presentation styles is shown in Figure 24 on page 39.

Any text added to a slide using the text tools available is automatically placed in a standard text box and allocated the Default Drawing Style from Drawing Styles. For more information on formatting text, see Chapter 3, Adding and Formatting Text.

Presentation styles cannot be created or deleted, but can be formatted, modified or updated to your requirements. Also, you cannot change the presentation style used for an object with another presentation style. For example, text with Outline 2 style cannot be changed to Outline 3 style.

Changing outline levels is done in normal view using the **Tab** key or **Shift+Tab** key combination or the **Promote** and **Demote** tools on the Outline toolbar. See Chapter 3, Adding and Formatting Text for more information.
**Drawing styles**

Drawing styles in Impress define the characteristics of graphic objects (including text objects) that you place on a slide. These styles include attributes for line, area, shadowing, transparency, text, connectors and dimensioning.

For example, if you need to create organization charts in your presentation, you will probably want all of the objects to have a consistent appearance, such as line style, font type, shadow, and so on. The easiest way to achieve this result with the minimum effort is to use a drawing style for the objects and apply it to each object. The major benefit is that if you decide to change, say, the background color of objects, all you need to do is modify the style rather than each individual object.

Drawing styles included with Impress cannot be deleted, but you can format, modify and update drawing styles. You can also create new or custom styles, see “Custom styles” on page 58. Any custom style created is only available in the presentation where it was created.

**Accessing styles**

Use one of the following methods to access or modify styles available in Impress:

- Use the keyboard shortcut F11 (Windows and Linux) or ⌘T (macOS).
- Go to **Format > Styles** on the Menu bar.
- Click on **Show the Styles Sidebar** located on the Line and Filling toolbar.
- Click on **Styles** on the Sidebar to open the Styles deck.

**Editing styles**

Formatting presentation and drawing styles can be carried out in either **Normal** or **Master Slide** view. Formatting options are available in dialogs for each style or using **Format** in the Menu bar. For more information on formatting text and objects, see Chapter 3, Adding and Formatting Text and Chapter 6, Formatting Graphic Objects.

**Dialog formatting**

1) Select an object on a slide or master slide and its style is highlighted in the Styles deck on the Sidebar.

2) Go to **Format > Styles > Edit Style** on the Menu bar or right-click on the highlighted style in the Styles deck on the Sidebar to open the formatting dialog for the selected style. An example dialog for Outline 1 style is shown in Figure 41.

3) Use the various options available in the tabbed pages of the dialog to format the style.

4) Click **OK** to save your formatting changes and close the dialog.
Figure 41: Example dialog for formatting styles

Note
Clicking on Reset before clicking OK removes all formatting changes you have made in the style formatting dialog.

Format menu

1) Open the Styles deck on the Sidebar. See “Accessing styles” on page 56 for more information.

2) Go to Format on the Menu bar to open a drop down menu with various formatting options available. Depending on the object selected, some formatting options will not be available and are greyed out.

3) Select a formatting option from the drop down menu. Depending on the option selected, another drop down menu may open giving further formatting options or a formatting dialog will open.

Modifying

1) Open the Styles deck on the Sidebar. See “Accessing styles” on page 56 for more information.

2) Click on Presentation Styles or Drawing Styles at the top left of the Styles deck to open the list of presentation or drawing styles.

3) Right-click on the style you want to modify and select Modify from the context menu to open the formatting dialog for the style selected. An example dialog for Outline 1 style is shown in Figure 41.

4) Make the necessary changes to the selected presentation or drawing style using the various options available in the dialog that has opened.

5) Click OK to save your changes and close the dialog.
**Updating**

Updating a presentation or drawing style is similar to modifying, but you make format changes to the text or object first. Updating styles can only be carried out in **Normal** view.

1) Select the text or object on your slide in **Normal** view.
2) Use the various tools on the Text Formatting toolbar, Line and Filling toolbar, or the options in **Format** on the Menu bar to format the selected object.
3) Open the Styles deck on the Sidebar. See “Accessing styles” on page 56 for more information.
4) Click on **Presentation Styles** or **Drawing Styles** at the top left of the Styles deck to open the list of styles. The style used for the selected object will be highlighted.
5) Click on **Update Style** at the top right of the Styles deck and the style is updated to include the formatting changes you have made to the selected object.

**Custom styles**

You cannot create custom presentation styles in Impress, but you can create custom drawing styles. These custom drawing styles are only available for the presentation that you are creating.

1) Create or select the object on your slide you want to use for creating a new drawing style.
2) Format the object to your requirements using the various formatting options available in the Text Formatting toolbar, Line and Filling toolbar, or the options in **Format** on the Menu bar.

3) Open the Styles deck on the Sidebar. See “Accessing styles” on page 56 for more information.
4) Click on **Drawing Styles** at the top left of the Styles deck to open the list of drawing styles.
5) Click on **New Style from Selection** at the top right of the Styles deck and the Create Style dialog opens (Figure 42).
6) Enter a name for your custom style in the **Style Name** text box.
7) Click **OK** to close the Create Style dialog. The custom style is created and appears in the drawing styles list in the Styles deck on the Sidebar.

**Direct formatting**

Direct formatting overrides any formatting applied to an object when a style is used. You cannot remove direct formatting from an object by applying a style to it. To remove any direct formatting, select the object so that the selection handles are visible, then use one of the following methods to clear any direct formatting:

- Use the keyboard shortcut **Ctrl+Shift+M**.
- Go to **Format > Clear Direct Formatting** in the Menu bar.
- If the object is a text object, highlight all of the text and then click on **Clear Direct Formatting** on the Text Formatting toolbar.
- If the object is a text object, highlight all of the text, right-click on the selected text and select **Clear Direct Formatting** from the context menu.

**Linked styles**

Impress styles support inheritance which allows a style to be linked to another (parent) style so that it inherits all the formatting settings of the parent. This inheritance creates families of styles.

For example, if you require multiple boxes that differ in color, but are otherwise identically formatted, the best way to proceed is to define a style for the box including borders, area fill, font, and so on and a number of styles that are hierarchically dependent which differ only in the fill color attribute. If you need to change the font size or the thickness of the border, you only have to change the parent style and all the other styles will change accordingly.

**Assigning styles keyboard shortcuts**

LibreOffice provides a set of predefined keyboard shortcuts which allow you to quickly apply styles while working with a document. You can redefine these shortcuts or define your own, as described in Appendix A, Keyboard Shortcuts.

**Working with templates**

A template is a special type of presentation that you use as a basis to create your presentations. For example, you can create a template for business presentations so that any new presentations has your company logo, name and information on the first slide and the remaining slides in your presentation only show the company logo and name.

Templates can contain anything that presentations can contain, such as text, graphics, a set of styles, and user-specific setup information such as measurement units, language, the default printer, and toolbar and menu customization.

All document types created using LibreOffice are based on templates. You can create a specific template for any document type (text, spreadsheet, drawing, presentation). If you do not specify a template when you start a new document, then the default template for that type of document is used. If you have not specified a default template, LibreOffice uses the blank template for that type of document that is installed with LibreOffice. This default template can be changed, see “Setting default template” on page 61 for more information.
However, Impress is a little different from other LibreOffice components, in that it starts with the Select a Template dialog (Figure 43), unless you have decided to turn off this dialog in LibreOffice options. When you create a presentation, if the template dialog is active, it opens offering several choices for templates as a starting point for your presentation.

If you have turned off the Select a Template dialog when creating a new presentation, LibreOffice uses the LibreOffice default template for presentations. If you have defined your own default template, LibreOffice uses your default template when you create a presentation.

For more information on templates and how to use them, see the Getting Started Guide.

![Select a Template dialog](image)

Figure 43: Select a Template dialog

**Templates supplied with LibreOffice**

Impress comes with a set of predefined templates. These templates only contain backgrounds and background objects providing you with a starting point to create your own presentations or presentation templates.

Any templates that you create will be located in the My Templates folder after you have saved your presentation as a template. Your templates will appear in the LibreOffice startup window and the Select a Template dialog the next time you start LibreOffice.

Use one of the following methods to create a new presentation using a template:

- Click on the small down arrow ▼ on the right of Templates in LibreOffice start up window and then select Impress Templates from the context menu to display the available presentation templates. Select a template and a new presentation opens.
- Go to File > New > Templates on the Menu bar to open the Templates dialog (this dialog is similar to the Select a Template dialog in Figure 43). Select Presentations from the Filter drop down list to display presentation templates. Select a presentation template and click OK. The dialog closes and a new presentation opens.
- Use the keyboard shortcut Shift+Ctrl+N to open the Templates dialog (this dialog is similar to the Select a Template dialog in Figure 43). Select Presentations from the Filter drop down list to display presentation templates. Select a presentation template and click OK. The dialog closes and a new presentation opens.
Creating templates

Create a template and save it to a template folder as follows:

1) Open the presentation that you want to use for a template, or open a template that you want to use as a basis for your template.

2) Add and format content and styles to your presentation.

3) Go to File > Templates > Save As Template on the Menu bar to open the Save as Template dialog (Figure 44).

4) Enter a name for the new template in the Template Name text box.

5) Select a destination folder for the new template.

6) If required, select the option Set as default template to use as the default template the next time you open LibreOffice and do not select a template. See “Setting default template” on page 61 for more information on default templates.

7) Click on Save to save your template and close the Save as Template dialog. Your templates will appear in the LibreOffice startup window and the Select a Template dialog the next time you start LibreOffice.

Setting default template

If you create a new presentation and do not select a template, LibreOffice creates the presentation from the default Impress template. This is normally a blank template. However, you can set any presentation template to be the default template, even a template that you have created. The template has to be located in a folder displayed in the Save as Template dialog so that LibreOffice can find it. You can always reset to the default template back to the LibreOffice default template later if you choose.

Changing default template

1) Use one of the following methods to open the Select a Template dialog (Figure 43 on page 60):

   – Go to File > New > Templates on the Menu bar.
– Go to **File > Templates > Manage Templates** on the Menu bar.

2) Select the template you want to use as the default LibreOffice presentation template.

3) Right click on the selected template and select **Set as Default** from the context menu.

4) Click on **Open** and a new presentation opens using the new default template and sets the default presentation template in LibreOffice. The next time that you create a new presentation and do not select a template, the presentation will be created using the new default presentation template.

**Resetting default template**

To reset the default presentation template back to the original LibreOffice default template for presentations:

1) Use one of the following methods to open the Select a Template dialog (Figure 43 on page 60):
   - Go to **File > New > Templates** on the Menu bar.
   - Go to **File > Templates > Manage Templates** on the Menu bar.

2) Click on **Settings** and select **Reset Default Template > Presentation** from the context menu. The next time that you create a new presentation and do not select a template, the presentation will be created using the default LibreOffice template for presentations.

**Editing templates**

You can edit template styles and content and reapply the template styles to presentations that were created from that template.

1) Use one of the following methods to open the Select a Template dialog (Figure 43 on page 60):
   - Go to **File > New > Templates** on the Menu bar.
   - Go to **File > Templates > Manage Templates** on the Menu bar.
   - Click on the small down arrow ▼ on the right of **Templates** in LibreOffice start up window and select Impress Templates from the context menu.

2) Right click on the template you want to edit and select **Edit** from the context menu and the template will open in Impress.

3) Carry out your editing updates of any styles, text and/or objects on the selected template.

4) Go to **File > Save** on the Menu bar or use the keyboard shortcut **Ctrl+S** to save your changes.

5) Close the template or create a presentation using the edited template.

**Note**

Any presentation created from the template before editing can be updated to show the changed template settings the next time you open the presentation after template editing. A confirmation dialog opens asking if you want to use the updated styles or keep the old styles. If select to keep the old styles, then the presentation will continue to use the old styles without any confirmation.
Organizing templates

LibreOffice can only use templates that are in LibreOffice template folders (categories). You can create new LibreOffice template folders or categories and use them to organize your templates. For example, separate template categories for different projects or clients. You can also import and export templates.

Tip

The location of LibreOffice template folders varies with your computer operating system. To learn where the template folders are stored on your computer, go to Tools > Options > LibreOffice > Paths.

Creating template categories

1) Use one of the following methods to open the Select a Template dialog (Figure 43 on page 60):
   - Go to File > New > Templates on the Menu bar.
   - Go to File > Templates > Manage Templates on the Menu bar.
2) Right click on Settings and select New Category from the context menu.
3) Enter a category name in Enter category name text box that has opened (Figure 45).
4) Click OK to save your new category and the category will appear in the drop down list for categories filter at the top of the Select a Template dialog.

Figure 45: Creating new category

Deleting template categories

You cannot delete the template categories supplied with LibreOffice or installed using the Extension Manager. You can only delete categories that you have created.

1) Use one of the following methods to open the Select a Template dialog (Figure 43 on page 60):
   - Go to File > New > Templates on the Menu bar.
   - Go to File > Templates > Manage Templates on the Menu bar.
2) Right click on Settings and select Delete Category from the context menu to open the Delete Category dialog (Figure 46).
3) Select the category you want to delete.
4) Click OK to delete the category and confirm the deletion.
Moving templates

To move a template from one category to another category:

1) Use one of the following methods to open the Select a Template dialog (Figure 43 on page 60):
   - Go to File > New > Templates on the Menu bar.
   - Go to File > Templates > Manage Templates on the Menu bar.

2) Select the template you want to move and click on Move.

3) Select a category from the displayed list or select Create a New Category in the Select Category dialog (Figure 47).

4) Click OK to move the template to its new category and close the Select Category dialog.

Deleting templates

You cannot delete the templates supplied with LibreOffice or installed using the Extension Manager. You can only delete templates that you have created or imported.
1) Use one of the following methods to open the Select a Template dialog (Figure 43 on page 60):
   – Go to File > New > Templates on the Menu bar.
   – Go to File > Templates > Manage Templates on the Menu bar.

2) Right click on the template you want to delete and select Delete from the context menu.

3) Click on Yes to confirm the deletion.

**Importing templates**

If the template that you want to use is in a different location on your computer, you must import it into a LibreOffice template folder for LibreOffice to recognize the template.

1) Use one of the following methods to open the Select a Template dialog (Figure 43 on page 60):
   – Go to File > New > Templates on the Menu bar.
   – Go to File > Templates > Manage Templates on the Menu bar.

2) Click Import and the Select Category dialog (Figure 47) opens.

3) Select a category from the displayed list or select Create a New Category in the Select Category dialog.

4) In the file browser window that opens, navigate to the folder where your template is located on your computer that you want to import.

5) Select the template and click Open. The file browser window closes and the template appears in the selected category.

**Exporting templates**

1) Use one of the following methods to open the Select a Template dialog (Figure 43 on page 60):
   – Go to File > New > Templates on the Menu bar.
   – Go to File > Templates > Manage Templates on the Menu bar.

2) Select the template you want to export, then click on Export to open a file browser window.

3) Navigate to the folder where you want to export the template and click on Select. The template is exported and the file browser window closes.
Chapter 3
Adding and Formatting Text
Introduction

Any text used in slides is contained in text boxes. This chapter describes the following:

- How to create, modify, use, and delete text boxes.
- How to create, modify and format the various types of text that can be inserted.
- How to insert special forms of text such as numbered or bulleted lists, tables, fields, and hyperlinks.

Working with text boxes

Adding text boxes to slides is carried out using one of the following methods:

- Use a predefined Impress layout which includes AutoLayout text boxes.
- Create a text box using the Insert Text Box for a horizontally aligned text box on the Standard toolbar (Figure 48) or the Drawing toolbar (Figure 49).
- Create a text box using the Insert Vertical Text for a vertically aligned text box on the Standard toolbar (Figure 48) or the Drawing toolbar (Figure 49).
- Use the keyboard shortcut F2 to insert a horizontally aligned text box.

Note

When inserting text boxes and adding or formatting text, the Text Formatting toolbar (Figure 50) automatically opens replacing the Line and Filling toolbar, if the Line and Filling toolbar is active and displayed.

Note

The Insert Vertical Text tool for creating a vertical text box and inserting vertical text is only available when Asian and Complex text layout (CTL) options are enabled. Go to in Tools > Options > Language Settings > Languages on the main menu bar to select these options for vertical text.

Note

AutoLayout text boxes can be moved, resized and deleted in the same way as text boxes. See “Moving text boxes” on page 69, “Text positioning” on page 71, and “Deleting text boxes” on page 73 for more information.
AutoLayout text boxes

AutoLayout text boxes are automatically created when you select one of the slide layouts available in Impress.

4) Select an Impress slide layout using one of the following methods:
   – Open the Layouts section on the Properties deck of the Sidebar (Figure 51).
   – Go to Slide > Layout on the Menu bar to open a context menu (Figure 52).

5) Click on the text Click to add Title or Click to add Text. This text will automatically disappear replaced by a flashing text cursor. The Text Formatting toolbar (Figure 50 on page 67) automatically opens replacing the Line and Filling toolbar.

6) Type or paste your text into the AutoLayout text box and, if necessary, format the text to your requirements using the information in this chapter.

7) If necessary, copy, resize and/or reposition the AutoLayout text box using the information in this chapter.

8) Click outside the AutoLayout text box to deselect it.
Creating text boxes

1) Click on **Insert Text Box** or **Insert Vertical Text** on the Standard toolbar (Figure 48 on page 67) or the Drawing toolbar (Figure 49 on page 67). The Text Formatting toolbar (Figure 50 on page 67) automatically opens replacing the Line and Filling toolbar.

2) Create a text box using one of the following methods:
   - Click on the slide and a text box is automatically created with the text cursor flashing in the text box. This text box will increase in width as you enter text in a single line and its height will not change. To create multiple lines and increase the height, press the `Enter` key to create a new single line paragraph.
   - Click and drag the cursor to set the width of the text box. As you enter text, the height of a text box will automatically increase as text wraps, creating a multiple line text box.

3) Type or paste your text in the text box.

4) Click outside the text box to deselect it.

**Note**

If you are using a vertical text box, it is the height that will increase as a single line when you enter text. If you click and drag using vertical text box, you set the height of the text box and the width of the text box automatically increases creating multiple vertical lines.

Moving text boxes

1) Click in the text box to select it so that the border is displayed indicating that the text box is in edit mode.

2) Move the cursor over the highlighted border and the cursor changes shape to the move cursor for your operating system (for example, a hand).

3) When the move cursor appears, click once on the border to display the selection handles.

4) Click and hold on the border, then drag the cursor to move the text box. A dashed outline of the text box shows where your text box will be placed as shown in Figure.

5) Release the mouse button when the text box is in the desired position.

6) Click outside the text box to cancel edit mode.

**Note**

Do not click on a selection handle as this will not move the text box, but resize the text box.

Resizing text boxes

1) Click in the text box to select it so that the border is displayed indicating that the text box is in edit mode.

2) Move the cursor over the highlighted border and click once on the border to display the selection handles.
3) Move the cursor over a selection handle and the cursor changes shape indicating the
direction the text box will be resized. Click and hold as you resize the text box, a dashed
outline appears indicating the new size of the text box as shown in Figure 54. The selection
handles are used to resize the text box as follows:

- Corner handles change the width and height of the text box simultaneously.
- Top and bottom selection handles change the height of the text box.
- Right and left selection handles change the width of the text box.

4) Release the mouse button when the text box is at the desired size.

5) Click outside the text box to cancel edit mode.

**Note**

To maintain the proportions of a text box while resizing, press and hold the *Shift* key,
then click and drag a selection handle. Make sure to release the mouse button
before releasing the *Shift* key.
The Text dialog (Figure 55) provides options that allow you to position text within an AutoLayout text box or a text box.

1) Select a text box so that the border and selection handles are displayed.
2) Right click in the text box and select Text from the context menu to open the Text dialog.
3) Select the various options on the Text page to position your text within the text box.
4) Click OK to save your changes and close the dialog.
5) Click outside the text box to deselect it.

The options in the Text dialog are as follows:

- **Drawing Object Text**
  - *Fit width to text* – width of the text box is automatically adjusted to the width of the text.
  - *Fit height to text* – height of the text box is automatically adjusted to the height of the text.
  - *Fit to frame* – the text width and height is adjusted to the width and height of the text box.

- **Spacing to Borders** – creates margins around the text within the text box.

- **Text Anchor** – sets the anchor point for the text within the text box. When the *Full width* option is selected, the text is automatically positioned in the center of the text box.

Note

**Text Animation** in the Text dialog sets the text animation effects and these are explained in Chapter 9, Slide Shows.
For more accurate control over the size and position of an AutoLayout text box or a text box, use the Position and Size dialog (Figure 56) instead of using the mouse.

1) Click in the text box to select it so that the border is displayed indicating that the text box is in edit mode.

2) Open the Position and Size dialog using one of the following methods:
   - Go to Format > Object and Shape > Position and Size on the main menu bar.
   - Right-click on the text box and select Position and Size from the context menu.
   - Use the keyboard shortcut F4.

3) Select the various options on the Position and Size page to position the text box.

4) Click OK to save your changes to the text box and close the Position and Size dialog.

5) Click outside the text box to cancel edit mode.

The options in the Position and Size page are as follows:

- **Position**
  - *Position X* (horizontal) and *Position Y* (vertical) – specify position of the text box. The position values of the text box represent the distance of the Base point to the top left corner of the slide.
  - *Base point* – position the text box by selecting one of the nine available positions. By default, the Base point is the top left corner of the text box.

- **Size**
  - *Width* and *Height* – specify size of the text box. To maintain the width/height ratio of the text box, select Keep ratio. The size values represent the distance of the Base point relative to the top left corner of the slide.
Position and Size on Sidebar

For more accurate control over the size and position of a text box, the Position and Size section in the Properties deck on the Sidebar (Figure 57) can also be used. However, there are fewer options available in the Position and Size section on the Sidebar than in the Position and Size dialog.

1) Click in the text box to select it so that the border is displayed indicating that the text box is in edit mode.

2) Click on Properties on the Sidebar to open the Properties deck, then click on Position and Size to open the section.

3) Specify measurement values in the Position X (horizontal) and Position Y (vertical) boxes to position of the text box on the slide. The position values of the text box represent the distance between the top left of text box to the top left corner of the slide.

4) Specify measurement values in the Width and Height boxes to adjust the size of the text box. To maintain the width/height ratio of the text box, select Keep ratio.

5) When satisfied with your changes, click outside the text box to cancel edit mode.

Deleting text boxes

1) Click in the text box to select it so that the border and selection handles are displayed indicating that the text box is in edit mode.
2) Press the *Delete* or *Backspace* key to delete the text box.

**Tip**

If you have more than one text box to delete, it can be quicker to drag a selection marquee around the text boxes and then press the *Delete* or *Backspace* key. Take care to avoid selecting and accidentally deleting any other text boxes or shapes you want to keep.

Inserting text

Pasting text

You can insert text into an AutoLayout or normal text box by copying it from another document and pasting it into Impress. However, the text will probably not match the formatting of the surrounding text or that of the other slides in the presentation. This may be what you want on some occasions. However, you may want to make sure that the presentation style is consistent and does not become a patchwork of different styles, font types, bullet points, and so on.

**Unformatted text**

It is good practice to paste text without formatting and apply the formatting later reducing the risk of errors in your presentation.

1) Highlight and copy the text in another document or slide.

2) Create a text box on your slide and make sure the text cursor is flashing in the text box. See “AutoLayout text boxes” on page 68 or “Creating text boxes” on page 69 for more information.

3) Paste unformatted text into the text box using one of the following methods:

   – Go to **Edit > Paste Special > Paste Unformatted Text** on the main menu bar.
   – Click on the small downward arrow ▼ to the right of the **Paste** tool on the Standard toolbar (Figure 48 on page 67) and select **Unformatted Text** from the context menu.
   – Use the keyboard shortcut **Ctrl+Shift+V** and select **Unformatted text** from the dialog that opens.
   – Use the keyboard shortcut **Ctrl+Alt+Shift+V** and unformatted text is pasted into the text box.

   Text is pasted at the cursor position in the text box formatted using the Default Drawing Style or the Presentation Style, if text was pasted into an AutoLayout text box.

4) Format the text to your requirements using the tools on the Text Formatting toolbar (Figure 50 on page 67) or the options in **Format** on the main menu bar. Alternatively and for text boxes only, apply a Drawing Style to the text. See Chapter 2, Master Slides, Styles and Templates for information.

**Note**

You cannot change a Presentation Style used in AutoLayout text boxes by selecting another Presentation Style. Make sure the AutoLayout text box uses the Presentation Style you want to use. See Chapter 2, Master Slides, Styles and Templates for information. Outline levels and outline styles are changed using the *Tab* key or *Shift+Tab* key combination.
**Formatted text**

Pasting formatted text into a text box or AutoLayout text box will overwrite any formatting and replace the text box style.

1) Highlight and copy the text in another document or slide.

2) Create a text box on your slide and make sure the text cursor is flashing in the text box. See “AutoLayout text boxes” on page 68 or “Creating text boxes” on page 69 for more information.

3) Paste formatted text into the text box. Text is pasted at the cursor position in the text box and the text formatting of the pasted text overwrites any style formatting of the text box.

4) If necessary, format the text to your requirements using the various tools on the Text Formatting toolbar or using the options available in **Format** on the Menu bar.

5) To clear any formatting of the pasted text and use the text box style, go to **Format > Clear Direct Formatting** on the Menu bar. See Chapter 2, Master Slides, Styles and Templates for more information.

**Note**

You can create your own Drawing Styles in Impress. These Drawing Styles are only available for the Impress presentation which you have created and saved them. You can also create templates that include any Drawing Styles that you have created.

**Inserting special characters**

You can insert special characters into your text, such as copyright, math, geometric, or monetary symbols, or characters from another language.

1) Click at the position where you want to insert the special character into the text.

2) Go to **Insert > Special Character** on the Menu bar to open the Special Characters dialog (Figure 58).

3) Select the font and character subset from the **Font** and **Subset** drop-down menus.

![Special Characters dialog](image)

*Figure 58: Special Characters dialog*
4) Select the special character you want to insert. A preview of the selected character appears in the preview box at the top of the dialog and the special character name is displayed below the preview box.

Alternatively, select the special character from the display of Recent Characters or Favorite Characters. A preview of the selected character appears in the preview box at the top of the dialog and the special character name is displayed below the preview box.

5) Click Insert to close the dialog and insert the special character at the cursor position in the text.

Alternatively, double-click on the special character you want to insert. This closes the dialog and inserts the special character at the cursor position in the text.

6) If you use a special character frequently, click on Add to Favorites and the special character is added to the display of Favorite Characters.

Inserting formatting marks

Formatting marks are a type of special character that you can insert into your text to correct the formatting. For example, it may not be desirable for words that are separated by a space or a hyphen to span over two lines. The solution is to insert a non-breaking space or non-breaking hyphen.

1) Click at the position where you want to insert the formatting mark into the text.

2) Go to Insert > Formatting Mark on the Menu bar to open a context menu (Figure 59).

3) From the options displayed in the context menu, select the formatting mark you require. It is inserted into the text at the cursor position.

The formatting marks that are available in Impress are as follows:

- **Non-breaking space** – inserts a space that will keep two adjacent words or characters together on line breaks (keyboard shortcut Ctrl+Shift+Space).

- **Non-breaking hyphen** – inserts a hyphen that will keep two adjacent characters together on line breaks (keyboard shortcut Ctrl+Shift+Hyphen).

- **Soft hyphen** – inserts an invisible hyphen within a word that will appear and create a line break once it becomes the last character in a line (keyboard shortcut Ctrl+Hyphen).

- **Narrow no break space** – inserts a narrow space that will keep two adjacent words or characters together on line breaks. A narrow space has a width that is about 70% of a normal space. It is used to represent the narrow space occurring around punctuation characters and can also be used as a numeric group separator.

- **No-width optional break** – inserts an invisible space within a word that will insert a line break once it becomes the last character in a line (keyboard shortcut Ctrl+Forward Slash).

- **No-width no break** – inserts an invisible space within a word that will keep the word together at the end of a line.
• Left-to-right mark – inserts a text direction mark that affects the text direction of any text following the mark. Only available when Complex text layout (CTL) is enabled.

• Right-to-left mark – inserts a text direction mark that affects the text direction of any text following the mark. Only available when Complex text layout (CTL) is enabled.

Formatting text

Text formatting can give a presentation a consistent look and a dynamic feel. This will enhance the understanding of your audience by preventing any distracting elements in your presentation. Text formatting can be applied (for example color, alignment, bullet types) to characters, words, sentences, paragraphs, and lists.

Quick font resizing

You can quickly increase or decrease font size of selected text using the tools Increase Font Size (Ctrl+] ) and Decrease Font Size (Ctrl+[ ) on the Text Formatting toolbar (Figure 50 on page 67) The amount by which the font size changes depends on the standard sizes available for the font in use.

Note

AutoLayout text boxes automatically adjust font size of any text inserted into the AutoLayout text box. For example, inserting a long piece of text into an AutoLayout text box, the font size may decrease in size to fit into the box.

Selecting text

Text must be selected before it can be formatted using one of the following methods. Any formatting changes will apply only to the selected text.

• To format all the text in a text box, click once on the border of the text box to display the selection handles. Any formatting changes will apply to all text in the text box.

• To format only part of the text, select text using one of the following methods:
  – Click in the text and drag the cursor over the text to highlight the text.
  – Double-click on text to select a complete word or triple click to select a whole paragraph.
  – Click in the text, then press and hold the Shift key and use the keyboard arrow keys to extend to select text.
Using styles

When you enter text, either in an AutoLayout text box or in a text box, it is formatted with a set of predefined attributes known as a style. The style used depends on the type of text box being used. For more information on using, modifying and updating styles, see Chapter 2, Master Slides, Styles and Templates.

Sometimes it is quicker and more efficient to apply manual or direct formatting. However, in situations where you need to perform the same formatting to many different parts of a presentation, the use of styles is recommended. This will create a consistent look to your presentation and reduce the possibility of any errors. Impress has two categories of styles – Presentation Styles and Drawing Styles.

**Presentation Styles**

Presentation styles are used in AutoLayout text boxes, master slide backgrounds, and master slide background objects.

The style applied to the text depends on the type of AutoLayout text box. These styles cannot be deleted, renamed or changed for another presentation style if you want to change the formatting of the text. For example, to change an outline style for another outline style, you have to change the outline level by using the Tab key or Shift+Tab key combination.

Presentation styles can be modified to change the text formatting or updated to change the style after formatting the text.

**Drawing Styles**

Drawing styles are used for text in text boxes and any graphic object you place on a slide. For information on formatting graphic objects, see Chapter 6, Formatting Graphic Objects.

When you enter text into a text box, the Default Drawing Style is applied to the text. You can change this style by selecting another style from the text group of Drawing Styles.

These styles cannot be deleted or renamed, but can be modified to change the text formatting or updated to change the style after formatting the text. You can also create custom drawing styles that are only available for the presentation being created.

**Note**

Unlike LibreOffice Writer, where it is recommended to use styles whenever possible, manual or direct formatting has to be used more often in LibreOffice Impress. The reason being is that Presentation Styles in Impress are restricted. For example, you cannot have two different Outline 1 levels using different types of bullet points for the same outline level. Also, the lack of support for character styles forces the use of manual or direct formatting to format sections of text when necessary.

**Text formatting**

Direct or manual text formatting can be applied directly to characters, words, sentences, and paragraphs. Direct formatting overrides any formatting that has been applied to text when using styles.
1) Select the text you want to format, see “Selecting text” on page 77 for more information.

2) Format text using one of the following methods. Formatting applied to text is immediate.
   - Various formatting tools on the Text Formatting toolbar (Figure 50 on page 67).
   - Go to Format on the Menu bar. Selecting a formatting option will open a context menu or dialog where you can select further formatting options to apply to your text.
   - Use the options available in the Paragraph and Character dialogs.
   - Use the options available in the Paragraph and Character sections in the Properties deck on the Sidebar.

3) Click outside the text box to deselect the text.

**Figure 60: Paragraph dialog - Indents and Spacing page**

**Paragraph dialog**

The Paragraph dialog (Figure 60) is used to format paragraphs of text.

1) Select text in a paragraph or the whole paragraph that you want to format.

2) Format text using one of the following methods and open the Paragraph dialog. Any formatting applied to a paragraph is immediate.
   - Right click on the selected text and select Paragraph from the context menu.
   - Go to **Format > Paragraph** on the Menu bar.

3) Use the various options available on the tabbed pages of the Paragraph dialog to format your text.

4) Click **OK** to save your changes and close the dialog.

5) Click outside the text box to deselect the text.

**Indents and spacing options**

The **Indents and Spacing** options page (Figure 60) in the Paragraph dialog has three main sections as follows:

- **Indent** – specifies the amount of space to leave between the left and the right page margins and the paragraph.
— **Before text** – enter the amount of space that you want to indent the paragraph from the page margin. If you want the paragraph to extend into the page margin, enter a negative number.

— **After text** – enter the amount of space that you want to indent the paragraph from the page margin. If you want the paragraph to extend into the page margin, enter a negative number.

— **First line** – indents the first line of a paragraph by the amount that you enter. To create a negative hanging indent enter a positive value for **Before text** and a negative value for **First line**. To create a positive hanging indent enter a positive value for **Before text** and a larger positive value for **First line**.

— **Automatic** – when selected, automatically indents a paragraph according to the font size and the line spacing. The setting value for **First line** is ignored.

**• Spacing** – specifies the amount of space to leave between paragraphs.

— **Above paragraph** – enter the amount of space that you want to leave above a paragraph.

— **Below paragraph** – enter the amount of space that you want to leave below a paragraph.

— **Don’t add space between paragraphs of the same style** – when selected, only the spacing below a paragraph is applied when the preceding and following paragraphs are of the same paragraph style.

**• Line spacing** – specifies the amount of space to leave between lines of text in a paragraph. The options available from the drop-down list are as follows:

— **Single** – applies single line spacing to a paragraph. This is the default setting.

— **1.15 Lines** – sets the line spacing to 1.15 lines.

— **1.5 Lines** – sets the line spacing to 1.5 lines.

— **Double** – sets the line spacing to two lines.

— **Proportional** – select this option and then enter a percentage value in the box, where 100% corresponds to single line spacing.

— **At Least** – sets the minimum line spacing to the value that you enter in the box. If you use different font sizes within a paragraph, the line spacing is automatically adjusted to the largest font size. If you prefer to have identical spacing for all lines, specify a value in that corresponds to the largest font size.

— **Leading** – sets the vertical space height that is inserted between two lines.

— **Fixed** – enter a fixed value to be used for line spacing.

---

**Tip**

Setting the line spacing to less than 100% is a good method to place a lot of text into a text box when space is limited. However, care must be taken as too small a value will make the text hard to read.

**Tip**

You can change the default unit of measurement in **Tools > Options > LibreOffice Impress > General** on the Menu bar.
Asian Typography options

The Asian Typography options page (Figure 61) is only available when Asian and Complex Text Layout (CTL) options are enabled in Tools > Options > Language Settings > Languages on the Menu bar. The Line Change options are as follows:

- **Apply list of forbidden characters to the beginning and end of lines** – prevents the characters in the list from starting or ending a line. The characters are relocated to either the previous line or the next line. To edit the list of restricted characters that start or end a line, go to Tools > Options > LibreOffice > Language Settings > Asian Layout on the Menu bar.

- **Allow hanging punctuation** – prevents commas and periods from breaking the line. Instead, these characters are added to the end of the line, even in the page margin.

- **Apply spacing between Asian and non-Asian text** – inserts a space between Asian and non-Asian characters.

![Figure 61: Paragraph dialog - Asian Typography page](image)

**Note**

To create tabs and use the same settings for tabs in more than one text box, it is recommended to modify, update or create a custom drawing style and apply the style to the text. See Chapter 2, Master Slides, Styles and Templates for more information.

Tab options

Use the Tabs options page (Figure 62) to determine the tab stops in an AutoLayout text box or text box as follow:

- **Position** – enter a measurement in the text box to set the position of a tab in a text box. Any tabs already created are listed in the preview box below the measurement setting.

- **Type** – determines the type of tab used.
  - **Left** – aligns the left edge of the text to the tab stop and extends the text to the right. If Asian language support is enabled in LibreOffice Preferences, this tab stop is called **Left/Top**.
– **Right** – aligns the right edge of the text to the tab stop and extends the text to the left of the tab stop. If Asian language support is enabled in LibreOffice Preferences, this tab stop is called **Right/Bottom**.
– **Center** – aligns the center of the text to the tab stop.
– **Decimal** – aligns the decimal point of a number to the center of the tab stop. The numbers to the left of the decimal point are aligned to the left of the tab. The numbers to the right of the decimal point are aligned to the right of the tab.
– **Character** – enter a character to use as a decimal separator when using decimal tabs.

**Fill character** – specifies the type of character inserted between the tab insertion point and the tab stop.
– **None** – no fill characters are inserted between the tab insertion point and the tab stop. It also removes any existing fill characters between the tab insertion point and the tab stop.
– **Dots**..... – inserts dots between the tab insertion point and the tab stop.
– **Dashes**---- – inserts dashes between the tab insertion point and the tab stop.
– **Line**______ – draws a line between the tab insertion point and the tab stop.
– **Character** – specify a character for insertion between the tab insertion point and the tab stop.

**Creating tabs**

1) Select the text box so that the selection handles on the text box border are displayed.
2) Right click on the selected text box and select **Paragraph** from the context menu or go to **Format > Paragraph** on the main menu bar to open the Paragraph dialog.
3) Click on **Tabs** to open the **Tabs** page in the Paragraph dialog (Figure 62 on page 81).
4) Enter the position measurement for the tab stop in the **Position** text box.
5) Select the type of tab from the options in **Type**.

**Note**

If you set the type to **Decimal**, the default character used is the character used for decimal points in your computer setup. If required, specify the character to be used as the decimal point in **Character** box.

6) Select the type of **Fill Character**. The fill character will be inserted between the tab insertion point and the tab stop.
7) Click on **New** to create the new tab stop in the text box. The new tab stop appears in the **Position** preview box.
8) Click **OK** to save your changes and close the dialog.
9) To use the new tab stop in more than one text paragraph in a text box or in another text box:
   – Modify or update the presentation or drawing style used for the text.
   – Create a custom drawing style and apply it to the text.

**Editing tabs**

1) Select the text box so that the selection handles on the text box border are displayed.
2) Right click on the selected text box and select **Paragraph** from the context menu or go to **Format > Paragraph** on the main menu bar to open the Paragraph dialog.

3) Click on **Tabs** to open the **Tabs** page in the Paragraph dialog.

4) Select the tab you want to edit in the **Position** preview box.

5) Select the **Type** and **Fill Character** you want to use for the selected tab stop.

6) Click **OK** to save your changes and close the dialog.

7) If necessary, update the style used for the text.

---

**Note**

To change the tab position, you have to delete the selected tab first, then create a new tab with the changes you require.

---

**Deleting tabs**

1) Select the text box so that the selection handles on the text box border are displayed.

2) Right click on the selected text box and select **Paragraph** from the context menu or go to **Format > Paragraph** on the main menu bar to open the Paragraph dialog.

3) Click on **Tabs** to open the **Tabs** page in the Paragraph dialog (Figure 62).

4) Select the tab you want to delete in the **Position** preview box.

5) Click on **Delete** to delete the selected tab.

    Alternatively, click **Delete All** to delete all of the tab stops that are set for the selected text box.

6) Click **OK** to save your changes and close the dialog.

---

**Deleting tabs**

1) Select the text box so that the selection handles on the text box border are displayed.

2) Right click on the selected text box and select **Paragraph** from the context menu or go to **Format > Paragraph** on the main menu bar to open the Paragraph dialog.

3) Click on **Tabs** to open the **Tabs** page in the Paragraph dialog.

4) Select the tab you want to delete in the **Position** preview box.

5) Click on **Delete** to delete the selected tab, or click **Delete All** to delete all of the tab stops that are set for the selected text box.

6) Click **OK** to save your changes and close the dialog.

---

**Alignment options**

Use the **Alignment** options page (Figure 63) to determine the text alignment in text boxes as follows.

- **Options**
  - **Left** – aligns text to the left margin of the text box. If Asian language support is enabled, this option is named **Left/Top**.
  - **Right** – aligns text to the right margin of the text box. If Asian language support is enabled, this option is named **Right/Bottom**.
  - **Center** – aligns the text to the center of in the text box.
  - **Justified** – aligns the text to the left and to the right margins of the text box.
• **Text-to-text**
  
  – **Alignment** – provides alignment options for oversized or undersized characters in the text relative to the rest of the text.

![Alignment options](image)

*Figure 63: Paragraph dialog - Alignment page*

• **Properties**
  
  – **Text direction** – specifies the text direction for text that uses **Complex Text Layout** (CTL) and is only available if complex text layout support is enabled.

• **Preview field** – displays a preview of how the text will appear in the text box.

### Sidebar Paragraph section

An alternative method of formatting paragraphs is to use the *Paragraph* section (Figure ) in the Properties deck on the Sidebar. The formatting options available in the *Paragraph* section are limited, but are similar in use to the formatting options available in the various pages of the Paragraph dialog.

1) Select a text box so that the selection handles on the text box border are displayed.

2) On the Sidebar, click on **Properties** to open the Properties deck.

3) Click on **Paragraph** to open the *Paragraph* section.

4) Format the text using the various tools available in the *Paragraph* section. See “Paragraph dialog” on page 79 for more information on formatting options.

5) If necessary, click on **More Options** on the right of the title bar to open the Paragraph dialog to format text.

The text formatting options available in the *Paragraph* section in the Properties deck on the Sidebar are as follows:

• **Align Left, Align Center, Align Right, Align Justified** – determines how text is aligned to the text box margins. These tools are also available on the Text Formatting toolbar (Figure 50 on page 67).

• **Left-To-Right, Right-To-Left** – only available when **Asian** and **Complex Text Layout** (CTL) options have been selected in **Tools > Options > Language Settings > Languages**. These tools are also available on the Text Formatting toolbar.
• **Align Top, Center Vertically, Align Bottom** – aligns text to the top, center or bottom of a text box. This is similar to vertical alignment of data within a table cell. These tools are also available on the Text Formatting toolbar.

![Figure 64: Paragraph section in Properties deck on Sidebar](image)

• **Increase Paragraph Spacing, Decrease Paragraph Spacing** – increases or decreases the spacing above and below the selected text. These tools are also available on the Text Formatting toolbar.

• **Above Paragraph Spacing, Below Paragraph Spacing** – increases or decreases the spacing either above or below selected text. Enter the amount of spacing you require in the text box.

• **Set Line Spacing** – adjust the spacing between the lines of selected text. Click on the small triangle to the right of the icon and select the type of line spacing you require from the drop-down list. This tool is also available on the Text Formatting toolbar.

• **Increase Indent, Decrease Indent** – each click increases or decreases the indent level of selected text by the default value for Impress. To specify your own indent measurement, enter a value in the Before text, After text or First line boxes.

• **Hanging Indent** – sets a different indent for the first line of text to the indent set for a whole paragraph of text as follows:
  - Enter a negative value in the First line box to reduce the indent of the first line of text.
  - Enter a positive value in the First line box to increase the indent of the first line of text.
  - First click sets a negative hanging indent and a second click sets a positive hanging indent.
  - This tool is only active when a Before text indent has been set for the paragraph of text.
  - To remove a hanging indent, set the value in the First line box to zero.

**Character formatting**

Direct or manual character formatting can be applied directly to individual characters and words. Direct character formatting will override any formatting that has been applied using direct text formatting and presentation or drawing styles.
1) Select the characters you want to format, see “Selecting text” on page 77 for more information.

2) Format characters using one of the following methods. Formatting applied to character(s) is immediate.

   – Various formatting tools on the Text Formatting toolbar (Figure 50 on page 67).
   – Go to Format on the Menu bar. Selecting a formatting option will either open a context menu or dialog where you can select further formatting options to apply to your text.
   – Use the options available in the Character dialog.
   – Use the options available in the Character section on the Sidebar.

3) Click outside the text box to deselect the text.

**Character dialog**

The Character dialog (Figure 65) is used to format individual characters.

1) Open the Character dialog using one of the following methods:

   – Right click on the selected text box and select Character from the context menu, then select the characters you want to format.
   – Select the characters you want to format, then go to Format > Character on the Menu bar.

2) Use the various options available on the tabbed pages of the Character dialog to format the selected characters.

3) Click OK to save your changes and close the dialog.

4) Click outside the text box to deselect the text.

**Fonts**

Use the Font page (Figure 65) in the Character dialog to select the font family, typeface (*Italic*, *Bold*, and so on), size, and language. A sample of the font is displayed in the preview box in the lower part of the dialog.

If support for Asian language and Complex Text Layout (CTL) has been enabled in Tools > Options > Language Settings > Languages, then formatting options are also available for Asian and CTL fonts in the Character dialog.

---

**Note**

The number of typefaces available will change depending on the font family that is selected.

**Tip**

When creating a presentation in multiple languages, you can use the language setting to create styles that only differ in the language in formatting attributes. This allows you to easily check spelling of all of the presentation contents without affecting appearance.
Font Effects

The options on the Font Effects page (Figure 66) in the Character dialog to apply font color, text decoration and effects to the selected text or characters. A sample of the font effect is displayed in the preview box in the lower part of the dialog.

- **Font Color**
  - Font color – sets the color for the selected text. Select a color from one of the available palettes. If Automatic is selected, the text color is set to black for light backgrounds and to white for dark backgrounds.
- **Transparency** – sets the transparency of the selected text. Enter a value in the text box. 100% entirely transparent, 0% no transparency.

- **Text Decoration**
  - **Overlining** – select the overlining style from the drop down list and the overlining color from one of the available palettes. If **Automatic** is selected, the text color is set to black for light backgrounds and to white for dark backgrounds.
  - **Strikethrough** – select a strikethrough style for the selected text.
  - **Underlining** – select the underlining style from the drop down list and the underlining color from one of the available palettes. If **Automatic** is selected, the text color is set to black for light backgrounds and to white for dark backgrounds.
  - **Individual words** – when selected, any overlining or underlining is applied to words only and spaces are ignored.

- **Effects**
  - **Case** – select a capitalization effect from the drop down list.
  - **Relief** – select a relief effect for the selected text. Embossed relief makes the characters appear as if they are raised above the page. Engraved relief makes the characters appear as if they are pressed into the page.
  - **Emphasis mark** – select a character to display over or below the entire length of the selected text.
  - **Position** – specifies where to display the emphasis marks. Either above the text or below the text.

![Figure 67: Character dialog - Position page](image)

**Position**
The options on the **Position** page (Figure 67) allows you to set the position, scaling and spacing of selected text.

- **Position** – sets the subscript or superscript options for a character.
  - **Normal** – removes superscript or subscript formatting.
  - **Superscript** – reduces the font size of the selected text and raises the text above the baseline.
  - **Subscript** – reduces the font size of the selected text and lowers the text below the baseline.
  - **Raise/lower by** – enter the amount to raise or to lower the selected text in relation to the baseline. 100% is equal to the height of the font.
  - **Relative font size** – enter the amount to reduce the font size of the selected text.
  - **Automatic** – sets the amount by which the selected text is automatically raised or lowered in relation to the baseline.
• **Scaling**
  – *Scale width* – enter a percentage of the font width to horizontally stretch or compress the selected text.

• **Spacing** – specifies the spacing between individual characters.
  – *Character spacing* – specifies the spacing between the characters of the selected text. Enter the amount to expand or condense the text in the text box. To increase spacing, set a positive value; to reduce spacing, set a negative value.
  – *Pair kerning* – automatically adjusts the character spacing for specific letter combinations. Kerning is only available for certain font types and requires printer support for this option.

**Highlighting**

The options on the **Highlighting** page (Figure 68) allows you to highlight text so that the characters are different color to the rest of the text in the text box.

• **Colors** – select a highlight color from one of the available palettes.

• **Active** – shows the present color of the text and the Red, Green and Blue (RGB) settings for the present color.

• **New** – shows the highlight color of the text that has been selected in **Colors** and the Red, Green and Blue (RGB) settings for the new color. The color can also be selected by changing the values in the RGB boxes or using the Pick a Color dialog when you click on **Pick**.

![Figure 68: Character dialog - Highlighting page](image)

**Sidebar Character section**

An alternative method of formatting text is to use the **Character** section (Figure 69) in the Properties deck on the Sidebar. The formatting options available in the **Character** section are limited, but are similar in use to the formatting options available in the various pages of the Character dialog.

1) Select a text box so that the selection handles on the text box border are displayed.

2) On the Sidebar, click on **Properties** to open the Properties deck.

3) Click on **Character** to open the **Character** section.
4) Format the text using the various tools available in the Character section. See “Character dialog” on page 86 for more information on formatting options.

5) If necessary, click on More Options on the right of the title bar to open the Character dialog to format text.

The text formatting options available in the Character section in the Properties deck on the Sidebar are as follows:

- **Font Name** and **Font Size** – select the font family and size that you want to use from the drop-down lists. These tools are also available on the Text Formatting toolbar.
- **Bold** and **Italic** – applies a bold or italic typeface to the selected text. These tools are also available on the Text Formatting toolbar.
- **Underline** – underlines the selected text. Click on the small triangle ▼ to the right and select the type of underlining you want to use from the drop-down list. Click More Options at the bottom of this drop-down list to open the Character dialog.
- **Strikethrough** – draws a line through the selected text. This tool is also available on the Text Formatting toolbar.
- **Shadow** – adds a shadow to the selected text. This tool is also available on the Text Formatting toolbar.
- **Increase Font Size** and **Decrease Font Size** – each click increases or reduces the size of the selected characters by the same amount. Actual size depends on your computer setup. These tools are also available on the Text Formatting toolbar.

- **Font Color** and **Highlight Color** – click on the small triangle ▼ to the right of these icons and select a color from the available palettes. These tools are also available on the Text Formatting toolbar.

- **Clear Direct Formatting** – removes any direct formatting and formatting by character styles from the selected text. Direct formatting is formatting that you applied without using styles: for example, setting bold typeface by clicking on Bold. This tool is also available on the Text Formatting toolbar.

- **Set Character Spacing** – click on the small triangle ▼ to the right of this tool and select the type of spacing between characters required. Spacing between characters is also know as kerning. You can also set a custom value for character spacing.

- **Superscript** – reduces the font size of the selected text and raises the text above the baseline. This tool is also available on the Text Formatting toolbar.

![Figure 69: Character section in Properties deck on Sidebar](image-url)
• **Subscript** – reduces the font size of the selected text and lowers the text below the baseline. This tool is also available on the Text Formatting toolbar.

### Creating lists

The procedure to create a bulleted or numbered list varies depending on the type of text box used. The tools to manage and format a list are the same.

### AutoLayout text boxes

In AutoLayout text boxes and by default, the outline styles available are bulleted lists. An example of these outline styles is shown in Figure 70. These outline styles are presentation styles and cannot be deleted, but can be modified or updated to your requirements. See Chapter 2, Master Slides, Styles and Templates for more information on styles.

By default, the list created in an AutoLayout text box is a bulleted list. To customize the list appearance or to change from bulleted to numbered or numbered to bulleted, see “Formatting lists” on page 94 for more information.

1) Create a new presentation and go to **View > Normal** on the Menu bar to make sure you are in normal view.

2) Select a layout for the slide using one of the following methods:
   - Right click in a blank area on the slide and select a layout type from the context menu that opens.
   - Go to **Slide > Layout** on the main menu bar and select a layout from the drop-down list.
   - Select a layout from the layouts displayed in the **Layouts** section in the Properties deck on the Sidebar.

3) Click on the text **Click to add Text** and start typing your first list item.

4) Click on **Enter** when you have finished typing the first list point creating a new list point.
5) Use the keyboard combination Shift+Enter to start a new line without creating a new list point. This new line will have the same indentation as the text in the list point.

6) To demote the outline level of a list point, use one of the following methods:
   - Click on the Tab key.
   - Use the keyboard shortcut Shift+Alt+Right Arrow.
   - Click on Demote on the Outline toolbar (Figure 71).
   - Click on Demote on the Lists section in the Properties deck on the Sidebar.
   - Go to Format > Lists on the Menu bar and select Demote from the context menu.

7) To promote the outline level of a list point, use one of the following methods:
   - Use the keyboard shortcut Shift+Tab.
   - Use the keyboard shortcut Shift+Alt+Left Arrow.
   - Click on Promote on the Outline toolbar.
   - Click on Promote on the Lists section in the Properties deck on the Sidebar.
   - Go to Format > Lists on the Menu bar and select Promote from the context menu.

8) To move a list point lower in the list order without changing the outline level, use one of the following methods:
   - Click on Move Down on the Outline toolbar.
   - Click on Move Down on the Lists section in the Properties deck on the Sidebar.
   - Go to Format > Lists on the Menu bar and select Move Down from the context menu.
   - Use the keyboard shortcut Shift+Alt+Down Arrow.

9) To move a list point higher in the list order without changing the outline level, use one of the following methods:
   - Click on Move Up on the Outline toolbar.
   - Click on Move Up on the Lists section in the Properties deck on the Sidebar.
   - Go to Format > Lists on the Menu bar and select Move Up from the context menu.
   - Use the keyboard shortcut Shift+Alt+Up Arrow.

10) To change the type and appearance of your list, see “Formatting lists” on page 94 for information.

**Note**

Do not try to change the outline style of a list point by selecting the list point and then selecting another outline style as you would in Writer. In Impress it is not possible to change presentation styles used for outline levels in this way.

**Note**

In AutoLayout text boxes, promoting or demoting an item in a list changes the presentation style to match the outline level. For example, second outline level corresponds to Outline 2 style, third outline level to Outline 3 style, and so on. This change of outline level may change the formatting of the list point (for example font size, bullet type, and so on).
Text boxes

1) Create a text box on a slide and make sure the cursor is flashing in the text box. See “Creating text boxes” on page 69 on how to create a text box.

2) Create a list using one of the following methods:
   – Click on Toggle Bulleted List or Toggle Numbered List in the Text Formatting toolbar (Figure 50 on page 67).
   – Click on Toggle Bulleted List or Toggle Numbered List in the Lists section in the Properties deck on the Sidebar (Figure 73 on page 96).
   – Go to Format > Lists on the main menu bar and select Bullet List or Numbered List from the context menu.

3) Type the text and click on Enter to start a new list point.

4) Use the keyboard combination Shift+Enter to start a new line without creating a new list point. The new line will have the same indentation as the list point.

5) To increase the indent level of a list point, use one of the following methods:
   – Click on the Tab key.
   – Click on the Demote icon on the Outline toolbar (Figure 71 on page 91).
   – Click on the Demote icon on the Lists section in the Properties deck on the Sidebar.
   – Go to Format > Lists on the main menu bar and select Demote from the context menu.

6) To decrease the indent level of a list point, use one of the following methods:
   – Use the keyboard shortcut Shift+Tab.
   – Click on the Promote icon on the Outline toolbar.
   – Click on the Promote icon on the Lists section in the Properties deck on the Sidebar.
   – Go to Format > Lists on the main menu bar and select Promote from the context menu.

7) To move a list point lower in the list order without changing the indent level, use one of the following methods:
   – Click on the Move Down icon on the Outline toolbar.
   – Click on the Move Down icon on the Lists section in the Properties deck on the Sidebar.
   – Go to Format > Lists on the main menu bar and select Move Down from the context menu.
   – Use the keyboard shortcut Shift+Ctrl+Down Arrow.

8) To move a list point higher in the list order without changing the indent level, use one of the following methods:
   – Click on the Move Up icon on the Outline toolbar.
   – Click on the Move Up icon on the Lists section in the Properties deck on the Sidebar.
   – Go to Format > Lists on the main menu bar and select Move Up from the context menu.
   – Use the keyboard shortcut Shift+Ctrl+Up Arrow.
9) To change the type and appearance of your list, see “Formatting lists” on page 94 for information.

**Formatting lists**

You can format the appearance of a list as follows:

- Change the list type, properties, size, position, and scope for the entire list or for a single list point using the Bullets and Numbering dialog (Figure 72).
- Change the list type, promote or demote a list point, or move a list point up or down in the list order using the Lists section in the Properties deck on the Sidebar (Figure 73 on page 96).
- Promote or demote a list point, or move a list point up or down in the list order using the Outline toolbar (Figure 71 on page 91).
- Change the list type using the tools on the Text Formatting toolbar (Figure 50 on page 67).
- Format the text used in the list. See “Formatting text” on page 77 for more information.

The Bullets and Numbering dialog (Figure 72) gives you greater control of how your list will look on your slide.

- **Level** – select the level(s) that you want to define the formatting options for. The selected level(s) is highlighted in the preview.
- **Properties**
  - **Type** – select the numbering style for the list indicator from the drop down list. When Graphic is selected as Type, select an image from a file or the Gallery.
  - **Color** – select a color for the list indicator from the palettes available.
  - **Start at** – enter a new starting number for the current level. Default figure is 1.

![Figure 72: Bullets and Numbering dialog](image_url)
• **Separator**
  - **Before** – enter a character or text to display in front of the number in the list. For example, to create a list that uses the style "•", enter "|" in this box.
  - **After** – enter a character or text to display behind the number in the list. For example, to create a list that uses the style "1."), enter ")" in this box.

• **Size**
  - **Rel. Size** – enter a percentage amount to resize the list indicator in relation to the font height of the current list.
  - **Width** – only available when Graphic is selected as Type. Enter a width for the graphic.
  - **Height** – only available when Graphic is selected as Type. Enter a height for the graphic.
  - **Keep ratio** – only available when Graphic is selected as Type. Maintains the size proportions of the graphic.

• **Position**
  - **Indent** – set the indent measurement for the list point(s).
  - **Width** – set the indent measurement of the text from the list indicator. For example, this makes sure there is enough room for the list indicator when large numbers used.
  - **Relative** – select this option to measure the indent value relative to the previous level and not from the margin.
  - **Alignment** – sets the paragraph alignment for the list indicator.

• **Scope**
  - **Slide** – applies the changes to the slide.
  - **Selection** – applies the changes only to the selected text.
  - **Apply to Master** – applies the changes to the master slide being used.

**Bullets and Numbering dialog**

The Bullets and Numbering dialog (Figure 72) can be opened using one of the following methods after selecting text or a text box:

- Go to **Format > Bullets and Numbering** on the Menu bar.
- Right click on the selected text and select **Bullets and Numbering** from the context menu.
- Click on **More Options** on the right side of **Lists** section in the Properties deck on the Sidebar.
- Click on **More Bullets** or **More Numbering** after clicking on the down pointing arrow ▼ on the right of **Toggle Bulleted List** or **Toggle Numbered List** on the **Lists** section in the Properties deck on the Sidebar.
- Click on **More Bullets** or **More Numbering** after clicking on the down pointing arrow ▼ on the right of **Toggle Bulleted List** or **Toggle Numbered List** on the Text Formatting toolbar (Figure 50 on page 67).

**Sidebar Lists section**

The **Lists** section (Figure 73) is opened by clicking on **Properties** on the Sidebar and then selecting **Lists**. Text or a text box must be selected for the **Lists** options to become available.
• **Toggle Bulleted List** – this tool is also available on the Text Formatting toolbar (Figure 50 on page 67) and is accessed using one of the following methods:
  – After selecting text, click on this icon to create a bulleted list. Click again to revert back to normal text.
  – Click on the down pointing arrow ▼ on the right to open a selection of bulleted list types (Figure 74).
• Click on **More Bullets** (Figure 74) to open the Bullets and Numbering dialog.
• **Toggle Numbered List** – this tool is also available on the Text Formatting toolbar and is accessed using one of the following methods:
  – After selecting text, click on this icon to create a numbered list. Click again to revert back to normal text.
  – Click on the down pointing arrow ▼ on the right to open a selection of numbered list types (Figure 75).
  – Click on **More Numbering** (Figure 75) to open the Bullets and Numbering dialog.

![Figure 73: Lists section in Properties deck on Sidebar](image1)

![Figure 74: More bullet types](image2)
• **Demote** – this tool is also available on the Outline toolbar (Figure 71 on page 91). Click on this tool to increase the indent level of a list point.

• **Promote** – this tool is also available on the Outline toolbar. Click on this tool to decrease the indent level of a list point.

• **Move Down** – this tool is also available on the Outline toolbar. Click on this tool move a list point lower in the list order without changing the indent level.

• **Move Up** – this tool is also available on the Outline toolbar. Click on this tool move a list point higher in the list order without changing the indent level.

• **More Options** – click on this icon in the Lists section title bar to open the Bullets and Numbering dialog for access to a more detailed selection of options for formatting lists.

---

### Using tables

Tables are a powerful mechanism to convey structured information quickly when used in a presentation. You can create tables directly in your presentation eliminating the need to embed a Calc spreadsheet or a Writer text table. However, in some circumstances, it makes sense to embed a table into a presentation, especially when you require greater functionality in the table. The tables provided by Impress do have a limited functionality.

Several predefined table designs are available in the Table Design section in the Properties deck on the Sidebar (Figure 76). The Sidebar Table Design section is only available when a table is selected.
When working with tables in Impress, the Table toolbar (Figure 77) automatically opens providing tools for creating and formatting your table.

**Inserting tables**

When inserting a table into a slide, it is useful to know the number of rows and columns required as well as an approximate idea of the table will look. The table can then be formatted after creation should it be necessary.

**Note**

When a table is inserted into a slide, the table is created inside a text box. This text box is the same size as the rows and columns of the table.

**Insert Table dialog**

1) Select the slide which will contain the table and, if necessary, modify the slide layout to create space for the table.

2) Go to **Insert > Table** on the Menu bar to open the Insert Table dialog (Figure 78).

3) Specify the **Number of columns** and **Number of rows** in the text boxes.

4) Click **OK** to insert the table in the slide and close the dialog.

**Table graphic**

1) Select the slide which will contain the table and, if necessary, modify the slide layout to create space for the table.

2) Click on **Table** on the Standard toolbar or the Table toolbar (Figure 77) to open the Table graphic (Figure 79).
3) Drag the cursor across and down in the table graphic to create the required number of rows and columns.

![Insert Table dialog](image)

*Figure 78: Insert Table dialog*

4) Release the mouse button to insert the table in the slide and close the Table graphic.

5) If necessary, click on **More Options** in the Table graphic to open the Insert Table dialog and create the rows and columns required.

---

**Note**

When inserting tables into a slide, the table is created with the default style and settings already applied. Currently these defaults are hard coded in LibreOffice. The table can then be formatted to your requirements.

---

**Formatting tables**

**Sidebar Table Design section**

To open and use the *Table Design* section in the Properties deck on the Sidebar (Figure 76 on page 98):

1) Insert a table into a slide) or select a table in a slide.

2) Click on *Table Design* in the Properties deck on the Sidebar to open the section and display the available designs, or click on *Table Design* on the Table toolbar (Figure 77 on page 98).

3) Select a design for your table and the types of rows and columns from the available options.
The following options for rows and columns are available in the Table Design section:

- **Header row** – selected by default. The first row is normally a header row and is displayed with a different background from the rest of the table.

- **Total row** – If selected, it changes the background of the last row to make it stand out from the other rows.

- **Banded rows** – selected by default and alternate rows have different backgrounds making it easier to read data entered into the rows. An example of banded rows is shown in Figure 80.

- **First column** – when selected, highlights the first column of the table using a darker background.

- **Last column** – when selected, highlights the last column of the table using a darker background.

- **Banded columns** – when selected, alternate columns are highlighted with dark and light colors. An example of banded columns is shown in Figure 80.

**Table toolbar**

When a table is selected, the Table toolbar is displayed. If the Table toolbar is not displayed when a table is selected, go to View > Toolbars > Table on the Menu bar. The Table toolbar contains the majority of the tools required to format a table.

- **Table** – inserts a new table in the selected slide.

- **Border Style** – opens a drop down selection of available border styles. Select cells in a table, then apply a border style. If the required border style is not available, use the Borders page in the Table Properties dialog (Figure 87 on page 105).

- **Border Color** – select a color from the available palettes for the borders that are used for selected cells. If the required border color is not available, use the Borders page in the Table Properties dialog.

- **Borders** – opens a drop-down menu where you can select a predefined border configuration for selected cells. If the required border pattern is not available, use the Borders page in the Table Properties dialog.

- **Area Style/Filling** – opens a drop-down menu where you can select how selected cells are filled: None, Color, Gradient, Hatching, Bitmap or Pattern. Depending on Area Style selection, the drop-down menu lists the available fillings for the Area Style selected. Refer to Chapter 6, Formatting Graphic Objects for more information.

- **Merge Cells** – merges the selected cells into one cell. The contents of merged cells are also merged. Alternatively, right-click on selected cells and select Merge Cells from the context menu, or go to Format > Table > Merge Cells on the Menu bar.
• **Split Cells** – splits a selected cell into multiple cells either horizontally or vertically. Make sure that the cursor is positioned on the cell you want to split, then click on **Split Cells** to open the Split Cells dialog (Figure 81).

Alternatively, right-click on the selected cell and select **Split Cells** from the context menu, or go to **Format > Table > Split Cells** on the Menu bar.

In the **Split Cells** dialog, select the number of cells required when splitting a cell and whether to split the cell horizontally or vertically. When splitting horizontally, you can select **Into equal proportions** to create cells of equal size. The contents of the split cell are kept in the original cell (left or top cell).

![Figure 81: Split Cells dialog](image)

• **Optimize** – evenly distributes the selected rows and columns in a table either horizontally or vertically. Clicking on Optimize opens the Optimize toolbar (Figure 82) and contains the following tools:

  – **Minimal Column Width** – defines the minimal column width for selected columns. Minimal column width depends on the shortest entry within a column.
  
  – **Minimal Row Height** – determines the minimal row height for selected rows. Minimal row height depends on the font size of the smallest character in the row.
  
  – **Optimal Column Width** – defines the optimal column width for selected columns. Optimal column width depends on the longest entry within a column.
  
  – **Optimal Row Height** – determines the optimal row height for selected rows. Optimal row height depends on the font size of the largest character in the row.
  
  – **Distribute Columns Evenly** – adjusts the width of the selected columns to match the width of the widest column in the selection. The total width of the table cannot exceed the width of the page.
  
  – **Distribute Rows Equally** – adjusts the height of the selected rows to match the height of the tallest row in the selection.

Alternatively, right-click in selected cells and select from the context menu the appropriate **Optimize** tool.

![Figure 82: Optimize toolbar](image)

• **Align Top, Center Vertically, Align Bottom** – selects vertical alignment of text in selected cells. Alternatively, right-click in selected cells and select **Align** from the context menu or go to **Format > Align** on the Menu bar and select the required alignment.
• **Insert Row Above, Insert Row Below, Insert Column Before, Insert Column After** – select a row or column then click on one of these tools to insert a row or column.

Alternatively, go to **Format > Table > Insert Row** or **Insert Column** on the Menu bar to open the Insert Row dialog (Figure 83) or Insert Column dialog (Figure 84). Select number of rows or columns and the insertion position then click **OK** to insert.

![Figure 83: Insert Rows dialog](image)

![Figure 84: Insert Columns dialog](image)

• **Delete Row, Delete Column** – clicking on these tools deletes a single row or column that contains a selected cell. To delete more than one row or column, highlight cells across the number of rows or columns as required, then click on **Delete Row** or **Delete Column**.

Alternatively, right-click in the selected cells and select **Delete > Delete Row** or **Delete Column** from the context menu.

To delete the whole table, select the table so that the text box border and selection handles are displayed. Click on **Delete Row** or **Delete Column** to delete the table.

• **Select Table, Select Column, Select Rows** – these tools select a complete table or columns or rows where cells are selected.

By default these tools are not displayed on the Table toolbar. To display these tools, right-click in a blank area on the toolbar and select **Visible Buttons** from the context menu. Click on the tool you want displayed in the toolbar.

• **Table Design** – when clicked, this tool opens the **Table Design** section in the Properties deck on the Sidebar. See “Sidebar Table Design section” on page 99 for more information.

• **Table Properties** – click this tool on to open the Table Properties dialog.
**Table Properties dialog**

The Table Properties dialog (Figure 85) has four tabbed pages that provide formatting options for **Font**, **Font Effects**, **Borders** and **Background**. The Table Properties dialog is opened using one of the following methods:

- Right-click in a table and select **Table Properties** from the context menu.
- Go to **Format > Table > Properties** on the Menu bar.
- Click on **Table Properties** on the Table toolbar.

![Figure 85: Table Properties dialog - Font page](image-url)

*Using tables | 103*
The formatting options available on each dialog page are as follows:

- **Font** (Figure 85) – select the required *Family*, *Typeface* (Italic, Bold, etc.), *Size* and *Language* for text in the table. A sample of the font selected is displayed in the preview box. See “Fonts” on page 86 for more information.

- **Font Effects** (Figure 86) – select the required *Font Color*, *Text Decoration* and *Effects* for the text in the table. A sample of the font effects applied to the text is displayed in the preview box. See “Font Effects” on page 87 for more information.

- **Borders** (Figure 87) – select advanced options that are not available when using *Border Style*, *Border Color* and *Borders* tools on the Table toolbar.

- **Background** (Figure 88) – select a color from the available palettes for the background of selected cells. This dialog provides the same functions as *Area Style/Filling* on the Table toolbar.
Tables are placed into text boxes when created and are treated just like any other graphic object in an Impress presentation. However, only the Position and Size dialog (Figure 56 on page 72) can be used for tables. See “Position and Size dialog” on page 72 for more information.

Open the Position and Size dialog using one of the following methods after selecting the table:

- Right click on the table and select **Position and Size** from the context menu.
- Go to **Format > Object and Shape > Position and Size** on the Menu bar.
- Use the keyboard shortcut **F4**.

You can also change text box position by dragging with the cursor and change text box size using the selection handles. See “Working with text boxes” on page 67 for more information.

**Position and size**

*Using tables | 105*
Note

When the size of a text box containing a table is changed, the table also increases or decreases in size to keep the text filled with the table.

Using fields

Fields allow the automatic insertion of text into a slide. Fields are commonly used when creating templates and slide masters. For more information, see Chapter 2, Slide Masters, Styles, and Templates.

Inserting fields

Insert a field into a slide as follows:

1) Select the slide where you want to add a field.
2) Go to Insert > Field on the Menu bar and select the type of field. The field is placed on the selected slide in a text box.
3) If necessary, position and resize the field text box. See “Working with text boxes” on page 67 for more information.
4) If necessary, format the text used for the field information. See “Formatting text” on page 77 for more information.

Field types

The types of field available are as follows:

- **Date (fixed)** – inserts the current date into your slide as a fixed field. The date is not automatically updated. Available date formats depends on the language setting in Tools > Options > Language Settings > Language. Right click on the date field and select the required date format from the context menu.

- **Date (variable)** – inserts the current date into your slide as a variable field. The date is automatically updated each time you open the file. Available date formats depends on the language setting in Tools > Options > Language Settings > Language. Right click on the date field and select the required date format from the context menu.

- **Time (fixed)** – inserts the current time into your slide as a fixed field. The time is not automatically updated. Available time formats depends on the language setting in Tools > Options > Language Settings > Language. Right click on the time field and select the required time format from the context menu.

- **Time (variable)** – inserts the current time into your slide as a variable field. The time is automatically updated each time you open the file. Available time formats depends on the language setting in Tools > Options > Language Settings > Language. Right click on the time field and select the required time format from the context menu.

- **Author** – inserts the first and last names of the author of the presentation. This information is taken from values entered in the LibreOffice user data. To modify this information go to Tools > Options > LibreOffice > User Data.

- **Slide Number** – inserts the slide number into the current slide. Alternatively, go to Format > Slide Number on the Menu bar. If you want to add a slide number to every slide, go to View > Master Slide on the Menu bar and insert the slide number field.
• **Slide Title** – inserts the slide title. The default slide name is Slide # if you have not renamed the slide.

• **Slide Count** – inserts the total number of slides in the presentation.

• **File Name** – inserts the name of the file used for the presentation. The file name only appears after you have saved the file.

### Using hyperlinks

When inserting text that can be used as a hyperlink, such as a website address or URL, Impress formats it automatically, creating a hyperlink, and applying color and underlining. If you do not want Impress to use its default settings, then you have to insert a hyperlink manually.

**Tip**

To prevent LibreOffice from automatically turning website addresses or URLs into hyperlinks, go to **Tools > AutoCorrect Options > Options** and deselect **URL Recognition**.

**Tip**

To change the color of hyperlinks, go to **Tools > Options > LibreOffice > Application Colors**, scroll to **Unvisited links** and/or **Visited links**, select the checkboxes, then select new colors from the color palettes for the links and click **OK**. Note this color change will change the color for all hyperlinks across all components of LibreOffice.

### Inserting hyperlinks

1) Go to **Insert > Hyperlinks** on the main menu bar or use the keyboard shortcut Ctrl+K to open the Hyperlink dialog (Figure 89).

![Hyperlink dialog - Internet page](figure89.png)

*Figure 89: Hyperlink dialog - Internet page*
2) On the left hand side, select the type of hyperlink you want to insert.

The top right part of the dialog changes depending on the hyperlink type. A full description of all options, and their interactions, is beyond the scope of this chapter. A summary of the most common choices used in a presentation is given below.

3) Create your hyperlink using the dialog, then click **Apply** to insert the hyperlink into your slide. The hyperlink is inserted into a text box.

4) Click **Close** or **OK** to close the dialog.

### Hyperlink types

- **Internet** (Figure 89) – select either Web or FTP protocol. Enter the required web address in the **URL**: text box and a name for the hyperlink in the **Text**: text box.

- **Mail** (Figure 90) – enter email details in **Recipient** and the subject of the link in **Subject**.

- **Document** (Figure 91) – creates a hyperlink to another document or to another place in a document, commonly referred to as a bookmark. Enter the details in the **Path** text box, or click on **Open File** to open a file browser. Leave this blank if you want to link to a target in the same presentation.

  Optionally, you can specify a target, for example a specific slide. Click on **Target in Document** to open a dialog where you can select the target. If you know the name of the target, you can type it into the **Target** text box.

- **New Document** (Figure92) – creates a hyperlink to a new document. Select **Edit now** to edit the newly created document immediately or **Edit later** to only create the hyperlink. Choose the type of document to create from the **File type** drop down list. Click on **Select path** to open a file browser so that you can choose a directory for the new document.

The **Further Settings** section on the Hyperlink dialog is common to all the hyperlink types, although some choices are more relevant to some types of links.
• **Frame** – set the value to determine how the hyperlink will open. This applies to documents that open in a web browser.

![Hyperlink dialog - Document page](image1.png)

Figure 91: Hyperlink dialog - Document page

![Hyperlink dialog - New Document page](image2.png)

Figure 92: Hyperlink dialog - New Document page

• **Form** – specifies if the link is to be presented as text or as a button.

• **Text** – specifies the text that will be visible to the user.

• **Name** – applicable to HTML documents. It specifies text that will be added as a NAME attribute in the HTML code behind the hyperlink.

### Formatting hyperlinks

A hyperlink is inserted in the center of the current slide. To edit the text, the size of a hyperlink text box, or to reposition the hyperlink on the slide:
1) Select it by dragging a selection across the text to display the text box border and selection handles. Do not click on the hyperlink because this will open the hyperlink.

2) Right-click on the selected hyperlink and select the type of formatting you want to change from the options available in the context menu.

3) To reposition hyperlink, click and drag on the border to move the hyperlink on the slide.

4) Select **Position and Size** from the context menu or press the F4 key to open the Position and Size dialog where you can change the options to move the hyperlink or resize the text box. See “Working with text boxes” on page 67 for more information.
Chapter 4
Adding and Formatting Images
Introduction

Images are often used in presentations as they can convey a large amount of information more quickly than the written word. You can also give a more professional look to your presentation by adding a company logo, for example. Also, you may want to use Impress to create a presentation consisting only of images, such as a slideshow of holiday snapshots to share with friends.

Inserting images

This section describes several ways to insert an image from an external source into the presentation. Once the image has been inserted, it can be formatted extensively.

Image files

Inserting image files

Inserting an image from a file is quick and easy and can be formatted after the image has been placed on the slide.

1) Insert a new slide or select a slide in your presentation. See Chapter 1, Introducing Impress for more information.

2) If necessary, select a layout for the slide. See Chapter 1, Introducing Impress for more information.

3) Go to Insert > Image on the Menu bar and the Insert Image file browser window opens (Figure 93).

4) Navigate to the directory containing the required image and select the file. The file name is displayed in the File name text box. LibreOffice recognizes a large number of image formats.

5) If necessary, select Preview and a thumbnail of the selected file is displayed in the preview pane on the right of the file browser.
6) Click on **Open** to place the image in the center of the selected slide. The file browser window closes and the image is displayed in the center of the slide with selection handles around the image border.

7) Format the image to your requirements. See “Formatting images” on page 117 for more information.

### Linking image files

The Insert Image file browser (Figure 93) has a **Link** option. This allows you to insert the image as a link to a file rather than embedding the image file into your presentation. However, it is preferable to embed images so that a presentation can be copied and used on other computers. Sometimes, it makes sense to link an image file rather than embed it and the reasons for linking could be follows:

- When an image file is large and linking rather than embedding will dramatically reduce the file size of the presentation.
- When the same image file is used in many presentations. For example, when using the same background image for all the presentations created.
- When the linked file will be available when loading the presentation. For example, if the presentation is a slide show of holiday photographs.

### Inserting scanned images

Inserting an image from a scanner is normally a simple process if one or more of the following points are valid:

- Scanner software driver has been installed on the computer.
- Scanner is supported by the SANE system if the computer operating system is Linux or other UNIX operating system.
- Scanner is TWAIN compatible and the computer is operating Windows or macOS.
• Scanner is configured on a computer with LibreOffice software installed.

The following scanning procedure is only an example to demonstrate how to insert an image from a scanner. The actual procedure you use depends on computer operating system, the type of scanner being used, and the scanner driver software installed.

1) Prepare the image for the scanner and make sure that the scanner is switched on.

2) Go to Insert > Media > Scan > Select Source on the Menu bar to open a scanner dialog. If you have previously used your scanner, then go to Insert > Media > Scan > Request on the Menu bar to open a scanner dialog.

3) If you have more than one scanner connected to a computer, select the scanner from the Select Source or Device Used drop-down list.

4) If available, click Create Preview or Preview to create a preview scan of the image and place it in the preview area.

5) If necessary crop the scanned image to what you require and make any necessary scanning adjustments.

6) Click Scan and the image is scanned. Impress then places the scanned image in the center of the selected slide.

7) Format the image to you requirements. See “Formatting images” on page 117 for more information.

![Figure 94: Gallery deck on Sidebar](image)

**Inserting Gallery images**

The Gallery deck on the Sidebar contains a collection of images that you can use in a presentation. You can also add your own images to the Gallery, making it an essential tool for creating presentations quickly and with a consistent look. The Gallery is available in all LibreOffice components. For more information on the Gallery, see the Getting Started Guide.

1) Open the Gallery deck in the Sidebar (Figure 94) using one of the following methods:
   - Go to Insert > Media > Gallery on the Menu bar.
   - Click on Gallery in the Sidebar.

2) Select a theme from the available themes and the images for that theme are displayed.
3) Scroll through the available images and select the one you want to use.

4) Click on the image and drag it onto the slide. Release the mouse button and the image is inserted into your slide.

5) Format the image to your requirements. See “Formatting images” on page 117 for more information.

Managing Gallery themes

Images in the Gallery are grouped by themes, such as Arrows, Bullets, Diagrams and so on, and these themes are listed in the box at the top of the Gallery deck on the Sidebar (Figure 94). Click on a theme to see its images displayed in the Gallery deck.

The default themes in the Gallery are read-only. No images or graphics can be added to or deleted from these themes. The default themes are easily recognizable by right-clicking on a theme name and the only available option in the pop-up menu is Properties.

Any themes that you create are the only themes that are customizable allowing you add or delete your own images. You can also create new theme categories where you can add or delete your images.

Creating new themes

1) Open the Gallery deck in the Sidebar (Figure 94 on page 114) using one of the following methods:
   - Go to Insert > Media > Gallery on the Menu bar.
   - Click on Gallery in the Sidebar.

2) Click New Theme above the list of themes and the Properties of New Theme dialog opens (Figure 95).

3) Click on the General tab and type a name for the new theme in the text box.

4) Click OK to save your new theme and close the dialog. The new theme is displayed in the list of themes in the Gallery.

Adding theme images

You can only add images to themes that you have created.

1) Right-click on a theme name that you created in the list of themes and select Properties from the context menu to open the Properties of New Theme dialog.
2) Click on the **Files** tab (Figure 96).

3) Click on **Find Files** to open the Select Path dialog.

4) Browse to the folder that contains the images you want to use.

5) Click **Select** to select the files contained in the folder and the Select Path dialog closes. The list of files contained in the folder now appear in the Properties of New Theme dialog (Figure 96).

6) Select **Preview** and any image selected appears in the preview box.

7) Select the files you want to use in your new theme and click **Add**. The added files will disappear from the file list and the images will appear in the Gallery.

8) If you want to add all the files in the list, then click **Add All**. All the files will disappear from the list and the images will appear in the Gallery.

9) Click **OK** when finished and the Properties of New Theme dialog closes.

**Note**

The name of the Properties of New Theme dialog will change to show the name of your new theme when selected in the Gallery, as shown in Figures 95 and 96.

![Properties of New Theme dialog - Files page](Figure 96: Properties of New Theme dialog - Files page)

**Deleting theme images**

You can only delete images from themes that you have created.

1) Open the Gallery deck and select a theme that you created.
2) Right-click on the image you want to delete in the Gallery.
3) Select **Delete** from the context menu.
4) Click **Yes** in the confirmation message to delete the image.

**Note**

Images are linked files and are deleted from the Gallery only. The original image files are not deleted.

**Updating themes**

All images in the Gallery are linked files. It is recommended that you update a theme you created to make sure that all the files are still available.

1) Open the **Gallery** deck in the Sidebar (Figure 94 on page 114) using one of the following methods:
   - Go to **Insert > Media > Gallery** on the Menu bar.
   - Click on **Gallery** in the Sidebar.
2) Right-click on a theme you created that contains at least one image file.
3) Select **Update** from the context menu.

**Formatting images**

**Moving images**

For more information on moving images, see Chapter 6, Formatting Graphic Objects.

1) Click on an image to select it and display the selection handles.
2) Move the cursor over the image until it changes shape. The cursor shape depends on the computer operating system, for example a four headed arrow or a hand.
3) Click and drag the picture to the desired position.
4) Release the mouse button.

**Resizing images**

For more information on resizing images, see Chapter 6, Formatting Graphic Objects.

1) Click on an image to select it and display the selection handles.
2) Position the cursor over one of the selection handles. The cursor changes shape giving a graphical representation of the direction of the resizing.
3) Click and drag the selection handle to resize the image.
4) Release the mouse button.

**Note**

The corner selection handles resize both the width and the height of the graphic object simultaneously. The top and bottom selection handles resize the image height. The left and right selection handles resize the image width.
Note

To retain the original proportions of the graphic as you drag a selection handle, *Shift+Click* on a selection handle and then drag. Make sure to release the mouse button before releasing the *Shift* key.

Tip

Re-sizing a bit-mapped (raster) image affects the image resolution causing some degree of blurring. It is recommended to use a specialized graphics program to correctly scale the picture to the desired size before inserting it into your presentation. LibreOffice recommends Gimp ([http://www.gimp.org/](http://www.gimp.org/)).

Rotating, slanting or skewing images

For more information on rotating, slanting or skewing an image, see Chapter 6, Formatting Graphic Objects.

1) Click on an image to select it and display the selection handles.

2) Click Rotate on the Drawing toolbar (Figure 97) and the selection handles change shape and color (Figure 98). The color and shape change depends on the computer operating system and how your computer has been setup.

   Alternatively, click again on the selected image and the selection handles change shape and color.

3) The central selection handle is the normal rotation point for the selected image. If required, click and drag this rotation point to another position (even outside of the image) to change how the selected image is rotated.

4) Click and drag a selection handle in the direction in which you want to rotate, slant or skew the image as follows:
   - Corner selection handles rotate the image.
   - Left and right selection handles slant the image.
   - Top and bottom selection handles skew the image.

5) When satisfied with the rotation, release the mouse button.
To restrict the rotation angles to multiples of 15 degrees, Shift+Click on a selection handle and then drag to rotate, slant or skew. Make sure to release the mouse button before releasing the Shift key.

Using Image Filters

**Image Filter toolbar**

When an image is selected, the Image Filter toolbar (Figure 99) becomes available to format an image using filters. The Image Filter toolbar is opened as follows:

1) Select an image on a slide.

2) Go to View > Toolbars > Image on the Menu bar to open the Image toolbar (Figure 100). The Image toolbar only opens when an image is selected.

3) Click on Filter to open the Image Filter toolbar (Figure 99). The Image Filter toolbar only opens when an image is selected.

4) Select the required filter and it is applied immediately to the image. See “Image filters” on page 119 for more information on filters.

Alternatively, go to Format > Image > Filter on the Menu bar and select a filter from the context menu. This applies the filter to the image at the filter default settings.

5) Click outside the image to deselect it, then save your presentation to save your changes.

**Image filters**

The effect of each image filter has on an image is described below. The best way to judge if a filter works for your picture is to try it. See the Draw Guide for more information on image filters and examples of the filter effects.

- **Invert** – inverts or reverses the color values of a color image (similar to a color negative), or the brightness values of a grayscale image. Apply the filter again to revert to the original graphic.

- **Smooth** – softens or blurs the image by applying a low pass filter reducing the contrast between neighboring pixels and produces a slight lack of sharpness. Selecting this filter opens the Smooth dialog where you can set and use the smooth radius parameter when you click OK.

- **Sharpen** – sharpens the image by applying a high pass filter, increasing the contrast between neighboring pixels emphasizing the difference in brightness. This will accentuate the outlines and the effect will be strengthened if you apply the filter several times.
• **Remove Noise** – removes noise by applying a median filter comparing every pixel with its neighbor. It then replaces any pixel with extreme values that deviate in color by a large amount from the mean value with a pixel that has a mean color value. The amount of picture information does not increase, but because there are fewer contrast changes resulting in an image that looks smoother.

• **Solarization** – solarization is a phenomenon in photography where an image recorded on a negative or on a photographic print is wholly or partially reversed in tone. Dark areas appear light or light areas appear dark. Solarization was originally a photochemical effect used during photographic film development and is now used in the digital world of computing to create a change or reversal of color. Selecting this image filter opens the Solarization dialog, where you can define the Threshold value for solarization. Entering a threshold value above 70% reverses the color values. Selecting the Invert option causes all the colors to be inverted.

• **Aging** – aging creates a look that resembles photographs developed in the early days of photography. All pixels are set to their gray values and then the green and blue color channels are reduced by the amount specified in Aging degree in the Aging dialog. Red color channel is not changed. Selecting this image filter opens the Aging dialog, where you can define the Aging degree and create an old look for your graphic.

• **Posterize** – posterizing reduces the number of colors in an image making it look flatter. When used on a photograph, posterizing can make the photograph look like a painting. Selecting this image filter opens the Posterize dialog, where you can define the number of poster colors to produce the effect you want.

• **Pop Art** – select this image filter to change the colors of an image to a pop-art format.

• **Charcoal Sketch** – selecting this image filter displays an image as a charcoal sketch. The contours of the image are drawn in black and the original colors are suppressed.

• **Relief** – this image filter calculates the edges of an image in relief as if the image is illuminated by a light source. Selecting this image filter opens the Emboss dialog where you can select the position of the Light source producing shadows that differ in direction and magnitude.

• **Mosaic** – this image filter joins groups of pixels and converts them into a rectangular tile in a single color creating an image that appears to be a mosaic. The larger the individual rectangles created, the fewer details the mosaic graphic has. Selecting this image filter opens the Mosaic dialog, where you can set the number of pixels used to create the Width and Height of each tile created. Selecting Enhanced edges will enhance the edges of each tile to create a sharper definition.

### Changing image mode

Use the **Image Mode** drop down list on the Image toolbar (Figure 100 on page 119) to change the image mode of a selected image. The options for image mode are as follows:

• **Default** – the view of the image is not changed.

• **Grayscale** – the image is shown in grayscale. A color image can become monochrome in grayscale. You can also use the color sliders to apply a uniform color to the monochrome graphic object.

• **Black and White** – the image is shown in black and white. All brightness values below 50% will appear black, all brightness values over 50% will appear white.

• **Watermark** – the image is raised in brightness and reduced in contrast so that it can be used in the background as a watermark.
**Color Adjustment**

After selecting an image, open the Color toolbar (Figure 101) using one of the following methods:

- Click on the Color icon in the Image toolbar.
- Go to Format > Image > Color on the Menu bar.

Use the Color toolbar to adjustment the individual colors within the whole of the image (red, green, blue) as well as the brightness, contrast, and gamma of the image. Increasing the gamma value of an image makes it more suitable to be used as a background or watermark as it will interfere less with a dark text.

**Replacing colors**

The Color Replacer dialog (Figure 102) only allows you to replace or change a color in embedded images for another color or set a color as transparent. The embedded image must be a bitmap (for example BMP, GIF, JPG, or PNG) or a metafile (for example WMF).

Up to four colors can be replaced at once. Color Replacer works on the entire image and you cannot select an area of the image for editing.

![Color Replacer dialog](image)

*Figure 101: Color toolbar*

*Figure 102: Color Replacer dialog*

The colors available in the Replace with… drop down lists are all contained palettes that are part of the installation of LibreOffice. If you have created any custom colors, then these colors will be available in the custom palette. For more information on creating custom colors, see the **Draw Guide**.

---

**Note**

The Color Replacer can only be used on embedded images. If you try to use the Color Replacer on a linked image, you will get the following error message “This image is linked to a document. Do you want to unlink the image in order to edit it?”
Replacing colors

Replace colors in an embedded image as follows:

1) Select an embedded image to start using the Color Replacer.

2) Go to Tools > Color Replacer on the Menu bar to open the Color Replacer dialog (Figure 102).

3) Click on Pipette at the top of the Color Replacer dialog to activate the color selection mode.

4) Move the cursor over the color you want to replace in the selected image and click on the color to be replaced. A check box is now marked and the selected color appears in Source color.

5) If necessary, select another three colors in the selected image. Only a maximum of four colors can be selected.

6) Enter the amount of tolerance required for replacing the color in the Tolerance box. The default selection is 10% tolerance.

7) Select a color from palettes available in the Replace with... drop-down list for each color selected. Transparent is the default selection.

8) After selecting up to four colors for replacement, click Replace to replace the colors in the selected image.

9) There is no preview of the effect. If the result is not what you required, select Edit > Undo in the Menu bar and repeat the color replacement.

Note

Using Color Replacer replaces all occurrences of the Source color that you have selected in the image.

Note

The default selection of Transparent in Replace with... removes the selected color from the image and creates transparent areas in the image.

Replacing transparent areas

It is also possible to replace transparent areas in an embedded image with a color.

1) Select an embedded image to start using the Color Replacer.

2) Go to Tools > Color Replacer on the Menu bar to open the Color Replacer dialog (Figure 102).

3) Select Transparency in the Color Replacer dialog.

4) Select a color from palettes available in the drop-down list next to Transparency.

5) Click Replace to replace the transparent areas with the selected color.

6) There is no preview of the effect. If the result is not what you required, select Edit > Undo in the Menu bar and repeat the transparency replacement.

Tolerance parameter

The Tolerance parameter is used to set how much of the source color in an embedded image is replaced by another color.
Replacing colors that are similar to the color you are replacing, enter a low value for the tolerance parameter.

Replacing a wider range of colors, enter a higher value for the tolerance parameter.

**Image transparency**

Specifies the transparency in an image where the percentage value of 0% is a fully opaque image up to 100% where a fully transparent image is possible. As with the gamma value of an image, increasing the transparency makes the image blend more smoothly into the background making the overlay text easier to read.

Click on **Transparency** on the Image toolbar and change the percentage value in the text box adjusting the image transparency.

**Adjusting shadow settings**

Select an image, then click on **Shadow** on the Image toolbar to apply a shadow to the image. The shadow applied uses the settings from the **Shadow** page of the Area dialog (Figure 103).

If a shadow is already applied to the image, clicking on **Shadow** will remove the shadow from the image.

To adjust the shadow settings applied to an image is as follows.

1) Go to **Format > Object and Shape > Area** on the Menu bar to open the Area dialog.
2) Click on **Shadow** (Figure 103) to open the **Shadow** page.

![Figure 103: Area dialog - Shadow page](image)

3) Select the position from one of nine positions where you want to cast the shadow from the image.
4) Select the **Color** of the shadow from the available color palettes in the drop down list.
5) Enter the **Distance** that you want the shadow to be offset from the image.
6) Enter a **Transparency** percentage from 0% (opaque) to 100% (transparent) to specify the shadow transparency.

The preview box in the dialog shows how the shadow will look when applied to the selected image.

**Cropping images**

In Impress you can crop an image using a mouse or a dialog. Mouse cropping is easier, but dialog cropping provides more precise control.
Mouse cropping

1) Select an image.

2) Use one of the following methods to put the image into cropping mode and crop marks appear around the image (Figure 104):
   - Click **Crop Image** on the Image toolbar (Figure 100 on page 119).
   - Go to **Format > Image > Crop** on the Menu bar.
   - Right click on the image and select **Crop** from the context menu.

3) Place the cursor over any of the crop marks and the cursor changes shape. Click and drag the crop mark to crop the image.
   - Corner crop marks change width and height of an image.
   - Left and right crop marks change the width of an image.
   - Top and bottom crop marks change the height of an image.

4) Click outside the image to deactivate cropping mode.

![Figure 104: Image cropping with mouse](image)

**Note**

Press and hold the **Shift** key, then click and drag a crop mark to proportionally reduce width and height of the image at the same time. Release the mouse button before releasing the **Shift** key.

Dialog cropping

1) Select an image.

2) Go to **Format > Image > Crop Dialog...** on the Menu bar to open the Crop dialog (Figure 105).

3) Crop the image using the options given in the Crop dialog. A preview of the selected image and cropping results appear in the dialog.

4) To revert back to the original size of the image, click **Original Size**.

5) Click **OK** to save your changes and close the dialog.

The Crop dialog has the following options:

- **Crop** – adjusts the crop size and type of cropping for an image.
  - **Keep scale** – maintains the original scale of the image when cropped. The size of the image changes to the cropped size (Figure 106).
  - **Keep image size** – maintains the original size of the image when cropped. The scale of the image changes (Figure 107). To reduce the scale of the graphic, select this option and enter negative values in the cropping boxes. To increase the scale of the graphic, enter positive values in the cropping boxes.
– **Left** – if *Keep scale* is selected, enter a positive amount to trim the left edge of the image, or a negative amount to add white space to the left of the image. If *Keep image size* is selected, enter a positive amount to increase the horizontal scale of the image, or a negative amount to decrease the horizontal scale of the image.

![Crop dialog](image1.png)

*Figure 105: Crop dialog*

– **Right** – if *Keep scale* is selected, enter a positive amount to trim the right edge of the image, or a negative amount to add white space to the right of the image. If *Keep image size* is selected, enter a positive amount to increase the horizontal scale of the image, or a negative amount to decrease the horizontal scale of the image.

– **Top** – if *Keep scale* is selected, enter a positive amount to trim the top of the image, or a negative amount to add white space above the image. If *Keep image size* is selected, enter a positive amount to increase the vertical scale of the image, or a negative amount to decrease the vertical scale of the image.

– **Bottom** – if *Keep scale* is selected, enter a positive amount to trim the bottom of the image, or a negative amount to add white space below the image. If *Keep image size* is selected, enter a positive amount to increase the vertical scale of the image, or a negative amount to decrease the vertical scale of the image.

- **Scale** – changes the scale of the selected image.
  - **Width** – enter the width for the selected image as a percentage.
– **Height** – enter the height of the selected image as a percentage.

- **Image Size** – changes the size of the selected image.
  – **Width** – enter a width for the selected image.
  – **Height** – enter a height for the selected image.
- **Original Size** – returns the selected image to its original size.

**Deleting images**

1) Click on an image to display the selection handles.
2) Press the Delete key.

**Creating image maps**

An image map defines areas of the image (called hotspots) associated with a URL (a web address or a file on the computer). Hotspots are the graphic equivalent of text hyperlinks. In Impress, clicking on a hotspot opens the linked page in the appropriate program (for example, default browser for HTML pages; LibreOffice Writer for ODT files; PDF viewer for PDF files).

You can create hotspots of various shapes, such as rectangles, ellipses, and polygons, and include several hotspots in the same image. When you click on a hotspot, the URL opens in a browser window or frame that you have specified. You can also specify the text that appears when the cursor hovers over a hotspot.

![Figure 108: Image Map dialog](image)

Use the ImageMap dialog (Figure 108) to create or edit a hotspot:

1) Select an image on a slide.
2) Go to **Tools > ImageMap** on the Menu bar and the ImageMap dialog opens. The main part of the dialog shows the selected image where hotspots will be defined.
3) Use the tools at the top of the dialog and the fields to define hotspots and their links.
4) Click on **Apply** to apply the settings.

5) When finished, click on **Save** to save the image map to a file. This opens a file browser window where you can navigate to the folder where you want to save the image map.

6) Click on **Close** to close the ImageMap dialog.

The tools available in the ImageMap dialog are as follows:

- **Apply** – click this icon to apply any changes made.
- **Open** – opens a file browser window where you can navigate to the folder where an image map has been saved.
- **Save** – opens a file browser window where you can navigate to the folder where you want to save an image map.
- **Close** – closes the Image Map dialog. A confirmation window opens asking for confirmation of what happens to any changes that have been made.
- **Select** – used to select a hotspot that has been created on an image.
- **Rectangle, Ellipse, Polygon** and **FreeForm Polygon** – drawing tools for hotspot shapes. These tools work in exactly the same way as the corresponding tools in the Drawing toolbar (Figure 97 on page 118). For more information see Chapter 5, Managing Graphic Objects.
- **Edit Points, Move Points, Insert Points, Delete Points** – advanced editing tools to manipulate the shape of a polygon hotspot. Select **Edit Points** first to activate the other points tools.
- **Undo** – undoes any action taken.
- **Redo** – redos any action that has been undone.
- **Active** – toggles the status of the hotspot activating a selected hotspot or deactivating it if active.
- **Macro** – associates a macro with the hotspot instead of a hyperlink.
- **Properties** – sets the hyperlink properties and adds the Name attribute to the hyperlink.
- **Address** – enter the URL address that points to a hyperlink. You can also point to an anchor in a document (for example a specific slide number). Using an anchor in a document, write the address in this format: `file:///<path>/document_name#anchor_name`.
- **Text** – enter the text that will be displayed when the cursor is moved over the hotspot.
- **Frame** – where the target of the hyperlink will open.
  - `_blank` – opens in a new browser window.
  - `_self` – default selection and opens in the current window.
  - `_top` – file opens in the topmost frame in the hierarchy.
  - `_parent` – file opens in the parent frame of the current frame. If there is no parent frame, the current frame is used.

**Tip**

The value `_self` for the target frame will work on the vast majority of the occasions. It is not recommended to use the other values, if available, unless absolutely necessary.
Chapter 5
Managing Graphic Objects
Introduction

This chapter describes how to manage graphic objects and in particular how to rotate, distort, arrange, and position them on the slide. Though this chapter focuses on the shapes that can be created with the available tools in Impress, some of the techniques described in this chapter are also applicable to images imported into slides.

Drawing toolbar

The Drawing toolbar (Figure 109) contains the majority of the tools normally used to create graphic objects. If this toolbar is not visible, select **View > Toolbars > Drawing** from the Menu bar. By default, the Drawing toolbar is docked vertically at the left side of the Impress window.

![Drawing toolbar]

Figure 109: Drawing toolbar

**Note**

Your Drawing toolbar may differ from the one shown in Figure 109 as this depends on how many drawing tools have been placed on the toolbar. Right-click on an empty area of the Drawing toolbar, then select **Visible Buttons** from the context menu to display the available tools. From this dialog you can install and remove tools to and from the toolbar. See Appendix B, Toolbars for more information.

Drawing tools

- **Select** – selects objects. To select a group of objects, click above the top left object and drag the mouse below the bottom right object of the intended selection while keeping the mouse button pressed. A rectangle identifying the selection area is displayed. You can also select several objects by pressing and holding the **Shift** key while selecting the individual objects.
- **Insert Text Box** – creates a text box with text aligned horizontally. See Chapter 3, Adding and Formatting Text for more information on working with text.
- **Insert Vertical Text** – creates a text box with text aligned vertically. This tool is available only when Asian language support has been enabled in **Tools > Options > Language Settings > Languages**. See Chapter 3, Adding and Formatting Text for more information on working with text.
- **Line Color** – click on the triangle ▼ to the right of the icon to open a color palette and select a color for the line. More colors are available by selecting a different color palette from the drop down list at the top of the color palette.
- **Fill Color** – click on the triangle ▼ to the right of the icon to open a color palette and select a color for the area fill. More colors are available by selecting a different color palette from the drop down list at the top of the color palette.
- **Insert Line** – draws a straight line from the point where you click the mouse to the point where you drag the mouse pointer and release the mouse button. Press the **Shift** key to restrict the angle of the line to multiples of 45°. Press the **Alt** key to draw a line from its center. Press the **Ctrl** key to detach the end point of the line from the grid (see ‘Using grid or snap functions’ on page 151).
• **Rectangle** – draws a rectangle when you drag the mouse from the top left to the bottom right corner. Press the *Shift* key to draw a square. Press the *Alt* key to draw a shape from its center. Press the *Shift + Alt* keys to draw a square from the center. Release the mouse button before releasing the *Shift or Alt* keys.

• **Ellipse** – draws an ellipse. Press the *Shift* key to draw a circle. Press the *Alt* key to draw a shape from its center. Press the *Shift + Alt* keys to draw a circle from the center. Release the mouse button before releasing the *Shift or Alt* keys.

• **Line and Arrows** – draws a straight line ending with an arrowhead. The arrowhead is placed at the end of the line where you release the mouse button. Click the triangle ▼ to the right of the tool icon to show the available tools (Figure 110). The *Shift*, *Alt* and *Ctrl* keys have the same effect as for the **Line** tool. Actual icon shown on the toolbar will depend on the tool that had previously been selected.

![Figure 110: Lines and Arrows toolbar](image)

• **Curves and Polygons** – draws a shape depending on the option that has been selected. Click the triangle ▼ to the right of the tool icon to show the available tools (Figure 111). Actual icon shown on the toolbar will depend on the tool that had previously been selected.

![Figure 111: Curves and Polygons toolbar](image)

• **Connectors** – draws a connector line between two figures. Click the triangle ▼ to the right of the tool icon to show the available tools. Actual icon shown on the toolbar will depend on the tool that had previously been selected. For more information see “Connectors and glue points” on page 157.

![Figure 112: Connectors toolbar](image)

• **Basic Shapes** – click the triangle ▼ to the right of the tool icon to open a toolbar showing the available tools (Figure 113). Actual icon shown on the toolbar will depend on the tool that had previously been selected.

![Figure 113: Basic Shapes toolbar](image)

• **Symbol Shapes** – click the triangle ▼ to the right of the tool icon to open a toolbar showing the available tools (Figure 114). Actual icon shown on the toolbar will depend on the tool that had previously been selected.
• **Block Arrows** – click the triangle ▼ to the right of the tool icon to open a toolbar showing the available tools (Figure 115). Actual icon shown on the toolbar will depend on the tool that had previously been selected.

• **Flowchart** – click the triangle ▼ to the right of the tool icon to open a toolbar showing the available tools (Figure 116). Actual icon shown on the toolbar will depend on the tool that had previously been selected.

• **Callouts** – click the triangle ▼ to the right of the tool icon to open a toolbar showing the available tools (Figure 117). Actual icon shown on the toolbar will depend on the tool that had previously been selected.

• **Stars and Banners** – click the triangle ▼ to the right of the tool icon to open a toolbar showing the available tools (Figure 118). Actual icon shown on the toolbar will depend on the tool that had previously been selected.

• **3D-Objects** – click the triangle ▼ to the right of the tool icon to open a toolbar showing the available tools (Figure 119). Press the Shift key to draw a 3D object with equal width and height. Press the Alt key to draw a shape from its center. Actual icon shown on the toolbar will depend on the tool that had previously been selected. For more information on 3D objects, see “Working with 3D objects” on page 162.
• **Rotate** – select an object then click on this tool to switch the object in rotation mode. The selection handles change color and pivot point appears in the center of the object.

• **Align** – click the triangle ▼ to the right of the tool icon to open the available alignment tools (Figure 120) for two or more objects: See “Aligning objects” on page 150 for more information.
  – *Left, Centered, Right* – determines the horizontal alignment of selected objects.
  – *Top, Center, Bottom* – determines the vertical alignment of selected objects.

• **Arrange** – changes the stack level of an object. Click the triangle ▼ to the right of the tool icon to open the available arrange tools (Figure 121) for a selected object. See “Arranging objects” on page 157 for more information.
  – *Bring to front* – the selected object is moved in front of all other objects.
  – *Bring forward* – the selected object is moved one level up in the stack.
  – *Send backwards* – the selected object is moved one level down in the stack.
  – *Send to back* – the selected object is moved behind all other objects.
  – *In front of object* – moves the first selected object in front of the second selected object.
  – *Behind object* – moves the first selected object behind the second selected object.
  – *Reverse* – swaps the stacking order of two selected objects.

• **Distribution** – opens the Distribution dialog (Figure 122) where you can set the horizontal and vertical spacing between objects.
• **Shadow** – applies a shadow to a selected object using the shadow settings from the Area dialog.

• **Crop Image** – this tool only becomes active when an image is selected that you want to crop.

• **Filter** – this tool only becomes active when an image is selected and opens the available filter options (Figure 123) for application to an image. For more information on image filters, see the Draw Guide.
  
  – **Invert** – inverts the color values of a color image, or the brightness values of a grayscale image. Apply the filter again to reverse the effect.
  
  – **Smooth** – softens or blurs the image by applying a low pass filter.
  
  – **Sharpen** – sharpens the image by applying a high pass filter.
  
  – **Remove Noise** – removes noise by applying a median filter.
  
  – **Solarization** – opens a dialog for defining solarization. Solarization refers to an effect that looks like what can happen when there is too much light during photo development.
  
  – **Aging** – all pixels are set to their gray values. The green and blue color channels are then reduced by the amount you specify. The red color channel is not changed.
  
  – **Posterize** – opens a dialog to determine the number of poster colors. This effect is based on the reduction of the number of colors. It makes photos look like paintings.

  – **Pop Art** – converts an image to a pop-art format.
  
  – **Charcoal Sketch** – displays the image as a charcoal sketch. The contours of the image are drawn in black, and the original colors are suppressed.
  
  – **Relief** – displays a dialog for creating reliefs. You can choose the position of the imaginary light source that determines the type of shadow created, and how the graphic image looks in relief.
  
  – **Mosaic** – joins small groups of pixels into rectangular areas of the same color. The larger the individual rectangles are, the fewer details the graphic image has.

• **Points** – edits the individual points that form the shape or line. Select this tool and then select a shape or a line. You can also press the F8 key to select this tool.
• **Show Glue Points Functions** – opens the Gluepoints toolbar allowing you to edit the glue points of a graphic object. Glue points are the positions where connector lines terminate or start. See “Glue points” on page 160 for more information.

• **Toggle Extrusion** – switches 3D effects on or off for the selected object. Clicking on this tool also opens the 3D-Settings toolbar. See “Working with 3D objects” on page 162 for details.

## Creating lines and shapes

This section is an introduction to creating lines and shapes. For more information on working with lines and shapes, see the *Draw Guide*.

### Drawing regular shapes

Regular shapes that are available on the Drawing toolbar (Figure 109 on page 129) are **Rectangle** and **Ellipse** plus the following shapes

- Basic Shapes (Figure 113 on page 130).
- Symbol Shapes (Figure 114 on page 131)
- Block Arrows (Figure 115 on page 131)
- Flowchart (Figure 116 on page 131)
- Callouts (Figure 117 on page 131)
- Stars and Banners (Figure 118 on page 131)
- 3D Objects (Figure 119 on page 132)

Some icons for regular shapes have a triangle ▼ to the right of the icon. Clicking on this triangle ▼ opens a sub-toolbar giving access to several different types of regular shapes. The icons on the Drawing toolbar shows the last tool used for each of these regular shapes.

Drawing a regular shape is as follows:

1) Select the required tool from the Drawing toolbar or from a sub-toolbar after clicking the triangle ▼ to the right of the icon.

2) Place the cursor on the slide, then click and drag the mouse to define an enclosing rectangle.

3) Release the mouse button and your shape is drawn on the slide.

4) Press and hold the *Shift* key when creating a shape to maintain equal height and width. For example, when using the **Rectangle** or **Ellipse** tool to draw a square or a circle. Release the mouse cursor before releasing the *Shift* key.

5) Press the *Alt* key to draw a shape from its center. Release the mouse cursor before releasing the *Alt* key.

6) Press and hold the *Shift* And *Alt* keys when creating a shape to maintain equal height and width and draw the shape from the center. For example, when using the **Rectangle** or **Ellipse** tool to draw a square or a circle. Release the mouse cursor before releasing the *Shift* and *Alt* keys.
**Regular shape adjustment**

When creating shapes that are included in Impress, one or more dots may be displayed in a different color to the selection handles. These dots perform a different function according to the shape they are applied to and are listed below.

**Basic Shapes**

Refer to Figure 113 on page 130 to identify the following shapes with adjustment dots.

- **Rectangle, Rounded** – use the dot to change the radius of the curve that replaces the angled corners of a rectangle or square.
- **Square, Rounded** – use the dot to change the radius of the curve that replaces the angled corners of a rectangle or square.
- **Parallelogram** – use the dot to change the internal angles between the sides.
- **Trapezoid** – use the dot to change the internal angles between the sides.
- **Circle Pie** – use the dots to change the size of the filled sector.
- **Block Arc** – use the dot to change both internal diameter and size of the filled area.
- **Isosceles Triangle** – use the dot to modify the shape and type of the triangle.
- **Hexagon** – use the dot to change the internal angles between the sides.
- **Octagon** – use the dot to change the internal angles between the sides.
- **Cylinder** – use the dot to change the perspective.
- **Cube** – use the dot to change the perspective.
- **Folded Corner** – use the dot to change the size of the folded corner.
- **Cross** – use the dot to change the thickness of the four arms of the cross.
- **Frame** – use the dot to change the thickness of the frame.
- **Ring** – use the dot to change the internal diameter of the ring.

**Symbol Shapes**

Refer to Figure 114 on page 131 to identify the following shapes with adjustment dots.

- **Smiley Face** – use the dot to change the smile on the face.
- **Heart** – use the dot to change the shape of the symbol.
- **Sun** – use the dot to change the shape of the symbol.
- **Moon** – use the dot to change the shape of the symbol.
- **Prohibited** – use the dot to change the thickness of the ring and the diagonal bar.
- **Square Bevel** – use the dot to change the thickness of the bevel.
- **Octagon Bevel** – use the dot to change the thickness of the bevel.
- **Diamond Bevel** – use the dot to change the thickness of the bevel.
- **Double Bracket** – use the dot to change the curvature of the bracket.
- **Left Bracket** – use the dot to change the curvature of the bracket.
- **Right Bracket** – use the dot to change the curvature of the bracket.
• **Double Brace** – use the dot to change the curvature of the bracket.
• **Left Brace** – use the dots to change the curvature of the brace and the position of the point.
• **Right Brace** – use the dots to change the curvature of the brace and the position of the point.

**Block Arrows**

Refer to Figure 115 on page 131 to identify the following shapes with adjustment dots.

• **Right Arrow** – use the dot to change the shape and thickness of the arrow.
• **Left Arrow** – use the dot to change the shape and thickness of the arrow.
• **Down Arrow** – use the dot to change the shape and thickness of the arrow.
• **Up Arrow** – use the dot to change the shape and thickness of the arrow.
• **Left and Right Arrow** – use the dot to change the shape and thickness of the arrow.
• **Up and Down Arrow** – use the dot to change the shape and thickness of the arrow.
• **Circular Arrow** – use the dot to change the shape and thickness of the arrow.
• **4-way Arrow** – use the dots to change the shape and thickness of the arrow.
• **Chevron** – use the dot to change the angle between the sides and the shape.
• **Pentagon** – use the dot to change the angle between the sides and the shape.
• **Striped Right Arrow** – use the dot to change the shape and thickness of the arrow.
• **Up, Right and Down Arrow** – use the dots to change the shape and thickness of the arrow.
• **Notched Right Arrow** – use the dot to change the shape and thickness of the arrow.
• **Up and Right Arrow** – use the dots to change the shape and thickness of the arrow.
• **Right Arrow Callout** – use the dots to change the shape and thickness of the callout.
• **Left Arrow Callout** – use the dots to change the shape and thickness of the callout.
• **Down Arrow Callout** – use the dots to change the shape and thickness of the callout.
• **Up Arrow Callout** – use the dots to change the shape and thickness of the callout.
• **Left and Right Arrow Callout** – use the dots to change the shape and thickness of the callout.
• **Up and Down Arrow Callout** – use the dots to change the shape and thickness of the callout.
• **4-way Arrow Callout** – use the dots to change the shape and thickness of the callout.
• **Up and Right Arrow Callout** – use the dots to change the shape and thickness of the callout.

**Callouts**

For all callouts (Figure 117 on page 131) use the adjustment dots to change the length, position and angle of the pointer.
**Stars and Banners**

Refer to Figure 118 on page 131 to identify the following shapes with adjustment dots.

- **4-Point Star** – use the dot to change the thickness and shape of the star points.
- **8-Point Star** – use the dot to change the thickness and shape of the star points.
- **24-Point Star** – use the dot to change the thickness and shape of the star points.
- **Vertical Scroll** – use the dot to change the width and shape of the scroll.
- **Horizontal Scroll** – use the dot to change the width and shape of the scroll.
- **Doorplate** – use the dot to change the inward curvature of the corners.

**Drawing curves, polygons and freeform lines**

Curves, polygons and lines on the Drawing toolbar (Figure 109 on page 129) have a triangle ▼ to the right of the icon. Clicking on this triangle ▼ opens a sub-toolbar giving access to several different types of curves, polygons and lines. The icons on the Drawing toolbar show the last tool used for each of these curves, polygons and lines. If a filled curve, filled polygon, or filled freeform line was selected, Impress draws the line connecting the last point to the start point and fills the inside area with the default color.

**Curves**

1) Click the triangle ▼ to the right of Curves and Polygons on the Drawing toolbar to open the Curves and Polygons sub-toolbar (Figure 111 on page 130).

2) Select either **Curve** or **Curve Filled**.

3) Place the cursor on the slide, then click and drag to create the starting point of your curve.

4) Release the mouse button and drag the cursor to draw a curve on the slide, bending the line into a curve.

5) Click to set the end point of the curve and fix the curve on the slide.

6) Drag the cursor to continue drawing a straight line. Each mouse click sets a corner point and allows you to continue drawing another straight line from the corner point.

7) Double-click to end the drawing of your curve.

8) If **Curve Filled** was selected, Impress automatically fills the curve with the default color.

**Note**

Holding down the **Shift** key when drawing lines with the curve or polygon tools will restrict the angles between lines to 45 or 90 degrees.

**Polygons and Polygons 45°**

1) Click the triangle ▼ to the right of Curves and Polygons on the Drawing toolbar to open the Curves and Polygons sub-toolbar.

2) Select either **Polygon**, **Polygon Filled**, **Polygon (45°)** or **Polygon Filled (45°)**.

3) Place the cursor on the slide, then click and drag to draw the first line from the start point. Release the mouse button and a line between the first and second points is drawn.
4) Move the cursor to draw the next line. Each mouse click sets a corner point and allows you to draw another line.

5) Double-click to end the drawing of your polygon.

6) If **Polygon Filled** or **Polygon Filled (45°)** was selected, Impress automatically fills the polygon with the default color.

---

**Note**

If **Polygon (45°)** or **Polygon Filled (45°)** were selected, the movement of the cursor and the angles between lines is restricted 45°.

---

**Freeform lines**

Using the **Freeform Line** or **Freeform Line Filled** tools is similar to drawing with a pencil on paper.

1) Click the triangle ▼ to the right of **Curves and Polygons** on the Drawing toolbar to open the Curves and Polygons sub-toolbar (Figure 111 on page 130).

2) Select either **Freeform Line** or **Freeform Line Filled**.

3) Click and drag the cursor to the line shape you require.

4) When you finished drawing your freeform line, release the mouse button and the drawing is completed.

5) If **Freeform Line Filled** was selected, Impress automatically fills the drawing between the start and end points with the default color.

---

**Drawing lines and arrows**

**Straight lines**

A straight line is the simplest element or object in Impress to create.

1) Use one of the following methods to draw a line:
   - Click **insert Line** in the Drawing toolbar (Figure 109 on page 129).
   - Click the triangle ▼ on the right of **Lines and Arrows** on the Drawing toolbar and select **Insert Line** from the sub-toolbar (Figure 110 on page 130).

2) Click at the point where you want to start the line and drag the cursor.

3) Release the mouse button at the point where you want to end the line. A selection handle appears at each end of the line. The selection handle at the starting point of the line is slightly larger than the end selection handle, as shown in Figure 124.

4) Keep the **Ctrl** key pressed while drawing a line to enable the end of the line to snap to the nearest grid point.

5) Keep the **Shift** key pressed while drawing a line to restrict the drawing angle of a line to multiple of 45 degrees.

6) Keep the **Alt** key pressed while drawing a line to cause the line to extend outwards symmetrically in both directions from the start point. This lets you draw lines by starting from the middle of the line.
Arrows are drawn like lines and are classified as a subgroup of lines, that is lines with arrowheads. Hovering the cursor over each type of arrow that is available will tell you the type of endings each tool will draw.

1) Click the triangle ▼ on the right of Lines and Arrows on the Drawing toolbar and select the type of arrow from the sub-toolbar (Figure 110 on page 130).

2) Click at the point where you want to start the arrow, then drag the cursor. The arrowhead(s) is drawn at the end of the line when you release the mouse button.

3) Keep the Ctrl key pressed while drawing an arrow to enable the end of the arrow to snap to the nearest grid point.

4) Keep the Shift key pressed while drawing an arrow to restrict the drawing angle of an arrow to multiple of 45 degrees.

5) Keep the Alt key pressed while drawing an arrow to cause the arrow to extend outwards symmetrically in both directions from the start point. This lets you draw arrows by starting from the middle of the arrow.

Grouping objects together

Grouping of objects is similar to putting objects into a container. You can move the objects as a group and apply global changes to the objects within the group. A group can always be undone and the objects that make up the group can always be manipulated separately.

This section gives only a brief introduction to grouping of objects. An example of grouping two objects together is shown in Figure 125. For more information on working with grouped objects, see the Draw Guide.
Temporary grouping

Temporary grouping is when several objects are selected. Any changes to object parameters that you carry out are applied to all of the objects within the temporary group. For example, you can rotate a temporary group of objects in its entirety.

A temporary group is created using one of the following methods:

- Hold down the *Shift* key whilst clicking multiple objects on a slide.
- Click and drag the cursor to create a marquee around multiple objects. Release the mouse button and all the objects within the marquee are selected.

To cancel a temporary grouping of objects, simply click outside of the selection handles displayed around the objects.

Grouping

To group objects together permanently:

1) Objects are grouped using one of the following methods:
   - Hold down the *Shift* key whilst clicking multiple objects on a slide.
   - Click and drag the cursor to create a marquee around multiple objects. Release the mouse button and all the objects within the marquee are selected.
   - To select all the objects, go to **Edit > Select All** on the Menu bar or use the keyboard shortcut *Ctrl+A*.

2) With selection handles displayed, use one of the following methods to create a group of selected objects:
   - Go to **Format > Group > Group** on the Menu bar.
   - Use the keyboard shortcut *Ctrl+Shift+G*.
   - Right-click on an object within the selected group and select **Group** from the context menu.

Editing or formatting groups

1) Click on an object in the group to select the group. Any editing or formatting can then be carried out on all the objects within the group or on individual objects within the group.

2) To edit an individual object within a group, you have to enter the group using one of the following methods:
   - Use the keyboard shortcut *F3*.
   - Go to **Format > Group > Enter Group** on the Menu bar.
   - Right-click and select **Enter Group** from the context menu.

3) Select individual objects within the group for editing or formatting. An example of editing individual objects in a group is shown in Figure 126.

4) When you have finished editing or formatting, use one of the following methods to exit the group and the whole group then becomes selected:
   - Use the keyboard shortcut *Ctrl+F3*.
   - Go to **Format > Group > Exit Group** on the Menu bar.
   - Right-click and select **Exit Group** from the context menu.
Ungrouping

1) Click on any one of the objects in the group to select the group.
2) With selection handles displayed, use one of the following methods to ungroup a group of objects:
   – Go to Format > Group > Ungroup on the Menu bar.
   – Use the keyboard shortcut Ctrl+Alt+Shift+G.
   – Right-click on the group and select Ungroup from the context menu.

Tip

If you use group and ungroup commands often, or any other command, you can add commands to a toolbar so that they are readily available. See Chapter 11, Setting Up and Customizing Impress for more information on customizing the user interface.

Positioning and resizing graphic objects

Using a mouse

Positioning

For quick positioning of a graphic object on a slide, use the mouse as follows:

1) Click on a graphic object or a group of objects to display the selection handles.
2) Move the cursor over a selected graphic object until the cursor changes shape. The cursor shape depends on the computer setup and the computer operating system.
3) Click and drag the graphic object to the desired position. During movement, a ghost image of the object appears to help with repositioning (Figure 127).
4) Release the mouse button when the graphic object is in the desired position.
Figure 127: Example of moving objects with mouse

**Note**

You can also use the arrow keys to quickly move a selected object or group to a new position.

**Tip**

By default Impress snaps objects the grid when objects are being repositioned. If you need to position the object between two points of the grid, hold down the Ctrl key, then click on the object and move it to the desired position. Alternatively, you can turn this snap function off or modify the grid resolution by going to **Tools > Options > LibreOffice Impress > Grid**.

**Resizing**

For quick positioning of a graphic object on a slide, use the mouse as follow:

1) Click on a graphic object or a group of objects to display the selection handles.

2) Move the cursor over a selection handle.

3) Click and drag the selection handle to resize the graphic object. During resizing, a ghost image of the object appears to help with resizing (Figure 128).

4) To maintain the width to height ratio, hold down the Shift key before clicking and dragging on a selection handle. Remember to release the mouse button before releasing the Shift key.

5) Release the mouse button when the graphic object is at the desired size.

Figure 128: Example of resizing objects with mouse
Positioning and Size dialog

For a more accurate placement of a graphic object on a slide, use the Position and Size dialog (Figure 129) as follows:

1) Select a graphic object to display the selection handles and open the Position and Size dialog using one of the following methods:
   - Use the keyboard shortcut F4.
   - Go to Format > Object and Shape > Position and Size on the Menu bar.
   - Right-click on the selected object and select Position and Size from the context menu.
   - Click on More Options on the right of the title bar for the Position and Size section in the Properties deck on the Sidebar.

2) Click on the Position and Size tab.

3) In the Position section, specify Position X (horizontal) and Position Y (vertical) position of the graphic object. The values represent the distance from the Base point selected on the right hand side of the dialog. The default selection for Base point is relative to the top left corner of the slide.

4) If necessary, in the Protect section of the dialog, select the Position option to prevent the graphic object from being repositioned.

5) Click OK to save the changes and to close the dialog.

Note

The units of measurement used in this dialog and other Impress dialogs are set in Tools > Options > LibreOffice Impress > General.
**Resizing**

1) Select a graphic object to display the selection handles and open the Position and Size dialog using one of the following methods:
   - Use the keyboard shortcut F4.
   - Go to Format > Object and Shape > Position and Size on the Menu bar.
   - Right-click on the selected object and select Position and Size from the context menu.
   - Click on More Options on the right of the title bar for the Position and Size section in the Properties deck on the Sidebar.

2) Click on the Position and Size tab.

3) In Size, select a Base point that you would like to use as an anchor when resizing the graphic object. The default selection of top left corner means that the top left corner of the object will not change position when resizing.

4) To maintain the proportions between width and height, in the Size section select the Keep ratio option before changing the Width or Height. When Keep ratio is selected, changes to one dimension results in an automatic change to the other maintaining the ratio between object width and height.

5) In the Size section, specify the Width and Height of the graphic object.

6) If necessary, in the Protect section of the dialog, select the Size option to prevent the graphic object from being resized.

7) Click **OK** to save the changes and to close the dialog.

**Sidebar Position and Size section**

**Positioning**

Use the Position and Size section in the Properties deck on the Sidebar to position a graphic object as follows:

1) Select a graphic object to display the selection handles.

2) Click on **Properties** in the Sidebar to open the Properties deck.

3) Click on Position and Size section to open the section (Figure 130).

4) Specify Position X (horizontal) and Position Y (vertical) position of the graphic object. The values represent the distance from the Base point that has been selected in the Position and Size dialog.
5) Press the *Enter* key to make the changes.

**Resizing**

Use the *Position and Size* section in the Properties deck on the Sidebar to resize a graphic object as follows:

1) Select a graphic object to display the selection handles.
2) Click on **Properties** in the Sidebar to open the Properties deck.
3) Click on **Position and Size** section to open the section (Figure 130).
4) To maintain the proportions between width and height, select the *Keep ratio* option before changing the *Width* or *Height*. When *Keep ratio* is selected, changes to one dimension results in an automatic change to the other maintaining the ratio between object width and height.
5) Press the *Enter* key to make the changes.

**Applying special effects**

As well as the basic actions of moving and resizing an object, a number of special effects can also be applied to objects in Impress. This section describes how to rotate, flip, distort and setting an object in a circle.

**Rotating graphic objects**

**Mouse rotation**

1) Click on a graphic object and the selection handles are displayed.
2) On the Line and Filling toolbar, click on the triangle ▼ to the right of **Transformations** then click on **Rotate** on the sub-toolbar. The selection handles change shape and also change color as shown in Figure 131. A pivot point indicating the rotation center also appears in the center of the object.
3) Move the mouse over one of the corner handles and the mouse cursor shape will change.

4) Click on a corner selection handle and move in the direction in which you want to rotate the graphic object. Only the corner selection handles are active for rotation.

5) When satisfied with the rotation, release the mouse button.

6) To change the rotation center of the object, click and drag the pivot point to the desired position before rotating. The pivot point can be moved to any position on the slide, even outside of the object boundaries.

7) To restrict the rotation angles to multiples of 15 degrees, press and hold the Shift key while rotating the graphic. This is useful for rotating pictures through a right angle, for example from portrait to landscape. Remember to release the Shift key before releasing the mouse button.

**Position and Size dialog rotation**

Instead of rotating a graphic object manually, use the Rotation page of the Position and Size dialog (Figure 132) to accurately rotate an object.

1) Select a graphic object to display the selection handles and open the Position and Size dialog using one of the following methods:
   - Use the keyboard shortcut F4.
   - Go to Format > Object and Shape > Position and Size on the Menu bar.
   - Right-click on the selected object and select Position and Size from the context menu.
   - Click on More Options on the right of the title bar for the Position and Size section in the Properties deck on the Sidebar.

2) Click on the Rotation tab to open the Rotation page.

3) In Pivot Point and, if necessary, enter a measurement for Position X and Position Y to move the position of the pivot point. The default position of the pivot point is the center of the object. Alternatively, select a pivot point from one of the 9 positions in Default settings.

4) In Rotation Angle, enter the degree amount for rotation in the Angle text box. Alternatively, in Default settings, click on the rotation angle indicator and drag it to a new angle. The angle of rotation is displayed in the Angle text box.

5) Click OK to save your changes and to close the dialog.
Sidebar rotation

Use the Position and Size section in the Properties deck on the Sidebar to rotate a graphic object as follows:

1) Select a graphic object to display the selection handles.
2) Click on Properties in the Sidebar to open the Properties deck.
3) Click on Position and Size section to open the section (Figure 130 on page 145).
4) In Rotation, enter the degree amount for rotation in the text box or click on the rotation angle indicator and drag it to a new angle. The angle of rotation is displayed in the Rotation text box.
5) Press the Enter key to make the changes.

Flipping objects

Quick flipping

1) Click on a graphic object to display the selection handles.
2) Quickly flip a selected object so it faces the other direction using one of the following methods:
   – Right-click on the selected object and select Flip > Vertically or Horizontally from the context menu.
   – Click on the Vertically or Horizontally flip tool on the Standard toolbar.
   – Go to Format > Flip > Vertically or Horizontally on the Menu bar.
   – Click on the Flip Vertically or Flip Horizontally flip tool in the Position and Size section on the Properties deck of the Sidebar.

Flip tool

To change the position and angle that an object flips over, the Flip tool on the Transformations toolbar has to be used as shown in Figure 133.

1) Click on a graphic object and the selection handles will show.
2) Go to View > Toolbars > Transformations to open the Transformations toolbar (Figure 134).

3) Click on Flip on the Transformations toolbar and an axis of symmetry appears as a dashed line through the center of the object. The object will be flipped about this axis of symmetry.

4) Click and drag the axis of symmetry to a new position, or position the cursor in one of the circles at each end of the axis of symmetry and drag with your mouse cursor to change the angle.

5) Place the cursor over one of the selection handles for the object.

6) Click and drag the cursor across the axis of symmetry to flip the object. The new position of the object is shown faintly until the mouse is released.

7) Release the mouse button and the object will appear flipped over. Angle and position of the flip will depend on the angle and position of the axis of symmetry.

**Note**

Press the Shift key while moving the axis of symmetry to rotate it in 45-degree increments.

**Mirror copies**

Impress does not include a mirror command. However, mirroring an object can be emulated by flipping the object:

1) Select the object you want to make a mirror copy of and copy the object to the clipboard.

2) Flip the object using one of the methods in “Quick flipping” on page 147, then move the flipped object to one side.

3) Click on an empty area of the page to deselect the object.

4) Paste from the clipboard to put a copy of the object into your slide.
5) Select both images, then right-click and select **Alignment** from the context menu and select the type of alignment you want to use. **Top**, **Center**, or **Bottom** if you are creating a horizontal mirror copy. **Left**, **Centered**, or **Right** if you are creating a vertical mirror copy.

**Distorting images**

Three tools on the Transformations toolbar (Figure 134 on page 148) allow an object to be distorted.

- **Distort** – distorts an object in perspective.
- **Set to circle (slant)** and **Set in Circle (perspective)** – both create a pseudo 3D effect.

**Note**

When using these tools, an object has to be transformed to a curve before distorting. Transforming an object into a curve cannot be reversed and can only be undone by using the **Undo** function.

**Distort tool**

1) Select an object and click on the **Distort** icon on the Transformations toolbar.

2) Click **Yes** to convert the object to a curve. If the object is already a curve, this dialog does not appear.

3) Click and drag a corner selection handle to distort the object using the opposite corner selection handle as an anchor point for the distortion (Figure 135).

4) Click and drag the vertical selection handles to distort the object using the opposite vertical side as an anchor point for the distortion.

5) Click and drag the horizontal selection handles to distort the object using the opposite horizontal side as an anchor point for the distortion.

*Figure 135: Example of object distortion*
Set in Circle (perspective) tool

1) Select an object and click on the Set in Circle (perspective) icon in the Transformations toolbar.

2) Click Yes to convert the object to a curve. If the object is already a curve, this dialog does not appear.

3) Click and drag one of the selection handles to give a pseudo 3D perspective using the opposite side as an anchor point (Figure 136). A ghosted image appears as you drag to give an indication of how the resulting object will look.

Set to circle (slant) tool

1) Select an object and click on the Set to circle (slant) tool in the Transformations toolbar.

2) Click Yes to convert the object to a curve. If the object is already a curve, this dialog does not appear.

3) Click and drag one of the selection handles to give a pseudo 3D perspective using the opposite side as an anchor point (Figure 137). A ghosted image appears as you drag to give an indication of how the resulting object will look.

Aligning objects

Use the alignment tools in LibreOffice to adjust the relative position of an object compared to another object. These alignment tools are only active if two or more objects are selected. The alignment options are as follows:

- **Left, Centered, Right** – determines the horizontal alignment of selected objects.
- **Top, Center, Bottom** – determines the vertical alignment of selected objects.

Select the objects you want to align and use one of the following methods to access the align options:

- Click on the triangle ▼ to the right of Align on the Line and Filling toolbar. Select an alignment option from the tools available. The Align icon shown on the Line and Filling toolbar will depend on the last tool used.

- Go to View > Toolbars > Align Objects on the Menu bar to open the Align Objects toolbar (Figure 120 on page 132). Select an alignment option from the tools available.

- Right-click on the group of selected objects and select Align and then one of the alignment options from the context menu.
Using grid or snap functions

In Impress, you can also position objects accurately and consistently using grid points, snap points and lines, object frames, individual points on objects, or page edges. This function is known as Snap. It allows you to position an object in exactly the same place on multiple slides.

![Grid dialog](image)

**Figure 138: Grid dialog**

It is easier to use snap functions at the highest practical zoom value for your presentation. You can use two different snap functions at the same time. For example, snapping to a guide line and the slide edge. It is recommended to activate only those snap functions that you really need.

**Configuring grid and snap**

To configure the grid and snap in your presentation, go to **Tools > Options > LibreOffice Impress > Grid** on the Menu bar to display the Grid dialog (Figure 138).

- **Grid** – specifies the settings for the configurable grid on your slides. This grid helps you determine the exact position of your objects. You can also set this grid in line with the snap grid. If you have activated the snap grid but wish to move or create individual objects without snap positions, keep the **Shift** key pressed to deactivate this function for as long as needed.
  - **Snap to grid** – specifies whether to move frames, drawing elements, and controls only between grid points. To change the status of the snap grip only for the current action, drag an object while holding down the **Ctrl** key.
  - **Visible grid** – specifies whether to display the grid.

- **Resolution**
  - **Horizontal** – defines the unit of measure for the spacing between grid points on the X-axis.
  - **Vertical** – defines the grid points spacing in the desired unit of measurement on the Y-axis.

- **Subdivision**
  - **Horizontal** – specify the number of intermediate spaces between grid points on the X-axis.
  - **Vertical** – specify the number of intermediate spaces between grid points on the Y-axis.

- **Synchronize axes** – specifies whether to change the current grid settings symmetrically. The resolution and subdivision for the X and Y axes remain the same.
Snap

- **To snap lines** – snaps the edge of a dragged object to the nearest snap line when you release the mouse button. You can also define this setting by using **Snap to Snap Guides** on the Options toolbar (Figure 139).

![Options toolbar]

*Figure 139: Options toolbar*

- **To the page margins** – specifies whether to align the contour of the graphic object to the nearest page margin. The cursor or a contour line of the graphics object must be in the snap range. In a drawing, this function can also be accessed with **Snap to page Margins** in the Options toolbar.

- **To object frame** – specifies whether to align the contour of the graphic object to the border of the nearest graphic object. The cursor or a contour line of the graphics object must be in the snap range. In drawing, this function can also be accessed with **Snap to Object Border** in the Options toolbar.

- **To object points** – specifies whether to align the contour of the graphic object to the points of the nearest graphic object. This only applies if the cursor or a contour line of the graphics object is in the snap range. In a drawing, this function can also be accessed with **Snap to Object Points** in the Options toolbar.

- **Snap range** – defines the snap distance between the mouse pointer and the object contour. Snaps to a snap point if the mouse pointer is closer than the distance selected.

Constrain Objects

- **When creating or moving objects** – specifies that graphic objects are restricted vertically, horizontally or diagonally (45°) when creating or moving them. You can temporarily deactivate this setting by pressing the **Shift** key.

- **Extend edges** – specifies that a square is created based on the longer side of a rectangle when the **Shift** key is pressed before you release the mouse button. This also applies to an ellipse (a circle will be created based on the longest diameter of the ellipse). When **Extend edges** is not selected, a square or a circle will be created based on the shorter side or diameter.

- **When rotating** – specifies that graphic objects can only be rotated within the rotation angle that you selected. If you want to rotate an object outside the defined angle, press the **Shift** key when rotating. Release the key when the desired rotation angle is reached.

- **Point reduction** – defines the angle for point reduction. When working with polygons, you might find it useful to reduce their editing points.

The grid and snap functions can also be displayed and switched on or off using one of the following methods:

- Go to **Tools > Options > LibreOffice Impress > Grid** on the Menu bar to display the Grid dialog.

- Right-clicking on a slide and using the options in the context menu.

- Using the tools in the Options toolbar. If the Options toolbar is not open, go to **View > Toolbars > Options** on the Menu bar.
Snap to grid

Using Snap to Grid

Use the Snap to Grid function to move an object exactly onto a grid point in a slide. This function can be switched on and off using one of the following methods:

- Go to View > Snap Guides > Snap to Grid on the Menu bar.
- Right-click on a slide and selecting Snap Guides > Snap to Grid from the context menu.
- Click on Snap to Grid on the Options toolbar.

Displaying grid

Display or turn off the grid in a presentation using one of the following methods:

- Go to View > Grid and Helplines > Display Grid on the Menu bar.
- Click on Display Grid on the Options toolbar.
- Right-click on a slide and select Grid and Helplines > Display Grid from the context menu.
- Selecting Visible grid option in the Grid dialog.

Changing color of grid points

By default and depending on your display and computer setup, the grid points are gray and are not always easy to see. To change the color of the grid points, go to Tools > Options > LibreOffice > Application Colors to open the Application Colors dialog (Figure 140). In the Drawing/Presentation section, select a more suitable color for the grid from the drop-down list.

Snap points and lines

Unlike the grid, snap lines and snap points are inserted when you want to position an object to a specific position on a slide. Snap lines can either be horizontally or vertically and appear as dashed lines. Snap points appear as small crosses with dashed lines. Snap points and snap lines do not appear in printed output.

Inserting snap points and lines

To insert a snap point or line use one of the following methods to open the New Snap Object dialog (Figure 141):

- Go to Insert > Snap Guide on the Menu bar.
- Right click in an empty space on a slide and select Insert Snap Guide from the context menu.
The options available in the New Snap Object dialog are as follows:

- **Position** – sets the position of a selected snap point or line relative to the top left corner of the page.
  - $X$ – enter the amount of space required between the snap point or line and the left edge of the page.
  - $Y$ – enter the amount of space required between the snap point or line and the top edge of the page.

- **Type** – specifies the type of snap object required.
  - *Point* – inserts a snap point. Both $X$ and $Y$ text boxes are active.
  - *Vertical* – inserts a vertical snap line. Only $X$ text box is active.
  - *Horizontal* – inserts a horizontal snap line. Only $Y$ text box is active.

**Tip**

When positioning snap lines, it is useful to display the rulers by selecting **View > Rulers** on the Menu bar. Drag a snap line directly onto a slide by clicking on the horizontal or vertical ruler and dragging a snap line onto the slide.

**Displaying snap points and lines**

Display or turn off snap points and lines in a presentation using one of the following methods:

- Go to **View > Snap Guides > Display Snap Guides** on the Menu bar.
- Click on **Display Snap Guides** on the Options toolbar.
• Right-click on a slide and select **Snap Guides > Display Snap Guides** from the context menu.

**Editing snap points and lines**

Edit a snap point as follows:

1) Right-click on a snap point and select **Edit Snap Point** from the context menu to open the **Edit Snap Point** dialog (Figure 142).

2) Enter new X and Y coordinate settings for the snap point and click **OK**. Alternatively, drag the snap point to a new position on the slide.

![Figure 142: Edit Snap Point dialog](image)

**Editing snap line**

Edit a snap line as follows:

1) Right-click on a snap line and select **Edit Snap Line** from the context menu to open the **Edit Snap Line** dialog (Figure 143).

2) Enter a new X coordinate setting for vertical snap lines or a new Y coordinate setting for horizontal snap lines and click **OK**. Alternatively, drag a snap line to a new position on the slide.

![Figure 143: Edit Snap Line dialog](image)

**Deleting snap points and lines**

1) Right-click on a snap point or line.

2) Select **Delete Snap Point** or **Delete Snap Line** from the context menu.

**Note**

Clicking on **Delete** in the Edit Snap Point or Edit Snap Line dialog also deletes a snap point or snap line.

**Configuring snap range**

To configure the snap range of when an object snaps to a position.

1) Go to **Tools > Options > LibreOffice Impress > Grid** on the Menu bar to open the Grid dialog (Figure 138 on page 151).
2) Enter the number of pixels to set the proximity of when the object snaps into position in the *Snap range* text box. The default setting is 5 pixels.

3) Click **OK** to set the new snap range and close the dialog.

**Using Helplines**

Helplines are a function in Impress to help position objects and can be displayed while an object is being moved. They extend from the edges of the object to the rulers at the top and left side of your workspace and do not have a snap function (Figure 144).

![Figure 144: Example of using helplines](image)

Use one of the following methods to display helplines while moving an object:

- Go to **Tools > Options > LibreOffice Impress > View** to open the View dialog (Figure 145) on the Menu bar and select **Helplines while moving** option.
- Click on **Helplines While Moving** on the Options toolbar.
- Right-click in an empty area on a slide and select **Grid and Helplines > Helplines While Moving** from the context menu.
Arranging objects

Impress organizes objects in a stack so that the objects on the top level of the stack cover the objects on lower levels if any overlapping occurs. The stack level of each object can be changed by arranging shapes on a slide.

Select an object or objects and use one of the following methods to change the stack level:

- Click on the required arrange tool on the Line and Filling toolbar.
- Right-click on selected objects and select Arrange, then select the required arrange option from the context menu.

The options available for arranging the object stack level on a slide are as follow:

- **Bring to Front** (Ctrl+Shift++) – the selected object is moved in front of all other objects.
- **Bring Forward** (Ctrl++) – the selected object is moved one level up in the stack.
- **Send Backward** (Ctrl+-) – the selected object is moved one level down in the stack.
- **Send to Back** (Ctrl+Shift+-) – the selected object is moved behind all other objects.
- **In Front of Object** – moves the first selected object in front of the second selected object. Select the first object, then click on the second object and the objects swap position.
- **Behind Object** – moves the first selected object behind the second selected object. Select the first object, then click on the second object and the objects swap position.
- **Reverse** – swaps the stacking order of two selected objects.

Connectors and glue points

Connectors are lines that can be anchored to glue points and by default are positioned on the border of an object. When an object with a connector attached is moved or resized, the connector automatically adjusts to the change. When creating a flowchart, organization chart, schematics, or diagrams, it is highly recommended to use connectors instead of simple lines.

Connectors

When a connector is drawn or selected, Impress displays selection handles that are different to the selection handles for normal lines. The termination points of a connector are square at the start of a connector and round at the end of a connector. The selection handles on a connector line are used to change the routing of a connector where applicable.

Impress offers a wide variety of predefined connectors, which differ in the termination shape (none, arrow, custom) and in the way the connector is drawn (straight, line, curved).

**Drawing connectors**

1) Click on the triangle ▼ to right of Connectors on the Drawing toolbar (Figure 109 on page 129) to open the Connectors sub-toolbar (Figure 112 on page 130). The Connectors icon shown on the Drawing toolbar depends on the last connector that had been previously used.

2) Select the type of connector required from the Connectors sub-toolbar.
3) Move the mouse cursor over one of the objects to be connected and small crosses appear around the object edges, normally in the same position as selection handles. These crosses are the glue points to which a connector can be attached (Figure 146).

4) Click on the required glue point to attach one end of the connector, then hold the mouse button down and drag the connector to another object.

5) When the cursor is over the glue point of the target object release the mouse button and the connector is drawn.

6) The selection handles that appear on the connector are used to adjust the path of the connector so that the connector does not cover another object in its path.

**Connector types**

The full range of predefined connectors can be accessed by clicking on the triangle ▼ on the title bar of the Connectors sub-toolbar and selecting **Visible Buttons** (Figure 112 on page 130). The connectors available on the toolbar are indicated either by the connector icon being highlighted or by a check mark against the name.

Connectors fall into four type groups:

- **Standard connectors** – connector name starts with **Connector**. Line segments run vertically and horizontally. Draws a connector with one or more 90-degree angle bends.

- **Line connectors** – connector name starts with **Line**. Consists of a line segment with two smaller segments at the ends and draws a connector that bends near a glue point. To adjust the length of the line segment between a bend point and a glue point, click the connector and drag the bend point.

- **Straight connectors** – connector name starts with **Straight**. Consists of a single line and draws a straight line connector.

- **Curved connectors** – connector name starts with **Curved**. Based on Bézier curves and curve around objects. Draws a curved line connector.

**Formatting connectors**

To detach or reposition a connector, click and drag either end of the connector line to a different location.

To change the connector route between objects avoiding any objects on the route, click on a control point on the connector line and drag it to a new position. In Figure 147, the control points are shown as small squares.

To change a connector type, right-click on the connector and select **Connector** from the context menu to open the Connector dialog (Figure 148). Use this dialog to select a connector type and change the connector properties.
- **Line skew** – defines the skew of the line and the dialog preview displays the result.
- **Line spacing** – sets the spacing for the connectors.
  - *Begin horizontal* – enter the amount of horizontal space you want at the beginning of the connector.
  - *Begin vertical* – enter the amount of vertical space you want at the beginning of the connector.
  - *End horizontal* – enter the amount of horizontal space you want at the end of the connector.
  - *End vertical* – enter the amount of vertical space you want at the end of the connector.
- **Preview window** – a left click zooms in on the preview and a right click zooms out.

![Figure 147: Connector between two objects](image)

![Figure 148: Connector dialog](image)

**Note**

You cannot swap the ends of the connector using the Connector dialog, that is start point becomes the end point and the end point becomes the start point. To swap the ends of a connector, you have to draw a new connector in the opposite direction.
Glue points

Glue points are not the same as the selection handles of an object. The selection handles are for moving or changing the shape of an object. Glue points are used to fix or glue a connector to an object so that when the object moves, the connector stays fixed to that object.

All objects have glue points, which are not normally displayed and only become visible when Connectors on the Drawing toolbar is selected. Note that the Connectors icon changes shape depending on the last connector tool used.

To add, customize or delete glue points on an object, open the Gluepoints toolbar (Figure 149) using one of the following methods:

- Go to View > Toolbars > Gluepoints on the Menu bar.
- Go to Edit > Glue Points on the Menu bar.
- Click on Show Glue Point Functions on the Drawing toolbar.

Glue point types

When the Gluepoints toolbar (Figure 149) opens, only the six tools on the left of the toolbar are active. The remaining six tools on the right of the toolbar only become active when Glue Point Relative is deselected.

The following briefly describes the function of each tool on the Gluepoints toolbar:

- **Insert Glue Point** – inserts a glue point when you click on an object.
- **Exit Direction Left** – connector attaches to the left edge of the selected glue point.
- **Exit Direction Top** – connector attaches to the top edge of the selected glue point.
- **Exit Direction Right** – connector attaches to the right edge of the selected glue point.
- **Exit Direction Bottom** – connector attaches to the bottom edge of the selected glue point.
- **Glue Point Relative** – maintains the relative position of a selected glue point when you resize an object. This tool is selected by default when the Gluepoint toolbar opens.

The following six tools only become active when the Glue Point Relative tool is deselected.

- **Glue Point Horizontal Left** – when the object is resized, the current glue point remains fixed at the left edge of the object.
- **Glue Point Horizontal Center** – when the object is resized, the current glue point remains fixed at the center of the object.
- **Glue Point Horizontal Right** – when the object is resized, the current glue point remains fixed at the right edge of the object.
- **Glue Point Vertical Top** – when the object is resized, the current glue point remains fixed at the top edge of the object.
- **Glue Point Vertical Center** – when the object is resized, the current glue point remains fixed at the vertical center of the object.
- **Glue Point Vertical Bottom** – when the object is resized, the current glue point remains fixed at the bottom edge of the object.
Note

Each glue point you have added can have only one horizontal position and one vertical position. Only one of the horizontal position tools and one of the vertical position tools can be selected and used at any one time.

Adding glue points

By default, most objects normally have four glue points. Add additional glue points to an object as follows:

1) Make sure no objects are selected and use one of the following methods to open the Gluepoints toolbar:
   - Go to View > Toolbars > Gluepoints on the Menu bar.
   - Go to Edit > Glue Points on the Menu bar.
   - Click on Show Glue Point Functions on the Drawing toolbar.

2) Select the object, then click on Insert Glue Point on the Gluepoints toolbar. Alternatively, right click on a glue point you have previously inserted and select Insert Glue Point from the context menu.

3) Move your cursor to a position where you want the glue point on an object and click to insert the glue point.

4) Select the type of glue point required from the options on the Gluepoints toolbar.

5) To move a glue point to another position, click on the glue point and drag it to its new position.

Tip

When adding, moving or customizing glue points, it is recommended to use the zoom function to make it easier to work with glue points. Also, glue points snap to the grid making it easier to position a glue point.

Customizing glue points

Only glue points that have been added to an object can be customized. The default glue points included with an object cannot be customized.

Customize the exit direction for an added glue point as follow:

1) Make sure no objects are selected and use one of the following methods to open the Gluepoints toolbar:
   - Go to View > Toolbars > Gluepoints on the Menu bar.
   - Go to Edit > Glue Points on the Menu bar.
   - Click on Show Glue Point Functions on the Drawing toolbar.

2) Double-click on a glue point that you have added to select the glue point for customization.

3) Select an exit direction you want to use for the connector from the options available on the Gluepoints toolbar, or right click on the glue point and select the exit direction from the context menu.

Customize the horizontal and vertical positioning for the added glue point as follow:

1) Make sure no objects are selected and use one of the following methods to open the Gluepoints toolbar:
– Go to View > Toolbars > Gluepoints on the Menu bar.
– Go to Edit > Glue Points on the Menu bar.
– Click on Show Glue Point Functions on the Drawing toolbar.

2) Double-click on a glue point that you have added to select the glue point for customization.

3) Click on Glue Point Relative on the Gluepoints toolbar to deselect this tool, or right-click on the glue point and deselect Glue Point Relative from the context menu.

4) Select the horizontal and vertical positioning tools you want to use for the glue point. Only one horizontal positioning tool and one vertical positioning tool can be used at any one time.

Deleting glue points

Only glue points that have been added to an object can be deleted. The default glue points included with an object cannot be deleted.

1) Select the glue point you have previously added and now want to delete.

2) Press the Delete key or go to Edit > Cut on the Menu bar.

Working with 3D objects

Although Impress offers advanced functions to manipulate 3D objects, this guide describes only the 3D settings applicable to an object. For additional information on how to use advanced 3D effects such as geometry and shading, refer to the Draw Guide.

3D objects can be created in Impress in any of the following ways:

• Click on the triangle ▼ to the right of 3D Objects on the Drawing toolbar and select a 3D object from the drop down list. After selection, draw your 3D object on a slide as you would with any object. The 3D Objects icon shown on the Drawing toolbar depends on the 3D object that had been previously selected and used.

• Go to View > Toolbars > 3D-Objects on the Menu bar to open the 3D-Objects toolbar (Figure 119 on page 132). The selection and drawing of 3D objects is the same as using 3D Objects on the Drawing toolbar.

• Right-click on an object already drawn on a slide and select Convert > To 3D or To 3D Rotation Object from the context menu. To 3D adds thickness to the object to create a 3D object. To 3D Rotation Object creates a 3D object by rotating the object around an axis.

• Select an object and click on Toggle Extrusion on the Drawing toolbar to apply a basic 3D effect and open the 3D-Settings toolbar (Figure 150). Select one of the options on the 3D-Settings toolbar to apply a different 3D effect.

The options available on the 3D-Settings toolbar are as follows:

• Toggle Extrusion – adds thickness to an object and activates the 3D properties.
• Tilt Down – tilts the object downwards around a horizontal axis.
• Tilt Up – tilts the object up around a horizontal axis.
• **Tilt Left** – tilts the object left around a vertical axis.

• **Tilt Right** – tilts the object right around a vertical axis.

• **Depth** – determines the thickness of the shape. An extended toolbar opens where some default values are given. If none of the values are satisfactory, select *Custom* and then enter the desired thickness.

• **Direction** – clicking on the triangle ▼ to the right of the icon opens a sub-toolbar that lets you select the direction of the perspective as well as the type (parallel or perspective).

• **Lighting** – clicking on the triangle ▼ to the right of the icon opens a sub-toolbar that lets you specify the direction and intensity of light.

• **Surface** – clicking on the triangle ▼ to the right of the icon opens a sub-toolbar that allows you to specify the type of surface from *Wire Frame* (useful when manipulating the object), *Matt*, *Plastic*, or *Metal*.

• **3D Color** – clicking on the triangle ▼ to the right of the icon opens a color palette letting you select a color for the object thickness.

---

**Note**

Most of the Fontwork shapes (see “Fontwork” on page 165) have 3D properties and can be manipulated with the 3D-Settings toolbar.

---

**Converting objects**

You can convert an object into a different type using one of the following methods:

• Right-click on the object and select **Convert** from the context menu, then select a conversion option from the context menu.

• Select an object and go to **Format > Convert** on the Menu bar and select a conversion option from the context menu.

The conversion options are as follows:

• **To Curve** – converts the selected object to a Bézier curve. Click on **Points** on the Drawing toolbar to edit the points after conversion to a Bézier curve.

• **To Polygon** – converts the selected object to a polygon. Click on Points on the Drawing toolbar to edit the object after conversion to a polygon. A polygon always consists of straight segments.

• **To Contour** – for basic shapes and is equivalent to converting to polygon. For more complex shapes (or for text objects) this conversion creates a group of polygons that you can then manipulate by entering the group.

• **To 3D** – converts the selected object to a 3D object.

• **To 3D Rotation Object** – creates a three-dimensional shape by rotating the selected object around its vertical axis.

• **To Bitmap** – converts the selected object to a bitmap.

• **To Metafile** – converts the selected object to Windows Metafile Format (WMF), containing both bitmap and vector graphic data.
Note
In most cases the conversion to a different type does not immediately produce visible results.

Tip
To Curve, To Polygon, To 3D, and To 3D Rotation Object can be added to the Drawing toolbar as additional tools by right-clicking in an empty area on the toolbar and selecting Visible Buttons. See Appendix B, Toolbars for more information.

Interaction with objects
You can associate an object to an action that is performed when it is clicked and this is called an interaction:

1) Select the object for interaction.
2) Open the Interaction dialog (Figure 151) using one of the following methods:
   - Click on Interaction on the Line and Filling toolbar.
   - Right-click on the object and select Interaction from the context menu.
   - Go to Format > Interaction on the Menu bar.
3) Select the interaction from the available options in Action at mouse click: and any parameters (if applicable) that maybe available. The Interaction dialog changes depending on the type of interaction selected. The interactions and parameters are explained in Table 3.
4) Click OK to save the changes and close the dialog.
5) To remove an interaction from a graphic object follow Steps 1 and 2 and then select No action as the interaction type at Step 3.

Table 3: Interaction types and their parameters

<table>
<thead>
<tr>
<th>Interaction</th>
<th>Parameters</th>
</tr>
</thead>
<tbody>
<tr>
<td>No action</td>
<td>No parameters.</td>
</tr>
<tr>
<td>Go to previous slide</td>
<td>No parameters.</td>
</tr>
<tr>
<td>Go to next slide</td>
<td>No parameters.</td>
</tr>
</tbody>
</table>
### Interaction Parameters

<table>
<thead>
<tr>
<th>Interaction</th>
<th>Parameters</th>
</tr>
</thead>
<tbody>
<tr>
<td>Go to first slide</td>
<td>No parameters.</td>
</tr>
<tr>
<td>Go to last slide</td>
<td>No parameters.</td>
</tr>
<tr>
<td>Go to page or object</td>
<td>Specify the target from the list in the Target box. You can search for a specific target in the Slide/Object box at the bottom of the screen.</td>
</tr>
<tr>
<td>Go to document</td>
<td>Select the document in the Document box. Use Browse to open a file browser. If the document to be opened is in Open Document Presentation format, the target list will be populated allowing selection of the specific target.</td>
</tr>
<tr>
<td>Play sound</td>
<td>Select the file containing the sound to be played. Use Browse to open a file browser.</td>
</tr>
<tr>
<td>Run program</td>
<td>Select the program to execute. Use Browse to open a file browser.</td>
</tr>
<tr>
<td>Run macro</td>
<td>Select a macro that will run during the presentation. Use Browse to open the Macro Selector dialog.</td>
</tr>
<tr>
<td>Exit presentation</td>
<td>When the mouse is clicked over the object, the presentation will terminate.</td>
</tr>
</tbody>
</table>

### Fontwork

With Fontwork you can create graphical text art objects to make your work more attractive. There are many different settings for text art objects (line, area, position, size, and more), so you have a large choice. For more information about Fontwork, see the Getting Started Guide.

Fontwork is also available with the Writer, Calc, and Draw modules of LibreOffice, but you will notice small differences in the way that each component displays it.

#### Creating Fontwork

1. Click on Fontwork on the Standard toolbar or go to Insert > Fontwork on the Menu bar to open the Fontwork Gallery dialog (Figure 152).

2. Select a Fontwork style from the dialog and click OK. The selected Fontwork appears on your slide and the dialog closes.

3. Double-click on the word Fontwork to switch on editing mode.

4. Type your own text to replace the word Fontwork and your text appears over the word Fontwork as shown in Figure 153.

5. Press the Esc key or click outside the selected area and your text replaces the word Fontwork.
Figure 152: Fontwork Gallery dialog

Figure 153: Editing Fontwork text

Figure 154: Fontwork toolbar

Figure 155: Fontwork Shape toolbar
Fontwork toolbar

The Fontwork toolbar (Figure 154) becomes visible and active on the workspace when you select a Fontwork object. If the toolbar is not visible, go to **View > Toolbars > Fontwork** on the Menu bar. The Fontwork toolbar contains the following tools:

- **Insert Fontwork Text** – opens the Fontwork Gallery dialog.
- **Fontwork Shape** – changes the shape of the selected object. Shapes available are shown in the Fontwork Shape toolbar (Figure 155).
- **Fontwork Same Letter Heights** – changes the height of characters in the selected Fontwork object. Toggles between normal height where the characters have different heights to where all characters have the same height.
- **Fontwork Alignment** – specifies the text alignment within the frame. Options available are left align, center, right align, word justify, and stretch justify. The effects of the text alignment can only be seen if the text spans over two or more lines. In the stretch justify mode, all lines are filled completely.
- **Fontwork Character Spacing** – selects the spacing between characters and whether kerning pairs should be used. Options available are very tight, tight, normal, loose, very loose and custom spacing. For custom spacing, input a percentage value: 100% is normal character spacing, less than 100% character spacing is tighter, and more than 100% character spacing is looser.
- **Toggle Extrusion** – converts the Fontwork object into a 3D shape using extrusion. See the **Draw Guide** for more information.

Modifying Fontwork

It is possible to treat Fontwork text as an object and apply all the formatting that has been described in this chapter. Assign line properties only to Fontwork which does not have a 3D effect, otherwise the changes will not be visible. You can also modify some of the Fontwork shapes just as you modify the angles of trapezoid and parallelogram basic shapes by moving the dot that is displayed along with the selection handles.

Animations

Animated slide transitions can be added between slides to give your presentation a more professional look when you change to the next slide (see Chapter 9, Slide Shows for more information on transitions). However, Impress also allows you to add animations onto the slides to create more interest in your presentation.

An animation consists of a sequence of images or objects called frames that are displayed in succession when the animation runs. Each frame may contain one or more objects. For example, make bullet points appear one by one; make pictures, shapes or other objects appear singly or as a group onto a slide. Animations can be controlled using the keyboard, mouse click, or automatically in a timed sequence.

**Note**

Anything that can be placed onto a slide is an object. For example, an object can be an image, clip art drawing, text, and so on.
Animations can look great in a presentation, but overuse of animations can make a good presentation into a poor presentation. Always use discretion when adding animations to your presentation.

Creating an animation

1) Select an object on a slide.
2) Open the Animation deck in the Sidebar (Figure 156) using one of the following methods:
   - Click on Animation on the Sidebar.
   - Right-click on a selected object and select Animation from the context menu.
   - Go to View > Animation on the Menu bar.
3) Click on Add Effect to add the selected object into the Animation preview box.
4) Select a category type from the options available in the Category drop down list.
5) Select an animation effect from the options available in the Effects list.
6) Select how the animation starts from the options available in the Start drop down list.
7) Select how the animation appears from the options available in the Direction drop down list.
8) Enter a time in seconds for how long the animation lasts in the Duration box.
9) Enter a timing delay in seconds for when the animated object appears in the presentation in the Delay box.
If necessary, click on Options to open the Effect Options dialog to set any effect options required for the animation, then click OK to close the dialog.

If necessary, change the order of when the selected object appears in the animation using Move Up or Move Down below the Animation preview box.

Click on Play to preview the animation effect.

If necessary, select Automatic Preview so that each time the animation is changed, there is a preview of the effect.

When you are satisfied, run the slide show to check your presentation.

**Animation options**

The available options on the Animation deck on the Sidebar allows you to control how an object is animated on a slide.
• **Add Effect** – click on this tool to add a selected object to the Animation preview box and add animation effects to the object.

• **Remove Effect** – click on this tool to remove a selected object and its animated effects from the Animation preview box.

• **Move Up** – click on this tool to move the selected object and its animation effect up the order of animation effects that have been applied to an object.

• **Move Down** – click on this icon to move the selected animation effect down the order of animation effects that have been applied to an object.

• **Category** – select a category from the options available in the drop down list.

• **Effect** – select an animation effect from the options available in the list.

• **Start** – select from the drop-down list how an animation effect starts when running an animation:
  – *On click* – the animation stops at this effect until the next mouse click.
  – *With previous* – the animation runs immediately.
  – *After previous* – the animation runs as soon as the previous animation ends.

• **Direction** – select from the drop-down list how an animation effect appears on the slide. The options available depend on the animation effect selected.

• **Options** – click this icon to open the Effect Options dialog where you can select, adjust and apply options to the animation effect and timing.

• **Duration** – select the duration in seconds of the selected animation effect.

• **Delay** – select the delay in seconds of when the animation effect starts.

• **Automatic Preview** – select this option to automatically preview an animation effect when it is applied to an object.

• **Play** – click on this icon to test run the animation.

![Effect Options dialog - Effect page](image)

*Figure 157: Effect Options dialog - Effect page*
Effect Options dialog

Effect page
The Effect page (Figure 157) contains the following options:

- **Direction** – specifies the direction for the animation effect.
- **Sound** – select a sound from the drop-down list when the animation effect is run.
- **After animation** – select from the drop-down list what happens after an animation effect ends.
  - *Don’t dim* – no after-effect runs.
  - *Dim with color* – after the animation a dim color fills the shape.
  - *Hide after animation* – hides the shape after the animation ends.
  - *Hide on next animation* – hides the shape on the next animation.
- **Dim color** – select a dim color from the available color palettes.
- **Text animation** – select the animation mode for the text in an object:
  - *All at once* – animates the text all at once.
  - *Word by word* – animates the text word by word.
- **Delay between characters** – specifies the percentage of delay between animations of words or letters.

Timing page
The Timing page (Figure 158) contains the following options:

- **Start** – displays the start property of the selected animation effect.
  - *On click* – the animation stops at this effect until the next mouse click.
  - *With previous* – the animation runs immediately.
  - *After previous* – the animation runs as soon as the previous animation ends.
- **Delay** – specifies a delay in seconds before the effect starts.
Figure 158: Effect Options dialog - Timing page

- **Speed** – specifies the duration in seconds of the effect.
- **Repeat** – specifies whether and how to repeat the current effect. Enter the number of repeats, or select from the list:
  - *none* – the effect is not repeated.
  - *Until next click* – the animation is repeated until the next mouse click.
  - *Until end of slide* – the animation repeats as long as the slide is displayed.
- **Rewind when done playing** – specifies whether to let the animated object returns to its starting state after the animation ends.
- **Animate as part of click sequence** – specifies whether to let the animation start in the normal click sequence.
- **Start effect on click of** – specifies whether to let the animation start when a specified shape is clicked. Select the shape by its name from the drop-down list.

**Text Animation page**

The Text Animation page (Figure 159) contains the following options and only appears when text is selected for animation:

- **Group text** – specifies how the text is animated
  - *As one object* – the whole text object is animated.
  - *All paragraphs at once* – all text paragraphs are animated.
  - *By XX level paragraphs* – text for the outline level selected is animated. The options available depends on how many outline levels there are in the animated text.
- **Automatically after** – specifies a delay in seconds before the text animation effect starts.
- **Animate attached shape** – animates an object that contains text.
- **In reverse order** – text paragraphs are animated in reverse order.
Animated images

You can animate drawing objects, text objects, and graphic objects (images) on your slides to make your presentation more interesting. LibreOffice Impress provides a simple animation editor where you can create animation images (frames) by assembling objects from your slide. The animation effect is achieved by rotating through the static frames that you create.

Creating animated image

1) Select an object or group of objects that you want to include in your animation and go to Insert > Media > Animated Image to open the Animation dialog (Figure 160).

2) Add an object or objects using one of the following methods:
   – Click on Apply Object to add a single object or a group of objects to the current animation frame.
   – Click on Apply Objects Individually button to create a separate animation frame for each of the selected objects.

3) In Animation Group, select Bitmap object.

4) Enter the frame (image) number in the Image Number box for the image you want to setup.

5) In Duration specify the duration time in seconds for displaying a frame.
6) Specify the number of times a frame is displayed in the animation sequence in **Loop Count**. This is called looping.

7) Repeat Steps 4 thru 6 for each image or object used for the animated image.

8) Click on **Create** and the animated image appears centrally on the slide.

### Note

If the image to be copied consists of several objects, you can choose to treat each object as a separate frame. In this case, click on **Apply Objects Individually**. Remember that each object will be centered in the animation.

### Animation dialog controls

- **First Image** – jumps to the first image in the animation sequence.
- **Backwards** – plays the animation backwards.
- **Stop** – stops playing the animation.
- **Play** – plays the animation.
- **Last Image** – jumps to the last image in the animation sequence.
- **Image Number** – indicates the position of the current image in the animation sequence. If you want to view another image, enter its number or click the up and down arrows.
- **Duration** – enter the number of seconds to display the current image. This option is only available if you select Bitmap object in Animation group.
- **Loop Count** – sets the number of times that animation will play. If you want the animation to play continuously, select Max. This option is only available if you select Bitmap object in Animation group.
- **Apply Object** – adds selected object or objects as a single image.
- **Apply Objects Individually** – adds an image for each selected object. If you select a grouped object, an image is created for each object in the group.

### Note

You can also select an animation, such as an animated GIF, and click this icon to open it for editing. When you are finished editing the animation, click **Create** to insert a new animation into your slide.

- **Delete Current Image** – deletes the current image from the animation sequence.
- **Delete All Images** – deletes all images in the animation.
- **Number** – total number of images in the animation.
- **Group object** – assembles images into a single object so that they can be moved as a group. You can still edit individual objects by double-clicking the group in the slide.
- **Bitmap object** – combines images into a single image.
- **Create** – inserts the animation into the current slide.
Chapter 6
Formatting Graphic Objects
**Introduction**

The format of each graphic object, in addition to its size, rotation, and position on the slide, is determined by a number of attributes that define the line, text, and area fill of each object. These attributes (among others) also contribute to a graphics style. Although this chapter discusses mainly the manual formatting of objects, it concludes by showing how to create, apply, modify, and delete graphics styles.

---

**Note**

When you hover the mouse cursor over an icon or tool on a toolbar or in the Sidebar, a pop up will indicate the purpose of the icon or tool.

---

**Line formatting**

In LibreOffice the term line indicates both a freestanding segment (line), the outer edge of a shape (border), or an arrow. In most cases the properties of the line you can modify are its style (solid, dashed, invisible, and so on), its width, color, and the type of arrowhead.

**Line and Filling toolbar**

Format a line using the Line and Filling toolbar (Figure 161) as follows:

1. Make sure the line is selected on a slide.
2. Select the line style from the Line Style drop-down list.
3. Either type the line width in the Line Width text box, or use the up and down arrows to change the line width.
4. Click on the triangle ▼ to the right of Line Color and select a color from one of the color palettes that are available.
5. Select from an Arrow Style drop-down list the type of arrowhead for each end of the line and change the line into an arrow. The left drop-down list adds an arrow head to the beginning of the line. The right drop-down list adds an arrow head to the end of the line.
6. If necessary, click on Shadow to add a shadow to the line. The shadow applied uses the settings set in the Line dialog (Figure 166 on page 180).
7. Deselect the line to save the changes to the line.

![Figure 161: Line and Filling toolbar](image)

**Sidebar**

To format a line using the Line section in the Properties deck on the Sidebar (Figure 162):

1. Make sure the line is selected in a slide.
2. Click on Properties on the Sidebar to open the Properties deck.
3. Click on the down arrowhead ▼ on the left of the Line title bar to open the Line section.
4) If necessary, select from the **Arrow Style** drop-down list the type of arrowhead for each end of the line and change the line into an arrow. The left drop-down list adds an arrow head to the beginning of the line. The right drop-down list adds an arrow head to the end of the line.

5) Select from the **Line Style** drop-down list the type of line from the options available.

6) Select the line width from the options in the **Width** drop-down list or enter a width in the **Custom Line Width** text box.

7) Select a line color from one of the color palettes that are available in the **Color** drop-down list.

8) Deselect the line to save the changes to the line.

9) If necessary, click on **More Options** in the right corner of the title bar opens the Line dialog (Figure 163) giving more control over formatting lines.
**Line dialog**

If you want to fully change the appearance of a line, then the Line dialog is used. This dialog consists of four pages: Line, Shadow, Line Styles and Arrow Styles and are explained in the following sections.

1) Select the line in a slide.
2) Open the Line dialog (Figure 163) using one of the following methods:
   - Go to Format > Object and Shape > Line on the Menu bar.
   - Right-click on the line and select Line from the context menu.
3) When you have made all changes to the selected line, click OK to close the dialog and save the changes. The preview box at the bottom of the dialog shows the effect of any changes made to a line.

**Lines**

The Line page in the Line dialog (Figure 163) is where the basic parameters of a line are set and is divided into three sections as follows.

- **Line Properties** – this section is on the left side and is used to set the following parameters:
  - *Style* – select a line style from the drop-down list.
  - *Color* – select a predefined color from the available color palettes. To create a custom color, see “Custom colors” on page 189 for more information.
  - *Width* – specifies the thickness of the line.
  - *Transparency* – sets the transparency percentage of a line. Figure 164 is an example of effect on different transparency percentages to lines when placed over an object.

- **Arrow Styles** – this section is only applicable to individual lines and is not used for lines that form the borders of an object.
  - *Start Style* – select the arrow style for the start of a line from the drop down list.
  - *Width* – specifies the thickness of the start arrow ending.
  - *End Style* – select the arrow style for the end of a line from the drop down list.
  - *Width* – specifies the thickness of the end arrow ending.

![Figure 164: Example of line transparency (0%, 25%, 50%, 75% left to right)](image-url)
Corner and Cap Styles – determines how the connection between two segments of a line looks. To appreciate the difference between corner and cap styles, choose a thick line style and observe how the preview changes as each option is selected.

- Corner style – select the shape used at the corners of the line from the drop down list. For a small angle between lines, a mitered shape is replaced with a beveled shape.
- Cap style – select the style of the line end caps from the drop down list. The caps are added to inner dashes as well.

Line shadows

Use the Shadow page (Figure 166) of the Line dialog to add and format a line shadow. The shadow settings in this dialog are the same as the shadow settings in the Area dialog (Figure 182 on page 200). Shadow settings in the Line dialog can have different values than the shadow settings in the Area dialog. For more information on shadow settings, see “Shadows” on page 199.

A quick way to apply a shadow to a line is using the Shadow tool on the Line and Filling toolbar (Figure 161 on page 176). Using the Shadow tool creates a shadow using the settings from the Shadow page in the Line dialog.

Line styles

Use the Line Styles page (Figure 167) to change the line style from the options available from the Line style drop down menu in Properties or create a new line style. An example of the line style selected or created is displayed at the bottom of the dialog page.

Create new line style

1) Open the Line dialog using one of the following methods:
   - Go to Format > Object and Shape > Line on the Menu bar.
   - Right-click on the line and select Line from the context menu.
2) Click on the Line Styles tab to open the Line Styles page (Figure 167).
3) Select from the Line style drop-down menu a style similar to the style you want to create.
4) Click Add and type a name for the new line style in the dialog that opens, then click OK to close the dialog.
5) In the Type drop down lists, select Dots or Dash. For lines with only dots or dashes, select Dots or Dash in both Type boxes.
6) In **Number**, specify the number of dots or dashes required. For different sized groups of dots or dashes, set a different quantity number in each **Number** box.

![Line dialog - Shadow page](image)

**Figure 166: Line dialog - Shadow page**

![Line dialog - Line Styles page](image)

**Figure 167: Line dialog - Line Styles page**

7) In **Length**, specify the length percentage for dashes. **Length** is not available if **Dots** has been selected for **Type**.

8) In **Spacing**, set a spacing percentage between the dots and/or dashes.

9) If necessary, select **Fit to line width** so that the new style fits the width of the selected line.

10) The new line style created is available only in the current document. If you want to use the line style in other documents, click on **Save Line Styles** and type a unique filename in the Save as dialog that opens. Saved line styles have the file extension of `.sod`.

11) To use a previously saved line style, click on **Load Line Styles**, then select a style from the list of saved styles and click on **Open** to load the style into your document.

12) If necessary, click on **Modify** to change the name of the style and follow Steps 4 thru 11 to create and use a new line style.

13) Click **OK** to save any changes and close the Line dialog.

**Deleting line styles**

1) Open the Line dialog using one of the following methods:
– Go to **Format > Object and Shape > Line** on the Menu bar.
– Right-click on the line and select **Line** from the context menu.

2) Click on the **Line Styles** tab to open the **Line Styles** page (Figure 167).

3) Select from the **Line style** drop-down the line style you want to delete.

4) Click on **Delete**, then confirm the deletion by clicking on **Yes** in the confirmation dialog that opens.

5) Click **OK** to save any changes and close the Line dialog.

---

**Note**

When deleting line styles, make sure that the line style is not used in another presentation.

---

**Arrow styles**

Use the **Arrow Styles** page (Figure 168) in the Line dialog to create new arrow styles, modify existing arrow styles, or load previously saved arrow styles.

---

**Note**

Any arrowhead created must be convertible to a curve. A curve is something you can draw without lifting a pencil. For example, a star can be converted to a curve, but a smiley face cannot.

---

**Creating arrow styles**

1) Draw a curve in the shape you want to use for the arrowhead, or create a shape and convert to a curve. The top of the shape must face upward (as shown in Figure 169) because this becomes the point of the arrow.

2) If necessary, select the shape, right-click and select **Convert > To Curve** from the context menu. If the shape is already a curve, **To Curve** will not be available.

3) Make sure the arrowhead shape is selected and open the Line dialog using one of the following methods:
   – Go to **Format > Object and Shape > Line** on the Menu bar.
   – Right-click on the line and select **Line** from the context menu.
4) Click on the **Arrow Styles** tab to open the **Arrow Styles** page (Figure 168).

5) Click on **Add**, type a name for the new arrow style in the dialog that opens and click **OK**. The new arrowhead style will appear at the bottom of the **Arrow style** drop down list.

6) The new arrow style created is available only in the current document. If you want to use this arrow style in other presentations, click on **Save arrow styles** and type a unique filename in the **Save as** dialog that opens. Saved arrow styles have the file extension of .soe.

7) To use a previously saved arrow styles, click on **Load arrow styles** and select the style from the saved list of styles. Click **Open** to load the style into your presentation.

8) If necessary, click on **Modify** to change the name of the style.

9) Click **OK** to save any changes and close the Line dialog.

**Deleting arrow styles**

1) Open the Line dialog using one of the following methods:
   - Go to **Format > Object and Shape > Line** on the Menu bar.
   - Right-click on the line and select **Line** from the context menu.

2) Click on the **Arrow Styles** tab to open the **Arrow Styles** page (Figure 168).
3) Select from the Arrow style drop-down the arrow style you want to delete.

4) Click on Delete, then confirm the deletion by clicking on Yes in the confirmation dialog that opens.

5) Click OK to save any changes and close the Line dialog.

**Note**

When deleting arrow styles, make sure that the arrow style has not been used in another presentation.

---

### Area fill formatting

The term area fill refers to the inside of an object that has an unbroken border, for example a rectangle, circle, star, pentagon and so on. An area fill can be a uniform color, gradient, hatching pattern, or bitmap (Figure 170). An area fill can also be made partly or wholly transparent and can throw a shadow.

---

**Figure 170: Examples of area fill types**

---

### Line and Filling toolbar

Tools on the Line and Filling toolbar (Figure 161 on page 176) provide a wide number of default fillings available to quickly format graphic objects. If this toolbar is not showing, go to View > Toolbars > Line and Filling on the Menu bar.

1) Select an object so that the selection handles are displayed.

2) From the Area Style/Filling drop-down list on the Line and Filling toolbar, select the type of fill required (None, Color, Gradient, Hatching, Bitmap, Pattern).

3) Deselect the object to save your changes.

**Note**

If you do not require an area fill for an object, select None from the options available when you click the left Area Style/Filling on the Line and Filling toolbar.
Sidebar

1) Make sure the object is selected in your drawing.

2) Click on Properties on the Sidebar to open the Properties deck, then click on the down arrowhead \( \downarrow \) on the left of the Area title bar to open the Area section (Figure 171).

3) Use the various options in the Fill and Transparency drop-down lists to format the fill and transparency of an object. For more information on area fills, see “Area dialog” on page 185.

4) Deselect the object to save your changes.

5) If necessary, click on More Options in the right corner of the Area title bar to open the Area dialog giving more control over the appearance of the object fill.

![Figure 171: Area section in Properties deck on Sidebar](image1)

![Figure 172: Area dialog - Area Color page](image2)
Area dialog

Use the Area dialog (Figure 172) to change existing area fills with greater control or create your own area fill.

1) Select the object you wish to edit.
2) Open the Area dialog using one of the following methods:
   – Go to Format > Object and Shape > Area on the Menu bar.
   – Right-click on the object and select Area from the context menu.
3) Click on the Area tab to open the Area page.
4) Select the type of area fill from the options available: None, Color, Bitmap, Gradient, Pattern, or Hatch. See “Area fill types” on page 185 for more information on area fill types.
5) Select the style of area fill from the options that become available. The number of available options will depend on the type of area fill selected above.
6) Click OK to close the Area dialog and save the changes.

Note

If an area fill for an object is not required, select None from the options available when you open the Area page in the Area dialog.

Area fill types

Color

1) Open the Area dialog and click on the Area tab to open the Area page.
2) Click on Color (Figure 172) to open the options available for a color fill.
3) In Palette, select your required palette from the drop down list and your required color from the available colors shown. All color fills available are solid colors.
   – Active – shows the present color fill of your selected object. After selecting a new color, a preview of the selected color appears in New.
   – Alternatively, enter the RGB or Hex values of a color in the appropriate text box.
   – Alternatively, click on Pick to open the Pick a Color dialog (Figure 173). Here you can pick a color from the color box or enter the RGB, Hex, HSB or CMYK values for your color.
   – If you have used a color before and would like to use it again, then select your color from those available in Recent Colors.
4) Click OK to close the dialog and save the changes. The area fill appears in the selected object.

Gradient

1) Open the Area dialog and click on the Area tab to open the Area page.
2) Click on **Gradient** (Figure 174) to open the options available for a gradient fill.

3) In **Gradient**, select your required gradient from the list of available gradients and it will appear in **Preview**.

4) To override the default gradient transition in your selection, deselect **Automatic** in **Options** and then enter the values for **Type**, **Increment**, **Angle**, **Border**, **From Color**, and **To Color** in the available boxes.

5) Click **OK** to close the dialog and save the changes. The area fill appears in the selected object.
Figure 174: Area dialog - Area Gradient page

Figure 175: Area dialog - Area Bitmap page
Bitmap

1) Open the Area dialog and click on the Area tab to open the Area page.
2) Click on Bitmap (Figure 175) to open the options available for a bitmap fill.
3) In Bitmap, select your required bitmap from the list of available bitmaps and it will appear in Preview. Alternatively, click on Add/Import and select an image from the file selection box that opens to use as a bitmap fill.
4) To override the settings for the bitmap in your selection, enter the Options values in the boxes for Style, Size, Position, Tiling Position, and Tiling Offset. See Table 5 on page 194 for information on Options.
5) Click OK to close the dialog and save the changes. The area fill appears in the selected object.

Pattern

1) Open the Area dialog and click on the Area tab to open the Area page.
2) Click on Pattern (Figure 176) to open the options available for a pattern fill.
3) In Pattern, select a pattern from the available patterns and it appears in Preview.
4) Click OK to close the dialog and save the changes. The area fill appears in the selected object.

Hatch

1) Open the Area dialog and click on the Area tab to open the Area page.
2) Click on Hatch (Figure 177) to open the options available for a hatch fill.
3) In Hatch, select a hatching from the list of available hatchings and it will appear in Preview.
Figure 177: Area dialog - Area Hatch page

4) To override the settings for the hatching in your selection, enter a new values for Options in the boxes for Spacing, Angle, Line type, Line color, and Background Color.

5) Click OK to close the dialog and save the changes. The area fill appears in the selected object.

Working with area fills

Although you can change the characteristics of an existing fill and then click the Modify button, it is recommended that you create new fills or modify custom fills rather than the predefined area fills. Predefined area fills may be reset when LibreOffice is updated.

Note

Color fills cannot be modified. You can only create custom color fills.

Custom colors

On the Color page of the Area dialog (Figure 172 on page 184), you can modify existing colors or create a color. You can specify a new color either as a combination of the three primary colors using RGB notation of Red (R), Green (G), and Blue (B) or using CMYK percentages of Cyan (C), Magenta (M), Yellow (Y), and Black (K).

Creating colors with Area dialog

1) Select the object you want to edit.

2) Open the Area dialog using one of the following methods:
   - Go to Format > Object and Shape > Area on the Menu bar.
   - Right-click on the object and select Area from the context menu.

3) Click on Area and then Color to open the Color page.
4) Specify the red (R), green (G), and blue (B) values on a 0 to 255 scale to create a new color.

5) Click on Add in Custom Palette and enter a name for the color in the Name dialog that opens.

6) Click OK to close the Name dialog and the color is added to the Custom Palette.

7) Click OK to save the changes and close the Area dialog. The new color appears as a fill in the selected object.

**Creating colors with Pick a Color dialog**

1) Select the object you want to edit.

2) Open the Area dialog using one of the following methods:
   - Go to Format > Object and Shape > Area on the Menu bar.
   - Right-click on the object and select Area from the context menu.

3) Click on Area and then Colors to open the Color page (Figure 172 on page 184).

4) Click on Pick to open the Pick a Color dialog (Figure 173 on page 186).

5) Create a new color using one of the following methods. A preview of the color created is shown in the colored box below the original color on the left side of the dialog.
   - Select a color range from the colored bar, then, using the mouse, move the target in the colored box until you are satisfied with the color selected.
   - Enter values for red (R), green (G), and blue (B) in the RGB text boxes.
   - Enter values for cyan (C), magenta (M), yellow (Y), and key (K) (black) in the CMYK text boxes.
   - Enter values for hue (H), saturation (S), and brightness (B) in the HSB text boxes. HSB values do not change the color, but how a color looks.

6) Click OK to close the Pick a Color dialog.

7) Click on Add in Custom Palette and enter a name for the color in the Name dialog that opens.

8) Click OK to close the Name dialog and the color is added to the Custom Palette.

9) Click OK to save the changes and close the Area dialog. The new color appears as a fill in the selected object.

**Deleting custom colors**

1) Select the object you want to edit.

2) Open the Area dialog using one of the following methods:
   - Go to Format > Object and Shape > Area on the Menu bar.
   - Right-click on the object and select Area from the context menu.

3) Click on Area and then Colors to open the Color page (Figure 172 on page 184).

4) Select Custom from the Palette drop-down list in Colors.

5) Select the color you want to delete and click on Delete. There is no confirmation given when deleting a color.

6) Click OK to save the changes and close the Area dialog.
Note

Only colors that you have created and placed in the custom palette can be deleted. You cannot delete colors from any of the other color palettes available in LibreOffice.

Custom gradients

You can modify existing gradients or create a custom gradient. Several types of gradients are predefined in LibreOffice and changing the From Color and To Color settings could be sufficient to obtain a satisfactory result.

Creating gradients

1) Select the object you want to edit.
2) Open the Area dialog using one of the following methods:
   – Go to Format > Object and Shape > Area on the Menu bar.
   – Right-click on the object and select Area from the context menu.
3) Click on Area and then Gradient to open the Gradient page (Figure 174 on page 187).
4) Select one of the predefined gradients shown in the Gradient box and the gradient appears in Preview.
5) In Options, select a gradient type from the Type drop down list: Linear, Axial, Radial, Ellipsoid, or Square. Each gradient type changes the gradient displayed in Preview.
6) Adjust the settings in Options as necessary. The options used to create a gradient are summarized in Table 4. Depending on the gradient type selected, some options will not be available.
7) Click on Add and enter a name for the gradient in the Name dialog that opens.
8) Click OK to close the Name dialog and the gradient is added to the gradient displayed in the Gradient box.
9) Click OK to close the Area dialog and save the changes.

Table 4: Gradient options

<table>
<thead>
<tr>
<th>Option</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Increment</td>
<td>Number of steps taken to change the color in From Color to the color in To Color. Minimum number of steps is 3; maximum number of steps is 256.</td>
</tr>
<tr>
<td>Center X</td>
<td>For Radial, Ellipsoid, Square, and Rectangular gradients, modify these values to set the horizontal offset of the gradient center.</td>
</tr>
<tr>
<td>Center Y</td>
<td>For Radial, Ellipsoid, Square, and Rectangular gradients, modify these values to set the vertical offset of the gradient center.</td>
</tr>
<tr>
<td>Angle</td>
<td>For all the gradient types, specifies the angle of the gradient axis.</td>
</tr>
<tr>
<td>Border</td>
<td>Increase this value to make the gradient start further away from the border of the object.</td>
</tr>
<tr>
<td>From Color</td>
<td>The start color for the gradient. In the edit box, enter the intensity of the color: 0% corresponds to black, 100% to the full color.</td>
</tr>
<tr>
<td>To Color</td>
<td>The end color for the gradient. In the edit box, enter the intensity of the color: 0% corresponds to black, 100% to the full color.</td>
</tr>
</tbody>
</table>
Modifying gradients

1) Select the object you want to modify.
2) Open the Area dialog using one of the following methods:
   - Go to Format > Object and Shape > Area on the Menu bar.
   - Right-click on the object and select Area from the context menu.
3) Click on Area and then Gradient to open the Gradient page.
4) Select a gradient you have previously created and added to the Gradients displayed in the Area dialog.
5) Enter the new values for the gradient options that you want to change. See Table 4 for more information on gradient options. Depending on the type of gradient selected, some options may not be available.
6) Click Modify to save your changes. There is no confirmation given when modifying a gradient.
7) Click OK to close the Area dialog and save the changes.

Renaming gradients

1) Select a filled object that uses a gradient fill that you want to rename.
2) Open the Area dialog using one of the following methods:
   - Go to Format > Object and Shape > Area on the Menu bar.
   - Right-click on the object and select Area from the context menu.
3) Click on Area and then Gradient to open the Gradient page.
4) Right click on the gradient and select Rename from the context menu.
5) Enter a name for the gradient in the Name dialog that opens.
6) Click OK save the change and close the Name dialog.
7) Click OK to save your changes and close the Area dialog.

Deleting gradients

1) Select the object you want to delete.
2) Open the Area dialog using one of the following methods:
   - Go to Format > Object and Shape > Area on the Menu bar.
   - Right-click on the object and select Area from the context menu.
3) Click on Area and then Gradient to open the Gradient page.
4) Select a gradient you have previously created and added to the Gradients displayed in the Area dialog.
5) Right click on the gradient and select Delete from the pop-up menu. Click on Yes to confirm the deletion.
6) Click OK to save your changes and close the Area dialog.
Note

It is recommended to only modify, rename or delete gradients that you have created. These custom gradients are always positioned at the bottom of the gradients displayed in the Gradient box. Modifying, renaming or deleting gradients that are installed with LibreOffice may cause problems in documents that use one of these gradients.

Advanced gradient controls

1) Select an object that contains a gradient as a fill.
2) Open the Area dialog using one of the following methods:
   - Go to Format > Object and Shape > Area on the Menu bar.
   - Right-click on the object and select Area from the context menu.
3) Click on Area and then Gradient to open the Gradient page.
4) Go to View > Toolbars > Transformations on the Menu bar or click on Transformations on the Line and Filling toolbar to open the Transformations toolbar (Figure 178).
5) Click Interactive gradient in the Transformations toolbar. This displays a dashed line connecting two colored squares. The colors show the From Color and To Color that are used for the selected gradient (Figure 179).
6) Select the type of gradient you want to use for the object from the Type drop-down list in Options on the Gradient page in the Area dialog. Properties you can adjust will depend on the gradient type you have selected and these are explained below.
   - Linear gradients – move the square corresponding to the From Color to change where the gradient starts (border value). Move the square corresponding to the To Color to change the orientation (angle value).
   - Axial gradients – move the To Color to change both the angle and border properties of the gradient. Only the square corresponding to the To Color can be moved.
   - Radial gradients – move the From Color to modify the border property to set the width of the gradient circle. Move the To Color to change the point where the gradient ends (Center X and Center Y values).
– **Ellipsoid gradients** – move the *From Color* to modify the border property to set the size of the gradient ellipsoid. Move the *To Color* to change the angle of the ellipsoid axis and the axis itself.

– **Quadratic gradients** – move the *From Color* to modify the border to set the size of the gradient square or rectangle and the angle of the gradient shape. Move the *To Color* to change the center of the gradient.

– **Square gradients** – move the *From Color* to modify the border to set the size of the gradient square or rectangle and the angle of the gradient shape. Move the *To Color* to change the center of the gradient.

7) Click **OK** to save your changes and close the Area dialog.

---

**Note**

Moving the squares will have different effects depending on the type of gradient. For example, for a linear gradient, the start and end squares of the gradient will always be situated to either side of the center point of the object.

---

**Custom bitmaps**

**Editing bitmaps**

1) Select an object that contains a bitmap as a fill or insert a bitmap into a selected object (see “Pattern” on page 188 for more information).

2) Open the Area dialog using one of the following methods:

   – Go to **Format > Object and Shape > Area** on the Menu bar.
   – Right-click on the object and select **Area** from the context menu.

3) Click on **Area** and then **Bitmap** to open the **Bitmap** page (Figure 175 on page 187).

4) Select a bitmap from the options available in **Bitmap** that you want use and edit as a fill. Note that any imported bitmaps will also be available.

5) In **Options**, select the properties for **Style**, **Size**, **Position**, **Tiling Position** and **Tiling Offset**. See Table 5 for more information on bitmap properties. The best way to understand bitmap properties is to use them. Figure 180 shows examples of bitmap fills.

6) Click **OK** to save your changes and close the Area dialog.

---

**Table 5: Bitmap options**

<table>
<thead>
<tr>
<th>Original bitmap</th>
</tr>
</thead>
<tbody>
<tr>
<td>Width and height 25% scaled</td>
</tr>
<tr>
<td>Anchor to top left corner</td>
</tr>
<tr>
<td>No offset</td>
</tr>
</tbody>
</table>

---

**Figure 180: Example of bitmap fills**

---

194 | Impress Guide
<table>
<thead>
<tr>
<th>Option</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Style – Custom position/size</td>
<td>When this option is selected, the position of the bitmap in the object and the size of the bitmap can be determined.</td>
</tr>
<tr>
<td>Style – Tiled</td>
<td>When this option is selected, the bitmap will be tiled to fill the area. The size of the bitmap used for the tiling is determined by the Size settings</td>
</tr>
<tr>
<td>Style – Stretched</td>
<td>When this option is selected, a bitmap will be stretched to fill object area.</td>
</tr>
<tr>
<td>Size – Width</td>
<td>Sets the width of the bitmap. For example, 100% means that the bitmap original width will be resized to occupy the whole fill area width, 50% means that the width of the bitmap will be half that of the fill area.</td>
</tr>
<tr>
<td>Size – Height</td>
<td>Sets the height of the bitmap. For example, 100% means that the bitmap original height will be resized to occupy the whole fill area height, 50% means that the height of the bitmap will be half that of the fill area.</td>
</tr>
<tr>
<td>Size – Scale</td>
<td>When selected, bitmap size is given as a percentage for Width and Height. When deselected, the actual size of the bitmap is given for Width and Height.</td>
</tr>
<tr>
<td>Position</td>
<td>When this option is selected, the anchoring point of the bitmap is determined. Default position is Center.</td>
</tr>
<tr>
<td>Tiling Position – X offset</td>
<td>When Tile is selected, sets the offset for the width of the bitmap in percentage values. 50% offset means that Impress will place the middle part of the bitmap at the anchor point and start tiling from there.</td>
</tr>
<tr>
<td>Tiling Position – Y offset</td>
<td>When Tile is selected, sets the offset for the height of the bitmap in percentage values. 50% offset means that Draw will place the middle part of the bitmap at the anchor point and start tiling from there.</td>
</tr>
<tr>
<td>Tiling Offset – Row</td>
<td>When Tile is selected, offsets the rows of tiled bitmaps by the entered percentage value so that each row is offset from the previous row.</td>
</tr>
<tr>
<td>Tiling Offset – Column</td>
<td>When Tile is selected, offsets the columns of tiled bitmaps by the entered percentage value so that each column is offset from the previous column.</td>
</tr>
</tbody>
</table>

**Importing bitmaps**

1) Select an object where you want to import a bitmap into the object.

2) Open the Area dialog using one of the following methods:
   - Go to Format > Object and Shape > Area on the Menu bar.
   - Right-click on the object and select Area from the context menu.

3) Click on Area and then Bitmap to open the Bitmap page.

4) Click on Add/Import and a file browser dialog opens.

5) Browse to the directory containing the bitmap file and select it, then click Open.

6) Enter a name for the new bitmap in the Name box, then click OK to close the Name box. The imported bitmap appears at the bottom of the Bitmap preview box.

7) Select the imported bitmap in the Bitmap preview box.

8) Click OK to import the imported bitmap into the selected object and close the Area dialog.

**Renaming bitmaps**

1) Select a filled object that uses a bitmap that you want to rename.
2) Open the Area dialog using one of the following methods:
   – Go to Format > Object and Shape > Area on the Menu bar.
   – Right-click on the object and select Area from the context menu.
3) Click on Area and then Bitmap to open the Bitmap page.
4) Right click on the bitmap and select Rename from the context menu.
5) Enter a name for the gradient in the Name box that opens.
6) Click OK save the change and close the Name box.
7) Click OK to save your changes and close the Area dialog.

**Deleting bitmaps**

1) Select an object that contains the bitmap you want to delete.
2) Open the Area dialog using one of the following methods:
   – Go to Format > Object and Shape > Area on the Menu bar.
   – Right-click on the object and select Area from the context menu.
3) Click on Area and then Bitmap to open the Bitmap page.
4) Right click on the bitmap in the Bitmap preview box that you want to delete.
5) Select Delete from the context menu and click on Yes to confirm the deletion.
6) Click OK to save your changes and close the Area dialog.

**Note**

It is recommended to only rename or delete bitmaps that you have created or imported. Renaming or deleting bitmaps that are installed with LibreOffice may cause problems in documents that use one of these bitmaps.

**Custom patterns**

**Creating or editing patterns**

1) Select an object that contains a pattern as a fill or insert a pattern into a selected object (see “Pattern” on page 188 for more information).
2) Open the Area dialog using one of the following methods:
   – Go to Format > Object and Shape > Area on the Menu bar.
   – Right-click on the object and select Area from the context menu.
3) Click on Area and then Pattern to open the Pattern page (Figure 176 on page 188).
4) Select a pattern from the options available in the Pattern preview box. Note that any imported patterns will also be available.
5) In Options, select the color you want to use from the available color palettes for the Foreground Color and Background Color.
6) In the Pattern Editor, start creating or editing the pattern by clicking with the left mouse button in the squares (pixels) that you want to fill with a different color. Each click in a square swaps the color from Background Color to Foreground Color or Foreground Color to Background Color. Check the Preview window to see if the desired effect is being achieved.
7) Click the Add button to open a Name box. Enter a name for the new pattern, then click OK to close the Name box. The new pattern appears at the bottom of the Pattern preview box.

8) Click OK to save your changes and close the Area dialog.

Modifying patterns
1) Select a filled object that uses a pattern that you want to modify.
2) Open the Area dialog using one of the following methods:
   - Go to Format > Object and Shape > Area on the Menu bar.
   - Right-click on the object and select Area from the context menu.
3) Click on Area and then Pattern to open the Pattern page.
4) Enter new colors for the Foreground Color and Background Color from the available color palettes.
5) In the Pattern Editor, start editing the pattern by clicking with the left mouse button in the squares (pixels) that you want to swap the color from Background Color to Foreground Color or Foreground Color to Background Color. Check the Preview window to see if the desired effect is being achieved.
6) Click Modify to save your changes. There is no confirmation given when modifying a hatch fill.
7) Click OK to close the Area dialog and save the changes.

Renaming patterns
1) Select a filled object that uses a pattern fill that you want to rename.
2) Open the Area dialog using one of the following methods:
   - Go to Format > Object and Shape > Area on the Menu bar.
   - Right-click on the object and select Area from the context menu.
3) Click on Area and then Pattern to open the Pattern page.
4) Right click on the pattern and select Rename from the context menu.
5) Enter a name for the bitmap in the Name box that opens.
6) Click OK to save the change and close the Name box.
7) Click OK to save your changes and close the Area dialog.

Deleting patterns
1) Select a filled object that uses a pattern fill that you want to delete.
2) Open the Area dialog using one of the following methods:
   - Go to Format > Object and Shape > Area on the Menu bar.
   - Right-click on the object and select Area from the context menu.
3) Click on Area and then Pattern to open the Pattern page.
4) Right click on the pattern and select Delete from the context menu. Click on Yes to confirm the deletion.
5) Click OK to save your changes and close the Area dialog.
Note

It is recommended to only modify, rename or delete patterns that you have created. Modifying, renaming or deleting patterns that are installed with LibreOffice may cause problems in documents that use one of these patterns.

Custom hatch fills

Creating new hatch fills or modifying an existing hatch fill, select the options available in Figure 177 on page 189. The options available are explained in Table 6. It is recommended to create a new hatch fill rather than modify an existing hatch fill.

Table 6: Hatch fill options

<table>
<thead>
<tr>
<th>Hatching option</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Spacing</td>
<td>Determines the spacing between two lines of the hatching fill. As the value is changed the preview window is updated.</td>
</tr>
<tr>
<td>Angle</td>
<td>Use the mini map below the numerical value to quickly set the angle formed by the line to multiples of 45 degrees. If the required angle is not a multiple of 45 degrees, just enter the desired value in the edit box.</td>
</tr>
<tr>
<td>Line type</td>
<td>Set single, double or triple line for the style of the hatching fill.</td>
</tr>
<tr>
<td>Line color</td>
<td>Use the list to select the color of the lines that will form the hatching fill.</td>
</tr>
<tr>
<td>Background color</td>
<td>When selected, adds a color fill behind the lines used for the hatching fill.</td>
</tr>
</tbody>
</table>

Creating hatch fills

1) Select an object that you want to use for a hatch fill.
2) Open the Area dialog using one of the following methods:
   - Go to Format > Object and Shape > Area on the Menu bar.
   - Right-click on the object and select Area from the context menu.
3) Click on Area and then Hatch to open the Hatch page (Figure 177 on page 189).
4) As a starting point, select a hatch fill similar to the one that you want to create.
5) Change the option settings of the lines forming the hatch fill. A preview is displayed in the Preview box. See Table 6 for information on hatch options.
6) Click on Add to open the Name box and enter a name for the new hatch fill.
7) Click OK to close the Name box. The new hatch fill appears at the bottom of the hatch fills displayed in the Hatch box.
8) Click OK to close the Area dialog and save the changes. The new hatch fill appears in the selected object.

Modifying hatch fills

1) Select a filled object that uses a hatch fill that you want to modify.
2) Open the Area dialog using one of the following methods:
   - Go to Format > Object and Shape > Area on the Menu bar.
   - Right-click on the object and select Area from the context menu.
3) Click on Area and then Hatch to open the Hatch page.
4) Enter new values for the option settings of the lines forming the hatch fill. A preview is displayed in the **Preview** box. See Table 6 for information on hatch options.

5) Click **Modify** to save your changes. There is no confirmation given when modifying a hatch fill.

6) Click **OK** to close the Area dialog and save the changes.

**Renaming hatch fills**

1) Select a filled object that uses a hatch fill that you want to rename.

2) Open the Area dialog using one of the following methods:
   - Go to **Format > Object and Shape > Area** on the Menu bar.
   - Right-click on the object and select **Area** from the context menu.

3) Click on **Area** and then **Hatch** to open the **Hatch** page.

4) Right click on the hatch fill and select **Rename** from the context menu.

5) Enter a name for the bitmap in the **Name** box that opens.

6) Click **OK** save the change and close the **Name** box.

7) Click **OK** to save your changes and close the Area dialog.

**Deleting hatch fills**

1) Select a filled object that uses a hatch fill that you want to delete.

2) Open the Area dialog using one of the following methods:
   - Go to **Format > Object and Shape > Area** on the Menu bar.
   - Right-click on the object and select **Area** from the context menu.

3) Click on **Area** and then **Hatch** to open the **Hatch** page.

4) Right click on the hatch fill and select **Delete** from the context menu. Click on **Yes** to confirm the deletion.

5) Click **OK** to save your changes and close the Area dialog.

---

**Note**

It is recommended to only modify, rename or delete hatch fills that you have created. Modifying, or renaming or deleting hatch fills that are installed with LibreOffice may cause problems in documents that use one of these hatch fills.

---

**Shadows**

Shadows can be applied to objects such as lines, shapes and text. The settings available and shown in Figure 182 are as follows:

- **Position** – select one of nine points determining the direction in which the shadow is cast.
- **Distance** – determines the offset distance between the object and the shadow.
- **Color** – sets the color used for the shadow.
- **Transparency** – determines the amount of transparency for the shadow: 0% opaque shadow, 100% transparent shadow.
**Area dialog – Shadow page**

1) Select an object where you want to apply a shadow.

2) Open the Area dialog using one of the following methods:
   - Go to **Format > Object and Shape > Area** on the Menu bar.
   - Right-click on the object and select **Area** to open the Area dialog.

3) Click on the **Shadow** tab to open the **Shadow** page (Figure 181).

4) Select **Use shadow** in **Properties** for the shadow settings to become active.

5) Select the anchor point for the direction of the shadow cast in relation to the object.

6) In **Color**, select the color palette and the color you require for the shadow.

7) In **Distance**, enter a distance in the text box to set spacing between the object and the shadow.

![Figure 181: Area dialog - Shadow page](image)

8) In **Transparency**, enter the percentage in the text box for the shadow transparency.

9) Click **OK** to close the Area dialog and save the changes.
Sidebar – Shadow section

1) Select an object where you want to apply a shadow.
2) Click on Properties to open the Properties deck on the Sidebar.
3) Click on Shadow to open the Shadow section (Figure 182) in the Properties deck.
4) Select Enable to add a shadow to the selected object.
5) In Angle, select the number of degrees from the options available in the drop down list to set the direction of the shadow is cast in relation to the object.
6) In Color, select the color palette and the color you require for the shadow.
7) In Distance, enter a distance in the text box to set spacing between the object and the shadow.
8) In Transparency, enter the percentage in the text box for the shadow transparency.
9) Deselect the object to save the changes made.

Line and Filling toolbar

1) Select an object where you want to apply a shadow.
2) Click on Shadow on the Line and Filling toolbar (Figure 161 on page 176). A shadow is created using the settings from the Shadow page in the Area dialog.
3) Deselect the object to save the changes made.

Transparencies

Transparencies can be applied to objects and to any shadow that has been applied to an object. In Impress two types of transparencies can be applied to an object – uniform transparency and gradient transparency. For more information on gradient transparencies, including an example of combining a color gradient with a gradient transparency, see “Custom gradients” on page 191.

To apply transparencies to lines, refer to “Line formatting” on page 176 for more information. To apply transparencies to shadows, refer to “Shadows” on page 199 for more information.

1) Select an object where you want to apply a transparency.
2) Open the Area dialog using one of the following methods:
Go to **Format > Object and Shape > Area** on the Menu bar.

Right-click on the object and select **Area** from the context menu.

3) Click on **Area** and then **Transparency** to open the **Transparency** page (Figure 183) in the Area dialog.

4) To create a uniform transparency, select **Transparency** and enter a percentage in the text box.

5) To create a gradient transparency so that the area becomes gradually transparent, select **Gradient** and select the type of gradient transparency from the drop-down list: *Linear, Axial, Radial, Ellipsoid, Quadratic* or *Square*.

6) Set the parameters for the type of the gradient transparency you selected above. Refer to Table 7 for a description of the properties. The available parameters depends on the type of gradient transparency.

7) Click **OK** to close the Area dialog and save the changes.

Table 7: Gradient transparency parameters

<table>
<thead>
<tr>
<th>Gradient transparency options</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Center X</td>
<td>For <em>Radial, Ellipsoid, Quadratic</em> and <em>Square</em> gradients. The values to set the horizontal offset of the gradient center.</td>
</tr>
<tr>
<td>Center Y</td>
<td>For <em>Radial, Ellipsoid, Quadratic</em> and <em>Square</em> gradients. The values to set the vertical offset of the gradient center.</td>
</tr>
<tr>
<td>Angle</td>
<td>For <em>Linear, Axial, Ellipsoid, Quadratic</em> and <em>Square</em> gradients. Specifies the angle of the gradient axis.</td>
</tr>
<tr>
<td>Border</td>
<td>Increase this value to make the gradient start further away from the border of the object.</td>
</tr>
<tr>
<td>Start value</td>
<td>Value for the starting transparency gradient. 0% is fully opaque, 100% means fully transparent.</td>
</tr>
<tr>
<td>End value</td>
<td>Value for the ending transparency gradient. 0% is fully opaque, 100% means fully transparent.</td>
</tr>
</tbody>
</table>

**Text in objects**

By default, an object is not dynamic when it is first created and does not behave like a text box. Text is typed in a single line and does not word wrap. To keep text within the borders of an object, use paragraphs, line breaks, smaller text size, increasing object size, or a combination of all four methods.

**Adding text**

1) Select an object where text will be added so that the selection handles are showing.

2) Put the selected object into text mode using one of the following methods. The cursor becomes a flashing text cursor centrally inside the object indicating text mode is active. The Text Formatting toolbar automatically opens replacing the Line and Filling toolbar.

   – Double-click on the object.
   – Click on **Insert Text Box** on the Drawing toolbar.
   – Use the keyboard shortcut **F2**.
   – Go to **Insert > Text Box** on the Menu bar.
Note

If double-clicking does not work, then go to View > Toolbars on the Menu bar and open the Options toolbar. Select Double-click to edit Text. Alternatively, use the keyboard shortcut F2.

3) To change to vertical text after the object is put into text mode, click on Insert Vertical Text on the Drawing toolbar.

4) Type your text. The text is centrally aligned horizontal and vertically within the boundaries of the object. The left corner of the Status Bar indicates text edit mode and the position of the text cursor (Figure 184).

Alternatively, copy and paste text into the selected object. It is recommended to paste text into an Impress object as unformatted text and then format the text to your requirements.

5) When finished, click outside of the object or press Esc to cancel text mode. The Line and Filling toolbar automatically opens replacing the Text Formatting toolbar.

Figure 184: Text information on Status Bar.
Formatting text in objects

This section only covers formatting of text which has been added to an object. For more information on formatting text that is used separately on a slide, see Chapter 3, Adding and Formatting Text.

1) Select the object which contains text and use one of the following methods to open the Text dialog (Figure 185):
   - Go to Format > Shape and Object > Text on the Menu bar.
   - Right-click on the object and select Text from the context menu.

2) Click on the Text tab to open the Text page.

3) Format and edit the text position within an object using the available options. The options are described in Table 8. Some options will not be available depending on the type of object to which the text has been added.

4) Click OK to close the Text dialog and save the changes to the text.

5) To format the text attributes (for example paragraph alignment or font type) use the tools available on the Text Formatting toolbar or go to Format on the Menu bar and use the options available in the drop down menu. See Chapter 3, Adding and Formatting Text for more information on formatting text attributes.

Table 8: Text formatting options

<table>
<thead>
<tr>
<th>Text options</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fit width to text</td>
<td>Expands the width of the object if the text is too long.</td>
</tr>
<tr>
<td>Fit height to text</td>
<td>Expands the object height whenever it is smaller than the text (set by default for lines).</td>
</tr>
<tr>
<td>Fit to frame</td>
<td>Expands the text so that it fills all the available space.</td>
</tr>
</tbody>
</table>

Figure 185: Text dialog - Text page
<table>
<thead>
<tr>
<th><strong>Text options</strong></th>
<th><strong>Meaning</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Adjust to contour</td>
<td>Makes the text follow a curved line.</td>
</tr>
<tr>
<td>Word wrap text in shape</td>
<td>Starts a new line automatically when the border of the object is reached.</td>
</tr>
<tr>
<td>Resize shape to fit text</td>
<td>Expands an object when the text inserted in the object is too large.</td>
</tr>
<tr>
<td>Spacing to borders</td>
<td>Specify the amount of space between the borders of the object and the text. This is similar to setting indentation and spacing for paragraphs.</td>
</tr>
<tr>
<td>Text anchor</td>
<td>Used to anchor the text to a particular point within the object.</td>
</tr>
<tr>
<td>Full width</td>
<td>Anchors the text in the center of the object and uses the full width of the object before wrapping text.</td>
</tr>
</tbody>
</table>

**Text animation**

Text can be animated when it has been placed into an object and is a separate animation from object animation. For information on object animation, see Chapter 5, Managing Graphic Objects.

1) Select the object which contains text and use one of the following methods to open the Text dialog:
   - Go to **Format > Shape and Object > Text** on the Menu bar.
   - Right-click on the object and select **Text** from the context menu.

2) Click on the **Text Animation** tab to open the **Text Animation** page (Figure 186).

3) Select the type of animation required from the **Effect** drop down list as follows:
   - **No animation** – default setting.
   - **Blink** – the text will blink on the screen.
   - **Scroll through** – the text will move into the object and then out following the selected direction.
   - **Scroll back and forth** – the text will move first in the selected direction, but will bounce back at the object border.
   - **Scroll in** – the text will scroll in towards the given direction starting from the edge of the object and stop in the center.

4) Set the **Direction** of the animation using one of the four arrows to set the scroll direction for the text.
5) Set the Properties for the animation using the following options:
   - **Start inside** – animation starts from inside the object.
   - **Text visible when editing** – select to see the text while editing.
   - **Animation cycles** – select **Continuous** and the text animates continuously or set a specific number of cycles for the animation.
   - **Increment** – sets the amount the animation moves in **Pixels** when selected or a specific distance when **Pixels** is deselected. Units of measurement depend on the settings in **Tools > Options > LibreOffice Impress > General**.
   - **Delay** – starts the animation when **Automatically** is selected or after a specific length of time when **Automatically** is deselected.

6) Click **OK** to close the Text dialog and save the animation effect.

### Formatting connectors

Connectors are lines that join two objects and always start from or finish at a glue point on an object. See Chapter 5, Managing Graphic Objects for a description and use of the connectors.

1) Right-click on a connector and select **Connector** from the context menu to open the Connector dialog (Figure 187). The Connector dialog displays a preview of a connector as changes are made.

2) Select the type of connector from the **Type** drop down list.

3) Set the **Line skew** for the connector. Line skew is used to set the distance between connectors where multiple connectors overlap.

4) Set the **Line spacing** for the connector. Line spacing is used to set the horizontal and vertical space between the connector and the object at each end of the connector.

5) Click **OK** to close the Connector dialog and save the changes.
To achieve style consistency in slides, or a presentation, or to apply the same formatting to a large number of objects, it is recommended to use image styles. In Impress, image styles are called drawing styles.

These drawing styles are similar to paragraph styles that are used for text. A drawing style groups all formatting properties applicable to a graphical object, then associates this properties group with a name. This allows the properties group to be used for other graphical objects. If a drawing style is modified (for example, changing area color), the changes are automatically applied to all objects that use the same drawing style.

If you use Impress frequently, a library of well-defined drawing styles is an invaluable tool for speeding up the process of formatting objects to any style guidelines you may need to follow (for example, company colors or fonts).

For more information on drawing (image) styles in Impress, see Chapter 2, Slide Masters, Styles, and Templates.

**Linked drawing styles**

Drawing styles support inheritance which allows a style to be linked to another (parent) style so that it inherits all the formatting settings of the parent. This inheritance creates families of styles.

For example, if multiple boxes are required that only differ in color, but are otherwise identically formatted, it is recommended to define an image style for the box including borders, area fill, font, and so on as the parent style. A number of drawing styles are then created that are hierarchically dependent to the parent style, but differing only in the fill color attribute. If you need to change the font size or border thickness, the parent style is changed and all the other styles change accordingly.
Default drawing style

In Impress, the drawing styles are located in the Styles deck on the Sidebar (Figure 188) in the Drawing Styles section. The Default Drawing Style cannot be deleted and is automatically applied to any graphic object created on a slide. This style is the starting point for creating new drawing styles.

Note

The Default Drawing Style can be modified. However, a modified Default Drawing Style only applies to the presentation where the style was modified.

Creating drawing styles

New style from Sidebar

1) Select a graphic object or create a new graphic object.
2) Open the Styles deck on the Sidebar (Figure 188) using one of the following methods:
   - Click on Styles at the side of the Sidebar.
   - Click on Show the Styles Sidebar on the Line and Filling toolbar.
   - Use the keyboard shortcut F11.
3) Click on **Drawing Styles** on the left of the title bar of the Styles deck to open the **Drawing Styles** section.

4) Right click on the style that is selected in the list and select **New** from the context menu to open the Graphic Styles dialog (Figure 189).

5) Click the **Organizer** tab to open the **Organizer** page.

6) Enter a name for the new drawing style in the **Name** text box.

7) In **Inherit from** text box, select **None** from the drop down list if you DO NOT want this new drawing style to be linked. By default, when the graphic object was created, it was allocated the Default Drawing Style and the new drawing style will be linked to this drawing style.

8) Use the various pages in the Graphic Styles dialog to format the new style.
   - **Font, Font Effects, Indents & Spacing, Alignment, Tabs, Highlighting and Asian Typography** – formats any text inserted into a graphic object.
   - **Dimensioning** – formats dimension lines.
   - **Text, Text Animation, Connector, Line, Area, Shadowing, and Transparency** – formats a graphic object.

9) Click **OK** to close the Graphics Styles dialog and save the new drawing style.

---

### Note

Any new drawing style created is automatically placed in the **Custom** category.

#### New style from selected object

1) Select an object you want to use to create a new drawing style.

2) Carry out any formatting changes to the object using the various dialogs and menu options available in Impress.

3) Click on **New Style from Selection** on the right of the title bar of the Styles deck to open the Create Style dialog (Figure Erro: Origem da referência não encontrada).

4) Enter a name for the new drawing style in the **Style Name** text box. A list is displayed of existing custom styles of that are available.

5) Click **OK** to save the new drawing style and close the Create Style dialog.

#### Modifying drawing styles

1) Open the Styles deck on the Sidebar (Figure 189 on page 208) using one of the following methods:
   - Click on the **Styles** icon at the side of the Sidebar.
   - Click on **Show the Styles Sidebar** on the Line and Filling toolbar.
   - Use the keyboard shortcut **F11**.

2) Click on **Drawing Styles** on the left of the title bar of the Styles deck to open the **Drawing Styles** section.

3) Right click on the style in the list you want to modify and select **Modify** from the context menu to open the Graphic Styles dialog (Figure 189 on page 208).

4) Carry out any formatting changes to the style using the options in the various pages of the Graphic Styles dialog.
5) Click **OK** to save the changes and close the Graphic Styles dialog.

**Updating drawing styles**

1) Select a graphic object or create a new graphic object.
2) Carry out any formatting changes to the selected object using the various dialogs and menu options available in Impress.
3) With the object still selected, open the Styles deck on the Sidebar using one of the following methods:
   - Click on the **Styles** icon at the side of the Sidebar.
   - Click on **Show the Styles Sidebar** on the Line and Filling toolbar.
   - Use the keyboard shortcut **F11**.
4) Click on **Update Style** on the right of the title bar of the **Styles** deck to update the style. There is no confirmation that the style has been updated.

**Applying drawing styles**

1) Open the Styles deck on the Sidebar using one of the following methods:
   - Click on the **Styles** icon at the side of the Sidebar.
   - Click on **Show the Styles Sidebar** on the Line and Filling toolbar.
   - Use the keyboard shortcut **F11**.
2) Click on **Drawing Styles** on the left of the title bar of the Styles deck to open the **Drawing Styles** section.
3) Select the object to which you want to apply a drawing style.
4) Double-click on the name of the drawing style you want to apply to the object and the drawing style is applied.

**Deleting drawing styles**

You cannot delete any of the predefined drawing styles in Impress, even if the predefined drawing style is not in use. Only custom (user defined) styles can be deleted.

1) Open the Styles deck on the Sidebar using one of the following methods:
   - Click on the **Styles** icon at the side of the Sidebar.
   - Click on **Show the Styles Sidebar** on the Line and Filling toolbar.
   - Use the keyboard shortcut **F11**.
2) Click on **Drawing Styles** on the left of the title bar of the Styles deck to open the **Drawing Styles** section.
3) Right-click on a drawing style and click **Delete** on the context menu.
4) Click **Yes** to confirm the deletion of the drawing style.

**Note**

Before deleting a custom drawing style, make sure the style is not in use in the presentation.
Chapter 7
OLE, Spreadsheets, Charts, and Other Objects
OLE objects

Object Linking and Embedding (OLE) is a software technology that allows linking and embedding of the following types of files into an Impress presentation.

- LibreOffice spreadsheets
- LibreOffice charts
- LibreOffice drawings
- LibreOffice formulas
- LibreOffice text

The major benefit of using OLE objects is that it provides a quick and easy method of editing the object using tools from the software used to create the object. These file types can all be created using LibreOffice and OLE objects can be created from new or from an existing file.

Inserting new OLE objects

When you insert a new OLE object into your presentation, it is only available in your presentation and can only be edited using Impress.

5) Select the slide where you want to insert an OLE object.
6) Go to Insert > Object > OLE Object on the Menu bar to open the Insert OLE Object dialog (Figure 190).
7) Select Create new and then select the type of OLE object you want to create.
8) Click OK and a new OLE object is inserted in the center of the slide in edit mode. The toolbars displayed change providing the necessary tools for you to create a new OLE object.

Note

For computers operating Windows, an additional option of Further objects is available in the Object Type list. Clicking on Further objects opens an Insert Object dialog (Figure 191) allowing you to create an OLE object using other software that is compatible with OLE and LibreOffice. This option is available for new OLE objects and OLE objects from a file.

![Insert OLE Object dialog for new objects](image)
Inserting OLE objects from files

To insert a file into your presentation as an OLE object:

1) Select the slide where you want to insert an OLE object.

2) Go to Insert > Object > OLE Object on the Menu bar to open the Insert OLE Object dialog (Figure 192).

3) Select Create from file and the dialog changes to a file search dialog (Figure 192).

4) Click on Search and a file open dialog is displayed.

5) Locate the file required and click Open. The filename appears in the File text box.

6) Insert the OLE object using one of the following methods to insert the OLE object in the center of the slide in edit mode:

   – Click OK to insert the file as an OLE object.
   – Select Link to file, then click OK to insert the OLE object with a link to the original file.
   – Select Display as icon, then click OK to insert the OLE object as an icon. When the icon is clicked on, the OLE object opens in a new window.
When inserting an existing file into a slide as an OLE object, by default, any changes made to the original file after insertion do not affect the copy of the file inserted into a presentation. Also, changes to the file copy in a presentation do not change the original file. If you want any changes made to the file, either in the original or in your presentation, to appear in both versions you have to link the original file with your presentation when it is inserted.

**Editing OLE objects**

To edit an OLE object after it has been created or inserted from a file:

1) Double-click on the OLE object to open it in edit mode. The toolbars in Impress will change to provide the tools necessary to edit the OLE object.

2) When finished editing the OLE object, click anywhere outside the OLE object to cancel editing.

3) Save the presentation. Any changes made to the OLE object are also saved.

**Resizing and moving OLE objects**

Resizing and moving OLE objects is exactly the same as resizing and moving graphic objects in Impress. For more information, see Chapter 5, Managing Graphic Objects.

**Note**

When resizing or moving a spreadsheet on slides, ignore any horizontal and vertical scroll bars, and the first row and first column. The the first row and first column are easily recognizable because of their light background color. They are only used for spreadsheet editing purposes and will not be included in the spreadsheet that appears as an OLE object on the slide.

**Note**

Do not double click on a spreadsheet OLE object when editing. Double clicking opens the OLE object editing mode for spreadsheets.

**Spreadsheets**

To include a spreadsheet in an Impress slide, you can either insert an existing spreadsheet file or insert a new spreadsheet as an OLE object (see “LibreOffice options” on page 290 for more information). For more information on spreadsheets, see the Calc Guide and the Getting Started Guide.

Embedding a spreadsheet into Impress includes most of the functionality of a Calc spreadsheet. Impress is capable of using Calc functions to carry out calculations and data analysis. However, if you plan to use complex data or formulas, it is recommended to perform those operations in a separate Calc spreadsheet first, then embed into Impress the spreadsheet with the results.

You may be tempted to use spreadsheets in Impress for creating tables or presenting data in a tabular format. However, inserting a table into Impress is often more suitable and faster, depending on the complexity of your data. See Chapter 3, Adding and Formatting Text for more information on inserting and formatting tables.
The entire spreadsheet is inserted into a slide as an OLE object. If the spreadsheet contains more than one sheet and the one required is not visible, double-click the spreadsheet and then select a different sheet from the sheet tab row at the bottom. See “Editing OLE objects” on page 214 for more information on editing a spreadsheet as an OLE object.

![Example OLE spreadsheet in editing mode](image)

**Editing spreadsheets**

When a spreadsheet is inserted into a slide, it is in edit mode ready for inserting or modifying data or modifying the format (Figure 193). The following also happens to provide and functions for spreadsheets:

- Calc formula toolbar replaces the Line and Filling bar as shown in Figure 193
- The Formatting toolbar (Figure 194) for spreadsheets opens providing tools required for basic formatting of a spreadsheet.
- The Menu bar changes to provide spreadsheet formatting options.

The Calc formula bar contains the following from left to right:

- Active cell reference or the name of a selected range of cells.
- Function Wizard tool.
- Select Function tool.
- Formula tool.
- An edit box to enter or review the displayed contents of the active cell. Click on the small triangle ▼ to the right of the edit box to expand, if necessary, the edit box.

**Cell navigation**

By default, when an embedded spreadsheet is opened, the active cell is A1. To move around the spreadsheet to select a cell to make it active, you can use one of the following methods:

- Keyboard arrow keys.
- Position the cursor in a cell and click.
- *Enter* key to move one cell down and *Shift+Enter* key combination to move one cell up.
• Tab key to move one cell to the right and Shift+Tab key combination to move one cell to the left.

Note

Other keyboard shortcuts are available to navigate around a spreadsheet. Refer to Getting Started Guide for more information.

Entering data

Data input into a cell can only be done when a cell is active. An active cell is easily identified by a thickened and bolder border. The cell reference or coordinates for the active cell is displayed at the left hand end of the Calc editing toolbar.

1) Select the cell to make it active and start typing. The data input is also displayed in the edit box on the Calc formula toolbar making the data entry easier to read.

2) Use the various tools and options on the Menu bar to enter data, formula, function, text, or date into a cell.

3) To confirm data input into a cell select a different cell with the cursor, or use the Enter key, Shift+Enter key combination, Tab key, or Shift+Tab key combination.

Tip

Sometimes it is useful to treat numbers as text (for example, telephone numbers) and to prevent Impress from removing the leading zeros or right align them in a cell. To force Impress to treat numbers as text, type a single quotation mark (') before entering the number.

Merging cells

1) Highlight the required number of cells to be merged.

2) Merge the highlighted cells using one of the following methods to open the Merge Cells dialog (Figure 195).
   – Go to Format > Merge Cells > Merge and Center Cells on the Menu bar.
   – Go to Format > Merge Cells > Merge Cells on the Menu bar.
   – Right-click on the selected cells and select Merge Cells from the context menu.

3) Select an option, click OK to merge the cells and close the Merge Cells dialog.

Splitting cells

Only multiple cells that have been merged can be split into separate cells.

1) Select a cell that was merged from multiple cells.
2) Split the merged cell into separate cells using one of the following methods:
   – Go to Format > Merge Cells > Split Cells on the Menu bar.
   – Right-click on the cell and select Split Cells from the context menu.

**Inserting cells, rows, or columns**

1) Select the same number of cells, rows, or columns on the embedded spreadsheet that you want to insert.

2) Insert cells using one of the following methods:
   – Go to Sheet > Insert Cells on the Menu bar.
   – Right-click on the selected cells and select Insert... from the context menu.

   Inserting cells opens the Insert Cells dialog (Figure 196). Select an insert option, then click **OK** to insert the cells and close the dialog.

3) Insert rows using one of the following methods:
   – Go to Sheet > Insert Rows > Rows Above or Sheet > Insert Rows > Rows Below on the Menu bar.
   – Right-click on the selected rows and select Insert Rows Above or Insert Rows Below from the context menu.

4) Insert columns using one of the following methods:
   – Go to Sheet > Insert Columns > Columns Before or Sheet > Insert Columns > Columns After on the Menu bar.
   – Right-click on the selected rows and select Insert Columns Before or Insert Columns After from the context menu.
Deleting cells, rows, or columns

1) Select the same number of cells, rows, or columns on the embedded spreadsheet that you want to delete.

2) Delete cells using one of the following methods:
   - Go to Sheet > Delete Cells on the Menu bar.
   - Right-click on the selected cells and select Delete... from the context menu.

Deleting cells opens the Delete Cells dialog (Figure 197). Select a delete option, then click OK to delete the cells and close the dialog.

3) Delete rows using one of the following methods:
   - Go to Sheet > Delete Rows on the Menu bar.
   - Right-click on the selected rows and select Delete... from the context menu.

4) Delete columns using one of the following methods:
   - Go to Sheet > Delete Columns on the Menu bar.
   - Right-click on the selected rows and select Delete Columns from the context menu.

Inserting sheets

1) Double-click on the embedded spreadsheet to open in edit mode.

2) Insert a sheet using one of the following methods:
   - Click on the plus sign to the left of the sheet names.
   - Right-click on the sheet names and select Insert > Sheet from the context menu and the Insert Sheet dialog (Figure 198) opens.
   - Go to Sheet > Insert Sheet on the Menu bar to open the Insert Sheet dialog.

3) When finished editing the embedded spreadsheet, click anywhere outside the border to cancel edit mode and save the changes.

Note

If there are multiple sheets in an embedded spreadsheet, only the active sheet is shown on the slide after exiting edit mode.
Figure 198: Insert Sheet dialog

**Insert Sheet dialog**

1) Open the Insert Sheet dialog.

2) Select **Position** for the new sheet in the spreadsheet – *Before current sheet* or *After current sheet*.

3) Insert a new sheet as follows:
   
   **h)** Select *New sheet*.
   
   **i)** Select *No. of sheets* to be inserted in the text box.
   
   **j)** In the *Name* text box, enter a name for the new sheet. This option is not available if inserting multiple sheets.

4) Insert a sheet from a file as follows:
   
   **a)** Select *From file*.
   
   **b)** Click on *Browse* to open an *Insert* dialog and navigate to the file location.
   
   **c)** If necessary, click on *Link* to create a link to the original file.
   
   **d)** Select the file and click on *Open* and the sheet names in the file appear in the preview box.
   
   **e)** Select the sheet you want to insert.

5) Click **OK** to close the dialog and insert the sheet into the embedded spreadsheet.

6) When finished editing an embedded spreadsheet, click anywhere outside the border to cancel edit mode and save the changes.

**Renaming sheets**

1) Double-click on the embedded spreadsheet to open in edit mode.

2) Select the sheet you want to rename.

3) Right-click on the sheet tab and select *Rename Sheet* from the context menu, or go to **Sheet > Rename Sheet** on the Menu bar to open the Rename Sheet dialog (Figure 199).

4) Enter a new name for the sheet in the *Name* text box.
5) Click **OK** to save the name change and close the dialog.

6) When finished editing the embedded spreadsheet, click anywhere outside the border to cancel edit mode and save the changes.

**Moving or copying sheets**

1) Double-click on the embedded spreadsheet to open in edit mode.

2) Select the sheet you want to move or copy.

![Rename Sheet dialog](image)

*Figure 199: Rename Sheet dialog*

3) Right-click on the sheet tab and select **Move or Copy Sheet** from the context menu, or go to **Sheet > Move or Copy Sheet** on the Menu bar to open the Move/Copy Sheet dialog (Figure 200).

![Move/Copy Sheet dialog](image)

*Figure 200: Move/Copy Sheet dialog*

4) Move or copy a sheet to another position within the OLE spreadsheet in the same presentation is as follows:
   
a) Select the option **Move or Copy** in **Action**.
b) Select the Location in the To document drop down list. In Impress, the presentation is named Untitled 1 (current document).

c) Select the position within the spreadsheet from the available list in Insert before.

d) If necessary, enter a new name for the sheet in the New name text box.

e) Click OK to move or copy the sheet and close the dialog.

5) Move or copy a sheet to another document containing a spreadsheet is as follows:

   a) Make sure the spreadsheet in the target document is selected.
   b) Select the option Move or Copy in Action.
   c) Select the Location in the To document drop down list. In Impress, the document is named Untitled 1 (current document). If the document is a Calc spreadsheet, the filename of the Calc spreadsheet is displayed.
   d) Select the position within the spreadsheet from the available list in Insert before.
   e) If necessary, enter a new name for the sheet in the New name text box.
   f) Click OK to move or copy the sheet and close the dialog.

6) To move the sheet with a mouse within the embedded spreadsheet, click on the sheet tab and drag it to a new position.

7) When finished editing the embedded spreadsheet, click anywhere outside the border to cancel edit mode and save the changes.

Deleting sheets

1) Double-click on the embedded spreadsheet to open in edit mode.

2) Select the sheet you want to delete.

3) Right-click on the sheet tab and select Delete Sheet from the context menu, or go to Sheet > Delete Sheet on the Menu bar.

4) Click Yes to confirm the deletion of the sheet.

5) When finished editing the embedded spreadsheet, click anywhere outside the border to cancel edit mode and save the changes.

Formatting spreadsheets

For presentation purposes, it may be necessary to change the formatting of a spreadsheet to match the style used in the presentation.

When working on an embedded spreadsheet, you can also access any styles created in Calc and use them. However, if you are going to use styles, it is recommended to create specific styles for embedded spreadsheets, as Calc styles maybe unsuitable when working in Impress.

Cell data formatting

1) Select a cell or a range of cells in an embedded spreadsheet using one of the following methods:
   – Click in a cell to select it.
   – To select the whole sheet, click on the blank cell at the top left corner between the row and column headers.
   – To select the whole sheet, use the keyboard shortcut Ctrl+A.
   – To select a column, click on the column header at the top of the spreadsheet.
– To select a row, click on the row header on the left hand side of the spreadsheet.

2) Open the Format Cells dialog (Figure 201) using one of the following methods:
   – Right-click on a cell and select **Format Cells** from the context menu.
   – Go to **Format > Cells** on the Menu bar.
   – Use the keyboard shortcut **Ctrl+1**.

3) Use the various pages in the **Format Cells** dialog to the cell data so that it matches the style of your presentation.

4) Click **OK** to close the **Format Cells** dialog and save your changes.

5) When you are satisfied with the formatting changes, click outside the spreadsheet area to save your changes and cancel editing mode.

**Row formatting**

1) Select a row by clicking in the row header.

2) Adjust the row height using one of the following methods:
   – Right click in the row header and select **Row Height** from the context menu and set the row height in the **Height** text in the Row Height dialog that opens.

![Format Cells dialog](image)

*Figure 201: Format Cells dialog*

– Right click in the row header and select **Row Height** from the context menu and select the **Default value** for row height in the Row Height dialog that opens.

– Right click in the row header and select **Optimal Height** from the context menu. Enter an optimal height in the **Add** text box or select the **Default value** in the Optimal Row Height dialog that opens. The optimal row height depends on the font size of the largest character in a row.

– Hover the cursor over the bottom border in the row header until it changes shape, then click and drag the border to increase or decrease the row height.
3) When you are satisfied with the formatting changes, click outside the spreadsheet area to save your changes and cancel editing mode.

**Column formatting**

1) Select a column by clicking in the column header.

2) Adjust the column width using one of the following methods:
   - Right click in the column header and select **Column Width** from the context menu and set the column width in the *Width* text box in the Column Width dialog that opens.
   - Right click in the column header and select **Column Width** from the context menu and select the *Default value* for column width in the Column Width dialog that opens.
   - Right click in the column header and select **Optimal Width** from the context menu. Enter an optimal width in the *Add* text box or select the *Default value* in the Optimal Column Width dialog that opens. The optimal column width depends on the longest entry within a column.
   - Hover the cursor over the left or right border in the column header until it changes shape, then click and drag the border to increase or decrease the column width.

![Figure 202: Calc Styles deck in Sidebar](image)

3) When you are satisfied with the formatting changes, click outside the spreadsheet area to save your changes and cancel editing mode.

**Using formatting styles**

When using styles in an embedded spreadsheet and the spreadsheet is in edit mode, Impress displays the available styles for a spreadsheet in the Styles deck on the Sidebar (Figure 202). Styles used in an embedded spreadsheet are similar to paragraph styles used in LibreOffice Writer.

1) Select the data in a cell or cells in the embedded spreadsheet.

2) Click on **Styles** to open the Styles deck in the Sidebar.

3) Double-click on a style to apply that style to the cell data.

4) When you are satisfied with the formatting changes, click outside the spreadsheet area to save your changes and cancel editing mode.
Charts

A chart is a graphical interpretation of information that is contained in a spreadsheet. More information about charts and the use of charts, see the Calc Guide.

Inserting charts

1) Select the slide where you want to insert a chart.

2) Use one of the following methods to insert a chart:
   - Go to Insert > Object > OLE Object on the Menu bar to insert a chart as an OLE object. See “LibreOffice options” on page 290 for more information on inserting a chart as an OLE object.
   - Go to Insert > Chart on the Menu bar and an example chart is inserted in the center of the slide in editing mode (Figure 203).
   - Click on Chart on the Standard toolbar and an example chart is inserted in the center of the slide in editing mode.

3) If necessary, click outside the chart area to cancel editing mode.

Note

When a chart is in editing mode, the Formatting toolbar (Figure 204) for charts automatically opens replacing the Line and Filling and Standard toolbars.

Figure 203: Example chart in editing mode

Figure 204: Chart Formatting toolbar
Selecting chart type

Your data can be presented using a variety of different charts. Impress contains several examples of chart types that will help you convey your message to your audience. You can select a chart type using the Chart Type dialog (Figure 205) or the Chart Type section in the Properties deck on the Sidebar (Figure 206).
Chart Type section in Properties on Sidebar

**Chart Type dialog**

1) Make sure the chart is selected and is in editing mode. The chart has a border and selection handles when in editing mode.

2) Open the Chart Type dialog using one of the following methods:
   - Click Chart Type on the Formatting toolbar.
   - Go to Format > Chart Type on the Menu bar.
   - Right-click on the chart and select Chart Type from the context menu.

3) Select a chart type from the left-hand preview box and the chart examples on the right change. Also, the available options for chart types change to match the chart type.

4) Select a chart example from the right-hand preview box.

5) Select the options required for the chart type selected.

6) Click OK to close the Chart Type dialog and return to the edit window.

7) Continue to format the chart, add data to the chart, or click outside the chart to return to normal view.

**Sidebar Chart Type**

1) Make sure the chart is selected and is in editing mode. The chart has a border and selection handles when in editing mode.

2) Click on Properties on the Sidebar to open the Properties deck.
3) Click on the downward pointing arrow ▼ on the left of title bar for the Chart Type section.
4) Select the chart type from the drop down list.
5) Select a chart example from the preview box.
6) Select the chart elements required for the chart type from the Elements section on the Sidebar.
7) Continue to format the chart, add data to the chart, or click outside the chart to return to normal view.

Chart types

The following summary of available chart types will help you to choose a type suitable for the data being used to create the chart. Column, bar, pie and area charts are available as 2D or 3D types. For more information on charts, see the Calc Guide.

- **Column** – displays data that shows trends over time. This chart is the default chart type used when a chart is inserted into a slide. It is recommended to use column charts where there is a relatively small number of data points. If there is a large time series as data, it is recommended to use a line chart.

- **Bar** – give an immediate visual impact for data comparison where time is not important, for example comparing the popularity of products in a marketplace.

- **Pie** – give a comparison of proportions. For example, when comparing what different departments spent on different items or what different departments actually spent overall. They work best with a small range of values, for example six or less. Using larger range of values, the visual impact of a pie chart begins to fade.

- **Area** – are versions of line or column charts. They are useful when emphasis of volume change is required. Area charts have a greater visual impact than a line chart, but the type of data used does make a difference to the visual impact.

- **Line** – are time series with progression. Ideal for raw data and useful for charts with data showing trends or changes over time where an emphasis in continuity is required. On line charts, the X-axis is ideal for representing time series data. 3D lines confuse the viewer, so just using a thicker line gives a better visual impact.

- **XY (Scatter)** – are great for visualizing data that have not been analyzed fully and may be best for data where have a constant value for comparison. For example weather data, reactions under different acidity levels, conditions at altitude, or any data which matches two numeric series. The X-axis usually plots the independent variable or control parameter (often a time series).

- **Bubble** – are used to represent three variables. Two variables identify the position of the center of a bubble on a Cartesian graph, while the third variable indicates the radius of the bubble.

- **Net** – are similar to polar or radar graphs and are useful for comparing data not in time series, but show different circumstances, such as variables in a scientific experiment. The poles of the net chart are the Y-axes of other charts. Generally, between three and eight axes are best; any more and this type of chart becomes confusing.

- **Stock** – are specialized column graphs specifically used for stocks and shares. Choose traditional lines, candlestick, and two-column charts. The data required for these charts is specialized with a series for opening price, closing price, and high and low prices. The X-axis represents a time series.
*Column and line* – are a combination of two other chart types. It is useful for combining two distinct, but related data series, for example sales over time (column) and the profit margin trends (line).

**Entering chart data**

1) Make sure the chart is selected and is in editing mode. The chart has a border and selection handles when in editing mode.

2) Open the Data Table dialog (Figure 207) using one of the following methods:
   - Click on Data Table on the Formatting toolbar for charts.
   - Go to View > Data Table on the Menu bar.
   - Right-click on the chart and select Data Table from the context menu.

3) Type or paste information into the cells to enter data into the Data Table dialog.

4) Use the tools in the top left corner of the Data Table dialog to insert, delete or reposition rows or columns (series).

5) Click on Close to save the changes and close the Data Table dialog.

6) Click outside the chart to return to normal view.

**Note**

To insert, delete or reposition a column, use the tools Insert Series, Delete Series, Move Series Left, and Move Series Right in the Data Table dialog.

**Adding or removing chart elements**

1) Make sure the chart is selected and is in editing mode. The chart has a border and selection handles when in editing mode.

2) To add an element to the chart use one of the following methods.
   - Go to Insert on the Menu bar and select, from the submenu, an element to add to the chart.
   - Right-click on the chart and select an element from the context menu.
   - Right-click on the chart wall and select an element from the context menu.
   - Right-click on an element and select an element from the context menu.
   - Open the Elements section in the Properties deck on the Sidebar (Figure 206 page 226) and select elements from the options available.
Note

Depending on the method selected to add an element will affect what type of element you can add to the chart. Also, when adding some elements to the chart, a dialog may open with more options to select for the element being added.

3) To remove an element from a chart use one of the following methods:
   - Right-click on the chart element you want to remove and select the delete option from the context menu. The type of element selected for removal changes the delete options in the context menu.
   - Select a chart element and press the delete or backspace key to remove it from the chart.
   - Open the Elements section in the Properties deck on the Sidebar and deselect the element.

4) Click outside the chart to return to normal view.

Chart and chart elements formatting

1) Make sure the chart is selected and is in editing mode. The chart has a border and selection handles when in editing mode.

2) To format an element on the chart use one of the following methods.

3) Go to Format on the Menu bar and select an element you want to format.
   - Right-click on an element and select Format XXXX from the context menu. The format option changes depending on which chart element has been selected. For example, select the chart wall and the format option is called Format Chart Wall.
   - Use the various tools on the Formatting toolbar for charts (Figure 205 on page 225) to format a chart element.

4) Selecting an element opens a formatting dialog specific for the element selected. Use the various options in the formatting dialog to format the element. For more information on formatting a chart, chart elements, and formatting options available, see the Calc Guide.

Resizing and moving charts

A chart and its chart elements can be resized and moved just like all other objects on a slide. For more information on resizing and moving a chart, see Chapter 5, Managing Graphic Objects and the Calc Guide.

Audio and video

Inserting audio or video

Using a file browser

1) Go to Insert > Audio or Video on the Menu bar and a file browser for Insert Audio or Video opens (Figure 208).

2) Navigate to the folder where the audio or video file is located. Only the audio and video files that are compatible with Impress will be highlighted in the file browser.
3) Select the compatible audio or video file required and click Open to embed the file in the center of the slide. The Media Playback toolbar (Figure 209) automatically opens.

![Figure 208: Insert Audio or Video file browser](image)

**Figure 208: Insert Audio or Video file browser**

![Figure 209: Media Playback toolbar](image)

**Figure 209: Media Playback toolbar**

4) Reposition and/or resize the audio or video file. See Chapter 5, Managing Graphic Objects for more information.

**Using the Gallery**

1) If the Gallery deck is not already open, use one of the following methods to open the Gallery deck:
   - Go to View > Sidebar on the Menu bar to open the Sidebar and select Gallery from the options available.
   - Go to View > Gallery on the Menu bar.
2) Browse to a theme containing media files, for example Sounds.
3) Click on the audio or video option required and drag it onto the slide. The Media Playback toolbar automatically opens.
4) Reposition and/or resize the audio or video file. See Chapter 5, Managing Graphic Objects for more information.

**Media playback**

The Media Playback toolbar automatically opens when an audio or video file is selected. The Media Playback toolbar contains the following tools from left to right:

- **Insert Audio or Video** – opens the Insert Audio or Video file browser where you can select a media file for insertion into a slide.
- **Play** – plays the media playback.
- **Pause** – pauses the playing of the media.
- **Stop** – stops the playing of media.
• **Repeat** – if selected, repeats the playing of the media until the tool is deselected.
• **Position** – selects the position of where to start playing from within the media file.
• **Mute** – suppresses the volume of a media file.
• **Volume** – adjusts the volume of the media file.
• **Media Path** – indicates where the media file is stored on a computer

### Formulas

Go to **Insert > Object > Formula** on the Menu bar to create a formula in a slide. A formula can also be inserted as an OLE object; see “LibreOffice options” on page 290 for more information.

When editing a formula, the Math menu becomes available allowing you to create or edit a formula. For information on how to create formulas, see the **Math Guide** or the **Getting Started Guide**.

When creating formulas, care should be taken about font sizes used to make sure they are similar in size to the font size used in the presentation. To change font attributes of a formula, go to **Format > Font Size** on the Menu bar. To change font type, go to **Format > Fonts** on the Menu bar.

**Note**

Unlike formulas in Writer, a formula in Impress is treated as an object and will not be automatically aligned with the rest of the objects on the slide. The formula can be moved around like other objects in Impress, but cannot be resized.

### Drawings, text files, HTML files and other objects

You can insert into a presentation drawings, text files, HTML files and other objects, but only objects that are compatible for insertion into an Impress presentation. Go to **Insert > File** on the Menu bar to open a file selection dialog. Only files compatible with Impress will be available for selection. Drawings, text files, HTML files and other objects can also be inserted as OLE objects; see “LibreOffice options” on page 290 for more information.
Chapter 8

Adding and Formatting Slides, Notes, Comments, and Handouts
**Introduction**

This chapter describes how to add new slides to a presentation, how to format slides, and how to format notes. Notes are generally used as prompts for the person giving the presentation.

**Inserting, renaming, and removing slides**

A new slide is inserted into a presentation after the selected slide which is displayed in the Workspace. If slide masters have been used in the presentation, the inserted slide will use the master slide of the selected slide displayed in the Workspace.

**Inserting new slides**

1) Open the presentation where you want to add a new slide, or create a new presentation.

2) Make sure Normal view is selected in the Workspace.

3) Select the slide in the presentation where you want to insert a new slide after the selected slide, then use one of the following methods to insert a new slide:
   - Go to **Slide > New Slide** on the Menu bar.
   - Right-click on the selected slide in the Slides pane and select **New Slide** from the context menu.
   - Right-click on the selected slide in the Slide Sorter view and select **New Slide** from the context menu.
   - Use the keyboard shortcut Ctrl+M.

4) To insert a new slide at the end of a presentation make sure there are no slides selected in the Slides pane, then use one of the following methods:
   - Go to **Slide > New Slide** on the Menu bar.
   - Right-click in an empty area in the Slides pane and select **New Slide** from the context menu.

**Inserting slides from a file**

1) Open the presentation where you want to insert a slide, or create a new presentation.

2) Make sure Normal view is selected in the Workspace.

3) Select the slide in the presentation where you want to insert a slide after the selected slide. Alternatively, to insert a slide at the end of the presentation, make sure that there are no slides selected in the Slides pane.

4) Go to **Slide > Insert Slide from File** on the Menu bar to open the Insert File dialog (Figure 210).

5) Navigate to the presentation file where you want to insert a slide from and click on **Open** to open the Insert Slides/Objects dialog (Figure 211).

6) Click on the small triangle next to the filename to expand the list of slides.

7) Select the slides you want to insert into your presentation.

8) If required, select the **Link** option to embed the slide as an OLE object.

9) Click **OK** to insert the slide into in the presentation and close the dialog.
When inserting a slide from a file, you can optionally link the slide instead of copying. This embeds the slide into your presentation using OLE. See Chapter 7, OLE, Spreadsheets, Charts, and Other Objects for more information about OLE.

Figure 211 shows the importance of giving descriptive names to slides in a presentation. Refer to “Renaming slides” on page 236 for more information.
Copying and pasting between presentations

1) Open the presentation that you want to copy a slide from and the presentation where you want to paste the copied slide.

2) In the presentation where you want to copy from, make sure that the Slide Sorter view is open in the Workspace so that you can easily locate the slides you want to copy.

3) Select the required slide and copy using one of the following methods:
   – Go to Edit > Copy on the Menu bar.
   – Right-click and select Copy from the context menu.
   – Click on Copy in the Standard toolbar.
   – Use the keyboard shortcut Ctrl+C.

4) Go to the presentation where you want to paste the slide into.

5) Make sure that Slide Sorter view is open in the Workspace.

6) Select the slide at the point where you want to insert the copied slide after the selected slide. Alternatively, to paste a slide at the end of the presentation, make sure that there are no slides selected in the Slides pane.

7) Paste the copied slide into the presentation using one of the following methods:
   – Go to Edit > Paste on the Menu bar.
   – Right-click and select Paste from the context menu.
   – Click on Paste in the Standard toolbar.
   – Use the keyboard shortcut Ctrl+V.

Dragging and dropping between presentations

1) Open both presentations that you want to use to move or copy slides between.

2) For both presentations, open the Slide Sorter view in the Workspace.

3) In the target presentation, select the slide at the point where you want to insert the copied slide after the selected slide. Alternatively, to paste a slide at the end of the target presentation, make sure that there are no slides selected in the Slides pane.

4) In the donor presentation, select the required slides that you want to move or copy.

5) To move the slides to the target presentation, click on the selected slides then drag and drop the selected slides into the target presentation.

6) To copy the slides to the target presentation, click on the selected slides then hold down the Ctrl key while dragging and dropping into the target presentation.

Duplicating slides

Duplicating a slide is an easy method of adding slides to a presentation if you want a new slide to inherit formatting, layout, and animations from a selected slide.

1) Open Normal or Slide Sorter views in the Workspace.

2) Select the slide or slides you want to duplicate in the Slide Sorter view or the Slides pane.

3) Go to Slide > Duplicate Slide on the Menu bar, or right click on the selected slide and select Duplicate Slide on the context menu. The duplicated slides are placed in the presentation after the selected slides.
Tip
Duplicating a slide is a good way of preventing slides from being shown with too much information, which can make it difficult for your audience to understand. If a slide becomes crowded with information, try duplicating the slide then split the information points over two or more slides. All the formatting, backgrounds, and so on will be preserved in each duplicated slide.

![Rename Slide dialog](image)

*Figure 212: Rename Slide dialog*

Renaming slides
1) Open Normal or Slide Sorter view in the Workspace.
2) Select a slide and open the Rename Slide dialog (Figure 212) using one of the following methods:
   - Go to Slide > Rename Slide on the Menu bar.
   - Right-click on the selected slide and select Rename Slide from the context menu.
3) In the Rename Slide dialog, type a new name for the slide in the Name text box.
4) Click OK to save the change and close the Rename Slide dialog.

Expanding slides
Occasionally there may be a slide with too many points to fit in the space available. Instead of reducing the font size or using other methods to squeeze more text onto the slide, it is better to subdivide the contents of the slide into two or more slides.
1) If necessary, duplicate the slide in case of error and you want to redo expansion of the slide.
2) Select the slide you want to expand in the Slide pane.
3) Go to Slide > Expand Slide on the Menu bar. This creates new slides from the first outline level on the original slide. The first outline level becomes the title of each new slide. Outline levels below each first level on the original slide are moved up one outline level in the new slides. An example of expanded slides is shown in Figure 213.
4) If necessary, rearrange the new slides in the presentation order.

Creating summary slides
Summary slides are useful for creating an agenda for a presentation.
1) Select the slide that will be the first slide to appear in the summary.
2) Go to **Slide > Summary Slide** on the Menu bar to create a summary slide (Figure 214) at the end of the presentation. Bullet points are created using the titles of the slides in the presentation.

3) If necessary, move the summary slide to the position where you want it to appear in the presentation.

**Deleting slides**

Select a slide or slides in the Slides pane or in **Normal** or **Slide Sorter** view in the Workspace, then use one of the following methods to delete slides:

- Go to **Slide > Delete Slide** on the Menu bar.
- Right-click on a selected slide and select **Delete Slide** from the context menu.
- Press the **Delete** or **Backspace** key.
Creating slides from an outline

When planning a presentation it may be useful to develop an outline from a LibreOffice Writer file. Once the outline is created, you can create one or more separate slides for each of the top level outline elements.

Using a Writer text document

The Writer document must contain headings formatted using heading paragraph styles.

1) Open the file in Writer that you want to use as a base to create a presentation outline.

2) Go to File > Send > Outline to Presentation on the Writer Menu bar. A new presentation is created and opens in Impress Outline view (Figure 215) and the heading paragraph styles are converted into the outline styles used in Impress.

3) If necessary, duplicate or expand slides and manually change slide contents to create a simpler presentation that your audience will have a better understanding. For more information, see “Duplicating slides” on page 235 and “Expanding slides” on page 236.
Using AutoAbstract

To create a presentation using AutoAbstract and send content from Writer to Impress, the text must contain headings formatted with the heading paragraph styles. When using AutoAbstract to copy the headings and subsequent paragraphs to a new presentation, you can specify the number of outline levels as well as the number of paragraphs to be displayed.

1) Open the file in Writer that you want to use as a base to create a presentation outline.

2) Go to File > Send > AutoAbstract to Presentation on the Writer Menu bar to open the Create AutoAbstract dialog (Figure 216).

3) Select the number of outline levels to be created in the presentation in the Include outline levels box. For example, if you choose three levels, all paragraphs formatted with Heading 1 to 3 styles are included.

4) Select the number of paragraphs for each outline level to be created in the presentation in the Paragraphs per level box.

5) Click OK to close the Create AutoAbstract dialog and create an outline in a new Impress presentation.

6) Some outline levels may have too many points to fit on one slide. If necessary, duplicate or expand slides and manually change slide contents to create a simpler presentation that your audience will have a better understanding. For more information, see “Duplicating slides” on page 235 and “Expanding slides” on page 236.

7) When the presentation is created, some hierarchical structure of the outline may be lost. If necessary, use Promote/Demote tools on the Outline toolbar (Figure 217) to move the outline points to the correct level.

Copying and pasting an outline

1) In Writer, open the file containing the outline you want to use in your presentation.

2) Highlight the outline and select Edit > Copy on the Menu bar, or right click on the outline and select Copy from the context menu.

3) Create a new presentation in Impress or create a new slide in an existing presentation that you want to use.

4) Select the layout you want to use for the slides. For more information, Chapter 1, Introducing Impress.

5) Paste the copied outline into the text area of the slide. Do not worry if the text does not fit the space on the slide.

6) If the slide contains too much text, duplicate or expand slides and manually change slide contents to create a simpler presentation that your audience will have a better understanding. For more information, see “Duplicating slides” on page 235 and “Expanding slides” on page 236.

7) When the presentation is created, some hierarchical structure of the outline may be lost. If necessary, use Promote/Demote tools on the Outline toolbar to move the outline points to the correct level.
Formatting slides

Use master slides to give your presentation a professional look and avoid manually modifying the formatting of each individual slide. Multiple master slides can be used in a single presentation to provide the same look to groups of slides or individual slides. See Chapter 2, Master Slides, Styles, and Templates for more information about using master slides.

Slide setup

Individual slides can be formatted separately in a presentation using the Slide Setup dialog (Figure 218) or the Slide section in the Properties deck on the Sidebar (Figure 219).

**Slide Setup dialog**

1) Make sure you are in Normal or Notes view in the Workspace.
2) Open the Slide Setup dialog using one of the following methods:
   - Go to Slide > Properties on the Menu bar.
   - Right-click in an empty area on the slide and select Properties from the context menu.
3) Use the various options available in the Slide, Background, and Transparency pages in the Slide Setup dialog to setup the slide. See Chapter 2, Master Slides, Styles and Templates for more information on the various options available in the Slide Setup dialog.
4) Click OK to save your changes and close the Slide Setup dialog.

**Sidebar Slide section**

Options selected in the Slide section are applied immediately to the slide.

1) Make sure you are in Normal or Notes view in the Workspace.
2) Click on Properties in the Sidebar to open the Properties deck.
3) Click on Slide to open the Slide section in the Properties deck.
4) Select the slide size to use from the predefined sizes in the Format drop down list.
5) Select the slide orientation to use from the Orientation drop down list.
6) Select the slide background to use from the Background drop down list. The background type selected changes the options available. For more information on slide backgrounds, see Chapter 2, Master Slides, Styles and Templates.

7) If necessary, select the master slide to use from the Master Slide drop down list.

8) If necessary, select to use or deselect not to use Master Background or Master Objects on the slide. Only available if a master slide has been used for the slide.

9) If necessary, click on Master View to check on how the master slide selected looks and if it matches your requirements.

Selecting master slides

You can apply a master slide to all the slides in a presentation or only to selected slides in a presentation. This allows the use of more than one master slide in a presentation. For more information on master slides, see Chapter 2, Master Slides, Styles and Templates.

1) Make sure you are in Normal or Notes view in the Workspace.
2) In the Sidebar, click on Master Slides to open the Master Slides deck (Figure 220) and display the available master slides for use.

3) Select a master slide from the options available in the sections for Used in This Presentation, Recently Used, or Available for Use.

4) Apply the selected master slide to slides using one of the following methods:
   - For all slides in the presentation, right-click on the selected master slide and select Apply to All Slides from the context menu.
   - For selected slides only, right-click on the selected master slide and select Apply to Selected Slides from the context menu.

**Changing master slides**

1) Make sure you are in Normal or Notes view in the Workspace.

2) Select the slide in the Slides Pane so that it appears in the Workspace.

3) Right-click in a blank area on the slide in the Workspace and select Change Slide Master in the context menu to open the Available Master Slides dialog (Figure 221).

4) Navigate the master slides displayed in the Select a Slide Design preview box to the required master slide. If the required master slide is not displayed, then click on Load to open the Load Master Slide dialog (Figure 222).
   g) Select the category of master slide required in the Categories list.
   h) Select the template required in the Templates list and a preview of the template appears in the Preview box.
   i) Click OK to close the Load Master Slide dialog and the master slide templates appear in the Select a Slide Design preview box in the Available Master Slides dialog.

5) Select the required master slide from the master slides displayed and click OK. The slide changes to show the new master slide and the Available Master Slides dialog closes.
Figure 221: Available Master Slides dialog

Figure 222: Load Master Slide dialog
Changing slide background

1) Make sure you are in Normal view in the Workspace.
2) Select a slide in your presentation.
3) Open the Slide Setup dialog (Figure 223) using one of the following methods:
   – Go to Slide > Properties on the Menu bar.
   – Right-click in an empty area on the slide and select Properties from the context menu.
4) Click on the Background tab to open the Background page and select the type of background you want to use. For more information on background types, see Chapter 2, Master Slides, Styles, and Templates, and Chapter 6, Formatting Graphic Objects.
5) Select from the various options offered by the different background types the background effect for your selected slide.
6) Click OK to save the changes to the background and close the Slide Setup dialog.

**Note**
Only the background for one slide in a presentation can be changed at a time. To change the background on more than one slide at a time, you have to use master slides. For more information on slide backgrounds, see Chapter 2, Master Slides, Styles and Templates.

Choosing slide layout

After creating a new slide, you can then decide on which layout is suitable for the slide contents and your presentation. Impress offers various predefined layouts that can be applied as a starting point for a slide. Figure 224 shows the predefined layouts that are available in Impress. If the layouts available in Impress do not fit your requirements, layout elements can be rearranged, duplicated, resized, or deleted as necessary.
If the layout is changed on a slide that already contains text and objects, Impress does not delete these elements, but repositions the elements according to the selected layout. This may result in some elements overlapping or being out of position.

Custom defined layouts cannot be created and saved in Impress for use on several slides. It is recommended to create a master slide or template that uses a custom layout and can be used on several slides. For more information on master slides and templates, see Chapter 2, Master Slides, Styles, and Templates.

1) Make sure you are in Normal or Slide Sorter view in the Workspace.

2) Select a slide in your presentation.

3) Change the slide layout using one of the following methods:
   - Select a layout in the Layouts section in the Properties deck on the Sidebar.
   - Go to Slide > Layout in the Menu bar and select a layout from the list in the context menu.
   - Right-click on the slide in the Slides Pane and select Layout from the context menu, then select a layout from the list in the context menu.
   - Right-click on the slide in Slide Sorter view in the Workspace and select Layout from the context menu, then select a layout from the list in the context menu.
   - Right-click in an empty area on the slide in Normal view in the Workspace and select Layout from the context menu, then select a layout from the list in the context menu.

4) When the slide layout has changed, make the necessary formatting, resizing, and repositioning adjustments to the elements on the slide. For more information on adjustments of slide elements, refer to the other chapters in this guide.

Figure 224: Layouts section in Properties on Sidebar
Note

Hovering the cursor over a layout in the Layouts section in the Properties deck on the Sidebar will display the layout type. These layout types match the layout list that is displayed in the context menu.

Presentation notes

Notes provide a convenient way to create reminders or add extra information to slides in a presentation. Notes are not displayed during a slide show. However, using dual displays, you can display notes on the second display as a presentation cue.

Note

When using a second display, it is recommended to use the Presenter Console. The Presenter Console allows you to display on your screen the slide notes, the next slide, and other useful information while only the slide is shown on the second display. For more information on the Presenter Console, see Chapter 1, Introducing Impress and Chapter 9, Slide Shows.

Adding notes

1) Select a slide where you want to add notes.
2) Open the Notes view (Figure 225) using one of the following methods:
   - Click on the Notes tab at the top of the Workspace.
   - Go to View > Notes on the Menu bar.
   - Click on Display Views and select Notes in Edit Modes on the Standard toolbar.
3) Click on Click to add notes below the slide then type or paste text or graphics as required into the notes box.
4) To add notes to another slide, repeat Steps 1 thru 3.
5) When you have finished adding notes, return to Normal view in the Workspace.

Note

The notes text box and slide image can be moved and resized on the Notes page. Also, more text boxes can be added to the Notes page. Refer to the other chapters in this guide for more information.
Figure 225: Notes view in Workspace

Click to add Notes

Figure 226: Master Notes view in Workspace

Click to move the slide

Click to edit the notes format
Formatting notes

It is recommended to use the Master Notes to format the appearance of notes, rather than formatting notes individually for each slide.

1) Select a slide that has notes added.

2) Open Master Notes view (Figure 226) using one of the following methods:
   - Go to View > Master Notes on the Menu bar.
   - Click on Master on the Standard toolbar, then click on the Notes tab at the top of the Workspace.
   - Click on Display Views and select Master Notes in Master Modes on the Standard toolbar.

3) Open the Slide Setup dialog for master notes (Figure 227) using one of the following methods:
   - Go to Slide > Properties on the Menu bar.
   - Right-click in an empty area on the master note and select Properties from the context menu.

4) Use the various options available in the Slide Setup dialog to setup the master note. See Chapter 2, Master Slides, Styles and Templates for more information on the various options available in the Slide Setup dialog.

5) Click OK save the formatting changes and close the Slide Setup dialog.

Adding text

When text is inserted in the Notes text box, it is automatically formatted using the predefined Notes style that is in the Presentation Styles section in the Styles deck on the Sidebar. The Notes style cannot be deleted, but can be modified to match your requirements.
1) Click on Styles in the Sidebar to open the Styles deck.

2) Click on Presentation Styles at the top of the Styles deck to open the Presentation Styles section.

3) Right click on Notes presentation style and select Modify from the context menu. This opens the Notes dialog (Figure 228).

4) Use the various pages in the Notes dialog to modify the Notes style to your requirements.

5) Click OK to save your changes and close the Notes dialog.

Text boxes can also be added to the notes page and then modified to suit your requirements. Also, text styles for any text in a text box can be created to suit your text requirements. Any text styles created are placed in the Custom category. These custom styles can be deleted when you have no further requirement for the custom style.

For more information on creating styles, adding text, and formatting text, see Chapter 2, Slide Masters, Styles and Templates, or Chapter 3, Adding and Formatting Text.

**Header and Footers**

In Notes, information can be entered into the header and footer areas on the notes page. The header and footer areas are similar to the header and footer areas used in the master slides. The header and footer areas are as follows:

- Header text
- Date and time – fixed or variable
- Footer text
- Page number
1) Select a slide that has notes added.

2) Open the Notes view. See “Adding notes” on page 246.

3) Open Master Notes view. See “Formatting notes” on page 248.

4) Go to Insert > Header and Footer on the Menu bar to open the Header and Footer dialog (Figure 229).

5) Click on the Notes and Handouts tab to open the header and footer options for Notes.

6) To add header text to the notes page, check the Header option and enter the text for the header in the Header text text box.

7) To add the date and time to the notes page, check the Date and time option and enter a fixed or variable date and time as follows:

   a) If the date and time is fixed, select the Fixed option and enter the date and time required in the Fixed text box.

   b) If the date and time is variable, select the Variable option then select the date and time format from the Format drop down list and select the language used from the Language drop down list. The language selected will affect the date and time formats that are available.

8) To add footer text to the notes page, check the Footer option and enter the text for the footer in the Footer text text box.

9) To add page numbers to the notes page, select the Page Number option so that the page number appears on each notes page in a presentation.

10) Click on Apply to All to save the changes and close the Header and Footer dialog.
Printing notes

Printing presentation notes gives you the opportunity to use the notes pages as handouts to the attendees of your presentation. For more information on printing slides and notes, see Chapter 10, Printing, E-mailing, Exporting, and Saving Slide Shows.

1) Select a slide that has notes added.
2) Open the Notes view. See “Adding notes” on page 246.
3) Go to File > Print on the Menu bar, or use the keyboard shortcut Ctrl+P to open the Print dialog (Figure 230).
4) Select LibreOffice Impress to open the options for printing notes.
5) In Type, select Notes from the drop down list.
6) Select all other required options for printing, for example number of copies required and number of pages.
7) Click OK to print and close the Print dialog.

Exporting notes as PDF

1) Select a slide that has notes added.
2) Open the Notes view. See “Adding notes” on page 246.
3) Go to File > Export As > Export as PDF on the Menu bar to open the PDF Options dialog (Figure 231).
4) In Structure on the General page, make sure that the option Export notes pages is selected.
5) If necessary, select the option Export only notes pages to create a PDF file for the presentation notes only.
6) If required, select the other pages in the PDF Options dialog and select the various options you want to use when creating a PDF file.

7) Click on Export to open a file browser window.

8) Navigate to the folder where you want to save the PDF file.

9) Enter a filename, click on Save to save the file in the designated folder and close the file browser window and PDF Options dialog.

**Note**

If the presentation has 10 slides for example, the PDF will contain 20 pages consisting of 10 pages of individual slides followed by 10 pages of notes formatted for the paper size selected.

### Adding comments

Impress supports comments similar to those in Writer and Calc.

1) Select **Tools > Options > LibreOffice > User Data** to configure the name and initials you want to appear in the comment. This is necessary so that your initials appear in comments and identify you as the comment author.

2) In **Normal View**, go to **Insert > Comment** on the Menu bar or use the keyboard shortcut Ctrl+Alt+C to open a blank comment (Figure 232).

   – A small box containing your initials appears in the upper left-hand corner of the slide, with a larger text box beside it. Impress automatically adds your name and the current date at the bottom of the text box.
   
   – If more than one person edits the document, each person is automatically allocated a different background color.

3) Type or paste your text into the comment.
4) Move the small comment markers anywhere you wish on the slide. Typically you might place it on or near an object you refer to in the comment.

5) To show or hide the comment markers, choose View > Comments on the Menu bar.

**Printing handouts**

Handouts are used when you want to distribute a copy of the presentation slides to each member of your audience. Handouts are only available in View > Master Handout on the Menu bar and are printed using the printing options in Impress.

**Note**

The printing of handouts depends on the printer, computer operating system, and how a computer is setup. The following printing procedure for handouts is only an example of how to print handouts.

1) Go to View > Master Handout on the Menu bar to set up the layout of slides for printing handouts. An example handout is displayed in the Workspace (Figure 233).

2) Go to Insert > Header and Footer on the Menu bar to open the Header and Footer dialog (Figure 229 on page 250).

3) Click on Notes and Handouts tab to open the page for notes and handouts in the Header and Footer dialog.

4) Select the required header and footer options from the default options. See “Header and Footers” on page 249 for more information.

5) Click on Apply to All to save your options for the handouts and close the Header and Footer dialog.

6) Go to File > Print on the Menu bar or use the keyboard shortcut Ctrl+P to open the Print dialog (Figure 230 on page 251).

7) Click on LibreOffice Impress to open the page for printing options of handouts.

8) In Document, select the required options from the drop down lists as follows:

   – **Type:** – select Handouts from the drop down list.
   – **Slides per page:** – select how many slides are printed on a sheet of paper.
   – **Order:** – select the order in which the slides are printed on a sheet of paper.

9) In Contents, select Slide name, Date and time, or Hidden pages if you want one or all of these items printed on the handouts.
10) In **Color**, select one option on how the handouts are printed.
11) In **Size**, select one option for size on how the handouts are printed.
12) Click on **Print** to print the handouts and close the Print dialog.

---

*Figure 233: Example handout in Workspace*
Chapter 9
Slide Shows and Photo Albums
Introduction

LibreOffice Impress gives you the tools to organize and display a slide show, including:

- Which slides to show and in what sequence.
- Whether to run the show automatically or manually.
- Transitions between slides.
- Animations on individual slides.
- Interactions: what happens when you click a button or link.
- A presenter console.

Creating slide shows

Basic settings

Most tasks associated with putting together a slide show are best done in Slide Sorter view where all of your slides in the presentation appear in the workspace.

13) Open the Slide Sorter view (Figure 234) using one of the following methods:
   - Go to View > Slide Sorter on the main menu bar.
   - Click the Slide Sorter tab at the top of the Workspace pane.
14) Go to Slide Show > Slide Show Settings on the main menu bar to open the Slide Show Settings dialog (Figure 235).
15) Select the options you want to use for your slide show.
16) Click OK to save your changes and close the Slide Show Settings dialog.

Slide Show options

- **Range** – select which slides to include in the slide show.
  - **All slides** – includes all slides except for those slides marked Hidden (see “Hiding slides” on page 258). Slides are shown in the sequence they occur in the file. To change the sequence, either rearrange the slides in the slide sorter or select the custom slide show option.
  - **From** – starts the show at the slide selected from the drop down list. For example, you might have several slides at the beginning that describe you and your company, but when you present this show to your work colleagues, you may want to skip that introduction.
  - **Custom slide show** – shows the slides in a different sequence that you have previously set up. This setting is not available until you have set up a custom slide show (see “Custom slide show” on page 259). You can set up as many different custom shows as you wish from one set of slides and they will appear in the drop-down list for this option.
- **Presentation Mode** – select how the slides will be displayed.
  - **Full screen** – shows the slides full screen without the LibreOffice program controls visible and exits the show after the last slide.
Figure 234: Slide Sorter view

Figure 235: Slide Show Settings dialog

- **In a window** – runs the slide show in the Impress window and exits the show after the last slide.
- **Loop and repeat after** – restarts the slide show after the last slide has displayed and after the specified length of time delay. A pause slide is displayed between the last slide and the start slide. Press the Esc key at any time to stop the show. If zero is entered as time delay, the show restarts immediately without showing a pause slide.
- **Show logo** – shows the LibreOffice logo on the pause slide when Loop and repeat after option is selected.

- **Options** – determine how the slide show runs as a presentation.
  - **Change slides manually** – prevents slides from changing automatically even if an automatic transition has been set up.
  - **Mouse pointer visible** – shows the mouse pointer during a slide show. If you do not have a laser pointer or other device to highlight items of interest during the show, this can be useful.
Mouse pointer as pen – enables you to write or draw on slides during the presentation. Anything you write with the pen is not saved when you exit the slide show. The color of the pen cannot be changed.

Animations allowed – displays all frames of animated GIF files during the slide show. If this option is not selected, only the first frame of an animated GIF file is displayed. This has nothing to do with the slide animations described in “Animations” on page 263.

Change slides by clicking on background – advances to the next slide when you click on the background of a slide. You can also press the spacebar on the keyboard to advance to the next slide.

Presentation always on top – prevents any other program window from appearing on top of the presentation.

• Multiple Displays – determines how the slide show is displayed.

  Presentation display – select from the drop down list which display to use for full screen slide show mode. Only available if the computer being used for the slide show is connected to more than one monitor.

Note

The multiple displays setting is not an option saved with the presentation file, but is instead saved as a local setting in the user configuration for the computer. This means that if you open the presentation on a different computer, the local settings for that computer are applied.

Hiding slides

You may not want to show all of the slides in a particular slide show. You can either hide some of the slides or set up a custom slide show to suit your requirements. For example, you may have draft slides that you do not want to show until they are finished, or you may have some slides that contain information for yourself, but not your audience.

Hiding slides

1) In the Slides pane, or Slide Sorter view in the Workspace, select the slides that you want to hide.

2) Hide selected slides using one of the following methods:
   – Click on Hide Slide in the Slide View toolbar (Figure 236).
   – Right-click on the selected slide and select Hide Slide from the context menu.
   – Go to Slide > Hide Slide on the main menu bar.

The selected slide is now displayed grayed out to indicate that it is hidden (Figure 237). The slide is not deleted and remains in the presentation file.

Showing hidden slides

1) In the Slides pane, or Slide Sorter view in the Workspace, select the hidden slides that you want to show.

2) Show the selected slides using one of the following methods. Show Slide is only active when there hidden slides are selected in your presentation.
   – Click on Show Slide in the Slide View toolbar.
   – Right-click on the selected slide and select Show Slide from the context menu.
   – Go to Slide > Show Slide on the main menu bar.
Custom slide show

To show the slides in a different order, you can either rearrange them in the Slides pane or Slide Sorter view in the Workspace, or set up a custom slide show.

You can define as many custom slide shows as you require from one set of slides. In a custom slide show, you can select which slides to include as well as the order in which they are shown. Any hidden slides will not appear in a custom slide show.

Creating custom slide show

1) Go to Slide Show > Custom Slide Show on the main menu bar to open the Custom Slide Shows dialog (Figure 238).

2) Click on New and the Define Custom Slide Show dialog opens (Figure 239).

3) Type a name for the new custom slide show in the Name text box.

4) In the Existing slides list, select the slides to include in the show.

5) Click the >> button to include the slides in the Selected slides list. You can select and include several slides at the same time. Hold down the Shift key and click the first and last slide in a group to select that group, or hold down the Ctrl key and click on individual slides to select them.
If required, rearrange the slide order in the **Selected slides** list. Click on a slide name and drag it to a new position in the list, then release the mouse button.

7) Click **OK** to save the custom slide show and return to the Custom Slide Shows dialog.

8) To activate a custom show, select it in the list in the Custom Slide Shows dialog and then select the **Use custom slide show** option.

9) Click **Start** to test the custom slide show or click **OK** to close the Custom Slide Shows dialog.

**Editing custom slide show**

1) Go to **Slide Show > Custom Slide Show** on the main menu bar to open the Custom Slide Shows dialog.

2) Select the name of the custom slide show you want to edit and click on **Edit** and the Define Custom Slide Show dialog opens.

3) Add slides, remove slides, change the slide order, or change the name of the custom slide show in the Define Custom Slide Show dialog.

4) Click **OK** to save the custom slide show and return to the Custom Slide Shows dialog.

5) Click **OK** to close the Custom Slide Shows dialog.

**Copying custom slide show**

1) Go to **Slide Show > Custom Slide Show** on the main menu bar to open the Custom Slide Shows dialog.

2) Select the title of the custom slide show you want to copy and click on **Copy**. The name of the selected custom slide show is repeated with the word (Copy 1) added to the name.

3) Select the name of the copied custom slide show and click on **Edit** and the Define Custom Slide Show dialog opens.

4) Change the name of the copied custom slide show in the Define Custom Slide Show dialog.

5) Click **OK** to save the copied custom slide show and return to the Custom Slide Shows dialog.
6) Click OK to close the Custom Slide Shows dialog.

**Deleting custom slide show**

1) Go to **Slide Show > Custom Slide Show** on the main menu bar to open the Custom Slide Shows dialog.

2) Select the name of the custom slide show you want to delete and click on **Delete**. Deletion is immediate and no confirmation message appears.

3) Click OK to close the Custom Slide Shows dialog.

**Using slide transitions**

Slide transitions are effects and/or sounds that take place between slides when slides change in a slide show. Transitions can add a professional look to a slide show, smoothing the change over between slides.

**Adding transitions**

1) Click on **Slide Transition** in the Sidebar to open the Slide Transition deck (Figure 240).

2) Open the presentation file where you want to add slide transitions.

3) In the Slides Pane or **Slide Sorter** view in the Workspace, select the slides where you want to apply slide transitions.

4) Click on a transition from the displayed list to apply it to the selected slide.

Figure 240: Slide Transition deck on Sidebar
5) To apply the same transition to all slides in the presentation, click on **Apply Transition to All Slides** at the bottom of the Slides Transition deck.

6) To check how the transition looks, click on **Play** at the bottom of the Slides Transition deck. Alternatively, to automatically preview how the transition looks when it is applied, select **Automatic Preview** at the bottom of the Slides Transition deck.

7) In the **Modify Transition** section, select from the available options as follows:

   - **Variant** – select an option from the drop list. The available options change according to the transition that has been selected.
   - **Duration** – enter a time for how long the transition lasts.
   - **Sound** – select a sound from the drop down list that is played when the transition activates. If a sound is selected, the **Loop until next sound** option becomes active. Select this option to play the sound repeatedly until another sound starts. If there are no subsequent sounds in your slide show, the selected sound will play continuously for the remainder of the show. Sounds can be played when **None** is selected for the transition effect.

8) In the **Advance Slide** section, select one of the two following options on how the slides change in a presentation. Only one option can be selected as follows:

   - **On mouse click** – each time the mouse is clicked, the presentation advances to the next slide.
   - **Automatically after** – enter a time in box to elapse before the next slide in the presentation advances into view.

   **Tip**

   A single type of transition can be applied to all the slides in the slide show or a different transition to any or every single slide in the slide show. While using many different transitions may be fun to do, it may not give your slide show a professional appearance.

**Removing transitions**

1) Click on **Slide Transition** in the Sidebar to open the Slide Transition deck.

2) Select the slides where you want to remove the transitions.

3) Select **None** at the top of the Slide Transition deck in the Sidebar.

   **Note**

   Slides with transitions are indicated by a star in the bottom left corner of the slide when viewed in the Slides Pane or the **Slide Sorter** view in the Workspace.

**Playing music**

You can play music during a slide show instead of a sound as a transition effect. When using music in a slide show, make sure you not infringing any musical copyright or licensing for the music.

1) Click on **Slide Transition** in the Sidebar to open the Slide Transition deck.

2) Open the presentation file where you want to add slide transitions.
3) In the Slides Pane or Slide Sorter view in the Workspace, select the slide where you want to add music.

4) In the Modify Transition section, select Other sound from the Sound drop-down list.

5) In the file browser window that opens, navigate to where the music file is located.

6) Select the music file you want to use and click on Play to check if the music file is suitable.

7) If the music is suitable, click Open to add the music to the selected slide and close the file browser window.

8) To play a music file continuously in the slide show, select the option Loop until next sound. The music file restarts once it is finished until the next music file that is inserted in the slide show.

**Note**

Do not select the Apply Transition to All Slides option, otherwise the selected music file restarts at every slide.

**Note**

The music file is linked to a slide show rather than embedded. If you plan to display the slide show on a different computer, remember that you also have to make the music file available on the computer where the slide show will be played and establish the link to the music file before starting the slide show.

### Animations

Slide animations are similar to transitions, but they are applied to individual elements in a single slide, such as title, chart, shape, or individual bullet point. Animations can make a presentation more lively and memorable. However, as with transitions, heavy use of animations can be fun, but distracting and even annoying for an audience expecting a professional presentation.

Animations are best applied using Normal view in the Workspace so that you can easily select individual objects on a single slide.

**Note**

At present it is not possible to apply animations to elements in master slides. This means that if you want to display the items in a text box one by one and use the same animation on more than one slide, you need to apply the effects to each slide. Alternatively you can copy the animated element from one slide to another.

### Applying animation

On a slide, an element such as a graphic or an entire text box has selection handles around it when selected. If you select only a portion of the text in a text box, you may not see any selection handles.

1) Go to View > Normal on the main menu bar to open Normal view in the Workspace.

2) Select the slide and element you want to animate.

3) On the Sidebar, select Animation to open the Animation deck (Figure 241).
4) Click on Add Effect (+ plus sign) to open the animation options on the **Animation** deck.

![Animation deck on Sidebar](image)

5) Select an animation category from the **Category** drop down list.

6) Select an animation effect from the available options in the **Effect** list.

7) Select how the animation starts from the **Start** drop down list.

8) Select the direction of the animation from the **Direction** drop down list.

9) Enter a time for the duration of the animation in the **Duration** box.

10) Enter a time for the delay of when the animation starts in the **Delay** box.

11) If you require more animation options, see “Additional animation options” on page 265 for more information.

12) If required, select **Automatic Preview** so you can automatically check how the animation looks when applied to a slide element.

13) Click on **Play** to check how the animation looks when applied to a slide element.
The options available for an animation depend on the *Category* and *Effect* that have been selected for an animation.

### Changing animation

1. Go to **View > Normal** on the main menu bar to open **Normal** view in the Workspace.
2. On the Sidebar, select **Animation** to open the Animation deck.
3. Select the slide and the slide element where you want to change the animation effect in the **Animation** box.
4. Using the procedure in “Applying animation” on page 263, select a new animation effect for the selected element.
5. Click on **Play** to check how the animation looks when applied to a slide element.

### Removing animation

1. Go to **View > Normal** on the main menu bar to open **Normal** view in the Workspace.
2. Select the slide and the animated element you want to remove.
3. On the Sidebar, select **Animation** to open the Animation deck.
4. Click on **Remove Effect** to remove the animation from the selected element.

### Additional animation options

Some animations have additional options that you can set or change. The actual options that are available depend on the animation selected.

1. Go to **View > Normal** on the main menu bar to open **Normal** view in the Workspace.
2. On the Sidebar, select **Animation** to open the Animation deck.
Figure 242: Effect Options dialog - Effect page

Figure 243: Effect Option dialog - Timing page
3) Select the slide and element where you want to apply additional animation options.

4) Click on Options to the right of the Direction drop down list to open the Effect Options dialog (Figure 242).

5) Click on a tab to open the options for the type of effect options you want to change and use.
   - **Effect** – specifies the settings and enhancements of the selected animation (Figure 242).
   - **Timing** – specifies the timing for the selected animation effect (Figure 243).
   - **Text Animation** – specifies how text is animated for the selected animation (Figure 244).

6) Click **OK** to save your changes and close the Effect Options dialog.

**Effect options**

Specifies the settings and enhancements for the selected animation using the **Effect** page in the Effect Options dialog (Figure 242).

- **Direction** – specifies the direction for the effect.
- **Sound** – select a sound from the drop down list or select one of the special entries as follows:
  - *(No sound)* – no sound is played during animation of the effect.
  - *(Stop previous sound)* – the sound of the previous effect is stopped as soon as the current effect runs.
  - *Other sound* – displays a file open dialog to select a sound or music file.
- **After animation** – select what happens after animation.
  - *(Don’t dim)* – no after-effect runs.
  - *Dim with color* – after the animation a dim color fills the shape.
  - *Hide after animation* – hides the shape after the animation ends.
  - *Hide on next animation* – hides the shape on the next animation.
- **Dim color** – select the dim color. Only available if *Dim with color* has been selected.
- **Text animation** – select the animation mode for the text of the current shape:
  - *(All at once)* – animates the text all at once.
  - *Word by word* – animates the text word by word.
• **Delay between characters** – specifies the percentage of delay between animations if *Word by word* or *Letter by letter* has been selected for *Text animation*.

**Timing options**

 Specifies the timing for the selected animation using the *Timing* page in the Effect Options dialog (Figure 243).

• **Start** – displays the start property of the selected animation effect.
  – *On click* – the animation stops at this effect until the next mouse click.
  – *With previous* – the animation runs immediately.
  – *After previous* – the animation runs as soon as the previous animation ends.

• **Delay** – specifies an additional delay in seconds until the effect starts.

• **Speed** – specifies the duration of the effect in seconds.

• **Repeat** – specifies when and how to repeat the current effect. Enter the number of repeats, or select from the list:
  – *none* – the effect is not repeated.
  – *Until next click* – the animation is repeated until the next mouse click.
  – *Until end of slide* – the animation repeats as long as the slide is displayed.

• **Rewind when done playing** – the animated shape returns to its starting state after the animation ends.

• **Animate as part of click sequence** – allows the animation start in a normal click sequence.

• **Start effect on click of** – allows the animation start when a specified shape is clicked. Select the shape by its name from the drop down list.

**Text animation options**

 Specifies the text animation settings for the selected animation using the *Text Animation* page in the Effect Options dialog (Figure 244).

• **Group text** – specifies how multiple paragraphs are animated:
  – *As one object* – all paragraphs are animated as one object.
  – *All paragraphs at once* – all paragraphs are animated at once, but paragraphs can have different effects.
  – *By 1st level paragraphs* – the first level paragraphs, including sub-level paragraphs, are animated one after another.

• **Automatically after** – if *By 1st level paragraphs* is selected for *Group text*, the paragraphs are animated one after the other. Enter an additional delay in seconds to animate subsequent paragraphs.

• **Animate attached shape** – deselect this box to animate only the text, not the shape.

• **In reverse order** – animates the paragraphs in reverse order.

**Animation example**

 Creating animations on a slide takes practice to achieve the animation effect you want. The following steps explains how to setup the animation shown in Figure 245 as a simple example of multiple animations that you can create. The example slide is taken from a LibreOffice presentation. It would be very easy for you to create a similar slide and recreate this example.
1) Go to View > Normal on the main menu bar to open Normal view in the Workspace.

2) Select a slide that you want to animate.

3) On the Sidebar, select Animation to open the Animation deck.

4) Select two elements on the slide, then click on Add Effect (+ plus sign) to open the animation options on the Animation deck. The selected elements appear on the Animation deck.

5) Select the first element (Shape 1: Green Bright) and select Entrance from the Category drop down list.

6) Select the following options for the animation:
   - Effect – Venetian Blinds
   - Start – On click
   - Direction – Vertical
   - Duration – 0.50 sec

7) Select the second element (Shape 3: Blue Bright) and select Motion Paths from the Category drop down list.

8) Select the following options for the animation:
   - Effect – 5 Point Star
   - Start – After previous
   - Duration – 10.00 sec

9) Go to Slide Show > Rehearse Timings on the main menu bar and check the animation of these two objects.
Using interactions

Interactions are where objects on a slide are used to create an event when it is clicked with the mouse cursor. These objects with interactions can be buttons, images, or text objects.

1) Go to View > Normal on the main menu bar to open Normal view in the Workspace.

![Interaction dialog](image)

**Figure 246: Interaction dialog**

2) Select a slide where you want to add an interaction to an object on the slide.

3) Select the object, then use one of the following methods to open the Interaction dialog (Figure 246).
   - Right-click on the object and select Interaction from the context menu.
   - Go to Format > Interaction on the main menu bar.

4) Select an interaction from the Action at mouse click drop-down list. The options available in this dialog depend on the interaction that has been selected.

5) Click OK to save your changes and close the Interaction dialog.

Slide shows

Running a slide show

1) Open your presentation and start the slide show using one of the following methods:
   - Use the keyboard shortcut F5 to start from the first slide or Shift+F5 to start from the current slide.
   - Go to Slide Show > Start from First Slide or Start from Current Slide on the main menu bar.
   - Click on Start from First Slide on the Slide Sorter toolbar.
2) If the slide transition is set to *Automatically after x sec*, the slide show starts and runs after the set time has elapsed.

3) If the slide transition is set to *On mouse click*, use one of the following methods to advance the slides:
   - Click the left mouse button.
   - Press the down arrow key.
   - Press the right arrow key.
   - Press the page down key.
   - Press the spacebar.

4) To navigate backwards through a slide show one slide at a time, use one of the following methods:
   - Press the up arrow key.
   - Press the left arrow key.
   - Press the page up key.

5) During a slide show, more navigation options are available when you right click on a slide and use the options available in the context menu.

6) When the last slide has displayed, the message *Click to exit presentation...* is displayed on screen. Press the *Esc* key or click the left mouse button to exit the slide show.

7) To exit the slide show and return to the Impress workspace at any time, press the *Esc* key during the slide show.

**Note**

During the slide show, any animations on a slide are run in the specified order as the slide is displayed.

**Context menu navigation and options**

If the slide show consists of more than one slide, right-clicking on the screen opens a context menu displaying navigation options. These navigation options are as follows:

- **Next** – moves to the next slide in the slide show.
- **Previous** – moves to the previous slide in the slide show.
- **Go to Slide** – displays a sub-context menu allowing selection and navigation to any slide in the slide show. The list of slides shows the need of naming slides in a slide show rather than using the default slide names of Slide 1, Slide 2, and so on. Naming slides makes it easier to identify the required slide.
- **Mouse pointer as Pen** – allows you to use the cursor as a pen and draw on a slide to emphasize or explain a point.
- **Pen Width** – opens a sub-context menu providing options to set the width of any lines drawn on a slide when using the cursor as a pen.
- **Change pen Color** – opens a dialog allowing you to change the line color when using the cursor as a pen.
- **Erase all ink on Slide** – deletes all lines drawn after you have finished using the cursor as a pen.
• **Screen** – opens a sub-context menu with a black or white color choice. This is useful if you want to pause the slide show for a break or to demonstrate something else.

• **End Show** – ends the presentation and returns you to the Impress workspace. This is the same effect as pressing the *Esc* key.

### Automatic slide show repeat

1) Go to **Slide Show > Slide Show Settings** on the main menu bar to open the Slide Show Settings dialog (Figure 235 on page 257).

2) In **Presentation Mode**, select the option *Loop and repeat after* and a time delay in the box of when you want the slide show to start again.

3) If necessary, select *Show logo* if you want the LibreOffice logo to be displayed during the pause between slide shows.

4) Click **OK** to save the settings and close the Slide Show Settings dialog.

### Slide show timing

#### Default timing

1) Click on **Slide Transition** in the Sidebar to open the Slide Transition deck (Figure 240 on page 261).

2) Select *None* at the top of the **Slide Transition** deck in the Sidebar as the transition effect.

3) Select the option *Automatically after* in **Advance Slide** and set a time in the box.

4) Click on **Apply Transition to All Slides** to set the default timing of the slide show.

5) Go to **Slide Show > Start from First Slide** on the main menu bar to check how the presentation runs.

6) If necessary, adjust the default timing until you are satisfied on how the slide show runs.

#### Variable timing

1) Select **Slide Show > Rehearse Timings** on the main menu bar. The slide show starts in full-screen mode and a timer appears in the lower left corner of the display.

2) When you want to advance to the next slide, click on the timer to set the time duration for the displayed slide and advance to the next slide. To keep the default time duration for a slide, click the slide and not the timer.

3) Continue until the time duration is set for all slides in the slide show. Impress records the time duration set for each slide.

4) To exit from rehearsal timing of the slide show, press the *Esc* key, or click on the slide.

### Presenter Console

Normally, LibreOffice Impress already includes the **Presenter Console** when LibreOffice is installed on your computer. If the **Presenter Console** is not included, the extension can be downloaded from the LibreOffice website and installed on your computer. For more information, see Chapter 11, Setting up and Customizing Impress.
The **Presenter Console** provides extra control over slide shows when using dual displays, such as a laptop for yourself and large display or projector for your audience. The view you see on your computer display includes the current slide that can be seen by the audience, the next slide in your presentation, any slide notes, and a presentation timer.

**Note**

The **Presenter Console** only works with operating systems that support two displays. When two displays are being used, one display can be a laptop.

*Figure 247: Presenter Console – Default view*
The **Presenter Console** provides the following views to assist you when making a presentation:

- **Default view** – displays the current slide, including any effects and the next slide in the presentation (Figure 247). Click on the *Previous* and *Next* arrows to navigate through a presentation.

- **Notes view** – click on *Notes* to switch to display any notes that accompany each slide in the presentation (Figure 248). Click on *Notes* again to return to the default view.
• **Slides view** – click on *Slides* to switch to display the slide thumbnails that are being used for the presentation (Figure 249). Click on *Slides* again to return to the default view.

• **Exchange** – click on this icon to switch the **Presentation Console** between displays.

**Photo albums**

Impress can create a photo album from a set of images, usually with one photo per slide. This photo album can be a slide show or multimedia show with graphics and images or your latest vacation pictures.

1) Create a new presentation or open an existing presentation.
2) Select the slide that is going to precede the photo album. In a new presentation, this will be the first slide.
3) Go to **Insert > Media > Photo Album** on the main menu bar to open the Create Photo Album dialog (Figure 250).
4) Click on **Add** to open a file browser.
5) Navigate to the folder where your pictures or photos are located.
6) Select the pictures or photos you want to use and click on **Open**. This closes the file browser and the selected files appear in the Create Photo Album dialog.
7) Select the number of images per slide in the *Slide layout*: drop-down list.
8) If required, select **Add caption to each slide**. This inserts a text box on each slide allowing you to add a caption to the images.
9) If required and there is only one image per slide, select **Fill Screen** for each image to fill the entire slide.
10) Create the required sequence of photos or pictures by moving image files up or down in the list of images.
11) When the sequence of images is ready, click **Insert Slides** to create the number of slides required for your photo album. Impress creates a presentation with as many slides that are required to contain your images. The sequence can be changed later, as you can with any slides.
12) If required, you can copy and paste images between slides as you can with any other elements that can be placed on a slide.

13) If required, you can setup your photo album and run it as a slide show. See “Creating slide shows” on page 256 and “Slide shows” on page 270.

Figure 250: Create Photo Album dialog
Chapter 10
Saving Slide Shows, Printing, Emailing, and Exporting
Saving slide shows

Slide shows created in Impress are, by default, saved in the Open Document Presentation (ODP) format. However, Impress can open and save a slide show in other widely used and recognized presentation formats.

New slide show

1) Create a new slide show. For more information, see Chapter 1, Introducing Impress and Chapter 9, Slide Shows and Photo Albums.

2) Save the new slide show using one of the following methods to open the Save as dialog (Figure 251).
   - Click on Save on the Standard toolbar.
   - Go to File > Save on the Menu bar.
   - Use the keyboard shortcut Ctrl+S.

3) Navigate to where you want to save the slide show.

4) Enter a filename in the File name text box.

5) Select a file format from the File type drop down list. By default, the file format is Open Document Presentation (.odp).

6) Click on Save to save the slide show and close the Save as dialog.

Figure 251: Save As dialog
Note

If you are NOT saving the slide show in the ODP presentation format, a Confirm File Format dialog (Figure 252) opens asking you to confirm the file format you have selected.

**ODP format**

1) Open a slide show in Impress and make all the required changes. Impress will open slide shows that have been saved in a presentation format that Impress recognizes.

2) Save the slide show in ODP format using one of the following methods:
   - Click on **Save** on the Standard toolbar.
   - Go to **File > Save** on the Menu bar.
   - Use the keyboard shortcut Ctrl+S.

**Other presentation formats**

1) Open a slide show in Impress and make all the required changes. Impress will open slide shows that have been saved in a presentation format that Impress recognizes.

2) Save the slide show in a presentation format that Impress recognizes, use one of the following methods:
   - Click the small triangle ▼ to the right of the **Save** icon on the Standard toolbar and select **Save As** from the drop down menu.
   - Go to **File > Save As** on the Menu bar.
   - Use the keyboard shortcut Ctrl+Shift+S.

3) In the **Save as** file browser that opens, navigate to where you want to save the slide show.

4) Enter a filename in the **File name** text box.

5) Select a presentation file format from the **File type** drop down list. By default, the file format is Open Document Presentation (.odp).

6) Click on **Save** to save the slide show and close the Save as dialog.
Impress provides many options for printing slides or a complete presentation. For example, multiple slides on one page, single slide per page, slides with notes, as an outline, with date and time, with page name, and so on. For more information on printing LibreOffice documents, see the *Getting Started Guide*.
Any printing options selected in Impress using the Print dialog (Figure 253 and Figure 254) only apply to the printing of the current document. To specify default printing settings for Impress, go to Tools > Options > LibreOffice > Print and Tools > Options > LibreOffice Impress > Print.

Note

Any print options selected with the Print dialog when printing from Impress will override the default printer settings that have been set using Tools > Options > LibreOffice > Print and Tools > Options > LibreOffice Impress > Print.

Printing slides

1) Open the Print dialog using one of the following methods:
   – Go to File > Print on the Menu bar.
   – Use the keyboard shortcut Ctrl+P.
   – Click on Print on the Standard toolbar.

2) Click on the General tab to open the page for general print options (Figure 253).
   c) If necessary, select a printer from the Printer drop down list of printers available.
   d) If necessary, in Printer click on Properties to display a properties dialog for the selected printer and select the options required. Click OK to save your Properties selection and close the dialog. Actual printer properties available depend on the printer selected and computer operating system being used.
   e) Select the slides to print, the paper side to print on (simplex or duplex), number of copies, and the print order from the options available in Range and Copies.
   f) Select the paper size, orientation, pages per sheet, and, if necessary, brochure printing from the options available in Page Layout.

3) Click on the LibreOffice Impress tab to open the page for LibreOffice Impress print options (Figure 254).
   a) Select the document type, slides per page and the printing order from the drop down lists in Document.
   b) Select whether to print slide name, date and time, or hidden pages from the options available in Contents.
   c) Select the type of color to print from the options available in Color.
   d) Select the printed size from the options available in Size.

4) On the General or LibreOffice Impress page, click on More Options and select if you want to Create separate print jobs for a collated output when printing multiple copies of your slides.

5) Click OK to print your slides and close the Print dialog.

Brochure printing

You can print your slides arranged so that, when printed, the slides are in the correct order to form a booklet or brochure.
The procedures given below are only examples. The actual procedure may differ as this depends on the computer operating system and type of printer being used. You may have to experiment to find the correct method for brochure printing.

**Single sided printing**

The following procedure is an example of how to create a brochure or booklet using a printer that is only capable of printing single sided.

1) Open the Print dialog using one of the following methods:
   - Go to File > Print on the Menu bar.
   - Use the keyboard shortcut Ctrl+P.
   - Click on Print on the Standard toolbar.

2) Click on the General tab to open the page for general print options.

3) Click on Properties and check the printer is set to the same page orientation as specified for the page setup for your slides. Usually page orientation does not matter, but it is important for brochures.

4) Click OK to close the properties dialog return to the Print dialog.

5) In Range and Copies section, select the All Slides option. A minimum of four slides is required to create a brochure.

6) In the Range and Copies section, select the Number of copies required to match the required number of brochures.

7) In the Layout section, select the Brochure option.

8) In the Range and Copies section, select Even slides option.

9) Click OK to print the Even slides.

10) Take the printed slides out of the printer and put them back into the printer in the correct orientation to print on the other side of the paper. You may need to experiment a bit to find out what the correct arrangement is for your printer.

11) In the Range and Copies section, select Odd slides option.

12) In the Range and Copies section, select the same Number of copies used for printing the Even slides.

13) Click OK to print the Odd slides and close the Print dialog.

14) Assemble your brochures and bind them, if necessary.

**Double sided or duplex printing**

Printing a brochure on a printer that is capable of double sided or duplex printing makes the task of creating brochures a lot simpler.

1) Open the Print dialog using one of the following methods:
   - Go to File > Print on the Menu bar.
   - Use the keyboard shortcut Ctrl+P.
   - Click on Print on the Standard toolbar.

2) Click on the General tab to open the page for general print options.
3) Click on **Properties** and check the printer is set to the same page orientation as specified for the page setup for your slides. Usually page orientation does not matter, but it is important for brochures.

4) In **Range and Copies** section, select the **All Slides** option. A minimum of four slides is required to create a brochure.

5) In **Range and Copies** section, select **Print on both sides (duplex long edge)** or **Print on both sides (duplex short edge)** option. Normally, long edge binding is used for portrait printing and short edge binding is used for landscape printing.

6) In the **Range and Copies** section, select the **Number of copies** required to match the required number of brochures.

7) In the **Range and Copies** section, select the **Collate** option. This option is only active when printing multiple copies of the same document.

8) In the **Layout** section, select the **Brochure** option.

9) Click **OK** to close the Print dialog and print the required number of pages for your brochures.

10) If necessary, bind the brochures to match either long edge or short edge binding.

---

**Emailing**

LibreOffice provides two methods of emailing an Impress slide show as an attachment in ODP format or PDF format directly from the Impress module. For more information on emailing LibreOffice documents, see the *Getting Started Guide*.

**ODP format**

1) Make sure the slide show you want to send as an email attachment is open in Impress.

2) Go to **Format > Send > Email Document** on the Menu bar and your default email program opens with the slide show already attached to the email.

3) Enter the recipient's name, subject title, and message then send the email.

**PDF format**

1) Make sure the slide show you want to send as an email attachment is open in Impress.

2) Go to **Format > Send > Email as PDF** on the Menu bar and the PDF Options dialog (Figure 255) opens.

3) If necessary, select the required PDF options to create a PDF version of the slide show. Normally, the default options already selected are sufficient to create a PDF file that the email recipient will be able to open.

4) Click on **Send** to close the PDF Options dialog and your default email program opens with the PDF file already attached to the email.

5) Enter the recipient's name, subject title, and message then send the email.
Exporting

Impress can export slide shows in the PDF format as well as other file formats. The PDF format is a standard file format for file viewing and is ideal for sending the file to someone who can only view a slide show file using a PDF viewer.

For more information on exporting LibreOffice documents, see the Getting Started Guide.

Quick PDF export

1) Make sure the slide show you want to convert to PDF format is open in Impress.
2) Use one of the following methods to export the file as a PDF and open a file browser window.
   - Click on Export Directly as PDF on the Standard toolbar.
   - Go to File > Export As > Export Directly as PDF on the Menu bar.
3) In the file browser window that opens, navigate to where you want to save the PDF file version of your slide show.
4) In the Name text box, enter a filename for the PDF file or use the filename that is displayed in this text box. The file format is fixed as PDF and cannot be changed.
5) Click on Save to save your slide show as a PDF file and close the file browser window.

PDF export

For more control over the content and quality of a PDF file, it is recommended to use the PDF Options dialog (Figure 255). For more information on the options available when exporting a slide show as a PDF file, see the Getting Started Guide.
1) Go to **File > Export as PDF** on the menu bar to open the PDF Options dialog.

2) Select the options required for your PDF file using the options available on the tabbed pages of the PDF Options dialog. For more information, see the *Getting Started Guide*.

3) Click on **Export** to open a file browser window.

4) Navigate to where you want to save the PDF file version of your slide show.

5) Enter a file name for the PDF in the **Name** text box. The file format is fixed as PDF and cannot be changed.

6) Click on **Export** to save and export the file to the location you have selected.

**Web pages (HTML) export**

Slide shows can be exported as a series of web pages (HTML format) that can be viewed in any browser.

1) Go to **File > Export** on the menu bar to open a file browser window.

2) In the file format box, select HTML format from the drop down list.

3) Navigate to where you want to save the HTML version of your slide show.

4) Create a folder to contain the HTML pages that will be generated and select the folder as the destination for the HTML pages.

5) Click on **Save** and the HTML Export dialog (Figure 256) opens.

---

**Note**

Exporting slide shows as web pages (HTML) does not retain any animation effects or slide transitions.

6) Select a design for all of the HTML pages, either from an existing design or by creating a new one. If you have not previously saved a design, the *Existing Design* option is not available.

*Figure 256: HTML Export dialog - Assign Design page*
Click on **Next** to select the publication type to use for creating the web pages (Figure 257). The available options will change depending on publication type selected.

- **Standard HTML** – one page for each slide with navigation links to move from slide to slide.
- **Standard HTML with frames** – one page with a navigation bar on the left-hand side; uses slide title as navigation links. Click on links to display pages in right-hand side.
- **Single-document HTML** – creates one HTML document from the slide show.
- **Automatic** – one page for each slide, with each page set with the refresh meta tag so a browser automatically cycles from one page to the next.
- **WebCast** – generates an ASP or Perl application to display the slides. Unfortunately LibreOffice has no direct support for PHP yet.
8) Click on **Next** to select the format for saving images (PNG, GIF or JPG) and the resolution used (Figure 258). When selecting a resolution, consider what the type of display users may have. For example, if a high resolution is selected, then a user with a medium-resolution display will have to scroll sideways to see the entire slide.

9) Click on Next and enter the details for a title page (Figure 259), such as name of the author, e-mail address and home page, along with any additional information you want to include. This page does not display if the *Create title page* option was not selected when selecting **Publication Type**.

10) Click on **Next** to select the style of navigation buttons to use when moving from one page to another (Figure 260). If you do not want to use buttons, make sure **Text only** is selected.

11) Click on **Next** to select the color scheme for the web pages (Figure 261). Available schemes include the existing scheme for the presentation, one based upon browser colors, and a user-defined scheme. You can save a new scheme so that it will appear on the first page of the HTML export wizard.
12) Click on **Create** to generate the HTML files. If this is a new design, a dialog opens so you can save the design for future use.

![HTML Export dialog - Select Color Scheme](image)

*Figure 261: HTML Export dialog - Select Color Scheme*

**Export in other formats**

1) Go to **File > Export** on the Menu bar to open a file browser window.

2) Navigate to where you want to save the PDF file version of your slide show.

3) Enter a file name for the exported file in the **File name** text box.

4) In the file format box, select the file format that you require.

5) Click on **Save** to export the file to your selected location. This will open an options dialog allowing you to select further options for the file format selected.

6) Click on **OK** to save your exported file and close the options dialog. For more information on exporting files, see the *Getting Started Guide*. 
Chapter 11
Setting Up and Customizing Impress
Introduction

This chapter covers some of the settings in LibreOffice that apply when using Impress, but may also apply to all the other modules in LibreOffice. The illustrations in this chapter have been taken from LibreOffice Impress. For more information on setting up and customizing all the modules in LibreOffice, see the Getting Started Guide.

LibreOffice options

Note

Revert has the same effect on all pages in the Options LibreOffice dialog. It resets the options to the values that were in place when you opened LibreOffice.

User Data options

Impress uses the first and last name stored in User Data for document properties, optional author field used in slides, and the name associated with any comments that have been made.

1) Go to Tools > Options on the main menu bar to open the Options LibreOffice dialog (Figure 262). The list on the left-hand side varies depending on which component of LibreOffice is open.

2) Click the expansion marker ▼ by LibreOffice on the left-hand side and select User Data to open the user data options page for LibreOffice. Enter or amend details that you would like to use for document properties.

3) Click OK to save the changes and close the Options LibreOffice dialog.

Figure 262: Options LibreOffice dialog - User Data page
Print options

Print options can be selected and changed using the **Print** page of the Options LibreOffice dialog (Figure 263) or during the printing process. See Chapter 10, Saving Slide Shows, Printing, E-mailing, and Exporting for more information about the printing of slide shows.

1) Go to **Tools > Options** on the main menu bar to open the Options LibreOffice dialog.

2) Click the expansion marker ▼ by LibreOffice on the left-hand side to open a list of subsections and select **Print** to open the printing options page for LibreOffice (Figure 263).

3) Select the print settings that suit your printer and your most common printing method.

4) Click **OK** to save the changes and close the Options LibreOffice dialog.

The amount of data sent to the printer can be reduced. This increases the print speed because the print files are smaller. It also makes it easier for printers with a smaller memory to print. However, reducing print data can result in slightly lower print quality.

- **Settings for** – specifies whether the print settings apply to the printer or to a file.
  - **Printer** – define options for reducing data while printing directly to a printer.
  - **Print to file** – define options for reducing data while printing to a file.

- **Defaults**
  - **Convert colors to grayscale** – specifies that all colors are printed only as grayscale.
  - **Include transparent objects** – when selected, any reduction in print quality also applies to the transparent areas of objects.

- **Reduce bitmaps** – specifies that bitmaps are printed with reduced quality. The resolution can only be reduced and not increased.
  - **Resolution** – specifies the maximum print quality in dpi.
  - **Normal print quality** – corresponds to a resolution of 200dpi.
  - **High print quality** – corresponds to a resolution of 300dpi.

- **Reduce transparency** – if selected, any transparent objects will be printed as normal, depending on the selection for the two options.
– **Automatically** – specifies that any transparencies are only printed if the transparent areas covers less than a quarter of the entire page.
– **No transparency** – when selected, transparencies are not printed.

**Note**

Transparency cannot be sent directly to a printer. The document areas where transparencies are to be visible must therefore always be calculated as bitmaps and sent to the printer. Depending on the size of the bitmaps and the print resolution, a large amount of data may result.

- **Warnings** – defines which warnings appear before any printing starts.
  - **Paper size** – select this option if a certain paper size is required for printing a document. If the paper size required is not available in the current printer, a warning is displayed.
  - **Paper orientation** – select this option if a specific page orientation is required for a document. If the format is not available, a warning is displayed.
  - **Transparency** – select this option if a warning is required when transparencies are contained in the document. A dialog appears allowing selection if the transparency is to be printed.

- **Reduce gradient** – if selected, gradients are printed with reduced quality.
  - **Gradient stripes** – specifies the maximum number of gradient stripes for printing.
  - **Intermediate color** – specifies that gradients are only printed in a single intermediate color.

**View options**

View options (Figure 264) control how the user interface for LibreOffice appears when creating slide shows. For more information on customizing the user interface, see the Getting Started Guide.

- **Icon style** – specifies the icon style for icons in toolbars and dialogs.
- **Icon size** – sets the icon size to **Automatic**, **Small**, **Large** or **Extra Large**.
  - **Toolbar** – specifies the display size of toolbar icons.
  - **Notebook bar** – specifies the display size of notebook bar icons.
  - **Sidebar** – specifies the display size of sidebar icons.
- **Visibility** – select from **Automatic**, **Hide** or **Show**. **Automatic** displays icons according to system settings and themes.
  - **Shortcuts** – displays keyboard shortcuts next to the corresponding menu items.
- **Mouse** – defines how the mouse cursor is positioned and the action of the middle button, if used.
  - **Positioning** – specifies if and how the mouse cursor is positioned in newly opened dialogs.
  - **Middle button** – defines the function of the middle mouse button. **Automatic** scrolling dragging while pressing the middle mouse button shifts the view. **Paste clipboard** pressing the middle mouse button inserts the contents of the clipboard.
• **Graphics Output** – defines how graphics are displayed.
  - *Use hardware acceleration* – directly accesses hardware features of the graphical display adapter to improve the screen display. The support for hardware acceleration is not available for all operating systems and platform distributions of LibreOffice.
  - *Use anti-aliasing* – when supported, you can enable and disable anti-aliasing of graphics. With anti-aliasing enabled, the display of most graphical objects looks smoother and with less artifacts.

• **Font Lists** – defines how the fonts are displayed.
  - Show preview of fonts – displays how a selected font will appear on the user interface.
  - *Screen font aliasing* – when selected, the display of fonts looks smoother and with less artifacts.

**Application Color options**

Application colors specify which color is used to display various elements of the user interface in LibreOffice. The only option specific to Impress is the color of the grid points. Scroll down in the page until you find **Drawing/Presentation**.

1) Go to **Tools > Options** on the main menu bar to open the Options LibreOffice dialog.

2) Click the expansion marker ▼ by LibreOffice on the left-hand side to open a list of subsections and select **Application Colors** to open the color options page for the colors used in LibreOffice (Figure 265).

3) Scroll down the **Custom Colors** list until you reach the option for **Drawing/Presentation**.

4) Select from the list of color palettes a color to use for the **Grid**.

5) Click **OK** to save the changes and close the Options LibreOffice dialog.

**Note**

If you wish to save your color changes as a color scheme, click **Save** and type a name in the Save scheme dialog, then click **OK**.
Impress options

In the Options LibreOffice dialog, click the expansion marker ▼ to the left of LibreOffice Impress on the left-hand side to open a list of subsections available for Impress (Figure 266).

General options

Select LibreOffice Impress > General (Figure 266) to specify the general options for slide shows.

- **New document**
  - *Start with Template Selection* – if selected, the Select a Template dialog opens when creating a new presentation.

- **Text objects**
  - *Allow quick editing* – if selected, you can edit text immediately after clicking a text object. If deselected, you must double-click to edit text. You can also activate this mode by clicking on Allow Quick Editing in the Options toolbar (Figure 267).
Only text area selectable – specifies whether to select a text frame by clicking the text. In the area of the text frame that is not filled with text, an object behind the text frame can be selected. You can also activate this mode by clicking on Select Text Area Only in the Options toolbar.

- Settings
  - Copy when moving – if selected, a copy is created when you move an object while holding down the Ctrl key. The same applies for rotating and resizing an object. The original object will remain in its current position and size.
  - Use background cache – specifies whether to use the cache for displaying objects on the master slide. This speeds up the display. Deselect this option if you want to display changing contents on the master slide.
  - Objects always moveable – when selected, it allows you to move an object with Rotate enabled. If this option is not selected, Rotate can only be used to rotate an object.
  - Unit of measurement – determines the unit of measurement used in Impress.
  - Tab stops – defines the spacing between tab stops.

- Presentation
  - Enable Presenter Console – when selected, opens the Presenter Console for presentations when using multiple displays.

- Compatibility – these settings are valid for the current presentation only.
  - Use printer metrics for document formatting – specifies that printer metrics are applied for printing and also for formatting the display on the screen. If this option is not selected, a printer independent layout will be used for screen display and printing. If you set this option for the current document and then save the document, for example, in an older binary format, this option will not be saved. If you later open the file from the older format, this option will be set by default.
  - Add spacing between paragraphs and tables – specifies that Impress calculates the paragraph spacing. Similar to Microsoft PowerPoint which adds the bottom spacing of a paragraph to the top spacing of the next paragraph to calculate the total spacing between both paragraphs. Impress utilizes only the larger of the two spacings.

View options

Select LibreOffice Impress > View (Figure 268) to specify the Display options for the available display modes.

- Rulers visible – specifies whether to display the rulers at the top and to the left of the work area.
- Helplines when moving – specifies whether to display guides when moving an object. Impress creates dotted guides that extend beyond the box containing the selected object and which cover the entire Workspace, helping you position the object. You can also activate this mode by clicking on Helplines While Moving in the Options toolbar.
All control points in Bézier editor – displays the control points of all Bézier points if you have previously selected a Bézier curve. If this option is not selected, only the control points of the selected Bézier points will be visible.

Contour of each individual object – Impress displays the contour line of each individual object when moving this object. This option enables you to see if single objects conflict with other objects in the target position. If you do not select this option, Impress displays only a square contour that includes all selected objects.

Grid options

Select LibreOffice Impress > Grid (Figure 269) to specify the grid settings for Impress. Using a grid helps you determine the exact position of your objects. You can also set this grid to line up with the snap grid.

Grid

- Snap to grid – activates the snap function. If this option is selected and you want to move or create individual objects without snapping to the grid, press the Shift key to deactivate Snap to grid whilst moving the individual object. You can also activate this mode by clicking on Snap to Grid on the Options toolbar.
- Visible grid – displays grid points on the screen. These points will not display or print as part of a presentation.

Resolution

- Horizontal – defines the measurement unit for the spacing between grid points on the X-axis.
- Vertical – defines the measurement unit for the spacing between grid points the Y-axis.
- Synchronize axes – when selected, the measurement and spacing settings for X and Y axes are synchronized for Resolution and Subdivision.

Subdivision

- Horizontal – specify the number of intermediate spaces between grid points on the X-axis.
- Vertical – specify the number of intermediate spaces between grid points on the Y-axis.
• **Snap**
  
  – *To snap lines* – snaps the edge of an object being dragged to the nearest snap line when you release the mouse. You can also activate this mode by clicking on *Snap to Snap Lines* on the Options toolbar.
  
  – *To the page margins* – specifies whether to align the contour of the graphic object to the nearest page margin. The cursor or a contour line of the graphics object must be in the snap range. You can also activate this mode by clicking on *Snap to Page Margins* on the Options toolbar.
  
  – *To object frame* – specifies whether to align the contour of the graphic object to the border of the nearest graphic object. The cursor or a contour line of the graphics object must be in the snap range. You can also activate this mode by clicking on *Snap to Object Border* on the Options toolbar.
  
  – *To object points* – specifies whether to align the contour of the graphic object to the points of the nearest graphic object. This only applies if the cursor or a contour line of the graphics object is in the snap range. You can also activate this mode by clicking on *Snap to Object Points* on the Options toolbar.
  
  – *Snap range* – defines the snap distance between the mouse pointer and the object contour. If the cursor is nearer than the distance specified, the cursor snaps to a snap point.

• **Constrain Objects**
  
  – *When creating or moving objects* – specifies that graphic objects are restricted vertically, horizontally or diagonally (45°) when creating or moving them. You can temporarily deactivate this setting by pressing the *Shift* key.
  
  – *Extend edges* – specifies that a square is created based on the longer side of a rectangle when the *Shift* key is pressed before you release the mouse button. This also applies to an ellipse where a circle will be created based on the longest diameter of the ellipse. When this option is *NOT* selected, a square or a circle will be created based on the shorter side or diameter.
  
  – *When rotating* – specifies that graphic objects can only be rotated within the rotation angle that you selected. If you want to rotate an object outside the defined angle, press the *Shift* key when rotating. Release the key when the desired rotation angle is reached.
  
  – *Point reduction* – defines the angle for point reduction. When working with polygons, you might find it useful to reduce their editing points.
Print options

Select **LibreOffice Impress > Print** (Figure 270) to specify print settings for a presentation. See Chapter 10 Saving Slide Shows, Printing, E-mailing, and Exporting for more information about printing and the options available.

- **Page Options**
  - *Default* – pages are printed at the default setting for printing.
  - *Fit to page* – a slide is resized to fit the printed page, while maintaining the relative positions of the objects on the slide.
  - *Tile pages* – specifies that pages are printed in tiled format. If the pages or slides are smaller than the paper, several pages or slides will be printed on one page of paper.
  - *Brochure* – elect this option to print the document in brochure format. Select *Front* to print from the front to the back of a brochure. Select *Back* to print from the back to the front of a brochure.
  - *Paper tray from printer settings* – when selected, the paper tray used is defined in the printer setup.

- **Print**
  - *Page name* – when selected, the page name is printed.
  - *Date* – when selected, the current date is printed.
  - *Time* – when selected, the current time is printed.
  - *Hidden pages* – when selected, any hidden pages in the slide show are printed.

- **Quality**
  - *Default* – when selected, the slides are printed in color.
  - *Grayscale* – when selected, the slides are printed as grayscale.
  - *Black & white* – when selected, the slides are printed in black and white.

Customizing user interface

Impress menus, toolbars, and keyboard shortcuts can be customized by adding, deleting, or modifying items in the menus, toolbars, and keyboard shortcuts that are used when you create slides and slide shows. For more information on customizing the user interface, see the *Getting Started Guide*. 

Figure 270: Options LibreOffice Impress dialog - Print page
Adding extensions

An extension is a package that can be installed into LibreOffice Impress to add a new function. Although individual extensions can be found in different places, the official LibreOffice extension repository is at http://extensions.libreoffice.org/. Some extensions are free of charge; others are available for a fee. Check the descriptions to see what licenses and fees apply to the ones that interest you. For more information on extensions, see the Getting Started Guide.
Impress Guide

Appendix A
Keyboard Shortcuts
Introduction

You can use LibreOffice without requiring a pointing device, such as a mouse or trackball, by using the keyboard shortcuts that are available in Impress. Tasks as varied and complex as docking and un-docking toolbars and windows, or changing the size or position of objects can all be accomplished with using keyboard shortcuts. Although LibreOffice has an extensive set of keyboard shortcuts, each LibreOffice module has keyboard shortcuts that are specific to that module.

For help with LibreOffice keyboard shortcuts, or using LibreOffice with a keyboard only, search the LibreOffice Help using the “shortcut” or “accessibility” keywords.

In addition to using keyboard shortcuts, that are listed in this appendix, you can also define your own keyboard shortcuts. You can assign keyboard shortcuts to standard Impress functions or your own macros and save them for use with Impress only, or with the other modules in LibreOffice. To customize keyboard shortcuts to your requirements, see the Getting Started Guide for more information.

Impress keyboard shortcuts

Note

Some keyboard shortcuts are not available for computers using macOS. This is indicated in the following tables by a blank cell.

Impress functions

<table>
<thead>
<tr>
<th>Windows</th>
<th>macOS</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Linux</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<p>| F2   | F2   | Switches to text edit mode and opens the Text Formatting toolbar. |
| F3   | F3   | Enter and edit a group of objects. |
| Ctrl + F3 | ⌘ + F3 | Exit a group of objects. |
| Shift + F3 | ⌘ + F3 | Opens the Duplicate dialog of a selected object. |
| F4   | F4   | Opens the Position and Size dialog of a selected object. |
| Shift + F5 | ⌘ + F5 | Opens Notes view and displays the first slide in the slide show. |
| Ctrl + Shift + F5 | ⌘ + Shift + F5 | Opens the Navigator. |
| F6   | F6   | Forward navigation of the emphasis within the on screen elements without using mouse. |
| Shift + F6 | ⌘ + F6 | Backward navigation of the emphasis within the on screen elements without using mouse. |
| F7   | F7   | Start spelling checker. |
| Shift + F7 | ⌘ + F7 | Switches on or off the automatic spell checking. |
| Ctrl + F7 | ⌘ + F7 | Opens the Thesaurus dialog for the language being used. Impress has to be in text editing mode to access the thesaurus. |</p>
<table>
<thead>
<tr>
<th>Windows/Linux</th>
<th>macOS</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>F8</strong></td>
<td><strong>F8</strong></td>
<td>When selected, opens the Edit Points toolbar.</td>
</tr>
<tr>
<td><strong>Ctrl + Shift + F8</strong></td>
<td><strong>⌘ + Shift + F8</strong></td>
<td>Fit text to frame of a selected object.</td>
</tr>
<tr>
<td><strong>Shift + F10</strong></td>
<td><strong>Shift + F10</strong></td>
<td>Opens the context menu of a selected object.</td>
</tr>
<tr>
<td><strong>F11</strong></td>
<td><strong>⌘ + T</strong></td>
<td>Open the Styles deck on the Sidebar.</td>
</tr>
<tr>
<td><strong>Ctrl + Shift + M</strong></td>
<td><strong>⌘ + Shift + M</strong></td>
<td>Switches on or off the Impress edit mode. When switched off, a slide show is displayed in read only mode.</td>
</tr>
</tbody>
</table>

**Slide shows**

<table>
<thead>
<tr>
<th>Windows/Linux</th>
<th>macOS</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>F5</strong></td>
<td></td>
<td>Starts a slide show.</td>
</tr>
<tr>
<td><strong>Shift + F5</strong></td>
<td></td>
<td>Starts a slide show at the slide where the slide show was previously stopped at.</td>
</tr>
<tr>
<td><strong>Esc Minus</strong></td>
<td><strong>(-)</strong></td>
<td>Stop and close the slide show.</td>
</tr>
<tr>
<td><strong>Spacebar</strong></td>
<td></td>
<td>If available, plays the next animation effect on a slide.</td>
</tr>
<tr>
<td><strong>Enter</strong></td>
<td></td>
<td>Shows the next slide</td>
</tr>
<tr>
<td><strong>N</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Down arrow</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Right arrow</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Page Down</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Backspace</strong></td>
<td><strong>P</strong></td>
<td>If available, plays the previous animation effect on a slide.</td>
</tr>
<tr>
<td><strong>Up arrow</strong></td>
<td></td>
<td>Shows the previous slide</td>
</tr>
<tr>
<td><strong>Left arrow</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Page Up</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Alt + Page Down</strong></td>
<td></td>
<td>Go to next slide without playing any animation effects.</td>
</tr>
<tr>
<td><strong>Alt + Page Up</strong></td>
<td></td>
<td>Go to the previous slide without playing any animation effects.</td>
</tr>
<tr>
<td><strong>[Number]</strong></td>
<td><strong>then</strong></td>
<td>Type the number of a slide and press <strong>Enter</strong> to show the slide.</td>
</tr>
<tr>
<td><strong>Enter</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Home</strong></td>
<td></td>
<td>Jump to first slide in the slide show.</td>
</tr>
<tr>
<td><strong>End</strong></td>
<td></td>
<td>Jump to the last slide in the slide show.</td>
</tr>
<tr>
<td><strong>B . (period)</strong></td>
<td></td>
<td>Show black screen until next key or mouse wheel event.</td>
</tr>
<tr>
<td><strong>W , (comma)</strong></td>
<td></td>
<td>Show white screen until next key or mouse wheel event.</td>
</tr>
</tbody>
</table>
### Impress shortcuts

<table>
<thead>
<tr>
<th>Windows/Linux</th>
<th>macOS</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Plus (+)</strong></td>
<td></td>
<td>Zoom in.</td>
</tr>
<tr>
<td><strong>Minus (-)</strong></td>
<td></td>
<td>Zoom out.</td>
</tr>
<tr>
<td><em>Times (×) on number pad</em></td>
<td></td>
<td>Fits the slide to fill the Workspace view.</td>
</tr>
<tr>
<td><em>Divide (÷) on number pad</em></td>
<td></td>
<td>Zooms in on the selected object.</td>
</tr>
<tr>
<td><strong>Ctrl + Shift + G</strong></td>
<td><strong>⌘ + Shift + G</strong></td>
<td>Group selected objects.</td>
</tr>
<tr>
<td><strong>Shift + Ctrl + Alt + G</strong></td>
<td><strong>⌘ + Shift + Option + G</strong></td>
<td>Unigroup selected group.</td>
</tr>
<tr>
<td><strong>Ctrl + click</strong></td>
<td><strong>⌘ + click</strong></td>
<td>Enter a group to edit individual objects in the group. Click outside the group to return to normal view.</td>
</tr>
<tr>
<td><strong>Ctrl + Shift + G</strong></td>
<td><strong>⌘ + Shift + G</strong></td>
<td>Combine selected objects.</td>
</tr>
<tr>
<td><strong>Ctrl + Shift + Alt + K</strong></td>
<td><strong>⌘ + Shift + Option + K</strong></td>
<td>Split a selected object that has been combined from a group of two or more objects.</td>
</tr>
<tr>
<td><strong>Ctrl + +</strong></td>
<td><strong>⌘ + +</strong></td>
<td>Bring to front.</td>
</tr>
<tr>
<td><strong>Ctrl + Shift + +</strong></td>
<td><strong>⌘ + Shift + +</strong></td>
<td>Bring forward.</td>
</tr>
<tr>
<td><strong>Ctrl + -</strong></td>
<td><strong>⌘ + -</strong></td>
<td>Send backward.</td>
</tr>
<tr>
<td><strong>Ctrl + Shift + -</strong></td>
<td><strong>⌘ + Shift + -</strong></td>
<td>Send to back.</td>
</tr>
<tr>
<td><strong>Arrow</strong></td>
<td><strong>Arrow</strong></td>
<td>Moves a selected object in the direction of the arrow. Also moves a slide within the Workspace when no objects are selected.</td>
</tr>
<tr>
<td><strong>Shift + Click and drag</strong></td>
<td><strong>Shift + Click and drag</strong></td>
<td>Hold down Shift then click and drag when resizing an object to maintain the proportions of the object.</td>
</tr>
<tr>
<td><strong>Shift + Click and drag</strong></td>
<td><strong>Shift + Click and drag</strong></td>
<td>Constrains movement of a selected object horizontally or vertically when dragged.</td>
</tr>
<tr>
<td><strong>Ctrl + Click and drag</strong></td>
<td><strong>⌘ + Click and drag</strong></td>
<td>Hold down the Ctrl (⌘) key, then click and drag a selected object to create a copy of the object.</td>
</tr>
<tr>
<td><strong>Alt + Click and drag</strong></td>
<td><strong>Option + Click and drag</strong></td>
<td>Hold down the Alt (Option) key and draw or resize an object from the centre of the object.</td>
</tr>
<tr>
<td><strong>Alt + Click</strong></td>
<td><strong>Option + Click</strong></td>
<td>Select an object that is behind the currently selected object.</td>
</tr>
<tr>
<td><strong>Alt + Shift + Click</strong></td>
<td><strong>Option + Shift + Click</strong></td>
<td>Select an object that is in front of the currently selected object.</td>
</tr>
<tr>
<td><strong>Shift + Click</strong></td>
<td><strong>Shift + Click</strong></td>
<td>Selects several adjacent objects or characters. Click at the start of a selection, move to the end of the selection, and then hold down Shift while you click.</td>
</tr>
<tr>
<td><strong>Tab</strong></td>
<td><strong>Tab</strong></td>
<td>Select objects in the order in which they were created.</td>
</tr>
<tr>
<td><strong>Shift + Tab</strong></td>
<td><strong>Shift + Tab</strong></td>
<td>Select objects in the reverse order in which they were created.</td>
</tr>
<tr>
<td>Windows Linux</td>
<td>macOS</td>
<td>Effect</td>
</tr>
<tr>
<td>---------------</td>
<td>--------------</td>
<td>------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Esc</td>
<td>Esc</td>
<td>Exit current mode.</td>
</tr>
<tr>
<td>Page Up</td>
<td></td>
<td>Switch to the previous slide. No function on the first slide.</td>
</tr>
<tr>
<td>Page Down</td>
<td></td>
<td>Switch to the next slide. No function on the last slide.</td>
</tr>
<tr>
<td>Enter</td>
<td>Enter</td>
<td>Activate a placeholder object in a new presentation (only if the frame is selected).</td>
</tr>
</tbody>
</table>
| Ctrl + Enter  | ⌘ + Enter    | AutoLayouts in Impress use placeholders for slide titles, text, and objects.  
To select a placeholder, press Ctrl + Enter (⌘ + Enter).  
To move to the next placeholder, press Ctrl + Enter (⌘ + Enter) again.  
If you press Ctrl + Enter (⌘ + Enter) after you reach the last placeholder in a slide, a new slide is inserted after the current slide using the same layout. |

## Editing text

<table>
<thead>
<tr>
<th>Windows Linux</th>
<th>macOS</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl + -</td>
<td>⌘ + -</td>
<td>Inserts a custom hyphen in text at the cursor position. Also known as a soft hyphen.</td>
</tr>
<tr>
<td>Ctrl + Shift + -</td>
<td>⌘ + Shift + -</td>
<td>Inserts a non-breaking hyphen in text at the cursor position. Also known as a hard hyphen.</td>
</tr>
<tr>
<td>Ctrl + Shift + Space</td>
<td>⌘ + Shift + Space</td>
<td>Non-breaking spaces. Non-breaking spaces are not used for hyphenation and are not expanded if the text is justified.</td>
</tr>
<tr>
<td>Shift + Enter</td>
<td>Shift + Enter</td>
<td>Line break without paragraph change.</td>
</tr>
<tr>
<td>Left arrow</td>
<td>Left arrow</td>
<td>Moves the cursor one character to the left.</td>
</tr>
<tr>
<td>Shift + Left arrow</td>
<td>Shift + Left arrow</td>
<td>Moves the cursor one character to the left and selects the character.</td>
</tr>
<tr>
<td>Ctrl + Left arrow</td>
<td>Option + Left arrow</td>
<td>Moves the cursor to the beginning of the previous word.</td>
</tr>
<tr>
<td>Ctrl + Shift + Left arrow</td>
<td>Option + Shift + Left arrow</td>
<td>Moves the cursor to the left and selects the word on the left.</td>
</tr>
<tr>
<td>Right arrow</td>
<td>Right arrow</td>
<td>Moves the cursor one character to the right.</td>
</tr>
<tr>
<td>Shift + Right arrow</td>
<td>Shift + Right arrow</td>
<td>Moves the cursor one character to the right and selects the character.</td>
</tr>
<tr>
<td>Ctrl + Right arrow</td>
<td>Option + Right arrow</td>
<td>Moves the cursor to the beginning of the next word.</td>
</tr>
<tr>
<td>Ctrl + Shift + Right arrow</td>
<td>Option + Shift + Right arrow</td>
<td>Moves the cursor to the right and selects the word on the right.</td>
</tr>
<tr>
<td>Up arrow</td>
<td>Up arrow</td>
<td>Moves the cursor up one line.</td>
</tr>
<tr>
<td>Shift + Up arrow</td>
<td>Shift + Up arrow</td>
<td>Moves the cursor up one line in the text and selects the lines of text.</td>
</tr>
<tr>
<td>Windows Linux</td>
<td>macOS</td>
<td>Effect</td>
</tr>
<tr>
<td>---------------</td>
<td>-------</td>
<td>--------</td>
</tr>
<tr>
<td>Ctrl + Up arrow</td>
<td>Option + Up arrow</td>
<td>Moves the cursor to the beginning of the paragraph.</td>
</tr>
<tr>
<td>Ctrl + Shift + Up arrow</td>
<td>Option + Shift + Up arrow</td>
<td>Moves the cursor to the beginning of the paragraph. Selects the text in the paragraph from the cursor position to the beginning of the paragraph.</td>
</tr>
<tr>
<td>Down arrow</td>
<td>Down arrow</td>
<td>Moves the cursor down one line.</td>
</tr>
<tr>
<td>Shift + Down arrow</td>
<td>Shift + Down arrow</td>
<td>Moves the cursor down one line in the text and selects the lines of text.</td>
</tr>
<tr>
<td>Ctrl + Down arrow</td>
<td>⌘ + Down arrow</td>
<td>Moves the cursor to the end of the paragraph.</td>
</tr>
<tr>
<td>Ctrl + Shift + Down arrow</td>
<td>Opt + Shift + Down arrow</td>
<td>Moves the cursor to the end of the paragraph. Selects the text in the paragraph from the cursor position to the end of the paragraph.</td>
</tr>
<tr>
<td>Home</td>
<td></td>
<td>Moves the cursor to the beginning of the line.</td>
</tr>
<tr>
<td>Shift + Home</td>
<td></td>
<td>Moves the cursor to the beginning of the line and selects the text from the cursor position.</td>
</tr>
<tr>
<td>Ctrl + Home</td>
<td></td>
<td>Moves the cursor to the beginning of the text block on the slide.</td>
</tr>
<tr>
<td>End</td>
<td></td>
<td>Moves the cursor to the end of the line.</td>
</tr>
<tr>
<td>Shift + End</td>
<td></td>
<td>Moves the cursor to the end of the line and selects the text from the cursor position.</td>
</tr>
<tr>
<td>Ctrl + End</td>
<td></td>
<td>Moves the cursor to the end of the text block on the slide.</td>
</tr>
<tr>
<td>Ctrl + Del</td>
<td></td>
<td>Delete the text from the cursor position to the end of the word.</td>
</tr>
<tr>
<td>Ctrl + Shift + Del</td>
<td></td>
<td>Delete the text from the cursor position to the end of the sentence.</td>
</tr>
<tr>
<td>Ctrl + Backspace</td>
<td>⌃ + Backspace</td>
<td>Delete the text from the cursor position to the beginning of the word.</td>
</tr>
<tr>
<td>Ctrl + Shift + Backspace</td>
<td>⌃ + Shift + Backspace</td>
<td>Delete the text from the cursor position to the beginning of the sentence.</td>
</tr>
</tbody>
</table>

**Menu keyboard shortcuts**

The keyboard shortcuts listed in the following tables are available in each menu category on the Menu bar. The tables give the menu item or sub-item, operating system validity, and the effect or purpose of the shortcut.

**Note**

The menus listed below are in the same order as displayed on the Menu bar from left to right.
## File menu

<table>
<thead>
<tr>
<th>Menu item or sub-item</th>
<th>Windows Linux</th>
<th>macOS</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open</td>
<td>Ctrl + O</td>
<td>⌘ + O</td>
<td>Opens the Open file browser so you can navigate to a folder and select a document.</td>
</tr>
<tr>
<td>Save</td>
<td>Ctrl + S</td>
<td>⌘ + S</td>
<td>Saves the open document.</td>
</tr>
<tr>
<td>Save As</td>
<td>Ctrl + Shift + S</td>
<td>⌘ + Shift + S</td>
<td>Opens the Save as file browser so you can save the open document as a new document.</td>
</tr>
<tr>
<td>Print</td>
<td>Ctrl + P</td>
<td>⌘ + P</td>
<td>Opens the Print dialog so that you can select how you want to print the document.</td>
</tr>
</tbody>
</table>

## Edit Menu

<table>
<thead>
<tr>
<th>Menu item or sub-item</th>
<th>Windows Linux</th>
<th>macOS</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo</td>
<td>Ctrl + Z</td>
<td>⌘ + Z</td>
<td>Undoes the previous editing action.</td>
</tr>
<tr>
<td>Redo</td>
<td>Ctrl + Y</td>
<td>⌘ + Y</td>
<td>Reverses the action of the last Undo command.</td>
</tr>
<tr>
<td>Cut</td>
<td>Ctrl + X</td>
<td>⌘ + X</td>
<td>Deletes the selected object and places it on the clipboard.</td>
</tr>
<tr>
<td>Copy</td>
<td>Ctrl + C</td>
<td>⌘ + C</td>
<td>Copies the selected object to the clipboard.</td>
</tr>
<tr>
<td>Paste</td>
<td>Ctrl + V</td>
<td>⌘ + V</td>
<td>Places the object on the clipboard into the document.</td>
</tr>
<tr>
<td>Paste Special &gt; Paste Unformatted Text</td>
<td>Ctrl + Shift + Alt + V</td>
<td>⌘ + Shift + Option + V</td>
<td>Paste copied text at the cursor position without any formatting.</td>
</tr>
<tr>
<td>Paste Special &gt; Paste Special</td>
<td>Ctrl + Shift + V</td>
<td>⌘ + Shift + V</td>
<td>Pastes the contents of the clipboard at the cursor position in a format that you can specify using the Paste Special dialog.</td>
</tr>
<tr>
<td>Select All</td>
<td>Ctrl + A</td>
<td>⌘ + A</td>
<td>Selects all objects on a slide.</td>
</tr>
<tr>
<td>Points</td>
<td>F8</td>
<td>F8</td>
<td>Opens the Edit Points toolbar if there is an object on the slide that uses editable points, for example a freeform line.</td>
</tr>
<tr>
<td>Edit Mode</td>
<td>Ctrl + Shift + M</td>
<td>⌘ + Shift + M</td>
<td>Switches on or off the Impress edit mode. When switched off, a slide show is displayed in read only mode.</td>
</tr>
</tbody>
</table>
### View menu

<table>
<thead>
<tr>
<th>Menu item or sub-item</th>
<th>Windows/Linux</th>
<th>macOS</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rulers</td>
<td>Ctrl + Shift + R</td>
<td>⌘ + Shift + R</td>
<td>Switches the rulers off and on in the Workspace.</td>
</tr>
<tr>
<td>Sidebar</td>
<td>Ctrl + F5</td>
<td>⌘ + F5</td>
<td>Opens or closes the Sidebar.</td>
</tr>
<tr>
<td>Styles</td>
<td>F11</td>
<td>⌘ + T</td>
<td>Opens or closes the Styles deck on the Sidebar.</td>
</tr>
<tr>
<td>Navigator</td>
<td>Ctrl + Shift + F5</td>
<td>⌘ + Shift + F5</td>
<td>Opens the Navigator.</td>
</tr>
</tbody>
</table>

### Insert menu

<table>
<thead>
<tr>
<th>Menu item or sub-item</th>
<th>Windows/Linux</th>
<th>macOS</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text Box</td>
<td>F2</td>
<td>F2</td>
<td>Switches to text edit mode and opens the Text Formatting toolbar.</td>
</tr>
<tr>
<td>Hyperlink</td>
<td>Ctrl + K</td>
<td>⌘ + K</td>
<td>Opens the Hyperlink dialog.</td>
</tr>
<tr>
<td>Comment</td>
<td>Ctrl + Alt + C</td>
<td>⌘ + Option + C</td>
<td>Inserts a new comment box onto the selected slide.</td>
</tr>
<tr>
<td>Formatting Mark &gt; Insert non-breaking space</td>
<td>Ctrl + Shift + Space</td>
<td>⌘ + Shift + Space</td>
<td>Inserts a non-breaking space at the cursor position.</td>
</tr>
<tr>
<td>Formatting Mark &gt; Insert Narrow No-break Space</td>
<td>Ctrl + Shift + F5</td>
<td>⌘ + Shift + F5</td>
<td>Inserts a narrow no-breaking space at the cursor position.</td>
</tr>
<tr>
<td>Formatting Mark &gt; No-width Optional Break</td>
<td>Ctrl + /</td>
<td>⌘ + /</td>
<td>Inserts a narrow no-width no optional break at the cursor position.</td>
</tr>
</tbody>
</table>

### Format menu

<table>
<thead>
<tr>
<th>Menu item or sub-item</th>
<th>Windows/Linux</th>
<th>macOS</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text &gt; Bold</td>
<td>Ctrl + B</td>
<td>⌘ + B</td>
<td>Applies Bold format to selected text.</td>
</tr>
<tr>
<td>Text &gt; Italic</td>
<td>Ctrl + I</td>
<td>⌘ + I</td>
<td>Applies Italic format to selected text.</td>
</tr>
<tr>
<td>Text &gt; Superscript</td>
<td>Ctrl + Shift + P</td>
<td>⌘ + Option + C</td>
<td>Applies superscript format to selected text.</td>
</tr>
<tr>
<td>Text &gt; Subscript</td>
<td>Ctrl + Shift + B</td>
<td>⌘ + Shift + B</td>
<td>Applies subscript format to selected text.</td>
</tr>
<tr>
<td>Text &gt; Increase Size</td>
<td>Ctrl + ]</td>
<td>⌘ + ]</td>
<td>Increases the point size of selected text.</td>
</tr>
<tr>
<td>Menu item or sub-item</td>
<td>Windows Linux</td>
<td>macOS</td>
<td>Effect</td>
</tr>
<tr>
<td>----------------------</td>
<td>---------------</td>
<td>-------</td>
<td>--------</td>
</tr>
<tr>
<td><strong>Text &gt; Decrease Size</strong></td>
<td>Ctrl + [</td>
<td>⌘ + [</td>
<td>Decreases the point size of selected text.</td>
</tr>
<tr>
<td><strong>Spacing &gt; Line Spacing 1</strong></td>
<td>Ctrl + 1</td>
<td>⌘ + 1</td>
<td>Sets the line spacing in a paragraph to a single line.</td>
</tr>
<tr>
<td><strong>Spacing Line Spacing 5</strong></td>
<td>Ctrl + 5</td>
<td>⌘ + 5</td>
<td>Sets the line spacing in a paragraph to one and half lines.</td>
</tr>
<tr>
<td><strong>Spacing &gt; Line Spacing 2</strong></td>
<td>Ctrl + 2</td>
<td>⌘ + 2</td>
<td>Sets the line spacing in a paragraph to two lines.</td>
</tr>
<tr>
<td><strong>Align &gt; Left</strong></td>
<td>Ctrl + L</td>
<td>⌘ + L</td>
<td>Sets the paragraph alignment to left aligned.</td>
</tr>
<tr>
<td><strong>Align &gt; Center</strong></td>
<td>Ctrl + E</td>
<td>⌘ + E</td>
<td>Sets the paragraph alignment to center aligned.</td>
</tr>
<tr>
<td><strong>Align &gt; Right</strong></td>
<td>Ctrl + R</td>
<td>⌘ + R</td>
<td>Sets the paragraph alignment to right aligned.</td>
</tr>
<tr>
<td><strong>Align &gt; Justified</strong></td>
<td>Ctrl + J</td>
<td>⌘ + J</td>
<td>Sets the paragraph alignment to justified.</td>
</tr>
<tr>
<td><strong>Lists &gt; Demote</strong></td>
<td>Shift + Alt + Right arrow</td>
<td></td>
<td>Demotes a point to the next level when <strong>Outline</strong> view.</td>
</tr>
<tr>
<td><strong>Lists &gt; Promote</strong></td>
<td>Shift + Alt + Left arrow</td>
<td></td>
<td>Promotes a point to the next level when in <strong>Outline</strong> view.</td>
</tr>
<tr>
<td><strong>Lists &gt; Move Down</strong></td>
<td>Shift + Alt + Down arrow</td>
<td>Shift + Option + Down arrow</td>
<td>Moves a point down the order when in <strong>Outline</strong> view.</td>
</tr>
<tr>
<td><strong>Lists &gt; Move Up</strong></td>
<td>Shift + Alt + Up arrow</td>
<td>Shift + Option + Up arrow</td>
<td>Moves a point up the order when in <strong>Outline</strong> view.</td>
</tr>
<tr>
<td><strong>Styles &gt; Manage Styles</strong></td>
<td>F11</td>
<td>⌘ + T</td>
<td>Opens or closes the Styles deck on the Sidebar.</td>
</tr>
<tr>
<td><strong>Object and Shape &gt; Position and Size</strong></td>
<td>F4</td>
<td>F4</td>
<td>Opens the Position and Size dialog of a selected object.</td>
</tr>
<tr>
<td><strong>Arrange &gt; Bring to Front</strong></td>
<td>Ctrl + Shift + +</td>
<td>⌘ + Shift + +</td>
<td>Moves a selected object to the front of other objects.</td>
</tr>
<tr>
<td><strong>Arrange &gt; Bring Forward</strong></td>
<td>Ctrl + +</td>
<td>⌘ + +</td>
<td>Moves a selected object in front of the forward object.</td>
</tr>
<tr>
<td><strong>Arrange &gt; Send Backward</strong></td>
<td>Ctrl + -</td>
<td>⌘ + -</td>
<td>Moves a selected object behind the backward object.</td>
</tr>
<tr>
<td><strong>Arrange &gt; Send to Back</strong></td>
<td>Ctrl + Shift + -</td>
<td>⌘ + Shift + -</td>
<td>Moves a selected object to the back of other objects.</td>
</tr>
<tr>
<td><strong>Group &gt; Group</strong></td>
<td>Ctrl + Shift + G</td>
<td>⌘ + Shift + G</td>
<td>Group selected objects.</td>
</tr>
<tr>
<td><strong>Group &gt; Ungroup</strong></td>
<td>Ctrl + Alt + Shift + G</td>
<td>⌘ + Option + Shift + G</td>
<td>Ungroup selected group.</td>
</tr>
<tr>
<td><strong>Group &gt; Enter Group</strong></td>
<td>F3</td>
<td>F3</td>
<td>Enter and edit a group of objects.</td>
</tr>
</tbody>
</table>
### Slide menu

<table>
<thead>
<tr>
<th>Menu item or sub-item</th>
<th>Windows Linux</th>
<th>macOS</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>New Slide</td>
<td>Ctrl + M</td>
<td>Ctrl + M</td>
<td>Inserts a new slide into the slide show.</td>
</tr>
<tr>
<td>Jump to Last Edited Slide</td>
<td>Alt + Shift + F5</td>
<td>Option + Shift + F5</td>
<td>Opens the last slide edited in the document.</td>
</tr>
<tr>
<td>Move &gt; Slide to Start</td>
<td>Ctrl + Shift + Home</td>
<td></td>
<td>Moves the selected slide to the beginning of the slide show.</td>
</tr>
<tr>
<td>Move &gt; Slide Up</td>
<td>Ctrl + Shift + Up</td>
<td>⌘ + Shift + Up Arrow</td>
<td>Moves the selected slide above the previous slide. No function on the first slide.</td>
</tr>
<tr>
<td>Move &gt; Slide Down</td>
<td>Ctrl + Shift + Down</td>
<td>⌘ + Shift + Down Arrow</td>
<td>Moves the selected slide below the next slide. No function on the last slide.</td>
</tr>
<tr>
<td>Move &gt; Slide to End</td>
<td>Ctrl + Shift + End</td>
<td></td>
<td>Moves the selected slide to the end of the slide show.</td>
</tr>
<tr>
<td>Navigate &gt; To Previous Slide</td>
<td>Page Up</td>
<td></td>
<td>Switch to the previous slide. No function on the first slide.</td>
</tr>
<tr>
<td>Navigate &gt; To Next Slide</td>
<td>Page Down</td>
<td></td>
<td>Switch to the next slide. No function on the last slide.</td>
</tr>
</tbody>
</table>

### Slide Show menu

<table>
<thead>
<tr>
<th>Menu item or sub-item</th>
<th>Windows Linux</th>
<th>macOS</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start from First Slide</td>
<td>F5</td>
<td>F5</td>
<td>Starts a slide show from the first slide.</td>
</tr>
<tr>
<td>Start from Current Slide</td>
<td>Shift + F5</td>
<td>Shift + F5</td>
<td>Starts a slide show at the slide where the slide show was previously stopped at.</td>
</tr>
</tbody>
</table>

### Tools menu

<table>
<thead>
<tr>
<th>Menu item or sub-item</th>
<th>Windows Linux</th>
<th>macOS</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Spelling</td>
<td>F7</td>
<td>F7</td>
<td>Start spelling checker.</td>
</tr>
<tr>
<td>Automatic Spell Checking</td>
<td>Shift + F7</td>
<td>Shift + F7</td>
<td>Switches on or off the automatic spell checking.</td>
</tr>
<tr>
<td>Thesaurus</td>
<td>Ctrl + F7</td>
<td>⌘ + F7</td>
<td>Opens the Thesaurus dialog for the language being used. Impress has to be in text editing mode to access the thesaurus.</td>
</tr>
</tbody>
</table>
### Windows menu

<table>
<thead>
<tr>
<th>Menu item or sub-item</th>
<th>Windows/Linux</th>
<th>macOS</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Extension Manager</td>
<td>Ctrl + Alt + E</td>
<td>⌘ + Alt + E</td>
<td>Opens the Extension Manager dialog.</td>
</tr>
<tr>
<td>Options</td>
<td>Alt + F12</td>
<td></td>
<td>Opens the Options LibreOffice dialog.</td>
</tr>
</tbody>
</table>

### Help menu

<table>
<thead>
<tr>
<th>Menu item or sub-item</th>
<th>Windows/Linux</th>
<th>macOS</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Closes Window</td>
<td>Ctrl + W</td>
<td>⌘ + W</td>
<td>Closes the active window. If there is only one window, LibreOffice Impress closes.</td>
</tr>
<tr>
<td>LibreOffice Help</td>
<td>F1</td>
<td>F1</td>
<td>Opens your browser application at the LibreOffice Help pages.</td>
</tr>
</tbody>
</table>

### Toolbar keyboard shortcuts

Impress provides several toolbars to help you to create slides and slide shows. Some of the tools on these Impress toolbars can be activated by using a keyboard shortcut.

#### Note

The toolbars are listed in the same order that is displayed in the context menu that opens when you click on View > Toolbars on the Menu bar.

### Drawing

<table>
<thead>
<tr>
<th>Tool name</th>
<th>Windows/Linux</th>
<th>macOS</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert Text Box</td>
<td>F2</td>
<td></td>
<td>Switches to text edit mode and opens the Text Formatting toolbar.</td>
</tr>
<tr>
<td>Position and Size</td>
<td>F4</td>
<td></td>
<td>Opens the Position and Size dialog of a selected object.</td>
</tr>
<tr>
<td>Points</td>
<td>F8</td>
<td></td>
<td>Opens the Edit Points toolbar if there is an object on the slide that uses editable points, for example a freeform line.</td>
</tr>
</tbody>
</table>
## Form Design

<table>
<thead>
<tr>
<th>Tool name</th>
<th>Windows/Linux</th>
<th>macOS</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Position and Size</td>
<td>F4</td>
<td>F4</td>
<td>Opens the Position and Size dialog of a selected object.</td>
</tr>
<tr>
<td>Bring to Front</td>
<td>Ctrl + Shift + +</td>
<td>⌘ + Shift + +</td>
<td>Moves a selected object to the front of other objects.</td>
</tr>
<tr>
<td>Send to Back</td>
<td>Ctrl + Shift + -</td>
<td>⌘ + Shift + -</td>
<td>Moves a selected object to the back of other objects.</td>
</tr>
<tr>
<td>Group</td>
<td>Ctrl + Shift + G</td>
<td>⌘ + Shift + G</td>
<td>Group selected objects.</td>
</tr>
<tr>
<td>Ungroup</td>
<td>Ctrl + Alt + Shift + G</td>
<td>⌘ + Option + Shift + G</td>
<td>Ungroup selected group.</td>
</tr>
<tr>
<td>Enter Group</td>
<td>F3</td>
<td>F3</td>
<td>Enter and edit a group of objects.</td>
</tr>
<tr>
<td>Exit Group</td>
<td>Ctrl + F3</td>
<td>⌘ + F3</td>
<td>Exit a group of objects.</td>
</tr>
</tbody>
</table>

## Image

<table>
<thead>
<tr>
<th>Tool name</th>
<th>Windows/Linux</th>
<th>macOS</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bring to Front</td>
<td>Ctrl + Shift + +</td>
<td>⌘ + Shift + +</td>
<td>Moves a selected object to the front of other objects.</td>
</tr>
<tr>
<td>Bring Forward</td>
<td>Ctrl + +</td>
<td>⌘ + +</td>
<td>Moves a selected object in front of the forward object.</td>
</tr>
<tr>
<td>Send Backward</td>
<td>Ctrl + -</td>
<td>⌘ + -</td>
<td>Moves a selected object behind the backward object.</td>
</tr>
<tr>
<td>Send to Back</td>
<td>Ctrl + Shift + -</td>
<td>⌘ + Shift + -</td>
<td>Moves a selected object to the back of other objects.</td>
</tr>
</tbody>
</table>

## Line and Filling

<table>
<thead>
<tr>
<th>Tool name</th>
<th>Windows/Linux</th>
<th>macOS</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Position and Size</td>
<td>F4</td>
<td>F4</td>
<td>Opens the Position and Size dialog of a selected object.</td>
</tr>
<tr>
<td>Bring to Front</td>
<td>Ctrl + Shift + +</td>
<td>⌘ + Shift + +</td>
<td>Moves a selected object to the front of other objects.</td>
</tr>
<tr>
<td>Bring Forward</td>
<td>Ctrl + +</td>
<td>⌘ + +</td>
<td>Moves a selected object in front of the forward object.</td>
</tr>
<tr>
<td>Send Backward</td>
<td>Ctrl + -</td>
<td>⌘ + -</td>
<td>Moves a selected object behind the backward object.</td>
</tr>
<tr>
<td>Send to Back</td>
<td>Ctrl + Shift + -</td>
<td>⌘ + Shift + -</td>
<td>Moves a selected object to the back of other objects.</td>
</tr>
<tr>
<td>Show the Styles Sidebar</td>
<td>F11</td>
<td>⌘ + T</td>
<td>Opens the Styles deck on the Sidebar.</td>
</tr>
</tbody>
</table>
## Outline

<table>
<thead>
<tr>
<th><strong>Tool name</strong></th>
<th><strong>Windows</strong></th>
<th><strong>macOS</strong></th>
<th><strong>Effect</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Demote</td>
<td>Shift + Alt + Right arrow</td>
<td></td>
<td>Demotes a point to the next level when Outline view.</td>
</tr>
<tr>
<td>Promote</td>
<td>Shift + Alt + Left arrow</td>
<td></td>
<td>Promotes a point to the next level when in Outline view.</td>
</tr>
<tr>
<td>Move Down</td>
<td>Shift + Alt + Down arrow</td>
<td>Shift + Option + Down arrow</td>
<td>Moves a point down the order when in Outline view.</td>
</tr>
<tr>
<td>Move Up</td>
<td>Shift + Alt + Up arrow</td>
<td>Shift + Option + Up arrow</td>
<td>Moves a point up the order when in Outline view.</td>
</tr>
</tbody>
</table>

## Slide Sorter

<table>
<thead>
<tr>
<th><strong>Tool name</strong></th>
<th><strong>Windows</strong></th>
<th><strong>macOS</strong></th>
<th><strong>Effect</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Start from First Slide</td>
<td>F5</td>
<td>F5</td>
<td>Starts a slide show from the first slide</td>
</tr>
</tbody>
</table>

## Standard

<table>
<thead>
<tr>
<th><strong>Tool name</strong></th>
<th><strong>Windows</strong></th>
<th><strong>macOS</strong></th>
<th><strong>Effect</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>New</td>
<td>Ctrl + N</td>
<td>⌘ + N</td>
<td>Opens a new presentation document.</td>
</tr>
<tr>
<td>Templates</td>
<td>Ctrl + Shift + N</td>
<td>⌘ + Shift + N</td>
<td>Opens the Templates dialog to create a new document using a template.</td>
</tr>
<tr>
<td>Open</td>
<td>Ctrl + O</td>
<td>⌘ + O</td>
<td>Opens the Open file browser so you can navigate to a folder and select a document.</td>
</tr>
<tr>
<td>Save</td>
<td>Ctrl + S</td>
<td>⌘ + S</td>
<td>Saves the open document.</td>
</tr>
<tr>
<td>Save As</td>
<td>Ctrl + Shift + S</td>
<td>⌘ + Shift + S</td>
<td>Opens the Save as file browser so you can save the open document as a new document.</td>
</tr>
<tr>
<td>Edit Mode</td>
<td>Ctrl + Shift + M</td>
<td>⌘ + Shift + M</td>
<td>Switches on edit mode when a document is in read only mode.</td>
</tr>
<tr>
<td>Print</td>
<td>Ctrl + P</td>
<td>⌘ + P</td>
<td>Opens the Print dialog so that you can select how you want to print the document.</td>
</tr>
<tr>
<td>Cut</td>
<td>Ctrl + X</td>
<td>⌘ + X</td>
<td>Deletes the selected object and places it on the clipboard.</td>
</tr>
<tr>
<td>Copy</td>
<td>Ctrl + C</td>
<td>⌘ + C</td>
<td>Copies the selected object to the clipboard.</td>
</tr>
<tr>
<td>Paste</td>
<td>Ctrl + V</td>
<td>⌘ + V</td>
<td>Places the object on the clipboard into the document.</td>
</tr>
<tr>
<td>Tool name</td>
<td>Windows Linux</td>
<td>macOS</td>
<td>Effect</td>
</tr>
<tr>
<td>--------------------</td>
<td>---------------</td>
<td>----------</td>
<td>------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Clear Direct</td>
<td>Ctrl + Shift</td>
<td>Ctrl + Shift + M</td>
<td>Removes direct formatting that has been applied without using styles.</td>
</tr>
<tr>
<td>Formatting</td>
<td>M</td>
<td>M</td>
<td></td>
</tr>
<tr>
<td>Undo</td>
<td>Ctrl + Z</td>
<td>Ctrl + Z</td>
<td>Undoes the previous editing action.</td>
</tr>
<tr>
<td>Redo</td>
<td>Ctrl + Y</td>
<td>Ctrl + Y</td>
<td>Reverses the action of the last Undo command.</td>
</tr>
<tr>
<td>Find and Replace</td>
<td>Ctrl + H</td>
<td>Ctrl + Option + F</td>
<td>Opens the Find and Replace dialog.</td>
</tr>
<tr>
<td>Spelling</td>
<td>F7</td>
<td>F7</td>
<td>Starts the spelling checker.</td>
</tr>
<tr>
<td>Toggle Automatic</td>
<td>Shift + F7</td>
<td>Shift + F7</td>
<td>Switches on or off the automatic spell checking.</td>
</tr>
<tr>
<td>Spell</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Start from First</td>
<td>F5</td>
<td>F5</td>
<td>Starts a slide show.</td>
</tr>
<tr>
<td>Slide</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Start from Current</td>
<td>Shift + F5</td>
<td>Shift + F5</td>
<td>Starts a slide show at the slide where the slide show was previously stopped at.</td>
</tr>
<tr>
<td>Insert Text Box</td>
<td>F2</td>
<td>F2</td>
<td>Switches to text edit mode and opens the Text Formatting toolbar.</td>
</tr>
<tr>
<td>Insert Hyperlink</td>
<td>Ctrl + K</td>
<td>Ctrl + K</td>
<td>Opens the Hyperlink dialog.</td>
</tr>
</tbody>
</table>

**Standard (Single Mode)**

<table>
<thead>
<tr>
<th>Tool name</th>
<th>Windows Linux</th>
<th>macOS</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>New</td>
<td>Ctrl + N</td>
<td>Ctrl + N</td>
<td>Opens a new presentation document.</td>
</tr>
<tr>
<td>Open</td>
<td>Ctrl + O</td>
<td>Ctrl + O</td>
<td>Opens the Open file browser so you can navigate to a folder and select a document.</td>
</tr>
<tr>
<td>Save</td>
<td>Ctrl + S</td>
<td>Ctrl + S</td>
<td>Saves the open document.</td>
</tr>
<tr>
<td>Print</td>
<td>Ctrl + P</td>
<td>Ctrl + P</td>
<td>Opens the Print dialog so that you can select how you want to print the document.</td>
</tr>
<tr>
<td>Undo</td>
<td>Ctrl + Z</td>
<td>Ctrl + Z</td>
<td>Undoes the previous editing action.</td>
</tr>
<tr>
<td>Redo</td>
<td>Ctrl + Y</td>
<td>Ctrl + Y</td>
<td>Reverses the action of the last Undo command.</td>
</tr>
<tr>
<td>Insert Text Box</td>
<td>F2</td>
<td>F2</td>
<td>Switches to text edit mode and opens the Text Formatting toolbar.</td>
</tr>
<tr>
<td>Position and</td>
<td>F4</td>
<td>F4</td>
<td>Opens the Position and Size dialog of a selected object.</td>
</tr>
<tr>
<td>Size</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Group</td>
<td>Ctrl + Shift + G</td>
<td>Ctrl + Shift + G</td>
<td>Group selected objects.</td>
</tr>
<tr>
<td>Ungroup</td>
<td>Ctrl + Alt + Shift + G</td>
<td>Ctrl + Option + Shift + G</td>
<td>Ungroup selected group.</td>
</tr>
<tr>
<td>Enter Group</td>
<td>F3</td>
<td>F3</td>
<td>Enter and edit a group of objects.</td>
</tr>
</tbody>
</table>

*Toolbar keyboard shortcuts | 313*
<table>
<thead>
<tr>
<th>Tool name</th>
<th>Windows/Linux</th>
<th>macOS</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Exit Group</td>
<td>Ctrl + F3</td>
<td>⌘ + F3</td>
<td>Exit a group of objects.</td>
</tr>
<tr>
<td>Start from First Slide</td>
<td>F5</td>
<td>F5</td>
<td>Starts a slide show from the first slide.</td>
</tr>
<tr>
<td>Start from Current Slide</td>
<td>Shift + F5</td>
<td>Shift + F5</td>
<td>Starts a slide show at the slide where the slide show was previously stopped at.</td>
</tr>
</tbody>
</table>

**Standard (Viewing Mode)**

<table>
<thead>
<tr>
<th>Tool name</th>
<th>Windows/Linux</th>
<th>macOS</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Save As</td>
<td>Ctrl + Shift + S</td>
<td>⌘ + Shift + S</td>
<td>Opens the Save as file browser so you can save the open document as a new document.</td>
</tr>
<tr>
<td>Edit Mode</td>
<td>Ctrl + Shift + M</td>
<td>⌘ + Shift + M</td>
<td>Switches on edit mode when a document is in read only mode.</td>
</tr>
<tr>
<td>Print</td>
<td>Ctrl + P</td>
<td>⌘ + P</td>
<td>Opens the Print dialog so that you can select how you want to print the document.</td>
</tr>
<tr>
<td>Copy</td>
<td>Ctrl + C</td>
<td>⌘ + C</td>
<td>Copies the selected object to the clipboard.</td>
</tr>
<tr>
<td>Find and Replace</td>
<td>Ctrl + H</td>
<td>⌘ + Option + F</td>
<td>Opens the Find and Replace dialog.</td>
</tr>
<tr>
<td>Start from First Slide</td>
<td>F5</td>
<td>F5</td>
<td>Starts a slide show from the first slide.</td>
</tr>
</tbody>
</table>

**Text**

<table>
<thead>
<tr>
<th>Tool name</th>
<th>Windows/Linux</th>
<th>macOS</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert Text Box</td>
<td>F2</td>
<td>F2</td>
<td>Switches to text edit mode and opens the Text Formatting toolbar.</td>
</tr>
</tbody>
</table>
Impress Guide

Appendix B
Toolbars
Introduction

In Impress there are several toolbars available to help you create an Impress presentation. Each toolbar has a default set of tools and the option to add additional tools to a toolbar.

⚠️ Note

The icons displayed in the Impress toolbars may differ from what you see on your screen. Toolbar icons depend on the computer system being used and how a LibreOffice has been setup.

Using toolbars

Displaying toolbars

To display and make a toolbar active go to View > Toolbars on the Menu bar. A context menu opens with a list of available toolbars for creating presentations in LibreOffice Impress. Click on a toolbar name to make it active. Active toolbars are indicated by a check mark next to the name as shown in Figure 271.

![Impress toolbars](image)

*Figure 271: Impress toolbars*

⚠️ Note

Some toolbars, although selected in View > Toolbars on the Menu bar, will not display until an object of the correct type is selected in the presentation. For example, the Image toolbar only displays when an image is selected.

Closing toolbars

To close a toolbar, use one of the following methods:

- Go to View > Toolbars on the Menu bar and deselect the toolbar.
• Right-click on an icon on a toolbar and select **Close Toolbar** from the context menu.
• Click on the X in the right corner of the title bar of a floating toolbar.

**Moving toolbars**

**Locked toolbars**

When a toolbar has been docked, it can also be locked into its position on the Impress main window. A floating toolbar cannot be locked into position.

• To lock a toolbar into its docked position, right click in a blank area on the toolbar and click on **Lock Toolbar Position** in the context menu. A check mark appears against this option indicating the toolbar is now locked.

• To unlock a toolbar, right click in a blank area on the toolbar and click on **Lock Toolbar Position** in the context menu. The check mark next to this option disappears indicating the toolbar is now unlocked. Also, a small vertical bar appears at the left end of the toolbar and is used to move the toolbar.

**Docked toolbars**

By default, some toolbars are docked into position in the Impress main window. For example, the Standard toolbar is docked at the top of the main window. Docked toolbars can be undocked and moved to a new docked position on the main window or left as a floating toolbar. Before moving a toolbar, the toolbar must be unlocked.

6) Move the mouse cursor over the small vertical handle at the left end of the toolbar. The mouse cursor changes to a moving cursor for your computer system and setup.

7) Click and hold down the left mouse button and drag the toolbar to a new location. This can be a new docked position or a floating toolbar. A hashed border appears around the toolbar indicating the toolbar position as you drag it.

8) Release the mouse button.

**Floating toolbars**

To move a floating toolbar, click on its title bar and drag it to a new floating location. Release the mouse button when the toolbar is in the desired position. A floating toolbar does not have to be positioned on the Impress main window for it to function.

**Docking toolbars**

To dock a toolbar, use one of the following methods:

• Click on the title bar and drag it to the top, bottom, left side, or right side of the main window. When the toolbar reaches a docking position, a hashed border appears at the docked position. Release the mouse button and the toolbar is docked.

• Right click ion the toolbar and select **Dock Toolbar** from the context menu. The toolbar moves into a docked position. If the position is not suitable, move the toolbar to a new docked position.

• To dock all floating toolbars that are active, right click on the toolbar and select **Dock All Toolbars** from the context menu.
Editing toolbars

When LibreOffice is installed on your computer, a set of toolbars suitable for each LibreOffice module are also installed. Each toolbar has a default set of tools to get you started in creating LibreOffice documents.

Adding tools

Install additional tools using Visible Buttons as follows:

1) Right-click on a toolbar and select Visible Buttons from the context menu to display a list of available tools.

2) Click on the tool you want to install and the tool will appear in the toolbar. The list of available tools closes automatically. A highlight or check mark next to the tool indicates that the tool is already installed on the toolbar.

Note

When adding tools using Visible Buttons, the tool is added to the toolbar at the same position as the tool appears in the Visible Buttons list. That is, the top tool in Visible Buttons appears at the left end of the toolbar; the bottom tool in Visible Buttons list appears at the right end of the toolbar. Tool positions cannot be changed using Visible Buttons.

Deleting tools

Remove tools using Visible Buttons from a toolbar as follows:

1) Right-click on a toolbar and select Visible Buttons from the context menu to display a list of available tools.

2) Click on the tool you want to remove and the tool is removed from the toolbar. The highlight or check mark next to the tool is also removed. The list of available tools closes automatically.

Customizing toolbars

Extra tools and commands that are not available in Visible Buttons can be added to a toolbar using customization. Customization also allows you to create new toolbars should you require a specific set of tools for a specific task. For information on customizing toolbars, see the Getting Started Guide.

Toolbars

Note

The tools installed on a toolbar are normally indicated in Visible Buttons either by the tool icon being highlighted or by a check mark. However, this install indication depends on computer setup and computer operating system being used.

Note

On some toolbars, the icons have a small downward pointing triangle ▼ to the right of an icon. Click on this triangle to open further options that are available for use.
3D-Objects

The 3D-Objects toolbar provides tools to create 3D objects in a presentation. It is activated either by going to View > Toolbars > 3D-Objects on the Menu bar or by clicking on the 3D Objects icon on the Drawing toolbar.

1) Cube
2) Sphere
3) Cylinder
4) Cone
5) Pyramid
6) Torus
7) Shell
8) Half Sphere

3D-Settings

The 3D-Settings toolbar and its tools only become active when an object has been converted to 3D using the tool Toggle Extrusion and the converted object is then selected.

1) Toggle Extrusion
2) Tilt Down
3) Tilt Up
4) Tilt Left
5) Tilt Right
6) Depth
7) Direction
8) Lighting
9) Surface
10) 3D Color

Align Objects

The Align Objects toolbar allows you to align several objects on a slide to improve the visual impact of a presentation.

1) Left
2) Centered
3) Right
4) Top
5) Center
6) Bottom

Comments

The Comments toolbar allows you to add, delete and navigate comments in a presentation. To use comments, it is recommended to add your name and initials in Tools > Options > LibreOffice > User Data so that comments can be easily identified.
1) Comment (Ctrl+Alt+C)  
2) Previous Comment (Ctrl+Alt+PgUp)  
3) Next Comment (Ctrl+Alt+PgDown)  
4) Delete Comment  
5) Delete All Comments

**Drawing**

The Drawing toolbar provides the majority of the tools normally used to create graphic objects on a slide. Some tool icons on this toolbar change to show the last tool selected and used.

![Drawing Toolbar](image)

1) Select  
2) Zoom & Pan  
3) Zoom  
4) Text Box (F2)  
5) Vertical Text  
6) Fontwork  
7) Line Color  
8) Fill Color  
9) Line  
10) Rectangle  
11) Ellipse  
12) Line Ends with Arrow  
13) Lines and Arrows  
14) Curves and Polygons  
15) Connectors  
16) Basic Shapes  
17) Symbol Shapes  
18) Block Arrows (Arrow Shapes in Visible Buttons)  
19) Flowchart  
20) Callouts (Callout Shapes in Visible Buttons)  
21) Stars and Banners (Star Shapes in Visible Buttons)  
22) 3D Shapes  
23) Position and Size (F4)  
24) Rotate  
25) Flip  
26) Align  
27) Arrange  
28) Distribution  
29) Shadow  
30) Crop  
31) Filter  
32) Edit Points (F8)  
33) Glue Points  
34) To Curve  
35) To Polygon  
36) To 3D  
37) T0 3D Rotation Object  
38) Toggle Extrusion  
39) Insert  
40) Controls

Some icon shapes shown on the Drawing toolbar depend on the last tool that had previously been selected and used.

- Click on the small downward pointing triangle ▼ to the right of an icon to open a pop up menu. Select the required shape you want to draw on a slide.
- To create a sub-toolbar, click and drag at the top of the pop up menu to an empty area on the main window The sub-toolbars for each object type and the various shapes available are shown below.

![Sub Toolbars](image)
**Edit Points**

The Edit Points toolbar becomes active when you select a polygon object and click *Edit Points* or use the keyboard shortcut *F8*. The tools provided allow you to edit the points of a curve or an object converted to a curve.

1) **Edit Points (F8)**
2) Move Points
3) Insert Points
4) Delete Points
5) Convert to Curve
6) Close Bezier
7) Split Curve
8) Corner Point
9) Smooth Transition
10) Symmetric Transition
11) Eliminate Points

**Find**

The Find toolbar opens by default in the bottom left corner of the Impress main window. The Find toolbar cannot be undocked and made into a floating toolbar.

1) Close Find Bar
2) Find Text
3) Find Previous
4) Find Next
5) Find All
6) Match Case
7) Find and Replace (Ctrl+H)

**Fontwork**

The Fontwork toolbar is used to create graphical text objects in a presentation and provide the tools allowing you to edit the graphical text object.

1) Insert Fontwork
2) Fontwork Shape
3) Fontwork Same Letter Heights
4) Fontwork Alignment
5) Fontwork Character Spacing
6) Toggle Extrusion
Form Controls

The Form Controls toolbar provides tools required to create an interactive form. The toolbar adds controls to a form in a text, drawing, spreadsheet, presentation, or HTML document (for example a button that runs a macro).

Form Controls

1) Select 15) Formatted Field
2) Toggle Design Mode 16) Date Field
3) Form Control Wizards 17) Numerical Field
4) Form Design 18) Group Box
5) Control Properties 19) Time Field
6) Form Properties 20) Currency Field
7) Label 21) Pattern Field
8) Text Box 22) Table Control
9) Check Box 23) Navigation Bar
10) Option Button 24) Image Control
11) List Box 25) File Selection
12) Combo Box 26) Spin Button
13) Push Button 27) Scrollbar
14) Image Button

Form Design

The Form Design toolbar opens a form in Design Mode so that a form can be edited. You cannot activate the controls of the form or edit contents in Design Mode. However, you can change the position and size of the controls, edit other properties, and add or delete controls in Design Mode.

Form Design

1) Select 11) Group (Ctrl+Shift+G)
2) Control Properties 12) Ungroup (Ctrl+Alt+Shift+G)
3) Form Properties 13) Enter Group (F3)
4) Position and Size (F4) 14) Exit Group (Ctrl+F3)
5) Form Navigator 15) Align
6) Activation Order 16) Open in Design Mode
7) Add Field 17) Grid
8) Automatic Control Focus 18) Snap to Grid
9) Bring to Front (Ctrl+Shift++) 19) Helplines While Moving
10) Send to Back (Ctrl+Shift+-)

Form Navigation

The Form Navigation toolbar provides tools to edit a database table or to control the data view. The toolbar is normally displayed at the bottom of a document that contains fields that are linked to a database. The Form Navigation toolbar is only active when forms are connected to a database.
The Form Navigation toolbar allows you to move within records as well as to insert and to delete records. If data is saved in a form, the changes are transferred to the database. This toolbar also provides tools providing sort, filter, and search functions for data records.

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1) Find Record</td>
<td>12) Delete Record</td>
</tr>
<tr>
<td>2) Record</td>
<td>13) Refresh</td>
</tr>
<tr>
<td>3) Absolute Record</td>
<td>14) Refresh Control</td>
</tr>
<tr>
<td>4) Text -&gt; Record</td>
<td>15) Sort</td>
</tr>
<tr>
<td>5) Total No. of Records</td>
<td>16) Sort Ascending</td>
</tr>
<tr>
<td>6) First Record</td>
<td>17) Sort Descending</td>
</tr>
<tr>
<td>7) Next Record</td>
<td>18) AutoFilter</td>
</tr>
<tr>
<td>8) Last Record</td>
<td>19) Apply Filter</td>
</tr>
<tr>
<td>9) New Record</td>
<td>20) Form-Based Filters</td>
</tr>
<tr>
<td>10) Save Record</td>
<td>21) Reset Filter/Sort</td>
</tr>
<tr>
<td>11) Undo Data entry</td>
<td>22) Data source as Table</td>
</tr>
</tbody>
</table>

### Glue Points

The Gluepoints toolbar provides tools to insert a glue point or modify the properties of a glue point. A glue point is a point where you can attach a connector. By default, LibreOffice automatically places a glue point at the center of each side of the bounding rectangle for every object you create.

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1) Insert Glue Point</td>
<td>7) Glue Point Horizontal Left</td>
</tr>
<tr>
<td>2) Exit Direction Left</td>
<td>8) Glue Point Horizontal Center</td>
</tr>
<tr>
<td>3) Exit Direction Top</td>
<td>9) Glue Point Vertical Top</td>
</tr>
<tr>
<td>4) Exit Direction Right</td>
<td>10) Glue Point Vertical Center</td>
</tr>
<tr>
<td>5) Exit Direction Bottom</td>
<td>11) Glue Point Vertical Bottom</td>
</tr>
<tr>
<td>6) Glue Point Relative</td>
<td></td>
</tr>
</tbody>
</table>

### Image

The Image toolbar provides tools to edit, modify, align, reposition and resize images. The Image toolbar only becomes active and available when an image is selected in a presentation. The Image toolbar automatically replaces the Line and Filling toolbar when it becomes active.

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1) Position and Size (F4)</td>
<td>11) Send Backward (Ctrl+/-)</td>
</tr>
<tr>
<td>2) Align</td>
<td>12) Send to Back (Ctrl+Shift+/-)</td>
</tr>
<tr>
<td>3) Left</td>
<td>13) In Front of Object</td>
</tr>
<tr>
<td>4) Centered</td>
<td>14) Behind Object</td>
</tr>
<tr>
<td>5) Right</td>
<td>15) Reverse</td>
</tr>
<tr>
<td>6) Top</td>
<td>16) Line Style</td>
</tr>
<tr>
<td>7) Center</td>
<td>17) Line Width</td>
</tr>
<tr>
<td>8) Bottom</td>
<td>18) Line Color</td>
</tr>
<tr>
<td>9) Bring to Front (Ctrl+Shift++)</td>
<td>19) Area Style/Filling</td>
</tr>
<tr>
<td>10) Bring Forward (Ctrl++)</td>
<td>20) Fill Color</td>
</tr>
</tbody>
</table>
21) Shadow  
22) Filter  
23) Image Mode  
24) Crop  
25) Vertically  
26) Horizontally  
27) Transformations  
28) Color  
29) Line  
30) Area  
31) Animation  
32) Interaction

**Insert**

The Insert toolbar allows you to insert different types of objects into your presentation.

![Insert Toolbar]

1) New Page (Ctrl+M)  
2) Floating Frame  
3) Insert Page from File  
4) Table  
5) Image  
6) Media  
7) Formula  
8) Chart  
9) OLE Object

**Legacy Circles and Ovals**

The Legacy Circles and Ovals toolbar provides tools to insert different types of circles and ovals into your presentation.

![Legacy Circles and Ovals Toolbar]

1) Ellipse  
2) Circle  
3) Ellipse Pie  
4) Circle Pie  
5) Ellipse Segment  
6) Circle Unfilled  
7) Ellipse Pie Unfilled  
8) Circle Pie Unfilled  
9) Ellipse Segment Unfilled  
10) Arc  
11) Circle Arc

**Legacy Rectangles**

The Legacy Rectangles toolbar provides tools to insert different types of rectangles and squares into your presentation.

![Legacy Rectangles Toolbar]

1) Rectangle  
2) Square  
3) Rectangle Rounded  
4) Rounded Square  
5) Rectangle Unfilled  
6) Square Unfilled  
7) Rounded Rectangle Unfilled  
8) Rounded Square Unfilled

**Line and Filling**

The Line and Filling toolbar lets you modify the main properties of an object. The tools and drop down lists vary according to the type of object selected.
Master View

The Master View toolbar provides tools where you can create a new master slide, rename a master slide, delete a master slide, and close master slide view. This toolbar is only active when Impress is in master view.

Media Playback

The Media Playback toolbar provides the standard tools required to insert, view, play and listen to audio and video files. Impress supports many different media formats.

Options

The Options toolbar allows you to define various settings for newly created presentation documents. For example how objects snap to the grid, object editing.
1) Rotation Mode after Clicking Object  8) Snap to Object Borders
2) Grid  9) Snap to Object Points
3) Display Snap Guide  10) Allow Quick Editing
4) Helplines While Moving  11) Select Text Area Only
5) Snap to Grid  12) Double-click to edit Text
6) Snap to Snap Guides  13) Modify Object with Attributes
7) Snap to Page Margins  14) Exit All Groups

Outline

The Outline toolbar provides frequently used editing tools for working with text outlines.

1) Demote (Alt+Shift+Right)  5) Show Formatting  6) Black & White View
2) Promote (Alt+Shift+Left)  7) Show Only First Level  8) Show All Levels
3) Move Down (Alt+Shift+Down)  9) Hide Subpoints  10) Show Subpoints
4) Move Up (Alt+Shift+Up)

Presentation

The Presentation toolbar provides frequently used tools for working with presentations.

1) New Slide  9) Go to Previous Slide 10) Go to Next Slide
2) Duplicate Slide  11) Go to Last Slide
3) Rename Slide  12) Move Slide to Start
4) Delete Slide  13) Move Slide Up
5) Slide Layout  14) Move Slide Down
6) Change Slide Master  15) Move Slide to End
7) Expand Slide
8) Go to First Slide
Slide Sorter

The Slide Sorter toolbar allows you to select slides in the current presentation and start a presentation from the first slide.

1) Select 2) Start from First Slide (F5)

Slide View

The Slide View toolbar opens with the Slide Sorter view.

1) Rehearse Timings 3) Hide Slide
2) Show Slide 4) Slides per Row

Standard

The Standard toolbar is common to all LibreOffice modules and provides the most common tools when creating and editing documents using LibreOffice. The Standard toolbar will differ between the different LibreOffice modules to allow for different toolsets used in creating the different types of documents.

1) Load URL 24) Grid
2) New (Ctrl+N) 25) Helplines While Moving
3) Templates (Ctrl+Shift+N) 26) Display Views
4) Open (Ctrl+O) 27) Views Tab Bar
5) Open Remote 28) Format Slide
6) Save (Ctrl+S) 29) Master Slide
7) Save As (Ctrl+Shift+S) 30) Start from First Slide (F5)
8) Email 31) Start from Current Slide (Shift+F5)
9) Edit Mode (Ctrl+Shift+M) 32) Table
10) PDF 33) Image
11) Print Directly 34) Media
12) Print (Ctrl+P) 35) Chart
13) Cut (Ctrl+X) 36) Text Box (F2)
14) Copy (Ctrl+C) 37) Symbol (toolbar name Insert Special Characters)
15) Paste (Ctrl+V) 38) Vertical Text
16) Close (installed) 39) Insert Fontwork
17) Clear (Ctrl+Shift+M) 40) Hyperlink (Ctrl+K)
18) Undo (Ctrl+Z) 41) Draw Functions
19) Redo (Ctrl+Y) 42) Interaction
20) Find and Replace (Ctrl+H) 43) LibreOffice Help
21) Auto Spellcheck (Shift+F7) 44) What's That
22) Zoom & Pan
23) Zoom
Standard (Single Mode)

The Standard (Single Mode) toolbar becomes active when the user interface is switched to single mode. Go to View > User Interface on the Menu bar and select Single Toolbar.

1) New (Ctrl+N)  
2) Open (Ctrl+O)  
3) Save (Ctrl+S)  
4) PDF  
5) Print (Ctrl+P)  
6) Print Preview (Ctrl+Shift+O)  
7) Undo (Ctrl+Z)  
8) Redo (Ctrl+Y)  
9) Find and Replace (Ctrl+H)  
10) Clone  
11) Spelling  
12) Entire Page  
13) New Slide  
14) Duplicate Slide  
15) Rename Slide  
16) Delete Slide  
17) Slide Layout  
18) Display Views  
19) Text Box (F2)  
20) Image  
21) Media  
22) Chart  
23) Table  
24) Insert Fontwork  
25) Line  
26) Rectangle  
27) Ellipse  
28) Lines and Arrows  
29) Curves and Polygons  
30) Connectors  
31) Basic Shapes  
32) Symbol Shapes  
33) Arrow Shapes  
34) Flowchart Shapes  
35) Callout Shapes  
36) Star Shapes  
37) 3D Objects  
38) Position and Size (F4)  
39) Rotate  
40) Flip  
41) Align  
42) Arrange  
43) Distribution  
44) Group (Ctrl+Shift+G)  
45) Ungroup (Ctrl+Alt+Shift+G)  
46) Enter Group (F3)  
47) Exit Group (Ctrl+F3)  
48) Select  
49) Entire Page  
50) Zoom & Pan  
51) Zoom  
52) Start from First Slide (F5)  
53) Start from Current Slide (Shift+F5)

Standard (Viewing Mode)

The Standard (Viewing Mode) toolbar provides tools to save, edit and distribute a document.

1) Save As (Ctrl+Shift+S)  
2) Edit Mode (Ctrl+Shift+M)  
3) Read Only Mode  
4) Email  
5) PDF  
6) EPUB  
7) Print Directly  
8) Print (Ctrl+P)  
9) Copy (Ctrl+C)  
10) Find and Replace (Ctrl+H)  
11) Zoom  
12) Start from First Slide (F5)

Table

The Table toolbar provides tools to edit and format a table placed on a slide. This toolbar only becomes active when a table is selected.
The **Text** toolbar provides tools to insert text boxes and callouts into a slide.

1) Text Box (F2)  
2) Fit Text in Textbox Size  
3) Callouts  
4) Vertical Text  
5) Fit Vertical Text to Frame  
6) Vertical Callouts

### Text Formatting

The Text Formatting toolbar provides tools for formatting text and alignment commands. This toolbar becomes active when text in a text box or graphic object has been selected and it automatically replaces the Line and Filling toolbar.

1) Font Name  
2) Font Size  
3) Increase (Ctrl+)  
4) Decrease (Ctrl-)  
5) Bold (Ctrl+B)  
6) Italic (Ctrl+I)  
7) Underline  
8) Double Underline  
9) Strikethrough  
10) Overline  
11) Superscript (Ctrl+Shift+P)  
12) Subscript (Ctrl+Shift+B)  
13) Shadow  
14) Outline  
15) Clear (Ctrl+Shift+M)  
16) lowercase  
17) UPPERCASE  
18) SMALL CAPITALS  
19) Font Color  
20) Highlight Color  
21) Bullets  
22) Numbering  
23) Outline  
24) Left (Ctrl+L)  
25) Center (Ctrl+E)  
26) Right (Ctrl+R)  
27) Justified (Ctrl+J)  
28) Top  
29) Center  
30) Bottom  
31) Line Spacing  
32) Character Spacing  
33) Increase  
34) Decrease  
35) Text direction from left to right  
36) Text direction from top to bottom  
37) Left-To-Right  
38) Right-To-Left
39) Select All (Ctrl+A)  
40) Character  

**Transformations**

The Transformations toolbar provides tools to modify the shape, orientation or fill of selected object(s).

![Transformations Toolbar]

1) Rotate  
2) Flip  
3) In 3D Rotation Object  
4) Set in Circle (perspective)  
5) Set to circle (slant)  
6) Distort  
7) Transparency tool (Interactive transparency tool)  
8) Gradient tool (Interactive gradient tool)

**TSCP Classification**

The TSCP Classification toolbar provides tools to help in selecting the security of a document. LibreOffice adds custom fields in the document properties (File > Properties > Custom Properties) to store the classification policy as document metadata. TSCP stands for Transglobal Secure Collaboration Participation.

![TSCP Classification Toolbar]

1) Apply document classification (Level)  
2) Manage Document Classification

**Zoom**

The Zoom toolbar provides tools to reduce or enlarge the screen display of the current document.

![Zoom Toolbar]

1) Zoom In  
2) Zoom Out  
3) 100%  
4) Zoom Previous  
5) Zoom Next  
6) Entire Page  
7) Page Width  
8) Optimal  
9) Object Zoom  
10) Zoom & Pan  
11) Shift
Impress Guide

Working With Presentations

About this book:
This book is for beginners to advanced users of Impress, the presentations (slide show) component of LibreOffice. Using Impress, you can create slides that contain text, bulleted and numbered lists, tables, charts, clip art, and other objects. Impress comes with predefined text styles and slide backgrounds; you can also create your own.

This book covers the main features of Impress. If you want an introduction to all of LibreOffice components, you might like to read Getting Started with LibreOffice first.

About the authors:
This book was written by volunteers from the LibreOffice community. Profits from sales of the printed edition will be used to benefit the community.

A PDF version of this book can be downloaded free from: https://documentation.libreoffice.org

About LibreOffice:
LibreOffice is the free, libre, and open source personal productivity suite from The Document Foundation. It runs on Windows, macOS, and GNU/Linux. Support and documentation is free from our large, dedicated community of users, contributors and developers.

You too can get involved with volunteer work in many areas: development, quality assurance, documentation, translation, user support, and more.

You can download the free Community release of LibreOffice from:
https://libreoffice.org/download/

For commercial use: You are encouraged to work with a certified LibreOffice professional for your business needs, from deployment or conversion off other office suites, staff training, or custom development needs.

You can find information on professional support services at:
https://www.libreoffice.org/get-help/professional-support/