Chapter 2
Setting up Writer
Choosing options to suit the way you work
Copyright

This document is Copyright © 2011–2014 by the LibreOffice Documentation Team. Contributors are listed below. You may distribute it and/or modify it under the terms of either the GNU General Public License (http://www.gnu.org/licenses/gpl.html), version 3 or later, or the Creative Commons Attribution License (http://creativecommons.org/licenses/by/4.0/), version 4.0 or later.

All trademarks within this guide belong to their legitimate owners.

Contributors

Jean Hollis Weber  John A Smith  John M. Długosz
Ron Faile Jr.

Feedback

Please direct any comments or suggestions about this document to the Documentation Team’s mailing list: documentation@global.libreoffice.org

Note: Everything you send to a mailing list, including your email address and any other personal information that is written in the message, is publicly archived and cannot be deleted.

Acknowledgments

This chapter is revised and updated from Chapter 2 of the OpenOffice.org 3.3 Writer Guide. The contributors to that chapter are:

Jean Hollis Weber  Agnes Belzunce  Daniel Carrera
Peter Hillier-Brook  Stefan A. Keel  Gary Schnabl
Janet M. Swisher  Michele Zarri  Jared Kobos

Publication date and software version

Published 8 March 2014. Based on LibreOffice 4.2.

Note for Mac users

Some keystrokes and menu items are different on a Mac from those used in Windows and Linux. The table below gives some common substitutions for the instructions in this chapter. For a more detailed list, see the application Help.

<table>
<thead>
<tr>
<th>Windows or Linux</th>
<th>Mac equivalent</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tools &gt; Options</td>
<td>LibreOffice &gt; Preferences</td>
<td>Access setup options</td>
</tr>
<tr>
<td>menu selection</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Right-click</td>
<td>Control+click and/or right-click depending on computer system</td>
<td>Opens a context menu</td>
</tr>
<tr>
<td>Ctrl (Control)</td>
<td>⌘ (Command)</td>
<td>Used with other keys</td>
</tr>
<tr>
<td>F5</td>
<td>Shift+⌘+F5</td>
<td>Open the Navigator</td>
</tr>
<tr>
<td>F11</td>
<td>⌘+T</td>
<td>Open the Styles and Formatting window</td>
</tr>
</tbody>
</table>

Documentation for LibreOffice is available at http://www.libreoffice.org/get-help/documentation
Contents

Copyright .................................................................................................................................. 2
  Contributors .......................................................................................................................... 2
  Feedback ............................................................................................................................... 2
  Acknowledgments .................................................................................................................. 2
  Publication date and software version ................................................................................. 2

Note for Mac users ................................................................................................................. 2

Choosing options that affect all LibreOffice components .................................................... 5
  User Data options .................................................................................................................. 5
  General options .................................................................................................................... 5
  Memory options ................................................................................................................... 6
  View options ......................................................................................................................... 7
  Print options ......................................................................................................................... 9
  Paths options ........................................................................................................................ 10
  Colors options ..................................................................................................................... 10
  Fonts options ....................................................................................................................... 11
  Security options ................................................................................................................ 12
  Personalization .................................................................................................................... 14
  Appearance options ........................................................................................................... 15
  Accessibility options .......................................................................................................... 15
  Advanced options .............................................................................................................. 16

Choosing options for loading and saving documents ............................................................ 16
  General ................................................................................................................................. 16
  VBA Properties ................................................................................................................... 19
  Microsoft Office ................................................................................................................ 19
  HTML compatibility ........................................................................................................... 20

Choosing options for Writer .................................................................................................. 20
  General options .................................................................................................................. 21
  View options ....................................................................................................................... 22
  Formatting Aids options ..................................................................................................... 22
  Grid options ......................................................................................................................... 23
  Basic Fonts (Western) options ............................................................................................ 23
  Print options ......................................................................................................................... 24
  Table options ....................................................................................................................... 25
  Changes options ................................................................................................................ 25
  Compatibility options ......................................................................................................... 26
  AutoCaption options .......................................................................................................... 27
  Mail Merge E-mail options ................................................................................................. 28

Choosing options for HTML documents ................................................................................ 29

Choosing language settings .................................................................................................. 29
  Install the required dictionaries ......................................................................................... 29
  Change some locale and language settings ....................................................................... 29
Choose spelling options............................................................................................................ 30
English sentence checking.................................................................................................... 31
Controlling Writer’s AutoCorrect functions........................................................................ 33
Choosing options that affect all LibreOffice components

This section covers some of the settings that apply to all the components of LibreOffice and are particularly important when using Writer. Other general options are discussed in Chapter 2, Setting up LibreOffice, in the *Getting Started* guide.

Click **Tools > Options**. The list on the left-hand side of the Options – LibreOffice dialog varies depending on which component of LibreOffice is open. The illustrations in this chapter show the list as it appears when a Writer document is open.

Click the marker (+ or triangle) by **LibreOffice** on the left-hand side. A list of pages drops down. Selecting an item in the list causes the right-hand side of the dialog to display the relevant page.

| Note | The *Revert* button (located in the lower right of the full Options dialog) has the same effect on all pages of the dialog. It resets options to the values that were in place when you opened the dialog. |

If you are using a version of LibreOffice other than US English, some field labels may be different from those shown in the illustrations.

**User Data options**

Because Writer can use the name or initials stored in the **LibreOffice – User Data** page for several things, including document properties (created by and last edited by information) and the name of the author of comments and changes, you will want to ensure that the correct information appears here.

Fill in the form (not shown here) or amend or delete any existing incorrect information. If you do not want user data to be part of the document's properties, clear the box at the bottom.

**General options**

The options on the **LibreOffice – General** page are described below.

![Figure 1: Setting general options for LibreOffice](image)

**Help**
- **Tips**
- **Extended tips**

**Open/Save dialogs**
- **Use LibreOffice dialogs**

**Document status**
- Printing sets "document modified" status
- Allow to save document even when the document is not modified

**Year (two digits)**
- Interpret as years between 1930 and 2029

**Help – Tips**
- When **Tips** is active, one or two words will appear when you hold the mouse pointer over an icon or field, without clicking.
Help – Extended tips
When Extended tips is active, a brief description of the function of a particular icon or menu command or a field on a dialog appears when you hold the mouse pointer over that item.

Open/Save dialogs – Use LibreOffice dialogs
To use the standard Open and Save dialogs for your operating system, deselect the Use LibreOffice dialogs option. When this option is selected, the Open and Save dialogs supplied with LibreOffice will be used. See Chapter 1, Introducing Writer, for more about the LibreOffice Open and Save dialogs. This book uses the LibreOffice Open and Save dialogs in illustrations.

Document status – Printing sets “document modified” status
If this option is selected, then the next time you close the document after printing, the print date is recorded in the document properties as a change and you will be prompted to save the document again, even if you did not make any other changes.

Document status – Allow to save document even when the document is not modified
Normally when a document has not been modified, the File > Save menu option and the Save button on the Standard Toolbar are disabled and the keyboard shortcut Ctrl+S has no effect. Select this option to allow documents to be saved even when they have not been modified.

Year (two digits)
Specifies how two-digit years are interpreted. For example, if the two-digit year is set to 1930, and you enter a date of 1/1/30 or later into your document, the date is interpreted as 1/1/1930 or later. An “earlier” date is interpreted as being in the following century; that is, 1/1/20 is interpreted as 1/1/2020.

Memory options
The options on the LibreOffice – Memory page control how LibreOffice uses your computer’s memory and how much memory it requires.

![Memory options](image)

Figure 2: Choosing Memory options for LibreOffice

Before changing these options, you may wish to consider the following points:

- More memory can make LibreOffice faster and more convenient (for example, more undo steps require more memory); but the trade-off is less memory available for other applications and you could run out of memory altogether.

- If your documents contain a lot of objects such as images, or the objects are large, LibreOffice’s performance may improve if you increase the memory for LibreOffice or the
memory per object. If you find that objects seem to disappear from a document that contains a lot of them, increase the number of objects in the cache. (The objects are still in the file even if you cannot see them on screen.)

- To load the Quickstarter when you start your computer, select the option near the bottom of the dialog. This makes LibreOffice start faster; the trade-off is that LibreOffice uses some memory even when not being used. This option (called Enable systray Quickstarter on Linux) is not available on Mac OS X or on systems where the Quickstarter module has not been installed.

**View options**

The options on the LibreOffice – View page affect the way the document window looks and behaves. Some of these options are described below. Set them to suit your personal preferences.

![User Interface Options](image)

**User Interface – Scaling**

If the text in the help files or on the menus of the LibreOffice user interface is too small or too large, you can change it by specifying a scaling factor. Sometimes a change here can have unexpected results, depending on the screen fonts available on your system. However, it does not affect the font size of the text in your documents.

**User Interface – Icon size and style**

The first box specifies the display size of toolbar icons (Automatic, Small, or Large); the Automatic icon size option uses the setting for your operating system. The second box specifies the icon style (theme); here the Automatic option uses an icon set compatible with your operating system.

**User Interface – Use system font for user interface**

If you prefer to use the system font (the default font for your computer and operating system) instead of the font provided by LibreOffice for the user interface, select this option.

**User interface – Screen font Anti-Aliasing**

(Not available in Windows; not shown in Figure 3.) Smooths the screen appearance of text. Enter the smallest font size to apply anti-aliasing.

**Menu – Icons in menus**

Causes icons as well as words to be visible in menus. Choice of Automatic, Hide or Show.
Font Lists – Show preview of fonts
Causes the font list to look like Figure 4, Left, with the font names shown as an example of the font. With the option deselected, the font list shows only the font names, not their formatting (Figure 4, Right). The fonts you will see listed are those that are installed on your system.

Fonts which are tuned for use with a specific script, such as Arabic, Hebrew, Malayalam, and so on, now show an additional preview of some sample text in the target script.

![Font list (Left) showing preview; (Right) without preview](image)

Figure 4: Font list (Left) showing preview; (Right) without preview

Font Lists – Show font history
Causes the last five fonts you have assigned to the current document to be displayed at the top of the font list.

Graphics output – Use hardware acceleration
Directly accesses hardware features of the graphical display adapter to improve the screen display. Not supported on all operating systems and LibreOffice distributions.

Graphics output – Use Anti-Aliasing
Enables and disables anti-aliasing, which makes the display of most graphical objects look smoother and with fewer artifacts. Not supported on all operating systems and LibreOffice distributions.

Tip
Press Shift+Ctrl+R to restore or refresh the view of the current document after changing the anti-aliasing settings, to see the effect.

Mouse positioning
Specifies if and how the mouse pointer will be positioned in newly opened dialogs.

Middle mouse button
Defines the function of the middle mouse button.

- **Automatic scrolling** – dragging while pressing the middle mouse button shifts the view.
- **Paste clipboard** – pressing the middle mouse button inserts the contents of the “Selection clipboard” at the cursor position.

The “Selection clipboard” is independent of the normal clipboard that you use by Edit > Copy/Cut/Paste or their respective keyboard shortcuts. Clipboard and “Selection clipboard” can contain different contents at the same time.
<table>
<thead>
<tr>
<th>Function</th>
<th>Clipboard</th>
<th>Selection clipboard</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copy content</td>
<td>Edit &gt; Copy or Ctrl+C</td>
<td>Select text, table, or object.</td>
</tr>
<tr>
<td>Paste content</td>
<td>Edit &gt; Paste or Ctrl+V pastes at the cursor position.</td>
<td>Clicking the middle mouse button pastes at the mouse pointer position.</td>
</tr>
<tr>
<td>Pasting into another document</td>
<td>No effect on the clipboard contents.</td>
<td>The last marked selection is the content of the selection clipboard.</td>
</tr>
</tbody>
</table>

**Selection – Transparency**

Determines the appearance of selected text or graphics, which appear on a shaded background. To make the shaded background more or less dark, increase or decrease the Transparency setting.

If you prefer selected material to appear in reversed color (typically white text on a black background), deselect this option.

**Print options**

On the LibreOffice – Print page, set the print options to suit your default printer and your most common printing method.

![LibreOffice Print Options](image)

*Figure 5: Choosing general printing options to apply to all LibreOffice components*

The option **PDF as Standard Print Job Format** is not available on Windows. Select this option to change the internal print job format from a Postscript document description to a PDF description. This format has a number of advantages over Postscript. For more information, see [http://www.linuxfoundation.org/collaborate/workgroups/openprinting/pdf_as_standard_print_job_format](http://www.linuxfoundation.org/collaborate/workgroups/openprinting/pdf_as_standard_print_job_format)

Deselecting this option reverts to the Postscript document workflow system.

In the **Printer warnings** section near the bottom of the page, you can choose whether to be warned if the paper size or orientation specified in your document does not match the paper size or orientation available for your printer. Having these warnings turned on can be quite helpful, particularly if you work with documents produced by people in other countries where the standard paper size is different from yours.
If your printouts are incorrectly placed on the page or chopped off at the top, bottom, or sides or the printer is refusing to print, the most likely cause is page-size incompatibility.

**Paths options**

On the **LibreOffice – Paths** page, you can change the location of files associated with, or used by, LibreOffice to suit your working situation. In a Windows system, for example, you might want to store documents by default somewhere other than My Documents.

To make changes, select an item in the list shown in Figure 6 and click **Edit**. On the Select Paths dialog (not shown), add or delete folders as required, and then click **OK** to return to the Options dialog. Note that many items can have at least two paths listed: one to a shared folder (which might be on a network) and one to a user-specific folder (normally on the user's personal computer). Items with more than one path allowed will use an Edit Paths dialog (not shown).

![Figure 6: Viewing the paths of files used by LibreOffice](image)

You can use the entries in the **LibreOffice – Paths** dialog to compile a list of files, such as those containing AutoText, that you need to back up or copy to another computer.

**Colors options**

On the **LibreOffice – Colors** page, you can specify colors to use in LibreOffice documents. You can select a color from a color table or selection list, edit an existing color, or define new colors. These colors will then be available in color selection lists in LibreOffice.

For details on how to modify a color or create a new color, see Chapter 14, Customizing LibreOffice, in the *Getting Started* guide.
Fonts options

You can define replacements for any fonts that might appear in your documents. If you receive from someone else a document containing fonts that you do not have on your system, LibreOffice will substitute fonts for those it does not find. You might prefer to specify a different font from the one the program chooses.

On the **LibreOffice – Fonts** page:

1) Select **Apply Replacement Table** option.
2) Select or type the name of the font to be replaced in the **Font** box. (If you do not have this font on your system, it will not appear in the drop-down list in this box, so you need to type it in.)
3) In the **Replace with** box, select a suitable font from the drop-down list of fonts installed on your computer.

4) The check mark to the right of the **Replace with** box turns green. Click on this check mark. A row of information now appears in the larger box below the input boxes. Select **Always** to replace the font, even if the original font is installed on your system. Select **Screen only** to replace the screen font only and never replace the font for printing. The results of combining these selections are given in Table 1. A listing in the display pane can be removed by selecting it and clicking the red cross.

5) In the bottom section of the page, you can change the typeface and size of the font used to display source code such as HTML and Basic (in macros).

### Table 1: Font substitution replacement actions

<table>
<thead>
<tr>
<th>Always checkbox</th>
<th>Screen only checkbox</th>
<th>Replacement action</th>
</tr>
</thead>
<tbody>
<tr>
<td>checked</td>
<td>blank</td>
<td>Font replacement on screen and when printing, whether the font is installed or not.</td>
</tr>
<tr>
<td>checked</td>
<td>checked</td>
<td>Font replacement only on screen, whether the font is installed or not.</td>
</tr>
<tr>
<td>blank</td>
<td>checked</td>
<td>Font replacement only on screen, but only if font is not available.</td>
</tr>
<tr>
<td>blank</td>
<td>blank</td>
<td>Font replacement on screen and when printing, but only if font is not available.</td>
</tr>
</tbody>
</table>

### Security options

Use the **LibreOffice – Security** page to choose security options for documents containing hidden information and for opening documents that contain macros.

*Figure 9: Choosing security options for opening and saving documents*

**Security Options and warnings**

If you record changes, save multiple versions, or include hidden information or notes in your documents, and you do not want some of the recipients to see that information, you can set warnings to remind you to remove it, or you can have LibreOffice remove some of it automatically. Note that (unless removed) much of this information is retained in a file whether
the file is in LibreOffice’s default Open Document format, or has been saved to other formats, including PDF.

Click the **Options** button to open a separate dialog with specific choices (Figure 10).

**Passwords for web connections**

You can enter a master password to enable easy access to websites that require a user name and password. If you select the **Persistently save passwords for web connections** option, a new dialog opens where you can specify the password. LibreOffice will securely store all passwords that you use to access files from web servers. You can retrieve the passwords from the list after you enter the master password.

**Macro security**

Click the **Macro Security** button to open the **Macro Security** dialog, where you can adjust the security level for executing macros and specify trusted sources.

**Certificate Path**

Users can digitally sign documents using LibreOffice. A digital signature requires a personal signing certificate. Most operating systems can generate a self-signed certificate. However, a personal certificate issued by an outside agency (after verifying an individual’s identity) has a higher degree of trust associated with it than does a self-signed certificate. LibreOffice does not provide a secure method of storing these certificates, but it can access certificates that have been saved using other programs. Click **Certificate** and select which certificate store to use.

**Security options and warnings**

The following options are on the **Security options and warnings** dialog (Figure 10).

**Remove personal information on saving**

Select this option to always remove user data from the file properties when saving the file. To manually remove personal information from specific documents, deselect this option.

![Security options and warnings dialog](image)

*Figure 10: Security options and warnings dialog*
Ctrl-click required to follow hyperlinks
The default behavior in LibreOffice is to Ctrl+click on a hyperlink to open the linked document. Many people find creation and editing of documents easier when accidental clicks on links do not activate the links. To set LibreOffice to activate hyperlinks using an ordinary click, deselect this option.

The other options on this dialog should be self-explanatory.

Personalization
Using Personalization, you can add a theme to your LibreOffice installation. Choices on this page are to not use a Theme, use a pre-installed Theme if one is available, select a Theme from the Mozilla Firefox site, or add your own design. This option defaults to Pre-installed Theme at installation time.

Figure 11: Personalization options

To install a Theme, click the Select Theme button to open the install dialog (Figure 12). From here you can enter an address (URL) to the theme or click the Visit Firefox Themes button. An internet connection is required for this process. Installation instructions are on this dialog.

Figure 12: Theme installation dialog

Full details about Themes are on the website: https://addons.mozilla.org/en-US/firefox/themes/

Figure 13: An example of an installed theme
Appearance options

Writing, editing, and (especially) page layout are often easier when you can see the page margins (text boundaries), the boundaries of tables and sections, grid lines, and other features. In addition, you might prefer to use colors that are different from LibreOffice’s defaults for such items as comment indicators or field shadings.

On the LibreOffice – Appearance page, you can specify which items are visible and the colors used to display various items.

- To show or hide items such as text boundaries, select or deselect the options next to the names of the items.
- To change the default colors for items, click the down-arrow in the Color setting column by the name of the item and select a color from the list box. Note that you can change the list of available colors as described in Chapter 14, Customizing LibreOffice, in the Getting Started guide.
- To save your color changes as a color scheme, click Save... and you will be prompted for a name.

![Figure 14: Showing or hiding text, object, and table boundaries](image)

Accessibility options

Accessibility options include whether to allow animated graphics or text, how long help tips remain visible, some options for high contrast display, and a way to change the font for the user interface of the LibreOffice program.

Accessibility support relies on the Java Runtime Environment for communication with assistive technology tools. The Support assistive technology tools option is not shown on all LibreOffice installations. See Assistive Tools in LibreOffice in the Help for other requirements and information.

Select or deselect the options as required.
Advanced options

Java options
If you install or update a Java Runtime Environment (JRE) after you install LibreOffice, or if you have more than one JRE installed on your computer, you can use the LibreOffice – Advanced options page to choose the JRE for LibreOffice to use.

Optional (unstable) options

Enable experimental features
Selecting this option enables features that are not yet complete or contain known bugs. The list of these features is different version by version.

Enable macro recording (limited)
This option enables macro recording, with some limitations. Opening a window, switching between windows, and recording in a different window to that in which the recording began, is not supported. Only actions relating to document contents are recordable, so changes in Options or customizing menus are not supported.

Expert Configuration button
Permits detailed changes to the LibreOffice configuration. Most users will have no need to use this.

Choosing options for loading and saving documents
You can set the Load/Save options to suit the way you work.
If the Options dialog is not already open, click Tools > Options. Click the marker (+ or triangle) to the left of Load/Save.

General
Most of the choices on the Load/Save – General page are familiar to users of other office suites. Some items of interest are described below.
Load user-specific settings with the document
A LibreOffice document contains certain settings which are read from the user’s system. When you save a document, these settings are saved with it.

Select this option so that when a document loads, it ignores the stored settings in favor of the settings on your computer.

Even if you do not select this option, some settings are taken from your LibreOffice installation:
- Settings available in File > Print > Options
- Name of Fax
- Spacing options for paragraphs before text tables
- Information about automatic updating for links, field functions and charts
- Information about working with Asian character formats.

The following settings are always loaded with a document, whether or not this option is marked:
- Data source linked to the document and its view.

If you deselect this option, the user’s personal settings do not overrule the settings in the document. For example, your choice (in the options for LibreOffice Writer) of how to update links is affected by the Load user-specific settings option.

Load printer settings with the document
If enabled, the printer settings will be loaded with the document. This can cause a document to be printed on a distant printer (perhaps in an office setting), if you do not change the printer manually in the Print dialog. If disabled, your standard printer will be used to print this document. The current printer settings will be stored with the document whether or not this option is selected.

Save AutoRecovery information every __ Minutes
Choose whether to enable AutoRecovery and how often to save the information used by the AutoRecovery process.
AutoRecovery in LibreOffice saves the information needed to restore all open documents in case of a crash. If you have this option set, recovering your document after a system crash will be easier.

Automatically save the document too
Specifies that LibreOffice saves all open documents when saving auto recovery information. Uses the same time interval as AutoRecovery does.

Edit document properties before saving
If this option is selected, the document's Properties dialog pops up to prompt you to enter relevant information the first time you save a new document (or whenever you use Save As).

Always create backup copy
Saves the previous version of a document as a backup copy whenever you save a document. Every time LibreOffice creates a backup copy, the previous backup copy is replaced. The backup copy gets the extension BAK. Authors whose work may be very lengthy should always consider using this option.

Save URLs relative to file system / to internet
Use these options to select the default for relative addressing of URLs in the file system and on the Internet. Relative addressing is only possible if the source document and the referenced document are both on the same drive.

A relative address always starts from the directory in which the current document is located. In contrast, absolute addressing always starts from a root directory. The following table demonstrates the difference in syntax between relative and absolute referencing:

<table>
<thead>
<tr>
<th>Examples</th>
<th>File system</th>
<th>Internet</th>
</tr>
</thead>
<tbody>
<tr>
<td>relative</td>
<td>../../images/img.jpg</td>
<td>../../images/img.jpg</td>
</tr>
<tr>
<td>absolute</td>
<td>file:///c/work/images/img.jpg</td>
<td><a href="http://myserver.com/work/images/img.jpg">http://myserver.com/work/images/img.jpg</a></td>
</tr>
</tbody>
</table>

If you choose to save relatively, the references to embedded graphics or other objects in your document will be saved relative to the location in the file system. In this case, it does not matter where the referenced directory structure is recorded. The files will be found regardless of location, as long as the reference remains on the same drive or volume. This is important if you want to make the document available to other computers that may have a completely different directory structure, drive or volume names. It is also recommended to save relatively if you want to create a directory structure on an Internet server.

If you prefer absolute saving, all references to other files will also be defined as absolute, based on the respective drive, volume or root directory. The advantage is that the document containing the references can be moved to other directories or folders, and the references remain valid.

Default file format and ODF settings
ODF format version. LibreOffice by default saves documents in Open Document Format (ODF) version 1.2 Extended. While this allows for improved functionality, there may be backwards compatibility issues. When a file saved in ODF 1.2 is opened in an earlier version of LibreOffice (using ODF 1.0/1.1), some of the advanced features may be lost. Two notable examples are cross-references to headings and the formatting of numbered lists. If you plan to share documents with people who are still using older versions of LibreOffice, you may wish to save the document using ODF version 1.0/1.1, even though some information will be lost.

Document type: The default is Text document. If you routinely share documents with users of Microsoft Word, you might want to change the Always save as attribute for text documents to one of the Word formats. Current versions of Microsoft Word can open ODF files, so this may no longer be needed.
Caution
If you need to save in Microsoft Word format, it is good practice to save in LibreOffice (OpenDocument) format (ODT) first and then do a Save As from your finished document to a Microsoft Word format. For best results, save to the DOC and not the DOCX format. Saving first in ODT format gives you the option to redo the document if the recipient of your document experiences trouble with the Microsoft format.

VBA Properties
On the Load/Save – VBA Properties page, you can choose whether to keep any macros in Microsoft Office documents that are opened in LibreOffice. These macros are disabled in LibreOffice.

![Figure 17: Choosing Load/Save VBA Properties](image)

If you choose **Load Basic code**, you can edit the macros in LibreOffice. The changed code is saved in an LibreOffice document but is not retained if you save into a Microsoft Office format.

If you are importing a Microsoft Word or Excel file containing VBA code, you can select the option **Executable code**. Whereas normally the code is preserved but rendered inactive, with this option the code is ready to be executed.

If you choose **Save original Basic code**, the macros are retained unchanged if you save the file into Microsoft Office format.

**Save original Basic code** takes precedence over **Load Basic code**. If both options are selected and you edit the disabled code in LibreOffice, the original Microsoft Basic code will be saved when saving in a Microsoft Office format.

To remove any possible macro viruses from the Microsoft Office document, deselect **Save original Basic code**. The document will be saved without the Microsoft Basic code.

Microsoft Office
On the Load/Save – Microsoft Office page, you can choose what to do when importing and exporting Microsoft Office OLE objects (linked or embedded objects or documents such as spreadsheets or equations).

Select the [L] check boxes to convert Microsoft OLE objects into the corresponding LibreOffice OLE objects when a Microsoft document is loaded into LibreOffice (mnemonic: “L” for “load”).
Select the [S] check boxes to convert LibreOffice OLE objects into the corresponding Microsoft OLE objects when a document is saved in a Microsoft format (mnemonic: “S” for “save”).

![Embedded objects](image1)

*Figure 18: Choosing Load/Save Microsoft Office options*

**HTML compatibility**

Choices made on the **Load/Save – HTML Compatibility** page (not shown) affect HTML pages imported into LibreOffice and those exported from LibreOffice. See *HTML documents; importing/exporting* in the Help, and the *Getting Started* book, for more information.

**Choosing options for Writer**

Settings chosen on the pages in the LibreOffice Writer section of the Options dialog determine how your Writer documents look and behave while you are working on them. If the Options dialog is not already open, click **Tools > Options**.

Click the marker (+ or triangle) by LibreOffice Writer on the left-hand side of the dialog. A list of pages drops down (see Figure 19).

![Options - LibreOffice Writer - General](image2)

*Figure 19: LibreOffice Writer options*
General options
The choices on the LibreOffice Writer – General page affect the updating of links and fields, the units used for rulers and other measurements, and the default tab stop positions.

Update links when loading
Depending on your work patterns, you may not want links to be updated when you load a document. For example, if your file links to other files on a network, you won’t want those links to try to update when you are not connected to the network.

Update fields and charts automatically
You may not want fields or charts to update automatically when you are working, because that slows down performance.

Settings – Tab stops
The Tab stops setting specifies the distance the cursor travels for each press of the Tab key. This setting is also used for the indent distance applied by the Increase Indent and Decrease Indent buttons on the Formatting Toolbar, which affect the indentation of entire paragraphs.

Using the default tab stops to space out or indent material on a page is not recommended. If you use the default tab interval and then send the document to someone who uses a different default tab interval, then your tabbed material will be displayed using the other person’s default tab settings. In addition, any changes to the default tab stops will change the existing default tab stops in any document you open afterward, as well as tab stops you insert after making the change.

To avoid these unwanted changes, define your own tabs in paragraph styles or individual paragraphs (see “Defining your own tab stops and indents” in Chapter 3, Working with Text).

Word Count
Allows extra word boundary characters. This feature overrides long dash (—) and short dash (–) to be word boundary characters for the purposes of counting words, and allows the user to specify additional word boundary characters.
View options

Two pages of options set the defaults for viewing Writer documents: View (described here) and Formatting Aids (described below).

Enabling the Guides helps you to precisely position a drawing object on a page by providing horizontal and vertical parallel lines the height and width of the object, across the complete working area of the screen as the object is moved.

If the remaining items on the LibreOffice Writer – View page are not self-explanatory, you can easily test their effects in a blank document.

This is a good page to check if, for example, you cannot see graphics on the screen or you see field codes instead of the text or numbers you are expecting.

![Guides and Display options]

Figure 21: Choosing View options for Writer

Formatting Aids options

The display of symbols such as paragraph ends and tabs helps you when writing, editing, and doing page layout. For example, you might want to know if any blank paragraphs or tabs are included or if any tables or graphics are too wide and intrude into the margins of the page. Selections here determine which symbols show when you select the Nonprinting Characters button in the Standard Toolbar.

On the LibreOffice Writer – Formatting Aids page, select the required options.

![Display and Layout assistance options]

Figure 22: Choosing Formatting Aids options
Direct cursor lets you enter text, images, tables, frames, and other objects in any blank area in your document. Writer inserts blank paragraphs and tabs to position the text or objects. This feature is incompatible with rigorous use of styles and can lead to many formatting oddities, so it should be avoided by professional writers.

Grid options

Specifying snap to grid can be very helpful when you are trying to align several objects such as graphics or tables.

On the LibreOffice Writer – Grid page, you can choose whether to enable this feature and what grid intervals to use. If the grid intervals (subdivisions) are too large, you may find that you do not have enough control in placing the objects.

![Grid options](image)

Figure 23: Choosing Grid options

Basic Fonts (Western) options

The default fonts specified on the LibreOffice Writer – Basic Fonts (Western) page (Figure 24) apply to both Writer documents and HTML (Web) documents. They define the basic fonts for the predefined templates. If you want to change the defaults, do so on this page. If you have Asian language support enabled (see Figure 32 on page 30) there will be a page for Basic Fonts (Asian) as well.

You can also modify specific templates (as described in Chapter 10) or choose other fonts for use in specific documents, either by applying direct formatting or by defining and applying styles in those templates and documents.

When choosing fonts on this page, you are not limited to single fonts or to the ones shown in the drop-down list. You can specify a “font family” as a comma-separated set of fonts that includes those suitable for Windows, Macintosh, Linux, and other operating systems. These choices are particularly important in HTML documents.

If the document is viewed on a system that does not have the first font specified, it will use one of the other fonts if that one is available. Otherwise, it will substitute a font that is available on the system.

Type the list of fonts, separated by commas, in the boxes. If you want these defaults to apply to the current document only, select that option. The Default button resets the values on this page to the defaults installed with LibreOffice.
Print options

On the LibreOffice Writer – Print page, you can choose which items are printed with the document by default. These options are in addition to those on the LibreOffice – Print page (Figure 8).

Some considerations:

• When you are working on drafts and you want to save printer ink or toner, you might want to deselect some of the items in the Contents section.

• The Print text in black selection causes color text (but not graphics) to print as black on a color printer; on a black-and-white printer, this option causes color text to print as solid black instead of shades of gray (dithered).

• The Print text in black option has a different effect than the Convert colors to grayscale option on the Options – LibreOffice – Print page (Figure 5), which prints all graphics as grayscale on color printers. (On black-and-white printers, color in graphics normally prints as grayscale.)
• If you are printing double-sided on a non-duplexing printer, you might choose to print only left or right pages, then turn the stack over and print the other pages.

Tip
You can override any of these defaults when printing a document. Click File > Print, then use the options on the various pages of the Print dialog.

Table options
On the LibreOffice Writer – Table page, you can specify the default behavior of tables.

Some considerations:
• If most of your tables will require borders or headings, select those options. If most of your tables are used for page layout, deselect borders and headings.
• **Number recognition** can be very useful if most of your tables contain numerical data; Writer will recognize dates or currency, for example, and format the numbers appropriately. However, if you want the numbers to remain as ordinary text, this feature can be quite irritating, so you will want to deselect it.
• The **Keyboard handling** section specifies the distances that cells move when you use keyboard shortcuts to move them and the size of rows and columns inserted using keyboard shortcuts.
• The choices in the **Behavior of rows/columns** section determine the effects that changes to rows or columns have on adjacent rows or columns and the entire table. You might need to test these selections to fully understand the effects.

Changes options
If you plan to use the change-tracking feature of Writer, use the LibreOffice Writer – Changes page to choose the way inserted and deleted material is marked, whether and how attribute changes are marked, and whether and how change bars are marked in the margins.
Compatibility options

Do you need to import Microsoft Word documents into LibreOffice Writer? If so, you might want to select some or all of the settings on the LibreOffice Writer – Compatibility page (Figure 28). If you are not sure about the effects of these settings, leave them as the defaults provided by LibreOffice. For information about the settings not described below, see the Help. All settings selected will apply to the current document.

Use printer metrics for document formatting
If this option is selected, the printer specified for the document determines how the document is formatted for viewing on screen. The line breaks and paragraph breaks you see on screen match those that apply when the document is printed on that printer.

This setting can be useful when several people are reviewing a document that will eventually be printed on a specific printer or when the document is exported to PDF (a process that uses “Adobe PDF” as the printer).
If this option is not selected, a printer-independent layout will be used for screen display and printing.

**Add spacing between paragraphs and tables (in current document)**

In LibreOffice Writer, paragraph spacing is defined differently than it is in MS Word documents. If you have defined spacing between two paragraphs or tables, spacing is also added in the corresponding MS Word documents.

If this option is selected, Microsoft Word-compatible spacing is added between paragraphs and tables in LibreOffice Writer documents.

**Add paragraph and table spacing at tops of pages (in current document)**

You can define paragraphs to have space appear before (above) them. If this option is selected, any space above a paragraph will also appear if the paragraph is at the beginning of a page or column, if the paragraph is positioned on the first page of the document, or after a manual page break.

If you import a Microsoft Word document, the spaces are automatically added during the conversion.

**Add paragraph and table spacing at bottom of table cells**

Specifies that the bottom spacing is added to a paragraph, even when it is the last paragraph in a table cell.

**Use as Default**

Click this button to use the current settings on this page as the default in LibreOffice.

### AutoCaption options

Do you want LibreOffice to automatically insert captions for tables, pictures, frames, and OLE objects that have been inserted in a Writer document?

| Note | You may not always want captions for every table, for example, if you use tables for layout as well as for tables of data. You can always add captions to individual tables, graphics, or other objects (right-click > Caption). |

If you do want automatic captions on one or more object types, use the options on the **LibreOffice Writer > AutoCaption** page. Enable the check box next to an object you want to be automatically captioned (**LibreOffice Writer Picture** in the example shown). With the item highlighted, specify the characteristics of the caption.

The supplied categories for captions are **Drawing**, **Illustration**, **Table**, and **Text**. However, you are not limited to the supplied categories. If you want to use another name (for example, **Figure**) for the caption label, type the required term in the box. In the example shown, **Figure** has been added to the list.

Additional information about numbering captions by chapter, character styles, frame styles, and other items on the **AutoCaption** page, is given in later chapters in the Writer Guide.
Mail Merge E-mail options

You can produce form letters using Writer and then use the mail merge function to personalize those letters and send them to a number of addresses taken from a data source, such as an address book. Mail merged documents can be printed and mailed, or sent by e-mail. (See Chapter 11, Using Mail Merge, for details.)

Use the **LibreOffice Writer – Mail Merge E-mail** page to set up the user and server information for sending form letters by e-mail. If you are not sure what information to put in any of the fields, consult your e-mail program or your Internet service provider.

---

**Figure 29:** Setting up a new category for automatic captions on graphics

**Figure 30:** Specifying settings for use when e-mailing mail-merged form letters
Choosing options for HTML documents

You can configure LibreOffice to treat HTML documents in Writer differently than regular documents.

1) If the Options dialog is not already open, click **Tools > Options**.
2) Click the expansion symbol (+ sign or triangle) by **LibreOffice Writer/Web** on the left-hand side of the Options dialog. A list of pages drops down.

Here you can customize settings related to printing, formatting aids, view options, table defaults, the grid, and a default background for HTML documents you’re working with in Writer.

The pages for View, Formatting Aids, Grid, Print, and Table are similar to the pages described above under LibreOffice Writer, but are for Writer/Web HTML pages instead.

The Background page allows you to specify the default background color for documents in Writer/Web. The background is valid for both new HTML documents and for those that you load, as long as these have not defined their own background.

Choosing language settings

You may need to do several things to set the language settings to what you want:

- Install the required dictionaries
- Change some locale and language settings
- Choose spelling options

Install the required dictionaries

LibreOffice automatically installs several dictionaries with the program. To add other dictionaries, be sure you are connected to the Internet, and then use **Tools > Language > More Dictionaries Online**. LibreOffice will open your default web browser to a page containing links to additional dictionaries that you can install. Follow the prompts to select and install the ones you want.

Change some locale and language settings

You can change some details of the locale and language settings that LibreOffice uses for all documents or for specific documents.

In the Options dialog, choose **Language Settings > Languages**. Click the expansion symbol (+ sign or triangle). The exact list shown depends on the **Enhanced language support** settings (see Figure 32).

![Figure 31: LibreOffice language options, with Asian language options enabled on the right side](image-url)
On the right-hand side of the **Language Settings – Languages** page (Figure 32), change the **User interface, Locale setting, Default currency**, and the settings under **Default languages for documents** as required. In the example, English (USA) has been chosen for all the appropriate settings.

If you want the language setting to apply to the current document only, instead of being the default for all new documents, select **For the current document only**.

If necessary, select the options to enable support for Asian languages (Chinese, Japanese, Korean) and support for CTL (complex text layout) languages such as Hindi, Thai, Hebrew, and Arabic. If you choose either of these options, the next time you open the Options dialog, you will see some extra pages under **Language Settings**, as shown in the right side of Figure 31. These pages (Searching in Japanese, Asian Layout, and Complex Text Layout) are not discussed here.

![Language Settings](image)

*Figure 32: Choosing language options*

**Choose spelling options**

To choose the options for checking spelling, choose **Language Settings > Writing Aids**. In the **Options** section of the page, choose the settings that are useful for you.

Some considerations:

- If you do not want spelling checked while you type, deselect **Check spelling as you type**. This option can also be deselected using the **AutoSpellcheck** button on the Standard Toolbar.
- If you want grammar to be checked as you type, you must have **Check spelling as you type** enabled too.
- If you use a custom dictionary that includes words in all uppercase and words with numbers (for example, AS/400), select **Check uppercase words** and **Check words with numbers**.
- **Check special regions** includes headers, footers, frames, and tables when checking spelling.

Here you can also check which of the user-defined (custom) dictionaries are active, or you can add or remove user installed dictionaries by clicking the **New** or **Delete** buttons. Dictionaries installed by the system cannot be deleted.
English sentence checking

On the **Language Settings > English sentence checking** page, you can choose which items are checked for, reported to you, or converted automatically. This menu is also found in the English dictionaries extension installed by default by LibreOffice. Select **Tools > Extension Manager**, select the English spelling dictionaries and click the **Options** button to reveal the menu. Select which of the optional features you wish to check.

After selecting the additional grammar checks, you must restart LibreOffice, or reload the document, for them to take effect.

**Grammar checking**

**Possible mistakes**
Checks for things such as; *with it's, he don't, this things* and so on.

**Capitalization**
Checks for the capitalization of sentences. The sentence boundary detection depends on abbreviations.
Word duplication
Checks for all word duplication, increased from the default number of words checked.

Parentheses
Checks for pairs of parentheses and quotation marks.

**Punctuation**

Word spacing
This option is selected by default. It checks for single spaces between words, indicating instances of double or triple spaces, but not of more than that.

Sentence spacing
Checks for single spacing between sentences, indicating when one or two extra spaces are found.

More spaces
Checks word and sentence spacing for more than two extra spaces.

Em dash; En dash
These options force a non-spaced em dash to replace a spaced en dash, or force a spaced en dash to replace a non-spaced em dash, respectively.

Quotation marks
Checks for correct typographical double quotation marks.

Multiplication sign
This option is selected by default. It replaces an 'x' used as a multiplication symbol with the correct typographical symbol.

Apostrophe
Replaces an apostrophe with the correct typographical character.

Ellipsis
Replaces three consecutive periods (full stops) with the correct typographical symbol.

Minus sign
Replaces a hyphen with the correct minus typographical character.

**Others**

Convert to metric; Convert to non-metric
Converts quantities in a given unit to quantities in the other type of unit: metric to imperial or imperial to metric.

Thousands separation of large numbers
Converts a number with five or more significant digits to a common format, that is one which uses the comma as a thousands separator, or to the ISO format which uses a narrow space as a separator.
Controlling Writer’s AutoCorrect functions

Some people find some or all of the items in Writer’s AutoCorrect feature annoying because Writer changes what you type when you do not want it changed. Many people find some of the AutoCorrect functions quite helpful; if you do, then select the relevant options. But if you find unexplained changes appearing in your document, this is a good place to look to find the cause.

To open the AutoCorrect dialog, choose **Tools > AutoCorrect Options**. (You need to have a document open for this menu item to appear.) In Writer, this dialog has five tabs. Many of the options are described in Chapter 3, Working with Text, in this book.

![AutoCorrect dialog in Writer](image)

*Figure 35: The AutoCorrect dialog in Writer*