Chapter 4
Formatting Pages
Using Page Styles, Tables, Frames, Columns, and Sections
Copyright

This document is Copyright © 2010–2014 by the LibreOffice Documentation Team. Contributors are listed below. You may distribute it and/or modify it under the terms of either the GNU General Public License (http://www.gnu.org/licenses/gpl.html), version 3 or later, or the Creative Commons Attribution License (http://creativecommons.org/licenses/by/4.0/), version 4.0 or later.

All trademarks within this guide belong to their legitimate owners.

Contributors

John A Smith                Jean Hollis Weber
Ron Faile Jr.               Jamie Eby

Feedback

Please direct any comments or suggestions about this document to the Documentation Team’s mailing list: documentation@global.libreoffice.org

Note: Everything you send to a mailing list, including your email address and any other personal information that is written in the message, is publicly archived and cannot be deleted.

Acknowledgments

This chapter is adapted and updated from Chapter 4 of the OpenOffice.org 3.3 Writer Guide. The contributors to that chapter are:

Agnes Belzunce                Ken Byars                Daniel Carrera
Peter Hillier-Brook           Lou Iorio                Sigrid Kronenberger
Peter Kupfer                  Ian Laurensen           Iain Roberts
Gary Schnabl                 Janet Swisher            Jean Hollis Weber
Claire Wood                   Michele Zarri

Publication date and software version

Published 21 May 2014. Based on LibreOffice 4.2.

Note for Mac users

Some keystrokes and menu items are different on a Mac from those used in Windows and Linux. The table below gives some common substitutions for the instructions in this chapter. For a more detailed list, see the application Help.

<table>
<thead>
<tr>
<th>Windows or Linux</th>
<th>Mac equivalent</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tools &gt; Options menu selection</td>
<td>LibreOffice &gt; Preferences</td>
<td>Access setup options</td>
</tr>
<tr>
<td>Right-click</td>
<td>Control+click and/or right-click depending on computer system</td>
<td>Opens a context menu</td>
</tr>
<tr>
<td>Ctrl (Control)</td>
<td>⌘ (Command)</td>
<td>Used with other keys</td>
</tr>
<tr>
<td>F5</td>
<td>Shift+⌘+F5</td>
<td>Opens the Navigator</td>
</tr>
<tr>
<td>F11</td>
<td>⌘+T</td>
<td>Opens the Styles and Formatting window</td>
</tr>
</tbody>
</table>

Documentation for LibreOffice is available at http://www.libreoffice.org/get-help/documentation
Contents

Copyright ................................................................. 2
Contributors ............................................................. 2
Feedback ................................................................. 2
Acknowledgments ..................................................... 2
Publication date and software version .......................... 2

Note for Mac users .................................................. 2

Introduction .............................................................. 5

Choosing a layout method ....................................... 5

Setting up basic page layout using styles ................. 7
Inserting a page break without switching the style ....... 7
Defining a different first page for a document .......... 8
Changing page orientation within a document .......... 8
Setting up a landscape page style ......................... 9
Inserting a landscape page into a portrait document .. 10
Adding title pages ................................................... 10

Changing page margins .......................................... 11

Using columns to define the page layout ................. 12
Defining the columns on a page ............................. 12
Specifying the number of columns ....................... 13
Formatting column width and spacing ................. 13
Formatting separator lines .................................. 13
Reverting to a single-column layout .................... 14
Changing the number of columns for existing text ... 14
Distributing text across columns ....................... 15

Using frames for page layout ................................ 15
Creating frames .................................................... 16
Moving, resizing, and changing frame attributes .... 17
Anchoring frames .................................................. 18
Linking frames ...................................................... 19

Using tables for page layout .................................. 21
Example: Creating sideheads using tables ............. 21

Using sections for page layout ................................. 23
Creating sections .................................................. 23
Naming sections .................................................... 24
Linking sections ................................................... 24
Write-protecting sections ..................................... 25
Password-protecting sections .............................. 25
Hiding sections ..................................................... 25
Formatting a section into columns ....................... 26
Indenting the section from margins ..................... 26
Changing the background of the section ............... 27
Customizing footnotes and endnotes in a section .... 27
Customizing footnotes .......................................... 27

Formatting Pages
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Customizing endnotes</td>
<td>28</td>
</tr>
<tr>
<td>Saving a new section</td>
<td>28</td>
</tr>
<tr>
<td>Editing and deleting sections</td>
<td>28</td>
</tr>
<tr>
<td>Editing section attributes</td>
<td>28</td>
</tr>
<tr>
<td>Editing the format of a section</td>
<td>29</td>
</tr>
<tr>
<td>Deleting sections</td>
<td>29</td>
</tr>
<tr>
<td>Updating links</td>
<td>29</td>
</tr>
<tr>
<td>Updating links automatically</td>
<td>29</td>
</tr>
<tr>
<td>Updating links manually</td>
<td>30</td>
</tr>
<tr>
<td>Creating headers and footers</td>
<td>31</td>
</tr>
<tr>
<td>Formatting headers and footers</td>
<td>32</td>
</tr>
<tr>
<td>Portrait headers on landscape pages</td>
<td>32</td>
</tr>
<tr>
<td>Numbering pages</td>
<td>35</td>
</tr>
<tr>
<td>Preliminaries: fields</td>
<td>35</td>
</tr>
<tr>
<td>Preliminaries: insert and format a header</td>
<td>36</td>
</tr>
<tr>
<td>Simple page numbering</td>
<td>36</td>
</tr>
<tr>
<td>Combining header text and page number</td>
<td>36</td>
</tr>
<tr>
<td>Changing the number format</td>
<td>37</td>
</tr>
<tr>
<td>Numbering the first page something other than 1</td>
<td>37</td>
</tr>
<tr>
<td>Numbering pages by chapter</td>
<td>38</td>
</tr>
<tr>
<td>Restarting page numbering</td>
<td>39</td>
</tr>
<tr>
<td>Example: Restart page numbering: a preface</td>
<td>40</td>
</tr>
<tr>
<td>Problems with restarting page numbering</td>
<td>41</td>
</tr>
<tr>
<td>Solving the page count problem</td>
<td>41</td>
</tr>
<tr>
<td>Defining borders and backgrounds</td>
<td>43</td>
</tr>
<tr>
<td>Adding a border</td>
<td>43</td>
</tr>
<tr>
<td>Adding color to the background</td>
<td>44</td>
</tr>
<tr>
<td>Adding a gradient to the background</td>
<td>44</td>
</tr>
<tr>
<td>Adding a graphic to the background</td>
<td>44</td>
</tr>
<tr>
<td>Deleting color, gradient or graphics from the background</td>
<td>46</td>
</tr>
</tbody>
</table>
**Introduction**

Writer provides several ways for you to control page layouts:

- Page styles
- Columns
- Frames
- Tables
- Sections

This chapter describes these methods and some associated functions:

- Headers and footers
- Numbering pages
- Changing page margins

---

**Tip**  
Page layout is usually easier if you select the options to show text, object, table, and section boundaries in **Tools > Options > LibreOffice > Appearance** and the options for paragraph ends, tabs, breaks, and other items in **Tools > Options > LibreOffice Writer > Formatting Aids**.

---

**Choosing a layout method**

The best layout method depends on what the final document should look like and what sort of information will be in the document. Here are some examples. Do not worry if all this does not mean much to you now. The techniques mentioned are all described in this chapter.

For a book similar to this user guide with one column of text, some figures without text beside them, and some other figures with descriptive text, use page styles for basic layout, and use tables to place figures beside descriptive text, where necessary.
Use page styles (with two columns) for an index or other document with two columns of text where the text continues from the left-hand column to the right-hand column and then to the next page, all in sequence (also known as *snaking columns* of text). If the title of the document (on the first page) is full-page width, put it in a single-column section.

For a newsletter with a complex layout, two or three columns on the page, and some articles that continue from one page to some place several pages later, use page styles for basic layout. Place articles in linked frames and anchor graphics to fixed positions on the page, if necessary.

For a document with terms and translations to appear side-by-side in what appear to be columns, use a table to keep items lined up so you can type in both "columns".
Setting up basic page layout using styles

In Writer, page styles define the basic layout of all pages, including page size, margins, the placement of headers and footers, borders and backgrounds, number of columns, and so on.

Writer comes with several page styles, which you can build on or modify, and you can define new (custom) page styles. You can have one or many page styles in a single document.

Note

All pages in a Writer document are based on styles. If you do not specify a page style, Writer uses the Default page style.

To change the layout of individual pages, either define a new page style or use one of the techniques (sections, frames, or tables) described later in this chapter.

This chapter describes some uses of page styles. Some other uses are discussed in Chapter 6, Introduction to Styles. The Page Style dialog is covered in detail in Chapter 7, Working with Styles.

Tip

Any modifications of page styles, including the Default page style, apply only to the document you are working on. If you want the changes to be the default for all documents, you need to put the changes into a template and make that template the default template. See Chapter 10, Working with Templates, for details.

Inserting a page break without switching the style

In many documents (for example, a multi-page report), you may want the text to flow from one page to the next as you add or delete information. Writer does this automatically, unless you override the text flow using one of the techniques described earlier.

If you do want a page break in a particular place, for example, to put a heading at the top of a new page, here is how to do it:

1) Position the cursor at the point you want to start the next page. Select Insert > Manual Break.
2) In the Type section, Page break is preselected, and Style is set at [None].
3) Click OK to position the paragraph at the start of the next page.

Figure 1: Inserting a manual page break
You can also insert a page break as follows;

1) Position the cursor in the paragraph you want to be at the start of the next page. Right-click and choose Paragraph in the pop-up menu.

2) On the Text Flow page of the Paragraph dialog, in the Breaks section, select Insert. Do not select With Page Style.

3) Click OK to position the paragraph at the start of the next page.

---

Defining a different first page for a document

Many documents, such as letters and reports, have a first page that is different from the other pages in the document. For example, the first page of a letterhead typically has a different header, as shown in Figure 2, or the first page of a report might have no header or footer, while the other pages do. This is simple to achieve with Writer.

Using the Default (or any other) page style for your document, you can add a header/footer as you wish to the first page by deselecting the Same content on first page option on the header/footer pages in the Page Style dialog, and then adding the header/footer. You can then add a different header/footer to the other pages of the document.

Figure 2: Letterhead with different headers for first and following pages

Changing page orientation within a document

A document can contain pages in more than one orientation. A common scenario is to have a landscape page in the middle of a document, whereas the other pages are in a portrait orientation. Here are the steps to achieve it.
Setting up a landscape page style

1) If you wish to keep the margins the same as on other pages, then note the margin settings of the current page style. (You can find the margin settings on the Page Style dialog, by selecting the Page tab as shown in Figure 4.)

2) In the Styles and Formatting window, right-click on Landscape in the list of page styles and choose Modify from the pop-up menu (Styles and Formatting can also be accessed from the Sidebar, View > Sidebar).

3) On the Organizer page of the Page Style dialog (Figure 3), make sure the Next Style property is set to Landscape (to allow for having more than one sequential landscape page).

4) On the Page page of the Page Style dialog (Figure 4), make sure the Orientation is set to Landscape. Change the margins so that they correspond with the margins of the portrait page. That is, the portrait top margin becomes the landscape right margin, and so on.

5) Click OK to save the changes.
**Inserting a landscape page into a portrait document**

Now that you have defined the *Landscape* page style, here is how to apply it.

1) Position the cursor in the paragraph or table at the start of the page that is to be set to landscape. Right-click and choose **Paragraph** or **Table**, respectively, in the pop-up menu.

2) On the **Text Flow** page of the Paragraph dialog (Figure 5) or the Table Format dialog (Figure 6), select **Insert** (or **Break** for a table) and **With Page Style**. Set the **Page Style** property to *Landscape*. Click **OK** to close the dialog and to apply the new page style.

![Figure 5: Specifying a page break before a paragraph](image)

![Figure 6: Specifying a page break before a table](image)

3) Position the cursor in the paragraph or table where the page is to return to portrait orientation and change the paragraph properties or table properties so that **With Page Style** is the portrait page style that was used before the *Landscape* page style.

4) Click **OK** to return to the previous portrait page style.

**Tip**

If you need the headers or footers on the landscape pages to be in portrait orientation, see “Portrait headers on landscape pages” on page 32.

**Adding title pages**

Writer provides a fast and convenient way to add one or more title pages to a document and optionally to restart the page number at 1 for the body of the document.

To begin, choose **Format > Title Page** from the Menu Bar. On the Title Page dialog (Figure 7), you can make a variety of choices:

- Convert existing pages to title pages, or insert new title pages
- How many pages to convert or insert
• Where those pages are located
• If and where to restart page numbering, and what number to start with
• What page style to use for the title page

Using this technique, you can insert several “title pages” at different points in your document, for example to add decorative pages between chapters as well as title, copyright, and other pages at the beginning of a book.

Figure 7: Adding title pages to a document

Changing page margins

You can change page margins in three ways:
• Using the page rulers—quick and easy, but does not have fine control.
• Using the Page Style dialog—can specify margins to two (fractional) decimal places.
• Using the Page panel of the Properties deck in the Sidebar.

Note
If you change the margins using the rulers or the Sidebar, the new margins affect the page style and will be shown in the Page Style dialog the next time you open it.

To change margins using the rulers:
  1) The shaded sections of the rulers are the margins (see Figure 8). Put the mouse cursor over the line between the gray and white sections. The pointer turns into a double-headed arrow and displays the current setting in a tool-tip.
  2) Hold down the left mouse button and drag the mouse to move the margin.

Caution
The small arrows on the ruler are used for indenting paragraphs. They are often in the same place as the page margins, so you need to be careful to move the margin marker, not the arrows. The double-headed arrows shown in Figure 8 are actual mouse cursors placed in the correct position.
To change margins using the Page Style dialog (Figure 4):
1) Right-click anywhere on the page and select Page from the context menu.
2) On the Page page of the dialog, type the required distances in the Margins boxes.

To change margins using the Page panel of the Properties deck of the Sidebar:
1) On the open Sidebar (View > Sidebar) select the Properties tab.
2) Open the Page panel if is not open by clicking the plus (+) symbol in the panel title
3) Click the Margin button to open the sub-panel and enter the required dimensions in the Custom size boxes (clicking the More Options button will open the Page Style dialog).

Using columns to define the page layout

You can use columns for page layout in the following ways:
- By defining the number of columns and their layout on a page, using page styles.
- By changing the number of columns for existing text.

Defining the columns on a page

It is a good idea to define your basic page style (such as Default) with the most common layout to be used in your document, either single-column or multiple-column. You can then either define extra page styles for pages with different numbers of columns or use sections (described in “Using sections for page layout” starting on page 23) for pages or parts of pages with different numbers of columns.

To define the number of columns on a page:
1) Choose Format > Columns to go to the Columns dialog (see Figure 9), or go to the Columns page of the Page Style dialog, or click the More Options button on the Page panel of the Properties deck of the Sidebar.
2) In the Settings section, choose the number of columns and specify any spacing between the columns and whether you want a vertical separator line to appear between the columns. You can use one of Writer’s predefined column layouts, or you can create a customized column layout. The preview pane, located to the right of the Settings section, shows how the column layout will look.
   Notice the Apply to box in the dialog of Figure 9. In this instance, the changes are being applied to the Default page style.
3) Click OK to save the changes.
Specifying the number of columns
In the Settings section, enter the number of columns into the Columns selection box, or select one of the column layout icons.

Formatting column width and spacing
Select the AutoWidth option in the Width and spacing section to create columns of equal width.

To customize the width and spacing of the columns:
1) In the Width and spacing section, deselect the AutoWidth option.
2) In the Width selection boxes, enter a width for each column.
3) On the Spacing line, enter the amount of space that you want between each pair of columns.

If you specify more than three columns, use the arrow keys on the Column line to scroll among the columns.

Formatting separator lines
To display separator lines between the columns:
1) Using the Style drop-down list, select the line style from the three styles available.
2) Using the Width control, select the width of line to use, settable from 0.25pt to 9.0pt. (1 pt = 1 point = 1/12 pica = 1/72 inch = 127/360 mm = 0.3527 mm.)
3) Using the Height control, select the height of line required, as a percentage of the column height. Variable from 25% to 100%.
4) If you entered a height of less than 100%, use the Position drop-down list to select a vertical alignment for the separator lines. The vertical-positioning options are: Top, Centered, or Bottom.
5) The line color can be selected from the Color drop-down list's palette of colors.
Reverting to a single-column layout
To revert to a single-column layout for the page style, go to the Settings section and either reset the number in the Columns box to 1 or click the single-column layout icon.

Changing the number of columns for existing text
You might want some parts of a page to have one column and other parts of the page to have two or more columns. For example, you might have a page-width headline over a three-column news story.

You can create columns and then type or paste text into them, or you can select some existing text and change the number of columns for displaying it.

When you select text and change the number of columns for that text (Format > Columns), Writer turns the selected text into a section, as described in "Using sections for page layout" on page 23.

Figure 10 shows the Columns dialog for a selection. The Apply to box has Selection highlighted and an extra option (Evenly distribute contents to all columns) appears in the Settings section.

Using columns to define the page layout
14
Distributing text across columns

As you add text to the section, you will see that the text flows from one column to the next. You can distribute text across the columns in one of two ways:

**Evenly**—Writer adjusts the length of the columns to the amount of text, so that all the columns are approximately the same height. As you add or delete text, the columns readjust.

**Newspaper-style**—Writer fills the columns one at a time, beginning with the first column. The last column may be shorter than the others.

To distribute text evenly, select the **Evenly distribute contents to all columns** option in the Settings area. Deselect this option if you want to distribute text newspaper-style.

---

**Tip**

Choose **View > Nonprinting Characters** (or press **Ctrl+F10**) to display end of paragraph markers (¶). Often, unexpected behavior of columns is due to extra paragraphs that are normally invisible to the user but are taking up space.

---

**Figure 11:** (Left) Evenly distributed columns; (Right) Newspaper-style columns.

---

Using frames for page layout

Frames can be very useful when producing a newsletter or other layout-intensive documents. Frames can contain text, tables, multiple columns, pictures, and other objects.

Use frames when you need to:

- Position something in a particular place on a page, for example, a logo or a “stop press” news box in one corner of a page.
- Allow text on one page to continue on another page, somewhere more distant than the next one, by linking the content of one frame to another so that the contents flow between them as you edit the text.
- Wrap text around an object, such as a photograph.

---

Using frames for page layout 15
Because LibreOffice does not allow you to define page styles with recurring frames, consider doing some quick sketches of the basic page layouts you need, indicating the approximate positions of different frames and their purposes. Try to keep the number of different page layouts as low as possible in order to avoid chaos in your design.

Pay special attention to the positioning of frames. Many of the predefined styles default to a center alignment. Although centering all frames looks reasonably good in most cases, it is rarely the best choice.

One of the most visually effective ways to position a frame is to align its left margin with that of the paragraph above it. To achieve this effect, the frame is inserted in a blank paragraph of the same style as the paragraph above. Select Insert > Frame; in the Position section of the Type page, select From Left in the Horizontal selection box to position the frame exactly where you want it.

You also should think about the type of wrap and the spacing between the frame and text. Instead of cramming a frame close to the text, use the Wrap tab to place some white space between them.

You can format frames individually or define and apply frame styles; see Chapter 7, Working with Styles.

**Example: Using a frame to center text on a page**

Although you can center text horizontally as part of a paragraph style or by using manual formatting, those methods do not work for vertical centering. To center text vertically, you need to place the text in a frame, anchor the frame to a page or a paragraph, and then center the frame vertically on the page. See “Anchoring frames” on page 18.

### Creating frames

You can create a frame in several ways, depending on your needs.

- Choose Insert > Frame to create an empty frame. The Frame dialog (Figure 13) appears. You can click OK and come back to customize it later, or you can set the frame’s characteristics at this stage.

- Select text or a graphic, choose Insert > Frame, and click OK to create a frame containing the selection. The selected text is automatically deleted from the normal text flow and inserted into the frame, and the Frame dialog appears.

- Insert a picture or other object by selecting Insert > Image > From file or Insert > Object > [type of object] to start the process to insert a picture or object. The item inserted automatically appears in a frame, but the Frame dialog does not appear.

- Select the Insert Frame Manually button on the Insert toolbar (go to View > Toolbars > Insert to display it), select the number of frames in the drop-down menu, the mouse cursor changes to a plus (+) symbol, click and drag the mouse to draw the frame.

![Insert Frame Manually button](image)

*Figure 12: Using a button on the Insert toolbar to create a frame*
Releasing the mouse button creates the frame: an area isolated from the main document.

To add content to a frame, first deselect the frame by clicking somewhere else on the page. Then, click inside the frame to place the text cursor there. Now add content just like you would on the main page. When you are done, deselect the frame.

**Moving, resizing, and changing frame attributes**

When an object is added to Writer, it is automatically enclosed in a frame of a predetermined type. The frame sets how the object is placed on the page, as well as how it interacts with other elements in the document. You can edit the frame by modifying the frame style it uses or by using a manual override when a frame is added to the document. Frame styles are discussed in Chapter 7, Working with Styles.

To change the size or location of a frame, first select the frame, then use either the mouse or the Frame dialog (Figure 13). Using the mouse is quicker but less accurate. You might want to use the mouse for gross layout and the dialog for fine-tuning.

![Frame dialog](figure13.png)

You can re-size the frame manually by clicking on the green squares (sizing handles) and dragging to the appropriate size, or start adding content to it (the frame will re-size automatically if, for example, you add a large picture to it) or go back to the Frame dialog and set the size and other characteristics.

To change the location of the frame using the mouse, drag and drop one of the edges or put the cursor anywhere within the frame. (The I-bar cursor changes to a four-headed arrow when properly positioned for a drag-and-drop move.)

To change the size of the frame, drag one of the sizing handles. Drag a handle on one of the sides to enlarge or reduce the text frame in one dimension only; drag a corner handle to enlarge or reduce it in both dimensions.

---

*Using frames for page layout*
These resizing actions distort the proportions of the frame. Holding down the *Shift* key while dragging one of the handles makes the frame keep the same proportions.

You can open the Frame dialog at any time by selecting the frame, right-clicking, and choosing **Frame** from the context menu.

To remove the default border on a newly created frame, open the Frame dialog, go to the **Borders** page, and in the **Style** box under **Line**, select **None**. Alternatively, you can assign a borderless style to the frame; see Chapter 7, Working with Styles, for information on frame styles.

**Note**

Do not confuse a frame’s border with the text boundaries that are made visible using the View menu (by selecting **View > Text Boundaries**).

![Frame dialog](image)

**Figure 14**: Removing the border from a frame

**Anchoring frames**

Using the Frame dialog (or by right-clicking and pointing to **Anchor**), you can anchor a frame to a page, paragraph, or character, or you can anchor it as a character.

**To Page**

The frame keeps the same position in relation to the page margins. It does not move as you add or delete text. This method is useful when the frame does not need to be visually associated with a particular piece of text. It is often used when producing newsletters or other documents that are very layout-intensive. This method is also used to center text on a page.

**To Paragraph**

The frame is associated with a paragraph and moves with the paragraph. It may be placed in the margin or another location. This method is useful as an alternative to a table for placing icons beside paragraphs. It is also used to center text on a page in documents which will be used in a master document (frames anchored to pages will disappear from the master document).

**To Character**

The frame is associated with a character but is not in the text sequence. It moves with the paragraph but may be placed in the margin or another location. This method is similar to anchoring to a paragraph.
As Character
The frame is placed in the document like any other character and, therefore, affects the height of the text line and the line break. The frame moves with the paragraph as you add or delete text before the paragraph. This method is useful for adding a small icon in sequence in a sentence. It is also the best method for anchoring a graphic to an empty paragraph so it does not move around the page in unexpected ways.

Linking frames
You can link frames to each other even when they are on different pages of a document. The contents will automatically flow from one to the next. This technique is very useful when designing newsletters, where articles may need to be continued on a different page.

Note
You cannot link from a frame to more than one other frame.

To link one frame to another:
1) Select the frame to be linked from.
2) Click the Link Frames button ( ) on the Frames toolbar.
3) Click the next frame in the series (which must be empty).

When a linked frame is selected, any existing links are indicated by a faint connecting line, as shown in Figure 15. Frames can be unlinked by selecting the Unlink Frames button ( ) on the Frames toolbar.

Figure 15: Linked frames

The height of a frame that is being linked from is fixed; you can change this height manually or by using the Frame dialog, but it does not automatically adjust to the size of the contents (that is, the AutoHeight attribute is disabled). Only the last frame of a chain can adapt its height to the content.

The Options page of the Frame dialog (Figure 16) shows the names of the selected frame and any frames it is linked to or from. You can change this information here. On this page, you can also select options to protect the contents, position, and size of the frame.
On the Hyperlink page (Figure 17), you can specify the file for the hyperlink to open. This file can be on your machine, a network, or the Internet.

To open this file, you must Ctrl+click in the area between the border and the text boundary. Note that as the mouse cursor moves over any area within the frame boundary the hyperlink tooltip will be displayed, but it will only be active at the edges.

The Wrap, Borders, Background, Columns, and Macro pages of the Frame dialog are the same as those for frame styles. Refer to the Chapter 7, Working with Styles, for details.
Using tables for page layout

Writer’s tables can serve several purposes, such as holding data as you might see it in a spreadsheet, lining up material, and creating more complex page layouts. For information about using tables of data, see Chapter 9, Working with Tables.

This topic describes how to achieve some common layouts by using tables.

Example: Creating sideheads using tables

Sideheads and marginal notes are commonly used in documents from resumes to computer user guides. The main body of the text is offset to leave white space (usually on the left-hand side) in which the sideheads or notes are placed. The first paragraph is aligned beside the sidehead, as in Figure 18.

In some cases you may want to put only one or two paragraphs in the table itself and the rest of the text and graphics in ordinary paragraphs (formatted to line up with the paragraphs in the table) so that text and graphics will flow more easily from one page to another when you add or delete material.

In other cases, you might put each paragraph in a separate row of the table and allow the table to break between pages.

Figure 18: Example of a sidehead

Note

Sideheads can also be created by placing text in a frame using the Marginalia frame style, as described in Chapter 7, Working with Styles.

To create a table for use with a sidehead:

1) Place the cursor where you want the table to appear and choose Insert > Table (Ctrl+F12).
2) In the Insert Table dialog, define a one-row, two-column table with no border and no heading. Click Insert to create the table.

Figure 19: Defining a two-column borderless table with no header
3) Right-click on the table and choose **Table** from the context menu. On the **Columns** page of the Table Format dialog, make the columns the required width.

![Table Format dialog](image)

*Figure 20: Defining a two-column table to line up with text offset at 1.2 inches*

4) On the **Table** page of the Table Format dialog (Figure 21), in the **Spacing** section, make the **Above** and **Below** values the same as the **Top** and **Bottom** spacing you have defined for ordinary paragraphs of text. Click **OK** to save your settings.

**Tip**

To check the top and bottom spacing for ordinary paragraphs:

1) Position the cursor in a paragraph and press `F11` (unless the Styles and Formatting window is already open). Check that the Styles and Formatting window shows paragraph styles (top left button).
2) The current style should be highlighted. If no paragraph style is highlighted, select **All Styles** in the bottom drop-down list. Right-click on it and select **Modify** from the pop-up list.
3) Go to the **Indents & Spacing** page and look in the **Spacing** area for the values in **Above paragraph** and **Below paragraph**.

![Table Format dialog](image)

*Figure 21: Defining the space above and below a table*
You may also want to turn off number recognition so that Writer will not try to format numbers if you want them to be plain text. To turn number recognition off:

1) Right-click in the table and then click Number Format on the context menu.
2) On the Format Number dialog, make sure the Category is set to Text. Click OK.

**Tip**
If you use this table format often, you may want to save it as AutoText, as described in Chapter 3, Working with Text. Select the table (not just the contents) to assign the shortcut.

![Format Number dialog](image)

*Figure 22: Setting number format to Text*

### Using sections for page layout

A section is a block of text that has special attributes and formatting. You can use sections to:

- Write-protect text
- Hide text
- Dynamically insert the contents of another document
- Add columns, margin indents, a background color, or a background graphic to a portion of your document
- Customize the footnotes and endnotes for a portion of your document

### Creating sections

To create a section:

1) Place the cursor at the point in your document where you want to insert the new section. Or, select the text that you want to place in the new section.
2) From the Menu Bar, choose Insert > Section. The Insert Section dialog opens.
3) Choose settings for each page of the dialog as required.
4) Click Insert.

The Insert Section dialog has five tabbed pages.

- Use the Section page to set the section’s attributes.
- Use the Columns page to format the section into columns.
- Use the Indents page to set indents from the right and left margins of the section.
- Use the Background page to add color or a graphic to the section’s background.
- Use the Footnotes/Endnotes page to customize the section’s footnotes and endnotes.
At any time before closing the dialog, you can reset a tabbed page to its default settings by clicking the **Reset** button. (Note, however, that you cannot reset the **Section** page. If you wish to undo changes to the **Section** page, you must do so manually).

![Insert Section dialog](image)

**Figure 23: Inserting a section using the Insert Section dialog**

**Naming sections**

Writer automatically enters a name for the section in the name box of the **New section** list box. To change the name, select it and type over it. The name is displayed in the **Sections** category of the Navigator window. If you give your sections meaningful names, you can navigate to them more easily.

**Linking sections**

You can insert the contents of another document into the section and then have Writer update it whenever the other document is updated. This is called linking the section to the other document.

To link the section to another document, follow these steps:

1) In the **Link** section of the dialog, select the **Link** option.

![Link section](image)

**Figure 24: Linking sections**

2) Click the (...) button to the right of the **File name** field. The Insert dialog opens.
3) Find and select the document you want to insert and then click the **Insert** button. The Insert dialog closes and the name of the selected document appears in the **File name** field.

4) If you want to insert only a section of the selected document, select the desired section from the **Section** drop-down list.

### Note

The section must already exist in the selected document. You cannot create a section in the selected document at this point.

You can update links automatically or manually. See “Updating links” on page 29.

**Write-protecting sections**

To write-protect the section so that its contents cannot be edited, select the **Protect** option in the **Write protection** area.

![Write protection dialog](image)

*Figure 25: Write-protecting sections*

### Note

Write-protection protects only the section’s contents, not its attributes or format.

**Password-protecting sections**

To prevent others from editing the section’s attributes or format, additionally protect the section with a password, as follows:

1) Select the **With password** option. The Enter Password dialog opens.

2) Type a password in the **Password** field and then confirm the password by typing it again in the **Confirm** field.

3) Click **OK**. The Enter Password dialog closes. Anyone who tries to edit the section’s attributes or format will be prompted to enter the password.

![Enter Password dialog](image)

*Figure 26: Password-protecting a section*

**Hiding sections**

You can hide the section so that it will not be displayed on the screen or printed. You can also specify conditions for hiding the section. For example, you can hide the section only from certain users.

---

**Using sections for page layout**

25
Note

You cannot hide a section if it is the only content on the page or if the section is in a header, footer, footnote, endnote, frame, or table cell.

To hide a section, select the **Hide** option in the *Hide* section of the dialog.

![Figure 27: Hiding sections](image)

To hide the section only under certain conditions, enter the desired conditions in the *With Condition* field. The syntax and operators that you use to enter conditions are the same ones that you use to enter formulas. For syntax and a list of operators, see Writer’s online help under *conditions*.

If the section is write-protected with a password, the password must be entered to hide or reveal the text.

Hiding text can be useful for printed documents, if for example you have an instruction manual for two widgets, Model A and Model B which are very similar. By setting a condition for, say, Model A widget, you can hide that text which only applies to Model B, before printing it.

**Caution**

Hiding text is not a secure way to stop someone else reading it. It will stop the casual reader but will not prevent someone who actively wants to find out what you have hidden—even if it is password protected.

**Formatting a section into columns**

Use the *Columns* page of the Insert Section dialog to format the section into columns. This page is very similar to the Columns dialog shown in Figure 10 on page 14. Please refer to that topic for details.

**Indenting the section from margins**

Use the *Indents* page (Figure 28), to set indents from the right and left margins of the section.

![Figure 28: Indenting sections](image)

Enter the desired left-margin indent in the **Before section** box. Enter the desired right-margin indent in the **After section** box. The preview box on the right-hand side of the page shows you how the section will look with the indents applied.
**Changing the background of the section**

Use the *Background* page to add color or a graphic to the background of the current section. This page is similar to the Background pages for paragraphs, frames, tables, and other objects in LibreOffice. For more information, refer to Chapter 7, Working with Styles.

**Customizing footnotes and endnotes in a section**

Use the *Footnotes/Endnotes* page to customize the current section's footnotes and endnotes.

![Insert Section](image)

*Figure 29: Setting footnotes and endnotes for sections*

**Customizing footnotes**

If you want the section's footnotes to appear separately from the other footnotes in the document, select the *Collect at end of text* option in the *Footnotes* area.

To number the section's footnotes separately from the other footnotes in the document, and format the numbering, follow these steps:

1. In the *Footnotes* section of the page, make sure that the *Collect at end of text* option is selected.
2. Select the *Restart numbering* option.
3. If you want the section's footnotes to start at a number other than 1, enter the desired starting number in the *Start at* number box.
4. Select the *Custom format* option.
5. From the drop-down list of the *Custom format* option, select a numbering format for the footnotes.

To add text to the selected numbering format, use the *Before* and *After* text input boxes. For example, if you want the footnote numbers to be preceded by the word “Note” and followed by a colon, fill the *Before* and *After* fields as shown in Figure 29.
**Customizing endnotes**

If you want the section's endnotes to appear at the end of the section rather than at the end of the document, select the **Collect at end of section** option in the *Endnotes* area.

To number the current section's endnotes separately from the other endnotes in the document, and format the numbering, apply the procedures described above to the Endnotes settings.

**Saving a new section**

To save a new section so that it appears in your document, click the **Insert** button. The Insert Section dialog closes and the new section appears in your document.

**Editing and deleting sections**

To edit a section, follow these steps:

1) From the Menu Bar, choose **Format > Sections**. The Edit Sections dialog (Figure 30) opens.

2) Select the section you want to edit by clicking its name in the list box.

**Editing section attributes**

To rename the selected section, simply type over its name in the *Section* name box.

From the Edit Sections dialog, you can also edit the selected section's link, write-protect, and hide attributes. To learn how to edit these attributes, see:

- “Linking sections” on page 24.
- “Write-protecting sections” on page 25.
- “Hiding sections” on page 25.

![Figure 30: Edit Sections dialog](image)

Using sections for page layout
**Editing the format of a section**

To edit the format of the selected section, click the **Options** button.

The Options dialog has four tabbed pages: **Columns, Indents, Background, and Footnotes/Endnotes**. The use of these pages is described earlier in this topic.

To reset a page to the conditions in place when the dialog opened, click the **Reset** button.

To save your Options settings and return to the Edit Sections dialog, click **OK**.

![Options dialog for sections](image)

**Deleting sections**

To delete the selected section, click the **Remove** button.

---

**Note**

Writer will not prompt you to confirm the deletion. To undo a deletion, click the **Cancel** button.

---

**Updating links**

You can set Writer to update linked sections automatically, and you can also update links manually.

**Updating links automatically**

To set Writer to update links without prompting you, or to turn off automatic updating, follow these steps:

1) Choose **Tools > Options > LibreOffice Writer > General**. The dialog displays general text document settings.

2) In the **Update** section of the dialog, under **Update links when loading**, select one of the following three options:
• Select **Always** if you want Writer to update links automatically, without prompting you, whenever you open a document that contains links.
• Select **On request** if you want Writer to prompt you before updating links.
• Select **Never** if you do not want Writer to update links.

3) Click **OK** to save your settings. The Options dialog closes.

### Updating links manually

A protected section cannot be updated manually. It must first be unprotected.

To update a link manually:

1) Open the document that contains the link.
2) Choose **Edit > Links**. The Edit Links dialog opens.
3) The list in the Edit Links dialog displays the names of all the files that are linked to the current document. Click the file that corresponds to the link that you want to update.
4) Click the **Update** button. The most recently saved contents of the linked file appear in the current document.
5) To close the Edit Links dialog, click **Close**.

**Figure 32: Edit Links dialog**
Creating headers and footers

Headers and footers are portions of a document that always appear at the top or bottom of a page. Typically, headers display the title or chapter name of a document.

In LibreOffice, headers are specified by page styles; therefore, when inserted, all the pages with the same page style will display the same header. The option to make the header/footer on the first page of a document different is available (see “Defining a different first page for a document” on page 8). Chapter 7 describes how to format a header as part of the page style formatting. For the purpose of this example, we will insert a header in the Default pages using manual formatting.

There are two ways to insert a header. The simplest method is to click above the top of the text area, then when the Header marker appears (Figure 33), click on the +. (To insert a footer, click below the bottom of the text area to display the Footer marker, and then click on the +.)

![Figure 33](image)

**Figure 33**: Header marker at top of text area

Headers can also be inserted from the Menu Bar by selecting Insert > Header > [Page Style]. The submenu lists the page styles used in your document. In addition, the submenu includes the entry All, which activates headers on all the pages of the document regardless of their page style.

For our example, select the Default menu item to activate the headers only on the pages that use the Default page style. Similarly, to insert a footer, choose Insert > Footer > [Page Style].

The Insert menu can also be used for deleting a preexisting header or footer for a page style. If that page style has a check mark in front of it, it contains a header/footer, and clicking on it opens a message box warning about deletion and asks whether you want to delete the header or footer for that particular page style.

![Figure 34](image)

**Figure 34**: A page with a page header

Items such as document titles, chapter titles, and page numbers, which often go into headers and footers, are best added as fields. That way, if something changes, the headers and footers are all updated automatically.
Fields are covered in Chapter 14, Working with Fields, but one example here may be useful. To insert the document title into the header on a Default page style:

1) Select File > Properties > Description, enter a title for your document in the Title area, and click OK to close the dialog.
2) Add a header (Insert > Header > Default).
3) Place the cursor in the header part of the page.
4) Select Insert > Fields > Title. The title should appear on a gray background (which does not show when printed and can be turned off).
5) To change the title of the document, reselect File > Properties > Description and edit.

Formatting headers and footers

In Writer headers and footers are considered paragraphs and therefore you can format the header or footer text using the same techniques you use for formatting text in the main body of the document.

You can define styles for headers and footers so that you can quickly obtain a consistent formatting in case you use several page styles. Writer includes three named header and footer styles: header/footer, left header/footer styles, and right header/footer styles. All six are identical and are available for the user to modify.

You can format the layout of headers and footers using two different methods. The first method is to use the Header or Footer markers that appear within headers and footers.

For example, to use the Header marker:

1) Click the top of the page. The blue Header marker will appear.
2) Click the plus sign in the Header marker. The plus sign will change to a down arrow.
3) Click the down arrow.
4) Select Format Header. This opens the Page Style dialog where you can change the margins, spacing, and height.
5) Click More to open the Border/Background dialog where you can add borders, background colors, and background images to the header.

You can also format headers and footers by modifying the page style at Format > Page > Header.

Caution

Do not use the Background and Borders tabs on the Page Style dialog to format headers. Style choices selected from those tabs will apply to the entire page rather than to the header.

Portrait headers on landscape pages

When you define a header and footer on a landscape page, they will be aligned with the long side of the page. If your landscape pages are going to be inserted between portrait pages, you might want the headers and footers to be on the short sides of the landscape pages, so the final printed product looks like the contents of the landscape pages have been rotated 90 degrees on portrait pages.

You can set up portrait headers and footers on landscape pages by using a trick involving frames. These are a bit tedious to set up, but once you have done so, you can copy and paste them to other landscape pages. This cannot be made part of the landscape page style. In the following example we want to insert a landscape page into our printed document, to have the same header and footer, and margins, as our portrait pages. We will use an A4 page size here.
To set up portrait headers and footers on landscape pages:

1) Note the margin settings for the portrait page which is the same as the landscape page will be, that is to say, for a right landscape page, the settings from a right portrait page (see the table).

We now need to make the landscape right and left margins 1 cm larger than the portrait top and bottom margins, respectively. This difference allows for the extra space used by the portrait header and footer (0.5 cm for the height of the header or footer and a 0.5 cm gap between the header or footer and the main text).

<table>
<thead>
<tr>
<th>Portrait page (right page)</th>
<th>Landscape page (right page)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Top margin</td>
<td>Right margin</td>
</tr>
<tr>
<td>1.5 cm</td>
<td>2.5 cm</td>
</tr>
<tr>
<td>Bottom margin</td>
<td>Left margin</td>
</tr>
<tr>
<td>1.5 cm</td>
<td>2.5 cm</td>
</tr>
<tr>
<td>Left (inner) margin</td>
<td>Top margin</td>
</tr>
<tr>
<td>2.8 cm</td>
<td>2.8 cm</td>
</tr>
<tr>
<td>Right (outer) margin</td>
<td>Bottom margin</td>
</tr>
<tr>
<td>1.8 cm</td>
<td>1.8 cm</td>
</tr>
</tbody>
</table>

2) We will continue this example setting the frame for the footer. The procedure is the same for doing the header. Apply these margin settings in the Landscape page style.

3) Copy and paste the footer from the portrait page into a blank paragraph in the text. Paste or move it into the landscape page. This text will then have the Footer style so the typeface, font size, and tab settings will match.

4) Select the text you just entered (including the fields). Choose Format > Character. On the Character dialog, choose the Position tab and set Rotation / scaling to 270 degrees (counterclockwise). Note in the preview pane that the tabs are removed in this process. Click OK.

5) With the text still selected, choose Insert > Frame. In the Frame dialog, select the Type tab and enter the width, height, and horizontal and vertical position for the footer. Deselect the Automatic options in Width and Height if they are selected.
• The width is the footer height taken from the Footer page of the portrait page style dialog.
• The frame height is obtained by simple arithmetic. The A4 page-width is 21cm, minus the sum of the top and bottom margins of 2.8cm and 1.8cm resulting in a frame height of 16.4cm.
• The horizontal position is the portrait page bottom margin.
• The vertical position is the landscape page top margin.

![Frame window with settings](image)

**Figure 37: Defining the size and position of the footer frame**

6) If your footer has a line above the text, as in this book, on the Borders page, select a right border and specify the line width and spacing to the frame’s contents.

7) Click **OK** to save these settings. The footer will now appear in the required position and orientation. Any fields will update.

Because tabs have been removed, insert the cursor in the frame, at the end of the text where the tab was, and insert as many spaces using the keyboard space bar, as you require for the layout to match that on the portrait page.

Repeat these steps (using appropriate settings) to set up a portrait header on the landscape page.

**Caution**

Make sure to return to the paragraph in the document from which you rotated the text, and return it to **0 degrees**, or any text typed in this location will rotate.
Numbering pages

This section describes techniques to insert page numbers and related information in a document. Some basic knowledge of page styles, which are fully described in chapters 6 and 7, may be needed to follow some of the examples given.

Preliminaries: fields

LibreOffice uses fields to manage page numbers. To insert a page number field, position the cursor where you want to insert the number and choose Insert > Fields > Page Number. The page number appears with a gray background. The gray background denotes a field; although it is visible on screen, it is not printed.

Tip

If you wish to turn off the gray background, choose View > Field Shadings (or press Ctrl+F8).

The page number field always displays the page number for the page where it is placed. If you see the words “Page number” instead of a number, press Ctrl+F9. This shortcut key toggles LibreOffice between displaying the Field Name (the variable) and the field’s result (the data in the variable).

Note

For a full introduction to fields, see Chapter 14, Working with Fields.
Preliminaries: insert and format a header
For the purpose of this example, we will insert a header in the Default page style pages using manual formatting. See “Creating headers and footers” on page 31.

Simple page numbering
The simplest case is to have the page number at the top of every page and nothing more. To do this, put the cursor on the header and select Insert > Fields > Page Number.

Figure 39: Page number inserted in the header
Now the correct page number appears on every page.

Combining header text and page number
There are a lot of interesting variations that you can apply without further knowledge of page styles. Here are some suggestions:

- Right-align the header to make the page number appear on the top-right.
- Type the word page before the page number field so the header reads page 1, page 2, and so on. This also requires using the Page Number field, discussed earlier (page 35).
- Add the document title so the header reads, for example: Peter's Favourite Poems, left justified, and page x with right justification, where x is the value of the Page Number field. Consider using a (right-aligned) tab to separate the title from the page number.
- LibreOffice also has a Page Count field (Insert > Fields > Page Count). Using it, you could, for example, have a header that reads page 2 of 12.

These variations are all illustrated in Figure 40.

Figure 40: Variations on the simple page numbering method
Changing the number format

Many more variations are possible. For example, you can set the page number to display in Roman numerals. To do that, you can double-click on the page number and select the desired format; however, a better choice is to specify the format of numbers in the page style as explained here.

Right-click in the text area of the page and select Page from the context menu.

On the Page page of the Page Style dialog, in the Layout settings section, select i, ii, iii, .... from the Format drop-down list to use lowercase numerals.

Numbering the first page something other than 1

Sometimes you may want to start a document with a page number greater than 1. For example, you may be writing a book, with each chapter in a separate file. Chapter 1 may start with page 1, but Chapter 2 could begin with page 25 and Chapter 3 with page 51.

Follow these instructions to start the page numbering in a document at a number greater than 1. (These instructions are for a page number in a footer, but you could use a header instead.)

1) Choose Insert > Footer > [page style] to activate the footer. If the page style already has footers active, there will be a check mark against its name. In which case click in the footer area of the page without clicking on the page style. If you do click the checked page style name, select No in the warning dialog if you do not want to remove any footer text already in place, or Yes if you do. Click in the footer area.

2) The cursor is now in the footer. To insert the page number, choose Insert > Fields > Page Number. The page number will be 1.

3) Click in the first paragraph in the text area.

4) Choose Format > Paragraph (or right-click and choose Paragraph from the context menu), to display the Paragraph dialog.

5) On the Text Flow page, in the Breaks section, select Insert and select Page in the Type drop-down list. Select With Page Style and the page style you are using for the first page of the document. Note that you are not inserting a page break, but a break in the page numbering.

6) The Page number field is now active. Type the page number you want to start with. Click OK to close the Paragraph dialog.

Tip

Do not set a starting page number that is an even number because you will end up with a blank page before the first page when you print the file or export it as a PDF.
Numbering pages by chapter

Technical documents often include the chapter number with the page number in the header or footer. For example, 1-1, 1-2, 1-3, ...; 2-1, 2-2, 2-3, ...

To set up this type of page numbering in LibreOffice, you need to do three things:

1) Ensure that your chapter titles are all identified by the same paragraph style, for example, the Heading1 style.

2) Use Tools > Outline Numbering to tell LibreOffice what paragraph style you are using for Level 1 in your outline, and specify “1,2,3” in the Number box.

![Outline Numbering](image)

Figure 42: Specifying paragraph style and numbering for chapter titles

3) Insert the chapter number in your document. To do this:

a) Place the cursor in the header or footer just before the page number you inserted earlier, and choose Insert > Fields > Other from the Menu Bar.

b) On the Fields dialog (Figure 43), go to the Document page. Select Chapter in the Type list, Chapter number in the Format list, and 1 in the Level box. Click Insert.

![Fields](image)

Figure 43: Inserting a chapter number field
c) Type a hyphen or other punctuation between the chapter number and the page number. For more information, see “Choosing paragraph styles for outline levels” and “Including chapter or section information in page headers” in Chapter 7, Working with Styles.

**Restarting page numbering**

Often you will want to restart the page numbering at 1, for example, on the page following a title page or a table of contents. In addition, many documents have the *front matter* (such as the table of contents) numbered with Roman numerals and the main body of the document numbered in Arabic numerals, starting with 1.

You can restart page numbering in two ways.

**Method 1:**

1) Place the cursor in the first paragraph of the new page (be aware a heading is a paragraph).
2) Choose **Format > Paragraph**.
3) On the *Text Flow* page of the Paragraph dialog (Figure 5 on page 10), select **Insert** in the *Breaks* area.
4) In the *Type* drop-down list, select **Page**.
5) In the *Position* drop-down list, select **Before** or **After** to position where you want to insert the page numbering break.
6) Select **With Page Style** and specify the page style to use.
7) Specify the page number to start from and then click **OK**. This does not insert a new page.

**Method 2:**

1) Place the cursor in the first paragraph of the new page.
2) Choose **Insert > Manual break**.
3) **Page break** is the default selected on the Insert Break dialog.
   
   ![Insert Break dialog](image)

   *Figure 44: Restarting page numbering after a manual page break*

   4) Choose the required page in the *Style* drop-down list.
   5) Select **Change page number**.
   6) Specify the page number to start from and then click **OK**. This does insert a new page.
Example: Restart page numbering: a preface

A standard preface has the following properties:

- Page numbers are displayed in Roman numerals (i, ii, iii, iv, …).
- After the preface, the document starts on a Default page.
- The page number resets to 1, and the number format becomes Arabic (1, 2, 3, 4, …).

Resetting the page number requires page breaks.

First, do the preliminary work for the Preface style:

1) Create a new page style and name it Preface.
2) Set its Next Style to Preface because a preface could span multiple pages.
3) Add a header to Preface and insert the Page Number field. Make the page numbers display as Roman numerals (i, ii, iii, iv, …):
   - Open the page style window for Preface (if not already open) and click the Header tab.
   - Select Header on under Header.
   - Click the Page tab (Figure 45). Under Layout settings, in the Format drop-down list, set the format to i, ii, iii, iv, …. Click OK to close the dialog.

After the preface is written, we are ready to restart the page numbering in the main body of the document to Arabic numerals. Follow these steps:

1) Make an empty paragraph at the very end of the preface.
2) Put the cursor on the blank line.
4) Select Page break and choose the Default Style.
5) Select the Change page number option and set the new value to 1. Click OK to close the dialog.

These settings are shown in Figure 44.

Note

You cannot assign an odd page number to a left page or an even page number to a right page. LibreOffice strongly adheres to the convention that odd page numbers go on right-hand pages and even page numbers on left-hand pages.

Figure 45: Set page number format to Roman numerals.
This change is also reflected on the Status Bar. The Page section of the status bar now shows the page number, the sequence number and the total page count (the graphic shows the cursor location is in Page 1, and that it is the forty-third page of forty-seven in the document).

![Figure 46: Page number in the status bar](image)

### Problems with restarting page numbering

Restarting page numbering may lead to two problems.

- The Statistics page in the document's properties (File > Properties) always displays the total number of pages in the document, which may not be what you want to appear in the Page Count field.

- When page numbering is restarted, LibreOffice always makes odd-numbered pages to be on the right and even-numbered pages to be on the left. It does this by inserting a blank page, if necessary. Sometimes this blank page is not desired, particularly when creating PDFs or when printing single sided.

#### Solving the page count problem

Suppose you know exactly how many pages are not to be included in the page count. (You want one page to be excluded in the page count for the following example.)

Instead of inserting a Page Count field, you can do the following:

1) Position the cursor where you want the page count to appear.

2) Press F2 to open the formula bar, just above the horizontal ruler in the main Writer window (see Figure 47).

3) After the equal sign, type page–1. If you want to exclude several pages, substitute the number of excluded pages for 1 in the formula.

4) Press Enter to close the formula bar and insert the resulting field into the document.

![Figure 47: Formula bar](image)

If you do not know the total number of pages in advance, then one approach is to create a bookmark on the last page and then insert a cross reference to it.

To create a bookmark on the last page:

1) Go to the last page (Ctrl+End).

2) Choose Insert > Bookmark.

3) In the Insert Bookmark dialog, type a name for the bookmark, for example LastPage.

4) Click OK.
To insert a cross-reference to the last page in the header or footer where you want to refer to the total number of pages:

1) Position the cursor at the desired location—for example after the space added after of in the header or footer, as in page xx of yy.

2) Choose Insert > Cross-reference.

3) On the Cross-references page of the Fields dialog (Figure 49), select Bookmarks in the Type column and LastPage in the Selection column. LastPage now appears in the Name box.

4) In the Insert Reference to box, select As page style. Click Insert.

**Note** Do not delete the bookmark at the end of the document. If you do, the cross-reference will not work.

If a field, such as a cross-reference, does not automatically update, press F9.
Defining borders and backgrounds

You can apply borders and backgrounds to many elements in Writer. Paragraphs, pages, frames, sections, page styles, paragraph styles, character styles, and frame styles can include both borders and backgrounds; tables of contents, and indexes can include backgrounds only. Text can have a border applied, either to individual characters or to selected text.

The dialog pages for borders and backgrounds are similar in each case. To illustrate their use, we will define a border and background for a text frame.

Tip

Page backgrounds fill only the area within the margins, including the header or footer (if any). To extend the background color or graphic into the margins, you need to define a frame of appropriate size and position, anchor it to the page or a paragraph, and send it to the background. For more about anchoring frames, see Chapter 8, Working with Graphics.

Adding a border

To begin, select the frame, right-click, and choose Frame from the context menu. Select the Borders tab.

Borders have three components: where they go, what they look like, and how much space is left around them.

- **Line arrangement** specifies where the borders go. Writer provides five default arrangements but you can just as easily click on the line you want to customize in the User-defined area to get exactly what you want. Each line can be individually formatted.

- **Line** specifies what the border looks like: the style, width and color. There are a number of different styles and colors to choose from. The Line Style, Width and Color will apply to those borders highlighted by a pair of black arrows in the User-defined thumbnail on the left hand side of the dialog.
• *Spacing to contents* specifies how much space to leave between the border and the contents of the element. Spaces can be specified to the left, right, above, and below. Check **Synchronize** to have the same spacing for all four sides. This spacing is like a padding and it is not factored in when calculating the text measurements.

• *Shadow style* properties always apply to the whole element. A shadow has three components: where it is, how far from the element it is cast, and what color it is.

**Adding color to the background**

In the Frame dialog, choose the Background page (Figure 53). Here you can add color, a gradient or a graphic.

To add color to the background, select from the color grid. You can adjust the transparency of the color to make any text easier to read.

**Adding a gradient to the background**

To add a gradient to the background:

1) From the As drop-down list on the Background page, select **Gradient**. The page now displays the gradient options (Figure 51), with an example in the preview pane to the right.

2) Select the required gradient from the list.

3) Click **OK**.

![Figure 51: Frame dialog: Background page showing Gradient choices](image)

**Adding a graphic to the background**

To add a graphic to the background:

1) From the As drop-down list on the Background page, select **Graphic**. The page now displays the graphics options, as shown in Figure 52.

2) Click the **Browse** button. The Find Graphics dialog opens.

---

*Defining borders and backgrounds*
3) Find the file you want and then click the Open button. The Find Graphics dialog closes and the selected graphic appears in the preview box on the right-hand side of the Background page. (If you do not see the graphic, select the Preview option.)

4) To embed the graphic in your document, deselect Link. To link the graphic to the document but not embed it, select Link. For more about linking graphics, see Chapter 8, Working with Graphics.

5) In the Type area, choose how you want the background graphic to appear:
   a) To position the graphic in a specific location, select Position and then click the desired location in the position grid.
   b) To stretch the graphic to fill the entire background area, select Area.
   c) To repeat the graphic across the entire background area, select Tile.

6) In the Transparency area, you can adjust the transparency of the graphic. This adjustment is often necessary to make any text easier to read.

Figure 52: Graphic options on the Background page of the Frame dialog

Figure 53: Frame dialog: Background page showing color choices
Deleting color, gradient or graphics from the background

To delete color, gradient or graphics from the background:

1) From the As drop-down list, select Color.
2) Click No Fill on the color grid.
3) Click OK.