Copyright

This document is Copyright © 2023 by the LibreOffice Documentation Team. Contributors are listed below. You may distribute it and/or modify it under the terms of either the GNU General Public License (https://www.gnu.org/licenses/gpl.html), version 3 or later, or the Creative Commons Attribution License (https://creativecommons.org/licenses/by/4.0/), version 4.0 or later.

All trademarks within this guide belong to their legitimate owners.

Contributors

To this edition
Jean Hollis Weber

To previous editions

Jean Hollis Weber  Olivier Hallot  Kees Kriek
Tsvetelina Georgieva  Antonio Fernández  Toni Blackwelder
Rafael Lima  Randolph Gamo  Jenna Sargent
Dante Legaspi  Felipe Viggiano  Pulkit Krishna
Colleen Hayes  John A Smith  Peter Schofield
Bruce Byfield  Gillian Polack  Cathy Crumbley
Hazel Russman  Leo Moons  David Blymire
Jeremy Cartwright  John M. Długosz  Barbara Duprey
Jamie Eby  Ron Faile Jr.  Gary Schnabl
Klaus-Jürgen Weghorn  Rafael Atias  Shravani Bellapukonda

Feedback

Please direct any comments or suggestions about this document to the Documentation Team’s forum at https://community.documentfoundation.org/c/documentation/loguides/ (registration is required) or send an email to: loguides@community.documentfoundation.org. Emails sent to the forum are moderated.

Note

Everything you send to a forum, including your email address and any other personal information that is written in the message, is publicly archived and cannot be deleted.

Publication date and software version

Published August 2023. Based on LibreOffice 7.6 Community.
Other versions of LibreOffice may differ in appearance and functionality.
Contents

Copyright ........................................................................................................................................ 2
Preface ........................................................................................................................................... 9
  Who is this book for? .................................................................................................................. 10
  What’s in this book? .................................................................................................................. 10
  Minimum requirements for using LibreOffice ........................................................................ 10
  How to get LibreOffice ............................................................................................................ 10
  Installing LibreOffice ................................................................................................................ 11
  Setting up and customizing LibreOffice ................................................................................... 11
  Extensions and add-ons ............................................................................................................. 11
  Where to get more help ............................................................................................................ 11
  What you see may be different .................................................................................................. 13
  Using LibreOffice on macOS .................................................................................................... 14
  Frequently asked questions ...................................................................................................... 14
  What’s new in LibreOffice Writer 7.6 Community? .................................................................. 15
Chapter 1, Introducing Writer ...................................................................................................... 16
  What is Writer? .......................................................................................................................... 17
  Parts of the main Writer window ............................................................................................... 17
  Context (right-click) menus ...................................................................................................... 26
  Dialogs ....................................................................................................................................... 26
  Document views ......................................................................................................................... 26
  Starting a new document ........................................................................................................... 27
  Opening an existing document ................................................................................................. 29
  Saving a document ..................................................................................................................... 30
  Using password protection and OpenPGP encryption ............................................................... 32
  Opening and saving files on remote servers ............................................................................ 34
  Moving quickly through a document ......................................................................................... 34
  Undoing and redoing changes ................................................................................................... 38
  Displaying multiple views of a document ............................................................................... 38
  Reloading a document .............................................................................................................. 39
  Closing a document .................................................................................................................. 39
Chapter 2, Working with Text: Basics .......................................................................................... 40
  Introduction ............................................................................................................................... 41
  Selecting text ............................................................................................................................. 41
  Cutting, copying, and pasting text ............................................................................................ 43
  Finding and replacing text ......................................................................................................... 43
  Inserting special characters ..................................................................................................... 45
  Checking spelling and grammar ............................................................................................... 49
  Using Language Tool ................................................................................................................ 54
  Using synonyms and the thesaurus ............................................................................................ 54
  Hyphenating words ................................................................................................................... 55
  Using AutoCorrect .................................................................................................................... 57
  Using Word Completion ............................................................................................................ 58
# Using AutoText

Changing the case of selected text

<table>
<thead>
<tr>
<th>Chapter 3, Working with Text: Advanced</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Introduction</td>
<td>63</td>
</tr>
<tr>
<td>Using built-in language tools</td>
<td>64</td>
</tr>
<tr>
<td>Advanced find and replace techniques</td>
<td>64</td>
</tr>
<tr>
<td>Tracking changes to a document</td>
<td>67</td>
</tr>
<tr>
<td>Adding other comments</td>
<td>70</td>
</tr>
<tr>
<td>Using footnotes and endnotes</td>
<td>75</td>
</tr>
<tr>
<td>Linking to another part of a document</td>
<td>77</td>
</tr>
<tr>
<td>Rearranging headings and text using the Navigator</td>
<td>78</td>
</tr>
<tr>
<td>Outline folding</td>
<td>80</td>
</tr>
<tr>
<td>Inserting material from other documents</td>
<td>81</td>
</tr>
<tr>
<td>Line numbering</td>
<td>82</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 4, Formatting Text</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Introduction</td>
<td>85</td>
</tr>
<tr>
<td>Formatting paragraphs using styles</td>
<td>86</td>
</tr>
<tr>
<td>Formatting paragraphs directly</td>
<td>87</td>
</tr>
<tr>
<td>Formatting characters using styles</td>
<td>87</td>
</tr>
<tr>
<td>Formatting characters directly</td>
<td>96</td>
</tr>
<tr>
<td>Formatting lists using styles</td>
<td>96</td>
</tr>
<tr>
<td>Formatting lists directly</td>
<td>101</td>
</tr>
<tr>
<td>Autoformatting</td>
<td>102</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 5, Formatting Pages: Basics</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Introduction</td>
<td>107</td>
</tr>
<tr>
<td>Setting up basic page layout using styles</td>
<td>108</td>
</tr>
<tr>
<td>Changing page margins</td>
<td>109</td>
</tr>
<tr>
<td>Inserting page breaks</td>
<td>111</td>
</tr>
<tr>
<td>Creating headers and footers</td>
<td>113</td>
</tr>
<tr>
<td>Numbering pages</td>
<td>115</td>
</tr>
<tr>
<td>Including other information in headers and footers</td>
<td>121</td>
</tr>
<tr>
<td>Defining a different first page for a document</td>
<td>121</td>
</tr>
<tr>
<td>Formatting footnotes and endnotes</td>
<td>124</td>
</tr>
<tr>
<td>Inserting column and line breaks</td>
<td>124</td>
</tr>
<tr>
<td>Changing page orientation within a document</td>
<td>125</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 6, Formatting Pages: Advanced</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Introduction</td>
<td>131</td>
</tr>
<tr>
<td>Choosing a layout method</td>
<td>132</td>
</tr>
<tr>
<td>Using columns to define the page layout</td>
<td>132</td>
</tr>
<tr>
<td>Using frames for page layout</td>
<td>133</td>
</tr>
<tr>
<td>Using tables for page layout</td>
<td>134</td>
</tr>
<tr>
<td>Using sections for page layout</td>
<td>139</td>
</tr>
<tr>
<td>Defining borders and backgrounds</td>
<td>141</td>
</tr>
</tbody>
</table>

---

LibreOffice 7.6 Writer Guide
Using document themes ......................................................... 152
Using page line-spacing for printing ........................................ 153

Chapter 7, Printing and Publishing .......................................... 155
Int roduction ........................................................................... 156
Quick printing ........................................................................ 156
Controlling printing using the Print dialog ............................... 156
Printing in black and white on a color printer ......................... 164
Previewing pages before printing .......................................... 165
Printing envelopes .................................................................. 165
Printing labels ....................................................................... 168
Exporting to PDF ................................................................... 168
Exporting to EPUB format ..................................................... 175
Exporting to other formats ................................................. 176
Emailing Writer documents .................................................. 176
Digital signing of documents ............................................... 177
Removing personal data ....................................................... 179
Redaction ............................................................................ 180
Accessibility checking ......................................................... 181

Chapter 8, Introduction to Styles .......................................... 183
What are styles? .................................................................... 184
The Styles deck in the Sidebar .............................................. 184
Applying styles ..................................................................... 185
Creating and modifying styles .......................................... 196
Deleting styles ..................................................................... 199
Example: creating and modifying paragraph styles ............... 199
Using paragraph styles to define a hierarchy of headings ......... 202

Chapter 9, Working with Styles .......................................... 205
Introduction ........................................................................... 206
Creating custom (new) styles ............................................. 206
Working with paragraph styles ........................................... 208
Working with character styles .......................................... 219
Working with frame styles .................................................. 220
Working with page styles .................................................. 222
Working with list styles ..................................................... 224
Solving formatting problems ............................................ 227

Chapter 10, Working with Templates .................................... 230
Introduction ........................................................................... 231
Creating a document from a template .................................. 231
Creating a template .......................................................... 233
Adding templates obtained from other sources ..................... 234
Editing a template ........................................................... 236
Changing the template assigned to a document ................. 237
Setting a default template ................................................. 238
Organizing templates.................................................................................................................. 239
Other ways to manage templates.............................................................................................. 241

Chapter 11, Images and Graphics......................................................................................... 242
Introduction................................................................................................................................. 243
Creating and editing images........................................................................................................ 243
Adding images to a document.................................................................................................... 244
Positioning images within the text........................................................................................... 248
Adding captions to images......................................................................................................... 253
Modifying images....................................................................................................................... 256
Using Writer’s drawing tools...................................................................................................... 263
Creating an image map................................................................................................................ 266
Managing the LibreOffice Gallery............................................................................................ 268
Using Fontwork.......................................................................................................................... 270

Chapter 12, Lists...................................................................................................................... 275
Introduction................................................................................................................................. 276
Types of list.................................................................................................................................. 276
Combining list and paragraph styles........................................................................................ 278
Nesting lists................................................................................................................................. 279
Outlining with paragraph styles................................................................................................ 280
Applying list styles..................................................................................................................... 281
Naming list styles....................................................................................................................... 282
Formatting list styles.................................................................................................................. 282

Chapter 13, Tables................................................................................................................... 294
Introduction................................................................................................................................. 295
Tools for working with tables..................................................................................................... 295
Creating a table.......................................................................................................................... 297
Formatting the table layout........................................................................................................ 301
Creating and applying table styles........................................................................................... 309
Formatting the table text.......................................................................................................... 311
Data entry and manipulation in tables...................................................................................... 312
Additional table operations....................................................................................................... 315
Using tables as a page layout tool............................................................................................. 317

Chapter 14, Mail Merge........................................................................................................... 318
What is mail merge?.................................................................................................................... 319
Creating and registering an address data source...................................................................... 319
Creating a form letter................................................................................................................. 321
Printing mailing labels................................................................................................................ 325
Printing envelopes..................................................................................................................... 328
Using the Mail Merge Wizard to create a form letter............................................................... 329

Chapter 15, Tables of Contents, Indexes, Bibliographies....................................................... 338
Introduction................................................................................................................................. 339
Tables of contents...................................................................................................................... 339
Alphabetic indexes..................................................................................................................... 346
<table>
<thead>
<tr>
<th>Other types of index</th>
<th>354</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bibliographies</td>
<td>356</td>
</tr>
</tbody>
</table>

**Chapter 16, Master Documents** | 367 |
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>What is a master document?</td>
<td>368</td>
</tr>
<tr>
<td>Why use a master document?</td>
<td>368</td>
</tr>
<tr>
<td>Master document Navigator</td>
<td>369</td>
</tr>
<tr>
<td>Styles in master documents and subdocuments</td>
<td>370</td>
</tr>
<tr>
<td>Updating a master document</td>
<td>370</td>
</tr>
<tr>
<td>Creating a master document: scenarios</td>
<td>371</td>
</tr>
<tr>
<td>Starting with a master document template</td>
<td>371</td>
</tr>
<tr>
<td>Starting with no existing documents</td>
<td>372</td>
</tr>
<tr>
<td>Combining several documents into a master document</td>
<td>377</td>
</tr>
<tr>
<td>Splitting a document into master and subdocuments</td>
<td>378</td>
</tr>
<tr>
<td>Restarting page numbering</td>
<td>379</td>
</tr>
<tr>
<td>Editing a master document</td>
<td>381</td>
</tr>
<tr>
<td>Creating a master document template</td>
<td>382</td>
</tr>
<tr>
<td>Creating one file from a master document and its subdocuments</td>
<td>382</td>
</tr>
<tr>
<td>Anchoring images</td>
<td>383</td>
</tr>
</tbody>
</table>

**Chapter 17, Fields** | 384 |
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Introduction</td>
<td>385</td>
</tr>
<tr>
<td>Quick and easy field entry</td>
<td>385</td>
</tr>
<tr>
<td>Using document properties to hold metadata and information that changes</td>
<td>385</td>
</tr>
<tr>
<td>Using other fields to hold information that changes</td>
<td>387</td>
</tr>
<tr>
<td>Using AutoText to insert often-used fields</td>
<td>388</td>
</tr>
<tr>
<td>Defining your own numbering sequences</td>
<td>389</td>
</tr>
<tr>
<td>Using automatic cross-references</td>
<td>390</td>
</tr>
<tr>
<td>Cross-referencing between subdocuments</td>
<td>393</td>
</tr>
<tr>
<td>Using fields in headers and footers</td>
<td>395</td>
</tr>
<tr>
<td>Managing bookmarks</td>
<td>396</td>
</tr>
<tr>
<td>Developing conditional content</td>
<td>397</td>
</tr>
<tr>
<td>Using placeholder fields</td>
<td>403</td>
</tr>
<tr>
<td>Using other fields</td>
<td>404</td>
</tr>
<tr>
<td>Classifying document contents</td>
<td>404</td>
</tr>
</tbody>
</table>

**Chapter 18, Forms** | 406 |
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Introduction</td>
<td>407</td>
</tr>
<tr>
<td>When to use forms</td>
<td>407</td>
</tr>
<tr>
<td>Creating a simple form</td>
<td>407</td>
</tr>
<tr>
<td>Form controls reference</td>
<td>409</td>
</tr>
<tr>
<td>Example: a simple form</td>
<td>413</td>
</tr>
<tr>
<td>Accessing data sources</td>
<td>419</td>
</tr>
<tr>
<td>Advanced form customization</td>
<td>422</td>
</tr>
<tr>
<td>Using content controls</td>
<td>425</td>
</tr>
</tbody>
</table>
Chapter 19, Spreadsheets, Charts, Other Objects.................................426
  Introduction: OLE and DDE objects....................................................427
  Spreadsheets......................................................................................429
  Charts and graphs..............................................................................434
  Audio and video..................................................................................438
  Formulas (equations). ........................................................................440
  Barcodes and QR codes......................................................................440
  Formatting OLE objects......................................................................441

Chapter 20, Customizing Writer............................................................443
  Introduction..........................................................................................444
  Choosing options for all of LibreOffice..............................................444
  Choosing options for loading and saving documents........................448
  Choosing Writer-specific options.......................................................450
  Choosing language settings.................................................................459
  Customizing menus............................................................................461
  Customizing toolbars.........................................................................464
  Customizing the user interface...........................................................466
  Assigning shortcut keys......................................................................467
  Assigning macros to events.................................................................469
  Adding functionality with extensions...............................................469
  Adding fonts........................................................................................470
  Adding custom colors..........................................................................471
  Setting up document themes...............................................................472

Chapter 21, User Interface Variants.....................................................474
  Introduction..........................................................................................475
  Selecting the user interface.................................................................475
  Standard interfaces.............................................................................475
  Tabbed interface..................................................................................476
  Tabbed Compact interface.................................................................488
  Groupedbar Compact interface............................................................488
  Contextual Single interface...............................................................489
Writer Guide 7.6

Preface
Who is this book for?

LibreOffice is a feature-rich, free, and open source office suite. It includes several powerful applications for word processing, spreadsheets, presentations, graphics, databases, and formula editing. Writer is the word-processing application. It is compatible with a wide range of document formats including Microsoft Word (.doc, .docx), and you can export your work in several formats including PDF.

Anyone who wants to get up to speed quickly with Writer will find this book valuable. You may be new to word processing software, or you may be familiar with another office suite.

What's in this book?

This book introduces the main features of Writer, the word processor component of LibreOffice, and provides instructions for their use.

Minimum requirements for using LibreOffice

LibreOffice 7.6 requires one of the following operating systems:

- Microsoft Windows: Windows 7 SP1; Windows 8, 10, or 11; Windows Server 2012. Administrator rights are needed for the installation process.
- GNU/Linux: Kernel version 3.10 or higher and glibc2 v2.17 or higher.
- macOS 10.15 (Catalina) or higher.

For a detailed list of requirements and operating systems supported, see the LibreOffice website, https://www.libreoffice.org/get-help/system-requirements/.

Note regarding Java

Some LibreOffice features (wizards and the HSQLDB database engine) require that the Java Runtime Environment (JRE) or, for macOS, the Java Development Kit (JDK) is installed on your computer. If you do not want to use Java, you can still use nearly all of the LibreOffice features.

Java is available at no cost. More information and download links to the appropriate edition for your operating system can be found at: https://java.com/en/download/manual.jsp.

For macOS, you need to install Oracle’s Java Development Kit (JDK), not just the Java Runtime Environment (JRE). Download links can be found at: https://www.oracle.com/java/technologies/downloads/.

If you want to use LibreOffice features that require Java, it is important that the correct 32-bit or 64-bit edition matches the installed version of LibreOffice. See the Advanced Options in Chapter 2, Setting up LibreOffice.

How to get LibreOffice

Versions of LibreOffice Community for Windows, Linux, and macOS are freely available and can be downloaded from https://www.libreoffice.org/download. Linux users will also find a free version of LibreOffice included by default in the majority of Linux distributions. Windows and macOS users can also buy versions through the Microsoft Store or Apple’s Mac App Store. Portable and other versions of LibreOffice are listed on the download page. Linux, Enterprise, Online, and other versions may differ in appearance and functionality from the descriptions in this book.
Installing LibreOffice

Information on installing and setting up LibreOffice on the various supported operating systems is given here: https://www.libreoffice.org/get-help/install-howto/.

Setting up and customizing LibreOffice

You can change the default settings (options) in LibreOffice to suit your preferences. To change settings, go to Tools > Options on the Menu bar (LibreOffice > Preferences on macOS). Settings are described in the Help and in the Getting Started Guide. Some settings of particular interest to users of Writer are covered in Chapter 20, Customizing Writer, in this book.

Tip

Many settings are intended for power users and programmers. If you do not understand what an option does, we recommend leaving it on the default setting unless instructions in this book recommend changing the setting.

You can customize menus, toolbars, and keyboard shortcuts in LibreOffice, add new menus and toolbars, and assign macros to events. See Chapter 20, Customizing Writer, for details.

Extensions and add-ons

You can add functionality to LibreOffice with extensions and add-ons. Several extensions are installed with the program and you can get others from the official extensions repository, https://extensions.libreoffice.org/ and from other sources. See Chapter 20, Customizing Writer, for more information on installing extensions and add-ons.

Where to get more help

This book, the other LibreOffice user guides, the Help system, and user support systems assume that you are familiar with your computer and basic functions such as starting a program, opening and saving files.

Help system

LibreOffice comes with an extensive online Help system. This is your first line of support. Windows and Linux users can choose to download and install the offline Help for use when not connected to the Internet; the offline Help is installed with the program on macOS.

To display the Help system, press F1 or select Help > LibreOffice Help on the Menu bar. If you do not have the offline help installed on your computer and you are connected to the Internet, your default browser will open the online Help pages on the LibreOffice website.

The Help menu includes links to other LibreOffice information and support resources. Notice that options marked with a ‡ sign are only accessible if your computer is connected to the Internet.

- What's This? For quick tips when a toolbar is visible, place the mouse pointer over any of the icons to see a small box (“tooltip”) with a brief explanation of the icon's function. For a more detailed explanation, select Help > What's This? and hold the pointer over the icon. In addition, you can choose whether to activate Extended Tips using Tools > Options > LibreOffice > General. (macOS: LibreOffice > Preferences > LibreOffice > General) on the Menu bar.
• **User Guides** ‡ Opens your default browser at the Documentation page of the LibreOffice website [https://documentation.libreoffice.org/en/](https://documentation.libreoffice.org/en/). There you will find user guides (to download as free PDFs or buy as printed copies) and other information.

• **Show Tip of the Day** Opens a small window with a random tip on how to use LibreOffice.

• **Search Commands** Opens a window where you can type a few letters or the name of a Menu bar command, to quickly find where the command is located. Clicking on a command in the resulting list may open a relevant dialog or have other effects.

• **Get Help Online** ‡ Opens your default browser at the Ask LibreOffice forum of questions and answers from the LibreOffice community [https://ask.libreoffice.org/en/questions/](https://ask.libreoffice.org/en/questions/).

• **Send Feedback** ‡ Opens your default browser at the Feedback page of the LibreOffice website [https://www.libreoffice.org/get-help/feedback/](https://www.libreoffice.org/get-help/feedback/). From there you can report bugs, suggest new features and communicate with others in the LibreOffice community.

• **Restart in Safe Mode** Opens a dialog where you can restart LibreOffice and reset the software to its default settings.

• **Get Involved** ‡ Opens your default browser at the Get Involved page of the LibreOffice website, [https://www.libreoffice.org/community/get-involved/](https://www.libreoffice.org/community/get-involved/). There you can choose a topic of interest to help improve the program.

• **Donate to LibreOffice** ‡ Opens your default browser at the Donation page of the LibreOffice website [https://donate.libreoffice.org/](https://donate.libreoffice.org/).

• **License Information** Outlines the licenses under which LibreOffice is made available.

• **Check for Updates** ‡ Opens a dialog and checks the LibreOffice website for updates to your version of the software.

• **About LibreOffice** Opens a dialog and displays information about the version of LibreOffice and the operating system you are using. This information will often be requested if you ask the community for help or assistance with the software. (On macOS, this option is found under **LibreOffice** on the Menu bar.)

### Other free online support

The LibreOffice community not only develops software, but provides free, volunteer-based support. See Table 1 and this web page: [https://www.libreoffice.org/get-help/](https://www.libreoffice.org/get-help/).

For comprehensive online support from the community, look at mailing lists and the Ask LibreOffice website, [https://ask.libreoffice.org/en/questions/](https://ask.libreoffice.org/en/questions/). Other websites run by users also offer free tips and tutorials.

*Table 1: Free support for LibreOffice users*

<table>
<thead>
<tr>
<th><strong>Free LibreOffice support</strong></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>FAQs</strong></td>
<td>Answers to frequently asked questions <a href="https://wiki.documentfoundation.org/Faq">https://wiki.documentfoundation.org/Faq</a></td>
</tr>
<tr>
<td><strong>Mailing lists</strong></td>
<td>Free community support is provided by a network of experienced users <a href="https://www.libreoffice.org/get-help/mailing-lists/">https://www.libreoffice.org/get-help/mailing-lists/</a></td>
</tr>
<tr>
<td><strong>Questions &amp; Answers and Knowledge Base</strong></td>
<td>Free community assistance is provided in a question and answer format. Search similar topics or ask a new question in <a href="https://ask.libreoffice.org/en/questions">https://ask.libreoffice.org/en/questions</a> The service is available in several other languages; replace /en/ with de, es, fr, ja, ko, nl, pt, tr, and others in the address above.</td>
</tr>
</tbody>
</table>

12 | LibreOffice 7.6 Writer Guide
**Free LibreOffice support**

| Native language support | The LibreOffice website in various languages  
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td><a href="https://www.libreoffice.org/community/nlc/">https://www.libreoffice.org/community/nlc/</a></td>
</tr>
<tr>
<td></td>
<td>Mailing lists for native languages</td>
</tr>
<tr>
<td></td>
<td><a href="https://wiki.documentfoundation.org/Local_Mailing_Lists">https://wiki.documentfoundation.org/Local_Mailing_Lists</a></td>
</tr>
<tr>
<td></td>
<td>Information about social networking</td>
</tr>
<tr>
<td></td>
<td><a href="https://wiki.documentfoundation.org/Website/Web_Sites_services">https://wiki.documentfoundation.org/Website/Web_Sites_services</a></td>
</tr>
<tr>
<td>Accessibility options</td>
<td>Information about available accessibility options.</td>
</tr>
<tr>
<td></td>
<td><a href="https://www.libreoffice.org/get-help/accessibility/">https://www.libreoffice.org/get-help/accessibility/</a></td>
</tr>
</tbody>
</table>

**Paid support and training**

You can also pay for support through service contracts from a vendor or consulting firm specializing in LibreOffice. For information about certified professional support, see The Document Foundation’s website: https://www.documentfoundation.org/gethelp/support/.

For schools, educational and research institutions, and large organizations, see https://www.libreoffice.org/download/libreoffice-in-business/.

**What you see may be different**

**Illustrations**

LibreOffice runs on Windows, Linux, and macOS operating systems, each of which has several versions and can be customized by users (fonts, colors, themes, window managers). The illustrations in this guide were taken from a variety of computers and operating systems. Therefore, some illustrations will not look exactly like what you see on your computer display.

Also, some of the dialogs may be different because of the settings selected in LibreOffice. You can either use dialogs from your computer’s operating system or from LibreOffice. The differences affect mainly Open, Save, and Print dialogs. To change which dialogs are used, go to **Tools > Options > LibreOffice > General** and select or deselect the option **Use LibreOffice dialogs**.

**Icons**

The LibreOffice community has created icons for several icon sets: Breeze, Colibre, Elementary, Karasa Jaga, Sifr, and Sukapura; some are also available in a dark version. As a user, you can can select your preferred set. The icons in this guide have been taken from a variety of LibreOffice installations that use different sets of icons. The icons for some of the many tools available in LibreOffice may differ from the ones used in this guide.

To change the icon set used, go to **Tools > Options > LibreOffice > View**. In the **Icon Style** section, choose from the drop-down list.

**Note**

Some Linux distributions include LibreOffice as part of the installation and may not include all the icon sets mentioned above. You should be able to download other icon sets from the software repository for your Linux distribution.

The Galaxy, Oxygen, and Tango icon sets are no longer included as part of the standard installation package for Windows, macOS, or Linux. You can download and install them as extensions from https://extensions.libreoffice.org/en/extensions/.
Some of the previously included gallery sets are now available only as extensions; see [https://extensions.libreoffice.org/?Tags%5B%5D=49](https://extensions.libreoffice.org/?Tags%5B%5D=49) or search for specific ones.

For example, the People Gallery is available from [https://extensions.libreoffice.org/en/extensions/show/people-gallery](https://extensions.libreoffice.org/en/extensions/show/people-gallery)

---

**Using LibreOffice on macOS**

Some keystrokes and menu items are different on macOS from those used in Windows and Linux. The table below gives some common substitutions for the instructions in this chapter. For a more detailed list, see the application Help.

<table>
<thead>
<tr>
<th>Windows or Linux</th>
<th>macOS equivalent</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tools &gt; Options menu selection</td>
<td>LibreOffice &gt; Preferences</td>
<td>Access setup options</td>
</tr>
<tr>
<td>Right-click</td>
<td>Control+click and/or right-click depending on computer setup</td>
<td>Opens a context menu</td>
</tr>
<tr>
<td>$Ctri$ (Control)</td>
<td>$⌘$ (Command)</td>
<td>Used with other keys</td>
</tr>
<tr>
<td>$Al$t</td>
<td>$⌥$ (Option) or $Al$t, depending on keyboard</td>
<td>Used with other keys</td>
</tr>
<tr>
<td>$F11$</td>
<td>$⌘$+$T</td>
<td>Open Styles deck in Sidebar</td>
</tr>
</tbody>
</table>

---

**Frequently asked questions**

**How is LibreOffice licensed?**

LibreOffice is distributed under the Open Source Initiative (OSI) approved Mozilla Public License (MPL). See [https://www.libreoffice.org/about-us/licenses/](https://www.libreoffice.org/about-us/licenses/)

It is based on code from Apache OpenOffice made available under the Apache License 2.0 but also includes software that differs from version to version under a variety of other Open Source licenses. New code is available under LGPL 3.0 and MPL 2.0.

**May I distribute LibreOffice to anyone? May I sell it? May I use it in my business?**

Yes.

**How many computers may I install it on?**

As many as you like.

**Do I need Java to run LibreOffice?**

The Java JDK/JRE is only required for some features, including the HSQLDB relational database engine. For more information, see “Minimum requirements for using LibreOffice” on page 10.

**How can I contribute to LibreOffice?**

You can help with the development and user support of LibreOffice in many ways, and you do not need to be a programmer. To start, check out this web page: [https://www.libreoffice.org/community/get-involved/](https://www.libreoffice.org/community/get-involved/).

**May I distribute the PDF of this book, or print and sell copies?**

Yes, as long as you meet the requirements of one of the licenses in the copyright statement at the beginning of this book. You do not have to request special permission.

We request that you share with the project some of the profits you make from sales of books, in consideration of all the work we have put into producing them. Visit [https://www.libreoffice.org/donate/](https://www.libreoffice.org/donate/) for instructions on how to donate to LibreOffice.
What’s new in LibreOffice Writer 7.6 Community?

This book has been updated from LibreOffice Writer Guide 7.5. It covers changes that are visible in the LibreOffice Writer user interface, including:

- Additional hyphenation settings (Chapter 2)
- New page number wizard (Chapter 5)
- Document themes (Chapter 6)
- Accessibility checking (Chapter 7)
- Styles Spotlight (Chapter 9)
- Table of Figures improvements (Chapter 15)
- Bibliography entries can now be edited directly from a bibliography table (Chapter 15)
- Updated chapter/heading numbering terminology
- Other changes in terminology

LibreOffice 7.6 Community also includes many other changes, including improvements in accessibility, change tracking, spell checking, and interoperability with Microsoft’s proprietary file formats.

Release Notes are here: https://wiki.documentfoundation.org/ReleaseNotes/7.6
Writer Guide 7.6

Chapter 1,
Introducing Writer
What is Writer?

Writer is the word processor component of LibreOffice, a freely available, fully-featured office productivity suite. In addition to the usual features of a word processor (text entry, editing, and formatting; spelling checker, thesaurus, hyphenation, and autocorrect; find and replace; and others), Writer provides these important features:

- Change tracking during revisions (Chapter 4)
- Page layout methods, including styles, frames, columns, and tables (Chapters 5 and 6)
- Export to PDF and ePub (Chapter 7)
- Document digital signatures (Chapter 7)
- Accessibility checking (Chapter 7)
- Templates and styles (Chapters 8, 9, and 10)
- Built-in drawing tools (Chapter 11)
- Lists (Chapter 12)
- Tables (Chapter 13)
- Mail merge (Chapter 14)
- Automated tables of contents and indexes (Chapter 15)
- Master documents, to group several documents into a single document (Chapter 16)
- Fields and forms (Chapters 17 and 18)
- Database integration, including a bibliography database (Chapters 14, 15, and 18)
- Embedding or linking of spreadsheets, equations, and other objects (Chapter 19)
- And many more

Parts of the main Writer window

The main Writer window is shown in Figure 1. Its features are described in this section.

Note

By default, LibreOffice Writer’s commands are grouped in menus and toolbars, as described in this section. In addition, Writer provides other user interface variations, displaying contextual groups of commands and contents. For more information, see the Help and Chapter 20, Customizing Writer.

Title bar

The Title bar is located at the top of the Writer window. It shows the file name of the current document. When the document is not yet named, the document name will appear as Untitled X, where X is a number. Untitled documents are numbered in the order in which they are created.

Menu bar

The Menu bar is located just below the Title bar in Windows and Linux and at the top of the screen in macOS. When one of the menus is selected, a submenu drops down to show further options, including:

- Commands that directly cause an action, such as Close or Save in the File menu.
- Commands that open dialogs. These are indicated by three dots following a command, such as Find and Replace... in the Edit menu.
• Commands that open further submenus. These are indicated by a right-pointing arrow following a command, such as **Toolbars** and **Zoom**, in the **View** menu. Moving the mouse pointer onto one of these items opens its submenu.

![Image of LibreOffice Writer interface]

**Figure 1: Parts of the main Writer window**

**Sidebar**

The Sidebar is normally open by default on the right side of the Writer window, as shown in Figure 1. If necessary, select **View > Sidebar** on the Menu bar to display it. The Sidebar also has a **Hide/Show** icon, as shown in Figure 2. When the Sidebar is closed, this icon is on the far right of the window; click it to open the Sidebar.

The Writer Sidebar contains eight decks by default: **Properties**, **Styles** (also shown as **Styles and Formatting** in some installations), **Gallery**, **Navigator**, **Page**, **Style Inspector**, **Manage Changes**, and **Accessibility Check**. Each deck can be opened by clicking its corresponding icon on the Tab bar to the right of the sidebar.

Each deck consists of a title bar and one or more content panels. A panel is like a combination of toolbar and dialog. Toolbars and Sidebar panels share many functions. For example, the icons for making text bold or italic exist in both the Formatting toolbar in the main Writer window and the Character panel of the Properties deck.

Some panels contain a **More Options** button, which opens a dialog with additional editing controls. When the dialog is open, the document is locked for other editing.

To adjust the width of the Sidebar, place the mouse pointer on its left edge. When a double-headed arrow appears, click and drag to right or left. You cannot make the Sidebar smaller than a certain width, which varies depending on which deck is open.

To undock the Sidebar and make it floating, and to dock a floating Sidebar, use the drop-down list in the Sidebar Settings located above the Tab bar (see Figure 3). In the same list, you can use the **Customization** menu to choose which tabs to include in the Sidebar.
The decks contained in the Writer Sidebar are described below.

**Properties deck:** Contains tools for directly formatting content.

When text is selected, these panels appear:

- **Style:** Apply, create, or update a paragraph style.
- **Character:** Modify text properties such as the font name, size, color, weight, or character spacing.
- **Paragraph:** Modify a paragraph’s alignment, background color, indent, and spacing, and toggle numbered or bulleted lists.

*Figure 2: Properties deck of Sidebar*

*Figure 3: Sidebar Settings menu*

The decks contained in the Writer Sidebar are described below.

**Properties deck:** Contains tools for directly formatting content.

When text is selected, these panels appear:

- **Style:** Apply, create, or update a paragraph style.
- **Character:** Modify text properties such as the font name, size, color, weight, or character spacing.
- **Paragraph:** Modify a paragraph’s alignment, background color, indent, and spacing, and toggle numbered or bulleted lists.
When the cursor is in a **table**, this panel appears in addition to the panels for text:

- **Table**: Modify table properties such as insert or delete rows, merge or split cells, define row height and column width, background color or image, and borders.

When a **graphic** or **image** is selected, these panels appear:

- **Area**: Modify the fill mode and transparency of the background.
- **Wrap**: Modify the position of the graphic relative to surrounding text, where these modifications are available.
- **Image**: Modify the graphic's brightness, contrast, color mode, or transparency.
- **Position and Size**: Modify width, height, rotation, or flip.

When a **drawing object** is selected, these panels appear:

- **Area**: Modify the fill mode and transparency of the background.
- **Position and Size**: Modify width, height, rotation, or flip.
- **Line**: Modify arrows, line style, width, color, or transparency.
- **Effect**: Add and adjust a Glow or Soft Edge effect to the object.

When a **frame** is selected, these panels appear:

- **Area**: Modify the fill mode and transparency of the background.
- **Wrap**: Modify the position of the graphic relative to surrounding text, where these modifications are available.

When a **video** or **audio clip** is selected, these panels appear:

- **Media Playback**: Control for play, pause, stop, seek, loop, and volume.
- **Position and Size**: Modify width and height.

**Styles deck**: Manage the styles used in the document, apply existing styles, create new styles, or modify them. For more information, see Chapter 8, Introduction to Styles, and Chapter 9, Working with Styles.

**Gallery deck**: Shows images and diagrams included in the Gallery themes. The Gallery has two sections: the first lists the themes by name (Arrows, Bullets, Diagrams, and so on) and the second displays the images in the selected theme. For more information on using the Gallery to add images to a document, create new themes and add your own images, see Chapter 11, Images and Graphics.

**Navigator deck**: Browse the document and reorganize its content by selecting content categories, such as headings, tables, frames, images, and so on. For more information, see “Using the Navigator” on page 39.

**Page deck**: Contains tools for formatting the page style. It has four panels:

- **Format**: Modify size, width, height, orientation, and margins of the page.
- **Styles**: Modify page numbering style, background, layout, and number of columns.
- **Header**: Activate/deactivate header and modify its margins, spacing, and contents.
- **Footer**: Activate/deactivate footer and modify its margins, spacing, and contents.

**Note**

Changing the options on the Page deck modifies the page style in use, affecting not only the current page but all pages using the same page style in this document.
Style Inspector deck: Displays all the attributes of paragraph styles, character styles, and manual (direct) formatting. For more information, see Chapter 9, Working with Styles.

Manage Changes deck: Lists tracked changes that have not yet been accepted or rejected. Double-click to jump to the location of the change. For more information, see Chapter 3, Working with Text: Advanced.

Accessibility Check deck: Lists accessibility issues found in the document. Double-click to jump to the location of the problem. For more information, see Chapter 7, Printing and Publishing.

Toolbars

Toolbars can be docked (fixed in place) or floating. Docked toolbars can be moved to different locations or made to float, and floating toolbars can be docked.

In a default LibreOffice installation (Figure 1), the top toolbar, just under the Menu bar, is called the Standard toolbar.

The second toolbar at the top is the Formatting toolbar. It is context-sensitive; that is, it shows the tools relevant to the current position of the cursor or the selected object. For example, when the cursor is in text, the Formatting toolbar provides tools for formatting text. When the cursor is on a graphic (image), the tools are for formatting images.

Writer includes several additional toolbars, which correspond to the current position of the cursor or selection. For example, when the cursor is in a table, the Table toolbar appears; and when the cursor is in a numbered or bulleted list, the Bullets and Numbering toolbar appears.

To free more space for the document, you can choose a single-toolbar alternative containing the most-used commands. To activate it, select View > User Interface > Single Toolbar.

Displaying or hiding toolbars

To display or hide toolbars, go to View > Toolbars on the Menu bar, then click the name of a toolbar in the drop-down list. An active toolbar shows a check mark beside its name. Note that toolbars created from tool palettes are not listed in the View menu.

To hide a toolbar, go to View > Toolbars on the Menu bar and deselect the toolbar, or right-click in an empty space between the icons on a toolbar and select Close Toolbar in the context menu.

Sub-menus and tool palettes

Toolbar icons with a small triangle to their right will display sub-menus, tool palettes, or other methods of selecting items, depending on the icon.

A tool palette is a pop-up collection of tools attached to a single tool in a toolbar. The palette can be made into a floating toolbar, as shown in Figure 4. Once removed from the parent toolbar, it displays a Title bar. Tool palettes can be floating or docked along an edge of the screen or in one of the existing toolbar areas.

![Figure 4: Example of tearing off a tool palette: click on the dots to form a floating toolbar](image-url)
Tip

If the dots at the top of the tool palette are not visible, the toolbar is locked. Unlock the toolbar as described in "Locking and unlocking toolbars" below.

**Locking and unlocking toolbars**

You can lock all toolbars, or individual toolbars, into place so they cannot be moved. When all toolbars are locked, you cannot unlock individual ones.

To lock all toolbars in place, go to View > Toolbars on the Menu bar and select **Lock Toolbars** at the bottom of the submenu. Restart LibreOffice for this change to take effect. To unlock all toolbars, click on **Lock Toolbars** again.

To lock an individual toolbar into place, be sure **Lock Toolbars** is not selected on View > Toolbars, then right-click on the toolbar and select **Lock Toolbar Position** in the context menu.

**Docking, locking, and moving toolbars**

Docked toolbars are indicated by dotted handles on the left end (Figure 5). They can be undocked and moved to a new docked position or left as a floating toolbar.

To undock a toolbar:

1) Move the mouse pointer over the toolbar handle, which is the small vertical bar to the left of a docked toolbar, as shown in Figure 5.

2) Click and hold down the left mouse button and drag the toolbar to a new location.

3) Release the mouse button.

![Figure 5: Toolbar handles](image)

To move a floating toolbar, click and hold down its title bar and drag it to a new floating location or dock the toolbar at the top or bottom of the main window.

To dock a floating toolbar, hold down the `Ctrl` key and double-click in the title bar of the toolbar.

Tip

If the toolbar handle is not displayed, its position is locked. To unlock the toolbar, right-click it and then deselect the option **Lock Toolbar Position**.

To dock a floating toolbar, right-click somewhere in the toolbar and choose **Dock Toolbar** in the context menu. To dock all floating toolbars, right-click and choose **Dock All Toolbars**.

To lock a docked toolbar into its position, right-click and choose **Lock Toolbar Position**. Locking maintains the toolbar’s position even when other toolbars on the same bar change location.

To close a selected toolbar, right-click and choose **Close Toolbar**.

**Customizing toolbars**

You can customize toolbars in several ways, including choosing which icons are visible and locking the position of a docked toolbar. You can also add icons and create new toolbars, as described in Chapter 20, Customizing Writer. To access a toolbar’s customization options, right-click anywhere on the toolbar to open a context menu.
• To show or hide icons defined for the selected toolbar, move the mouse pointer to **Visible Buttons** in the context menu. Visible icons are indicated by an outline around the icon or by a check mark beside the icon (Figure 6), depending on your operating system. Select or deselect icons to hide or show them on the toolbar.

• To open the Customize dialog, click **Customize Toolbar** or choose **View > Toolbars > Customize**. See Chapter 20, Customizing Writer, for more information.

Figure 6: Toolbar context menu and selection of visible toolbar icons:
1) Right-click anywhere on the toolbar; 2) Point to Visible Buttons; 3) Visible icons are marked.

**Rulers**

The horizontal ruler across the top of the workspace is visible by default but the vertical ruler on the left is hidden by default. To enable the vertical ruler, choose **View > Rulers > Vertical Ruler** on the Menu bar, or choose **Tools > Options > LibreOffice Writer > View** (macOS: **LibreOffice > Preferences > LibreOffice Writer > View**). To quickly show or hide both rulers, use the key combination `Ctrl+Shift+R`.

**Tip**

The horizontal ruler has a comments button on its right end; click this to quickly show or hide any comments.
Status bar

The Writer Status bar is located at the bottom of the workspace. It provides information about the document and convenient ways to quickly change some document features. It can be hidden by deselecting it in the View menu.

![Writer Status bar, left end](image1)

**Figure 7: Writer Status bar, left end**

**Document changes status**
This icon changes color to indicate whether the document has unsaved changes. You can click this icon to save the document.

**Page number**
Shows the sequence number of the current page, the total number of pages in the document, and the current page number (if different from the sequence number). For example, if page numbering was restarted at 1 on the fifth page, its page number is 1 and its sequence number is 5.

If any bookmarks have been defined in the document, a right-click on this field shows a list of bookmarks. Click a bookmark to move the cursor to that location in the document.

To jump to a specific page in the document, left-click this field to open the Go to Page dialog (Figure 14 on page 39). Type the desired page number and click **OK**.

**Word and character count**
The word and character counts of the document are shown in the Status bar, and are updated as you edit. If you select a portion of text, the count for that selection will temporarily replace the document total count.

The character count shown here includes spaces. To display the character count excluding spaces, click on this field or choose **Tools > Word Count** on the Menu bar. To see the number of words and characters (and other information including the number of pages, tables, and images) in the entire document, go to **File > Properties > Statistics**.

**Status of the accessibility check**
If **Tools > Automatic Accessibility Checking** is selected on the Menu bar, this field shows an icon, with a tooltip indicating the number of accessibility issues found in the document. The Accessibility Check tab in the Sidebar provides details.

**Page style**
Shows the page style of the current page. To select a different page style, right-click on this field. A list of page styles pops up; click on one to select it. To edit the attributes of the current page style, left-click on this field. The Page Style dialog opens.

⚠️ **Caution**
Changing the page style here may affect the styles assigned to other pages, depending on how the page styles are set up. See Chapters 8 and 9 for details.
Text Language
Shows the language and localization used for spelling, hyphenation, and the thesaurus. It is based on the position of the cursor or the selected text.

Click to open a menu where you can choose another language or localization for the selected text or for the paragraph where the cursor is located. You can also choose None (Do not check spelling) to exclude the text from a spelling check or Reset to default language. Choosing More... opens the Character dialog. See Chapter 3, Working with Text: Basics, for more information.

Insert mode
Click to change to Overwrite mode; click again to return to Insert mode. In Insert mode, any text after the cursor position moves forward to make room for the text you type; in Overwrite mode, text after the cursor position is replaced by the text you type. You cannot switch modes when Edit > Track Changes > Record is active.

Selection mode
Click to display a list of the selection modes (Standard, Extending, Adding, and Block), then click on one to activate it. The icon changes to indicate the mode, and a tooltip shows which mode is active. See Chapter 3, Working with text: Basics, for more information.

Digital signature
If the document has been digitally signed, an icon is displayed here; otherwise, it is blank. Click here to sign the document or to view the existing certificate. See Chapter 7, Printing and Publishing, for more information.

Section or object information
When the cursor is in a section, heading, or list item, or when an object (such as an image or table) is selected, information about that item appears here. Click in this area to open a relevant dialog, as indicated in the tooltip for this area.

Table 2: Section or object information in Status bar

<table>
<thead>
<tr>
<th>Object</th>
<th>Information shown</th>
<th>Dialog opened</th>
</tr>
</thead>
<tbody>
<tr>
<td>Image or Frame</td>
<td>Size and position</td>
<td>Image or Frame</td>
</tr>
<tr>
<td>List item</td>
<td>Level and (if relevant) list style</td>
<td>Bullets and Numbering. If a list style was used, no dialog appears.</td>
</tr>
<tr>
<td>Heading</td>
<td>Heading numbering level and (if relevant) list style</td>
<td>Bullets and Numbering. If a list style was used, no dialog appears.</td>
</tr>
<tr>
<td>Table</td>
<td>Name or number and cell reference of cursor</td>
<td>Table Properties</td>
</tr>
<tr>
<td>Section</td>
<td>Name of section</td>
<td>Edit Sections</td>
</tr>
<tr>
<td>Index</td>
<td>Type of index</td>
<td>Table of Contents, Index or Bibliography</td>
</tr>
<tr>
<td>Others</td>
<td>Varies</td>
<td>Varies</td>
</tr>
</tbody>
</table>

View layout
Click the corresponding icon to change between single-page, multiple-page, and book layout views (Figure 9). You can edit the document in any view. Zoom settings interact with the selected view layout and the window width to determine how many pages are visible in the document window.
Figure 9: View layouts: single-page, multiple-page, book

**Zoom**

To change the view magnification, drag the Zoom slider, or click the + and − signs, or right-click the zoom level percent to pop up a list of magnification values from which to choose. Zoom interacts with the selected view layout to determine how many pages are visible in the document window.

**Context (right-click) menus**

Context menus provide quick access to many menu functions. They are opened by right-clicking on a paragraph, graphic, or other object. When a context menu opens, the functions or options available will depend on the object that has been selected. This can be the easiest way to reach a function, especially if you are not sure where the function is located in the menus or toolbars.

**Dialogs**

A dialog is a special type of window. Its purpose is to inform you of something, or request input from you, or both. It provides controls for you to specify how to carry out an action.

In most cases, you can interact only with the dialog (not the document itself) as long as the dialog remains open. When you close the dialog, then you can again work with the document. (Usually, clicking **OK** or a similar button saves your changes and closes the dialog; clicking **Cancel** closes the dialog without saving any changes.)

Some dialogs can be left open as you work, so you can switch back and forth between the dialog and the document. An example of this type is the Find & Replace dialog.

**Document views**

Writer has three ways to view and edit a document: **Normal**, **Web**, and **Full Screen**. To change the view, go to the **View** menu and select the required view.

**Normal view**

Normal view is the default view in Writer. It shows how the document will look when printed it or exported as a PDF. In this view, you can use the Zoom slider and the View Layout icons on the Status bar to change the magnification. You can also hide or show the headers and footers and the gap between pages, by selecting **View > Show Whitespace** on the Menu bar. This works only when single-page view is active on the Status bar. Hiding whitespace also works in Full Screen view.
Web view
Web view shows how the document will look if viewed in a Web browser; this is useful when creating HTML documents. In Web view, you can use only the Zoom slider. The View Layout icons on the Status bar are disabled, and most of the choices on the Zoom & View Layout dialog are not available.

Full Screen view
In Full Screen view, no toolbars or sidebar are displayed; the document takes up the full area available, using the zoom and layout settings previously selected. To exit Full Screen view and return to the previous view, press the Esc key or click the Full Screen button on the floating toolbar in the top left-hand corner. You can also use Ctrl+Shift+J to enter or exit Full Screen view.

Tip
You can also view a document using File > Print Preview, or press Ctrl+Shift+0, but this view does not allow editing. See Chapter 7, Printing and Publishing.

Starting a new document
You can start a new, blank document in Writer in several ways. If a document is already open in LibreOffice, the new document is created in a new window.

- When LibreOffice is running but no document is open, the Start Center (Figure 10 on page 32) is shown. Click one of the icons to open a new document of that type, or click the Templates icon to start a new document using a template.
- Use File > New on the Menu bar and select the type of document in the submenu.
- When Writer is open, use the keyboard shortcut Ctrl+N to create a new Writer document.
- If a document is already open in LibreOffice, click the New icon on the Standard toolbar and a new document of the type shown on the icon is created in a new window. The New icon changes depending on which component of LibreOffice was last created.
- If a document is already open in LibreOffice, click on the small triangle to the right of the New icon on the Standard toolbar and select the type of document in the context menu.

From the Start Center
When LibreOffice is open but no document is open, the Start Center (Figure 10) is shown. Click Create: Writer Document to create a new text document, or click Templates and choose a template to start a new document using a template other than the default template.

To filter the collection of documents shown, select a document type in the Filter drop-down list. To remove from the list any documents that are no longer available (for example, if they have been renamed or moved in the file system on your computer or network), use the drop-down on the top right.
A template is a set of predefined styles and settings that is used to create a new document. Templates enable the easy creation of multiple documents with the same default settings. For example, all the chapters of the *Writer Guide* are based on the same template. As a result, all the chapters look alike; they have the same headers and footers, use the same fonts, and so on.

A new LibreOffice installation may contain only a few templates, but you can create your own or download more from [https://extensions.libreoffice.org/](https://extensions.libreoffice.org/) and other websites. See Chapter 10, Working with Templates.

To open the Template dialog, do one of the following:

- Press the `Ctrl+Shift+N` keys.
- Choose **File > Templates > Manage Templates** on the Menu bar.
- Choose **File > New > Templates** on the Menu bar.
- Click the arrow next to the **New** icon on the Standard toolbar and select **Templates** in the drop-down list.

The example shown in Figure 11 highlights a template in the **Documents** folder. To create a new document based on that template, double-click the desired template or right-click the template and then click **Open**. For more about the Templates dialog, see Chapter 10, Working with Templates.
Opening an existing document

You can open an existing document in several ways. When no document is open:

- Click **Open File** or **Remote files** in the Start Center.
- Choose **File > Open** or **File > Open Remote** on the Menu bar.
- Press **Ctrl+O** on the keyboard.
- Click a thumbnail in the list of recently opened documents displayed in the Start Center. You can scroll up or down in the Start Center to locate a recently opened document.

**Note**

Renamed or relocated documents can still be listed in the Start Center. Selecting one gives an error message that the file does not exist. To remove the thumbnail from the Start Center, hover the mouse pointer over the thumbnail until an X appears in the upper right corner, and then click on the X.

If a document is already open:

- Click the **Open** icon on the Standard toolbar.
- Click the small triangle to the right of the **Open** icon and select from a list of recently opened documents, or select **Open Remote File**.
- Use **File > Recent Documents** to make a selection from the submenu.

When using the Open dialog, navigate to the relevant folder, select the file, then click **Open**. If a document is already open in LibreOffice, the second document opens in a new window.
You can reduce the list of files in the Open dialog by selecting the type of file required. For example, choose *Text documents* as the file type to see only documents that Writer can open. This method opens Word files (*.doc and *.docx) and other formats as well as OpenDocument files (*.odt).

You can also open an existing Writer document using the same methods you would use to open any document in your operating system.

**Opening files not in OpenDocument Text (.odt) format**

You can open an existing document that is in a format that LibreOffice recognizes by double-clicking on the file icon on the desktop or in a file manager such as Windows Explorer or macOS Finder. LibreOffice may need to be associated with file types that are not ODF files for the appropriate LibreOffice component to open.

For example, on a Windows computer, if Microsoft Office is not installed or if Microsoft Office is installed but Word file types (*.doc or *.docx) have been associated with LibreOffice, then double-clicking on a Word file opens it in LibreOffice Writer.

If Microsoft Office is installed on the computer, and Word file types have not been associated with LibreOffice, then double-clicking on a Word file opens it in Microsoft Word.

On macOS, if Microsoft Office is not installed and you have not associated those file types with LibreOffice, double-clicking a file may open it in Apple’s Pages application.

To avoid files opening in the wrong application, do not double-click on them; instead, right-click on the file and select *Open with > LibreOffice*.

See the LibreOffice Help for more about file associations.

**Saving a document**

To save a document, use any of the following commands:

- **Save** – use to keep the document, its current filename and location.
- **Save As** – use to create a new document, or change the filename and/or file format, or save the file in a different location on your computer.
- **Save Remote** – use if your document is already stored in a remote server or will be stored in a remote server.
- **Save a Copy** – use to save a copy of your current document and keep the current document open for more editing.
- **Save All** – use to save all the files open in your current session.

**Save commands**

*Save a new file or a previously-saved file*

Do one of the following:

- Press `Ctrl+S`.
- Choose *File > Save* on the Menu bar.
- Click the *Save* icon on the Standard toolbar.

If the file has not been saved previously, a Save As dialog appears after selecting one of the above options. Enter the file name, verify the file type and location, and click *Save*.

If a previously-saved file is being saved with the same file name, file type, and location, nothing else needs to be done.
Save to a remote server
Use this command to store the document on a remote server, or if it is already stored on a remote server.
Choose File > Save Remote. When the Save As dialog appears, enter or verify the name, type, and location, then click Save.
See “Opening and saving files on remote servers” on page 38 for more information.

Save a copy
Use this command to keep the document open for more editing and also save a separate copy of the current version.
Choose File > Save a Copy. When the Save As dialog appears, enter or verify the name, type, and location, then click Save. The copy is not opened and the original file remains open and active.

Save all
Use this command to save all files open in the current session.
Choose File > Save All. All open files will be saved without changes to name, type, or location.

Save As command
Use this command to save the current version as a new document by changing the file name or file type, or by saving the file in a different location on your computer.
Choose File > Save As, or use Ctrl+Shift+S to open a Save As dialog where you can change the file name, type, or location, and click Save.
To preserve the original file, first save a copy as described above.

Note
LibreOffice uses the term “export” for some file operations involving a change of file type, such as PDF and ePub. See Chapter 7, Printing and Publishing, for more information.

Saving documents automatically
By default, Writer saves documents automatically in a temporary file at regular intervals and creates backup copies. To set or change the time interval, or to turn off automatic saving or backup copies:

1) Select Tools > Options > Load/Save > General on the Menu bar (macOS: LibreOffice > Preferences > Load/Save > General).
2) Click Save AutoRecovery information every and set the time interval.
3) Optionally, select Always create backup copy.
4) Click OK to save the changes.
5) At the prompt to restart LibreOffice, choose to restart immediately or later. The changes will be active after the restart.

Backup copies accumulate in the folder specified in Tools > Options > LibreOffice > Paths.
For more information see Chapter 20, Setting Up Writer.
Saving as a Microsoft Word document

You may need to save documents in Microsoft Word formats such as .docx. To do this:

1) Important: If the file is in Writer’s format (.odt), first save the document in that format. If you do not, any changes made since the last time you saved will only appear in the Microsoft Word version of the document.

2) Then click File > Save As.

3) On the Save As dialog, in the File type drop-down menu, select the type of Microsoft Word format required. You may also choose to change the file name.

4) Click Save.

This creates a separate document with a different file extension. From this point on, all changes made to the document will occur only in the new document. To work with the .odt version of the document, you must open it again.

**Tip**

To have Writer save documents by default in a Microsoft Word file format, go to Tools > Options > Load/Save > General (macOS: LibreOffice > Preferences > Load/Save > General). In the section named Default File Format and ODF Settings, next to Document type, select Text document, then under Always save as, select your preferred file format.

Exchanging documents with users of Apple Pages

Although Writer can open and edit files in Apple Pages format (*.pages), it cannot save in that format or export to that format. Apple Pages cannot open files in OpenDocument format, so if you need to share files with users of Pages, save your .odt file to a compatible format, such as .rtf or .docx.

Pages users can also export (not save) a copy of a Pages document in a format compatible with Writer, such as .docx or .rtf, which writer can then open, edit, and save to.

Using password protection and OpenPGP encryption

LibreOffice provides two types of document protection: password protection and OpenPGP encryption. Files encrypted with the Save password cannot be decrypted without the password, which must be sent to each user who needs to decrypt the document. With OpenPGP encryption, the document is encrypted using an algorithm, which requires a key. Each key is used only once and is sent to the recipient along with the document.

Password protection

LibreOffice provides two levels of password protection: read-protect (file cannot be viewed without a password) and write-protect (file can be viewed in read-only mode but cannot be changed without a password). Thus you can make the content available for reading by one group of people and for reading and editing by a different group. This behavior is compatible with Microsoft Word file protection.

To protect a document with passwords:

1) Use File > Save As when saving the document. (You can also use File > Save the first time you save a new document.)

2) On the Save As dialog, select the Save with password option in the lower left corner (Figure 12), and then click Save.
3) The Set Password dialog opens (Figure 13). Here you have several choices:
   – To read-protect the document, type a password in the two fields at the top of the
dialog.
   – To write-protect the document, click the *Options* button and select *Open file read-
only* in the *File Sharing Password* section.
   – To write-protect the document but allow selected people to edit it, select *Open file
   read-only* and type a password in the two boxes at the bottom of the dialog.

4) Click **OK** to save the file. If either pair of passwords does not match, an error message
appears. Close the message box to return to the Set Password dialog and enter the
password again.

**Caution**
LibreOffice uses a very strong encryption mechanism that makes it almost
impossible to recover the contents of a document if the password is lost.

**Changing or removing the password for a document**
When a document is password-protected, you can change or remove the password while the
document is open. Choose **File > Properties > General** and click the **Change Password** button.
OpenPGP encryption

LibreOffice uses the OpenPGP software installed on your computer. If no OpenPGP software is available, you must download and install one suitable for your operating system before you can use this option.

You must define a personal pair of cryptography keys with the OpenPGP application. Refer to the OpenPGP software installed on how to create a pair of keys. For more information on using this form of encryption, see the supplied Help.

OpenPGP encryption requires the use of the public key of the recipient; this key must be available in the OpenPGP key chain stored in your computer.

To encrypt a document:

1) Choose File > Save As.
2) In the Save As dialog, enter a name for the file.
3) Select the Encrypt with GPG key option (see Figure 12). [GPG (GNU Privacy Guard) is an implementation of the Open PGP standard.]
4) Click Save. The OpenPGP public key selection dialog opens.
5) Choose the public key of the recipient. You can select multiple keys.
6) Click OK to close the dialog and save the file encrypted with the selected public keys.

Opening and saving files on remote servers

LibreOffice can open and save files stored on remote servers (that is, not on your computer or local area network). Keeping files on remote servers allows you to work with the documents using different computers. For example, you can work on a document in the office and also at home or elsewhere. Storing files on a remote server also backs up documents, saving data from computer loss or hard disk failure. Some servers are also able to check files in and out, thus controlling their usage and access.

LibreOffice supports many document servers that use well-known network protocols such as FTP, WebDav, Windows share, and SSH. It also supports popular services like Google Drive and Microsoft OneNote, as well as commercial and open source servers that implement the OASIS CMIS standard. For more information, see the Getting Started Guide.

Moving quickly through a document

Writer provides ways to move quickly through a document and find specific items, including:

- Go to Page
- Navigator
- Outline folding
- Reminders

Using Go to Page

You can jump to a specific page in the document in these ways:

- Use the Go to Page field on the top right of the Navigator (see Figure 15).
- Use the Go to Page dialog (Figure 14), which shows the current page number and the number of pages in the document. Type the number of the destination page in the text box and click OK.
To open the Go to Page dialog, do any of the following:

– Click on the page number field on the Status Bar.
– Choose **Edit > Go to Page** on the Menu bar.
– Press `Ctrl+G` on the keyboard.

![Go to Page dialog](image)

*Figure 14: Go to Page dialog*

**Using the Navigator**

In a default installation of LibreOffice, the Navigator is part of the Sidebar. It lists all of the headings, tables, text frames, graphics, bookmarks, and other objects contained in a document.

To open the Navigator (Figure 15), do one of the following:

- Click the **Navigator** tab in the Tab bar on the right of the Sidebar.
- Click the **Navigator** icon (if visible) on the Standard toolbar.
- Press `F5`.
- Choose **View > Navigator** on the Menu bar.

Click the + sign or triangle to the left of a category or subcategory to display its contents.

| Note | In a master document, the Navigator has different functions. See Chapter 16, Master Documents. |

The Navigator provides several convenient ways to move around a document and find items in it:

- To jump to a specific page in the document, type its sequence number in the box at the top of the Navigator and press *Enter*. The sequence number may be different from the page number if numbering has been restarted at any point.
- When a category is opened to show the list of items in it, double-click an item to jump directly to that item's location in the document. For example, you can jump directly to a selected heading, image, or comment by using this method. The item is highlighted in the document.
- To see the contents in only one category, click on that category and then click the **Content Navigation View** icon. Click the icon again to display all the categories. You can also change the number of heading levels shown when viewing Headings.
- Use the **Previous** and **Next** icons to jump to other objects of the type selected in the Navigate By drop-down list.
- In the top left of the Navigator is a *Navigate By* drop-down list. Pick a type of object (such as a bookmark, table, or index entry) and then use the Previous (`^`) and Next (`v`) buttons to jump from one to the next (Figures 15 and 16).
Table 3: Function of icons in the Navigator

1. Navigate By  
   Opens a drop-down list where you can select the type of element by which you want to navigate.

2. Header/Footer  
   Jumps between the text area and the header or footer area (if the page has them).

3. Anchor <-> Text  
   Jumps between a footnote anchor and the corresponding footnote text.

4. Set Reminder  
   Inserts a reminder. See “Setting reminders” on page 41.

5. Previous/Next  
   Jumps to the previous/next element of the type selected in the Navigate By drop-down list.

6. Go to Page  
   Jumps to the page number shown in the box. Type a page number or select it using the + and – signs.

7. Content Navigation View  
   Switches between showing all categories and showing only the selected category.

8. List Box On/Off  
   Toggles between having the list box shown or hidden.

9. Heading Levels Shown  
   Choose the number of heading levels to be shown.

10. Drag Mode  
    Select Insert as Hyperlink, Link, or Copy. See Chapter 3, Working with Text: Advanced.

11. Promote/Demote Level  
    Quickly change the level of the selected heading in the document. See Chapter 3, Working with Text: Advanced.

12. Promote/Demote Chapter  

Note
A hidden section (or other hidden object) in a document appears gray in the Navigator, and displays the word “hidden” as a tooltip. For more about hidden sections, see Chapter 6, Formatting Pages: Advanced.
Objects are much easier to find if they have identifying names, and object names are important for accessibility. By default, LibreOffice gives objects names such as Image1, Image2, Table1, Table2, and so on. These names are assigned in the order in which the objects are added to the document, which may not correspond to the location of the object in the document.

You can rename objects after inserting them. For example, to rename an image, right-click its name in the Navigator, choose Image in the context menu, then choose Image > Rename. The view jumps to the image (to show which one it is) and a small dialog pops up. Type a new name for the image and click OK to save.

Using outline folding
Using outline folding, you can hide and show all content under headings, including text, images, tables, frames, shapes, and text boxes. In large documents, this feature can help you quickly scroll to the right position for editing and reading.

To enable this feature, go to Tools > Options > LibreOffice Writer > View (macOS: LibreOffice > Preferences > LibreOffice Writer > View) and select Show outline-folding buttons. Optionally select Include sub levels.

Outline folding works with the Navigator and directly using a mouse. For more information, see Chapter 3, Working with Text: Advanced.

Setting reminders
Reminders let you mark places in your document that you want to return to later on, for example to add or correct information or simply mark where you finished editing.

To set a reminder at the cursor’s current location, click the Set Reminder icon in the Navigator. You can set up to 5 reminders in a document; setting a sixth causes the first to be deleted.
Reminders are not highlighted in any way in the document, nor are they listed in the Navigator, so you cannot see where they are, except that when you jump from one to the next, the location of the cursor shows the location of the reminder.

To jump between reminders, first select the **Reminder** option in the Navigate By drop-down list. Then click the **Previous** and **Next** icons.

Reminders are not saved with the document.

## Undoing and redoing changes

To undo the most recent change in a document, press `Ctrl+Z`, choose **Edit > Undo** on the Menu bar, or click the **Undo** icon on the Standard toolbar.

To get a list of all the changes that can be undone, click the small triangle to the right of the **Undo** icon on the Standard toolbar. You can select several sequential changes on the list and undo them at the same time (Figure 17).

![Figure 17: List of actions that can be undone](image)

After changes have been undone, **Redo** becomes active. To redo a change, select **Edit > Redo**, or press `Ctrl+Y` or click the **Redo** icon on the Standard toolbar. As with **Undo**, click the down arrow icon of the combination icon to get a list of the changes that can be restored.

## Displaying multiple views of a document

You can open, view, and edit several views of the same document in LibreOffice at the same time. These views are displayed in windows that can show different pages or use different zoom levels or other settings. A change to the document in one window is immediately reflected in the other windows. In Writer, for example, you might find this useful for copying or moving information from one page to another.

To open a new window showing the document, go to **Window > New Window** on the Menu bar. In each window opened, the filename in the title bar is automatically numbered as shown by the example in Figure 18.

If other LibreOffice documents are open at the same time, the list of windows also includes them. The active window has a marker by its filename in the list. You can switch between windows by clicking on a name in the list, or by clicking on the window itself if it is visible on the display.

To close the active window, go to **Window > Close Window** on the Menu bar, or use the keyboard shortcut `Ctrl+w`, or click the **Close** icon on the Menu bar or Title bar of the window.
Reloading a document

Reloading is useful in two situations.

- To discard all the changes made in an editing session after the last document save.
- To show any formatting changes that do not show until the document has been closed and reopened; saving and then reloading has the same result.

To reload a document, go to File > Reload on the Menu bar. If you have made changes to a file since the last save, a confirmation dialog will warn you that reloading will discard your last changes. Choose whether to save or discard the changes.

Closing a document

To close a document, go to File > Close on the Menu bar or click the X on the right or left end of the Menu bar (in Windows and Linux) or the Title bar (in macOS). When you close the last document in Windows or Linux, the LibreOffice Start Center opens. In macOS, only the Menu bar remains at the top of the screen.

If the document has not been saved since the last change, a message box is displayed. Choose whether to save or discard your changes.
Chapter 2,
Working with Text: Basics
Introduction

This chapter covers the basics of working with text in Writer. It assumes that you are familiar with the use of a mouse and keyboard and that you have read about Writer’s menus and toolbars and other topics covered in Chapter 1, Introducing Writer.

We recommend also displaying formatting aids, such as end-of-paragraph marks, tabs, breaks, and other items in Tools > Options > LibreOffice Writer > Formatting Aids (macOS: LibreOffice > Preferences > LibreOffice Writer > Formatting Aids). To hide or display these markers, go to View > Formatting Marks. See Chapter 20, Setting up Writer, for more information.

This chapter covers the following topics:

- Selecting, cutting, copying, pasting, and moving text.
- Finding and replacing text.
- Inserting special characters.
- Checking spelling and grammar, using the thesaurus, and choosing hyphenation options.
- Using the AutoCorrect, Word Completion, AutoText, and case-changing features.

See also Chapter 3, Working with Text: Advanced, and Chapter 4, Formatting Text.

Selecting text

Selecting text in Writer is similar to selecting text in other applications. You can swipe the mouse pointer over text or use multiple clicks to select a word (double-click), sentence (triple-click), or paragraph (quadruple-click).

You can also click in the text, press F8 to enter Extending selection mode, and then use the arrow keys on the keyboard to select a contiguous block of text. Press F8 again when finished selecting the block of text.

In addition, you can select non-contiguous items and vertical blocks of text.

One way to change the selection mode is to use the icon on the Status bar (see Figure 19).

When you right-click the icon, a context menu displays the options: Standard selection, Extending selection (F8), Adding selection (Shift+F8), and Block selection (Ctrl+Shift+F8). Click on an option to activate it.

![Figure 19: Changing the selection mode using the status bar](image)

Selecting items that are not consecutive

To select non-consecutive items (Figure 20) using the mouse in Standard selection mode:

1) Select the first piece of text.
2) Hold down the Ctrl key and use the mouse to select the next piece of text.
3) Repeat as often as needed.
To select non-consecutive items using the keyboard in Adding selection mode:

1) Select the first piece of text. For more information about keyboard selection of text, see the topic “Navigating and Selecting with the Keyboard” in the LibreOffice Help (F1).

2) Press Shift+F8, or click the Selection mode icon on the Status bar and select Adding Selection in the list, to enable Adding selection mode.

3) Use the arrow keys to move to the start of the next piece of text to be selected. Hold down the Shift key and select the next piece of text.

4) Repeat as often as required.

Now you can work with the selected text (copy it, delete it, change the style, and so on). After finishing your work with the selected text, press Esc to exit Adding selection mode.

```
Figure 20: Selecting non-consecutive pieces of text
```

### Selecting a vertical block of text

To select a vertical block of text that spans through multiple rows, use Writer’s Block selection mode. Go to Edit > Selection Mode > Block Area, or press Ctrl+F8, or click the Selection mode icon on the status bar and select Block selection in the list. Now you can highlight the selection, using mouse or keyboard, as shown in Figure 21.

```
Figure 21: Selecting a block of text
```
Cutting, copying, and pasting text

Cutting and copying text in Writer is similar to cutting and copying text in other applications. You can copy or move text within a document, or between documents, by dragging or by using menu selections, icons, or keyboard shortcuts. You can also copy text from other sources such as Web pages and paste it into a Writer document.

- To move (drag and drop) selected text using the mouse, drag it to the new location and release it; the cursor changes shape while dragging.
- To copy selected text, hold down the Ctrl key while dragging. The text retains the formatting it had before dragging.
- To move (cut and paste) selected text, use Ctrl+X to cut the text, insert the cursor at the paste-in point and use Ctrl+V to paste. Alternatively, use the Copy/Paste buttons on the Standard toolbar or the options under Edit on the Menu bar.

When you paste text, the result depends on the source of the text and how you paste it. If you click the Paste button, then the pasted text keeps its original formatting (such as bold or italics). Text pasted from websites and other sources may be placed automatically into frames or tables as part of the format when you paste. If you do not like the results, click the Undo button or press Ctrl+Z.

To make the pasted text inherit the paragraph style at the insertion point:

- Choose Edit > Paste Special, or
- Click the arrow on the combination Paste button, or
- Double-click the Paste button without releasing the left mouse button, or
- Press Ctrl+Shift+V

Then select Unformatted text or Paste Unformatted text in the resulting menu.

You can also press Ctrl+Alt+Shift+V, which pastes unformatted text directly.

The range of choices on the Paste Special menu varies depending on the origin and formatting of the text (or other object) to be pasted. Figure 22 shows an example with text on the clipboard.

![Figure 22: Paste Special menu](image)

Finding and replacing text

Writer has two ways to find text within a document: the Find toolbar for fast searching and the Find and Replace dialog. In the dialog, you can:

- Find and replace words and phrases.
- Use wildcards and regular expressions to fine-tune a search (see Chapter 3).
- Find and replace specific attributes or formatting (see Chapter 3).
- Find and replace paragraph styles (see Chapter 3).
Using the Find toolbar

By default, the Find toolbar is docked at the bottom of the LibreOffice window, just above the Status Bar (Figure 23), but you can float it or dock it in another location. For more information on floating and docking toolbars, see Chapter 1, Introducing Writer. If the Find toolbar is not visible, choose View > Toolbars > Find or Edit > Find on the Menu bar or press Ctrl+F.

![Figure 23: Docked position of Find toolbar](image)

To use the Find toolbar, click in the box and type the search text, then press Enter to find the next occurrence of that term. Click the Find Next or Find Previous (arrow) buttons as needed.

Click the Find All button to select all instances of the search term within the document. Select Match Case to find only the instances that exactly match the use of upper and lower case letters in the search term. To open the Find and Replace dialog, click the icon next to Match Case.

To close the Find toolbar, click the X button on the left, or press Esc on the keyboard when the cursor is in the search box.

Using the Find and Replace dialog

To display the Find and Replace dialog (Figure 24), use any of the following methods:

- Use the keyboard shortcut Ctrl+H (macOS: Cmd+Shift+F).
- Choose Edit > Find and Replace on the Menu bar.
- Click the Find and Replace button on the Find toolbar.

When the dialog is open, click Other options to expand it.

![Figure 24: Expanded Find and Replace dialog](image)
To use the Find and Replace dialog:

1) Type the text you want to find in the Find box.

2) To replace the text with different text, type the new text in the Replace box.

3) You can select various options, such as matching the case or matching whole words only.

   The other options include searching only in selected text, searching from the current cursor position backwards toward the beginning of the document, searching for similar words, searching in comments, and using regular expressions (wildcards). The use of other options is described in Chapter 3, Working with Text: Advanced.

   Additional options are shown when CTL or Asian languages have been selected in Tools > Options > Language Settings > Languages.

4) When you have set up the search, click Find Next. As the document view moves to each found instance, you can replace the text by clicking Replace or skip that instance by clicking Find Next again.

**Tip**

If you click Find All, Writer selects all instances of the search text in the document. Similarly, if you click Replace All, Writer replaces all matches, without stopping for you to accept each instance.

**Note**

Use Replace All with caution; otherwise, you may end up with mistakes that you won’t be able to undo later if you save and close the file. (Ctrl+Z works only before the file is saved.) A mistake with Replace All might require a manual, word-by-word, search to fix.

**Inserting special characters**

A special character is one not found on a basic English keyboard. For example, © ¾ æ ç Ł ñ ö ø ç are all special characters.

To insert one or more special characters, place the cursor in the position where you want the characters to appear. Then do one of the following:

- Click the Special Character icon on the Standard toolbar to open a list of favorite and recently used characters and click on one to insert it (Figure 25). You can also open the Special Characters dialog (Figure 26) by clicking the More Characters button in this list.

![Figure 25: Insert Special Characters icon on the Standard toolbar](image-url)

Chapter 2, Working with Text: Basics | 45
• Click **Insert > Special Character** to open the Special Characters dialog (Figure 26). Double-click the characters (from any font or mixture of fonts) you wish to insert, in order; they appear in the document as you select them. The selected characters are also added to the Recent Characters list on the lower left of the dialog.

![Special Characters dialog](image)

**Figure 26: Special Characters dialog**

**Tips**

To view details of a character, single-click it; details are shown on the right, along with its numerical code.

To insert a character and leave the dialog open, double-click the character. To insert a character and close the dialog, click it and then click the **Insert** button.

Different fonts include different special characters. If you do not find a special character you want, try changing the **Font** selection.

**Inserting non-breaking spaces, hyphens, and more**

You can insert a variety of formatting marks while typing or later. Most of these marks can be inserted using a keyboard shortcut; all are available in **Insert > Formatting Mark** on the Menu bar (Figure 27).

**Non-breaking space**

To prevent two words from being separated at the end of a line, press **Ctrl+Shift** when you type the space between the two words.

**Non-breaking hyphen**

Use a non-breaking hyphen (also called a hard hyphen) in cases where you do not want the hyphen to appear at the end of a line, for example in 123-4567. To insert a non-breaking hyphen, press **Shift+Ctrl+hyphen**.
Soft Hyphen
Soft hyphens (also called custom, discretionary, or optional hyphens) specify where words should be divided at the end of a line. If the word does not occur at the end of a line, the hyphen does not appear. To insert a soft hyphen, press Ctrl+hyphen.

Narrow No-break Space
For a non-breaking space that is not as wide as a normal space, press Alt+Shift while typing the space.

No-width Optional Break
Use Ctrl+/ to insert an invisible space in a word that will cause a line break if it is the last character in the line. Available when complex text layout (CTL) is enabled.

Word Joiner
Inserts an invisible space in a word that will keep the word together at the end of a line. In earlier versions of Writer, this mark was called No-width no break.

When complex text layout (CTL) is enabled, these additional formatting marks are active:

Left-to-right Mark
Inserts an invisible mark that affects the text direction of any text following the mark.

Right-to-Left Mark
Inserts an invisible mark that affects the text direction of any text following the mark.

Inserting en and em dashes
To enter en and em dashes as you type, you can use the Replace dashes option on the Options tab under Tools > AutoCorrect > AutoCorrect Options. This option replaces one or two hyphens, under certain conditions, with the corresponding dash (Table 4).

– An en-dash is a dash the width of the letter “n” in the font you are using. Type at least one character, a space, a hyphen, another space, and at least one more letter. The hyphen will be replaced by an en-dash.

— An em-dash is a dash the width of the letter “m” in the font you are using. Type at least one character, two hyphens, and at least one more character. The two hyphens will be replaced by an em-dash. Exception: if the characters are numbers, as in a date or time range, the two hyphens are replaced by an en-dash.
In Table 4, the A and B represent text consisting of letters A to Z or digits 0 to 9.

**Table 4: Inserting dashes**

<table>
<thead>
<tr>
<th>Text that you type</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>A - B (A, space, hyphen, space, B)</td>
<td>A – B (A, space, en dash, space, B)</td>
</tr>
<tr>
<td>A -- B (A, space, hyphen, hyphen, space, B)</td>
<td>A – B (A, space, en dash, space, B)</td>
</tr>
<tr>
<td>A--B (A, hyphen, hyphen, B)</td>
<td>A—B (A, em dash, B)</td>
</tr>
<tr>
<td>1--2 (number, hyphen, hyphen, number)</td>
<td>1–2 (number, en dash, number)</td>
</tr>
<tr>
<td>A-B (A, hyphen, B)</td>
<td>A-B (unchanged)</td>
</tr>
<tr>
<td>A-B (A, space, hyphen, B)</td>
<td>A -B (unchanged)</td>
</tr>
<tr>
<td>A--B (A, space, hyphen, hyphen, B)</td>
<td>A –B (A, space, en dash, B)</td>
</tr>
</tbody>
</table>

Another way to insert en and em dashes is through the **Insert > Special Characters** menu. Select the **U+2013** or **U+2014** character (found in the General punctuation subset), respectively.

A third method uses keyboard shortcuts. These shortcuts vary depending on your operating system, as described below.

**Tip**

You can also record macros to insert en and em dashes and assign those macros to unused key combinations, for example **Ctrl+Shift+N** and **Ctrl+Shift+M**. For more information about key combinations, see Chapter 20, Customizing Writer.

**macOS**

For an en dash, hold down the **Option (Alt)** key and type a hyphen. For an em dash, the combination is **Shift+Option+Hyphen**.

**Windows**

On most non-Asian installations of Windows, hold down the left **Alt** key and type on the numeric keypad: 0150 for an en dash or 0151 for an em dash. The dash appears when you release the **Alt** key.

**Tip**

On a keyboard with no numeric keypad, use a **Fn (Function)** key combination to type the numbers. (The **Fn** key is usually next to the right of the left-hand **Ctrl** key on the keyboard.) For example, on a US keyboard layout, the combination for an en dash should be **Alt+Fn+ming** and for an em dash it should be **Alt+Fn+miij**.

**Linux**

Hold down the **Compose** key and type two hyphens and a period for an en dash, or three hyphens for an em dash. The dash appears when you release the **Compose** key.

**Tip**

The key that operates as a **Compose** key varies with the Linux distribution. It is usually one of the **Alt** or **Win** keys, but may be another key, and should be user-selectable.
Checking spelling and grammar

By default, four dictionaries are installed for each language, if they are available for that language: a spelling checker, a grammar checker, a hyphenation dictionary, and a thesaurus. The spelling checker determines if each word in the document is in the installed dictionary. The grammar checker works in combination with the spelling checker. You can enable or disable the grammar checker in the Spelling dialog.

You can choose to check spelling and grammar automatically as you type and at any other time.

Spelling

To enable automatic checking of spelling, go to Tools on the Menu bar and select Automatic Spell Checking, or click the Automatic Spell Checking icon (which may not be displayed by default) on the Standard Toolbar, or go to Tools > Options > Language Settings > Writing Aids (macOS: LibreOffice > Preferences > Language Settings > Writing Aids) and select Check spelling as you type in the Options list. For more information about spell checking options, see Chapter 20, Customizing Writer.

Automatic Spell Checking checks each word as it is typed and displays a wavy red line under any unrecognized words. Right-click an unrecognized word to open a context menu (Figure 28). You can click one of the suggested words to replace the underlined word with the one selected. If the list does not contain the word you want, click Spelling to open a dialog. When the word is corrected, the line disappears. If the word is correct but not in the dictionary, you can chose Add to dictionary to add it.

![Spelling context menu](image)

Figure 28: Spelling context menu

If the document has change tracking enabled, then the context menu contains extra options relating to changes in the text.

The choices in the second and third sections of the menu are:

- **Ignore**
  This one instance of the underlined word will be ignored while the document is open. Other instances, if they exist, will still be underlined. This setting is not stored with the document.

- **Ignore All**
  All instances of the word in the document will be ignored, and the word will be added to the IgnoreAllList user-defined dictionary.
Add to Dictionary
The word is added by default to the Standard dictionary.

Spelling
This choice opens the Spelling dialog, which is explained in the next section.

Always correct to
Selecting this opens the submenu, which repeats the suggestions for the word from the top section listing. Selecting a replacement word here stores the word pair in the replacement table under Tools > AutoCorrect > AutoCorrect Options > Replace. The underlined word is replaced with the selected word.

AutoCorrect Options
Opens the AutoCorrect Options dialog (see page 64), where you can add your own corrections or change those supplied with LibreOffice.

In the fourth section of the context menu, you can set language settings for the text. These settings can be applied to the selection or to the paragraph containing the selection.

Spelling and grammar
To perform a combined spelling and grammar check on the document (or a text selection), select Tools > Spelling or click the Spelling button on the Standard toolbar, or press F7. In order to use this feature, the appropriate dictionaries must be installed.

The Spelling tool checks either the document from the cursor point onwards, or the text selection. It opens the Spelling dialog (Figure 29) if any unrecognized words are found or if any of the built-in grammar rules are broken. You can choose to restart from the beginning of the document when the check reaches the end of the document.

If the Check grammar option is selected in the lower left of the dialog, any grammar errors detected will also be shown. Figure 31 shows an example.

**Figure 29: Spelling alert using the Spelling dialog**

Text language
The language to be used for checking spelling can be selected from this drop-down list.
Not in dictionary
The sentence containing the error is displayed in the pane. If an unrecognized word is found, it is highlighted. If the error is grammatical, it is indicated in a colored bar below the Text language setting (Figure 31). The sentence or the word can be edited in the pane.

Suggestions
The box contains suggested replacements for the highlighted word. Select a word and then select Correct or Correct All to replace it.

For grammatical errors there is a single choice. Select Change to accept the suggestion.

Ignore Once, Ignore All, Add to Dictionary
Clicking one of these buttons has the same effect as the item in the context menu described above.

Ignore Rule
When checking grammar, you can choose to ignore the suggested change.

Correct
Replaces the unknown word with the suggested word, or makes the suggested grammatical change.

Correct All
Replaces all instances of the word with the selected replacement word. Not available for grammar checking.

Add to AutoCorrect
Adds the combination of the incorrect word and the selected replacement suggestion to the AutoCorrect replacement table, but does not make any change in the document.

Undo
Enabled when a change has been made to the sentence, so you can reverse the change. The button is not available if you use a Correct button to replace a word.

Options
Opens the Options dialog where you can select user-defined dictionaries and set the spell checking rules.

Grammar
By default, Check grammar as you type is enabled in Tools > Options > Language Settings > Writing Aids > Options. Automatic Spell Checking must be enabled for this to work. You can also check grammar at any time using the Spelling tool, and you can disable grammar checking as you type.

When grammar checking as you type is enabled, any errors detected are shown underlined by a wavy blue line. Right-clicking on this line opens a context menu (Figure 30).

Figure 30: Context menu for grammar errors
The first entry in the menu describes the suspected broken grammatical rule.

The second menu item in the left example is **Explanations**, which opens your browser to a web page offering more information about the error. This entry is not always present in the context menu, as seen in the second example in Figure 30.

In the second section of the menu is the suggested correction. Clicking this changes the text to the suggestion. The example to the right appears blank, but clicking here removes the extra space causing the error.

In the third section of the menu, choose whether to ignore the indicated error or to open the Spelling dialog, shown in Figure 31.

In the final section of the menu, you can set the language for the selection or the paragraph.

In the example shown in Figure 31, hovering the mouse pointer over **More...** on the upper right-hand side displays the URL for more information on the error indicated. Clicking on **More...** opens your default browser to that URL.

![Figure 31: Spelling dialog showing URL for expanded grammar explanation](image)

**Tip**

To select a different color for the wavy underline for grammar mistakes, go to **Tools > Options > LibreOffice > Application Colors**. See Chapter 20, Customizing Writer.

**English sentence checking**

Additional grammar checking rules can be selected through **Tools > Options > Language Settings > English sentence checking**. You can also go to **Tools > Extensions**, select **English spelling dictionaries**, and then click the **Options** button.

On the **English Sentence Checking** page (Figure 32), choose which items are checked for, reported to you, or converted automatically. After selecting the additional grammar checks, you must restart LibreOffice, or reload the document, for them to take effect.
Grammar checking
Possible mistakes
Checks for errors such as *with it's*, *he don't*, *this things* and so on.

Capitalization
Checks for the capitalization of sentences.

Word duplication
Checks for all word duplication, rather than just the default words 'and', 'or', 'for' and 'the'.

Parentheses
Checks for correct pairing of parentheses and quotation marks.

Punctuation
Word spacing
This option is selected by default. It checks for single spaces between words, indicating instances of double or triple spaces. To find and correct longer groups of spaces, you need to run the checker more than once.

Quotation marks
Checks that double quotation marks are typographically correct, that is, beginning ["] and ending ["] quotation marks curve in the correct directions.

Sentence spacing
Checks for a single space between sentences, indicating when one or two extra spaces are found.

Apostrophe
Replaces an apostrophe with the correct (curved) typographical character.

More spaces
Checks word and sentence spacing for more than two extra spaces.

Em dash; En dash
These options force a non-spaced *em* dash to replace a spaced *en* dash, or force a spaced *en* dash to replace a non-spaced *em* dash, respectively. This feature provides for different punctuation conventions.

Multiplication sign
This option is selected by default. It replaces an 'x' used as a multiplication symbol with the correct typographical symbol.
Ellipsis
Replaces three consecutive periods (full stops) with the correct typographical symbol.

Minus sign
Replaces a hyphen with the correct minus typographical character.

Others

Convert to metric; Convert to non-metric
Converts quantities in a given type of unit to quantities in the other type of unit.

Thousands separation of large numbers
Depending on the locale setting for the document, converts a number with five or more significant digits to either use a comma as a thousands separator or the ISO format, which uses a narrow space as a separator.

Using Language Tool

Language Tool is a multilingual grammar, style, and spelling checker provided by https://languagetool.org/. Writer can now use this tool for grammar checking along with the built-in grammar checker described above. When Language Tool is activated (see Chapter 20, Customizing Writer), it appears on the list of available language modules in Tools > Options > Language Settings > Writing Aids.

Using synonyms and the thesaurus

You can access a short list of synonyms from a context menu (Figure 33).

1) Right-click a word and point to Synonyms on the context menu. A submenu of alternative words and phrases is displayed.

2) Click a word or phrase in the submenu to have it replace the highlighted word or phrase in the document.

![Figure 33: Synonyms on the context menu](image-url)
The thesaurus gives a more extensive list of alternative words and phrases. To use the thesaurus:

1) Right-click on a word, point to Synonyms in the context menu, then click Thesaurus in the Synonyms submenu. See Figure 33.

2) In the Thesaurus dialog (Figure 34), select a word or phrase in the list of meanings.

3) Click Replace to make the substitution.

For example, when given the word house, the thesaurus offers several meanings, including dwelling, legislature, sign of the zodiac, and others. Select a replacement word from the list under the relevant meaning, so for dwelling, you will see dwelling, home, domicile, abode, and other alternatives.

**Note**

If the current language does not have a thesaurus installed, this feature is disabled.

![Figure 34: The thesaurus offers alternatives to words](image)

**Hyphenating words**

You can hyphenate words at the end of a line in two ways: let Writer do it automatically (using styles and its hyphenation dictionaries), or insert conditional (soft) hyphens manually where needed. Or, you can choose to not hyphenate at all. Each choice has its pros and cons.
**Automatic hyphenation**

This option uses styles and over-rides the **Tools > Options** choices described on the next page.

To turn automatic hyphenation of words on or off:

1) Click the **Styles** tab on the Sidebar to open the Styles deck. On the **Paragraph Styles** list, right-click **Default Paragraph Style** and select **Modify**.

2) On the Paragraph Style dialog (Figure 35), go to the **Text Flow** tab.

3) Under **Hyphenation**, select or deselect **Automatically**. When automatic hyphenation is on, you can also set the criteria for when it should occur.

4) Click **OK** to save.

---

**Note**

Turning on hyphenation for the **Default Paragraph Style** affects all other paragraph styles that are based on the **Default Paragraph Style**. You can individually change other styles so that hyphenation is not active; for example, you might not want headings to be hyphenated. Any styles that are not based on the **Default Paragraph Style** are not affected. For more information, see Chapters 8 and 9 in this book.

---

**Figure 35: Turning on automatic hyphenation**

**Hyphenation options**

When automatic hyphenation is enabled, the following options can be set:

- **Don't hyphenate words in CAPS**
  Don't insert hyphens in words written entirely in capital letters.

- **Don't hyphenate the last word**
  Don't insert hyphens in the last word of a paragraph.

- **Characters at line end**
  Specify the minimum number of characters to leave at the end of a line.

- **Characters at line begin**
  Specify the minimum number of characters that must appear at the beginning of the line after the hyphen.
**Maximum consecutive hyphenated lines**
Specify the maximum number of consecutive lines that can be hyphenated.

**Minimum word length in characters**
Specify the minimum word length in characters that can be hyphenated.

**Hyphenation zone**
Specify the length of the horizontal space in which a word cannot be hyphenated; instead, the line of text will break between words. Specifying a hyphenation zone results in enlarged spaces between words in justified text, and greater distance from paragraph margins in non-justified text.

You can also specify some hyphenation settings in Tools > Options > Language Settings > Writing Aids. These choices apply when there is no specific setting in a paragraph style. Hyphenation options set in Writing Aids are effective only if hyphenation is turned on through paragraph styles.

In Options, near the bottom of the dialog, scroll down to find the hyphenation settings.

![Options dialog for hyphenation settings](image)

**Figure 36: Setting hyphenation options**

To change the minimum number of characters for hyphenation, or the minimum number of characters before or after a line break, select the item, and then click the Edit button in the Options section.

**Hyphenate without inquiry**
Specifies that you will never be asked to manually hyphenate words that the hyphenation dictionary does not recognize. If this box is not selected, when a word is not recognized, a dialog will open where you can manually enter hyphens.

**Hyphenate special regions**
Specifies that hyphenation will also be carried out in footnotes, headers, and footers.

**Manual hyphenation**
To manually hyphenate words, do not use a normal hyphen, which will remain visible even if the word is no longer at the end of a line when you add or delete text or change margins or font size. Instead, use a soft hyphen, which is visible only when required.

To insert a soft hyphen inside a word, click where you want the hyphen to appear and press **Ctrl+hyphen (minus sign)** or use Insert > Formatting Mark > Insert soft Hyphen. The word will be hyphenated at this position when it is at the end of the line, even if automatic hyphenation for this paragraph is switched off.

**Using AutoCorrect**
Writer’s AutoCorrect function includes a long list of common misspellings and typing errors, which it corrects automatically. It also includes codes for inserting special characters, emojis, and other symbols. You can add your own special characters.

AutoCorrect is turned on by default when Writer is installed. You may wish to disable some of its features, modify others, or turn it off completely. To turn AutoCorrect off, uncheck Tools > AutoCorrect > While Typing.
You can add your own corrections or special characters or change those supplied with LibreOffice. Select **Tools > AutoCorrect > AutoCorrect Options** to open the AutoCorrect dialog (Figure 37). On the **Replace** tab, you can define what strings of text are corrected and how.

To stop Writer replacing a specific spelling, go to the **Replace** tab, highlight the word pair, and click **Delete**. To add a new spelling to the list, type it into the **Replace** and **With** boxes on the **Replace** tab, and click **New**.

![Figure 37: Replace tab of AutoCorrect dialog](image)

**Tip**

LibreOffice has an extensive list of emojis and other special characters available using AutoCorrect. For example, type :smiling: and AutoCorrect will replace it with ☺. Or, (c) will be changed to ©. You can add your own special characters.

See Chapter 4, Formatting Text, for discussion of the **Options** and **Localized Options** tabs of the AutoCorrect dialog.

**Using Word Completion**

If Word Completion is enabled, Writer tries to guess which word you are typing and offers to complete the word for you. To accept the suggestion, press **Enter**. Otherwise, continue typing.

To turn off Word Completion, select **Tools > AutoCorrect > AutoCorrect Options > Word Completion** and deselect **Enable word completion**.
You can customize word completion on the *Word Completion* page of the AutoCorrect dialog (Figure 38):

- Add (append) a space automatically after an accepted word.
- Show the suggested word as a tip (hovering over the word) rather than completing the text as you type.
- Collect words when working on a document, and then either save them for later use in other documents or select the option to remove them from the list when closing the document.
- Change the key that accepts a suggested entry; the options are *right arrow*, *End* key, *Enter* (*Return*), *Space bar*, and *Tab*.
- Change the maximum number of words remembered for word completion and the length of the smallest words to be remembered.
- Delete specific entries from the word completion list.

*Figure 38: Customizing word completion*

**Note**

Automatic word completion occurs only after you type a word for the second time in a document.
Using AutoText

Use AutoText to store text, tables, fields, graphics, and other items for reuse and assign them to a key combination for easy retrieval. For example, rather than typing “Senior Management” every time you use that phrase, you can set up an AutoText entry to insert those words when you type “sm” and press F3.

AutoText is especially powerful when assigned to fields. See Chapter 17, Fields.

Creating AutoText

To store some text as AutoText:

1) Type the text into a document.
2) Select the text.
3) Go to Tools > AutoText on the Menu bar (or press Ctrl+F3).
4) In the AutoText dialog (Figure 39), type a name for the AutoText in the Name box. Writer will suggest a one-letter shortcut, which you can change.

5) Choose the category for the AutoText entry, for example My AutoText.
6) Click the AutoText button at the bottom of the dialog and select from the menu either New (to have the AutoText retain specific formatting, no matter where it is inserted) or New (text only) (to have the AutoText take on the formatting around the insertion point).
7) Click Close to return to your document.

Tip

If the only option under the AutoText button is Import, either you have not entered a name for your AutoText or there is no text selected in the document.
To save a table as AutoText:

1) Create a table and format it the way you want.
2) Select the table and go to **Tools > AutoText** on the Menu bar (or press $\text{Ctrl}+F3$).
3) Type a name for the AutoText (or amend the suggested shortcut and choose the category for the AutoText entry).
4) Click the **AutoText** button and select **New** (because you want the formatting of the table preserved).
5) Click **Close** to return to your document.

**Inserting AutoText**

To insert AutoText, type the shortcut and press $F3$.

**Printing a list of AutoText entries**

To print a list of AutoText entries:

1) Choose **Tools > Macros > Organize Macros > Basic**.
2) In the **Macro From** list, find and expand **Gimmicks**.
3) Select **AutoText** and then click the **Run** button at the bottom of the dialog (not shown in Figure 40). A list of the current AutoText entries is generated in a separate text document. You can then print this document.

![BASIC Macros dialog](image)

**Figure 40: BASIC Macros dialog**

**Changing the case of selected text**

To quickly change the case of text, select it, choose **Format > Text** on the Menu bar, and then choose one of the following:

- **UPPERCASE**, where all letters are capitalized.
- **lowercase**, where no words (except proper nouns) are capitalized.
- **Cycle Case**, which cycles the selected words through uppercase, lowercase, and capitalize every word.
- **Sentence case**, where only the first word is capitalized (together with any proper nouns).
- **Capitalize Every Word**, where every word is capitalized.
• **TOGGLE case**, which changes every letter to the opposite case.
• **Small capitals**, which capitalizes all letters in a reduced font size.

Writer does not have an automated way to do Title Case, where all words are capitalized except for certain subsets defined by rules that are not universally standardized. However, you can use *Capitalize Every Word* and then restore those words that you do not want capitalized.

The **Format > Text** menu also includes several manual formatting options, including bold, italic, and superscript. If Asian language support has been enabled, there are also several options that are used with Asian text: half-width, full-width, Hiragana, and Katakana.

You can also change the case of text using the Character dialog or a character style. Choose **Format > Character**, click the **Font Effects** tab (Figure 41), then select the type of capitalization in the Effects – Case: box.

![Character dialog](image)

*Figure 41: Changing the case using the Character dialog*
Chapter 3,  
Working with Text: Advanced
Introduction

This chapter covers the more advanced tools for working with text in Writer:

- The built-in language tools
- Advanced find-and-replace techniques, including wildcards
- Track changes and insert comments
- Footnotes and endnotes
- Linking to other parts of a document
- Outline folding (hiding and showing contents)
- Inserting material from other documents
- Line numbering

This chapter assumes that familiarity with the basic text techniques described in Chapter 2, Working with Text: Basics. We also recommend displaying formatting aids, such as end-of-paragraph marks, tabs, breaks, and other items in Tools > Options > LibreOffice Writer > Formatting Aids. For information on formatting text, see Chapter 4.

Using built-in language tools

Writer provides some tools that make work easier if you mix multiple languages within the same document or if you write documents in various languages:

- The functions in Tools > Language
- Language settings in Options
- Paragraph and character styles
- The functions available on the Status bar

The main advantage of changing the language for a text selection is that you can then use the correct dictionaries to check spelling and apply the localized versions of AutoCorrect replacement tables, thesaurus, and hyphenation rules. A grammar checking dictionary may also be available for the selected language.

You can also set the language for a paragraph or a group of characters as None (Do not check spelling). This option is especially useful when you insert text such as web addresses or programming language snippets that you do not want to check for spelling.

Using Tools > Language

You can set the language for the whole document, for individual paragraphs, or even for individual words and characters, in Tools > Language on the Menu bar (Figure 42):

- For Selection applies a specified language to the selected text. If the language you wish to apply is not listed in the submenu, choose More... to open the Character dialog.
- For Paragraph applies the specified language to the paragraph where the cursor is located. If the language you wish to apply is not listed in the submenu, choose More... to open the Character dialog.
- For All Text applies the specified language to all of the document, including text inserted after making the change. If the language you wish to apply is not listed in the submenu, choose More... to open the Tools > Language Settings > Languages dialog.

The Reset to Default Language option on the submenu is the fastest way to return a selection, paragraph, or all text to the default language set in Tools > Options (described below).
The Tools > Language menu options include two that are activated when Asian is selected in Tools > Options > Language Settings > Languages > Default languages for documents: Chinese Conversion and Hangul/Hanja Conversion. These options are not covered in this book.

Figure 42: Options available through Tools > Language on the Menu bar

Using language settings in Options

Another way to change the language of a whole document is to use Tools > Options > Language Settings > Languages (macOS: LibreOffice > Preferences > Language Settings > Languages). In the Default languages for documents section (Figure 43), you can choose a language for all the text that is not explicitly marked as a different language.

Caution

A change in the default language from the Options dialog is a general change of settings of LibreOffice and will therefore apply to all the documents created in the future. To change the language for the current document only, be sure to select the For the current document only option (Figure 43).

Figure 43: Options in the Languages settings

Note

The spelling checker works only for those languages in the list that have a checkmark symbol next to them. If you do not see this symbol next to your preferred language, you can install the dictionary using Tools > Language > More Dictionaries Online.
Using paragraph and character styles

Changing the language on the Font tab of the Paragraph Styles dialog (Figure 44) will change the language for all paragraphs that use that paragraph style. To include whole paragraphs in different languages in a single document, you can use a different paragraph style for each language. For example, you might define BodyText-EN and BodyText-FR in a document containing paragraphs in both English and French.

See Chapter 9, Working with Styles, for more information on how to manage the language settings of a style.

![Figure 44: Setting the language for a paragraph style](image)

Using the Status bar

To set paragraphs to be checked in a language that is different from the language of the rest of the document, you can put the cursor in the paragraph (or select more than one paragraph) and change the language on the Status bar (Figure 45). This change affects only the selected paragraphs.

The language used for checking spelling is also shown in the Status bar, next to the page style in use. You can change the language for the paragraph or the entire document; click the language in the Status bar to pop up a menu of choices.

![Figure 45: Language choices on the Status bar](image)

The Reset to Default Language option on the menu and submenu is the fastest way to return a paragraph or the entire document to the default language set in Tools > Options.
**Advanced find and replace techniques**

In addition to finding and replacing words and phrases (described in Chapter 2), you can use Writer’s Find and Replace dialog to find and replace paragraph styles and text formatting.

**Find and replace paragraph styles**

Combining material from several sources may result in unwanted paragraph styles in a document. To quickly change all the paragraphs from one style to another (preferred) style:

1) On the Find and Replace dialog with Other Options displayed, select **Paragraph Styles**. The Find and Replace boxes now contain a list of paragraph styles in use in the document.

   If you have text formats or attributes specified, this option is labeled **Including Styles**. Select **No Format** to remove any attributes and return the option to **Paragraph Styles**.

2) Select the styles you want to search for and replace.

3) Click **Find**, **Find All**, **Replace**, or **Replace All**.

Repeat steps 2 and 3 for each style that you want to replace.

**Find and replace text formatting**

Unlike Find and Replace for paragraph styles described above, the formats or attributes to be searched for do not appear inside the Find or Replace box. Instead, the formats or attributes to be found or replaced appear below the Find and Replace boxes (Figure 46). Clicking on the down-arrow to the right does not bring up options.

![Figure 46: Find and replace text formatting](image)

To find a type of formatting in the document, follow this procedure:

1) Open the Find and Replace dialog (Figure 46) and select **Other options**.
2) To clear any previous format criteria, place the cursor in the Find box and then click the **No Format** button. To clear the selected Replace options, place the cursor in the Replace box and click the **No Format** button.

3) Click the **Format** button to open the Search for Formatting dialog, which looks much like the Character dialog. Select a format from any of the tabs (for example: bold, 14 pt, Spacing above paragraph).

4) To find this format that has been applied only by direct formatting, leave the **Including Styles** box unchecked. To find this format also applied inside a character or paragraph style, select the **Including Styles** box.

5) Choose **Find All** to have all formats found highlighted. Choose **Find Previous** or **Find Next** to find one format instance at a time.

6) To replace the chosen format, click inside the Replace box, then choose **Format** and choose a replacement from the tabbed options.

7) Replace the formats one at a time using **Find Previous > Replace** or **Find Next > Replace**. Use **Replace All** to change all formats at once.

8) To avoid errors the next time you use this dialog, it is a good idea to repeat Step 2 and clear all the formatting criteria selected.

To change the formatting for a specific word or phrase in a document:

1) Type the word or phrase in the Find box.

2) In the **Replace** box, type in the new text you want to use and choose the formats you would like to change. However, if you want to keep the same word or phrase and only change its format, ensure you also type the word or phrase in the **Replace** box. Otherwise, Writer will remove the word or phrase from the document.

3) Replace the words and formats one at a time using **Find Previous > Replace** or **Find Next > Replace**. Use **Replace All** to change all words and formats at once.

**Similarity search**

This option finds terms that are similar to the **Find** text. For example, a similarity search can find words that differ by two characters.

Select **Similarity search** and click the **Similarities** button to open a dialog where you can modify the text search by length and number of characters different from the search term (Figure 47).

![Figure 47: Similarity search dialog](image-url)
**Exchange characters**
Enter the number of characters in the search term that can be exchanged. For example, if you specify 2 exchanged characters, “black” and “crack” are considered similar.

**Add characters**
Enter the maximum number of characters by which a word can exceed the number of characters in the search term.

**Remove characters**
Enter the number of characters by which a word can be shorter than the search term.

**Combine**
Searches for a term that matches any combination of the similarity search settings.

**Search with wildcards and regular expressions**
A *wildcard* is a special character that represents one or more unspecified characters. Wildcards make text searches more powerful but often less specific. LibreOffice enables you to use combinations of characters known as *regular expressions* which are more specific than simple wildcards but less so than a literal string. Regular expressions are very powerful but not very intuitive. They can save time and effort by combining multiple finds into one.

Table 5 shows a few of the regular expressions used by LibreOffice. The Help describes many more regular expressions and their uses.

To use wildcards and regular expressions when searching and replacing:

1) On the Find and Replace dialog, click **Other Options** to see more choices. On this expanded dialog, select the **Regular expressions** option.

2) Type the search text, including the wildcards, in the **Search for** box and the replacement text (if any) in the **Replace with** box. Not all regular expressions work as replacement characters; the line break (\n) is one that does work.

3) Click **Find**, **Find All**, **Replace**, or **Replace All** (not recommended).

**Table 5: Examples of search wildcards (regular expressions)**

<table>
<thead>
<tr>
<th>To find</th>
<th>Use this expression</th>
<th>Examples and comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>Any single character</td>
<td>. (a period or full stop)</td>
<td>b.d finds bad, bud, bid, and bed.</td>
</tr>
<tr>
<td>One of the specified characters</td>
<td>[xyz]</td>
<td>b[iu]n finds bin and bun.</td>
</tr>
<tr>
<td>Any single character in this range</td>
<td>[x-y]</td>
<td>[r-t]eed finds reed, seed, and teed; ranges must be in alphabetically ascending order.</td>
</tr>
<tr>
<td>Any single character except the characters inside the brackets</td>
<td>[^x]</td>
<td>p[^a]st finds post and pest, but not past.</td>
</tr>
<tr>
<td>The beginning of a word</td>
<td>(&lt;start</td>
<td>(&lt;log finds logbook and logistics, but not catalog.</td>
</tr>
<tr>
<td>The end of a word</td>
<td>end&gt;</td>
<td>log)&gt; finds catalog, but not logistics.</td>
</tr>
<tr>
<td>A paragraph marker</td>
<td>$</td>
<td>Does not work as a replacement character. Use \n instead.</td>
</tr>
<tr>
<td>A line break</td>
<td>\n</td>
<td>Finds a line break that was inserted with <strong>Shift+Enter</strong>. When used as a replacement character, it inserts a paragraph marker.</td>
</tr>
</tbody>
</table>
Note

To search for a character that is defined as a wildcard, type a backslash (\) before the character to indicate that you are using it literally. For example, to find the text $5.00, you would conduct a search using \\$5\.00.

Tracking changes to a document

You can use several methods to keep track of changes made to a document:

- Make your changes to a copy of the document (stored in a different folder, under a different name, or both), then use Writer to compare the two files and show the changes. This technique is particularly useful if you are the only person working on the document, as it avoids the increase in file size and complexity caused by the other methods. See “Comparing documents” on page 85.
- Save versions that are stored as part of the original file. However, this method can cause problems with large or complex documents, especially if you save a lot of versions. Avoid this method if you can.
- Use Writer’s change marks (often called “redlines” or “revision marks”) to show added, deleted, or moved material and changed formatting. Later, you or another person can review and accept or reject each change.

This section describes the use of change tracking features, which include:

- Tracking insertion and deletion of text, images, tables, and other objects.
- Tracking changes of the attributes of paragraph styles and character styles.
- Tracking insertion and deletion of table rows, including empty rows.
- Showing moved material in a different color from added or deleted material.
- Tracking material moved using the Navigator.
- Tracking footnote deletion and insertion.
- Showing list numbering changes at the list item.

Note

Not all changes are recorded. For example, changing a tab stop from align left to align right, and changes in formulas (equations) or linked graphics are not recorded.

Preparing a document for review

When you send a document to someone else to review or edit, you may want to prepare it first so that the editor or reviewer does not have to remember to turn on the revision marks. After you have protected the document, any subsequent user must enter the correct password in order to turn off protection or accept or reject changes.

1) Open the document. Check whether it contains multiple versions by clicking File > Versions. If multiple versions are listed, save the current version as a separate document with a different name and use this new document as the review copy.

2) With the review copy open, make sure that change recording is turned on. The Edit > Track Changes > Record Menu bar item and the Record Track Changes icon on the Track Changes toolbar are highlighted when recording is turned on.

3) Click Protect Track Changes on the Track Changes toolbar or select Edit > Track Changes > Protect on the Menu bar. On the Enter Password dialog that opens, type a password (twice) and click OK.
An alternative to steps 2 and 3 above is to choose File > Properties > Security tab, select the Record changes option, then click Protect and enter the password.

Track Changes menu and toolbar

In addition to the Track Changes menu (Figure 48), Writer provides a convenient toolbar (Figure 49) that includes buttons for the same functions. To enable the Track Changes toolbar, click View > Toolbars > Track Changes. You can dock this toolbar in a convenient place or leave it floating.

![Track Changes menu](image)

**Figure 48: Track Changes menu**

![Track Changes toolbar](image)

**Figure 49: Track Changes toolbar**

1. Show Track Changes
2. Record Track Changes
3. Previous Track Change
4. Next Track Change
5. Accept Track Change
6. Reject Track Change
7. Accept All Track Changes
8. Reject All Track Changes
9. Accept Track Change and select Next
10. Reject Track Change and select Next
11. Manage Track Changes
12. Insert Comment
13. Insert Track Change Comment
14. Protect Track Changes
15. Compare Non-Track Changed Document
16. Merge Track Changed Document

Recording changes

To begin recording (tracking) changes, click Record Track Changes on the Track Changes toolbar or select Edit > Track Changes > Record on the Menu bar. To show or hide the display of changes, click Show Track Changes on the Track Changes toolbar or select Edit > Track Changes > Show on the Menu bar.
To enter a comment on a tracked change, place the cursor in the area of the change and then click **Edit > Track Changes > Comment** or click the **Insert Track Change Comment** button (not the Insert Comment button) on the Track Changes toolbar.

To stop recording changes, click **Edit > Track Changes > Record** again.

**Tip**

See also “Adding other comments” on page 85 for a way to annotate text that is not associated with a tracked change.

**Recording inserted, deleted, and moved material**

By default, inserted text is underlined, deleted text has a line through it (strike through), both are in color, and a mark (change bar) appears in the margin. To modify the default settings, see Chapter 20, Customizing Writer.

In an existing table, a deleted row is shown in pink and an inserted row in cyan. A new, blank table is marked in the margin but the rows are not colored.

Moved material is shown in green and indicated by a double underline (new location) or double strikethrough (old location).

**Recording changes of paragraph styles and other formatting**

When a different paragraph style is applied to a paragraph, the change is indicated by a mark in the margin.

By default, a change of character style or a manually applied character attribute is indicated by bold, colored text in addition to the attribute (such as italic or underlined), and the change is indicated by a mark in the margin.

Changes in list numbering show the original list numbers of all list items as well as the new numbers. Some examples are shown in Figure 50.

![Figure 50: Examples of recorded list numbering changes](image)

**Outline tracking**

Outline tracking uses the Navigator to track changes in the sequence of entire portions of a document: a heading and any material between it and the next heading of the same level. With Track Changes enabled, using the **Move Heading Up** and **Move Heading Down** buttons on the Navigator causes the moved material to be marked and tracked in the same way as material moved using drag-and-drop or cut-and-paste.

Outline tracking is enabled by default. To disable it, right-click on any heading in the Navigator and choose **Off** from the context menu.

**Viewing changes and comments**

Hold the mouse pointer over a tracked change to display a *Help Tip* showing the type of change, the author, date, and time of day for the change. If *Extended Tips* are enabled, any comments recorded for this change are also shown.
In addition to being displayed as an extended tip, recorded comments are shown in the list in the Manage Changes dialog (Figure 51). If no comment has been recorded for a change, the Comment field is blank.

To move from one tracked change to the next, use the Previous Change and Next Change icons on the Track Changes toolbar (Figure 49).

By default, tracked changes are displayed inline. To display either deletions or insertions in the margins instead, select from the Show Track Changes drop-down in the Track Changes toolbar (Figure 49).

**Accepting or rejecting changes**

To accept or reject recorded changes, use any of these tools:

- Track Changes toolbar (Figure 49)
- Items on the Track Changes menu (Figure 48)
- Right-click (context) menu
- Manage Changes dialog
- Manage Changes deck on the Sidebar

**Track Changes menu and toolbar**

For quick and easy accepting and rejecting of changes, use the Track Changes toolbar (Figure 49), which includes buttons for the same functions as appear on the Edit > Track Changes submenu (Figure 48).

**Right-click (context) menu**

1) If tracked changes are not showing, click the Show Track Changes icon on the Track Changes toolbar or select Edit > Track Changes > Show on the Menu bar.

2) Hover the mouse pointer over a recorded change. A box appears with information about the type of change, who made it, and the date and time.

3) Right-click the changed text. In the context menu, choose Accept Change or Reject Change.

**Manage Changes dialog and Sidebar deck**

1) Click the Manage Track Changes icon on the Track Changes toolbar or select Edit > Track Changes > Manage on the Menu bar. The Manage Changes dialog (Figure 51) opens, showing changes that have not yet been accepted or rejected. Or, click the Manage Changes icon in the Sidebar to display the same information.

2) When you select a change in the dialog, the change itself is highlighted in the document, so you can see what was changed.

3) Click Accept or Reject to accept or reject the selected change. You can also click Accept All or Reject All if you do not want to review the changes individually.
To show only the changes of certain people or only the changes on specific days or various other restrictions, use the **Filter** tab (Figure 52) on the Manage Changes dialog. After specifying the filter criteria, return to the **List** tab to see those changes that meet your criteria.

**Figure 51: The List tab of the Manage Changes dialog**

**Figure 52: Filter page of Manage Changes dialog**
Comparing documents

Sometimes reviewers may forget to track the changes they make. You can find the changes if you compare the original document and the one that is edited. To compare them:

1) Open the edited document. Select Edit > Track Changes > Compare Document or click the Compare Non-Track Changed Document icon on the Track Changes toolbar.

2) A file browser dialog opens. Select the original document and click Open.

Writer finds and marks the changes and displays the Manage Changes dialog. From this point, you can go through and accept or reject changes as described earlier.

To set the level of detail used by this feature, go to Tools > Options > LibreOffice Writer > Comparison. See Chapter 20, Customizing Writer.

Merging modified documents

The processes discussed to this point are effective when you have one reviewer at a time. Sometimes, however, multiple reviewers all return edited copies of a document. Writer provides a facility to merge documents containing tracked changes into the original document, but the condition for making this work is very specific: the edited documents may differ only and exclusively in the recorded changes – all other original text must be identical.

To merge documents, all of the edited documents (but not the original document) need to have recorded changes in them.

1) Open the original document into which you want to merge all copies.

2) Click Edit > Track Changes > Merge Document or click the Merge Track Changed Document icon on the Track Changes toolbar. A file selection dialog opens.

3) Select the edited copy of the document to be merged with the first. If there have been no subsequent changes to the original document, the copy is merged into the original.

   If any changes have been made to the original document, an error dialog appears that informs you that the merge is unsuccessful.

4) After the documents merge, you will see the recorded changes from the copy in the original document.

5) Repeat until all copies are merged.

All recorded changes are now included in the open copy. Save this file under another name.

Adding other comments

Writer provides another type of comment, which authors and reviewers can use to exchange ideas, ask for suggestions, or mark items needing attention.

You can select a block of text, including multiple paragraphs, to be highlighted for a comment, or you can insert a comment at a single point. To insert a comment, select the text, or place the cursor in the place the comment refers to. Right-click and choose Insert > Comment or press Ctrl+Alt+C or click the Insert Comment button (not the same as the Insert Track Change Comment button) on the Track Changes toolbar.

The anchor point of the comment is connected by a dotted line to a box on the right-hand side of the page where you can type the text of the comment. A Comments button is also added to the right of the horizontal ruler (Figure 53): you can click this button to toggle the display of the comments on and off.
Writer automatically adds the author’s name and a time stamp indicating when the comment was created. Select **Tools > Options > LibreOffice > User Data** to enter or change the name you want to appear in the Author field of the comment.

When you are finished typing the comment, click somewhere else on a page of the document. Otherwise, you will not be able to move away from the comment box.

If more than one person edits the document, each author is automatically allocated a different background color. Figure 53 shows an example of text with comments from two different authors. If an author selects text that overlaps another author’s comments, then the comments from the second author are nested with those of the first author.

![Figure 53: Comments in LibreOffice Writer](image)

Right-click on a comment, or click the arrow in the lower left, to open a context menu where you can delete the current comment, the whole current comment thread, all the comments from the same author, or all the comments in the document. From this menu, you can also choose **Format all comments** to open a dialog to apply some basic formatting to the text of the comment. You can also change font type, size, and alignment on the Menu bar.

When the document has been reviewed and commented and requires your action, you can mark each comment Resolved or Unresolved, using options on the comment's context menu. When you mark a comment resolved, the word **Resolved** is inserted under the date in the comment box. You can toggle the display of all resolved comments in the document by using **View > Resolved Comments** on the Menu bar. You can also add an answer to the comment.

To navigate from one comment to another, open the Navigator (**F5**), scroll to find and expand the **Comments** section. Double-click the comment text to move the cursor to the anchor point of the comment in the document.

You can also navigate the comments by selecting **Comment** in the **Navigate By** box at the top of the Navigator and clicking the Up and Down arrows next to it, to move to the next or previous comment. You can also navigate use the keyboard: **Ctrl+Alt+Page Down** moves to the next comment and **Ctrl+Alt+Page Up** moves to the previous comment.

To print the comments in a document, choose one of the options in the Comments drop-down list in the Print dialog (**File > Print > LibreOffice Writer** tab): **Comments only**, **Place at end of document**, **Place at end of page**, **Place in margins** (Figure 54).
Using footnotes and endnotes

Footnotes appear at the bottom of the page on which they are referenced. Endnotes are collected at the end of a document.

To work effectively with footnotes and endnotes, you need to:

- Insert footnotes and define their format, if the default values do not meet your needs; see below.
- Define the location of footnotes on the page, and the color and line style for separator lines, if the defaults do not meet your needs. See Chapter 5, Formatting Pages: Basics.

Inserting footnotes and endnotes

To insert a footnote or an endnote:

1) Position the cursor where you want the footnote or endnote marker to appear.
2) Select Insert > Footnote and Endnote on the Menu bar and choose Footnote or Endnote, or click the Insert Footnote or Insert Endnote button on the Standard toolbar.
3) A footnote or endnote marker is inserted in the text and, depending on your choice, the cursor is relocated either to the footnote area at the bottom of the page or to the endnote area at the end of the document. Type the footnote or endnote content in this area.

To change the default Footnote/Endnote settings, go to Tools > Footnotes and Endnotes on the Menu bar.

To choose whether to use the automatic numbering sequence specified in the footnote settings or specify a custom number, go to Insert > Footnote and Endnote > Footnote or Endnote on the Menu bar to open the Insert Footnote/Endnote dialog (Figure 55).

You can edit an existing footnote or endnote in the same way you edit any other text.

To delete a footnote or endnote, delete the footnote marker. The contents of the footnote or endnote are deleted automatically, and the numbering of other footnotes or endnotes is adjusted automatically.
Formatting footnotes and endnotes

To format the footnotes themselves, click **Tools > Footnotes and Endnotes**. On the Footnotes/Endnotes Settings dialog (Figure 56), choose preferred settings.

![Figure 56: Defining footnote formatting](image)

Linking to another part of a document

Typed cross-references to other parts of a document can easily get out of date if you reorganize the order of topics, add or remove material, or reword a heading. Writer provides two ways to ensure that references are up to date: *hyperlinks* and *automatic cross-references*. Both methods can be used to link to other parts of the same document or to another document.

Both methods have the same result: if you *Ctrl+click* the link when the document is open in Writer, you are taken directly to the cross-referenced item. However, they also have major differences:

- The text in a hyperlink does **not** automatically update if you change the text of the linked item (although you can change it manually), but changed text does automatically update in a cross-reference.
- When using a hyperlink, you do not have a choice of the content of the link (for example text or page number), but when using a cross-reference, you have several choices.
• To hyperlink to an object such as an image, and have the hyperlink show useful text such as Figure 6, either give such an object a useful name instead of leaving it as the default name (“Image12”), which may not correspond to the object's position in the document, or use the Hyperlink dialog to modify the visible text. In contrast, cross-references to figures with captions can be set to automatically show useful text, and you have a choice of several variations of the name.

• When a Writer document is saved to HTML, hyperlinks remain active but cross-references do not. (Both remain active when the document is exported to PDF.)

Using cross-references
To ensure that the text of cross-references update if a heading, caption, or other linked item is reworded, use automatic cross-references. For details, see Chapter 17, Fields.

Using bookmarks
Bookmarks are listed in the Navigator and can be accessed directly from there with a single mouse click. In HTML documents, bookmarks are converted to anchors that you can jump to by hyperlink. You can also cross-reference to a bookmark. For more information, see Chapter 17.

Using hyperlinks
When you type text (such as website addresses or URL) that can be used as a hyperlink, and then press the spacebar or the Enter key, Writer automatically creates the hyperlink and applies formatting to the text (usually a color and underlining).

If this does not happen, you can enable this feature using Tools > AutoCorrect > AutoCorrect Options. On the Options tab, select the URL Recognition option.

If you do not want LibreOffice to convert a specific URL to a hyperlink, you can go to Edit > Undo on the Menu bar, or press Ctrl+Z immediately after the formatting has been applied, or place the cursor in the hyperlink, right-click, and select Remove Hyperlink in the context menu.

You can also insert hyperlinks to other parts of your document, to other documents or parts of documents, and to email addresses, using the Navigator and the Hyperlink dialog, and you can modify all hyperlinks using the Hyperlink dialog. For details, see Chapter 12, Creating HTML Files, in the Getting Started Guide.

The standard (default) behavior for activating hyperlinks within LibreOffice is to use Ctrl+click. To change this behavior, go to Tools > Options > LibreOffice > Security, click the Options button next to Security Options and Warnings, and deselect Ctrl-click required to open hyperlinks. If clicking in your links activates them, check that page to see if the option has been deselected.

Editing hyperlinks
To edit a hyperlink, click anywhere in the link text and then open the Hyperlink dialog by right-clicking and choosing Edit Hyperlink in the context menu, or clicking the Hyperlink icon on the Standard Toolbar, or choosing Edit > Hyperlink on the Menu bar. Make your changes and click Apply. If you need to edit several hyperlinks, you can leave the Hyperlink dialog open until you have edited all of them. Be sure to click Apply after each one. When you are finished, click Close.

To change the color of hyperlinks, go to Tools > Options > LibreOffice > Application Colors, scroll to Unvisited links and/or Visited links in the General section, select those options, pick the new colors, and click OK. This will change the color for all hyperlinks in all components of LibreOffice, which may not be what you want.
Rearranging headings and text using the Navigator

The Navigator (Figure 57) provides several ways to move headings and their associated text to another location in a document: by dragging, using icons, or using the context menu (Figure Error: Reference source not found).

If necessary, click the expansion symbol (+ sign or arrow) to the left of a heading to expand the list of subheadings. To more easily find a required heading, change the **Show Up to Outline Level** selection to show only a few levels of headings.

![Figure 57: Promote/Demote and Move Up/Move Down](image)

1. Promote Outline Level  
2. Demote Outline Level  
3. Move Heading Up  
4. Move Heading Down  
5. Show Up to Outline Level

![Figure 58: Context menu for headings in the Navigator](image)
To move a heading with its associated text and subsections up or down in the document, but not change the outline level of the heading, do one of the following:

- In the Navigator, click the heading of the block of text to be moved and drag the heading to a new location in the list of headings.
- Click the heading in the Navigator list, and then click either the Move Heading Up or Move Heading Down icon.
- Right-click on the heading in the Navigator list and select either Move Heading Up or Move Heading Down in the context menu.

To move only the selected heading and not the text associated with the heading, hold down the Ctrl key while dragging or clicking an icon or selecting from the context menu.

To change the outline level of a heading (for example, from Heading 2 to Heading 1 or Heading 3) and its associated subheadings, without changing the location of the headings, do one of the following:

- Select the heading in the Navigator, then click either the Promote Outline Level or Demote Outline Level icon.
- Right-click the heading in the Navigator, then select either Promote Outline Level or Demote Outline Level in the context menu.

To change the outline level of only the selected heading, but not its associated subheadings, hold down the Ctrl key while clicking the icon or selecting from the context menu.

Outline folding

Using outline folding, you can hide and show all content under headings, including text, images, tables, frames, shapes, and text boxes. In large documents, this feature can help you quickly scroll to the right position for editing and reading.

**Note**

To enable this feature, go to Tools > Options > LibreOffice Writer > View (macOS: LibreOffice > Preferences > LibreOffice Writer > View) and select Show outline-folding buttons. Optionally select Include sub levels.

Using the Navigator

Open the Navigator (F5) and display the Headings entries. Right-click on a heading in the Navigator and select Outline Folding > Toggle from the context menu (Figure Error: Reference source not found) to hide or show the content between that heading and the next heading of the same level.

Using a mouse

Hover the mouse pointer over a heading to display a small arrow in the left margin to indicate that outline folding is enabled. A down arrow indicates the heading and its contents are visible. A right arrow indicates the heading has hidden contents.

**Using a mouse**

Figure 59: Outline Folding marker

Press the Control key (Command on macOS). When the mouse pointer changes shape, click to hide or show the content between that heading to the next heading of the same level.
Saving, printing, and exporting folded contents

Documents saved in Open Document Format (.odt) will retain the current settings of hidden and shown contents. The document contents are not affected by the folding settings.

Note

Hidden (folded) contents will not be printed or exported to PDF. To print or export the full document, be sure to toggle off outline folding.

Inserting material from other documents

You may wish to reuse material from other files in the document you are writing. For example, you might be writing a set of instructions that include some common paragraphs. You could, of course, retype or copy and paste the common paragraphs into each document. However, if the common paragraphs are edited, you may need to update that information in every document where it occurs.

Writer provides some tools for making these tasks easier:

- The Section dialog, described in Chapter 6, Formatting Pages: Advanced.
- Two items in the Navigator’s drag modes, described below.

To use the Navigator tools, first select the item you want to insert from the source document, then choose Insert as Link or Insert as Copy. You cannot create links or copies of graphics, OLE objects, references, or indexes using this method.

Insert as Link

Inserts the selected item as a link where you drag and drop in the current document. Text is inserted as a protected section, marked as linked to the source document. The content of the link is automatically updated when the source is changed. To manually update the links in a document, choose Tools > Update > Links.

Insert as Copy

Inserts an independent copy of the selected item where you drag and drop in the current document. Text is in a section, but it is not protected.Copied items are not updated when the source is changed. You can remove the section, leaving the contents as normal text.

Line numbering

Line numbers in the margin are often used in legal documents, poetry, and lists of programming code. Writer can insert line numbers in an entire document or for selected paragraphs. Line numbers are included when you print the document. You can also add a separator between line numbers. Figure 60 shows an example with numbering on every line.

You can choose how many lines are numbered (for example, every line or every tenth line), the numbering type, and whether numbers restart on each page. In addition, a text separator (any text you choose) can be set on a different numbering scheme (one every 12 lines, for example).

To add line numbers to an entire document, click Tools > Line Numbering and select the Show numbering option in the top left corner of the Line Numbering dialog (Figure 61). Then select any options you want and click OK.
To disable line numbering for the entire document, you can edit the Default Paragraph Style (because all paragraph styles are based on the Default Paragraph Style):

1) In the Sidebar, go to the Styles pane and click the Paragraph Styles icon.
2) Right-click on the Default Paragraph Style and choose Modify.
3) Click the Outline & List tab (Figure 62).
4) In the Line Numbering area, deselect Include this paragraph in line numbering.
5) Click OK.

To enable line numbering for specific paragraphs:

1) First disable the feature for the document (as above), then select the paragraphs where you want to add the line numbers.
2) Choose Format > Paragraph, or right-click and choose Paragraph > Paragraph on the context menu.
3) On the Outline & List tab of the Paragraph dialog, select Include this paragraph in line numbering.
4) Click OK.

Figure 60: Line numbering example

Figure 61: Line Numbering dialog
Alternatively, you can disable line numbering for specific paragraphs (while leaving most of them enabled) by selecting the paragraphs, choosing **Format > Paragraph** or right-clicking and choosing **Paragraph > Paragraph** on the context menu, then going to the Outline & List tab and deselecting **Include this paragraph in line numbering**.

You can also create a paragraph style that includes line numbering, and apply it to the paragraphs that you want to add line numbers to. For example, to number the lines of example code in a document, you will probably want to use a font or indentation that is different from normal text.

To specify the starting line number:

1) Click in the paragraph and choose **Format > Paragraph** or right-click and choose **Paragraph > Paragraph** on the context menu.

2) On the Outline & List tab, make sure **Include this paragraph in line numbering** is selected.

3) Select **Restart at this paragraph** and enter a line number in the **Start with** box.

4) Click **OK**.
Chapter 4,
Formatting Text
Introduction

This chapter covers the basics of formatting text in Writer, the word-processing component of LibreOffice:

- Formatting paragraphs and characters
- Using autoformatting
- Creating unordered, ordered, and outline lists

It assumes familiarity with the text techniques described in Chapter 2, Working with Text: Basics and Chapter 3, Working with Text: Advanced.

We recommend also following the suggestions in Chapter 20, Customizing Writer, about displaying formatting aids, such as end-of-paragraph marks, and selecting other setup options.

Page formatting is covered in Chapters 5 and 6.

Formatting: direct (manual) or styles

There are two basic ways to format text:

Direct (or Manual) formatting
Applies formatting directly to specific paragraphs, characters, pages, frames, lists, or tables. For example, select a word, then click on a button on the Formatting toolbar to format the text as bold or italics.

Styles
Bundles formatting options under one name. For example, a paragraph style defines numerous settings for options such as font type and size, whether paragraphs should be indented, the space between lines, how paragraphs should be aligned on the page, and many others.

Using styles is recommended

Writer is a style-based program. Because styles apply whole groups of formats at the same time, it is easy to format a document consistently and to change the formatting of an entire document with minimal effort. Therefore, the use of paragraph and character styles is highly recommended.

In addition, styles are used by LibreOffice for many other processes. For example, Writer relies on heading styles (or other selected styles) when it compiles a table of contents.

For information on styles and how to use them, see Chapters 8 and 9 in this book.

Applying styles is quick and easy using the Styles deck of the Sidebar.

Removing manual formatting

Note

Manual formatting overrides styles and cannot be removed by applying a style to it.

To remove manual formatting, select the text and choose Format > Clear Direct Formatting on the Menu bar, or right-click and choose Clear Direct Formatting on the context menu, or click the Clear Direct Formatting icon on the Formatting toolbar, or press Ctrl+M on the keyboard.
Format paragraphs using styles

Styles can be applied to paragraphs in several ways; see Chapter 8, Introduction to Styles:

- Set Paragraph Style drop-down list at the left end of the Formatting toolbar and the Formatting (Styles) toolbar
- Set Paragraph Style drop-down list at the top of the Properties deck of the Sidebar
- Paragraph Styles tab of the Styles deck on the Sidebar
- Styles menu on the Menu Bar (limited to common styles)
- Keyboard shortcuts Ctrl+1 to Ctrl+5 (paragraph styles Heading 1 to Heading 5)
- Formatting (Styles) toolbar using View > Toolbars > Formatting (Styles); see Figure 63.

Figure 63: Formatting (Styles) toolbar

Format paragraphs directly

Many formats can be applied to paragraphs using the icons on the Formatting toolbar and on the Paragraph panel of the Sidebar’s Properties deck (View > Sidebar) or commands on the Format menu on the Menu bar. Other formatting options are provided in the Paragraph dialog (page 105).

Formatting toolbar

On the Formatting toolbar, the icons and formats include:

- Set Paragraph Style (drop-down list)
- Align Left, Align Center, Align Right, Justified
- Align Top, Center Vertically, Align Bottom
- Toggle Unordered List (with a palette of bullet types)
- Toggle Ordered List (with a palette of numbering types)
- Select Outline Format (with a palette of outline types)
- Increase Paragraph Spacing, Decrease Paragraph Spacing
- Increase Indent, Decrease Indent, Hanging Indent
- Paragraph (to open the Paragraph dialog)
- Set Line Spacing (choose from 1, 1.15, 1.5, 2, or custom spacing)

Not all toolbar icons are visible in a standard installation, but you can customize the toolbar to include those you use regularly; see Chapter 1, Introducing Writer.

Sidebar Properties deck

The Sidebar Properties deck (Figure 64) includes panels for applying styles, manually formatting characters, and manually formatting paragraphs. Click the expansion symbol (+ or triangle) to open the panels if necessary.

Style panel

Includes the Set Paragraph Style drop-down list and icons for Clone Formatting, Update Selected Style, and New Style from Selection. These tools are described in Chapter 8, Introduction to Styles.
**Character panel**
See Figure 79 on page 110 and the description starting on page 109.

**Paragraph panel**
Contains most of the formatting controls, including several that are not found on the Formatting toolbar. Clicking the down-arrow by a button opens the control for further choices, such as fixed line spacing or color palette.

Each panel’s title bar has a More Options icon on the right, which opens the relevant dialog (Paragraph Style, Character, or Paragraph) containing additional settings. Changing the values of any of these settings affects only the paragraph where the cursor is located, or several paragraphs if more than one are selected. To change the values for many paragraphs of that type, using a paragraph style is better.

![Paragraph panel of the Properties deck in the Sidebar](image)

**Alignment options**
Use the icons labelled 1–4 in Figure 64 to choose the alignment of a paragraph: Left, Right, Centered, or Justified. Figure 65 shows examples of the alignment options applied to text.

<table>
<thead>
<tr>
<th>1</th>
<th>Align Left</th>
<th>8</th>
<th>No List</th>
<th>15</th>
<th>Above Paragraph Spacing</th>
</tr>
</thead>
<tbody>
<tr>
<td>2</td>
<td>Align Center</td>
<td>9</td>
<td>Background Color</td>
<td>16</td>
<td>Below Paragraph Spacing</td>
</tr>
<tr>
<td>3</td>
<td>Align Right</td>
<td>10</td>
<td>Increase Paragraph Spacing</td>
<td>17</td>
<td>Before Text Indent</td>
</tr>
<tr>
<td>4</td>
<td>Justified</td>
<td>11</td>
<td>Decrease Paragraph Spacing</td>
<td>18</td>
<td>After Text Indent</td>
</tr>
<tr>
<td>5</td>
<td>Toggle Unordered List</td>
<td>12</td>
<td>Increase Indent</td>
<td>19</td>
<td>First Line Indent</td>
</tr>
<tr>
<td>6</td>
<td>Toggle Ordered List</td>
<td>13</td>
<td>Decrease Indent</td>
<td>20</td>
<td>Set Line Spacing</td>
</tr>
<tr>
<td>7</td>
<td>Select Outline Format</td>
<td>14</td>
<td>Hanging Indent</td>
<td>21</td>
<td>More Options</td>
</tr>
</tbody>
</table>

![Text alignment options](image)

---

88 | LibreOffice 7.6 Writer Guide
When using justified text, the last line is by default aligned to the left. However, you can also align the last line to the center of the paragraph area or justify it so that spaces are increased between the words in order to fill the whole line. If you select the Expand single word option, then whenever the last line of a justified paragraph consists of a single word, this word is stretched by inserting spaces between characters so that it occupies the full length of the line.

Figure 66 shows an example of the effect obtained when choosing each of these options for a typical text font. In most cases, leave the setting on the default (left-aligned); but for some dramatic purposes (such as a very large font on a poster), you might prefer one of the other choices.

These options are controlled in the Alignment tab of the Paragraph dialog (Figure 67), reached by choosing Format > Paragraph on the Menu bar, or by right-clicking in the paragraph and selecting Paragraph in the context menu, or by clicking the More Options button on the Paragraph panel in the Properties deck of the Sidebar.

Line and paragraph spacing

Set Line spacing (icon 19, Figure 64) refers to the distance from one baseline (the imaginary line at the bottom of a letter like “n” or “m”) to the next baseline. It is determined by the size of the font, as illustrated in Figure 68.
The Line Spacing submenu is shown in Figure 69. Here you can choose among standard spacings or define a custom value: **Proportional** (for example, 110%), **At least** (the amount specified in the Value box), **Leading**, or **Fixed**. To see the differences between these choices, do a few sample paragraphs and change the selections.

![Figure 68: Line spacing is the distance between two baselines](image)

**Note**

All options except **Fixed** or **At Least** use the font’s default. These two options allow you to set your own spacing, which is especially useful at small font sizes to increase readability.

![Figure 69: Line spacing submenu](image)
Paragraph spacing refers to the vertical spacing between one paragraph and the paragraphs above and below it. As shown in Figure 64, the current values are shown in the Above Paragraph Spacing box (14) and the Below Paragraph Spacing box (15). You can change either or both of these settings independently.

**Tip**

Paragraph spacing is often used in computer documentation, such as this book. Paragraph indentation (see next topic) is more commonly used in other documents. For good design, use paragraph spacing or paragraph indentation, never both.

### Paragraph indentation

Use the icons labelled 11, 12, and 32 in Figure 64 to increase the amount of space to leave between the left and right page margins and the paragraph.

The distances are determined by settings 16 (Before Text Indent; that is, from the left margin), 17 (After Text Indent; that is, from the right margin), and 18 (First Line Indent, which indents the first line from the left margin, or from the specified indentation from the margin).

Button 13, Hanging Indent, leaves the first line at the left margin (or the specified indentation from the margin) and indents all the other lines of the paragraph by the amount specified by button 18 or in the Paragraph dialog.

<table>
<thead>
<tr>
<th>This paragraph is an example of a paragraph with a <strong>first line indent</strong>. It is typical of paragraphs in books.</th>
</tr>
</thead>
<tbody>
<tr>
<td>This paragraph is an example of a paragraph with a <strong>hanging indent</strong>. It is often used for numbered paragraphs or those with an icon or other image on the left.</td>
</tr>
</tbody>
</table>

*Figure 70: Examples of first line and hanging indents*

**Note**

In right-to-left languages, the behavior of the Before Text and After Text indents is the opposite: “before” is on the right margin; “after” is on the left margin.

### Paragraph background color

Click the button labeled 8 in Figure 64 to open a palette and choose a color for the background of the paragraph. In this palette (Figure 71), optionally click Custom Color to open the Pick a Color dialog, where you can define new colors to be added to the palette. See Chapter 20, Customizing Writer, for more information about defining background colors.

**Note**

If the paragraph has been indented from the right or left margin, the background color is not applied to the area of the indent. To extend the color to the margin, use a frame, table, or other method; see Chapter 6, Formatting Pages: Advanced.

---

This is an example of an indented paragraph with a paragraph background color. The background color does not extend into the indented area.
Figure 71: Selecting a background color for a paragraph

**Settings on the Paragraph dialog**

The paragraph dialog includes several more tabs: **Tabs** (covered in “Setting tab stops and indents” on page 108), **Borders, Drop Caps, Area** (more choices than just color), **Transparency, Text Flow**, and **Outline & List**. For more information, see Chapter 8, Introduction to Styles, and Chapter 9, Working with Styles.

**Borders**

*Borders* are useful for setting a paragraph off from the surrounding text, to include digressions from the main topic. For example, the Tips, Notes, and Cautions in this book use a border below the text.
You can add borders to any combination of top, bottom, and sides of paragraphs. You can choose the style (solid, dotted, dashed, doubled), width, and color of the lines; these choices apply to all borders on a paragraph. The spacing from each line to the paragraph's contents can be set individually for the top, bottom, left, and right.

On the Borders tab of the Paragraph dialog (Figure 72), you can also choose to apply a shadow to a paragraph; “distance” refers to the width of the shadow.

Select the **Merge with next paragraph** option to suppress top or bottom lines when the indent, border, and shadow styles of the next paragraph are the same as the current paragraph.

**Drop caps**

*Drop capitals* are enlarged letters that mark the start of a new chapter or section. To improve consistency, they are best set up in a paragraph style that you apply to the relevant paragraphs. See Chapter 9, Working with Styles, for details.

**Area**

*Area* (also called “fill” and “background” in some parts of LibreOffice) includes five types of fill (background): color, gradient, image, pattern, and hatching. Select a fill type to display the choices available for that type. These choices are covered in more detail in Chapter 5, Formatting Pages: Basics. You can also create your own fills.

![Figure 73: Types of fill for paragraph backgrounds](image)

**Transparency**

*Transparency* affects the paragraph's background. It is useful for creating watermarks and making colors or images more pale (for more contrast with the text). The available choices are shown in Chapter 5, Formatting Pages: Basics, and are covered in detail in the *Draw Guide*.

**Text Flow**

The *Text Flow* tab (Figure 74) has several sections. Hyphenation is covered in Chapter 2, Working with Text: Basics, and breaks are covered in Chapter 5, Formatting Pages: Basics.

In the *Options* section, you can specify how paragraphs are treated at the bottom of a page. *Do not split paragraph* and *Keep with next paragraph* should be self-explanatory. The other options avoid a single line at the bottom of a page (called an *orphan*) or a single line at the top of a page (a *widow*).
Outline & List

The Outline & List tab in the Paragraph dialog provides options for choosing the outline level of the paragraph and its list style (if any). If the paragraph is part of an ordered list, you can specify that list numbering restarts at the paragraph, and what number to restart with. List styles shown include both inbuilt and custom (user-defined) list styles.

This tab does not cover the same functions as the Heading Numbering dialog (Tools > Heading Numbering), but the Outline level selected here is related to the outline defined there. See Chapter 8, Introduction to Styles, and Chapter 9, Working with Styles, for a discussion of these features.

Line numbering is discussed in Chapter 3, Working with Text: Advanced.
Setting tab stops and indents

The horizontal ruler shows the tab stops. Any tab stops that you have defined will overwrite the default tab stops. Tab settings affect indentation of full paragraphs (using the Increase Indent and Decrease Indent icons on the Formatting toolbar or the Paragraph panel of the Properties deck in the Sidebar) as well as indentation of parts of a paragraph (by pressing the Tab key on the keyboard).

Tip

Many indents, for example at the beginning of a paragraph, can be set in the paragraph style, so you don’t need to use the Tab key to activate them.

Using the default tab spacing can cause formatting problems if you share documents with other people. If you use the default tab spacing and then send the document to someone else who has chosen a different default tab spacing, tabbed material will change to use the other person’s settings. Instead of using the defaults, define your own tab settings, as described in this section.

To define indents and tab settings for one or more selected paragraphs, right-click a paragraph and choose Paragraph to open the Paragraph dialog; then select either the Tabs tab (Figure 76) or the Indents & Spacing tab of the dialog. Alternatively, double-click the horizontal ruler to open the Indents & Spacing tab of the Paragraph dialog. A better strategy is to define tabs for the paragraph style. Refer to Chapters 8 and 9 for more about paragraph styles.

Changing the default tab stop interval

Tip

Using tabs to space out material on a page is not recommended. Depending on what you are trying to accomplish, a table or frame is usually a better choice.

Changing the default tab stop interval

Caution

Any changes to the default tab setting will affect the existing default tab stops in any document opened afterward, as well as tab stops inserted after making the change.

To set the measurement unit and the spacing of default tab stop intervals, go to Tools > Options > LibreOffice Writer > General.
Changing measurement units for tab stops and rulers

To set or change the measurement unit for rulers in the current document, right-click on the ruler to open a list of units, as shown in Figure 78 for the horizontal ruler. Select one of them to change the ruler to that unit. The selected setting applies only to that ruler.

Formatting characters using styles

To apply a character style, highlight the characters or words and apply the selected character style from any of the following:

- Character Styles tab of the Styles deck on the Sidebar
- Styles menu on the Menu bar (limited)
- Right-click context menu (limited)
- Formatting (Styles) toolbar (Figure 63)

For more about character styles, refer to Chapter 8, Introduction to Styles, and Chapter 9, Working with Styles.

Formatting characters directly

Many formats can be applied to characters using the icons on the Formatting toolbar and by using the Characters panel of the Properties deck of the Sidebar. Not all toolbar icons are visible in a standard installation, but you can customize the toolbar to include those you use regularly; see Chapter 1, Introducing Writer. These formats include:

- Font Name, Font Size
- Bold, Italic, Underline, Double Underline, Overline, Strikethrough, Outline
- Superscript, Subscript
- Uppercase, Lowercase
- Increase Font Size, Decrease Font Size
- Font Color (with a palette of colors)
- Background Color (with a palette of colors)
- Character Highlighting Color (with a palette of colors)
To change the characteristics of an entire paragraph (for example the font name, size, or color), and for many other purposes, it is highly recommended to use styles rather than manually formatting characters. For information on styles and how to use them, see Chapters 8 and 9. Applying styles is quick and easy using the Styles deck of the Sidebar.

Figure 79 shows the Character panel in the Properties deck of the Sidebar. Click the arrow next to a button to open a palette of further choices, such as font color or character spacing.

Click the More Options button (16) to open the Character dialog, which includes more choices than are available through the Formatting toolbar or the Sidebar.

Note
Just as direct paragraph formatting overrides the current paragraph style, applying direct character formatting to characters overrides the current character style formatting.

Font name, size, and effects

To change the font name and size used for selected characters, use the drop-down menus on the Formatting toolbar, the Character panel in the Sidebar, or the Character dialog.

Similarly, to apply bold, italics, underline, strikethrough, or shadow effects to selected characters, use the Formatting toolbar, the Character panel in the Sidebar, or the Character dialog. The Underline effect has a drop-down menu of line types (Figure 80).

The Formatting toolbar includes other effects that are not in the Sidebar: overline and double underline; these icons may not be visible in a default installation.

To choose the color of the font or its highlighting, open the appropriate color palette (10 or 11; similar to the one shown in Figure 71). The highlighting selection over-rides any background color that has been applied to the paragraph.

<table>
<thead>
<tr>
<th>1</th>
<th>Font Name</th>
<th>6</th>
<th>Strikethrough</th>
<th>11</th>
<th>Font Color</th>
</tr>
</thead>
<tbody>
<tr>
<td>2</td>
<td>Font Size</td>
<td>7</td>
<td>Toggle Shadow</td>
<td>12</td>
<td>Character Highlighting Color</td>
</tr>
<tr>
<td>3</td>
<td>Bold</td>
<td>8</td>
<td>Clear Direct Formatting</td>
<td>13</td>
<td>Set Character Spacing</td>
</tr>
<tr>
<td>4</td>
<td>Italic</td>
<td>9</td>
<td>Increase Font Size</td>
<td>14</td>
<td>Superscript</td>
</tr>
<tr>
<td>5</td>
<td>Underline</td>
<td>10</td>
<td>Decrease Font Size</td>
<td>15</td>
<td>Subscript</td>
</tr>
</tbody>
</table>

16 | More Options |

Figure 79: Character panel in the Properties deck of the Sidebar
To increase or decrease the font size of selected characters, you can click the relevant icons on the Formatting toolbar or the Character panel on the Sidebar; however, you have no control over the amount of the increase or decrease, which is usually 2 points. For finer control, use the Font Size drop-down list instead.

To change characters into subscripts or superscripts (using the default values for size and position), select them and click the relevant icons on the Formatting toolbar or the Character panel in the Sidebar. For more control, use the Character dialog.

To quickly change the spacing between characters, select them and choose from the Character Spacing drop-down menu in the Sidebar (Figure 81).

**Figure 80: Selecting the line style for the Underline effect**

**Figure 81: Changing character spacing**

**Settings on the Character dialog**

The Character dialog has six tabs, described in this section. Most of these tabs are the same as the tabs on the Character Style dialog (see Chapter 9, Working with Styles).
Font and Font Effects

On the Font tab (Figure 82), specify the font's family, style (choices vary with the font, but typically include regular, bold, and italic), and size; and the language for the paragraph, if it differs from the language for the document. The box at the bottom shows a preview of the selections.

On the Font Effects tab (Figure 83), choose the color of the font and a range of effects, many of which are not suitable for formal documents. Figures 84 and Error: Reference source not found show the choices in some of the drop-down lists.

Figure 82: Font tab of the Character dialog

Figure 83: Font Effects tab of the Character dialog
The Position tab (Figure 86) collects the options that affect the position of text on the page. This tab is divided into three sections: **Position**, **Rotation/Scaling**, and **Spacing**.

The **Position** section controls the appearance of superscripts and subscripts.

The **Rotation/Scaling** section controls the rotation of the characters. The Scale width box controls the percentage of the font width by which to compress or stretch the rotated text.

The **Spacing** section controls the spacing between individual characters. The Pair Kerning option (selected by default) automatically adjusts the character spacing for specific letter combinations. Pair Kerning is only available for certain font types and, for printed documents, works only if your printer supports it.

**Hyperlink**

The **Hyperlink** tab of the Character dialog is an alternative to using the Hyperlink dialog (**Insert > Hyperlink**). It includes fewer choices and is specifically for text (not button) links. Hyperlinks can be to other parts of the same document, to other documents, or to web pages.
When LibreOffice recognizes a string of characters that may be a URL (internet address), it replaces the characters with a hyperlink and formats the hyperlink as specified in the Internet Link character style. On this dialog you can choose a different character style (if the style has been defined previously) or replace the URL with other text. To turn off this feature, choose Tools > AutoCorrect > AutoCorrect Options, go to the Options tab and deselect URL Recognition.

For more about creating and editing hyperlinks, see the Help system or the Getting Started Guide.

**Highlighting**

The Highlighting tab controls the background color for selected characters. It is similar to the Highlighting drop-down palette.

**Borders**

The Borders tab is the same as the Borders tab on the Paragraph dialog; see page 105.

### Formatting lists using styles

Whenever possible, use paragraph styles for creating unordered (bulleted) and ordered (numbered) lists. Writer comes with two sets of paragraph styles for this purpose. However, these styles do not include options for settings such as the type of bullet or position of numbers. Those settings come from list styles, which are intended to be attached to paragraph styles. It is recommended to use them together in these ways:

- Use paragraph styles List 1, List 2, List 3, and so on for creating unordered lists. These styles use Bullet list styles.
- Use paragraph styles Numbering 1, Numbering 2, Numbering 3, etc, for creating ordered lists. These styles use the list styles called Numbering 1, Numbering 2, etc.

With paragraph styles, you can easily create nested lists, in which list items have sub-items under them, as in an outline. This requires specifying the settings for the additional levels. Once you have set up nested lists, you can readily change the hierarchy of an item. To demote an item one level, position the cursor at the beginning of the line (after the bullet or number) and press the Tab key. To promote an item one level, press Shift+Tab.

For more about creating lists using styles, see Chapters 8 (Introduction to Styles), 9 (Working with Styles) and 12 (Lists).
Formatting lists directly

You can directly format ordered or unordered lists in several ways:

- Use the Bullets and Numbering toolbar (Figure 88).
- Use the **Toggle Unordered List** and **Toggle Ordered List** icons on the Formatting toolbar, the Formatting (Styles) toolbar, or the Paragraph panel of the Properties deck of the Sidebar (Figure 64).
- Use the Bullets and Numbering dialog (Figures 90 and 91).

To produce a simple ordered or unordered list, select the paragraphs in the list and then click the appropriate icon on the Paragraph panel on the toolbar.

**Tip**

It is a matter of personal preference whether you type information first, then apply numbering/bullets or apply these as you type.

**Note**

Bullets and numbering applied in these ways cannot be removed with **Format > Clear Direct Formatting** on the Menu bar, or with the **Clear Direct Formatting** icon on the Formatting toolbar, or with **Clear Direct Formatting** in the context menu, or by using Ctrl+M. Rather, they are turned off or removed from selected text by toggling the relevant icons on the Formatting toolbar or on the Sidebar Properties deck.

Using the Bullets and Numbering toolbar

To create a nested list (where one or more list items has a sub-list under it, as in an outline), use the icons on the Bullets and Numbering toolbar (Figure 88). You can move items up or down the list, create subpoints, change the style of bullets, add paragraphs without numbers or bullets (for list items that include more than one paragraph), and access the Bullets and Numbering dialog, which contains more detailed controls.

Use **View > Toolbars > Bullets and Numbering** to display the toolbar.

![Bullets and Numbering toolbar](image)

1. Demote Outline Level
2. Promote Outline Level
3. Demote Outline Level with Subpoints
4. Promote Outline Level with Subpoints
5. Move Item Down
6. Move Item Up
7. Move Item Down with Subpoints
8. Move Item Up with Subpoints
9. Insert Unnumbered Entry
10. Toggle Restart Numbering
11. Add to List
12. Bullets and Numbering (opens the dialog)

**Tip**

You can use keyboard shortcuts to move paragraphs up or down the outline levels. Place the cursor at the beginning of the numbered paragraph and press:

- **Tab:** Down a level or **Shift+Tab:** Up a level.
Tip

To insert a tab stop at the beginning of a numbered paragraph (that is, after the number but before the text), press Ctrl+Tab.

If you create a nested list using the icons on the Bullets and Numbering toolbar, all the levels of the list (up to 10) initially apply the same numbering (or bullet) format. To use a combination of numbering formats and bullets when creating nested lists, you can:

- Click in each list item and then select one of the choices in the drop-down palettes under the Toggle Unordered List and Toggle Ordered List icons on the Formatting toolbar or the Properties deck of the Sidebar.
- Use the Bullets and Numbering dialog.

A much better strategy is to define and apply a list style, as discussed in Chapter 12, Lists.

**Using the Bullets and Numbering palettes on the Sidebar**

On the Paragraph panel on the Properties deck of the Sidebar, click the arrow next to the **Toggle Unordered List** control to open a palette of bullet styles or click the arrow next to the **Toggle Ordered List** control to open a palette of numbering styles.

The selections on these palettes (Figure 89) can be used to create nested lists and access the Bullets and Numbering dialog. The Sidebar does not include tools for promoting and demoting items in the list, as found on the Bullets and Numbering toolbar.

![Figure 89: Bullets and Numbering choices on the Properties deck of the Sidebar](image)

**Using the Bullets and Numbering dialog**

The Bullets and Numbering dialog has six tabs. Four tabs provide pre-defined symbols and sequences to choose from: Unordered, Ordered, Outline (choose from eight standard outline sequences), and Image (choose a bullet image). Two tabs provide detailed options for defining your own lists: Position (Figure 90) and Customize (Figure 91). These are the same as the tabs provided for list styles, discussed in Chapter 12, Lists.
Autoformatting

You can set Writer to automatically format parts of a document according to the choices made on the Options and Localized Options tabs of the AutoCorrect dialog (Tools > AutoCorrect > AutoCorrect Options). The Help describes each of these choices and how to activate the autoformats.
Tip

If unexpected formatting changes occur in a document, this is a good place to look for the cause.

To automatically format the file according to the options set, choose **Tools > AutoCorrect** and select or deselect the items on the submenu.

**While Typing**
Automatically formats the document while you type.

**Apply**
Automatically formats the document.

**Apply and Edit Changes**
Automatically formats the file and then opens a dialog where you can accept or reject the changes.

**AutoCorrect Options**
Opens the AutoCorrect dialog (Figures 92 and 93), where you can choose the autoformatting you want.

The **Localized Options** tab (Figure 92) controls the formatting of quotation marks and apostrophes (which look like a closing single quote). Most fonts include curly quotation marks (also known as “smart quotes”), but for some purposes (such as marking minutes and seconds of latitude and longitude) you may wish to format them as straight quotes.

<table>
<thead>
<tr>
<th>Straight quotes</th>
<th>Smart quotes</th>
</tr>
</thead>
<tbody>
<tr>
<td>`' '  &quot; &quot;</td>
<td>`' '  &quot; &quot;</td>
</tr>
</tbody>
</table>

**Figure 92: Autoformatting quotation marks**
Tip

Most people keep the AutoCorrect setting for smart quotes and use the Special Characters dialog to insert straight quotes when needed. See Chapter 2, Working with Text: Basics.

![Autoformatting choices on the Options tab](image)

**Figure 93: Autoformatting choices on the Options tab**
Chapter 5,
Formatting Pages: Basics
Page styles and related features
Introduction

Writer provides several ways to control page layouts. This chapter describes the use of page styles and some associated functions:

- Margins
- Page breaks
- Headers and footers
- Page numbering
- Title pages
- Footnotes and endnotes

Chapter 6, Formatting Pages: Advanced covers the use of columns, frames, tables, and sections; changing page orientation within a document; and the use of borders and backgrounds. Some other uses of page styles are discussed in Chapter 8, Introduction to Styles. The Page Style dialog is covered in detail in Chapter 9, Working with Styles.

Note

All pages in a Writer document are based on page styles. The other layout methods (described in Chapter 6) build upon the underlying page style.

Tip

Page layout is usually easier if you select the options to show text, object, table, and section boundaries in Tools > Options > LibreOffice > Application Colors and the options for paragraph ends, tabs, breaks, and other items in Tools > Options > LibreOffice Writer > Formatting Aids.

Setting up basic page layout using styles

In Writer, page styles define the basic layout of all pages, including page size, margins, the placement of headers and footers, borders and backgrounds, number of columns, page numbers, and so on.

Writer comes with several page styles, which you can build on or modify, and you can define new (custom) page styles. A single document can use one or many page styles. If you do not specify a page style, Writer uses the Default Page Style.

To change the layout of individual pages, either define a new page style or use one of the techniques (sections, frames, or tables) described in Chapter 6, Formatting Pages: Advanced.

Note

For some documents, all layout changes (such as the position of page numbers and other elements in a header or footer on facing pages) can be defined in a single page style.

Tip

Any modifications of page styles, including the Default Page Style, apply only to the document you are working on. If you want the changes to be the default for all documents, you need to put the changes into a template and make that template the default template. See Chapter 10, Working with Templates, for details.
Changing page margins

You can change page margins in these ways:

• Using the page rulers—quick and easy, but does not have fine control.
• Using the Page Style dialog—can specify margins to two decimal places.
• Using the Page deck in the Sidebar—changes all margins to the same value.

Note

If you change the margins using any of these methods, the new margins are recorded in the page style and affect all pages that use that style. The new margins will be shown in the Page Style dialog the next time you open it.

To change the margins on some pages, but not others, you must use different page styles and switch between them; see “Inserting page breaks” on page 127.

To change margins using the rulers:

1) The shaded sections of the rulers are the margins (Figure 94). Put the mouse pointer over the line between the gray and white sections. The pointer turns into a double-headed arrow (or some other symbol, depending on your operating system) and displays the current setting in a tooltip.

2) Hold down the left mouse button and drag the mouse to move the margin.

Note

The small arrows on the ruler are used for indenting paragraphs. They are often in the same place as the page margins, so be careful to move the margin marker, not the arrows. The double-headed arrows shown in Figure 94 are the mouse pointers placed in the correct position.

Tip

After making a change, pass the mouse pointer over the new margin to show its new measurement.

To change margins using the Page Style dialog:

1) Right-click anywhere on the page and select **Page Style** in the context menu.
2) On the Page tab of the dialog (Figure 95), type the required distances in the Margins boxes. The Gutter margin is the extra space to leave between the left (or inner) edge of the page and the left (or inner) margin. Alternatively, leave the Gutter set to zero and add the gutter margin amount to the left or inner margin value.

3) Click OK to save.

![Figure 95: Page tab of Page Style dialog](image)

To change margins using the Page deck in the Sidebar, choose one of the preset margins in the drop-down list (Figure 96) or open the Page Style dialog from the More Options icon at the top right of the Format section's title bar.

![Figure 96: Changing margins using the Sidebar](image)
Changing the margin on the Sidebar changes all four margins to the same dimension. Use another method if you want margins of different sizes.

**Inserting page breaks**

In many documents (for example, a multi-page report), you want the text to flow from one page to the next as you add or delete information. Writer does this automatically, unless you override the text flow using one of the techniques described in this section.

**Controlling automatic page breaks**

You can control some of the automatic text flow in several ways, including:

- Use the **Keep with next paragraph** option, for example to prevent the lead-in sentence to a list from being separated from the list. This option is found on the **Text Flow** tab of the Paragraph dialog (right-click and choose **Paragraph > Paragraph** in the context menu to open the dialog).

- Use the **Do not split paragraph** option on the **Text Flow** tab of the Paragraph dialog (for individual paragraphs) or the Paragraph Style dialog (for all paragraphs with that style).

- Use a paragraph style to require a paragraph to start on a new page. A typical use is for chapter titles to always start on a new right-hand (odd-numbered) page; use the Paragraph Style dialog to define this. See Chapter 9, Working with Styles, for more information.

**Inserting a page break without changing the page style**

To have a page break in a particular place—for example, to put a heading at the top of a new page—you can position the cursor at the point where you want to start the new page and select **Insert > Page Break** on the Menu bar.

**Inserting a page break and changing to a new page style**

To have the new page use a different page style—for example, to change from a First Page style to a Left Page style—use either of these methods.

**Caution**

Do not try to change a page style for a single page without inserting a page break. The page style of some or all of the other pages—before and after the changed page—may also change. For more information, see Chapter 8, Introduction to Styles.
Method 1

1) Position the cursor at the point you want to start the next page. Select **Insert > More Breaks > Manual Break**.

2) In the **Type** section of the Insert Break dialog (Figure 98), **Page break** is preselected, and **Style** is set at [None]. In the **Style** drop-down list, select the page style for the next page. Do not select the **Change page number** option. Click **OK**.

![Figure 98: Inserting a manual page break and changing the page style](image)

Method 2

1) Position the cursor in the paragraph you want to be at the start of the next page. Right-click and choose **Paragraph > Paragraph** in the context menu.

2) On the **Text Flow** page of the Paragraph dialog (Figure 99), in the **Breaks** section, select **Insert** and **With page style**. In the **Style** drop-down list, select the page style for the next page. Do not select the **Page number** option. Click **OK** to insert the page break.

![Figure 99: Inserting a manual page break using the Paragraph dialog](image)

**Tip**

See "Numbering the first page something other than 1" on page 135 for information on the use of the page number field in these dialogs.
Creating headers and footers

Headers are portions of a document that appear at the top of every page; footers appear at the bottom of a page. They typically include a page number and sometimes document information such as the title.

In Writer, headers and footers are specified in page styles. Therefore, all the pages with the same page style will display the same header and footer, although the contents of the header/footer may vary. For example, the header/footer on the first page of a section, chapter, or document may contain different information than the rest of the headers and footers in the document, even though the page style is the same. See “Using one page style” on page 138.

Terminology

A heading is a paragraph that introduces a chapter or section of a document; for example, “Creating headers and footers” above. A header (also known as a running header) appears in the top margin of each page and typically displays information about the document; it is similar to a footer at the bottom of pages.

To insert a header, do one of the following:

• Click above the top of the text area. When the Header marker appears, click the +. To insert a footer, click below the bottom of the text area to display the Footer marker, and then click the +.

• Select Insert > Header and Footer > Header > [Page Style] on the Menu bar. The submenu lists the page styles used in the document and the entry All, which activates headers on all the page styles of the document. Similarly, to insert a footer, choose Insert > Header and Footer > Footer > [Page Style].

For example, select Default Page Style to activate the headers or footers only on the pages that use the Default Page Style. An area will appear at the top or bottom of the page (Figure 101).
• Right-click anywhere on the page and select **Page Style** in the context menu. On the Page Style dialog, go to the **Header** tab and select **Header on**, or go to the **Footer** tab and select **Footer on**. This method affects only the one page style.

**Formatting headers and footers**

In Writer, headers and footers are paragraphs; therefore, you can format the header or footer text using the same techniques as for formatting text in the main body of the document. See Chapter 4, Formatting Text.

You can also add images to headers and footers using any of the techniques described in Chapter 11, Images and Graphics, and you can line up information using tables as described in Chapter 6, Formatting Pages: Advanced.

**Tip**

Writer provides paragraph styles for headers and footers, which you can modify and use in the same way as other paragraph styles. See Chapter 8, Introduction to Styles, and Chapter 9, Working with Styles.

Some formatting can be applied using the **Page** tab on the Sidebar: margins, spacing, and whether same content goes on the first page and/or left and right pages (Figure 102).

![Figure 102: Formatting a header or footer using the Sidebar](image)

For more options, use the Page Style dialog.

1) **Use any of these methods to open the Page Style dialog:**
   - Click anywhere on the page and choose **Format > Page Style** on the Menu bar.
   - Right-click anywhere on the page and choose **Page Style** in the context menu.
   - If the page has a header, click in the header area. When the Header marker appears, click the down arrow and select **Format Header**.
   - If the page has a footer, click in the footer area. When the Footer marker appears, click the down arrow and select **Format Footer**.
   - On the **Page** tab of the Sidebar, click the **More Options** icon on the right of the Header or Footer title bar.
2) On the *Header* or *Footer* tab of the Page Style dialog (Figure 103), change the margins, spacing, and height.

3) Click **More** to open the Border/Background dialog (Figure 104), where you can add borders, background colors, and background images to the header or footer.

![Figure 103: Footer tab of Page Style dialog](image)

![Figure 104: Border / Background tab for header or footer](image)

**Numbering pages**

When you place a page number field in a header or footer, the number appears on every page with that page style and changes automatically from one page to the next. The page number appears with a gray background. This gray background denotes a field; although the background is visible on screen, it is not printed.
This topic describes some techniques to insert page numbers and related information in headers or footers of a document:

- Simple page numbering
- Page number format
- Restarting page numbering and changing numbering format
- Numbering the first page something other than 1
- Error: Reference source not found
- Numbering pages by chapter

### Simple page numbering

The simplest case is to have the page number at the top or bottom of every page and nothing more (Figure 105). To do this, choose **Insert > Page Number** (to open the Page Number Wizard) or place the cursor in the header or footer and choose **Insert > Field > Page Number** (to insert the page number directly and optionally adjust settings later).

![Figure 105: Page number inserted in the header](image)

**Page number wizard**

Choose **Insert > Page Number** from the Menu bar to open the Page Number Wizard (Figure 106), where you can choose the location (header or footer), the alignment (right, center, left), the numbering style (i, ii, iii or 1, 2, 3 or other variations), and other settings for the page numbers.

If you do not use the Page Number Wizard, or to change any of the settings, follow the instructions in “Page number alignment” and “Page number format” below.

For additional page number settings, see “Restarting page numbering and changing numbering format” on page 134, “Numbering the first page something other than 1” on page 135, and “Numbering pages by chapter” on page 135.
Page number alignment

To align the page number to the left, right, or center, click in the header or footer and then use one of these methods to modify the footer paragraph:

- Click on one of the alignment icons on the Formatting toolbar.
- Open the Properties deck in the Sidebar. In the Paragraph section, click on one of the alignment icons (Figure 107).
- Right-click and choose Paragraph > Paragraph in the context menu. On the Paragraph dialog, go to the Alignment tab and choose an alignment option, then click OK.
**Page number format**

You can set the page number to display in several types of numerals: Arabic (1, 2, 3), lower-case Roman (i, ii, iii), ordinal (1st, 2nd, 3rd) and others. To do that, either double-click the page number and select **Page Style** in the context menu.

1) Right-click in the text area of the page and select **Page Style** in the context menu.

2) On the **Page** tab of the Page Style dialog, in the **Layout Settings** section on the right, select i, ii, iii, ... in the **Page numbers**: drop-down list to use lowercase Roman numerals (Figure 109).

![Figure 109: Changing the format of page numbers](image)

**Caution**

Any change in the number format affects the page numbers on all pages using that page style, regardless of the method used to change the format. To change the format of page numbers on some pages but not all, you need to use different page styles; see “Restarting page numbering and changing numbering format” below.

**Restarting page numbering and changing numbering format**

Many documents, such as books, have the front matter (such as the table of contents) numbered with Roman numerals and the main body of the document numbered in Arabic numerals, restarting at 1. To restart the page numbering at 1, follow these instructions.

First, define the numbering format for two page styles: **Front Matter** and **Default Page Style**. See “Using different page styles” on page 138 and “Page number format” above.

Next, in the front matter of the document, insert a page number (see “Simple page numbering” on page 132).

Then, restart page numbering:

1) Place the cursor in the first paragraph of the page to have the Default Page Style. (A heading is a paragraph.)

2) Choose **Format > Paragraph** on the Menu bar, or right-click and choose **Paragraph > Paragraph**, to display the Paragraph dialog.

3) On the **Text Flow** tab of the Paragraph dialog, in the **Breaks** area (Figure 110):

   a) Select **Insert**.

   b) In the **Type** drop-down list, select **Page**.

   c) In the **Position** drop-down list, select **Before**.
d) Select **With page style** and choose from the drop-down list the page style for the next page.

e) Select **Page number** to make the field active. Type 1. Click **OK**.

![Figure 110: The Breaks section of the Text Flow tab of the Paragraph Style dialog](image)

**Numbering the first page something other than 1**

The instructions for starting a document with a page number greater than 1 are similar to Step 3 in the previous section.

1) Insert a page number in the header or footer (**Insert > Page Number**).
2) Click in the first paragraph in the text area. Choose **Format > Paragraph** (or right-click and choose **Paragraph > Paragraph** in the context menu).
3) In the **Text Flow** page of the Paragraph dialog, in the **Breaks** section (Figure 110), select **Insert** and select **Page** in the **Type** drop-down list. Select **With page style** and the page style used for the first page of the document.
4) Select **Page number** to make the field active. Type the starting page number required. Click **OK**.

**Note**

If the starting page number selected is an even number, a blank page will occur before the first page. LibreOffice adheres to the convention that odd page numbers go on right-hand pages and even page numbers on left-hand pages.

This blank page can be suppressed when the file is printed or exported as a PDF. See Chapter 7, Printing and Publishing, for more information.

**Numbering pages by chapter**

Technical documents often include the chapter number with the page number in the header or footer. For example, 1-1, 1-2, 1-3, ...; 2-1, 2-2, 2-3, ... To set up this type of page numbering in Writer, do these things:

1) Ensure that chapter titles are all identified by the same paragraph style, for example, the Heading 1 style.
2) Use **Tools > Heading Numbering** to tell Writer what paragraph style is used for Level 1, and specify “1,2,3” in the Number box (Figure 111).
3) Insert the chapter number in the document:
   a) Place the cursor in the header or footer just before the page number inserted earlier, and choose `Insert > Field > More Fields` on the Menu bar.
   
   b) On the Fields dialog (Figure 112), go to the `Document` tab. Select `Heading` in the `Type` list, `Heading number` in the `Format` list, and `1` in the `Level` box. Click `Insert`.
   
   c) Type a hyphen or other punctuation between the chapter number and the page number.

![Figure 111: Specifying paragraph style and numbering for chapter titles](image1)

![Figure 112: Inserting a heading number field](image2)
Including other information in headers and footers

In addition to page numbers, other information often is placed into headers and footers. For example:

- Type the word Page (and a space) before the Page Number field so the header reads Page 1, Page 2, and so on.
- Use the Page Count field (Insert > Field > Page Count) and the Page Number field, so a header reads Page 1 of 4, Page 2 of 4, and so on.
- Document titles and chapter titles can be typed in or (better) added as fields. That way, if something changes, the headers and footers are all updated automatically.

Fields are covered in Chapter 17, but one example may be useful here. To insert the document title into the header on a Default page style:

1) Select File > Properties > Description on the Menu bar, enter a title for the document in the Title area, and click OK to close the dialog.
2) Add a header as described above.
3) Place the cursor in the header part of the page.
4) Select Insert > Field > Title on the Menu bar. The title should appear on a gray background (which does not show when printed and can be turned off).
5) To change the title of the document, select File > Properties > Description again and edit.

Defining a different first page for a document

Many documents, such as letters and memos, have a first page that is different from the other pages in the document. For example, the first page of a letterhead typically has a different header, as shown in Figure 113, or the first page of a report might have no header or footer, while the other pages do.

Figure 113: Letterhead with different headers for first and following pages
You can do this in several ways:

- Use the Default (or any other) page style for the document. Deselect the **Same content on first page** option on the header/footer tabs in the Page Style dialog, and then add different headers/footers to the first page and to the other pages of the document. See “Using one page style” on page 138.

- Use different page styles for the first page and for the following pages. Set the Next Page attribute for the first page so the next page automatically becomes the style for following pages. See “Using different page styles” on page 138.

- Add a title page at the beginning of the document. See “Adding title pages” on page 139.

### Using one page style

This example uses the Default Page Style.

1) Right-click anywhere on the page and choose **Page Style** in the context menu. On the relevant tab (Header or Footer) of the Page Style dialog, select **Header/Footer on** and deselect **Same content on first page** (Figure 114). Optionally select **Same content on left and right pages**.

2) Insert a header or footer on any page using the Default Page Style. See “Creating headers and footers” on page 127.

3) Add different header and footer content to the first page and to the other pages of the document. For example, leave the header/footer blank on the first page.

![Figure 114: Setting up footers to have different content on different pages](image)

### Using different page styles

As an example, we can use the First Page and Default page styles that come with LibreOffice. Figure 115 shows what we want to happen: the first page is to be followed by the default page, and all the following pages are to be in the default page style.

To do this, open the Page Style dialog for the First Page style, go to the Organizer tab, and choose **Default Page Style** in the Next Style list (Figure 116).

![Figure 115: Flow of page styles](image)
Adding title pages

Writer provides a fast and convenient way to add one or more title pages to a document and optionally to restart the page number at 1 for the body of the document.

Choose **Format > Title Page** on the Menu bar to display the Title Page dialog (Figure 117).

![Figure 117: Adding title pages to a document](image)

On the Title Page dialog, you can make the following choices:

- Convert existing pages to title pages, or insert new title pages.
- How many pages to convert or insert.
- Where those pages are located.
- If and where to restart page numbering, and what number to start with.
- What page style to use for the title page.

Using this technique, you can insert several “title pages” at different points in a document, for example to add decorative pages between chapters as well as title, copyright, and other pages at the beginning of a book.
Formatting footnotes and endnotes

Footnotes appear at the bottom of the page on which they are referenced. Endnotes are collected at the end of a document.

To work effectively with footnotes and endnotes if the defaults do not meet your needs:

- Insert footnotes and define their format (see Chapter 3, Working with Text: Advanced).
- Define the location of footnotes on the page, and the color and line styles for separator line.

Defining footnote location and separator line

The location of footnotes on the page, and the color and style of the line that separates the footnotes from the text, are defined in the page style. If you are using several page styles, and may have footnotes on any of them, be sure to define the footnote location and separator line on each of the page styles.

Choose Format > Page Style on the Menu bar or right-click a page and choose Page Style in the context menu, to display the Page Style dialog. Go to the Footnote tab (Figure 118) and make selections, then click OK to save the changes.

Keeping the default setting Not larger than page area, the footnotes area is calculated automatically on the basis of the number of footnotes. To manually control the maximum space that footnotes can take, select the Maximum footnote height option and enter the value in the preferred unit of measurement.

A footnote higher than the maximum height will spill over on to the next page. Use the second section of the page to customize the separator between the footnotes and the main text area.

Inserting column and line breaks

In addition to manual page breaks (discussed on page 127), you may sometimes wish to use column breaks and line breaks. The methods for inserting these breaks are similar to the methods for manual page breaks.
**Column breaks**

Manual column breaks are available only in a multi-column document or section. To insert a manual column break:

1) Position the cursor at the point you want to start the new column. Select Insert > More Breaks > Manual Break on the Menu bar.
2) In the Type section of the Insert Break dialog (Figure 98), select Column break. Click OK.

You can also use the Breaks section in the Paragraph dialog (Figure 99).

**Line breaks**

You can use line breaks to manually format text in several ways:

- Continue on the next line (the default).
- Continue on the next full line, below all anchored objects that intersect with the current line.
- Continue on the next line that is unblocked on the left-hand side.
- Continue on the next line that is unblocked on the right-hand side.

To insert a default line break, press Shift+Enter.

To insert other line break types:

1) Position the cursor at the point you want to break the text to a new line. Select Insert > More Breaks > Manual Break on the Menu bar.
2) In the Type section of the Insert Break dialog (Figure 119), select Line break.
3) Select the type of line break required. Click OK.

![Figure 119: Inserting a line break](image)

**Changing page orientation within a document**

A document can contain pages in more than one orientation. A common scenario is to have a landscape page in the middle or end of a document, where the other pages are in portrait orientation. Here are the steps to achieve it.
Setting up a landscape page style

1) To keep the margins the same as on other pages, then note the margin settings of the current page style (found on the Page tab of the Page Style dialog).

2) On the Styles deck of the Sidebar, right-click Landscape in the list of page styles and choose Edit Style.

3) On the Organizer tab of the Page Style dialog (Figure 120), make sure Next Style is set to Landscape (to allow for having more than one sequential landscape page).

![Figure 120: Set the next page style to Landscape](image)

4) On the Page tab of the Page Style dialog (Figure 121), make sure Orientation is set to Landscape. Change the margins so that they correspond with the margins of the portrait page. That is, the portrait top margin becomes the landscape left margin, and so on.

5) Click OK to save the changes.

![Figure 121: Set orientation and margins for a landscape page](image)

Inserting a landscape page into a portrait document

After the Landscape page style is defined, here is how to apply it:

1) Position the cursor in the paragraph or table at the start of the page that is to be set to landscape. Right-click and choose Paragraph > Paragraph or Table Properties, respectively, in the context menu.
2) On the *Text Flow* page of the Paragraph dialog (Figure 122) or the Table Properties dialog (Figure 123), select **Insert** (or **Break** for a table) and **With Page Style**. Set the Page Style property to Landscape. Click **OK** to apply the new page style.

3) Position the cursor in the paragraph or table where the page is to return to portrait orientation and change the paragraph properties or table properties so that **With Page Style** is the portrait page style that was used before the Landscape page style. Click **OK** to return to the portrait page style.

![Figure 122: Specifying a page break before a paragraph](image1)

![Figure 123: Specifying a page break before a table](image2)

**Portrait headers or footers on landscape pages**

When a header or footer is defined on a landscape page, it is positioned on the long side of the page. If landscape pages are inserted between portrait pages, you might want the headers and footers to be on the short sides of the landscape pages, so that turning the landscape pages 90 degrees (as in a printed book) presents the same layout as on the portrait pages.

You can set up portrait-oriented headers and footers on landscape pages by using frames. These are a bit tricky to set up, but once you have done so, they are part of the Landscape page style and appear on all landscape pages in the document.

In the example below, we want to insert a landscape page into a document so that it has the same header, footer, and margins as the portrait pages. In the example, the default page style is portrait, A4 size, with header and footer of 0.5 cm with 0.5 cm spacing.

To match the layout of the landscape page to that of the portrait pages:

- The landscape page should have the header enabled, but not the footer.
- The top margin of the landscape page will be one centimeter less than the left margin of the portrait page, since it will have an (empty) header where we will anchor both the vertical header and footer frames.
- The bottom margin of the landscape page will be equal to the right margin of the portrait page.
The left and right margins of the landscape page must be one centimeter larger than the corresponding top and bottom of the portrait page so that the longitudinal size of both pages matches. That centimeter is the result of adding the size of the header or footer and the spacing to the main text (0.5 for the header or footer and 0.5 cm for the spacing).

To achieve these results, follow these steps:

1) Modify the margins of the Landscape page style so the size of the text space is the same on both page styles.

<table>
<thead>
<tr>
<th>Portrait (vertical) page</th>
<th>Landscape (horizontal) page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Top margin</td>
<td>1.5 cm</td>
</tr>
<tr>
<td>Bottom margin</td>
<td>1.5 cm</td>
</tr>
<tr>
<td>Left (inner) margin</td>
<td>2.8 cm</td>
</tr>
<tr>
<td>Right (outer) margin</td>
<td>1.8 cm</td>
</tr>
<tr>
<td>Top margin</td>
<td>1.8 cm</td>
</tr>
<tr>
<td>Bottom margin</td>
<td>1.8 cm</td>
</tr>
<tr>
<td>Left (inner) margin</td>
<td>2.5 cm</td>
</tr>
<tr>
<td>Right (outer) margin</td>
<td>2.5 cm</td>
</tr>
</tbody>
</table>

2) Insert a manual page break where you want a landscape page to appear (Insert > More Breaks > Manual Break) and choose Landscape for the page style.

3) Copy and paste all the content from the footer of the portrait page and paste it into a blank paragraph on the landscape page. Be sure this text has the Footer paragraph style so the font settings will match.

4) Select the full text (including the fields) you just pasted. Choose Format > Character. In the Character dialog, choose the Position tab and set Rotation / Scaling to 270 degrees (counterclockwise). Click OK.

5) With the text still selected, choose Insert > Frame > Frame. In the Frame dialog (Figure 126), select the Type tab and enter the width, height, and horizontal and vertical position for the footer. Deselect the automatic sizing options in Width and Height.
6) Select the entire frame and modify the width and height:
   – The width should be 0.5 cm (height of the vertical page style footer).
   – The height must be equal to the Din A4 page width (21 cm) minus the sum of the top
     and bottom margins of 2.8 cm and 1.8 cm, which results in 16.4 cm.

7) Cut the frame (Ctrl+X), move to the header of the landscape page and paste it into the
    header (Ctrl+V), so that, anchored in the empty header paragraph, it repeats every time
    you insert a landscape page.

8) Set the position of the frame relative to the entire page.
   – Vertical position 2.80 cm (same distance as the left margin vertically).
   – Horizontal position: 1.50 cm (same distance as the bottom margin vertically).

9) If the footer has a line above the text, on the Borders tab, select a right border and specify
    the line width and spacing to the frame’s contents.

10) Click OK to save these settings. The footer will now appear in the required position and
    orientation on any page using the Landscape style.

11) Since rotated text does not allow tabs, click in the frame at the end of the text where the
    tab was, and type as many spaces as you need for the layout to match the portrait page.

Tip

To set up a portrait header on the landscape page, repeat these steps (from step 3)
but set the horizontal position to 27.70 cm (29.7 cm, minus 2 cm from the margin and
header).
Figure 127: Footers in place for both page styles
Chapter 6, 
Formatting Pages: Advanced

Using columns, frames, tables, sections, and themes
Introduction

Writer provides several ways to control page layouts. Chapter 5, Formatting Pages: Basics, described the use of page styles and some associated functions. This chapter covers the use of:

- Columns
- Frames
- Tables
- Sections
- Changing page orientation within a document
- Borders and backgrounds
- Using page line-spacing for printing

Note

All pages in a Writer document are based on page styles. The other layout methods described in this chapter build upon the underlying page style.

Tip

Page layout is usually easier if you select the options to show text, object, table, and section boundaries in Tools > Options > LibreOffice > Application Colors and the options for paragraph ends, tabs, breaks, and other items in Tools > Options > LibreOffice Writer > Formatting Aids.

Choosing a layout method

The best layout method depends on what the final document should look like, what sort of information will be in the document, and whether the document will be published in a fixed format (print, PDF) or a variable format (HTML, ePub) or more than one format. Here are some examples. The techniques mentioned are all described in this chapter.

- For a book similar to this user guide with one column of text, some figures without text beside them, and some other figures with descriptive text, use page styles for basic layout, and use tables to place figures beside descriptive text, where necessary.
- Use sections (with two or more columns) for an index or other document with two columns of text where the text continues from the left-hand column to the right-hand column and then to the next page, all in sequence. If the title of the document (on the first page) is full-page width, put it in a single-column section.
- For a newsletter with a complex layout, two or three columns on the page, and some articles that continue from one page to some place several pages later, use page styles for basic layout, then place articles in linked frames. If necessary, anchor graphics to fixed positions on the page.

Tip

For a document to be published in HTML, EPUB, or another format that is not fixed, use minimal layout techniques. Some methods (columns, frames, wide tables) often do not export well to those formats.
Using columns to define the page layout

It is a good idea to define your basic page style (such as Default Page Style) with the most common layout to be used in your document, either single-column or multiple-column. You can then define extra page styles for pages with different numbers of columns.

Note

If you wish to combine different numbers of columns on a single page, you must use sections, as described in "Using sections for page layout" starting on page 161.

To define the number of columns for a page style:

1) Choose Format > Page Style on the Menu bar, or right-click on the page and choose Page Style in the context menu, or click the More Options button in the Format section of the Page deck on the Sidebar, to open the Page Style dialog. Go to the Columns tab (Figure 128).

2) In the Settings section, choose the number of columns and specify any spacing between them and whether you want a vertical separator line to appear between the columns. Use one of Writer’s predefined column layouts or create a customized column layout. The preview on the right shows how the column layout will look.

3) Click OK to save the changes.

Figure 128: Defining the number of columns on a page

Formatting column width and spacing

Select AutoWidth in the Width and Spacing section to create columns of equal or preset width. To customize the width and spacing of the columns:

1) In the Width and Spacing section, deselect the AutoWidth option.

2) In the Width selection boxes, enter a width for each column.

3) On the Spacing line, enter the amount of space between each pair of columns.

If more than three columns are specified, use the arrow buttons on the Column line to scroll among the columns.
Formatting separator lines

White space may be all that is needed between columns, but to create separator lines:

1) Using the Style drop-down list, select the line style from the three styles available.

2) Using the Width control, select the width of line to use, settable from 0.25pt to 9.0pt.
   (1 point = 1/12 pica = 1/72 inch = 127/360 mm = 0.3527 mm.)

3) Using the Height control, select the height of line required, as a percentage of the column height. You can choose from the supplied values or type in measurements.

4) For a height less than 100%, use the Position drop-down list to select a vertical alignment for the separator lines. The vertical positioning options are Top, Centered, or Bottom.

5) Select the line color from the Color drop-down list.

Distributing text across columns

As text is added to a column, the text flows from one column to the next. The last column may be shorter than the others.

To distribute text evenly, so that all the columns are approximately the same height, use a multi-column section instead; see “Formatting a section into columns” on page 164.

Tip

Choose View > Formatting Marks (or press Ctrl+F10) to display end of paragraph markers (¶). Often, unexpected behavior of columns is due to extra paragraphs that are normally invisible but are taking up space.

Using frames for page layout

Frames can be very useful when producing newsletters or other layout-intensive documents. Frames can contain text, tables, multiple columns, pictures, and other objects. Use frames to:

• Position something in a particular place on a page, for example, a logo or a “stop press” news box in one corner of a page.

• Allow text on one page to continue on another page, somewhere more distant than the next one, by linking the content of one frame to another so the contents flow between them as you edit the text.

• Wrap text around an object, such as a photograph.

Because LibreOffice does not allow page styles with recurring frames (unless anchored in a header or footer), consider doing some quick sketches of the basic page layouts you need, indicating the approximate positions of different frames and their purposes. Keep the number of different page layouts as low as possible to avoid chaos in the design.

Pay special attention to the positioning of frames. A visually effective way to position a frame is to align its left margin with that of the paragraph above it. To do this, insert the frame in a blank paragraph of the same style as the paragraph above. Select Insert > Frame > Frame; in the Position section of the Type page of the Frame dialog (Figure 129 on page 155), select From Left in the Horizontal selection box to position the frame exactly where you want it.

Also, think about the type of wrap and the spacing between the frame and text. Instead of placing a frame close to the text, use the Wrap page to place some white space between them.

To format frames individually, or define and apply frame styles, see Chapter 9, Working with Styles.
Creating a frame

To create a frame, use one of these methods:

- Choose **Insert > Frame > Frame** to create an empty frame. The Frame dialog (Figure 129) opens. Set the frame’s characteristics at this stage or click **OK** and come back to customize it later.

- Select text and choose **Insert > Frame > Frame** to open the Frame dialog. Customize the frame (for example, to add space between the frame and the text) and click **OK**. The selected text is removed from the normal text flow and inserted into the frame.

- Choose **Insert > Frame > Frame Interactively** to quickly draw an empty frame. The mouse cursor changes shape. Click and drag the mouse to draw an empty frame. To customize the frame, right-click it and choose **Properties** in the context menu.

- Insert a formula or OLE object by selecting **Insert > Object > [type of object]**. The item is inserted and appears in a frame. To customize the frame, right-click it and choose **Properties** in the context menu.

To add content to a frame, first deselect the frame by clicking in an empty space somewhere else on the page. Then, click inside the frame to place the text cursor there. Now add content as you would on the main page. When you are done, deselect the frame.

Note

The menu item **Insert > Frame > Floating Frame** is for use with HTML documents.

![Frame dialog, Position and Size tab](image)

**Figure 129: Frame dialog, Position and Size tab**

Frame toolbar

When you create or select a frame, the Frame toolbar (Figure 130) is displayed. By default, it replaces the Formatting toolbar. You can also display it by using **View > Toolbars > Frame**.
Moving, resizing, and changing frame attributes

When an object is added to Writer, it is automatically enclosed in a frame of a predetermined type. The frame sets how the object is placed on the page, as well as how it interacts with other elements in the document. You can edit the frame by modifying the frame style it uses or by manually formatting it when you add it to the document. Frame styles are discussed in Chapter 9, Working with Styles.

To change the size or location of a frame, first select the frame, then use either the mouse or the Frame dialog (Figure 129). Using the mouse is faster but less accurate.

**Tip**

You might want to use the mouse for gross layout and the dialog for fine-tuning.

To re-size the frame manually, use any of these ways:

- Click on the green squares (sizing handles) and drag to the appropriate size.
- Add content to it (the frame will re-size automatically if, for example, you add a large picture to it).
- Go back to the Frame dialog and set the size and other characteristics.

To change the location of the frame using the mouse, drag and drop one of the edges or place the mouse pointer over an edge of the frame. The mouse pointer changes to a four-headed arrow when properly positioned for a drag-and-drop move.

To change the size of the frame, drag one of the sizing handles. Drag a handle on one of the sides to enlarge or reduce the text frame in one dimension only; drag a corner handle to enlarge or reduce it in both dimensions.

These resizing actions distort the proportions of the frame. Holding down the *Shift* key while dragging one of the handles makes the frame keep the same proportions.

To open the Frame dialog, select the frame, right-click, and choose Properties in the context menu.

To add or remove a frame's border, click the relevant button on the Frame toolbar (Figure 130) to display some choices; or open the Frame dialog, go to the Borders page (Figure 131), and in the Line Arrangement section, select the first Preset (*Set No Borders*); or assign a borderless style to the frame; see Chapter 9, Working with Styles, for information on frame styles.

**Note**

Do not confuse a frame's border with the text boundaries that are made visible using the View menu (by selecting View > Text Boundaries).
Anchoring frames

To anchor a frame, click on it, then right-click and point to Anchor, or click the Anchor button on the Frame toolbar and select the type of anchor, or open the Frame dialog to the Type tab.

**To Page (available only on Frame dialog, not the toolbar or context menu)**

The frame keeps the same position in relation to the page margins. It does not move as you add or delete text. This method is useful when the frame does not need to be visually associated with a particular piece of text. It is often used when producing newsletters or other documents that are very layout-intensive, or to center text vertically on a page.

The To Page anchor is deprecated. It is best to choose another type of anchor.

**To Paragraph**

The frame is associated with a paragraph and moves with the paragraph. It may be placed in the margin or another location. It is also used to center text on a page in documents which will be used in a master document (frames anchored to pages will disappear from the master document).

**To Character**

The frame is associated with a character but is not in the text sequence. It moves with the paragraph but may be placed in the margin or another location. This method is similar to anchoring to a paragraph.

**As Character**

The frame is placed in the document like any other character and, therefore, affects the height of the text line and the line break. The frame moves with the text as you add or delete text. This method is useful for adding a small icon in sequence in a sentence. It is also the best method for anchoring an image to an empty paragraph so it does not move around the page in unexpected ways.

Linking frames

You can link frames to each other even when they are on different pages of a document. The contents will automatically flow from one to the next. This technique is very useful when designing newsletters, where articles may need to be continued on a different page.
To link one frame to another:

1) Select the frame to be linked from.
2) Click the **Link Frames** icon on the Frames toolbar.
3) Click the next frame in the series (which must be empty).

When a linked frame is selected, any existing links are indicated by a faint connecting line (see Figure 132). To unlink frames, select the **Unlink Frames** icon on the Frames toolbar.

![Figure 132: Linked frames](image)

The height of a frame that is being linked from is fixed; you can change this height manually or by using the Position and Size tab on the Frame dialog, but it does not automatically adjust to the size of the contents (that is, the AutoHeight attribute is disabled). Only the last frame of a chain can adapt its height to the content.

The **Wrap**, **Borders**, **Area**, **Columns**, **Transparency**, and **Macro** pages of the Frame dialog are the same as those for frame styles. Refer to Chapter 9, Working with Styles, for details.

![Figure 133: Options tab of the Frame dialog](image)
The Options tab of the Frame dialog (Figure 133) shows the names of the selected frame and any frames it is linked to or from (Sequence). You can change this information here. On this tab, you can also select options to protect the contents, position, and size of the frame and provide accessibility information (Description). If the frame has no information content and is merely decorative, select the Decorative option.

**Using tables for page layout**

Writer's tables can serve several purposes, such as holding data as you might see it in a spreadsheet, lining up material, and creating more complex page layouts. This topic describes how to achieve some common layouts by using tables. For information about using tables of data, see Chapter 13, Tables.

**Positioning information in headers or footers**

Instead of using tabs or frames, you can use a table in a header or footer to position different elements such as page number, document title, author, and so on. These elements are often inserted using fields, as described in Chapter 17, Fields.

**Creating sideheads using tables**

Sideheads and marginal notes are commonly used in documents such as resumes and computer user guides. The main body of the text is offset to leave white space (usually on the left-hand side) in which the sideheads or notes are placed. The first paragraph is aligned beside the sidehead, as in Figure 134.

<table>
<thead>
<tr>
<th>Example of a sidehead</th>
<th>In some cases you may want to put only one or two paragraphs in the table itself and the rest of the text and graphics in ordinary paragraphs (formatted to line up with the paragraphs in the table) so that text and graphics will flow more easily from one page to another when you add or delete material.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>In other cases, you might put each paragraph in a separate row of the table and allow the table to break between pages.                                                                процесс шаг за шагом</td>
</tr>
</tbody>
</table>

**Note**

Sideheads can also be created by placing text in a frame using the Marginalia frame style, as described in Chapter 9, Working with Styles.

**Example**

To create a table for use with a sidehead:

1. Place the cursor where you want the table to appear and choose Table > Insert Table (Ctrl+F12).
2. In the Insert Table dialog (Figure 135), define a two-column, one-row table with no heading. Choose None under Styles so the table will have no border. Click Insert.
3. Right-click the table and choose Table Properties in the context menu. On the Columns tab of the Table Properties dialog (Figure 136), set the column widths.
4. On the Table tab of the Table Properties dialog (Figure 137), in the Spacing section, make the Above and Below values the same as the Top and Bottom spacing you have defined for ordinary paragraphs of text. In the Properties section, optionally give this table a name. Click OK to save your settings.
Tip

To check the top and bottom spacing for a paragraph: position the cursor in the paragraph and open the Properties deck on the Sidebar. In the Paragraph section, look under Spacing for the values.

Figure 135: Defining a two-column borderless table with no heading

Figure 136: Defining a two-column table to line up with text offset at 3.3cm
To turn off number recognition so that Writer will not try to format numbers that should be plain text:

1) Place the cursor in a table, and then select **Table > Number Format** on the Menu bar.
2) On the Format Number dialog (Figure 138), make sure the **Category** is set to **Text**.
3) Click **OK**.

**Tip**

If you use this table format often, you may want to save it as a table style, using **Table > AutoFormat Styles**. See Chapter 13, Tables.

### Using sections for page layout

A section is a block of text that has special attributes and formatting. Use sections to:

- Write-protect text.
- Hide text.
- Dynamically insert the contents of another document.
- Add columns, margin indents, a background color, or a background graphic to a portion of a document.
- Customize the footnotes and endnotes for a portion of a document.
Creating sections

To create a section:

1) Place the cursor at the point in your document where you want to insert the new section. Or, select the text that you want to place in the new section.

2) On the Menu bar, choose **Insert > Section**. The Insert Section dialog (Figure 139) opens.

3) Choose settings for each page of the dialog as described below. Click **Insert**.

The Insert Section dialog has five tabs:

- Use the **Section** tab to set the section’s attributes.
- Use the **Columns** tab to format the section into columns.
- Use the **Indents** tab to set indents from the right and left margins of the section.
- Use the **Area** tab to add color or a graphic to the section’s background.
- Use the **Footnotes/Endnotes** tab to customize the section’s footnotes and endnotes.

![Insert Section dialog](image)

**Figure 139: Inserting a section using the Insert Section dialog**

At any time before closing the dialog, you can reset a tabbed page other than the **Section** page to its default settings by clicking the **Reset** button. If you wish to undo changes to the **Section** page, you must do so manually.

**Naming sections**

Writer automatically enters a name for the section in the name box of the New Section list. To change the name, select it and type over it. The name is displayed in the Sections category of the Navigator window. Navigation is easier if you give your sections meaningful names.
**Linking sections**

You can insert the contents of another document into the section and then have Writer update it whenever the other document is updated.

**Note**

If you want to insert only a part of the other document, be sure that part exists as a section in the document.

To link the section to another document, follow these steps:

1) In the *Link* section of the dialog (Figure 140), select the *Link* option.
2) Click the *Browse* button to the right of the *File name* field. The Insert dialog opens.
3) Find and select the required document and click the *Insert* button. The name of the selected document appears in the *File name* field.
4) To insert only a section of the selected document, select the desired section from the *Section* drop-down list.

*Figure 140: Linking sections*

To update links automatically or manually, see “Updating links” on page 167.

**Write-protecting sections**

To write-protect the section so that its contents cannot be edited, select *Protect* in the *Write protection* area (Figure 141).

**Note**

Write-protection protects only the section’s contents, not its attributes or format.

*Figure 141: Write-protecting sections*

**Password-protecting sections**

**Caution**

Be very careful to remember or safely store the password, because it cannot be retrieved without advanced tools.

To prevent others from editing the section’s attributes or format, additionally protect the section with a password:

1) Select *Protect* and *With password*.
2) On the Enter Password dialog, type a password in the Password field and again in the Confirm field.

3) Click OK.

Anyone who tries to edit the section's attributes or format will be prompted to enter the password.

**Hiding sections**

You can hide the section so that it will not be displayed on the screen or printed. You can also specify conditions for hiding the section. For example, you can hide the section only from certain users. Hiding is very useful for creating a single source document containing students’ and teachers’ copies of a document such as a test.

**Note**

You cannot hide a section if it is the only content on the page or if the section is in a header, footer, footnote, endnote, frame, or table cell.

To hide a section, select the Hide option in the Hide section of the dialog.

To hide the section only under certain conditions, enter the desired conditions in the With Condition field. The syntax and operators that you use to enter conditions are the same ones that you use to enter formulas. For syntax and a list of operators, see the Help and Chapter 17, Fields.

If the section is write-protected with a password, the password must be entered to hide or reveal the text.

**Formatting a section into columns**

You can give some parts of a page one column and other parts of the page two or more columns. For example, you might have a page-width headline over a three-column news story.

**Tip**

You cannot select text on a multi-column formatted page and change it to a single column using this method. Instead, you need to define a single-column page style and then select the text you want to be in a two-column section on that page.

Use the Columns tab of the Insert Section dialog (Figure 142) to format the section into columns.

*Figure 142: Choosing evenly distributed columns*

As you add text to the section, the text flows from one column to the next. You can distribute text across the columns in one of two ways, as shown in Figure 143.

**Evenly distribute contents to all columns**

When this option is selected, Writer adjusts the length of the columns to the amount of text, so that all the columns are approximately the same length. As you add or delete text, the columns readjust.
When this option is not selected, Writer fills the columns newspaper-style: one column at a time, beginning with the first column. The last column may be shorter than the others.

Figure 143: (Left) Evenly distributed columns; (Right) Newspaper-style columns

**Indenting the section from margins**

Use the Indents tab (Figure 144), to set indents from the right and left margins of the section. Enter the desired left-margin indent in the **Before section** box. Enter the desired right-margin indent in the **After section** box. The preview box on the right-hand side of the tab shows you how the section will look with the indents applied.

Figure 144: Indenting a section

**Changing the background of the section**

Use the Area tab to add color or an image to the background of the current section. This page is similar to the Area tabs for paragraphs, frames, tables, and other objects. For more information, refer to “Defining borders and backgrounds” on page 168 and the Draw Guide.

**Customizing footnotes and endnotes in a section**

Use the Footnotes/Endnotes page of the Insert Section dialog (Figure 145) to customize the current section's footnotes and endnotes.
Customizing footnotes

To number the section's footnotes separately from the other footnotes in the document, and format the numbering, follow these steps:

1) In the Footnotes section of the page, make sure that Collect at end of text is selected.

2) Select Restart numbering.

3) To start the section's footnotes at a number other than 1, enter the desired starting number in the Start at box.

4) Select the Custom format option. In the drop-down list, select a numbering format for the footnotes.

To add text to the selected numbering format, use the Before and After boxes. For example, if you want the footnote numbers to be preceded by the word Note and followed by a colon, fill the Before and After boxes as shown in Figure 145.

Customizing endnotes

To have the section's endnotes appear at the end of the section rather than at the end of the document, select the Collect at end of section option in the Endnotes area.

To number the current section's endnotes separately from the other endnotes in the document, and format the numbering, apply the procedures described above to the Endnotes settings.

Editing and deleting sections

To edit a section, choose Format > Sections on the Menu bar. In the Edit Sections dialog (Figure 146), select the section you want to edit by clicking its name in the Section list.

Editing section attributes

To rename the selected section, type over its name in the Section name box.

On the Edit Sections dialog, you can also edit the selected section's link, write-protect, and hide attributes. See “Linking sections” on page 163, “Write-protecting sections” on page 163, and “Hiding sections” on page 164.
To edit the format of the selected section, click the Options button. The Options dialog has four tabs: Columns, Indents, Background, and Footnotes/Endnotes. These tabs are the same as those in the Insert Section dialog described earlier; the Background tab on the Options dialog corresponds to the Area tab in the Insert Section dialog.

To reset a tab to the conditions in place when the dialog opened, click the Reset button. To save the Options settings, click OK. You are returned to the Edit Sections dialog.

Removing sections
To remove the selected section, click the Remove button. This does not delete the contents of the section; the contents become part of the main document. If the contents were linked, they are now embedded.

Updating links
Writer can update linked sections automatically, and you can also update links manually. A protected section must first be unprotected before it can be updated.

To set Writer to update links automatically, or to turn off automatic updating:


2) In the Update links when loading section of the dialog, select one of the options:
   - Always Writer will update links automatically, without a prompt, when opening a document that contains links.
   - On request Writer will display a prompt before updating links.
   - Never Writer will not update links when opening a document.

3) Click OK to save the settings.
To update a link manually:

1) Open the document that contains the link.
2) Choose Edit > External Links.
3) The list in the Edit Links dialog (Figure 147) displays the names of all the files that are linked to the current document. Select the file that corresponds to the link to be updated.
4) Click the Update button. The most recently saved contents of the linked file appear in the current document. To close the Edit Links dialog, click Close.

Removing links
To remove a link to a file and embed its contents, go to the Edit Links dialog, select the file that corresponds to the link you want to remove, and click the Break Link button. This action does not delete the text in the Section; it just breaks the link. If desired, the text must be removed manually.

Defining borders and backgrounds

Borders and backgrounds can be applied to many elements in Writer, including paragraphs, pages, frames, sections, page styles, paragraph styles, character styles, and frame styles. The dialog pages for borders and backgrounds are similar in each case. To illustrate their use, we will define a border and background for a frame.

Tip
Page backgrounds can fill the entire page (sheet of paper) or only the area within the margins; see the section on page styles in Chapter 9, Working with Styles. Page borders surround only the area within the margins, including the header or footer if any exist.

Tables, indexes, tables of contents, and bibliographies can also have borders and backgrounds, although the choices for background are limited to Color or Image.
**Adding a border**

To begin, select the frame, right-click, and choose **Properties** in the context menu. Select the **Borders** tab (Figure 148).

![Frame dialog: Borders page](image)

*Figure 148: Frame dialog: Borders page*

Borders have three components: where they go, what they look like, and how much space is left around them. Optionally they may also have a shadow property.

- **Line Arrangement** specifies where the borders go. Writer provides five default arrangements but you can click the line you want to customize in the User-defined area to get exactly what you want. Each line can be individually formatted.

- **Line** specifies what the border looks like: the style, width, and color. Each parameter has a number of attributes to choose from. The attributes selected will apply to those borders highlighted by a pair of black arrows in the **User-defined** thumbnail on the left side of the dialog.

- **Padding** specifies how much space to leave between the border and the contents of the element. Spaces can be specified to the left, right, top, and bottom. Select **Synchronize** to have the same spacing for all four sides.

- **Shadow Style** properties always apply to the whole element. A shadow has three components: where it is (Position), how far from the element it is cast (Distance), and what color it is.

**Adding a color to the background area**

To begin, select the frame, right-click, and choose **Properties** in the context menu. On the Frame dialog, select the **Area** tab (Figure 149), then choose **Color**. Select from the color grid or create a new color to use for this frame, and then click **OK** to apply it to the background.

**Tip**

For selected words or other characters (right-click, **Character > Character**), the “background” is called **highlighting**. The only choices are **Color** or **None**.
Adding an image to the background

To add an image to the background, choose the Area tab, then choose Image (Figure 150). Choose one of the supplied images from the list on the left, or add your own.
To use a supplied image, select it from the thumbnails on the left.

1) In the Options area, choose the placement for the image:
   – Style – custom position/size, tiled, or stretched.
   – Size – specify the width and height. Select Scale to stretch or shrink the image to fit
     the selected size.
   – Position – select where the image is to be displayed.

2) Click OK to apply the image to the background.

To add or import an image:

1) Click the Add/Import button. The Import dialog opens.

2) Find the file you want and then click Open. The selected image now appears in the list of
   thumbnails on the left and in the preview box on the right of the Area tab.

Adding a gradient, pattern, or hatch to the background

To add a gradient, pattern, or hatch to the background, choose the Area tab, then choose the
required background type. The dialog now displays the options for that type, with an example in
the preview pane to the right. Select the required design from the list or create a new design to
use for this frame. Click OK to apply it to the background. See the Draw Guide for more about
defining gradients, patterns, and hatching.

Deleting a color, gradient, image, or other background

To delete a background, select None near the top of the Area tab of the Frame dialog.

Adjusting the transparency of the background

Transparency is useful for creating watermarks (a logo or text in the background of a page,
typically showing the company name or a statement such as Draft) and making colors or images
more pale (for more contrast with the text). Use the Transparency tab (Figure 151) to define the
type of transparency. The choices are covered in detail in the Draw Guide.

![Figure 151: Transparency options](image)

Chapter 6, Formatting Pages: Advanced | 151
Using document themes

Document themes collect various format selections into a set that can be applied and changed with two clicks. Theme colors have been implemented in LibreOffice 7.6; font and format settings are planned for a later release. This topic introduces the use of theme colors.

LibreOffice supplies several sets of theme colors, and you can define other sets (see Chapter 20, Customizing Writer). Theme colors have names like Dark 1, Light 1, Accent 1, and so on. They can be used in styles or applied manually.

To set up a document to use themes, choose colors for fonts, backgrounds, or objects from a Theme color palette (Figure 152), not an ordinary color palette. The first row of the palette contains the theme colors, with other rows containing modifications.

![Figure 152: A palette of theme colors](image)

To change the set of theme colors, choose Format > Theme on the Menu bar and select a different theme in the Theme dialog (Figure 153). Colors defined as theme colors change in the document. You need not change any style and need not change any object individually. Figure 154 shows an example.

![Figure 153: Theme dialog](image)
Using page line-spacing for printing

Page line-spacing (also called Register-true) is particularly useful for printed documents that will have two pages set next to each other (for example, in a book or brochure), for multi-column layouts, and for documents intended for double-sided printing.

To use page line-spacing, you need to select options on the page styles and the paragraph styles or individual paragraphs to be included, because these options work together.

To enable a page style for page line-spacing

Each page style to be included in page line-spacing must be enabled separately. To do so:

1) Open the Page Style dialog for the selected page style, using one of these methods:
   – Right-click on any page using that style and select Page Style in the context menu.
   – On any page using that style, go to Format > Page Style on the Menu bar.
   – On the Sidebar, go to the Styles deck, select the Page Styles icon at the top, then right-click on the required page style and select Edit Style.

2) On the Page tab, in the Layout Settings section, select the Use page line-spacing option, specify the Reference Style, and click OK.

Note

The Reference Style sets an invisible vertical (typographical) grid, using the line distance specified in the style. All paragraphs that have Page line-spacing activated will use that line distance, aligning the bottom of a text line to the next grid line, regardless of font size or presence of graphics. Each line is thus the same height. Writer will align the base lines of text printed on adjacent columns, opposite pages, and both sides of a sheet of paper to this invisible grid.

All paragraphs with the selected Reference Style (or that inherit the Reference Style) will be activated automatically for Page line-spacing.
**To enable paragraph styles for page line-spacing**

1) On the Styles deck of the Sidebar, right-click the Paragraph Style to enable, and choose **Edit Style**.

2) In the Paragraph Style dialog, go to the **Indents & Spacing** tab.

3) Select **Activate page line-spacing** to enable the paragraph style for page line-spacing. Deselect the option to exempt the paragraph style from page line-spacing. The option has no effect if **Page line-spacing** is disabled in the page style.

**To enable paragraphs for page line-spacing**

1) Select all the paragraphs you want to enable, and then go to **Format > Paragraph** on the Menu bar.

2) In the Paragraph dialog, go to the **Indents & Spacing** tab.

3) Select **Activate page line-spacing** to enable the selected paragraphs for page line-spacing. Deselect the option to exempt the selected paragraphs from page line-spacing. The option has no effect if **Page line-spacing** is disabled in the page style.
Chapter 7,
Printing and Publishing
Introduction

This chapter describes features in LibreOffice Writer related to printing, publishing, and distribution of documents:

- Printing, including documents, envelopes, and labels
- Exporting to PDF, EPUB, and other formats
- Emailing documents
- Digital signing of documents
- Removing personal data before distributing documents
- Redaction
- Accessibility checking of a document before publication

Quick printing

If the Print Directly icon is visible on the Standard toolbar, you can click it to print the entire document using the current default print settings. If the icon is not visible, you can make it visible by right-clicking on the toolbar, pointing to Visible Buttons, and selecting Print Directly.

Specifying the default printer

To specify the default printer, choose File > Printer Settings on the Menu bar. The Printer Setup dialog (Figure 155) opens. To access other printing options, click the Options button on the Printer Setup dialog. The same default options are available through Tools > Options > LibreOffice Writer > Print, and more general print options through Tools > Options > LibreOffice > Print. See Chapter 20, Customizing Writer, for more information.

![Printer Setup dialog](image)

Figure 155: Printer Setup dialog

Controlling printing using the Print dialog

For more control over printing, use the Print dialog (File > Print, Ctrl+P (⌘+P for macOS), or the Print icon on the Standard toolbar). The appearance of the Print dialog is different on Windows and Linux than it is on macOS, so they are described separately in this chapter.

Print dialog on Windows and Linux

On Windows and Linux, the Print dialog (Figure 156) has two tabs, on which you can choose a range of options, as described in the following sections. The appearance of this dialog may vary slightly depending on the operating system in use.
Selecting general printing options

On the General tab of the Print dialog, you can choose:

- The printer, from the list of available printers.
- Which pages to print, the number of copies to print, and whether to collate multiple copies (Range and copies section).
- Paper size and print orientation (Page Layout section).
- How many pages to print on one sheet of paper and whether to draw a border around each page (Page Layout section).
- Whether to print a brochure (see page 182).
- Whether to print in reverse page order (useful on some printers to make the pages come out in page order).

Figure 156: The Print dialog on Windows and Linux
Selecting printer and print job options
In the Printer section of the General tab, click the Properties button to display the selected printer’s properties dialog where you can choose portrait or landscape orientation, which paper tray to use, and the paper size to print on.

Click Collation and Paper Sides at the bottom of the Range and Copies section of the General tab to choose whether to create separate print jobs for collated output, instead of one print job containing all the collated pages (not relevant if only one copy of a document is printed).

Selecting what to print
In addition to printing a full document, you can choose to print individual pages, a ranges of pages, or a selection from a document.

Individual page
1) In the Print dialog, in the Range and Copies section, select the Pages option. The text box shows the current page number.
2) Enter the page number of the page you want to print. The preview box on the left changes to show the selected page.

Range of pages
1) In the Print dialog, in the Range and Copies section, select the Pages option.
2) Enter the page numbers of the pages to print (for example, 1–4 or 1,3,7,11 or a combination).

Selection of text or graphics
1) In the document, select the material to print, then open the Print dialog.
2) In the Range and Copies section of the Print dialog, the Selection option is now active and selected and the preview box shows the selected material (Figure 157).

![Printing dialog](image)

Figure 157: Printing a selection of text in Windows and Linux
**Choices on the LibreOffice Writer tab**

On the *LibreOffice Writer* tab (Figure 158) you can choose to print a subset of contents (for example, images or hidden text), print text in black (even if a color is defined for the text), whether to print automatically inserted blank pages, and whether and where to print any comments that are in the document.

Some selections may not be available all the time. For example, if the document contains no comments, the *Comments* drop-down list is disabled.

![Figure 158: LibreOffice Writer tab of Print dialog](image)

**Print dialog on macOS**

The LibreOffice Print dialog in macOS has several pages, described in the following sections. These pages are listed in a drop-down menu below the upper part of the dialog (Figure 159). Its appearance and layout on macOS 13 (Ventura) vary a bit from macOS 12 (Monterey) and earlier. The examples here are from macOS 12.

![Figure 159: Pages of the Print dialog on macOS 12](image)
Selecting general printing options

In the upper part of the Print dialog on macOS (Figure 159), you can choose:

- The printer, from the list of available printers
- The number of copies to print
- Which pages to print: all, or a continuous range of pages; for a discontinuous range of pages, see the Pages section under LibreOffice Writer in the lower part of the dialog.

Choices on the LibreOffice Writer page

On the LibreOffice Writer page of the Print dialog on macOS (Figure 160), you can choose:

- What contents to print: page background, images and other graphic objects, hidden text, text placeholders, and form controls.
- Whether to print text in black, instead of any colors defined in the document.
- Whether to print automatically inserted blank pages, a selection of pages, or a selection of contents.
- Whether and where to print comments.
- Whether to print a brochure (see page 185).

Some selections may not be available all the time. For example, if the document contains no comments, the Comments drop-down list is disabled.

![Figure 160: The LibreOffice Writer page of the Print dialog on macOS 12](image)
Selecting what to print

In addition to printing a full document, you can choose to print individual pages, a range of pages, or a selection from a document.

Individual page
To print an individual page, you can use either of the top or bottom Pages sections of the Print dialog (Figure 157). In the top section, enter the required page number in both the From: and To: boxes. The preview box on the left changes to show the selected page.

Consecutive range of pages
To print a consecutive range of pages, you can use either of the Pages sections of the Print dialog (Figure 157). In the top section, enter the first and last page numbers in the From: and To: boxes. Or, use the method described below for a non-consecutive range of pages.

Non-consecutive range of pages
To print a non-consecutive range of pages (for example, 1, 3, 7, 11 or a combination like 1–4; 7, 11, 22), you need to use the bottom Pages section (in the LibreOffice Writer area). Select the Pages: option. The box below Selection becomes active. Type the required page numbers in this box.

Selection of text or graphics
To print a selection of text or graphics: in the document, select the material to print, then open the Print dialog. In the bottom Pages section of the Print dialog, the Selection option is now active and selected and the preview box shows the selected material (Figure 161).

Figure 161: Printing a selection of text on macOS 12
Printing multiple pages on a single sheet of paper

You can print multiple pages of a document on one sheet of paper. To do this:

- [Windows or Linux] On the Page Layout section of the General tab of the Print dialog (Figure 162), click Pages per Sheet and select from the Pages per sheet drop-down list the number of pages to print per sheet of paper.

- [macOS] Go to the Layout page (Figure 163) of the Print dialog and select from the Pages per Sheet drop-down list the number of pages to print per sheet of paper.

When printing more than two pages per sheet, you can choose the order in which they are printed across and down the paper. The preview panel on the left of the Print dialog changes to show how the printed document will look.

Printing a brochure

In Writer, you can print a document with two pages on each side of a sheet of paper, arranged so that when the printed pages are folded in half, the pages are in the correct order to form a booklet or brochure.

Tip

Plan your document so it will look good when printed half size; choose appropriate margins, font sizes, and so on. You may need to experiment.
The process for printing a brochure is the same for all operating systems, but the settings are found in different places.

![Figure 164: Settings for printing a brochure using Windows or Linux]

To print a brochure on a single-sided (simplex) printer:

1) [Windows and Linux] In the Page Layout section of the General tab of the Print dialog, select Brochure near the bottom (Figure 164).
   [macOS] On the LibreOffice page of the Print dialog, select Brochure near the bottom.
   The preview on the left changes to show the sequence in which the pages will be printed.

2) If Asian or CTL is selected in your language settings, the Print dialog will include a drop-down menu near the Brochure option (not shown in Figure 164). This list provides Left-to-right script and Right-to-left script options. Select the required setting.

3) [Windows and Linux] In the Range and Copies section of the General tab of the Print dialog, under Collation and Paper Sides—Include, select Even pages.
   [macOS] On the Paper Handling page of the Print dialog (Figure 165), in the Pages to Print drop-down list, select Even pages.

4) Click Print. Take the printed pages out of the printer and put them back into the printer in the correct orientation to print on the blank side. You may need to experiment to find the correct arrangement for your printer.
5) [Windows and Linux] In the *Range and Copies* section of the *General* tab of the Print dialog, under *Collation and Paper Sides*—Include, select **Odd pages**.

[macOS] On the *Paper Handling* page of the Print dialog (Figure 165), in the *Pages to Print* drop-down list, select **Odd pages**.

6) Click **Print**.

**Tip**

If your printer can print double-sided (duplex) automatically, choose **Odd and Even Pages** in step 3 and skip steps 4 and 5.

![Figure 165: Settings for printing a brochure using macOS](image)

**Printing in black and white on a color printer**

You may wish to print documents in black and white on a color printer. Several choices are available.

**Note**

Some color printers may print in color regardless of the settings you choose.

[Windows and Linux] For one document, change the printer settings to print in black and white or grayscale:

1) On the Print dialog, click **Properties** to open the Properties dialog for the printer. The available choices vary from one printer to another, but you should find options for the color settings. See your printer’s help or user manual for more information.

2) The choices for color might include black and white or grayscale. Choose grayscale.

3) Click **OK** to confirm your choice and return to the Print dialog.

4) Click **Print** to print the document.

[macOS] For one document, change the *Color* setting on the *LibreOffice Writer* page of the Print dialog (Figure 160):

1) In the *Color* section, select **Print text in black**.

2) Click **Print** to print the document.

[All] To print all color text and images as grayscale, change the LibreOffice settings:

1) Choose **Tools > Options > LibreOffice > Print** [macOS: **LibreOffice > Preferences > LibreOffice > Print**].

2) Select the **Convert colors to grayscale** option. Click **OK** to save the change.
To print all color text as black, and all images as grayscale, change the LibreOffice Writer settings:

1) Choose Tools > Options > LibreOffice Writer > Print [macOS: LibreOffice > Preferences > LibreOffice Writer > Print].

2) Under Contents, select the Print text in black option. Click OK to save the change.

**Previewing pages before printing**

The normal page view in Writer shows what each page will look like when printed; you can edit the pages in that view. If you are designing a document to be printed double-sided, you may want to see what facing pages look like. Writer provides two ways to do this:

- **View Layout** (editable view): use the Book View button on the status bar and (usually) zoom out.

  ![Figure 166: Book view icon on Status bar](image)

- **Print Preview** (read-only view).

To use Print Preview:

1) Choose File > Print Preview on the Menu bar, or click the Toggle Print Preview icon on the Standard toolbar, or press Ctrl+Shift+O. Writer now displays the Print Preview toolbar instead of the Formatting toolbar.

   ![Figure 167: Print Preview toolbar](image)

2) Select the required preview icon: Single Page Preview, Two Pages Preview, Book Preview, or Multiple Pages Preview.

3) To print the document from this view, click the Print icon to open the Print dialog. Choose the print options and click Print.

**Printing envelopes**

Printing envelopes involves two steps: setup and printing.

To set up an envelope to be printed by itself or with a document:

1) Click Insert > Envelope on the Menu bar.

2) In the Envelope dialog, start with the Envelope tab (Figure 168). Verify, add, or edit the information in the Addressee and Sender (the “from” on the envelope) boxes. The sender information is picked up from the User Data page in Tools > Options > LibreOffice (macOS: LibreOffice > Preferences > LibreOffice).

   You can type information directly into the Addressee and Sender boxes, or use the right-hand drop-down lists to select the database or table from which you can draw the envelope information. See Chapter 14, Mail Merge, for details on how to print envelopes from a database.
Figure 168: Choosing addressee and sender information for an envelope

3) On the *Format* tab (Figure 169), verify or edit the positioning of the addressee and the sender information. The preview area on the lower right illustrates your choices.

Figure 169: Choosing positioning and size of elements for an envelope
4) To format the text of these blocks, click the **Edit** button to the right. In the drop-down list you have two choices: **Character** and **Paragraph**.

   - Select **Character** to open a dialog similar to the standard Character dialog, where you can set the formatting of the text.
   - Select **Paragraph** to open a dialog similar to the standard Paragraph dialog, where you can set the paragraph’s attributes.

5) In the lower left of this tab is the **Size** section. Choose the envelope format in the drop-down list. The width and height of the selected envelope are shown in the boxes below the selected format. If you chose a pre-existing format, just verify these sizes. If you chose User Defined in the Format list, then you can edit the sizes.

6) After formatting, go to the **Printer** tab (Figure 170) to choose which printer to use, setup (for example, specification of the tray holding envelopes), and other printer options such as envelope orientation and shifting. You may need to experiment to see what options work best for your printer and how the envelopes need to be positioned in the printer.

![Figure 170: Choosing printer options for an envelope](image)

7) When you have finished formatting and are ready to print, click either **New Document** or **Insert** to finish. **New Document** makes only an envelope or starts a new document with the envelope. **Insert** puts the envelope into your existing document as page 1.

8) Save this file before you do anything else.

To print the envelope:

1) Choose **File > Print** on the Menu bar.

2) [Windows and Linux] On the Print dialog (Figure 156 on page 180), under **Range and Copies**, choose **Pages** and type **1** in the box. Choose the required printer (which may be different from the usual printer).

   [macOS] On the Print dialog (Figure 159 on page 182), in the upper section of the dialog, choose **Pages – From**: and type **1** in both boxes.

3) Click **Print**.
Printing labels

Labels are commonly used for printing address lists (where each label shows a different address), but they can also be used to make multiple copies of one label, for example return-address stickers, labels for CDs/DVDs, or other items.

Printing labels, like printing envelopes, has two steps: setup and printing. This topic is covered in detail in Chapter 14, Mail Merge.

Exporting to PDF

LibreOffice can export documents to PDF (Portable Document Format). This standard file format is ideal for sending the file to someone else to view using Adobe Reader or other PDF viewers.

**Warning**

A document in PDF format is not protected against contents tampering or editing by default. The PDF document contents can be edited by specialized software tools, including LibreOffice Draw.

**Tip**

Unlike Save As, the Export command writes a copy of the current document in a new file with the chosen format, but keeps the current document and format open in your session.

Quick export to PDF

Click the **Export Directly as PDF** icon on the Standard toolbar, or **File > Export As > Export Directly as PDF**, to export the entire document using the PDF settings you most recently selected in the PDF Options dialog. You are asked to enter the file name and location for the PDF, but you do not get a chance to choose a page range, the image compression, or other options.

Controlling PDF content and quality

For more control over the content and quality of the resulting PDF, use **File > Export as > Export as PDF**. The PDF Options dialog opens. This dialog has six tabs (**General**, **Initial View**, **User Interface**, **Links**, **Security**, and **Digital Signatures**). Select the appropriate settings, and then click **Export**. Then you are asked to enter the location and file name of the PDF to be created, and click **Save** (Windows and Linux) or **Export** (macOS) to export the file.

**Note**

You can also export to PDF with **File > Export**. On the Export dialog, select the PDF file format, the file name and location, and click **Save** or **Export**. The PDF Options dialog then opens. Select the appropriate settings and then click **Export**. The only difference between the two export methods is the sequence in which steps occur.

**General tab of PDF Options dialog**

On the **General** tab (Figure 173), you can choose which pages to include in the PDF, the type of compression to use for images (which affects the quality of images in the PDF), and other options.
Range section
- **All**: Exports the entire document to PDF.
- **Pages**: To export a range of pages, use the format 3-6 (pages 3 to 6). To export single pages, use the format 7;9;11 (pages 7, 9 and 11). You can also export a combination of page ranges and single pages, by using a format like 3-6;8;10;12.
- **Selection**: Exports whatever material is selected.
- **View PDF after export**: Your default PDF viewer will open and display the newly exported PDF.

Images section
- **Lossless compression**: Images are stored without any loss of quality. Tends to make large files when used with photographs. Recommended for other kinds of images or graphics.
- **JPEG compression**: Allows for varying degrees of quality. A setting of 90% works well with photographs (smaller file size, little perceptible loss of quality).
- **Reduce image resolution**: Lower DPI (dots per inch) images have lower quality. Lower resolutions (100 dpi or less) may be sufficient for viewing on a computer screen, but many modern devices have much higher resolutions; and for printing it is generally preferable to use at least 300 or 600 dpi, depending on the capability of the printer. Higher DPI settings increase the size of the exported file.

**Note**
EPS (Encapsulated PostScript) images with embedded previews are exported only as previews. EPS images without embedded previews are exported as empty placeholders.
Watermark section

- **Sign with Watermark**: When this option is selected, a transparent overlay of the text you enter into the watermark text box will appear on each page of the PDF.

General section

- **Hybrid PDF (embed ODF file)**: Use this setting to export the document as a PDF containing two file formats: PDF and ODF. In PDF viewers it behaves like a normal PDF file, and it remains fully editable in LibreOffice.

- **Archive (PDF/A, ISO 19005)**: PDF/A is an ISO standard for long-term preservation of documents, by embedding all the information necessary for faithful reproduction (such as fonts) while forbidding other elements (including forms, security, and encryption). PDF tags are written. **PDF/A-1b** refers to the minimum compliance level with PDF/A-1. **PDF/A-2b** is recommended for most users, because it allows layers and transparency with shapes and images. It also compresses better, usually producing smaller files. **PDF/A-3b** is identical to PDF/A-2b, but also accepts embedding of other file formats.

- **Universal Accessibility (PDF/UA)**: Creates a universal accessibility-compliant PDF file that follows the requirements of PDF/UA (ISO 14289) specifications. When this option is selected, clicking **Export** causes a Warning dialog to pop up if the document contains accessibility issues. See the Help and “Accessibility checking” on page 204.

- **Tagged PDF**: Tagged PDF contains information about the structure of the document’s contents. This can help to display the document on devices with different screens, and when using screen reader software. Some tags that are exported are table of contents, hyperlinks, and controls. This option can increase file sizes significantly.

- **Create PDF form – Submit format**: Choose the format of submitting forms from within the PDF file. This setting overrides the control’s URL property that you set in the document. There is only one common setting valid for the whole PDF document: PDF (sends the whole document), FDF (sends the control contents), HTML, and XML. Most often you will choose the PDF format.

- **Allow duplicate field names**: If enabled, the same field name can be used for multiple fields in the generated PDF file. You can enter data in the first occurrence of the named field in the PDF document and all fields with the same name will carry your entry. If disabled, field names will be exported using generated unique names.

Tip

Some Print-on-Demand and other commercial printing services require PDFs to contain no transparency. To meet this requirement, select **Archive PDF/A-1b** and deselect **Create PDF form**.

Structure section

- **Export outlines**: Exports headings as an outline (table of contents list) displayed by most PDF viewers, including Adobe Reader. In Writer 7.0 and earlier, these were called **bookmarks**.

- **Export placeholders**: The PDF will include any defined placeholder fields, which can be filled in by users.

- **Comments as PDF annotations**: Comments are included in the PDF as annotations.

- **Comments in margin**: Page contents are reduced in size, leaving space for comments to be printed in the margin of the pages. If the document contains no comments, this option has no effect.
• **Export automatically inserted blank pages**: If selected, automatically inserted blank
  pages are exported to the PDF. This is best if you are printing the PDF double-sided. For
  example, books usually have chapters set to always start on an odd-numbered (right-
  hand) page. When the previous chapter ends on an odd page, Writer inserts a blank
  page between the two odd pages. This option controls whether to export that blank page.

• **Use reference XObjects**: Reference XObjects enable one PDF file to import content
  from another. More information can be found in section 8.10.4 of the PDF specification,
  ISO 32000-2:2017 ([https://www.iso.org/standard/63534.html](https://www.iso.org/standard/63534.html)). If you are not familiar with
  referenceXObjects, leave this box unchecked.

**Initial View tab of PDF Options dialog**

On the **Initial View** tab (Figure 172), you can choose how the PDF opens by default in a PDF
viewer. The selections should be self-explanatory.

If you have Complex Text Layout enabled (in **Tools > Options > Language settings >
Languages**), an additional selection is available under the **Continuous facing option**: **First
page is left** (normally, the first page is on the right when using the Continuous facing option).

![Figure 172: Initial View tab of PDF Options dialog](image)

**User Interface tab of PDF Options dialog**

On the **User Interface** tab (Figure 173), you can choose more settings to control how a PDF
viewer displays the file. Some of these choices are particularly useful when you are creating a
PDF to be used as a presentation or a kiosk-type display.

**Window options section**

• **Resize window to initial page**. The PDF viewer window will resize to fit the first page of
  the PDF.

• **Center window on screen**. The PDF viewer window will be centered on the computer
  screen.

• **Open in full screen mode**. The PDF viewer will open full-screen.

• **Display document title**. The PDF viewer will display the document's title (as recorded in
  **File > Properties**) in the title bar.
User interface options section

- **Hide menubar.** The PDF viewer will hide the Menu bar.
- **Hide toolbar.** The PDF viewer will hide the toolbar.
- **Hide window controls.** The PDF viewer will hide other window controls.

**Transitions**

Not available in Writer.

**Collapse Outlines**

Select how many heading levels are displayed in the outline, if *Export Outlines* is selected on the *General* tab.

**Links tab of PDF Options dialog**

On the *Links* tab (Figure 174), you can choose how links in documents are exported to PDF.

- **Export bookmarks as named destinations**
  
  Bookmarks are exported as “named destinations” to which Web pages and PDF documents can link.

- **Convert document references to PDF targets**

  If you have defined links to other documents with OpenDocument extensions (such as .odt, .ods, and .odp), the file extensions are converted to .pdf in the exported PDF document.

- **Export URLs relative to file system**

  If you have defined relative links in a document, this option exports those links to the PDF.
Cross-document links
 Defines the behavior of links clicked in PDF files. Select one of the alternatives:

– *Default mode*: The PDF links will be handled as specified in your operating system.
– *Open with PDF reader application*: Use the same application used to display the PDF document to open linked PDF documents.
– *Open with Internet browser*: Use the default Internet browser to display linked PDF documents.

Security tab of PDF Options dialog
 PDF export includes options to encrypt the PDF (so it cannot be opened without a password) and apply some digital rights management (DRM) features.

• With an *open password* set, the PDF can only be opened with the password. Once opened, there are no restrictions on what the user can do with the document (for example, print, copy, or change it).
• With a *permissions password* set, the PDF can be opened by anyone, but its permissions can be restricted (Figure 175). After you set a password for permissions, the other choices on the Security page become available.
• With both the open password and permission password set, the PDF can only be opened with the correct password, and its permissions can be restricted.

![Figure 175: Security tab of PDF Options dialog with Permissions password set](image)

**Note**
 Permissions settings are effective only if the user’s PDF viewer respects the settings.

Digital Signatures tab of PDF Options dialog
 The *Digital Signatures* tab (Figure 176) contains the options for exporting a digitally signed PDF. Digital signatures are used to ensure that the PDF was really created by the original author (that is, you), and that the document has not been modified since it was signed.
The signed PDF export uses the keys and X.509 certificates already stored in your default key store location or on a smartcard. The key store to be used can be selected under Tools > Options > LibreOffice > Security > Certificate Path (Linux) or LibreOffice > Preferences > Security > Certificate Path (macOS). [On Windows, LibreOffice uses the default Windows location for storing and retrieving certificates.]

When using a smartcard, it must already be configured for use by your key store. This is usually done during installation of the smartcard software. Details about using these features is outside the scope of this chapter.

![Figure 176: Digital Signatures tab of PDF Options dialog](image)

- **Use this certificate to digitally sign PDF documents**: Click **Select** to open the Select Certificate dialog, where all certificates found in your selected key store are displayed. If the key store is protected by a password, you are prompted for it. When using a smartcard that is protected by a PIN, you are also prompted for that.
- Select the certificate to use for digitally signing the exported PDF, then click **Sign**.

All other fields on the Digital Signatures tab are accessible only after a certificate has been selected.

- **Certificate password**: Enter the password used for protecting the private key associated with the selected certificate. Usually this is the key store password. If the key store password has already been entered in the Select Certificate dialog, the key store may already be unlocked and not require the password again.
- When using a smartcard, enter the PIN here. Some smartcard software will prompt you for the PIN again before signing.
- **Location, Contact information, Reason**: Optionally enter additional information about the digital signature that will be applied to the PDF. This information will be embedded in the appropriate PDF fields and will be visible to anyone viewing the PDF. Any or all of the three fields may be left blank.
- **Time Stamp Authority**: Optionally select a Time Stamping Authority (TSA) URL. During the PDF signing process, the TSA will be used to obtain a digitally signed timestamp that is then embedded in the signature. Anyone viewing the PDF can use this timestamp to verify when the document was signed.
- The list of TSA URLs that can be selected is maintained under Tools > Options > LibreOffice > Security > TSAs. If no TSA URL is selected (the default), the signature will not be timestamped, but will use the current time from your local computer.
Exporting to EPUB format

EPUB format has become popular since mobile devices such as smartphones, tablets, and e-readers appeared on the market. The EPUB format is implemented as an archive file consisting of HTML files carrying the content, along with images and other supporting files.

Writer can export a file to EPUB. A text-only document generally exports well, but some contents (such as illustrations, tables, and cross-references) may not export correctly.

Quick export to EPUB

Choose File > Export As > Export Directly as EPUB to export the entire document using the EPUB settings you most recently selected on the EPUB Export dialog (Figure 177). Enter the file name and location for the EPUB file; you do not get a chance to select other options.

Controlling export to EPUB

For more control over the content and quality of the resulting EPUB file, use File > Export As > Export as EPUB. The EPUB Export dialog opens (Figure 177).

![Figure 177: EPUB Export dialog](image)

Version

Choose the EPUB version for the exported file. Values are EPUB 2.0 and EPUB 3.0. Most new e-readers can read EPUB 3.0.

Split method

Select the method to start a new section. Choose Heading to start the section on a heading, according to the document's heading numbering (outline levels). Choose Page break to start the section on a page break.
Layout method
Choose **Reflowable** to have the ebook display change to fit the screen size and the user’s preference (so page size and header/footer content is not exported). Choose **Fixed** to have the ebook layout remain the same under all conditions.

Customize - Cover image
The path to the image file for the cover page. If no image is specified, the EPUB file will automatically use any image with a name like cover.gif, cover.jpg, cover.png, or cover.svg. A custom cover image is embedded in the EPUB file.

Customize - Media directory
The path to the optional directory for the cover image, metadata, and multimedia files. If you do not specify a directory, the exporter looks for custom media and metadata in the current document directory inside a folder with the same name as the document file name.

Metadata
The basic information for the file that provides tags to help searches. These fields provide another chance to edit metadata that is picked up by default from **File > Properties** in Writer.

Tip
Other ways to export to EPUB from Writer (.odt) files include Calibre, an open-source e-book manager that runs on Windows, macOS, and Linux. Calibre provides many e-book conversion facilities and allows editing of the result. [https://calibre-ebook.com/](https://calibre-ebook.com/)

Exporting to other formats
LibreOffice uses the term “export” for some file operations involving a change of file type. If you cannot find what you want under **File > Save As**, look under **File > Export** as well. Writer can export files to XHTML, EPUB and other formats, as shown in Figure 178.

Choose **File > Export**. On the Export dialog, specify a file name for the exported document, then select the required file format and click **Export**.

Emailing Writer documents
LibreOffice provides several ways to quickly and easily send a Writer document as an email attachment in one of three formats: .odt (OpenDocument Text, Writer’s default format), .docx (Microsoft Word format), or .pdf.

To send the current document in .odt format, choose:

1) **File > Send > Email Document**, or **File > Send > Email as OpenDocument Text**. Writer opens your default email program (if installed). The document is attached to a new email.
2) In your email program, enter the recipient, subject, and any text you want to add, then send the email.

If you choose *Email as Microsoft Word*, Writer first creates a file in Word format (.docx) and then opens your email program with the Word file attached to a new email. Similarly, if you choose *Email as PDF*, Writer opens the PDF Options dialog where you can select the settings you want, then creates a PDF, and then opens your email program with the PDF attached to a new email.

**Emailing a document to several recipients**

To email a document to several recipients, you can use the features in your email program or you can use Writer’s mail merge facilities to extract email addresses from an address book.

You can use Writer’s mail merge to send email in two ways:

- Use the Mail Merge Wizard to create the document and send it.
- Create the document in Writer without using the Wizard, then use the Wizard to send it.

See Chapter 14, Mail Merge, for details.

**Digital signing of documents**

To sign a document digitally, you need a personal key, also known as a certificate. A personal key is stored on your computer as a combination of a private key, which must be kept secret, and a public key, which you add to your documents when you sign them. You can get a certificate from a certification authority, which may be a private company or a governmental institution.

When you apply a digital signature to a document, a checksum is computed from the document's content plus your personal key. The checksum and your public key are stored with the document.

When someone later opens the document on any computer with a recent version of LibreOffice, the program will compute the checksum again and compare it with the stored checksum. If both are the same, the program will signal that you see the original, unchanged document.

In addition, the program can show you the public key information from the certificate. You can compare the public key with the public key that is published on the web site of the certificate authority. Whenever someone changes something in the document, this change breaks the digital signature.

For a more detailed description of how to get and manage a certificate, and signature validation, see the LibreOffice Help.

A signed document shows an icon in the Status bar. You can double-click the icon to view the certificate. More than one signature can be added to a document.

Changing an existing description invalidates the signature. However, multiple signatures from the same author are allowed, because each signature can have a different description.

**Applying a digital signature**

The following procedure is an example of how to digitally sign a document. The actual procedure depends on how your computer is set up and its operating system.

1) **Choose File > Digital Signatures > Digital Signatures**.

   - If you have set LibreOffice to warn you when the document contains comments or recorded changes (see “Removing personal data” on page 202), you may see a message box asking whether you want to continue signing the document.
   - If you have not saved the document since the last change, a message box appears. Click **Yes** twice: once to continue and again to save the file.
2) The Digital Signatures dialog (Figure 179) opens. It lists existing signatures together with their description (if they have any). Click the **Sign Document** button to add a new signature to the document.

![Digital Signatures dialog](image)

*Figure 179: Digital signatures dialog*

3) In the Select Certificate dialog (Figure 180), select your certificate, add an optional description, and click **Sign** to return to the Digital Signatures dialog. The certificate used is displayed in the dialog with an icon next to its name. This icon indicates the status of the digital signature.

![Select Certificate dialog](image)

*Figure 180: Select Certificate dialog*
4) Click **Close** in the Digital Signatures dialog to apply the digital signature.

**Including a signature line**

You can generate a graphic box representing a signature line using **Insert > Signature Line** (see Figure 181), and you can optionally sign the signature line using a digital certificate.

![Signature Line](image)

*Figure 181: Creating a signature line for a document*

![Signature](image)

*Figure 182: Signature line example*

**Removing personal data**

You may wish to ensure that personal data, versions, comments, hidden information, or recorded changes are removed from files before you send them to other people or create PDFs from them.

In **Tools > Options > LibreOffice > Security**, (macOS: **LibreOffice > Preferences > LibreOffice > Security**) click the **Options** button to display a dialog (Figure 183) where you can set LibreOffice to warn you when files contain certain information and/or automatically remove personal information on saving.

To remove personal and some other data from a file, go to **File > Properties**. On the General tab, uncheck **Apply user data** and click the **Reset Properties** button. This removes any names in the created and modified fields, deletes the modification and printing dates, and resets the editing time to zero, the creation date to the current date and time, and the version number to 1.

To remove version information, either (a) go to **File > Versions**, select the versions from the list and click **Delete**, or (b) use **Save As** and save the file with a different name.
Redaction

You can redact documents to remove or hide sensitive information, to allow the selective disclosure of information in a document while keeping other parts of the document secret. For example, when a document is subpoenaed in a court case, information not specifically relevant to the case at hand is often redacted.

To redact a document:

1) Open the document in Writer.
2) Click Tools > Redact on the Menu bar, and wait for the document to be prepared for redaction and transferred to Draw. The Redaction toolbar (Figure 184) opens.

3) Do the redaction by using the Rectangle Redaction and Freeform Redaction tools on the Redaction toolbar. The shapes will be transparent and in gray so you can see what you are redacting.

4) Optionally use the Export Directly as PDF tool to make an in-redaction copy of the document in PDF to use as a verbatim copy for review. The redacted items will be in transparent gray.

5) To finalize the redaction, select the desired option (black or white) on the Redacted Export tool. The transparent grey shapes are converted to opaque black or white shapes and the document is exported as a pixellized PDF. There will be no selectable text in it, and the redacted content will be non-existent.

Auto-redaction

To partially automate the redaction process, you can define certain words (such as names) to be redacted wherever they are found in the document. To do this, choose Tools > Auto-Redact on the Menu bar to open the Automatic Redaction dialog (Figure 185). Here you can load a list of terms (targets), add targets, delete targets, edit targets, and save a list of targets.
Accessibility checking

LibreOffice includes several accessibility features, including support for external devices and applications including screen readers.

Before publishing a document, you can use Writer’s Accessibility Check tool to review common problems. To run the check manually, choose Tools > Accessibility Check on the Menu bar. When exporting to PDF, selecting Universal Accessibility (PDF/UA) on the General tab of the PDF Export dialog (Figure 171) and clicking Export pops up a Warning dialog (Figure 186).

The Accessibility Check dialog (Figure 187) is displayed by default in the Sidebar. It shows a list of all issues found in the document. The checks include:

- The document title is set.
- The document language is set, or that all styles in use have the language set.
- All images, graphics, OLE objects have alternative (or title, in some cases) text.
- Tables do not include split or merged cells.
- Manual numbering (not using integrated numbering). For example writing "1." "2." "3." at the beginning of the paragraphs.
- Contrast between text and the background.
- Footnotes and endnotes, which should be avoided.
- Heading order: headings must not skip a level (for example Heading 1 to Heading 3, skipping Heading 2).
Click the Fix button to jump to the page and select the object or issue that requires attention for accessibility.

Figure 187: Accessibility Check dialog

![Accessibility Check dialog](image)
Chapter 8,
Introduction to Styles
What are styles?

Most people are used to writing documents according to physical attributes. For example, you might specify the font family, font size, and weight (for example: Helvetica 12pt, bold). In contrast, styles are logical attributes. For example, you can define a set of font characteristics and call it Title or Heading 1. In other words, styles mean that you shift the emphasis from what the text looks like to what the text is.

Why use styles?

Styles help improve consistency in a document. They also make major formatting changes easy. For example, you might decide to change the indentation of all paragraphs or change the font of all titles. For a long document, this simple task could be prohibitive. Styles make the task easy. In addition, Writer uses styles for other purposes, such as compiling a table of contents; see “Using paragraph styles to define a hierarchy of headings” on page 228.

Style categories

LibreOffice Writer has six style categories:

- **Paragraph** styles affect entire paragraphs and are also used for purposes such as compiling a table of contents.
- **Character** styles affect a block of text inside a paragraph; they provide exceptions to paragraph styles.
- **Page** styles affect page formatting (page size, margin, and the like).
- **Frame** styles affect frames and images.
- **List** styles affect outlines, ordered (numbered) lists, and unordered (bulleted) lists.
- **Table** styles affect the appearance of tables of data.

Paragraphs are the building blocks of every document: headings are paragraphs; headers, footers, and items in numbered lists are also paragraphs. Paragraph styles are, therefore, the most frequently used styles and are the ones treated in most detail in this chapter.

**Note**

Manual formatting (also called direct formatting) overrides styles. You cannot get rid of manual formatting by applying a style to it.

To remove manual formatting, select the text and choose **Format > Clear Direct Formatting** on the Menu bar, or right-click and choose **Clear Direct Formatting** in the context menu, or press $\text{Ctrl}+\text{M}$.

The Styles deck in the Sidebar

Styles management is primarily available through the Styles deck in the Sidebar (Figure 188). Here you can apply styles, modify styles, and create new styles.

To begin, do any of the following:

- Click the **Styles** icon on the Sidebar.
- Choose **Styles > Manage Styles** on the Menu bar.
- Press $F11$ ($\text{⌘}+\text{T}$ on macOS).

The first six icons at the top of the Styles deck select the category of styles. Click one of these icons to display a list of styles in that category, such as paragraph or character styles.
Filtering the visible styles

At the bottom of the Styles deck, use the drop-down menu to select a filter for the list of styles. At the beginning of the writing process, you may want to have access to all the available styles (by selecting All Styles), and then hide some of them (Ctrl+click to select each style to be excluded and finally right-click one of these styles and select Hide in the context menu). As the document develops, it is quicker to reduce the list displayed to only the styles already in use (by selecting Applied Styles). If you work on a document where you want to apply custom styles only, select instead Custom Styles. The Hierarchical view is most useful when modifying styles as it reveals which styles are linked together. This topic is discussed in Chapter 9, Working with Styles.

In the Paragraph Styles view, the drop-down menu contains several more filtering options so you can view, for example, only Text Styles, Special Styles, and so on.

Applying styles

Styles can be applied easily using the Styles deck on the Sidebar. Some styles can also be applied using other methods, as explained in this topic.

Applying paragraph styles

Paragraph styles can be applied in several ways:

- Paragraph Styles tab of the Styles deck on the Sidebar
- Styles menu on the Menu Bar (limited to common styles)
- Context menu (limited)
• Set Paragraph Style drop-down list at the left end of the Formatting toolbar and the Formatting (Styles) toolbar
• Set Paragraph Style drop-down list at the top of the Properties deck of the Sidebar
• Formatting (Styles) toolbar (Figure 192); limited to common styles
• Fill Format Mode icon on the Styles deck on the Sidebar
• Keyboard shortcuts Ctrl+1 to Ctrl+5 (Heading 1 to Heading 5)

**Using the Styles deck on the Sidebar**
Put the cursor in the paragraph and double-click the name of the style in the Paragraph Styles tab of the Styles deck on the Sidebar. You can select more than one paragraph and apply the same style to all of them at the same time.

**Using the Styles menu**
The Styles menu on the Menu bar (Figure 189) provides the most commonly used paragraph, character, and list styles, plus quick links to create, edit, and manage styles. You can add styles to the Styles menu; see Chapter 20, Customizing Writer. To apply a paragraph style, put the cursor in the paragraph and click **Styles > [name of paragraph style]** on the Menu bar. The other choices on this menu are described later in this chapter.

![Figure 189: The Styles menu](image)
**Using the context (right-click) menu**
Right-click anywhere in a paragraph to open the context menu. Point to **Paragraph**. The submenu (Figure 190) includes some commonly used paragraph styles. You can add paragraph styles to this submenu; see Chapter 20, Customizing Writer.

![Figure 190: Context menu, Paragraph submenu](image1)

**Using the Set Paragraph Style list**
When a paragraph style is in use in a document, the style name appears on the **Set Paragraph Style** list near the left end of the Formatting toolbar (see Figure 191), the Formatting (Styles) toolbar, and the top of the Properties deck on the Sidebar.

![Figure 191: The Set Paragraph Style list on the Formatting toolbar](image2)

To apply a style from this list, put the cursor in the paragraph to change, and then click the arrow to drop down the list of styles and click the desired style; or drop down the list and use the up or down arrow keys to move through the list, then press **Enter** to apply the highlighted style.

**Tip**
If the Sidebar Styles deck is not open, you can select **More Styles** at the bottom of the list to open it.
Using the Formatting (Styles) toolbar

The Formatting (Styles) toolbar (Figure 192) includes common paragraph, character, and list styles. Use View > Toolbars > Formatting (Styles) on the Menu bar to display it.

To apply a paragraph style, put the cursor in the paragraph and click the relevant button on the toolbar. You can add styles to the this toolbar; see Chapter 20, Customizing Writer.

![Formatting (Styles) toolbar](image)

Figure 192: Formatting (Styles) toolbar

Using Fill Format Mode

You can use Fill Format Mode to apply a style to many areas quickly without having to go back to the Styles deck and double-click each time. This method is useful for formatting scattered paragraphs, words, or other items with the same style, and it may be easier to use than making multiple selections first and then applying a style to all of them.

1. Open the Styles deck on the Sidebar (Figure 188).
2. Select a style to copy, and then click the Fill Format Mode icon at the top right.
3. To apply a paragraph, page, or frame style, hover the mouse over the paragraph, page, or frame and click. To apply a character style, hold down the mouse button while selecting the characters. Clicking on a word applies the character style to that word.
4. Repeat step 3 until you have made all the changes for that style.
5. To quit Fill Format mode, click the icon again or press the Esc key.

Using keyboard shortcuts

Some keyboard shortcuts for applying styles are predefined. For example, Ctrl+0 applies the Text body style, Ctrl+1 applies the Heading 1 style, and Ctrl+2 applies the Heading 2 style. You can modify these shortcuts and create your own; see Chapter 20, Customizing Writer, for instructions.

Applying character styles

To apply a character style, select the characters or words and apply the character style from any of the following:

- Styles menu on the Menu bar (limited)
- Character Styles tab of the Styles deck on the Sidebar
- Right-click context menu (limited)
- Formatting (Styles) toolbar (Figure 192)

Tip

You may need to remove direct formatting before applying character styles. Select the text, then choose Format > Clear Direct Formatting on the Menu bar, or right-click and choose Clear Direct Formatting from the context menu, or press Ctrl+M.

Using the Styles menu

The Styles menu on the Menu bar (Figure 189) provides the most commonly used paragraph, character, and list styles, plus quick links to create and edit styles. To apply a character style, select the characters and click Styles > [name of character style]. You can add styles to the Styles menu; see Chapter 20, Customizing Writer.
**Using the Styles deck on the Sidebar**
Open the Styles deck and click the Character Styles icon at the top. The list of available character styles is displayed. To apply a character style:

1) Select the text, or put the cursor into a single word, where you wish to apply the style.
2) Double-click the appropriate character style on the Styles deck.

**Note**
To apply a character style to more than a single word, you need to select all of the text to be changed. To apply the style to a single word, you only have to place the cursor in the word. In contrast, paragraph styles are applied to the whole of the paragraph in which the cursor is placed.

**Using the context (right-click) menu**
Select the block of text, or put the cursor into the single word, then right-click to open the context menu. Choose **Character**. The submenu (Figure 193) includes some commonly used character styles. You can add character styles to this submenu; see Chapter 20, Customizing Writer.

![Figure 193: Context menu, Character submenu](image)

**Using the Formatting (Styles) toolbar**
The Formatting (Styles) toolbar (Figure 192) includes common paragraph, character, and list styles. If it not visible, use **View > Toolbars > Formatting (Styles)** on the Menu bar to display it.

To apply a character style, select the text or put the cursor in a word and click the relevant icon on the toolbar. You can add styles to the this toolbar; see Chapter 20, Customizing Writer.

**Removing or replacing character styles**
To remove the character style formatting from some text, or change the character style to a different style, do this:

1) Select the text.
2) In the Styles deck on the Sidebar, click the **Character Styles** icon in the top bar.
3) Double-click the required character style, or double-click **No Character Style** to remove the character style.
Applying frame styles

When you insert an object (such as a graphic) into a document, it will automatically have an invisible frame around it. Some designers like to add frame styles to introduce variety. For example, you could have one frame style for photographs and a different frame style for other graphics such as line drawings. The one for photographs might have a border with a drop shadow, while the one for drawings might have only a border.

To apply a style to a frame:

1) Select the frame.
2) In the Styles deck on the Sidebar, click the Frame Styles icon in the top bar.
3) Double-click the required frame style.

Having applied a style to a frame, you can now modify the frame to be just how you want it. Most of a frame’s design can be set in a style, but the following options must be set manually:

- **Anchoring**: how the frame is positioned in relation to the rest of the page’s contents (Format > Anchor). See Chapter 11, Images and Graphics, for details on anchoring images, frames, and other objects.
- **Arrangement**: the frame’s position in a stack of objects (Format > Arrange). See Chapter 11, Images and Graphics, for details on arranging images, frames, and other objects.
- **Adding a hyperlink**: so that a click on the frame opens a web page or another document (Insert > Hyperlink).

When a frame is selected, the Frame toolbar replaces the Formatting toolbar, and the context menu has items for anchoring, arrangement, wrap, and alignment.

Applying page styles

Put the cursor anywhere on the page. The applied page style is shown on the Status bar.

Figure 194: The current page style is displayed on the Status bar

To apply a different page style:

- Right-click on the style on the status bar and select a style from the context menu, or
- Open the Styles deck on the Sidebar, select the Page Styles icon at the top (fourth icon), and then double-click the desired page style.

Caution

Changing a page style may also cause the style of subsequent pages to change. The results may not be what you want. To change the style of only one page, you may need to insert a manual page break, as described below.

As discussed in Chapter 9, Working with Styles, a correctly set up page style will, in most cases, contain information on what the page style of the next page should be. For example, when you apply a Left Page style to a page, you can indicate in the page style settings that the next page must have a Right Page style; a First Page style could be followed by either a Left Page style or a Default Page Style; or any sequence you prefer.

Another way to change the page style is to insert a manual page break and specify the style of the subsequent page. The idea is simple: you break a sequence of page styles and start a new sequence. To insert a page break, choose Insert > More Breaks > Manual Break. This section illustrates two common scenarios where page breaks are useful.
**Example: Chapters**

A possible scenario: You are writing a book that is divided into chapters. Each chapter starts with a page style called *First Page*. The following pages use the *Default Page Style*. At the end of each (except the last) chapter, we return to the *First Page* style for the next chapter.

Figure 195 illustrates the flow of page styles when using page breaks.

![Figure 195: Dividing a document into chapters using page styles](image)

At some point, you will want to start a new chapter. Follow these steps:

1. Put the cursor at the end of the chapter, on a blank line (empty paragraph) of its own.
2. Choose *Insert > More Breaks > Manual Break*. The Insert Break dialog (Figure 196) opens.
3. Under *Type*, choose *Page break* and under *Page Style*, select *First Page*.

![Figure 196: Choose Page break and select the First Page style](image)

**Tip**

You can automate these breaks by defining the paragraph style of the chapter’s title (usually Heading 1) to include a page break.

**Example: Page with special formatting**

Use page breaks to insert a page with special formatting, for example a landscape page or a page with more columns. Suppose that the current page has the *Default Page Style*.


---

*Chapter 8, Introduction to Styles | 191*
2) Select the desired page style (say, *Special Page*) in the Insert Break dialog.

3) Type something on this page. Then insert another page break, selecting *Default Page Style* again.

This concept is illustrated in Figure 197.

![Figure 197: Inserting a page with special formatting](image)

**Example: A book chapter sequence of pages**

Book chapters typically start on a right-hand page, with the first page of the chapter having a different layout from the rest of the pages. The other pages in the chapter are “mirrored” for double-sided printing. For example, page numbers in the header or footer may be positioned on the outside edge of pages and a wider margin (allowing for binding) provided on the inside edge.

Table 6 shows the properties of two page styles (First Page and Default Page Style) set up for a typical book chapter’s sequence of pages.

**Table 6: Properties of customized page styles for a book chapter**

<table>
<thead>
<tr>
<th>Page Style</th>
<th>Desired effect</th>
<th>Property: setting</th>
</tr>
</thead>
<tbody>
<tr>
<td>First Page</td>
<td>First page always on the right (an odd-numbered page)</td>
<td>Page &gt; Page layout &gt; Only right</td>
</tr>
<tr>
<td></td>
<td>No header or footer</td>
<td>Header &gt; Header on: Not selected</td>
</tr>
<tr>
<td></td>
<td>Top margin of page larger than on other pages</td>
<td>Page &gt; Margins &gt; Top: 6.00cm</td>
</tr>
<tr>
<td>Default Page</td>
<td>Mirrored margins</td>
<td>Page &gt; Page layout: Mirrored</td>
</tr>
<tr>
<td>Style</td>
<td>Header with page number on the top outside edge of each page</td>
<td>Header &gt; Header on: Selected</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Header &gt; Header &gt; Same content left/right: Not selected</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Header &gt; Header &gt; Same content</td>
</tr>
<tr>
<td></td>
<td></td>
<td>First page: Selected</td>
</tr>
</tbody>
</table>

Figure 198 illustrates the transitions from the First Page to Default Page Style, with the change of header between left and right pages shown by the # symbol.

![Figure 198: First Page and then the Default Page Style with different headers for alternate pages](image)

**Step 1.** Set up the First Page style.

1) On the Styles deck, click the Page Styles icon to display a list of page styles.

2) Right-click *First Page* and select **Edit Style** in the context menu.
3) On the Organizer tab of the Page Style: First Page dialog, change Next Style to Default Page Style.

![Page Style: First Page dialog](image1.png)

*Figure 199: Specifying the next style after the first page of a chapter*

4) On the Page tab, specify either a gutter margin or a larger left margin for binding, and a larger top margin to move the chapter title down the page. See Chapter 9, Working with Styles, for more information about using gutter margins. This example does not use one.

![Page settings](image2.png)

*Figure 200: Setting page margins and layout for the First Page style*

5) On the Header and Footer tabs, be sure the Header on and Footer on options are not selected. Click OK to save your changes.

**Step 2.** Set up the Default Page Style.

1) On the Styles deck, in the list of page styles, right-click Default Page Style and select Edit Style in the context menu.

2) On the Organizer tab of the Page Style: Default Page Style dialog, be sure Next Style is set to Default Page Style.

3) On the Page tab of the Page Style: Default Page Style dialog, select Mirrored for Page layout and set the Inner and Outer margins to the same width as the Left and Right margins, respectively, on the First Page style. If a gutter margin has been set for the First Page style, use the same width for the gutter margin on the Default Page Style.
4) On the Header tab of the Page Style: Default Page Style dialog (Figure 202), select Header on and Same content on first page. Deselect Same content on left and right pages. Click OK to save your changes.

Figure 202: Setting up the header properties for the Default Page Style

Step 5. Set up the page numbers in the page headers.

1) Insert two page breaks in the document. You should now have one page with the First Page style, followed by two page of Default Page Style.

2) On the first (left hand) page with Default Page Style, place the cursor in the header and insert a page number field (**Insert > Page Number**). Keep the paragraph alignment set to left aligned.

3) On the next (right hand) page with Default Page Style, place the cursor in the header and insert a page number field. Change the paragraph alignment to right aligned.
4) Delete the blank pages that have been used to configure the headers. The settings remain in the file.

**Step 4.** Set up the Heading 1 paragraph style to begin chapters with the First Page style.

1) On the Styles deck, on the Paragraph Styles tab, right-click *Heading 1* and select *Edit Style*.

2) On the *Text Flow* tab of the Paragraph Style dialog, in the *Breaks* section, select *Insert, With Page Style*, and *First Page*. Click *OK* to save your changes.

![Paragraph Style: Heading 1](image)

*Figure 203: Setting a paragraph style to start on a page of a selected style*

Now when you apply the Heading 1 paragraph style to the paragraph that will be the title of the chapter, it will automatically start on a new page with the First Page style.

---

**Note**

By default, the Heading 1 paragraph style is assigned to Heading (Outline) Level 1. The assignment of paragraph styles to outline levels is done through **Tools > Heading Numbering**.

---

**Applying list styles**

List styles define properties such as indentation, numbering style (for example, 1,2,3; a,b,c; or bullets), and punctuation after the number, but they do not by themselves define properties such as font, borders, text flow, and so on. The latter are properties of paragraph styles.

Although you can apply list styles using the Styles menu or the Styles deck in the Sidebar, those methods are not recommended.

Whenever possible, use paragraph styles for creating bulleted and numbered lists. Writer comes with two sets of paragraph styles for this purpose. It is recommended to use list styles and paragraph styles together in these ways:

- Use paragraph styles List 1, List 2, List 3, and so on for creating unordered (bulleted) lists. These styles use Bullet list styles.
- Use paragraph styles Numbering 1, Numbering 2, Numbering 3, etc, for creating ordered (numbered) lists. These styles use the list styles called Numbering 1, Numbering 2, etc.

Writer has several predefined list styles, which use different bullet symbols or number sequences (123, abc, ABC, and so on). As with any style, you can redefine the properties of these styles, for example the numbering or bullet symbol and the indentation. You can also define other list styles in these series or create your own series. For more information, see Chapter 9, Working with Styles. Much more information about list styles is in Chapter 12, Lists.
Applying table styles

Table styles define properties such as the font, paragraph spacing, number of columns, borders, and background color.

To apply a table style, position the cursor anywhere in the table, go to the Styles deck on the Sidebar, choose Table Styles, then double-click the name of a style on the list.

See Chapter 13, Tables, for information on creating a table style.

Creating and modifying styles

Writer provides many predefined styles, which are useful when sharing a document to another machine, especially one with a different language version of LibreOffice, but you may find that they do not fit your preferences. You can modify the predefined styles or build your own library of custom styles to use in addition to or in place of the predefined ones.

Note

New styles you create or changes you make to an existing style are available only within the document they belong to. Styles always stay with a document.

If you want to reuse modified or new styles in other documents, either save the styles in a template (see Chapter 10, Working with Templates) or copy the styles into the other documents, as described in “Load Styles (from a template or document)” on page 223.

Writer provides these methods to modify both predefined and custom (user-created) styles:

- Create or update a style from a selection
- Load or copy styles from another document or template
- Change a style using the Style dialog
- Use AutoUpdate (paragraph and frame styles only)
- Use AutoFormat (table styles only); see Chapter 13, Tables

Using the Styles actions menu

The last icon at the top of the Styles deck, Styles actions, provides three functions: New Style from Selection, Update Selected Style, and Load Styles from Template. These functions are also available from the Styles menu on the Menu bar.

New Style from Selection

Use New Style from Selection to create a new style from the formatting of an item in the current document. For example, you can change the formatting of a paragraph until it appears as you like, and then you can turn that formatting into a new style. This procedure can save time because you do not have to remember all the formatting settings you want, as is necessary when creating a new style with the Style dialog. In addition, you can immediately see how the item will look when formatted with the style you are creating.

Follow these steps to create a new style from a selection:

1) In the document, change the formatting of the object (paragraph, frame, and so on) to your liking. Select the item you want to save as a style.

2) Open the Styles deck in the Sidebar and choose the category of style to create (paragraph, character, and so on) from the tabs at the top.

3) Click the Styles actions icon, then select New Style from Selection (Figure 204).
4) The New Style from Selection dialog shows the names of any existing custom styles of the selected type. Type a name for the new style and click OK to save it.

**Update Selected Style**

Follow these steps to update a paragraph style from a selection:

1) Create a new paragraph (or select an existing paragraph) and edit all the properties you want to alter in the style, such as indentation, font properties, alignment, and others.

2) Click anywhere in the paragraph.

3) On the Styles deck of the Sidebar, select the style you want to update (single-click, not double-click) and then click the **Styles actions** icon and select **Update Selected Style**.

The procedure to update another category of style (character, page, or frame styles) is the same: select the item in question, modify it, select the style you want to update, and choose **Update Selected Style** from the **Styles actions** icon.

**Load Styles (from a template or document)**

The last option under the **Styles actions** icon is **Load Styles from Template**, which is used to copy styles into the current document by loading them from a template or another document. Using this method, you can copy all styles, or groups of styles, at one time.

1) Open the document to copy styles into.

2) On the Styles deck, click the **Styles actions** icon and then **Load Styles from Template** (Figure 204).

3) On the Load Styles from Template dialog (Figure 205), find and select the template to copy styles from.

4) Select the options for the types of styles to be copied: Paragraph and Character, Frame, Page, or List. If you select **Overwrite**, the styles being copied will replace any styles of the same names in the target document.

5) Click OK to copy the styles.
If the required styles are contained in a text document rather than a template:

1) Select the type of styles to be copied.
2) Click the **From File** button to open a file browser. Select the required document.
3) Click **Open** to copy the styles to the open document.

**Drag-and-drop a selection to create a style**

Another way to create a new style is to drag-and-drop a text selection into the Styles deck.

1) Open the Styles deck on the Sidebar.
2) Select the style category you are going to create (for example a character style) using one of the icons near the top of the deck.
3) Select the object on which you want to base the style and drag it to the Styles deck. The cursor changes to indicate whether the operation is possible.
4) In the Create Style dialog, type a name for the new style and click **OK** to save the style.

**Note**

You cannot use the drag-and-drop method to create a new page style or table style.

**Changing a style using the Style dialog**

To change a style (but not a table style) using the Style dialog, right-click the style in the Styles deck and select **Edit Style** in the context menu.

The dialog displayed depends on the type of style selected. Each style’s dialog has several tabs. The properties on these dialogs are described in Chapter 9, Working with Styles.

See Chapter 13, Tables, for information on changing a table style.

**Using AutoUpdate**

On the Organizer tab of the Paragraph Style and Frame Style dialogs is an **AutoUpdate** option (marked in Figure 206). If this option is selected, then LibreOffice will apply to the style any modification made manually to a paragraph formatted with that style.
Caution

If you are in the habit of manually overriding styles in your document, be sure that AutoUpdate is not enabled, or you may suddenly find whole sections of your document reformatting unexpectedly.

Figure 206: AutoUpdate option on the Organizer page of the Paragraph Style dialog

Deleting styles

It is not possible to delete LibreOffice’s predefined styles from a document or template, even if they are not in use. However, custom styles can be deleted.

To delete any unwanted styles using the Styles deck of the Sidebar, select each one to be deleted (hold Ctrl while selecting multiple styles), and then right-click and select Delete in the context menu. If the style is in use, a message appears warning you that the style is in use and asking you to verify that you really want to delete the style.

If the style is not in use, it is deleted immediately without confirmation.

Note

If you delete a style that is in use, all objects with that style will return to the style it was based on (inherited from) but may retain some of the deleted style’s formatting as manual formatting.

Tip

If an unwanted paragraph style is in use, you can use Find and Replace to replace it with a substitute style before deleting it. See Chapter 3, Working with Text: Advanced, for more information.

Example: creating and modifying paragraph styles

This section provides an example of a typical use of custom paragraph styles. We will create a Poem paragraph style and a Poem Header paragraph style, with the following properties:

- Poem: Centered, with a font size of 10pt.
- Poem Heading: Centered, bold, with a 12pt font size.

In addition, a Poem Heading style is to be followed by a Poem style. In other words, when you press Enter at the end of a paragraph in the Poem Heading paragraph style, the paragraph style for the next paragraph in the document changes to Poem.
Note

You may have noticed this behavior already. After you enter a heading using a Heading paragraph style and press Enter, the next style switches to Text body.

Creating the Poem paragraph style

We will use the Default Paragraph Style as a starting point.

1) On the Styles deck, click the Paragraph Styles icon.
2) Right-click Default Paragraph Style and choose New.

On the Paragraph Style dialog, select the Organizer tab. To create a custom style, you need to configure the top three entries.

<table>
<thead>
<tr>
<th>Style fields</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>The name of the style itself, like Heading 1 or Text body. Type the name Poem.</td>
</tr>
<tr>
<td>Next Style</td>
<td>The style of the paragraph that follows the paragraph that is in the Poem style. When you press Enter while typing text in the Poem style, this style is automatically applied to the new paragraph. Set this value to Poem.</td>
</tr>
<tr>
<td>Inherit from</td>
<td>If the properties of the Poem style are inherited from another style, say Default Paragraph Style, then any change in Default will affect Poem. For our example, this is not the behavior we want. Set this entry to – None –. This means that Poem is not inherited from any other style.</td>
</tr>
</tbody>
</table>

Do not select AutoUpdate. After making these changes, the dialog should look like Figure 207.

![Figure 207: Initial configuration for the Poem style. Set the first three entries as shown.](image)

The next step is to configure the alignment and font properties of this style.

- On the Alignment page, select the Center option.
- On the Font page, select the 12pt font size.

Click OK to save the new Poem style.
Creating the Poem Heading style

To create a new Poem Heading style, use the same procedure as above, with these changes:

- **Next Style**: Select Poem, not Poem Heading. When you press Enter while typing text in the Poem Heading style, the Poem style is automatically applied to the new paragraph.
- **Inherit from**: Heading.

The dialog should look like Figure 208.

![Figure 208: Settings for the Poem Heading style](image)

Now choose the settings of the new style:

1) On the **Alignment** page, select **Center**.
2) On the **Font** page, choose a font and select typeface **Bold** and size **14pt**.
3) Click **OK** to save the new Poem Heading style.

Sample poem

It is a good idea to test out your new styles and see if you are happy with them. Typing a poem using the styles we have just defined should produce the results in Figure 209.

![Figure 209: Sample poem](image)

Changing the formatting of styles

One of the main advantages of styles is that they allow the document formatting to be changed after the content has been written. For example, suppose you have written a 100-page book of poetry and used the style settings described above. Then you (or your publisher) decide you do not like the way the poems look; you prefer them to be left-aligned, not centered.
To change the alignment of the *Poem* and *Poem Heading* styles:

1) In the Styles deck, right-click *Poem* and select *Edit Style*.
2) On the *Alignment* page of the Paragraph Style dialog, select *Left*.
3) Click OK, and you should see the text change.
4) Repeat these changes for the *Poem Heading* style.

The poem should now look similar to Figure 210.

![The Old Salt]

“The Old Salt”

I was walking through the dockyard in a panic,
When I met a matelot old and grey.
Upon his back he had his bag and hammock,
And this is what I heard him say.
I wonder, yes I wonder,
Has the Jaunty made a blunder,
When he served this draft chit out for me.
For years I’ve been a stanchion,
I’m the pride of Jago’s mansion,
It’s a shame to send me off to sea.

*Figure 210: Result after changes to the styles*

## Using paragraph styles to define a hierarchy of headings

Paragraph styles are the key to Writer’s table of contents feature. **Tools > Heading Numbering** defines the hierarchy of headings in a document. The default paragraph styles assigned to heading levels are the heading styles supplied with Writer: *Heading 1*, *Heading 2*, and so on. However, you can substitute any styles you wish, including custom (user-defined) styles.

The headings defined using the heading numbering feature can be used for more than the table of contents (described in Chapter 15, Tables of Contents, Indexes, Bibliographies). For example, fields are commonly used to display section headings in headers and footers of pages (see Chapter 17, Fields).

### Choosing paragraph styles for heading levels

If you are using the default heading styles for the headings in your outline, and you do not want to use heading numbering, you do not need to do anything on the Chapter Numbering dialog. The default outline numbering scheme uses the default heading styles.

To use custom styles in place of one or more of the default heading styles:

1) Choose **Tools > Heading Numbering** to open the Heading Numbering dialog (Figure 211).
2) On the Numbering tab, click the number in the *Level* box corresponding to the heading for which you want to change the paragraph style.
3) In the *Numbering: Paragraph Style* section, choose in the drop-down list the paragraph style you want to assign to that heading level. In this example, you might choose *My Heading 1* to replace *Heading 1* and for Level 2, *My Heading 2* to replace *Heading 2*.
4) Repeat for each numbering level that you want to change. Click OK when done.
Assigning outline levels to other styles

In Writer, you can assign an outline level to any paragraph style. This feature enables you to create a table of contents that includes those headings along with the headings using styles listed in the Heading Numbering dialog. For example, you might use a different sequence of styles for appendixes, but you want the appendix headings and subheadings to appear in the table of contents at the same levels as the chapter headings and subheadings.

To assign an outline level to a paragraph style, go to the Outline & List tab for the style, and select the required outline level from the drop-down list. Click OK to save this change.
Setting up heading numbering

If you want one or more heading levels to be numbered, many choices are available; this example defines a scheme to create headings that look like those in the illustration below.

1. This is a Heading 1
   1.1 This is a Heading 2
   1.1.1 This is a Heading 3
   1.1.2 Another Heading 3

2. Another Heading 1
   2.1 Another Heading 2
   2.1.1 Another Heading 3

3. Another Heading 1

*Figure 213: The numbering scheme to be set up*

Use the *Numbering* tab of the Heading Numbering dialog to define the numbering scheme and its appearance. Figure 214 shows the default settings.

1. In the *Level* list, choose 1. In the *Number* list, choose 1, 2, 3, ....
2. In the *Level* list, choose 2. In the *Number* list, choose 1, 2, 3, .... The *Show sublevels* field is now active; it should show 2 (if not, choose 2).
3. In the *Level* list, choose 3. In the *Number* list, choose 1, 2, 3, .... The *Show sublevels* field should show 3 (if not, choose 3).
Chapter 9,
Working with Styles
Introduction

Chapter 8, Introduction to Styles, describes the basics of how to use, apply, and manage styles. This chapter gives a more detailed description of how to create or modify some styles, using the many options available on the various tabs of the Style dialog. It explains how these options affect the appearance of the style and how to use them efficiently.

The Style dialogs share many of the same tabs as the manual formatting dialogs, so this chapter can also help you apply manual formatting (though you do not need that if you use styles).

Creating custom (new) styles

In addition to using the predefined styles provided by LibreOffice, you can add new custom (user-defined) styles. In Chapter 8, three methods are given for creating a new style: drag-and-drop, the New Style from Selection icon on the Styles deck, and the Style dialog.

The first two of these methods are convenient because you can check the visual effects that the style produces before creating it. However, for full control over the style (and its relationship to other styles), you need to use the Style dialog, as described in this chapter.

Note

Table styles are created in a different way; see Chapter 13, Tables.

Style dialog

Open the Styles deck on the Sidebar. Select the category of style you want to create by clicking on the appropriate icon on the top part of the Styles deck.

Right-click in the window and select New in the context menu. The dialog that is displayed depends on the type of style you selected.

Tip

The dialogs used to create a new style and to modify an existing style are mostly the same, but with one exception: conditional styles have a different dialog. See “Using conditional paragraph styles” on page 248.

Organizer tab

The Organizer tab, shown in Figure 215, is common to all style categories (except Table styles), with only small differences between them. Therefore, it is described only once.

Depending on the style you are creating, you will find the following fields on this tab:

- **Name**: present on all the categories. Use this field to name the style you are creating.
- **AutoUpdate**: only present for paragraph and frame styles. If this option is selected, then Writer will apply any manual modification to a paragraph or frame formatted with that style to the style itself.

Caution

If you are in the habit of manually overriding styles in your document, be sure that AutoUpdate is not enabled, or you may suddenly find whole sections of your document reformatted unexpectedly.
Figure 215: The Organizer tab displayed when a new Paragraph style is created

- **Next Style**: only available for paragraph and page styles. Use it to specify which style will be applied to the next element of the same type. For example, a left page style is usually followed by a right page style, a first page style followed by a left page style, a heading followed by a text body, and so on.

- **Inherit from**: available for paragraph, character, and frame styles; it determines the position of the style in the hierarchy. All the starting properties of the new style are inherited (copied) from the style specified here; see below for more information.

- **Category**: available for all styles; use it to associate the new style with one of the categories. You cannot change the category of the predefined styles. Setting this field is useful when filtering the contents of the Styles deck.

- **Contains**: shows a summary of the properties of the style.

**Style inheritance**

When creating a new paragraph style or a new character style, you can use an existing style as a starting point for its settings. In this sense, LibreOffice links the styles together.

When style settings are inherited, a change in the parent style affects every style inherited from it. To see the connections between styles, switch to the Hierarchical view on the Styles deck filter. For example, every Heading style (such as Heading 1, Heading 2) is inherited from a style called Heading. This relationship is illustrated in Figure 216.

Inheritance is a method to create “families” of styles in which you can change their properties simultaneously. For example, if you decide that all the headings should be green (such as in this guide), you only need to change the font color of the parent style to achieve the desired result. However, changes made to a parameter of the parent style do not override changes previously made to the same parameter in the child styles. For example, if you change the Heading 2 font color to green, a change of the font color of the Heading style (the parent style) to red will not affect the Heading 2 font color.

You can easily check which properties are specific to a style by looking at the **Contains** section of the Organizer tab. If you want to reset the properties of a child style to that of the parent style, click the **Reset to Parent** button located at the bottom of each Paragraph and Character style dialog.
**Example: Changing a property of a parent style**

Suppose that you want to change the font of not only Heading 1 or Heading 2, but all headings.

1. Open the Styles deck, select the Paragraph Styles category, right-click Heading, then select **Edit Style** to open the Paragraph Style dialog for the Heading style.

2. Select the **Font** tab, then select a font and click **OK**. Now the fonts of all the heading styles (Heading 1 through Heading 10) are changed in a single operation.

![Figure 217: Changing the Heading font](image)

**Working with paragraph styles**

Although this section describes most of the parameters scattered over the tabbed pages shown in Figure 217, you do not need to configure them all. In most cases, you need to modify only a few attributes, particularly if you link styles or base the new style on a similar one.

**Indents & Spacing tab**

On the **Indents & Spacing** tab (Figure 218), you can set up the indentation of the paragraph and the spacing between lines and between one paragraph and the paragraphs above and below.

Use the **Indent** section of the tab to set up the indentation, using these parameters:

- **Before text**: controls the space between the left margin of the page and the leftmost part of the paragraph area. Entering a negative value results in the text starting on the left of the margin. This may be useful in situations where your left margin is quite wide, but you want the headings to be centered in the page.

- **After text**: controls the space between the right margin of the page and the rightmost part of the paragraph area. Entering a negative value results in the text extending into the right margin of the page.

- **First line**: enter the offset in this box (either positive or negative) of the first line of the paragraph relative to the paragraph area. A positive value increases the indentation of the first line; a negative value makes the first line start to the left of the paragraph area.

- **Automatic**: select this box to allow Writer to automatically control the indentation of the first line. The value is calculated by Writer on the basis of the font size and other parameters.
Figure 218: Settings on the Indents and Spacing tab of the Paragraph Style dialog

Use the Spacing section of the tab to determine the amount of vertical space above and below the paragraph. It is customary to include some “space above” in heading styles so that they are separated from the text body of the previous section without the need to insert empty paragraphs. Spacing between paragraphs is also normal in certain types of documents. The body text style of this guide is configured to leave some space between consecutive paragraphs. You can select the option to remove space between paragraphs of the same style.

Note

An option in Tools > Options > LibreOffice Writer > Compatibility controls whether space above and space below are added together (the default) or if the larger space is the only one that applies. See Chapter 20, Customizing Writer, for more information.

The spacing between paragraphs does not affect the spacing between lines within a paragraph, which is controlled in the Line spacing section. You can select one of the following values:

- **Single**: the default setting; applies single line spacing to the paragraph. The spacing is calculated automatically based on the font size.
- **1.15 lines**: sets the line spacing to 1.15 lines. This small increase often improves the appearance of text without using a lot of vertical space.
- **1.5 lines**: sets the line spacing to 1.5 lines.
- **Double**: sets the line spacing to 2 lines.
- **Proportional**: activates the edit box. Enter a percentage value; 100% means single line spacing, 200% double line spacing, and so on.
- **At least**: activates the edit box. Enter the minimum value (in the selected unit of measurement) to be used for the line spacing.
- **Leading**: activates the edit box. To control the height of the vertical space between the base lines of two successive lines of text, enter a value, which is added to the value of single line spacing.
- **Fixed**: activates the edit box. Enter the exact value of the line spacing.
Tip

When using different font sizes in the same paragraph, the line spacing may be uneven. To obtain evenly spaced lines, select Fixed or At least in the drop-down list and a value that is large enough to create a spacing between the lines sufficient to account for the largest font size used.

The last option on this tab is **Activate page line-spacing**. It works with the *Use page line-spacing* option for a page style (see page 254). See the Help and Chapter 6, Formatting Pages: Advanced, for more information on the use of these options.

Alignment tab

Use the Alignment tab to modify the horizontal alignment of the text, choosing between Left, Right, Center, and Justified. The results of the selection are shown in a preview window on the right-hand side of the tab.

When selecting Justified alignment, you can also decide how Writer should treat the last line of the paragraph. By default, Writer aligns the last line to the left (Start), but you can choose to align it to the center or to justify it (meaning that the words on the last line will be spaced in order to occupy it fully). If you have selected to justify the last line and select the **Expand single word** option, then when the last line of a justified paragraph consists of a single word, this word is stretched by inserting spaces between characters so that it occupies the full length of the line.

The Alignment tab is also used to control the Text to Text vertical alignment, useful when you have mixed font sizes on the same row. Choose the element of the fonts on the line that will be aligned between Automatic, Base line, Top, Middle, Bottom. Refer to Figure 219 for a visual representation of these reference points.

![Figure 219: Text to text vertical alignment: Base line, Top, Middle, Bottom](image)

Text flow options for paragraph styles

The Text Flow tab (Figure 220) has three parts: Hyphenation, Breaks, and Options.

**Hyphenation options**

When **Automatically** is selected under *Hyphenation*, these options are available:

- **Don't hyphenate words in CAPS**
  Don't insert hyphens in words written entirely in capital letters.

- **Don't hyphenate the last word**
  Don't insert hyphens in the last word of a paragraph.

- **Characters at line end**
  Controls the minimum number of characters to be left at the end of a line.

- **Characters at line begin**
  Controls the minimum number of characters that must appear at the beginning of the line following a hyphen.
Maximum consecutive hyphenated lines
Controls the maximum number of consecutive lines that can be hyphenated. The typographical standard is 2.

Minimum word length in characters
Specify the minimum word length in characters that can be hyphenated.

Hyphenation zone
Specify the length of the horizontal space in which a word cannot be hyphenated; instead, the line of text will break between words. Specifying a hyphenation zone results in enlarged spaces between words in justified text, and greater distance from paragraph margins in non-justified text.

Figure 220: The Text Flow tab of the Paragraph Style dialog

Breaks options
In the Breaks section, you can require a paragraph to start on a new page or column and specify the position of the break, the style of the new page, and the page number. A typical use for this option is to start the first page of a new chapter on a new (usually right-hand) page.

To always start a new page with a particular style, choose the following settings:

- In the Breaks section, select Insert. Make sure that Type is set to Page and Position is set to Before.
- Select With Page Style and choose the page style from the list.
- To continue page numbering from the previous chapter, do not select the Page number option. To restart each chapter’s page numbering at 1 (a style used in some technical documents), select Page number and set it to 1.
Note

If you want the first page of a new chapter to always start on a right-hand page, make sure that the page style for the first chapter page is set for the right page only by making this selection in the Layout settings field on the Page tab of the Page Style dialog (see Figure 231 on page 253).

Other options

The Options section of the Text Flow tab provides settings to control what happens when a paragraph does not fit on the bottom of a page:

- **Do not split paragraph**: If a paragraph does not fit on the bottom of one page, the entire paragraph moves to the top of the next page. This could cause a large blank space at the bottom on the page.
- **Keep with next paragraph**: Use for headings or the lead-in sentence to a list, to ensure that it is not the last paragraph on a page.
- **Orphan control** and **Widow control**: Widows and orphans are typographic terms. An orphan is the first line of a paragraph alone at the bottom of a page or column. A widow is the last line of a paragraph that appears alone at the top of the next page or column. Use these options to allow paragraphs to split across pages or columns but require at least two or more lines to remain together at the bottom or top of a page or column. You can specify how many lines must remain together.

Font options for the paragraph style

Three tabs of the Paragraph Style dialog are dedicated to settings controlling the appearance of the typeface: the Font, Font Effects, and Position tabs. The first two tabs are straightforward. Many of the options are the same as those used when creating a character style, as discussed on page 250. Options that can be used when creating a paragraph style are described here.

**Tip**

On the Font tab, in the lower right, is a **Features** button. The configurable features available in the dialog that opens depend on the selected font and are not described here. They may include, for example, discretionary ligatures and horizontal kerning.

**Specifying a relative font size**

You can specify a fixed font size (in points or other measurement units). In addition, if you are creating a style based on another style (linked style), you can specify a font size relative to that other style either as a percentage or as a plus or minus point value (–2pt or +5pt). Relative font sizes are commonly used for Web pages.

For example, the Heading 1 paragraph style is based on the Heading style. If the font size of the Heading style is 14pt, and the font size of the Heading 1 style is specified as 130%, the resultant font size of text in a paragraph formatted with the Heading 1 style is 14pt times 130% = 18.2pt.

To specify a percentage font size: in the Paragraph Style dialog, select the Font tab. In the Size box, enter the percentage amount followed by the symbol % (Figure 221). Similarly, you can enter a plus or minus sign followed by the number of points to be added to or subtracted from the base font size.

To change from a relative font size back to an absolute font size, enter the desired font size in a specific measurement, such as points (pt).
Selecting a language for a paragraph style

The language selected for a document (on Tools > Options > Language Settings > Languages) determines the dictionary used for spelling, thesaurus, hyphenation, the decimal and thousands delimiter used, and the default currency format. You can only use a language whose dictionary is installed.

Within the document, you can apply a separate language to any paragraph style. This setting has priority over the language of the whole document.

On the Font tab of the Paragraph Style dialog, languages with installed dictionaries are marked in the Language list by a small icon (Figure 222). When checking spelling, Writer will use the correct dictionary for paragraphs with this style.

If you write documents in multiple languages, you can use the linked styles to create two paragraph styles that differ only in the language option. If you then want to change some of the other properties of the paragraph style, all you need do is to change the parent style.

To insert occasional words in a different language and avoid their being picked by mistake with the spelling checker, it is more convenient to use a character style, as discussed in “Creating a new character style” on page 250.
Tip

The selection [None] for Language is useful when a paragraph includes text you don’t want checked, like URLs and programming code.

Options for positioning text

The Position tab of the Paragraph Style dialog collects all the options that affect the position of the text on the screen or printed page.

![Position tab of the Paragraph Style dialog](image)

*Figure 223: The Position tab of the Paragraph Style dialog*

Use the Position section to control the appearance of superscripts and subscripts (characters above or below the normal line of type, as in H2O or M2). However, you will normally apply superscript and subscripts to groups of characters rather than to entire paragraphs. Therefore, it is strongly recommended to change these parameters only when defining a character style and, instead, leave the default settings for the paragraph styles.

The second section of the Position tab controls the rotation of the paragraph area. One common use for rotated paragraphs is to fit headings above narrow table columns (Figure 224). Another use is to create portrait headers and footers on landscape pages; see Chapter 6, Formatting Pages: Advanced, for details.

![Rotated table](image)

*Figure 224: A table with rotated headings*

The Scale width box controls the percentage of the font width by which to compress or stretch the rotated text horizontally; that is, from the first character to the last.
Rotated table headings are usually more readable if they are angled, not vertical. To produce angled text, you need to create a text object from the Drawing toolbar and rotate it to any angle you wish. See Chapter 11, Images and Graphics.

**Example: Rotating the text in a paragraph style**

As an example, we will apply rotated table headings to a pre-existing table.

1) Create a new paragraph style. Name it *Table Heading Rotated*.
2) On the Position tab of the Paragraph Style dialog, in the Rotation / scaling section, select 90 degrees. Click OK to save the new style.
3) Select the heading row of the table and apply the new style. Any text in the cells of the heading row is now rotated.
4) If the headings are aligned to the top of the cells, you may want to change the alignment to the bottom of the cells, as shown in Figure 224. To do this, click the **Bottom** icon on the Table toolbar or select **Format > Alignment > Bottom** on the Menu bar.

**Spacing options**

Use the *Spacing* section of the *Position* tab to control the spacing between individual characters in the paragraph. When selecting an option other than default in the drop-down menu, use the edit box to enter the value in points by which you want to expand or condense the text.

The *Pair kerning* option (selected by default) increases or decreases the amount of space between certain pairs of letters to improve the overall appearance of the text (Figure 225). Kerning automatically adjusts the character spacing for specific letter combinations. Kerning is only available for certain font types and, for printed documents, only works if your printer supports it.

![Figure 225: Kerning disabled (left) and enabled (right)](image)

**Controlling tab stops**

Although borderless tables are generally considered a much better solution to space out material across a page, in some situations tabs are sufficient to do what you need, with the added advantages of being simpler to manage and quicker to apply.

**Caution**

If you need to use tabs, and you will be sending a document to other people, do not use the default tab stops. If the recipients of the document have defined default tab stops that are not the same as the ones you are using, the paragraph may look very different on their machines. Instead, define the tab stops explicitly in the paragraph or the paragraph style; then you can be sure that everyone will see the same layout.

To define tab stops in your paragraph style, use the **Tabs** page, shown in Figure 226. Here you can choose the type of tab: Left, Right, Centered, or Decimal; the character to be used as a decimal point; and the Fill Character—the characters that appear between the end of the text before the tab and the beginning of the text after the tab.
You can also create a custom fill character by entering it in the corresponding box. A common use of a fill character is adding dots between a heading and a page number in a table of contents or an underscore character when creating a form to fill in.

![Paragraph Style: Untitled2](image)

**Figure 226: Specifying tab stops for a paragraph style**

To create a new tab stop, specify its position relative to the left margin, the type of tab, and the fill character and click the **New** button. The new tab stop is then listed in the **Position** box on the left. To modify the position of a tab stop, create a new one in the desired position and delete the old one using the buttons on the right-hand side of the page.

It is not possible to define tabs that exceed the page margin. In the rare cases where that may be needed, use a borderless table instead.

### Outline & List tab

Use the **Outline & List** tab to assign an outline level to any paragraph style, as described in Chapter 8, Introduction to Styles. This feature enables you to create a table of contents that includes those paragraphs along with the headings using styles listed in **Tools > Heading Numbering**.

You can also use this tab to associate a paragraph style with a list style. Refer to Chapter 12, Lists, for additional information and an example.

### Setting up a drop cap

Drop caps (one or more characters in a larger font at the beginning of a paragraph) are generally suitable only for a first paragraph style. You can predefine the properties in the **Drop Caps** tab of the Paragraph Style dialog. Select the **Display drop caps** option to enable the other choices: the number of lines occupied, the number of characters to enlarge (if you want the whole first word, check the corresponding box), and the space between the drop caps and the text.

Drop caps use the same font and have the same properties as the rest of the paragraph; however, you can easily modify their appearance by creating a specific character style and using it. For example, you may want the drop caps to be of a different color or apply an outline effect. Select the character style you want to use in the corresponding drop-down menu.
Background (area), highlighting, and transparency

Adding a background color, gradient, pattern, hatching, or image to a paragraph is an alternative to using a frame. You can customize the background using the Area tab of the Paragraph Style dialog. The choices are described in Chapter 6, Formatting Pages: Advanced.

You may want to consider the following points when working with the Area tab:

- If you do not find the desired color in the list of predefined ones, you can define your own as described in Chapter 20, Customizing Writer.
- You can select different backgrounds for the paragraph area and for the text in the paragraph. Use the Highlighting tab for the text. Figure 229 shows the difference.
- The area treatment is applied only to the paragraph area. If you have defined an indented paragraph, the space between the paragraph and the margin does not have the paragraph’s background color.

On the Transparency tab, you can choose the transparency options for the selected background. Values range from 0% (fully opaque) to +100% (fully transparent).
Borders

Borders are often used to set off paragraphs from the text without using a frame, or to separate header and footer areas from the main text area (such as in this guide), and to provide decorative elements in some heading styles. Consider the following points:

• Watch out for the effects that the spacing between borders and paragraph area produces on indentations and tabulations.
• If you want the border to be drawn around multiple paragraphs, leave the Merge with next paragraph option at the bottom of the page selected.
• Often, white space can have the same effect.

See Chapter 4, Formatting Text, for more about the Borders tab.

Using conditional paragraph styles

Making a paragraph style conditional means it changes its formatting depending on where it is used. For example, you may want the style MyTextBody to be black by default but turn white when inside a frame with a blue background.

Probably the most common use for conditional formatting is with single-style outlining. Single-style outlining is a type of outline numbering designed with a Numbering List Style. Instead of using different styles for the various outline levels, it changes the number formatting when you press the Tab key to create a subordinate heading.

The only trouble with single-style outlining is that all levels look the same. This is where a conditional paragraph style comes in handy. Assign the paragraph style to an outline style in the Outline & List tab and then open the Condition tab. There, you can assign the levels of the outline style to other paragraph styles. Then, when you press the Tab key while using the paragraph style, each level of the outline takes on different formatting, making single-style outlining even more convenient than it is on its own.

When you create a conditional style, you are saying “in this condition make this style look like that other style”. For example, “When typing into a footer, make this style look like the my_footer paragraph style; when typing into a table, make this style look like the table_text paragraph style”.

In addition to setting the normal (unconditional) properties of the style, you need to define which other style it will look like in different situations. To do this, use the Condition tab.

Note

Predefined styles (other than Text body) such as Default, Heading 1, and Heading 2 cannot be set to be conditional.

Caution

If you want to create a new style and make it conditional, you have to do it while the Paragraph Style dialog is still open for the first time. After the dialog closes, the Condition tab no longer appears in the dialog when it is reopened.
To set up a conditional paragraph style:

1) Define a new paragraph style.
2) Select all the paragraph properties for the style. **Do not click OK!**
3) Click the **Condition** tab.
4) Select the first condition in the **Context** list (left side of the dialog) and select the style you want for this condition in the **Paragraph Styles** list on the right-hand side.
5) Click **Apply**. The name of the paragraph style appears in the middle list.
6) Repeat steps 4) and 5) for each condition you want to have linked to a different style.
7) Click **OK**.

When the style is selected, you will see that the formatting of your text depends on the context.

**Working with character styles**

Character styles over-ride the formatting in a paragraph style. They are applied to groups of characters, such as words or phrases, rather than whole paragraphs. They are mainly used when you want to change the appearance or attributes of parts of a paragraph without affecting other parts. Examples of effects that can be obtained by means of character styles are **bold** or **italic** typeface or colored words.

Other ways of using character styles are described elsewhere in this book. These uses include making chapter numbers, page numbers, or list numbers larger than the surrounding text and formatting hyperlinks. When you do not want some words (for example, names, or words in a different language) to be detected as spelling mistakes, you can define the language (if any) to be applied in the character style’s properties.
Creating a new character style

The tabs of the Character Styles dialog are similar to those for paragraph styles:

- Use the Organizer tab to name the new character style and set up its hierarchical level (if needed).
- Use the Font tab to choose the font, style, and size for the new character style. You can specify the font size as a percentage or a point increase or decrease in the size of the font in the paragraph where the character style is applied. You can also specify the language of the text to which the character style is applied, so you can insert words in a different language and have their spelling checked using the correct dictionary.
- Use the Font Effects tab to set up attributes such as font color, underlining, relief, or other effects. If you frequently use hidden text, for example, it may be convenient to define a character style where the Hidden option is marked. Relief effects may be appropriate for a drop cap or to give more emphasis to the chapter number or other parts of the title.
- Use the Highlighting tab to apply a colored background to the text. This yields the same effect as using the Highlight Color tool on the Standard toolbar.
- Use the Borders tab to apply a border and a shadow to the text, if so desired.
- Use the Position tab to create a subscript or superscript in case you are not satisfied with the default ones or even a sub-subscript which may be useful for certain scientific publications. In the same tab, you can create rotated, condensed, or expanded text.

Note

When rotating a group of characters, you also need to specify whether the rotated text should fit in the line or if, instead, it is allowed to expand above and below the line. This property is active only for character styles.

Working with frame styles

Frames are often used as containers for text or graphics. To provide consistency in the appearance of frames used for similar purposes, it is a good idea to define styles for frames. For example, you might want photographs to be enclosed in a frame with a drop-shadowed border, line drawings in a frame with a plain border, marginal notes in a frame without a border but with a shaded background, and so on.

Writer provides several predefined frame styles (Table 7), which you can modify as needed, and you can define new frame styles. The technique for defining and applying frame styles is similar to that for other styles.

Tip

There is considerable overlap between the uses of frames and sections for some page layout purposes. See Chapter 6, Formatting Pages: Advanced, for information about the use of frames and sections.
Table 7: Predefined frame styles and their uses

<table>
<thead>
<tr>
<th>Style</th>
<th>Comments and Use</th>
</tr>
</thead>
<tbody>
<tr>
<td>Formula</td>
<td>The frame style used for formulas. The default includes AutoSize, which adjusts the size of the frame to the formula.</td>
</tr>
<tr>
<td>Frame</td>
<td>The default frame style.</td>
</tr>
<tr>
<td>Graphics</td>
<td>The default frame style for graphics. The defaults include AutoSize to fit the graphic, no text wrap, and a thin border around the frame.</td>
</tr>
<tr>
<td>Labels</td>
<td>The default frame style for use with File &gt; New &gt; Labels. It seems to be used by LibreOffice automatically and is not intended for users.</td>
</tr>
<tr>
<td>Marginalia</td>
<td>A frame style for placing a frame beside the left margin. This style is intended for comments added in the margin of text. The style also is useful for creating sideheads—headings against the left margin, which often are used in technical documentation. An example is given in Chapter 8, Introduction to Styles.</td>
</tr>
<tr>
<td>OLE</td>
<td>The default frame style for OLE objects and floating frames. The default places the frame at the top and center of a body of text.</td>
</tr>
<tr>
<td>Watermark</td>
<td>The default frame style for a watermark, a graphic placed as the background to a body of text. The default is a Through wrap, with text passing over the frame and anything in it. The graphic should be faint enough that text still is readable over top of it.</td>
</tr>
</tbody>
</table>

How frame styles work

When an object is added to Writer, it is automatically enclosed in a frame of a predetermined type. The frame sets how the object is placed on the page, as well as how it interacts with other elements in the document. You can edit the frame by modifying the frame style it uses or by using a manual override when a frame is added to the document.

Because frames and objects are used together, it is sometimes easy to forget they are separate elements. In some cases, such as charts, you can edit the frame and object separately.

Note

Unlike other elements that use styles, frames can be defined only partly by their style because their use can vary so much. Several elements of frames, such as the anchor and protected elements, need to be defined manually for individual frames.

To format a frame manually, select Insert > Frame on the Menu bar. The dialog that opens contains all the settings available when frame styles are set up, as well as some that are only available when the frame is inserted. See Chapter 6, Formatting Pages: Advanced, for more information.

Planning the styles

If you are using a mix of graphics, you may want to define two related styles, one with a border for graphics with white backgrounds and one without a border for all other backgrounds. You also may want to design one or more frames for text only.

Otherwise, the default frame styles (listed in Table 7) cover most users’ needs. The only significant addition that you might need is one or more styles for text frames.
Creating or modifying frame styles

To access frame style settings, right-click on a frame style in the Style deck and select **New** or **Edit Style** in the context menu.

- **Type** tab: sets the size and position of the frame. One of the most useful options here is **AutoSize**, which automatically adjusts the frame to the object it contains. If the frame style is used automatically, then this option should be selected.
- **Options** tab: sets whether the contents of the frame are printed, editable in a read-only document, or only decorative. This tab also sets the text direction, which is useful if you are using the frame for contents in a language that uses right-to-left text direction.
- **Wrap** tab: sets how text is positioned in relation to the frame and how close text comes to a frame. If you want the frame contents to stand out from the paragraphs around it, set the wrap to **Wrap Off**. This probably is the single most important tab for frames.
- **Area** tab: sets the background color, bitmap, hatching, gradient, or pattern. This tab is useful mostly for text frames in complex page layouts, in which a text frame has an appearance different from the general background of the page.
- **Transparency** tab: sets the transparency options for the selected background. Values can range from 0% (fully opaque) to +100% (fully transparent).
- **Borders** tab: sets the attribute for a line around the frame, if any.
- **Columns** tab: this tab can be ignored unless the frame is being used for text. The options are the same as those used to set up a page style, as described in Chapter 6, Formatting Pages: Advanced.
- **Macro** tab: sets a macro to use with the frame in order to trigger an action when the user interacts with the frame. These options are useful for on-line Writer or HTML documents.

Working with page styles

Page styles control page properties (margins, page size, header and footer, among others). However, unlike paragraphs, characters, and frames, pages can not have directly applied properties. If you change the properties of a page, you are actually changing the underlying page style, so those changes are applied to all pages that use that page style. To change the properties of individual pages, you need to create a new page style.

Creating a new page style

To create a new page style, open the Styles deck and click the **Page Styles** icon. Right-click anywhere in the window and select **New**. The Page Style dialog contains nine tabs.

**Organizer tab**

The **Organizer tab** is described on page 236.

**General settings for the page style**

The **Page** tab of the Page Style dialog is where you can control the general settings of the page. The tab consists of three sections, plus a preview area in the top right.

In the **Paper Format** section, you can specify the size of the paper, choosing from one of the many predefined formats, or select **User** to define your own paper size using the **Width** and **Height** fields. Select the orientation of the paper: **Portrait** or **Landscape**. If your printer has more than one tray, you can specify the tray from which to print pages in the new page style.
In the Margins section, specify the size of the margins in your preferred unit of measurement. If you select Mirrored for Page layout in the Layout settings section, then the names of the margins change from Left and Right to Inner and Outer.

The Gutter margin is the extra space to leave between the left (or inner) edge of the page and the left (or inner) margin, to allow for binding of a book. (Alternatively, you can leave the Gutter set to zero and add the gutter margin amount to the left or inner margin value.) See also the Gutter position setting, which can be Left (the default) or Top.

![Page Style dialog](image)

*Figure 231: Page tab of Page Style dialog*

In the Layout Settings section, choose the desired Page layout in the drop-down list. Decide whether the page style being defined applies to both left and right pages (default), mirrored pages, or right or left pages only. Some considerations:

- If you plan to bind the printed pages using this style like a book, select a mirrored layout.
- A common practice in page layouts is to have asymmetrical page margins—both for left and right margins and for top and bottom margins. The most common scheme follows these two general rules for printed page layouts: (a) The outer margin (right margin on a right-hand page) would be wider than the inner margin (left margin on a right-hand page); (b) The bottom margin would be larger than the top margin.
- If you want the first page of a new chapter to always start on a right page, make sure that the page style for the first chapter page is set for the right page only in the Layout settings field. The typical procedure for the rest of a chapter is to define a single “mirrored” page style (perhaps, Default Page Style) for both left and right pages. A mirrored page can have different headers and footers. If done this way, every chapter will use two page styles.
- You can choose to define separate page styles for left and right pages, if you want the pages to be very different in appearance (for example, different margins or columns; imagine a book with a full-page photograph on the left pages and two columns of text on the right pages). In that case, make sure that the Next Style field for the first page style is set for a left-only page, which, in turn, is set to be followed by a right-only page style. If done this way, every chapter will use three page styles. A hypothetical case might have these page style names: First Page, Left Page, and Right Page.
Use the Page numbers drop-down list to specify the page numbering style to apply to this page style.

The Use page line-spacing option works with the Activate page line-spacing option for paragraphs and paragraph styles (see page 240). See the Help and Chapter 6, Formatting Pages: Advanced, for more information on the use of these options.

By default, page backgrounds (colors, images, and so on) fill the entire page, including the area in the margins. If you want the background to fill only the text area, but not the margin area, then deselect the Background covers margins option in the lower right of the dialog.

**Area and Border tabs**

The Area and Border tabs are described in detail in Chapter 6, Formatting Pages: Advanced. Use the Area tab to apply a background (covers the entire page, including the margins) or the Border tab to draw a border around the text area of the page (inside the margins). You can also add a shadow to the text area.

**Header and Footer tabs**

You can associate a different header or footer with each page style. This property makes it easy to have different headers on left and right pages, to avoid headers on pages at the start of a new chapter, and so on. You can also have a different header or footer on the same page style where it is used for the first page of a document.

If you choose a Mirrored or Right and Left page layout on the Page tab, you can specify a different header for left or right pages even if you use a single style for both. This option is not available on the predefined Left Page and Right Page page styles or on any other page style defined to be a left or right page only.

The Header and Footer tabs are described in detail in Chapter 5, Formatting Pages: Basics.

Figure 232: Different header content on left and right pages

**Columns tab**

Use the Columns tab to create the column layout for the page style. It has three sections: Settings, Width and Spacing, and Separator Line. Choose the desired number of columns. If you select more than one column, the Width and Spacing section and the Separator Line section become active. You can use the predefined settings (equally spaced columns) or deselect the AutoWidth option and enter the parameters manually. When you work with multiple columns per page, you can also fine tune the position and size of a separator line between the columns.

**Footnote tab**

Use the Footnote tab to adjust the appearance of the footnotes. See Chapter 5, Formatting Pages: Basics, for details.

**Working with list styles**

List styles work together with paragraph styles. They define indentation, alignment, and the numbering or bullet characters used for list items. You can define many list styles, from simple bulleted lists to complex multi-level (nested) lists.
As with other styles, the main reasons for using list styles are consistency and speeding up your work. Although you can create simple lists quickly by clicking the **Toggle Ordered List** or **Toggle Unordered List** icons on the Formatting toolbar, and create quite complex nested lists using the icons on the Bullets and Numbering toolbar, the appearance of the resulting lists may not be what you want, and you might want to have more than one style of list.

You can use the Bullets and Numbering choice on the Format menu to manually format the appearance of some or all of the lists, but if you later need to change their appearance, you will have a lot of manual work to do.

See Chapter 12, Lists, for details on how list styles and paragraph styles work together.

**Creating a new list style**

The dialog to create a new list style includes six tabs in addition to the usual **Organizer** tab discussed on page 236.

**Unordered, Ordered, and Image tabs**

The **Unordered**, **Ordered**, and **Image** tabs contain predefined formatting for list item symbols (bullets or numbers). To use one of them for your style, click the image. A thick border indicates the selection. The bullets on the **Bullets** tab are font characters; those on the **Image** tab are graphics.

**Outline tab**

Use the **Outline** tab to select from eight predefined nested lists. You can also select one and use it as a starting point for your own style, customizing the list using the **Position** tab and the **Customize** tab, as described below.

**Position tab**

Use the **Position** tab (Figure 233) to fine tune the indentation and spacing of the list item symbol and the text of the list item. This tab is particularly effective when used in combination with the **Customize** tab.

![Figure 233: Position settings for a List style](image)
You can adjust the following settings for each individual level or all levels at once (to make them all the same).

- **Aligned at**: the position of the numbering symbol, measured from the left margin of the page.
- **Numbering alignment**: Select Left to align the numbering symbol to start directly at the Aligned at position. Select Right to align the symbol to end directly before the Aligned at position. Select Centered to center the symbol around the Aligned at position. This option does not set the alignment of the paragraph, only the numbering symbol.
- **Numbering followed by**: the character to follow the numbering symbol (plus any characters—for example a punctuation mark—chosen on the Customize tab to appear after the number). Choose between a tab stop, a space, or nothing.
- **Tab stop at**: If you selected the tab stop above, you can specify the position of the tab.
- **Indent at**: Specify the distance from the left page margin to the start of all lines in the numbered or bullet paragraph that follow the first line.

**Tip**

To fully appreciate how the Numbering alignment and other parameters work, try to create a numbered list with more than ten elements and make sure that enough room has been made for numbers with two or more digits. You may also wish to right-align numbers 10 or greater.

**Customize tab**

Use the Customize tab (Figure 234) to define the style of the outline levels. The options available on this tab depend on the type of marker selected for the list. First, on the left side, select the level you want to modify. To modify all ten levels at once, select 1 – 10 as the level. If you started from a predefined outline, some of the levels will already have settings.

![Figure 234: The Customize tab for a List style](image)

Depending on the numbering style selected in the Number box (bullet, graphic, numbering), some of the following options become available on the tab (not all are shown in the illustration):

- **Start at**: the first value of the list (for example, to start the list at 4 instead of 1).
- **Character Style**: the style to be used for the number or bullet.
• **Show sublevels**: The number of previous levels to include in the numbering style. For example, if you enter "2" and the previous level uses the "A, B, C..." numbering style, the numbering scheme for the current level becomes: "A.1".

• **Separator – Before**: any text to appear before the number (for example, Step).

• **Separator – After**: any text to appear after the number (for example, a punctuation mark).

• Character **Select** button: click to select the character for the bullet.

• Graphics **Select** button: opens a list of available graphics (Gallery) or allows the selection of a file to be used as the list marker.

• **Width** and **Height**: the dimensions of the graphic marker.

• **Keep ratio** option: fixes the ratio between the width and the height of the graphic marker.

• **Alignment**: the alignment of the graphic object.

The right-hand side of the dialog shows a preview of the modifications made.

If you choose the **Linked graphics** option in the **Number** list, the graphic object is linked rather than embedded in the document. The bullet will not be displayed when the document is opened on a different computer (unless the same graphic file is located in the same location on both computers) or if the graphic file used is moved to a different location on the computer.

To revert to the default values, click the **Reset** button in the bottom right corner. Finally, if you wish to use consecutive numbers regardless of the outline level, select the Consecutive numbering box at the bottom of the tab.

**Solving formatting problems**

Two new features in LibreOffice Writer assist in finding and fixing formatting problems related to the use of paragraph and character styles and direct formatting: Style Inspector and Style Spotlight. These features improve compatibility between LibreOffice and Microsoft Office.

**Using the Style Inspector**

The Style Inspector (Figure 235) is located on the Sidebar. It displays all the attributes of the styles (paragraph and character) and any direct formatting present in the paragraph or word where the cursor is located. These details can be useful when you are trying to figure out why some formatting in a document appears to be incorrect or inconsistent.

Use the Style Inspector to uncover formatting issues in a text document.

• Style properties overwritten by direct formatting are grayed out in the Paragraph and Character style tree, indicating that the style property is not effective any more.

• Paragraph style properties that are re-defined by a child paragraph style are grayed out.

• Character style properties that are re-defined by a child character style are grayed out.

• Paragraph style and direct properties that are re-defined by character styles or character direct properties are grayed.

For example, if the margins of the paragraph are changed by direct formatting using the rulers, the margins property of the paragraph style are grayed out and the margins properties are displayed in the Paragraph Direct Formatting entry of the Style Inspector.
Another example: if the Emphasis character style highlights a word with a yellow background, and the user mistakenly overwrote it by using a white background, the yellow attribute is grayed out and white is listed under Direct Formatting in the Style Inspector. The Style Inspector shows only those attributes that diverge from the parent style.

Some features of the Style Inspector are of interest mainly to advanced users:

- The Style Inspector can show any hidden RDF (Resource Description Framework, a W3C standard) metadata at the cursor position associated with text spans, paragraphs, and bookmarks. For annotated text spans, “Nested Text Content” item can show the boundary of the nested annotated text ranges and metadata fields.
- Custom color metadata field shadings can be set for an annotated text range or a metadata field, for visualization of metadata categories in the document editor. Use View > Field Shadings or Ctrl+F8 to disable or enable these field shadings.

For more information, see the Release Notes for LibreOffice 7.1 and 7.2 Community:
https://wiki.documentfoundation.org/ReleaseNotes/7.2#RDF_metadata_in_Style_Inspector
https://wiki.documentfoundation.org/ReleaseNotes/7.2#Custom_color_metadata_field_shadings

**Using the Styles Spotlight**

The Styles Spotlight provides a visual indicator of styles and manual formatting present in the document. It works for paragraphs and characters only.

To activate the Spotlight, go to the Styles tab in the Sidebar and select the **Spotlight** option at the bottom of the Paragraph Styles or Character Styles deck. Colored and numbered boxes then appear beside the names of the styles (Figure 236), indicators for paragraph styles appear in the left margin (Figure 237), and highlighting with numbers indicate character styles within the text.
Figure 236: Styles Spotlight for paragraph styles

A manually formatted paragraph is indicated by a hatch pattern in the colored indicators in the margin. When the extended tips features is enabled in LibreOffice > Preferences > LibreOffice > General, a tooltip shows the style name and, if relevant, the words “+ Paragraph Direct Formatting”.

**Figure 237: Example of Style Spotlight indicators**
Chapter 10,
Working with Templates
Introduction

A template is a model document that is used to create other documents. For example, you can create a template for business reports that has your company's logo on the first page. New documents created from this template will all have your company's logo on the first page.

Templates can contain anything that regular documents can contain, such as text, graphics, a set of styles, and user-specific setup information such as measurement units, language, the default printer, and toolbar and menu customization.

All documents in LibreOffice are based on templates. You can create, or download and install, as many templates as you wish, and you can set a default template for each type of document (text, spreadsheet, drawing, presentation). If you do not choose a template when you start a new Writer document, then the document is based on the default template for text documents. If you have not specified a default template, Writer uses the built-in blank template for text documents that is installed with LibreOffice. See “Setting a default template” on page 271.

Writer supports templates for master documents as well as for ordinary documents. For more about master documents, see Chapter 16.

This chapter describes the use of LibreOffice’s template management features. You can also manage and use templates in other ways, but the effects are a bit different. See “Other ways to manage templates” on page 274 for more information.

Creating a document from a template

A new installation of LibreOffice may not include many templates, but you can create your own (see “Creating a template” on page 266) or install templates obtained from other sources (see “Adding templates obtained from other sources” on page 267).

To create a document from a template:

1) Open the Templates dialog (Figure 238) using one of these methods:
   - Choose File > New > Templates or File > Templates > Manage Templates on the Menu bar.
   - Press the key combination Ctrl+Shift+N.
   - Click the arrow next to the New icon on the Standard toolbar and select Templates.
   - Select Templates > Manage Templates in the Start Center (visible in LibreOffice when no document is open).

2) In the Filter lists at the top of the Templates dialog, you can select the type and category of template you want to use. The relevant templates are listed on the dialog. Click on the icons to the right of the Categories list to switch between Thumbnail view (Figure 238) and List view (Figure 239).

3) Find and double-click the required template, or select the template and click Open. A new document based on the selected template opens in Writer. You can then edit and save the new document.

The template the document is based on is listed in File > Properties > General.

Tip

In the Start Center, click on the Templates button or open the drop-down menu and select a type of template, to view the available templates without opening the Templates dialog. Click on the required template to create a new document.
Figure 238: Thumbnail view of Templates dialog, showing context menu for a selected user-created template

Figure 239: List view of Templates dialog

Note

The connection between a template and a document remains until the template is modified and you do not update the document to match the template.

If you copy or move the document to a different computer which does not have a copy of that template installed, the connection is broken even though it continues to be listed in the document's properties. See “Changing the template assigned to a document” on page 270 for a way to reconnect a template to a document.
Creating a template

You can create templates in two ways: by saving a document as a template or by using a wizard.

Creating a template from a document

In addition to formatting, any settings that can be added to or modified in a document can be saved within a template. For example, printer settings; general behaviors set from Tools > Options, such as paths and colors; menu and toolbar customizations, described in Chapter 20, Customizing Writer.

Templates can also contain predefined text, saving you from having to type it every time you create a new document. For example, a letter template may contain your name, address, and salutation.

To create a template from a document:

1) Open a new or existing text (Writer) document.
2) Add any content that you want to appear in any document you create from the new template, for example company logo or a copyright statement.
3) Create or modify any styles that you want to use in the new template.
4) On the Menu bar, choose File > Templates > Save as Template. The Save as Template dialog (Figure 240) opens, displaying the existing categories and a box for the name for the new template.
5) Select a category, for example My Templates or Business Correspondence. You can also set this template as a default template at this time. Click Save.

Creating a template using a wizard

You can use wizards to create templates for letters, faxes, and agendas. To create a template using a wizard:

1) On the Menu bar, choose File > Wizards > [type of template required] (Figure 241).
2) Follow the instructions on the pages of the wizard. This process is slightly different for each type of template, but the format is similar.
3) In the last section of the wizard, specify the template name that will show in the Templates dialog and the file name and location for saving the template. The two names can be different but this may cause confusion. The default location is your user templates folder but you can choose a different location.

4) To set the file name or change the folder, click the Path icon (the three dots to the right of the location). On the Save As dialog, make selections and click **Save** to return to the wizard.

5) Finally, choose whether to create a new document from the template immediately or manually change the template. Click **Finish** to save the template.

### Adding templates obtained from other sources

LibreOffice refers to sources of templates as repositories. A repository can be local (a directory on your computer to which you have downloaded templates) or remote (a URL from which you can download templates).

To open the official LibreOffice template repository, type `https://extensions.libreoffice.org/` in the address bar of a web browser or click the **Get more extensions online...** link in the Extensions dialog (see Chapter 14, Customizing Writer). On the Extensions web page (Figure 242), in the left-hand column under **Add tag filters**, select **Templates** and **Writer**. The web page will update.

![Figure 242: Searching for templates in the repository](image)
Alternatively, type keywords in the *What are you looking for?* box at the top and click **Search**. In the search results, find the required template and click on its name to display a page with details; click the **Download** button to put the template anywhere on your computer. Proceed to “Installing templates” below.

Alternatively, choose **Manage > Extensions** on the upper right of the Templates dialog (Figure 243) to open an Extensions: Templates dialog (Figure 244), where you can scroll through a list of extensions or filter the list by typing a search term in the box at the top of the dialog.

![Figure 243: Getting more templates for LibreOffice](image)

On other websites, you may find collections of templates that have been packaged into extension (.OXT) files.
Installing templates

You can install templates using either the Templates dialog or the Extensions dialog.

To install templates using the Templates dialog:

1) Download the template or package and save it anywhere on your computer.
2) In the Templates dialog, click the Manage button on the upper right (Figure 243) and select Import in the submenu.
3) On the Select Category dialog, select the category where you want to import the template and click OK. A file browser window opens.
4) Find and select the template that you want to import and click Open. The file browser window closes and the template is imported and appears in the selected category.

To install templates using the Extensions dialog:

1) Download the template or package and save it anywhere on your computer.
2) In LibreOffice, select Tools > Extensions on the Menu bar. In the Extensions dialog, click Add to open a file browser window.
3) Find and select the template or package of templates you want to install and click Open.
   The package begins installing. You may be asked to accept a license agreement.
4) When the package installation is complete, restart LibreOffice. The templates are available for use through the Templates dialog and the extension is listed in the Extensions dialog.

See Chapter 20, Customizing Writer, for more about the Extensions dialog.

Tip

You can manually copy new templates into the template folders. The location varies with your computer’s operating system. To learn where the template folders are stored on your computer, go to Tools > Options > LibreOffice > Paths. You can also add new template folders in other locations; for more information, see the Getting Started Guide.

Editing a template

You cannot edit a template that was supplied with LibreOffice. You can only edit templates that you created or imported.

You can edit a template’s styles and content and then, if you wish, reapply the template’s styles to documents that were created from that template. You cannot reapply content.

To edit a template:

1) Open the Templates dialog, as described on page 264.
2) In the Templates dialog, find the template that you want to edit. Right-click on it to open the context menu (Figure 238), then click Edit. The template opens in Writer.
3) Edit the template as you would edit any other document. To save your changes, choose File > Save on the Menu bar.

Updating a document from a changed template

If you make any changes to a template and its styles, the next time you open a document that was created from the template before the changes, a confirmation message is displayed.
To update the document:

1) Select **Update Styles** to apply the changed styles in the template to the document.
2) Select **Keep Old Styles** if you do not want to apply the changed styles in the template to the document (but see the Caution notice below).

**Caution**

If you choose **Keep Old Styles**, the document is no longer connected to the template, even though the template is still listed under **File > Properties > General**. To reconnect the document to the template, use the procedure described in “Changing the template assigned to a document” below.

### Changing the template assigned to a document

At times you might want to associate a document with a different template, or perhaps you’re working with a document that did not start from a template or one that has become detached from its template.

You can change the template assigned to a document, or reconnect a document to a template, in two ways: manually or by using the Template Changer extension to LibreOffice.

- To change or reassign a template manually, first create a new, blank document from the required template, as described in “Manually changing the template” below. Then copy the contents of the old document into the new document.
- To use the Template Changer extension, first you need to download and install it, then restart LibreOffice to activate it. After that, you can open the document and use **File > Templates > Change template (current document)** on the Menu bar.

**Note**

Changing or updating a template affects only the formatting used in styles. It does not affect any content. You may also need to manually update content, for example a logo, copyright notice, or the layout of a copyright page.

### Manually changing the template

For best results, the names of styles should be the same in the existing document and the new template. If they are not, you may need to replace old styles with new ones. See Chapter 2, *Working with Text: Basics*, for more about replacing styles.

To manually associate a document with a different template:

1) Open the Templates dialog as described on page 264.
2) In the Templates dialog, double-click the template you want to use. A new document opens, containing any text or graphics that were in the template.
3) Delete any unwanted text or graphics from this new document. Use **File > Save As** to save the new document, but leave it open.
4) Open the document you want to change. (It opens in a new window.)
5) Use **Edit > Select All**, or press **Ctrl+A**, to select everything in the old document.
6) Use **Edit > Copy**, or press **Ctrl+C**, to copy the contents of the old document to the clipboard.
5) Click in the new document created in step 2. Use **Edit > Paste**, or press **Ctrl+V**, to paste the contents of the old document into the new one.

6) Update the table of contents if there is one. Save the new document using **File > Save**.

7) Close the old file without saving.

---

**Caution**

Any changes recorded (tracked) in the old document will be lost during this process. The resulting document will contain only the changed text.

---

### Setting a default template

If you create a document by choosing **File > New > Text Document** on the Menu bar, or by clicking the **Text Document** button in the Start Center, Writer creates the document from the default template for text documents. You can, however, set a custom template to be the default. You can reset the default later, if you choose.

#### Setting a template as the default

Many default settings, such as page size and margins, font choices, line spacing, and so on, can be changed using styles, but those changes apply only to the document you are working on. To make the changes the default settings for that document type, you need to replace the default template supplied with LibreOffice with a new one that you create.

You can set any template in the Templates dialog to be the default for that document type:

1) Open the Templates dialog as described on page 264.

2) In the Templates dialog, open the category containing the template that you want to set as the default, then select the template.

3) Right-click the selected template and select **Set as Default** from the context menu (Figure 238). An icon marks the template as the default (Figure 245).

The next time that you create a document of that type by choosing **File > New**, the document will be created from this template.

![LibreOffice 7.x Template](image)

*Figure 245: Default template icon*

### Resetting Writer’s default template as the default

To re-enable Writer’s original default template as the default:

1) Open the Templates dialog as described on page 264.

2) In the Templates dialog, click the **Manage** button on the upper right (Figure 246).
Figure 246: Resetting the default template for text documents

3) Click **Reset Default Text Document** in the drop-down menu. This choice does not appear unless a custom template had been set as the default, as described in the previous section.

You can also reset the default template as follows:

1) Go to the Templates dialog and open the category containing the template you set as default. It is indicated by a green check mark.

2) Right-click on this template and select **Reset Default** in the context menu.

The next time that you create a document by choosing **File > New** (or equivalent), the document will be created from the original default template for the document type.

Organizing templates

LibreOffice can manage only those templates that are in its template categories, although you can create a document from a template that is not in one of these folders (see “Creating a document from a template” on page 274). You can create new template categories and use them to organize your templates. For example, you might have one category for report templates and another for letter templates. You can also import and export templates.

To begin, choose **File > Templates > Manage Templates** to open the Templates dialog.

Creating a template category

To create a template category:

1) Click the **Manage** button on the upper right of the Templates dialog.

2) Click **New category** in the context menu (Figure 246).

3) In the pop-up dialog, type a name for the new category and click **OK**. The new category now appears in the list of categories.

Deleting a template category

You cannot delete template categories supplied with LibreOffice. Nor can you delete categories added using the Extension dialog unless you first remove the extension that installed them.

However, you can delete a category that you created:

1) Open the Templates dialog and select the category in the **Filter** list at the top.

2) Click the **Manage** button, and select **Delete Category** in the submenu (Figure 247). When a confirmation message box appears, click **Yes**.
Renaming a template category

You cannot rename template categories supplied with LibreOffice. You can only rename categories that you created.

Open the Templates dialog, select the category in the Filter list at the top, then click the **Manage** button and select **Rename Category** in the submenu (Figure 247). In the small dialog that opens, type a name in the *Enter New Name* text box and click **OK**.

Moving a template

To move a template from one template category to another, select it in the Templates dialog, right-click on it and select **Move** in the context menu (Figure 238). In the **Select Category** dialog (Figure 248), select the destination category and click **OK**. The selected template is moved to the selected category. You can also create a new category into which to move the template.

Renaming a template

You cannot rename templates supplied with LibreOffice. You can only rename a template that you have created or imported.

Open the Templates dialog, find and select the template you want to rename, then right-click the template and select **Rename** in the context menu. In the small dialog that opens, type a name in the *Enter New Name* text box and click **OK**.

This action changes the Title on the Description tab of the template’s document properties. It does not change the file name of the template.
Deleting a template

You cannot delete templates supplied with LibreOffice. Nor can you delete any templates installed using the Extensions dialog except by removing the extension that installed them. However, you can delete templates that you have created or imported.

1) (Optional) In the Filter drop-down lists at the top of the Templates dialog, select the category that contains the template you want to delete.
2) Select the template to delete.
3) Right-click to open the context menu of the template and click Delete. A message box appears and asks you to confirm the deletion. Click Yes.

Tip

You can also press the Delete key on the keyboard to delete the selected template on the Templates dialog.

Exporting a template

To export a template to another location on your computer or network:

1) In the Templates dialog, select the template that you want to export.
2) Right-click on the template and choose Export in the submenu. A file browser window opens.
3) Find the location where you want to export the template and select Select Folder or OK.
4) Click OK on the displayed information dialog.

Note

Exporting a template does not remove it from the Templates dialog. The action places a copy of the template in the location you specify.

Other ways to manage templates

You can create and use templates stored anywhere on your computer, without using the Templates dialog. However, some results are different from those described in this chapter.

Creating a document from a template

You can create a document from a template by double-clicking the template in your computer’s file browser window. The resulting document is not associated with (linked to) the template from which it was created. The template is not listed in the document’s properties and any changes to the template cannot be directly applied to the document. For many purposes, such as writing a letter, this may be what you want.

Creating a template from a document

You can create a template from a document using File > Save As and selecting ODF Text Document Template (.ott) as the file type, then saving it anywhere you want, for example in a project folder. The resulting template will not be visible in the Templates dialog, unless you import it or add the project folder to the locations shown for templates on the LibreOffice – Paths page of the Tools > Options dialog.
Chapter 11, Images and Graphics

Images, Drawing Tools, Gallery, Fontwork
Introduction

Graphic and image files, including photos, drawings, and scanned images, can be added to Writer documents. Writer can import various vector (line drawing) and raster (bitmap) file formats.

Images in Writer are of these basic types:

- Image files, such as photos, drawings, and scanned images
- Diagrams created using LibreOffice’s drawing tools
- Artwork created using clip art or Fontwork
- Charts created using LibreOffice’s Calc component

This chapter covers images, diagrams, and artwork. Instructions on how to create charts are given in Chapter 19, Spreadsheets, Charts, other Objects. For more detailed descriptions on working with drawing tools, see the Draw Guide. For more about charts, see the Calc Guide.

Creating and editing images

You might create images using a graphics program, scan them, or download them from the Internet (make sure you have permission to use them), or use photos taken with a digital camera. Writer can import various vector (line drawing) images, and can rotate and flip such images. Writer also supports raster (bitmap) file formats, the most common of which are GIF, JPG, PNG, and BMP. See the Help for a full list.

Writer can import SmartArt images from Microsoft Office files. It can also open a Microsoft Word file containing SmartArt and edit the images.

To edit photos and other bitmap images, use a bitmap editor. To edit line drawings, use a vector drawing program. For many graphics, LibreOffice Draw is sufficient. Open-source (and usually no-cost) tools such as GIMP (bitmap editor) and Inkscape (vector drawing program) are excellent. These and many other programs work on Windows, macOS, and Linux.

Some things to consider when choosing or creating images include image quality and whether the image will be printed in color or black-and-white (grayscale).

For best results:

- Create images that have the exact dimensions required for the document, or use an appropriate graphics package to scale photographs and large drawings to the required dimensions. Do not scale images with Writer, even though Writer has tools for doing this, because the results might not be as clear as required.
- Do any other required image manipulation (brightness and contrast, color balance, cropping, conversion to grayscale, and so on) in a graphics package, not in Writer, even though Writer has the tools to do a lot of these things, too.
- If the document is meant for screen use only, there is no need to use high resolution images of 300 or more dpi (dots per inch). Most computer monitors work at between 72 and 96 dpi; reducing the resolution (and the file size) has no negative impact on what is displayed. For printing, 300 dpi or higher is generally preferred.

Preparing images for black-and-white printing

If color images are to be printed in grayscale, check that any adjacent colors have good contrast and print dark enough. Test by printing on a black-and-white printer using a grayscale setting. Better still: change the “mode” of the image to grayscale, either in a photo editor or in Writer itself (see “Image mode” on page 294).
For example, the following diagram looks good in color. The circle is dark red and the square is dark blue. In grayscale, the difference between the two is not so clear. A third element in the diagram is a yellow arrow, which is almost invisible in grayscale.

![Original drawing in color](image1.png) ![Drawing printed in grayscale](image2.png)

Changing the colors of the circle and the arrow improves the contrast and visibility of the resulting grayscale image.

![Original drawing in color](image3.png) ![Drawing printed in grayscale](image4.png)

If the document will be available in black-and-white print only, a better result can often be obtained by choosing grayscale fills, not color fills.

### Adding images to a document

Images can be added to a document in several ways: by inserting an image file stored on the computer or network, directly from a graphics program or a scanner, by dragging them from the clip art internal gallery, or by copying and pasting from a source being viewed on the computer.

### Inserting an image file

When the image is in a file stored on the computer, insert it into a Writer document using any of the following methods.

#### Drag and drop

This method embeds (saves a copy of) the image file in the Writer document. To link the file instead of embedding it, hold down the Ctrl+Shift keys while dragging the image.

1. Open a file browser window and locate the image to be inserted.
2. Drag the image into the Writer document and drop it where you want it to appear. A faint vertical line marks where the image will be dropped.

#### Insert Image dialog

1. Click in the Writer document where you want the image to appear.
2. Choose Insert > Image on the Menu bar or click the Insert Image icon on the Standard toolbar.
3. On the Insert Image dialog, navigate to the file to be inserted, and select it.
4. At the bottom of the dialog (Figure 249) is a Link option; see “Linking an image file” on page 282. Select Preview to show a thumbnail of the selected image on the right, as in the example. Click Open.
Copy and paste
Using the clipboard, you can copy images into a LibreOffice document from another LibreOffice document and from other programs.

1) Open both the source document or program and the target Writer document.
2) In the source document, select the image to be copied.
3) Copy the image to the clipboard.
4) Switch to the target document.
5) Click to place the cursor where the image is to be inserted.
6) Press Ctrl+V (or right-click and select Paste in the context menu, or click the Paste icon on the Standard toolbar) to insert the image.

Caution
If the application from which the image was copied is closed before the image is pasted into the target, the image stored on the clipboard could be lost.

Linking an image file
If the Link option in the Insert Image dialog is selected, Writer creates a link to the file containing the image instead of saving a copy of the image in the document. The image is displayed in the document, but when the document is saved, it contains only a reference to the image file, not the image itself. The document and the image remain as two separate files, and they are merged together only when you open the document again.
Linking an image has two advantages and one disadvantage:

- **Advantage** – The image file can be modified separately, and the modified image will appear when the document is next opened. This can be a big advantage if you (or someone else, perhaps a graphic artist) are updating images.
- **Advantage** – Linking can reduce the size of the document when it is saved, because the image file itself is not included. However, file size is usually not a problem on a modern computer, and LibreOffice can handle quite large files.
- **Disadvantage** – If you send the document to someone else, or move it to a different computer, you must also include the image files, or the recipient will not be able to see the linked images. You need to keep track of the location of the images and make sure the recipient knows where to put them, so the document can find them. For example, you might keep images in a subfolder named Images (under the folder containing the document); the recipient of the file needs to put the images in a subfolder with the same name and in the same place relative to the document.

### Note
When inserting the same image several times in a document, LibreOffice embeds only one copy of the image file.

**Embedding linked images**

Linked images can easily be embedded later:

1. Open the document in Writer and choose **Edit > External Links** on the Menu bar.
2. The Edit Links dialog (Figure 250) shows all the linked files. In the Source file list, select the files to be changed from linked to embedded.
3. Click the **Break Link** button and then click **Yes** to confirm embedding the image.

![Figure 250: Edit Links dialog](image)
**Linking an embedded image**

To change an image from embedded to linked:

1) Be sure you have the image as a separate file. If necessary, export (save) the embedded image as a file. See “Exporting (saving) images” on page 299.

2) In the Writer document, select the embedded image. Right-click and choose **Properties** in the context menu.

3) In the Image dialog, go to the **Rotation** tab (Figure 251). The **Link File name** field is empty for an embedded image.

4) Click the **Browse** button to the right of the **Link File name** field. A file browser opens. Find and select the file to be linked, and then click **Open**. The path to the selected file now appears in the **File name** field.

5) Click **OK** in the Image dialog. The embedded file is now replaced by a linked file.

*Figure 251: Rotation tab of Image dialog, showing Link file name*

**Inserting an image using a scanner**

If a scanner is connected to the computer, Writer can call the scanning application and insert the scanned image into a document.

1) Choose **Insert > Media > Scan > Select Source** on the Menu bar and select the scan source from the list of available devices.

2) Click in the document where the image is to be inserted.

3) Choose **Insert > Media > Scan > Request**. The imaging software opens; adjust settings for image quality, size, and other attributes.

Although this practice is quick and easy, it is unlikely to result in a high-quality image of the correct size. You may get better results by scanning material into a graphics program and cleaning it up there before inserting the resulting image into Writer.

**Inserting an image from the Gallery**

The Gallery (Figure 252) provides a convenient way to group reusable objects such as graphics and sounds that can be inserted into documents. The Gallery is available in LibreOffice Writer, Calc, Impress, and Draw. You can copy or link an object from the Gallery into a document.

For more about the Gallery, see the *Getting Started Guide*.
To insert an object from the Gallery into a document:

1) Click the **Gallery** icon on the Sidebar.
2) Select a theme in the list provided.
3) Select an object with a single click.
4) Drag and drop the image into the document, or right-click the object and choose *Insert* in the context menu.
5) Adjust the size of the image and position and anchor it as needed; see page 285.

### Positioning images within the text

When you add an image to a text document, you need to choose how to position it with respect to the text and other images. Positioning is controlled by four settings:

- **Arrangement** refers to the placement of an image on an imaginary vertical axis. Arrangement controls how images are stacked upon each other or relative to the text.
- **Alignment** refers to the vertical or horizontal placement of an image in relation to the chosen anchor point.
- **Anchoring** refers to the reference point for the images. This point could be the page or frame where the object is, a paragraph, or even a character. An image always has an anchor point.
- **Wrapping** refers to the relation of images to the surrounding text, which may wrap around the image on one or both sides, be overprinted behind or in front of the image, or treat the image as a separate paragraph or character.
The settings can be accessed in several ways, depending on the nature of the graphic:

- In the **Format** menu: Anchor, Wrap, and Arrange (for images and drawing objects).
- In the context menu displayed when you right-click the image; this menu also includes an Align submenu.
- For images, on the **Position and Size** and **Wrap** tabs of the Image dialog. You cannot control the arrangement or alignment using the dialog.
- For drawing objects, on the **Position and Size** tab of the Position and Size dialog. To open the dialog, right-click the drawing object and choose **Position and Size** in the context menu.
- For an embedded object (such as a Calc spreadsheet or Draw document), on the OLE-Object toolbar.

**Note**

While all the positioning techniques discussed in this section apply equally to frames, contour wrapping is not possible for frames.

### Arranging images

Arranging an image means to determine its position relative to other images or text. Arranging is only relevant when objects are overlapping. You can choose between four common settings, plus a fifth special setting for drawing objects:

- **Bring to Front**
  Places the image on top of any other images or text.

- **Forward One**
  Brings the image one level up in the stack. Depending on the number of overlapping objects, you may need to apply this option several times to obtain the desired result.

- **Back One**
  Sends the image one level down in the object stack.

- **Send to Back**
  Sends the image to the bottom of the stack.

- **To Background / To Foreground**
  Only available for drawing objects; moves the drawing object behind or in front of the text respectively.

**Tip**

To select an object that is covered by other objects, press the **Tab** key to move through the objects until you reach the object you want.

### Anchoring images

You can anchor images as a character or to a page, paragraph, or character. You can also place images in a frame and anchor the frame to a page, paragraph, or character. Which method you choose depends on what you are trying to achieve.

- **To Page** (available only on Image dialog, not the toolbar or context menu)
  The image keeps the same position in relation to the page margins. It does not move as you add or delete text or other images. This method is useful when producing newsletters or other documents that are very layout intensive, or for placing logos in letterheads. This anchor type is deprecated; you are advised to use one of the other anchor types.
To Paragraph
The image is associated with a paragraph and moves with the paragraph. It may be placed in the margin or another location. This method is useful as an alternative to a table for placing icons beside paragraphs.

To Character
The image is associated with a character but is not in the text sequence. It moves with the paragraph but may be placed in the margin or another location. This method is similar to anchoring to a paragraph.

As Character
The image is placed in the document like any other character and, therefore, affects the height of the text line and the line break. The image moves with the text as you add or delete text before the image. This method is useful for keeping screenshots in sequence in a procedure (by anchoring them as a character in a blank paragraph) or for adding a small (inline) icon in sequence in a sentence.

To Frame
If the image has been placed in a frame, you can anchor the image in a fixed position inside the frame. The frame can then be anchored to page, to paragraph, to character, or as character.

Tip
You can set a default anchor for images in Tools > Options > LibreOffice Writer > Formatting Aids (Figure 253).

Figure 253: Choices for setting a default image anchor

Aligning images
After the anchor point of an image has been established, decide the position of the image relative to its anchor: this is called aligning the image. Choose from six options: three for aligning the image horizontally (left, center, right) and three for aligning the image vertically (top, middle, bottom). Horizontal alignment is not available for images anchored As Character.

For finer control of the alignment, use the Position options on the Position and Size page of the Image dialog, shown in Figure 254.

For both the horizontal and vertical position, start by picking the reference point in the right hand side drop-down menu, then select in the first drop-down menu among Left, Right, or Center for Horizontal or Top, Bottom, Center for Vertical. If you select From left or From top, you can specify the distance.

In the example in Figure 254, the image was anchored To Page; the upper-left corner of the image will be placed at 5 cm from the left edge of the page text area and 10 cm from the top edge of the entire page.
Wrapping text around images

The Wrap setting determines the relation between the text and the image. It is normally selected after anchoring and alignment of the image. Several choices are available in the context menu, depending on the anchoring selection, and additional choices (including spacing from text on one or more sides of the image) are on the Wrap tab of the Image dialog (Figure 255).

- **Wrap Off**
  Places the object on a separate line in the document. The text is placed above and below the image but not to either side of it.

- **Before**
  Wraps text on the left side of the object if there is enough space.

- **After**
  Wraps text on the right side of the object if there is enough space.

- **Parallel**
  Wraps text on all four sides of the border frame of the object.

- **Through**
  Superimposes the image on the text. That is, the image is in front of the text. This option should be used with an image-transparency setting in order to make the text under the image visible.

- **Optimal**
  The text flows around the image. Moving the image around the page causes the text to be rearranged to fill the space to the left and right of it. Optimal prevents text from being placed to the side of the image if the spacing between the image and the margin is less than 2 cm.

- **First paragraph**
  Starts a new paragraph after the image even if the text could still wrap around the image.

- **In Background**
  Similar to Through, but the image is placed behind the text so there may be no need to change the transparency to make the text visible. Best used only for images without a lot of contrast or different colors.

- **Contour**
  Wraps text around the shape of the object.

- **Outside only**
  Wraps text only around the contour of the object, but not in open areas within the object shape.

- **Allow overlap**
  Specifies whether the object is allowed to overlap another object. This option has no effect on wrap-through objects, which can always overlap.
Note

When anchoring an image As character, you can adjust the distance between the image and the text, but no wrapping option is available.

On the Wrap tab of the Image dialog (Figure 255), use the Spacing section to adjust the spacing between the image and the text.

![Figure 255: Options on the Wrap tab of the Image dialog](image)

**Editing the contour**

To create a contour, select Contour on the Wrap tab for an image (not available when Through or Wrap Off is selected), or right-click on the image and select Wrap > Edit Contour in the context menu. To edit the contour, right-click the image and select Wrap > Edit Contour in the context menu, or select the image and choose Format > Wrap > Edit Contour on the Menu bar.

The Contour Editor (Figure 256) opens. Use the tools provided to draw the region of the image you do not want to be covered by the text; this area will be shaded.

![Figure 256: The Contour Editor](image)
The tools available in the Contour Editor include Rectangle, Ellipse, Polygon, and AutoContour. Some familiarity with drawing tools is required to create complex contours; however, in most circumstances there is no need for high accuracy. To adjust the contour shape point by point, select the **Edit Points** button. See the **Draw Guide** for details.

Click the **Apply** button to save the contour.

Figure 257 shows contour wrapping and spacing around an image and a drawing object.

![Image and drawing objects with contour wrapping](image)

**Figure 257: Image and drawing objects with contour wrapping**

### Adding captions to images

You can add captions to images in three ways: automatically, by using the Caption dialog, or manually.

#### Adding captions automatically

You can set up LibreOffice to add captions automatically whenever you insert an image, a table, or other objects into a document. You can choose which objects are captioned automatically, what the sequence name is for each caption (for example, **Table** or **Figure**), and the position of the caption.

To set up automatic captions, choose **Tools > Options > LibreOffice Writer > AutoCaption**. At the right of the dialog, choose which objects you want to be automatically captioned and specify the characteristics of the captions.

When you insert an image, if automatic captioning is enabled, the image is placed in a frame along with a caption containing the default sequence name for images. Position the cursor in the caption area and type the text for the caption. You can change the sequence name by selecting one in the drop-down Category list or by typing in your own.

#### Adding captions using the Caption dialog

To add captions using the Caption dialog:

1. Insert the image, then either right-click it and select **Insert Caption** in the context menu, or select it and choose **Insert > Caption** on the Menu bar.

2. Under **Properties** on the Insert Caption dialog (Figure 258), make selections for the **Category**, **Numbering**, and **Before caption** fields [Figure, Arabic (1 2 3), and a colon (:), respectively, for the example in Figure 258] and type the caption text in the **Caption** box at the top. The text entered for the caption appears in the box at the bottom, after the category name, number, and separator.

3. Click **OK**. The image and its caption are placed in a frame.
In the Category box, you can type any name you want (for example, Photo) if the drop-down list does not include it. Writer will create a numbering sequence using that name, as it does when using the AutoCaption feature.

**Figure 258: Defining the caption for an illustration**

**Numbering images by chapter**

To display additional options for numbering captions, select the **Options** button in the Insert Caption dialog to open the Caption Options dialog (Figure 259). Some of these settings, which refer to the heading (outline) level, will have an effect only if outline level paragraph styles are used for the chapter headings within the document.

When heading numbering is set up, Writer will restart the caption numbering for each chapter it encounters. For example, if the last figure caption in chapter 1 is Figure 1.15, and the next figure caption is in chapter 2, the numbering will start over at Figure 2.1.

Options for chapter numbering of captions are:

- **Caption order** specifies whether the category or numbering appears first in the caption.
- **Character style** specifies a character style for the category and caption number, which can be different from the character style in the caption text; for example color or font size.
- The **Frame Format** option *Use border and shadow of selected object* does not apply to table captions, because a table is not an object enclosed in a frame.
- Under **Heading Number Before Caption Number**, **Up to level** specifies how many levels of heading numbers (starting from level 1) are displayed. Select [None] to display no heading number.
- **Separator** specifies the character to appear between the chapter number and the figure number.

**Note**

Changes to **Up to level** or **separator** are also applied to any existing captions in the document.
Adding captions manually

If you save as or export to other formats, you may find that captions applied as described above (either automatically or using the Caption dialog) are lost during the export.

To avoid export problems, or as another way to put captions above images or below them (the usual case), you can add a caption manually, in either of two ways:

- Place the image and its caption in separate paragraphs.
- Use a table.

Place the image and its caption in separate paragraphs

Insert the image and anchor it to its paragraph as a character. Press Enter to create a new paragraph for the caption.

1) In the caption paragraph, type, for example, Figure and add a space.
2) To insert the figure number automatically, click Insert > Field > More Fields (Ctrl+F2) and select the Variables tab.
3) Select Number range in the Type list. Select Figure in the Select list and choose (for example) Arabic (1 2 3) in the Format drop-down list. Click the Insert button.
4) A number will appear after the word “Figure” in the caption. Now, type the text of the caption.

Tip

When manually adding captions to a lot of figures using this method, you might want to make an AutoText entry containing, for example, Figure and a space, the figure-number field, and an optional separator and a space after it.
Tip

To ensure the image and its caption stay together on the page, create a new paragraph style, for example Figure. If the image is going above the caption, define the text flow of the Figure paragraph style as Keep with next paragraph and the next style as Caption. Conversely, if the caption is going above, define the Caption paragraph style as Keep with next paragraph and the next style as Figure.

Use a table

Create a one-column, two-row table. Place the image in one row and type the caption in the other row—or use two or more rows for the caption and other text. This method can be especially useful for images with numbered legends.

Modifying images

When inserting a new image, you may need to modify it to suit the document. The placement of the image relative to the text is discussed in “Positioning images within the text” on page 285. This section describes the use of the Image toolbar, resizing, cropping, and rotating an image.

Writer provides many tools for working with images. These tools are sufficient for most people’s everyday requirements. However, for professional results it is generally better to use an image manipulation program such as GIMP to modify images (for example, to crop, resize, rotate, and change color values) and then insert the result into Writer.

Using the Image toolbar

When you insert an image or select one already present in the document, the Image toolbar (Figure 260) appears.

Figure 260: Image toolbar plus Color toolbar and Image Filter toolbar
You can set the Image toolbar to always be present (View > Toolbars > Image) and choose whether to float or dock it. Two other toolbars can be opened from this one: the Image Filter toolbar, which can be torn off and placed elsewhere on the window, and the Color toolbar, which opens as a separate floating toolbar.

From these three toolbars, you can apply small corrections to the image or obtain special effects: transparency, color adjustment, flipping and rotating, and applying special-effects filters.

**Image filters**

Table 8 provides a short description of the available filters. The best way to understand them is to see them in action. Experiment with the different filters and filter settings. To undo all the changes, press Ctrl+Z or Alt+Backspace or select Edit > Undo. See the Draw Guide for more about image filters.

<table>
<thead>
<tr>
<th>Name</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Invert</td>
<td>Inverts the color values of a color image or the brightness values of a grayscale image.</td>
</tr>
<tr>
<td>Smooth</td>
<td>Softens the contrast of an image.</td>
</tr>
<tr>
<td>Sharpen</td>
<td>Increases the contrast of an image.</td>
</tr>
<tr>
<td>Remove noise</td>
<td>Removes single pixels from an image.</td>
</tr>
<tr>
<td>Solarization</td>
<td>Mimics the effects of too much light in an image. A further dialog opens to adjust the parameters.</td>
</tr>
<tr>
<td>Aging</td>
<td>Simulates the effects of time on an image. Can be applied several times. A further dialog opens to adjust the aging level.</td>
</tr>
<tr>
<td>Posterize</td>
<td>Makes an image appear like a painting by reducing the number of colors used.</td>
</tr>
<tr>
<td>Pop Art</td>
<td>Modifies the image dramatically.</td>
</tr>
<tr>
<td>Charcoal Sketch</td>
<td>Displays the image as a charcoal sketch.</td>
</tr>
<tr>
<td>Relief</td>
<td>A dialog is displayed to adjust the light source that will create the shadow and, hence, the relief effect.</td>
</tr>
<tr>
<td>Mosaic</td>
<td>Joins groups of pixels into a single area of one color.</td>
</tr>
</tbody>
</table>

**Image mode**

You can change color images to grayscale, to black-and-white, or to a watermark by selecting the image and then selecting the relevant item from the Image Mode list.

**Flip vertically, horizontally or in 90° rotations**

To flip an image vertically, horizontally, or rotate it by ninety degrees, select the image, and then click the relevant button on the image toolbar.

**Transparency**

Increase the percentage value in the Transparency box on the image toolbar to make the image more transparent. This is particularly useful when creating a watermark or when placing the image in the background.

**Color**

Use this toolbar to modify the individual RGB color components of the image (red, green, blue) as well as the brightness, contrast, and gamma of the image. If the result is not satisfactory, you can press Ctrl+Z to restore the default values.
Using the Formatting toolbar and Image dialog

When an image is selected, you can customize some aspects of its appearance using the tools available on the Formatting toolbar and in the dialog opened by right-clicking on the image and selecting Properties. You can, for example, create a border around the image, selecting style and color; or you can (on the Borders tab of the Image dialog) add a shadow to the image.

Cropping images

When you are only interested in a section of the image for the purpose of your document, you may wish to crop (cut off) parts of it. Writer provides two ways to crop an image: the Crop tool and the Crop tab of the Image dialog. The Crop tool provides a quick and easy way to crop an image; but for more control, use the Image dialog.

Note

If you crop an image in Writer, the image itself is not changed. Writer hides, not cuts off, part of the image. If you export the document to HTML, the original image is exported, not the cropped image. For exporting individual cropped images, see “Exporting (saving) images” on page 299.

Using the Crop tool

To use the Crop tool, right-click the image and select Crop in the context menu. Cropping handles appear at the corners and mid-points of the sides of the image (Figure 261). Drag a handle to cut off part of the image. Click outside the image to turn off cropping mode.

Figure 261: Cropping handles on an image

Using the Crop tab of the Image dialog

To crop an image using the Image dialog, right-click the image and select Properties in the context menu, then select the Crop tab of the Image dialog (Figure 262).

The units of measurement shown on the Crop tab are those set in Tools > Options > LibreOffice Writer > General.

Two options are available in the Crop section. Keep scale maintains the proportions of the image; Keep image size may result in distortion of the image.

As the values for Left, Right, Top, and Bottom are altered, the boundaries of the image in the preview box change to show the crop area on the image, and the Width and Height fields under either Scale or Image size change. This results in either an image size change (Figure 262) or a scale change for a fixed image size (Figure 263).

The original image size is indicated to the left of the Original Size button.
Resizing an image

To fit the image into the document, you may have to resize it.

A quick and easy way to resize is by dragging the image’s sizing handles:

1) Click the image, if necessary, to show the sizing handles.
2) Position the mouse pointer over one of the sizing handles. The pointer changes shape, giving a graphical representation of the direction of the resizing.
3) Click and drag to resize the image.
4) Release the mouse button when satisfied with the new size.
Tip

The corner handles resize both the width and the height of the image simultaneously, while the other four handles resize only one dimension at a time. To retain the original proportions of the image, hold down the `Shift` key while dragging one of these handles.

For more accurate resizing of images, use either the `Crop` tab (Figure 262) or the `Position and Size` tab (Figure 264) of the Image dialog.

On the `Crop` tab you can adjust the following settings:

- Scale Width and Height: specify in percentages the scaling of the image. The size of the image changes accordingly. For a symmetrical resizing, both values need to be identical.
- Image size: specify the size of the image in your preferred unit of measurement. The image enlarges or shrinks accordingly.
- Original size button: when clicked, restores the image to its original size. This will be the size resulting after any cropping was carried out.

On the `Position and Size` tab of the Image dialog (Figure 264), in the `Size` section, toggle the `Relative to` option to switch between percentage and actual dimension. For a symmetrical resizing, select the `Keep ratio` option. Clicking on the `Original Size` button restores the original image size, but the scale dimensions are altered if the image has been cropped.

![Figure 264: Resizing by specifying a size on the Position and Size tab](image)

Rotating or flipping an image

To quickly rotate an image 90 or 180 degrees, or flip it vertically or horizontally, right-click the image and select **Rotate or Flip** in the context menu, then choose the desired result.

To rotate images at any required angle, use either of these methods:

- **Interactively.** Select the image and click the **Rotate** icon on the Image toolbar or right-click and select **Rotate or Flip > Rotate**. Rotation handles appear around the object. Hover the mouse pointer over a handle; when the pointer changes shape, click and drag it to the required angle. This method is quick and easy, but not precise.

- **Using the Image dialog.** For precise rotation angles, right-click the image and select **Properties**. On the Image dialog (Figure 266), select the **Rotation** tab. In the Rotation Angle section, specify the rotation required in the **Angle** field.
Image dialog options
The Image dialog has ten tabs, summarized here. For more information, refer to the Help.

- **Crop**: described on page 295 (Figures 262 and 263).
- **Position and Size** (Figure 254) and **Wrap** (Figure 255): explained in “Positioning images within the text” on page 285.
- **Rotation** (Figure 266): flip or rotate the image, and display the original location of the file in case the image is linked rather than embedded.
- **Options** (Figure 267): give the image a descriptive name (to appear in the Navigator) and provide accessibility information including the text alternative and description to display when the cursor hovers over the image in a screen reader or web browser, protect some of the image settings from accidental changes, and prevent the image from being printed. If the image is decorative, such as a logo or colored shape, select the **Decorative** option; the Text Alternative and Description fields become unavailable.
- **Borders**: create borders around the image. The Borders dialog is the same as the one used for defining table or paragraph borders; see Chapter 4, Formatting Text. You can also add a shadow to the image.
• **Area:** change the background color of the image. This setting produces the desired results only for images with transparency. See Chapter 4, Formatting Text.

• **Hyperlink:** associate a hyperlink to the image, or create an image map (see page 303).

• **Transparency:** set the transparency options for the image.

• **Macro:** associate a macro to the image. You can choose among the predefined macros or write your own.

![Image dialog, Options tab](image.png)

*Figure 267: Image dialog, Options tab*

### Deleting an image

To delete an image, click it to show the resizing handles, then press the *Delete* key.

### Exporting (saving) images

To make complex adjustments to the image in another program, or to save an image for use in another document, you can export it directly from the document. Right-click the image and choose **Save** in the context menu to open the Image Export dialog. Writer will let you save the image in several formats. Name the image, select the desired image format in the File type list, and click **Save**.

Before the image is saved another dialog opens, where you can choose various image size and format options. The content of this dialog depends on the output file type selected. If the image has been modified within Writer, you will see a confirmation dialog where you can choose to save the original version or the modified version of the image.

### Compressing images

If you insert a large image in a document and resize it to fit into the layout of the page, the complete original image is stored in the document file to preserve its content, possibly resulting in a large document file to store or send by email.

If you can accept some loss of quality of the image rendering, you can compress or resize the image object to reduce its data volume while preserving its display in the page layout. You probably do not want to compress something that will be professionally printed.
Right-click to select the image and open the context menu. Then choose **Compress** to open the Compress Image dialog (Figure 268). Use the **Calculate New Size** button to update the image information on the dialog on each parameter set you change.

Click **OK** to apply the compression settings. If the resulting image is not acceptable, press \(Ctrl+Z\) to undo and choose another compression setting. For more information, see the Help.

![Compress Image dialog](image)

*Figure 268: Compressing an image*

**Using Writer’s drawing tools**

You can use Writer’s drawing tools to create graphics such as simple diagrams using rectangles, circles, lines, text, and other predefined shapes. You can also group several drawing objects to make sure they maintain their relative position and proportion.

You can place the drawing objects directly on a page in the document or insert them into a frame.

You can also use the drawing tools to annotate photographs, screen captures, or other illustrations produced by other programs, but this is not recommended because:

- You cannot include images in a group with drawing objects, so they may get out of alignment in your document.
- If you convert a Writer document to another format, such as HTML, the drawing objects and the images will not remain associated; they are saved separately.

In general, if you need to create complex drawings, it is recommended you use LibreOffice Draw, which includes many more features such as layers and styles.

**Creating drawing objects**

To begin using the drawing tools, display the Drawing toolbar (Figure 269) by clicking **View > Toolbars > Drawing** or by clicking on the **Show Draw Functions** icon on the standard toolbar.

The Drawing toolbar may appear at the bottom or left side of the workspace. You can move it to another location and dock it, or float it and move it to a convenient place on the screen.
To use a drawing tool:

1) Click in the document where you want the drawing to be anchored. You can change the anchor later, if necessary.

2) Select the tool on the Drawing toolbar (Figure 269). The cursor changes to a drawing-functions pointer and the normal Formatting toolbar changes to the Drawing Object Properties toolbar (Figure 270).

3) Move the cross-hair pointer to the place in the document where you want the image to appear and then click-and-drag to create the drawing object. Release the mouse button. The selected drawing function remains active, so that you can draw another object of the same type.

4) To cancel the selected drawing function, press the Esc key or click the Select icon (the arrow) on the Drawing toolbar.

5) You can now change the properties (fill color, line type and weight, anchoring, and others) of the drawing object using either the Drawing Object Properties toolbar (Figure 270) or the choices and dialogs reached by right-clicking on the drawing object.
Setting or changing properties for drawing objects

To set the properties for a drawing object before you draw it:

1) On the Drawing toolbar (Figure 269), click the Select tool.
2) On the Drawing Object Properties toolbar (Figure 270), click the icon for each property and select the value you want for that property.
3) For more control, or to define new attributes, you can click the Area or Line icons on the toolbar to display detailed dialogs.

The default you set applies to the current document and session. It is not retained when you close the document or close Writer, and it does not apply to any other document you open. The defaults apply to all the drawing objects except text objects.

To change the properties for an existing drawing object, select the object, then continue as described above.

You can also specify the position and size, rotation, and slant and corner radius properties of the drawing object: right-click the drawing object and select Position and Size in the context menu. Choose any properties, as required.

Resizing a drawing object

To resize a drawing object, select the object, click one of the eight handles around it and drag it to its new size. The object will be scaled up or down.

When you grab an edge or corner handle of an object and drag it, LibreOffice will not keep the object’s proportions. If you also press the Shift key, the resizing will keep object proportions.

For more accurate control of the size of the object, right-click on the object and choose Position and Size in the context menu, or choose Format > Text Box and Shape > Position and Size on the Menu bar. Use the Position and Size tab to set the dimensions independently. If the Keep ratio option is selected, then the two dimensions change so that the proportion is maintained, resulting in a scaled resizing.

Grouping drawing objects

Grouping drawing objects makes it easier to handle several objects as a single entity, while preserving their relative sizes and positions. When objects are grouped, any editing operations carried out on that group are applied to all members of the group. If you click on one member of the group, the whole group is selected.

To group drawing objects:

1) Select one object, then hold down the Shift key and select the others you want to include in the group. The bounding box expands to include all the selected objects.
2) With the objects selected, hover the mouse pointer over one of the objects and choose Format > Group > Group on the Menu bar, or click the Group icon on the Drawing Object Properties toolbar, or right-click and choose Group in the context menu.

Note

You cannot include an embedded or linked image in a group with drawing objects.

You can edit an individual member of a group without ungrouping or breaking the group. Select the group and then choose Format > Group > Enter Group on the Menu bar, or click the Enter Group icon on the Drawing Object Properties toolbar, or right-click and select Enter Group in the context menu.
When you have finished editing an individual member of a group, choose Format > Group > Exit Group on the Menu bar, or click the Exit Group icon on the Drawing Object Properties toolbar, or right-click and select Exit Group in the context menu.

To ungroup or break apart a group of objects, select the group and then choose Format > Group > Ungroup on the Menu bar, or click the Ungroup icon on the Drawing Object Properties toolbar, or right-click and select Ungroup in the context menu.

Rotating drawing objects

You can rotate a drawing object in a similar way to rotating images (page 297). To rotate a drawing object to any required angle, use either of these methods:

- **Interactively.** Select the drawing object and click the Rotate icon on the Drawing Object Properties toolbar. Rotation handles appear around the object. Hover the mouse pointer over a handle; when the pointer changes shape, click and drag it to the required angle.

- **Position and Size dialog.** Right-click the object and select Position and Size. On the dialog (Figure 271), select the Rotation tab. In the Rotation Angle field, specify the rotation required. By default, rotation is around the center of the object, but you can choose a different pivot point.

**Tip**

Of particular interest to Writer is the Text Box drawing object. Ordinary text can only be rotated to 90, 180, or 270 degrees, as described in Chapter 9, but a Text Box object can be rotated to any desired angle.

![Figure 271: Position and Size dialog, Rotation tab](image)

Creating an image map

An image map defines areas of an image (called hotspots) with hyperlinks to web addresses, other files on the computer, or parts of the same document. Hotspots are the graphic equivalent of text hyperlinks. Clicking on a hotspot causes LibreOffice to open the linked page in the appropriate program (for example, the default browser for an HTML page; LibreOffice Calc for a ODS file; a PDF viewer for a PDF). You can create hotspots of various shapes and include several hotspots in the same image.
To use the ImageMap Editor (Figure 272):

1) In the Writer document, select the image in which you want to define the hotspots.
2) Choose Tools > ImageMap on the Menu bar. The ImageMap Editor (Figure 272) opens.
3) Use the tools and fields in the dialog (described below) to define the hotspots and links.
4) Click the Apply icon to apply the settings.
4) When done, click the Save icon to save the image map to a file, then close the dialog.

The main part of the dialog shows the image on which the hotspots are defined. A hotspot is identified by a line indicating its shape.

The toolbar at the top of the dialog contains the following tools:

- **Apply**: applies the changes.
- **Open**, **Save**, **Close**, and **Select**.
- **Rectangle**, **Ellipse**, **Polygon**, and **Freeform Polygon**: tools for drawing a hotspot shape. These tools work in the same way as the tools in the Drawing toolbar.
- **Edit**, **Move**, **Insert**, **Delete Points**: advanced editing tools to manipulate the shape of a polygon hotspot. Select the **Edit Points** tool to activate the other tools.
- **Undo** and **Redo**: cancels the previous action or reapplies the previous canceled action.
- **Active**: toggles the status of a selected hotspot between active and inactive.
- **Macro**: associates a macro with the hotspot instead of just associating a hyperlink.
- **Properties**: sets the hyperlink properties and adds the Name attribute to the hyperlink.

Figure 272: The dialog to create or edit an image map
Below the toolbar, specify for the selected hotspot:

- **Address**: the address pointed to by the hyperlink. You can also point to an anchor in a document; to do this, write the address in this format:
  
  `file:///<path>/document_name#anchor_name`

- **Text alternative**: type the text that you want to be displayed when the mouse pointer is moved over the hotspot.

- **Frame**: where the target of the hyperlink will open: pick among `_blank` (opens in a new browser window), `_self` (opens in the active browser window), `_top` or `_parent`.

**Tip**

The value `_self` for the target frame will work in the vast majority of occasions. It is therefore not recommended to use the other choices unless absolutely necessary.

---

**Managing the LibreOffice Gallery**

By default, the Gallery is opened in the Sidebar. You can let the Gallery float as you can other Sidebar decks. You can display the Gallery in Icon View (Figure 250) or Detailed View (Figure 273), and you can hide or show the Gallery by clicking on the Sidebar’s **Hide** button.

![Figure 273: Gallery in Detailed View](image)

Graphics in the Gallery are grouped by themes, such as Arrows, Diagrams, and People. You can create other groups or themes and add your own images or find extensions containing more graphics. Click a theme to see its contents displayed in the Gallery window.
Adding a new theme to the Gallery

You may wish to add your own theme to the Gallery to hold any images or other objects that you use frequently, for example, a company logo. Or you may wish to add several themes, each holding images for a specific project.

To add a new theme to the Gallery:

1) Click the New button below the list of themes (Figure 273).
2) In the Properties of New Theme dialog, click the General tab and type a name for the new theme.
3) Click the Files tab and add images to the theme, as described below.

Tip

You can also get more gallery themes from the LibreOffice extensions website at https://extensions.libreoffice.org/, including themes from previous versions of LibreOffice that are no longer installed with the program. Themes in extensions install automatically.

Adding objects to the Gallery

To add objects to a theme that you have created:

1) Right-click the name of the theme and select Properties in the context menu.
2) In the theme’s Properties dialog, click the Files tab (Figure 274).

To add several files at once:

1) In the Properties dialog, click the Find Files button.
2) The Select Path dialog (not shown) opens. You can enter the path for the file’s directory in the Path text box, or you can navigate to locate the file’s directory.
3) Click the Select button to start the search. A list of files is then displayed in the Properties dialog. You can use the file type drop-down list to limit the files displayed.
4) To add all of the files shown in the list, click Add All. Otherwise, select the files to add and then click Add (hold down either the Shift key or the Ctrl key while clicking on the files).
To add a single file:

1) In the Properties dialog, click Add to open the Gallery dialog (a file browser).
2) Use the navigation controls to locate the image to add to the theme. Select it and then click Open to add it to the theme.
3) Click OK on the Properties dialog to close it.

**Deleting images and themes from the Gallery**

To delete an image from a theme, right-click on the name of the image file or its thumbnail in the Gallery, then click Delete in the context menu. A message appears, asking if you want to delete this object. Click Yes.

**Note**

Deleting the name of a file from the list in the Gallery does not delete the file from the hard disk or other location.

To delete a theme from the Gallery, select it from the list of themes, right-click, then click Delete in the context menu. You cannot delete a theme supplied with LibreOffice.

**Location of the Gallery and the objects in it**

Graphics and other objects shown in the Gallery can be located anywhere on your computer’s hard disk, on a network drive, or other removable media. When you add graphics to the Gallery, the files are not moved or copied; the location of each new object is simply added as a reference.

In a workgroup, you may have access to a shared Gallery (where you cannot change the contents unless authorized to do so) and a user Gallery, where you can add, change, or delete objects.

The location of the user Gallery is specified in Tools > Options > LibreOffice > Paths. You can change this location, and you can copy your gallery files (SDV) to other computers. Gallery contents provided with LibreOffice are stored in a different location, which cannot be changed.

**Note**

The locations of Gallery themes distributed through LibreOffice extensions are determined by the extensions’ settings.

**Using Fontwork**

With Fontwork you can create graphical text art objects to make your work more attractive. There are many different settings for text art objects (line, area, position, size, and more), so you have a large choice.

**Creating a Fontwork object**

1) On the Fontwork toolbar (View > Toolbars > Fontwork) or the Drawing toolbar (View > Toolbars > Drawing), click the Insert Fontwork Text icon, or choose Insert > Fontwork on the Menu bar.

2) In the Fontwork Gallery dialog (Figure 275), select a Fontwork style (scroll down to see more choices), then click OK.
3) The Fontwork object will appear in the document. Notice the squares around the edge (indicating that the object is selected) and the differently colored dot; these are discussed in “Moving and resizing Fontwork objects” on page 310.

4) Resize the object using one of the corner handles (hold down the Shift key to keep the sides proportional), or right-click and choose Position and Size in the context menu for more precise sizing.

5) Double-click the object to edit the Fontwork text (Figure 276). Type your own text in place of the black text that appears over the object.

6) Click anywhere in a free space or press Esc to apply the changes.

**Editing a Fontwork object**

Now that the Fontwork object is created, you can edit some of its attributes. To do this, you can use the Fontwork toolbar, the Fontwork panel on the Properties deck in the Sidebar, the Formatting toolbar, or menu options as described in this section. If the selected Fontwork object is a 3D object, you can also use the 3D-Settings toolbar.
Using the Fontwork toolbar

Make sure that the Fontwork toolbar (Figure 277) is visible. If you do not see it, go to View > Toolbars > Fontwork. Click the icons to edit Fontwork objects. Icons 2–6 also appear in the Fontwork panel on the Properties deck in the Sidebar.

![Fontwork toolbar](image)

Figure 277: The floating Fontwork toolbar

1) **Fontwork Gallery**: Opens the Fontwork Gallery (Figure 275).
2) **Fontwork Shape**: Edits the shape of the selected object. You can choose from a palette of shapes.

![Fontwork Shapes](image)

Figure 278: Fontwork Shapes

3) **Fontwork Same Letter Heights**: Changes the height of characters in the object. Toggles between normal height (some characters taller than others, for example capital letters, d, h, l and others) and all letters the same height.

![Normal and same letter heights](image)

Figure 279: Left: normal letters; right: same letter heights

4) **Fontwork Alignment**: Changes the alignment of characters. Choices are Align Left, Center, Align Right, and Stretch Justify. The effects of the text alignment can only be seen if the text spans over two or more lines. Stretch Justify fills all the lines completely.

![Fontwork Alignment](image)

Figure 280: Fontwork Alignment
5) **Fontwork Character Spacing**: Changes the character spacing and kerning in the object. Choices are *Very Tight, Tight, Normal, Loose, Very Loose*, and *Custom...*, which opens a small dialog where you can specify a percentage.

![Fontwork Character Spacing](image)

*Figure 281: Fontwork Character Spacing*

6) **Toggle Extrusion**: changes a 2D Fontwork object into a 3D object or a 3D object into a 2D object.

**Using the Formatting toolbar**
You can customize the Fontwork object with several more attributes. Click on the object; the Formatting toolbar changes to show the options for customizing the object. These choices are the same as the ones for other drawing objects, described earlier in this chapter. See also the *Draw Guide* for details.

**Using menu options**
You can use some of the choices in the Format menu to anchor, align, arrange, and group selected Fontwork objects, wrap text around them, and flip them horizontally and vertically.

You can also right-click a Fontwork object and choose many of the same options in the context menu. The context menu also provides quick access to the Line, Area, and Position and Size dialogs. On the Position and Size dialog, you can enter precise values for size and position. For more information on all of these menu options, see the *Draw Guide*.

**Using the 3D-Settings toolbar**
If the selected Fontwork object is a 3D object, you can also use the options on the 3D-Settings toolbar. You can also change a 2D Fontwork object into a 3D object (or change a 3D object into a 2D object) by clicking the **Toggle Extrusion** icon on the Fontwork toolbar. For more information, see the *Draw Guide*.

**Moving and resizing Fontwork objects**
When you select a Fontwork object, eight squares (known as handles) appear around the edge of the object, as shown below. You can drag these handles to resize the object.

A dark or colored dot also appears on the object. This dot may be in the same place as a handle, or it may be somewhere else. If you hover the cursor over this dot, the cursor changes shape. You can drag the dot in different directions to distort the object.

Hovering the mouse pointer over other parts of the object turns the pointer into the usual symbol for dragging the object to another part of the page.

For precise control of the location and size of the object, and to rotate the object, use the Position and Size dialog (Figure 271 on page 303).
Figure 282: Handles and distortion dot on Fontwork object
Chapter 12, Lists
Introduction

This chapter expands on information given in Chapter 9, Working with Styles, and provides some extra examples.

In many word processors, list options are included in paragraph styles, but Writer treats them as a separate type of style that can be linked to paragraph styles for use.

Writer’s separate list styles have two major advantages:

- The same list style can be used with multiple paragraph styles, avoiding duplication of design work.
- A paragraph’s associated list style can be changed with a single selection.

Tip

You cannot change the style used by the default toolbar and sidebar icons for lists. You can create new toolbar buttons that apply list styles to paragraphs, but a better strategy is to create paragraph styles for lists and, if you wish, create toolbar icons and/or items on the Styles menu for them. See Chapter 20, Customizing Writer, for information on creating toolbar buttons and menu items.

Types of list

With list styles, you can create three types of list:

- Unordered (bullet) lists: List items start with a bullet, special character, or graphic.
- Ordered (numbered) lists: List items start with a number, upper or lower case letter, or upper or lower case Roman numeral.
- Outline lists: Hierarchical summaries of an argument or piece of writing, in which each level has its own numbering system.

Unordered (bullet) lists

Unordered lists are popular in technical documents, presentations, many web sites, and other online documents. They are used when the order of the points is irrelevant or not important.

Writer provides several pre-defined bullet styles for unordered lists (Figure 283), and you can select others in the Gallery or create your own bullets.

![Figure 283: Writer’s pre-defined bullet types](image)
Tip

Unordered list styles can be used for other purposes in addition to normal lists, especially if you choose a graphic for the bullet. See “Example: Styling the Tips, Notes, and Cautions in this book” on page 329.

Ordered (numbered) lists

Ordered lists should only be used when the order of the information matters. For instance, in a procedure from a technical manual, one step might be impossible – or even dangerous – without doing another one first.

Each step can have multiple paragraphs, most of them unordered, describing what happens when it is performed or the alternatives.

If each step has multiple paragraphs or you have more than about a dozen steps, you may need to divide the list into smaller lists or use nested lists (see “Nesting lists” on page 319).

Writer provides several pre-defined ordered list styles (Figure 284), and you can define others.

Outline lists

Outline lists summarize the structure of a much longer, typically unwritten document. In finished technical and legal documents, they are used in headings to make the structure obvious, although this use is becoming less common than it was a few decades ago.

Writer gives several options for outline lists (Figure 285). List styles create an outline method that uses a single paragraph style. When such a paragraph style is in use, you change the level and the numbering by pressing the Tab key to go down a level, and Shift+Tab to go up a level. This single style outlining is the fastest to apply.

Figure 284: Writer’s pre-defined numbered lists

Figure 285: Writer’s pre-defined outline list styles
Many writers use outline lists when writing a document and then, before publication, remove the letters and numbers of the outline by changing or removing the numbering style associated with the paragraph style.

The conventions for outline lists are:

- Usually, a different numbering system is used for each level to help distinguish them.
- Levels can be ordered using Arabic numerals, upper and lower case Roman numerals, and upper and lower case letters.
- Upper case Roman numerals are usually reserved for the top level, and upper case letters are used before lower case ones. Another alternative is Arabic numbers followed by lower case letters. However, these rules are not fixed.
- In technical manuals, multiple levels used to be common in headings (for instance, I.A.2 or 1.1.1). This style has largely fallen out of practice except in a few specialized cases such as legal documents, for the obvious reason that they are hard to remember. Also, if each heading is indented, after two or three levels almost no space is left for text.

### Combining list and paragraph styles

Paragraph styles are essential to lists and outlining. When applying a list style, the underlying paragraph style remains unchanged. If the list must also have a certain font size, indentations, and so on, you might expect to first apply a paragraph style and then a list style (or the other way around). However, you can embed a list style in a paragraph style using the Outline & List tab of the Paragraph Style dialog, and then apply only the paragraph style to the list.

This section gives an example of combining list and paragraph styles:

1. Create a list style you want to use for the paragraph. For example: MyNumberedList.
2. Create a new paragraph style.
3. On the Organizer tab of the Paragraph Style dialog:
   a) Give the new paragraph style a name, say NumberedParagraph.
   b) For the Next Style, choose NumberedParagraph (this will make the following paragraph also be in this style, until you choose a different style).
   c) In Inherited from, choose None.
4. Set up this paragraph style to your liking. Because the indentation is controlled by the List style, to avoid undesired interactions do not change the indent settings on the Indents & Spacing tab. (You might want to change the spacing above and below the paragraph.)
5. On the Outline & List tab (Figure 286), choose the MyNumberedList style created in step 1 in the Numbering style list.
6. Click OK to save this style.

To have full control, it is common practice in publishing to define three base paragraph styles for lists: List Start for the first element of the list, List Continue for the subsequent elements of the list, and List End for the last element of the list. However, for many purposes, one paragraph style does the job.

You could also define a paragraph style to be used for unordered list items (one for each nested level you intend to use) as well as an introductory style for the paragraph preceding the start of the list, to allow for keeping the introductory paragraph with the first list item or for specifying spacing before the first list item that is different from the spacing between other paragraphs.
Nesting lists

A nested list – a list within a list – is an ordered or unordered list with subordinate (usually indented) ordered or unordered lists. Rather than being just a list of numbered items (1, 2, 3...), a nested list may have item 1, then indented items numbered a, b, c or i, ii, iii or some other numbering or bulleted method before the main number 2. With list styles, you can achieve any combination of list formats you want. A nested list may even combine ordered items with unordered items (Figure 287).

To nest a list, you have two choices. The first is to create a list style, and set up two or more list levels with different formatting choices on the Position and Customize tabs. The advantage of list levels is that each level can be formatted separately, but all the levels remain connected. The preview pane can help you set up each list level.

The customized list style is associated with a paragraph style for use. To switch to a lower list level while using the associated paragraph style, press the Tab key before entering content; to switch to a higher list level, press Shift+Tab.

The second choice is to create two list styles, then associate each list style with a separate paragraph style.

Neither choice has any advantage over the other, since you are still dealing with the same options. However, in both cases, each nested list is typically indented more than the list level above it. Typically, each list level will use a different bullet style or numbering system.
Style names like *Bulleted* and *Bulleted 2* or *Nested* will help to remind you of the relation between the two paragraph styles. For convenience, use the same names for both the paragraph and list styles, since they cannot be mixed up.

**Outlining with paragraph styles**

LibreOffice has several ways to outline using paragraph styles. With **Tools > Heading Numbering**, you can choose a numbering style for each paragraph style, making it part of the outline levels. Alternatively, you can associate each Heading style with a separate list style using the Styles deck on the Sidebar.

An easier form of outlining is to create a single list style for outlining. You can manually set up the different levels on the list style’s *Customize* tab, or you can get much the same result by selecting a pre-defined pattern from the list style’s *Outline* tab instead.

To use the paragraph style, press *Enter+Tab* to add a sub-level paragraph. The sub-level paragraph automatically uses the numbering pattern of the list style. To raise the level of a paragraph style, press *Enter+Shift+Tab*.

**Creating outlines with a single paragraph style**

To set up a single paragraph style for outlining:

1. Create a list style and associate it with one of the pre-defined formats on the *Outline* tab.
2. Select or make a paragraph style for outlining. You cannot use the *Heading 1-10* styles. Presumably, this restriction prevents confusion between a single paragraph style outline and the registered outline levels (see next section).
3. On the *Organizer* tab of the paragraph style, set the style to use itself as the *Next style*.
4. Assign the list style to the paragraph style using the *Numbering* field on the paragraph style’s *Outline & List* tab.

**Adding paragraph styles to outline levels**

Outline levels are a concept used throughout LibreOffice to automate advanced features. For example, outline levels determine which paragraph styles are displayed by default in the Navigator under *Headings*, and in a table of contents.

By default, outline levels are mapped to the *Heading 1–10* paragraph styles. *Outline Level 1* is mapped to *Heading 1*, and so on. You can change these mappings, or add another paragraph style to an outline level in the *Outline level* field on the *Outline & List* tab (Figure 288).

![Figure 288: Assigning a paragraph style to an outline level](image-url)
Tip

You can assign more than one paragraph style to an outline level, but only one paragraph style displays in Tools > Heading Numbering.

Applying list styles

List styles define properties such as indentation, numbering style (for example, 1, 2, 3; a, b, c; or bullets), and punctuation after the number, but they do not by themselves define properties such as font, borders, text flow, and so on. The latter are properties of paragraph styles.

Although you can apply list styles using the Styles menu on the Menu bar or the Styles deck on the Sidebar, those methods are not recommended.

Whenever possible, use paragraph styles for creating lists. Writer comes with two sets of paragraph styles for this purpose. It is recommended to use list styles and paragraph styles together in these ways:

- Use paragraph styles List 1, List 2, List 3, and so on for creating unordered lists. These styles use Bullet styles.
- Use paragraph styles Numbering 1, Numbering 2, Numbering 3, etc, for creating ordered lists. These styles use the list styles Numbering 1, Numbering 2, and so on.

Writer has several predefined list styles, which use different bullet symbols or number sequences (123, abc, ABC, and so on). As with any style, you can redefine the properties of these styles, for example the numbering or bullet symbol and the indentation. You can also define other list styles in these series or create your own series.

List styles can have up to ten levels, used for nested lists. To switch from one level to another, use the Promote Outline Level or Demote Outline Level icons on the Bullets and Numbering toolbar, or press the Tab key (one level down) or Shift+Tab keys (one level up), or right-click on the list element and select List > Promote Outline Level or Demote Outline Level.

Restarting or continuing the numbering

When creating more than one ordered list of the same type within a document, Writer applies sequential numbering to all the lists. Sometimes this is what you want (for example, when placing illustrations between the ordered paragraphs); at other times you want to restart the numbering.

To restart the numbering of any ordered list, right-click the paragraph and select List > Restart Numbering in the context menu or use the Restart numbering at this paragraph option in the Apply List Style section on the Paragraph dialog (Figure 289).

![Figure 289: Restarting list numbering](image_url)
When editing a document, you may want to change from restarting numbering to continuing the numbering from a previous list. To do so, right-click on the list element and choose List > Add to List in the context menu.

**Naming list styles**

LibreOffice provides several default styles for unordered and ordered lists. You can modify these styles, and you can add your own list styles and give them descriptive names like *Arabic Numeral Blue* or *Lower Case Indented*.

**Tip**

Using the same name for both the list style and the paragraph style with which it is linked can make working with different types of styles much easier. If you use a character style to define the bullet or number, give it the same name, too.

![Diagram](image)

*Figure 290: Give related styles similar names and you can locate the ones you need more quickly*

**Formatting list styles**

Bullets and numbers in list styles can be formatted in two ways.

The quick way is to select a list style from the *Unordered*, *Ordered*, *Outline*, or *Image* tabs of the List Style dialog (Figure 291). Each of these tabs give a variety of options, although not an exhaustive selection. The choices on the *Image* tab may look old-fashioned, but they can be useful; see “Example: Styling the Tips, Notes, and Cautions in this book” on page 329.

The second way is to customize unordered or ordered lists, using the *Customize* and *Position* tabs on the List Style dialog. Both tabs have ten levels. These settings are mostly useful for creating a single outline numbering style, in which the numbering changes each time you press the *Tab* key (see “Outline lists” on page 317). For most unordered and ordered lists, either set the *Level* to 1, or leave the *Level* at the default 1-10.

**Positioning bullets, numbers, and list items**

The *Position* tab of the List Style dialog (Figure 291) sets up the spacing before bullets or numbers, and between the bullet or number and the text.

When a list style is linked to a paragraph style, editing the fields on the *Position* tab in the List Style dialog results in changes to the *Indent > Before text* and *Indent > First line* settings on the *Indents & Spacing* tab for the paragraph style. To avoid complications, make all the changes on the *Position* tab for the list style, not the paragraph style.
Understanding position fields

When defining a new list style, the important fields on the Position tab are:

- **Aligned at:** The vertical position for numbers, measured from the left margin. In most cases, you can leave this field at 0 (at the left margin). However, if you use any Numbering alignment except Left, numbers set this field to another value.

- **Numbering alignment:** How the bullet or number is aligned. Most of the time, you can leave this field at the default of Left, but if you are having trouble positioning text, changing the alignment to Center or Right can sometimes solve the problem, especially for lists or levels that require two-digit numbers.
- **Numbering followed by:** Sets the space between the number or bullet and the text. Although the choices include *space* or *nothing*, the choice that offers the most control is *Tab stop at*. Set the exact tab in the Tab stop at field directly below the drop-down list.

- **Indent at:** Sets the start of the text. This setting should be equal or greater to the tab stop set for *Numbering followed by*.

![Figure 293: The dotted line is the margin in this example. If the value of the Numbering Alignment is 0, then choosing Center or Right can force the numbers into the left margin.](image)

### Formatting ordered lists

To create an ordered list, select a numbering style from the *Number* field on the Customize tab (Figure 294). The selections in the drop-down list begin with typical choices for Western European languages: Arabic, upper and lower case letters, and upper and lower case Roman numerals. Scroll down, and options for Bulgarian, Russian, Serbian, and Greek are available.

![Figure 294: Select a numbering style from the Customize tab](image)

### Adding characters before and after numbers

You can set up to 40 characters before or after the number using the *Before* and *After* fields. These characters are added automatically whenever the list style is applied.

Common characters after a number might be a period or a parenthesis. Alternatively, you might put a parenthesis both before or after the number, or text such as *Step* in the *Before* field.
In a numbered list, you can choose the number of outline levels in the list by adjusting the *Show sublevels* field. For example, if you decided to show three sublevels, the first use of the third sublevel would be numbered 1.1.1.

**Note**

Using the *Before, After, and/or Show sublevels* fields means that the settings on the *Position* tab need to be adjusted so there is enough space between the number and the text.

**Setting the character style**

By default, the *Character Style* field for numbered lists is set to the *Numbering Symbols* character style, and for bulleted lists to the *Bullets* character style.

For most purposes, you probably have no reason to change these defaults. Unless modified, these character styles use the same font and font size as the default character style of the list paragraph, and they apply to both the number and any text in the *Before* or *After* fields.

Common modifications include making the numbers or bullets larger, giving them a corporate color, making them bold, or using a condensed version of a font.

**Note**

You may need to change the text indent if you use a larger font, especially for two- or three-digit numbers. The line height may also need to be increased.

**Example: Formatting large list numbers**

To have the numbers in a larger or different font, or a different color, from the text of the list, follow these steps:

1) Create a new *character style* for the numbers, or modify an existing character style. For this example, the new style is named *Numbers Large*.
   On the *Font* tab of the Character Style dialog for *Numbers Large*, increase the font size. To change the color of the number, go to the *Font Effects* tab. Click **OK** to save the new or modified character style.

2) Create a new *list style*, or modify an existing list style. On the *Customize* tab of the List Style dialog (Figure 295), choose the character style you created or modified. For this example, choose *Numbers Large*. Click **OK** to save the style.

3) Create a new *paragraph style*, or modify an existing paragraph style. On the *Outline & List* tab of the Paragraph Style dialog, choose the list style you created or modified.

4) Apply the paragraph style in the usual way to the items of the list.

**Caution**

If you modify an existing character, list, or paragraph style, the changes will affect all lists in the document that use those styles.
Working with two-digit list numbers

Numbers with two digits can displace list items (Figure 296). You can correct this problem in several ways:

- Add extra space between the number and the list item using the Indent at field on the Position tab of the dialog. Do not add so much space that the association between numbers and list items is lost.
- Adjust the size of the numbers using the Character Style field on the Customize tab.
- Set the Numbering Alignment to Right. Watch that this change does not extend numbers into the left margin.

9. Lorem ipsum dolor sit amet, consectetur adipiscing elit.
10. Fusce molestie, nisl eu suscipit imperdiet. nibh orci sodales erat, in scelerisque justo lacus vitae leo

Figure 296: Unless extra spacing is provided, the list items are displaced when the numbering enters two digits.

Tip

People occasionally ask for numbered lists that count down from the starting number, instead of up, presumably for Top 10 lists and other countdowns. Unfortunately, LibreOffice will not automatically generate numbers for reverse order in lists. A reverse order list must be entered manually.
Formatting unordered lists

The default character style for unordered lists provides a standard bullet symbol for the Default Paragraph Style. You can change the character style from Numbering Symbols to Bullets or any other style defined in the document. To change the bullet symbol, click the Select button by the Character field on the Customize tab (Figure 297). The Special Characters dialog opens. Choose any symbol supported by the current font.

Tip

When you use an unusual character style for bullets, be sure to embed the font used when you share a file.

If your design includes nested bullet lists – that is, bullet lists within bullet lists – you might want to create an additional list style with a name like Bullets2.

However, if you do use more than one bullet list style, make sure their designs are compatible. In fact, indenting the nested bullets and nothing more is usually enough to distinguish them from the top level bullets.

Example: Making a checklist

Depending on the characters you choose, unordered list styles can serve as more than bullet lists. For example, an unordered list can be made into a checklist by selecting the font or character used for the bullet.

Figure 298: Three bullet styles for checklists

If you want a checklist to be used with a pen, set up the list style in the usual way, using a character style that uses the OpenSymbol font that ships with LibreOffice, and assign the character U+E00B (a shaded open box) as the bullet (that is two zeros, not lower case “o”s). Print the list, and it is immediately ready for use. Add some corporate branding and letterhead, and the To Do list can be used in business.

If you want to use the list on the computer, create two list styles, one that uses the character U+2752, and one that uses the character U+E531 (a box with a check mark). Create the list using the first style, then tick off an item by applying the second style to it.

Depending on the purpose of the list, you can also create a third list style that uses the character U+E532 (an X mark) to indicate items that were not completed.
Using images as bullets

Using an image instead of a standard bullet is a convenient way to add some originality to your document. However, you are limited by the small size at which most bullets display. Mostly, simple images with strong contrast work best as a substitute bullet. Often, a black and white image is most effective.

Images used for bullets are also a way to position an image on a page. In particular, they can be used to create warning signs and indications in a technical manual or an informal text.

In either case, select a graphic to use in **Customize > Number** in the dialog for the List style. Choosing *Graphics* embeds the picture within the document file. By contrast, *Linked graphics* only adds a link to the graphic. You may need to scroll up in the Number drop-down list to see these choices.

![Image of bullet options](image)

*Figure 299: The fields for using a graphic as a bullet appear after you select Graphics or Linked Graphics*

After you choose *Graphics* or *Linked graphics*, the dialog displays a set of fields for editing the bullet:

- The *Select* drop-down list has two choices for selecting an image: *Gallery*, which opens a list of bullets in the Gallery, and *From file*, which opens a file manager.
- The *Width* and *Height* fields set the size at which the image displays. They do not affect the original image file.

**Tip**

If the image is cut off, either adjust the image size or else change the line spacing to *At Least* so the top half of the characters in a line is not chopped off.

- *Keep ratio*, when selected, ensures that changing either the *Width* or *Height* field changes the other proportionally.
- *Alignment* can usually be ignored, but can help when the height of the graphic is greater than the height of the text, as in the graphics for Tips, Notes, and Cautions in the LibreOffice guides.
Example: Styling the Tips, Notes, and Cautions in this book

List styles can be used for more than lists. For example, the Tips, Notes, and Cautions in the LibreOffice guides use list styles to position the graphics and text. Here is how the Tips are created and used. The others are done in the same way, but with a different logo and text.

Step 1. Create a paragraph style for the body of a tip, note, or caution.

The body of a tip, note, or caution in this book is indented under the heading and has a line under it to set it off from the main text.

1) On the Sidebar, go to Styles > Paragraph Styles. Right-click and choose New. Name the new style Text Note.

2) On the Indents & Spacing tab (Figure 300), specify the indentation and spacing for the body of the Tip.

3) On the Borders tab (Figure 301), select a bottom border, increase the thickness, and specify the spacing between the text and the border. Choose Merge with next paragraph to cause the border to appear under only the final paragraph if the Tip includes more than one paragraph.

4) Click OK to save the paragraph style.

Figure 300: Choosing indentation and spacing for the body of the Tip

Figure 301: Defining the bottom border of the Tip body text
Step 2. Create a list style.

1) On the Sidebar, go to Styles > List Styles. Right-click and choose New. Name the new style Heading Tip.

2) On the Image tab (Figure 302), select an appropriate image. (Or, skip this step and select an image on the Customize tab.)

3) On the Customize tab (Figure 303), choose Graphics in the Number field. Optionally, click Select in the Graphics field and choose an image from a file or from the Gallery. (For the Tips, Notes, and Cautions in the LibreOffice guides, images were selected from external files.)

If the bullet image selected is too large or too small for your design, specify a width and height. You can use these fields to resize the original image.

In the Alignment field, select where you want the image to line up with the text.
4) On the **Position** tab (Figure 304), choose settings as described in “Positioning bullets, numbers, and list items” on page 322. Click **OK** to save the list style.

![Figure 304: Choosing position and spacing settings for the bullet image](image)

**Step 3.** Create a paragraph style for the **Heading Tip** and connect it to the list style.

1) In the Sidebar, go to **Styles > Paragraph Styles**. Right-click and choose **New**. Name the new style **Heading Tip**.

2) On the **Organizer** tab (Figure 305), specify the **Next Style** to be the one you created for the body of the Tip; in this case, **Text Note**.

![Figure 305: Specifying the Next style for the Heading Tip style](image)

3) Style the paragraph in the usual way, then go to the **Outline & List** tab (Figure 306). In the **List style** field, select the list style you created. Click **OK** to save the paragraph style.

![Figure 306: Connecting the list style to the paragraph style](image)
Step 4. Apply the paragraph styles to the heading and text of the Tip, Note, or Caution.

1) Type the word Tip in a new paragraph. (You must type at least one character or a space, or else the graphic disappears when you press Enter, leaving the indent but no bullet.)

2) Apply the Heading Tip paragraph style.

3) Press Enter. The next paragraph should automatically have the Text Note paragraph style. Type the text for the body of the tip. (If you have already typed the text, then apply the style manually.)

Example: Creating and using a simple list style

In this example, we will create a list that is used to number the songs on a CD. The numbers are right-aligned, and some space is left between the number and the title of the track.

As we want to reuse the same list for other CDs, we will define a new list style and a related paragraph style, then apply the paragraph style to the tracks list. (We could directly apply the list style to the items on the list, but using a paragraph style is better practice.)

Creating the CDBack-list list style

1) Select the List Styles icon on the Styles deck of the Sidebar.

2) Right-click anywhere in the list box and choose New. The List Style dialog is displayed.

3) On the Organizer tab, type CDBack-list in the Name box and leave the Category as Custom styles.

4) On the Customize tab (Figure 294), modify the options (if necessary) as follows:

   - Level: 1
   - Number: 1, 2, 3,...
   - Start at: 1
   - Character style: None
   - Show sublevels: grayed out.
   - Separator Before: and After: empty.
   - Do not select Consecutive numbering.

5) The list will adopt the settings of the underlying paragraph style. To use a special font, size, or color for the numbering symbol, create a character style and select it on the Customize tab.

6) To have the word Track appear before the number, add it to the Before field on the Customize tab. Do not forget to add a space to separate the word from the number.

7) Set up the final parameters of the CDBack-list list style on the Position tab (Figure 291):

   - Level: 1.
   - Aligned at: 1.5cm. (This refers to the alignment of the numbers.)
   - Numbering alignment: Right.
   - Numbering followed by: Tab stop.
   - Tab stop at: 4.0cm.
   - Indent at: 4.0cm. (This sets the indentation of the list.)

8) Click OK to finish.
Creating the CDTracks paragraph style

Although the list style could be directly applied to the items on the list, using a paragraph style is better practice. The new CDTracks style will be based on the Default Paragraph Style.

1) Click the Paragraph Styles icon on the Styles deck of the Sidebar. Then right-click on the Default Paragraph Style in the list box and choose New.

2) On the Organizer tab of the Paragraph Style tab, type CDTracks in the Name box and optionally set the Next style to be CDTracks.

3) On the Outline & List tab, choose CDTrack in the Numbering style drop-down list.

4) Click OK to save the new paragraph style.

Applying the CDTracks paragraph style

Now that the list style and paragraph style are available, they can be quickly applied to any list in the document.

1) When starting a new list, before pressing Enter to start a new line, double-click the desired paragraph style name in the Styles deck on the Sidebar. At the end of the list, press Enter, then double-click the paragraph style (on the Styles deck) required for the rest of the text.

2) For an existing list, select it and then double-click the required paragraph style name on the Styles deck.

![Figure 307: A numbered list of CD tracks created from the settings in this example](image)

Chapter 12, Lists | 293
Chapter 13, Tables
Introduction

Tables are a useful way to organize and present large amounts of information, for example:

- Technical, financial, or statistical reports.
- Catalogs showing descriptions, prices, characteristics, and photographs of products.
- Bills or invoices.
- Lists of names with address, age, profession, and other information.

Tables can often be used as an alternative to spreadsheets to organize materials. A well-designed table can help readers understand better what you are saying. While you would normally use tables for text or numbers, you could put other objects, such as pictures, in cells. Writer's tables provide limited spreadsheet functions; see “Using spreadsheet functions in a table” on page 357.

Tables can also be used as a page-layout tool to position text in areas of a document instead of using several Tab characters. Another example is in headers and footers to support independent positioning of different elements, such as page number, document title, and so on. This use of tables is described in Chapter 6, Formatting Pages: Advanced.

Tools for working with tables

All of the table commands described in this chapter are conveniently located under Table on the Menu bar (Figure 308) and on the Table toolbar (Figure 309). Some are also found in the context menu for a table or in the Table panel of the Properties deck in the Sidebar (Figure 310).
When you create a table or select an existing table, the Table toolbar (Figure 309) is displayed automatically. To display it at any time, click **View > Toolbars > Table**. The toolbar can float over the main Writer window, or it can be docked along any edge of the main window. See Chapter 1, Introducing Writer, for more about docking and floating toolbars, and how to hide and display specific tools on a toolbar.

![Figure 309: Table toolbar](image)

Insert rows above, Insert rows below, Insert columns before, Insert columns after, Delete selected rows, Delete selected columns, Delete table, Select Cell, Select Table, Merge Cells, Split Cells

1. Insert rows above
2. Insert rows below
3. Insert columns before
4. Insert columns after
5. Delete selected rows
6. Delete selected columns
7. Delete table
8. Select Cell
9. Select Table
10. Merge Cells
11. Split Cells
12. Split Table
13. Optimize Size
14. Align Top
15. Center Vertically
16. Align Bottom
17. Table Cell Background Color
18. AutoFormat Styles
19. Borders
20. Border Style
21. Border Color
22. Number Format: Currency
23. Number Format: Percent
24. Number Format: Decimal
25. Number Format
26. Insert Caption
27. Sort
28. Protect Cells
29. Unprotect Cells
30. Sum
31. Insert or Edit Formula
32. Table Properties

When the cursor is in a table, the Properties deck in the Sidebar (Figure 310) includes table properties.

![Figure 310: Table properties in the Sidebar](image)
Creating a table

Before creating a table in a Writer document, it helps to have an idea of the visual result wanted and an estimate of the number of rows and columns required. Every parameter can be changed at a later stage; however, thinking ahead can save time as changes to fully formatted tables often require a significant effort.

Creating a new table

To quickly create a table with the default properties, click the **Insert Table** icon on the Standard toolbar. On the drop-down graphic, choose the size of the table (up to fifteen rows and up to ten columns). To create the table, click the cell that you want to be on the last row of the last column.

To create a new table and specify the properties for the table, position the cursor where you want the table to appear, then use any of these methods to open the Insert Table dialog (Figure 312):

- Choose **Table > Insert Table** on the Menu bar.
- Press Ctrl+F12.
- On the Standard toolbar, click the **Insert Table** icon and select **More Options** at the bottom of the drop-down graphic.

In the **General** section of the Insert Table dialog, in the **Name** box, you can enter a different name from the Writer-generated default for the table. This might come in handy when using the Navigator to jump quickly to a table.

In the **Columns** and **Rows** boxes, specify the number of columns and rows for the new table. You can change the size of the table later, if necessary.
Under **Options**, set up the initial table characteristics:

- **Heading** — Enables a heading to be used in the table and defines the number of rows to be used as headings. A second (and, occasionally, third) heading row can be useful for sub-headings in a complex table.

  The default Table Heading paragraph style is applied to the heading rows. You can edit the Table Heading paragraph style to change these default settings.

- **Repeat heading rows on new pages** — Enables the heading rows to be repeated at the top of subsequent pages if the table spans more than one page.

- **Heading rows** — Specifies the number of rows to be used for the heading. Default is 1.

- **Don't split table over pages** — Prevents the table from spanning more than one page.

  This can be useful if the table starts near the end of a page, and would look better if it were completely located on the following page. If the table starts earlier on the page but does not all fit, this setting can lead to awkward page breaks. If the table becomes longer than would fit on one page, either deselect this option or manually split the table.

The **Styles** section lists several predefined table layouts, also known as table styles. See “Creating and applying table styles” on page 352 for more information. You can select and preview the desired table option from the list.

After making your choices, click **Insert**. Writer creates a table as wide as the text area (from the left page margin to the right page margin), with all columns the same width and all rows the same height. You can adjust the columns and rows later to suit your needs.
Creating nested tables

You can create tables within tables, nested to a depth limited only by imagination and practicality. Nested tables are especially useful for page layout. Figure 313 demonstrates a simple, two-level example. The shaded table is inside a cell of the larger table. To achieve this, simply click in a cell of an existing table and use any of the methods mentioned in “Creating a new table” above.

![Nested Table Example](image)

**Figure 313: Nested table example**

Using AutoCorrect to create a table

You can also create a table by typing a series of hyphens (-) or tabs separated by plus signs. Use the plus signs to indicate column dividers, while hyphens and tabs are used to indicate the width of a column. When using tabs, the default tab setting determines the width; this setting can be changed in Tools > Options > LibreOffice Writer > General.

For example, this character sequence:
```
+-----------------+---------------+------+
```
creates a table like this:

```
```

**Note**

This function can be disabled or enabled in Tools > AutoCorrect > AutoCorrect Options. On the Options page, deselect or select Create table.

Creating a table from formatted text

To create a table from formatted text, select the text, then choose Table > Convert > Text to Table on the Menu bar. The text to be converted must contain characters to indicate column separators. Paragraph marks indicate an end of a table row.

**Tip**

Unlike the creation of a table by other methods, conversion from text to table preserves the paragraph style and character style applied to the original text.

1) Start by editing the text, if necessary, to ensure the column separator character is where you want it. Select the text to be converted and choose Table > Convert > Text to Table to open the dialog shown in Figure 314.

2) The Separate text at section has four options for the separator for the columns of text. Select Other to choose the default comma (useful if you are importing a .csv file) or type any character in the box.

The Options are the same as those in the Insert Table dialog (Figure 312).

3) Click OK to convert the text.
Example

In this example we will convert the following text into a table.

Row 1 Column 1; Row 1 Column 2; Row 1 Column 3
Row 2 Column 1; Row 2 Column 2; Row 2 Column 3

In this case, the separator between elements is a semicolon. Select the text and choose Table > Convert > Text to Table. We obtain the following result.

<table>
<thead>
<tr>
<th>Row 1 Column 1</th>
<th>Row 1 Column 2</th>
<th>Row 1 Column 3</th>
</tr>
</thead>
<tbody>
<tr>
<td>Row 2 Column 1</td>
<td>Row 2 Column 2</td>
<td>Row 2 Column 3</td>
</tr>
</tbody>
</table>

Tip

You can also convert a table into plain text. This may be useful when you want to export the table contents into a different program. Place the cursor anywhere in the table, choose Table > Convert > Table to Text on the Menu bar, pick the preferred row separator, and click OK to finish.

Inserting a portion of a spreadsheet

To copy a spreadsheet area into a Writer document as a Writer table:

1) Open both the Writer document and the spreadsheet.
2) Select the sheet area (cells) that you want to copy.
3) Right-click and choose Copy in the context menu, or press Ctrl+C; then click in the Writer document and choose Paste in the context menu or press Ctrl+V. Or, drag the area into the Writer document.

See also Chapter 19, Spreadsheets, Charts, Other Objects, for other methods of inserting spreadsheets into Writer documents.
Formatting the table layout

Formatting a table is a two-step process: formatting the table layout (the subject of this section) and formatting the table text (the subject of the next section).

Tip

If you apply similar formatting of table layout and table text to multiple tables, using table styles can speed up your work and provide consistency. See “Creating and applying table styles” on page 352.

Formatting the layout involves one or more of the following operations: adjusting the size of the table and its position on the page, adjusting sizes of rows and columns, adding or removing rows or columns, merging and splitting individual cells, changing borders and background.

Default parameters

If you create a table using the Insert Table dialog or the Insert Table icon on the Standard toolbar, the following defaults are set:

- The cells use the Table Contents paragraph style. In the default template, this style is identical to the Default Paragraph Style.
- The default table occupies all the space from margin to margin (text area).
- The default table has thin black borders around each cell (grid).
- If you activate the Heading option, the cells in the heading row (or rows) use the Table Heading paragraph style.

Resizing and positioning the table

To quickly resize a table, first move the mouse pointer to either the left or right edge. When the pointer changes shape, drag the border to the new position. This method only changes the size of the first or last column; it does not change the alignment of the table on the page.

For more precise control over the size and position of the table on the page, use the Table Properties dialog (Figure 315). Choose Table > Properties on the Menu bar, or right-click anywhere in the table and choose Table Properties in the context menu, or click the More Options icon in the Table panel of the Properties deck on the Sidebar.

![Table Properties dialog, Table tab](Figure 315: Table Properties dialog, Table tab)
On the **Table** tab of the dialog (Figure 315), you can set the alignment of the table:

- **Automatic**: the default setting for a table, fills the width of the text area.
- **Left**: aligns the table with the left margin.
- **Right**: aligns the table with the right margin.
- **From Left**: lets you specify under **Spacing** exactly how far from the left margin the table is placed.
- **Center**: aligns the table in the middle between the left and right margins. If the table width is greater than the margin, the table will extend outside of the margins.
- **Manual**: lets you specify the distances from both left and right margins under **Spacing**.

Selecting an alignment option other than Automatic activates the **Width** field in the **Properties** section, where you can enter the desired size of the table. Select **Relative** to see the width as percentage of the text area.

In the **Spacing** section, use the **Above** and **Below** boxes to modify the separation between the text and the table.

When the size of the table is less than the size of the text area, Writer will insert some values in the **Left** and **Right** boxes. Otherwise these values are not available. You can enter values:

- In both the **Left** and **Right** boxes if you select **Manual** alignment.
- In the **Left** box when you select the **From left**, **Right**, or **Center** alignment.
- In the **Right** box if you select Left alignment.

**Specifying text flow**

On the **Text Flow** tab of the Table Properties dialog (Figure 316), you can:

- Insert a page or column break either before or after the table. Use the **Text Flow: Break** option, combined with the **Page** or **Column** and the **Before** or **After** options. If you insert a page break before the table (that is, start the table on a new page), you can also change the page style that will go with it by selecting **With Page Style** and a new page style. As with any page break, you can also reset the page numbers using the **Page number** box.
- Keep a table on one page by deselecting **Allow table to split across pages and columns**. If this item is deselected, the next item is not active.
- Keep each row on one page by deselecting **Allow row to break across pages and columns**.
- Use **Keep with next paragraph** to keep the table and an immediately following paragraph together if you insert a page break.
- Use **Repeat heading**, and its associated numbers box, to select the number of table heading rows that will be repeated on each page. A complicated table may need two or three heading rows to be easily read and understood.
- Use the **Text orientation** list to select the direction for the text in the cells. Select from **Horizontal**, **Vertical (top to bottom)**, **Vertical (bottom to top)**, or **Use superordinate object settings** (meaning use the default text flow settings for the page).
- Select the vertical alignment of the text in the table or the selected cells; the choices are to align with the top of the cell, the center of the cell, or the bottom of the cell. This alignment is in addition to the Left-Right alignment options available on the **Table** tab of the Table Properties dialog.
**Note**

A table heading row cannot span two pages, but any other row can. A one-row table (often used for page layout purposes), if set up with the default of including a heading, will not break across pages. The solution is to make sure the table is defined without a heading row.

![Table Properties dialog, Text Flow tab](image)

**Figure 316: Table Properties dialog, Text Flow tab**

### Resizing rows and columns

You can adjust the height of rows and the width of columns in a table in several ways.

- Move the mouse pointer next to the edge of the cell and when a double-headed arrow appears, click and hold the left mouse button, drag the border to the desired position, and release the mouse button.

- On the horizontal ruler, column dividers are marked by a pair of thin gray lines; the vertical ruler indicates row dividers in the same way. You can resize a row or column by holding the mouse button down on the appropriate divider and dragging it to the desired location.

- Use the keyboard as described below.

Selecting **Table > Size** on the Menu bar also offers some resizing options:

- Select **Column Width or Row Height** to enter a dimension into the size box for each selectable column or row of the table.

- The **Minimize Column Width or Minimize Row Height** options make the selected columns or rows as narrow as possible while still fitting their contents. The rows or columns may not all be the same height or width.

- The **Optimal Column Width or Optimal Row Height** options make the selected columns or rows fit the largest character in any row or the longest entry in any column.

- Use **Distribute Columns/Rows Evenly** to quickly bring them back to all being the same width or height.

For greater control over the width of each column, use the **Columns** tab of the Table Properties dialog (Figure 317).
Right-click on the table and choose **Table Properties** in the context menu, or choose **Table > Properties** on the Menu bar, or click the **More Options** icon in the Table panel of the Properties deck on the Sidebar. On the Table Properties dialog, select the **Columns** tab.

- **Adapt table width**: If a table already stretches to the page margins, it cannot stretch any wider and the *Adapt table width* option can only be used to reduce the column width. If the table is narrower, increasing the width of a column will increase the width of the whole table. This option is not available if *Automatic* has been selected in the **Alignment** area of the Table tab.

  If the table width already extends past the margins, with the *Adapt table width* option checked, attempting to change a column width will automatically decrease that column’s size so that the table will now shrink to the page margins while keeping the size of any other column intact.

- **Adjust columns proportionally** results in all columns changing their widths by the same percentage when one is changed. For example, if you reduce by half the size of a column, the sizes of all the other columns will be halved. This option is not available if *Automatic* has been selected in the **Alignment** area of the Table tab.

- **Remaining space** shows how much further the table can expand before hitting the limit of the margins. This value cannot be edited and will not be negative in the event that the table width is already larger than the space between the left and right margins.

- **Under Column width**, each individual column can be adjusted. If you have more than six columns, use the arrows at the right and left to view them all. With no options selected, the column to the right of the one being adjusted will automatically change to keep the table width constant. Adjusting the most right hand column causes the first column to change.

**Tip**

Rather than starting from the Table Properties dialog, it is often more efficient to make rough adjustments to a new table using the mouse, and then fine-tune the layout using the **Columns** tab and the **Table** tab of the Table Properties dialog.

You can also resize a table using the keyboard:

1) Place the cursor in the cell where you want to make changes.

2) Press and hold the `Alt` key while using the arrow keys.
   - The left and right arrow keys adjust the column width by moving the border on the right edge of the cell, but not past the margin.
   - The up and down arrows adjust the row height (when possible) by moving the border on the lower edge of the cell.
To adjust the resizing parameters and behavior for keyboard handling, choose Tools > Options > LibreOffice Writer > Table (Figure 318).

**Figure 318: Choosing keyboard handling of table columns and rows**

Use the Row and Column values in the Move cells section to determine the amount of change produced by a single keystroke while resizing. In the Behavior of rows/columns section, you can choose one of three strategies when resizing:

- **Fixed**: the resizing will affect only the adjacent cell and not the entire table. The width of the table does not change when resizing its cells.
- **Fixed, proportional**: when resizing a cell, all the other cells are also resized proportionally, but in the opposite direction so as to maintain the width of the table.
- **Variable**: resizing a cell affects the table size. For example, when you widen a cell, the width of the table increases. This is the default option.

**Inserting rows and columns**

To quickly insert one row or column, place the cursor in the row or column before or after which you want to add new rows or columns, and then do one of the following:

- Click the Rows Above or Rows Below icons on the Table toolbar or the Table panel of the Properties deck on the Sidebar to insert one row above or below the selected one.
- Click the Columns Before or Columns After icons on the Table toolbar or the Table panel of the Properties deck on the Sidebar to insert one column before or after the selected one.
- Choose Table > Insert > Rows Above/Below or Table > Insert > Columns Before/After on the Menu bar.
- Right-click and choose Insert > Rows Above/Below or Insert > Columns Before/After in the context menu.

To insert any number of rows or columns:

1) Place the cursor in the row or column where you want to add new rows or columns.
2) Choose Table > Insert > Rows or Table > Insert > Columns on the Menu bar, or right-click and choose Insert > Rows or Insert > Columns in the context menu.
3) In the small dialog that opens, select the number of rows or columns to add, and whether they appear before or after the one selected. Set Number to the number of rows or columns to insert, and Position to Before or After.
4) Click OK to close the dialog.
Note

Regardless of how they are inserted, new rows or columns have the same formatting as the row or column where the cursor was located.

Deleting rows and columns
To quickly delete one or more rows or columns, select the rows or columns you want to delete and do one of the following:

- Click the Delete selected rows or Delete selected columns icons on the Table toolbar or the Table panel of the Properties deck on the Sidebar.
- Right-click and choose Delete > Rows or Delete > Columns.
- Choose Table > Delete > Rows or Table > Delete > Columns on the Menu bar.

Merging and splitting cells
A common use for merging cells is to make a heading row that takes up the entire width of the table, or a subheading row over more than one column.

To merge a cell or group of cells into one cell:

1) Select the cells to merge.
2) Right-click and choose Merge Cells in the context menu, or choose Table > Merge Cells from the Menu bar, or click the Merge Cells icon on the Table toolbar or the Table panel of the Properties deck on the Sidebar. Any content of the cells appears in the merged cell.

To split a cell into multiple cells:

1) Position the cursor inside the cell.
2) Right-click and choose Split Cells in the context menu, or choose Table > Split Cells on the Menu bar, or click the Split Cells icon on the Table toolbar or the Table panel of the Properties deck on the Sidebar.
3) On the Split Cells dialog, select how to split the cell and how many cells to create. A cell can be split either horizontally (create more rows) or vertically (create more columns).

Figure 319: Split Cells dialog

It is generally best to merge and split cells after completing other layout formatting. This is because some operations such as deleting a column or a row may produce a result difficult to predict when applied to a table with merged or split cells.
Specifying table borders

To quickly apply some table borders, use the palette of options on the Borders, Border Style, and Border color icons in the Table toolbar or the Table panel of the Properties deck on the Sidebar. For more control, use the Borders tab of the Table Properties dialog (Figure 320).

![Figure 320: Table Properties dialog, Borders page](image)

- **Line arrangement** specifies where the borders go. If a group of cells is selected, the border will be applied only to those cells. You can specify individually the style of the border for the outside edges of the selected cells and for the cell divisions. Writer provides default arrangements, but you can click the line you want to customize in the User-defined area to get exactly what you want. When multiple cells are selected, you can select the edges of the selection as well as the cell dividers.

- **Line** specifies what the border looks like. You can choose from the drop-down lists for Style and Color, and specify a Width. Your selections apply to those borders highlighted by a pair of black arrows in the User-defined area.

- **Padding** specifies how much space to leave between the border and the cell contents. Spacing can be specified individually for the left, right, top, and bottom borders. Choose Synchronize to have the same spacing on all four sides.

- **Shadow Style** properties always apply to the whole table. A shadow has three components: where it is (position), how far from the table it is cast (distance), and what color it is.

- If **Merge adjacent line styles** (under Properties) is checked, two cells sharing a common border will have their borders merged, rather than being side by side or above/below each other.

---

**Note**

When the selected cells have different styles of border, the User-defined area shows the border as a gray line. You can click the gray line to choose a new border style (first click), leave the border as it is (second click) or delete the border (third click).
Tip

To reset everything on the Borders tab of the Table Properties dialog, select the No Borders icon under Line arrangement Presets (the box on the left).

Selecting background colors and images

A table background can greatly improve the readability of data, visually highlight important parts of the table (such as the heading or a specific cell), or just make the table more appealing. You can choose between two types of background: solid color or image. The background can be applied to the whole table, to a single cell, or to a row.

You can quickly apply color cell backgrounds using the palette of options on the Table Cell Background Color icon in the Table toolbar or the Table panel of the Properties deck on the Sidebar. For more control, or to use an image as a background, use the Background tab of the Table Properties dialog (Figure 321).

![Figure 321: Table Properties dialog: inserting an image as a background](image)

Tip

Consider the color contrast between the background and foreground (usually text). Background colors and images can also have transparency applied to help make the text more readable. The row background option is quite handy for creating alternate color rows or assigning a different background to the heading of the table.

Note

The background selected for a cell will be in front of the row background which in turn will be in front of (and hide) the table background.
To set the background for a cell, row, or table:

1) Place the cursor anywhere inside the cell, row, or table you want to work with. If you want to apply a background to a group of cells, select the group.

2) Right-click and choose Table Properties in the context menu, or choose Table > Properties on the Menu bar, or click the More Options icon on the Table panel of the Properties deck on the Sidebar.

3) In the Table Properties dialog, select the Background tab (Figure 321).

4) Choose whether to apply the settings to cell, row, or table.
   - **Cell**: changes apply only to the selected cells, or the cell where the cursor currently resides. Even when a group of cells is selected, the background settings are applied to each cell individually.
   - **Row**: changes affect the entire row where the cursor resides.
   - **Table**: changes will set the background for the entire table, regardless of the cursor position or selected cells.

5) To apply a color, click the **Color** button, select the color, and click OK. To apply an image, click the **Image** button. Then,
   a) Select from the given images or use the Add/Import button.
   b) Under **Options**, select the type of placement for the image.
      - **Style** – select the way the image is to appear: custom position/size, tiled, or stretched.
      - **Size** – select the required Image aspect ratio or the Scale option.
      - **Position** – select where the image is to be displayed.
   c) To apply the image, click OK.

### Displaying or hiding table boundaries

A table boundary is a set of pale (usually gray) lines around the cells when viewed on-screen in LibreOffice with no borders enabled. These boundaries are not printed; their only function is to show where the table cells are. They are particularly useful when using tables for page layout.

To display tables the same way on the screen as on the printed page, with no boundary lines, deselect View > Table Boundaries, or go to Tools > Options > LibreOffice > Application Colors, where you can display or hide boundaries around text, tables, headers and footers, figures, and other parts of a document, and you can choose the color of boundary lines.

Turning boundaries off does not hide any borders that the table may have.

### Creating and applying table styles

Using table styles, you can apply an elaborate format to your table with just a few clicks. Like other styles, table styles enable you to produce consistent looking tables in a document.

#### Applying a table style

To apply a table style, go to the Table Styles tab of the Styles deck on the Sidebar. Then place the cursor anywhere in the table and double-click the name of a style.

For more control, go to Table > AutoFormat Styles on the Menu bar, or click the AutoFormat Styles icon on the Table toolbar. On the AutoFormat dialog (Figure 322), select a format from the list, choose which features you wish to use in your table (font, alignment, borders, and so on), and then click OK. The table will be reformatted.
Tip

You can rename the formats by selecting one and clicking the Rename button. The name will change in this dialog and in the Table Styles page on the sidebar.

You can delete a format by selecting it and clicking the Delete button. However, you cannot rename or delete the Default Table Style.

Creating a table style

Although the Table Styles tab of the Sidebar’s Styles deck includes a quick way to apply table styles, they are created by using the AutoFormat feature. Follow these steps:

1) Create a table. Format it as you wish: font, alignment, borders, background, number format.

2) Put the cursor anywhere in the table. Select Table > AutoFormat Styles on the Menu bar, or click the AutoFormat Styles icon on the Table toolbar.

3) On the AutoFormat dialog (Figure 322), choose which formatting to include in the new table style, and then click Add.

4) In the pop-up dialog, type a name for the new style and click OK. The new style is added to the list of formats in the AutoFormat dialog and to the list of table styles in the Styles deck in the sidebar.

Table styles also include the following table-level properties:

- Break
- Keep with next paragraph
- Repeat heading
- Allow table to split across pages
- Allow rows to break across pages
- Merge adjacent line styles
- Table shadow
Tip

These styles do not include table and column widths in the table format. To insert a table with predefined full formatting, save it as AutoText. See Chapter 2, Working with Text: Basics, for instructions.

Formatting the table text

Once the table layout is set, you can move on to formatting the text in the individual cells. You can apply manual formatting as with any other paragraph in the text, but it is highly recommended that you use paragraph and character styles, for consistency and ease of maintenance. Other aspects to consider include text flow, alignment, and orientation.

You can format each cell independently of other cells, or you can simultaneously format a group of cells by selecting them before applying the desired formatting.

Tip

You can apply basic table text formatting by choosing a table style and then modify only those cells that you wish to be different.

Vertical alignment

By default, text entered into a table is aligned to the top-left of the cell. You can change the default for the entire table, as described above, or for individually selected cells.

To vertically align the text in specific cells:

1) Place the cursor in the cell you wish to change, or select multiple cells.
2) Click an icon on the Table toolbar: Align Top, Center Vertically, or Align Bottom.

Number formats

The number format can be set for a whole table, a group of cells, or a single cell. For example, cells can be set to display in a particular currency, to four decimal places, or in a particular date format.

Number recognition specifies that numbers in a text table are recognized and formatted as numbers. If Number recognition is not selected, numbers are saved in text format and are automatically left-aligned. To enable Number recognition, go to Tools > Options > LibreOffice Writer > Table and select the option in the Input in Tables section.

To set the number format for one or more cells, select the cells, then either click the icon for one of the popular formats on the Table toolbar, or choose Table > Number Format on the Menu bar. On the Format Number dialog (Figure 323), you can set options for various categories of numerical data.

- In the Category list, select the category you want, such as currency, date, or text.
- In the Format list, choose a format for the category you just selected.
- For some categories, such as Date, you may wish to change the language using the Language list, while for other numerical categories you can use the Options section of the dialog to customize the appearance.
Tip

Writer displays the formatting code for the category and format selected in *Format Code* section at the bottom of the dialog. For example, if you select a date format such as 31 Dec 1999 the corresponding code is D MMM YYYY. Advanced users can easily customize this formatting code as well as create new user-defined codes.

![Format Number dialog](image)

*Figure 323: Format Number dialog*

Rotating text in a table cell

You can rotate text in a table cell by 90 or 270 degrees. Text rotation can be useful when you have long headings for narrow columns.

- Select the text to be rotated and then choose **Format > Character**, or right-click and select **Character > Character** in the context menu.
- On the **Position** tab, in the **Rotation / Scaling** section, choose the rotation angle, optionally change the Scale width, and click **OK**.

Note

Text rotation within table cells can also be achieved with the use of paragraph styles, discussed in Chapter 9, Working with Styles.

Data entry and manipulation in tables

Moving between cells

To move between cells within a table, use the mouse, the arrow keys, or the *Tab* key.

The arrow keys move the cursor one text character left or right at a time. If a cell is empty, pressing the arrow key moves the cursor to the adjacent cell.

The *Tab* key moves directly to the next cell and, if the cursor is in the last cell in the table, creates a new row. Pressing *Shift+Tab* moves the cursor back a cell.
To enter a Tab character as part of the text of the cell, press the Ctrl and Tab keys at the same time.

To move to the beginning of the table, press Ctrl+Home. If the active cell is empty, the move is to the beginning of the table. If the cell has content, the first press goes to the beginning of the cell and the next press goes to the beginning of the table. (Pressing again goes to the beginning of the document.)

To move to the end of the table, press Ctrl+End. If the active cell is empty, the move is to the end of the table. If the cell has content, the first press goes to the end of the cell and the next press goes to the end of the table. (Pressing again goes to the end of the document.)

**Sorting data in a table**

Just as in a spreadsheet, data in a table can be sorted. You can specify up to three levels of sorting (for example, sort first by age numerically, then alphabetically by name within each age).

To sort data in a table:

1) Select the table (or part of the table) to be sorted.
2) Choose Table > Sort on the Menu bar, or click the Sort icon on the Table toolbar.
3) In the Sort dialog (Figure 324):
   a) Decide whether you want to sort in the direction of rows or columns. The default sorting direction is by rows, which results in sorting the data in a column.
   b) Select up to three keys to sort on, in the correct order.
   c) For each key, select which column or row to sort on, whether the sort is Numeric or Alphanumeric and whether it is Ascending or Descending.
   d) Click OK to perform the sort.

![Sort window](Figure 324: Selecting criteria for sorting)
Note

Be sure to select all cells that might be affected by the sorting. For example, if you select only the cells of one column, the sort affects that column only, while the others remain unchanged. In such a case, you risk mixing the data of the rows.

Using spreadsheet functions in a table

For many simple mathematical functions, Writer tables can be used as basic spreadsheets. Just as in a spreadsheet, each table cell is identified by a letter (for the column) and a number (for the row). For example, cell C4 is the cell in the third column from the left and fourth row from the top. When the cursor is in a cell, the table name and this cell reference is displayed on the status bar.

Tip

Basic spreadsheet functions in tables are much the same as in LibreOffice Calc. The main difference is that cell references are formatted differently. Cell A2 (first column, second row) is referred to in Calc as A2 (or $A$2 for an absolute reference). In Writer tables, it is referred to as <A2>.

For example, suppose you had two numbers in cells <B1> and <C2> and wanted to display the sum of the two in cell <A1>, as shown in Figure 325.

Do the following to sum up 4 and 5:

1) Click in cell <A1> and press the = key, or choose Table > Formula on the Menu bar, or press F2, or click the Sum icon or the Formula icon on the Table toolbar, or click the Formula icon in the Table panel of the Properties deck on the Sidebar.

   The Formula bar appears automatically at the top of the workspace. In the leftmost side of the bar, you can see the coordinates of the selected cell.

2) Click in cell <B1>. The identifiers of this cell are automatically displayed in the Formula bar and inserted into cell <A1>.

3) Press the + key.

4) Click in cell <C2>. You can see the final formula = <B1>+<C2> displayed both in the selected cell and on the Object bar.

5) Press the Enter key, or click the green check mark (may be a different symbol on some installations) on the Formula Bar, to replace the formula in the cell with the result of the calculation.

Figure 325: Using spreadsheet functions in a table
Tip

To display a cell’s formula and make it available for editing, choose Table > Formula on the Menu bar, or use one of the other methods above.

To display the list of the mathematical functions available for use in a table, display the Formula toolbar and then click the Formula $f(x)$ icon.

In our example, this gives the result 9 in the top left cell. For summing contiguous cells, you can simply select the cells in the row, column, or the rectangle of rows and columns. Thus, for example, to add a column of numbers, do this:

1) Type an equals sign = in an empty cell.
2) Select the cells to be added together, in this case the cells from A2 to A5. The formula should be something like =$A2:A5$.
3) Press the Enter key or click the green check mark on the Formula Bar.
4) The result appears in the empty cell where you entered the formula.

When using a function, you can type the cell references manually or select them. Thus, to add up the four numbers that we added above (A2, A3, A4, A5), do this:

1) Type an equals sign = in an empty cell.
2) Type sum or select it from the function list $f(x)$.
3) Select the contiguous cells to be added together. The formula should be something like =sum$A2:A5$.
4) Press the Enter key or click the green check mark on the Formula Bar. The answer appears in the empty cell where you entered the formula.

Caution

In Writer, formulas are not updated automatically when inserting or deleting rows or columns of the table, although the results do update when you change a value in a cell. If you plan to use complex formulas, consider embedding a Calc spreadsheet in the Writer document. See Chapter 19, Spreadsheets, Charts, Other Objects.

Additional table operations

Protecting cells in a table

You can protect the contents of individual cells of a table from changes. When a cell is protected, most of the menu items and toolbar icons are inactivated.

Note

This protection is not intended for secure protection. It protects the cells against accidental changes.

To turn on cell protection, place the cursor in a cell or select cells, then click the Protect Cells icon on the Table toolbar or choose Table > Protect Cells on the Menu bar.

To turn off cell protection, place the cursor in the cell or select the cells. Then click the Unprotect Cells icon on the Table toolbar or choose Table > Unprotect Cells on the Menu bar.

To remove protection for the entire current table or all selected tables, press Shift+Ctrl+T.
Adding a caption

You can easily add a caption to any table. Writer will keep track of all your captioned tables, automatically number them, and update any links to them. To add a caption to a table:

1) Right-click anywhere in the table and select **Insert Caption** in the context menu, or choose **Insert > Caption** on the Menu bar, or click the **Insert Caption** icon on the Table toolbar.

2) Under **Properties** on the Caption dialog, make your selections for the Category (it defaults to Table, which is usually what you want), Numbering, and Separator fields. The position of the caption defaults to above a table; you can change this if necessary.

3) Type your caption text in the text box at the top of the dialog.

4) Click **OK**.

You can also set up Writer to add captions to tables automatically. The procedure is the same as for adding captions automatically to images, described in Chapter 11.

Cross-referencing to a table

You can insert a cross-reference to a captioned table. Clicking on the cross-reference takes the reader directly to the table. For details, see Chapter 17, Fields.

Splitting a table

One table can be split into two tables, and two tables can be merged into a single table. Tables are split horizontally: the rows above the split point are put into one table, and the rows below into another. To split a table:

1) Place the cursor in a cell that will be in the top row of the second table after the split (the table splits immediately above the cursor).

2) Choose **Table > Split Table** on the Menu bar or click the **Split Table** icon on the Table toolbar.

3) A Split Table dialog opens, where you can choose how to handle heading rows.

4) Click **OK**. The table is then split into two tables separated by a blank paragraph.

**Note**

If cells in one table include formulas using data from the other table, those cells will contain an error message: **Expression is faulty**.

Merging tables

To merge two tables:

1) Delete the blank paragraph between the tables. You must use the **Delete** key (not the **Backspace** key) to do this.

2) Select any cell in one of the tables.

3) Choose **Table > Merge Table** from the Menu bar.
Tip

To see clearly where the paragraphs are and to delete them easily, choose View > Formatting Marks (Ctrl+F10) or click the ¶ icon in the Standard toolbar.

Deleting a table

To delete a table, do any of the following:

- Right-click anywhere in the table and choose Delete > Table in the context menu.
- Click anywhere in the table and choose Table > Delete > Table on the Menu bar.
- Select from the end of the paragraph before the table to the start of the paragraph after the table, and then press the Delete key or the Backspace key.

Note

The third method also merges the paragraph after the table with the paragraph before the table, which may not be what you want.

Copying a table

To copy a table from one part of the document and paste it into another part:

1) Select the table.
2) Press Ctrl+C or click the Copy icon on the Standard toolbar.
3) Click where you want the table to be copied.
4) Press Ctrl+V or click the Paste icon on the Standard toolbar.

Moving a table

To move a table from one part of a document to another part:

1) Select the table.
2) Press Ctrl+X or click the Cut icon on the Standard toolbar.
3) Click where you want the table to be moved.
4) Press Ctrl+V or click the Paste icon on the Standard toolbar. This pastes the cells and their contents and formatting.

Inserting a paragraph before or after a table

To insert a paragraph before a table, position the cursor before any text or other contents in the first (upper left-hand) cell and press Alt+Enter. To insert a paragraph after a table, position the cursor after any text in the last (lower right-hand) cell and press Alt+Enter.

Using tables as a page layout tool

Tables may be used as a page layout tool to position text in a document instead of using tabs or spaces. For more information and tips about using tables in page layout, see Chapter 6, Formatting Pages: Advanced.
Chapter 14, Mail Merge

Form Letters, Mailing Labels, and Envelopes
What is mail merge?

Writer’s mail merge provides features to create and print multiple copies of one item (such as return address labels, promotional stickers, or t-shirt transfers) or to produce copies that include variable information (for example names, addresses, and amounts due):

- Form letters (a document to send to a list of recipients)
- Mailing labels, labels for physical file folders, and similar purposes
- Envelopes

Variable data is typically derived from a data source, as discussed below. If all output is to be the same (for example, return address labels), the merge can use manually entered text or images.

This chapter describes the mail merge process. The steps include:

1) Create and register a data source.
2) Create and print form letters, mailing labels, and envelopes.
3) Optionally, save the output in an editable file instead of printing it directly.

Creating and registering an address data source

An address data source is a database containing the name and address records from which mailing labels and envelopes can be derived. LibreOffice can create the database from spreadsheets, text files including Writer documents, and databases such as MySQL. If the information to be used in the mail merge is currently in a format that LibreOffice cannot access directly, you need to convert it, for example by exporting to a comma-separated values (CSV) file.

For a data source to be directly accessible from within a Writer document, it must be registered. You need to do this only once.

1) From within a Writer document, or from the LibreOffice Start Center, choose File > Wizards > Address Data Source.
2) The choices on the first page of the wizard (Figure 326) vary with your operating system. Select the appropriate type of external address book. For a spreadsheet, it is Other external data source. Depending on your choice, the list of steps on the left may change. Click Next.

![Address Book Data Source Wizard](image)

*Figure 326: Select type of external address book*

3) On the next page of the Wizard (Figure 327), click on the Settings button.
4) On the Create Address Data Source page (Figure 328), select the Database type. In our example, it is Spreadsheet. Click Next.

5) On the next page (Figure 329), click Browse and navigate to the spreadsheet that contains the address information. Select the spreadsheet and click Open to return to this dialog.

6) To test that the connection has been correctly established, click the Test Connection button in the lower right of the dialog (not shown in Figure 329). You should get the message The connection was established successfully; otherwise, you will get an error message.

7) Click Finish.

8) On the next page (Figure 330), click Next. You do not need to click the Field Assignment button. (When you are using the Mail Merge Wizard, you may need to do the Field Assignment step; see page 379.)
9) On the Data Source Title page (Figure 331), the name and location of the new database (.odb) is shown in the Location field. You can change this name or store the database file in a different location; deselect **Embed this address book definition into the current document**, then click **Browse** to choose the location and name the file.

You can also change the name in the **Address book name** field. This is the registered name, which LibreOffice displays in data source listings. In our example, the name **Addresses** was used for both.

10) Click **Finish**. The data source is now registered.

### Creating a form letter

You can create a form letter manually—the simplest and most comprehensive method, which is described here—or you can use the Mail Merge wizard starting on page 375.

1) Create a new Writer document (**File > New > Text Document**) or open an existing form letter with **File > Open**.
2) Display the registered data sources: View > Data Sources (or press Shift+Ctrl+F4).

3) Find the data source that you wish to use for the form letter, in this case Addresses. Expand this folder and the Tables folder, and select Sheet1. The address data file is displayed.

4) Now create or modify the form letter by typing in the text, punctuation, line breaks, and so on that will be present in all of the letters.

   To add the mail-merge fields where needed (such as names and addresses), click in the field heading and drag it to the appropriate point in the letter. Be sure to add spaces or other punctuation as needed. Press Enter at the end of each line in the address block.

5) Our example database (Figure 332) contains a field for a second address line (AD2) that is blank for some addresses. If you wish to remove any blank lines that may appear in the address block when the letters are printed, you can use the procedure described in “Suppressing blank lines (optional)” on page 369. Otherwise, continue to the next step.

6) The document is now ready to be printed.
a) Choose **File > Print** and click **Yes** in the message box.

![Mail merge confirmation message](image)

*Figure 334: Mail merge confirmation message*

b) In the Mail Merge dialog (Figure 335), in the *Records* section, you can choose to print all records or selected records. To select individual records to be printed, press **Ctrl**+click on each one. To select a block of records, select the first record in the block, scroll to the last record in the block, and **Shift**+click on the last record. You can also specify a range of record numbers to print.

c) To send the letters directly to the printer, select **Printer** in the *Output* section and click **OK**. Or, you can save the letters to a file for further editing or formatting; see “Saving merged documents” on page 370.

d) If you have not saved the original, prototype form letter document (template) previously, then you should do so now. Having a form letter template could greatly simplify the creation of other form letters and is highly recommended.

![Mail Merge dialog](image)

*Figure 335: The Mail Merge dialog*

**Suppressing blank lines (optional)**

If you wish to suppress blank lines, follow this procedure:

1) Click at the end of a paragraph to be suppressed if empty, and then choose **Insert > Field > More Fields** to display the Fields dialog.

2) Select the **Functions** tab and then choose **Hidden Paragraph** in the **Type** column.

**Note**

When using the Mail Merge Wizard (page 375), you can select automatic suppression of blank lines and avoid the work described in this step.
Now click in the **Condition** box and enter the details of the condition that defines a blank address field. It has the general form of:

```
! [Database.Table.Database field]
```

For example, in our database the condition to test if the \texttt{AD2} field is empty would be:

```
! [Addresses.Sheet1.AD2]
```

as illustrated in Figure 336.

Alternative ways to express this condition include \texttt{NOT Addresses.Sheet1.AD2} and \texttt{Addresses.Sheet1.AD2 EQ ""}.

4) Click **Insert**.

### Saving merged documents

You may prefer to save the letters in a file, to allow for proofreading or formatting. To do this:

1) In the Mail Merge dialog (Figure 335), select the records to be included, then select **File** in the **Output** section to activate some other choices on the page (Figure 337).

2) You can choose whether to save the output as a single document (containing all of the letters) or save the letters as individual documents; and you can specify the name, location, and format of the files.

3) Click **OK**. In the Save as dialog, enter a file name for the saved letters and choose a folder in which to save them. The letters will be saved consecutively as separate pages in the single document, or numbered consecutively in individual files.

You can now open the letters and edit them individually as you would edit any other document.
Printing mailing labels

Labels are commonly used for printing address lists (where each label shows a different address), but they can also be used for making multiple copies of one label only, for example return-address stickers, or labels for CDs/DVDs or other items.

Before beginning this process, note the brand and type of labels you intend to use. You can also define your own label size; see Step 6).

Tip

If you are printing the same information on each label, you may find the Business Cards dialog useful. Access it through File > New > Business Cards. The Labels and Business Cards dialogs are very similar.

Preparing for printing

To prepare mailing labels for printing:

2) On the Labels page (Figure 338), select the Database and Table.
3) From the Database field drop-down list, select the first field to be used in the label (in this example, FNAME), then click the left arrow button to move it to the Label text area.
4) Continue adding fields and inserting desired punctuation, spaces, and line (paragraph) ends until the label is composed. Figure 338 shows the completed label.

![Figure 338: The completed label](image)

On some operating systems, a scroll bar will appear below the Label text box and you can see where the paragraph ends are located. On others (as in the example), the fields may appear in a list and you cannot see where the paragraph ends are located. You can check them later in the procedure (Step 8)).
5) Select the label stock in the Brand drop-down list. The types for that brand then appear in the Type drop-down list. Select the size and type of labels required, and then go to Step 7. If your label sheets are not listed, go to Step 6.

6) To define labels that are not on the list:
   a) Select [User] in the Type box on the Labels page. Then, click the Format page of the Labels dialog (Figure 339). Measure on your labels those dimensions illustrated and enter them into the respective boxes on the left side.
   
   - **Horizontal pitch** is the distance between the left edges of adjacent labels.
   - **Vertical pitch** is the distance between the upper edge of a label and the upper edge of the label directly below.

   ![Figure 339: Specify settings, if necessary](image)

   b) You can now save the label template if you are likely to use it again. Click Save.
   c) In the Save Label Format dialog that pops up, type names for your label Brand and Type. Click OK.

7) On the Options tab of the Labels dialog (Figure 340), select Synchronize contents.

   ![Figure 340: Options tab of the Labels dialog](image)
8) Click **New Document**. You now have a one-page document containing a series of frames, one for each label of the selected type and filled with the data source address fields that you selected. Although this document appears to have only one page of labels, the printed or saved output will be expanded to include enough pages for all of the selected records from the data source.

9) In this document you can see the paragraph ends if you use the **Toggle Formatting Marks** toolbar button or **View > Formatting Marks** on the Menu bar.

10) You should also see a small window containing a **Synchronize Labels** button, usually in the upper left corner of the screen.

11) If any paragraph ends or other punctuation are missing, or if you wish to change the font or other characteristics of one or more fields or lines (paragraphs) of all the labels, you can do so now. In the upper left label, select the field(s) that you wish to change, then change them manually or by selecting a paragraph style or character style. Add any missing punctuation. Then click the **Synchronize Labels** button to automatically add these changes to all of the labels.

### Printing

1) Choose **File > Print**. The message shown in Figure 334 appears. Click **Yes** to print.

2) In the Mail Merge dialog (Figure 335), you can choose to print all records or selected records. To select records to be printed, use **Ctrl+click** to select individual records. To select a block of records, select the first record in the block, scroll to the last record in the block, and **Shift+click** on the last record.

3) Click **OK** to send the labels directly to the printer. If you prefer to save the labels to a file, then select **File** in the **Output** section, where **Save as single document** is preselected. In this case, clicking **OK** opens the Save As dialog, where you can enter a file name and location, as described in Step 6) on page 368.

**Note**

Blank lines in addresses on labels are suppressed automatically, as they are when using the Mail Merge Wizard (page 375).

### Editing a saved file of mailing labels

To edit a saved file of mailing labels, open the file in the same way as any other Writer document.

You can edit individual records manually (for example, to correct a spelling error without needing to change the source spreadsheet and regenerate the labels), but you cannot edit all labels at once (for example, to change the font used) by a manual technique. However, you can edit the paragraph and/or character styles associated with the label records:

1) Right-click in a label record. Choose **Paragraph > Edit Style** in the context menu.

2) Then in the Paragraph Style dialog, you can make changes to the font name, the font size, the indents, and other attributes.
Printing envelopes

Instead of printing mailing labels, you may wish to print directly onto envelopes.

The production of envelopes involves two steps, setup and printing. For general instructions on setting up envelopes for printing using the Format and Printer pages of the Envelope dialog, see Chapter 7, Printing, Exporting, Emailing, and Signing.

To produce a single envelope, you can type or paste the name and address into the Addressee box, or you can get information from an address data source as described in this section.

Setting up envelopes for printing

1) Choose **Insert > Envelope** on the Menu bar.

2) On the **Envelope** tab of the Envelope dialog (Figure 346), choose whether to add Sender information (the “from” address) to the envelope. If so, type the information in the **Sender** box. If you’re using envelopes preprinted with sender information, either leave this box empty or deselect the **Sender** checkbox.

3) Create the **Addressee** fields by dragging and dropping from the data source headings, as described in “Printing mailing labels” on page 371, then click the New Document button to create the envelope template.

   Alternatively, click **New Document**, open the Data Sources window above the envelope template, then drag the data source headings into the Addressee box on the envelope.

4) At this point you may wish to save this document as a template.
Merging and printing the envelopes

To merge addresses and print the envelopes:

1) Choose **File > Print**. The message shown in Figure 334 appears. Click **Yes** to print.

2) The Mail Merge dialog (Figure 335) appears. As with form letters and mailing labels, you can choose to print envelopes for one, several, or all address records in the database.

3) Make your selections and then click **OK** to print direct to the printer. To check the envelopes before printing them, see “Saving merged documents” on page 370 for instructions. Blank lines are automatically suppressed.

Using the Mail Merge Wizard to create a form letter

The manual method of creating a form letter is described in “Creating a form letter” on page 367. If you prefer to use the Mail Merge wizard, the technique is described in this section.


**Step 1: Select starting document**

The Mail Merge Wizard (Figure 342) gives several options for the starting document:

- Use the current document
- Create a new document
- Start from existing document
- Start from a template
- Start from a recently saved starting document

For the purposes of this example, we opened a new text document.

Select **Use the current document** and click **Next**.

![Figure 342: Mail Merge Wizard: Select starting document](image)

If the current document does not have a registered data source associated, a warning message is displayed. Click the **Exchange Database** button to open the Exchange Databases dialog (Figure 343) and select the required database from the **Available Databases** list. If necessary, click the **Browse** button to open a file browser and find the required database to register. Click **Define** to close the dialog and associate the selected database with the document.
Step 2: Select document type

The wizard can produce letters or email messages. In this example, we are producing a letter. Select Letter and click Next.

Step 3: Insert address block

This is the most complex step in the wizard. In this step (Figure 345) you will do three things:

1) Tell the wizard which data source to use. The data source must be an existing file.
2) Select the address block to use in the document. This means choosing which fields appear (for example, whether the country is included) and how they look.
3) Make sure that the fields all match correctly. This is very important. For example, the UK English version of the wizard has a field called `<Surname>`. If your spreadsheet has a column called “Last Name”, you need to tell the wizard that `<Surname>` and “Last Name” are equivalent. This is described in “Matching the fields” on page 379.
Selecting the data source (address list)

1) If the current address list, identified beneath the Select Different Address List button in section 1 (Figure 345), is not the one you wish to use, click the button to open the Select Address List dialog (Figure 346) for choosing a data source.
If you have not already created the address list, you may click **Create** to do so now. This step will allow you to create a .csv (Comma Separated Values) file with a new list of address records. If you have an address list that is not registered in LibreOffice, but which you wish to use, click **Add** and select the file from the location in which it is saved.

In each of these cases a new data source (.odb file) will be created and registered.

2) Select the address list and click **OK** to return to the Insert Address Block dialog. We retain Addresses as our address book for this example. The wizard can also exclude certain records; click **Filter** to choose them.

**Selecting and optionally editing the address block**

1) In section 2 (Figure 345), select the address block to appear on the letter, define its appearance, and choose the fields it contains. The main page gives two choices. Click **More** to open the Select Address Block dialog for more choices.

2) The Select Address Block dialog (Figure 347) displays the original two blocks plus other choices for the format of the address block (you may need to scroll down to see all of the choices). You can also optionally include or exclude the country (for example, only include the country if it is not England) in the **Address Block Settings** section. The formats provided are relatively common, but they might not exactly match your preference. If this is the case, select the address block that is closest to what you want and click **Edit**, which opens the Edit Address Block dialog.

3) In the Edit Address Block dialog (Figure 348), you can add or delete address elements using the arrow buttons between the boxes. To move elements around, use the arrow buttons on the right. For example, to add an extra space between the first and the last names in Figure 348, click <Last Name> and then click the **Move right** arrow button on the right-hand side.

![Figure 347: Select Address Block dialog](image)
4) Click **OK** to close the Edit Address Block dialog, then click **OK** on the Select Address Block dialog to save your changes and return to the Mail Merge Wizard.

**Matching the fields**

Finally, it is time to match the wizard’s fields with the spreadsheet fields, so that items like `<Surname>` and “Last Name” match correctly.

1) Look at section 3 of the wizard (shown in Figure 345 on page 377). The box at the bottom displays one record at a time, using the address block format you specified. Use the right and left arrow buttons below that address box to step through the addresses, checking that they display correctly. Do not assume that all the records display correctly, just because one or two do.

2) If the addresses do not display correctly, click **Match Fields**. The Match Fields dialog (Figure 349) has three columns:
   - Address elements are the terms the wizard uses for each field, such as `<First Name>` and `<Last Name>`.
   - Use the **Matches to field** column to select, for each address element, the field from your data source that matches it.
   - The **Preview** column shows what will be shown for this field from the selected address block, so you can double-check that the match is correct.

3) When you have matched all the fields, click **OK** to return to the Insert Address Block dialog. Now, when you use the arrow buttons to look at all the addresses, they should all look correct. If not, go back and change anything you’re not happy with, before clicking **Next** to move to the next step.
Note that you will not be able to continue until you have correctly matched all the fields in your chosen address block. If you see <not yet matched> in a field position it indicates that the field in question is not correctly matched.

**Figure 349: Match Fields dialog**

4) Notice the option for **Suppress lines with empty fields** in section 2 of Figure 345. Using the Wizard, you do not have to create your own conditional suppression fields, as you do when using the manual form letter method described earlier in this chapter.

**Step 4: Create salutation**

It is possible to create just about any salutation you want in this step (see Figure 350).

Select **This document should contain a salutation** to enable the **General salutation** list box. Some general texts are available in the list box, or you can enter your own text. A preview pane displays your choice.

Select **Insert personalized salutation** to enable further salutation constructs.

You can, for example, use a different greeting for men and women. To do this, Writer must have some way of knowing whether a person is male or female. In a spreadsheet, you might have a column called Gender. In the section **Address list field indicating a female recipient**, set the **Field name** to Gender and the **Field value** to F. The Male salutation is then printed for all men and the Female salutation for all women. Unfortunately, LibreOffice does not provide for other genders; however, you can use a non-gendered salutation.

If you do not have such a column in your spreadsheet, or if you do not need to distinguish between genders in the salutation, then you can leave the **Field name** and **Field value** boxes empty and use the customized content of the **Male** list box for the salutation to all recipients.
Figure 350: Mail Merge Wizard: Create a salutation

As an example:

1) Click the **New** button alongside the **Male** list box. The Custom Salutation (Male Recipients) dialog opens (see Figure 351).

2) Select **Salutation** in the **Salutation elements** list on the right and drag it into box 1 on the right.

3) In the **Customize salutation** box, select an appropriate greeting or type your own text into the box. Edit it as needed.

4) Select and move **First Name** from the **Salutation elements** list into box 1, using either the Add to salutation arrow button or by dragging it. Then click the **Move right** arrow button on the right-hand side to add space between the salutation and the first name.

5) Select and move **Last Name** from the **Salutation elements** list into box 1, then click the **Move right** arrow button to add space between the first and the last names.

6) Finally, move Punctuation Mark across and select the comma from the choices in the **Customize salutation** box.

7) The construct is shown in the **Preview** box.

8) Carry out any final editing. Click **OK**.

This method allows you to use gender neutral titles such as Doctor (Dr) and Reverend (Rev), or titles such as Ms, or omit titles.
Step 5: Adjust layout

In Step 5: Adjust layout, you can adjust the position of the address block and salutation on the page. You can place the address block anywhere on the page. The salutation is always on the left, but you can move it up and down the page. Use the buttons shown in Figure 352 to move the elements.
You now have a Writer document into which you can type the contents of the letter. To merge the fields and print the letters, choose File > Print on the Menu bar. A message pops up, asking if you want to print a form letter. Click Yes.

The Mail Merge dialog (Figure 335) is now displayed, where you can optionally select records to include or exclude (in the top section) and, in the Output section, choose to print the letters immediately (Printer) or save them (File) for further editing or printing at a later time.

If you choose File, you can then choose whether to save the output as a single document (containing all of the letters) or save the letters as individual documents, and you can specify the name, location, and format of the files. Click OK to save the letters. You can now open the letters and edit them individually as you would edit any other document.
Chapter 15, *Tables of Contents, Indexes, Bibliographies*
Introduction

This chapter describes how to create and maintain a table of contents, an index, and a bibliography for a text document using LibreOffice Writer. Other types of index are mentioned briefly. To understand the instructions, you need a basic familiarity with Writer and styles (see Chapter 8, Introduction to Styles, and Chapter 9, Working with Styles).

Tables of contents

Writer’s table of contents (TOC) feature lets you build an automated TOC from the headings in a document. Whenever changes are made to the text of a heading in the body of the document or the page on which the heading appears, those changes automatically appear in the table of contents when it is updated.

Before you start, make sure that the headings are styled consistently. For example, you can use the Heading 1 style for chapter titles and the Heading 2 and Heading 3 styles for chapter subheadings.

This section shows you how to:

* Create a table of contents quickly, using the defaults.
* Customize a table of contents.

**Note**

You can use any style you want for the different levels to appear in the TOC; the examples in this chapter uses the default Heading styles. You can specify other paragraph styles to appear in the TOC, as described in “Create From” on page 391.

**Tips**

If some of your headings do not show up in the table of contents, check that the headings have been tagged with the correct paragraph style. If a whole level of headings does not show up, check the settings in Tools > Heading Numbering. See Chapter 8, Introduction to Styles.

If you add or delete text (so that headings move to different pages) or you add, delete, or change headings, you need to update the table of contents. To do this: Right-click anywhere in the TOC and select Update Index in the context menu.

If you cannot place the cursor in the TOC, choose Tools > Options > LibreOffice Writer > Formatting Aids, and then select Enable cursor in the Protected Areas section.

The TOC appears with a gray background. This background is there to remind you that the TOC is a field; the text you see is generated automatically. The background is not printed and does not appear if the document is converted to a PDF. To turn off this gray background, go to Tools > Options > LibreOffice > Application Colors, then scroll down to the Text Document section and deselect Index and table shadings.

This change may leave a gray background showing behind the dots between the headings and the page numbers, because the dots are part of a tab. To turn that shading off, go to Tools > Options > LibreOffice Writer > Formatting Aids and deselect the option for Tabs in the Display formatting section.
Creating a table of contents quickly

Most of the time you will find the default table of contents to be all you need, although the formatting may be inelegant. To insert a default TOC:

1) Create a document, using the following paragraph styles for different heading levels (such as chapter and section headings): Heading 1, Heading 2, and Heading 3. These are what will appear in the TOC. Writer can evaluate up to ten levels of headings.

2) Click in the document where you want the TOC to appear.

3) Choose Insert > Table of Contents and Index > Table of Contents, Index or Bibliography.

4) Click OK. The result will be a typical table of contents with the entries generated as hyperlinks.

Caution

If you have Edit > Track Changes > Show enabled when editing a document and you update the TOC, then errors may occur, as the TOC will still include any deleted headings and deleted text may cause page numbering in the TOC to be wrong. To avoid this problem, be sure this option is deselected before updating a TOC.

Customizing a table of contents

The table of contents can be customized to suit the style and requirements of the document.

To start, right-click anywhere in an existing table of contents and choose Edit Index in the context menu, or click in the document where the TOC should appear and choose Insert > Table of Contents and Index > Table of Contents, Index or Bibliography, to open the Table of Contents, Index or Bibliography dialog shown in Figure 353.

![Figure 353: Type tab of Table of Contents, Index or Bibliography dialog](image)
The Table of Contents, Index or Bibliography dialog has five tabs. Each tab covers a different aspect of the TOC structure and appearance:

- **Type** tab: set the attributes of the TOC.
- **Entries** and **Styles** tabs: format the entries in the TOC.
- **Columns** tab: put the TOC into more than one column.
- **Background** tab: add color or an image to the background of the TOC.

To display a preview box, located on the right-hand side of the dialog, select the **Preview** option in the lower left of the dialog. The illustrations in this chapter show the dialog as it appears with the preview box hidden.

---

**Note**

The preview box shows the result of settings made on the **Type**, **Entries**, and **Styles** tabs. It does not show changes made on the **Columns** and **Background** tabs.

---

After making all the changes, click **OK** to apply them. To revert to the default settings for the **Columns** and **Background** tabs, select each tab in turn and click the **Reset** button. The settings on the **Type**, **Entries**, and **Styles** tabs must be reset manually; the **Reset** button has no effect.

### Type tab

Use the **Type** tab (Figure 353) to set the attributes of the Table of Contents.

- **Title**
  
  To give the table of contents a different title, type it in the Title field. To delete the title, clear the Title field.

- **Type**
  
  Select a type in the drop-down list. For a TOC, be sure the Type is set to Table of Contents. See "Alphabetic indexes" on page 396 and "Other types of index" on page 404 for more about creating other types of indexes.

---

**Note**

You can change the type of index only when you first create it. Once you define an index type (for example, a table of contents) you cannot change it.

---

**Protected against manual changes**

By default, to prevent the TOC from being changed accidentally, this option is selected; the TOC can only be changed by using the context menu or the dialog. If the option is not selected, the TOC can be changed directly, just like other text. However, any manual changes will be lost when the TOC is updated, so they should be avoided.

### Create Index or Table of Contents

In the **For** drop-down list in this area, you can select whether the TOC will cover all the headings of the document (**Entire document**) or just the headings of the chapter where it is inserted. In early versions of LibreOffice, the heading level designating a chapter was fixed; from version 7.4, it is the current heading level.

### Evaluate up to level

Writer can use up to 10 levels of headings when it builds the table of contents. To specify the number of levels included, enter the required number in the **Evaluate up to level** box.

### Create From

The third section of the **Type** tab determines what Writer should use to create the TOC. The choices (not mutually exclusive) are Headings, Additional styles, and Index marks.
Headings

By default, Writer uses the paragraphs formatted with the paragraph styles associated with heading levels in **Tools > Heading Numbering**.

You can change the paragraph styles used for heading levels, and you can include other paragraph styles by assigning an outline level to those styles. Both of these methods are described in Chapter 8, Introduction to Styles.

Additional styles

You can add more paragraph styles to the TOC. This can be useful, for example, when you want to include the heading of an annex (appendix) in the TOC. If the Headings option is also selected, the additional styles will be included in the table of contents together with the ones defined in the heading numbering. Select this option and click the **Assign styles** button to open the Assign Styles dialog (Figure 354).

![Assign Styles dialog](image)

**Figure 354: Assigning additional styles to TOC levels**

Index marks

This selection adds any index entries inserted into the document by using **Insert > Table of Contents and Index > Index Entry**. Normally you would not use this selection for a table of contents. However, if you select **Table of Contents** in the Index drop-down list at the top of the Insert Index Entry dialog (Figure 355), Writer will distinguish between them and any index entries intended for inclusion in an alphabetic or other index.

![Insert Index Entry dialog](image)

**Figure 355: Insert TOC index entry**
Entries tab

Use the Entries tab (Figure 356) to define and format the entries in the TOC. Each level can be styled independently from the other levels by adding and deleting elements.

![Entries tab of Table of Contents, Index or Bibliography dialog](image)

Click a number in the Level column. The Structure line contains the elements included in the entries for that level. Elements that can be added to the structure line are displayed just below the structure line, and are grayed out if they cannot be included (usually because they are already in use):

- The **LS** icon represents the start of a hyperlink.
- The **N#** icon represents the heading number assigned to a heading style in **Tools > Heading Numbering**. See Chapter 8, Introduction to Styles.
- The **E** icon represents the heading text; that is, the text formatted with the paragraph style used for each level.
- The **T** icon represents a tab stop.
- The **#** icon represents the page number.
- The **LE** icon represents the end of a hyperlink.
- Each white field on the Structure line represents a blank space where you can add custom text or another element.

**Note**

In the Heading Numbering dialog (see Chapter 8, Introduction to Styles), if you have included any text in the Before or After boxes in the Separator section for any given level, then that text will be part of the N# field for that level. Take care when building the structure line not to create any unwanted effects in the appearance of the TOC.

Adding elements

To add an element to the Structure line:

1) Click in the white field where you want to insert the element.
2) Click one of the active buttons just below the Structure line. For example, to add a tab, click the Tab Stop button. An icon representing the new element appears on the Structure line.
3) To add custom text, such as the word Chapter, type the text in the white field. Don't forget a trailing space.
Changing elements
To change an element in the Structure line, click the icon representing that element and then click a non-grayed out element in the row of buttons just below the Structure line. For example, to change a chapter number to a tab stop, click the N# icon on the Structure line (it shows then as being pressed) and then click the Tab Stop button in the row of available elements. To cancel before changing an element, click in one of the white spaces.

Applying changes to all levels
If you wish to apply the same structure and formatting to all levels, click the All button on the right.

Deleting elements
To delete an element from the Structure line, click the button representing that element and then press the Delete key on your keyboard. For example, to delete the default hyperlink setting, click the LS icon and then press the Delete key. Repeat this for the LE icon.

Applying character styles
You might want an element to be a bit different from the rest of the line. For example, you might want the page number to be bold. To apply a character style to an element:

1)  Be sure you have previously defined a suitable character style.
2)  On the Structure line, click the button representing the element to which you want to apply a style.
3)  In the Character Style drop-down list, select the desired style.

To view or edit the attributes of a character style, select the style in the Character Style drop-down list and then click the Edit button.

Tip
The default character style for hyperlinks (such as those inserted by Insert > Hyperlink) is Internet Link, which by default is underlined and shown in blue.

The default hyperlinks of TOC entries are set to the Index Link character style, which may be different in appearance from the Internet Link style. If you want them to appear the same as internet links, you can select the LS icon on the Structure line and change the character style selection for TOC entries to Internet Link.

Alternatively, you can change the attributes for Index Link.

Tab parameters
Click on the Tab stop icon on the Structure line to bring up these controls:

•  Fill character: select the tab character you wish to use; the first choice is none (blank).
•  Tab stop position: specify the distance to leave between the left page margin and the tab stop. Optionally, select Align right for the tab stop; this selection inactivates the distance.

Tab position relative to paragraph style indent
When this option is selected, entries are indented according to the settings of their individual formats. Where a paragraph style specifies an indent on the left, tab stops are relative to this indent. If this option is not selected, tab stops are relative to the left margin position.
**Styles tab**

Use the Styles tab (Figure 357) to change which paragraph style is assigned to display the text of each level in the table of contents. In most cases, the best strategy is to keep the assigned styles but change their settings as needed to make the TOC appear the way you want.

To apply a custom paragraph style to an outline level:

1) In the Levels list, select the level.
2) In the Paragraph Styles list, click on the desired paragraph style.
3) Click the < button to apply the selected paragraph style to the selected outline level.

The style assigned to each level appears in square brackets in the Levels list.

To remove paragraph styling from an outline level, select the outline level in the Levels list, and then click the Default button.

To view or edit the attributes of a paragraph style, click the style in the Paragraph Styles list, and then click the Edit button.

![Figure 357: Styles tab of the Table of Contents, Index or Bibliography dialog](image)

**Columns tab**

Use the Columns tab to change the number of columns for the TOC. Multiple columns are more likely to be used in an index than in a TOC, so this tab is described in the section on indexes.

See Figure 362.

**Background tab**

Use the Background tab (Figure 358) to add color or an image to the background of the TOC.

See Chapter 6, Formatting Pages: Advanced, for more about adding a background.

![Figure 358: Background tab](image)
Adding color
To add color to the background of the table of contents, select the **Color** button near the top of the dialog, then select a color from those provided and click **OK**.

See Chapter 20, Customizing Writer, for information about defining custom background colors.

Adding an image
To add an image to the background of the table of contents, select the **Image** button. The **Background** tab now displays the image options.

Deleting a color or an image
To delete a color or an image from the table background, select **None** at the top of the dialog.

Editing a table of contents
To edit an existing TOC, right-click anywhere in the TOC and choose **Edit Index** in the context menu. You can also open the Navigator in the Sidebar, click the expansion symbol (+ sign or triangle) next to Indexes, then double-click on **Table of Contents**.

The Table of Contents, Index or Bibliography dialog (Figure 353 on page 390) opens. You can edit and save the TOC as described in the previous section.

Updating a table of contents
Writer does not update the TOC automatically, so after any changes to the headings in a document, you need to update the TOC manually. Right-click anywhere in the TOC; in the context menu, choose **Update Index**.

You can also update the index from the Navigator: expand Indexes, right-click on the name of table of contents you want to update, and choose **Index > Update**.

Deleting a table of contents
To delete the TOC from a document, right-click anywhere in the TOC and choose **Delete Index** in the context menu. You can also delete the index from the Navigator by choosing **Index > Delete** in the menu shown in Figure Error: Reference source not found. Writer will not prompt you to confirm the deletion.

Alphabetic indexes
An alphabetical index is a list of keywords or phrases used throughout a document that, if listed in order with page numbers, may help the reader find information quickly. Generally an index is found in the back of a book or document.

This section describes how to:

- Add index entries manually.
- Use a concordance file.
- Create an alphabetic index quickly.
- Customize the display of index entries.
- Customize the appearance of the index.
- View and edit existing index entries.
**Adding index entries**

Before you can create an index, you must create some index entries, either manually or by using a concordance (see page 398). To create index entries manually:

1) To add a word to the index, place the cursor anywhere in that word. To add multiple consecutive words as one entry, select the entire phrase.

2) Choose **Insert > Table of Contents and Index > Index Entry**, or click the **Insert Index Entry** icon on the Insert toolbar, to display a dialog similar to the one in Figure 359. When the dialog opens, the selected text appears in the **Entry** box. You can accept the word or phrase shown, or change it to whatever you want.

3) Click **Insert** to create the entry.

![Insert Index Entry dialog](image)

*Figure 359: Inserting an index entry*

**Tip**

A cursor placed immediately before the first character of a word, or immediately after the last character of a word if it is followed by a space, counts as being in that word.

You can create multiple entries without closing the dialog. For each one:

1) Click at the location in the document that you want to index.
2) Click again on the dialog.
3) Change the entry if needed, and click **Insert**.
4) Repeat steps 1–3 until you have finished with the entries, then click **Close**.

Below is a brief explanation of the fields in the Insert Index Entry dialog and how to use them.

**Index**

The type of index this entry is for. The default is Alphabetical Index, but you can use this field to create extra entries for a table of contents or user-defined indexes or lists of almost anything. For example, you might want an index containing only the scientific names of species mentioned in the text, and a separate index containing only the common names of species. See “Other types of index” on page 404.
Entry
The word or phrase to be added to the selected index. This word or phrase does not need to be in the document itself; you can add synonyms and other terms that you want to appear in the index.

1st key
An index key is an entry that has no associated page number and has several subentries that do have page numbers. Using keys is a useful way of grouping related topics. (See “Example of using an index key” on page 398.)

2nd key
You can have up to a three-level index, where some of the first-level keys have level-2 entries that are also keys (without page numbers). This degree of index complexity is not often necessary.

Main entry
When the same term is indexed on several pages, often one of those pages has more important or detailed information on that topic, so you want it to be the main entry. To make the page number for the main, or most important, entry stand out, select this option and then define the character style for the page number of a main index entry to be bold, for example.

Apply to all similar texts
Select this option to have Writer automatically identify and mark any other word or phrase that matches the current selection. The Match case and Whole words only options become available if this option is selected. Use this option with care, as it may result in many unwanted page numbers (for minor uses of a word) being listed in the index.

Example of using an index key
An index key is a primary entry under which subentries are grouped. For example, you might want to create a grouping similar to this:

LibreOffice
Calc, 10
Impress, 15
Writer, 5

In this example, LibreOffice is the 1st key. The subentries (with the page numbers showing) are the indexed entries. To insert an index entry for the topic Writer, on the Insert Index Entry dialog (Figure 359 on page 397), type Writer in the Entry box and LibreOffice in the 1st key box.

Note
If field shading is active (Tools > Options > LibreOffice > Application Colors > Text Document > Field shadings), when a selected word or phrase has been added to the index, it is shown in the text with a gray background. If the text of an index entry has been changed from the text of the word selected, the index entry is marked by a small gray rectangle at the start or end of that word.

Creating a concordance
A concordance is a plain text file that lists words to add to the index. It has one word or phrase defined on each line. Each line has a strict structure, consisting of seven fields, separated by semicolons:

Search_term;Alternative_entry;1st_key;2nd_key;Match_case;Word_only

No space is entered between the semicolon and a field's content. A key is a higher level heading that a search term is placed beneath.
If you choose not to have an alternative entry, a first key or a second key, leave those fields blank, so that one semi-colon immediately follows another.

The last two fields are structured somewhat differently. If you want only entries that have the same upper or lower case letters as your entries, enter 1 in the second to last field. Similarly, entering 1 in the last field sets the index to only include instances where the entry is a whole word, and not part of a larger one. You can also leave the last two fields blank, as you can with any of the others.

For example, entering:

Macaw;Ara;Parrots;;0;0

Would produce an entry for macaw with

- A listing under macaw.
- An alternate listing under ara (the scientific name).
- A listing of Parrots, Macaw.
- No second key (notice the two semi-colons).
- Inclusion of instances that start with a lower or upper case letter (both “macaw” and “Macaw”).
- Inclusion of instances in which the term is a whole word or part of a longer word.

Whether creating a concordance is faster than adding entries manually is debatable, but a concordance is certainly more systematic. The disadvantage of a concordance is that it can produce an index that includes instances of common words that are irrelevant for your purposes. In many cases, a useful index may require a combination of manual entries and a concordance.

Creating an alphabetic index quickly

Now that you have some index entries, you can create the index.

Although indexes can be customized extensively in Writer, most of the time you need to make only a few choices.

To create an index quickly:

1) Click in the document where you want to add the index and click Insert > Table of Contents and Index > Table of Contents, Index or Bibliography to open the Table of Contents, Index or Bibliography dialog.

2) In the Type box on the Type tab (Figure 360), select Alphabetical Index.

3) In the Options section, consider deselecting Case sensitive (so capitalized and lower-case words are treated as the same word) and Combine identical entries with p or pp.

4) If using a concordance, select Concordance file in the Options section, then click the File button and select the concordance file you created.

5) Click OK. The result will be a typical index.

Customizing an index

To customize an existing index, right-click anywhere in the index and choose Edit Index in the context menu.

The Table of Contents, Index or Bibliography dialog (Figure 360) has five tabs. All of them can be used to customize the index.

- Type tab: set the attributes of the index.
- Entries and Styles tabs: to format the entries in the index.
• **Columns tab**: put the index into more than one column.

• **Background tab**: add color or an image to the background of the index.

After making your changes, click **OK** to save the index so it appears in your document.

**Type tab**

Use the **Type tab** (Figure 360) to set the basic attributes of the index.

To give the index a different title, edit the Title field. To delete the title, clear the Title field.

Be sure the type of index is set to Alphabetical Index.

By default, to prevent the index from being changed accidentally, the option **Protected against manual changes** is selected; the index can only be changed by using the context menu or the dialog. If the option is not selected, the index can be changed directly just like other text, but any manual changes to an index will be lost when it is updated, so they should be avoided.

![Figure 360: Type tab for an alphabetic index](image)

In the drop-down list in the **Create Index or Table of Contents** section, select **Entire document**, or choose to create an index for just the current chapter.

Other options determine how the index handles entries.

**Combine identical entries**

Defines how identical entries are dealt with. Normally each page number of an indexed word or phrase will be shown in the index; however, these can be combined using the **Combine identical entries with p or pp**.

If you want a page range displayed, select **Combine with –** (which will produce something similar to 23–31). To include different entries based on what letters are capitalized, select **Case sensitive**.

**AutoCapitalize entries**

Automatically capitalizes the first letter of each entry regardless of how the terms show within the document.

**Keys as separate entries**

For the index keys to have their own page numbers, select this option.
Concordance file
Choose the concordance file to be used, if any. See page 398 for more information.

Sort
Defines how the entries are sorted when displayed. The only option is alphanumeric, but you can define which language alphabet will be used.

Entries tab
Use the Entries tab to set exactly how and what will be displayed for each of the entries. The tab is similar to Figure 361.

Note
Hyperlinking from the index to the location of entries in the text is new in Writer 7.6.

Figure 361: Entries tab for an alphabetical index

To begin, in the Level column select the index level whose elements you want to format. Level “S” refers to the single letter headings that divide the index entries alphabetically when the Alphabetical delimiter option is selected in the Format section. (You will be able to apply your changes to all index levels later.) In the Structure and Formatting section, the Structure line displays the elements for entries in that level. Each button on the line represents one element:

- The E icon represents the entry text.
- The T icon represents a tab stop.
- The # icon represents the page number.
- The HI icon represents chapter information. This is not present by default, but can be added by selecting the Heading info button.

Each white field on the Structure line represents a blank space. You can add, change, or delete elements as described on page 393 for a table of contents.

Heading Info
The Heading Info button inserts heading information, such as the heading number and contents, as selected from the Heading info list that appears when this option is selected. Heading information is specified in Tools > Heading Numbering.
Applying character styles
Each element on the Structure line may be given additional formatting. For example, you may want the page number to be a different size from the rest of the index text. To do this, apply a character style to one of the elements in the Structure line, as for a table of contents (page 394).

Formatting entries
Apply additional formatting using the options in the Format section.

Alphabetical delimiter
This separates the index entries into blocks that start with the same first letter, using that letter as a header. For example, if the index begins:

apple, 4
author, 10
break, 2
bus, 4

Then selecting this option will produce:

A
apple, 4
author, 10

B
break, 2
bus, 4

Key separated by commas
Arranges the entries in the index on the same line but separated by commas.

Tab position relative to Paragraph Style indent
When selected, entries are indented according to the settings of their individual formats. Where a paragraph style with an indent on the left is in use, tab stops will be relative to this indent. If this option is not selected, tab stops will be relative to the left margin position.

Styles and Background tabs
Use the Styles tab to change which paragraph style is assigned to display the text of each level in the index. In most cases, the best strategy is to keep the assigned styles but change their settings as needed to make the index appear the way you want.

The Background tab is the same as for TOCs. Refer to “Styles tab” on page 395 and “Background tab” on page 395 for detailed information on these tabs.

Columns tab
Use the Columns tab (Figure 362) to change the number of columns for the index.
Adding multiple columns
To display the index in more than one column:

1) Enter the number of columns desired in the box labeled Columns or select the icon representing the number of columns.

2) To evenly distribute the columns according to the page width, select the AutoWidth box. If it is unchecked, you can manually set each of the following:
   – Width of each of the columns
   – Spacing between the columns

3) To have a separator line between the columns:
   – Style: The default is None, or select from three choices of line style.
   – Width: The width (thickness) of the line. The default is 0.25pt.
   – Color: Choose the color of the separator line. The default is Black.
   – Height: The height of the line, as a percentage of the full column height. The default is 100%
   – Position: Position of the line relative to the columns (top, centered, or bottom) if the height is less than 100%.

Maintaining an index
To modify the appearance of an index, right-click anywhere in the index and choose Edit Index in the context menu. The Table of Contents, Index or Bibliography dialog opens and you can edit and save the index using the five tabs described in the previous section.

To update or delete an index, right-click anywhere in the index and select Update Index or Delete Index.
**Viewing and editing existing index entries**

Once you have added the initial entries, you can make some amendments. You can view and edit these using the following steps:

1) Ensure that field shading is active (View > Field Shadings or Ctrl+F8), so you can locate index entries more easily.

2) Place the cursor in the field shading of an existing index entry in the body of the document, right-click, and select Edit Index Entry in the content menu. In the case of a changed-text entry, the field shading is immediately before the word. Placing the cursor immediately before a word marked as a text entry will satisfy both selection criteria.

3) A dialog similar to Figure 363 appears. You can move through the various index entries using the forward and back arrow buttons. If there is more than one entry for a single word or phrase, a second row of buttons with a vertical bar at the point of the arrow head is displayed allowing you to scroll through each of these entries.

4) Make the necessary modifications or additions to the index entries, and then click **OK**.

![Figure 363: Viewing and editing index entries](image)

**Other types of index**

An alphabetical index is not the only type of index that Writer can produce. Other types include indexes of figures, tables, and objects, and you can even create a user-defined index. This chapter does not give examples of all the possibilities.

To create other indexes:

1) Place the cursor where you want the index created.

2) Select Insert > Table of Contents and Index > Table of Contents, Index or Bibliography on the Menu bar.

3) On the Table of Contents, Index or Bibliography dialog, in the Type drop-down list, select the index wanted.

4) Modify the various tabs, which are similar to those discussed in previous sections.

5) Click **OK** when everything has been set.
Example: Creating an table of figures

Creating a table of figures or tables is easy if the figure captions were created using Insert > Caption or manually using a number range variable as described in Chapter 17, Fields.

1) On the Table of Contents, Index or Bibliography dialog, in the Type drop-down list, choose Table of Figures. Optionally, change the Title.

2) Be sure Captions is selected in the Create From section, and choose the category of caption. The default for Category is Figure; the example uses Figure for the captions.

3) Under Display, you can choose References (to include the category, number, and caption text), Category and Number, or Caption Text. We have chosen References.

4) Optionally select Create from additional paragraph style and select a style from the list.

5) The other tabs of this dialog are similar to those described for tables of contents.

6) Click OK. The result is shown in Figure 365.

Table of Figures

Figure 1: Type tab of Table of Contents, Index or Bibliography dialog
Figure 2: Assigning additional styles to TOC levels
Figure 3: Entries tab of Table of Contents, Index or Bibliography dialog
Figure 4: Styles tab of the Table of Contents, Index or Bibliography dialog
Figure 5: Background tab, showing Color choices
Figure 6: Image options on the Background tab
Figure 7: Insert Index Entry icon on Insert toolbar
Figure 8: Inserting an index entry
Figure 9: Type tab for an alphabetic index
Figure 10: Entries tab for an alphabetical index
Figure 11: Columns tab of the Table of Contents, Index or Bibliography dialog
Figure 12: Viewing and editing index entries
Figure 13: Creating other types of indexes
Figure 14: Resulting table of figures
Figure 15: Bibliography Database main window
Figure 16: Setting up a filter for the bibliographic database

Figure 365: Resulting table of figures
Bibliographies

A bibliography is a list of references used in a document. The references can be stored in a bibliographic database or within the document itself.

This topic shows you how to use Writer's facilities to:

- Create a bibliographic database; add and maintain entries.
- Add a reference (citation) into a document.
- Format the bibliography.
- Update and edit an existing bibliography.

Citation styles and the bibliographic database

Although you can create citations (references) within a document itself, creating a bibliographic database allows reuse in other documents and saves a lot of time.

Citations within the text require entries in different fields in the bibliography database, and different presentations in the text. Before creating a list of references, determine which citation style you need for a document. The five main styles are:

- MLA (Modern Languages Association): Literature, art, and humanities.
- Chicago: History and specific publications.
- Turabian: A variation of the Chicago style for general use by university students.
- AMA (American Medical Association): Medicine, Health, and Biology.

The Bibliography Database (Figure 366) is the source for citations in the text, no matter what citation style you use.

All citations use the Identifier field to set the format for a citation in the document. In this column, add the citation in the correct form for the citation style. All necessary information, including the Identifier field, should be entered before any citation is created in the document.

Tip

Writer has a single bibliography database for all documents. Since formatting entries can be tedious, consider creating a template with citations for each type of source material.

Creating a bibliographic database

For most of this topic, the database table used is the sample one that comes with Writer. For information on creating a new table in the bibliographic database, see the Getting Started Guide.

The bibliography database has to cover many different media and circumstances, which is why it contains so many fields. It also includes fields such as ISBN that no citation style uses, but might be useful to you during your research.

Note

Any single entry in the bibliography needs only about half a dozen fields filled in, no matter what citation format you use. What differs is the fields needed for each type of source material and the order of the fields in each citation style.
To open the database select **Tools > Bibliography Database**. The Bibliography Database window, similar to that in Figure 366, opens. The upper part of the tab shows all of the records, in a table layout similar to that of a spreadsheet. The lower part of the tab shows all the fields of the selected record.

**Note**

The **Identifier** column in the database table and the **Short Name** field below the table are the same field. The sample entries in the sample database for these fields are meaningless. Replace them with the proper format for the citation style to be used.

![Bibliography Database main window](image)

**Figure 366: Bibliography Database main window**

**Changing the data source**

To change the data source in use (for example, if you have more than one bibliographic database for different purposes), select **Data > Choose Data Source** on the Menu bar, or click the **Data Source** button on the toolbar near the top of the Database window. The Choose Data Source dialog lists registered data sources. Select one of them and click **OK**.

To add (register) a different data source, see instructions in the **Getting Started Guide**.
Filtering records
To set up a filter for specific records within the bibliographic database, select Data > Filter on the Bibliographic Database Menu bar, or click the Standard Filter button on the toolbar near the top of the window. In the Standard Filter dialog (Figure 367), choose the fields, conditions, and values for the filter and click **OK**.

![Figure 367: Setting up a filter for the bibliographic database](image)

Adding entries to the database
Entries can be added to the bibliography database in two ways: using the Data Source view of the database, or the Bibliography Database window.

To add entries using the Data Source view of the bibliography database:

1) Select View > Data Sources on the Menu bar, or press Shift+Ctrl+F4, to open the data source window, similar to Figure 368.

2) Make sure that the correct table is selected in the Bibliography database. You may have to expand some levels to be able to select the correct ones.

![Figure 368: Data Source view of Bibliography database](image)

3) Scroll to the bottom of the list and type into the relevant fields in a blank line. The **Save current record** icon (in the upper left) becomes active. Click on it to save the addition to the database.

To add entries using the Bibliography Database window:

1) Select Tools > Bibliography Database on the Menu bar. The window shown in Figure 366 on page 407 opens.

2) Select Data > Record on the Menu bar of the window, or click the + icon to the left of the horizontal scroll bar.

3) Type a name for the entry in the **Short Name** box. Complete other fields as required.

4) To complete the entry and add it to the database, click on any other cell in the table.
Maintaining entries in the database

To maintain entries in the database, use either the Data Source view or the Bibliography Database window. Select the appropriate record and modify the fields as appropriate.

Modified entries are saved automatically to the database when the cursor moves off the record.

Advanced: Modifying the bibliographic database

You can modify the bibliography database in several ways, as summarized below.

Note

For more information on how to use LibreOffice’s database features, see the Getting Started Guide.

Column details

To change the details of columns in the bibliographic database, select Data > Column Arrangement on the Menu bar, or click the Column Arrangement button on the toolbar near the top of the window (Figure 366). On the Column Layout dialog (Figure 369), you can change which fields are allocated to columns. For example, you can select to have Author data go into the Identifier column, by changing the destination in the drop-down list. The Short name data column destination sets to <none> automatically, to prevent setting duplicate destinations for data.

Figure 369: Changing column layout for bibliographic database
Field details
To make changes to the bibliography database (for example, rename fields or change the length of fields), do the following:

1) In the main document (not the Bibliography Database window), press Shift+Ctrl+F4 or click View > Data Sources to open the Data Source window, similar to Figure 368.

2) Make sure that the Bibliography database is selected as well as the correct table.

3) Right-click the table entry (biblio in the example) and select Edit Database File in the context menu. This opens a window similar to Figure 370, which is the main menu for Base, the database component of LibreOffice.

4) If Tables (in the Database section on the left) is not selected, select it now.

5) Right-click the biblio table name in the Tables section and select Edit in the context menu to display a window similar to that shown in Figure 371.

6) You can now select each of the fields. Select the text in the Field Name cell and change the entry as required. Click in the Field Type cell to open a selection menu to change the data type in that cell. In the Field Properties section, you can modify the data properties. For each field selected, a description of that field appears to the right of the section.

7) When finished, you will be asked to confirm that you want the changes saved.

Figure 370: Main window for working with databases
Adding references (citations) into a document

Writer supports two methods of adding references to your document:

- From a bibliography database, such as the one built into Writer.
- Directly from the keyboard.

Entering references from a database

To add references from the bibliographic database into a document:

1) Place the cursor where you want the reference to appear.
2) On the Menu bar, choose Insert > Table of Contents and Index > Bibliography Entry.
3) In the Insert Bibliography Entry dialog (Figure 372), choose Bibliography database in the Bibliography Source section at the top of the dialog.

4) Select the reference from the Short name drop-down list in the middle of the dialog. The Author and Title of the selected reference are shown below the Short name field, to help you verify that it is the reference you want.
5) To insert the reference into the document, click **Insert**. You can keep the dialog open and insert another reference into the document; you do not need to close and reopen it.

6) When you have finished inserting all the references, click **Close**.

**Entering references from documents**

You may choose to enter bibliographic entries directly into the document, instead of from an external database. Click in the document where you want to add the entry.

1) Select **Insert > Table of Contents and Index > Bibliography Entry**.

2) In the Insert Bibliography Entry dialog (Figure 372), select **Document content** in the **Bibliography Source** section at the top of the dialog.

3) Click **New** to open the Define Bibliography Entry dialog.
   a) Complete all the fields that are relevant to your entry. Type a unique name in the **Short name** box; the Insert Bibliography Entry dialog uses this entry for the citation.
   b) Select an option in the menu in the **Type** box to enable the **OK** button.
   c) Click **OK** when all the fields wanted are completed.
   d) Click **Insert** to add the Short name field to the document, and then click **Close**.

To re-use an entry in your document, restart the sequence above, and then select the Short name required from the current list of entries, instead of selecting to add a new entry.

**Editing a reference**

To edit a reference:

1) Right-click the entry (the cursor then displays to the left of the entry).

2) In the context menu, select **Bibliography Entry**. The Edit Bibliography Entry dialog (similar to the Insert Bibliography Entry dialog) opens.

3) To quickly edit only the Short name, click the text box, edit the entry and then click **Apply**.

4) To edit more of the entry, click **Edit** to open the Define Bibliography Entry dialog.
   Make any changes required and then click **OK** to return to the Edit Bibliography Entry dialog.

5) Click **Apply** to accept the changes and exit the dialog.

**Note**

Modified references are stored only in the document. If the source is a bibliography database, that database remains unmodified.

**Creating the bibliography**

1) Place the cursor at the point where you wish to insert the bibliography.

2) Select **Insert > Table of Contents and Index > Table of Contents, Index or Bibliography** and change the **Type** to Bibliography, to display a dialog similar to that shown in Figure 373.
Type tab

Writer supports two ways of displaying references (citations) in the text of a document:

- Using the text recorded in the Short name field of each bibliographic entry, for example (Smith, 2001) depending on citation style.
- By numbering the referenced documents in the sequence they occur in the text, for example [1].

Tip

To specify which citation style is used in the document, use the Type tab on the Table of Contents, Index or Bibliography dialog (Figure 373).

Formatting the bibliography involves choices made in two places:

- Table of Contents, Index or Bibliography dialog, covered in this section.
- Bibliography 1 paragraph style (see page 414).

The basic settings are selected on the Type tab.

1) To give the bibliography a title, enter it in the Title field. (A title is not required.)
2) You can protect the bibliography from being changed accidentally, by selecting Protected against manual changes. If this option is selected, the bibliography can only be changed using the right-click menu or the Table of Contents, Index or Bibliography dialog. If the option is not selected, the bibliography can be changed directly on the document page, just like other text, but any manual changes will be lost when you update the bibliography.
3) To have the bibliographic entries (citations) numbered within the body of the document (for example, [1], [2]...), select Number entries. If, however, you wish to have the Short name field contents (from the database) appear in the document, deselect this option.
4) Select the type of brackets that you want for the referenced entries shown within the body of the document.
5) Define the sorting you require. Currently only alphanumeric sorting is supported. Sorting by the sequence that entries appear in the text is done on the Entries tab.
Entries tab

The structure of the Entries tab (Figure 374) is similar to that for tables of contents and indexes.

![Entries tab](image)

**Figure 374: Entries tab for bibliographies**

The *Type* section refers to the kind of source, such as a book, periodical, or web page. Each entry in the Type list has a default structure format. You can define how the entry will appear, based on its source, by selecting from the Type list of entries, or simply apply the same format to all entries by clicking the *All* button.

The Structure of the entry is based on the fields available in the bibliographic database. Consult the citation style required for your document and modify the Structure line as needed.

To remove elements from the Structure line, click the element, then click the *Remove* button.

To add an element, click in the Structure line where it is to be inserted. Select either the *Tab Stop*, or an element in the drop-down list to the left of the *Insert* button, and then click *Insert*. The elements in the drop-down list are those fields found in the Bibliography Database.

All the elements on the Structure line can be formatted using the Character Style selection list. For example, you can define a character style so that book and journal titles are in italics or bold.

To determine how entries are sorted, modify the *Sort by* options. To sort by the sequence that entries appear in the text, choose *Document position*. In most modern citation styles, you will want *Content* (alphabetical descending order). Use *Sort keys* to group similar references.

**Styles, Columns and Background tabs**

Refer to “Styles tab” on page 395, “Columns tab” on page 402 and “Background tab” on page 395 for detailed information on these tabs.

**Modifying the paragraph style for the bibliography**

You can modify the Bibliography 1 paragraph style to suit your requirements. For example, to number the entries in the bibliography list, you need to define a list style and link that list style to the Bibliography 1 paragraph style. To do this:

1) On the Styles deck in the sidebar, click on the *List Styles* icon. Right-click on *Numbering 123* and choose *New* in the context menu.
2) In the List Style dialog, go to the Organizer tab and type a name for this style. In our example, we have named it **Bibliography**.

3) In our example we want to have the numbers enclosed in square brackets. To do this, go to the Customize tab and type `[` in the Before box and `]` in the After box, as shown in Figure 375. Remove any other punctuation, such as a period, that may be in the After box.

![Figure 375: Specifying square brackets before and after the number in a list](image)

4) Now go to the Position tab of the List Style dialog (Figure 376). In the Indent at and Tab stop at boxes, specify how much indentation you want for the second and following lines of any item in the bibliography list of your document. Often you will need to experiment a bit to see what is the best setting. In our example, we have chosen 1 cm.

![Figure 376: Setting the spacing between the margin and the text](image)

5) Click **OK** to save these settings and close the List Style dialog. Return to the Styles deck, click the Paragraph Styles icon, choose All Styles in the list at the bottom of that window, then right-click on Bibliography 1 and choose **Modify**.
6) On the Paragraph Style dialog, go to the Outline & List tab and select Bibliography in the List Style drop-down list (Figure 377). Click OK to save this change to the Bibliography 1 paragraph style.

Figure 377: Applying a list style to a paragraph style

Now when you generate the bibliography, the list will look something like the one shown in Figure 378. You may also need to modify the structure line on the Entries tab (Figure 374).

Figure 378: Result of changing settings for Bibliography 1 paragraph style

Updating, editing, and deleting an existing bibliography

Right-click anywhere in the bibliography. From the context menu, select:

- **Update Index** to update the bibliography.
- **Edit Index** to open the Table of Contents, Index or Bibliography dialog so you can edit and save the bibliography.
- **Delete Index** to delete the bibliography without a confirmation request.

External bibliography tool

If you find Writer’s bibliography feature too limited, you may wish to try Zotero, a free and open source tool, available for macOS, Windows, and Linux. It is reported to work well with Writer (https://www.zotero.org/).
Chapter 16, 
Master Documents
What is a master document?

A master document (.odm) is a container that joins separate text documents (.odt) into one larger document and unifies the formatting, table of contents (TOC), bibliography, index, and other material. Master documents are typically used for producing long documents such as a book, a thesis, or a long report. Figure 379 shows a typical scheme for master documents.

![Figure 379: Structure of a master document](image)

**Note**

A master document is actually a Writer document with some extra features for handling linked subdocuments. All features of a text document are available to a master document including printing, export to PDF, and export to a conventional Writer text document.

Why use a master document?

A master document is especially useful in these situations:

- When the file size or number of pages is quite large; writing, reviewing, and editing may be easier when done on subsets of the full document.
- When for security and reliability reasons you choose to store chapters in different places to minimize risks of losing the complete document (single point of failure).
- When a long report needs periodic updates of a single set of subdocuments, not affecting the structure of the report.
- When different people are writing different chapters or other parts of the full document.
• When files will be published as stand-alone documents as well as becoming part of a larger document. The chapters of this Writer Guide are an example of this usage.

• When subdocuments are used in more than one final document.

You can use several methods to create master documents. Each method has its advantages and disadvantages. Which method you choose depends on what you are trying to accomplish. The different methods are described in this chapter, along with suggestions on when to use each one.

**Master document Navigator**

In Writer, the Navigator has two forms: one is used in ordinary text documents and the other in master documents.

In an ordinary text document, the Navigator displays lists of the graphics, tables, index entries, hyperlinks, references, and other items in the document, as shown on the left in Figure 380. The master document Navigator on the right displays the document structure shown in Figure 379.

![Figure 380: Navigator for a text document (left) and for a master document (right)](image)

In a master document, you can toggle between the regular and master views by clicking on the **Toggle Master View** icon at the upper left. In the master view, the Navigator lists the subdocuments and text sections, as shown on the right in Figure 380. The use of the Navigator in a master document is covered in more detail later in this chapter (see “Step 6. Insert the subdocuments into the master document” on page 428 and “Combining several documents into a master document” on page 430).

**Note**

You cannot edit the contents of a subdocument shown in a master document. The subdocuments are linked in read-only mode. You will be warned if you try.

However, a double-click on a subdocument entry in the master document Navigator opens the subdocument for editing. This can be a convenient way to quickly open a subdocument file when doing the finishing touches of the master document.
Styles in master documents and subdocuments

A stand-alone document becomes a subdocument when it is linked into a master document.

A document can be used as a subdocument in several master documents. Each master document may have different style definitions (font, type size, color, page size, margins, and so on), which affect the appearance of the final document, but the individual documents retain their original characteristics.

The relationships between styles in a master document and its subdocuments are as follows:

- Custom styles used in subdocuments, such as paragraph styles, are automatically available to the master document. This preserves the custom formatting of subdocuments in the master document final result.
- The styles in the subdocuments are only changed in the master document, so when a subdocument is opened for editing the original subdocument styles are not affected. This preserves subdocuments' style specifics.
- If a style with the same name exists in the master document and in the subdocuments (for example, Default Paragraph Style), then the master document style overrides the style of the subdocument. This provides formatting consistency for all subdocuments contents in the master document final result.
- If more than one subdocument uses a custom style with the same name (for example, myBodyText), then only the one in the first subdocument to be linked is imported into the master document. The custom style of the first subdocument over-rides the custom style of the same name used in the other subdocuments.
- Direct formatting used in subdocuments is preserved in the master document.

**Tip**

Master document best practices recommend to use the same document template for the master document and its subdocuments. Then the subdocuments will look the same when they are loaded into the master document as they do when viewed as individual files.

When you modify or create a style, be sure to make the change in the template. Then when you reopen a subdocument or a master document, the styles can be updated from the template.

If the master document and the subdocuments do not share the same original template, it may be necessary to update the set of styles available to all subdocuments and master document.

### Updating a master document

Since master documents are containers for linking individual subdocuments, it is important to update the master periodically to refresh indexes, table of contents, page numbering, references, and more, especially after editing subdocuments.

**Note**

When opening a master document, Writer prompts to update the links to the subdocuments. Click **Yes** to refresh the master document immediately.
To update the master document at any time, choose **Tools > Update > Update all** (or any of the specific elements listed in the submenu), or use the icons in the master document Navigator (Figure 381).

![Figure 381: Update icon in the Navigator](image)

Depending on the document complexity, this operation may take some time, as Writer will go through all the linked files to rebuild the master document with all the references adjusted.

**Note**

When saving a master document, all the subdocuments are embedded in the master. This allows the master document to be opened in full when the linked subdocuments are not available. In this case, when you are asked if you want to update all links, choose **No**.

### Creating a master document: scenarios

Which method you choose from the three most common methods for creating a master document depends on the current state of your document:

- You already have a master document template available. See “Creating a master document template” on page 435,
- You have no existing documents but intend to write a long book containing several chapters, possibly by multiple authors.
- You have several existing documents (chapters) by one or more authors that you want to combine into one book, controlled by the master document.
- You have one existing document (a book) that you want to split into several subdocuments (chapters) that will be controlled by the master document.

We will look at each of these scenarios in turn.

### Starting with a master document template

As described in Chapter 10, Working with Templates, you can start a blank master document using a master document template created previously. Ideally, the template should contain the formatting styles, the document's front and back covers, the table of contents, and other parts of the final document.

1) If any text or page breaks came into this document from the template, delete the text. (The TOC, index, and any fields in headers and footers can stay.)
2) Add the subdocuments as explained in “Step 6. Insert the subdocuments into the master document” on page 428.
3) Update the master document so the references, table of contents, page numbering, and other automatic operations are refreshed.
Starting with no existing documents

When you start with no existing documents, you can set up everything the way you want from the beginning. Follow these steps, in the order given. Each step is explained in detail in the following topics.

   Step 1. Plan the project
   Step 2. Create a template
   Step 3. Create the master document
   Step 4. Create subdocuments
   Step 5. Add some pages to the master document
   Step 6. Insert the subdocuments into the master document
   Step 7. Add table of contents, bibliography, index

Step 1. Plan the project

Although you can make changes at most steps in this process, the more you can plan before you start, the less work you will have to correct any problems later. Here are some things you need to plan. Figure 379 shows the structure to plan for the task.

Parts of book or report required. What pages will be in the master document and what will be in the subdocuments? Consider as an example a book with the parts given in the table below.

<table>
<thead>
<tr>
<th>Part</th>
<th>Location</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title (cover) page</td>
<td>In master document</td>
</tr>
<tr>
<td>Copyright page</td>
<td>In master document</td>
</tr>
<tr>
<td>Table of contents (TOC)</td>
<td>In master document</td>
</tr>
<tr>
<td>Preface (Foreword)</td>
<td>Subdocument</td>
</tr>
<tr>
<td>Chapters 1 to 7</td>
<td>Subdocuments</td>
</tr>
<tr>
<td>Bibliography</td>
<td>In master document</td>
</tr>
<tr>
<td>Index</td>
<td>In master document</td>
</tr>
</tbody>
</table>

Page, paragraph, character, frame, and numbering styles. Determine the styles you wish to use. See Chapter 8, Introduction to Styles, and Chapter 9, Working with Styles, for instructions on how to create or modify styles and examples of the use of styles in book design. Pay particular attention to setting up headings using styles, as described in Chapter 8.

Fields and AutoText entries, as required. See Chapter 2, Working with Text: Basics, and Chapter 17, Fields, for ideas.

One or more templates for master and subdocuments. If you are starting a new project, create the master document and all the subdocuments from the same template. Not using the same template can create style inconsistencies that could cause your document not to look as you expect. For example, if two subdocuments have a style with the same name that is formatted differently in each document, the master document will use the formatting from the first subdocument that was added.

Page numbering. In our example, the pages are numbered sequentially from the title page. (The title page style can be defined not to show the page number, but it will still count as page 1.) Therefore the first chapter begins on a higher number page, for example page 5. To create a book in which the page numbering restarts at 1 for the first chapter, you need to do some additional work. See "Restarting page numbering" on page 432.
Step 2. Create a template

You can create a template from an existing document or template that contains some or all of the page, paragraph, character, and other styles you want for this document, or you can create the template from a blank document. For more about templates, see Chapter 10, Working with Templates. Be sure to use File > Save As Template when creating the template.

Tip

You can also create master document templates; see page 435.

Step 3. Create the master document

It does not matter in what order you create the master and subdocuments, and you do not have to create all the subdocuments at the same time, when you are starting the project. You can add new subdocuments at any time, as you need them.

Follow this process to create the master document:

1) Open a new document from the template you created in Step 2. Create a template, by choosing File > New > Templates, then selecting the template you created. Be sure the first page of this new document is set to the page style you want for the first page of the final document. In our example, the style for the first page is Title page.

2) If any text or page breaks came into this document from the template, delete the text. (The TOC, index, and any fields in headers and footers can stay.)

3) Click File > Send > Create Master Document. Save the master document in the folder for this project. We will return to this master document later. For now, you can either leave it open or close it.

Note

Using File > New > Master Document will create a master document file (.odm) associated with the default template. If your document is, or will be, based on a custom template, use the method described above.

Step 4. Create subdocuments

A subdocument is no different from any other text document. It becomes a subdocument only when it is linked into a master document and opened from within the master document. It can still be used as a stand-alone document. Some settings in the master document will override the settings in a subdocument, but only when the document is being viewed, manipulated, or printed through the master document.

Create a subdocument in the same way as you create any ordinary document:

1) Open a blank document based on the project template (very important) by choosing File > New > Templates, then selecting the required template.

2) Delete any unwanted text or other material that was brought in from the template, and set the first page to the page style you specified for the first page of a chapter.

3) Click File > Save As. Give the document a suitable name and save it in the folder for this project.

If you already have some of the chapters written, the files may not be based on the template you just created for this project. Although you can use the existing files as subdocuments as they are, you may want to change the template attached to those files; if so, use the technique described in Chapter 10, Working with Templates.
Step 5. Add some pages to the master document

To assist you, do the following:

- Make sure paragraph marks are showing. You can set them in **Tools > Options > LibreOffice Writer > Formatting Aids**, or click the **Toggle Formatting Marks** icon on the Standard toolbar, or press **Ctrl+F10**.
- Show text boundaries, table boundaries, and section boundaries (**Tools > Options > LibreOffice > Application Colors**).

If the master document does not contain any required “front matter” such as a title page, copyright page, or TOC page, add them now. The example in this section uses the sequence of page styles given in “Step 1. Plan the project” on page 425.

1) Open the master document (.odm file) you created and type the contents of the title page (or leave placeholders and fill in later). With the insertion point in the last blank paragraph on the page, click **Insert > More Breaks > Manual Break**. On the Insert Break dialog, select **Page break** and the page style for the second page (**Copyright Page** in our example), and leave the **Change page number** option deselected. Click **OK**.

![Figure 382: Inserting a page break between the title page and the copyright page](image)

2) Type the contents of the copyright page (or leave placeholders). With the insertion point in the last blank paragraph on the page, use the same method to insert another manual page break, this time setting the page style to **Table of Contents** page.

3) On the Table of Contents page, leave a blank paragraph or two or insert a TOC (**Insert > Table of Contents and Index > Table of Contents, Index or Bibliography**). The TOC will not have any contents until you add the subdocuments, but a gray mark or box indicates its location. For more about inserting and formatting TOCs, see Chapter 15, Tables of Contents, Indexes, Bibliographies.

**Note**

Depending on the style definitions for the first paragraph (usually a heading) on the Copyright and TOC pages, you may not need to insert manual page breaks.
Step 6. Insert the subdocuments into the master document

Now we are ready to add the subdocuments.

**Tip**

Subdocuments are inserted into a master document *before* the item highlighted in the Navigator. If you insert the last subdocument first, and then insert the other subdocuments before the last one, they will end up in the correct sequence without the necessity of moving them up or down in the list.

1) Display the Navigator (click the **Navigator** icon on the Sidebar).
2) Be sure the **Navigator** is showing the Master View (see “Master document Navigator” on page 422). If necessary, click the **Toggle Master View** icon at the upper left to switch between regular and master views.
3) On the Navigator, select **Text**, then click **Insert > File** on the Navigator toolbar, or right-click on **Text** and select **Insert > File** in the context menu.

![Figure 383: Inserting a subdocument into a master document using the Navigator](image)

A standard file browser dialog opens. Select the required file (which you created in Step 4) and click Insert. This example uses seven chapters; we will load Chapter 7 first, as suggested in the Tip above.

The inserted file is listed in the Navigator before the Text item, as shown in Figure 384.

![Figure 384: Navigator after inserting one subdocument](image)

4) Because the Text section contains the title page and other material, highlight it and click the **Move Up** icon to move it to the top of the list. (Or, highlight the subdocument you just inserted (Chapter 7) and click the **Move Down** icon to move it below the Text section.)
5) Highlight the subdocument you just inserted (Chapter 7), then click **Insert > File** to insert the first subdocument; in this example, Chapter 1. Chapter 7 remains highlighted. Repeat with Chapter 2, Chapter 3, and so on until all the subdocuments have been added to the list. You can insert several several files at the same time. The Navigator will now look something like Figure 385.
6) Save the master document again.
Tip

You can reorder the subdocuments in the master document by dragging and dropping the subdocument entry in the Navigator.

![Image of Navigator showing a series of files in a master document]

Figure 385: Navigator showing a series of files in a master document

Step 7. Add table of contents, bibliography, index

You can generate a table of contents, bibliography, or index for the book, using the master document. You must insert these items into a text section in the master document. For more about these document elements, see Chapter 15, Tables of Contents, Indexes, Bibliographies.

In case you did not insert a table of contents in step 5, position the cursor on the page in the first text section where the table of contents is to go and choose Insert > Table of Contents and Index > Table of Contents, Index or Bibliography to create it.

If you do not have a Text section at the end of the master document, insert one before the last subdocument, then move it down so it is after the last subdocument. Now, if you have included bibliographic entries in your subdocuments, you can put the insertion point on the page in this last text section where the bibliography is to go and create the bibliography.

If you have included index entries in your subdocuments, put the insertion point on the page in the last text section where the index is to go and create the index.

Figure 386 shows the Navigator after addition of a TOC and index.

![Image of Navigator showing subdocuments, table of contents, and index in a master document]

Figure 386: Navigator showing subdocuments, table of contents, and index in a master document
Combining several documents into a master document

When you have several existing documents, you can combine them into one document controlled by a master document.

This method works best when all of the documents were created from the same template, but you can also use it when the documents have been created from different templates. This method is especially useful when the subdocuments are created or maintained by multiple writers. For example, you might be creating an anthology of short stories, a book of symposium papers, or a set of engineering test results with a standard company title page.

We will use a book of engineering test results as an example.

**Tip**

You could create a master document template (see page 435) and use it as the starting point for this method. In that case, skip steps 1 and 2 and start with step 3.

1) Open the title page document that you plan to use as the master document. To avoid creating too many subdocuments when this document is converted to a master document, have only one level 1 heading present. If there are more, temporarily change them to lower level headings and note which they are (add, for example, an asterisk at the end of each heading to remind you which have to revert to level 1 headings later).

2) Select **File > Send > Create Master Document**, name and save this master document (see “How to do it” on page 431).

Let us assume the original document was named FrontPage with a single Level 1 heading, and that when we created the master document (.odm file) we named it TestFile.

In this case, the master document is a blank file containing only one section. Also created at the same time was a subdocument named TestFile1, which is a .odt file containing the text from the FrontPage file. When you open the .odm file and click **Yes** to update all links, this file is linked in to the master document to provide the original content.

The original FrontPage file is left intact in its folder.

3) Open the master document and click **Yes** to update links. The master document opens with the Navigator showing by default (see “Master document Navigator” on page 422 and “Step 6. Insert the subdocuments into the master document“ on page 428 for more detailed information).

4) Click the **Insert** icon and select **File**.

![Figure 387: Adding files to the master document](image)

Figure 387: Adding files to the master document

5) Navigate to the location of the test results files (Results1.odt, Results2.odt, and so on). Select the first file to insert, Results1.odt for example, and click **Insert**. The file is inserted above the existing entry.
6) Click the **Move Up** icon to have the TestFile1 text above the Results1 text (file contents are inserted above the selected file in the master document).

7) Repeat from step 4 as often as required. It does not matter which file is highlighted in the master document when you insert the next one, just select the inserted file and use the **Move Up** or **Move Down** icons to position it as required.

![Figure 388: Moving subdocuments](image)

8) To edit the master document, to perhaps add a serial number and a client's name, in the master document right-click TestFile1.odt and select **Edit** in the context menu. Add the required content to the file that opens, save and close the file (see “Editing a master document” on page 434 for more detailed information).

9) Select **Tools > Update > Links** on the Menu bar, or click **Update > Links** in the Navigator and click **Yes** to confirm. All the edits in the master document will now show.

### Splitting a document into master and subdocuments

When you have one existing document that you want to split into a master document and several subdocuments, you can have Writer split the document automatically at headings with an outline level of your choice. Although this method is quick and easy, some cleanup work may be necessary. The automatically generated file names for the subdocuments are maindocnameX.odt, where X is 1, 2, 3, and so on. If you have a Preface or other “chapter” starting with a Heading 1 before Chapter 1, the file names will not directly correspond to the chapter numbers. You may wish to rename the subdocuments; see “Adding, deleting, or renaming subdocuments” on page 434.

#### How to do it

1) Open the document and choose **File > Send > Create Master Document**.

2) On the Name and Path of Master Document dialog (Figure 389):

   a) Navigate to the folder where you want to save the master document and its subdocuments (or create a new folder).

   b) Type a name for the master document in the **File name** box.

   c) In the **separated by** list, choose the outline level where the file should be split into subdocuments. Usually this is **Outline: Level 1** for a chapter heading, but your document may be structured differently. For more information about outline levels, see Chapter 8, Introduction to Styles.

   d) Leave the **Automatic file name extension** option selected, and click **Save** to split the document into subdocuments and create the master document.

   If you selected **Outline: Level 1** and the paragraph style at that level is Heading 1, each of the subdocuments begins with a Heading 1 paragraph.
The examples in the previous sections showed a very basic collection of files with sequential page numbering. This is useful for many documents, including e-books, but a typical printed book has the following sequence of page numbers:

- No page numbers on cover page or copyright page.
- Lower-case roman numerals in the front matter, starting with i.
- Arabic numerals in the body of the document, starting with 1.
- Page numbering sequential through the rest of the book.

To set up a master document to produce such a book, you need to define a different paragraph style for the heading of the first chapter and assign two special characteristics to it.

**Example**

Each chapter may start with a Heading 1 paragraph, set up in the Breaks section of the Text Flow tab of the Paragraph Style dialog to start on a new page (Figure 390). The Page number checkbox is not selected, so numbering continues from the number of the previous page.
Look on the Outline & List tab (Figure 391) of this dialog to see what outline level Heading 1 is assigned to. Usually this will be Outline level: Level 1. The level cannot be changed here because it has been set in Tools > Heading Numbering.

Only one paragraph style can be assigned to Outline Level 1 through Tools > Heading Numbering. However, you can assign additional paragraph styles to any outline level by using the Outline & List tab on the Paragraph Style dialog.

Therefore, you want to define a style called Heading 1 Chapter 1 that is identical in appearance to Heading 1 but has one essential difference:

1) Right-click Heading 1 in the Paragraph Styles section of the Styles tab in the Sidebar, and select New. On the Organizer tab of the Paragraph Style dialog, name the new style, select the next style, and be sure Inherit from shows Heading 1.

2) On the Text Flow tab, in the Breaks section (Figure 390), select Insert, Type: Page, Position: Before, With Page Style: First Page, and Page number: 1.

3) On the Outline & List tab, set the Outline level to Level 1 (Figure 393). This ensures that the heading will appear in the Table of Contents along with the other chapter headings. The List Style for this heading is No List, as it was not assigned an outline level through the Heading Numbering dialog.

4) Now, assign the new style to the first paragraph of Chapter 1, and you’re done.
Editing a master document

After creating a master document, you may want to change its appearance or contents.

Changing the appearance of the master document

You can change the styles in the template as your project develops. Do not make changes to styles in the master document or in any of the subdocuments; make those changes in the template.

To update the master document (and all of the subdocuments) with changes to the template, open the master document. You will get two messages: first, to ask if you want to update all links; and second, if you want to apply the changed styles. Answer Yes to both of these messages.

Editing subdocuments

You cannot edit a subdocument from within the master document. Instead, you must open the subdocument, either by double-clicking on it in the master document's Navigator, or by opening it from outside the master document. Then you can edit it just as you would edit any other document.

If, while editing a subdocument, you want to make changes to the styles that apply to the master document, see “Changing the appearance of the master document” above.

If you change the contents of any subdocument, you need to manually update the table of contents, bibliography, and index from within the master document.

Adding, deleting, or renaming subdocuments

To add a subdocument, follow the method described in “Step 6. Insert the subdocuments into the master document” on page 428.

To delete a subdocument, right-click its file name in the Navigator and choose Delete.

If you rename a subdocument by changing its file name, the next time you update links in the master document, that subdocument will show up in the Navigator as a broken link (shown in red). To fix this, you can either change back the name of the file (the link will be restored in the next update) or follow these steps:

1) Right-click the broken link in the Navigator and choose Edit link.
2) In the Edit Sections dialog (Figure 394), select the renamed file, and edit the name of the section (which is the name shown in the Navigator).
3) Click OK to save the changes.

Figure 394: Editing a link in a master document
Creating a master document template

A master document template is created in much the same way as any other template, described in Chapter 10, Working with Templates:

1) First, create the master document using File > Send > Create Master Document, as described in earlier sections of this chapter.

2) Then, use File > Templates > Save as Template to create the template (.otm), which will then be listed in the Templates dialog along with other templates.

Tip

Include in the name you give a master document template some indication that it is not an ordinary template.

Creating one file from a master document and its subdocuments

Master documents are .odm files containing linked subdocuments, which are in .odt format. Although linked files are very useful when writing and editing a large document such as a book, sometimes you might need to have a copy of the entire book in one file, for example when sending it to a publisher.

To export a master document to a .odt file (without affecting the original .odm file):

1) Open the master document and update all links. Choose File > Export on the Menu bar.

2) On the Export dialog (Figure 395), type a name for the exported .odt file and choose ODF Text Document (.odt) in the File format list (it should be the default choice). Click Export. This step creates an .odt file, with each subdocument in a separate write-protected section.

3) Close the master document and open the new .odt file, updating all links.

4) To break the links and remove the write protection, go to Format > Sections, select the first item in the Section list, then Shift+click on the last item in the list in order to select all the items. Deselect both Link in the Link section and Protect in the Write Protection section.

5) Click OK.

If you wish to eliminate some or all of the sections to have a plain text document, select the sections you wish to remove, and click Remove. The contents of those sections remain in the document; only the section markers are removed. Click OK.

Figure 395: Exporting a master document to an Open Document Text (.odt) file
Anchoring images

An image (graphic) anchored To page in a subdocument is not displayed in a master document. Because the master document reorganizes the page flow, page numbers, and cross-references when it collates the subdocuments, the image loses its anchor reference and disappears.

In contrast, an image anchored To page in a text section of a master document stays with that page and does not move if the length of subdocuments changes. The image may end up on a page somewhere in the middle of a subdocument, not where you want it to be.

**Note**

The anchor “to page” is deprecated. Avoid using it.

To keep an image positioned precisely on a particular page, anchor the image as follows:

1. Right-click the image and choose **Properties** in the context menu.
2. On the **Type** tab of the Image dialog (Figure 396), set the anchor to **To character**, **As character**, or **To paragraph**.
3. Under **Position**, choose suitable horizontal and vertical references to the page. Click **OK** to save the changes.

![Figure 396: Anchoring an image and setting its position on a page](image)

Chapter 16, Master Documents | 383
Chapter 17, Fields
**Introduction**

Fields are used for a variety of purposes: for example, data that changes (such as the current date or the total number of pages) or might change (the name of a product or book under development), user-defined numbering sequences, automatic cross-references, and conditional content (words or paragraphs that are visible or printed in some conditions but not others). Index entries are also fields.

This chapter describes some common uses of fields. A full discussion of fields and their use is beyond the scope of this book. Power users can find more details in the application Help.

**Tip**

Fields have a gray background when viewed on screen, unless you have deselected View > Field shadings on the Menu bar or changed the color of field shadings in Tools > Options > LibreOffice > Application Colors. This gray background does not show when you print the file or export to PDF.

**Keyboard shortcuts for fields**

Here are some handy keyboard shortcuts to use when working with fields:

- `Ctrl+F2` Open the Fields dialog.
- `Ctrl+F8` Turn field shadings on or off.
- `Ctrl+F9` Show or hide field names.
- `F9` Update fields.

**Quick and easy field entry**

To quickly insert common fields into your document, choose Insert > Page Number or Insert > Field on the Menu bar and selecting the required field in the submenu.

![Figure 397: Inserting common fields](image)

**Using document properties to hold metadata and information that changes**

The Properties dialog (File > Properties) for a document has six tabs. The information on the General tab and the Statistics tab is generated by the program. Some information (the name of the person on the Created and Modified lines of the General tab) is derived from the User Data page in Tools > Options > LibreOffice. The options on the Font and Security tabs are discussed elsewhere in this book.
Use the Description and Custom Properties tabs for:

- Metadata to assist in classifying, sorting, storing, and retrieving documents. Some of this metadata is exported to the closest equivalent in HTML and PDF; some fields have no equivalent and are not exported.
- Information that changes. You can store data for use in fields in your document; for example, the title of the document, contact information for a project participant, or the name of a product might change during the course of a project.

This dialog can be used in a template, where the field names can serve as reminders to writers of information they need to include. (Placeholders can serve a similar function within the text; see page 460.)

You can return to this dialog at any time and change the information you entered. When you do so, all of the references to that information will change wherever they appear in the document. For example, on the Description tab (Figure 398) you might need to change the contents of the Title field from the draft title to the production title.

![Figure 398: The Description tab of the document's Properties dialog](image)

Use the Custom Properties tab (Figure 399) to store information that does not fit into the fields supplied on the other tabs of this dialog.

![Figure 399: Custom Properties tab](image)

When the Custom Properties tab is first opened in a new document, it may be blank. If the new document is based on a template, this tab may contain fields.

Click the Add Property button in the lower right of the tab (not shown in illustration) to insert a row of boxes where you can enter your custom properties.

- The Name box includes a drop-down list of typical choices; scroll down to see all the choices. If none of the choices meet your needs, you can type a new name into the box.
- In the Type column, you can choose from Text, DateTime, Date, Duration, Number, or Yes or no for each field. You cannot create new types.
- In the Value column, type or select what you want to appear in the document where this field is used. Choices may be limited to specific data types depending on the selection in the Type column; for example, if the Type selection is Date, the Value for that property is limited to a date.

To remove a custom property, click the button at the right-hand end of the row.
Tip
To change the format of the Date value, go to Tools > Options > Language Settings > Languages and change the Locale setting.

Using other fields to hold information that changes

One way that people use fields is to hold information that is likely to change during the course of a project. For example, the name of a manager, a product, or even your entire company may change. If you have inserted the changeable information as fields, you can change the information in one place, and it will automatically change in all the places where that field occurs.

Writer provides several places where you can store the information referred to by a field. We will look at some of them here.

Seven document properties (Page Number, Page Count, Date, Time, Title, First Author, and Subject) are on the Insert > Field menu (Figure 397). To insert one of these fields, click it in the menu. Some of these fields get their information from the Document Properties dialog (Figure 398).

Other document properties are on the DocInformation and Document tabs of the Fields dialog (Figures 400 and 401), reached by choosing Insert > Field > More Fields or pressing Ctrl+F2.

The Custom item in the Type list on the DocInformation tab is derived from the Custom Properties tab of the Document Properties dialog (Figure 399); it does not appear on the list if no custom properties have been defined.

Some of the field values are picked up from the User Data page of the Tools > Options > LibreOffice dialog, so make sure the information on that page is correct.

To insert one of these fields, select it in the Type list and then select in the Select and Format lists if choices appear. Finally, click Insert.

Figure 400: Inserting a Date Modified field using the DocInformation tab of the Fields dialog
Figure 401: Inserting a File name field using the Document tab of the Fields dialog

Tip
To make the content fixed, select **Fixed content** (see Figure 400, lower right) when inserting the field. If necessary, come back to this dialog later and deselect this option to make the field variable again. For example, if you use a field to insert the creation date of a document, you do not want that date to change.

Using AutoText to insert often-used fields

If you use the same fields often, you can use AutoText as a quick and easy way to insert them.

To define an AutoText entry for a field:

1) Insert a field into your document, as described previously.
2) Select the field you inserted, and then choose **Tools > AutoText** (or press `Ctrl+F3`).
3) On the AutoText dialog (Figure 402), choose the group where this new entry will be stored (in this example, My AutoText), type a name for the entry, and change the suggested shortcut if you wish.
4) Click the **AutoText** button and click **New** to have the entry inserted as a field. Do not choose **New (text only)** because the AutoText entry will be plain text, not a field. (The New selections do not appear until you have selected a group and typed a name for the entry.)
5) Click **Close** to close the AutoText dialog.

To insert this field at the cursor position, type the shortcut and press `F3`. 

388 | LibreOffice 7.6 Writer Guide
Defining your own numbering sequences

You may want to define your own numbering sequences to use in situations where you do not always want the number at the start of the paragraph, or where you want more control than the built-in numbering choices give you, or where list styles do not do what you want.

This topic describes how to create a numbering sequence, using a number range variable field.

To create a number range variable using Arabic (1 2 3) numbers:

1) Position the cursor in a blank paragraph in your document.
2) Choose Insert > Field > More Fields or press Ctrl+F2, then select the Variables tab (Figure 403).
3) In the Type list, select Number range. In the Format list, select Arabic (1 2 3). Type whatever you want in the Name field. (We have used Step in this example.)
4) Click Insert. The name of the variable (Step) now appears in the Selection list, and a number field (showing 1) appears at the insertion point in your document. The Fields dialog remains open.
5) If you click several more times on the Insert button in the Fields dialog, the numbers 2, 3, 4, and so on will appear in the document.
6) You can now delete the fields you inserted; the Step sequence remains in the Select box in the Fields dialog (in this document only). You can insert this field at any place in the document.
Tip

To avoid doing all of that every time you want to put in a Step number, create an AutoText entry for Step. Then you can insert the field in the same way you would insert any other AutoText. See "Using AutoText to insert often-used fields" on page 444.

Tip

If a user-defined variable is not in use in the document, the X icon next to the Value box is active. You can delete the variable by clicking this icon. To remove a variable that is used in the current document, first delete from the document all fields using that variable, and then remove the variable from the list.

Using automatic cross-references

If you type in cross-references to other parts of the document, those references can easily get out of date if you reword a heading, add or remove figures, or reorganize topics. Replace any typed cross-references with automatic ones and all the references will update automatically to show the current wording or page/figure/table numbers.

The Cross-references tab of the Fields dialog (Figure 404) lists some items, such as headings, numbered paragraphs, and bookmarks. If figure captions, table captions, user-defined number range variables, and some other items have been defined in a document, that type also appears in the list.

You can shorten the list of items shown in the Selection box if you know a word or phrase that appears in the item required: type the word or phrase in the Filter Selection box.
Tip

Some people use Writer's Hyperlink feature for cross-references. However, the visible text of the hyperlink does not change if you change the text of the item to which it links. For that reason, you may wish to use cross-references in most situations. The exception is when the document is to be saved as HTML; cross-references do not become hyperlinks in a HTML document, so you need to use hyperlinks in the Writer document.

Inserting cross-references

To insert a cross-reference to a heading, figure, or other item shown on the Cross-references tab:

1) Place the cursor where you want the cross-reference to appear in the document.

2) If the Fields dialog is not open, choose Insert > Cross-reference or press Ctrl+F2. On the Cross-references tab (Figure 404), in the Type list, click the type of item you are referencing (for example, Headings or Figure).

3) Click the required item in the Selection list, which shows both automatically created entries (for example, Headings) and user-defined references (for example, bookmarks).

4) In the Refer using list, choose the type of reference required. The choices vary with the item being referenced (see “Formats for cross-references” below).

5) Click Insert.

Formats for cross-references

For all types of cross-reference, you can select from the following formats:

- **Page number (unstyled):** the page number of the target, without using formatting specified in the page style.
- **Chapter:** the number of the chapter where the referenced target is located.
- **Referenced text:** the full text set as a reference or bookmark.
• “Above”/“Below”: the word above or below depending on the position of the field relative to the referenced target.

• **Page number (styled):** the page number of the target, using the formatting specified in the page style. This is very useful when putting a reference to a page in the front matter where roman numerals are usually employed.

For headings or numbered paragraphs, three additional options are available:

• **Number:** Inserts the number of the heading or numbered paragraph, including superior levels depending on the context (see example below).

• **Number (no context):** inserts only the number of the heading or of the numbered paragraph. For example, if referencing a numbered item 2.4, it inserts 4.

• **Number (full context):** inserts the full number including higher hierarchical levels. For example, if referencing a numbered item 2.4, the full numbering (2.4) is inserted.

For objects inserted with captions such as a table or a figure, you can also choose:

• **Category and Number:** inserts both the category and number of the referenced object (for example, Figure 6). This is the most used formatting for figures and tables.

• **Caption Text:** inserts the full caption of the referenced object. For example, Figure 6: This is an example figure.

• **Numbering:** inserts the sequential number of the referenced object, without the category (for example, if referencing Table 2, the field will contain only the number 2).

**Example of cross-referencing to numbered headings**

In chapter 1, subchapter 2, subpart 5, the heading may be numbered as 1.2.5. A reference inseredt to text in the previous subpart (1.2.4), using the **Number** format, is shown as 4. If the numbering is set to show more sublevels, the same reference will be shown as 2.4 or 1.2.4, depending on the setting. Use the **Number (full context)** format to always see 1.2.4, no matter how the numberi is formatted.

**Preparing items as targets for cross-referencing**

If you want to insert a cross-reference to something that is not automatically shown on the Cross-references tab, for example an illustration without a caption or an item in a bullet list, you must first prepare the item as a target to be referenced. To do this, you can use a bookmark or set a reference. After a target has been defined, you can cross-reference to it as described in “Inserting cross-references” on page 447.

**Note**

Both bookmarks and set references can now be used for either location or text. In previous versions of LibreOffice, bookmarks could be used only for location references.

**Using bookmarks**

Bookmarks are listed in the Navigator and can be accessed directly from there. In HTML documents, bookmarks are converted to anchors that you can jump to using a hyperlink.

See “Managing bookmarks” on page 452 for more information about bookmarks, including renaming and editing them.

1) Select the text you want to bookmark, or click in the required place in the text. Choose **Insert > Bookmark** on the Menu bar.
2) On the Bookmark dialog (Figure 412), the larger box lists any previously defined bookmarks. Type a name for this new bookmark in the top box (or accept the default name) and click **Insert**.

3) You can leave the Bookmark dialog open while you insert more bookmarks. When you are done, click **Close**.

### Setting references
Set references are inserted and managed on the **Cross-references** tab of the Fields dialog.

1) Select the text you want to bookmark, or click in the required place in the text. Choose **Insert > Cross-reference** on the Menu bar.

2) On the **Cross-references** tab of the Fields dialog (Figure 405), select **Set Reference** in the **Type** list. The **Selection** list now shows any references that have been defined. This dialog can remain open while you set several items as references.

3) The text of the item appears in the **Value** box in the lower right of the dialog. In the **Name** box, type some text by which you can identify this item. This field name is case-sensitive.

4) Click **Insert**. The text you typed in the **Name** box now appears in the **Selection** list.

5) Repeat steps 3 and 4 as often as required.

6) Click **Close** to save and exit the dialog.

![Figure 405: Setting text to be used as a target for a cross-reference](image)

### Cross-referencing between subdocuments
You might want to include automatically updated cross-references between subdocuments in a master document. This topic describes how to do this using set references. The process is similar when using bookmarks.

### Preparing the references
Follow the procedure described in “Preparing items as targets for cross-referencing” on page 448 for all items to be targets of cross-references. In this case you need to include headings, figure captions, and other items, because they will not be listed automatically as they are for items within one document.
Tip

Keep a list of your names for the reference fields, and be sure each name is unique – not just within one document, but for all the documents involved. One way to keep track of this information is to save it in a separate file or spreadsheet.

The field names are case-sensitive. You can check the field name by holding the mouse pointer over the referenced item. For example, in Figure 406 the heading has the field name `word count`.

![Figure 406: Finding the field name for a set reference](image)

### Inserting the cross-references

1. In the document, place the cursor where you want the cross-reference to appear. Click **Insert > Cross Reference**.

2. On the **Cross-references** tab of the Fields dialog (Figure 407), select **Insert Reference** in the **Type** list on the left. Select **Referenced text** in the **Refer using** list.

![Figure 407: Fields dialog showing manual entry of field name](image)

3. The **Selection** list on the right shows only the reference field names (if any) for the subdocument you are using, so ignore that list and check the list you created manually in “Preparing the references” above. In the **Name** field in the lower right, type the name of the reference you set in the subdocument you are referring to. In our example, the name of the reference is `word count`.

4. Click **Insert**, type any text you want to appear between the reference and page number (such as “on page ”), and then insert another reference with **Page number (unstyled)** in the **Refer using** list. The cross-references will show an error as shown in Figure 408. When you hover the mouse pointer over one of these fields, you will see the field name.
(You can turn on the display of field codes by clicking View > Field Names. The two error fields shown in Figure 408 now look like Figure 409.)

5) After you have inserted all the cross-references required in the subdocument, click Close to save it and return to the master document window.

```
Error: Reference source not found on page Error: Reference source not found
```

Figure 408: Viewing the field name

```
word count word count word count
```

Figure 409: Displaying field codes

6) Select Tools > Update > Links on the Menu bar, or click Update > Links in the Navigator. All the edits in the master document will now show. Within the master document, navigate to the page of the subdocument on which you inserted the cross-reference field.

You should now see the text of the cross-reference appear in the spot where you inserted it. If it does not work, save the master document, close it, and open it again, updating the links. (If you open the subdocument for editing, the error message in Figure 408 will be shown.)

```
Counting changed words in a document on page 1
```

Figure 410: Field contents visible

This technique also works if you open a subdocument directly in step 2 (that is, not from within the master document) and insert a cross-reference field.

### Using fields in headers and footers

You can insert fields into headers or footers, using techniques described earlier in this chapter:

- To insert a page number, document title, author, creation date and time, current date and time, or total page count field, use Document Properties (see page 441) or choose Insert > Field > [item] on the Menu bar.

- To insert a cross-reference to a bookmark, heading, or other item, use Insert > Cross-reference or Insert > Field > More Fields > Cross-references.

- If Heading 1 has been used for chapter titles, use a Document field to insert the current chapter title, so the header or footer contents change from one chapter to the next. See Figure 411. (Writer calls chapter titles Heading contents.) If outline numbering is used on Heading 1, choose whether to include these numbers in the field (Heading number and contents). Use Insert > Field > More Fields > Document.

- To insert cross-references to other heading levels, specify a value in the Up to level box in the lower right of the Document tab of the Fields dialog (Figure 411). That is, Level 1 = Heading 1, Level 2 = Heading 2, and so on.
A cross-reference field in the header of a page picks up the first heading of that level on the page. A field in the footer picks up the last heading of that level on the page.

You can add a page count to the footer; for example, Page 9 of 12. Type the word Page and a space in front of the Page field. Type a space, the word of, and a space after the Page field. Then choose Insert > Field > Page Count.

To include the chapter number with the page number:

1) Position the cursor just before the Page field you inserted. On the Document tab of the Fields dialog, select Chapter in the Type column and Chapter number without separator in the Format column. Click Insert.

2) Go to the header or footer where you inserted this field and type the character you want to appear between the chapter number and the page number; for example, a hyphen.

3) The table of contents will not automatically pick up these chapter numbers, so you need to make a change on the Entries tab of the Table of Contents, Index or Bibliography dialog, as described in Chapter 15, Tables of Contents, Indexes, Bibliographies.

Managing bookmarks

Bookmarks can be used for location references and for text references.

Text enclosed by a bookmark can be edited in the Bookmark dialog (Figure 412) as well as in the document itself. When you edit text in the dialog, it is also edited in the document. If you have change tracking on, the change is tracked in the document.

To use the Bookmark dialog to edit the text of a bookmark:

1) Open the Bookmarks list in the Navigator, right-click on the name of a bookmark, and select Edit in the context menu. The Bookmark dialog opens with that bookmark selected. You can select any bookmark in the list when the dialog is open.

2) With the required bookmark selected, click the Edit Text button. The text of the selected bookmark is highlighted in the Text column.
3) Click in the highlighted text in the dialog to edit it. Click Close when done.

![Bookmark dialog](image)

Figure 412: Bookmark dialog

To edit the name of a bookmark, right-click it in the Navigator and select Rename in the context menu, or select it in the Bookmark dialog and click the Rename button. A small dialog opens. Type the new name, or edit the existing name, and click OK to save.

To locate a bookmark in the document, right-click it in the Navigator and select Go to in the context menu, or select it in the Bookmark dialog and click the Go to button. The cursor jumps to the bookmark's location, with the bookmark highlighted.

Other bookmark enhancements are for metadata visualization, accessibility, and visibility of bookmark locations in a document. For details on those features, see the release notes, [https://wiki.documentfoundation.org/ReleaseNotes/7.5#Bookmarks](https://wiki.documentfoundation.org/ReleaseNotes/7.5#Bookmarks)

### Developing conditional content

Conditional content is text and graphics that are included or excluded from a document depending on a condition you specify.

A simple example is a reminder letter for an overdue account. The first and second reminders might have a subject line of “Reminder Notice”, but the third reminder letter might have the subject “Final Notice” and a different final paragraph.

A more complex example is a software manual for a product that comes in two versions, Pro and Lite. Both product versions have much in common, but the Pro version includes some features that are not in the Lite version. If you use conditional content, you can maintain one file containing information for both versions and print (or create online help) customized for each version. You do not have to maintain two sets of the information that is the same for both versions, so you will not forget to update both versions when something changes.

**Tip**

In some cases, the same effect can be obtained by hiding a paragraph or character style; see Chapter 9, Working with Styles.
Choose the types of conditional content to use

This topic describes several Writer features that can help you design and maintain conditional content. You can use one or any combination of these features in the same document.

**Conditional text**
With conditional text, you can have two alternative texts (a word, phrase, or sentence). One text will be displayed and printed if the condition you specify is met, and the other will be displayed and printed if the condition is not met. You cannot include graphics or edit the text except in the Field dialog (not in the body of the document). You also cannot format part of the text (for example, bold one word but not the others), but you can format the field to affect all of the field contents (for example, making all of the words bold or italic). You cannot include a cross-reference or other field in the text.

**Hidden text**
With hidden text (a word, phrase, or sentence), you have only two choices: show or hide. If the condition you specify is met, the text is hidden; if the condition is not met, the text is displayed. The disadvantages are the same as for conditional text: you cannot include graphics, edit the text in the body of the document, format part of the text, or include a field.

**Hidden paragraphs**
Hidden paragraphs are like other paragraphs, but you can specify a condition under which the paragraph is not displayed or printed. You can include graphics, edit the text in the body of the document, format any part of the text, and include fields.

A blank paragraph can also be hidden, for example if a database field has no content for the current record. This is useful when merging an address into a letter: if you allow two lines for the street address and the database record uses only one line, you can prevent the blank line from appearing in the document.

**Hidden sections**
Hidden sections are like hidden paragraphs, but they can include more than one paragraph, for example, a heading plus one or more paragraphs. However, a section cannot contain less than a paragraph, so you cannot use this method for single words or phrases. The contents of a hidden section behave just like the contents of any other part of the document, but you can specify a condition under which the section is not displayed or printed. In addition, you can password protect a section.

**Plan your conditional content**
Conditions are what programmers call logical expressions. You must formulate a logical expression for each condition because a condition is always either true (met) or false (not met). You can use the same condition in many places in your document, for different types of conditional content.

To make conditional content work, you need to choose or define a variable and define a logical expression (condition) involving the selected variable.

**Choose or define a variable**
You can use the following variables in the condition:

- User-defined variables
- Predefined LibreOffice variables, which use statistical values from the document properties
- User data
- Database field contents—for example, from your address book

You cannot use internal variables (for example, page number or chapter name) in conditions.
**Define a logical expression (condition) involving the variable**

The condition compares a specified fixed value with the contents of a variable or database field. To formulate a condition, use the same elements as you would to create a formula: operators, mathematical and statistical functions, number formats, variables, and constants. The possible operators, and many examples of use, are given in the Help. You can define quite complex expressions, but in most cases a simple condition will do the job.

**Create the variable**

To create the variable, you can use choices found on the DocInformation, Variables, and Database tabs of the Fields dialog.

**DocInformation fields**

“Using document properties to hold metadata and information that changes” on page 441 described how to set up a custom document property. You can use that document property as the variable in your condition statement.

**User-defined variable field**

To set up a variable or user field:

1. Place the cursor where you want the field to be inserted.
2. On the Fields dialog, select the Variables tab (Figure 413).

![Figure 413: Defining a variable to use with conditional content](image)

3. Select **Set variable** in the Type list and **Text** in the Format list. Type a name for the variable in the Name box, and a value in the Value box. In this example ProLite is chosen for the name (as a reminder that this variable is related to the two product versions), and the value is set as Lite to remember “If it is the Lite version, then this text should be hidden.”

4. Select **Invisible** so the field does not show in the document. Click **Insert**, then click **Close**. A small gray mark will appear where you inserted the field.
Tip

Because the gray mark is so small, you may have trouble finding it again, especially if you have other fields in the document. You may prefer to leave the variable field visible while you work, and change it to invisible just before you create final copy.

At any time, you can place the insertion point just before the field and choose Edit > Fields or right-click the field and choose Fields in the context menu. On the Edit Fields dialog (Figure 418), select or deselect Invisible.

Apply the condition to the content

Now that you have defined the variable, you can use it in a condition statement. This topic describes some of the possibilities.

Conditional text

First, let us set up some conditional text that will insert the words Great Product Lite into the Lite version and Great Product Pro into the Pro version of the manual. You would use this field whenever you want to mention the name of the product.

1) Place the cursor where you want one of these phrases to appear. (You can move or delete it later, if you wish.)

2) On the Functions tab of the Fields dialog, select Conditional text in the Type list.

3) As shown in Figure 414, type ProLite EQ "Lite" in the Condition box, Great Product Lite in the Then box, and Great Product Pro in the Else box.

Note

These fields are case-sensitive, and quotation marks are required around a text value such as Lite.

4) Click Insert to insert the field, then click Close. You should see Great Product Lite in the text.

Figure 414: Inserting conditional text

Tip

If you want to insert this field into your text in many places (as you probably would for a product name), create an AutoText entry for it. See “Using AutoText to insert often-used fields” on page 444 for instructions.
**Hidden text**
You might use hidden text for words or short phrases that describe features of Great Product Pro that are not found in the Lite version. You can reuse the same field in several places in the document—for example, by copying and pasting it. To create a hidden text field:

1) On the *Functions* tab of the Fields dialog, select *Hidden text* in the *Type* list (Figure 415).

![Figure 415: Creating a condition for hidden text](image)

2) Type `ProLite EQ "Lite"` in the Condition box and type the required text in the *Hidden text* box. Remember, this is the text that is hidden if the condition is true.

3) Click **Insert** to create and insert the field.

To show all hidden text so you can edit it, do one of the following:

- On the **Tools > Options > LibreOffice Writer > View** page, select the **Display fields: Hidden text** option.
- Double-click in front of the variable that you used to define the condition for hiding the text, and enter a different value for the variable.

**Hidden paragraphs**
A conditional paragraph is hidden if the condition is true. To hide a paragraph:

1) Click in the paragraph to be hidden.

2) On the *Functions* tab (Figure 416) of the Fields dialog, select *Hidden Paragraph* in the *Type* list.

3) For this example, type `ProLite EQ "Lite"` in the *Condition* box.

4) Click **Insert** to create and insert the field.

![Figure 416: Creating a condition for a hidden paragraph](image)
To show all hidden paragraphs so you can edit them, do one of the following:

- Choose View > Field Hidden Paragraphs on the Menu bar.
- On the Tools > Options > LibreOffice Writer > View page, select the Display Fields: Hidden paragraphs option.
- Double-click in front of the variable that you used to define the condition for hiding the paragraph, and enter a different value for the variable.

**Hidden sections**

A conditional section is hidden if the condition is true. To create a conditional section:

1) Select the text that you want to be included in the conditional section. (You can edit this text later, just as you can edit any other text.)

2) Choose Insert > Section. On the Insert Section dialog (Figure 417), go to the Section tab, then select Hide and enter the condition in the With Condition box. You can also give the section a name; this is strongly recommended, so you can find it again easily if you have several sections in your document.

3) Click Insert to insert the section into the document.

![Figure 417: Creating a section to be hidden when a specified condition is met](image)

To show a hidden section so you can edit it:

1) Choose Format > Sections.

2) On the Edit Sections dialog, select the section from the list.

3) Deselect Hide and click OK. You can now edit the contents of the section. Afterwards, you can choose Format > Sections and select Hide to hide the section again.
To make the hidden section a normal part of the document (that is, to remove the section markers, but not the contents of the section):

1) Show the hidden section, as described above.
2) On the Edit Sections dialog, select the section from the list.
3) Click **Remove**. The contents of the section are now a normal part of the document.

**Change the value of the variable**

To change the value of the variable between *Lite* and *Pro*:

1) Find the variable field you created in “Choose or define a variable” on page 454.
2) Click once just in front of this field, then right-click and click **Fields** in the context menu.
3) On the Edit Fields dialog (Figure 418), change the value of the variable to *Pro*.
4) If you have set fields to update automatically, all of the conditional and hidden text that uses this variable as a condition will change.

---

**Note**

Conditional text and hidden text can only be edited in the Edit Fields dialog.

---

**Tip**

To turn on automatic updating of fields, choose **Tools > Options > LibreOffice Writer > General**, and select **Fields** under **Automatically Update**.

---

*Figure 418: Changing the value of the variable*
Using placeholder fields

A placeholder field prompts you to enter something (text, a table, a frame, an image, or an object).

To insert a placeholder field into a document:

1) On the Functions tab of the Fields dialog, select Placeholder in the Type column and select what the placeholder is for in the Format column.

2) In the Placeholder box, type the text that you want to appear in the placeholder field.

3) In the Reference box, type the text that you want to display as a help tip when you rest the mouse pointer over the field.

Figure 419 shows the results of inserting a placeholder field for an image.

Because the <Logo> field is an Image placeholder, when you click the field in the document, the Insert Image dialog opens, prompting you to select an image. When you select an image and click Open, the image replaces the field in the document.

Similarly, clicking on a Table placeholder field opens the Insert Table dialog, clicking on a Frame placeholder field opens the Frame dialog, and clicking on an Object placeholder field opens the Insert OLE Object dialog. The Text placeholder field is different: you simply click it and type some text in the Placeholder box, which replaces the field.

Using other fields

Other uses of fields, including database fields, form fields, and content controls, are described in various chapters of this book.

LibreOffice provides many other fields that you may find useful, but they are too specialized to cover in this book. Please refer to the Help system for details, instructions, and examples.

Classifying document contents

Document classification and security are important for businesses and governments. Where sensitive information is exchanged between users and organizations, the parties agree how such information will be identified and handled. LibreOffice provides standardized means for sensitive information to be identified and protected, using a set of standard fields to hold sensitive information.

To enable document classification, open the TSCP bar (View > Toolbars > TSCP Classification). This toolbar contains list boxes to help in selecting the security of the document. LibreOffice then adds custom fields in the document properties (File > Properties, Custom Properties tab) to store the classification policy as document metadata.

To prevent a breach in security policy, contents with a higher classification level cannot be pasted into documents with a lower classification level.
Chapter 18, Forms
Introduction

This chapter covers the use of interactive forms within Writer documents. A form has sections that are not to be edited, and other sections that are designed for the reader to make changes. For example, a questionnaire has an introduction and questions (which do not change) and spaces for the reader to type answers or select from supplied choices.

Writer provides several ways to enter information into a form, including check boxes, option buttons, text boxes, pull-down lists, and other items, collectively known as form controls.

LibreOffice forms include a lot of features. Not everything is described in this chapter. Notable omissions are using forms in HTML documents and writing macros to link to form controls.

LibreOffice Calc, Impress, and Draw also support forms in much the same way that Writer does.

When to use forms

Forms are used in three ways:

- To create a simple document for the recipient to complete, such as a questionnaire sent out to a group of people who fill it in and return it.
- To link into a database or data source and allow the user to enter information. Someone in a sales department might enter purchasers’ information into a database using a form.
- To view information held in a database or data source. A librarian might call up information about books.

Using forms to access a database offers a fast and easy way to build complex graphical front ends. Your form can include not only the fields that link to the data source, but also text, graphics, tables, drawings and other elements.

A typical way to use a simple form is:

1) You design the form, then save it.
2) You send the form to others (for example, by email).
3) They fill in the form, save it, and send it back to you.
4) You open the form and see what their answers are.

Tip

By using a data source, or setting a form to update over the web, you can gather data automatically. However, those methods are more complex and are not covered in this chapter.

Alternatives to using forms in Writer

LibreOffice Base provides an alternative way to access a data source. Forms in Base and Writer share a lot of similarities, but one may be better for a particular task than the other. Base is appropriate only if the form accesses a data source; you would not use it for simple forms.

Creating a simple form

This topic explains how to create a simple form without any links to a data source or database and without advanced customization.
Create a document

You do not need to do anything special when creating a document to use as a form, though you may wish to enable the grid so that controls can be positioned accurately. Go to View > Grid and Helplines on the Menu bar and select Display Grid. You may also wish to select Snap to Grid.


Open the form toolbars

Two toolbars control form creation: Form Controls (Figure 421) and Form Design (Figure 422). Select View > Toolbars > Form Controls and View > Toolbars > Form Design on the Menu bar to show them both. You can also open the Form Design toolbar on the Form Controls toolbar.

The Form Controls toolbar has an icon for each of the most commonly used types of control. Some of these controls are also located on the Form menu (Figure 420).

You can dock these toolbars in different places on the Writer window, or leave them floating. When they are floating, you can also change them from vertical to horizontal and change the number of tools on a row; to make these changes, drag a corner of the toolbar.

See “Form controls reference” on page 468 for descriptions of the tools on these toolbars.

Activate design mode

Click the Design Mode icon on the Form Controls toolbar to turn design mode on. (Click it again to turn it off.) This activates or deactivates the icons for inserting form controls and selects controls for editing.

When design mode is off, the form behaves as it would for the end user. Buttons can be pressed, check boxes selected, list items selected, and so on.

Insert form controls

1) To insert a form control into the document, click the control's icon to select it. The mouse pointer changes shape.

2) Click in the document where you want the control to appear. (You can move it later.)

3) Hold the left mouse button down and drag the control to size it. Some controls have a fixed size symbol followed by the name of the control (for example, Check Box or Option Button).

4) The control icon remains active, so you can insert several controls of the same type without needing to go back to the toolbar.

5) To change to another tool, click its icon on the toolbar.

6) To stop inserting controls, click the Select icon on the Form Controls toolbar, or click any of the controls you have just inserted. The mouse pointer changes back to its normal appearance.

Tip

To make a form control square, hold down the Shift key when creating it. To keep the proportions of an existing control the same, hold down Shift when resizing it.
Configure controls

After inserting the controls, you need to configure them to look and behave as you want. Right-click a form control within the document and select Control in the context menu, or double-click on a form control, to open the Properties dialog for the selected control.

The Properties dialog has three tabs: General, Data, and Events. For simple forms, only the General tab is needed. See “Configure form controls” on page 473, “Form control formatting options” on page 483, and the descriptions in the Help for more information. Configuration for use with a database is discussed in “Creating a form for data entry” on page 479.

The fields on this dialog vary with the type of control. To see additional fields, use the scroll bar or enlarge the dialog vertically.

Use the form

To use the form, leave design mode by clicking the Design Mode icon to deactivate it. Save the form document.

Form controls reference

Form menu on Menu bar

Figure 420: Form menu on Menu bar
**Form Controls toolbar**

The icons you see in Writer may differ from the ones shown here or they may be in a different order on the toolbar.

![Form Controls toolbar](image)

Table 9: Tools on Form Controls toolbar

<table>
<thead>
<tr>
<th><strong>Form Controls toolbar</strong></th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 Select</td>
<td>Selects a form control to perform some other action on it.</td>
</tr>
<tr>
<td>2 Design Mode</td>
<td>Toggles between design mode on (to edit forms) and design mode off (to use forms).</td>
</tr>
<tr>
<td>3 Toggle Form Control Wizards</td>
<td>Some form controls (List Box and Combo Box) have optional wizards. If you do not want the wizard to launch when you create one of these controls, use the Wizards On/Off icon to switch wizards off.</td>
</tr>
<tr>
<td>4 Form Design</td>
<td>Launches the Form Design toolbar, which can also be opened with View &gt; Toolbars &gt; Form Design.</td>
</tr>
<tr>
<td>5 Label</td>
<td>A text label. The difference between this and just typing on the page is that, as a control, you can link a label field to macros so, for example, something happens when the mouse passes over it or clicks on it.</td>
</tr>
<tr>
<td>6 Text Box</td>
<td>A control to create a box into which the form's user can type any text.</td>
</tr>
<tr>
<td>7 Check Box</td>
<td>A box that can be selected or deselected on the form. You can label the box.</td>
</tr>
<tr>
<td>8 Option Button</td>
<td>Creates an option button (also known as a radio button). When multiple buttons are grouped together, only one can be selected at a time. The easiest way to group multiple buttons is to use the Group Box icon on the More Controls toolbar, with wizards enabled.</td>
</tr>
<tr>
<td>9 List Box</td>
<td>Creates a list of options as a pull-down menu that the user can choose from. If the form is linked to a data source and wizards are on, creating a list box launches the List Box Wizard. If the form is not linked to a data source, turn wizards off and create an empty list box. Then in the List Entries field on the General tab, enter the options you want to appear on the list.</td>
</tr>
<tr>
<td>10 Combo Box</td>
<td>As with a List Box, you set up a list of choices. In addition, a panel at the top either displays the choice made or allows the form user to type in something else. This works the same as the List Box.</td>
</tr>
<tr>
<td>11 Push Button</td>
<td>Creates a button that can be linked to a macro. The label is the name that appears on the button.</td>
</tr>
<tr>
<td>12</td>
<td>Image Button</td>
</tr>
<tr>
<td>-----</td>
<td>--------------</td>
</tr>
<tr>
<td>13</td>
<td>Formatted Field</td>
</tr>
<tr>
<td>14</td>
<td>Date Field</td>
</tr>
<tr>
<td>15</td>
<td>Numerical Field</td>
</tr>
<tr>
<td>16</td>
<td>Group Box</td>
</tr>
<tr>
<td>17</td>
<td>Time Field</td>
</tr>
<tr>
<td>18</td>
<td>Currency Field</td>
</tr>
<tr>
<td>19</td>
<td>Pattern Field</td>
</tr>
<tr>
<td>20</td>
<td>Table Control</td>
</tr>
<tr>
<td>21</td>
<td>Navigation Bar</td>
</tr>
<tr>
<td>22</td>
<td>Image Control</td>
</tr>
<tr>
<td>23</td>
<td>File Selection</td>
</tr>
<tr>
<td>24</td>
<td>Spin Button</td>
</tr>
<tr>
<td>25</td>
<td>Scrollbar</td>
</tr>
</tbody>
</table>
**Table 10: Tools on Form Design toolbar**

<table>
<thead>
<tr>
<th>Number</th>
<th>Tool Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Select anchor for object</td>
</tr>
<tr>
<td>2</td>
<td>Align Objects</td>
</tr>
<tr>
<td>3</td>
<td>Bring to Front</td>
</tr>
<tr>
<td>4</td>
<td>Forward One</td>
</tr>
<tr>
<td>5</td>
<td>Back One</td>
</tr>
<tr>
<td>6</td>
<td>Send to Back</td>
</tr>
<tr>
<td>7</td>
<td>To Foreground</td>
</tr>
<tr>
<td>8</td>
<td>To Background</td>
</tr>
<tr>
<td>9</td>
<td>Select</td>
</tr>
<tr>
<td>10</td>
<td>Design Mode</td>
</tr>
<tr>
<td>11</td>
<td>Control Properties</td>
</tr>
<tr>
<td>12</td>
<td>Form Properties</td>
</tr>
<tr>
<td>13</td>
<td>Form Navigator</td>
</tr>
<tr>
<td>14</td>
<td>Add Field</td>
</tr>
<tr>
<td>15</td>
<td>Activation Order</td>
</tr>
<tr>
<td>16</td>
<td>Open in Design Mode</td>
</tr>
<tr>
<td>17</td>
<td>Automatic Control Focus</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>---</td>
<td>---</td>
</tr>
<tr>
<td>18</td>
<td>Position and Size</td>
</tr>
<tr>
<td>19</td>
<td>Display Grid</td>
</tr>
<tr>
<td>20</td>
<td>Snap to Grid</td>
</tr>
<tr>
<td>21</td>
<td>Helplines While Moving</td>
</tr>
</tbody>
</table>

**Example: a simple form**

In this example, we will create the form shown in Figure 423. If you follow the given steps, your form will look similar to this one.

```
Favorite Shape Survey

Thank you for agreeing to take part in this survey. Please complete the form and return it by email to your teacher.

Name: [ ]

Gender: [ ] Male [ ] Female [ ] Other

Favorite shape: [ ]

All shapes you like:
[ ] Circle [ ] Triangle [ ] Square [ ] Pentagon
```

*Figure 423: Completed form*

**Create the document**

Open a new document (File > New > Text Document) and type any text to be included (see Figure 424 for an example). It is a good idea to sketch the final result to use as a guide when designing the form, although it can easily be changed later.

```
Favorite Shape Survey

Thank you for agreeing to take part in this survey. Please complete the form and return it by email to your teacher.

Name: 

Gender: 

Favorite shape: 

All shapes you like: 
```

*Figure 424: Initial document without form controls*
Add form controls

The next step is to add the form controls to the document. We will have four controls:

- **Name** is a text box.
- **Gender** is three option buttons: male, female, or other; user can select one.
- **Favorite shape** is a list of options; user can select one.
- **All shapes you like** is a series of check boxes; user can select one or more.

To add these controls:

1) Select **View > Toolbars > Form Controls** to open the Form Control toolbar.
2) If the tools are not active, click the **Design Mode** icon to activate them.
3) Click the **Text Box** icon, then click in the document and drag the shape of the **Name** text box to approximately the size you want. Drag it to line up with the **Name**: label.
4) Make sure **Toggle Form Control Wizards** is **OFF**. Click the **Option Button** icon. Click and drag to create three option buttons near the **Gender**: label in the document. We will configure these in the next section.
5) Click the **List Box** icon and draw a list box by **Favourite shape**: in the document. This will just be an empty pane for now.
6) Click the **Check Box** icon and create four check boxes by **All shapes you like**, side by side across the page.

Your document should now look something like Figure 425. Do not worry if the controls are not lined up well; we will fix this later.

![Figure 425: Document with form controls](image)

Configure form controls

**Text box**

No further configuration is required for the Name field, but you may wish to change the height or width of the field, its background color, or other formatting. If so:

1) Be sure **Design Mode** is on and **Wizards** are off.
2) Double-click on the **Name** field to open the Properties: Text Box dialog (Figure 426).
3) On the **General** tab, scroll down (or expand the dialog by dragging the bottom edge down) to find the **Width** and **Height** properties. Change these as needed.
4) You can then close the dialog or leave it open while you configure the other controls.

![Figure 426: Changing the width and height of a text box](image)

**Option buttons**

The Gender option buttons need to be configured to allow only one of the three to be selected. You can do this in two ways: using individual option buttons as described here, or using a Group Box (see page 476).

1) Be sure **Design Mode** is **ON** and **Wizards** are **OFF**.

2) If the Properties dialog is open, click once on the first option button to change the dialog to Properties: Option Button. If the dialog is not open, double-click the first option button. In the Properties dialog (Figure 427), on the **General** tab, type **Male** in the **Label** field and **Gender** in the **Group name** field.

3) Repeat for the other two options, using **Female** and **Other**, respectively, for the **Label** and **Gender** for the **Group name**. (Grouping allows only one option to be selected at a time.)

![Figure 427: Specifying label and group names for an option button](image)

If the option buttons are too far apart, click on each in turn and drag it to the left or right.

If the option buttons are not lined up neatly, do this:

1) Click the **Select** button on the Form Controls toolbar and draw a box around the three option button controls with the mouse to select all of them (Figure 428).
2) Right-click and choose **Align > Top** in the context menu. Figure 429 shows the result.

![Gender and Favorite shape](image1)

**Figure 428: Select controls and align to top**

![Result of action to align controls](image2)

**Figure 429: Result of action to align controls**

**List box**

To add the list of choices to the list box, do this:

1) Be sure **Design Mode** is **ON** and **Wizards** are **OFF**. Double-click the List Box control to open the control's Properties dialog (Figure 430). Select the **General** tab.

2) Scroll down to find the List Entries text input box. Type the names of the shapes (Circle, Triangle, Square, Pentagon) one at a time. After each, press **Shift+Enter**, as shown in Figure 430.

![Properties: List Box](image3)

**Figure 430: Entering the terms for a list**

When you click away from the List entries box in the dialog, you should see a line saying "Circle","Triangle","Square","Pentagon" (Figure 431).
Check boxes

To give the check boxes names:

1) Be sure **Design Mode** is **ON** and **Wizards** are **OFF**. Double-click the first Check Box control.

2) In the Properties: Check Box dialog (Figure 432), change the text in the Label field to *Circle* and press *Enter*. The cursor moves to the next line, and the label on the check box in the document changes immediately.

3) Click each of the other three check boxes in turn. Change the text in the Label text input box in the Properties dialog to *Triangle*, *Square*, and *Pentagon* in turn.

4) Close the Properties dialog.

5) Turn **Design Mode** off.

You have now completed the form, which should look something like Figure 423 on page 472.

Group box

As an alternative to creating individual option buttons for Gender (described on page 474), you can use a Group Box to insert a group of option buttons. Group boxes stack the selections one under the other (as shown in Figure 436 on page 478); individual buttons can be moved into any arrangement you prefer (we arranged them horizontally on page 474).
To use a Group Box instead of individual Option Buttons:

1) Be sure both **Design Mode** and **Wizards** are **ON**. Click the **Group Box** icon and draw a box next to the **Gender**: label. The Group Element Wizard (Figure 433) opens automatically.

2) Type **Male** in the box on the left. Click the >> button to move it to the **Option fields** box on the right.

3) Repeat for **Female** and **Other**. The Wizard should now look like Figure 434. Click **Next >**.

4) On the next page of the Wizard (Figure 435), choose **No, one particular field is not going to be selected** as a default. Click **Next >**.

5) On the next page, make no changes. Click **Next >**.

6) On the next page, delete the words “Group Box” from the caption area. If we did not have a **Gender**: label already in the form, you might want to type **Gender** as the caption.

7) Click **Finish**. The survey form should look like Figure 436.

---

![Image 433: Inserting a Group Box using the Group Element Wizard](image)

**Figure 433:** Inserting a Group Box using the Group Element Wizard

![Image 434: Wizard after adding names for the option fields](image)

**Figure 434:** Wizard after adding names for the option fields
Finishing touches

The form is complete, but you may wish to make further changes to the document. If you plan to send this out to other people to complete, you probably want to make the document read-only so that users would be able to fill in the form but not make any other changes to the document.

To make the document read-only, select File > Properties, select the Security tab and enable Open file read-only.

Note

If the document is read-only, anyone filling in the form will need to use File > Save as to save the document.

Accessing data sources

The most common use for a form is to input information into a database. For example, you can design a form that others can use to enter information into a contacts database. Because it is part of a Writer document, the form can contain graphics, formatting, tables, and other elements to make it look just the way you want. Modifying the form is as simple as editing a document.

LibreOffice can access numerous data sources. These include ODBC, MySQL, Oracle JDBC, spreadsheets and text files. As a general rule, databases can be accessed for reading and writing; other data sources (such as spreadsheets) are read-only.

Tip

To see the list of supported data source types for your operating system, choose File > New > Database. On the first page of the Database Wizard, select Connect to an existing database and then open the drop-down list.

For the purpose of this chapter, we assume you have previously created a database or other data source and registered it for use with Writer. Chapter 14, Mail Merge, describes how to create and register a database.
Creating a form for data entry

Once a database is registered with LibreOffice, follow these steps to link a form to the data source:

2) Design your form, without putting in the actual fields (you can always change it later).
3) Show the Form Controls and Form Design toolbars.
4) Click the Design Mode icon to put the document into design mode.
5) Click the Text Box icon. Click in the document and drag to create a text box for the first form field.
6) Additional fields, of any type, can be added in the same way (click and drag).

So far you have followed the same steps used before when creating your first form. To link the form with the data source you registered:

1) Click the Form Properties icon on the Form Design toolbar, or right-click any of the fields you inserted and select Form Properties, to open the Form Properties dialog (Figure 437).

![Form Properties dialog](image)

*Figure 437: Form properties, connecting to a data source*

2) In the Form Properties dialog, choose the Data tab.
   - Set Data Source to be the data source you registered.
   - Set Content Type to be Table.
   - Set Content to be the name of the table you want to access.
   - Close the dialog.

3) For each form control in turn, click the control to select it (small green boxes appear around it), then launch the Properties dialog: either right-click and select Control Properties or click the Control Properties icon on the Form Controls toolbar.
4) In the Properties dialog, click the *Data* tab (Figure 438). If you set up the form correctly, the Data Field option will contain a list of the different fields in the data source (for example, Name, Address and Telephone). Select the field you want.

![Figure 438: Form control properties, Data tab](image)

5) Repeat for each control in turn until every control that should be assigned to a field has been assigned.

**Caution**

If you created a database in LibreOffice Base and your Primary Key field had *AutoValue* set to *Yes*, that field does not need to be part of the form. If *AutoValue* was set to *No*, you will have to include it and users will need to enter a unique value into that field whenever they make a new entry—not something that is recommended.

### Entering data into a form

Once you have created a form and tied it to a database, use it to enter data into the database or modify data already there:

1) Make sure that the form is **not** in design mode. (On the Form Controls toolbar, click the *Design Mode* icon. When design mode is off, most of the buttons on the toolbar will be grayed out.)

2) Make sure that the Form Navigation toolbar is on *(View > Toolbars > Form Navigation)*. This toolbar normally appears at the bottom of the workspace.

![Figure 439: Form Navigation toolbar](image)

3) If there is existing data in the data source, use the control buttons on the Form Navigation toolbar to look at different records. To amend data in a record, edit the values in the form. To submit the changes, press *Enter* with the cursor in the last field. The record is saved and the next record is displayed.

4) If there is no data in the form, enter information by typing into the fields of the form. To submit the new record, press *Enter* with the cursor in the last field.

5) Other functions can be performed from the Form Navigation toolbar, including deleting a record and adding a new record.

**Note**

If a user tries to fill in the form and receives the error “Attempt to insert null into a non-nullable column”, then the form designer should go back to the database and confirm that the Primary Key field has the Auto Value set to Yes. This error will prevent the form user from saving the records.
Advanced form customization

Linking a macro to a form control

You can set any form control (for example, text box or button) to perform an action when triggered by some event.

To assign a macro to an event:

1) Create the macro. See Chapter 13, Getting Started with Macros, in the Getting Started Guide.

2) Be sure the form is in design mode. Right-click the form control, select Control Properties in the context menu, and click the Events tab (Figure 440).

3) Click the browse icon by any event to open the Assign Action dialog (Figure 441).

4) Click the Macro button and select the macro from the list in the Macro Selector dialog (not shown). You return to the Assign action dialog. Repeat as needed, then click OK to close the dialog.
Macros can also be assigned to events relating to the form as a whole. To do this, right-click a form control in the document, select **Form Properties**, and click the **Events** tab.

![Assign Action dialog](image)

**Figure 441: Assign Action dialog**

**Fine-tuning database access permissions**

By default, when a database is accessed from a form, any changes can be made to it: records can be added, deleted, and amended. You may not want that behavior. For example, you may want users to be able only to add new records or to be prohibited from deleting existing records.

In design mode, right-click a form control and select **Form Properties** in the context menu. On the **Data** tab of the Form Properties dialog (Figure 442), set each of these options to **Yes** or **No** to control the access users have to the data source: **Allow additions**, **Allow deletions**, **Allow modifications**, and **Add data only**.

Individual fields can also be protected. This might be useful if you wanted a user to be able to modify some parts of a record but only view others, such as a stock list where item descriptions are fixed and quantities can be modified.

To make an individual field read-only, in design mode, right-click the form control within the document and select **Control** from the context menu. Select the **General** tab and set **Read-only** to **Yes**.
Form control formatting options

You can customize the way form controls look and behave in a number of ways. These are all accessed in design mode. Right-click the form control, select Control Properties in the context menu and select the General tab in the Properties dialog.

- Set a label for the control in the Label box (not to be confused with the box called Label Field). Some form controls, such as push buttons and option buttons, have visible labels that can be set. Others, such as text boxes, do not.
- Set whether the form control will print out if the document is printed with the Print option.
- Use the Font setting to set the font, typeface, and size for a field's label or for text typed into a field. This setting does not affect the size of check boxes or option buttons.
- For a text box, you can set the maximum text length. This is very useful when adding records into a database. Every database text field has a maximum length and, if the data entered is too long, LibreOffice displays an error message. By setting the maximum text length of the form control to be the same as that of the database field, this error can be avoided.
- You can set the default option for a form control. By default, a control is blank, or has every option unselected. You can set the control to start with a particular option or list item selected.
- For controls where a password is being entered, setting the Password character (for example to *) displays only that character, but saves what the user really types.
- You can add additional information and help text for a form control.
- You can use other formatting controls such as background color, 3-D look, text formatting, scroll bars, and borders to further define how the control appears.
Using content controls

Content controls are placeholders. You can add and customize content controls for use in templates, forms, and documents. Content controls can provide instructions on their use. Some are similar to the controls described earlier in this chapter, but can be easier to work with and format. However, unlike some fields, content controls do not connect to any data in a database.

**Rich Text**
Contains custom formatted text or other items, such as tables, pictures, or other content controls.

**Plain Text**
Limited to plain text in a single or multiple paragraphs. Unlike rich text, it cannot contain other items, such as tables, pictures, or other content controls.

**Picture**
Contains a single image anchored as-character. Clicking on the content control opens the file open dialog to select an image to replace the placeholder.

**Check Box**
Contains a single check box character to interact with. Clicking on the content control toggles the checked state of the check box.

**Combo Box**
Contains a drop-down selection of list entries that you can select and text box that you can edit directly.

**Drop-down List**
Contains a drop-down button control with a list of display-text and value pairs. Unlike a combo box, the drop-down list does not let users enter custom input.

**Date**
Contains a calendar control. Limits text to a single paragraph.

To insert a content control into a document, template, or form:

1) Place the cursor where you want the control to appear.
2) Choose **Form > Content Controls > Insert [Required Control]** on the Menu bar.
3) Choose **Form > Content Controls > Content Control Properties** on the Menu bar. This is not available for a Picture control.
4) On the Content Control Properties dialog (Figure 443), optionally select **Content is placeholder text**, type a title and a tag. The properties vary for each control. For details, please see the Help.

![Content Control Properties dialog](image)

*Figure 443: Content Control Properties dialog*
Chapter 19, 
Spreadsheets, Charts, Other Objects
Introduction: OLE and DDE objects

You can embed or link objects as either OLE (Object Linking and Embedding) or DDE (Dynamic Data Exchange). Both methods enable you to use information from one application (say, Calc) in another application (Writer, in this case). The difference between a DDE object and a linked OLE object is that a linked OLE object can be edited from the document in which it is added as a link, but a DDE object cannot.

For example, if a Calc spreadsheet is pasted into a Writer document as a DDE object, then the spreadsheet cannot be edited in the Writer document. But if the original Calc spreadsheet is updated, the changes are automatically made in the Writer document. If the spreadsheet is inserted as a Linked OLE object into the Writer document, then the spreadsheet can be edited in Writer as well as in the Calc document and both documents are in sync with each other.

Both linking and embedding insert information from one document into another document, but the methods store information differently. They are different from directly copying and pasting information because you can open and edit objects in the applications that created them.

An embedded OLE object is a copy of information from another document. There is no link to the source document and any changes made to the source document are not reflected in the destination document. Embed objects if you want to be able to use the application that created them for editing, but you do not want the OLE object to be updated when you edit information in the source document.

A linked object is a reference to information in another document. Link objects when you want to use the same information in more than one document. Then, if you change the original information, you need to update only the links in order to update the document containing the OLE objects. You can also set links to be updated automatically. When you link an object, you need to maintain access to the source application and the linked document. If you rename or move either of them, you may need to reestablish the link.

The following types of files or documents can be inserted into a Writer document as an OLE object: spreadsheets, charts, drawings, formulas (equations), and presentations.

Inserting a new OLE object

When you insert a new OLE object into a document, it is embedded; that is, the object is available only in that document and can only be edited using Writer.

To insert a new OLE object into a document:

1) Click where you want to insert the object.
2) Choose Insert > OLE Object > OLE Object on the Menu bar.
3) On the Insert OLE Object dialog (Figure 444), select Create new.
4) Select the type of object you want to create and click OK.
5) A new OLE object is inserted in the document in edit mode. The toolbars displayed in Writer will change, providing the necessary tools to create the new OLE object.

Note

Computers running Microsoft Windows show an additional option of Further objects in the Object Type list. This option opens a dialog where you can create an OLE object using other software that is compatible with OLE and LibreOffice. This option is available for new OLE objects and for OLE objects from another file.

After a new OLE object is created, it can be formatted as described in “Formatting OLE objects” on page 503.
Inserting a file as an OLE object

When you insert an existing file (for example, a spreadsheet) into a Writer document as an OLE object, you can choose whether to embed or link the file.

1) Click where you want to insert the file and choose Insert > OLE Object > OLE Object on the Menu bar.

2) On the Insert OLE Object dialog, select Create from file. The dialog changes to show a File text box (Figure 445).

3) Click Search to open a file browser.

4) Locate the file you want to insert and click Open.
   - To insert the file as a live link so that any changes made are synchronized in both the original file and your document, select the Link to file option.
   - To show a selectable icon for the application that created the file (in this case, Calc), instead of displaying the contents of the file, select the Display as icon option.

5) Click OK to insert the file as an OLE object.

After a file is inserted as an OLE object, the object can be formatted as described in “Formatting OLE objects” on page 503.
**Editing OLE objects**

To edit an OLE object after it has been created or inserted from a file:

1. Double-click the OLE object to open it in edit mode. The toolbars displayed in Writer will change to provide the tools necessary to edit the object.
2. When you finish editing the object, click anywhere outside the object to exit edit mode.
3. Save the Writer document. Any changes made to the OLE object are also saved.

If the OLE object is linked, then if you change a spreadsheet in Writer it will change in Calc; if you change it in Calc, it will change in Writer. This can be a very powerful tool when creating reports in Writer using Calc data, to make a quick change without opening Calc.

**Creating a DDE link in Writer**

To create a DDE link from Calc to Writer:

1. Open both the Writer document and the Calc spreadsheet.
2. In Calc, select the cells to make the DDE link to. Copy them.
3. Go to the place in the Writer document where you want the DDE link. Select Edit > Paste Special > Paste Special. Writer displays its Paste Special dialog (Figure 446).
4. Select **Dynamic Data Exchange (DDE link)** in the **Selection** list.
5. Click the **OK** button. Now the link has been created in Writer. When the Calc spreadsheet is updated, the table in Writer is automatically updated.

![Figure 446: Paste Special dialog in Writer, with DDE link selected](image)

**Spreadsheets**

To include a spreadsheet in a Writer document, you can insert either an existing spreadsheet file or a new spreadsheet as an OLE object, as explained above, or create a DDE (Dynamic Data Interchange) object.

**Embedding or linking a spreadsheet**

Embedding a spreadsheet into Writer includes most of the functionality of a Calc spreadsheet. Writer is capable of performing complex calculations and data analysis. However, if you plan to use complex data or formulas, it is recommended to perform those operations in a separate Calc spreadsheet and use Writer only to display the embedded spreadsheet with the results.
Some people use spreadsheets in Writer for creating complex tables or presenting data in a tabular format. However, the Table feature in Writer is often more suitable and faster to use, depending on the complexity of the data; see Chapter 13, Tables.

To embed a spreadsheet into a Writer document, follow the instructions in “Inserting a file as an OLE object” on page 490.

When an entire spreadsheet is inserted into a document, if it contains more than one sheet and the one you want is not visible, double-click the spreadsheet, and then select a different sheet from the row of sheet tabs at the bottom.

After a spreadsheet is inserted as an OLE object, it can be formatted as described in “Formatting OLE objects” on page 503.

**Resizing and moving spreadsheet objects**

When selected, a spreadsheet object is treated like any other object.

**Resizing**

To resize the area occupied by the spreadsheet:

1) Click on the object to show the selection handles in the border.

2) Move the mouse pointer over one of the handles. The pointer changes shape to give a visual representation of the effects applied to the area.

3) Click and hold the left mouse button and drag the handle. The corner handles move the two adjacent sides simultaneously, while the handles at the midpoint of the sides modify one dimension at a time.

**Moving**

Moving a spreadsheet object to change its position within the document is the same as moving any other object in Writer:

1) Click on the object to show the selection handles in the border.

2) Move the mouse pointer over the object until the pointer changes shape (normally a hand, but this depends on your computer setup). Be careful not to double-click the spreadsheet object and activate object editing mode.

3) Click and drag the object to the desired position. Release the mouse button.

**Editing a spreadsheet object**

To edit a spreadsheet object, double-click it, or select it and choose Edit > Object > Edit on the Menu bar, or right-click and choose Edit in the context menu.

The object is edited in its own frame within the Writer document, but some of the toolbars change in Writer. One of the most important changes is the presence of the Formula bar, which contains (from left to right):

- The **Name Box**, that shows the active cell reference or the name of a selected range of cells.
- The **Function Wizard** icon.
- The **Select Function** and **Formula** icons or the **Cancel** and **Accept** icons, depending on the editing actions taken in the spreadsheet.
- A long **Input Line** to enter or review the contents of the active cell.

People familiar with Calc will immediately recognize the tools and the menu items. See the **Getting Started Guide** or the **Calc Guide** for more information.

430 | LibreOffice 7.6 Writer Guide
**Spreadsheet organization**
A spreadsheet consists of pages called sheets. However, in Writer, only one sheet can be shown at a time when a spreadsheet with multiple sheets is embedded into a Writer document.

Each sheet is organized into cells, which are the elementary units of the spreadsheet. They are identified by a row number (shown on the left-hand side) and a column letter (shown in the top row). For example, the top left cell is identified as A1, while the third cell in the second row is C2. All data elements, whether text, numbers, or formulas, are entered into a cell.

**Note**
If the embedded spreadsheet has multiple sheets, only the active sheet is shown on the page after exiting edit mode.

**Working with embedded sheets**
You can insert, rename, delete, and edit sheets in an embedded spreadsheet. To begin, double-click the embedded spreadsheet to open it in edit mode. When you finish editing the embedded spreadsheet, click anywhere outside the border to exit edit mode and save the changes. For more details on these procedures, refer to the *Getting Started Guide*.

**Inserting sheets**
1) Right-click a sheet name and select **Insert Sheet** in the context menu, or go to **Sheet > Insert Sheet** on the Menu bar to open the Insert Sheet dialog.
2) Select the sheet position, number of sheets to be inserted, sheet name, or which spreadsheet file to use from the options available in the Insert Sheet dialog.
3) Click **OK** to close the dialog and insert the sheet.

**Renaming sheets**
Right-click the sheet tab and select **Rename Sheet** in the context menu, or go to **Sheet > Rename Sheet** on the Menu bar, to open the Rename Sheet dialog.

**Moving and copying sheets**
1) Right-click the sheet name and select **Move or Copy Sheet** in the context menu, or go to **Sheet > Move or Copy Sheet** on the Menu bar to open the Move/Copy Sheet dialog.
2) Select whether to move or copy the sheet, the sheet location and position, and a new sheet name. Click **OK** to close the dialog and move or copy the sheet.
3) Alternatively, click the sheet tab and drag it to a new position in the embedded spreadsheet.

**Deleting sheets**
1) Right-click the sheet tab and select **Delete Sheet** in the context menu, or go to **Sheet > Delete Sheet** on the Menu bar. If the spreadsheet has only one sheet remaining, you cannot delete that sheet.
2) Click **Yes** to confirm.

**Cell navigation**
To move around the spreadsheet to select a cell to make it active, do any of the following:

- Use the keyboard arrow keys.
- Position the cursor in a cell and left-click the mouse.
- Press the **Enter** key to move one cell down and **Shift+Enter** to move one cell up.
- Press the **Tab** key to move one cell to the right and **Shift+Tab** to move one cell to the left.
**Entering data**

Data input into a cell can only be done when a cell is active. An active cell is easily identified by a thickened and bolder border. The cell reference (or coordinates) for the active cell is displayed at the left-hand end of the Formula bar.

1) Select the cell to make it active and start typing. The data input is also displayed in the **Input line** on the Formula toolbar, making the data entry easier to read.

2) Use the **Function Wizard**, **Select Function**, and **Formula** icons to enter data, formulas, or functions into a cell. If the input is not a formula (for example, a text or date entry), the **Select Function** and **Formula** icons change into the **Cancel** and **Accept** icons.

3) To confirm data input into a cell, either select a different cell, or press the **Enter** key, or click the **Accept** icon on the Formula bar.

**Formatting cell data**

Writer normally recognizes the type of contents (text, number, date, time, and so on) entered into a cell and applies default formatting to it. However, if Writer wrongly recognizes the type of data entered into a cell:

1) Select the cell, then right-click it and select **Format Cells** in the context menu, or go to **Format > Cells** on the Menu bar, or use the keyboard shortcut **Ctrl+1**.

2) In the Format Cells dialog, click the appropriate tab to open the correct page and use the options on that page to format the cell data.

3) Click **OK** to close the dialog and save the changes.

**Tip**

To force Writer to treat numbers as text (for example, telephone numbers) and to prevent Writer from removing the leading zeros or right-align them in a cell, type a single quotation mark (‘) before entering the number.

**Formatting spreadsheets**

It may be necessary to change the formatting of a spreadsheet to match the style used in the document.

When working on an embedded spreadsheet, you can also access any cell styles created in Calc and use them. However, when using styles, it is recommended to create specific cell styles for embedded spreadsheets, as Calc cell styles may be unsuitable when working within Writer.

**Manual formatting**

To manually format an embedded spreadsheet:

1) Select a cell or a range of cells. See the **Getting Started Guide** or the **Calc Guide** for more information on selecting ranges of cells.

2) Right-click the selection and go to **Format Cells** in the context menu, or go to **Format > Cells** on the Menu bar, or use the keyboard shortcut **Ctrl+1** to open the Format Cells dialog.

3) Use the various dialog pages to format the embedded spreadsheet so that it matches the style of the document.

4) Click **OK** to close the dialog and save the changes.

5) If necessary, adjust the column width by hovering the mouse pointer over the line separating two columns in the header row until the pointer changes to a double-headed arrow; then click the left button and drag the separating line to the new position.
6) If necessary, adjust the row height by hovering the mouse pointer over the line separating two rows in the row header until the pointer changes to a double-headed arrow; then click the left button and drag the separating line to the new position.

7) When satisfied with the formatting changes, click outside the spreadsheet area to save the changes and exit edit mode.

**Using formatting styles**

When an embedded spreadsheet is in edit mode, Writer displays the available styles for a spreadsheet in the Styles deck in the sidebar.

If a required style is not available, you can create it (see Chapter 8, Introduction to Styles). Styles used in an embedded spreadsheet are similar to paragraph styles used in Writer.

To use styles in an embedded spreadsheet, open the Styles deck in the Sidebar, then select data in a cell and double-click a style in the Styles deck to apply it.

**Inserting and deleting rows or columns**

To insert rows or columns in an embedded spreadsheet:

1) Select the column or row where you want the new column or row inserted.

2) Go to **Sheet** on the Menu bar and select either **Insert Columns > Columns Before**, or **Insert Columns > Columns After**, or **Insert Rows > Rows Above**, or **Insert Rows > Rows Below**.

   Or, right-click the column or row header and select **Insert Columns Before**, **Insert Columns After**, **Insert Rows Above**, or **Insert Rows Below** in the context menu.

To delete rows or columns from an embedded spreadsheet:

1) Highlight the rows or columns to be deleted.

2) Go to **Sheet > Delete Rows** or **Delete Columns**, or right-click and select **Delete Columns** or **Delete Rows** in the context menu.

**Deleting cells**

1) Select the cells to be deleted.

2) Go to **Sheet > Delete Cells**, or press Ctrl+--. Or, right-click on a cell and select **Delete** in the context menu.

3) Select the required option on the Delete Cells dialog.

**Merging and splitting cells**

To merge contiguous cells into a single cell:

1) Select the cells to be merged.

2) Right-click on the selected cells and select **Merge Cells** in the context menu, or go to **Format > Merge Cells > Merge Cells** or **Merge and Center Cells** on the Menu bar, or click on the **Merge and Center Cells** icon on the Formatting toolbar. Using **Merge and Center Cells** will center align any contents in the cells.

3) If the cells contain any data, a small dialog opens, showing choices for moving or hiding data in the hidden cells. Make a selection and click **OK**.

To split a group of cells that have been merged into a single cell:

1) Select the cell that contains merged cells.

2) Go to **Format > Merge Cells > Split Cells** or right-click and select **Split Cells** in the context menu. If the split cells contained data that was merged before, this data will not be split again.
Charts and graphs

Charts and graphs are graphical interpretations of data, often from a spreadsheet. For more information, see the *Calc Guide*.

Inserting a chart

You can add a chart to a document as an OLE object (see page 15) or using the tools in Writer. To add a chart using Writer’s tools, choose Insert > Chart on the Menu bar to insert a generic chart (Figure 447) at the cursor location. The chart is selected and the Menu bar and toolbars change to those appropriate for charts.

![Figure 447: Chart with sample data](image)

Selecting chart type

Data can be presented using a variety of different charts. Writer contains several chart types that will help convey a message to the audience. See “Chart types” on page 497.

![Figure 448: Chart Type dialog showing two-dimensional charts](image)

1) Make sure that the chart is selected. The chart has a border and selection handles when selected.

2) Click the Chart Type icon on the Formatting toolbar or go to Format > Chart Type on the Menu bar, or right-click the chart and select Chart Type in the context menu to open Chart Type dialog (Figure 448).
3) As you change selections in the left-hand list, the chart examples on the right change. You can move the Chart Type dialog to one side to see the effect in the chart.

4) As you change chart types, other selections become available on the right-hand side. For example, some chart types have both 3D and 2D variants. When 3D Look is selected, more options become available for selection of shapes for the columns or bars.

5) Choose the chart characteristics you want and click OK to save the changes and return to the edit window.

6) Continue to format the chart, add data to it, or click outside the chart to return to normal view.

**Chart types**

The following summary of the chart types available will help you choose a type suitable for the data. Column, bar, pie, and area charts are available as 2D or 3D types. Examples of these types are given in detail in the *Calc Guide*.

**Column charts**

A column chart shows vertical bars, with the height of each bar proportional to its value. They usually display data that shows trends over time. It is recommended to use column charts where you have a relatively small number of data points. If you have a large time series as the data, it is recommended to use a line chart.

**Bar charts**

A bar chart is like a column chart that has been shifted 90 degrees. It shows horizontal bars rather than vertical columns. Bar charts give an immediate visual impact for data comparison where time is not important, for example comparing the popularity of products in a marketplace.

**Pie charts**

A pie chart shows values as sections of a circle. The area of each section is proportional to its value. Pie charts give a comparison of proportions, for example, when comparing what different departments spent on different items or what different departments actually spent overall. They work best with a small range of values, up to about. Using a larger range of values, the visual impact begins to fade.

**Area charts**

Area charts are versions of line or column charts. They are useful to emphasize volume of change. Area charts have a greater visual impact than a line chart, but use them carefully, because the type of data makes a difference to the visual impact.

**Line charts**

Line charts give time series with progression. They are ideal for raw data and useful for charts with data showing trends or changes over time where you want to emphasize continuity. On line charts, the X-axis is ideal for representing time series data. 3D lines may confuse the viewer, so just using a thicker line gives a better visual impact.

**XY (Scatter) charts**

Scatter charts are great for visualizing data that you have not had time to analyze and may be best for data where you have a constant value for comparison: for example weather data, reactions under different acidity levels, conditions at altitude, or any data which matches two numeric series. The X-axis usually plots the independent variable or control parameter (often a time series).

**Bubble charts**

A bubble chart is a variation of a scatter chart that can show three variables in two dimensions. Two variables identify the position of the center of a bubble on a Cartesian graph, while the third variable indicates the radius of the bubble. These charts are often used to present financial data or social/demographic data.
Net charts
Net charts are similar to polar or radar graphs and are useful for comparing data not in time series, but show different circumstances, such as variables in a scientific experiment. The poles of the net chart are the Y-axes of other charts. Generally, between three and eight axes are best; any more and this type of chart becomes confusing.

Stock charts
Stock charts are specialized column graphs specifically used for stocks and shares. You can choose traditional lines, candlestick, and two-column charts. The data required for these charts is specialized with series for opening price, closing price, and high and low prices. The X-axis represents a time series.

Column and line charts
A column and line chart is a combination of two other chart types. It is useful for combining two distinct, but related data series, for example sales over time (column) and the profit margin trends (line).

Entering chart data
1) Select the chart and then select the chart type.
2) Click the Data Table icon, or select View > Data Table on the Menu bar, or right-click and select Data Table in the context menu to open the Data Table dialog (Figure 449).
3) Type or paste information into the cells within the desired rows and columns in the Data Table dialog. You can also use the icons in the top left corner of the Data Table dialog to insert, delete or move data.

![Figure 449: Chart Data Table dialog](image)

Adding or removing chart elements
The specimen chart inserted into a document includes two elements: a chart wall and a chart legend (also known as the key). You can add or remove elements to or from a chart.
1) Make sure the chart is selected and in edit mode.
2) To add an element to the chart, go to Insert on the Menu bar and select an element in the submenu, or right-click the chart wall or a chart element and select an element in the context menu. Selecting an element opens a dialog where you can specify options for the element.

**Note**
Right-clicking on a chart element will give more options to choose from when adding elements to a chart. The number of available insert options in the context menu depends on the type of element selected.
To remove an element from a chart, right-click the chart element to remove and select **Delete** in the context menu. The type of element selected for removal will change the delete options in the context menu. Or, select an element in the chart and press the \textit{Del (Delete)} key or the \textit{Backspace} key to remove it from the chart.

**Chart formatting**

To change the format of a selected chart:

1) Make sure the chart is selected and in edit mode.
2) Go to **Format** on the Menu bar and select on the submenu an element to format, or right-click a chart element and select a format option from the context menu. Selecting an element opens a dialog where you can specify format options for the element.

The formatting options available depend on whether the whole chart is selected or which chart element has been selected.

**Resizing and moving charts**

You can resize or move a chart interactively or by using the Position and Size dialog. You can also use a combination of both methods.

**Resizing**

To resize a chart interactively:

1) Click a chart to select it. Selection handles appear around the chart.
2) To increase or decrease the height of a chart, click and drag on a selection handle at the top or bottom of the chart.
3) To increase or decrease the width of a chart, click and drag on a selection handle at the left or right of the chart.
4) To increase or decrease both the height and width of a chart at the same time, click and drag on a selection handle in one of the corners. To maintain the correct aspect ratio between height and width, hold the \textit{Shift} key down while you click and drag.

**Moving**

To move a chart interactively:

1) Click the chart to select it. Selection handles appear around the chart.
2) Move the mouse pointer anywhere on the chart other than on a selection handle.
3) When it changes shape, click and drag the chart to its new location.
4) Release the mouse button when the chart is in the desired position.

**Position and Size dialog**

To resize or move a chart using the Position and Size dialog:

1) Double-click the chart so that it is in edit mode.
2) Go to **Format > Position and Size** on the Menu bar, or right-click the chart and select **Position and Size** in the context menu. For more information on using the Position and Size dialog, see Chapter 11, Images and Graphics.

Outside of the edit mode, it is possible to change the position and size of the chart in the **Type** page on the Properties dialog. Right-click on the chart and select **Properties** in the context menu.
Chart elements

You can move or resize individual elements of a chart element independently of other chart elements. For example, you can move the chart legend to a different position. Pie charts allow individual wedges of the pie to be moved as well as “exploding” the entire pie.

1) Double-click the chart so that it is in edit mode.
2) Click any chart element to select it. Selection handles appear.
3) Move the mouse pointer over the selected element and when the pointer changes shape, click and drag to move the element.
4) Release the mouse button when the element is in the desired position.

Note

If the chart is 3D, round selection handles appear; these handles control the three-dimensional angle of the chart. You cannot resize or reposition the chart while the round selection handles are showing. **Shift+click** to get back to the square resizing handles. You can now resize and reposition the 3D chart.

Changing chart area background

The chart area is the area surrounding the chart graphic and includes the (optional) main title and key.

1) Double-click the chart so that it is in edit mode.
2) Go to **Format > Chart Area** on the Menu bar, or right-click in the chart area and select **Format Chart Area** in the context menu, or double-click in the chart area to open the Chart Area dialog.
3) Click the **Area** tab and select the button corresponding to the type of background fill to use. The available options will change depending on the type of fill selected.
4) Make your selections and click **OK** to close the dialog and save the changes.

Changing chart wall background

The chart wall is the area that contains the chart graphic. Keep in mind that some chart types do not use a wall, like the pie chart for example.

1) Double-click the chart so that it is in edit mode.
2) Select the chart wall and go to **Format > Format Selection** on the Menu bar, or right-click in the chart wall and select **Format Wall** in the context menu, or double-click in the chart wall to open the Chart Wall dialog.
3) Click the **Area** tab and proceed as above.
4) Click **OK** to close the dialog and save the changes.

Audio and video

Although linked audio and video files are irrelevant when a Writer document is printed, if the document is opened on a computer or exported to PDF or HTML, you can play the files by clicking on the links.
Using media files

To insert a media file into a document:

1) Choose Insert > Media > Audio or Video on the Menu bar to open the Insert Audio or Video dialog.
2) Select the media file to insert and click Open to place the object in the document.

Tip

To see a list of audio and video file types supported by Writer, open the drop-down list of file types. This list defaults to All audio and video files, so you can also choose unsupported files such as .mov.

Writer only links media files and does not embed a media file into a document. Therefore if a document is moved to a different computer, any links will be broken and the media files will not play. To prevent this from happening:

1) Place any media files that are included in a document in the same folder where the document is stored.
2) Insert the media file in the document.
3) Send both the document and any media files to the computer which is to be used for the document and place both files in the same folder on that computer.

Using the Gallery

To insert media clips directly from the Gallery:

1) Go to the Gallery deck on the Sidebar.
2) Browse to a theme containing media files (for example, Sounds).
3) Click the movie or sound to be inserted and drag it into the document area.

Media playback

The Media Playback toolbar is automatically opened when a media file is selected. The default position of the toolbar is at the bottom of the workspace, just above the Drawing toolbar. However, this toolbar can be undocked and placed anywhere. If the toolbar does not open, go to View > Toolbars > Media Playback on the Menu bar.

The Media Playback toolbar contains the following tools:

- **Insert Audio or Video** – opens the Insert Audio or Video dialog.
- **Play, Pause, Stop** – controls media playback.
- **Repeat** – if selected, media will continuously repeat playing until this tool is deselected.
- **Position** (Playback slider) – selects the position to start playing from within the media file.
- **Timer** – displays current position of the media clip and length of media file.
- **Mute** – when selected, the sound will be suppressed.
- **Volume** – adjusts the volume of the media file.
- **Media path** – the location of the file on the computer.
- **View** (Scaling drop-down menu) – only available for movies; allows scaling of the clip.
For detailed information on how to create formulas, see the *Math Guide* or the *Getting Started Guide*.

To create a formula (equation) in Writer, go to **Insert > OLE Object > Formula Object** on the Menu bar. See page 15 for more information.

To easily add numbered formulas in Writer, you can use the AutoText entry **fn** (for “formula numbered”):

1. Start a new line in the document.
2. Type `fn` and then press the F3 key. A two-column table with no borders is inserted into the document. The left column contains a sample formula and the right column contains a reference number, as shown below.

   \[ E = mc^2 \]  
   \[ (1) \]

3. Delete the sample formula and insert your formula as an object in the left column.
4. Alternatively, first insert the formula into the document, then carry out Steps 1 and 2 above replacing the sample formula with your formula.

When creating or editing a formula, the Math menu becomes available.

When creating formulas, take care about the font sizes to make sure they are similar in size to fonts used in the document. To change font attributes of a Math object, double-click in the formula to enter edit mode and go to **Format > Font Size** on the Menu bar. To change font type, use **Format > Fonts**.

### Barcodes and QR codes

Writer, Calc, Impress, and Draw can generate barcodes and QR codes. Barcodes are used for many purposes. A QR code (short for Quick Response code) is a type of barcode. QR codes often contain data that points to a website or application.

1. Choose **Insert > OLE Object > QR and Barcode** on the Menu bar to open the QR and Barcode dialog (Figure 450).
2. Fill in the **URL/Text** field, select an error correction factor (the complexity of the graphic generated), the width of the margin around it, and the type of code, then click **OK**.

   Figure 450 shows an example of a QR code. Figure 451 shows an example of an ISBN barcode.

After the QR code or barcode has been generated, you can edit it by right-clicking in the code and selecting **Edit Barcode**.

To format other aspects of the code, including position and size, borders (line), background (area), anchor, wrap, and more, right-click on it and choose from the context menu. See Chapter 11, Images and Graphics, for more information.
Formatting OLE objects

Use the OLE Object dialog (Figure 452) to format spreadsheets and other OLE objects in similar ways to formatting frames and images: position and size, borders, area (background), transparency, and more. Right-click on the object and choose Properties from the context menu to open the dialog.
Figure 452: OLE Object dialog
Chapter 20,
Customizing Writer
This chapter briefly describes some of the setup options found under Tools > Options (LibreOffice > Preferences on macOS) on the Menu bar in Writer. Additional options, and more details about the ones given here, are covered in the Help and in the Getting Started Guide. Several of the most relevant options are discussed in other chapters of this book, in the context of tasks where they are most applicable.

This chapter also briefly describes some common customizations to menus, toolbars, and keyboard shortcuts, including adding new menus and toolbars and assigning macros to events. Other customizations are made easy by extensions that can be installed from the LibreOffice website or from other providers. You can also activate and use some experimental features; see page 538.

**Tip**

Many options are intended for power users and programmers. If you don’t understand what an option does, it is usually best to leave it on the default setting unless instructions in this book recommend changing the setting.

**Note**

Customizations to menus and toolbars can be saved in a template. To do so, first save them in a document and then save the document as a template as described in Chapter 10, Working with Templates. If you work on more than one project, you may find that having different menus and toolbars can be useful.

### Choosing options for all of LibreOffice

This section covers some of the settings that apply to all the components of LibreOffice (Writer, Calc, Impress, Draw, Math, and Base) and that are particularly important when using Writer.

Go to Tools > Options (LibreOffice > Preferences on macOS) and then click the marker (+ or triangle) by LibreOffice on the left-hand side. A list of pages drops down. Select an item in the list to display the relevant page on the right-hand side of the dialog.

**Tip**

The Reset button (located in the lower part of any page of the Options dialog) resets the values on that page to the values that were in place when you opened the dialog. It may be called Revert on some installations.

If you are using a version of LibreOffice other than US English, some field labels may be different from those shown in the illustrations.

### User data

Because Writer can use the name or initials stored in the LibreOffice – User Data page for several things, including document properties (‘created by’ and ‘last edited by’ information), the name of the author of comments and changes, and the sender address in mailing lists, make sure that the correct information appears here.

Fill in the form, or amend or delete any existing information. If you do not want user data to be part of the document’s properties, deselect **Use data for document properties**.
Tip

To have documents open at the page where the cursor is located when they were saved, select **Use data for document properties** on this dialog page, and go to **File > Properties** for each document and select **Apply user data** on the *General* tab. Unless both of these settings are selected, the document will open at the first page.

Alternatively, select **Load view position with the document even if it was saved by a different user** on the **Load/Save – General** page (see page 514).

In the Cryptography section, you can set the preferred public key for OpenPGP encryption and digital signature. These preferred keys will be pre-selected in the key selection dialog when you sign or encrypt a document (see Chapter 7, Printing and Publishing).

![User Data page](image)

**Figure 453: User Data page**

View options

The options on the *LibreOffice – View* page affect how the document window looks and behaves. Set them to suit your personal preferences. For details, see the Help or the *Getting Started Guide*.

Print options

On the *LibreOffice – Print* page, set the print options to suit your default printer and your most common printing method.

In the **Warnings** section on the right side of the page, you can choose whether to be warned if the paper size or orientation specified in the document does not match the paper size or orientation available for your printer. Having these warnings turned on can be quite helpful, particularly if you work with documents produced by people in other countries where the standard paper size is different from yours.
Tip
If your printouts are incorrectly placed on the page or chopped off at the top, bottom, or sides, or the printer is refusing to print, a likely cause is page size incompatibility.

Paths options
On the LibreOffice – Paths page, you can change the location of files associated with, or used by, LibreOffice to suit your needs. For example, you might want to store documents by default somewhere other than My Documents, or you might want to store project templates in folders not in the supplied template paths. Multiple paths are possible. For more information, see the Getting Started Guide.

Fonts options
If a document contains fonts that are not on your system, LibreOffice will substitute fonts for those it does not find. To specify different fonts from the ones that the program chooses, use the LibreOffice – Fonts page to specify replacement fonts.

Tip
Liberation fonts (Serif, Sans, and Mono) are often good choices to substitute for Times, Arial, and Courier.

Note
The choices made here do not affect the default fonts in documents. To do that, see “Basic Fonts options” on page 519. To change more than the basic fonts, create a new default template for Writer documents; see Chapter 10, Working with Templates.
Security options

Use the *LibreOffice – Security* page to choose security options for saving documents and for opening documents that contain macros. For information on the options not mentioned here, refer to the Help or the *Getting Started Guide*.

**Security Options and Warnings**

If you record changes, save multiple versions, or include hidden information or notes in your documents, and you do not want some recipients to see that information, you can set warnings to remind you to remove it, or you can have *LibreOffice* remove some of it automatically. Note that unless the information is removed, much of it is retained even when the file has been saved to other formats, including PDF.

Click the **Options** button to open a separate dialog with several options, including:

**Remove personal information on saving**

Select this option to always remove user data from the file properties when saving the file. To save personal information with documents and still be able to manually remove personal information only from specific documents, do not select this option.

**Ctrl-click required to open hyperlinks**

The default behavior in *LibreOffice* is that using *Ctrl+click* on a hyperlink opens the linked document or website. This is because many people find writing and editing documents is easier when accidental clicks on links do not activate the links. To set *LibreOffice* to activate hyperlinks using just an ordinary click, do not select this option.

**Application colors**

Writing, editing, and (especially) page layout are often easier when the page margins (text boundaries), the boundaries of tables and sections, grid lines, and other features are visible. In addition, you might prefer to use colors that are different from *LibreOffice*’s defaults.

On the *LibreOffice – Application colors* page (Figure 455), you can specify which user interface elements are visible and the colors used to display them.

- To show or hide items such as text boundaries, select or deselect the boxes in the **On** column next to the names of the elements.
- To change the default colors for a specific element, click the down-arrow in the **Color setting** column by the name of the element and select a color from the drop-down list.
- To save your color changes as a color scheme, click **Save**, type a name in the **Scheme** box, and then click **OK**.

*Figure 455: Showing or hiding text, object, and table boundaries*
Choosing options for loading and saving documents

You can set the options for loading and saving documents to suit the way you work.

If the Options dialog is not already open, click **Tools > Options**. Click the expansion symbol (+ or triangle) to the left of Load/Save.

**General**

Most of the choices on the *Load/Save – General* page (Figure 456) are familiar to users of other office suites. Some items of interest are described below.

![Figure 456: Choosing Load and Save options](image)

### Load
- Load user-specific settings with the document
- Load printer settings with the document
- Load view position with the document even if it was saved by a different user

### Save
- Save AutoRecovery information every: 10 minutes
- Edit document properties before saving
- Always create backup copy
- Save URLs relative to file system
- Save URLs relative to internet

### Default File Format and ODF Settings

- **ODF format version**: 1.3 Extended (recommended)
- **Document type**: Text documents (Writer)
- **Always save as**: ODF Text Document (*.odt)
- Warn when not saving in ODF or default format

**Load user-specific settings with the document**

When a LibreOffice document is saved, certain settings from the user’s system are saved with it. When the document is opened on another user’s system, it will use the settings saved from the previous user’s system. Deselecting this option causes the current user’s settings to override the settings previously saved with the document.

Even if this option is not selected, some settings are always loaded with the document:

- Settings in **File > Print > Options**.
- Spacing options for paragraphs before text tables.
- Information about automatic updating for links, field functions, and charts.
- Information about working with Asian character formats.
- Settings for any data sources linked to a document.
Load printer settings with the document
If this option is enabled, the printer settings of the previous user will be loaded with the
document. In an office setting, this may cause a document to be printed on a distant
network printer unless the printer is manually changed in the Print dialog. If disabled, the
current user’s default printer will be used to print the document. The current printer
settings will be stored with the document whether or not this option is selected.

Load view position with the document even if it was saved by a different user
The “view position” is the location of the cursor in the document. This option causes the
last-saved view position to be loaded regardless of who saved the document.

Save AutoRecovery information every ___ minutes
Choose whether to enable AutoRecovery and how often to save the information used by
the AutoRecovery process. AutoRecovery in LibreOffice saves the information needed to
restore all open documents in case of a crash. If you have this option set, recovering your
document after a system crash will be easier. This option is on by default.

Edit document properties before saving
If this option is selected, the document’s Properties dialog prompts you to enter relevant
information the first time you save a new document (or whenever you use Save As).

Always create backup copy
Saves the previously saved version of a document as a backup copy in a separate folder
whenever you save a document. When LibreOffice creates a new backup copy, the
previous backup copy is replaced. To see or change the backup folder, go to Tools > Options > LibreOffice > Paths. When opening
a backup file, you will be prompted to specify the program to open it with; choose
LibreOffice. This option is on by default.

Tip
Authors whose work may be very lengthy should always consider enabling
LibreOffice to create an automatic backup copy.

Save URLs relative to file system / to internet
Use these options to select the default for relative addressing of URLs in the file system
and on the Internet. For details, see the Getting Started Guide.

Default File Format and ODF Settings
ODF format version: LibreOffice by default saves documents in OpenDocument Format
(ODF) version 1.3 Extended. While this allows for improved functionality, there may be
backwards compatibility issues. When a file saved in ODF 1.3 Extended is opened in an
editor that uses an earlier version of ODF, some of the advanced features may be lost. If
you plan to share documents with people who use editors that use older versions of ODF,
you may wish to save the document using ODF 1.2 Extended (compatibility mode).

Document type: If you routinely share documents with users of Microsoft Word, you
might want to change the Always save as option to one of the Word formats. However,
you can choose a Word format when you save any individual file.

VBA Properties
On the VBA Properties page, choose whether to keep any macros in Microsoft Office documents
that are opened in LibreOffice. For details, see the Getting Started Guide.
Microsoft Office

On the Load/Save – Microsoft Office page, choose what to do when importing and exporting Microsoft Office OLE objects (linked or embedded objects or documents such as equations or spreadsheets): convert them into or from the corresponding LibreOffice OLE object or load and save them in their original format. For details, see the Getting Started Guide.

HTML compatibility

Choices made on the Load/Save – HTML Compatibility page affect HTML pages imported into LibreOffice and those exported from LibreOffice. For more information, see the Help and the Getting Started Guide.

Choosing Writer-specific options

Settings chosen in the LibreOffice Writer section of the Options dialog determine how Writer documents look and behave while you are working on them. If the Options dialog is not already open, choose Tools > Options. Click the marker (+ or triangle) by LibreOffice Writer on the left side of the dialog.

General options

The choices on the LibreOffice Writer – General page (Figure 457) affect the updating of links and fields, the units used for rulers and other measurements, and the default tab stop positions.

![Figure 457: Choosing general options for Writer](image)

Automatically Update [Fields and Charts]

You may not want fields or charts to update automatically while you are working, because that slows down performance. Alternatively, you may want automatic updates if you are referring to information in the fields or charts.

Update Links when Loading

Depending on your work patterns, you may not want links to be updated when you load a document. For example, if your file links to other files on a network, you won't want those links to try to update when you are not connected to the network.
Settings

Measurement unit
Document designers recommend using points as the default measurement because you can easily relate things like font size to things like indents and tabs.

Tab stops
The Tab stops setting specifies the distance the cursor travels for each press of the Tab key. This setting is also used for the indent distance applied by the Increase Indent and Decrease Indent buttons on the Formatting Toolbar, which affect the indentation of entire paragraphs.

Tip
To avoid unwanted changes, do not rely on default tab settings. Rather, define tabs in paragraph styles or individual paragraphs (see Chapter 4, Formatting Text).

Word Count

Additional separators
For counting words, specifies the characters that are considered to separate words, in addition to spaces, tabs, line breaks, and paragraph breaks.

Show standardized page count
Editors and publishers often define a “standard” page as containing a specified number of characters or words; this field allows quick calculation of the number of these pages.

View options

Two pages of options set the defaults for viewing Writer documents: View (described here) and Formatting Aids (described on page 518). View is a good page to check if, for example, you cannot see graphics on the screen.

Guides – Helplines While Moving
Helplines assist with precisely position a frame or drawing object on a page. When enabled, horizontal and vertical lines appear that are the height and width of a selected object. These lines extend across the complete working area as the object is moved.

Display Fields

Hidden text
Display text that is hidden by Conditional Text or Hidden Text fields.

Hidden paragraphs
Display paragraphs that contain a Hidden Paragraph field. This option has the same function as the menu command View > Field Hidden Paragraphs.

Display tracked changes

Tracked deletions in margin
By default, deletions are shown in the text with a strikethrough font. To show deletions in the margin, not in the text, select this option.

Tooltips on tracked changes
When this option is selected, hold the mouse pointer over a tracked change to show the type of change, the author, date, and time of day for the change. To hide these tooltips, deselect this option.

Outline Folding

Show outline-folding buttons
When this option is selected, a button with an arrow is visible near any selected heading in your document. Click on it to “fold” (hide) all text from the current heading to the next heading.
Include sub levels

If this option is also selected, clicking on a heading folds all text from that heading to the next same-level heading with all its subheadings.

The other options should be self-explanatory. If not, please refer to the Help.

![Figure 458: Choosing default View options for Writer](image)

**Formatting Aids options**

On the *LibreOffice Writer – Formatting Aids* page (Figure 459), select the desired options.

![Figure 459: Choosing default Formatting Aids options](image)

**Layout Assistance – Math baseline alignment**

To set the default vertical alignment for formula (Math) objects to use the text base line as a reference, select this option. To enable changing the vertical positioning of objects, deselect this option; you can then set the position for individual objects. See the *Math Guide* for more information.
Display Formatting

The Display Formatting options determine which symbols show when you select View > Formatting Marks on the Menu bar or the Formatting Marks icon on the Standard toolbar. Symbols such as paragraph ends and tabs can help in writing, editing, and page layout. For example, they can show if there are any blank paragraphs or if any tables or graphics are too wide and intrude into the margins of the page.

Protected Areas – Enable cursor

When this option is selected, you can set the cursor in a protected area, but you cannot make any changes. To make changes, you first need to unprotect the area. The methods of protecting and unprotecting vary with the area.

Direct Cursor

Direct Cursor lets you enter text, images, tables, frames, and other objects in any blank area in your document. Writer then inserts your choice of tabs, spaces, indents, and so on to position the text or objects. For details on these choices, please see the Help.

Note

The direct cursor feature can lead to many formatting oddities and is incompatible with rigorous use of styles.

Image – Anchor

Choose the default anchor for newly added images: To Paragraph, To Character, or As Character. For more about anchoring images, see Chapter 11, Images and Graphics.

Grid options

Snap to grid automatically moves an object to the nearest gridlines. This can be very helpful when you are trying to align several objects such as graphics or tables.

On the LibreOffice Writer – Grid page (Figure 460), you can choose whether to enable this feature and what grid intervals to use. If the grid intervals (subdivisions) are too large, you may find that you do not have enough control in placing the objects.

![Figure 460: Choosing Grid options for Writer](image)

Basic Fonts options

On the LibreOffice Writer – Basic Fonts (Western) page (Figure 461), you can choose the fonts and font sizes for the Default Paragraph Style, headings, lists, captions, and indexes. These values are applied to new documents unless different settings are selected in the document itself or defined in the document's template.

To reset the values to the defaults when LibreOffice was installed, click the Default button.

If Asian and/or CTL have been activated in Languages, extra pages are provided for their font options.
Print options

On the LibreOffice Writer – Print page, you can choose which items are printed with a Writer document by default. These options are in addition to the general options for all LibreOffice components on the LibreOffice – Print page (see page 511).

Some considerations:

- To save printer ink or toner when working on drafts, you might want to deselect some of the items in the Contents section.

- The Print text in black option causes color text (but not graphics) to print as black on a color printer; on a black-and-white printer, this option causes color text to print as solid black instead of shades of gray (dithered).

- By comparison, the Convert colors to grayscale option on the Options – LibreOffice – Print page (Figure 454), prints all text and graphics as grayscale on color printers. (On black-and-white printers, color in graphics normally prints as grayscale.)
• If you are printing double-sided on a non-duplexing printer, you might choose to print only left or right pages, then turn the stack over and print the other pages.

**Tip**

You can override any of these defaults when printing a specific document. Click **File > Print**, then use the options on the various pages of the Print dialog.

**Table options**

On the *LibreOffice Writer – Table* page (Figure 463), you can specify the default behavior of tables. See the Help or Chapter 13, Tables, for more information.

![Figure 463: Choosing default Table options](image)

Some considerations:

• If most of your tables will require borders or headings, you may wish to select those options. If most of your tables are used for page layout, deselect **Border** and **Heading**.

• Select **Do not split** to prevent tables from being split across pages.

• **Number recognition** can be very useful if most of your tables contain numerical data. Writer will recognize dates or currency, for example, and format the numbers appropriately. However, if you want the numbers to remain as ordinary text, this feature can be quite irritating, so you may want to deselect it.

• The **Keyboard Handling** section specifies the distances that cells move when you use keyboard shortcuts to move them and the size of rows and columns inserted using keyboard shortcuts. If you don’t use keyboard shortcuts for this purpose, you can ignore these settings. See the Help for more information.

• The **Behavior of rows/columns** section specifies the effects that changes to rows or columns have on adjacent rows or columns and the entire table. You might need to test these selections to fully understand the effects.
Changes options

If you plan to use the change-tracking feature of Writer (described in Chapter 3, Working with Text: Advanced), use the *LibreOffice Writer – Changes* page (Figure 464) to choose the way changes to text and formatting are marked. Change bars can show where a change has been made to a line of text and are formatted under Lines Changed.

![Figure 464: Choosing options for comparing documents](image)

Comparison options

The options on the *LibreOffice Writer – Comparison* page determine the level of detail used by the Compare Document feature (*Edit > Track Changes > Compare Document*), described in Chapter 3, Working with Text: Advanced.

Choose whether to compare word-by-word, character-by-character, or using an algorithm (Auto, which is the default). When *By word* or *By character* is selected, the random number choices are activated; optionally specify the minimum number of characters to be compared (*Ignore pieces of length __*).

![Figure 465: Choosing options for comparing documents](image)
Compatibility options

The settings on the LibreOffice Writer – Compatibility page (Figure 466) are used mainly when importing documents from Microsoft Word. If you are not sure about the effects of these settings, leave them as the defaults provided by LibreOffice. For information about settings that are not described below, see the Help. All settings selected will apply only to the current document, unless you select the Use as Default button at the bottom (not shown in the figure).

![Compatibility options](image)

**Global Compatibility Options**
- Reorganize Form menu for Microsoft compatibility

**Compatibility options for “WG7620-CustomizingWriter”**
- Add spacing between paragraphs and tables
- Add paragraph and table spacing at tops of pages
- Use OpenOffice.org 1.1 tabstop formatting
- Do not add leading (extra space) between lines of text
- Use OpenOffice.org 1.1 line spacing
- Add paragraph and table spacing at bottom of table cells
- Use OpenOffice.org 1.1 object positioning
- Use OpenOffice.org 1.1 text wrapping around objects
- Consider wrapping style when positioning objects
- Expand word space on lines with manual line breaks in justified paragraphs
- Protect form (no longer protects whole document. Insert write protected section instead)
- Word-compatible trailing blanks
- Tolerate white lines of PDF page backgrounds for compatibility with old documents
- Hide paragraphs of database fields (e.g., mail merge) with an empty value

**Figure 466: Choosing compatibility options**

**Add spacing between paragraphs and tables**
Paragraph spacing is treated differently in LibreOffice Writer than it is in Microsoft Word. If you have defined spacing between paragraphs or tables in LibreOffice, this spacing is added to the spacing defined in Microsoft Word. This only affects the current document.

If this option is selected, Microsoft Word-compatible spacing is added between paragraphs and tables in LibreOffice Writer documents.

**Add paragraph and table spacing at tops of pages**
You can define paragraphs and tables to have space appear before (above) them. If this option is selected, any space above a paragraph will also appear if the paragraph is at the beginning of a page or column, or if the paragraph is positioned on the first page of the document, or after a manual page break. This only affects the current document.

If you import a Microsoft Word document, the spaces are automatically added during the conversion.

**Add paragraph and table spacing at bottom of table cells**
Specifies that the bottom spacing is added to a paragraph, even when it is the last paragraph in a table cell.

**AutoCaption options**

LibreOffice can automatically insert captions for tables, pictures, frames, and OLE objects in a Writer document. To set this up, use the options on the LibreOffice Writer > AutoCaption page. Select the object you want to be automatically captioned (LibreOffice Writer Table in Figure 467). With the item highlighted, specify the characteristics of the caption.

The categories supplied for captions are Illustration, Table, Text, Drawing, and Figure. To use another name (for example, Photo) for the caption label, type it in the Category box.
You may not want captions for every table, for example if you use tables for layout as well as for tables of data. You can always add captions to individual tables, graphics, or other objects (`right-click > Insert Caption`). Information about numbering captions by chapter, character styles, frame styles, and other items on the `AutoCaption` page is given in other chapters in this book.

**Mail Merge Email options**

Using a data source such as an address book, Writer can insert personal, address, and other information into form letters. These documents can be printed for mailing or they can be emailed through Writer. See Chapter 14, Mail Merge, for details.
Use the *LibreOffice Writer – Mail Merge Email* page (Figure 524) to set up the user and server information for sending form letters by email. If you are not sure what information to put in any of the fields, consult your email program or your internet service provider.

**Choosing language settings**

You may need to do several things to get the language settings you want:

- Install the required dictionaries.
- Change some locale and language settings.
- Choose spelling and grammar options.
- Enable Language Tool.

**Install the required dictionaries**

LibreOffice automatically installs many language modules with the program. A language module can contain up to three submodules: spelling dictionary, hyphenation dictionary, and thesaurus. These are usually referred to as “dictionaries” in Writer.

To add other dictionaries, be sure you are connected to the Internet, and then choose **Tools > Language > More Dictionaries Online** on the Menu bar. LibreOffice will open your default web browser to a page containing links to additional dictionaries that you can install. Follow the prompts to select and install the ones you want.

**Change some locale and language settings**

You can change some details of the locale and language settings that LibreOffice uses for all documents or for specific documents. See the Help for details on all these options.

In the Options dialog, click the expansion symbol (+ sign or triangle) by **Language Settings** and choose **Languages**. On the right-hand side of the **Language Settings – Languages** page (Figure 469), change the settings as required.

![Figure 469: Choosing language options](image-url)
In the example, English (USA) has been chosen for all the appropriate settings, but you could choose a mixture of languages. For example, if you were working in Germany, you might prefer the user interface to be in English (USA), but German (Germany) for the Locale setting, which influences settings for numbering, currency, and units of measure.

If you want the language setting to apply to the current document only, instead of being the default for all new documents, select **For the current document only**.

Changes to the system input language normally affect text typed into a document after the change. If you do not want this to happen, select **Ignore system input language**; new text will then continue to follow the language of the document or the paragraph, not the system language.

If necessary, select the options to enable support for Asian languages (Chinese, Japanese, Korean) and support for CTL (complex text layout) languages such as Hindi, Thai, Hebrew, and Arabic. If you choose either of these options, the next time you open the Options dialog, you will see some extra pages under Language Settings. These pages are not discussed here.

**Choose spelling and grammar options**

To change the options for checking spelling and grammar, use the **Language Settings > Writing Aids** page (Figure 470).

![Image: Figure 470: Choosing languages, dictionaries, and options for checking spelling](image)

Some considerations:

- You can over-ride the **Check spelling as you type** setting in a document using **Tools > Automatic Spell Checking** on the Menu bar or the **Toggle Automatic Spell Checking** icon on the Standard toolbar.
- To have grammar checked as you type, also enable **Check spelling as you type**.
- If you use a custom dictionary that includes words in all uppercase and words with numbers (for example, AS/400), select **Check uppercase words** and **Check words with numbers**.
• **Check special regions** means that text in headers, footers, frames, and tables are also checked when checking spelling.

Here you can also select which of the user-defined (custom) dictionaries are active, add a new custom dictionary, edit dictionaries, and delete custom dictionaries. Dictionaries installed by the system cannot be deleted. For details on using the *Available Language Modules* and *User-defined Dictionaries* sections, please see the Help.

---

**Tip**

When checking spelling, words marked “Add to Dictionary” are added by default to the standard dictionary. Words marked “Ignore All” are added to the List of Ignored Words dictionary. See Chapter 2, Working with Text: Basics.

---

### Defining and using custom dictionaries

You can add a variety of custom (user-defined) dictionaries, including a dictionary of exceptions (words to be avoided, which will be marked as incorrect) or dictionaries of project-specific terms (words that will not be marked as incorrect). You can then select which, if any, of these custom dictionaries to use (in addition to a standard dictionary) when setting up a document.

For more information, see *Writing Aids* in the Help.

### Sentence checking

LibreOffice can check sentences in many languages. These checkers are enabled by default if the language is the computer’s default language, and others can be added using the Extensions dialog (see page 535). The set of rules for the sentence checkers depends on the language.

On the *Language Settings > English Sentence Checking* page, you can choose which items are checked for, reported to you, or converted automatically. This menu is also found in the English dictionaries extension installed by default by LibreOffice (select *Tools > Extensions*, select *English spelling dictionaries* and click the *Options* button to reveal the menu). Select which of the optional features you wish to check (see Chapter 2, Working with Text: Basics).

After selecting the additional grammar checks, you must restart LibreOffice, or reload the document, for them to take effect.

### Activating Language Tool

Language Tool is a multilingual grammar, style, and spelling checker provided by [https://languagetool.org/](https://languagetool.org/). Its use is not described in this guide; please see the website for details.

If you have an API key for LanguageTool, you can activate the tool by selecting *Enable LanguageTool* in *Language Settings > LanguageTool Server Settings*, then supply the requested information (Base URL, Username, and API Key).

### Customizing menus

You can add to and rearrange menus on the Menu bar, add commands to menus, and make other changes. You can also modify context (right-click) menus in a similar way.

To customize a menu, choose *Tools > Customize*. On the Customize dialog, go to the *Menus* tab (Figure 471) or the *Context Menus* tab.
Modifying an existing menu

1) In the **Scope** drop-down list in the upper right of the Customize dialog, choose whether to apply the customized menu to all of LibreOffice Writer or only to a specific document.

2) In the **Target** drop-down list, select the menu that you want to customize. The list includes the main menus and submenus. The commands on the selected menu are shown in the **Assigned Commands** list.

3) To add a command to the selected menu, click on a command in the **Available Commands** list and then click the large right arrow. You can narrow the search by using the **Search** box on the top left or selecting the **Category** in the drop-down list. Use the up and down arrows on the right-hand side to move the command into the position where you want it in the list.

4) To remove a command from the selected menu, click on it in the **Assigned Commands** list and then click the large left arrow.

5) To insert a separator or submenu, select the item directly before where you want the inserted item to appear, and use the commands in the **Insert** drop-down.
To rename a menu item, select it in the *Assigned Commands* list and choose *Rename* in the *Modify* drop-down.

When you have finished making all your changes, click **OK** to save them.

**Creating a new menu**

You might find a “Favorites” menu useful, or a menu collecting tools for a specific project. To create a new menu:

1) On the *Menus* tab of the Customize dialog, click the symbol next to *Target* and select *Add* in the drop-down list (Figure 474) to display the New Menu dialog (Figure 475).

2) Type a name for the new menu in the *Menu name* box.

3) Use the up and down arrow buttons to move the new menu into the required position on the Menu bar.

4) Click **OK** to save and return to the Customize dialog.

The new menu now appears on the list of menus in the Customize dialog. It will appear on the Menu bar itself after you save your customizations.

After creating a new menu, you need to add some commands to it, as described above for modifying a menu.
Customizing toolbars

You can customize toolbars in several ways, including choosing which icons are visible and locking the position of a docked toolbar (as described in Chapter 1, Introducing Writer), and adding or deleting icons (commands) in the list of those available on a toolbar. You can also create new toolbars.

Modifying existing toolbars

The procedures for creating and modifying a toolbar are similar to those for menus.

1) Choose **Tools > Customize** on the Menu bar.

2) On the Toolbars tab of the Customize dialog (Figure 476), in the **Scope** drop-down list on the upper right, choose whether to save this changed toolbar for Writer or for a selected document.

3) In the **Target** drop-down list, select the toolbar that you want to customize. The current toolbar content is displayed in the **Assigned Commands** list.

4) Select a command in the **Available Commands** list on the left. You can narrow your search by using the **Search** box on the top left or choosing a category in the drop-down list just below.

5) Click on the large right arrow to add the selected command to the **Assigned Commands** list for the toolbar (on the right). Use the up and down arrows in the far right to position the command in the toolbar.

6) To remove a command from a toolbar, select it in the **Assigned Commands** list on the right and click the large left arrow.
7) To show or hide a command assigned to a toolbar, select or clear the checkbox by its icon in the Assigned Commands list on the right.

8) To insert a separator, select the item directly before where you want the separator to appear, and use the command in the Insert drop-down.

9) To rename a toolbar item, select it in the Assigned Commands list and choose Rename in the Modify drop-down.

When you have finished making all your changes, click OK to save them.

![Figure 476: The Toolbars tab of the Customize dialog](image)

### Creating a new toolbar

To create a new toolbar:

1) Choose Tools > Customize on the Menu bar.

2) On the Toolbars tab of the Customize dialog, click the symbol next to Target and select Add in the list, to display the Name dialog.

3) On the Name dialog, type the new toolbar’s name and choose in the Save In drop-down list where to save this new toolbar: for Writer or for a selected document.

The new toolbar now appears on the list of toolbars in the Customize dialog. After creating a new toolbar, you need to add some commands to it, as described above.
Choosing icons for toolbar commands

Toolbar buttons usually have icons, not words, on them, but not all of the commands have associated icons. If the command does not have an icon, you can choose an icon for it. To choose an icon, select the command in the list on the right, and click Modify > Change Icon. On the Change Icon dialog (Figure 477), scroll through the available icons, select one, and click OK to assign it to the command.

To use a custom icon, create it in a graphics program and import it into LibreOffice by clicking the Import button on the Change Icon dialog. Custom icons should be 16x16 pixels in size to achieve the best quality and should not contain more than 256 colors.

![Change Icon dialog](Figure 477: Change Icon dialog)

Customizing the user interface

By default, LibreOffice Writer’s commands are grouped in cascading menus and in toolbars filled with icons—the standard user interface described in Chapter 1. In addition, Writer provides other user interface variations, displaying contextual groups of commands and contents. These are described in Chapter 21, User Interface Variants.

When you set up Writer, you can choose one of these user interfaces, and you can switch between them and the standard interface at any time.

In three variants (Tabbed, Tabbed Compact, and Groupedbar Compact), the area at the top of the workspace is divided into tabs, where each tab displays a set of icons grouped by context. The context can change depending on the object selected in the document, for example a table or an image.

After one of these variants has been selected (using View > User Interface), you can use the checkboxes on the Notebookbar tab of the Customize dialog (Figure 478) to show and hide the individual options on the various tabs that are provided in the Tabbed mode user interface.

Use the Reset button to reset the selected configuration to the default settings.
Assigning shortcut keys

In addition to using the built-in keyboard shortcuts, you can define others. You can assign shortcuts to standard LibreOffice functions or your own macros and save them for use with Writer or with the entire LibreOffice suite.

To adapt shortcut keys to your needs, use the Keyboard tab of the Customize dialog (Figure 479).

1) Choose whether to have the shortcut key assignment available in all components of LibreOffice or only in Writer.
2) Select the desired shortcut key in the Shortcut Keys list at the top of the page.
3) Select the required function in the Category and Function lists.
4) Click the Modify button. The selection now appears in the Keys list on the lower right.
5) Click OK to accept the change.

Repeat as required.
Figure 479: Defining keyboard shortcuts for applying styles

Note

Shortcut keys that are grayed-out in the listing on the Customize dialog, such as F1 and F10, are not available for reassignment.

Saving changes to a file

Changes to the shortcut key assignments can be saved in a keyboard configuration file for use at a later time, so you can create and apply different configurations as needed. To save keyboard shortcuts to a file:

1) After making keyboard shortcut assignments, click the **Save** button at the right of the Customize dialog (Figure 479).

2) On the Save Keyboard Configuration dialog, type a name for the keyboard configuration file in the **File name** box, or select an existing file from the list. Browse to the location where you want to save the file. (The file extension is .cfg for Configuration.)

3) Click **Save**. A confirmation dialog appears if you are about to overwrite an existing file, otherwise there will be no feedback and the file will be saved.

Loading a saved keyboard configuration

To load a saved keyboard configuration file and replace your existing configuration, click the **Load** button on the Customize dialog, and then select the configuration file on the Load Keyboard Configuration dialog.

468 | LibreOffice 7.6 Writer Guide
Resetting the shortcut keys

To reset all of the keyboard shortcuts to their default values, click the Reset button on the Customize dialog. Use this feature with care; no confirmation dialog will be displayed.

Assigning macros to events

In LibreOffice, when something happens, we say that an event occurred. For example, a document is opened, a key is pressed, or the mouse moved. You can associate a macro with an event, so the macro is run when the event occurs. For example, a common use is to assign the “open document” event to run a macro that performs certain setup tasks for the document.

To associate a macro with an event, use the Events tab of the Customize dialog. For more information, see the Getting Started Guide.

Adding functionality with extensions

An extension is a package that can be installed into LibreOffice to add new functionality. Template sets, spelling dictionaries, clipart galleries, macros, and dialog libraries can be packaged as LibreOffice extensions. They can add new top-level menus, submenus or toolbar icons. Extensions may also have their own settings.

Several extensions are shipped bundled with LibreOffice and are installed with the program. These can only be removed by changing the installation options. Others can be downloaded from various websites. The official extension repository is located at https://extensions.libreoffice.org/. These extensions are free of charge.

Some extensions from other sources are free of charge; others are available for a fee. Check the descriptions to see what licenses and fees apply to the ones that interest you.

Download the extension to your computer in any folder that you want (usually Downloads).

Installing extensions

To install an extension that is listed in the repository, follow these steps:

1) In LibreOffice, select Tools > Extensions on the Menu bar.
2) In the Extensions dialog (Figure 480), click Get more extensions online.
3) An internet browser window opens. Find and select the extension you want to install and download it to your computer.
4) After the extension is downloaded and saved, return to the Extensions dialog and click Add. Find and select the extension you want to install and click Open. The extension begins installing. You may be asked to accept a license agreement.
5) When the installation is complete, the extension is listed in the Extensions dialog.

To install an extension that is not listed in the repository, download the extension, then continue with step 3 above.

Updating extensions

Click the Check for Updates button on the Extensions dialog to check for updates to installed extensions.
Removing and disabling extensions

To remove (uninstall) an extension that you installed, select the extension in the main window of the Extensions dialog and click the **Remove** button.

To disable an extension without removing (uninstalling) it, select the extension in the main window of the Extensions dialog and click the **Disable** button, which then changes to **Enable**.

Adding fonts

LibreOffice supports PostScript (.pfb), TrueType (.ttf), and OpenType (.otf) font file formats. Other font formats exist, and may be supported by your operating system, but these formats may be limited in selection and quality.

If you have administration privileges, you can install additional fonts through your operating system; they will then be available for use by LibreOffice and will appear in Writer’s font lists.

Finding free-licensed fonts

In addition to proprietary fonts from sources like Adobe, hundreds of free-licensed fonts are available. You can use, share, and edit free-licensed fonts as you please. Most are available at no cost. Many are clones or near-variations of classic fonts, but some are original fonts.

Many Linux distributions include a few free-licensed fonts in their package repositories. Other places where you can find free-licensed fonts include The League of Moveable Type (https://www.theleagueofmoveabletype.com/) and the Font Library (https://fontlibrary.org/).
Adding custom colors

To add custom colors to a color palette, for example to exactly match a corporate color scheme, follow this procedure:

1) Insert any drawing object, such as a square, into any document.
2) Right-click on the object and choose Area in the context menu.
3) Go to the Color tab (Figure 481). Under Colors > Palette, choose which palette you wish to add the new color to. Under New, define the new color using RGB or Hex notation, or click the Pick button to select the color on the Pick a Color dialog (Figure 482).

4) Click Add in the lower left corner, enter a name for the new color in the pop-up dialog, and click OK to save.
5) Delete the drawing object from the document, if it is not needed.
Setting up document themes

Document themes collect various format selections into a set that can be applied and changed with two clicks. Theme colors have been implemented in LibreOffice Writer 7.6; font and format settings are planned for a later release.

LibreOffice supplies several sets of theme colors. To define your own set:

1) Choose Format > Theme on the Menu bar. In the Theme dialog (Figure 483), select a theme to use as a starting point and click Add.

2) In the Theme Color Edit dialog (Figure 484), name the new theme and select colors from any available palette.

3) Click OK to save the new theme, which will now appear in the Theme dialog.

See Chapter 6, Formatting Page: Advanced, for instructions on using document themes.

Note

User-defined theme color sets are saved only in the document; to use them in other documents, you need to make a template.

Themes enhance compatibility with Microsoft Word. However, they are not yet part of ODF (OpenDocument Format), so you need to save to ODF 1.3 Extended to use them.
Figure 483: Theme dialog

Figure 484: Creating a new theme
Chapter 21, 
User Interface Variants
Introduction

By default, LibreOffice Writer’s commands are grouped in cascading menus and in toolbars filled with icons—the standard user interface described in Chapter 1. These menus and toolbars are described in the chapters that discuss the related tasks and functions.

In addition, Writer provides other user interface variants, displaying contextual groups of commands and contents. This chapter describes these user interface variants and provides a quick reference to the location of the tools and functions when using each of the variants.

Selecting the user interface

When you set up Writer, you can choose one of these user interfaces, and you can switch between them and the standard interface at any time.

1) Choose **View > User Interface** on the Menu bar.

2) On the Select Your Preferred User Interface dialog (Figure 485), choose one of the variants on the left. An example of the variant is shown in the Preview box on the right, along with a short description.

3) Choose the relevant button to apply your selection to all components of LibreOffice, or only to Writer. The Writer window changes to match your selection.

4) Click **Close** to close the dialog.

![Figure 485: Selecting a user interface](image)

If you have activated experimental features (**Tools > Options > Advanced**), more choices may appear on the left-hand side. These choices are not described here.

Standard interfaces

Three of the user interface choices in Figure 485 are described in Chapter 1, Introducing Writer.

**Standard Toolbar**

Classic mode with two visible toolbars: standard and formatting. The sidebar shows only its tabs.

**Single Toolbar**

Only one toolbar with frequently used features. The sidebar shows only its Hide button.

**Sidebar**

The sidebar is fully opened and only one toolbar (Formatting) is showing.
The elements on each of the standard user interfaces can be modified using the View menu on the Menu bar.

**Tabbed interface**

The Tabbed interface (Figure 486) provides a familiar interface for users coming from proprietary office suites such as Microsoft Office. It includes a Menu bar, an Icon bar, a Tab bar, icons for the active tab, one or more tab-specific menus, and a Quick Menu. On Windows and Linux, the Menu bar can be hidden or displayed by clicking on the Menu Bar icon in the Icon bar (Figure 488).

![Figure 486: Tabbed Interface with Menu bar hidden](image)

1 Icon bar  2 Active tab  3 Icons on active tab  4 Tabs  5 Tab menus  6 Quick menu

In Writer, this user interface variant includes nine fixed tabs and five additional tabs. Each tab displays a set of icons grouped by context. The context can change depending on the location of the cursor or the item selected. Each tab also includes one or more tab-specific drop-down menus at the right-hand end. The Quick Menu is the same for all tabs.

The Tabbed interface can be customized using the Notebookbar tab of the Customize dialog to show and hide the individual icons on the various tabs. See Chapter 20, Customizing Writer, for more information.

If the icons on a tab do not fit into the width of the Writer window, >> appears at the end of the row. Click it to display the other commands (Figure 487).

![Figure 487: Displaying more commands on a tab](image)

**Icon bar**

The icon bar (Figure 488) is located at the top left of the tabs.

![Figure 488: Icon bar](image)

1 Menu bar – Show / Hide the menu bar.
2 Open (Ctrl+O) – Open a file browser, where you can select the file to be opened.
3 Save (Ctrl+S) – Save the open file.
4 Undo (Ctrl+Z) – Undo the last action performed.
5 Redo (Ctrl+Y) – Redo the last undone action.
6 Print (Ctrl+P) – Open the Print dialog.
Quick menu

At the right-hand end of the tab bar is a Quick menu (Figure 489) containing some commonly used commands and links. Some of the Quick menu items have submenus, indicated by arrows on the right.

Fixed tabs

The fixed tabs in Writer are File, Home, Insert, Layout, References, Review, View, Extension, and Tools. The tabs are described on the following pages. The illustrations show the left and right ends of the tabs separately so they are large enough to more easily see the commands.

File tab

The File tab (Figure 490) includes commands to create new documents; open, save, print, and close documents; manage templates; export to PDF and EPUB; display document properties; add a digital signature; and sign an existing PDF.
The File tab has two menus (Figure 491): **File** and **Help**. The **File** menu contains the same commands as the icons on the tab. The **Help** menu provides links to a variety of resources.

**Home tab**
The **Home** tab (Figure 492) includes commands to cut, copy, paste, and format text; insert common items (image, table, special characters, and page break); apply, update, and edit styles; and others.
The Home menu (Figure 493) provides additional commands that are not on the tab.

Insert tab

The Insert tab (Figure 494) includes commands to insert many commonly used items.
The Insert menu (Figure 495) provides some of the same commands.

![Insert tab menu](image)

**Figure 495: Insert tab menu**

**Layout tab**

The **Layout** tab (Figure 496) provides commands for working on page layout.

![Tabbed Interface – Layout tab](image)

**Figure 496: Tabbed Interface – Layout tab**
The Layout menu (Figure 497) provides commands for a few of the same items.

References tab

The References tab (Figure 498) provides commands for working with tables of contents, indexes, footnotes and endnotes, cross-references, bibliographies, and fields.

The References menu (Figure 499) provides many of the same commands.
**Review tab**

The **Review** tab (Figure 500) assists in editing. It provides quick access to recording, showing, hiding, and managing changes.

![Review tab](image)

**Figure 500: Tabbed Interface – Review tab**

The Review menu (Figure 501) provides many of the same commands.

![Review tab menu](image)

**Figure 501: Review tab menu**
**View tab**

The **View** tab (Figure 502) provides commands related to the display of a document on screen.

![View tab](image)

**Figure 502: Tabbed Interface – View tab**

The View menu (Figure 503) provides many of the same commands.

![View menu](image)

**Figure 503: View tab menu**

**Extension tab**

The **Extension** tab (Figure 504) contains only the menu for accessing the Extensions dialog.

![Extension tab](image)

**Figure 504: Tabbed Interface – Extension tab**
**Tools tab**
The Tools tab (Figure 505) provides several tools for macros, mail merge, and form creation.

![Figure 505: Tabbed Interface – Tools tab](image)

The Tools menu (Figure 506) provides some of the same commands.

![Figure 506: Tools tab menu](image)

**Additional tabs**
Additional tabs appear when an item is selected; they are displayed between the View and Extension tabs. The additional tabs in Writer are Draw, Image, Media, Object, and Table.

**Draw tab**
The Draw tab (Figure 507) is displayed when a drawing object is selected. It provides commands for captioning and modifying the drawing object and for inserting and modifying Fontwork objects.
Figure 507: Tabbed Interface – Draw tab

The Draw menu (Figure 508) provides a subset of commands, which vary depending on the drawing object.

![Draw menu examples](image)

**Image tab**

The **Image** tab (Figure 509) provides commands for working with images, including captions, cropping, borders and area styles and colors, anchors, wrapping, positioning, and filtering.

![Image tab menu examples](image)
The Image menu (Figure 510) provides links to dialogs for working with images.

![Image tab menu](image1.png)

**Figure 510: Image tab menu**

**Media tab**

The Media tab (Figure 511) provides commands for positioning and running an audio or video file.

![Media tab](image2.png)

**Figure 511: Tabbed Interface – Media tab**

The Media menu (Figure 512) provides some of the same commands.

![Media tab menu](image3.png)

**Figure 512: Media tab menu**
**Object tab**

The **Object** tab (Figure 513) provides commands to position, resize, link, choose colors and borders for the selected object. The illustration shows the tab when a frame is selected.

*Figure 513: Tabbed Interface – Object tab*

The Object menu (Figure 514) provides a few of the same commands. The illustration shows the menu when a frame is selected.

*Figure 514: Object tab menu*

**Table tab**

The **Table** tab (Figure 515) is opened when the cursor is in a table.

*Figure 515: Tabbed Interface – Table tab*
The Table menu (Figure 516) includes some commands not shown on the tab.

![Table tab menu](image)

**Figure 516: Table tab menu**

### Tabbed Compact interface

The Tabbed Compact interface has the same tabs as the Tabbed interface, but the commands on each tab are arranged in a single row of icons, many with drop-down menus of choices.

![Tabbed Compact interface example: Insert tab](image)

**Figure 517: Tabbed Compact interface example: Insert tab**

### Groupedbar Compact interface

The Groupedbar Compact interface (Figure 518) is divided into groups that contain commands organized as sets of icons and menus.

![Groupedbar Compact interface example](image)

**Figure 518: Groupedbar Compact interface example**
The Groupedbar menu (Figure 519) provides a subset of commands, including a convenient way to change the user interface.

![Figure 519: Groupedbar menu](image)

**Contextual Single interface**

The Contextual Single interface displays a standard Menu bar and a single toolbar with context-dependent content.
Writer Guide

About this book
Anyone who wants to get up to speed quickly with LibreOffice Writer will find this book valuable. You may be new to word processing software, or you may be familiar with another office suite.
This book introduces some of the main features of LibreOffice Writer:
- Text entry, editing, and formatting - Templates and styles - Tables of data
- Page-layout methods, including frames, columns, and tables
- Export to PDF, including bookmarks - Mail merge - Fields and forms
- Embedding or linking of graphics, spreadsheets, and other objects
- Tables of contents, indexes, and bibliographies - Master documents
- Database integration, including a bibliography database - And many more

About the authors
This book was written by volunteers from the LibreOffice community.
A PDF version of this book can be downloaded free from:
https://documentation.libreoffice.org/en/

About LibreOffice
LibreOffice is the free, libre, and open source personal productivity suite from The Document Foundation. It runs on Windows, macOS, and GNU/Linux. Support and documentation are free from our large, dedicated community of users, contributors, and developers.
You can get involved with volunteer work in many areas: development, quality assurance, documentation, translation, user support, and more.
You can download LibreOffice Community free from
https://libreoffice.org/download/

For commercial/enterprise users: The LibreOffice Enterprise class of applications may look and behave differently from the Community edition described in this book. For guides to Enterprise editions of LibreOffice, please refer to the professional partners that produced them.